Overview

actiontree Documentation
Contents | Index
Overview
Show All
Origin Of Module Name

Insert origin of module name here.

Overview

Insert overview here.

Send comments on this topic.
Copyright (c) 2003-2008 Rockstar San Diego. All rights reserved.


Components

Components
Show All

Here's a table listing the primary components of this module.

Send comments on this topic.


Relationships

Relationships

Insert text with inheritance and dependency info for the classes in this library. Ideally, include UML diagrams (as a GIF) followed by any additional explanations.


Command Line Options

Command Line Options
Parameter Name | In File | Description
actoptlevel | X:gta5srcdevragesuitesrcactiontreeActionNode.cpp | [actiontree] Optimization level (1-5) for loading act trees (remove this)
actresources | X:gta5srcdevragesuitesrcactiontreeActionNode.cpp | Load XAT action tree resources instead of ACT files
cnamestrings | X:gta5srcdevragesuitesrcactiontreeCName.cpp | include the string portion of cnames in the resources
DumpTaskSizeStats | X:gta5srcdevragesuitesrcactiontreeTracks.cpp | Dump csv data showing the size of each track.
extraHeapMem | X:gta5srcdevragesuitesrcactiontreeActionNode.cpp | Allocates extra heap memory at the cost of resoruce memory
globalreferenceerror | X:gta5srcdevragesuitesrcactiontreeActionNode.cpp | Error on finding a global reference
spewact | X:gta5srcdevragesuitesrcactiontreeActionNode.cpp | [actiontree] print act load/unload to the console.
spewdrv | X:gta5srcdevragesuitesrcactiontreeActionNode.cpp | [actiontree] Allow print statements to the console.
spewdrvchannel | X:gta5srcdevragesuitesrcactiontreeActionNodeTracks.cpp | specify a channel (selected from g_PrintChannelNames)


Working Examples

Working Examples


rage Namespace

rage Namespace
Namespaces | Classes | Structs | Types | Templates | Functions | Variables | Enumerations | Macros
Show All
Namespaces
Namespace | Description
actDebug |
condEKG |
Classes
Class | Description
ActionCallbackContext |
ActionContext |
ActionController | ActionController
ActionIntention | ActionIntention
ActionNode |
ActionNodeBank | ActionNodeBank Matching a Playable Node will also include the tracks of this Bank during Playback
ActionNodeFileReference |
ActionNodeImplementation | ActionNodeImplementation
ActionNodeLwRef |
ActionNodePlayable |
ActionNodeReference | ActionNodeReference
ActionNodeTree |
ActionNodeTreeHandle |
ActionNodeUnresolvedRef |
ActionTreeLog | Simple Log class that notifies Observers when there is a new message
actTreeDebugOut |
ArchiveFileRecord |
ATask |
CBasicString | Helper for paths
CFastNamePath |
CName |
CNamePath | Helper for paths
Condition |
ConditionActionNodePlayTime |
Conditional | EQUITY AND RELATIONAL OPERATORS... And some compare helper functions
ConditionFalse |
ConditionGroup |
ConditionGroupCondition |
ConditionGroupConditionAnd |
ConditionGroupConditionNot |
ConditionGroupConditionOnly |
ConditionGroupConditionOr |
ConditionNOT |
ConditionOR |
ConditionPrint |
ConditionRandom |
ConditionTrue |
CSubject |
DataMember |
ExecuteTask |
ExecuteTrack |
GameTaskManager |
IArchive |
IBoolDataMember |
ICommandDataMember |
IDataMembers |
IEnumDataMember |
IFloatDataMember |
IGroupDataMember |
IIntDataMember |
IMultiNodeReferenceTrack |
IName |
INodeReferenceDataMember |
INodeReferenceTrack |
InstancedActionController |
IObserver |
IStringDataMember |
ITrackFactory |
IVector2DataMember |
IVector3DataMember |
NodeReferenceTrack |
OpportunityRandomLatchTask | OpportunityRandomLatchTask
OpportunityRandomLatchTrack | OpportunityRandomLatchTrack
OpportunityTask |
OpportunityTrack |
PrintTask |
PrintTrack |
SequenceTask |
SequenceTrack |
SpawnActionController | this makes the big assumption that spawn tracks are inside nodes that would already be referenced counted through other mechanisms
SpawnTask |
SpawnTrack |
StubTask |
TextBuffer |
TextParser |
Track |
TrackOrCondition |
TrackRegistry |
Structs
Struct | Description
ActionContextDebugDepth | : helper class to keep track of the call depth into important functions like Play, Match, Update
ActionNodeDebugName | : helper class to extract the name of the action node consistently.
Types
Type | Description
ActionNodeTreePtr |
ActionVistorCallBack |
DebugOutputFunctor | ok to define type outside of debug builds.
FactoryIArchive |
Templates
Template | Description
BoolDataMember |
CommandDataMember |
EnumDataMember |
FloatDataMember |
GroupDataMember |
GroupDataMemberNoInterface |
IntDataMember |
NodeReferenceDataMember |
StringDataMember |
TaskSizeCompileTimeAssert | Class template to facilitate size checking
TaskSizeCompileTimeAssert<SpawnTask> | Special case for Spawn, because this sucker's massive.
TrackFactory |
Vector2DataMember |
Vector3DataMember |
Functions
Function | Description
!= |
== |
HashUCstring | string is upper cased
RAGE_DECLARE_CHANNEL |
StringCopyNew | Helper Function
Variables
Variable | Description
gDebugActTreeOut |
gTempHashString |
Enumerations
Enumeration | Description
eActionNodeResolveMode |
Macros
Macro | Description
ACCELERATION_DATAMEMBER |
ACCELERATION_DATAMEMBER_SIMPLE |
ACCELERATION_MIN_MAX_DATAMEMBER |
ACT_DEBUG_CODE |
ACT_DEBUG_DEF |
ACTIONTREE_CNAME_USE_ATSTRINGHASH |
ACTIONTREE_CNAME_USE_HASH_ASM | For the brave, there is a slightly faster assembly language version of HashUCstring() for Xenon, in 'CName.cpp', which can be enabled by setting this to 1. /FF
actTreeDebug |
actTreeDebugPop |
actTreeDebugPush | NO_OUTPUT
ALL_ACTIONTREE_TRACKS |
ANGLE_DATAMEMBER |
ANGLE_DATAMEMBER_SIMPLE |
ANGLE_MIN_MAX_DATAMEMBER |
BEGIN_DATAMEMBERS |
BEGIN_DATAMEMBERS_NO_BREAKPOINT |
BEGIN_DATAMEMBERS_NO_MEMBERS | Data Members MACROS for registering with the class
BEGIN_DATAMEMBERS_NO_MEMBERS_NO_NAME |
BEGIN_DATAMEMBERS_NO_NAME |
BEGIN_DATAMEMBERS_NOT_TRACK |
BOOL_DATAMEMBER |
BOOL_DATAMEMBER_SIMPLE |
COMMAND_DATAMEMBER |
COMMAND_DATAMEMBER_SIMPLE |
COMMENT_DATAMEMBER |
CONTROL_CONTEXT_ENABLED |
DATAMEMBERS_INTERFACE_RESOURCE_CTOR |
DATAMEMEBERS_INTERFACE |
DATAMEMEBERS_INTERFACE_NAME | ... was classname
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE |
DATAMEMEBERS_INTERFACE_NO_PLACE |
DATAMEMEBERS_INTERFACE_NO_PLACE_NO_NAME |
DATAMEMEBERS_INTERFACE_PLACE |
DATAMEMEBERS_INTERFACE_STRUCT | DECLARESTRUCT
DEBUG_BREAK |
DEBUGTASKS | define this to enable 'task tracking' debug functionality
DEFINE_sMIN_sMAX | Static min/max definitions -- this must go in the .cpp file when you use the TRACK_PARAMETER_sMIN_sMAX macro.
DELETE_CORE_TASK |
DELETE_GAME_TASK |
DELETE_GAME_TASK_ON_END | This is to replace the calls to delete running tasks when ending This allows tracks/task to control when they actually get deleted by the actionController... mainly to support animation blend control
ENABLE_TRACK_TIMERS |
END_DATAMEMBERS |
END_DATAMEMBERS_LITE |
ENUM_DATAMEMBER |
ENUM_DATAMEMBER_SIMPLE |
FLOAT_DATAMEMBER |
FLOAT_DATAMEMBER_SIMPLE |
FLOAT_MIN_MAX_DATAMEMBER |
GROUP_DATAMEMBER |
GROUP_DATAMEMBER_NO_INTERFACE |
GROUP_DATAMEMBER_READONLY |
INCREMENT_DEBUG_TASK_UPDATE_COUNTER |
INT_DATAMEMBER |
INT_DATAMEMBER_SIMPLE |
INT_MIN_MAX_DATAMEMBER |
LENGTH_DATAMEMBER |
LENGTH_DATAMEMBER_SIMPLE |
LENGTH_MIN_MAX_DATAMEMBER |
LENTH_DATAMEMBER |
MAGIC_NOPLACE |
MAGIC_NP_ENUM |
MAGIC_NP_PADDING |
MAGIC_NP_PARAM |
MAGIC_NP_STRING |
MAX_HASH_STRING |
NEW_CORE_TASK |
NEW_GAME_TASK | RESOURCECOMPILER
NODE_REFERENCE_DATAMEMBER |
NODE_REFERENCE_DATAMEMBER_SIMPLE |
NODENAMELEN |
PFSTAT_ONLY |
PLAY_HISTORY_DEBUG |
spewdrvDisplayf |
STRING_DATAMEMBER |
STRING_DATAMEMBER_SIMPLE |
TASK_POOL_FUNCTIONS |
TIME_DATAMEMBER |
TIME_DATAMEMBER_SIMPLE |
TIME_END_NOT_INSERTED | Magic number for ATask::m_TimeEnd
TIME_MIN_MAX_DATAMEMBER |
TRACK_MEMBER |
TRACK_MEMBER_ENUM |
TRACK_PADDING |
TRACK_PARAMETER | Helper MACRO for simple track param definitions in class
TRACK_PARAMETER_CNAME |
TRACK_PARAMETER_ENUM |
TRACK_PARAMETER_ENUM_STATIC |
TRACK_PARAMETER_MIN_MAX |
TRACK_PARAMETER_sMIN_sMAX | Static min/max
TRACK_PARAMETER_STATIC |
TRACK_PARAMETER_STRING |
TRACK_PARAMETER_STRING_STATIC |
TRACK_PARAMETER_VECTOR2 |
TRACK_PARAMETER_VECTOR2_STATIC |
TRACK_PARAMETER_VECTOR3 |
TRACK_PARAMETER_VECTOR3_STATIC |
TRACK_TIME_DATAMEMBER |
TRACK_TIME_DATAMEMBER_SIMPLE |
TRACK_TIME_MIN_MAX_DATAMEMBER |
TRACKMSG |
VECTOR2_DATAMEMBER |
VECTOR3_DATAMEMBER |
VECTOR3_DATAMEMBER_SIMPLE |
VELOCITY_DATAMEMBER |
VELOCITY_DATAMEMBER_SIMPLE |
VELOCITY_MIN_MAX_DATAMEMBER |
Links
Namespaces, Classes, Structs, Types, Templates, Functions, Variables, Enumerations, Macros


rage::actDebug Namespace

rage::actDebug Namespace
Functions | rage Namespace
Show All
Functions
Function | Description
CanOutputDebug | : checks if we can output the actiontree module debug : checks if we can output the act controller debug
CanOutputDebug | : checks if we can output the actiontree module debug for the given context object : checks if we can output the actiontree module debug
CanOutputDebug | : checks if we can output the actiontree module debug for the given context object : checks if we can output the actiontree module debug
ExtractPathAndNodeName | : extracts the name of the action node
GetActDebugLevel | : gets the debug level for the actiontree module. : gets the debug level for the act controller
OutputFullNameEumeration | : checks if we need to output the full name for the nodes : return true if we want to see the full name enumeration, need to make this a configuration TODO(ddn)
SetConditionFilter | : sets the debug condition filters : sets the debug condition filters
Namespace

rage Namespace

Links
Functions, rage Namespace
Send comments on this topic.


rage::actDebug::CanOutputDebug Function

rage::actDebug::CanOutputDebug Function
rage::actDebug Namespace
Show All

: checks if we can output the actiontree module debug

: checks if we can output the act controller debug

C++
bool CanOutputDebug();
Namespace

rage::actDebug Namespace

File

ActionController.h

Links
rage::actDebug Namespace


rage::actDebug::CanOutputDebug Function

rage::actDebug::CanOutputDebug Function
rage::actDebug Namespace
Show All

: checks if we can output the actiontree module debug for the given context object

: checks if we can output the actiontree module debug

C++
bool CanOutputDebug(
    const ActionContext& ctx
);
Namespace

rage::actDebug Namespace

File

ActionController.h

Links
rage::actDebug Namespace


rage::actDebug::CanOutputDebug Function

rage::actDebug::CanOutputDebug Function
rage::actDebug Namespace
Show All

: checks if we can output the actiontree module debug for the given context object

: checks if we can output the actiontree module debug

C++
bool CanOutputDebug(
    const ActionContext* ctx
);
Namespace

rage::actDebug Namespace

File

ActionController.h

Links
rage::actDebug Namespace


rage::actDebug::ExtractPathAndNodeName Function

rage::actDebug::ExtractPathAndNodeName Function
rage::actDebug Namespace
Show All

: extracts the name of the action node

C++
const char* ExtractPathAndNodeName(
    ActionNode* node,
    bool pathOnly = false
);
Namespace

rage::actDebug Namespace

File

ActionController.h

Links
rage::actDebug Namespace


rage::actDebug::GetActDebugLevel Function

rage::actDebug::GetActDebugLevel Function
rage::actDebug Namespace
Show All

: gets the debug level for the actiontree module.

: gets the debug level for the act controller

C++
unsigned int GetActDebugLevel();
Namespace

rage::actDebug Namespace

File

ActionController.h

Links
rage::actDebug Namespace


rage::actDebug::OutputFullNameEumeration Function

rage::actDebug::OutputFullNameEumeration Function
rage::actDebug Namespace
Show All

: checks if we need to output the full name for the nodes

: return true if we want to see the full name enumeration, need to make this a configuration TODO(ddn)

C++
bool OutputFullNameEumeration();
Namespace

rage::actDebug Namespace

File

ActionController.h

Links
rage::actDebug Namespace


rage::actDebug::SetConditionFilter Function

rage::actDebug::SetConditionFilter Function
rage::actDebug Namespace
Show All

: sets the debug condition filters

: sets the debug condition filters

C++
void SetConditionFilter(
    bool onTrue,
    bool onFalse
);
Namespace

rage::actDebug Namespace

File

ActionController.h

Links
rage::actDebug Namespace


rage::condEKG Namespace

rage::condEKG Namespace
Functions | rage Namespace
Show All
Functions
Function | Description
EXT_PF_GROUP |
PF_GROUP |
PF_LINK |
PF_PAGE |
PF_PAGE |
PF_TIMER |
PF_TIMER |
PF_TIMER |
PF_TIMER |
PFPAGELINK_ACTTRACKS |
Namespace

rage Namespace

Links
Functions, rage Namespace
Send comments on this topic.


rage::condEKG::EXT_PF_GROUP Function

rage::condEKG::EXT_PF_GROUP Function
rage::condEKG Namespace
Show All
C++
EXT_PF_GROUP(
    actEKGGroup
);
Namespace

rage::condEKG Namespace

File

Condition.cpp

Links
rage::condEKG Namespace


rage::condEKG::PF_GROUP Function

rage::condEKG::PF_GROUP Function
rage::condEKG Namespace
Show All
C++
PF_GROUP(
    actEKGGroup
);
Namespace

rage::condEKG Namespace

File

ActionController.cpp

Links
rage::condEKG Namespace


rage::condEKG::PF_LINK Function

rage::condEKG::PF_LINK Function
rage::condEKG Namespace
Show All
C++
PF_LINK(
    actEKGPage,
    actEKGGroup
);
Namespace

rage::condEKG Namespace

File

ActionController.cpp

Links
rage::condEKG Namespace


rage::condEKG::PF_PAGE Function

rage::condEKG::PF_PAGE Function
rage::condEKG Namespace
Show All
C++
PF_PAGE(
    actEKGPage,
    "action tree"
);
Namespace

rage::condEKG Namespace

File

ActionController.cpp

Links
rage::condEKG Namespace


rage::condEKG::PF_PAGE Function

rage::condEKG::PF_PAGE Function
rage::condEKG Namespace
Show All
C++
PF_PAGE(
    actEKGPage2,
    "action tree (detail)"
);
Namespace

rage::condEKG Namespace

File

ActionController.cpp

Links
rage::condEKG Namespace


rage::condEKG::PF_TIMER Function

rage::condEKG::PF_TIMER Function
rage::condEKG Namespace
Show All
C++
PF_TIMER(
    condition,
    actEKGGroup
);
Namespace

rage::condEKG Namespace

File

Condition.cpp

Links
rage::condEKG Namespace


rage::condEKG::PF_TIMER Function

rage::condEKG::PF_TIMER Function
rage::condEKG Namespace
Show All
C++
PF_TIMER(
    task_begin,
    actEKGGroup
);
Namespace

rage::condEKG Namespace

File

ActionController.cpp

Links
rage::condEKG Namespace


rage::condEKG::PF_TIMER Function

rage::condEKG::PF_TIMER Function
rage::condEKG Namespace
Show All
C++
PF_TIMER(
    task_end,
    actEKGGroup
);
Namespace

rage::condEKG Namespace

File

ActionController.cpp

Links
rage::condEKG Namespace


rage::condEKG::PF_TIMER Function

rage::condEKG::PF_TIMER Function
rage::condEKG Namespace
Show All
C++
PF_TIMER(
    task_update,
    actEKGGroup
);
Namespace

rage::condEKG Namespace

File

ActionController.cpp

Links
rage::condEKG Namespace


rage::condEKG::PFPAGELINK_ACTTRACKS Function

rage::condEKG::PFPAGELINK_ACTTRACKS Function
rage::condEKG Namespace
Show All
C++
::rage::pfPageLink PFPAGELINK_ACTTRACKS(
    & PFPAGE_actEKGPage2,
    DataMember::GetPfGroupActTracks()
);
Namespace

rage::condEKG Namespace

File

ActionController.cpp

Links
rage::condEKG Namespace


ActionCallbackContext Class

ActionCallbackContext Class
Constructors | Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
ActionCallbackContext
C++
public: class ActionCallbackContext;
Constructors
Constructor | Description
ActionCallbackContext |
Destructors
Destructor | Description
~ActionCallbackContext |
Methods
Method | Description
Bind | : binds this object to the controller it is hooking
GetController | : gets the controller this callback context hooks
OnEndTask |
OnNodeCleanup |
OnPlay | : callback hooks
OnPlayTracks |
OnSequence |
OnStop |
Update | : update function allows callback context to execute logic, ext code must update this object.
Namespace

rage Namespace

File

ActionController.h

Links
Constructors, Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


ActionCallbackContext::ActionCallbackContext Constructor

ActionCallbackContext::ActionCallbackContext Constructor
ActionCallbackContext Class
Show All
C++
public: ActionCallbackContext();
Class

ActionCallbackContext Class

File

ActionController.h

Links
ActionCallbackContext Class
Send comments on this topic.


ActionCallbackContext::~ActionCallbackContext Destructor

ActionCallbackContext::~ActionCallbackContext Destructor
ActionCallbackContext Class
Show All
C++
public: virtual ~ActionCallbackContext();
Class

ActionCallbackContext Class

File

ActionController.h

Links
ActionCallbackContext Class
Send comments on this topic.


ActionCallbackContext::Bind Method

ActionCallbackContext::Bind Method
ActionCallbackContext Class
Show All

: binds this object to the controller it is hooking

C++
public: void Bind(
    ActionController* controller
);
Class

ActionCallbackContext Class

File

ActionController.h

Links
ActionCallbackContext Class
Send comments on this topic.


ActionCallbackContext::GetController Method

ActionCallbackContext::GetController Method
ActionCallbackContext Class
Show All

: gets the controller this callback context hooks

C++
public: ActionController* GetController(
    void
);
Class

ActionCallbackContext Class

File

ActionController.h

Links
ActionCallbackContext Class
Send comments on this topic.


ActionCallbackContext::OnEndTask Method

ActionCallbackContext::OnEndTask Method
ActionCallbackContext Class
Show All
C++
public: virtual bool OnEndTask(
    ActionController*,
    ActionNode*
);
Class

ActionCallbackContext Class

File

ActionController.h

Links
ActionCallbackContext Class
Send comments on this topic.


ActionCallbackContext::OnNodeCleanup Method

ActionCallbackContext::OnNodeCleanup Method
ActionCallbackContext Class
Show All
C++
public: virtual bool OnNodeCleanup(
    ActionController*,
    ActionNode*
);
Class

ActionCallbackContext Class

File

ActionController.h

Links
ActionCallbackContext Class
Send comments on this topic.


ActionCallbackContext::OnPlay Method

ActionCallbackContext::OnPlay Method
ActionCallbackContext Class
Show All

: callback hooks

C++
public: virtual bool OnPlay(
    ActionController*,
    ActionNode*
);
Class

ActionCallbackContext Class

File

ActionController.h

Links
ActionCallbackContext Class
Send comments on this topic.


ActionCallbackContext::OnPlayTracks Method

ActionCallbackContext::OnPlayTracks Method
ActionCallbackContext Class
Show All
C++
public: virtual bool OnPlayTracks(
    ActionController*,
    ActionNode*
);
Class

ActionCallbackContext Class

File

ActionController.h

Links
ActionCallbackContext Class
Send comments on this topic.


ActionCallbackContext::OnSequence Method

ActionCallbackContext::OnSequence Method
ActionCallbackContext Class
Show All
C++
public: virtual bool OnSequence(
    ActionController*,
    ActionNode*
);
Class

ActionCallbackContext Class

File

ActionController.h

Links
ActionCallbackContext Class
Send comments on this topic.


ActionCallbackContext::OnStop Method

ActionCallbackContext::OnStop Method
ActionCallbackContext Class
Show All
C++
public: virtual bool OnStop(
    ActionController*,
    ActionNode*
);
Class

ActionCallbackContext Class

File

ActionController.h

Links
ActionCallbackContext Class
Send comments on this topic.


ActionCallbackContext::Update Method

ActionCallbackContext::Update Method
ActionCallbackContext Class
Show All

: update function allows callback context to execute logic, ext code must update this object.

C++
public: virtual void Update(
    float
);
Class

ActionCallbackContext Class

File

ActionController.h

Links
ActionCallbackContext Class
Send comments on this topic.


ActionContext Class

ActionContext Class
Nested Types | Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
ActionContext
C++
public: class ActionContext;
Nested Types
Nested Type | Description
DebugActionContextCB | ok to define type outside of debug builds.
Constructors
Constructor | Description
ActionContext |
Destructors
Destructor | Description
~ActionContext |
Methods
Method | Description
Clone | Create a copy of pContext:
GetActorName |
NullOp |
OnACTError |
OnStopPostTaskEnd | Called from ActionController::Stop(), after all tasks have ended.
PreUpdate | optional project specific
ResetDebug |
VerifyNewNode | __DEV only callback on new node selection for verification purposes
Data Members
Data Member | Description
m_ActionController |
m_Actor | you probably will want to create your own derived version of this have this system do anything useful...
m_CurrentAction | the current action node for a given operation. Useful to identify the originating state for an operation.
m_CurrentMatchingNode | only valid while a node or bank's condition group is being evaluated
m_Debug | boolean to turn on/off debugging for individual objects
m_DebugContextClBk | external callback used for hooking the debugging of this object
m_Depth | used to identify how deep the call stack is for the context
m_Entity | general purpose information
m_OpeningBranch | This is basically a replacement for an opening branch the sequences to a start point when there are no nodes to sequence
Namespace

rage Namespace

File

ActionController.h

Links
Nested Types, Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


ActionContext::m_ActionController Data Member

ActionContext::m_ActionController Data Member
ActionContext Class
Show All
C++
public: ActionController* m_ActionController;
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::m_Actor Data Member

ActionContext::m_Actor Data Member
ActionContext Class
Show All

you probably will want to create your own derived version of this have this system do anything useful...

C++
public: Actor* m_Actor;
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::m_CurrentAction Data Member

ActionContext::m_CurrentAction Data Member
ActionContext Class
Show All

the current action node for a given operation. Useful to identify the originating state for an operation.

C++
public: ActionNode* m_CurrentAction;
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::m_CurrentMatchingNode Data Member

ActionContext::m_CurrentMatchingNode Data Member
ActionContext Class
Show All

only valid while a node or bank's condition group is being evaluated

C++
public: ActionNode* m_CurrentMatchingNode;
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::m_Debug Data Member

ActionContext::m_Debug Data Member
ActionContext Class
Show All

boolean to turn on/off debugging for individual objects

C++
public: bool m_Debug;
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::m_DebugContextClBk Data Member

ActionContext::m_DebugContextClBk Data Member
ActionContext Class
Show All

external callback used for hooking the debugging of this object

C++
public: DebugActionContextCB m_DebugContextClBk;
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::m_Depth Data Member

ActionContext::m_Depth Data Member
ActionContext Class
Show All

used to identify how deep the call stack is for the context

C++
public: int m_Depth;
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::m_Entity Data Member

ActionContext::m_Entity Data Member
ActionContext Class
Show All

general purpose information

C++
public: void* m_Entity;
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::m_OpeningBranch Data Member

ActionContext::m_OpeningBranch Data Member
ActionContext Class
Show All

This is basically a replacement for an opening branch the sequences to a start point when there are no nodes to sequence

C++
public: ActionNode* m_OpeningBranch;
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::ActionContext Constructor

ActionContext::ActionContext Constructor
ActionContext Class
Show All
C++
public: ActionContext();
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::~ActionContext Destructor

ActionContext::~ActionContext Destructor
ActionContext Class
Show All
C++
public: virtual ~ActionContext();
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::Clone Method

ActionContext::Clone Method
ActionContext Class
Show All

Create a copy of pContext:

C++
public: virtual ActionContext* Clone(
    const ActionContext * pContext
);
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::GetActorName Method

ActionContext::GetActorName Method
ActionContext Class
Show All
C++
public: virtual const char* GetActorName() const;
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::NullOp Method

ActionContext::NullOp Method
ActionContext Class
Show All
C++
public: static const char* NullOp(
    ActionContext*
);
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::OnACTError Method

ActionContext::OnACTError Method
ActionContext Class
Show All
C++
public: virtual void OnACTError(
    int = 0
) const;
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::OnStopPostTaskEnd Method

ActionContext::OnStopPostTaskEnd Method
ActionContext Class
Show All

Called from ActionController::Stop(), after all tasks have ended.

C++
public: virtual void OnStopPostTaskEnd();
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::PreUpdate Method

ActionContext::PreUpdate Method
ActionContext Class
Show All

optional project specific

C++
public: virtual void PreUpdate();
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::ResetDebug Method

ActionContext::ResetDebug Method
ActionContext Class
Show All
C++
public: void ResetDebug(
    void
);
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::VerifyNewNode Method

ActionContext::VerifyNewNode Method
ActionContext Class
Show All

__DEV only callback on new node selection for verification purposes

C++
public: virtual void VerifyNewNode(
    ActionNode *
);
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContext::DebugActionContextCB Nested Type

ActionContext::DebugActionContextCB Nested Type
ActionContext Class
Show All

ok to define type outside of debug builds.

C++
public: typedef rage::atFunctor1<const char*, ActionContext*> DebugActionContextCB;
Class

ActionContext Class

File

ActionController.h

Links
ActionContext Class
Send comments on this topic.


ActionContextDebugDepth Struct

ActionContextDebugDepth Struct
Constructors | Destructors | Members | Data Members | rage Namespace | Inheritance Hierarchy
Show All

: helper class to keep track of the call depth into important functions like Play, Match, Update

ActionContextDebugDepth
C++
public: struct ActionContextDebugDepth {
  public: ActionNode* m_PrevNode;
  public: ActionContext* m_Ctx;
  public: const char* m_Op;
};
Constructors
Constructor | Description
ActionContextDebugDepth |
Destructors
Destructor | Description
~ActionContextDebugDepth |
Data Members
Data Member | Description
m_Ctx |
m_Op |
m_PrevNode |
Namespace

rage Namespace

File

ActionController.h

Links
Constructors, Destructors, Members, Data Members, rage Namespace, Inheritance Hierarchy


ActionContextDebugDepth::m_Ctx Data Member

ActionContextDebugDepth::m_Ctx Data Member
ActionContextDebugDepth Struct
Show All
C++
public: ActionContext* m_Ctx;
Struct

ActionContextDebugDepth Struct

File

ActionController.h

Links
ActionContextDebugDepth Struct
Send comments on this topic.


ActionContextDebugDepth::m_Op Data Member

ActionContextDebugDepth::m_Op Data Member
ActionContextDebugDepth Struct
Show All
C++
public: const char* m_Op;
Struct

ActionContextDebugDepth Struct

File

ActionController.h

Links
ActionContextDebugDepth Struct
Send comments on this topic.


ActionContextDebugDepth::m_PrevNode Data Member

ActionContextDebugDepth::m_PrevNode Data Member
ActionContextDebugDepth Struct
Show All
C++
public: ActionNode* m_PrevNode;
Struct

ActionContextDebugDepth Struct

File

ActionController.h

Links
ActionContextDebugDepth Struct
Send comments on this topic.


ActionContextDebugDepth::ActionContextDebugDepth Constructor

ActionContextDebugDepth::ActionContextDebugDepth Constructor
ActionContextDebugDepth Struct
Show All
C++
public: ActionContextDebugDepth(
    ActionNode* node,
    ActionContext* ctx,
    const char* op
);
Struct

ActionContextDebugDepth Struct

File

ActionController.h

Links
ActionContextDebugDepth Struct
Send comments on this topic.


ActionContextDebugDepth::~ActionContextDebugDepth Destructor

ActionContextDebugDepth::~ActionContextDebugDepth Destructor
ActionContextDebugDepth Struct
Show All
C++
public: ~ActionContextDebugDepth();
Struct

ActionContextDebugDepth Struct

File

ActionController.h

Links
ActionContextDebugDepth Struct
Send comments on this topic.


ActionController Class

ActionController Class
Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All

ActionController

ActionController
    rage::InstancedActionController
    rage::SpawnActionController
C++
public: class ActionController;
Constructors
Constructor | Description
ActionController |
Destructors
Destructor | Description
~ActionController |
Methods
Method | Description
BeginDebugTask |
clearAll |
EndDebugTask |
EndTask |
GetBeginBreakPoint |
GetContext |
GetControlContext |
GetCurrentNodePlayTime |
GetCurrentPlayCount |
GetCurrentPlayingNode |
GetDebug |
GetEndBreakPoint |
GetPlayHistory |
GetRequestedNode |
GetRunningTaskRoot |
GetUpDateBreakPoint |
IsBusy | const ActionNode * GetCurrentSequencedNode(void)const{return(m_SequencedNode); short GetSequencedPriority(void)const{return(m_SequencedPriority);
Play | These deal with ActionNodes so Banks can be sequenced or played The PlayActionNode will search for playable NODE to sequence!
PlayRemote | : used by the mutli-player function to execute remote actions. keeps a signature to prevent multiple plays of same action.
PlayTracks |
RemoveTask |
Sequence |
SetBeginBreakPoint | These are for hooking in BreakPoints on Track/Task instances
SetContext |
SetControlContext | does nothing CONTROL_CONTEXT_ENABLED
SetDebug |
SetEndBreakPoint |
SetRequestedNode |
SetUpDateBreakPoint |
StartSequencedTracks |
Stop |
TRACKMSG |
Update | Normally only update is called
UpdateDebugTask |
UpdateTasks |
UpdateTasksTimeEnd |
UpdateWithKeepAlive |
Data Members
Data Member | Description
s_NoOfTaskUpdates |
Namespace

rage Namespace

File

ActionController.h

Links
Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


ActionController::s_NoOfTaskUpdates Data Member

ActionController::s_NoOfTaskUpdates Data Member
ActionController Class
Show All
C++
public: static int s_NoOfTaskUpdates;
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::ActionController Constructor

ActionController::ActionController Constructor
ActionController Class
Show All
C++
public: ActionController();
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::~ActionController Destructor

ActionController::~ActionController Destructor
ActionController Class
Show All
C++
public: virtual ~ActionController();
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::BeginDebugTask Method

ActionController::BeginDebugTask Method
ActionController Class
Show All
C++
public: bool BeginDebugTask(
    ATask* task
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::clearAll Method

ActionController::clearAll Method
ActionController Class
Show All
C++
protected: void clearAll(
    void
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::EndDebugTask Method

ActionController::EndDebugTask Method
ActionController Class
Show All
C++
public: bool EndDebugTask(
    ATask* task
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::EndTask Method

ActionController::EndTask Method
ActionController Class
Show All
C++
public: void EndTask(
    Track* track
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::GetBeginBreakPoint Method

ActionController::GetBeginBreakPoint Method
ActionController Class
Show All
C++
public: static bool GetBeginBreakPoint(
    void
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::GetContext Method

ActionController::GetContext Method
ActionController Class
Show All
C++
public: ActionContext* GetContext(
    void
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::GetControlContext Method

ActionController::GetControlContext Method
ActionController Class
Show All
C++
public: ActionCallbackContext* GetControlContext(
    void
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::GetCurrentNodePlayTime Method

ActionController::GetCurrentNodePlayTime Method
ActionController Class
Show All
C++
public: float GetCurrentNodePlayTime(
    void
) const;
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::GetCurrentPlayCount Method

ActionController::GetCurrentPlayCount Method
ActionController Class
Show All
C++
public: unsigned GetCurrentPlayCount(
    void
) const;
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::GetCurrentPlayingNode Method (void)

ActionController::GetCurrentPlayingNode Method (void)
ActionController Class
Show All
C++
public: ActionNodePlayable* GetCurrentPlayingNode(
    void
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::GetCurrentPlayingNode Method (void)

ActionController::GetCurrentPlayingNode Method (void)
ActionController Class
Show All
C++
public: const ActionNodePlayable* GetCurrentPlayingNode(
    void
) const;
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::GetDebug Method

ActionController::GetDebug Method
ActionController Class
Show All
C++
public: bool GetDebug(
    char * DebugPrefix
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::GetEndBreakPoint Method

ActionController::GetEndBreakPoint Method
ActionController Class
Show All
C++
public: static bool GetEndBreakPoint(
    void
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::GetPlayHistory Method

ActionController::GetPlayHistory Method
ActionController Class
Show All
C++
public: ActionNodePlayable* GetPlayHistory(
    void
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::GetRequestedNode Method

ActionController::GetRequestedNode Method
ActionController Class
Show All
C++
public: ActionNode* GetRequestedNode();
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::GetRunningTaskRoot Method

ActionController::GetRunningTaskRoot Method
ActionController Class
Show All
C++
public: ATask* GetRunningTaskRoot();
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::GetUpDateBreakPoint Method

ActionController::GetUpDateBreakPoint Method
ActionController Class
Show All
C++
public: static bool GetUpDateBreakPoint(
    void
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::IsBusy Method

ActionController::IsBusy Method
ActionController Class
Show All

const ActionNode * GetCurrentSequencedNode(void)const{return(m_SequencedNode); short GetSequencedPriority(void)const{return(m_SequencedPriority);

C++
public: bool IsBusy(
    void
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::Play Method

ActionController::Play Method
ActionController Class
Show All

These deal with ActionNodes so Banks can be sequenced or played The PlayActionNode will search for playable NODE to sequence!

C++
public: void Play(
    ActionNode* actionNode
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::PlayRemote Method

ActionController::PlayRemote Method
ActionController Class
Show All

: used by the mutli-player function to execute remote actions. keeps a signature to prevent multiple plays of same action.

C++
public: void PlayRemote(
    ActionNode* actionNode
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::PlayTracks Method

ActionController::PlayTracks Method
ActionController Class
Show All
C++
public: void PlayTracks(
    ActionNode* actionNode
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::RemoveTask Method (ATask *, ATask *)

ActionController::RemoveTask Method (ATask *, ATask *)
ActionController Class
Show All
C++
public: __forceinline void RemoveTask(
    ATask * task,
    ATask * prevTask
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::RemoveTask Method (ATask *, ATask *, ATask *)

ActionController::RemoveTask Method (ATask *, ATask *, ATask *)
ActionController Class
Show All
C++
public: __forceinline void RemoveTask(
    ATask * task,
    ATask * prevTask,
    ATask * nextTask
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::Sequence Method

ActionController::Sequence Method
ActionController Class
Show All
C++
public: void Sequence(
    ActionNode* actionNode,
    signed short priority = 0,
    bool override = false
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::SetBeginBreakPoint Method

ActionController::SetBeginBreakPoint Method
ActionController Class
Show All

These are for hooking in BreakPoints on Track/Task instances

C++
public: static void SetBeginBreakPoint(
    bool tf
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::SetContext Method

ActionController::SetContext Method
ActionController Class
Show All
C++
public: void SetContext(
    ActionContext* context
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::SetControlContext Method

ActionController::SetControlContext Method
ActionController Class
Show All

does nothing CONTROL_CONTEXT_ENABLED

C++
public: void SetControlContext(
    ActionCallbackContext*
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::SetDebug Method

ActionController::SetDebug Method
ActionController Class
Show All
C++
public: void SetDebug(
    bool bActive,
    const char * DebugPrefix
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::SetEndBreakPoint Method

ActionController::SetEndBreakPoint Method
ActionController Class
Show All
C++
public: static void SetEndBreakPoint(
    bool tf
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::SetRequestedNode Method

ActionController::SetRequestedNode Method
ActionController Class
Show All
C++
public: void SetRequestedNode(
    ActionNode * pNode
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::SetUpDateBreakPoint Method

ActionController::SetUpDateBreakPoint Method
ActionController Class
Show All
C++
public: static void SetUpDateBreakPoint(
    bool tf
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::StartSequencedTracks Method

ActionController::StartSequencedTracks Method
ActionController Class
Show All
C++
public: void StartSequencedTracks(
    float deltaTime,
    bool nodeEnding = false
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::Stop Method

ActionController::Stop Method
ActionController Class
Show All
C++
public: void Stop(
    void
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::TRACKMSG Method (char *, ATask *)

ActionController::TRACKMSG Method (char *, ATask *)
ActionController Class
Show All
C++
public: void TRACKMSG(
    char * Msg,
    ATask * task
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::TRACKMSG Method (char *, ActionNode *)

ActionController::TRACKMSG Method (char *, ActionNode *)
ActionController Class
Show All
C++
public: void TRACKMSG(
    char * Msg,
    ActionNode * node
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::TRACKMSG Method (char *, Track *)

ActionController::TRACKMSG Method (char *, Track *)
ActionController Class
Show All
C++
public: void TRACKMSG(
    char * Msg,
    Track * track
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::TRACKMSG Method (char *, char *, void *)

ActionController::TRACKMSG Method (char *, char *, void *)
ActionController Class
Show All
C++
public: void TRACKMSG(
    char * Msg,
    char * Name,
    void * ptr
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::Update Method

ActionController::Update Method
ActionController Class
Show All

Normally only update is called

C++
public: void Update(
    float deltaTime
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::UpdateDebugTask Method

ActionController::UpdateDebugTask Method
ActionController Class
Show All
C++
public: bool UpdateDebugTask(
    ATask* task,
    float timeDelta
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::UpdateTasks Method

ActionController::UpdateTasks Method
ActionController Class
Show All
C++
public: bool UpdateTasks(
    float deltaTime
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::UpdateTasksTimeEnd Method

ActionController::UpdateTasksTimeEnd Method
ActionController Class
Show All
C++
public: void UpdateTasksTimeEnd(
    float deltaTime
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionController::UpdateWithKeepAlive Method

ActionController::UpdateWithKeepAlive Method
ActionController Class
Show All
C++
public: bool UpdateWithKeepAlive(
    float deltaTime
);
Class

ActionController Class

File

ActionController.h

Links
ActionController Class
Send comments on this topic.


ActionIntention Class

ActionIntention Class
Constructors | Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All

ActionIntention

ActionIntention
C++
public: class ActionIntention;
Constructors
Constructor | Description
ActionIntention |
Destructors
Destructor | Description
~ActionIntention |
Methods
Method | Description
Clear |
Update |
Namespace

rage Namespace

File

ActionController.h

Links
Constructors, Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


ActionIntention::ActionIntention Constructor

ActionIntention::ActionIntention Constructor
ActionIntention Class
Show All
C++
public: ActionIntention();
Class

ActionIntention Class

File

ActionController.h

Links
ActionIntention Class
Send comments on this topic.


ActionIntention::~ActionIntention Destructor

ActionIntention::~ActionIntention Destructor
ActionIntention Class
Show All
C++
public: virtual ~ActionIntention();
Class

ActionIntention Class

File

ActionController.h

Links
ActionIntention Class
Send comments on this topic.


ActionIntention::Clear Method

ActionIntention::Clear Method
ActionIntention Class
Show All
C++
public: void Clear(
    void
);
Class

ActionIntention Class

File

ActionController.h

Links
ActionIntention Class
Send comments on this topic.


ActionIntention::Update Method

ActionIntention::Update Method
ActionIntention Class
Show All
C++
public: void Update(
    float deltaTime
);
Class

ActionIntention Class

File

ActionController.h

Links
ActionIntention Class
Send comments on this topic.


ActionNode Class

ActionNode Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Friends | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::IArchive
        ActionNode
            rage::ActionNodeImplementation
            rage::ActionNodeReference
C++
public: class ActionNode : public IArchive;
Structs
Struct | Description
ActionTreeTaskParams |
Constructors
Constructor | Description
ActionNode |
IArchive |
Destructors
Destructor | Description
~ActionNode |
~IArchive |
~IName |
Methods
Method | Description
AddBranch | Add Resources
AddChildActionNode |
AddChildActionNodes |
AddCondition |
AddRoot |
AddStuff |
AddTrack |
AddTracksBank |
BalanceWeights |
ChangeChildPriority |
ChangeConditionPriority |
ChangePriority |
ChangeTrackPriority |
ClearChildNodes | never call clear in the real game, only in resource compiler outside of Begin/EndBuild
ClearRoots |
Create |
CreateIArchive |
DATAMEMEBERS_INTERFACE_NO_NAME |
DeInit |
DeleteChildActionNodes | Remove Resources
DeleteCondition |
DeleteTrack |
DumpTiming |
DumpTimingRecursive |
EvalRemote | : evalutes the remtoe conditions for this node. Return false if any condition objects.
EvalRemoteTransition | : evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.
Find |
FindChildNode |
FindFirstPlayable |
FindRoot | Find methods... should rework this
GetChild |
GetChildCount | Traversal
GetCNamePath | Get Resource for views
GetCondition |
GetConditionCount |
GetConditionGroup |
GetCondtionFormat |
GetFileRoot |
GetName |
GetName |
GetNameFullPath |
GetNameFullPathDebug |
GetParent |
GetPathCRC | MP functionality
GetPriority | Sibling Position Child Priority
GetRefCount |
GetRoot |
GetTrack |
GetTrackCount |
GetTrackFormat |
GetType |
IncRefCount |
Init |
IsDescendantOf |
Load |
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
OnTreeUnload |
OperateAllNodes |
OperateChildOnNodes | Helper for recursive visit function
PrintAllNodes |
ReadConditionGroup |
RecursSetFileRoots |
RemoveChildActionNode |
ReserveTracks |
ResetTiming |
ResetTimingRecursive |
ResolveAllTrackReferences |
ResolveAllWeights |
ResolveTrackReferences |
ResolveWeights |
SetOnLoad |
SetOnUnload |
SetParent |
TaskLoadActionNode |
TokenName | Write to buffer
TRACK_PARAMETER_STRING |
UnLoad |
UnLoadAll |
Write |
Write |
writeBegin |
writeChildren |
writeComment |
WriteCondition |
writeConditions |
writeEnd |
writeTracks |
Data Members
Data Member | Description
m_bUpdatedOnce |
m_bViewExpanded |
m_childNodes |
m_FileRoot | Points to root node of file for ref counting fun
m_GlobalEditPriority |
m_OnLoad |
m_OnUnload |
m_Pad |
m_parent |
m_PathCRC | used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed
m_Root |
m_Type |
RORC_VERSION | Don't forget to bump this whenever this structure changes
sm_ActFullPath |
sm_ActPath |
sm_OnTreeUnloadCallback |
sm_PostLoadCallback |
sm_RscFirstPass | set to false the second time through
Friends
Friend | Description
class ActionNodeReference | need to be able to access private data
class ActionNodeTree |
Namespace

rage Namespace

File

ActionNode.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Friends, rage Namespace, Inheritance Hierarchy


ActionNode::m_bUpdatedOnce Data Member

ActionNode::m_bUpdatedOnce Data Member
ActionNode Class
Show All
C++
public: bool m_bUpdatedOnce;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::m_bViewExpanded Data Member

ActionNode::m_bViewExpanded Data Member
ActionNode Class
Show All
C++
public: bool m_bViewExpanded;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::m_childNodes Data Member

ActionNode::m_childNodes Data Member
ActionNode Class
Show All
C++
protected: atArray<datOwner<ActionNode> > m_childNodes;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::m_FileRoot Data Member

ActionNode::m_FileRoot Data Member
ActionNode Class
Show All

Points to root node of file for ref counting fun

C++
protected: ActionNodeTreeHandle* m_FileRoot;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::m_GlobalEditPriority Data Member

ActionNode::m_GlobalEditPriority Data Member
ActionNode Class
Show All
C++
public: static int m_GlobalEditPriority;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::m_OnLoad Data Member

ActionNode::m_OnLoad Data Member
ActionNode Class
Show All
C++
protected: static ActionVistorCallBack m_OnLoad;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::m_OnUnload Data Member

ActionNode::m_OnUnload Data Member
ActionNode Class
Show All
C++
protected: static ActionVistorCallBack m_OnUnload;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::m_Pad Data Member

ActionNode::m_Pad Data Member
ActionNode Class
Show All
C++
protected: datPadding<3> m_Pad;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::m_parent Data Member

ActionNode::m_parent Data Member
ActionNode Class
Show All
C++
protected: datRef<ActionNode> m_parent;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::m_PathCRC Data Member

ActionNode::m_PathCRC Data Member
ActionNode Class
Show All

used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed

C++
protected: unsigned int m_PathCRC;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::m_Root Data Member

ActionNode::m_Root Data Member
ActionNode Class
Show All
C++
protected: static ActionNodeBank* m_Root;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::m_Type Data Member

ActionNode::m_Type Data Member
ActionNode Class
Show All
C++
protected: rage::u8 m_Type;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::RORC_VERSION Data Member

ActionNode::RORC_VERSION Data Member
ActionNode Class
Show All

Don't forget to bump this whenever this structure changes

C++
public: static const int RORC_VERSION = 5;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::sm_ActFullPath Data Member

ActionNode::sm_ActFullPath Data Member
ActionNode Class
Show All
C++
public: static const char * sm_ActFullPath;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::sm_ActPath Data Member

ActionNode::sm_ActPath Data Member
ActionNode Class
Show All
C++
public: static const char* sm_ActPath;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::sm_OnTreeUnloadCallback Data Member

ActionNode::sm_OnTreeUnloadCallback Data Member
ActionNode Class
Show All
C++
public: static void (* sm_OnTreeUnloadCallback)(ActionNode*);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::sm_PostLoadCallback Data Member

ActionNode::sm_PostLoadCallback Data Member
ActionNode Class
Show All
C++
public: static void (* sm_PostLoadCallback)(ActionTreeTaskParams*);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::sm_RscFirstPass Data Member

ActionNode::sm_RscFirstPass Data Member
ActionNode Class
Show All

set to false the second time through

C++
public: static bool sm_RscFirstPass;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


rage::ActionNode::ActionTreeTaskParams Struct

rage::ActionNode::ActionTreeTaskParams Struct
ActionNode Class
Show All
C++
public: struct ActionTreeTaskParams {
  public: const char* name;
  public: const char* path;
  public: ActionNodeTree* tree;
  public: bool threadcachedname;
  public: const void* owner;
};
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::ActionNode Constructor

ActionNode::ActionNode Constructor
ActionNode Class
Show All
C++
public: ActionNode(
    int type = TYPE_AN
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::~ActionNode Destructor

ActionNode::~ActionNode Destructor
ActionNode Class
Show All
C++
public: virtual ~ActionNode();
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::AddBranch Method

ActionNode::AddBranch Method
ActionNode Class
Show All

Add Resources

C++
public: void AddBranch(
    char* branchString
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::AddChildActionNode Method

ActionNode::AddChildActionNode Method
ActionNode Class
Show All
C++
public: inline void AddChildActionNode(
    ActionNode* newNode
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::AddChildActionNodes Method

ActionNode::AddChildActionNodes Method
ActionNode Class
Show All
C++
public: void AddChildActionNodes(
    ActionNode** newNodes,
    int numNodes
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::AddCondition Method (TextParser&)

ActionNode::AddCondition Method (TextParser&)
ActionNode Class
Show All
C++
public: virtual Condition* AddCondition(
    TextParser& textParser
) = 0;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::AddCondition Method (const char*)

ActionNode::AddCondition Method (const char*)
ActionNode Class
Show All
C++
public: virtual Condition* AddCondition(
    const char* conditionFormat
) = 0;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::AddRoot Method

ActionNode::AddRoot Method
ActionNode Class
Show All
C++
public: static void AddRoot(
    ActionNode* root
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::AddStuff Method

ActionNode::AddStuff Method
ActionNode Class
Show All
C++
public: virtual void AddStuff(
    TextParser& textParser
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::AddTrack Method (TextParser&)

ActionNode::AddTrack Method (TextParser&)
ActionNode Class
Show All
C++
public: virtual Track* AddTrack(
    TextParser& textParser
) = 0;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::AddTrack Method (Track*)

ActionNode::AddTrack Method (Track*)
ActionNode Class
Show All
C++
public: virtual Track* AddTrack(
    Track*
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::AddTrack Method (const char*)

ActionNode::AddTrack Method (const char*)
ActionNode Class
Show All
C++
public: virtual Track* AddTrack(
    const char* trackFormat
) = 0;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::AddTracksBank Method

ActionNode::AddTracksBank Method
ActionNode Class
Show All
C++
public: void AddTracksBank(
    TextParser& textParser
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::BalanceWeights Method

ActionNode::BalanceWeights Method
ActionNode Class
Show All
C++
public: float BalanceWeights(
    float weight
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::ChangeChildPriority Method

ActionNode::ChangeChildPriority Method
ActionNode Class
Show All
C++
public: int ChangeChildPriority(
    ActionNode* child,
    bool increase
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::ChangeConditionPriority Method

ActionNode::ChangeConditionPriority Method
ActionNode Class
Show All
C++
public: virtual void ChangeConditionPriority(
    int,
    bool
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::ChangePriority Method

ActionNode::ChangePriority Method
ActionNode Class
Show All
C++
public: int ChangePriority(
    bool increase
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::ChangeTrackPriority Method

ActionNode::ChangeTrackPriority Method
ActionNode Class
Show All
C++
public: virtual void ChangeTrackPriority(
    int,
    bool
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::ClearChildNodes Method

ActionNode::ClearChildNodes Method
ActionNode Class
Show All

never call clear in the real game, only in resource compiler outside of Begin/EndBuild

C++
public: void ClearChildNodes();
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::ClearRoots Method

ActionNode::ClearRoots Method
ActionNode Class
Show All
C++
public: static void ClearRoots(
    void
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::Create Method

ActionNode::Create Method
ActionNode Class
Show All
C++
public: static ActionNode* Create(
    TextParser& textParser
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::CreateIArchive Method

ActionNode::CreateIArchive Method
ActionNode Class
Show All
C++
public: static IArchive* CreateIArchive(
    TextParser& textParser
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::DATAMEMEBERS_INTERFACE_NO_NAME Method

ActionNode::DATAMEMEBERS_INTERFACE_NO_NAME Method
ActionNode Class
Show All
C++
public: DATAMEMEBERS_INTERFACE_NO_NAME(
    ActionNode
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::DeInit Method

ActionNode::DeInit Method
ActionNode Class
Show All
C++
public: static void DeInit(
    void
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::DeleteChildActionNodes Method

ActionNode::DeleteChildActionNodes Method
ActionNode Class
Show All

Remove Resources

C++
public: void DeleteChildActionNodes(
    void
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::DeleteCondition Method (Condition*)

ActionNode::DeleteCondition Method (Condition*)
ActionNode Class
Show All
C++
public: virtual bool DeleteCondition(
    Condition*
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::DeleteCondition Method (int)

ActionNode::DeleteCondition Method (int)
ActionNode Class
Show All

#ifdef DR_V_EDIT_MODE

Delete resources... this is only while in edit mode... Like in the tool

we may want to reenable this in RAW_ACT_FILE_SUPPORT?

C++
public: virtual void DeleteCondition(
    int
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::DeleteTrack Method (Track*)

ActionNode::DeleteTrack Method (Track*)
ActionNode Class
Show All
C++
public: virtual bool DeleteTrack(
    Track*
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::DeleteTrack Method (int)

ActionNode::DeleteTrack Method (int)
ActionNode Class
Show All
C++
public: virtual void DeleteTrack(
    int
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::DumpTiming Method

ActionNode::DumpTiming Method
ActionNode Class
Show All
C++
public: static void DumpTiming();
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::DumpTimingRecursive Method

ActionNode::DumpTimingRecursive Method
ActionNode Class
Show All
C++
public: void DumpTimingRecursive(
    fiStream* fid
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::EvalRemote Method

ActionNode::EvalRemote Method
ActionNode Class
Show All

: evalutes the remtoe conditions for this node. Return false if any condition objects.

C++
public: virtual bool EvalRemote(
    ActionContext* context = 0
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::EvalRemoteTransition Method

ActionNode::EvalRemoteTransition Method
ActionNode Class
Show All

: evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.

C++
public: virtual bool EvalRemoteTransition(
    ActionContext* context = 0
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::Find Method (const CFastNamePath&, ActionNode*)

ActionNode::Find Method (const CFastNamePath&, ActionNode*)
ActionNode Class
Show All
C++
public: static ActionNode* Find(
    const CFastNamePath& nodeNamePath,
    ActionNode* startNode = NULL
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::Find Method (const CNamePath*, ActionNode*)

ActionNode::Find Method (const CNamePath*, ActionNode*)
ActionNode Class
Show All
C++
public: static ActionNode* Find(
    const CNamePath* nodeNamePath,
    ActionNode* startNode = NULL
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::Find Method (const char*, ActionNode*)

ActionNode::Find Method (const char*, ActionNode*)
ActionNode Class
Show All
C++
public: static ActionNode* Find(
    const char* nodeNamePath,
    ActionNode* startNode = NULL
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::Find Method (const int*, int, ActionNode*)

ActionNode::Find Method (const int*, int, ActionNode*)
ActionNode Class
Show All
C++
public: static ActionNode* Find(
    const int* nodeNamePath,
    int numNames,
    ActionNode* startNode = NULL
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::FindChildNode Method (const char*)

ActionNode::FindChildNode Method (const char*)
ActionNode Class
Show All
C++
public: ActionNode* FindChildNode(
    const char* nodeName
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::FindChildNode Method (int)

ActionNode::FindChildNode Method (int)
ActionNode Class
Show All
C++
public: ActionNode* FindChildNode(
    int id
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::FindFirstPlayable Method

ActionNode::FindFirstPlayable Method
ActionNode Class
Show All
C++
public: ActionNodePlayable* FindFirstPlayable(
    void
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::FindRoot Method

ActionNode::FindRoot Method
ActionNode Class
Show All

Find methods... should rework this

C++
public: ActionNode* FindRoot(
    void
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetChild Method

ActionNode::GetChild Method
ActionNode Class
Show All
C++
public: virtual ActionNode* GetChild(
    int childIndex
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetChildCount Method

ActionNode::GetChildCount Method
ActionNode Class
Show All

Traversal

C++
public: virtual int GetChildCount(
    void
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetCNamePath Method

ActionNode::GetCNamePath Method
ActionNode Class
Show All

Get Resource for views

C++
public: void GetCNamePath(
    CNamePath & outPath
) const;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetCondition Method

ActionNode::GetCondition Method
ActionNode Class
Show All
C++
public: virtual Condition* GetCondition(
    int conditionIndex
) = 0;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetConditionCount Method

ActionNode::GetConditionCount Method
ActionNode Class
Show All
C++
public: virtual int GetConditionCount(
    void
) = 0;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetConditionGroup Method

ActionNode::GetConditionGroup Method
ActionNode Class
Show All
C++
protected: virtual ConditionGroup* GetConditionGroup(
    void
) = 0;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetCondtionFormat Method

ActionNode::GetCondtionFormat Method
ActionNode Class
Show All
C++
public: virtual const char* GetCondtionFormat(
    int conditionIndex
) = 0;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetFileRoot Method ()

ActionNode::GetFileRoot Method ()
ActionNode Class
Show All
C++
public: ActionNodeTreeHandle * GetFileRoot() const;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetFileRoot Method (void)

ActionNode::GetFileRoot Method (void)
ActionNode Class
Show All
C++
public: ActionNodeTreeHandle* GetFileRoot(
    void
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetName Method (void)

ActionNode::GetName Method (void)
ActionNode Class
Show All
C++
public: virtual CName* GetName(
    void
) = 0;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetName Method (void)

ActionNode::GetName Method (void)
ActionNode Class
Show All
C++
public: virtual const CName* GetName(
    void
) = 0 const;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetNameFullPath Method (char*, int)

ActionNode::GetNameFullPath Method (char*, int)
ActionNode Class
Show All
C++
public: void GetNameFullPath(
    char* returnBuffer,
    int size
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetNameFullPath Method (char*, int)

ActionNode::GetNameFullPath Method (char*, int)
ActionNode Class
Show All

these functions should probably also be #if !__FINAL since they now can't do anything useful in a shipped game

C++
public: void GetNameFullPath(
    char* returnBuffer,
    int size
) const;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetNameFullPathDebug Method

ActionNode::GetNameFullPathDebug Method
ActionNode Class
Show All
C++
public: const char* GetNameFullPathDebug(
    void
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetParent Method

ActionNode::GetParent Method
ActionNode Class
Show All
C++
public: ActionNode* GetParent(
    void
) const;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetPathCRC Method

ActionNode::GetPathCRC Method
ActionNode Class
Show All

MP functionality

C++
public: unsigned int GetPathCRC();
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetPriority Method

ActionNode::GetPriority Method
ActionNode Class
Show All

Sibling Position Child Priority

C++
public: int GetPriority() const;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetRefCount Method

ActionNode::GetRefCount Method
ActionNode Class
Show All
C++
public: int GetRefCount();
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetRoot Method

ActionNode::GetRoot Method
ActionNode Class
Show All
C++
public: static ActionNodeBank* GetRoot(
    void
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetTrack Method

ActionNode::GetTrack Method
ActionNode Class
Show All
C++
public: virtual Track* GetTrack(
    int trackIndex
) = 0;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetTrackCount Method

ActionNode::GetTrackCount Method
ActionNode Class
Show All
C++
public: virtual int GetTrackCount(
    void
) = 0;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetTrackFormat Method

ActionNode::GetTrackFormat Method
ActionNode Class
Show All
C++
public: virtual const char* GetTrackFormat(
    int trackIndex
) = 0;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::GetType Method

ActionNode::GetType Method
ActionNode Class
Show All
C++
public: int GetType() const;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::IncRefCount Method

ActionNode::IncRefCount Method
ActionNode Class
Show All
C++
public: void IncRefCount();
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::Init Method

ActionNode::Init Method
ActionNode Class
Show All
C++
public: void Init(
    void
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::IsDescendantOf Method (const ActionNode *)

ActionNode::IsDescendantOf Method (const ActionNode *)
ActionNode Class
Show All
C++
public: bool IsDescendantOf(
    const ActionNode * ancestor
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::IsDescendantOf Method (const CName&)

ActionNode::IsDescendantOf Method (const CName&)
ActionNode Class
Show All
C++
public: bool IsDescendantOf(
    const CName& ancestor
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::IsDescendantOf Method (const char*)

ActionNode::IsDescendantOf Method (const char*)
ActionNode Class
Show All
C++
public: bool IsDescendantOf(
    const char* ancestor
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::Load Method

ActionNode::Load Method
ActionNode Class
Show All
C++
public: static ActionNode* Load(
    const char* fileName,
    const char* basePath
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::Match Method

ActionNode::Match Method
ActionNode Class
Show All

Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found

C++
public: virtual ActionNodePlayable* Match(
    ActionContext* context = 0
) = 0;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::OnTreeUnload Method

ActionNode::OnTreeUnload Method
ActionNode Class
Show All
C++
public: static void OnTreeUnload(
    ActionNode* childBranch
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::OperateAllNodes Method

ActionNode::OperateAllNodes Method
ActionNode Class
Show All
C++
public: static void OperateAllNodes(
    ActionVistorCallBack& clbk
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::OperateChildOnNodes Method

ActionNode::OperateChildOnNodes Method
ActionNode Class
Show All

Helper for recursive visit function

C++
protected: static void OperateChildOnNodes(
    ActionNode* parent,
    ActionVistorCallBack& clbk
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::PrintAllNodes Method

ActionNode::PrintAllNodes Method
ActionNode Class
Show All
C++
public: static void PrintAllNodes(
    ActionNode* parent,
    int iDepth = 0
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::ReadConditionGroup Method

ActionNode::ReadConditionGroup Method
ActionNode Class
Show All
C++
public: virtual void ReadConditionGroup(
    TextParser& textParser
) = 0;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::RecursSetFileRoots Method

ActionNode::RecursSetFileRoots Method
ActionNode Class
Show All
C++
public: virtual void RecursSetFileRoots(
    ActionNodeTreeHandle * pFileRoot
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::RemoveChildActionNode Method

ActionNode::RemoveChildActionNode Method
ActionNode Class
Show All
C++
public: inline bool RemoveChildActionNode(
    ActionNode* childNode
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::ReserveTracks Method

ActionNode::ReserveTracks Method
ActionNode Class
Show All
C++
public: virtual void ReserveTracks(
    int count
) = 0;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::ResetTiming Method

ActionNode::ResetTiming Method
ActionNode Class
Show All
C++
public: static void ResetTiming();
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::ResetTimingRecursive Method

ActionNode::ResetTimingRecursive Method
ActionNode Class
Show All
C++
public: void ResetTimingRecursive();
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::ResolveAllTrackReferences Method

ActionNode::ResolveAllTrackReferences Method
ActionNode Class
Show All
C++
public: static void ResolveAllTrackReferences(
    eActionNodeResolveMode mode = NODES_ADDED
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::ResolveAllWeights Method

ActionNode::ResolveAllWeights Method
ActionNode Class
Show All
C++
public: static void ResolveAllWeights();
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::ResolveTrackReferences Method

ActionNode::ResolveTrackReferences Method
ActionNode Class
Show All
C++
public: void ResolveTrackReferences(
    eActionNodeResolveMode mode = NODES_ADDED
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::ResolveWeights Method

ActionNode::ResolveWeights Method
ActionNode Class
Show All
C++
public: virtual void ResolveWeights();
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::SetOnLoad Method

ActionNode::SetOnLoad Method
ActionNode Class
Show All
C++
public: static void SetOnLoad(
    ActionVistorCallBack clbk
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::SetOnUnload Method

ActionNode::SetOnUnload Method
ActionNode Class
Show All
C++
public: static void SetOnUnload(
    ActionVistorCallBack clbk
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::SetParent Method

ActionNode::SetParent Method
ActionNode Class
Show All
C++
public: void SetParent(
    ActionNode* parent
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::TaskLoadActionNode Method

ActionNode::TaskLoadActionNode Method
ActionNode Class
Show All
C++
public: static void TaskLoadActionNode(
    sysTaskParameters & p
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::TokenName Method

ActionNode::TokenName Method
ActionNode Class
Show All

Write to buffer

C++
public: virtual const char* TokenName();
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::TRACK_PARAMETER_STRING Method

ActionNode::TRACK_PARAMETER_STRING Method
ActionNode Class
Show All
C++
public: TRACK_PARAMETER_STRING(
    Comment
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::UnLoad Method (ActionNodeTreeHandle*)

ActionNode::UnLoad Method (ActionNodeTreeHandle*)
ActionNode Class
Show All
C++
public: static void UnLoad(
    ActionNodeTreeHandle* node
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::UnLoad Method (const char*)

ActionNode::UnLoad Method (const char*)
ActionNode Class
Show All
C++
public: static void UnLoad(
    const char* branchRoot
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::UnLoadAll Method

ActionNode::UnLoadAll Method
ActionNode Class
Show All
C++
public: static void UnLoadAll(
    void
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::Write Method (TextBuffer&)

ActionNode::Write Method (TextBuffer&)
ActionNode Class
Show All
C++
public: virtual void Write(
    TextBuffer& textBuffer
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::Write Method (TextBuffer&, const char*)

ActionNode::Write Method (TextBuffer&, const char*)
ActionNode Class
Show All
C++
public: void Write(
    TextBuffer& textBuffer,
    const char* headerName
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::writeBegin Method

ActionNode::writeBegin Method
ActionNode Class
Show All
C++
protected: void writeBegin(
    TextBuffer& tB
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::writeChildren Method

ActionNode::writeChildren Method
ActionNode Class
Show All
C++
protected: void writeChildren(
    TextBuffer& tB
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::writeComment Method

ActionNode::writeComment Method
ActionNode Class
Show All
C++
protected: void writeComment(
    TextBuffer& tB
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::WriteCondition Method

ActionNode::WriteCondition Method
ActionNode Class
Show All
C++
public: virtual void WriteCondition(
    int conditionIndex,
    TextBuffer& textBuff
) = 0;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::writeConditions Method

ActionNode::writeConditions Method
ActionNode Class
Show All
C++
protected: void writeConditions(
    TextBuffer& tB
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::writeEnd Method

ActionNode::writeEnd Method
ActionNode Class
Show All
C++
protected: void writeEnd(
    TextBuffer& tB
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNode::writeTracks Method

ActionNode::writeTracks Method
ActionNode Class
Show All
C++
protected: void writeTracks(
    TextBuffer& tB
);
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


friend class ActionNodeReference Friend

friend class ActionNodeReference Friend
ActionNode Class
Show All

need to be able to access private data

C++
public: friend class ActionNodeReference;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


friend class ActionNodeTree Friend

friend class ActionNodeTree Friend
ActionNode Class
Show All
C++
public: friend class ActionNodeTree;
Class

ActionNode Class

File

ActionNode.h

Links
ActionNode Class
Send comments on this topic.


ActionNodeBank Class

ActionNodeBank Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Friends | rage Namespace | Inheritance Hierarchy
Show All

ActionNodeBank Matching a Playable Node will also include the tracks of this Bank during Playback

rage::IName
    rage::IArchive
        rage::ActionNode
            rage::ActionNodeImplementation
                ActionNodeBank
C++
public: class ActionNodeBank : public ActionNodeImplementation;
Structs
Struct | Description
ActionTreeTaskParams |
Constructors
Constructor | Description
ActionNode |
ActionNodeBank |
ActionNodeImplementation |
IArchive |
Destructors
Destructor | Description
~ActionNode |
~ActionNodeBank |
~ActionNodeImplementation |
~IArchive |
~IName |
Methods
Method | Description
AddBranch | Add Resources
AddChildActionNode |
AddChildActionNodes |
AddCondition |
AddCondition |
AddRoot |
AddStuff |
AddTrack |
AddTrack |
AddTracksBank |
BalanceWeights |
ChangeChildPriority |
ChangeConditionPriority |
ChangeConditionPriority |
ChangePriority |
ChangeTrackPriority |
ChangeTrackPriority |
ClearChildNodes | never call clear in the real game, only in resource compiler outside of Begin/EndBuild
ClearRoots |
Create |
CreateIArchive |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DeInit |
DeleteChildActionNodes | Remove Resources
DeleteCondition |
DeleteCondition |
DeleteTrack |
DeleteTrack |
DumpTiming |
DumpTimingRecursive |
EvalRemote | : evalutes the remtoe conditions for this node. Return false if any condition objects.
EvalRemoteTransition | : evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.
Find |
FindChildNode |
FindFirstPlayable |
FindRoot | Find methods... should rework this
GetChild |
GetChildCount | Traversal
GetCNamePath | Get Resource for views
GetCondition |
GetCondition |
GetConditionCount |
GetConditionCount | Get Resource for views
GetConditionGroup |
GetConditionGroup |
GetCondtionFormat |
GetCondtionFormat |
GetFileRoot |
GetName |
GetName |
GetName |
GetNameFullPath |
GetNameFullPathDebug |
GetParent |
GetPathCRC | MP functionality
GetPriority | Sibling Position Child Priority
GetRefCount |
GetRoot |
GetTrack |
GetTrack |
GetTrackCount |
GetTrackCount |
GetTrackFormat |
GetTrackFormat |
GetType |
IncRefCount |
Init |
IsDescendantOf |
Load |
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
OnTreeUnload |
OperateAllNodes |
OperateChildOnNodes | Helper for recursive visit function
PrintAllNodes |
ReadConditionGroup |
ReadConditionGroup |
RecursSetFileRoots |
RemoveChildActionNode |
ReserveTracks |
ReserveTracks |
ResetTiming |
ResetTimingRecursive |
ResolveAllTrackReferences |
ResolveAllWeights |
ResolveTrackReferences |
ResolveWeights |
ResolveWeights |
SetOnLoad |
SetOnUnload |
SetParent |
TaskLoadActionNode |
TokenName | Write to buffer
TokenName | Write to buffer
TRACK_PARAMETER_STRING |
UnLoad |
UnLoadAll |
Write |
Write |
writeBegin |
writeChildren |
writeComment |
WriteCondition |
WriteCondition |
writeConditions |
writeEnd |
writeTracks |
Data Members
Data Member | Description
m_bUpdatedOnce |
m_bViewExpanded |
m_childNodes |
m_Conditions |
m_FileRoot | Points to root node of file for ref counting fun
m_GlobalEditPriority |
m_Name |
m_OnLoad |
m_OnUnload |
m_Pad |
m_parent |
m_PathCRC | used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed
m_Root |
m_tracks |
m_Type |
RORC_VERSION | Don't forget to bump this whenever this structure changes
sm_ActFullPath |
sm_ActPath |
sm_OnTreeUnloadCallback |
sm_PostLoadCallback |
sm_RscFirstPass | set to false the second time through
Friends
Friend | Description
class ActionNodeReference | need to be able to access private data
class ActionNodeTree |
Namespace

rage Namespace

File

ActionNode.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Friends, rage Namespace, Inheritance Hierarchy


ActionNodeBank::ActionNodeBank Constructor (const char*, int)

ActionNodeBank::ActionNodeBank Constructor (const char*, int)
ActionNodeBank Class
Show All
C++
public: ActionNodeBank(
    const char* name,
    int type = TYPE_AN_BANK
);
Class

ActionNodeBank Class

File

ActionNode.h

Links
ActionNodeBank Class
Send comments on this topic.


ActionNodeBank::ActionNodeBank Constructor (int)

ActionNodeBank::ActionNodeBank Constructor (int)
ActionNodeBank Class
Show All
C++
public: ActionNodeBank(
    int type = TYPE_AN_BANK
);
Class

ActionNodeBank Class

File

ActionNode.h

Links
ActionNodeBank Class
Send comments on this topic.


ActionNodeBank::~ActionNodeBank Destructor

ActionNodeBank::~ActionNodeBank Destructor
ActionNodeBank Class
Show All
C++
public: virtual ~ActionNodeBank();
Class

ActionNodeBank Class

File

ActionNode.h

Links
ActionNodeBank Class
Send comments on this topic.


ActionNodeBank::DATAMEMEBERS_INTERFACE_NO_NAME Method

ActionNodeBank::DATAMEMEBERS_INTERFACE_NO_NAME Method
ActionNodeBank Class
Show All
C++
public: DATAMEMEBERS_INTERFACE_NO_NAME(
    ActionNodeBank
);
Class

ActionNodeBank Class

File

ActionNode.h

Links
ActionNodeBank Class
Send comments on this topic.


ActionNodeBank::Match Method

ActionNodeBank::Match Method
ActionNodeBank Class
Show All

Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found

C++
public: virtual ActionNodePlayable* Match(
    ActionContext* context = 0
);
Class

ActionNodeBank Class

File

ActionNode.h

Links
ActionNodeBank Class
Send comments on this topic.


ActionNodeBank::ResolveWeights Method

ActionNodeBank::ResolveWeights Method
ActionNodeBank Class
Show All
C++
public: virtual void ResolveWeights();
Class

ActionNodeBank Class

File

ActionNode.h

Links
ActionNodeBank Class
Send comments on this topic.


ActionNodeBank::TokenName Method

ActionNodeBank::TokenName Method
ActionNodeBank Class
Show All

Write to buffer

C++
public: const char* TokenName();
Class

ActionNodeBank Class

File

ActionNode.h

Links
ActionNodeBank Class
Send comments on this topic.


ActionNodeDebugName Struct

ActionNodeDebugName Struct
Constructors | Members | Operators | Data Members | rage Namespace | Inheritance Hierarchy
Show All

: helper class to extract the name of the action node consistently.

ActionNodeDebugName
C++
public: struct ActionNodeDebugName {
  public: const char* m_Name;
};
Constructors
Constructor | Description
ActionNodeDebugName |
Operators
Operator | Description
() |
Data Members
Data Member | Description
m_Name |
Namespace

rage Namespace

File

ActionController.h

Links
Constructors, Members, Operators, Data Members, rage Namespace, Inheritance Hierarchy


ActionNodeDebugName::m_Name Data Member

ActionNodeDebugName::m_Name Data Member
ActionNodeDebugName Struct
Show All
C++
public: const char* m_Name;
Struct

ActionNodeDebugName Struct

File

ActionController.h

Links
ActionNodeDebugName Struct
Send comments on this topic.


ActionNodeDebugName::ActionNodeDebugName Constructor

ActionNodeDebugName::ActionNodeDebugName Constructor
ActionNodeDebugName Struct
Show All
C++
public: ActionNodeDebugName(
    ActionNode*
);
Struct

ActionNodeDebugName Struct

File

ActionController.h

Links
ActionNodeDebugName Struct
Send comments on this topic.


ActionNodeDebugName::() Operator

ActionNodeDebugName::() Operator
ActionNodeDebugName Struct
Show All
C++
public: const char* operator ()(
    void
);
Struct

ActionNodeDebugName Struct

File

ActionController.h

Links
ActionNodeDebugName Struct
Send comments on this topic.


ActionNodeFileReference Class

ActionNodeFileReference Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Friends | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::IArchive
        rage::ActionNode
            rage::ActionNodeReference, rage::IDataMembers
                    ActionNodeFileReference
C++
public: class ActionNodeFileReference : public ActionNodeReference, public IDataMembers;
Structs
Struct | Description
ActionTreeTaskParams |
Constructors
Constructor | Description
ActionNode |
ActionNodeFileReference |
ActionNodeReference |
IArchive |
IDataMembers |
Destructors
Destructor | Description
~ActionNode |
~ActionNodeFileReference |
~ActionNodeReference |
~IArchive |
~IDataMembers |
~IName |
Methods
Method | Description
AddBranch | Add Resources
AddChildActionNode |
AddChildActionNodes |
AddCondition |
AddCondition |
AddRoot |
AddStuff |
AddTrack |
AddTrack |
AddTracksBank |
BalanceWeights |
ChangeChildPriority |
ChangeConditionPriority |
ChangePriority |
ChangeTrackPriority |
ClearChildNodes | never call clear in the real game, only in resource compiler outside of Begin/EndBuild
ClearRoots |
Create |
CreateIArchive |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DeclareStruct |
DeInit |
DeleteChildActionNodes | Remove Resources
DeleteCondition |
DeleteCondition |
DeleteTrack |
DumpTiming |
DumpTimingRecursive |
EvalRemote | : evalutes the remtoe conditions for this node. Return false if any condition objects.
EvalRemoteTransition | : evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.
Find |
FindChildNode |
FindFirstPlayable |
FindRoot | Find methods... should rework this
GetActionNode |
GetArchiveFileRecord | FileArchive interfaces
GetChild |
GetChild |
GetChildCount | Traversal
GetChildCount | Traversal
GetCNamePath | Get Resource for views
GetCondition |
GetCondition |
GetConditionCount |
GetConditionCount | Get Resource for views
GetConditionGroup |
GetConditionGroup |
GetCondtionFormat |
GetCondtionFormat |
GetFileName |
GetFileRoot |
GetFullPathName |
GetMember |
GetName |
GetName |
GetName |
GetNameFullPath |
GetNameFullPathDebug |
GetNumMembers |
GetParent |
GetPathCRC | MP functionality
GetPathName |
GetPriority | Sibling Position Child Priority
GetRefCount |
GetReferenceFullPath |
GetReferenceName |
GetRoot |
GetTrack |
GetTrack |
GetTrackCount |
GetTrackCount |
GetTrackFormat |
GetTrackFormat |
GetType |
IncRefCount |
Init |
IsDescendantOf |
IsNull |
Load |
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
OnTreeUnload |
OperateAllNodes |
OperateChildOnNodes | Helper for recursive visit function
PrintAllNodes |
Read |
Read |
ReadConditionGroup |
ReadConditionGroup |
ReadFile | The Actual SubTreeFile
RecursSetFileRoots |
RecursSetFileRoots |
RemoveChildActionNode |
ReserveTracks |
ReserveTracks |
Reset |
ResetTiming |
ResetTimingRecursive |
ResolveAllTrackReferences |
ResolveAllWeights |
ResolveReference | Try to find a node to connect to...
ResolveTrackReferences |
ResolveWeights |
SetActionNode |
SetFileName |
SetFullPathName |
SetOnLoad |
SetOnUnload |
SetParent |
SetPathName |
SetReferenceName |
TaskLoadActionNode |
TokenName | Write to buffer
TokenName | Write to buffer
TRACK_PARAMETER_STRING |
UnLoad |
UnLoadAll |
Write |
Write |
Write |
Write |
writeBegin |
writeChildren |
writeComment |
WriteCondition |
WriteCondition |
writeConditions |
writeEnd |
writeTracks |
Data Members
Data Member | Description
m_bUpdatedOnce |
m_bViewExpanded |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_childNodes |
m_FileRoot | Points to root node of file for ref counting fun
m_GlobalEditPriority |
m_nameFullPath |
m_OnLoad |
m_OnUnload |
m_Pad |
m_parent |
m_PathCRC | used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed
m_referenceName |
m_referenceNode |
m_Root |
m_Type |
RORC_VERSION | Don't forget to bump this whenever this structure changes
sm_ActFullPath |
sm_ActPath |
sm_OnTreeUnloadCallback |
sm_PostLoadCallback |
sm_RscFirstPass | set to false the second time through
Friends
Friend | Description
class ActionNodeReference | need to be able to access private data
class ActionNodeTree |
Namespace

rage Namespace

File

ActionNode.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Friends, rage Namespace, Inheritance Hierarchy


ActionNodeFileReference::ActionNodeFileReference Constructor (ActionNodeFileReference&)

ActionNodeFileReference::ActionNodeFileReference Constructor (ActionNodeFileReference&)
ActionNodeFileReference Class
Show All
C++
public: ActionNodeFileReference(
    ActionNodeFileReference&
);
Class

ActionNodeFileReference Class

File

ActionNode.h

Links
ActionNodeFileReference Class
Send comments on this topic.


ActionNodeFileReference::ActionNodeFileReference Constructor (const char*, int)

ActionNodeFileReference::ActionNodeFileReference Constructor (const char*, int)
ActionNodeFileReference Class
Show All
C++
public: ActionNodeFileReference(
    const char* name,
    int type = TYPE_AN_FILE_REFERENCE
);
Class

ActionNodeFileReference Class

File

ActionNode.h

Links
ActionNodeFileReference Class
Send comments on this topic.


ActionNodeFileReference::ActionNodeFileReference Constructor (int)

ActionNodeFileReference::ActionNodeFileReference Constructor (int)
ActionNodeFileReference Class
Show All
C++
public: ActionNodeFileReference(
    int type = TYPE_AN_FILE_REFERENCE
);
Class

ActionNodeFileReference Class

File

ActionNode.h

Links
ActionNodeFileReference Class
Send comments on this topic.


ActionNodeFileReference::~ActionNodeFileReference Destructor

ActionNodeFileReference::~ActionNodeFileReference Destructor
ActionNodeFileReference Class
Show All
C++
public: virtual ~ActionNodeFileReference();
Class

ActionNodeFileReference Class

File

ActionNode.h

Links
ActionNodeFileReference Class
Send comments on this topic.


ActionNodeFileReference::DATAMEMEBERS_INTERFACE_NO_NAME Method

ActionNodeFileReference::DATAMEMEBERS_INTERFACE_NO_NAME Method
ActionNodeFileReference Class
Show All
C++
public: DATAMEMEBERS_INTERFACE_NO_NAME(
    ActionNodeFileReference
);
Class

ActionNodeFileReference Class

File

ActionNode.h

Links
ActionNodeFileReference Class
Send comments on this topic.


ActionNodeFileReference::GetArchiveFileRecord Method

ActionNodeFileReference::GetArchiveFileRecord Method
ActionNodeFileReference Class
Show All

FileArchive interfaces

C++
public: ArchiveFileRecord* GetArchiveFileRecord(
    void
);
Class

ActionNodeFileReference Class

File

ActionNode.h

Links
ActionNodeFileReference Class
Send comments on this topic.


ActionNodeFileReference::GetFileName Method

ActionNodeFileReference::GetFileName Method
ActionNodeFileReference Class
Show All
C++
public: const char* GetFileName();
Class

ActionNodeFileReference Class

File

ActionNode.h

Links
ActionNodeFileReference Class
Send comments on this topic.


ActionNodeFileReference::GetFullPathName Method

ActionNodeFileReference::GetFullPathName Method
ActionNodeFileReference Class
Show All
C++
public: const CBasicString* GetFullPathName();
Class

ActionNodeFileReference Class

File

ActionNode.h

Links
ActionNodeFileReference Class
Send comments on this topic.


ActionNodeFileReference::GetPathName Method

ActionNodeFileReference::GetPathName Method
ActionNodeFileReference Class
Show All
C++
public: const char* GetPathName();
Class

ActionNodeFileReference Class

File

ActionNode.h

Links
ActionNodeFileReference Class
Send comments on this topic.


ActionNodeFileReference::Read Method

ActionNodeFileReference::Read Method
ActionNodeFileReference Class
Show All
C++
public: virtual void Read(
    TextParser& textParser
);
Class

ActionNodeFileReference Class

File

ActionNode.h

Links
ActionNodeFileReference Class
Send comments on this topic.


ActionNodeFileReference::ReadFile Method

ActionNodeFileReference::ReadFile Method
ActionNodeFileReference Class
Show All

The Actual SubTreeFile

C++
public: void ReadFile(
    void
);
Class

ActionNodeFileReference Class

File

ActionNode.h

Links
ActionNodeFileReference Class
Send comments on this topic.


ActionNodeFileReference::RecursSetFileRoots Method

ActionNodeFileReference::RecursSetFileRoots Method
ActionNodeFileReference Class
Show All
C++
public: virtual void RecursSetFileRoots(
    ActionNodeTreeHandle * pFileRoot
);
Class

ActionNodeFileReference Class

File

ActionNode.h

Links
ActionNodeFileReference Class
Send comments on this topic.


ActionNodeFileReference::SetFileName Method

ActionNodeFileReference::SetFileName Method
ActionNodeFileReference Class
Show All
C++
public: void SetFileName(
    const char* fileName
);
Class

ActionNodeFileReference Class

File

ActionNode.h

Links
ActionNodeFileReference Class
Send comments on this topic.


ActionNodeFileReference::SetFullPathName Method

ActionNodeFileReference::SetFullPathName Method
ActionNodeFileReference Class
Show All
C++
public: void SetFullPathName(
    const char* fileNameFullPath
);
Class

ActionNodeFileReference Class

File

ActionNode.h

Links
ActionNodeFileReference Class
Send comments on this topic.


ActionNodeFileReference::SetPathName Method

ActionNodeFileReference::SetPathName Method
ActionNodeFileReference Class
Show All
C++
public: void SetPathName(
    const char* path
);
Class

ActionNodeFileReference Class

File

ActionNode.h

Links
ActionNodeFileReference Class
Send comments on this topic.


ActionNodeFileReference::TokenName Method

ActionNodeFileReference::TokenName Method
ActionNodeFileReference Class
Show All

Write to buffer

C++
public: virtual const char* TokenName();
Class

ActionNodeFileReference Class

File

ActionNode.h

Links
ActionNodeFileReference Class
Send comments on this topic.


ActionNodeFileReference::Write Method (TextBuffer&)

ActionNodeFileReference::Write Method (TextBuffer&)
ActionNodeFileReference Class
Show All
C++
public: virtual void Write(
    TextBuffer& textBuffer
);
Class

ActionNodeFileReference Class

File

ActionNode.h

Links
ActionNodeFileReference Class
Send comments on this topic.


ActionNodeFileReference::Write Method (TextBuffer&, const char*)

ActionNodeFileReference::Write Method (TextBuffer&, const char*)
ActionNodeFileReference Class
Show All
C++
public: void Write(
    TextBuffer& textBuffer,
    const char* headerName
);
Class

ActionNodeFileReference Class

File

ActionNode.h

Links
ActionNodeFileReference Class
Send comments on this topic.


ActionNodeImplementation Class

ActionNodeImplementation Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Friends | rage Namespace | Inheritance Hierarchy
Show All

ActionNodeImplementation

rage::IName
    rage::IArchive
        rage::ActionNode
            ActionNodeImplementation
                rage::ActionNodeBank
                rage::ActionNodePlayable
C++
public: class ActionNodeImplementation : public ActionNode;
Structs
Struct | Description
ActionTreeTaskParams |
Constructors
Constructor | Description
ActionNode |
ActionNodeImplementation |
IArchive |
Destructors
Destructor | Description
~ActionNode |
~ActionNodeImplementation |
~IArchive |
~IName |
Methods
Method | Description
AddBranch | Add Resources
AddChildActionNode |
AddChildActionNodes |
AddCondition |
AddCondition |
AddRoot |
AddStuff |
AddTrack |
AddTrack |
AddTracksBank |
BalanceWeights |
ChangeChildPriority |
ChangeConditionPriority |
ChangeConditionPriority |
ChangePriority |
ChangeTrackPriority |
ChangeTrackPriority |
ClearChildNodes | never call clear in the real game, only in resource compiler outside of Begin/EndBuild
ClearRoots |
Create |
CreateIArchive |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DeInit |
DeleteChildActionNodes | Remove Resources
DeleteCondition |
DeleteCondition |
DeleteTrack |
DeleteTrack |
DumpTiming |
DumpTimingRecursive |
EvalRemote | : evalutes the remtoe conditions for this node. Return false if any condition objects.
EvalRemoteTransition | : evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.
Find |
FindChildNode |
FindFirstPlayable |
FindRoot | Find methods... should rework this
GetChild |
GetChildCount | Traversal
GetCNamePath | Get Resource for views
GetCondition |
GetCondition |
GetConditionCount |
GetConditionCount | Get Resource for views
GetConditionGroup |
GetConditionGroup |
GetCondtionFormat |
GetCondtionFormat |
GetFileRoot |
GetName |
GetName |
GetName |
GetNameFullPath |
GetNameFullPathDebug |
GetParent |
GetPathCRC | MP functionality
GetPriority | Sibling Position Child Priority
GetRefCount |
GetRoot |
GetTrack |
GetTrack |
GetTrackCount |
GetTrackCount |
GetTrackFormat |
GetTrackFormat |
GetType |
IncRefCount |
Init |
IsDescendantOf |
Load |
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
OnTreeUnload |
OperateAllNodes |
OperateChildOnNodes | Helper for recursive visit function
PrintAllNodes |
ReadConditionGroup |
ReadConditionGroup |
RecursSetFileRoots |
RemoveChildActionNode |
ReserveTracks |
ReserveTracks |
ResetTiming |
ResetTimingRecursive |
ResolveAllTrackReferences |
ResolveAllWeights |
ResolveTrackReferences |
ResolveWeights |
SetOnLoad |
SetOnUnload |
SetParent |
TaskLoadActionNode |
TokenName | Write to buffer
TRACK_PARAMETER_STRING |
UnLoad |
UnLoadAll |
Write |
Write |
writeBegin |
writeChildren |
writeComment |
WriteCondition |
WriteCondition |
writeConditions |
writeEnd |
writeTracks |
Data Members
Data Member | Description
m_bUpdatedOnce |
m_bViewExpanded |
m_childNodes |
m_Conditions |
m_FileRoot | Points to root node of file for ref counting fun
m_GlobalEditPriority |
m_Name |
m_OnLoad |
m_OnUnload |
m_Pad |
m_parent |
m_PathCRC | used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed
m_Root |
m_tracks |
m_Type |
RORC_VERSION | Don't forget to bump this whenever this structure changes
sm_ActFullPath |
sm_ActPath |
sm_OnTreeUnloadCallback |
sm_PostLoadCallback |
sm_RscFirstPass | set to false the second time through
Friends
Friend | Description
class ActionNodeReference | need to be able to access private data
class ActionNodeTree |
Namespace

rage Namespace

File

ActionNode.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Friends, rage Namespace, Inheritance Hierarchy


ActionNodeImplementation::m_Conditions Data Member

ActionNodeImplementation::m_Conditions Data Member
ActionNodeImplementation Class
Show All
C++
protected: ConditionGroup m_Conditions;
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::m_Name Data Member

ActionNodeImplementation::m_Name Data Member
ActionNodeImplementation Class
Show All
C++
protected: CName m_Name;
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::m_tracks Data Member

ActionNodeImplementation::m_tracks Data Member
ActionNodeImplementation Class
Show All
C++
protected: atArray<datRef<Track> > m_tracks;
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::ActionNodeImplementation Constructor (const char*, int)

ActionNodeImplementation::ActionNodeImplementation Constructor (const char*, int)
ActionNodeImplementation Class
Show All
C++
public: ActionNodeImplementation(
    const char* name,
    int type = TYPE_AN_IMP
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::ActionNodeImplementation Constructor (int)

ActionNodeImplementation::ActionNodeImplementation Constructor (int)
ActionNodeImplementation Class
Show All
C++
public: ActionNodeImplementation(
    int type = TYPE_AN_IMP
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::~ActionNodeImplementation Destructor

ActionNodeImplementation::~ActionNodeImplementation Destructor
ActionNodeImplementation Class
Show All
C++
public: virtual ~ActionNodeImplementation();
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::AddCondition Method (TextParser&)

ActionNodeImplementation::AddCondition Method (TextParser&)
ActionNodeImplementation Class
Show All
C++
public: Condition* AddCondition(
    TextParser& textParser
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::AddCondition Method (const char*)

ActionNodeImplementation::AddCondition Method (const char*)
ActionNodeImplementation Class
Show All
C++
public: virtual Condition* AddCondition(
    const char* conditionFormat
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::AddTrack Method (TextParser&)

ActionNodeImplementation::AddTrack Method (TextParser&)
ActionNodeImplementation Class
Show All
C++
public: virtual Track* AddTrack(
    TextParser& textParser
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::AddTrack Method (Track*)

ActionNodeImplementation::AddTrack Method (Track*)
ActionNodeImplementation Class
Show All
C++
public: virtual Track* AddTrack(
    Track* track
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::AddTrack Method (const char*)

ActionNodeImplementation::AddTrack Method (const char*)
ActionNodeImplementation Class
Show All
C++
public: virtual Track* AddTrack(
    const char* trackFormat
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::ChangeConditionPriority Method

ActionNodeImplementation::ChangeConditionPriority Method
ActionNodeImplementation Class
Show All
C++
public: virtual void ChangeConditionPriority(
    int conditionIndex,
    bool increase
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::ChangeTrackPriority Method

ActionNodeImplementation::ChangeTrackPriority Method
ActionNodeImplementation Class
Show All
C++
public: virtual void ChangeTrackPriority(
    int trackIndex,
    bool increase
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::DATAMEMEBERS_INTERFACE_NO_NAME Method

ActionNodeImplementation::DATAMEMEBERS_INTERFACE_NO_NAME Method
ActionNodeImplementation Class
Show All
C++
public: DATAMEMEBERS_INTERFACE_NO_NAME(
    ActionNodeImplementation
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::DeleteCondition Method (Condition *)

ActionNodeImplementation::DeleteCondition Method (Condition *)
ActionNodeImplementation Class
Show All
C++
public: virtual bool DeleteCondition(
    Condition * pCondition
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::DeleteCondition Method (int)

ActionNodeImplementation::DeleteCondition Method (int)
ActionNodeImplementation Class
Show All

Delete resources... this is only while in edit mode... Like in the tool

C++
public: virtual void DeleteCondition(
    int index
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::DeleteTrack Method (Track *)

ActionNodeImplementation::DeleteTrack Method (Track *)
ActionNodeImplementation Class
Show All
C++
public: virtual bool DeleteTrack(
    Track * pTrack
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::DeleteTrack Method (int)

ActionNodeImplementation::DeleteTrack Method (int)
ActionNodeImplementation Class
Show All
C++
public: virtual void DeleteTrack(
    int index
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::GetCondition Method

ActionNodeImplementation::GetCondition Method
ActionNodeImplementation Class
Show All
C++
public: virtual Condition* GetCondition(
    int conditionIndex
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::GetConditionCount Method

ActionNodeImplementation::GetConditionCount Method
ActionNodeImplementation Class
Show All

Get Resource for views

C++
public: virtual int GetConditionCount(
    void
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::GetConditionGroup Method

ActionNodeImplementation::GetConditionGroup Method
ActionNodeImplementation Class
Show All
C++
protected: virtual ConditionGroup* GetConditionGroup(
    void
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::GetCondtionFormat Method

ActionNodeImplementation::GetCondtionFormat Method
ActionNodeImplementation Class
Show All
C++
public: virtual const char* GetCondtionFormat(
    int conditionIndex
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::GetName Method (void)

ActionNodeImplementation::GetName Method (void)
ActionNodeImplementation Class
Show All
C++
public: virtual CName* GetName(
    void
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::GetName Method (void)

ActionNodeImplementation::GetName Method (void)
ActionNodeImplementation Class
Show All
C++
public: virtual const CName* GetName(
    void
) const;
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::GetTrack Method

ActionNodeImplementation::GetTrack Method
ActionNodeImplementation Class
Show All
C++
public: virtual Track* GetTrack(
    int trackIndex
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::GetTrackCount Method

ActionNodeImplementation::GetTrackCount Method
ActionNodeImplementation Class
Show All
C++
public: virtual int GetTrackCount(
    void
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::GetTrackFormat Method

ActionNodeImplementation::GetTrackFormat Method
ActionNodeImplementation Class
Show All
C++
public: virtual const char* GetTrackFormat(
    int trackIndex
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::ReadConditionGroup Method

ActionNodeImplementation::ReadConditionGroup Method
ActionNodeImplementation Class
Show All
C++
public: virtual void ReadConditionGroup(
    TextParser& textParser
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::ReserveTracks Method

ActionNodeImplementation::ReserveTracks Method
ActionNodeImplementation Class
Show All
C++
public: virtual void ReserveTracks(
    int count
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeImplementation::WriteCondition Method

ActionNodeImplementation::WriteCondition Method
ActionNodeImplementation Class
Show All
C++
public: virtual void WriteCondition(
    int conditionIndex,
    TextBuffer& textBuff
);
Class

ActionNodeImplementation Class

File

ActionNode.h

Links
ActionNodeImplementation Class
Send comments on this topic.


ActionNodeLwRef Class

ActionNodeLwRef Class
Constructors | Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
ActionNodeLwRef
C++
public: class ActionNodeLwRef;
Constructors
Constructor | Description
ActionNodeLwRef |
Destructors
Destructor | Description
~ActionNodeLwRef |
Methods
Method | Description
DeclareStruct |
GetActionNode |
IMPLEMENT_PLACE_INLINE |
IsNull |
SetActionNode |
SetParent |
SetReferenceName |
Namespace

rage Namespace

File

ActionNode.h

Links
Constructors, Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


ActionNodeLwRef::ActionNodeLwRef Constructor ()

ActionNodeLwRef::ActionNodeLwRef Constructor ()
ActionNodeLwRef Class
Show All
C++
public: ActionNodeLwRef();
Class

ActionNodeLwRef Class

File

ActionNode.h

Links
ActionNodeLwRef Class
Send comments on this topic.


ActionNodeLwRef::ActionNodeLwRef Constructor (datResource&)

ActionNodeLwRef::ActionNodeLwRef Constructor (datResource&)
ActionNodeLwRef Class
Show All
C++
public: ActionNodeLwRef(
    datResource& rsc
);
Class

ActionNodeLwRef Class

File

ActionNode.h

Links
ActionNodeLwRef Class
Send comments on this topic.


ActionNodeLwRef::~ActionNodeLwRef Destructor

ActionNodeLwRef::~ActionNodeLwRef Destructor
ActionNodeLwRef Class
Show All
C++
public: ~ActionNodeLwRef();
Class

ActionNodeLwRef Class

File

ActionNode.h

Links
ActionNodeLwRef Class
Send comments on this topic.


ActionNodeLwRef::DeclareStruct Method

ActionNodeLwRef::DeclareStruct Method
ActionNodeLwRef Class
Show All
C++
public: void DeclareStruct(
    datTypeStruct& s
);
Class

ActionNodeLwRef Class

File

ActionNode.h

Links
ActionNodeLwRef Class
Send comments on this topic.


ActionNodeLwRef::GetActionNode Method

ActionNodeLwRef::GetActionNode Method
ActionNodeLwRef Class
Show All
C++
public: ActionNode* GetActionNode() const;
Class

ActionNodeLwRef Class

File

ActionNode.h

Links
ActionNodeLwRef Class
Send comments on this topic.


ActionNodeLwRef::IMPLEMENT_PLACE_INLINE Method

ActionNodeLwRef::IMPLEMENT_PLACE_INLINE Method
ActionNodeLwRef Class
Show All
C++
public: IMPLEMENT_PLACE_INLINE(
    ActionNodeLwRef
);
Class

ActionNodeLwRef Class

File

ActionNode.h

Links
ActionNodeLwRef Class
Send comments on this topic.


ActionNodeLwRef::IsNull Method

ActionNodeLwRef::IsNull Method
ActionNodeLwRef Class
Show All
C++
public: bool IsNull() const;
Class

ActionNodeLwRef Class

File

ActionNode.h

Links
ActionNodeLwRef Class
Send comments on this topic.


ActionNodeLwRef::SetActionNode Method

ActionNodeLwRef::SetActionNode Method
ActionNodeLwRef Class
Show All
C++
public: void SetActionNode(
    ActionNode* node
);
Class

ActionNodeLwRef Class

File

ActionNode.h

Links
ActionNodeLwRef Class
Send comments on this topic.


ActionNodeLwRef::SetParent Method

ActionNodeLwRef::SetParent Method
ActionNodeLwRef Class
Show All
C++
public: void SetParent(
    ActionNode* parent
);
Class

ActionNodeLwRef Class

File

ActionNode.h

Links
ActionNodeLwRef Class
Send comments on this topic.


ActionNodeLwRef::SetReferenceName Method

ActionNodeLwRef::SetReferenceName Method
ActionNodeLwRef Class
Show All
C++
public: void SetReferenceName(
    const char* path
);
Class

ActionNodeLwRef Class

File

ActionNode.h

Links
ActionNodeLwRef Class
Send comments on this topic.


ActionNodePlayable Class

ActionNodePlayable Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Friends | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::IArchive
        rage::ActionNode
            rage::ActionNodeImplementation
                ActionNodePlayable
C++
public: class ActionNodePlayable : public ActionNodeImplementation;
Structs
Struct | Description
ActionTreeTaskParams |
Constructors
Constructor | Description
ActionNode |
ActionNodeImplementation |
ActionNodePlayable |
IArchive |
Destructors
Destructor | Description
~ActionNode |
~ActionNodeImplementation |
~ActionNodePlayable |
~IArchive |
~IName |
Methods
Method | Description
AddBranch | Add Resources
AddChildActionNode |
AddChildActionNodes |
AddCondition |
AddCondition |
AddRoot |
AddStuff |
AddStuff |
AddTrack |
AddTrack |
AddTrack |
AddTracksBank |
BalanceWeights |
ChangeChildPriority |
ChangeConditionPriority |
ChangeConditionPriority |
ChangePriority |
ChangeTrackPriority |
ChangeTrackPriority |
ClearChildNodes | never call clear in the real game, only in resource compiler outside of Begin/EndBuild
ClearRoots |
Create |
CreateIArchive |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE | This is only for editing reasons. This is a level that aids in production flow. By assigning certain editing tasks with a "Priority" you can hand off work to different people and track changes made at lesser priority levels We'll use an increasing number for higher priority: E.G. Default:0 Visual Effects:1 Sound:2
DECLARE_PLACE |
DeclareStruct |
DeInit |
DeleteChildActionNodes | Remove Resources
DeleteCondition |
DeleteCondition |
DeleteTrack |
DeleteTrack |
DumpTiming |
DumpTimingRecursive |
EvalRemote | : evalutes the remtoe conditions for this node. Return false if any condition objects.
EvalRemoteTransition | : evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.
Find |
FindChildNode |
FindFirstPlayable |
FindRoot | Find methods... should rework this
GetChild |
GetChildCount | Traversal
GetCNamePath | Get Resource for views
GetCondition |
GetCondition |
GetConditionCount |
GetConditionCount | Get Resource for views
GetConditionGroup |
GetConditionGroup |
GetCondtionFormat |
GetCondtionFormat |
GetEditPriority |
GetFileRoot |
GetName |
GetName |
GetName |
GetNameFullPath |
GetNameFullPathDebug |
GetParent |
GetPathCRC | MP functionality
GetPriority | Sibling Position Child Priority
GetRefCount |
GetRoot |
GetTrack |
GetTrack |
GetTrackCount |
GetTrackCount |
GetTrackFormat |
GetTrackFormat |
GetType |
IncRefCount |
Init |
IsDescendantOf |
Load |
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
OnTreeUnload |
OperateAllNodes |
OperateChildOnNodes | Helper for recursive visit function
PrintAllNodes |
ReadConditionGroup |
ReadConditionGroup |
RecursSetFileRoots |
RemoveChildActionNode |
ReserveTracks |
ReserveTracks |
ResetTiming |
ResetTimingRecursive |
ResolveAllTrackReferences |
ResolveAllWeights |
ResolveTrackReferences |
ResolveWeights |
SetEditPriority |
SetOnLoad |
SetOnUnload |
SetParent |
TaskLoadActionNode |
TokenName | Write to buffer
TokenName | Write to buffer
TRACK_PARAMETER_STRING |
UnLoad |
UnLoadAll |
Update | Observer Interface for EditPriority
UpdateDetach |
Write |
Write |
Write |
writeBegin |
writeChildren |
writeComment |
WriteCondition |
WriteCondition |
writeConditions |
writeEnd |
writeTracks |
Data Members
Data Member | Description
m_bUpdatedOnce |
m_bViewExpanded |
m_childNodes |
m_Conditions |
m_FileRoot | Points to root node of file for ref counting fun
m_GlobalEditPriority |
m_Name |
m_OnLoad |
m_OnUnload |
m_Pad |
m_parent |
m_PathCRC | used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed
m_Root |
m_tracks |
m_Type |
RORC_VERSION | Don't forget to bump this whenever this structure changes
sm_ActFullPath |
sm_ActPath |
sm_OnTreeUnloadCallback |
sm_PostLoadCallback |
sm_RscFirstPass | set to false the second time through
Friends
Friend | Description
class ActionNodeReference | need to be able to access private data
class ActionNodeTree |
Namespace

rage Namespace

File

ActionNode.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Friends, rage Namespace, Inheritance Hierarchy


ActionNodePlayable::ActionNodePlayable Constructor (const char*, int)

ActionNodePlayable::ActionNodePlayable Constructor (const char*, int)
ActionNodePlayable Class
Show All
C++
public: ActionNodePlayable(
    const char* name,
    int type = TYPE_AN_PLAYABLE
);
Class

ActionNodePlayable Class

File

ActionNode.h

Links
ActionNodePlayable Class
Send comments on this topic.


ActionNodePlayable::ActionNodePlayable Constructor (datResource&)

ActionNodePlayable::ActionNodePlayable Constructor (datResource&)
ActionNodePlayable Class
Show All
C++
public: ActionNodePlayable(
    datResource& r
);
Class

ActionNodePlayable Class

File

ActionNode.h

Links
ActionNodePlayable Class
Send comments on this topic.


ActionNodePlayable::ActionNodePlayable Constructor (int)

ActionNodePlayable::ActionNodePlayable Constructor (int)
ActionNodePlayable Class
Show All
C++
public: ActionNodePlayable(
    int type = TYPE_AN_PLAYABLE
);
Class

ActionNodePlayable Class

File

ActionNode.h

Links
ActionNodePlayable Class
Send comments on this topic.


ActionNodePlayable::~ActionNodePlayable Destructor

ActionNodePlayable::~ActionNodePlayable Destructor
ActionNodePlayable Class
Show All
C++
public: virtual ~ActionNodePlayable();
Class

ActionNodePlayable Class

File

ActionNode.h

Links
ActionNodePlayable Class
Send comments on this topic.


ActionNodePlayable::AddStuff Method

ActionNodePlayable::AddStuff Method
ActionNodePlayable Class
Show All
C++
public: virtual void AddStuff(
    TextParser& textParser
);
Class

ActionNodePlayable Class

File

ActionNode.h

Links
ActionNodePlayable Class
Send comments on this topic.


ActionNodePlayable::AddTrack Method

ActionNodePlayable::AddTrack Method
ActionNodePlayable Class
Show All
C++
public: virtual Track* AddTrack(
    Track* track
);
Class

ActionNodePlayable Class

File

ActionNode.h

Links
ActionNodePlayable Class
Send comments on this topic.


ActionNodePlayable::DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE Method

ActionNodePlayable::DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE Method
ActionNodePlayable Class
Show All

This is only for editing reasons. This is a level that aids in production flow. By assigning certain editing tasks with a "Priority" you can hand off work to different people and track changes made at lesser priority levels We'll use an increasing number for higher priority: E.G. Default:0 Visual Effects:1 Sound:2

C++
public: DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE(
    ActionNodePlayable
);
Class

ActionNodePlayable Class

File

ActionNode.h

Links
ActionNodePlayable Class
Send comments on this topic.


ActionNodePlayable::DECLARE_PLACE Method

ActionNodePlayable::DECLARE_PLACE Method
ActionNodePlayable Class
Show All
C++
public: DECLARE_PLACE(
    ActionNodePlayable
);
Class

ActionNodePlayable Class

File

ActionNode.h

Links
ActionNodePlayable Class
Send comments on this topic.


ActionNodePlayable::DeclareStruct Method

ActionNodePlayable::DeclareStruct Method
ActionNodePlayable Class
Show All
C++
public: void DeclareStruct(
    datTypeStruct & s
);
Class

ActionNodePlayable Class

File

ActionNode.h

Links
ActionNodePlayable Class
Send comments on this topic.


ActionNodePlayable::GetEditPriority Method

ActionNodePlayable::GetEditPriority Method
ActionNodePlayable Class
Show All
C++
public: GetEditPriority(
    void
);
Class

ActionNodePlayable Class

File

ActionNode.h

Links
ActionNodePlayable Class
Send comments on this topic.


ActionNodePlayable::Match Method

ActionNodePlayable::Match Method
ActionNodePlayable Class
Show All

Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found

C++
public: virtual ActionNodePlayable* Match(
    ActionContext* context = 0
);
Class

ActionNodePlayable Class

File

ActionNode.h

Links
ActionNodePlayable Class
Send comments on this topic.


ActionNodePlayable::SetEditPriority Method

ActionNodePlayable::SetEditPriority Method
ActionNodePlayable Class
Show All
C++
public: void SetEditPriority(
    int priority
);
Class

ActionNodePlayable Class

File

ActionNode.h

Links
ActionNodePlayable Class
Send comments on this topic.


ActionNodePlayable::TokenName Method

ActionNodePlayable::TokenName Method
ActionNodePlayable Class
Show All

Write to buffer

C++
public: virtual const char* TokenName();
Class

ActionNodePlayable Class

File

ActionNode.h

Links
ActionNodePlayable Class
Send comments on this topic.


ActionNodePlayable::Update Method

ActionNodePlayable::Update Method
ActionNodePlayable Class
Show All

Observer Interface for EditPriority

C++
public: virtual void Update(
    CSubject* theChangedSubject
);
Class

ActionNodePlayable Class

File

ActionNode.h

Links
ActionNodePlayable Class
Send comments on this topic.


ActionNodePlayable::UpdateDetach Method

ActionNodePlayable::UpdateDetach Method
ActionNodePlayable Class
Show All
C++
public: virtual void UpdateDetach(
    CSubject* theChangedSubject
);
Class

ActionNodePlayable Class

File

ActionNode.h

Links
ActionNodePlayable Class
Send comments on this topic.


ActionNodePlayable::Write Method (TextBuffer&)

ActionNodePlayable::Write Method (TextBuffer&)
ActionNodePlayable Class
Show All
C++
public: virtual void Write(
    TextBuffer& textBuffer
);
Class

ActionNodePlayable Class

File

ActionNode.h

Links
ActionNodePlayable Class
Send comments on this topic.


ActionNodePlayable::Write Method (TextBuffer&, const char*)

ActionNodePlayable::Write Method (TextBuffer&, const char*)
ActionNodePlayable Class
Show All
C++
public: void Write(
    TextBuffer& textBuffer,
    const char* headerName
);
Class

ActionNodePlayable Class

File

ActionNode.h

Links
ActionNodePlayable Class
Send comments on this topic.


ActionNodeReference Class

ActionNodeReference Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Friends | rage Namespace | Inheritance Hierarchy
Show All

ActionNodeReference

rage::IName
    rage::IArchive
        rage::ActionNode
            ActionNodeReference
                rage::ActionNodeFileReference
C++
public: class ActionNodeReference : public ActionNode;
Structs
Struct | Description
ActionTreeTaskParams |
Constructors
Constructor | Description
ActionNode |
ActionNodeReference |
IArchive |
Destructors
Destructor | Description
~ActionNode |
~ActionNodeReference |
~IArchive |
~IName |
Methods
Method | Description
AddBranch | Add Resources
AddChildActionNode |
AddChildActionNodes |
AddCondition |
AddCondition |
AddRoot |
AddStuff |
AddTrack |
AddTrack |
AddTracksBank |
BalanceWeights |
ChangeChildPriority |
ChangeConditionPriority |
ChangePriority |
ChangeTrackPriority |
ClearChildNodes | never call clear in the real game, only in resource compiler outside of Begin/EndBuild
ClearRoots |
Create |
CreateIArchive |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DeInit |
DeleteChildActionNodes | Remove Resources
DeleteCondition |
DeleteCondition |
DeleteTrack |
DumpTiming |
DumpTimingRecursive |
EvalRemote | : evalutes the remtoe conditions for this node. Return false if any condition objects.
EvalRemoteTransition | : evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.
Find |
FindChildNode |
FindFirstPlayable |
FindRoot | Find methods... should rework this
GetActionNode |
GetChild |
GetChild |
GetChildCount | Traversal
GetChildCount | Traversal
GetCNamePath | Get Resource for views
GetCondition |
GetCondition |
GetConditionCount |
GetConditionCount | Get Resource for views
GetConditionGroup |
GetConditionGroup |
GetCondtionFormat |
GetCondtionFormat |
GetFileRoot |
GetName |
GetName |
GetName |
GetNameFullPath |
GetNameFullPathDebug |
GetParent |
GetPathCRC | MP functionality
GetPriority | Sibling Position Child Priority
GetRefCount |
GetReferenceFullPath |
GetReferenceName |
GetRoot |
GetTrack |
GetTrack |
GetTrackCount |
GetTrackCount |
GetTrackFormat |
GetTrackFormat |
GetType |
IncRefCount |
Init |
IsDescendantOf |
IsNull |
Load |
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
OnTreeUnload |
OperateAllNodes |
OperateChildOnNodes | Helper for recursive visit function
PrintAllNodes |
ReadConditionGroup |
ReadConditionGroup |
RecursSetFileRoots |
RemoveChildActionNode |
ReserveTracks |
ReserveTracks |
ResetTiming |
ResetTimingRecursive |
ResolveAllTrackReferences |
ResolveAllWeights |
ResolveReference | Try to find a node to connect to...
ResolveTrackReferences |
ResolveWeights |
SetActionNode |
SetOnLoad |
SetOnUnload |
SetParent |
SetReferenceName |
TaskLoadActionNode |
TokenName | Write to buffer
TRACK_PARAMETER_STRING |
UnLoad |
UnLoadAll |
Write |
Write |
writeBegin |
writeChildren |
writeComment |
WriteCondition |
WriteCondition |
writeConditions |
writeEnd |
writeTracks |
Data Members
Data Member | Description
m_bUpdatedOnce |
m_bViewExpanded |
m_childNodes |
m_FileRoot | Points to root node of file for ref counting fun
m_GlobalEditPriority |
m_nameFullPath |
m_OnLoad |
m_OnUnload |
m_Pad |
m_parent |
m_PathCRC | used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed
m_referenceName |
m_referenceNode |
m_Root |
m_Type |
RORC_VERSION | Don't forget to bump this whenever this structure changes
sm_ActFullPath |
sm_ActPath |
sm_OnTreeUnloadCallback |
sm_PostLoadCallback |
sm_RscFirstPass | set to false the second time through
Friends
Friend | Description
class ActionNodeReference | need to be able to access private data
class ActionNodeTree |
Namespace

rage Namespace

File

ActionNode.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Friends, rage Namespace, Inheritance Hierarchy


ActionNodeReference::m_nameFullPath Data Member

ActionNodeReference::m_nameFullPath Data Member
ActionNodeReference Class
Show All
C++
protected: CBasicString m_nameFullPath;
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::m_referenceName Data Member

ActionNodeReference::m_referenceName Data Member
ActionNodeReference Class
Show All
C++
protected: CNamePath m_referenceName;
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::m_referenceNode Data Member

ActionNodeReference::m_referenceNode Data Member
ActionNodeReference Class
Show All
C++
protected: rage::datRef<ActionNode> m_referenceNode;
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::ActionNodeReference Constructor (const char*, int)

ActionNodeReference::ActionNodeReference Constructor (const char*, int)
ActionNodeReference Class
Show All
C++
public: ActionNodeReference(
    const char* name,
    int type = TYPE_AN
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::ActionNodeReference Constructor (int)

ActionNodeReference::ActionNodeReference Constructor (int)
ActionNodeReference Class
Show All
C++
public: ActionNodeReference(
    int type = TYPE_AN
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::~ActionNodeReference Destructor

ActionNodeReference::~ActionNodeReference Destructor
ActionNodeReference Class
Show All
C++
public: virtual ~ActionNodeReference();
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::AddCondition Method (TextParser&)

ActionNodeReference::AddCondition Method (TextParser&)
ActionNodeReference Class
Show All
C++
public: Condition* AddCondition(
    TextParser& textParser
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::AddCondition Method (const char*)

ActionNodeReference::AddCondition Method (const char*)
ActionNodeReference Class
Show All
C++
public: virtual Condition* AddCondition(
    const char* conditionFormat
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::AddTrack Method (TextParser&)

ActionNodeReference::AddTrack Method (TextParser&)
ActionNodeReference Class
Show All
C++
public: virtual Track* AddTrack(
    TextParser& textParser
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::AddTrack Method (Track*)

ActionNodeReference::AddTrack Method (Track*)
ActionNodeReference Class
Show All

return ActionNode::AddTrack(track);

C++
public: virtual Track* AddTrack(
    Track* track
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::AddTrack Method (const char*)

ActionNodeReference::AddTrack Method (const char*)
ActionNodeReference Class
Show All
C++
public: virtual Track* AddTrack(
    const char* trackFormat
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::DATAMEMEBERS_INTERFACE_NO_NAME Method

ActionNodeReference::DATAMEMEBERS_INTERFACE_NO_NAME Method
ActionNodeReference Class
Show All
C++
public: DATAMEMEBERS_INTERFACE_NO_NAME(
    ActionNodeReference
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::DeleteCondition Method (Condition*)

ActionNodeReference::DeleteCondition Method (Condition*)
ActionNodeReference Class
Show All
C++
public: virtual bool DeleteCondition(
    Condition*
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::DeleteCondition Method (int)

ActionNodeReference::DeleteCondition Method (int)
ActionNodeReference Class
Show All

Delete resources... this is only while in edit mode... Like in the tool

C++
public: virtual void DeleteCondition(
    int index
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::GetActionNode Method

ActionNodeReference::GetActionNode Method
ActionNodeReference Class
Show All
C++
public: ActionNode* GetActionNode(
    void
) const;
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::GetChild Method

ActionNodeReference::GetChild Method
ActionNodeReference Class
Show All
C++
public: virtual ActionNode* GetChild(
    int childIndex
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::GetChildCount Method

ActionNodeReference::GetChildCount Method
ActionNodeReference Class
Show All

Traversal

C++
public: virtual int GetChildCount(
    void
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::GetCondition Method

ActionNodeReference::GetCondition Method
ActionNodeReference Class
Show All
C++
public: virtual Condition* GetCondition(
    int conditionIndex
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::GetConditionCount Method

ActionNodeReference::GetConditionCount Method
ActionNodeReference Class
Show All

Get Resource for views

C++
public: virtual int GetConditionCount(
    void
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::GetConditionGroup Method

ActionNodeReference::GetConditionGroup Method
ActionNodeReference Class
Show All
C++
protected: virtual ConditionGroup* GetConditionGroup(
    void
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::GetCondtionFormat Method

ActionNodeReference::GetCondtionFormat Method
ActionNodeReference Class
Show All
C++
public: virtual const char* GetCondtionFormat(
    int conditionIndex
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::GetName Method (void)

ActionNodeReference::GetName Method (void)
ActionNodeReference Class
Show All
C++
public: virtual CName* GetName(
    void
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::GetName Method (void)

ActionNodeReference::GetName Method (void)
ActionNodeReference Class
Show All
C++
public: virtual const CName* GetName(
    void
) const;
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::GetReferenceFullPath Method

ActionNodeReference::GetReferenceFullPath Method
ActionNodeReference Class
Show All
C++
public: const char* GetReferenceFullPath(
    void
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::GetReferenceName Method

ActionNodeReference::GetReferenceName Method
ActionNodeReference Class
Show All
C++
public: const char* GetReferenceName(
    void
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::GetTrack Method

ActionNodeReference::GetTrack Method
ActionNodeReference Class
Show All
C++
public: virtual Track* GetTrack(
    int trackIndex
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::GetTrackCount Method

ActionNodeReference::GetTrackCount Method
ActionNodeReference Class
Show All
C++
public: virtual int GetTrackCount(
    void
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::GetTrackFormat Method

ActionNodeReference::GetTrackFormat Method
ActionNodeReference Class
Show All
C++
public: virtual const char* GetTrackFormat(
    int trackIndex
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::IsNull Method

ActionNodeReference::IsNull Method
ActionNodeReference Class
Show All
C++
public: bool IsNull() const;
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::Match Method

ActionNodeReference::Match Method
ActionNodeReference Class
Show All

Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found

C++
public: virtual ActionNodePlayable* Match(
    ActionContext* context = 0
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::ReadConditionGroup Method

ActionNodeReference::ReadConditionGroup Method
ActionNodeReference Class
Show All
C++
public: virtual void ReadConditionGroup(
    TextParser&
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::ReserveTracks Method

ActionNodeReference::ReserveTracks Method
ActionNodeReference Class
Show All
C++
public: virtual void ReserveTracks(
    int count
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::ResolveReference Method

ActionNodeReference::ResolveReference Method
ActionNodeReference Class
Show All

Try to find a node to connect to...

C++
public: void ResolveReference(
    eActionNodeResolveMode mode = NODES_ADDED
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::SetActionNode Method

ActionNodeReference::SetActionNode Method
ActionNodeReference Class
Show All
C++
public: void SetActionNode(
    ActionNode* node
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::SetReferenceName Method

ActionNodeReference::SetReferenceName Method
ActionNodeReference Class
Show All
C++
public: void SetReferenceName(
    const char* name
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeReference::WriteCondition Method

ActionNodeReference::WriteCondition Method
ActionNodeReference Class
Show All
C++
public: virtual void WriteCondition(
    int,
    TextBuffer&
);
Class

ActionNodeReference Class

File

ActionNode.h

Links
ActionNodeReference Class
Send comments on this topic.


ActionNodeTree Class

ActionNodeTree Class
Constructors | Destructors | Members | Methods | Friends | rage Namespace | Inheritance Hierarchy
Show All
pgBase
    ActionNodeTree
C++
public: class ActionNodeTree : public pgBase;
Constructors
Constructor | Description
ActionNodeTree |
Destructors
Destructor | Description
~ActionNodeTree |
Methods
Method | Description
DECLARE_PLACE |
DECLARE_THREADED_PLACE |
DeclareStruct |
GetRoot |
GetRorcVersion |
ResolveReferences |
SetRoot |
Friends
Friend | Description
class ActionNodeTreeHandle |
class pgStreamable<ActionNodeTree> |
Namespace

rage Namespace

File

ActionNode.h

Links
Constructors, Destructors, Members, Methods, Friends, rage Namespace, Inheritance Hierarchy


ActionNodeTree::ActionNodeTree Constructor (ActionNode*)

ActionNodeTree::ActionNodeTree Constructor (ActionNode*)
ActionNodeTree Class
Show All
C++
public: ActionNodeTree(
    ActionNode* pRoot = 0
);
Class

ActionNodeTree Class

File

ActionNode.h

Links
ActionNodeTree Class
Send comments on this topic.


ActionNodeTree::ActionNodeTree Constructor (datResource&)

ActionNodeTree::ActionNodeTree Constructor (datResource&)
ActionNodeTree Class
Show All
C++
public: ActionNodeTree(
    datResource& rsc
);
Class

ActionNodeTree Class

File

ActionNode.h

Links
ActionNodeTree Class
Send comments on this topic.


ActionNodeTree::~ActionNodeTree Destructor

ActionNodeTree::~ActionNodeTree Destructor
ActionNodeTree Class
Show All
C++
public: ~ActionNodeTree();
Class

ActionNodeTree Class

File

ActionNode.h

Links
ActionNodeTree Class
Send comments on this topic.


ActionNodeTree::DECLARE_PLACE Method

ActionNodeTree::DECLARE_PLACE Method
ActionNodeTree Class
Show All
C++
public: DECLARE_PLACE(
    ActionNodeTree
);
Class

ActionNodeTree Class

File

ActionNode.h

Links
ActionNodeTree Class
Send comments on this topic.


ActionNodeTree::DECLARE_THREADED_PLACE Method

ActionNodeTree::DECLARE_THREADED_PLACE Method
ActionNodeTree Class
Show All
C++
public: DECLARE_THREADED_PLACE();
Class

ActionNodeTree Class

File

ActionNode.h

Links
ActionNodeTree Class
Send comments on this topic.


ActionNodeTree::DeclareStruct Method

ActionNodeTree::DeclareStruct Method
ActionNodeTree Class
Show All
C++
public: void DeclareStruct(
    datTypeStruct& s
);
Class

ActionNodeTree Class

File

ActionNode.h

Links
ActionNodeTree Class
Send comments on this topic.


ActionNodeTree::GetRoot Method

ActionNodeTree::GetRoot Method
ActionNodeTree Class
Show All
C++
public: ActionNode* GetRoot() const;
Class

ActionNodeTree Class

File

ActionNode.h

Links
ActionNodeTree Class
Send comments on this topic.


ActionNodeTree::GetRorcVersion Method

ActionNodeTree::GetRorcVersion Method
ActionNodeTree Class
Show All
C++
public: static int GetRorcVersion();
Class

ActionNodeTree Class

File

ActionNode.h

Links
ActionNodeTree Class
Send comments on this topic.


ActionNodeTree::ResolveReferences Method

ActionNodeTree::ResolveReferences Method
ActionNodeTree Class
Show All
C++
public: void ResolveReferences(
    eActionNodeResolveMode mode
);
Class

ActionNodeTree Class

File

ActionNode.h

Links
ActionNodeTree Class
Send comments on this topic.


ActionNodeTree::SetRoot Method

ActionNodeTree::SetRoot Method
ActionNodeTree Class
Show All
C++
public: void SetRoot(
    ActionNode* pRoot
);
Class

ActionNodeTree Class

File

ActionNode.h

Links
ActionNodeTree Class
Send comments on this topic.


friend class ActionNodeTreeHandle Friend

friend class ActionNodeTreeHandle Friend
ActionNodeTree Class
Show All
C++
public: friend class ActionNodeTreeHandle;
Class

ActionNodeTree Class

File

ActionNode.h

Links
ActionNodeTree Class
Send comments on this topic.


friend class pgStreamable<ActionNodeTree> Friend

friend class pgStreamable<ActionNodeTree> Friend
ActionNodeTree Class
Show All
C++
public: friend class pgStreamable<ActionNodeTree>;
Class

ActionNodeTree Class

File

ActionNode.h

Links
ActionNodeTree Class
Send comments on this topic.


ActionNodeTreeHandle Class

ActionNodeTreeHandle Class
Nested Types | Members | Methods | Data Members | Friends | rage Namespace | Inheritance Hierarchy
Show All
pgStreamableRef
    ActionNodeTreeHandle
C++
public: class ActionNodeTreeHandle : public pgStreamableRef<ActionNodeTree>;
Nested Types
Nested Type | Description
SetMap |
Methods
Method | Description
AddRef |
Cleanup |
DecRefCount |
ForceLoad |
Get |
GetName |
GetObject |
GetRefCount |
GetRoot |
GetStreamable | This is for debugging only.
IncRefCount |
IsDeleted |
IsResident |
IsStreamingOrResident |
IsValid |
Kill | Delete this object (including the handle itself), regardless what the reference count says.
PagedIn |
SetStreamingPriority |
Data Members
Data Member | Description
sm_LoadFromResources |
Friends
Friend | Description
class ActionNode |
class ActionNodeTree | Should not be necessary except because of this stupid GetActionNodeTree hack.
class atPtr<ActionNodeTreeHandle> |
Namespace

rage Namespace

File

ActionNode.h

Links
Nested Types, Members, Methods, Data Members, Friends, rage Namespace, Inheritance Hierarchy


ActionNodeTreeHandle::sm_LoadFromResources Data Member

ActionNodeTreeHandle::sm_LoadFromResources Data Member
ActionNodeTreeHandle Class
Show All
C++
public: static bool sm_LoadFromResources;
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::AddRef Method

ActionNodeTreeHandle::AddRef Method
ActionNodeTreeHandle Class
Show All
C++
public: void AddRef();
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::Cleanup Method

ActionNodeTreeHandle::Cleanup Method
ActionNodeTreeHandle Class
Show All
C++
public: static void Cleanup();
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::DecRefCount Method

ActionNodeTreeHandle::DecRefCount Method
ActionNodeTreeHandle Class
Show All
C++
public: void DecRefCount();
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::ForceLoad Method

ActionNodeTreeHandle::ForceLoad Method
ActionNodeTreeHandle Class
Show All
C++
public: void ForceLoad();
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::Get Method

ActionNodeTreeHandle::Get Method
ActionNodeTreeHandle Class
Show All
C++
public: static ActionNodeTreeHandle* Get(
    const char * filename,
    const char * pathname,
    int bucket,
    bool loadIfNotResident
);
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::GetName Method

ActionNodeTreeHandle::GetName Method
ActionNodeTreeHandle Class
Show All
C++
public: const char * GetName() const;
Returns

The name of this animation set.

Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::GetObject Method

ActionNodeTreeHandle::GetObject Method
ActionNodeTreeHandle Class
Show All
C++
public: ActionNodeTree * GetObject() const;
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::GetRefCount Method

ActionNodeTreeHandle::GetRefCount Method
ActionNodeTreeHandle Class
Show All
C++
public: int GetRefCount() const;
Returns

The reference count to this object.

Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::GetRoot Method

ActionNodeTreeHandle::GetRoot Method
ActionNodeTreeHandle Class
Show All
C++
public: ActionNode * GetRoot() const;
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::GetStreamable Method

ActionNodeTreeHandle::GetStreamable Method
ActionNodeTreeHandle Class
Show All

This is for debugging only.

C++
public: pgStreamable<ActionNodeTree> & GetStreamable();
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::IncRefCount Method

ActionNodeTreeHandle::IncRefCount Method
ActionNodeTreeHandle Class
Show All
C++
public: void IncRefCount();
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::IsDeleted Method

ActionNodeTreeHandle::IsDeleted Method
ActionNodeTreeHandle Class
Show All
C++
public: bool IsDeleted() const;
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::IsResident Method

ActionNodeTreeHandle::IsResident Method
ActionNodeTreeHandle Class
Show All
C++
public: bool IsResident() const;
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::IsStreamingOrResident Method

ActionNodeTreeHandle::IsStreamingOrResident Method
ActionNodeTreeHandle Class
Show All
C++
public: static bool IsStreamingOrResident(
    const char * filename
);
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::IsValid Method

ActionNodeTreeHandle::IsValid Method
ActionNodeTreeHandle Class
Show All
C++
public: bool IsValid() const;
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::Kill Method

ActionNodeTreeHandle::Kill Method
ActionNodeTreeHandle Class
Show All

Delete this object (including the handle itself), regardless what the reference count says.

C++
public: void Kill();
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::PagedIn Method

ActionNodeTreeHandle::PagedIn Method
ActionNodeTreeHandle Class
Show All
C++
public: virtual void PagedIn();
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::SetStreamingPriority Method

ActionNodeTreeHandle::SetStreamingPriority Method
ActionNodeTreeHandle Class
Show All
C++
public: static void SetStreamingPriority(
    float priority
);
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


friend class ActionNode Friend

friend class ActionNode Friend
ActionNodeTreeHandle Class
Show All
C++
public: friend class ActionNode;
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


friend class ActionNodeTree Friend

friend class ActionNodeTree Friend
ActionNodeTreeHandle Class
Show All

Should not be necessary except because of this stupid GetActionNodeTree hack.

C++
public: friend class ActionNodeTree;
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


friend class atPtr<ActionNodeTreeHandle> Friend

friend class atPtr<ActionNodeTreeHandle> Friend
ActionNodeTreeHandle Class
Show All
C++
public: friend class atPtr<ActionNodeTreeHandle>;
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeTreeHandle::SetMap Nested Type

ActionNodeTreeHandle::SetMap Nested Type
ActionNodeTreeHandle Class
Show All
C++
public: typedef atSimplePooledMapType<u32, ActionNodeTreeHandle*, 4> SetMap;
Class

ActionNodeTreeHandle Class

File

ActionNode.h

Links
ActionNodeTreeHandle Class
Send comments on this topic.


ActionNodeUnresolvedRef Class

ActionNodeUnresolvedRef Class
Constructors | Members | Methods | Friends | rage Namespace | Inheritance Hierarchy
Show All
ActionNodeUnresolvedRef
C++
public: class ActionNodeUnresolvedRef;
Constructors
Constructor | Description
ActionNodeUnresolvedRef |
Methods
Method | Description
DECLARE_PLACE |
DeclareStruct |
Friends
Friend | Description
class ActionNodeLwRef |
class ActionNodeTree |
Namespace

rage Namespace

File

ActionNode.h

Links
Constructors, Members, Methods, Friends, rage Namespace, Inheritance Hierarchy


ActionNodeUnresolvedRef::ActionNodeUnresolvedRef Constructor ()

ActionNodeUnresolvedRef::ActionNodeUnresolvedRef Constructor ()
ActionNodeUnresolvedRef Class
Show All
C++
public: ActionNodeUnresolvedRef();
Class

ActionNodeUnresolvedRef Class

File

ActionNode.h

Links
ActionNodeUnresolvedRef Class
Send comments on this topic.


ActionNodeUnresolvedRef::ActionNodeUnresolvedRef Constructor (datResource&)

ActionNodeUnresolvedRef::ActionNodeUnresolvedRef Constructor (datResource&)
ActionNodeUnresolvedRef Class
Show All
C++
public: ActionNodeUnresolvedRef(
    datResource& rsc
);
Class

ActionNodeUnresolvedRef Class

File

ActionNode.h

Links
ActionNodeUnresolvedRef Class
Send comments on this topic.


ActionNodeUnresolvedRef::DECLARE_PLACE Method

ActionNodeUnresolvedRef::DECLARE_PLACE Method
ActionNodeUnresolvedRef Class
Show All
C++
public: DECLARE_PLACE(
    ActionNodeUnresolvedRef
);
Class

ActionNodeUnresolvedRef Class

File

ActionNode.h

Links
ActionNodeUnresolvedRef Class
Send comments on this topic.


ActionNodeUnresolvedRef::DeclareStruct Method

ActionNodeUnresolvedRef::DeclareStruct Method
ActionNodeUnresolvedRef Class
Show All
C++
public: void DeclareStruct(
    datTypeStruct& s
);
Class

ActionNodeUnresolvedRef Class

File

ActionNode.h

Links
ActionNodeUnresolvedRef Class
Send comments on this topic.


friend class ActionNodeLwRef Friend

friend class ActionNodeLwRef Friend
ActionNodeUnresolvedRef Class
Show All
C++
public: friend class ActionNodeLwRef;
Class

ActionNodeUnresolvedRef Class

File

ActionNode.h

Links
ActionNodeUnresolvedRef Class
Send comments on this topic.


friend class ActionNodeTree Friend

friend class ActionNodeTree Friend
ActionNodeUnresolvedRef Class
Show All
C++
public: friend class ActionNodeTree;
Class

ActionNodeUnresolvedRef Class

File

ActionNode.h

Links
ActionNodeUnresolvedRef Class
Send comments on this topic.


ActionTreeLog Class

ActionTreeLog Class
Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All

Simple Log class that notifies Observers when there is a new message

rage::CSubject
    ActionTreeLog
C++
public: class ActionTreeLog : public CSubject;
Constructors
Constructor | Description
CSubject |
Destructors
Destructor | Description
~CSubject |
Methods
Method | Description
Attach |
Dettach |
GetInstance |
GetMessage |
Log |
Notify |
Warn |
Data Members
Data Member | Description
m_Observers |
Namespace

rage Namespace

File

SubjectObserver.h

Links
Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


ActionTreeLog::GetInstance Method

ActionTreeLog::GetInstance Method
ActionTreeLog Class
Show All
C++
public: static ActionTreeLog* GetInstance();
Class

ActionTreeLog Class

File

SubjectObserver.h

Links
ActionTreeLog Class
Send comments on this topic.


ActionTreeLog::GetMessage Method

ActionTreeLog::GetMessage Method
ActionTreeLog Class
Show All
C++
public: const char* GetMessage(
    void
);
Class

ActionTreeLog Class

File

SubjectObserver.h

Links
ActionTreeLog Class
Send comments on this topic.


ActionTreeLog::Log Method

ActionTreeLog::Log Method
ActionTreeLog Class
Show All
C++
public: void Log(
    const char* message
);
Class

ActionTreeLog Class

File

SubjectObserver.h

Links
ActionTreeLog Class
Send comments on this topic.


ActionTreeLog::Warn Method

ActionTreeLog::Warn Method
ActionTreeLog Class
Show All
C++
public: void Warn(
    const char* message
);
Class

ActionTreeLog Class

File

SubjectObserver.h

Links
ActionTreeLog Class
Send comments on this topic.


actTreeDebugOut Class

actTreeDebugOut Class
Constructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
actTreeDebugOut
C++
public: class actTreeDebugOut;
Constructors
Constructor | Description
actTreeDebugOut |
Methods
Method | Description
GetRef |
Out |
Namespace

rage Namespace

File

ActionController.h

Links
Constructors, Members, Methods, rage Namespace, Inheritance Hierarchy


actTreeDebugOut::actTreeDebugOut Constructor ()

actTreeDebugOut::actTreeDebugOut Constructor ()
actTreeDebugOut Class
Show All
C++
public: actTreeDebugOut();
Class

actTreeDebugOut Class

File

ActionController.h

Links
actTreeDebugOut Class


actTreeDebugOut::actTreeDebugOut Constructor (const int, DebugOutputFunctor)

actTreeDebugOut::actTreeDebugOut Constructor (const int, DebugOutputFunctor)
actTreeDebugOut Class
Show All
C++
public: actTreeDebugOut(
    const int dlevel,
    DebugOutputFunctor func
);
Class

actTreeDebugOut Class

File

ActionController.h

Links
actTreeDebugOut Class


actTreeDebugOut::GetRef Method

actTreeDebugOut::GetRef Method
actTreeDebugOut Class
Show All
C++
public: actTreeDebugOut& GetRef();
Class

actTreeDebugOut Class

File

ActionController.h

Links
actTreeDebugOut Class


actTreeDebugOut::Out Method

actTreeDebugOut::Out Method
actTreeDebugOut Class
Show All
C++
public: void Out(
    const char* fmt,
    ...
) const;
Class

actTreeDebugOut Class

File

ActionController.h

Links
actTreeDebugOut Class


ArchiveFileRecord Class

ArchiveFileRecord Class
Constructors | Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
ArchiveFileRecord
C++
public: class ArchiveFileRecord;
Constructors
Constructor | Description
ArchiveFileRecord |
Destructors
Destructor | Description
~ArchiveFileRecord |
Methods
Method | Description
GetArchiveObject |
GetFileName |
GetFullPathName |
GetPathName |
Init |
IsFileChangedOnDisk |
IsFileWriteAble |
ReadFromFile |
SetArchiveObject |
SetFactoryIArchive | Redirect how the Object gets created
SetFileName |
SetFullPathName |
SetPathName |
WriteToFile |
Namespace

rage Namespace

File

ActionNode.h

Links
Constructors, Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


ArchiveFileRecord::ArchiveFileRecord Constructor ()

ArchiveFileRecord::ArchiveFileRecord Constructor ()
ArchiveFileRecord Class
Show All
C++
public: ArchiveFileRecord();
Class

ArchiveFileRecord Class

File

ActionNode.h

Links
ArchiveFileRecord Class
Send comments on this topic.


ArchiveFileRecord::ArchiveFileRecord Constructor (const char*, const char*)

ArchiveFileRecord::ArchiveFileRecord Constructor (const char*, const char*)
ArchiveFileRecord Class
Show All
C++
public: ArchiveFileRecord(
    const char* fileNameFullPath,
    const char* basePath = NULL
);
Class

ArchiveFileRecord Class

File

ActionNode.h

Links
ArchiveFileRecord Class
Send comments on this topic.


ArchiveFileRecord::ArchiveFileRecord Constructor (rage::datResource&)

ArchiveFileRecord::ArchiveFileRecord Constructor (rage::datResource&)
ArchiveFileRecord Class
Show All
C++
public: ArchiveFileRecord(
    rage::datResource&
);
Class

ArchiveFileRecord Class

File

ActionNode.h

Links
ArchiveFileRecord Class
Send comments on this topic.


ArchiveFileRecord::~ArchiveFileRecord Destructor

ArchiveFileRecord::~ArchiveFileRecord Destructor
ArchiveFileRecord Class
Show All
C++
public: virtual ~ArchiveFileRecord();
Class

ArchiveFileRecord Class

File

ActionNode.h

Links
ArchiveFileRecord Class
Send comments on this topic.


ArchiveFileRecord::GetArchiveObject Method

ArchiveFileRecord::GetArchiveObject Method
ArchiveFileRecord Class
Show All
C++
public: IArchive* GetArchiveObject(
    void
);
Class

ArchiveFileRecord Class

File

ActionNode.h

Links
ArchiveFileRecord Class
Send comments on this topic.


ArchiveFileRecord::GetFileName Method

ArchiveFileRecord::GetFileName Method
ArchiveFileRecord Class
Show All
C++
public: const CBasicString* GetFileName();
Class

ArchiveFileRecord Class

File

ActionNode.h

Links
ArchiveFileRecord Class
Send comments on this topic.


ArchiveFileRecord::GetFullPathName Method

ArchiveFileRecord::GetFullPathName Method
ArchiveFileRecord Class
Show All
C++
public: const CBasicString* GetFullPathName();
Class

ArchiveFileRecord Class

File

ActionNode.h

Links
ArchiveFileRecord Class
Send comments on this topic.


ArchiveFileRecord::GetPathName Method

ArchiveFileRecord::GetPathName Method
ArchiveFileRecord Class
Show All
C++
public: const CBasicString* GetPathName();
Class

ArchiveFileRecord Class

File

ActionNode.h

Links
ArchiveFileRecord Class
Send comments on this topic.


ArchiveFileRecord::Init Method

ArchiveFileRecord::Init Method
ArchiveFileRecord Class
Show All
C++
public: static void Init();
Class

ArchiveFileRecord Class

File

ActionNode.h

Links
ArchiveFileRecord Class
Send comments on this topic.


ArchiveFileRecord::IsFileChangedOnDisk Method

ArchiveFileRecord::IsFileChangedOnDisk Method
ArchiveFileRecord Class
Show All
C++
public: bool IsFileChangedOnDisk(
    void
);
Class

ArchiveFileRecord Class

File

ActionNode.h

Links
ArchiveFileRecord Class
Send comments on this topic.


ArchiveFileRecord::IsFileWriteAble Method

ArchiveFileRecord::IsFileWriteAble Method
ArchiveFileRecord Class
Show All
C++
public: bool IsFileWriteAble(
    void
);
Class

ArchiveFileRecord Class

File

ActionNode.h

Links
ArchiveFileRecord Class
Send comments on this topic.


ArchiveFileRecord::ReadFromFile Method

ArchiveFileRecord::ReadFromFile Method
ArchiveFileRecord Class
Show All
C++
public: virtual void ReadFromFile(
    void
);
Class

ArchiveFileRecord Class

File

ActionNode.h

Links
ArchiveFileRecord Class
Send comments on this topic.


ArchiveFileRecord::SetArchiveObject Method

ArchiveFileRecord::SetArchiveObject Method
ArchiveFileRecord Class
Show All
C++
public: void SetArchiveObject(
    IArchive* object
);
Class

ArchiveFileRecord Class

File

ActionNode.h

Links
ArchiveFileRecord Class
Send comments on this topic.


ArchiveFileRecord::SetFactoryIArchive Method

ArchiveFileRecord::SetFactoryIArchive Method
ArchiveFileRecord Class
Show All

Redirect how the Object gets created

C++
public: void SetFactoryIArchive(
    FactoryIArchive factoryFunc
);
Class

ArchiveFileRecord Class

File

ActionNode.h

Links
ArchiveFileRecord Class
Send comments on this topic.


ArchiveFileRecord::SetFileName Method

ArchiveFileRecord::SetFileName Method
ArchiveFileRecord Class
Show All
C++
public: void SetFileName(
    const char* fileName
);
Class

ArchiveFileRecord Class

File

ActionNode.h

Links
ArchiveFileRecord Class
Send comments on this topic.


ArchiveFileRecord::SetFullPathName Method

ArchiveFileRecord::SetFullPathName Method
ArchiveFileRecord Class
Show All
C++
public: void SetFullPathName(
    const char* fileNameFullPath
);
Class

ArchiveFileRecord Class

File

ActionNode.h

Links
ArchiveFileRecord Class
Send comments on this topic.


ArchiveFileRecord::SetPathName Method

ArchiveFileRecord::SetPathName Method
ArchiveFileRecord Class
Show All
C++
public: void SetPathName(
    const char* path
);
Class

ArchiveFileRecord Class

File

ActionNode.h

Links
ArchiveFileRecord Class
Send comments on this topic.


ArchiveFileRecord::WriteToFile Method

ArchiveFileRecord::WriteToFile Method
ArchiveFileRecord Class
Show All
C++
public: bool WriteToFile(
    const char* pOtherFileName = 0
);
Class

ArchiveFileRecord Class

File

ActionNode.h

Links
ArchiveFileRecord Class
Send comments on this topic.


ATask Class

ATask Class
Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
ATask
    rage::ExecuteTask
    rage::OpportunityTask
    rage::PrintTask
    rage::SequenceTask
    rage::SpawnTask
    rage::StubTask
C++
public: class ATask;
Constructors
Constructor | Description
ATask |
Destructors
Destructor | Description
~ATask |
Methods
Method | Description
Begin |
End |
GetActionController |
GetMyContext |
GetTrack |
Update |
Data Members
Data Member | Description
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted
Namespace

rage Namespace

File

ATask.h

Links
Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


ATask::m_NextRunningTask Data Member

ATask::m_NextRunningTask Data Member
ATask Class
Show All

Next in the linked list of running tasks

C++
public: ATask * m_NextRunningTask;
Class

ATask Class

File

ATask.h

Links
ATask Class
Send comments on this topic.


ATask::m_TimeEnd Data Member

ATask::m_TimeEnd Data Member
ATask Class
Show All

Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted

C++
public: float m_TimeEnd;
Class

ATask Class

File

ATask.h

Links
ATask Class
Send comments on this topic.


ATask::ATask Constructor

ATask::ATask Constructor
ATask Class
Show All
C++
public: ATask();
Class

ATask Class

File

ATask.h

Links
ATask Class
Send comments on this topic.


ATask::~ATask Destructor

ATask::~ATask Destructor
ATask Class
Show All
C++
public: virtual ~ATask();
Class

ATask Class

File

ATask.h

Links
ATask Class
Send comments on this topic.


ATask::Begin Method

ATask::Begin Method
ATask Class
Show All
C++
public: virtual bool Begin(
    void
);
Class

ATask Class

File

ATask.h

Links
ATask Class
Send comments on this topic.


ATask::End Method

ATask::End Method
ATask Class
Show All
C++
public: virtual bool End(
    void
);
Class

ATask Class

File

ATask.h

Links
ATask Class
Send comments on this topic.


ATask::GetActionController Method ()

ATask::GetActionController Method ()
ATask Class
Show All
C++
public: virtual ActionController* GetActionController();
Class

ATask Class

File

ATask.h

Links
ATask Class
Send comments on this topic.


ATask::GetActionController Method ()

ATask::GetActionController Method ()
ATask Class
Show All
C++
public: virtual const ActionController* GetActionController() const;
Class

ATask Class

File

ATask.h

Links
ATask Class
Send comments on this topic.


ATask::GetMyContext Method

ATask::GetMyContext Method
ATask Class
Show All
C++
public: virtual ActionContext* GetMyContext();
Class

ATask Class

File

ATask.h

Links
ATask Class
Send comments on this topic.


ATask::GetTrack Method

ATask::GetTrack Method
ATask Class
Show All
C++
public: virtual Track* GetTrack(
    void
) = 0;
Class

ATask Class

File

ATask.h

Links
ATask Class
Send comments on this topic.


ATask::Update Method

ATask::Update Method
ATask Class
Show All
C++
public: virtual bool Update(
    float deltaTime
);
Class

ATask Class

File

ATask.h

Links
ATask Class
Send comments on this topic.


BoolDataMember Template

BoolDataMember Template
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        rage::IBoolDataMember
            BoolDataMember
C++
template <class T> public: class BoolDataMember : public IBoolDataMember;
Constructors
Constructor | Description
BoolDataMember |
DataMember |
IBoolDataMember |
Destructors
Destructor | Description
~BoolDataMember |
~DataMember | RAW_ACT_FILE_SUPPORT
~IBoolDataMember | RAW_ACT_FILE_SUPPORT
~IName |
Methods
Method | Description
GetBool |
GetBool |
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
IsDefault |
Read |
Read |
Set_GetFunction |
SetBool |
SetBool |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


BoolDataMember::BoolDataMember Constructor

BoolDataMember::BoolDataMember Constructor
BoolDataMember Template
Show All
C++
public: BoolDataMember(
    const char* RAW_ACT_FILE_SUPPORT_ONLY(name),
    GetBoolMemberFunction getFunc = 0,
    SetBoolMemberFunction RAW_ACT_FILE_SUPPORT_ONLY(setFunc) = 0
);
Template

BoolDataMember Template

File

datamember.h

Links
BoolDataMember Template
Send comments on this topic.


BoolDataMember::~BoolDataMember Destructor

BoolDataMember::~BoolDataMember Destructor
BoolDataMember Template
Show All
C++
public: virtual ~BoolDataMember();
Template

BoolDataMember Template

File

datamember.h

Links
BoolDataMember Template
Send comments on this topic.


BoolDataMember::GetBool Method

BoolDataMember::GetBool Method
BoolDataMember Template
Show All
C++
public: virtual bool GetBool(
    IDataMembers* dm
);
Template

BoolDataMember Template

File

datamember.h

Links
BoolDataMember Template
Send comments on this topic.


BoolDataMember::IsDefault Method

BoolDataMember::IsDefault Method
BoolDataMember Template
Show All
C++
public: virtual bool IsDefault(
    IDataMembers* dm
);
Template

BoolDataMember Template

File

datamember.h

Links
BoolDataMember Template
Send comments on this topic.


BoolDataMember::Set_GetFunction Method

BoolDataMember::Set_GetFunction Method
BoolDataMember Template
Show All
C++
public: void Set_GetFunction(
    bool (T::*getFunc)(void)
);
Template

BoolDataMember Template

File

datamember.h

Links
BoolDataMember Template
Send comments on this topic.


BoolDataMember::SetBool Method

BoolDataMember::SetBool Method
BoolDataMember Template
Show All
C++
public: virtual void SetBool(
    IDataMembers* dm,
    bool data
);
Template

BoolDataMember Template

File

datamember.h

Links
BoolDataMember Template
Send comments on this topic.


CBasicString Class

CBasicString Class
Constructors | Destructors | Members | Methods | Operators | rage Namespace | Inheritance Hierarchy
Show All

Helper for paths

CBasicString
C++
public: class CBasicString;
Constructors
Constructor | Description
CBasicString |
Destructors
Destructor | Description
~CBasicString |
Methods
Method | Description
DECLARE_PLACE |
DeclareStruct |
GetString |
SetString |
Operators
Operator | Description
= |
== |
Namespace

rage Namespace

File

CName.h

Links
Constructors, Destructors, Members, Methods, Operators, rage Namespace, Inheritance Hierarchy


CBasicString::CBasicString Constructor ()

CBasicString::CBasicString Constructor ()
CBasicString Class
Show All
C++
public: CBasicString();
Class

CBasicString Class

File

CName.h

Links
CBasicString Class
Send comments on this topic.


CBasicString::CBasicString Constructor (const CBasicString&)

CBasicString::CBasicString Constructor (const CBasicString&)
CBasicString Class
Show All
C++
public: CBasicString(
    const CBasicString& rhs
);
Class

CBasicString Class

File

CName.h

Links
CBasicString Class
Send comments on this topic.


CBasicString::CBasicString Constructor (const char*)

CBasicString::CBasicString Constructor (const char*)
CBasicString Class
Show All
C++
public: CBasicString(
    const char* strvalue
);
Class

CBasicString Class

File

CName.h

Links
CBasicString Class
Send comments on this topic.


CBasicString::CBasicString Constructor (rage::datResource&)

CBasicString::CBasicString Constructor (rage::datResource&)
CBasicString Class
Show All
C++
public: CBasicString(
    rage::datResource& r
);
Class

CBasicString Class

File

CName.h

Links
CBasicString Class
Send comments on this topic.


CBasicString::~CBasicString Destructor

CBasicString::~CBasicString Destructor
CBasicString Class
Show All
C++
public: ~CBasicString();
Class

CBasicString Class

File

CName.h

Links
CBasicString Class
Send comments on this topic.


CBasicString::DECLARE_PLACE Method

CBasicString::DECLARE_PLACE Method
CBasicString Class
Show All
C++
public: DECLARE_PLACE(
    CBasicString
);
Class

CBasicString Class

File

CName.h

Links
CBasicString Class
Send comments on this topic.


CBasicString::DeclareStruct Method

CBasicString::DeclareStruct Method
CBasicString Class
Show All
C++
public: void DeclareStruct(
    rage::datTypeStruct & s
);
Class

CBasicString Class

File

CName.h

Links
CBasicString Class
Send comments on this topic.


CBasicString::GetString Method

CBasicString::GetString Method
CBasicString Class
Show All
C++
public: const char* GetString(
    void
) const;
Class

CBasicString Class

File

CName.h

Links
CBasicString Class
Send comments on this topic.


CBasicString::SetString Method

CBasicString::SetString Method
CBasicString Class
Show All
C++
public: void SetString(
    const char* strvalue
);
Class

CBasicString Class

File

CName.h

Links
CBasicString Class
Send comments on this topic.


CBasicString::= Operator

CBasicString::= Operator
CBasicString Class
Show All
C++
public: CBasicString& operator =(
    const CBasicString& rhs
);
Class

CBasicString Class

File

CName.h

Links
CBasicString Class
Send comments on this topic.


CBasicString::== Operator (const CBasicString&)

CBasicString::== Operator (const CBasicString&)
CBasicString Class
Show All
C++
public: bool operator ==(
    const CBasicString& rhs
) const;
Class

CBasicString Class

File

CName.h

Links
CBasicString Class
Send comments on this topic.


CBasicString::== Operator (const CName&)

CBasicString::== Operator (const CName&)
CBasicString Class
Show All
C++
public: bool operator ==(
    const CName& rhs
) const;
Class

CBasicString Class

File

CName.h

Links
CBasicString Class
Send comments on this topic.


CBasicString::== Operator (const char*)

CBasicString::== Operator (const char*)
CBasicString Class
Show All
C++
public: bool operator ==(
    const char* strvalue
) const;
Class

CBasicString Class

File

CName.h

Links
CBasicString Class
Send comments on this topic.


CFastNamePath Class

CFastNamePath Class
Constructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
CFastNamePath
C++
public: class CFastNamePath;
Constructors
Constructor | Description
CFastNamePath |
Methods
Method | Description
GetNameHash |
GetNumElements |
SetPath |
Namespace

rage Namespace

File

CName.h

Links
Constructors, Members, Methods, rage Namespace, Inheritance Hierarchy


CFastNamePath::CFastNamePath Constructor ()

CFastNamePath::CFastNamePath Constructor ()
CFastNamePath Class
Show All
C++
public: CFastNamePath();
Class

CFastNamePath Class

File

CName.h

Links
CFastNamePath Class
Send comments on this topic.


CFastNamePath::CFastNamePath Constructor (const char*)

CFastNamePath::CFastNamePath Constructor (const char*)
CFastNamePath Class
Show All
C++
public: CFastNamePath(
    const char* path
);
Class

CFastNamePath Class

File

CName.h

Links
CFastNamePath Class
Send comments on this topic.


CFastNamePath::GetNameHash Method ()

CFastNamePath::GetNameHash Method ()
CFastNamePath Class
Show All
C++
public: const int* GetNameHash() const;
Class

CFastNamePath Class

File

CName.h

Links
CFastNamePath Class
Send comments on this topic.


CFastNamePath::GetNameHash Method (int)

CFastNamePath::GetNameHash Method (int)
CFastNamePath Class
Show All
C++
public: int GetNameHash(
    int i
) const;
Class

CFastNamePath Class

File

CName.h

Links
CFastNamePath Class
Send comments on this topic.


CFastNamePath::GetNumElements Method

CFastNamePath::GetNumElements Method
CFastNamePath Class
Show All
C++
public: int GetNumElements(
    void
) const;
Class

CFastNamePath Class

File

CName.h

Links
CFastNamePath Class
Send comments on this topic.


CFastNamePath::SetPath Method

CFastNamePath::SetPath Method
CFastNamePath Class
Show All
C++
public: void SetPath(
    const char* path
);
Class

CFastNamePath Class

File

CName.h

Links
CFastNamePath Class
Send comments on this topic.


CName Class

CName Class
Constructors | Destructors | Members | Methods | Operators | rage Namespace | Inheritance Hierarchy
Show All
CName
C++
public: class CName;
Constructors
Constructor | Description
CName |
Destructors
Destructor | Description
~CName |
Methods
Method | Description
DECLARE_PLACE |
DeclareStruct |
GetID |
GetString |
Hash | This is here so you can change what CName Uses for Hashing... and also know which one it uses internally on the client side
SetID |
SetString |
Operators
Operator | Description
= |
== |
Namespace

rage Namespace

File

CName.h

Links
Constructors, Destructors, Members, Methods, Operators, rage Namespace, Inheritance Hierarchy


CName::CName Constructor ()

CName::CName Constructor ()
CName Class
Show All
C++
public: CName();
Class

CName Class

File

CName.h

Links
CName Class
Send comments on this topic.


CName::CName Constructor (const CName&)

CName::CName Constructor (const CName&)
CName Class
Show All
C++
public: CName(
    const CName& rhs
);
Class

CName Class

File

CName.h

Links
CName Class
Send comments on this topic.


CName::CName Constructor (const char*)

CName::CName Constructor (const char*)
CName Class
Show All
C++
public: explicit CName(
    const char* name
);
Class

CName Class

File

CName.h

Links
CName Class
Send comments on this topic.


CName::CName Constructor (const int)

CName::CName Constructor (const int)
CName Class
Show All
C++
public: explicit CName(
    const int id
);
Class

CName Class

File

CName.h

Links
CName Class
Send comments on this topic.


CName::CName Constructor (datResource&)

CName::CName Constructor (datResource&)
CName Class
Show All
C++
public: CName(
    datResource& r
);
Class

CName Class

File

CName.h

Links
CName Class
Send comments on this topic.


CName::~CName Destructor

CName::~CName Destructor
CName Class
Show All
C++
public: ~CName();
Class

CName Class

File

CName.h

Links
CName Class
Send comments on this topic.


CName::DECLARE_PLACE Method

CName::DECLARE_PLACE Method
CName Class
Show All
C++
public: DECLARE_PLACE(
    CName
);
Class

CName Class

File

CName.h

Links
CName Class
Send comments on this topic.


CName::DeclareStruct Method

CName::DeclareStruct Method
CName Class
Show All
C++
public: void DeclareStruct(
    datTypeStruct & s
);
Class

CName Class

File

CName.h

Links
CName Class
Send comments on this topic.


CName::GetID Method

CName::GetID Method
CName Class
Show All
C++
public: int GetID(
    void
) const;
Class

CName Class

File

CName.h

Links
CName Class
Send comments on this topic.


CName::GetString Method

CName::GetString Method
CName Class
Show All
C++
public: const char* GetString(
    void
) const;
Class

CName Class

File

CName.h

Links
CName Class
Send comments on this topic.


CName::Hash Method

CName::Hash Method
CName Class
Show All

This is here so you can change what CName Uses for Hashing... and also know which one it uses internally on the client side

C++
public: static int Hash(
    const char* name
);
Class

CName Class

File

CName.h

Links
CName Class
Send comments on this topic.


CName::SetID Method

CName::SetID Method
CName Class
Show All
C++
public: void SetID(
    const int id
);
Class

CName Class

File

CName.h

Links
CName Class
Send comments on this topic.


CName::SetString Method

CName::SetString Method
CName Class
Show All
C++
public: void SetString(
    const char* name
);
Class

CName Class

File

CName.h

Links
CName Class
Send comments on this topic.


CName::= Operator

CName::= Operator
CName Class
Show All
C++
public: CName& operator =(
    const CName& rhs
);
Class

CName Class

File

CName.h

Links
CName Class
Send comments on this topic.


CName::== Operator (const CName&)

CName::== Operator (const CName&)
CName Class
Show All
C++
public: bool operator ==(
    const CName& rhs
) const;
Class

CName Class

File

CName.h

Links
CName Class
Send comments on this topic.


CName::== Operator (const char*)

CName::== Operator (const char*)
CName Class
Show All
C++
public: bool operator ==(
    const char* name
) const;
Class

CName Class

File

CName.h

Links
CName Class
Send comments on this topic.


CName::== Operator (const int)

CName::== Operator (const int)
CName Class
Show All
C++
public: bool operator ==(
    const int id
) const;
Class

CName Class

File

CName.h

Links
CName Class
Send comments on this topic.


CNamePath Class

CNamePath Class
Constructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All

Helper for paths

CNamePath
C++
public: class CNamePath;
Constructors
Constructor | Description
CNamePath |
Methods
Method | Description
CatName |
CatNameID |
DECLARE_PLACE |
DeclareStruct |
DeInitStatic |
GetFullPathDebug |
GetName |
GetNumElements |
InitStatic |
SetPath |
Data Members
Data Member | Description
s_CNameTraverseDown |
s_CNameTraverseUp |
Namespace

rage Namespace

File

CName.h

Links
Constructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


CNamePath::s_CNameTraverseDown Data Member

CNamePath::s_CNameTraverseDown Data Member
CNamePath Class
Show All
C++
public: static CName s_CNameTraverseDown;
Class

CNamePath Class

File

CName.h

Links
CNamePath Class
Send comments on this topic.


CNamePath::s_CNameTraverseUp Data Member

CNamePath::s_CNameTraverseUp Data Member
CNamePath Class
Show All
C++
public: static CName s_CNameTraverseUp;
Class

CNamePath Class

File

CName.h

Links
CNamePath Class
Send comments on this topic.


CNamePath::CNamePath Constructor ()

CNamePath::CNamePath Constructor ()
CNamePath Class
Show All
C++
public: CNamePath();
Class

CNamePath Class

File

CName.h

Links
CNamePath Class
Send comments on this topic.


CNamePath::CNamePath Constructor (const char*)

CNamePath::CNamePath Constructor (const char*)
CNamePath Class
Show All
C++
public: CNamePath(
    const char* path
);
Class

CNamePath Class

File

CName.h

Links
CNamePath Class
Send comments on this topic.


CNamePath::CNamePath Constructor (rage::datResource&)

CNamePath::CNamePath Constructor (rage::datResource&)
CNamePath Class
Show All
C++
public: CNamePath(
    rage::datResource& r
);
Class

CNamePath Class

File

CName.h

Links
CNamePath Class
Send comments on this topic.


CNamePath::CatName Method (const CName&)

CNamePath::CatName Method (const CName&)
CNamePath Class
Show All
C++
public: void CatName(
    const CName& name
);
Class

CNamePath Class

File

CName.h

Links
CNamePath Class
Send comments on this topic.


CNamePath::CatName Method (const CName*)

CNamePath::CatName Method (const CName*)
CNamePath Class
Show All
C++
public: void CatName(
    const CName* name
);
Class

CNamePath Class

File

CName.h

Links
CNamePath Class
Send comments on this topic.


CNamePath::CatNameID Method

CNamePath::CatNameID Method
CNamePath Class
Show All
C++
public: void CatNameID(
    int cnameHashID
);
Class

CNamePath Class

File

CName.h

Links
CNamePath Class
Send comments on this topic.


CNamePath::DECLARE_PLACE Method

CNamePath::DECLARE_PLACE Method
CNamePath Class
Show All
C++
public: DECLARE_PLACE(
    CNamePath
);
Class

CNamePath Class

File

CName.h

Links
CNamePath Class
Send comments on this topic.


CNamePath::DeclareStruct Method

CNamePath::DeclareStruct Method
CNamePath Class
Show All
C++
public: void DeclareStruct(
    rage::datTypeStruct& s
);
Class

CNamePath Class

File

CName.h

Links
CNamePath Class
Send comments on this topic.


CNamePath::DeInitStatic Method

CNamePath::DeInitStatic Method
CNamePath Class
Show All
C++
public: static void DeInitStatic(
    void
);
Class

CNamePath Class

File

CName.h

Links
CNamePath Class
Send comments on this topic.


CNamePath::GetFullPathDebug Method

CNamePath::GetFullPathDebug Method
CNamePath Class
Show All
C++
public: const char* GetFullPathDebug();
Class

CNamePath Class

File

CName.h

Links
CNamePath Class
Send comments on this topic.


CNamePath::GetName Method (int)

CNamePath::GetName Method (int)
CNamePath Class
Show All
C++
public: CName& GetName(
    int i
);
Class

CNamePath Class

File

CName.h

Links
CNamePath Class
Send comments on this topic.


CNamePath::GetName Method (int)

CNamePath::GetName Method (int)
CNamePath Class
Show All
C++
public: const CName& GetName(
    int i
) const;
Class

CNamePath Class

File

CName.h

Links
CNamePath Class
Send comments on this topic.


CNamePath::GetNumElements Method

CNamePath::GetNumElements Method
CNamePath Class
Show All
C++
public: int GetNumElements(
    void
) const;
Class

CNamePath Class

File

CName.h

Links
CNamePath Class
Send comments on this topic.


CNamePath::InitStatic Method

CNamePath::InitStatic Method
CNamePath Class
Show All
C++
public: static void InitStatic(
    void
);
Class

CNamePath Class

File

CName.h

Links
CNamePath Class
Send comments on this topic.


CNamePath::SetPath Method

CNamePath::SetPath Method
CNamePath Class
Show All
C++
public: void SetPath(
    const char* path
);
Class

CNamePath Class

File

CName.h

Links
CNamePath Class
Send comments on this topic.


CommandDataMember Template

CommandDataMember Template
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        rage::IStringDataMember
            rage::ICommandDataMember
                CommandDataMember
C++
template <class T> public: class CommandDataMember : public ICommandDataMember;
Constructors
Constructor | Description
CommandDataMember |
DataMember |
ICommandDataMember |
IStringDataMember |
Destructors
Destructor | Description
~CommandDataMember |
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Methods
Method | Description
Execute |
Execute |
GetName |
GetName |
GetPfGroupActTracks |
GetString |
GetString |
GetType |
GetType |
GetType |
IsDefault |
Read |
Read |
SetString |
SetString |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


CommandDataMember::CommandDataMember Constructor

CommandDataMember::CommandDataMember Constructor
CommandDataMember Template
Show All
C++
public: CommandDataMember(
    const char* name,
    GetStringMemberFunction getFunc,
    SetStringMemberFunction RAW_ACT_FILE_SUPPORT_ONLY(setFunc),
    ExecuteFunction execFunc
);
Template

CommandDataMember Template

File

datamember.h

Links
CommandDataMember Template
Send comments on this topic.


CommandDataMember::~CommandDataMember Destructor

CommandDataMember::~CommandDataMember Destructor
CommandDataMember Template
Show All
C++
public: virtual ~CommandDataMember();
Template

CommandDataMember Template

File

datamember.h

Links
CommandDataMember Template
Send comments on this topic.


CommandDataMember::Execute Method

CommandDataMember::Execute Method
CommandDataMember Template
Show All
C++
public: virtual bool Execute(
    IDataMembers* dm
);
Template

CommandDataMember Template

File

datamember.h

Links
CommandDataMember Template
Send comments on this topic.


CommandDataMember::GetString Method

CommandDataMember::GetString Method
CommandDataMember Template
Show All
C++
public: virtual const char* GetString(
    IDataMembers* dm
);
Template

CommandDataMember Template

File

datamember.h

Links
CommandDataMember Template
Send comments on this topic.


CommandDataMember::SetString Method

CommandDataMember::SetString Method
CommandDataMember Template
Show All
C++
public: virtual void SetString(
    IDataMembers* dm,
    const char* data
);
Template

CommandDataMember Template

File

datamember.h

Links
CommandDataMember Template
Send comments on this topic.


Condition Class

Condition Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            Condition
                rage::ConditionActionNodePlayTime
                rage::ConditionFalse
                rage::ConditionGroupCondition
                rage::ConditionNOT
                rage::ConditionOR
                rage::ConditionPrint
                rage::ConditionRandom
                rage::ConditionTrue
C++
public: class Condition : public TrackOrCondition;
Constructors
Constructor | Description
Condition |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~IDataMembers |
Methods
Method | Description
Break |
Create |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |
Namespace

rage Namespace

File

Condition.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


Condition::RORC_VERSION Data Member

Condition::RORC_VERSION Data Member
Condition Class
Show All

Don't forget to bump this whenever a RAGE condition is added or modified

C++
public: static const int RORC_VERSION = 1;
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::Condition Constructor ()

Condition::Condition Constructor ()
Condition Class
Show All
C++
public: Condition();
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::Condition Constructor (datResource&)

Condition::Condition Constructor (datResource&)
Condition Class
Show All
C++
public: Condition(
    datResource&
);
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::~Condition Destructor

Condition::~Condition Destructor
Condition Class
Show All
C++
public: virtual ~Condition();
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::Create Method (TextParser&)

Condition::Create Method (TextParser&)
Condition Class
Show All
C++
public: static Condition* Create(
    TextParser& textParser
);
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::Create Method (const char*)

Condition::Create Method (const char*)
Condition Class
Show All
C++
public: static Condition* Create(
    const char* trackName
);
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::DECLARE_PLACE Method

Condition::DECLARE_PLACE Method
Condition Class
Show All
C++
public: DECLARE_PLACE(
    Condition
);
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::DeclareStruct Method

Condition::DeclareStruct Method
Condition Class
Show All
C++
public: virtual void DeclareStruct(
    datTypeStruct & s
);
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::DeInit Method

Condition::DeInit Method
Condition Class
Show All
C++
public: static void DeInit(
    void
);
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::EvalRemote Method

Condition::EvalRemote Method
Condition Class
Show All

Evaluates the remote condition

C++
public: virtual bool EvalRemote(
    ActionContext* = 0
);
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::GetLogical Method

Condition::GetLogical Method
Condition Class
Show All
C++
public: virtual Logical GetLogical(
    void
);
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::GetNumConditions Method

Condition::GetNumConditions Method
Condition Class
Show All
C++
public: static int GetNumConditions();
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::GetNumRegistered Method

Condition::GetNumRegistered Method
Condition Class
Show All
C++
public: static int GetNumRegistered(
    void
);
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::GetPFTimer Method

Condition::GetPFTimer Method
Condition Class
Show All
C++
public: virtual ::rage::pfTimer* GetPFTimer() = 0;
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::GetRegistered Method

Condition::GetRegistered Method
Condition Class
Show All
C++
public: static const CName* GetRegistered(
    int index
);
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::GetTrackRegistry Method

Condition::GetTrackRegistry Method
Condition Class
Show All

Used for games to register their own conditions

C++
public: static TrackRegistry& GetTrackRegistry();
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::Init Method

Condition::Init Method
Condition Class
Show All
C++
public: static void Init(
    int maxEntries = -1
);
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::IsRemoteCondition Method

Condition::IsRemoteCondition Method
Condition Class
Show All

: Checks if this is a remote condition

C++
public: virtual bool IsRemoteCondition(
    void
);
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::Match Method

Condition::Match Method
Condition Class
Show All
C++
public: virtual bool Match(
    ActionContext* context = 0
) = 0;
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


Condition::NewTask Method

Condition::NewTask Method
Condition Class
Show All
C++
public: virtual ATask* NewTask(
    ActionContext*
);
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


rage::Condition::Logical Enumeration

rage::Condition::Logical Enumeration
Condition Class
Show All
C++
public: enum Logical {
  public: L_NONE,
  public: L_NOT,
  public: L_OR
};
Class

Condition Class

File

Condition.h

Links
Condition Class
Send comments on this topic.


ConditionActionNodePlayTime Class

ConditionActionNodePlayTime Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                ConditionActionNodePlayTime
C++
public: class ConditionActionNodePlayTime : public Condition;
Constructors
Constructor | Description
Condition |
ConditionActionNodePlayTime |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionActionNodePlayTime |
~IDataMembers |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
TRACK_PARAMETER |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |
Namespace

rage Namespace

File

Condition.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


ConditionActionNodePlayTime::ConditionActionNodePlayTime Constructor

ConditionActionNodePlayTime::ConditionActionNodePlayTime Constructor
ConditionActionNodePlayTime Class
Show All
C++
public: ConditionActionNodePlayTime();
Class

ConditionActionNodePlayTime Class

File

Condition.h

Links
ConditionActionNodePlayTime Class
Send comments on this topic.


ConditionActionNodePlayTime::~ConditionActionNodePlayTime Destructor

ConditionActionNodePlayTime::~ConditionActionNodePlayTime Destructor
ConditionActionNodePlayTime Class
Show All
C++
public: virtual ~ConditionActionNodePlayTime();
Class

ConditionActionNodePlayTime Class

File

Condition.h

Links
ConditionActionNodePlayTime Class
Send comments on this topic.


ConditionActionNodePlayTime::DATAMEMEBERS_INTERFACE Method

ConditionActionNodePlayTime::DATAMEMEBERS_INTERFACE Method
ConditionActionNodePlayTime Class
Show All
C++
public: DATAMEMEBERS_INTERFACE(
    ConditionActionNodePlayTime
);
Class

ConditionActionNodePlayTime Class

File

Condition.h

Links
ConditionActionNodePlayTime Class
Send comments on this topic.


ConditionActionNodePlayTime::Match Method

ConditionActionNodePlayTime::Match Method
ConditionActionNodePlayTime Class
Show All
C++
public: virtual bool Match(
    ActionContext* context = 0
);
Class

ConditionActionNodePlayTime Class

File

Condition.h

Links
ConditionActionNodePlayTime Class
Send comments on this topic.


ConditionActionNodePlayTime::TRACK_PARAMETER Method

ConditionActionNodePlayTime::TRACK_PARAMETER Method
ConditionActionNodePlayTime Class
Show All
C++
public: TRACK_PARAMETER(
    float,
    PlayTime
);
Class

ConditionActionNodePlayTime Class

File

Condition.h

Links
ConditionActionNodePlayTime Class
Send comments on this topic.


Conditional Class

Conditional Class
Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All

EQUITY AND RELATIONAL OPERATORS... And some compare helper functions

Conditional
C++
public: class Conditional;
Methods
Method | Description
CompareFloat |
CompareInt |
Data Members
Data Member | Description
m_ConditionalStringName | Conditional
m_ConditionalStringNameSize |
Enumerations
Enumeration | Description
Operators |
Namespace

rage Namespace

File

Tracks.h

Links
Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


Conditional::m_ConditionalStringName Data Member

Conditional::m_ConditionalStringName Data Member
Conditional Class
Show All

Conditional

C++
public: static const char* m_ConditionalStringName[];
Class

Conditional Class

File

Tracks.h

Links
Conditional Class
Send comments on this topic.


Conditional::m_ConditionalStringNameSize Data Member

Conditional::m_ConditionalStringNameSize Data Member
Conditional Class
Show All
C++
public: static const int m_ConditionalStringNameSize;
Class

Conditional Class

File

Tracks.h

Links
Conditional Class
Send comments on this topic.


Conditional::CompareFloat Method

Conditional::CompareFloat Method
Conditional Class
Show All
C++
public: static bool CompareFloat(
    float value,
    float compareValue,
    Operators condition
);
Class

Conditional Class

File

Tracks.h

Links
Conditional Class
Send comments on this topic.


Conditional::CompareInt Method

Conditional::CompareInt Method
Conditional Class
Show All
C++
public: static bool CompareInt(
    int value,
    int compareValue,
    Conditional::Operators condition
);
Class

Conditional Class

File

Tracks.h

Links
Conditional Class
Send comments on this topic.


rage::Conditional::Operators Enumeration

rage::Conditional::Operators Enumeration
Conditional Class
Show All
C++
private: enum Operators {
  public: C_EQUAL,
  public: C_NOT_EQUAL,
  public: C_LESSTHAN,
  public: C_GREATERTHAN,
  public: C_LESSTHAN_EQUAL,
  public: C_GREATERTHAN_EQUAL
};
Class

Conditional Class

File

Tracks.h

Links
Conditional Class
Send comments on this topic.


ConditionFalse Class

ConditionFalse Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                ConditionFalse
C++
public: class ConditionFalse : public Condition;
Constructors
Constructor | Description
Condition |
ConditionFalse |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionFalse |
~IDataMembers |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |
Namespace

rage Namespace

File

Condition.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


ConditionFalse::ConditionFalse Constructor

ConditionFalse::ConditionFalse Constructor
ConditionFalse Class
Show All
C++
public: ConditionFalse();
Class

ConditionFalse Class

File

Condition.h

Links
ConditionFalse Class
Send comments on this topic.


ConditionFalse::~ConditionFalse Destructor

ConditionFalse::~ConditionFalse Destructor
ConditionFalse Class
Show All
C++
public: virtual ~ConditionFalse();
Class

ConditionFalse Class

File

Condition.h

Links
ConditionFalse Class
Send comments on this topic.


ConditionFalse::DATAMEMEBERS_INTERFACE Method

ConditionFalse::DATAMEMEBERS_INTERFACE Method
ConditionFalse Class
Show All
C++
public: DATAMEMEBERS_INTERFACE(
    ConditionFalse
);
Class

ConditionFalse Class

File

Condition.h

Links
ConditionFalse Class
Send comments on this topic.


ConditionFalse::Match Method

ConditionFalse::Match Method
ConditionFalse Class
Show All
C++
public: virtual bool Match(
    ActionContext*
);
Class

ConditionFalse Class

File

Condition.h

Links
ConditionFalse Class
Send comments on this topic.


ConditionGroup Class

ConditionGroup Class
Constructors | Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
ConditionGroup
C++
public: class ConditionGroup;
Constructors
Constructor | Description
ConditionGroup |
Destructors
Destructor | Description
~ConditionGroup |
Methods
Method | Description
AddCondition |
AddConditions |
ChangeConditionPriority |
DECLARE_PLACE |
DeclareStruct |
DeleteCondition |
EvalRemote |
GetCondition |
GetConditionCount |
Match |
Read |
Write |
Namespace

rage Namespace

File

Condition.h

Links
Constructors, Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


ConditionGroup::ConditionGroup Constructor ()

ConditionGroup::ConditionGroup Constructor ()
ConditionGroup Class
Show All
C++
public: ConditionGroup();
Class

ConditionGroup Class

File

Condition.h

Links
ConditionGroup Class
Send comments on this topic.


ConditionGroup::ConditionGroup Constructor (datResource &)

ConditionGroup::ConditionGroup Constructor (datResource &)
ConditionGroup Class
Show All
C++
public: ConditionGroup(
    datResource & r
);
Class

ConditionGroup Class

File

Condition.h

Links
ConditionGroup Class
Send comments on this topic.


ConditionGroup::~ConditionGroup Destructor

ConditionGroup::~ConditionGroup Destructor
ConditionGroup Class
Show All
C++
public: ~ConditionGroup();
Class

ConditionGroup Class

File

Condition.h

Links
ConditionGroup Class
Send comments on this topic.


ConditionGroup::AddCondition Method

ConditionGroup::AddCondition Method
ConditionGroup Class
Show All
C++
public: void AddCondition(
    Condition* condition
);
Class

ConditionGroup Class

File

Condition.h

Links
ConditionGroup Class
Send comments on this topic.


ConditionGroup::AddConditions Method

ConditionGroup::AddConditions Method
ConditionGroup Class
Show All
C++
public: void AddConditions(
    Condition** conditions,
    int count
);
Class

ConditionGroup Class

File

Condition.h

Links
ConditionGroup Class
Send comments on this topic.


ConditionGroup::ChangeConditionPriority Method

ConditionGroup::ChangeConditionPriority Method
ConditionGroup Class
Show All
C++
public: void ChangeConditionPriority(
    int conditionIndex,
    bool increase
);
Class

ConditionGroup Class

File

Condition.h

Links
ConditionGroup Class
Send comments on this topic.


ConditionGroup::DECLARE_PLACE Method

ConditionGroup::DECLARE_PLACE Method
ConditionGroup Class
Show All
C++
public: DECLARE_PLACE(
    ConditionGroup
);
Class

ConditionGroup Class

File

Condition.h

Links
ConditionGroup Class
Send comments on this topic.


ConditionGroup::DeclareStruct Method

ConditionGroup::DeclareStruct Method
ConditionGroup Class
Show All
C++
public: void DeclareStruct(
    datTypeStruct & s
);
Class

ConditionGroup Class

File

Condition.h

Links
ConditionGroup Class
Send comments on this topic.


ConditionGroup::DeleteCondition Method

ConditionGroup::DeleteCondition Method
ConditionGroup Class
Show All
C++
public: bool DeleteCondition(
    IDataMembers * pConditionToDelete
);
Class

ConditionGroup Class

File

Condition.h

Links
ConditionGroup Class
Send comments on this topic.


ConditionGroup::EvalRemote Method

ConditionGroup::EvalRemote Method
ConditionGroup Class
Show All
C++
public: bool EvalRemote(
    ActionContext* context = 0
);
Class

ConditionGroup Class

File

Condition.h

Links
ConditionGroup Class
Send comments on this topic.


ConditionGroup::GetCondition Method

ConditionGroup::GetCondition Method
ConditionGroup Class
Show All
C++
public: Condition* GetCondition(
    int index
);
Class

ConditionGroup Class

File

Condition.h

Links
ConditionGroup Class
Send comments on this topic.


ConditionGroup::GetConditionCount Method

ConditionGroup::GetConditionCount Method
ConditionGroup Class
Show All
C++
public: int GetConditionCount(
    void
);
Class

ConditionGroup Class

File

Condition.h

Links
ConditionGroup Class
Send comments on this topic.


ConditionGroup::Match Method

ConditionGroup::Match Method
ConditionGroup Class
Show All
C++
public: bool Match(
    ActionContext* RESTRICT context = 0
);
Class

ConditionGroup Class

File

Condition.h

Links
ConditionGroup Class
Send comments on this topic.


ConditionGroup::Read Method

ConditionGroup::Read Method
ConditionGroup Class
Show All
C++
public: void Read(
    TextParser& textParser
);
Class

ConditionGroup Class

File

Condition.h

Links
ConditionGroup Class
Send comments on this topic.


ConditionGroup::Write Method

ConditionGroup::Write Method
ConditionGroup Class
Show All
C++
public: void Write(
    TextBuffer& tB
);
Class

ConditionGroup Class

File

Condition.h

Links
ConditionGroup Class
Send comments on this topic.


ConditionGroupCondition Class

ConditionGroupCondition Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                ConditionGroupCondition
                    rage::ConditionGroupConditionAnd
                    rage::ConditionGroupConditionNot
                    rage::ConditionGroupConditionOnly
                    rage::ConditionGroupConditionOr
C++
public: class ConditionGroupCondition : public Condition;
Constructors
Constructor | Description
Condition |
ConditionGroupCondition |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionGroupCondition |
~IDataMembers |
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
EvalRemote | Evaluates the remote condition
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup |
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read | if __RESOURCECOMPILER
Read |
ReadConditionGroup |
Reset |
SetConditionGroup | In order to have a local ConditionGroup
SetDebugBreakPoint |
SetEnableBreakPoints |
TRACK_MEMBER |
TRACK_PADDING |
Write |
Write | lint !e1735
WriteCondition |
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |
Namespace

rage Namespace

File

Condition.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


ConditionGroupCondition::ConditionGroupCondition Constructor

ConditionGroupCondition::ConditionGroupCondition Constructor
ConditionGroupCondition Class
Show All
C++
public: ConditionGroupCondition();
Class

ConditionGroupCondition Class

File

Condition.h

Links
ConditionGroupCondition Class
Send comments on this topic.


ConditionGroupCondition::~ConditionGroupCondition Destructor

ConditionGroupCondition::~ConditionGroupCondition Destructor
ConditionGroupCondition Class
Show All
C++
public: virtual ~ConditionGroupCondition();
Class

ConditionGroupCondition Class

File

Condition.h

Links
ConditionGroupCondition Class
Send comments on this topic.


ConditionGroupCondition::AddCondition Method (TextParser&)

ConditionGroupCondition::AddCondition Method (TextParser&)
ConditionGroupCondition Class
Show All
C++
public: virtual IDataMembers * AddCondition(
    TextParser& textBuffer
);
Class

ConditionGroupCondition Class

File

Condition.h

Links
ConditionGroupCondition Class
Send comments on this topic.


ConditionGroupCondition::AddCondition Method (const char*)

ConditionGroupCondition::AddCondition Method (const char*)
ConditionGroupCondition Class
Show All
C++
public: virtual IDataMembers * AddCondition(
    const char* conditionFormat
);
Class

ConditionGroupCondition Class

File

Condition.h

Links
ConditionGroupCondition Class
Send comments on this topic.


ConditionGroupCondition::ChangeConditionPriority Method

ConditionGroupCondition::ChangeConditionPriority Method
ConditionGroupCondition Class
Show All
C++
public: virtual void ChangeConditionPriority(
    int conditionIndex,
    bool increase
);
Class

ConditionGroupCondition Class

File

Condition.h

Links
ConditionGroupCondition Class
Send comments on this topic.


ConditionGroupCondition::DATAMEMEBERS_INTERFACE Method

ConditionGroupCondition::DATAMEMEBERS_INTERFACE Method
ConditionGroupCondition Class
Show All
C++
public: DATAMEMEBERS_INTERFACE(
    ConditionGroupCondition
);
Class

ConditionGroupCondition Class

File

Condition.h

Links
ConditionGroupCondition Class
Send comments on this topic.


ConditionGroupCondition::DeleteCondition Method

ConditionGroupCondition::DeleteCondition Method
ConditionGroupCondition Class
Show All
C++
public: virtual bool DeleteCondition(
    IDataMembers * pConditionToDelete
);
Class

ConditionGroupCondition Class

File

Condition.h

Links
ConditionGroupCondition Class
Send comments on this topic.


ConditionGroupCondition::GetCondition Method

ConditionGroupCondition::GetCondition Method
ConditionGroupCondition Class
Show All
C++
public: virtual IDataMembers* GetCondition(
    int conditionIndex
);
Class

ConditionGroupCondition Class

File

Condition.h

Links
ConditionGroupCondition Class
Send comments on this topic.


ConditionGroupCondition::GetConditionCount Method

ConditionGroupCondition::GetConditionCount Method
ConditionGroupCondition Class
Show All
C++
public: virtual int GetConditionCount(
    void
);
Class

ConditionGroupCondition Class

File

Condition.h

Links
ConditionGroupCondition Class
Send comments on this topic.


ConditionGroupCondition::GetConditionFormat Method

ConditionGroupCondition::GetConditionFormat Method
ConditionGroupCondition Class
Show All
C++
public: virtual const char* GetConditionFormat(
    int conditionIndex
);
Class

ConditionGroupCondition Class

File

Condition.h

Links
ConditionGroupCondition Class
Send comments on this topic.


ConditionGroupCondition::GetConditionGroup Method

ConditionGroupCondition::GetConditionGroup Method
ConditionGroupCondition Class
Show All
C++
public: ConditionGroup* GetConditionGroup(
    void
);
Class

ConditionGroupCondition Class

File

Condition.h

Links
ConditionGroupCondition Class
Send comments on this topic.


ConditionGroupCondition::Match Method

ConditionGroupCondition::Match Method
ConditionGroupCondition Class
Show All
C++
public: bool Match(
    ActionContext* context = 0
);
Class

ConditionGroupCondition Class

File

Condition.h

Links
ConditionGroupCondition Class
Send comments on this topic.


ConditionGroupCondition::Read Method

ConditionGroupCondition::Read Method
ConditionGroupCondition Class
Show All

if __RESOURCECOMPILER

C++
public: virtual void Read(
    TextParser& textParser
);
Class

ConditionGroupCondition Class

File

Condition.h

Links
ConditionGroupCondition Class
Send comments on this topic.


ConditionGroupCondition::ReadConditionGroup Method

ConditionGroupCondition::ReadConditionGroup Method
ConditionGroupCondition Class
Show All
C++
public: virtual void ReadConditionGroup(
    TextParser& textParser
);
Class

ConditionGroupCondition Class

File

Condition.h

Links
ConditionGroupCondition Class
Send comments on this topic.


ConditionGroupCondition::SetConditionGroup Method

ConditionGroupCondition::SetConditionGroup Method
ConditionGroupCondition Class
Show All

In order to have a local ConditionGroup

C++
public: void SetConditionGroup(
    ConditionGroup* conditionGroup
);
Class

ConditionGroupCondition Class

File

Condition.h

Links
ConditionGroupCondition Class
Send comments on this topic.


ConditionGroupCondition::TRACK_MEMBER Method

ConditionGroupCondition::TRACK_MEMBER Method
ConditionGroupCondition Class
Show All
C++
public: TRACK_MEMBER(
    ConditionGroup,
    Conditions
);
Class

ConditionGroupCondition Class

File

Condition.h

Links
ConditionGroupCondition Class
Send comments on this topic.


ConditionGroupCondition::TRACK_PADDING Method

ConditionGroupCondition::TRACK_PADDING Method
ConditionGroupCondition Class
Show All
C++
public: TRACK_PADDING(
    0,
    4
);
Class

ConditionGroupCondition Class

File

Condition.h

Links
ConditionGroupCondition Class
Send comments on this topic.


ConditionGroupCondition::WriteCondition Method

ConditionGroupCondition::WriteCondition Method
ConditionGroupCondition Class
Show All
C++
public: virtual void WriteCondition(
    int conditionIndex,
    TextBuffer& textBuff
);
Class

ConditionGroupCondition Class

File

Condition.h

Links
ConditionGroupCondition Class
Send comments on this topic.


ConditionGroupConditionAnd Class

ConditionGroupConditionAnd Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                rage::ConditionGroupCondition
                    ConditionGroupConditionAnd
C++
public: class ConditionGroupConditionAnd : public ConditionGroupCondition;
Constructors
Constructor | Description
Condition |
ConditionGroupCondition |
ConditionGroupConditionAnd |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionGroupCondition |
~ConditionGroupConditionAnd |
~IDataMembers |
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
EvalRemote | Evaluates the remote condition
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup |
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
Match |
NewTask |
Read | if __RESOURCECOMPILER
Read |
ReadConditionGroup |
Reset |
SetConditionGroup | In order to have a local ConditionGroup
SetDebugBreakPoint |
SetEnableBreakPoints |
TRACK_MEMBER |
TRACK_PADDING |
Write |
Write | lint !e1735
WriteCondition |
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |
Namespace

rage Namespace

File

Condition.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


ConditionGroupConditionAnd::ConditionGroupConditionAnd Constructor

ConditionGroupConditionAnd::ConditionGroupConditionAnd Constructor
ConditionGroupConditionAnd Class
Show All
C++
public: ConditionGroupConditionAnd();
Class

ConditionGroupConditionAnd Class

File

Condition.h

Links
ConditionGroupConditionAnd Class
Send comments on this topic.


ConditionGroupConditionAnd::~ConditionGroupConditionAnd Destructor

ConditionGroupConditionAnd::~ConditionGroupConditionAnd Destructor
ConditionGroupConditionAnd Class
Show All
C++
public: virtual ~ConditionGroupConditionAnd();
Class

ConditionGroupConditionAnd Class

File

Condition.h

Links
ConditionGroupConditionAnd Class
Send comments on this topic.


ConditionGroupConditionAnd::DATAMEMEBERS_INTERFACE Method

ConditionGroupConditionAnd::DATAMEMEBERS_INTERFACE Method
ConditionGroupConditionAnd Class
Show All
C++
public: DATAMEMEBERS_INTERFACE(
    ConditionGroupConditionAnd
);
Class

ConditionGroupConditionAnd Class

File

Condition.h

Links
ConditionGroupConditionAnd Class
Send comments on this topic.


ConditionGroupConditionAnd::Match Method

ConditionGroupConditionAnd::Match Method
ConditionGroupConditionAnd Class
Show All
C++
public: virtual bool Match(
    ActionContext* context = 0
);
Class

ConditionGroupConditionAnd Class

File

Condition.h

Links
ConditionGroupConditionAnd Class
Send comments on this topic.


ConditionGroupConditionNot Class

ConditionGroupConditionNot Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                rage::ConditionGroupCondition
                    ConditionGroupConditionNot
C++
public: class ConditionGroupConditionNot : public ConditionGroupCondition;
Constructors
Constructor | Description
Condition |
ConditionGroupCondition |
ConditionGroupConditionNot |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionGroupCondition |
~ConditionGroupConditionNot |
~IDataMembers |
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
EvalRemote | Evaluates the remote condition
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup |
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
Match |
NewTask |
Read | if __RESOURCECOMPILER
Read |
ReadConditionGroup |
Reset |
SetConditionGroup | In order to have a local ConditionGroup
SetDebugBreakPoint |
SetEnableBreakPoints |
TRACK_MEMBER |
TRACK_PADDING |
Write |
Write | lint !e1735
WriteCondition |
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |
Namespace

rage Namespace

File

Condition.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


ConditionGroupConditionNot::ConditionGroupConditionNot Constructor

ConditionGroupConditionNot::ConditionGroupConditionNot Constructor
ConditionGroupConditionNot Class
Show All
C++
public: ConditionGroupConditionNot();
Class

ConditionGroupConditionNot Class

File

Condition.h

Links
ConditionGroupConditionNot Class
Send comments on this topic.


ConditionGroupConditionNot::~ConditionGroupConditionNot Destructor

ConditionGroupConditionNot::~ConditionGroupConditionNot Destructor
ConditionGroupConditionNot Class
Show All
C++
public: virtual ~ConditionGroupConditionNot();
Class

ConditionGroupConditionNot Class

File

Condition.h

Links
ConditionGroupConditionNot Class
Send comments on this topic.


ConditionGroupConditionNot::DATAMEMEBERS_INTERFACE Method

ConditionGroupConditionNot::DATAMEMEBERS_INTERFACE Method
ConditionGroupConditionNot Class
Show All
C++
public: DATAMEMEBERS_INTERFACE(
    ConditionGroupConditionNot
);
Class

ConditionGroupConditionNot Class

File

Condition.h

Links
ConditionGroupConditionNot Class
Send comments on this topic.


ConditionGroupConditionNot::Match Method

ConditionGroupConditionNot::Match Method
ConditionGroupConditionNot Class
Show All
C++
public: virtual bool Match(
    ActionContext* context = 0
);
Class

ConditionGroupConditionNot Class

File

Condition.h

Links
ConditionGroupConditionNot Class
Send comments on this topic.


ConditionGroupConditionOnly Class

ConditionGroupConditionOnly Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                rage::ConditionGroupCondition
                    ConditionGroupConditionOnly
C++
public: class ConditionGroupConditionOnly : public ConditionGroupCondition;
Constructors
Constructor | Description
Condition |
ConditionGroupCondition |
ConditionGroupConditionOnly |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionGroupCondition |
~ConditionGroupConditionOnly |
~IDataMembers |
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
EvalRemote | Evaluates the remote condition
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup |
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
Match |
NewTask |
Read | if __RESOURCECOMPILER
Read |
ReadConditionGroup |
Reset |
SetConditionGroup | In order to have a local ConditionGroup
SetDebugBreakPoint |
SetEnableBreakPoints |
TRACK_MEMBER |
TRACK_PADDING |
Write |
Write | lint !e1735
WriteCondition |
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |
Namespace

rage Namespace

File

Condition.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


ConditionGroupConditionOnly::ConditionGroupConditionOnly Constructor

ConditionGroupConditionOnly::ConditionGroupConditionOnly Constructor
ConditionGroupConditionOnly Class
Show All
C++
public: ConditionGroupConditionOnly();
Class

ConditionGroupConditionOnly Class

File

Condition.h

Links
ConditionGroupConditionOnly Class
Send comments on this topic.


ConditionGroupConditionOnly::~ConditionGroupConditionOnly Destructor

ConditionGroupConditionOnly::~ConditionGroupConditionOnly Destructor
ConditionGroupConditionOnly Class
Show All
C++
public: virtual ~ConditionGroupConditionOnly();
Class

ConditionGroupConditionOnly Class

File

Condition.h

Links
ConditionGroupConditionOnly Class
Send comments on this topic.


ConditionGroupConditionOnly::DATAMEMEBERS_INTERFACE Method

ConditionGroupConditionOnly::DATAMEMEBERS_INTERFACE Method
ConditionGroupConditionOnly Class
Show All
C++
public: DATAMEMEBERS_INTERFACE(
    ConditionGroupConditionOnly
);
Class

ConditionGroupConditionOnly Class

File

Condition.h

Links
ConditionGroupConditionOnly Class
Send comments on this topic.


ConditionGroupConditionOnly::Match Method

ConditionGroupConditionOnly::Match Method
ConditionGroupConditionOnly Class
Show All
C++
public: virtual bool Match(
    ActionContext* context = 0
);
Class

ConditionGroupConditionOnly Class

File

Condition.h

Links
ConditionGroupConditionOnly Class
Send comments on this topic.


ConditionGroupConditionOr Class

ConditionGroupConditionOr Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                rage::ConditionGroupCondition
                    ConditionGroupConditionOr
C++
public: class ConditionGroupConditionOr : public ConditionGroupCondition;
Constructors
Constructor | Description
Condition |
ConditionGroupCondition |
ConditionGroupConditionOr |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionGroupCondition |
~ConditionGroupConditionOr |
~IDataMembers |
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
EvalRemote | Evaluates the remote condition
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup |
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
Match |
NewTask |
Read | if __RESOURCECOMPILER
Read |
ReadConditionGroup |
Reset |
SetConditionGroup | In order to have a local ConditionGroup
SetDebugBreakPoint |
SetEnableBreakPoints |
TRACK_MEMBER |
TRACK_PADDING |
Write |
Write | lint !e1735
WriteCondition |
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |
Namespace

rage Namespace

File

Condition.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


ConditionGroupConditionOr::ConditionGroupConditionOr Constructor

ConditionGroupConditionOr::ConditionGroupConditionOr Constructor
ConditionGroupConditionOr Class
Show All
C++
public: ConditionGroupConditionOr();
Class

ConditionGroupConditionOr Class

File

Condition.h

Links
ConditionGroupConditionOr Class
Send comments on this topic.


ConditionGroupConditionOr::~ConditionGroupConditionOr Destructor

ConditionGroupConditionOr::~ConditionGroupConditionOr Destructor
ConditionGroupConditionOr Class
Show All
C++
public: virtual ~ConditionGroupConditionOr();
Class

ConditionGroupConditionOr Class

File

Condition.h

Links
ConditionGroupConditionOr Class
Send comments on this topic.


ConditionGroupConditionOr::DATAMEMEBERS_INTERFACE Method

ConditionGroupConditionOr::DATAMEMEBERS_INTERFACE Method
ConditionGroupConditionOr Class
Show All
C++
public: DATAMEMEBERS_INTERFACE(
    ConditionGroupConditionOr
);
Class

ConditionGroupConditionOr Class

File

Condition.h

Links
ConditionGroupConditionOr Class
Send comments on this topic.


ConditionGroupConditionOr::Match Method

ConditionGroupConditionOr::Match Method
ConditionGroupConditionOr Class
Show All
C++
public: virtual bool Match(
    ActionContext* context = 0
);
Class

ConditionGroupConditionOr Class

File

Condition.h

Links
ConditionGroupConditionOr Class
Send comments on this topic.


ConditionNOT Class

ConditionNOT Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                ConditionNOT
C++
public: class ConditionNOT : public Condition;
Constructors
Constructor | Description
Condition |
ConditionNOT |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionNOT |
~IDataMembers |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |
Namespace

rage Namespace

File

Condition.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


ConditionNOT::ConditionNOT Constructor

ConditionNOT::ConditionNOT Constructor
ConditionNOT Class
Show All
C++
public: ConditionNOT();
Class

ConditionNOT Class

File

Condition.h

Links
ConditionNOT Class
Send comments on this topic.


ConditionNOT::~ConditionNOT Destructor

ConditionNOT::~ConditionNOT Destructor
ConditionNOT Class
Show All
C++
public: virtual ~ConditionNOT();
Class

ConditionNOT Class

File

Condition.h

Links
ConditionNOT Class
Send comments on this topic.


ConditionNOT::DATAMEMEBERS_INTERFACE Method

ConditionNOT::DATAMEMEBERS_INTERFACE Method
ConditionNOT Class
Show All
C++
public: DATAMEMEBERS_INTERFACE(
    ConditionNOT
);
Class

ConditionNOT Class

File

Condition.h

Links
ConditionNOT Class
Send comments on this topic.


ConditionNOT::GetLogical Method

ConditionNOT::GetLogical Method
ConditionNOT Class
Show All
C++
public: virtual Logical GetLogical(
    void
);
Class

ConditionNOT Class

File

Condition.h

Links
ConditionNOT Class
Send comments on this topic.


ConditionNOT::Match Method

ConditionNOT::Match Method
ConditionNOT Class
Show All
C++
public: virtual bool Match(
    ActionContext*
);
Class

ConditionNOT Class

File

Condition.h

Links
ConditionNOT Class
Send comments on this topic.


ConditionOR Class

ConditionOR Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                ConditionOR
C++
public: class ConditionOR : public Condition;
Constructors
Constructor | Description
Condition |
ConditionOR |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionOR |
~IDataMembers |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |
Namespace

rage Namespace

File

Condition.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


ConditionOR::ConditionOR Constructor

ConditionOR::ConditionOR Constructor
ConditionOR Class
Show All
C++
public: ConditionOR();
Class

ConditionOR Class

File

Condition.h

Links
ConditionOR Class
Send comments on this topic.


ConditionOR::~ConditionOR Destructor

ConditionOR::~ConditionOR Destructor
ConditionOR Class
Show All
C++
public: virtual ~ConditionOR();
Class

ConditionOR Class

File

Condition.h

Links
ConditionOR Class
Send comments on this topic.


ConditionOR::DATAMEMEBERS_INTERFACE Method

ConditionOR::DATAMEMEBERS_INTERFACE Method
ConditionOR Class
Show All
C++
public: DATAMEMEBERS_INTERFACE(
    ConditionOR
);
Class

ConditionOR Class

File

Condition.h

Links
ConditionOR Class
Send comments on this topic.


ConditionOR::GetLogical Method

ConditionOR::GetLogical Method
ConditionOR Class
Show All
C++
public: virtual Logical GetLogical(
    void
);
Class

ConditionOR Class

File

Condition.h

Links
ConditionOR Class
Send comments on this topic.


ConditionOR::Match Method

ConditionOR::Match Method
ConditionOR Class
Show All
C++
public: virtual bool Match(
    ActionContext*
);
Class

ConditionOR Class

File

Condition.h

Links
ConditionOR Class
Send comments on this topic.


ConditionPrint Class

ConditionPrint Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                ConditionPrint
C++
public: class ConditionPrint : public Condition;
Constructors
Constructor | Description
Condition |
ConditionPrint |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionPrint |
~IDataMembers |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetText |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetText |
TRACK_MEMBER |
TRACK_PARAMETER_ENUM |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |
PrintChannels | keep in sync with PrintTrack::PrintChannels
Namespace

rage Namespace

File

Condition.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


ConditionPrint::ConditionPrint Constructor

ConditionPrint::ConditionPrint Constructor
ConditionPrint Class
Show All
C++
public: ConditionPrint();
Class

ConditionPrint Class

File

Condition.h

Links
ConditionPrint Class
Send comments on this topic.


ConditionPrint::~ConditionPrint Destructor

ConditionPrint::~ConditionPrint Destructor
ConditionPrint Class
Show All
C++
public: virtual ~ConditionPrint();
Class

ConditionPrint Class

File

Condition.h

Links
ConditionPrint Class
Send comments on this topic.


ConditionPrint::DATAMEMEBERS_INTERFACE Method

ConditionPrint::DATAMEMEBERS_INTERFACE Method
ConditionPrint Class
Show All
C++
public: DATAMEMEBERS_INTERFACE(
    ConditionPrint
);
Class

ConditionPrint Class

File

Condition.h

Links
ConditionPrint Class
Send comments on this topic.


ConditionPrint::GetText Method

ConditionPrint::GetText Method
ConditionPrint Class
Show All
C++
public: const char* GetText(
    void
);
Class

ConditionPrint Class

File

Condition.h

Links
ConditionPrint Class
Send comments on this topic.


ConditionPrint::Match Method

ConditionPrint::Match Method
ConditionPrint Class
Show All
C++
public: virtual bool Match(
    ActionContext* context = 0
);
Class

ConditionPrint Class

File

Condition.h

Links
ConditionPrint Class
Send comments on this topic.


ConditionPrint::SetText Method

ConditionPrint::SetText Method
ConditionPrint Class
Show All
C++
public: void SetText(
    const char* newString
);
Class

ConditionPrint Class

File

Condition.h

Links
ConditionPrint Class
Send comments on this topic.


ConditionPrint::TRACK_MEMBER Method

ConditionPrint::TRACK_MEMBER Method
ConditionPrint Class
Show All
C++
public: TRACK_MEMBER(
    char*,
    string
);
Class

ConditionPrint Class

File

Condition.h

Links
ConditionPrint Class
Send comments on this topic.


ConditionPrint::TRACK_PARAMETER_ENUM Method

ConditionPrint::TRACK_PARAMETER_ENUM Method
ConditionPrint Class
Show All
C++
public: TRACK_PARAMETER_ENUM(
    PrintChannels,
    PrintChannel
);
Class

ConditionPrint Class

File

Condition.h

Links
ConditionPrint Class
Send comments on this topic.


rage::ConditionPrint::PrintChannels Enumeration

rage::ConditionPrint::PrintChannels Enumeration
ConditionPrint Class
Show All

keep in sync with PrintTrack::PrintChannels

C++
public: enum PrintChannels {
  public: CHANNEL_SPEWDRV,
  public: CHANNEL_NM_DEBUG,
  public: CHANNEL_MISC_A,
  public: CHANNEL_MISC_B,
  public: NUM_PRINT_CHANNELS
};
Class

ConditionPrint Class

File

Condition.h

Links
ConditionPrint Class
Send comments on this topic.


ConditionRandom Class

ConditionRandom Class
Nested Types | Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                ConditionRandom
C++
public: class ConditionRandom : public Condition;
Nested Types
Nested Type | Description
ConditionRandFunc |
Constructors
Constructor | Description
Condition |
ConditionRandom |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~IDataMembers |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetRandFunc |
TRACK_PARAMETER |
TRACK_PARAMETER_ENUM |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
sm_RandomNum | shared across all instances
sm_RandomUsed | If used make a new one
Enumerations
Enumeration | Description
Logical |
RandomModes |
Namespace

rage Namespace

File

Condition.h

Links
Nested Types, Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


ConditionRandom::sm_RandomNum Data Member

ConditionRandom::sm_RandomNum Data Member
ConditionRandom Class
Show All

shared across all instances

C++
public: static int sm_RandomNum;
Class

ConditionRandom Class

File

Condition.h

Links
ConditionRandom Class
Send comments on this topic.


ConditionRandom::sm_RandomUsed Data Member

ConditionRandom::sm_RandomUsed Data Member
ConditionRandom Class
Show All

If used make a new one

C++
public: static bool sm_RandomUsed;
Class

ConditionRandom Class

File

Condition.h

Links
ConditionRandom Class
Send comments on this topic.


ConditionRandom::ConditionRandom Constructor

ConditionRandom::ConditionRandom Constructor
ConditionRandom Class
Show All
C++
public: ConditionRandom();
Class

ConditionRandom Class

File

Condition.h

Links
ConditionRandom Class
Send comments on this topic.


ConditionRandom::DATAMEMEBERS_INTERFACE Method

ConditionRandom::DATAMEMEBERS_INTERFACE Method
ConditionRandom Class
Show All
C++
public: DATAMEMEBERS_INTERFACE(
    ConditionRandom
);
Class

ConditionRandom Class

File

Condition.h

Links
ConditionRandom Class
Send comments on this topic.


ConditionRandom::Match Method

ConditionRandom::Match Method
ConditionRandom Class
Show All
C++
public: virtual bool Match(
    ActionContext* context = 0
);
Class

ConditionRandom Class

File

Condition.h

Links
ConditionRandom Class
Send comments on this topic.


ConditionRandom::SetRandFunc Method

ConditionRandom::SetRandFunc Method
ConditionRandom Class
Show All
C++
public: static void SetRandFunc(
    ConditionRandFunc func
);
Class

ConditionRandom Class

File

Condition.h

Links
ConditionRandom Class
Send comments on this topic.


ConditionRandom::TRACK_PARAMETER Method

ConditionRandom::TRACK_PARAMETER Method
ConditionRandom Class
Show All
C++
public: TRACK_PARAMETER(
    int,
    Goal
);
Class

ConditionRandom Class

File

Condition.h

Links
ConditionRandom Class
Send comments on this topic.


ConditionRandom::TRACK_PARAMETER_ENUM Method

ConditionRandom::TRACK_PARAMETER_ENUM Method
ConditionRandom Class
Show All
C++
public: TRACK_PARAMETER_ENUM(
    RandomModes,
    RandomMode
);
Class

ConditionRandom Class

File

Condition.h

Links
ConditionRandom Class
Send comments on this topic.


rage::ConditionRandom::RandomModes Enumeration

rage::ConditionRandom::RandomModes Enumeration
ConditionRandom Class
Show All
C++
private: enum RandomModes {
  public: R_DIRECT,
  public: R_PERCENTAGE,
  public: NUM_R_MODES
};
Class

ConditionRandom Class

File

Condition.h

Links
ConditionRandom Class
Send comments on this topic.


ConditionRandom::ConditionRandFunc Nested Type

ConditionRandom::ConditionRandFunc Nested Type
ConditionRandom Class
Show All
C++
public: typedef int (* ConditionRandFunc)(ActionContext *content);
Class

ConditionRandom Class

File

Condition.h

Links
ConditionRandom Class
Send comments on this topic.


ConditionTrue Class

ConditionTrue Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                ConditionTrue
C++
public: class ConditionTrue : public Condition;
Constructors
Constructor | Description
Condition |
ConditionTrue |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionTrue |
~IDataMembers |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |
Namespace

rage Namespace

File

Condition.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


ConditionTrue::ConditionTrue Constructor

ConditionTrue::ConditionTrue Constructor
ConditionTrue Class
Show All
C++
public: ConditionTrue();
Class

ConditionTrue Class

File

Condition.h

Links
ConditionTrue Class
Send comments on this topic.


ConditionTrue::~ConditionTrue Destructor

ConditionTrue::~ConditionTrue Destructor
ConditionTrue Class
Show All
C++
public: virtual ~ConditionTrue();
Class

ConditionTrue Class

File

Condition.h

Links
ConditionTrue Class
Send comments on this topic.


ConditionTrue::DATAMEMEBERS_INTERFACE Method

ConditionTrue::DATAMEMEBERS_INTERFACE Method
ConditionTrue Class
Show All
C++
public: DATAMEMEBERS_INTERFACE(
    ConditionTrue
);
Class

ConditionTrue Class

File

Condition.h

Links
ConditionTrue Class
Send comments on this topic.


ConditionTrue::Match Method

ConditionTrue::Match Method
ConditionTrue Class
Show All
C++
public: virtual bool Match(
    ActionContext*
);
Class

ConditionTrue Class

File

Condition.h

Links
ConditionTrue Class
Send comments on this topic.


CSubject Class

CSubject Class
Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
CSubject
    rage::ActionTreeLog
C++
public: class CSubject;
Constructors
Constructor | Description
CSubject |
Destructors
Destructor | Description
~CSubject |
Methods
Method | Description
Attach |
Dettach |
Notify |
Data Members
Data Member | Description
m_Observers |
Namespace

rage Namespace

File

SubjectObserver.h

Links
Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


CSubject::m_Observers Data Member

CSubject::m_Observers Data Member
CSubject Class
Show All
C++
protected: std::vector<IObserver*> m_Observers;
Class

CSubject Class

File

SubjectObserver.h

Links
CSubject Class
Send comments on this topic.


CSubject::CSubject Constructor

CSubject::CSubject Constructor
CSubject Class
Show All
C++
public: CSubject();
Class

CSubject Class

File

SubjectObserver.h

Links
CSubject Class
Send comments on this topic.


CSubject::~CSubject Destructor

CSubject::~CSubject Destructor
CSubject Class
Show All
C++
public: virtual ~CSubject();
Class

CSubject Class

File

SubjectObserver.h

Links
CSubject Class
Send comments on this topic.


CSubject::Attach Method

CSubject::Attach Method
CSubject Class
Show All
C++
public: virtual void Attach(
    IObserver* observer
);
Class

CSubject Class

File

SubjectObserver.h

Links
CSubject Class
Send comments on this topic.


CSubject::Dettach Method

CSubject::Dettach Method
CSubject Class
Show All
C++
public: virtual void Dettach(
    IObserver* observer
);
Class

CSubject Class

File

SubjectObserver.h

Links
CSubject Class
Send comments on this topic.


CSubject::Notify Method

CSubject::Notify Method
CSubject Class
Show All
C++
public: virtual void Notify();
Class

CSubject Class

File

SubjectObserver.h

Links
CSubject Class
Send comments on this topic.


DataMember Class

DataMember Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    DataMember
        rage::IBoolDataMember
        rage::IEnumDataMember
        rage::IFloatDataMember
        rage::IGroupDataMember
        rage::IIntDataMember
        rage::IStringDataMember
        rage::IVector2DataMember
        rage::IVector3DataMember
C++
public: class DataMember : public IName;
Constructors
Constructor | Description
DataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetType |
IsDefault |
Read |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


DataMember::m_Name Data Member

DataMember::m_Name Data Member
DataMember Class
Show All
C++
protected: CName m_Name;
Class

DataMember Class

File

datamember.h

Links
DataMember Class
Send comments on this topic.


DataMember::m_WriteBuff Data Member

DataMember::m_WriteBuff Data Member
DataMember Class
Show All

RAW_ACT_FILE_SUPPORT

C++
protected: static char m_WriteBuff[];
Class

DataMember Class

File

datamember.h

Links
DataMember Class
Send comments on this topic.


DataMember::DataMember Constructor ()

DataMember::DataMember Constructor ()
DataMember Class
Show All
C++
public: DataMember();
Class

DataMember Class

File

datamember.h

Links
DataMember Class
Send comments on this topic.


DataMember::DataMember Constructor (const char*)

DataMember::DataMember Constructor (const char*)
DataMember Class
Show All
C++
public: DataMember(
    const char* name
);
Class

DataMember Class

File

datamember.h

Links
DataMember Class
Send comments on this topic.


DataMember::~DataMember Destructor

DataMember::~DataMember Destructor
DataMember Class
Show All

RAW_ACT_FILE_SUPPORT

C++
public: virtual ~DataMember();
Class

DataMember Class

File

datamember.h

Links
DataMember Class
Send comments on this topic.


DataMember::GetName Method (void)

DataMember::GetName Method (void)
DataMember Class
Show All
C++
public: virtual CName* GetName(
    void
);
Class

DataMember Class

File

datamember.h

Links
DataMember Class
Send comments on this topic.


DataMember::GetName Method (void)

DataMember::GetName Method (void)
DataMember Class
Show All
C++
public: virtual const CName* GetName(
    void
) const;
Class

DataMember Class

File

datamember.h

Links
DataMember Class
Send comments on this topic.


DataMember::GetPfGroupActTracks Method

DataMember::GetPfGroupActTracks Method
DataMember Class
Show All
C++
public: static ::rage::pfGroup * GetPfGroupActTracks();
Class

DataMember Class

File

datamember.h

Links
DataMember Class
Send comments on this topic.


DataMember::GetType Method

DataMember::GetType Method
DataMember Class
Show All
C++
public: virtual TYPE GetType(
    void
) = 0;
Class

DataMember Class

File

datamember.h

Links
DataMember Class
Send comments on this topic.


DataMember::IsDefault Method

DataMember::IsDefault Method
DataMember Class
Show All
C++
public: virtual bool IsDefault(
    IDataMembers *
);
Class

DataMember Class

File

datamember.h

Links
DataMember Class
Send comments on this topic.


DataMember::Read Method

DataMember::Read Method
DataMember Class
Show All
C++
public: virtual void Read(
    IDataMembers* dm,
    TextParser& textParser
) = 0;
Class

DataMember Class

File

datamember.h

Links
DataMember Class
Send comments on this topic.


DataMember::Write Method

DataMember::Write Method
DataMember Class
Show All
C++
public: virtual void Write(
    IDataMembers* dm,
    TextBuffer& textBuff
) = 0;
Class

DataMember Class

File

datamember.h

Links
DataMember Class
Send comments on this topic.


rage::DataMember::TYPE Enumeration

rage::DataMember::TYPE Enumeration
DataMember Class
Show All
C++
public: enum TYPE {
  public: DM_BOOL,
  public: DM_INT,
  public: DM_FLOAT,
  public: DM_VECTOR2,
  public: DM_VECTOR3,
  public: DM_TIME,
  public: DM_TRACK_TIME,
  public: DM_ANGLE,
  public: DM_LENGTH,
  public: DM_VELOCITY,
  public: DM_ACCELERATION,
  public: DM_ENUM,
  public: DM_STRING,
  public: DM_NODEREF,
  public: DM_COMMAND,
  public: DM_GROUP_DATAMEMBER,
  public: DM_GROUP_DATAMEMBER_NO_INTERFACE
};
Class

DataMember Class

File

datamember.h

Links
DataMember Class
Send comments on this topic.


EnumDataMember Template

EnumDataMember Template
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        rage::IEnumDataMember
            EnumDataMember
C++
template <class T> public: class EnumDataMember : public IEnumDataMember;
Constructors
Constructor | Description
DataMember |
EnumDataMember |
IEnumDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~EnumDataMember |
~IName |
Methods
Method | Description
GetEnum |
GetEnum |
GetEnumName |
GetName |
GetName |
GetNumEnums |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
IsDefault |
Read |
Read |
SetEnum |
SetEnum |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


EnumDataMember::EnumDataMember Constructor

EnumDataMember::EnumDataMember Constructor
EnumDataMember Template
Show All
C++
public: EnumDataMember(
    const char* name,
    GetIntMemberFunction getFunc,
    SetIntMemberFunction RAW_ACT_FILE_SUPPORT_ONLY(setFunc),
    const char* const enumNameArray[],
    int numEnums
);
Template

EnumDataMember Template

File

datamember.h

Links
EnumDataMember Template
Send comments on this topic.


EnumDataMember::~EnumDataMember Destructor

EnumDataMember::~EnumDataMember Destructor
EnumDataMember Template
Show All
C++
public: virtual ~EnumDataMember();
Template

EnumDataMember Template

File

datamember.h

Links
EnumDataMember Template
Send comments on this topic.


EnumDataMember::GetEnum Method

EnumDataMember::GetEnum Method
EnumDataMember Template
Show All
C++
public: virtual int GetEnum(
    IDataMembers* dm
);
Template

EnumDataMember Template

File

datamember.h

Links
EnumDataMember Template
Send comments on this topic.


EnumDataMember::IsDefault Method

EnumDataMember::IsDefault Method
EnumDataMember Template
Show All
C++
public: virtual bool IsDefault(
    IDataMembers* dm
);
Template

EnumDataMember Template

File

datamember.h

Links
EnumDataMember Template
Send comments on this topic.


EnumDataMember::SetEnum Method

EnumDataMember::SetEnum Method
EnumDataMember Template
Show All
C++
public: virtual void SetEnum(
    IDataMembers* dm,
    int data
);
Template

EnumDataMember Template

File

datamember.h

Links
EnumDataMember Template
Send comments on this topic.


ExecuteTask Class

ExecuteTask Class
Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
rage::ATask
    ExecuteTask
C++
public: class ExecuteTask : public ATask;
Constructors
Constructor | Description
ATask |
ExecuteTask |
Destructors
Destructor | Description
~ATask |
~ExecuteTask |
Methods
Method | Description
Begin |
Begin | ExecuteTask
End |
End |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
Update |
Update |
Data Members
Data Member | Description
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted
Namespace

rage Namespace

File

CoreTask.h

Links
Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


ExecuteTask::ExecuteTask Constructor

ExecuteTask::ExecuteTask Constructor
ExecuteTask Class
Show All
C++
public: ExecuteTask(
    ActionContext* context,
    ExecuteTrack* track
);
Class

ExecuteTask Class

File

CoreTask.h

Links
ExecuteTask Class
Send comments on this topic.


ExecuteTask::~ExecuteTask Destructor

ExecuteTask::~ExecuteTask Destructor
ExecuteTask Class
Show All
C++
public: virtual ~ExecuteTask();
Class

ExecuteTask Class

File

CoreTask.h

Links
ExecuteTask Class
Send comments on this topic.


ExecuteTask::Begin Method

ExecuteTask::Begin Method
ExecuteTask Class
Show All

ExecuteTask

C++
public: virtual bool Begin(
    void
);
Class

ExecuteTask Class

File

CoreTask.h

Links
ExecuteTask Class
Send comments on this topic.


ExecuteTask::End Method

ExecuteTask::End Method
ExecuteTask Class
Show All
C++
public: virtual bool End(
    void
);
Class

ExecuteTask Class

File

CoreTask.h

Links
ExecuteTask Class
Send comments on this topic.


ExecuteTask::GetTrack Method

ExecuteTask::GetTrack Method
ExecuteTask Class
Show All
C++
public: virtual Track* GetTrack(
    void
);
Class

ExecuteTask Class

File

CoreTask.h

Links
ExecuteTask Class
Send comments on this topic.


ExecuteTask::Update Method

ExecuteTask::Update Method
ExecuteTask Class
Show All
C++
public: virtual bool Update(
    float deltaTime
);
Class

ExecuteTask Class

File

CoreTask.h

Links
ExecuteTask Class
Send comments on this topic.


ExecuteTrack Class

ExecuteTrack Class
Structs | Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Track
                rage::INodeReferenceTrack
                    rage::NodeReferenceTrack
                        ExecuteTrack
C++
public: class ExecuteTrack : public NodeReferenceTrack;
Structs
Struct | Description
Timer |
Constructors
Constructor | Description
ExecuteTrack |
IDataMembers |
INodeReferenceTrack |
NodeReferenceTrack |
Track |
TrackOrCondition |
Destructors
Destructor | Description
~ExecuteTrack |
~IDataMembers |
~NodeReferenceTrack |
~Track |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
NewTask |
Read |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent |
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
UpdateFrame |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ActionNodeRef |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |
Namespace

rage Namespace

File

ActionNodeTracks.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


ExecuteTrack::ExecuteTrack Constructor

ExecuteTrack::ExecuteTrack Constructor
ExecuteTrack Class
Show All
C++
public: ExecuteTrack();
Class

ExecuteTrack Class

File

ActionNodeTracks.h

Links
ExecuteTrack Class
Send comments on this topic.


ExecuteTrack::~ExecuteTrack Destructor

ExecuteTrack::~ExecuteTrack Destructor
ExecuteTrack Class
Show All
C++
public: virtual ~ExecuteTrack();
Class

ExecuteTrack Class

File

ActionNodeTracks.h

Links
ExecuteTrack Class
Send comments on this topic.


ExecuteTrack::DATAMEMEBERS_INTERFACE Method

ExecuteTrack::DATAMEMEBERS_INTERFACE Method
ExecuteTrack Class
Show All
C++
public: DATAMEMEBERS_INTERFACE(
    ExecuteTrack
);
Class

ExecuteTrack Class

File

ActionNodeTracks.h

Links
ExecuteTrack Class
Send comments on this topic.


ExecuteTrack::NewTask Method

ExecuteTrack::NewTask Method
ExecuteTrack Class
Show All
C++
public: ATask* NewTask(
    ActionContext* context
);
Class

ExecuteTrack Class

File

ActionNodeTracks.h

Links
ExecuteTrack Class
Send comments on this topic.


FloatDataMember Template

FloatDataMember Template
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        rage::IFloatDataMember
            FloatDataMember
C++
template <class T> public: class FloatDataMember : public IFloatDataMember;
Constructors
Constructor | Description
DataMember |
FloatDataMember |
IFloatDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~FloatDataMember |
~IName |
Methods
Method | Description
GetFloat |
GetFloat |
GetMinMaxFloat | RAW_ACT_FILE_SUPPORT
GetMinMaxFloat | RAW_ACT_FILE_SUPPORT
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
IsDefault |
Read |
Read |
SetFloat |
SetFloat |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


FloatDataMember::FloatDataMember Constructor

FloatDataMember::FloatDataMember Constructor
FloatDataMember Template
Show All
C++
public: FloatDataMember(
    const char* RAW_ACT_FILE_SUPPORT_ONLY(name),
    GetFloatMemberFunction getFunc,
    SetFloatMemberFunction RAW_ACT_FILE_SUPPORT_ONLY(setFunc),
    TYPE type = DM_FLOAT,
    GetMinFloatMemberFunction getMinFunc = 0,
    GetMaxFloatMemberFunction getMaxFunc = 0
);
Template

FloatDataMember Template

File

datamember.h

Links
FloatDataMember Template
Send comments on this topic.


FloatDataMember::~FloatDataMember Destructor

FloatDataMember::~FloatDataMember Destructor
FloatDataMember Template
Show All
C++
public: virtual ~FloatDataMember();
Template

FloatDataMember Template

File

datamember.h

Links
FloatDataMember Template
Send comments on this topic.


FloatDataMember::GetFloat Method

FloatDataMember::GetFloat Method
FloatDataMember Template
Show All
C++
public: virtual float GetFloat(
    IDataMembers* dm
);
Template

FloatDataMember Template

File

datamember.h

Links
FloatDataMember Template
Send comments on this topic.


FloatDataMember::GetMinMaxFloat Method

FloatDataMember::GetMinMaxFloat Method
FloatDataMember Template
Show All

RAW_ACT_FILE_SUPPORT

C++
public: virtual bool GetMinMaxFloat(
    IDataMembers* dm,
    float & rMin,
    float & rMax
);
Template

FloatDataMember Template

File

datamember.h

Links
FloatDataMember Template
Send comments on this topic.


FloatDataMember::GetType Method

FloatDataMember::GetType Method
FloatDataMember Template
Show All
C++
public: virtual TYPE GetType(
    void
);
Template

FloatDataMember Template

File

datamember.h

Links
FloatDataMember Template
Send comments on this topic.


FloatDataMember::IsDefault Method

FloatDataMember::IsDefault Method
FloatDataMember Template
Show All
C++
public: virtual bool IsDefault(
    IDataMembers* dm
);
Template

FloatDataMember Template

File

datamember.h

Links
FloatDataMember Template
Send comments on this topic.


FloatDataMember::SetFloat Method

FloatDataMember::SetFloat Method
FloatDataMember Template
Show All
C++
public: virtual void SetFloat(
    IDataMembers* dm,
    float data
);
Template

FloatDataMember Template

File

datamember.h

Links
FloatDataMember Template
Send comments on this topic.


GameTaskManager Class

GameTaskManager Class
Structs | Nested Types | Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
GameTaskManager
C++
public: class GameTaskManager;
Structs
Struct | Description
DummyTask |
DummyTaskHeader | This is the dummy structure that is used in the pool. The templated version of AllocateTask will put the actual class in there.
Nested Types
Nested Type | Description
DummyTask0 |
DummyTask1 |
DummyTask2 |
Constructors
Constructor | Description
GameTaskManager | GameTaskManager
Destructors
Destructor | Description
~GameTaskManager |
Methods
Method | Description
AddWidgets |
AllocateTask |
DECLARE_TASK_POOL_FUNCTIONS |
DeleteTask |
GetDummyTask | Get the DummyTask that contains the ATask. Obviously, this may only be called for ATask objects that were created using AllocateTask.
GetInstance |
InitClass |
ShutdownClass |
Data Members
Data Member | Description
m_CriticalSection | Critical section to prevent collisions.
m_TaskPool0 | Our pool for the tasks.
m_TaskPool1 |
m_TaskPool2 |
sm_Instance |
Namespace

rage Namespace

File

Tracks.h

Links
Structs, Nested Types, Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


GameTaskManager::m_CriticalSection Data Member

GameTaskManager::m_CriticalSection Data Member
GameTaskManager Class
Show All

Critical section to prevent collisions.

C++
protected: ::rage::sysCriticalSectionToken m_CriticalSection;
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GameTaskManager::m_TaskPool0 Data Member

GameTaskManager::m_TaskPool0 Data Member
GameTaskManager Class
Show All

Our pool for the tasks.

C++
protected: ::rage::atDynaPoolWithStats<DummyTask0, false> m_TaskPool0;
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GameTaskManager::m_TaskPool1 Data Member

GameTaskManager::m_TaskPool1 Data Member
GameTaskManager Class
Show All
C++
protected: ::rage::atDynaPoolWithStats<DummyTask1, false> m_TaskPool1;
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GameTaskManager::m_TaskPool2 Data Member

GameTaskManager::m_TaskPool2 Data Member
GameTaskManager Class
Show All
C++
protected: ::rage::atDynaPoolWithStats<DummyTask2, false> m_TaskPool2;
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GameTaskManager::sm_Instance Data Member

GameTaskManager::sm_Instance Data Member
GameTaskManager Class
Show All
C++
protected: static GameTaskManager * sm_Instance;
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


rage::GameTaskManager::DummyTask Struct

rage::GameTaskManager::DummyTask Struct
GameTaskManager Class
Show All
C++
private: struct DummyTask : public DummyTaskHeader {
  public: char m_Task[Size];
};
Members

m_Task
The task itself will be constructed in this buffer. The data in here is guaranteed to be derived from ATask. This array actually has the size of whatever pool it is in.

Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


rage::GameTaskManager::DummyTaskHeader Struct

rage::GameTaskManager::DummyTaskHeader Struct
GameTaskManager Class
Show All

This is the dummy structure that is used in the pool. The templated version of AllocateTask will put the actual class in there.

C++
public: struct DummyTaskHeader {
public:
  private: enum {
    public: MAGIC_HEADER = 0x5534354B
  };
  public: int m_PoolID;
  public: int m_Magic;
  public: char unused[8];
};
Members

m_PoolID
This is the task pool that this object is stored in. -1 indicates that it has not been put in any pool. This variable is used by the GameTaskManager.
m_Magic
For verification purposes. __ASSERT only, unused otherwise.
unused
Sigh.

Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GameTaskManager::GameTaskManager Constructor

GameTaskManager::GameTaskManager Constructor
GameTaskManager Class
Show All

GameTaskManager

C++
public: GameTaskManager(
    int maxTasks0 = MaxTasks0,
    int maxTasks1 = MaxTasks1,
    int maxTasks2 = MaxTasks2
);
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GameTaskManager::~GameTaskManager Destructor

GameTaskManager::~GameTaskManager Destructor
GameTaskManager Class
Show All
C++
public: ~GameTaskManager();
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GameTaskManager::AddWidgets Method

GameTaskManager::AddWidgets Method
GameTaskManager Class
Show All
C++
public: void AddWidgets(
    ::rage::bkBank & bank
);
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GameTaskManager::AllocateTask Method

GameTaskManager::AllocateTask Method
GameTaskManager Class
Show All
C++
public: template <typename T, typename C, typename P> T * AllocateTask(
    C* pContext,
    P* pThisTask
);
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GameTaskManager::DECLARE_TASK_POOL_FUNCTIONS Method (0)

GameTaskManager::DECLARE_TASK_POOL_FUNCTIONS Method (0)
GameTaskManager Class
Show All
C++
protected: DECLARE_TASK_POOL_FUNCTIONS(
    0
);
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GameTaskManager::DECLARE_TASK_POOL_FUNCTIONS Method (2)

GameTaskManager::DECLARE_TASK_POOL_FUNCTIONS Method (2)
GameTaskManager Class
Show All
C++
protected: DECLARE_TASK_POOL_FUNCTIONS(
    2
);
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GameTaskManager::DeleteTask Method

GameTaskManager::DeleteTask Method
GameTaskManager Class
Show All
C++
public: template <typename T> void DeleteTask(
    T * task
);
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GameTaskManager::GetDummyTask Method

GameTaskManager::GetDummyTask Method
GameTaskManager Class
Show All

Get the DummyTask that contains the ATask. Obviously, this may only be called for ATask objects that were created using AllocateTask.

C++
public: DummyTaskHeader * GetDummyTask(
    ATask * task
);
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GameTaskManager::GetInstance Method

GameTaskManager::GetInstance Method
GameTaskManager Class
Show All
C++
public: static GameTaskManager & GetInstance();
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GameTaskManager::InitClass Method

GameTaskManager::InitClass Method
GameTaskManager Class
Show All
C++
public: static void InitClass(
    int maxTasks0 = MaxTasks0,
    int maxTasks1 = MaxTasks1,
    int maxTasks2 = MaxTasks2
);
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GameTaskManager::ShutdownClass Method

GameTaskManager::ShutdownClass Method
GameTaskManager Class
Show All
C++
public: static void ShutdownClass();
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GameTaskManager::DummyTask0 Nested Type

GameTaskManager::DummyTask0 Nested Type
GameTaskManager Class
Show All
C++
public: typedef DummyTask<TaskPoolSize0> DummyTask0;
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GameTaskManager::DummyTask1 Nested Type

GameTaskManager::DummyTask1 Nested Type
GameTaskManager Class
Show All
C++
public: typedef DummyTask<TaskPoolSize1> DummyTask1;
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GameTaskManager::DummyTask2 Nested Type

GameTaskManager::DummyTask2 Nested Type
GameTaskManager Class
Show All
C++
public: typedef DummyTask<TaskPoolSize2> DummyTask2;
Class

GameTaskManager Class

File

Tracks.h

Links
GameTaskManager Class
Send comments on this topic.


GroupDataMember Template

GroupDataMember Template
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        rage::IGroupDataMember
            GroupDataMember
                rage::GroupDataMemberNoInterface
C++
template <class T> public: class GroupDataMember : public IGroupDataMember;
Constructors
Constructor | Description
DataMember |
GroupDataMember |
IGroupDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~GroupDataMember |
~IName |
Methods
Method | Description
Add |
Add |
ChangePriority |
ChangePriority |
Delete |
Delete |
GetCount |
GetCount |
GetDataMember |
GetDataMember |
GetDataMemberFormat |
GetDataMemberFormat |
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
Read |
Read |
ReadAllElements |
ReadAllElements |
Write |
Write |
WriteElements |
WriteElements |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


GroupDataMember::GroupDataMember Constructor

GroupDataMember::GroupDataMember Constructor
GroupDataMember Template
Show All
C++
public: GroupDataMember(
    const char* RAW_ACT_FILE_SUPPORT_ONLY(name),
    AddNewFunction addNewFunction,
    AddFunction addFunction,
    DeleteFunction deleteFunction,
    GetCountFunction getCountFunction,
    GetDataMemberFunction getDataMemberFunction,
    GetDataMemberFormatFunction getDataMemberFormatFunction,
    ChangePriorityFunction changePriorityFunction,
    ReadAllElementsFunction readAllElementsFunction,
    WriteElementsFunction writeElementsFunction
);
Parameters

addFunction
RAW_ACT_FILE_SUPPORT

Template

GroupDataMember Template

File

datamember.h

Links
GroupDataMember Template
Send comments on this topic.


GroupDataMember::~GroupDataMember Destructor

GroupDataMember::~GroupDataMember Destructor
GroupDataMember Template
Show All
C++
public: virtual ~GroupDataMember();
Template

GroupDataMember Template

File

datamember.h

Links
GroupDataMember Template
Send comments on this topic.


GroupDataMember::Add Method (IDataMembers*, TextParser&)

GroupDataMember::Add Method (IDataMembers*, TextParser&)
GroupDataMember Template
Show All
C++
public: virtual IDataMembers * Add(
    IDataMembers* dm,
    TextParser& textParser
);
Template

GroupDataMember Template

File

datamember.h

Links
GroupDataMember Template
Send comments on this topic.


GroupDataMember::Add Method (IDataMembers*, const char*)

GroupDataMember::Add Method (IDataMembers*, const char*)
GroupDataMember Template
Show All
C++
public: virtual IDataMembers * Add(
    IDataMembers* dm,
    const char* datamemberName
);
Template

GroupDataMember Template

File

datamember.h

Links
GroupDataMember Template
Send comments on this topic.


GroupDataMember::ChangePriority Method

GroupDataMember::ChangePriority Method
GroupDataMember Template
Show All
C++
public: virtual void ChangePriority(
    IDataMembers* dm,
    int index,
    bool increase
);
Template

GroupDataMember Template

File

datamember.h

Links
GroupDataMember Template
Send comments on this topic.


GroupDataMember::Delete Method (IDataMembers*, IDataMembers*)

GroupDataMember::Delete Method (IDataMembers*, IDataMembers*)
GroupDataMember Template
Show All
C++
public: virtual bool Delete(
    IDataMembers* dm,
    IDataMembers* pItemToDelete
);
Template

GroupDataMember Template

File

datamember.h

Links
GroupDataMember Template
Send comments on this topic.


GroupDataMember::Delete Method (IDataMembers*, int)

GroupDataMember::Delete Method (IDataMembers*, int)
GroupDataMember Template
Show All
C++
public: virtual void Delete(
    IDataMembers* dm,
    int index
);
Template

GroupDataMember Template

File

datamember.h

Links
GroupDataMember Template
Send comments on this topic.


GroupDataMember::GetCount Method

GroupDataMember::GetCount Method
GroupDataMember Template
Show All
C++
public: virtual int GetCount(
    IDataMembers* dm
);
Template

GroupDataMember Template

File

datamember.h

Links
GroupDataMember Template
Send comments on this topic.


GroupDataMember::GetDataMember Method

GroupDataMember::GetDataMember Method
GroupDataMember Template
Show All
C++
public: virtual IDataMembers* GetDataMember(
    IDataMembers* dm,
    int index
);
Template

GroupDataMember Template

File

datamember.h

Links
GroupDataMember Template
Send comments on this topic.


GroupDataMember::GetDataMemberFormat Method

GroupDataMember::GetDataMemberFormat Method
GroupDataMember Template
Show All
C++
public: virtual const char* GetDataMemberFormat(
    IDataMembers* dm,
    int index
);
Template

GroupDataMember Template

File

datamember.h

Links
GroupDataMember Template
Send comments on this topic.


GroupDataMember::ReadAllElements Method

GroupDataMember::ReadAllElements Method
GroupDataMember Template
Show All
C++
public: virtual void ReadAllElements(
    IDataMembers* dm,
    TextParser& textParser
);
Template

GroupDataMember Template

File

datamember.h

Links
GroupDataMember Template
Send comments on this topic.


GroupDataMember::WriteElements Method

GroupDataMember::WriteElements Method
GroupDataMember Template
Show All
C++
public: virtual void WriteElements(
    IDataMembers* dm,
    int index,
    TextBuffer& textBuff
);
Template

GroupDataMember Template

File

datamember.h

Links
GroupDataMember Template
Send comments on this topic.


GroupDataMemberNoInterface Template

GroupDataMemberNoInterface Template
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        rage::IGroupDataMember
            rage::GroupDataMember
                GroupDataMemberNoInterface
C++
template <class T> public: class GroupDataMemberNoInterface : public GroupDataMember<T>;
Constructors
Constructor | Description
DataMember |
GroupDataMember |
GroupDataMemberNoInterface |
IGroupDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~GroupDataMember |
~IName |
Methods
Method | Description
Add |
Add |
ChangePriority |
ChangePriority |
Delete |
Delete |
GetCount |
GetCount |
GetDataMember |
GetDataMember |
GetDataMemberFormat |
GetDataMemberFormat |
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
GetType |
IsDefault |
Read |
Read |
ReadAllElements |
ReadAllElements |
Write |
Write |
WriteElements |
WriteElements |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


GroupDataMemberNoInterface::GroupDataMemberNoInterface Constructor

GroupDataMemberNoInterface::GroupDataMemberNoInterface Constructor
GroupDataMemberNoInterface Template
Show All
C++
public: GroupDataMemberNoInterface(
    const char* name,
    AddNewFunction addNewFunction,
    AddFunction addFunction,
    DeleteFunction deleteFunction,
    GetCountFunction getCountFunction,
    GetDataMemberFunction getDataMemberFunction,
    GetDataMemberFormatFunction getDataMemberFormatFunction,
    ChangePriorityFunction changePriorityFunction,
    ReadAllElementsFunction readAllElementsFunction,
    WriteElementsFunction writeElementsFunction
);
Parameters

addFunction
RAW_ACT_FILE_SUPPORT

Template

GroupDataMemberNoInterface Template

File

datamember.h

Links
GroupDataMemberNoInterface Template
Send comments on this topic.


GroupDataMemberNoInterface::GetType Method

GroupDataMemberNoInterface::GetType Method
GroupDataMemberNoInterface Template
Show All
C++
public: virtual DataMember::TYPE GetType(
    void
);
Template

GroupDataMemberNoInterface Template

File

datamember.h

Links
GroupDataMemberNoInterface Template
Send comments on this topic.


IArchive Class

IArchive Class
Constructors | Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    IArchive
        rage::ActionNode
C++
public: class IArchive : public IName;
Constructors
Constructor | Description
IArchive |
Destructors
Destructor | Description
~IArchive |
~IName |
Methods
Method | Description
GetName |
Write |
Namespace

rage Namespace

File

ActionNode.h

Links
Constructors, Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


IArchive::IArchive Constructor

IArchive::IArchive Constructor
IArchive Class
Show All
C++
public: IArchive();
Class

IArchive Class

File

ActionNode.h

Links
IArchive Class
Send comments on this topic.


IArchive::~IArchive Destructor

IArchive::~IArchive Destructor
IArchive Class
Show All
C++
public: virtual ~IArchive();
Class

IArchive Class

File

ActionNode.h

Links
IArchive Class
Send comments on this topic.


IArchive::Write Method

IArchive::Write Method
IArchive Class
Show All
C++
public: virtual void Write(
    TextBuffer& textBuffer
) = 0;
Class

IArchive Class

File

ActionNode.h

Links
IArchive Class
Send comments on this topic.


IBoolDataMember Class

IBoolDataMember Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        IBoolDataMember
            rage::BoolDataMember
C++
public: class IBoolDataMember : public DataMember;
Constructors
Constructor | Description
DataMember |
IBoolDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IBoolDataMember | RAW_ACT_FILE_SUPPORT
~IName |
Methods
Method | Description
GetBool |
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
Read |
Read |
SetBool |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


IBoolDataMember::IBoolDataMember Constructor

IBoolDataMember::IBoolDataMember Constructor
IBoolDataMember Class
Show All
C++
public: IBoolDataMember(
    const char* name
);
Class

IBoolDataMember Class

File

datamember.h

Links
IBoolDataMember Class
Send comments on this topic.


IBoolDataMember::~IBoolDataMember Destructor

IBoolDataMember::~IBoolDataMember Destructor
IBoolDataMember Class
Show All

RAW_ACT_FILE_SUPPORT

C++
public: virtual ~IBoolDataMember();
Class

IBoolDataMember Class

File

datamember.h

Links
IBoolDataMember Class
Send comments on this topic.


IBoolDataMember::GetBool Method

IBoolDataMember::GetBool Method
IBoolDataMember Class
Show All
C++
public: virtual bool GetBool(
    IDataMembers* dm
) = 0;
Class

IBoolDataMember Class

File

datamember.h

Links
IBoolDataMember Class
Send comments on this topic.


IBoolDataMember::GetType Method

IBoolDataMember::GetType Method
IBoolDataMember Class
Show All
C++
public: virtual TYPE GetType(
    void
);
Class

IBoolDataMember Class

File

datamember.h

Links
IBoolDataMember Class
Send comments on this topic.


IBoolDataMember::Read Method

IBoolDataMember::Read Method
IBoolDataMember Class
Show All
C++
public: virtual void Read(
    IDataMembers* dm,
    TextParser& textParser
);
Class

IBoolDataMember Class

File

datamember.h

Links
IBoolDataMember Class
Send comments on this topic.


IBoolDataMember::SetBool Method

IBoolDataMember::SetBool Method
IBoolDataMember Class
Show All
C++
public: virtual void SetBool(
    IDataMembers* dm,
    bool data
) = 0;
Class

IBoolDataMember Class

File

datamember.h

Links
IBoolDataMember Class
Send comments on this topic.


IBoolDataMember::Write Method

IBoolDataMember::Write Method
IBoolDataMember Class
Show All
C++
public: virtual void Write(
    IDataMembers* dm,
    TextBuffer& textBuff
);
Class

IBoolDataMember Class

File

datamember.h

Links
IBoolDataMember Class
Send comments on this topic.


ICommandDataMember Class

ICommandDataMember Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        rage::IStringDataMember
            ICommandDataMember
                rage::CommandDataMember
C++
public: class ICommandDataMember : public IStringDataMember;
Constructors
Constructor | Description
DataMember |
ICommandDataMember |
IStringDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Methods
Method | Description
Execute |
GetName |
GetName |
GetPfGroupActTracks |
GetString |
GetType |
GetType |
GetType |
IsDefault |
Read |
Read |
SetString |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


ICommandDataMember::ICommandDataMember Constructor

ICommandDataMember::ICommandDataMember Constructor
ICommandDataMember Class
Show All
C++
public: ICommandDataMember(
    const char* name
);
Class

ICommandDataMember Class

File

datamember.h

Links
ICommandDataMember Class
Send comments on this topic.


ICommandDataMember::Execute Method

ICommandDataMember::Execute Method
ICommandDataMember Class
Show All
C++
public: virtual bool Execute(
    IDataMembers* dm
) = 0;
Class

ICommandDataMember Class

File

datamember.h

Links
ICommandDataMember Class
Send comments on this topic.


ICommandDataMember::GetType Method

ICommandDataMember::GetType Method
ICommandDataMember Class
Show All
C++
public: virtual TYPE GetType(
    void
);
Class

ICommandDataMember Class

File

datamember.h

Links
ICommandDataMember Class
Send comments on this topic.


IDataMembers Class

IDataMembers Class
Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        IDataMembers
            rage::ActionNodeFileReference
            rage::IDataMembers
            rage::TrackOrCondition
C++
public: class IDataMembers : public IDataMembers;
Constructors
Constructor | Description
IDataMembers |
IDataMembers |
Destructors
Destructor | Description
~IDataMembers |
~IDataMembers |
Methods
Method | Description
DeclareStruct |
DeclareStruct |
GetMember |
GetMember |
GetNumMembers |
GetNumMembers |
Read |
Read |
Reset |
Reset |
Write |
Write |
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


IDataMembers::m_ChangedMember Data Member

IDataMembers::m_ChangedMember Data Member
IDataMembers Class
Show All

This is the last DataMember that changed... should be ONLY used on update... sortof hacky

C++
public: DataMember* m_ChangedMember;
Class

IDataMembers Class

File

datamember.h

Links
IDataMembers Class
Send comments on this topic.


IDataMembers::IDataMembers Constructor

IDataMembers::IDataMembers Constructor
IDataMembers Class
Show All
C++
public: IDataMembers();
Class

IDataMembers Class

File

datamember.h

Links
IDataMembers Class
Send comments on this topic.


IDataMembers::~IDataMembers Destructor

IDataMembers::~IDataMembers Destructor
IDataMembers Class
Show All
C++
public: virtual ~IDataMembers();
Class

IDataMembers Class

File

datamember.h

Links
IDataMembers Class
Send comments on this topic.


IDataMembers::DeclareStruct Method

IDataMembers::DeclareStruct Method
IDataMembers Class
Show All
C++
public: void DeclareStruct(
    datTypeStruct& s
);
Class

IDataMembers Class

File

datamember.h

Links
IDataMembers Class
Send comments on this topic.


IDataMembers::GetMember Method

IDataMembers::GetMember Method
IDataMembers Class
Show All
C++
public: virtual DataMember* GetMember(
    int i
) = 0;
Class

IDataMembers Class

File

datamember.h

Links
IDataMembers Class
Send comments on this topic.


IDataMembers::GetNumMembers Method

IDataMembers::GetNumMembers Method
IDataMembers Class
Show All
C++
public: virtual int GetNumMembers(
    void
) = 0;
Class

IDataMembers Class

File

datamember.h

Links
IDataMembers Class
Send comments on this topic.


IDataMembers::Read Method

IDataMembers::Read Method
IDataMembers Class
Show All
C++
public: virtual void Read(
    TextParser& textParser
);
Class

IDataMembers Class

File

datamember.h

Links
IDataMembers Class
Send comments on this topic.


IDataMembers::Reset Method

IDataMembers::Reset Method
IDataMembers Class
Show All
C++
public: virtual void Reset();
Class

IDataMembers Class

File

datamember.h

Links
IDataMembers Class
Send comments on this topic.


IDataMembers::Write Method

IDataMembers::Write Method
IDataMembers Class
Show All
C++
public: virtual void Write(
    TextBuffer& textBuff,
    const char* headerName = 0
);
Class

IDataMembers Class

File

datamember.h

Links
IDataMembers Class
Send comments on this topic.


IEnumDataMember Class

IEnumDataMember Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        IEnumDataMember
            rage::EnumDataMember
C++
public: class IEnumDataMember : public DataMember;
Constructors
Constructor | Description
DataMember |
IEnumDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Methods
Method | Description
GetEnum |
GetEnumName |
GetName |
GetName |
GetNumEnums |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
Read |
Read |
SetEnum |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


IEnumDataMember::IEnumDataMember Constructor

IEnumDataMember::IEnumDataMember Constructor
IEnumDataMember Class
Show All
C++
public: IEnumDataMember(
    const char* RAW_ACT_FILE_SUPPORT_ONLY(name),
    const char* const enumNameArray[],
    int numEnums
);
Class

IEnumDataMember Class

File

datamember.h

Links
IEnumDataMember Class
Send comments on this topic.


IEnumDataMember::GetEnum Method (IDataMembers*)

IEnumDataMember::GetEnum Method (IDataMembers*)
IEnumDataMember Class
Show All
C++
public: virtual int GetEnum(
    IDataMembers* dm
) = 0;
Class

IEnumDataMember Class

File

datamember.h

Links
IEnumDataMember Class
Send comments on this topic.


IEnumDataMember::GetEnum Method (const char*)

IEnumDataMember::GetEnum Method (const char*)
IEnumDataMember Class
Show All
C++
public: int GetEnum(
    const char* EnumName
);
Class

IEnumDataMember Class

File

datamember.h

Links
IEnumDataMember Class
Send comments on this topic.


IEnumDataMember::GetEnumName Method

IEnumDataMember::GetEnumName Method
IEnumDataMember Class
Show All
C++
public: const char* GetEnumName(
    int enumID
);
Class

IEnumDataMember Class

File

datamember.h

Links
IEnumDataMember Class
Send comments on this topic.


IEnumDataMember::GetNumEnums Method

IEnumDataMember::GetNumEnums Method
IEnumDataMember Class
Show All
C++
public: int GetNumEnums(
    void
);
Class

IEnumDataMember Class

File

datamember.h

Links
IEnumDataMember Class
Send comments on this topic.


IEnumDataMember::GetType Method

IEnumDataMember::GetType Method
IEnumDataMember Class
Show All
C++
public: virtual TYPE GetType(
    void
);
Class

IEnumDataMember Class

File

datamember.h

Links
IEnumDataMember Class
Send comments on this topic.


IEnumDataMember::Read Method

IEnumDataMember::Read Method
IEnumDataMember Class
Show All
C++
public: virtual void Read(
    IDataMembers* dm,
    TextParser& textParser
);
Class

IEnumDataMember Class

File

datamember.h

Links
IEnumDataMember Class
Send comments on this topic.


IEnumDataMember::SetEnum Method

IEnumDataMember::SetEnum Method
IEnumDataMember Class
Show All
C++
public: virtual void SetEnum(
    IDataMembers* dm,
    int data
) = 0;
Class

IEnumDataMember Class

File

datamember.h

Links
IEnumDataMember Class
Send comments on this topic.


IEnumDataMember::Write Method

IEnumDataMember::Write Method
IEnumDataMember Class
Show All
C++
public: virtual void Write(
    IDataMembers* dm,
    TextBuffer& textBuff
);
Class

IEnumDataMember Class

File

datamember.h

Links
IEnumDataMember Class
Send comments on this topic.


IFloatDataMember Class

IFloatDataMember Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        IFloatDataMember
            rage::FloatDataMember
C++
public: class IFloatDataMember : public DataMember;
Constructors
Constructor | Description
DataMember |
IFloatDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Methods
Method | Description
GetFloat |
GetMinMaxFloat | RAW_ACT_FILE_SUPPORT
GetName |
GetName |
GetPfGroupActTracks |
GetType |
IsDefault |
Read |
Read |
SetFloat |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


IFloatDataMember::IFloatDataMember Constructor

IFloatDataMember::IFloatDataMember Constructor
IFloatDataMember Class
Show All
C++
public: IFloatDataMember(
    const char* name
);
Class

IFloatDataMember Class

File

datamember.h

Links
IFloatDataMember Class
Send comments on this topic.


IFloatDataMember::GetFloat Method

IFloatDataMember::GetFloat Method
IFloatDataMember Class
Show All
C++
public: virtual float GetFloat(
    IDataMembers* dm
) = 0;
Class

IFloatDataMember Class

File

datamember.h

Links
IFloatDataMember Class
Send comments on this topic.


IFloatDataMember::GetMinMaxFloat Method

IFloatDataMember::GetMinMaxFloat Method
IFloatDataMember Class
Show All

RAW_ACT_FILE_SUPPORT

C++
public: virtual bool GetMinMaxFloat(
    IDataMembers* dm,
    float & rMin,
    float & rMax
) = 0;
Class

IFloatDataMember Class

File

datamember.h

Links
IFloatDataMember Class
Send comments on this topic.


IFloatDataMember::Read Method

IFloatDataMember::Read Method
IFloatDataMember Class
Show All
C++
public: virtual void Read(
    IDataMembers* dm,
    TextParser& textParser
);
Class

IFloatDataMember Class

File

datamember.h

Links
IFloatDataMember Class
Send comments on this topic.


IFloatDataMember::SetFloat Method

IFloatDataMember::SetFloat Method
IFloatDataMember Class
Show All
C++
public: virtual void SetFloat(
    IDataMembers* dm,
    float data
) = 0;
Class

IFloatDataMember Class

File

datamember.h

Links
IFloatDataMember Class
Send comments on this topic.


IFloatDataMember::Write Method

IFloatDataMember::Write Method
IFloatDataMember Class
Show All
C++
public: virtual void Write(
    IDataMembers* dm,
    TextBuffer& textBuff
);
Class

IFloatDataMember Class

File

datamember.h

Links
IFloatDataMember Class
Send comments on this topic.


IGroupDataMember Class

IGroupDataMember Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        IGroupDataMember
            rage::GroupDataMember
C++
public: class IGroupDataMember : public DataMember;
Constructors
Constructor | Description
DataMember |
IGroupDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Methods
Method | Description
Add |
ChangePriority |
Delete |
GetCount |
GetDataMember |
GetDataMemberFormat |
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
Read |
Read |
ReadAllElements |
Write |
Write |
WriteElements |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


IGroupDataMember::IGroupDataMember Constructor

IGroupDataMember::IGroupDataMember Constructor
IGroupDataMember Class
Show All
C++
public: IGroupDataMember(
    const char* name
);
Class

IGroupDataMember Class

File

datamember.h

Links
IGroupDataMember Class
Send comments on this topic.


IGroupDataMember::Add Method (IDataMembers*, TextParser&)

IGroupDataMember::Add Method (IDataMembers*, TextParser&)
IGroupDataMember Class
Show All
C++
public: virtual IDataMembers * Add(
    IDataMembers* dm,
    TextParser& textParser
) = 0;
Class

IGroupDataMember Class

File

datamember.h

Links
IGroupDataMember Class
Send comments on this topic.


IGroupDataMember::Add Method (IDataMembers*, const char*)

IGroupDataMember::Add Method (IDataMembers*, const char*)
IGroupDataMember Class
Show All
C++
public: virtual IDataMembers * Add(
    IDataMembers* dm,
    const char* datamemberName
) = 0;
Class

IGroupDataMember Class

File

datamember.h

Links
IGroupDataMember Class
Send comments on this topic.


IGroupDataMember::ChangePriority Method

IGroupDataMember::ChangePriority Method
IGroupDataMember Class
Show All
C++
public: virtual void ChangePriority(
    IDataMembers* dm,
    int index,
    bool increase
) = 0;
Class

IGroupDataMember Class

File

datamember.h

Links
IGroupDataMember Class
Send comments on this topic.


IGroupDataMember::Delete Method (IDataMembers*, IDataMembers*)

IGroupDataMember::Delete Method (IDataMembers*, IDataMembers*)
IGroupDataMember Class
Show All
C++
public: virtual bool Delete(
    IDataMembers* dm,
    IDataMembers* pItemToDelete
) = 0;
Class

IGroupDataMember Class

File

datamember.h

Links
IGroupDataMember Class
Send comments on this topic.


IGroupDataMember::Delete Method (IDataMembers*, int)

IGroupDataMember::Delete Method (IDataMembers*, int)
IGroupDataMember Class
Show All
C++
public: virtual void Delete(
    IDataMembers* dm,
    int index
) = 0;
Class

IGroupDataMember Class

File

datamember.h

Links
IGroupDataMember Class
Send comments on this topic.


IGroupDataMember::GetCount Method

IGroupDataMember::GetCount Method
IGroupDataMember Class
Show All
C++
public: virtual int GetCount(
    IDataMembers* dm
) = 0;
Class

IGroupDataMember Class

File

datamember.h

Links
IGroupDataMember Class
Send comments on this topic.


IGroupDataMember::GetDataMember Method

IGroupDataMember::GetDataMember Method
IGroupDataMember Class
Show All
C++
public: virtual IDataMembers* GetDataMember(
    IDataMembers* dm,
    int index
) = 0;
Class

IGroupDataMember Class

File

datamember.h

Links
IGroupDataMember Class
Send comments on this topic.


IGroupDataMember::GetDataMemberFormat Method

IGroupDataMember::GetDataMemberFormat Method
IGroupDataMember Class
Show All
C++
public: virtual const char* GetDataMemberFormat(
    IDataMembers* dm,
    int conditionIndex
) = 0;
Class

IGroupDataMember Class

File

datamember.h

Links
IGroupDataMember Class
Send comments on this topic.


IGroupDataMember::GetType Method

IGroupDataMember::GetType Method
IGroupDataMember Class
Show All
C++
public: virtual TYPE GetType(
    void
);
Class

IGroupDataMember Class

File

datamember.h

Links
IGroupDataMember Class
Send comments on this topic.


IGroupDataMember::Read Method

IGroupDataMember::Read Method
IGroupDataMember Class
Show All
C++
public: virtual void Read(
    IDataMembers* dm,
    TextParser& textParser
);
Class

IGroupDataMember Class

File

datamember.h

Links
IGroupDataMember Class
Send comments on this topic.


IGroupDataMember::ReadAllElements Method

IGroupDataMember::ReadAllElements Method
IGroupDataMember Class
Show All
C++
public: virtual void ReadAllElements(
    IDataMembers* dm,
    TextParser& textParser
) = 0;
Class

IGroupDataMember Class

File

datamember.h

Links
IGroupDataMember Class
Send comments on this topic.


IGroupDataMember::Write Method

IGroupDataMember::Write Method
IGroupDataMember Class
Show All
C++
public: virtual void Write(
    IDataMembers* dm,
    TextBuffer& textBuff
);
Class

IGroupDataMember Class

File

datamember.h

Links
IGroupDataMember Class
Send comments on this topic.


IGroupDataMember::WriteElements Method

IGroupDataMember::WriteElements Method
IGroupDataMember Class
Show All
C++
public: virtual void WriteElements(
    IDataMembers* dm,
    int index,
    TextBuffer& textBuff
) = 0;
Class

IGroupDataMember Class

File

datamember.h

Links
IGroupDataMember Class
Send comments on this topic.


IIntDataMember Class

IIntDataMember Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        IIntDataMember
            rage::IntDataMember
C++
public: class IIntDataMember : public DataMember;
Constructors
Constructor | Description
DataMember |
IIntDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Methods
Method | Description
GetInt |
GetMinMaxInt | RAW_ACT_FILE_SUPPORT
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
Read |
Read |
SetInt |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


IIntDataMember::IIntDataMember Constructor

IIntDataMember::IIntDataMember Constructor
IIntDataMember Class
Show All
C++
public: IIntDataMember(
    const char* name
);
Class

IIntDataMember Class

File

datamember.h

Links
IIntDataMember Class
Send comments on this topic.


IIntDataMember::GetInt Method

IIntDataMember::GetInt Method
IIntDataMember Class
Show All
C++
public: virtual int GetInt(
    IDataMembers* dm
) = 0;
Class

IIntDataMember Class

File

datamember.h

Links
IIntDataMember Class
Send comments on this topic.


IIntDataMember::GetMinMaxInt Method

IIntDataMember::GetMinMaxInt Method
IIntDataMember Class
Show All

RAW_ACT_FILE_SUPPORT

C++
public: virtual bool GetMinMaxInt(
    IDataMembers* dm,
    int & rMin,
    int & rMax
) = 0;
Class

IIntDataMember Class

File

datamember.h

Links
IIntDataMember Class
Send comments on this topic.


IIntDataMember::GetType Method

IIntDataMember::GetType Method
IIntDataMember Class
Show All
C++
public: virtual TYPE GetType(
    void
);
Class

IIntDataMember Class

File

datamember.h

Links
IIntDataMember Class
Send comments on this topic.


IIntDataMember::Read Method

IIntDataMember::Read Method
IIntDataMember Class
Show All
C++
public: virtual void Read(
    IDataMembers* dm,
    TextParser& textParser
);
Class

IIntDataMember Class

File

datamember.h

Links
IIntDataMember Class
Send comments on this topic.


IIntDataMember::SetInt Method

IIntDataMember::SetInt Method
IIntDataMember Class
Show All
C++
public: virtual void SetInt(
    IDataMembers* dm,
    int data
) = 0;
Class

IIntDataMember Class

File

datamember.h

Links
IIntDataMember Class
Send comments on this topic.


IIntDataMember::Write Method

IIntDataMember::Write Method
IIntDataMember Class
Show All
C++
public: virtual void Write(
    IDataMembers* dm,
    TextBuffer& textBuff
);
Class

IIntDataMember Class

File

datamember.h

Links
IIntDataMember Class
Send comments on this topic.


IMultiNodeReferenceTrack Class

IMultiNodeReferenceTrack Class
Structs | Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Track
                rage::INodeReferenceTrack
                    IMultiNodeReferenceTrack
C++
public: class IMultiNodeReferenceTrack : public INodeReferenceTrack;
Structs
Struct | Description
Timer |
Constructors
Constructor | Description
IDataMembers |
IMultiNodeReferenceTrack |
INodeReferenceTrack |
Track |
TrackOrCondition |
Destructors
Destructor | Description
~IDataMembers |
~Track |
Methods
Method | Description
Break |
Create |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRefs |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRef |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | (to eliminate the need for dynamic_cast
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
Read |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent | Sets the parent for *all* node references.
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
UpdateFrame |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |
Namespace

rage Namespace

File

ActionNodeTracks.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


IMultiNodeReferenceTrack::IMultiNodeReferenceTrack Constructor ()

IMultiNodeReferenceTrack::IMultiNodeReferenceTrack Constructor ()
IMultiNodeReferenceTrack Class
Show All
C++
public: IMultiNodeReferenceTrack();
Class

IMultiNodeReferenceTrack Class

File

ActionNodeTracks.h

Links
IMultiNodeReferenceTrack Class
Send comments on this topic.


IMultiNodeReferenceTrack::IMultiNodeReferenceTrack Constructor (datResource&)

IMultiNodeReferenceTrack::IMultiNodeReferenceTrack Constructor (datResource&)
IMultiNodeReferenceTrack Class
Show All
C++
public: IMultiNodeReferenceTrack(
    datResource& r
);
Class

IMultiNodeReferenceTrack Class

File

ActionNodeTracks.h

Links
IMultiNodeReferenceTrack Class
Send comments on this topic.


IMultiNodeReferenceTrack::GetActionNode Method

IMultiNodeReferenceTrack::GetActionNode Method
IMultiNodeReferenceTrack Class
Show All
C++
public: ActionNode* GetActionNode(
    int idx
);
Class

IMultiNodeReferenceTrack Class

File

ActionNodeTracks.h

Links
IMultiNodeReferenceTrack Class
Send comments on this topic.


IMultiNodeReferenceTrack::GetActionNodeReference Method

IMultiNodeReferenceTrack::GetActionNodeReference Method
IMultiNodeReferenceTrack Class
Show All
C++
public: const char * GetActionNodeReference(
    int idx
);
Class

IMultiNodeReferenceTrack Class

File

ActionNodeTracks.h

Links
IMultiNodeReferenceTrack Class
Send comments on this topic.


IMultiNodeReferenceTrack::GetActionNodeReferenceFullPath Method

IMultiNodeReferenceTrack::GetActionNodeReferenceFullPath Method
IMultiNodeReferenceTrack Class
Show All
C++
public: const char * GetActionNodeReferenceFullPath(
    int idx
);
Class

IMultiNodeReferenceTrack Class

File

ActionNodeTracks.h

Links
IMultiNodeReferenceTrack Class
Send comments on this topic.


IMultiNodeReferenceTrack::GetNumRefs Method

IMultiNodeReferenceTrack::GetNumRefs Method
IMultiNodeReferenceTrack Class
Show All
C++
public: virtual int GetNumRefs() = 0 const;
Class

IMultiNodeReferenceTrack Class

File

ActionNodeTracks.h

Links
IMultiNodeReferenceTrack Class
Send comments on this topic.


IMultiNodeReferenceTrack::GetRef Method

IMultiNodeReferenceTrack::GetRef Method
IMultiNodeReferenceTrack Class
Show All
C++
public: virtual ActionNodeLwRef & GetRef(
    int idx
) = 0;
Class

IMultiNodeReferenceTrack Class

File

ActionNodeTracks.h

Links
IMultiNodeReferenceTrack Class
Send comments on this topic.


IMultiNodeReferenceTrack::GetTrackType Method

IMultiNodeReferenceTrack::GetTrackType Method
IMultiNodeReferenceTrack Class
Show All

(to eliminate the need for dynamic_cast

C++
public: virtual int GetTrackType() const;
Class

IMultiNodeReferenceTrack Class

File

ActionNodeTracks.h

Links
IMultiNodeReferenceTrack Class
Send comments on this topic.


IMultiNodeReferenceTrack::GetTrackTypeStatic Method

IMultiNodeReferenceTrack::GetTrackTypeStatic Method
IMultiNodeReferenceTrack Class
Show All
C++
public: static int GetTrackTypeStatic();
Class

IMultiNodeReferenceTrack Class

File

ActionNodeTracks.h

Links
IMultiNodeReferenceTrack Class
Send comments on this topic.


IMultiNodeReferenceTrack::IsActionNodeReferenceNull Method

IMultiNodeReferenceTrack::IsActionNodeReferenceNull Method
IMultiNodeReferenceTrack Class
Show All
C++
public: bool IsActionNodeReferenceNull(
    int idx
);
Class

IMultiNodeReferenceTrack Class

File

ActionNodeTracks.h

Links
IMultiNodeReferenceTrack Class
Send comments on this topic.


IMultiNodeReferenceTrack::IsActionNodeResolved Method (eActionNodeResolveMode)

IMultiNodeReferenceTrack::IsActionNodeResolved Method (eActionNodeResolveMode)
IMultiNodeReferenceTrack Class
Show All
C++
public: virtual bool IsActionNodeResolved(
    eActionNodeResolveMode mode = NODES_ADDED
);
Class

IMultiNodeReferenceTrack Class

File

ActionNodeTracks.h

Links
IMultiNodeReferenceTrack Class
Send comments on this topic.


IMultiNodeReferenceTrack::IsActionNodeResolved Method (int, eActionNodeResolveMode)

IMultiNodeReferenceTrack::IsActionNodeResolved Method (int, eActionNodeResolveMode)
IMultiNodeReferenceTrack Class
Show All
C++
public: bool IsActionNodeResolved(
    int idx,
    eActionNodeResolveMode mode = NODES_ADDED
);
Class

IMultiNodeReferenceTrack Class

File

ActionNodeTracks.h

Links
IMultiNodeReferenceTrack Class
Send comments on this topic.


IMultiNodeReferenceTrack::ResolveReference Method

IMultiNodeReferenceTrack::ResolveReference Method
IMultiNodeReferenceTrack Class
Show All
C++
public: virtual void ResolveReference(
    eActionNodeResolveMode mode
);
Class

IMultiNodeReferenceTrack Class

File

ActionNodeTracks.h

Links
IMultiNodeReferenceTrack Class
Send comments on this topic.


IMultiNodeReferenceTrack::SetActionNode Method

IMultiNodeReferenceTrack::SetActionNode Method
IMultiNodeReferenceTrack Class
Show All
C++
public: virtual void SetActionNode(
    int idx,
    ActionNode* node
);
Class

IMultiNodeReferenceTrack Class

File

ActionNodeTracks.h

Links
IMultiNodeReferenceTrack Class
Send comments on this topic.


IMultiNodeReferenceTrack::SetActionNodeParent Method

IMultiNodeReferenceTrack::SetActionNodeParent Method
IMultiNodeReferenceTrack Class
Show All

Sets the parent for *all* node references.

C++
public: virtual void SetActionNodeParent(
    ActionNode* parent
);
Class

IMultiNodeReferenceTrack Class

File

ActionNodeTracks.h

Links
IMultiNodeReferenceTrack Class
Send comments on this topic.


IMultiNodeReferenceTrack::SetActionNodeReference Method

IMultiNodeReferenceTrack::SetActionNodeReference Method
IMultiNodeReferenceTrack Class
Show All
C++
public: void SetActionNodeReference(
    int idx,
    const char* actionNodePath
);
Class

IMultiNodeReferenceTrack Class

File

ActionNodeTracks.h

Links
IMultiNodeReferenceTrack Class
Send comments on this topic.


IName Class

IName Class
Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
IName
    rage::DataMember
    rage::IArchive
    rage::ITrackFactory
C++
public: class IName;
Destructors
Destructor | Description
~IName |
Methods
Method | Description
GetName |
Namespace

rage Namespace

File

datamember.h

Links
Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


IName::~IName Destructor

IName::~IName Destructor
IName Class
Show All
C++
public: virtual ~IName();
Class

IName Class

File

datamember.h

Links
IName Class
Send comments on this topic.


IName::GetName Method (void)

IName::GetName Method (void)
IName Class
Show All
C++
public: virtual CName* GetName(
    void
) = 0;
Class

IName Class

File

datamember.h

Links
IName Class
Send comments on this topic.


IName::GetName Method (void)

IName::GetName Method (void)
IName Class
Show All
C++
public: virtual const CName* GetName(
    void
) = 0 const;
Class

IName Class

File

datamember.h

Links
IName Class
Send comments on this topic.


INodeReferenceDataMember Class

INodeReferenceDataMember Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        rage::IStringDataMember
            INodeReferenceDataMember
                rage::NodeReferenceDataMember
C++
public: class INodeReferenceDataMember : public IStringDataMember;
Constructors
Constructor | Description
DataMember |
INodeReferenceDataMember |
IStringDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Methods
Method | Description
GetFullPath |
GetName |
GetName |
GetPfGroupActTracks |
GetString |
GetType |
GetType |
GetType |
IsDefault |
IsResolved |
Read |
Read |
SetString |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


INodeReferenceDataMember::INodeReferenceDataMember Constructor

INodeReferenceDataMember::INodeReferenceDataMember Constructor
INodeReferenceDataMember Class
Show All
C++
public: INodeReferenceDataMember(
    const char* name
);
Class

INodeReferenceDataMember Class

File

datamember.h

Links
INodeReferenceDataMember Class
Send comments on this topic.


INodeReferenceDataMember::GetFullPath Method

INodeReferenceDataMember::GetFullPath Method
INodeReferenceDataMember Class
Show All
C++
public: virtual const char* GetFullPath(
    IDataMembers* dm
) = 0;
Class

INodeReferenceDataMember Class

File

datamember.h

Links
INodeReferenceDataMember Class
Send comments on this topic.


INodeReferenceDataMember::GetType Method

INodeReferenceDataMember::GetType Method
INodeReferenceDataMember Class
Show All
C++
public: virtual TYPE GetType(
    void
);
Class

INodeReferenceDataMember Class

File

datamember.h

Links
INodeReferenceDataMember Class
Send comments on this topic.


INodeReferenceDataMember::IsResolved Method

INodeReferenceDataMember::IsResolved Method
INodeReferenceDataMember Class
Show All
C++
public: virtual bool IsResolved(
    IDataMembers* dm
) = 0;
Class

INodeReferenceDataMember Class

File

datamember.h

Links
INodeReferenceDataMember Class
Send comments on this topic.


INodeReferenceTrack Class

INodeReferenceTrack Class
Structs | Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Track
                INodeReferenceTrack
                    rage::IMultiNodeReferenceTrack
                    rage::NodeReferenceTrack
C++
public: class INodeReferenceTrack : public Track;
Structs
Struct | Description
Timer |
Constructors
Constructor | Description
IDataMembers |
INodeReferenceTrack |
Track |
TrackOrCondition |
Destructors
Destructor | Description
~IDataMembers |
~Track |
Methods
Method | Description
Break |
Create |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeResolved |
NewTask |
Read |
Reset |
ResetTimers |
ResolveReference |
SetActionNodeParent |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
UpdateFrame |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |
Namespace

rage Namespace

File

ActionNodeTracks.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


INodeReferenceTrack::INodeReferenceTrack Constructor ()

INodeReferenceTrack::INodeReferenceTrack Constructor ()
INodeReferenceTrack Class
Show All
C++
public: INodeReferenceTrack();
Class

INodeReferenceTrack Class

File

ActionNodeTracks.h

Links
INodeReferenceTrack Class
Send comments on this topic.


INodeReferenceTrack::INodeReferenceTrack Constructor (datResource&)

INodeReferenceTrack::INodeReferenceTrack Constructor (datResource&)
INodeReferenceTrack Class
Show All
C++
public: INodeReferenceTrack(
    datResource& r
);
Class

INodeReferenceTrack Class

File

ActionNodeTracks.h

Links
INodeReferenceTrack Class
Send comments on this topic.


INodeReferenceTrack::GetTrackType Method

INodeReferenceTrack::GetTrackType Method
INodeReferenceTrack Class
Show All

2 = INodeReferenceTrack (to eliminate the need for dynamic_cast

C++
public: virtual int GetTrackType() const;
Class

INodeReferenceTrack Class

File

ActionNodeTracks.h

Links
INodeReferenceTrack Class
Send comments on this topic.


INodeReferenceTrack::GetTrackTypeStatic Method

INodeReferenceTrack::GetTrackTypeStatic Method
INodeReferenceTrack Class
Show All
C++
public: static int GetTrackTypeStatic();
Class

INodeReferenceTrack Class

File

ActionNodeTracks.h

Links
INodeReferenceTrack Class
Send comments on this topic.


INodeReferenceTrack::IsActionNodeResolved Method

INodeReferenceTrack::IsActionNodeResolved Method
INodeReferenceTrack Class
Show All
C++
public: virtual bool IsActionNodeResolved(
    eActionNodeResolveMode mode
) = 0;
Class

INodeReferenceTrack Class

File

ActionNodeTracks.h

Links
INodeReferenceTrack Class
Send comments on this topic.


INodeReferenceTrack::ResolveReference Method

INodeReferenceTrack::ResolveReference Method
INodeReferenceTrack Class
Show All
C++
public: virtual void ResolveReference(
    eActionNodeResolveMode mode
) = 0;
Class

INodeReferenceTrack Class

File

ActionNodeTracks.h

Links
INodeReferenceTrack Class
Send comments on this topic.


INodeReferenceTrack::SetActionNodeParent Method

INodeReferenceTrack::SetActionNodeParent Method
INodeReferenceTrack Class
Show All
C++
public: virtual void SetActionNodeParent(
    ActionNode* parent
) = 0;
Class

INodeReferenceTrack Class

File

ActionNodeTracks.h

Links
INodeReferenceTrack Class
Send comments on this topic.


InstancedActionController Class

InstancedActionController Class
Structs | Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
rage::ActionController
    InstancedActionController
C++
public: class InstancedActionController : public ActionController;
Structs
Struct | Description
refCountingTracks |
Constructors
Constructor | Description
ActionController |
Destructors
Destructor | Description
~ActionController |
~InstancedActionController |
Methods
Method | Description
AddSequncedTrack |
BeginDebugTask |
clearAll |
ClearSequencedTrack |
clearSequencedTracks |
DeleteSequencedTrack |
EndDebugTask |
EndTask |
GetBeginBreakPoint |
GetContext |
GetControlContext |
GetCurrentNodePlayTime |
GetCurrentPlayCount |
GetCurrentPlayingNode |
GetDebug |
GetEndBreakPoint |
GetNumSequencedTracks |
GetPlayHistory |
GetRequestedNode |
GetRunningTaskRoot |
GetSequencedTrack | implement this in the subclasses
GetUpDateBreakPoint |
IsBusy | const ActionNode * GetCurrentSequencedNode(void)const{return(m_SequencedNode); short GetSequencedPriority(void)const{return(m_SequencedPriority);
Play | These deal with ActionNodes so Banks can be sequenced or played The PlayActionNode will search for playable NODE to sequence!
PlayRemote | : used by the mutli-player function to execute remote actions. keeps a signature to prevent multiple plays of same action.
PlayTracks |
RemoveTask |
Sequence |
SetBeginBreakPoint | These are for hooking in BreakPoints on Track/Task instances
SetContext |
SetControlContext | does nothing CONTROL_CONTEXT_ENABLED
SetDebug |
SetEndBreakPoint |
SetRequestedNode |
SetUpDateBreakPoint |
StartSequencedTracks |
Stop |
TRACKMSG |
Update | Normally only update is called
UpdateDebugTask |
UpdateTasks |
UpdateTasksTimeEnd |
UpdateWithKeepAlive |
Data Members
Data Member | Description
m_SequencedTracks |
s_NoOfTaskUpdates |
Namespace

rage Namespace

File

ActionController.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


InstancedActionController::m_SequencedTracks Data Member

InstancedActionController::m_SequencedTracks Data Member
InstancedActionController Class
Show All
C++
protected: rage::atFixedArray<refCountingTracks, MAX_SEQUENCED_TRACKS> m_SequencedTracks;
Class

InstancedActionController Class

File

ActionController.h

Links
InstancedActionController Class
Send comments on this topic.


rage::InstancedActionController::refCountingTracks Struct

rage::InstancedActionController::refCountingTracks Struct
InstancedActionController Class
Show All
C++
private: struct refCountingTracks {
  public: ActionNodeTreePtr m_TreeHandle;
  public: Track* m_Track;
};
Class

InstancedActionController Class

File

ActionController.h

Links
InstancedActionController Class
Send comments on this topic.


InstancedActionController::~InstancedActionController Destructor

InstancedActionController::~InstancedActionController Destructor
InstancedActionController Class
Show All
C++
public: ~InstancedActionController();
Class

InstancedActionController Class

File

ActionController.h

Links
InstancedActionController Class
Send comments on this topic.


InstancedActionController::AddSequncedTrack Method

InstancedActionController::AddSequncedTrack Method
InstancedActionController Class
Show All
C++
protected: virtual void AddSequncedTrack(
    Track* track,
    ActionNodeTreeHandle* NOTTOOL_ONLY(ptr)
);
Class

InstancedActionController Class

File

ActionController.h

Links
InstancedActionController Class
Send comments on this topic.


InstancedActionController::ClearSequencedTrack Method

InstancedActionController::ClearSequencedTrack Method
InstancedActionController Class
Show All
C++
protected: virtual void ClearSequencedTrack(
    int
);
Class

InstancedActionController Class

File

ActionController.h

Links
InstancedActionController Class
Send comments on this topic.


InstancedActionController::clearSequencedTracks Method

InstancedActionController::clearSequencedTracks Method
InstancedActionController Class
Show All
C++
protected: virtual void clearSequencedTracks();
Class

InstancedActionController Class

File

ActionController.h

Links
InstancedActionController Class
Send comments on this topic.


InstancedActionController::DeleteSequencedTrack Method

InstancedActionController::DeleteSequencedTrack Method
InstancedActionController Class
Show All
C++
protected: virtual void DeleteSequencedTrack(
    int i
);
Class

InstancedActionController Class

File

ActionController.h

Links
InstancedActionController Class
Send comments on this topic.


InstancedActionController::GetNumSequencedTracks Method

InstancedActionController::GetNumSequencedTracks Method
InstancedActionController Class
Show All
C++
protected: virtual int GetNumSequencedTracks();
Class

InstancedActionController Class

File

ActionController.h

Links
InstancedActionController Class
Send comments on this topic.


InstancedActionController::GetSequencedTrack Method

InstancedActionController::GetSequencedTrack Method
InstancedActionController Class
Show All

implement this in the subclasses

C++
protected: virtual Track* GetSequencedTrack(
    int i
);
Class

InstancedActionController Class

File

ActionController.h

Links
InstancedActionController Class
Send comments on this topic.


IntDataMember Template

IntDataMember Template
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        rage::IIntDataMember
            IntDataMember
C++
template <class T> public: class IntDataMember : public IIntDataMember;
Constructors
Constructor | Description
DataMember |
IIntDataMember |
IntDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
~IntDataMember |
Methods
Method | Description
GetInt |
GetInt |
GetMinMaxInt | RAW_ACT_FILE_SUPPORT
GetMinMaxInt | RAW_ACT_FILE_SUPPORT
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
IsDefault |
Read |
Read |
SetInt |
SetInt |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


IntDataMember::IntDataMember Constructor

IntDataMember::IntDataMember Constructor
IntDataMember Template
Show All
C++
public: IntDataMember(
    const char* RAW_ACT_FILE_SUPPORT_ONLY(name),
    GetIntMemberFunction getFunc,
    SetIntMemberFunction RAW_ACT_FILE_SUPPORT_ONLY(setFunc),
    GetMinIntMemberFunction getMinFunc = 0,
    GetMaxIntMemberFunction getMaxFunc = 0
);
Template

IntDataMember Template

File

datamember.h

Links
IntDataMember Template
Send comments on this topic.


IntDataMember::~IntDataMember Destructor

IntDataMember::~IntDataMember Destructor
IntDataMember Template
Show All
C++
public: virtual ~IntDataMember();
Template

IntDataMember Template

File

datamember.h

Links
IntDataMember Template
Send comments on this topic.


IntDataMember::GetInt Method

IntDataMember::GetInt Method
IntDataMember Template
Show All
C++
public: virtual int GetInt(
    IDataMembers* dm
);
Template

IntDataMember Template

File

datamember.h

Links
IntDataMember Template
Send comments on this topic.


IntDataMember::GetMinMaxInt Method

IntDataMember::GetMinMaxInt Method
IntDataMember Template
Show All

RAW_ACT_FILE_SUPPORT

C++
public: virtual bool GetMinMaxInt(
    IDataMembers* dm,
    int & rMin,
    int & rMax
);
Template

IntDataMember Template

File

datamember.h

Links
IntDataMember Template
Send comments on this topic.


IntDataMember::IsDefault Method

IntDataMember::IsDefault Method
IntDataMember Template
Show All
C++
public: virtual bool IsDefault(
    IDataMembers* dm
);
Template

IntDataMember Template

File

datamember.h

Links
IntDataMember Template
Send comments on this topic.


IntDataMember::SetInt Method

IntDataMember::SetInt Method
IntDataMember Template
Show All
C++
public: virtual void SetInt(
    IDataMembers* dm,
    int data
);
Template

IntDataMember Template

File

datamember.h

Links
IntDataMember Template
Send comments on this topic.


IObserver Class

IObserver Class
Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
IObserver
C++
public: class IObserver;
Destructors
Destructor | Description
~IObserver | in tool this results in a pure virtual function call
Methods
Method | Description
HandleMessage |
Update |
UpdateDetach |
Namespace

rage Namespace

File

SubjectObserver.h

Links
Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


IObserver::~IObserver Destructor

IObserver::~IObserver Destructor
IObserver Class
Show All

in tool this results in a pure virtual function call

C++
public: virtual ~IObserver();
Class

IObserver Class

File

SubjectObserver.h

Links
IObserver Class
Send comments on this topic.


IObserver::HandleMessage Method

IObserver::HandleMessage Method
IObserver Class
Show All
C++
public: virtual bool HandleMessage(
    CBasicString*
);
Class

IObserver Class

File

SubjectObserver.h

Links
IObserver Class
Send comments on this topic.


IObserver::Update Method

IObserver::Update Method
IObserver Class
Show All
C++
public: virtual void Update(
    CSubject* theChangedSubject
) = 0;
Class

IObserver Class

File

SubjectObserver.h

Links
IObserver Class
Send comments on this topic.


IObserver::UpdateDetach Method

IObserver::UpdateDetach Method
IObserver Class
Show All
C++
public: virtual void UpdateDetach(
    CSubject* theChangedSubject
) = 0;
Class

IObserver Class

File

SubjectObserver.h

Links
IObserver Class
Send comments on this topic.


IStringDataMember Class

IStringDataMember Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        IStringDataMember
            rage::ICommandDataMember
            rage::INodeReferenceDataMember
            rage::StringDataMember
C++
public: class IStringDataMember : public DataMember;
Constructors
Constructor | Description
DataMember |
IStringDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetString |
GetType |
GetType |
IsDefault |
Read |
Read |
SetString |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


IStringDataMember::IStringDataMember Constructor

IStringDataMember::IStringDataMember Constructor
IStringDataMember Class
Show All
C++
public: IStringDataMember(
    const char* name
);
Class

IStringDataMember Class

File

datamember.h

Links
IStringDataMember Class
Send comments on this topic.


IStringDataMember::GetString Method

IStringDataMember::GetString Method
IStringDataMember Class
Show All
C++
public: virtual const char* GetString(
    IDataMembers* dm
) = 0;
Class

IStringDataMember Class

File

datamember.h

Links
IStringDataMember Class
Send comments on this topic.


IStringDataMember::GetType Method

IStringDataMember::GetType Method
IStringDataMember Class
Show All
C++
public: virtual TYPE GetType(
    void
);
Class

IStringDataMember Class

File

datamember.h

Links
IStringDataMember Class
Send comments on this topic.


IStringDataMember::Read Method

IStringDataMember::Read Method
IStringDataMember Class
Show All
C++
public: virtual void Read(
    IDataMembers* dm,
    TextParser& textParser
);
Class

IStringDataMember Class

File

datamember.h

Links
IStringDataMember Class
Send comments on this topic.


IStringDataMember::SetString Method

IStringDataMember::SetString Method
IStringDataMember Class
Show All
C++
public: virtual void SetString(
    IDataMembers* dm,
    const char* data
) = 0;
Class

IStringDataMember Class

File

datamember.h

Links
IStringDataMember Class
Send comments on this topic.


IStringDataMember::Write Method

IStringDataMember::Write Method
IStringDataMember Class
Show All
C++
public: virtual void Write(
    IDataMembers* dm,
    TextBuffer& textBuff
);
Class

IStringDataMember Class

File

datamember.h

Links
IStringDataMember Class
Send comments on this topic.


ITrackFactory Class

ITrackFactory Class
Constructors | Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    ITrackFactory
        rage::TrackFactory
C++
public: class ITrackFactory : public IName;
Constructors
Constructor | Description
ITrackFactory |
Destructors
Destructor | Description
~IName |
~ITrackFactory |
Methods
Method | Description
GetName |
GetRorcChecksum |
GetTrackType |
NewTrack |
Place |
SetTypeId | RAW_ACT_FILE_SUPPORT
Namespace

rage Namespace

File

Tracks.h

Links
Constructors, Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


ITrackFactory::ITrackFactory Constructor

ITrackFactory::ITrackFactory Constructor
ITrackFactory Class
Show All
C++
public: ITrackFactory(
    char*
);
Class

ITrackFactory Class

File

Tracks.h

Links
ITrackFactory Class
Send comments on this topic.


ITrackFactory::~ITrackFactory Destructor

ITrackFactory::~ITrackFactory Destructor
ITrackFactory Class
Show All
C++
public: virtual ~ITrackFactory();
Class

ITrackFactory Class

File

Tracks.h

Links
ITrackFactory Class
Send comments on this topic.


ITrackFactory::GetRorcChecksum Method

ITrackFactory::GetRorcChecksum Method
ITrackFactory Class
Show All
C++
public: virtual int GetRorcChecksum() = 0 const;
Class

ITrackFactory Class

File

Tracks.h

Links
ITrackFactory Class
Send comments on this topic.


ITrackFactory::GetTrackType Method

ITrackFactory::GetTrackType Method
ITrackFactory Class
Show All
C++
public: virtual int GetTrackType() = 0;
Class

ITrackFactory Class

File

Tracks.h

Links
ITrackFactory Class
Send comments on this topic.


ITrackFactory::NewTrack Method

ITrackFactory::NewTrack Method
ITrackFactory Class
Show All
C++
public: virtual TrackOrCondition* NewTrack(
    void
) = 0;
Class

ITrackFactory Class

File

Tracks.h

Links
ITrackFactory Class
Send comments on this topic.


ITrackFactory::Place Method

ITrackFactory::Place Method
ITrackFactory Class
Show All
C++
public: virtual void Place(
    TrackOrCondition* pNode,
    datResource& r
) = 0;
Class

ITrackFactory Class

File

Tracks.h

Links
ITrackFactory Class
Send comments on this topic.


ITrackFactory::SetTypeId Method

ITrackFactory::SetTypeId Method
ITrackFactory Class
Show All

RAW_ACT_FILE_SUPPORT

C++
public: virtual void SetTypeId(
    int id
) = 0;
Class

ITrackFactory Class

File

Tracks.h

Links
ITrackFactory Class
Send comments on this topic.


IVector2DataMember Class

IVector2DataMember Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        IVector2DataMember
            rage::Vector2DataMember
C++
public: class IVector2DataMember : public DataMember;
Constructors
Constructor | Description
DataMember |
IVector2DataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetVector2 |
IsDefault |
Read |
Read |
SetVector2 |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


IVector2DataMember::IVector2DataMember Constructor

IVector2DataMember::IVector2DataMember Constructor
IVector2DataMember Class
Show All
C++
public: IVector2DataMember(
    const char * name
);
Class

IVector2DataMember Class

File

datamember.h

Links
IVector2DataMember Class
Send comments on this topic.


IVector2DataMember::GetVector2 Method

IVector2DataMember::GetVector2 Method
IVector2DataMember Class
Show All
C++
public: virtual void GetVector2(
    IDataMembers* dm,
    rage::Vector2 & outV2
) = 0;
Class

IVector2DataMember Class

File

datamember.h

Links
IVector2DataMember Class
Send comments on this topic.


IVector2DataMember::Read Method

IVector2DataMember::Read Method
IVector2DataMember Class
Show All
C++
public: virtual void Read(
    IDataMembers* dm,
    TextParser& textParser
);
Class

IVector2DataMember Class

File

datamember.h

Links
IVector2DataMember Class
Send comments on this topic.


IVector2DataMember::SetVector2 Method

IVector2DataMember::SetVector2 Method
IVector2DataMember Class
Show All
C++
public: virtual void SetVector2(
    IDataMembers* dm,
    const rage::Vector2 & v2
) = 0;
Class

IVector2DataMember Class

File

datamember.h

Links
IVector2DataMember Class
Send comments on this topic.


IVector2DataMember::Write Method

IVector2DataMember::Write Method
IVector2DataMember Class
Show All
C++
public: virtual void Write(
    IDataMembers* dm,
    TextBuffer& textBuff
);
Class

IVector2DataMember Class

File

datamember.h

Links
IVector2DataMember Class
Send comments on this topic.


IVector3DataMember Class

IVector3DataMember Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        IVector3DataMember
            rage::Vector3DataMember
C++
public: class IVector3DataMember : public DataMember;
Constructors
Constructor | Description
DataMember |
IVector3DataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetVector3 |
IsDefault |
Read |
Read |
SetVector3 |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


IVector3DataMember::IVector3DataMember Constructor

IVector3DataMember::IVector3DataMember Constructor
IVector3DataMember Class
Show All
C++
public: IVector3DataMember(
    const char * name
);
Class

IVector3DataMember Class

File

datamember.h

Links
IVector3DataMember Class
Send comments on this topic.


IVector3DataMember::GetVector3 Method

IVector3DataMember::GetVector3 Method
IVector3DataMember Class
Show All
C++
public: virtual void GetVector3(
    IDataMembers* dm,
    rage::Vector3 & outV3
) = 0;
Class

IVector3DataMember Class

File

datamember.h

Links
IVector3DataMember Class
Send comments on this topic.


IVector3DataMember::Read Method

IVector3DataMember::Read Method
IVector3DataMember Class
Show All
C++
public: virtual void Read(
    IDataMembers* dm,
    TextParser& textParser
);
Class

IVector3DataMember Class

File

datamember.h

Links
IVector3DataMember Class
Send comments on this topic.


IVector3DataMember::SetVector3 Method

IVector3DataMember::SetVector3 Method
IVector3DataMember Class
Show All
C++
public: virtual void SetVector3(
    IDataMembers* dm,
    const rage::Vector3 & v3
) = 0;
Class

IVector3DataMember Class

File

datamember.h

Links
IVector3DataMember Class
Send comments on this topic.


IVector3DataMember::Write Method

IVector3DataMember::Write Method
IVector3DataMember Class
Show All
C++
public: virtual void Write(
    IDataMembers* dm,
    TextBuffer& textBuff
);
Class

IVector3DataMember Class

File

datamember.h

Links
IVector3DataMember Class
Send comments on this topic.


NodeReferenceDataMember Template

NodeReferenceDataMember Template
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        rage::IStringDataMember
            rage::INodeReferenceDataMember
                NodeReferenceDataMember
C++
template <class T> public: class NodeReferenceDataMember : public INodeReferenceDataMember;
Constructors
Constructor | Description
DataMember |
INodeReferenceDataMember |
IStringDataMember |
NodeReferenceDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
~NodeReferenceDataMember |
Methods
Method | Description
GetFullPath |
GetFullPath | RAW_ACT_FILE_SUPPORT
GetName |
GetName |
GetPfGroupActTracks |
GetString |
GetString |
GetType |
GetType |
GetType |
IsDefault |
IsDefault |
IsResolved |
IsResolved |
Read |
Read |
SetString |
SetString |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


NodeReferenceDataMember::NodeReferenceDataMember Constructor

NodeReferenceDataMember::NodeReferenceDataMember Constructor
NodeReferenceDataMember Template
Show All
C++
public: NodeReferenceDataMember(
    const char* name,
    GetStringMemberFunction getFunc,
    SetStringMemberFunction setFunc,
    GetStringMemberFunction getFullPathFunc,
    GetBoolMemberFunction isResolved
);
Template

NodeReferenceDataMember Template

File

datamember.h

Links
NodeReferenceDataMember Template
Send comments on this topic.


NodeReferenceDataMember::~NodeReferenceDataMember Destructor

NodeReferenceDataMember::~NodeReferenceDataMember Destructor
NodeReferenceDataMember Template
Show All
C++
public: virtual ~NodeReferenceDataMember();
Template

NodeReferenceDataMember Template

File

datamember.h

Links
NodeReferenceDataMember Template
Send comments on this topic.


NodeReferenceDataMember::GetFullPath Method

NodeReferenceDataMember::GetFullPath Method
NodeReferenceDataMember Template
Show All

RAW_ACT_FILE_SUPPORT

C++
public: virtual const char* GetFullPath(
    IDataMembers* dm
);
Template

NodeReferenceDataMember Template

File

datamember.h

Links
NodeReferenceDataMember Template
Send comments on this topic.


NodeReferenceDataMember::GetString Method

NodeReferenceDataMember::GetString Method
NodeReferenceDataMember Template
Show All
C++
public: virtual const char* GetString(
    IDataMembers* dm
);
Template

NodeReferenceDataMember Template

File

datamember.h

Links
NodeReferenceDataMember Template
Send comments on this topic.


NodeReferenceDataMember::IsDefault Method

NodeReferenceDataMember::IsDefault Method
NodeReferenceDataMember Template
Show All
C++
public: virtual bool IsDefault(
    IDataMembers * dm
);
Template

NodeReferenceDataMember Template

File

datamember.h

Links
NodeReferenceDataMember Template
Send comments on this topic.


NodeReferenceDataMember::IsResolved Method

NodeReferenceDataMember::IsResolved Method
NodeReferenceDataMember Template
Show All
C++
public: virtual bool IsResolved(
    IDataMembers* dm
);
Template

NodeReferenceDataMember Template

File

datamember.h

Links
NodeReferenceDataMember Template
Send comments on this topic.


NodeReferenceDataMember::SetString Method

NodeReferenceDataMember::SetString Method
NodeReferenceDataMember Template
Show All
C++
public: virtual void SetString(
    IDataMembers* dm,
    const char* data
);
Template

NodeReferenceDataMember Template

File

datamember.h

Links
NodeReferenceDataMember Template
Send comments on this topic.


NodeReferenceTrack Class

NodeReferenceTrack Class
Structs | Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Track
                rage::INodeReferenceTrack
                    NodeReferenceTrack
                        rage::ExecuteTrack
                        rage::OpportunityTrack
                        rage::SequenceTrack
                        rage::SpawnTrack
C++
public: class NodeReferenceTrack : public INodeReferenceTrack;
Structs
Struct | Description
Timer |
Constructors
Constructor | Description
IDataMembers |
INodeReferenceTrack |
NodeReferenceTrack |
Track |
TrackOrCondition |
Destructors
Destructor | Description
~IDataMembers |
~NodeReferenceTrack |
~Track |
Methods
Method | Description
Break |
Create |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
Read |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent |
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
UpdateFrame |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ActionNodeRef |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |
Namespace

rage Namespace

File

ActionNodeTracks.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


NodeReferenceTrack::m_ActionNodeRef Data Member

NodeReferenceTrack::m_ActionNodeRef Data Member
NodeReferenceTrack Class
Show All
C++
protected: ActionNodeLwRef m_ActionNodeRef;
Class

NodeReferenceTrack Class

File

ActionNodeTracks.h

Links
NodeReferenceTrack Class
Send comments on this topic.


NodeReferenceTrack::NodeReferenceTrack Constructor ()

NodeReferenceTrack::NodeReferenceTrack Constructor ()
NodeReferenceTrack Class
Show All
C++
public: NodeReferenceTrack();
Class

NodeReferenceTrack Class

File

ActionNodeTracks.h

Links
NodeReferenceTrack Class
Send comments on this topic.


NodeReferenceTrack::NodeReferenceTrack Constructor (datResource&)

NodeReferenceTrack::NodeReferenceTrack Constructor (datResource&)
NodeReferenceTrack Class
Show All
C++
public: NodeReferenceTrack(
    datResource& r
);
Class

NodeReferenceTrack Class

File

ActionNodeTracks.h

Links
NodeReferenceTrack Class
Send comments on this topic.


NodeReferenceTrack::~NodeReferenceTrack Destructor

NodeReferenceTrack::~NodeReferenceTrack Destructor
NodeReferenceTrack Class
Show All
C++
public: virtual ~NodeReferenceTrack();
Class

NodeReferenceTrack Class

File

ActionNodeTracks.h

Links
NodeReferenceTrack Class
Send comments on this topic.


NodeReferenceTrack::DeclareStruct Method

NodeReferenceTrack::DeclareStruct Method
NodeReferenceTrack Class
Show All
C++
public: void DeclareStruct(
    datTypeStruct & s
);
Class

NodeReferenceTrack Class

File

ActionNodeTracks.h

Links
NodeReferenceTrack Class
Send comments on this topic.


NodeReferenceTrack::GetActionNode Method

NodeReferenceTrack::GetActionNode Method
NodeReferenceTrack Class
Show All
C++
public: ActionNode* GetActionNode(
    void
);
Class

NodeReferenceTrack Class

File

ActionNodeTracks.h

Links
NodeReferenceTrack Class
Send comments on this topic.


NodeReferenceTrack::GetActionNodeReference Method

NodeReferenceTrack::GetActionNodeReference Method
NodeReferenceTrack Class
Show All
C++
public: const char* GetActionNodeReference(
    void
);
Class

NodeReferenceTrack Class

File

ActionNodeTracks.h

Links
NodeReferenceTrack Class
Send comments on this topic.


NodeReferenceTrack::GetActionNodeReferenceFullPath Method

NodeReferenceTrack::GetActionNodeReferenceFullPath Method
NodeReferenceTrack Class
Show All
C++
public: const char* GetActionNodeReferenceFullPath(
    void
);
Class

NodeReferenceTrack Class

File

ActionNodeTracks.h

Links
NodeReferenceTrack Class
Send comments on this topic.


NodeReferenceTrack::IsActionNodeReferenceNull Method

NodeReferenceTrack::IsActionNodeReferenceNull Method
NodeReferenceTrack Class
Show All
C++
public: bool IsActionNodeReferenceNull();
Class

NodeReferenceTrack Class

File

ActionNodeTracks.h

Links
NodeReferenceTrack Class
Send comments on this topic.


NodeReferenceTrack::IsActionNodeResolved Method ()

NodeReferenceTrack::IsActionNodeResolved Method ()
NodeReferenceTrack Class
Show All
C++
public: virtual bool IsActionNodeResolved();
Class

NodeReferenceTrack Class

File

ActionNodeTracks.h

Links
NodeReferenceTrack Class
Send comments on this topic.


NodeReferenceTrack::IsActionNodeResolved Method (eActionNodeResolveMode)

NodeReferenceTrack::IsActionNodeResolved Method (eActionNodeResolveMode)
NodeReferenceTrack Class
Show All
C++
public: virtual bool IsActionNodeResolved(
    eActionNodeResolveMode mode
);
Class

NodeReferenceTrack Class

File

ActionNodeTracks.h

Links
NodeReferenceTrack Class
Send comments on this topic.


NodeReferenceTrack::ResolveReference Method

NodeReferenceTrack::ResolveReference Method
NodeReferenceTrack Class
Show All
C++
public: virtual void ResolveReference(
    eActionNodeResolveMode mode
);
Class

NodeReferenceTrack Class

File

ActionNodeTracks.h

Links
NodeReferenceTrack Class
Send comments on this topic.


NodeReferenceTrack::SetActionNode Method

NodeReferenceTrack::SetActionNode Method
NodeReferenceTrack Class
Show All
C++
public: virtual void SetActionNode(
    ActionNode* node
);
Class

NodeReferenceTrack Class

File

ActionNodeTracks.h

Links
NodeReferenceTrack Class
Send comments on this topic.


NodeReferenceTrack::SetActionNodeParent Method

NodeReferenceTrack::SetActionNodeParent Method
NodeReferenceTrack Class
Show All
C++
public: virtual void SetActionNodeParent(
    ActionNode* parent
);
Class

NodeReferenceTrack Class

File

ActionNodeTracks.h

Links
NodeReferenceTrack Class
Send comments on this topic.


NodeReferenceTrack::SetActionNodeReference Method

NodeReferenceTrack::SetActionNodeReference Method
NodeReferenceTrack Class
Show All
C++
public: void SetActionNodeReference(
    const char* actionNodePath
);
Class

NodeReferenceTrack Class

File

ActionNodeTracks.h

Links
NodeReferenceTrack Class
Send comments on this topic.


OpportunityRandomLatchTask Class

OpportunityRandomLatchTask Class
Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All

OpportunityRandomLatchTask

rage::ATask
    rage::OpportunityTask
        OpportunityRandomLatchTask
C++
public: class OpportunityRandomLatchTask : public OpportunityTask;
Constructors
Constructor | Description
ATask |
OpportunityRandomLatchTask |
OpportunityTask |
Destructors
Destructor | Description
~ATask |
~OpportunityRandomLatchTask |
~OpportunityTask |
Methods
Method | Description
AcquireLatchTime | allow latch time to be overridden, to allow for "OpportunityRandomLatch
AcquireLatchTime | allow latch time to be overridden, to allow for "OpportunityRandomLatch
Begin |
Begin |
End |
End |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
GetTrack |
Update |
Update |
Data Members
Data Member | Description
m_AlreadyBreaked |
m_Context |
m_Latched |
m_latchedPlayable |
m_LatchTime | acquired latch time. Just grabbed from track in the superclass.
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted
Namespace

rage Namespace

File

CoreTask.h

Links
Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


OpportunityRandomLatchTask::OpportunityRandomLatchTask Constructor

OpportunityRandomLatchTask::OpportunityRandomLatchTask Constructor
OpportunityRandomLatchTask Class
Show All
C++
public: OpportunityRandomLatchTask(
    ActionContext * context,
    OpportunityRandomLatchTrack* track
);
Class

OpportunityRandomLatchTask Class

File

CoreTask.h

Links
OpportunityRandomLatchTask Class
Send comments on this topic.


OpportunityRandomLatchTask::~OpportunityRandomLatchTask Destructor

OpportunityRandomLatchTask::~OpportunityRandomLatchTask Destructor
OpportunityRandomLatchTask Class
Show All
C++
public: virtual ~OpportunityRandomLatchTask();
Class

OpportunityRandomLatchTask Class

File

CoreTask.h

Links
OpportunityRandomLatchTask Class
Send comments on this topic.


OpportunityRandomLatchTask::AcquireLatchTime Method

OpportunityRandomLatchTask::AcquireLatchTime Method
OpportunityRandomLatchTask Class
Show All

allow latch time to be overridden, to allow for "OpportunityRandomLatch

C++
public: virtual void AcquireLatchTime();
Class

OpportunityRandomLatchTask Class

File

CoreTask.h

Links
OpportunityRandomLatchTask Class
Send comments on this topic.


OpportunityRandomLatchTask::GetTrack Method

OpportunityRandomLatchTask::GetTrack Method
OpportunityRandomLatchTask Class
Show All
C++
public: virtual Track* GetTrack();
Class

OpportunityRandomLatchTask Class

File

CoreTask.h

Links
OpportunityRandomLatchTask Class
Send comments on this topic.


OpportunityRandomLatchTrack Class

OpportunityRandomLatchTrack Class
Structs | Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All

OpportunityRandomLatchTrack

rage::IDataMembers
        rage::TrackOrCondition
            rage::Track
                rage::INodeReferenceTrack
                    rage::NodeReferenceTrack
                        rage::OpportunityTrack
                            OpportunityRandomLatchTrack
C++
public: class OpportunityRandomLatchTrack : public OpportunityTrack;
Structs
Struct | Description
Timer |
Constructors
Constructor | Description
IDataMembers |
INodeReferenceTrack |
NodeReferenceTrack |
OpportunityRandomLatchTrack |
OpportunityTrack |
Track |
TrackOrCondition |
Destructors
Destructor | Description
~IDataMembers |
~NodeReferenceTrack |
~OpportunityRandomLatchTrack |
~OpportunityTrack |
~Track |
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup | In order to have a local ConditionGroup
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
NewTask |
NewTask |
Read |
ReadConditionGroup |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent |
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
TRACK_MEMBER |
TRACK_PADDING |
TRACK_PARAMETER |
TRACK_PARAMETER |
UpdateFrame |
Write |
Write | lint !e1735
WriteCondition |
Data Members
Data Member | Description
m_ActionNodeRef |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |
Namespace

rage Namespace

File

ActionNodeTracks.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


OpportunityRandomLatchTrack::OpportunityRandomLatchTrack Constructor

OpportunityRandomLatchTrack::OpportunityRandomLatchTrack Constructor
OpportunityRandomLatchTrack Class
Show All
C++
public: OpportunityRandomLatchTrack();
Class

OpportunityRandomLatchTrack Class

File

ActionNodeTracks.h

Links
OpportunityRandomLatchTrack Class
Send comments on this topic.


OpportunityRandomLatchTrack::~OpportunityRandomLatchTrack Destructor

OpportunityRandomLatchTrack::~OpportunityRandomLatchTrack Destructor
OpportunityRandomLatchTrack Class
Show All
C++
public: virtual ~OpportunityRandomLatchTrack();
Class

OpportunityRandomLatchTrack Class

File

ActionNodeTracks.h

Links
OpportunityRandomLatchTrack Class
Send comments on this topic.


OpportunityRandomLatchTrack::DATAMEMEBERS_INTERFACE Method

OpportunityRandomLatchTrack::DATAMEMEBERS_INTERFACE Method
OpportunityRandomLatchTrack Class
Show All
C++
public: DATAMEMEBERS_INTERFACE(
    OpportunityRandomLatchTrack
);
Class

OpportunityRandomLatchTrack Class

File

ActionNodeTracks.h

Links
OpportunityRandomLatchTrack Class
Send comments on this topic.


OpportunityRandomLatchTrack::NewTask Method

OpportunityRandomLatchTrack::NewTask Method
OpportunityRandomLatchTrack Class
Show All
C++
public: ATask * NewTask(
    ActionContext * context
);
Class

OpportunityRandomLatchTrack Class

File

ActionNodeTracks.h

Links
OpportunityRandomLatchTrack Class
Send comments on this topic.


OpportunityRandomLatchTrack::TRACK_PADDING Method

OpportunityRandomLatchTrack::TRACK_PADDING Method
OpportunityRandomLatchTrack Class
Show All
C++
public: TRACK_PADDING(
    0,
    4
);
Class

OpportunityRandomLatchTrack Class

File

ActionNodeTracks.h

Links
OpportunityRandomLatchTrack Class
Send comments on this topic.


OpportunityRandomLatchTrack::TRACK_PARAMETER Method

OpportunityRandomLatchTrack::TRACK_PARAMETER Method
OpportunityRandomLatchTrack Class
Show All
C++
public: TRACK_PARAMETER(
    float,
    TimeLatchMax
);
Class

OpportunityRandomLatchTrack Class

File

ActionNodeTracks.h

Links
OpportunityRandomLatchTrack Class
Send comments on this topic.


OpportunityTask Class

OpportunityTask Class
Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
rage::ATask
    OpportunityTask
        rage::OpportunityRandomLatchTask
C++
public: class OpportunityTask : public ATask;
Constructors
Constructor | Description
ATask |
OpportunityTask |
Destructors
Destructor | Description
~ATask |
~OpportunityTask |
Methods
Method | Description
AcquireLatchTime | allow latch time to be overridden, to allow for "OpportunityRandomLatch
Begin |
Begin |
End |
End |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
Update |
Update |
Data Members
Data Member | Description
m_AlreadyBreaked |
m_Context |
m_Latched |
m_latchedPlayable |
m_LatchTime | acquired latch time. Just grabbed from track in the superclass.
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted
Namespace

rage Namespace

File

CoreTask.h

Links
Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


OpportunityTask::m_AlreadyBreaked Data Member

OpportunityTask::m_AlreadyBreaked Data Member
OpportunityTask Class
Show All
C++
protected: bool m_AlreadyBreaked;
Class

OpportunityTask Class

File

CoreTask.h

Links
OpportunityTask Class
Send comments on this topic.


OpportunityTask::m_Context Data Member

OpportunityTask::m_Context Data Member
OpportunityTask Class
Show All
C++
protected: ActionContext* m_Context;
Class

OpportunityTask Class

File

CoreTask.h

Links
OpportunityTask Class
Send comments on this topic.


OpportunityTask::m_Latched Data Member

OpportunityTask::m_Latched Data Member
OpportunityTask Class
Show All
C++
protected: bool m_Latched;
Class

OpportunityTask Class

File

CoreTask.h

Links
OpportunityTask Class
Send comments on this topic.


OpportunityTask::m_latchedPlayable Data Member

OpportunityTask::m_latchedPlayable Data Member
OpportunityTask Class
Show All
C++
protected: ActionNodePlayable* m_latchedPlayable;
Class

OpportunityTask Class

File

CoreTask.h

Links
OpportunityTask Class
Send comments on this topic.


OpportunityTask::m_LatchTime Data Member

OpportunityTask::m_LatchTime Data Member
OpportunityTask Class
Show All

acquired latch time. Just grabbed from track in the superclass.

C++
protected: float m_LatchTime;
Class

OpportunityTask Class

File

CoreTask.h

Links
OpportunityTask Class
Send comments on this topic.


OpportunityTask::OpportunityTask Constructor

OpportunityTask::OpportunityTask Constructor
OpportunityTask Class
Show All
C++
public: OpportunityTask(
    ActionContext* context,
    OpportunityTrack* track
);
Class

OpportunityTask Class

File

CoreTask.h

Links
OpportunityTask Class
Send comments on this topic.


OpportunityTask::~OpportunityTask Destructor

OpportunityTask::~OpportunityTask Destructor
OpportunityTask Class
Show All
C++
public: virtual ~OpportunityTask();
Class

OpportunityTask Class

File

CoreTask.h

Links
OpportunityTask Class
Send comments on this topic.


OpportunityTask::AcquireLatchTime Method

OpportunityTask::AcquireLatchTime Method
OpportunityTask Class
Show All

allow latch time to be overridden, to allow for "OpportunityRandomLatch

C++
protected: virtual void AcquireLatchTime();
Class

OpportunityTask Class

File

CoreTask.h

Links
OpportunityTask Class
Send comments on this topic.


OpportunityTask::Begin Method

OpportunityTask::Begin Method
OpportunityTask Class
Show All
C++
public: virtual bool Begin(
    void
);
Class

OpportunityTask Class

File

CoreTask.h

Links
OpportunityTask Class
Send comments on this topic.


OpportunityTask::End Method

OpportunityTask::End Method
OpportunityTask Class
Show All
C++
public: virtual bool End(
    void
);
Class

OpportunityTask Class

File

CoreTask.h

Links
OpportunityTask Class
Send comments on this topic.


OpportunityTask::GetTrack Method

OpportunityTask::GetTrack Method
OpportunityTask Class
Show All
C++
public: virtual Track* GetTrack(
    void
);
Class

OpportunityTask Class

File

CoreTask.h

Links
OpportunityTask Class
Send comments on this topic.


OpportunityTask::Update Method

OpportunityTask::Update Method
OpportunityTask Class
Show All
C++
public: virtual bool Update(
    float deltaTime
);
Class

OpportunityTask Class

File

CoreTask.h

Links
OpportunityTask Class
Send comments on this topic.


OpportunityTrack Class

OpportunityTrack Class
Structs | Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Track
                rage::INodeReferenceTrack
                    rage::NodeReferenceTrack
                        OpportunityTrack
                            rage::OpportunityRandomLatchTrack
C++
public: class OpportunityTrack : public NodeReferenceTrack;
Structs
Struct | Description
Timer |
Constructors
Constructor | Description
IDataMembers |
INodeReferenceTrack |
NodeReferenceTrack |
OpportunityTrack |
Track |
TrackOrCondition |
Destructors
Destructor | Description
~IDataMembers |
~NodeReferenceTrack |
~OpportunityTrack |
~Track |
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup | In order to have a local ConditionGroup
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
NewTask |
Read |
ReadConditionGroup |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent |
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
TRACK_MEMBER |
TRACK_PARAMETER |
UpdateFrame |
Write |
Write | lint !e1735
WriteCondition |
Data Members
Data Member | Description
m_ActionNodeRef |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |
Namespace

rage Namespace

File

ActionNodeTracks.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


OpportunityTrack::OpportunityTrack Constructor

OpportunityTrack::OpportunityTrack Constructor
OpportunityTrack Class
Show All
C++
public: OpportunityTrack();
Class

OpportunityTrack Class

File

ActionNodeTracks.h

Links
OpportunityTrack Class
Send comments on this topic.


OpportunityTrack::~OpportunityTrack Destructor

OpportunityTrack::~OpportunityTrack Destructor
OpportunityTrack Class
Show All
C++
public: virtual ~OpportunityTrack();
Class

OpportunityTrack Class

File

ActionNodeTracks.h

Links
OpportunityTrack Class
Send comments on this topic.


OpportunityTrack::AddCondition Method (TextParser&)

OpportunityTrack::AddCondition Method (TextParser&)
OpportunityTrack Class
Show All
C++
public: virtual IDataMembers* AddCondition(
    TextParser& textParser
);
Class

OpportunityTrack Class

File

ActionNodeTracks.h

Links
OpportunityTrack Class
Send comments on this topic.


OpportunityTrack::AddCondition Method (const char*)

OpportunityTrack::AddCondition Method (const char*)
OpportunityTrack Class
Show All
C++
public: virtual IDataMembers* AddCondition(
    const char* conditionFormat
);
Class

OpportunityTrack Class

File

ActionNodeTracks.h

Links
OpportunityTrack Class
Send comments on this topic.


OpportunityTrack::ChangeConditionPriority Method

OpportunityTrack::ChangeConditionPriority Method
OpportunityTrack Class
Show All
C++
public: virtual void ChangeConditionPriority(
    int conditionIndex,
    bool increase
);
Class

OpportunityTrack Class

File

ActionNodeTracks.h

Links
OpportunityTrack Class
Send comments on this topic.


OpportunityTrack::DATAMEMEBERS_INTERFACE Method

OpportunityTrack::DATAMEMEBERS_INTERFACE Method
OpportunityTrack Class
Show All
C++
public: DATAMEMEBERS_INTERFACE(
    OpportunityTrack
);
Class

OpportunityTrack Class

File

ActionNodeTracks.h

Links
OpportunityTrack Class
Send comments on this topic.


OpportunityTrack::DeleteCondition Method

OpportunityTrack::DeleteCondition Method
OpportunityTrack Class
Show All
C++
public: virtual bool DeleteCondition(
    IDataMembers * pConditionToDelete
);
Class

OpportunityTrack Class

File

ActionNodeTracks.h

Links
OpportunityTrack Class
Send comments on this topic.


OpportunityTrack::GetCondition Method

OpportunityTrack::GetCondition Method
OpportunityTrack Class
Show All
C++
public: virtual IDataMembers* GetCondition(
    int conditionIndex
);
Class

OpportunityTrack Class

File

ActionNodeTracks.h

Links
OpportunityTrack Class
Send comments on this topic.


OpportunityTrack::GetConditionCount Method

OpportunityTrack::GetConditionCount Method
OpportunityTrack Class
Show All
C++
public: virtual int GetConditionCount(
    void
);
Class

OpportunityTrack Class

File

ActionNodeTracks.h

Links
OpportunityTrack Class
Send comments on this topic.


OpportunityTrack::GetConditionFormat Method

OpportunityTrack::GetConditionFormat Method
OpportunityTrack Class
Show All
C++
public: virtual const char* GetConditionFormat(
    int conditionIndex
);
Class

OpportunityTrack Class

File

ActionNodeTracks.h

Links
OpportunityTrack Class
Send comments on this topic.


OpportunityTrack::GetConditionGroup Method

OpportunityTrack::GetConditionGroup Method
OpportunityTrack Class
Show All

In order to have a local ConditionGroup

C++
public: ConditionGroup* GetConditionGroup(
    void
);
Class

OpportunityTrack Class

File

ActionNodeTracks.h

Links
OpportunityTrack Class
Send comments on this topic.


OpportunityTrack::NewTask Method

OpportunityTrack::NewTask Method
OpportunityTrack Class
Show All
C++
public: virtual ATask* NewTask(
    ActionContext* context
);
Class

OpportunityTrack Class

File

ActionNodeTracks.h

Links
OpportunityTrack Class
Send comments on this topic.


OpportunityTrack::ReadConditionGroup Method

OpportunityTrack::ReadConditionGroup Method
OpportunityTrack Class
Show All
C++
public: virtual void ReadConditionGroup(
    TextParser& textParser
);
Class

OpportunityTrack Class

File

ActionNodeTracks.h

Links
OpportunityTrack Class
Send comments on this topic.


OpportunityTrack::TRACK_MEMBER Method

OpportunityTrack::TRACK_MEMBER Method
OpportunityTrack Class
Show All
C++
public: TRACK_MEMBER(
    ConditionGroup,
    Conditions
);
Class

OpportunityTrack Class

File

ActionNodeTracks.h

Links
OpportunityTrack Class
Send comments on this topic.


OpportunityTrack::TRACK_PARAMETER Method (bool, Recycle)

OpportunityTrack::TRACK_PARAMETER Method (bool, Recycle)
OpportunityTrack Class
Show All
C++
public: TRACK_PARAMETER(
    bool,
    Recycle
);
Class

OpportunityTrack Class

File

ActionNodeTracks.h

Links
OpportunityTrack Class
Send comments on this topic.


OpportunityTrack::TRACK_PARAMETER Method (float, TimeLatch)

OpportunityTrack::TRACK_PARAMETER Method (float, TimeLatch)
OpportunityTrack Class
Show All
C++
public: TRACK_PARAMETER(
    float,
    TimeLatch
);
Class

OpportunityTrack Class

File

ActionNodeTracks.h

Links
OpportunityTrack Class
Send comments on this topic.


OpportunityTrack::WriteCondition Method

OpportunityTrack::WriteCondition Method
OpportunityTrack Class
Show All
C++
public: virtual void WriteCondition(
    int conditionIndex,
    TextBuffer& textBuff
);
Class

OpportunityTrack Class

File

ActionNodeTracks.h

Links
OpportunityTrack Class
Send comments on this topic.


PrintTask Class

PrintTask Class
Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
rage::ATask
    PrintTask
C++
public: class PrintTask : public ATask;
Constructors
Constructor | Description
ATask |
PrintTask |
Destructors
Destructor | Description
~ATask |
~PrintTask |
Methods
Method | Description
Begin |
Begin | PrintTask
End |
End |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
Update |
Update |
Data Members
Data Member | Description
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted
Namespace

rage Namespace

File

CoreTask.h

Links
Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


PrintTask::PrintTask Constructor

PrintTask::PrintTask Constructor
PrintTask Class
Show All
C++
public: PrintTask(
    ActionContext* context,
    PrintTrack* track
);
Class

PrintTask Class

File

CoreTask.h

Links
PrintTask Class
Send comments on this topic.


PrintTask::~PrintTask Destructor

PrintTask::~PrintTask Destructor
PrintTask Class
Show All
C++
public: virtual ~PrintTask();
Class

PrintTask Class

File

CoreTask.h

Links
PrintTask Class
Send comments on this topic.


PrintTask::Begin Method

PrintTask::Begin Method
PrintTask Class
Show All

PrintTask

C++
public: virtual bool Begin(
    void
);
Class

PrintTask Class

File

CoreTask.h

Links
PrintTask Class
Send comments on this topic.


PrintTask::End Method

PrintTask::End Method
PrintTask Class
Show All
C++
public: virtual bool End(
    void
);
Class

PrintTask Class

File

CoreTask.h

Links
PrintTask Class
Send comments on this topic.


PrintTask::GetTrack Method

PrintTask::GetTrack Method
PrintTask Class
Show All
C++
public: virtual Track* GetTrack(
    void
);
Class

PrintTask Class

File

CoreTask.h

Links
PrintTask Class
Send comments on this topic.


PrintTask::Update Method

PrintTask::Update Method
PrintTask Class
Show All
C++
public: virtual bool Update(
    float deltaTime
);
Class

PrintTask Class

File

CoreTask.h

Links
PrintTask Class
Send comments on this topic.


PrintTrack Class

PrintTrack Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Track
                PrintTrack
C++
public: class PrintTrack : public Track;
Structs
Struct | Description
Timer |
Constructors
Constructor | Description
IDataMembers |
PrintTrack |
Track |
TrackOrCondition |
Destructors
Destructor | Description
~IDataMembers |
~PrintTrack |
~Track |
Methods
Method | Description
AddWidgets |
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetText |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
NewTask |
NewTask |
Read |
Reset |
ResetTimers |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetText |
SetTimeBegin |
SetTimeEnd |
ShouldPrint |
TimerStart |
TimerStop |
TRACK_MEMBER |
TRACK_PARAMETER |
TRACK_PARAMETER_ENUM |
UpdateFrame |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_PrintChannelEnabled |
sm_TimerPool |
Enumerations
Enumeration | Description
PrintChannels | keep in sync with ConditionPrint::PrintChannels
Namespace

rage Namespace

File

ActionNodeTracks.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


PrintTrack::sm_PrintChannelEnabled Data Member

PrintTrack::sm_PrintChannelEnabled Data Member
PrintTrack Class
Show All
C++
public: static bool sm_PrintChannelEnabled[NUM_PRINT_CHANNELS];
Class

PrintTrack Class

File

ActionNodeTracks.h

Links
PrintTrack Class
Send comments on this topic.


PrintTrack::PrintTrack Constructor

PrintTrack::PrintTrack Constructor
PrintTrack Class
Show All
C++
public: PrintTrack();
Class

PrintTrack Class

File

ActionNodeTracks.h

Links
PrintTrack Class
Send comments on this topic.


PrintTrack::~PrintTrack Destructor

PrintTrack::~PrintTrack Destructor
PrintTrack Class
Show All
C++
public: virtual ~PrintTrack();
Class

PrintTrack Class

File

ActionNodeTracks.h

Links
PrintTrack Class
Send comments on this topic.


PrintTrack::AddWidgets Method

PrintTrack::AddWidgets Method
PrintTrack Class
Show All
C++
public: static void AddWidgets(
    bkBank& bank
);
Class

PrintTrack Class

File

ActionNodeTracks.h

Links
PrintTrack Class
Send comments on this topic.


PrintTrack::DATAMEMEBERS_INTERFACE Method

PrintTrack::DATAMEMEBERS_INTERFACE Method
PrintTrack Class
Show All
C++
public: DATAMEMEBERS_INTERFACE(
    PrintTrack
);
Class

PrintTrack Class

File

ActionNodeTracks.h

Links
PrintTrack Class
Send comments on this topic.


PrintTrack::GetText Method

PrintTrack::GetText Method
PrintTrack Class
Show All
C++
public: const char* GetText(
    void
);
Class

PrintTrack Class

File

ActionNodeTracks.h

Links
PrintTrack Class
Send comments on this topic.


PrintTrack::NewTask Method

PrintTrack::NewTask Method
PrintTrack Class
Show All
C++
public: virtual ATask* NewTask(
    ActionContext* context
);
Class

PrintTrack Class

File

ActionNodeTracks.h

Links
PrintTrack Class
Send comments on this topic.


PrintTrack::SetText Method

PrintTrack::SetText Method
PrintTrack Class
Show All
C++
public: void SetText(
    const char* newString
);
Class

PrintTrack Class

File

ActionNodeTracks.h

Links
PrintTrack Class
Send comments on this topic.


PrintTrack::ShouldPrint Method

PrintTrack::ShouldPrint Method
PrintTrack Class
Show All
C++
public: static bool ShouldPrint(
    int filter
);
Class

PrintTrack Class

File

ActionNodeTracks.h

Links
PrintTrack Class
Send comments on this topic.


PrintTrack::TRACK_MEMBER Method

PrintTrack::TRACK_MEMBER Method
PrintTrack Class
Show All
C++
public: TRACK_MEMBER(
    char*,
    string
);
Class

PrintTrack Class

File

ActionNodeTracks.h

Links
PrintTrack Class
Send comments on this topic.


PrintTrack::TRACK_PARAMETER Method

PrintTrack::TRACK_PARAMETER Method
PrintTrack Class
Show All
C++
public: TRACK_PARAMETER(
    bool,
    OnUpdate
);
Class

PrintTrack Class

File

ActionNodeTracks.h

Links
PrintTrack Class
Send comments on this topic.


PrintTrack::TRACK_PARAMETER_ENUM Method

PrintTrack::TRACK_PARAMETER_ENUM Method
PrintTrack Class
Show All
C++
public: TRACK_PARAMETER_ENUM(
    PrintChannels,
    PrintChannel
);
Class

PrintTrack Class

File

ActionNodeTracks.h

Links
PrintTrack Class
Send comments on this topic.


rage::PrintTrack::PrintChannels Enumeration

rage::PrintTrack::PrintChannels Enumeration
PrintTrack Class
Show All

keep in sync with ConditionPrint::PrintChannels

C++
public: enum PrintChannels {
  public: CHANNEL_SPEWDRV,
  public: CHANNEL_NM_DEBUG,
  public: CHANNEL_MISC_A,
  public: CHANNEL_MISC_B,
  public: NUM_PRINT_CHANNELS
};
Class

PrintTrack Class

File

ActionNodeTracks.h

Links
PrintTrack Class
Send comments on this topic.


SequenceTask Class

SequenceTask Class
Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
rage::ATask
    SequenceTask
C++
public: class SequenceTask : public ATask;
Constructors
Constructor | Description
ATask |
SequenceTask |
Destructors
Destructor | Description
~ATask |
~SequenceTask |
Methods
Method | Description
Begin |
End |
End |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
Update |
Data Members
Data Member | Description
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted
Namespace

rage Namespace

File

CoreTask.h

Links
Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


SequenceTask::SequenceTask Constructor

SequenceTask::SequenceTask Constructor
SequenceTask Class
Show All
C++
public: SequenceTask(
    ActionContext* context,
    SequenceTrack* track
);
Class

SequenceTask Class

File

CoreTask.h

Links
SequenceTask Class
Send comments on this topic.


SequenceTask::~SequenceTask Destructor

SequenceTask::~SequenceTask Destructor
SequenceTask Class
Show All
C++
public: virtual ~SequenceTask();
Class

SequenceTask Class

File

CoreTask.h

Links
SequenceTask Class
Send comments on this topic.


SequenceTask::End Method

SequenceTask::End Method
SequenceTask Class
Show All
C++
public: virtual bool End(
    void
);
Class

SequenceTask Class

File

CoreTask.h

Links
SequenceTask Class
Send comments on this topic.


SequenceTask::GetTrack Method

SequenceTask::GetTrack Method
SequenceTask Class
Show All
C++
public: virtual Track* GetTrack(
    void
);
Class

SequenceTask Class

File

CoreTask.h

Links
SequenceTask Class
Send comments on this topic.


SequenceTrack Class

SequenceTrack Class
Structs | Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Track
                rage::INodeReferenceTrack
                    rage::NodeReferenceTrack
                        SequenceTrack
C++
public: class SequenceTrack : public NodeReferenceTrack;
Structs
Struct | Description
Timer |
Constructors
Constructor | Description
IDataMembers |
INodeReferenceTrack |
NodeReferenceTrack |
SequenceTrack |
Track |
TrackOrCondition |
Destructors
Destructor | Description
~IDataMembers |
~NodeReferenceTrack |
~SequenceTrack |
~Track |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
NewTask |
Read |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent |
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
UpdateFrame |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ActionNodeRef |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |
Namespace

rage Namespace

File

ActionNodeTracks.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


SequenceTrack::SequenceTrack Constructor

SequenceTrack::SequenceTrack Constructor
SequenceTrack Class
Show All
C++
public: SequenceTrack();
Class

SequenceTrack Class

File

ActionNodeTracks.h

Links
SequenceTrack Class
Send comments on this topic.


SequenceTrack::~SequenceTrack Destructor

SequenceTrack::~SequenceTrack Destructor
SequenceTrack Class
Show All
C++
public: virtual ~SequenceTrack();
Class

SequenceTrack Class

File

ActionNodeTracks.h

Links
SequenceTrack Class
Send comments on this topic.


SequenceTrack::DATAMEMEBERS_INTERFACE Method

SequenceTrack::DATAMEMEBERS_INTERFACE Method
SequenceTrack Class
Show All
C++
public: DATAMEMEBERS_INTERFACE(
    SequenceTrack
);
Class

SequenceTrack Class

File

ActionNodeTracks.h

Links
SequenceTrack Class
Send comments on this topic.


SequenceTrack::NewTask Method

SequenceTrack::NewTask Method
SequenceTrack Class
Show All
C++
public: ATask* NewTask(
    ActionContext* context
);
Class

SequenceTrack Class

File

ActionNodeTracks.h

Links
SequenceTrack Class
Send comments on this topic.


SpawnActionController Class

SpawnActionController Class
Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All

this makes the big assumption that spawn tracks are inside nodes that would already be referenced counted through other mechanisms

rage::ActionController
    SpawnActionController
C++
public: class SpawnActionController : public ActionController;
Constructors
Constructor | Description
ActionController |
Destructors
Destructor | Description
~ActionController |
~SpawnActionController |
Methods
Method | Description
AddSequncedTrack |
BeginDebugTask |
clearAll |
clearSequencedTracks |
DeleteSequencedTrack |
EndDebugTask |
EndTask |
GetBeginBreakPoint |
GetContext |
GetControlContext |
GetCurrentNodePlayTime |
GetCurrentPlayCount |
GetCurrentPlayingNode |
GetDebug |
GetEndBreakPoint |
GetNumSequencedTracks |
GetPlayHistory |
GetRequestedNode |
GetRunningTaskRoot |
GetSequencedTrack | implement this in the subclasses
GetUpDateBreakPoint |
IsBusy | const ActionNode * GetCurrentSequencedNode(void)const{return(m_SequencedNode); short GetSequencedPriority(void)const{return(m_SequencedPriority);
Play | These deal with ActionNodes so Banks can be sequenced or played The PlayActionNode will search for playable NODE to sequence!
PlayRemote | : used by the mutli-player function to execute remote actions. keeps a signature to prevent multiple plays of same action.
PlayTracks |
RemoveTask |
Sequence |
SetBeginBreakPoint | These are for hooking in BreakPoints on Track/Task instances
SetContext |
SetControlContext | does nothing CONTROL_CONTEXT_ENABLED
SetDebug |
SetEndBreakPoint |
SetRequestedNode |
SetUpDateBreakPoint |
StartSequencedTracks |
Stop |
TRACKMSG |
Update | Normally only update is called
UpdateDebugTask |
UpdateTasks |
UpdateTasksTimeEnd |
UpdateWithKeepAlive |
Data Members
Data Member | Description
m_SequencedTracks |
s_NoOfTaskUpdates |
Namespace

rage Namespace

File

ActionController.h

Links
Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


SpawnActionController::m_SequencedTracks Data Member

SpawnActionController::m_SequencedTracks Data Member
SpawnActionController Class
Show All
C++
protected: rage::atFixedArray<Track*, MAX_SEQUENCED_TRACKS> m_SequencedTracks;
Class

SpawnActionController Class

File

ActionController.h

Links
SpawnActionController Class
Send comments on this topic.


SpawnActionController::~SpawnActionController Destructor

SpawnActionController::~SpawnActionController Destructor
SpawnActionController Class
Show All
C++
public: ~SpawnActionController();
Class

SpawnActionController Class

File

ActionController.h

Links
SpawnActionController Class
Send comments on this topic.


SpawnActionController::AddSequncedTrack Method

SpawnActionController::AddSequncedTrack Method
SpawnActionController Class
Show All
C++
protected: virtual void AddSequncedTrack(
    Track* track,
    ActionNodeTreeHandle*
);
Class

SpawnActionController Class

File

ActionController.h

Links
SpawnActionController Class
Send comments on this topic.


SpawnActionController::clearSequencedTracks Method

SpawnActionController::clearSequencedTracks Method
SpawnActionController Class
Show All
C++
protected: virtual void clearSequencedTracks();
Class

SpawnActionController Class

File

ActionController.h

Links
SpawnActionController Class
Send comments on this topic.


SpawnActionController::DeleteSequencedTrack Method

SpawnActionController::DeleteSequencedTrack Method
SpawnActionController Class
Show All
C++
protected: virtual void DeleteSequencedTrack(
    int i
);
Class

SpawnActionController Class

File

ActionController.h

Links
SpawnActionController Class
Send comments on this topic.


SpawnActionController::GetNumSequencedTracks Method

SpawnActionController::GetNumSequencedTracks Method
SpawnActionController Class
Show All
C++
protected: virtual int GetNumSequencedTracks();
Class

SpawnActionController Class

File

ActionController.h

Links
SpawnActionController Class
Send comments on this topic.


SpawnActionController::GetSequencedTrack Method

SpawnActionController::GetSequencedTrack Method
SpawnActionController Class
Show All

implement this in the subclasses

C++
protected: virtual Track* GetSequencedTrack(
    int i
);
Class

SpawnActionController Class

File

ActionController.h

Links
SpawnActionController Class
Send comments on this topic.


SpawnTask Class

SpawnTask Class
Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
rage::ATask
    SpawnTask
C++
public: class SpawnTask : public ATask;
Constructors
Constructor | Description
ATask |
SpawnTask | SpawnTask
Destructors
Destructor | Description
~ATask |
~SpawnTask |
Methods
Method | Description
Begin |
Begin |
End |
End |
GetActionController |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
Update |
Update |
Data Members
Data Member | Description
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted
Namespace

rage Namespace

File

CoreTask.h

Links
Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


SpawnTask::SpawnTask Constructor

SpawnTask::SpawnTask Constructor
SpawnTask Class
Show All

SpawnTask

C++
public: SpawnTask(
    ActionContext* context,
    SpawnTrack* track
);
Class

SpawnTask Class

File

CoreTask.h

Links
SpawnTask Class
Send comments on this topic.


SpawnTask::~SpawnTask Destructor

SpawnTask::~SpawnTask Destructor
SpawnTask Class
Show All
C++
public: virtual ~SpawnTask();
Class

SpawnTask Class

File

CoreTask.h

Links
SpawnTask Class
Send comments on this topic.


SpawnTask::Begin Method

SpawnTask::Begin Method
SpawnTask Class
Show All
C++
public: virtual bool Begin(
    void
);
Class

SpawnTask Class

File

CoreTask.h

Links
SpawnTask Class
Send comments on this topic.


SpawnTask::End Method

SpawnTask::End Method
SpawnTask Class
Show All
C++
public: virtual bool End(
    void
);
Class

SpawnTask Class

File

CoreTask.h

Links
SpawnTask Class
Send comments on this topic.


SpawnTask::GetActionController Method ()

SpawnTask::GetActionController Method ()
SpawnTask Class
Show All
C++
public: virtual ActionController* GetActionController();
Class

SpawnTask Class

File

CoreTask.h

Links
SpawnTask Class
Send comments on this topic.


SpawnTask::GetActionController Method ()

SpawnTask::GetActionController Method ()
SpawnTask Class
Show All
C++
public: virtual const ActionController* GetActionController() const;
Class

SpawnTask Class

File

CoreTask.h

Links
SpawnTask Class
Send comments on this topic.


SpawnTask::GetTrack Method

SpawnTask::GetTrack Method
SpawnTask Class
Show All
C++
public: virtual Track* GetTrack(
    void
);
Class

SpawnTask Class

File

CoreTask.h

Links
SpawnTask Class
Send comments on this topic.


SpawnTask::Update Method

SpawnTask::Update Method
SpawnTask Class
Show All
C++
public: virtual bool Update(
    float deltaTime
);
Class

SpawnTask Class

File

CoreTask.h

Links
SpawnTask Class
Send comments on this topic.


SpawnTrack Class

SpawnTrack Class
Structs | Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            rage::Track
                rage::INodeReferenceTrack
                    rage::NodeReferenceTrack
                        SpawnTrack
C++
public: class SpawnTrack : public NodeReferenceTrack;
Structs
Struct | Description
Timer |
Constructors
Constructor | Description
IDataMembers |
INodeReferenceTrack |
NodeReferenceTrack |
SpawnTrack |
Track |
TrackOrCondition |
Destructors
Destructor | Description
~IDataMembers |
~NodeReferenceTrack |
~SpawnTrack |
~Track |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
NewTask |
Read |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent |
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
TRACK_PARAMETER |
UpdateFrame |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ActionNodeRef |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |
Namespace

rage Namespace

File

ActionNodeTracks.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


SpawnTrack::SpawnTrack Constructor

SpawnTrack::SpawnTrack Constructor
SpawnTrack Class
Show All
C++
public: SpawnTrack();
Class

SpawnTrack Class

File

ActionNodeTracks.h

Links
SpawnTrack Class
Send comments on this topic.


SpawnTrack::~SpawnTrack Destructor

SpawnTrack::~SpawnTrack Destructor
SpawnTrack Class
Show All
C++
public: virtual ~SpawnTrack();
Class

SpawnTrack Class

File

ActionNodeTracks.h

Links
SpawnTrack Class
Send comments on this topic.


SpawnTrack::DATAMEMEBERS_INTERFACE Method

SpawnTrack::DATAMEMEBERS_INTERFACE Method
SpawnTrack Class
Show All
C++
public: DATAMEMEBERS_INTERFACE(
    SpawnTrack
);
Class

SpawnTrack Class

File

ActionNodeTracks.h

Links
SpawnTrack Class
Send comments on this topic.


SpawnTrack::NewTask Method

SpawnTrack::NewTask Method
SpawnTrack Class
Show All
C++
public: virtual ATask* NewTask(
    ActionContext* context
);
Class

SpawnTrack Class

File

ActionNodeTracks.h

Links
SpawnTrack Class
Send comments on this topic.


SpawnTrack::TRACK_PARAMETER Method

SpawnTrack::TRACK_PARAMETER Method
SpawnTrack Class
Show All
C++
public: TRACK_PARAMETER(
    bool,
    KeepAlive
);
Class

SpawnTrack Class

File

ActionNodeTracks.h

Links
SpawnTrack Class
Send comments on this topic.


StringDataMember Template

StringDataMember Template
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        rage::IStringDataMember
            StringDataMember
C++
template <class T> public: class StringDataMember : public IStringDataMember;
Constructors
Constructor | Description
DataMember |
IStringDataMember |
StringDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
~StringDataMember |
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetString |
GetString |
GetType |
GetType |
IsDefault |
IsDefault |
Read |
Read |
SetString |
SetString |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


StringDataMember::StringDataMember Constructor

StringDataMember::StringDataMember Constructor
StringDataMember Template
Show All
C++
public: StringDataMember(
    const char* RAW_ACT_FILE_SUPPORT_ONLY(name),
    GetStringMemberFunction getFunc,
    SetStringMemberFunction RAW_ACT_FILE_SUPPORT_ONLY(setFunc)
);
Template

StringDataMember Template

File

datamember.h

Links
StringDataMember Template
Send comments on this topic.


StringDataMember::~StringDataMember Destructor

StringDataMember::~StringDataMember Destructor
StringDataMember Template
Show All
C++
public: virtual ~StringDataMember();
Template

StringDataMember Template

File

datamember.h

Links
StringDataMember Template
Send comments on this topic.


StringDataMember::GetString Method

StringDataMember::GetString Method
StringDataMember Template
Show All
C++
public: virtual const char* GetString(
    IDataMembers* dm
);
Template

StringDataMember Template

File

datamember.h

Links
StringDataMember Template
Send comments on this topic.


StringDataMember::IsDefault Method

StringDataMember::IsDefault Method
StringDataMember Template
Show All
C++
public: virtual bool IsDefault(
    IDataMembers * dm
);
Template

StringDataMember Template

File

datamember.h

Links
StringDataMember Template
Send comments on this topic.


StringDataMember::SetString Method

StringDataMember::SetString Method
StringDataMember Template
Show All
C++
public: virtual void SetString(
    IDataMembers* dm,
    const char* data
);
Template

StringDataMember Template

File

datamember.h

Links
StringDataMember Template
Send comments on this topic.


StubTask Class

StubTask Class
Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
rage::ATask
    StubTask
C++
public: class StubTask : public ATask;
Constructors
Constructor | Description
ATask |
StubTask |
Destructors
Destructor | Description
~ATask |
~StubTask |
Methods
Method | Description
Begin |
Begin |
End |
End |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
Update |
Update |
Data Members
Data Member | Description
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted
Namespace

rage Namespace

File

CoreTask.h

Links
Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


StubTask::StubTask Constructor

StubTask::StubTask Constructor
StubTask Class
Show All
C++
public: StubTask(
    Track* track
);
Class

StubTask Class

File

CoreTask.h

Links
StubTask Class
Send comments on this topic.


StubTask::~StubTask Destructor

StubTask::~StubTask Destructor
StubTask Class
Show All
C++
public: virtual ~StubTask();
Class

StubTask Class

File

CoreTask.h

Links
StubTask Class
Send comments on this topic.


StubTask::Begin Method

StubTask::Begin Method
StubTask Class
Show All
C++
public: virtual bool Begin(
    void
);
Class

StubTask Class

File

CoreTask.h

Links
StubTask Class
Send comments on this topic.


StubTask::End Method

StubTask::End Method
StubTask Class
Show All
C++
public: virtual bool End(
    void
);
Class

StubTask Class

File

CoreTask.h

Links
StubTask Class
Send comments on this topic.


StubTask::GetTrack Method

StubTask::GetTrack Method
StubTask Class
Show All
C++
public: virtual Track* GetTrack(
    void
);
Class

StubTask Class

File

CoreTask.h

Links
StubTask Class
Send comments on this topic.


StubTask::Update Method

StubTask::Update Method
StubTask Class
Show All
C++
public: virtual bool Update(
    float
);
Class

StubTask Class

File

CoreTask.h

Links
StubTask Class
Send comments on this topic.


TaskSizeCompileTimeAssert Template

TaskSizeCompileTimeAssert Template
Constructors | Members | rage Namespace | Inheritance Hierarchy
Show All

Class template to facilitate size checking

TaskSizeCompileTimeAssert
C++
template <class TaskClass> public: class TaskSizeCompileTimeAssert;
Constructors
Constructor | Description
TaskSizeCompileTimeAssert |
Namespace

rage Namespace

File

Tracks.h

Links
Constructors, Members, rage Namespace, Inheritance Hierarchy


TaskSizeCompileTimeAssert::TaskSizeCompileTimeAssert Constructor

TaskSizeCompileTimeAssert::TaskSizeCompileTimeAssert Constructor
TaskSizeCompileTimeAssert Template
Show All
C++
public: TaskSizeCompileTimeAssert();
Template

TaskSizeCompileTimeAssert Template

File

Tracks.h

Links
TaskSizeCompileTimeAssert Template
Send comments on this topic.


TaskSizeCompileTimeAssert<SpawnTask> Template

TaskSizeCompileTimeAssert<SpawnTask> Template
Members | Methods | rage Namespace | Inheritance Hierarchy
Show All

Special case for Spawn, because this sucker's massive.

TaskSizeCompileTimeAssert<SpawnTask>
C++
template <> public: class TaskSizeCompileTimeAssert<SpawnTask>;
Methods
Method | Description
TaskSizeCompileTimeAssert |
Namespace

rage Namespace

File

Tracks.cpp

Links
Members, Methods, rage Namespace, Inheritance Hierarchy


TaskSizeCompileTimeAssert<SpawnTask>::TaskSizeCompileTimeAssert Method

TaskSizeCompileTimeAssert<SpawnTask>::TaskSizeCompileTimeAssert Method
TaskSizeCompileTimeAssert<SpawnTask> Template
Show All
C++
public: TaskSizeCompileTimeAssert();
Template

TaskSizeCompileTimeAssert<SpawnTask> Template

File

Tracks.cpp

Links
TaskSizeCompileTimeAssert<SpawnTask> Template


TextBuffer Class

TextBuffer Class
Constructors | Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
TextBuffer
C++
public: class TextBuffer;
Constructors
Constructor | Description
TextBuffer |
Destructors
Destructor | Description
~TextBuffer |
Methods
Method | Description
AddNewLine |
DecreaseIndent |
GetBuffer |
GetWrittenLength |
IncreaseIndent |
Reset |
Write |
Namespace

rage Namespace

File

TextParser.h

Links
Constructors, Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


TextBuffer::TextBuffer Constructor

TextBuffer::TextBuffer Constructor
TextBuffer Class
Show All
C++
public: TextBuffer(
    int initialSize
);
Class

TextBuffer Class

File

TextParser.h

Links
TextBuffer Class
Send comments on this topic.


TextBuffer::~TextBuffer Destructor

TextBuffer::~TextBuffer Destructor
TextBuffer Class
Show All
C++
public: ~TextBuffer();
Class

TextBuffer Class

File

TextParser.h

Links
TextBuffer Class
Send comments on this topic.


TextBuffer::AddNewLine Method

TextBuffer::AddNewLine Method
TextBuffer Class
Show All
C++
public: void AddNewLine();
Class

TextBuffer Class

File

TextParser.h

Links
TextBuffer Class
Send comments on this topic.


TextBuffer::DecreaseIndent Method

TextBuffer::DecreaseIndent Method
TextBuffer Class
Show All
C++
public: void DecreaseIndent();
Class

TextBuffer Class

File

TextParser.h

Links
TextBuffer Class
Send comments on this topic.


TextBuffer::GetBuffer Method

TextBuffer::GetBuffer Method
TextBuffer Class
Show All
C++
public: const char* GetBuffer(
    void
);
Class

TextBuffer Class

File

TextParser.h

Links
TextBuffer Class
Send comments on this topic.


TextBuffer::GetWrittenLength Method

TextBuffer::GetWrittenLength Method
TextBuffer Class
Show All
C++
public: int GetWrittenLength();
Class

TextBuffer Class

File

TextParser.h

Links
TextBuffer Class
Send comments on this topic.


TextBuffer::IncreaseIndent Method

TextBuffer::IncreaseIndent Method
TextBuffer Class
Show All
C++
public: void IncreaseIndent();
Class

TextBuffer Class

File

TextParser.h

Links
TextBuffer Class
Send comments on this topic.


TextBuffer::Reset Method

TextBuffer::Reset Method
TextBuffer Class
Show All
C++
public: void Reset(
    void
);
Class

TextBuffer Class

File

TextParser.h

Links
TextBuffer Class
Send comments on this topic.


TextBuffer::Write Method (const char*)

TextBuffer::Write Method (const char*)
TextBuffer Class
Show All
C++
public: void Write(
    const char* string
);
Class

TextBuffer Class

File

TextParser.h

Links
TextBuffer Class
Send comments on this topic.


TextBuffer::Write Method (const char*, const char*, const char)

TextBuffer::Write Method (const char*, const char*, const char)
TextBuffer Class
Show All
C++
public: void Write(
    const char* name,
    const char* value,
    const char separator = '\t'
);
Class

TextBuffer Class

File

TextParser.h

Links
TextBuffer Class
Send comments on this topic.


TextBuffer::Write Method (const char*, float, const char)

TextBuffer::Write Method (const char*, float, const char)
TextBuffer Class
Show All
C++
public: void Write(
    const char* name,
    float value,
    const char separator = '\t'
);
Class

TextBuffer Class

File

TextParser.h

Links
TextBuffer Class
Send comments on this topic.


TextBuffer::Write Method (const char*, int, const char)

TextBuffer::Write Method (const char*, int, const char)
TextBuffer Class
Show All
C++
public: void Write(
    const char* name,
    int value,
    const char separator = '\t'
);
Class

TextBuffer Class

File

TextParser.h

Links
TextBuffer Class
Send comments on this topic.


TextBuffer::Write Method (float)

TextBuffer::Write Method (float)
TextBuffer Class
Show All
C++
public: void Write(
    float value
);
Class

TextBuffer Class

File

TextParser.h

Links
TextBuffer Class
Send comments on this topic.


TextBuffer::Write Method (int)

TextBuffer::Write Method (int)
TextBuffer Class
Show All
C++
public: void Write(
    int value
);
Class

TextBuffer Class

File

TextParser.h

Links
TextBuffer Class
Send comments on this topic.


TextParser Class

TextParser Class
Constructors | Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
TextParser
C++
public: class TextParser;
Constructors
Constructor | Description
TextParser | Create a text parser that can be used to move over a string as a stream of tokens. The seperators string is NOT copied, and is usually expected to be a string constant ala "\/ "
Destructors
Destructor | Description
~TextParser |
Methods
Method | Description
AddvanceToToken |
advanceToQuote |
EndOfText |
GetCurrentReadPosition |
GetNextToken |
GetQuotedString | Parse a quoted string into the given buffer; return true on success, false if the buffer was too small.
GetTokenAsFloat |
GetTokenAsInt |
GetTokenString | Return the next token in the given buffer; return true on success, false if the buffer was too small.
IsParsingFile |
MatchCurrentToken |
MatchCurrentTokenCaseInsensitive |
NeedToSpecialParseQuotedString |
PopReadPosition |
PushReadPosition |
SetCurrentReadPosition |
Namespace

rage Namespace

File

TextParser.h

Links
Constructors, Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


TextParser::TextParser Constructor (const char*, char*)

TextParser::TextParser Constructor (const char*, char*)
TextParser Class
Show All

Create a text parser that can be used to move over a string as a stream of tokens. The seperators string is NOT copied, and is usually expected to be a string constant ala "\/ "

C++
public: TextParser(
    const char* Text,
    char* separators
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::TextParser Constructor (rage::fiStream*, char*)

TextParser::TextParser Constructor (rage::fiStream*, char*)
TextParser Class
Show All
C++
public: TextParser(
    rage::fiStream* Stream,
    char* separators
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::~TextParser Destructor

TextParser::~TextParser Destructor
TextParser Class
Show All
C++
public: ~TextParser();
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::AddvanceToToken Method

TextParser::AddvanceToToken Method
TextParser Class
Show All
C++
public: void AddvanceToToken(
    const char* token
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::advanceToQuote Method

TextParser::advanceToQuote Method
TextParser Class
Show All
C++
public: void advanceToQuote(
    void
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::EndOfText Method

TextParser::EndOfText Method
TextParser Class
Show All
C++
public: bool EndOfText(
    void
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::GetCurrentReadPosition Method

TextParser::GetCurrentReadPosition Method
TextParser Class
Show All
C++
public: const char* GetCurrentReadPosition(
    void
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::GetNextToken Method

TextParser::GetNextToken Method
TextParser Class
Show All
C++
public: void GetNextToken(
    void
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::GetQuotedString Method (char *, size_t)

TextParser::GetQuotedString Method (char *, size_t)
TextParser Class
Show All

Parse a quoted string into the given buffer; return true on success, false if the buffer was too small.

C++
public: bool GetQuotedString(
    char * buffer,
    size_t bufferSize
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::GetQuotedString Method (void)

TextParser::GetQuotedString Method (void)
TextParser Class
Show All
C++
public: const char* GetQuotedString(
    void
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::GetTokenAsFloat Method

TextParser::GetTokenAsFloat Method
TextParser Class
Show All
C++
public: float GetTokenAsFloat(
    void
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::GetTokenAsInt Method

TextParser::GetTokenAsInt Method
TextParser Class
Show All
C++
public: int GetTokenAsInt(
    void
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::GetTokenString Method (char *, size_t)

TextParser::GetTokenString Method (char *, size_t)
TextParser Class
Show All

Return the next token in the given buffer; return true on success, false if the buffer was too small.

C++
public: bool GetTokenString(
    char * buffer,
    size_t bufferSize
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::GetTokenString Method (void)

TextParser::GetTokenString Method (void)
TextParser Class
Show All
C++
public: const char* GetTokenString(
    void
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::IsParsingFile Method

TextParser::IsParsingFile Method
TextParser Class
Show All
C++
public: bool IsParsingFile(
    void
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::MatchCurrentToken Method (const char*)

TextParser::MatchCurrentToken Method (const char*)
TextParser Class
Show All
C++
public: bool MatchCurrentToken(
    const char* token
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::MatchCurrentToken Method (const char*, bool)

TextParser::MatchCurrentToken Method (const char*, bool)
TextParser Class
Show All
C++
public: bool MatchCurrentToken(
    const char* token,
    bool consume
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::MatchCurrentTokenCaseInsensitive Method

TextParser::MatchCurrentTokenCaseInsensitive Method
TextParser Class
Show All
C++
public: bool MatchCurrentTokenCaseInsensitive(
    const char* token
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::NeedToSpecialParseQuotedString Method

TextParser::NeedToSpecialParseQuotedString Method
TextParser Class
Show All
C++
public: bool NeedToSpecialParseQuotedString();
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::PopReadPosition Method

TextParser::PopReadPosition Method
TextParser Class
Show All
C++
public: void PopReadPosition(
    void
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::PushReadPosition Method

TextParser::PushReadPosition Method
TextParser Class
Show All
C++
public: void PushReadPosition(
    void
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


TextParser::SetCurrentReadPosition Method

TextParser::SetCurrentReadPosition Method
TextParser Class
Show All
C++
public: void SetCurrentReadPosition(
    const char* pos
);
Class

TextParser Class

File

TextParser.h

Links
TextParser Class
Send comments on this topic.


Track Class

Track Class
Structs | Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        rage::TrackOrCondition
            Track
                rage::INodeReferenceTrack
                rage::PrintTrack
C++
public: class Track : public TrackOrCondition;
Structs
Struct | Description
Timer |
Constructors
Constructor | Description
IDataMembers |
Track |
TrackOrCondition |
Destructors
Destructor | Description
~IDataMembers |
~Track |
Methods
Method | Description
Break |
Create |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
NewTask |
Read |
Reset |
ResetTimers |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
UpdateFrame |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |
Namespace

rage Namespace

File

Tracks.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


Track::m_FrameCount Data Member

Track::m_FrameCount Data Member
Track Class
Show All
C++
public: static int m_FrameCount;
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::m_Master Data Member

Track::m_Master Data Member
Track Class
Show All
C++
protected: bool m_Master;
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::m_Pad Data Member

Track::m_Pad Data Member
Track Class
Show All
C++
protected: rage::datPadding<1> m_Pad;
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::m_TimeBegin Data Member

Track::m_TimeBegin Data Member
Track Class
Show All
C++
protected: float m_TimeBegin;
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::m_TimeEnd Data Member

Track::m_TimeEnd Data Member
Track Class
Show All
C++
protected: float m_TimeEnd;
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::m_TimerId Data Member

Track::m_TimerId Data Member
Track Class
Show All
C++
protected: rage::u16 m_TimerId;
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::RORC_VERSION Data Member

Track::RORC_VERSION Data Member
Track Class
Show All

Don't forget to bump this whenever a RAGE track is added or modified

C++
public: static const int RORC_VERSION = 1;
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::sm_TimerPool Data Member

Track::sm_TimerPool Data Member
Track Class
Show All
C++
public: static atStaticPool<Timer, 65535> sm_TimerPool;
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::Timer Struct

Track::Timer Struct
Members | Methods | Data Members | Track Class | Inheritance Hierarchy
Show All
Track::Timer
C++
public: struct Timer {
  public: int m_Count[3];
  public: utimer_t m_Time[3];
  public: utimer_t m_StartTime;
};
Methods
Method | Description
GetAverage |
GetTime |
GetTotal |
Reset |
Start |
Stop |
Data Members
Data Member | Description
m_Count |
m_StartTime |
m_Time |
Class

Track Class

File

Tracks.h

Links
Members, Methods, Data Members, Track Class, Inheritance Hierarchy


Track::Timer::m_Count Data Member

Track::Timer::m_Count Data Member
Track::Timer Struct
Show All
C++
public: int m_Count[3];
Struct

Track::Timer Struct

File

Tracks.h

Links
Track::Timer Struct
Send comments on this topic.


Track::Timer::m_StartTime Data Member

Track::Timer::m_StartTime Data Member
Track::Timer Struct
Show All
C++
public: utimer_t m_StartTime;
Struct

Track::Timer Struct

File

Tracks.h

Links
Track::Timer Struct
Send comments on this topic.


Track::Timer::m_Time Data Member

Track::Timer::m_Time Data Member
Track::Timer Struct
Show All
C++
public: utimer_t m_Time[3];
Struct

Track::Timer Struct

File

Tracks.h

Links
Track::Timer Struct
Send comments on this topic.


Track::Timer::GetAverage Method

Track::Timer::GetAverage Method
Track::Timer Struct
Show All
C++
public: float GetAverage(
    int functionIndex
);
Struct

Track::Timer Struct

File

Tracks.h

Links
Track::Timer Struct
Send comments on this topic.


Track::Timer::GetTime Method

Track::Timer::GetTime Method
Track::Timer Struct
Show All
C++
public: static utimer_t GetTime();
Struct

Track::Timer Struct

File

Tracks.h

Links
Track::Timer Struct
Send comments on this topic.


Track::Timer::GetTotal Method

Track::Timer::GetTotal Method
Track::Timer Struct
Show All
C++
public: float GetTotal(
    int functionIndex
);
Struct

Track::Timer Struct

File

Tracks.h

Links
Track::Timer Struct
Send comments on this topic.


Track::Timer::Reset Method

Track::Timer::Reset Method
Track::Timer Struct
Show All
C++
public: void Reset();
Struct

Track::Timer Struct

File

Tracks.h

Links
Track::Timer Struct
Send comments on this topic.


Track::Timer::Start Method

Track::Timer::Start Method
Track::Timer Struct
Show All
C++
public: void Start();
Struct

Track::Timer Struct

File

Tracks.h

Links
Track::Timer Struct
Send comments on this topic.


Track::Timer::Stop Method

Track::Timer::Stop Method
Track::Timer Struct
Show All
C++
public: void Stop(
    int functionIndex
);
Struct

Track::Timer Struct

File

Tracks.h

Links
Track::Timer Struct
Send comments on this topic.


Track::Track Constructor ()

Track::Track Constructor ()
Track Class
Show All
C++
public: Track();
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::Track Constructor (datResource&)

Track::Track Constructor (datResource&)
Track Class
Show All
C++
public: Track(
    datResource&
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::~Track Destructor

Track::~Track Destructor
Track Class
Show All
C++
public: virtual ~Track();
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::Create Method (TextParser&)

Track::Create Method (TextParser&)
Track Class
Show All
C++
public: static Track* Create(
    TextParser& textParser
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::Create Method (const char*)

Track::Create Method (const char*)
Track Class
Show All
C++
public: static Track* Create(
    const char* trackName
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::DECLARE_PLACE Method

Track::DECLARE_PLACE Method
Track Class
Show All
C++
public: DECLARE_PLACE(
    Track
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::DeclareStruct Method

Track::DeclareStruct Method
Track Class
Show All
C++
public: virtual void DeclareStruct(
    datTypeStruct & s
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::DeInit Method

Track::DeInit Method
Track Class
Show All
C++
public: static void DeInit(
    void
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::GetAverageTime Method

Track::GetAverageTime Method
Track Class
Show All
C++
public: float GetAverageTime(
    int functionIndex
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::GetDuration Method

Track::GetDuration Method
Track Class
Show All
C++
public: float GetDuration(
    void
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::GetFrameCount Method

Track::GetFrameCount Method
Track Class
Show All
C++
public: static int GetFrameCount();
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::GetMaster Method

Track::GetMaster Method
Track Class
Show All

Timing for playback

C++
public: bool GetMaster(
    void
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::GetNumRegistered Method

Track::GetNumRegistered Method
Track Class
Show All
C++
public: static int GetNumRegistered(
    void
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::GetNumTracks Method

Track::GetNumTracks Method
Track Class
Show All
C++
public: static int GetNumTracks();
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::GetPFTimer Method

Track::GetPFTimer Method
Track Class
Show All
C++
public: virtual ::rage::pfTimer* GetPFTimer() = 0;
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::GetRegistered Method

Track::GetRegistered Method
Track Class
Show All
C++
public: static const CName* GetRegistered(
    int index
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::GetRegisteredTrackType Method

Track::GetRegisteredTrackType Method
Track Class
Show All
C++
public: static int GetRegisteredTrackType(
    int index
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::GetTimeBegin Method

Track::GetTimeBegin Method
Track Class
Show All
C++
public: float GetTimeBegin(
    void
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::GetTimeEnd Method

Track::GetTimeEnd Method
Track Class
Show All
C++
public: float GetTimeEnd(
    void
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::GetTimer Method

Track::GetTimer Method
Track Class
Show All
C++
public: Timer& GetTimer() const;
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::GetTotalTime Method

Track::GetTotalTime Method
Track Class
Show All
C++
public: float GetTotalTime(
    int functionIndex
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::GetTrackRegistry Method

Track::GetTrackRegistry Method
Track Class
Show All

Used for games to register their own tracks

C++
public: static TrackRegistry& GetTrackRegistry();
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::GetTrackType Method

Track::GetTrackType Method
Track Class
Show All

1 = Track (to eliminate the need for dynamic_cast

C++
public: virtual int GetTrackType() const;
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::GetTrackTypeStatic Method

Track::GetTrackTypeStatic Method
Track Class
Show All
C++
public: static int GetTrackTypeStatic();
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::Init Method

Track::Init Method
Track Class
Show All
C++
public: static void Init(
    int maxEntries = -1
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::NewTask Method

Track::NewTask Method
Track Class
Show All
C++
public: virtual ATask* NewTask(
    ActionContext* context
) = 0;
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::ResetTimers Method

Track::ResetTimers Method
Track Class
Show All
C++
public: void ResetTimers();
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::SetMaster Method

Track::SetMaster Method
Track Class
Show All
C++
public: void SetMaster(
    bool tf
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::SetTimeBegin Method

Track::SetTimeBegin Method
Track Class
Show All
C++
public: void SetTimeBegin(
    float beginTime
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::SetTimeEnd Method

Track::SetTimeEnd Method
Track Class
Show All
C++
public: void SetTimeEnd(
    float endTime
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::TimerStart Method

Track::TimerStart Method
Track Class
Show All
C++
public: void TimerStart(
    int
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::TimerStop Method

Track::TimerStop Method
Track Class
Show All
C++
public: void TimerStop(
    int functionIndex
);
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


Track::UpdateFrame Method

Track::UpdateFrame Method
Track Class
Show All
C++
public: static void UpdateFrame();
Class

Track Class

File

Tracks.h

Links
Track Class
Send comments on this topic.


TrackFactory Template

TrackFactory Template
Constructors | Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::ITrackFactory
        TrackFactory
C++
template <class T> public: class TrackFactory : public ITrackFactory;
Constructors
Constructor | Description
ITrackFactory |
TrackFactory |
Destructors
Destructor | Description
~IName |
~ITrackFactory |
~TrackFactory |
Methods
Method | Description
GetName |
GetName |
GetRorcChecksum |
GetRorcChecksum |
GetTrackType |
GetTrackType |
NewTrack |
NewTrack |
Place |
Place |
SetTypeId | RAW_ACT_FILE_SUPPORT
SetTypeId | RAW_ACT_FILE_SUPPORT
Namespace

rage Namespace

File

Tracks.h

Links
Constructors, Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


TrackFactory::TrackFactory Constructor

TrackFactory::TrackFactory Constructor
TrackFactory Template
Show All
C++
public: TrackFactory(
    char* name
);
Template

TrackFactory Template

File

Tracks.h

Links
TrackFactory Template
Send comments on this topic.


TrackFactory::~TrackFactory Destructor

TrackFactory::~TrackFactory Destructor
TrackFactory Template
Show All
C++
public: virtual ~TrackFactory();
Template

TrackFactory Template

File

Tracks.h

Links
TrackFactory Template
Send comments on this topic.


TrackFactory::GetName Method (void)

TrackFactory::GetName Method (void)
TrackFactory Template
Show All
C++
public: virtual CName* GetName(
    void
);
Template

TrackFactory Template

File

Tracks.h

Links
TrackFactory Template
Send comments on this topic.


TrackFactory::GetName Method (void)

TrackFactory::GetName Method (void)
TrackFactory Template
Show All
C++
public: virtual const CName* GetName(
    void
) const;
Template

TrackFactory Template

File

Tracks.h

Links
TrackFactory Template
Send comments on this topic.


TrackFactory::GetRorcChecksum Method

TrackFactory::GetRorcChecksum Method
TrackFactory Template
Show All
C++
public: virtual int GetRorcChecksum() const;
Template

TrackFactory Template

File

Tracks.h

Links
TrackFactory Template
Send comments on this topic.


TrackFactory::GetTrackType Method

TrackFactory::GetTrackType Method
TrackFactory Template
Show All
C++
public: virtual int GetTrackType();
Template

TrackFactory Template

File

Tracks.h

Links
TrackFactory Template
Send comments on this topic.


TrackFactory::NewTrack Method

TrackFactory::NewTrack Method
TrackFactory Template
Show All
C++
public: virtual TrackOrCondition* NewTrack(
    void
);
Template

TrackFactory Template

File

Tracks.h

Links
TrackFactory Template
Send comments on this topic.


TrackFactory::Place Method

TrackFactory::Place Method
TrackFactory Template
Show All
C++
public: virtual void Place(
    TrackOrCondition* pNode,
    rage::datResource& r
);
Template

TrackFactory Template

File

Tracks.h

Links
TrackFactory Template
Send comments on this topic.


TrackFactory::SetTypeId Method

TrackFactory::SetTypeId Method
TrackFactory Template
Show All

RAW_ACT_FILE_SUPPORT

C++
public: virtual void SetTypeId(
    int id
);
Template

TrackFactory Template

File

Tracks.h

Links
TrackFactory Template
Send comments on this topic.


TrackOrCondition Class

TrackOrCondition Class
Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
rage::IDataMembers
        TrackOrCondition
            rage::Condition
            rage::Track
C++
public: class TrackOrCondition : public IDataMembers;
Constructors
Constructor | Description
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~IDataMembers |
Methods
Method | Description
Break |
DeclareStruct |
DeclareStruct |
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetMember |
GetName |
GetNumMembers |
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
Namespace

rage Namespace

File

Tracks.h

Links
Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


TrackOrCondition::TrackOrCondition Constructor

TrackOrCondition::TrackOrCondition Constructor
TrackOrCondition Class
Show All
C++
public: TrackOrCondition();
Class

TrackOrCondition Class

File

Tracks.h

Links
TrackOrCondition Class
Send comments on this topic.


TrackOrCondition::Break Method

TrackOrCondition::Break Method
TrackOrCondition Class
Show All
C++
public: bool Break(
    void
);
Class

TrackOrCondition Class

File

Tracks.h

Links
TrackOrCondition Class
Send comments on this topic.


TrackOrCondition::DeclareStruct Method

TrackOrCondition::DeclareStruct Method
TrackOrCondition Class
Show All
C++
protected: virtual void DeclareStruct(
    datTypeStruct & s
);
Class

TrackOrCondition Class

File

Tracks.h

Links
TrackOrCondition Class
Send comments on this topic.


TrackOrCondition::GetConditionGroup Method

TrackOrCondition::GetConditionGroup Method
TrackOrCondition Class
Show All
C++
public: virtual ConditionGroup* GetConditionGroup();
Class

TrackOrCondition Class

File

Tracks.h

Links
TrackOrCondition Class
Send comments on this topic.


TrackOrCondition::GetDebugBreakPoint Method

TrackOrCondition::GetDebugBreakPoint Method
TrackOrCondition Class
Show All
C++
public: bool GetDebugBreakPoint(
    void
);
Class

TrackOrCondition Class

File

Tracks.h

Links
TrackOrCondition Class
Send comments on this topic.


TrackOrCondition::GetEnableBreakPoints Method

TrackOrCondition::GetEnableBreakPoints Method
TrackOrCondition Class
Show All
C++
public: static bool GetEnableBreakPoints(
    void
);
Class

TrackOrCondition Class

File

Tracks.h

Links
TrackOrCondition Class
Send comments on this topic.


TrackOrCondition::GetName Method (void)

TrackOrCondition::GetName Method (void)
TrackOrCondition Class
Show All
C++
public: virtual CName* GetName(
    void
) = 0;
Class

TrackOrCondition Class

File

Tracks.h

Links
TrackOrCondition Class
Send comments on this topic.


TrackOrCondition::GetName Method (void)

TrackOrCondition::GetName Method (void)
TrackOrCondition Class
Show All
C++
public: virtual const CName* GetName(
    void
) = 0 const;
Class

TrackOrCondition Class

File

Tracks.h

Links
TrackOrCondition Class
Send comments on this topic.


TrackOrCondition::GetTrackType Method

TrackOrCondition::GetTrackType Method
TrackOrCondition Class
Show All

1 = Track (to eliminate the need for dynamic_cast

C++
public: virtual int GetTrackType() const;
Class

TrackOrCondition Class

File

Tracks.h

Links
TrackOrCondition Class
Send comments on this topic.


TrackOrCondition::GetTrackTypeStatic Method

TrackOrCondition::GetTrackTypeStatic Method
TrackOrCondition Class
Show All
C++
public: static int GetTrackTypeStatic();
Class

TrackOrCondition Class

File

Tracks.h

Links
TrackOrCondition Class
Send comments on this topic.


TrackOrCondition::GetTypeId Method

TrackOrCondition::GetTypeId Method
TrackOrCondition Class
Show All
C++
public: virtual int GetTypeId() = 0 const;
Class

TrackOrCondition Class

File

Tracks.h

Links
TrackOrCondition Class
Send comments on this topic.


TrackOrCondition::SetDebugBreakPoint Method

TrackOrCondition::SetDebugBreakPoint Method
TrackOrCondition Class
Show All
C++
public: void SetDebugBreakPoint(
    bool bp
);
Class

TrackOrCondition Class

File

Tracks.h

Links
TrackOrCondition Class
Send comments on this topic.


TrackOrCondition::SetEnableBreakPoints Method

TrackOrCondition::SetEnableBreakPoints Method
TrackOrCondition Class
Show All
C++
public: static void SetEnableBreakPoints(
    bool tf
);
Class

TrackOrCondition Class

File

Tracks.h

Links
TrackOrCondition Class
Send comments on this topic.


TrackOrCondition::Write Method

TrackOrCondition::Write Method
TrackOrCondition Class
Show All

lint !e1735

C++
public: virtual void Write(
    TextBuffer& tB,
    const char* headerName = 0
);
Class

TrackOrCondition Class

File

Tracks.h

Links
TrackOrCondition Class
Send comments on this topic.


TrackRegistry Class

TrackRegistry Class
Constructors | Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
TrackRegistry
C++
public: class TrackRegistry;
Constructors
Constructor | Description
TrackRegistry |
Destructors
Destructor | Description
~TrackRegistry |
Methods
Method | Description
Create |
DegisterTrackFactorys |
DeInit |
GetDictionary |
GetNumRegisteredTracks |
GetRegisteredTrackName |
GetRegisteredTrackType |
GetRorcChecksum |
Init |
Place |
RegisterTrackFactory |
ResetDictionary |
Sort |
Namespace

rage Namespace

File

Tracks.h

Links
Constructors, Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


TrackRegistry::TrackRegistry Constructor

TrackRegistry::TrackRegistry Constructor
TrackRegistry Class
Show All
C++
public: TrackRegistry();
Class

TrackRegistry Class

File

Tracks.h

Links
TrackRegistry Class
Send comments on this topic.


TrackRegistry::~TrackRegistry Destructor

TrackRegistry::~TrackRegistry Destructor
TrackRegistry Class
Show All
C++
public: virtual ~TrackRegistry();
Class

TrackRegistry Class

File

Tracks.h

Links
TrackRegistry Class
Send comments on this topic.


TrackRegistry::Create Method (TextParser&)

TrackRegistry::Create Method (TextParser&)
TrackRegistry Class
Show All
C++
public: TrackOrCondition* Create(
    TextParser& textParser
);
Class

TrackRegistry Class

File

Tracks.h

Links
TrackRegistry Class
Send comments on this topic.


TrackRegistry::Create Method (const char*)

TrackRegistry::Create Method (const char*)
TrackRegistry Class
Show All
C++
public: TrackOrCondition* Create(
    const char* trackName
);
Class

TrackRegistry Class

File

Tracks.h

Links
TrackRegistry Class
Send comments on this topic.


TrackRegistry::DegisterTrackFactorys Method

TrackRegistry::DegisterTrackFactorys Method
TrackRegistry Class
Show All
C++
public: void DegisterTrackFactorys(
    void
);
Class

TrackRegistry Class

File

Tracks.h

Links
TrackRegistry Class
Send comments on this topic.


TrackRegistry::DeInit Method

TrackRegistry::DeInit Method
TrackRegistry Class
Show All
C++
public: void DeInit();
Class

TrackRegistry Class

File

Tracks.h

Links
TrackRegistry Class
Send comments on this topic.


TrackRegistry::GetDictionary Method

TrackRegistry::GetDictionary Method
TrackRegistry Class
Show All
C++
public: atArray<TrackOrCondition*>& GetDictionary();
Class

TrackRegistry Class

File

Tracks.h

Links
TrackRegistry Class
Send comments on this topic.


TrackRegistry::GetNumRegisteredTracks Method

TrackRegistry::GetNumRegisteredTracks Method
TrackRegistry Class
Show All
C++
public: int GetNumRegisteredTracks(
    void
);
Class

TrackRegistry Class

File

Tracks.h

Links
TrackRegistry Class
Send comments on this topic.


TrackRegistry::GetRegisteredTrackName Method

TrackRegistry::GetRegisteredTrackName Method
TrackRegistry Class
Show All
C++
public: const CName* GetRegisteredTrackName(
    int index
);
Class

TrackRegistry Class

File

Tracks.h

Links
TrackRegistry Class
Send comments on this topic.


TrackRegistry::GetRegisteredTrackType Method

TrackRegistry::GetRegisteredTrackType Method
TrackRegistry Class
Show All
C++
public: int GetRegisteredTrackType(
    int index
);
Class

TrackRegistry Class

File

Tracks.h

Links
TrackRegistry Class
Send comments on this topic.


TrackRegistry::GetRorcChecksum Method

TrackRegistry::GetRorcChecksum Method
TrackRegistry Class
Show All
C++
public: int GetRorcChecksum() const;
Class

TrackRegistry Class

File

Tracks.h

Links
TrackRegistry Class
Send comments on this topic.


TrackRegistry::Init Method

TrackRegistry::Init Method
TrackRegistry Class
Show All
C++
public: void Init(
    int maxEntries = 100,
    bool detectDuplicates = true
);
Class

TrackRegistry Class

File

Tracks.h

Links
TrackRegistry Class
Send comments on this topic.


TrackRegistry::Place Method

TrackRegistry::Place Method
TrackRegistry Class
Show All
C++
public: void Place(
    TrackOrCondition* pNode,
    datResource& rsc
);
Class

TrackRegistry Class

File

Tracks.h

Links
TrackRegistry Class
Send comments on this topic.


TrackRegistry::RegisterTrackFactory Method

TrackRegistry::RegisterTrackFactory Method
TrackRegistry Class
Show All
C++
public: void RegisterTrackFactory(
    ITrackFactory* trackFactory
);
Class

TrackRegistry Class

File

Tracks.h

Links
TrackRegistry Class
Send comments on this topic.


TrackRegistry::ResetDictionary Method

TrackRegistry::ResetDictionary Method
TrackRegistry Class
Show All
C++
public: void ResetDictionary();
Class

TrackRegistry Class

File

Tracks.h

Links
TrackRegistry Class
Send comments on this topic.


TrackRegistry::Sort Method

TrackRegistry::Sort Method
TrackRegistry Class
Show All
C++
public: void Sort(
    void
);
Class

TrackRegistry Class

File

Tracks.h

Links
TrackRegistry Class
Send comments on this topic.


Vector2DataMember Template

Vector2DataMember Template
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        rage::IVector2DataMember
            Vector2DataMember
C++
template <class T> public: class Vector2DataMember : public IVector2DataMember;
Constructors
Constructor | Description
DataMember |
IVector2DataMember |
Vector2DataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
~Vector2DataMember |
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
GetVector2 |
GetVector2 |
IsDefault |
IsDefault |
Read |
Read |
SetVector2 |
SetVector2 |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


Vector2DataMember::Vector2DataMember Constructor

Vector2DataMember::Vector2DataMember Constructor
Vector2DataMember Template
Show All
C++
public: Vector2DataMember(
    const char * RAW_ACT_FILE_SUPPORT_ONLY(name),
    GetVector2MemberFunction getFunc,
    SetVector2MemberFunction RAW_ACT_FILE_SUPPORT_ONLY(setFunc),
    TYPE type = DM_VECTOR2
);
Template

Vector2DataMember Template

File

datamember.h

Links
Vector2DataMember Template
Send comments on this topic.


Vector2DataMember::~Vector2DataMember Destructor

Vector2DataMember::~Vector2DataMember Destructor
Vector2DataMember Template
Show All
C++
public: virtual ~Vector2DataMember();
Template

Vector2DataMember Template

File

datamember.h

Links
Vector2DataMember Template
Send comments on this topic.


Vector2DataMember::GetType Method

Vector2DataMember::GetType Method
Vector2DataMember Template
Show All
C++
public: virtual TYPE GetType();
Template

Vector2DataMember Template

File

datamember.h

Links
Vector2DataMember Template
Send comments on this topic.


Vector2DataMember::GetVector2 Method

Vector2DataMember::GetVector2 Method
Vector2DataMember Template
Show All
C++
public: virtual void GetVector2(
    IDataMembers* dm,
    rage::Vector2 & outV2
);
Template

Vector2DataMember Template

File

datamember.h

Links
Vector2DataMember Template
Send comments on this topic.


Vector2DataMember::IsDefault Method

Vector2DataMember::IsDefault Method
Vector2DataMember Template
Show All
C++
public: virtual bool IsDefault(
    IDataMembers* dm
);
Template

Vector2DataMember Template

File

datamember.h

Links
Vector2DataMember Template
Send comments on this topic.


Vector2DataMember::SetVector2 Method

Vector2DataMember::SetVector2 Method
Vector2DataMember Template
Show All
C++
public: virtual void SetVector2(
    IDataMembers* dm,
    const rage::Vector2 & v2
);
Template

Vector2DataMember Template

File

datamember.h

Links
Vector2DataMember Template
Send comments on this topic.


Vector3DataMember Template

Vector3DataMember Template
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::IName
    rage::DataMember
        rage::IVector3DataMember
            Vector3DataMember
C++
template <class T> public: class Vector3DataMember : public IVector3DataMember;
Constructors
Constructor | Description
DataMember |
IVector3DataMember |
Vector3DataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
~Vector3DataMember |
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
GetVector3 |
GetVector3 |
IsDefault |
IsDefault |
Read |
Read |
SetVector3 |
SetVector3 |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |
Namespace

rage Namespace

File

datamember.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


Vector3DataMember::Vector3DataMember Constructor

Vector3DataMember::Vector3DataMember Constructor
Vector3DataMember Template
Show All
C++
public: Vector3DataMember(
    const char * RAW_ACT_FILE_SUPPORT_ONLY(name),
    GetVector3MemberFunction getFunc,
    SetVector3MemberFunction RAW_ACT_FILE_SUPPORT_ONLY(setFunc),
    TYPE type = DM_VECTOR3
);
Template

Vector3DataMember Template

File

datamember.h

Links
Vector3DataMember Template
Send comments on this topic.


Vector3DataMember::~Vector3DataMember Destructor

Vector3DataMember::~Vector3DataMember Destructor
Vector3DataMember Template
Show All
C++
public: virtual ~Vector3DataMember();
Template

Vector3DataMember Template

File

datamember.h

Links
Vector3DataMember Template
Send comments on this topic.


Vector3DataMember::GetType Method

Vector3DataMember::GetType Method
Vector3DataMember Template
Show All
C++
public: virtual TYPE GetType();
Template

Vector3DataMember Template

File

datamember.h

Links
Vector3DataMember Template
Send comments on this topic.


Vector3DataMember::GetVector3 Method

Vector3DataMember::GetVector3 Method
Vector3DataMember Template
Show All
C++
public: virtual void GetVector3(
    IDataMembers* dm,
    rage::Vector3 & outV3
);
Template

Vector3DataMember Template

File

datamember.h

Links
Vector3DataMember Template
Send comments on this topic.


Vector3DataMember::IsDefault Method

Vector3DataMember::IsDefault Method
Vector3DataMember Template
Show All
C++
public: virtual bool IsDefault(
    IDataMembers* dm
);
Template

Vector3DataMember Template

File

datamember.h

Links
Vector3DataMember Template
Send comments on this topic.


Vector3DataMember::SetVector3 Method

Vector3DataMember::SetVector3 Method
Vector3DataMember Template
Show All
C++
public: virtual void SetVector3(
    IDataMembers* dm,
    const rage::Vector3 & v3
);
Template

Vector3DataMember Template

File

datamember.h

Links
Vector3DataMember Template
Send comments on this topic.


rage::eActionNodeResolveMode Enumeration

rage::eActionNodeResolveMode Enumeration
rage Namespace
Show All
C++
public: enum eActionNodeResolveMode {
  public: NODES_ADDED,
  public: NODES_REMOVED,
  public: ALL_NODES
};
Namespace

rage Namespace

File

ActionNode.h

Links
rage Namespace


rage::!= Function

rage::!= Function
rage Namespace
Show All
C++
bool operator !=(
    const ActionNodeTreePtr& lhs,
    const char* name
);
Namespace

rage Namespace

File

ActionNodeTreePtr.h

Links
rage Namespace


rage::== Function

rage::== Function
rage Namespace
Show All
C++
bool operator ==(
    const ActionNodeTreePtr& lhs,
    const char* name
);
Namespace

rage Namespace

File

ActionNodeTreePtr.h

Links
rage Namespace


rage::HashUCstring Function

rage::HashUCstring Function
rage Namespace
Show All

string is upper cased

C++
int HashUCstring(
    const char * string
);
Namespace

rage Namespace

File

CName.h

Links
rage Namespace


rage::RAGE_DECLARE_CHANNEL Function

rage::RAGE_DECLARE_CHANNEL Function
rage Namespace
Show All
C++
RAGE_DECLARE_CHANNEL(
    spewdrv
);
Namespace

rage Namespace

File

ActionNodeTracks.h

Links
rage Namespace


rage::StringCopyNew Function

rage::StringCopyNew Function
rage Namespace
Show All

Helper Function

C++
void StringCopyNew(
    char* & oldString,
    const char* newString
);
Namespace

rage Namespace

File

Tracks.h

Links
rage Namespace


rage::ActionNodeTreePtr Type

rage::ActionNodeTreePtr Type
rage Namespace
Show All
C++
typedef atPtr<ActionNodeTreeHandle> ActionNodeTreePtr;
Namespace

rage Namespace

File

ActionNodeTreePtr.h

Links
rage Namespace


rage::ActionVistorCallBack Type

rage::ActionVistorCallBack Type
rage Namespace
Show All
C++
typedef rage::atFunctor1<void, ActionNode*> ActionVistorCallBack;
Namespace

rage Namespace

File

ActionNode.h

Links
rage Namespace


rage::DebugOutputFunctor Type

rage::DebugOutputFunctor Type
rage Namespace
Show All

ok to define type outside of debug builds.

C++
typedef rage::atFunctor2<void, unsigned int, const char*> DebugOutputFunctor;
Namespace

rage Namespace

File

ActionController.h

Links
rage Namespace


rage::FactoryIArchive Type

rage::FactoryIArchive Type
rage Namespace
Show All
C++
typedef IArchive* (* FactoryIArchive)(TextParser&);
Namespace

rage Namespace

File

ActionNode.h

Links
rage Namespace


rage::gDebugActTreeOut Variable

rage::gDebugActTreeOut Variable
rage Namespace
Show All
C++
DebugOutputFunctor gDebugActTreeOut;
Namespace

rage Namespace

File

ActionController.h

Links
rage Namespace


rage::gTempHashString Variable

rage::gTempHashString Variable
rage Namespace
Show All
C++
static char gTempHashString[MAX_HASH_STRING];
Namespace

rage Namespace

File

CName.h

Links
rage Namespace


rage::ACCELERATION_DATAMEMBER Macro

rage::ACCELERATION_DATAMEMBER Macro
rage Namespace
Show All
C++
#define ACCELERATION_DATAMEMBER(className, name, GetFunction, SetFunction) rage_new FloatDataMember<className>( VALIDATE_OR_REMOVE_NAME(name), &className::GetFunction, RAW_ACT_FILE_SUPPORT_ORNULL(&className::SetFunction), DataMember::DM_ACCELERATION),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::ACCELERATION_DATAMEMBER_SIMPLE Macro

rage::ACCELERATION_DATAMEMBER_SIMPLE Macro
rage Namespace
Show All
C++
#define ACCELERATION_DATAMEMBER_SIMPLE(className, name) ACCELERATION_DATAMEMBER(className, #name, Get##name, Set##name)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::ACCELERATION_MIN_MAX_DATAMEMBER Macro

rage::ACCELERATION_MIN_MAX_DATAMEMBER Macro
rage Namespace
Show All
C++
#define ACCELERATION_MIN_MAX_DATAMEMBER(className, nameStr, name) rage_new FloatDataMember<className>( VALIDATE_OR_REMOVE_NAME(nameStr), &className::Get##name, &className::Set##name, DataMember::DM_ACCELERATION, &className::GetMin##name, &className::GetMax##name),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::ACT_DEBUG_CODE Macro

rage::ACT_DEBUG_CODE Macro
rage Namespace
Show All
C++
#define ACT_DEBUG_CODE(X)
Namespace

rage Namespace

File

ActionController.h

Links
rage Namespace


rage::ACT_DEBUG_DEF Macro

rage::ACT_DEBUG_DEF Macro
rage Namespace
Show All
C++
#define ACT_DEBUG_DEF (!__TOOL) && (__BANK)
Namespace

rage Namespace

File

ActionController.h

Links
rage Namespace


rage::ACTIONTREE_CNAME_USE_ATSTRINGHASH Macro

rage::ACTIONTREE_CNAME_USE_ATSTRINGHASH Macro
rage Namespace
Show All
C++
#define ACTIONTREE_CNAME_USE_ATSTRINGHASH (!ACTIONTREE_CNAME_USE_HASH_ASM && !__TOOL)
Namespace

rage Namespace

File

CName.h

Links
rage Namespace


rage::ACTIONTREE_CNAME_USE_HASH_ASM Macro

rage::ACTIONTREE_CNAME_USE_HASH_ASM Macro
rage Namespace
Show All

For the brave, there is a slightly faster assembly language version of HashUCstring() for Xenon, in 'CName.cpp', which can be enabled by setting this to 1. /FF

C++
#define ACTIONTREE_CNAME_USE_HASH_ASM (0 && __XENON && !__TOOL)
Namespace

rage Namespace

File

CName.h

Links
rage Namespace


rage::actTreeDebug Macro

rage::actTreeDebug Macro
rage Namespace
Show All
C++
#define actTreeDebug(...)
Namespace

rage Namespace

File

ActionController.h

Links
rage Namespace


rage::actTreeDebugPop Macro

rage::actTreeDebugPop Macro
rage Namespace
Show All
C++
#define actTreeDebugPop(...)
Namespace

rage Namespace

File

ActionController.h

Links
rage Namespace


rage::actTreeDebugPush Macro

rage::actTreeDebugPush Macro
rage Namespace
Show All

NO_OUTPUT

C++
#define actTreeDebugPush(...)
Namespace

rage Namespace

File

ActionController.h

Links
rage Namespace


rage::ALL_ACTIONTREE_TRACKS Macro

rage::ALL_ACTIONTREE_TRACKS Macro
rage Namespace
Show All
C++
#define ALL_ACTIONTREE_TRACKS ACTIONTREE_TRACK(ExecuteTrack, ExecuteTask, "Execute") ACTIONTREE_TRACK(OpportunityTrack, OpportunityTask, "Opportunity") ACTIONTREE_TRACK(OpportunityRandomLatchTrack, OpportunityRandomLatchTask, "OpportunityRandomLatch") ACTIONTREE_TRACK(PrintTrack, PrintTask, "Print") ACTIONTREE_TRACK(SequenceTrack, SequenceTask, "Sequence") ACTIONTREE_TRACK(SpawnTrack, SpawnTask, "Spawn")
Notes

When adding new tracks/conditions

----------------------------------------------------------------------------

Try to use TrackNames that Group well... typically this is: NOUN_VERB: E.G. "WeaponAnimation" "WeaponCollision" "WeaponFire" "WeaponFX" "WeaponIncrementCharge" "WeaponSetCharge"

This makes it easier to find and use the Tracks/Conditions Also... you dont need to worry about registering in Alphabetical order anymore... A sort at the end takes care of that for the tool

Namespace

rage Namespace

File

Tracks.cpp

Links
rage Namespace


rage::ANGLE_DATAMEMBER Macro

rage::ANGLE_DATAMEMBER Macro
rage Namespace
Show All
C++
#define ANGLE_DATAMEMBER(className, name, GetFunction, SetFunction) rage_new FloatDataMember<className>( VALIDATE_OR_REMOVE_NAME(name), &className::GetFunction, RAW_ACT_FILE_SUPPORT_ORNULL(&className::SetFunction), DataMember::DM_ANGLE),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::ANGLE_DATAMEMBER_SIMPLE Macro

rage::ANGLE_DATAMEMBER_SIMPLE Macro
rage Namespace
Show All
C++
#define ANGLE_DATAMEMBER_SIMPLE(className, name) ANGLE_DATAMEMBER(className, #name, Get##name, Set##name)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::ANGLE_MIN_MAX_DATAMEMBER Macro

rage::ANGLE_MIN_MAX_DATAMEMBER Macro
rage Namespace
Show All
C++
#define ANGLE_MIN_MAX_DATAMEMBER(className, nameStr, name) rage_new FloatDataMember<className>( VALIDATE_OR_REMOVE_NAME(nameStr), &className::Get##name, &className::Set##name, DataMember::DM_ANGLE, &className::GetMin##name, &className::GetMax##name),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::BEGIN_DATAMEMBERS Macro

rage::BEGIN_DATAMEMBERS Macro
rage Namespace
Show All
C++
#define BEGIN_DATAMEMBERS(className) PFSTAT_ONLY(::rage::pfTimer TRACK_TIMER_##className(#className,*DataMember::GetPfGroupActTracks(),true);) PFSTAT_ONLY(::rage::pfTimer* className::GetPFTimer() {) PFSTAT_ONLY(return &TRACK_TIMER_##className;}) BEGIN_DATAMEMBERS_NOT_TRACK(className) rage_new BoolDataMember<className>( "breakPoint", &className::GetDebugBreakPoint, &className::SetDebugBreakPoint),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::BEGIN_DATAMEMBERS_NO_BREAKPOINT Macro

rage::BEGIN_DATAMEMBERS_NO_BREAKPOINT Macro
rage Namespace
Show All
C++
#define BEGIN_DATAMEMBERS_NO_BREAKPOINT(className) BEGIN_DATAMEMBERS_NOT_TRACK(className)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::BEGIN_DATAMEMBERS_NO_MEMBERS Macro

rage::BEGIN_DATAMEMBERS_NO_MEMBERS Macro
rage Namespace
Show All

Data Members MACROS for registering with the class

C++
#define BEGIN_DATAMEMBERS_NO_MEMBERS(className) BEGIN_DATAMEMBERS_NO_MEMBERS_NO_NAME(className) CName className::m_MembersClassName;
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::BEGIN_DATAMEMBERS_NO_MEMBERS_NO_NAME Macro

rage::BEGIN_DATAMEMBERS_NO_MEMBERS_NO_NAME Macro
rage Namespace
Show All
C++
#define BEGIN_DATAMEMBERS_NO_MEMBERS_NO_NAME(className) PFSTAT_ONLY(::rage::pfTimer TRACK_TIMER_##className(#className,*DataMember::GetPfGroupActTracks(),true);) PFSTAT_ONLY(::rage::pfTimer* className::GetPFTimer() {) PFSTAT_ONLY(return &TRACK_TIMER_##className;}) int className::m_TypeId = -1; int className::m_DataMembersCount = 0; DataMember** className::m_DataMembers = 0; void className::CreateMembersInterFace() { } void className::DestroyMembersInterFace(void) { }
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::BEGIN_DATAMEMBERS_NO_NAME Macro

rage::BEGIN_DATAMEMBERS_NO_NAME Macro
rage Namespace
Show All
C++
#define BEGIN_DATAMEMBERS_NO_NAME(className) PFSTAT_ONLY(::rage::pfTimer TRACK_TIMER_##className(#className,*DataMember::GetPfGroupActTracks(),true);) PFSTAT_ONLY(::rage::pfTimer* className::GetPFTimer() {) PFSTAT_ONLY(return &TRACK_TIMER_##className;}) int className::m_TypeId = -1; int className::m_DataMembersCount = 0; DataMember** className::m_DataMembers = 0; void className::CreateMembersInterFace() { DataMember* dataMembersTest[] = {
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::BEGIN_DATAMEMBERS_NOT_TRACK Macro

rage::BEGIN_DATAMEMBERS_NOT_TRACK Macro
rage Namespace
Show All
C++
#define BEGIN_DATAMEMBERS_NOT_TRACK(className) int className::m_TypeId = -1; int className::m_DataMembersCount = 0; DataMember** className::m_DataMembers = 0; CName className::m_MembersClassName; void className::CreateMembersInterFace() { DataMember* dataMembersTest[] = {
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::BOOL_DATAMEMBER Macro

rage::BOOL_DATAMEMBER Macro
rage Namespace
Show All
C++
#define BOOL_DATAMEMBER(className, name, GetFunction, SetFunction) rage_new BoolDataMember<className>( VALIDATE_OR_REMOVE_NAME(name), &className::GetFunction, RAW_ACT_FILE_SUPPORT_ORNULL(&className::SetFunction)),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::BOOL_DATAMEMBER_SIMPLE Macro

rage::BOOL_DATAMEMBER_SIMPLE Macro
rage Namespace
Show All
C++
#define BOOL_DATAMEMBER_SIMPLE(className, name) BOOL_DATAMEMBER(className, #name, Get##name, Set##name)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::COMMAND_DATAMEMBER Macro

rage::COMMAND_DATAMEMBER Macro
rage Namespace
Show All
C++
#define COMMAND_DATAMEMBER(className, name, GetFunction, SetFunction, ExecuteFunction) rage_new CommandDataMember<className>( VALIDATE_OR_REMOVE_NAME(name), &className::GetFunction, RAW_ACT_FILE_SUPPORT_ORNULL(&className::SetFunction), &className::ExecuteFunction),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::COMMAND_DATAMEMBER_SIMPLE Macro

rage::COMMAND_DATAMEMBER_SIMPLE Macro
rage Namespace
Show All
C++
#define COMMAND_DATAMEMBER_SIMPLE(className, name, ExecuteFunction) COMMAND_DATAMEMBER(className, #name, Get##name, Set##name, ExecuteFunction)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::COMMENT_DATAMEMBER Macro

rage::COMMENT_DATAMEMBER Macro
rage Namespace
Show All
C++
#define COMMENT_DATAMEMBER(comment)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::CONTROL_CONTEXT_ENABLED Macro

rage::CONTROL_CONTEXT_ENABLED Macro
rage Namespace
Show All
C++
#define CONTROL_CONTEXT_ENABLED 0
Namespace

rage Namespace

File

ActionController.h

Links
rage Namespace


rage::DATAMEMBERS_INTERFACE_RESOURCE_CTOR Macro

rage::DATAMEMBERS_INTERFACE_RESOURCE_CTOR Macro
rage Namespace
Show All
C++
#define DATAMEMBERS_INTERFACE_RESOURCE_CTOR(...)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::DATAMEMEBERS_INTERFACE Macro

rage::DATAMEMEBERS_INTERFACE Macro
rage Namespace
Show All
C++
#define DATAMEMEBERS_INTERFACE(...) DATAMEMEBERS_INTERFACE_NO_NAME(__VA_ARGS__) DATAMEMEBERS_INTERFACE_NAME(__VA_ARGS__)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::DATAMEMEBERS_INTERFACE_NAME Macro

rage::DATAMEMEBERS_INTERFACE_NAME Macro
rage Namespace
Show All

... was classname

C++
#define DATAMEMEBERS_INTERFACE_NAME(...) static CName m_MembersClassName; virtual CName* GetName(void){return(&m_MembersClassName);} virtual const CName* GetName(void) const {return(&m_MembersClassName);} RAW_ACT_FILE_SUPPORT_ONLY(virtual void SetName(const char* name){m_MembersClassName.SetString(name);})
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::DATAMEMEBERS_INTERFACE_NO_NAME Macro

rage::DATAMEMEBERS_INTERFACE_NO_NAME Macro
rage Namespace
Show All
C++
#define DATAMEMEBERS_INTERFACE_NO_NAME(...) PFSTAT_ONLY(virtual ::rage::pfTimer* GetPFTimer();) DATAMEMBERS_INTERFACE_RESOURCE_CTOR(__VA_ARGS__) DATAMEMEBERS_INTERFACE_PLACE(__VA_ARGS__) DATAMEMEBERS_INTERFACE_STRUCT() DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE(__VA_ARGS__)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE Macro

rage::DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE Macro
rage Namespace
Show All
C++
#define DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE(...) static void CreateMembersInterFace(); static void DestroyMembersInterFace(void); static int m_DataMembersCount; static DataMember** m_DataMembers; static int m_TypeId; static int m_RorcChecksum; virtual int GetTypeId() const {return m_TypeId;} virtual int GetNumMembers(void){return (m_DataMembersCount);} virtual DataMember* GetMember(int i){return m_DataMembers[i];}
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::DATAMEMEBERS_INTERFACE_NO_PLACE Macro

rage::DATAMEMEBERS_INTERFACE_NO_PLACE Macro
rage Namespace
Show All
C++
#define DATAMEMEBERS_INTERFACE_NO_PLACE(classname) DATAMEMEBERS_INTERFACE_NO_PLACE_NO_NAME(classname) DATAMEMEBERS_INTERFACE_NAME(classname)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::DATAMEMEBERS_INTERFACE_NO_PLACE_NO_NAME Macro

rage::DATAMEMEBERS_INTERFACE_NO_PLACE_NO_NAME Macro
rage Namespace
Show All
C++
#define DATAMEMEBERS_INTERFACE_NO_PLACE_NO_NAME(classname) PFSTAT_ONLY(virtual ::rage::pfTimer* GetPFTimer();) classname(rage::datResource&); DATAMEMEBERS_INTERFACE_STRUCT() DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE(classname)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::DATAMEMEBERS_INTERFACE_PLACE Macro

rage::DATAMEMEBERS_INTERFACE_PLACE Macro
rage Namespace
Show All
C++
#define DATAMEMEBERS_INTERFACE_PLACE(...)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::DATAMEMEBERS_INTERFACE_STRUCT Macro

rage::DATAMEMEBERS_INTERFACE_STRUCT Macro
rage Namespace
Show All

DECLARESTRUCT

C++
#define DATAMEMEBERS_INTERFACE_STRUCT
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::DEBUG_BREAK Macro

rage::DEBUG_BREAK Macro
rage Namespace
Show All
C++
#define DEBUG_BREAK
Namespace

rage Namespace

File

Tracks.h

Links
rage Namespace


rage::DEBUGTASKS Macro

rage::DEBUGTASKS Macro
rage Namespace
Show All

define this to enable 'task tracking' debug functionality

C++
#define DEBUGTASKS
Namespace

rage Namespace

File

ActionController.h

Links
rage Namespace


rage::DEFINE_sMIN_sMAX Macro

rage::DEFINE_sMIN_sMAX Macro
rage Namespace
Show All

Static min/max definitions -- this must go in the .cpp file when you use the TRACK_PARAMETER_sMIN_sMAX macro.

C++
#define DEFINE_sMIN_sMAX(className, type, name, minVal, maxVal) type className::sm_Min##name = minVal;
type className::sm_Max##name = maxVal;
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::DELETE_CORE_TASK Macro

rage::DELETE_CORE_TASK Macro
rage Namespace
Show All
C++
#define DELETE_CORE_TASK(taskName, task) GameTaskManager::GetInstance().DeleteTask<taskName>(task)
Namespace

rage Namespace

File

Tracks.h

Links
rage Namespace


rage::DELETE_GAME_TASK Macro

rage::DELETE_GAME_TASK Macro
rage Namespace
Show All
C++
#define DELETE_GAME_TASK(taskName, task) delete task
Namespace

rage Namespace

File

Tracks.h

Links
rage Namespace


rage::DELETE_GAME_TASK_ON_END Macro

rage::DELETE_GAME_TASK_ON_END Macro
rage Namespace
Show All

This is to replace the calls to delete running tasks when ending This allows tracks/task to control when they actually get deleted by the actionController... mainly to support animation blend control

C++
#define DELETE_GAME_TASK_ON_END(taskName, task) if(task && task->DeleteOnEnd()) { TRACKMSG( "Delete", task); DELETE_GAME_TASK(taskName, task); }
Notes

was previously ActionController::DeleteTaskOnEnd()

Namespace

rage Namespace

File

Tracks.h

Links
rage Namespace


rage::ENABLE_TRACK_TIMERS Macro

rage::ENABLE_TRACK_TIMERS Macro
rage Namespace
Show All
C++
#define ENABLE_TRACK_TIMERS (0 && !__TOOL && !__RESOURCECOMPILER && __DEV)
Namespace

rage Namespace

File

Tracks.h

Links
rage Namespace


rage::END_DATAMEMBERS Macro

rage::END_DATAMEMBERS Macro
rage Namespace
Show All
C++
#define END_DATAMEMBERS(className) }; m_DataMembersCount = sizeof(dataMembersTest)/sizeof(DataMember*); m_DataMembers = rage_new DataMember*[m_DataMembersCount]; memcpy(m_DataMembers,dataMembersTest,sizeof(DataMember*)*m_DataMembersCount);
} void className::DestroyMembersInterFace(void)
{ for(int i=0;i<m_DataMembersCount;i++)
{ delete m_DataMembers[i];
} delete [] m_DataMembers;
}
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::END_DATAMEMBERS_LITE Macro

rage::END_DATAMEMBERS_LITE Macro
rage Namespace
Show All
C++
#define END_DATAMEMBERS_LITE(className) }; m_DataMembersCount = sizeof(dataMembersTest)/sizeof(DataMember*); m_DataMembers = rage_new DataMember*[m_DataMembersCount]; for(int i=0;i<m_DataMembersCount;i++)
{ m_DataMembers[i] = dataMembersTest[i];
}
}
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::ENUM_DATAMEMBER Macro

rage::ENUM_DATAMEMBER Macro
rage Namespace
Show All
C++
#define ENUM_DATAMEMBER(className, name, GetFunction, SetFunction, enumNameArray, numEnumNames) rage_new EnumDataMember<className>( VALIDATE_OR_REMOVE_NAME(name), &className::GetFunction, RAW_ACT_FILE_SUPPORT_ORNULL(&className::SetFunction), enumNameArray, numEnumNames),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::ENUM_DATAMEMBER_SIMPLE Macro

rage::ENUM_DATAMEMBER_SIMPLE Macro
rage Namespace
Show All
C++
#define ENUM_DATAMEMBER_SIMPLE(className, name, enumNameArray, numEnumNames) ENUM_DATAMEMBER(className, #name, Get##name, Set##name, enumNameArray, numEnumNames)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::FLOAT_DATAMEMBER Macro

rage::FLOAT_DATAMEMBER Macro
rage Namespace
Show All
C++
#define FLOAT_DATAMEMBER(className, name, GetFunction, SetFunction) rage_new FloatDataMember<className>( VALIDATE_OR_REMOVE_NAME(name), &className::GetFunction, RAW_ACT_FILE_SUPPORT_ORNULL(&className::SetFunction)),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::FLOAT_DATAMEMBER_SIMPLE Macro

rage::FLOAT_DATAMEMBER_SIMPLE Macro
rage Namespace
Show All
C++
#define FLOAT_DATAMEMBER_SIMPLE(className, name) FLOAT_DATAMEMBER(className, #name, Get##name, Set##name)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::FLOAT_MIN_MAX_DATAMEMBER Macro

rage::FLOAT_MIN_MAX_DATAMEMBER Macro
rage Namespace
Show All
C++
#define FLOAT_MIN_MAX_DATAMEMBER(className, nameStr, name) rage_new FloatDataMember<className>( VALIDATE_OR_REMOVE_NAME(nameStr), &className::Get##name, &className::Set##name, DataMember::DM_FLOAT, &className::GetMin##name, &className::GetMax##name),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::GROUP_DATAMEMBER Macro

rage::GROUP_DATAMEMBER Macro
rage Namespace
Show All
C++
#define GROUP_DATAMEMBER(className, name, A, B, E, GetCountFunction, GetDataMemberFunction, GetDataMemberFormatFunction, ChangePriorityFunction, C, D) rage_new GroupDataMember<className>( VALIDATE_OR_REMOVE_NAME(name), className::GetCountFunction, &className::GetDataMemberFunction, &className::GetDataMemberFormatFunction, &className::ChangePriorityFunction),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::GROUP_DATAMEMBER_NO_INTERFACE Macro

rage::GROUP_DATAMEMBER_NO_INTERFACE Macro
rage Namespace
Show All
C++
#define GROUP_DATAMEMBER_NO_INTERFACE(className, name, A, B, E, GetCountFunction, GetDataMemberFunction, GetDataMemberFormatFunction, ChangePriorityFunction, C, D) rage_new GroupDataMemberNoInterface<className>( VALIDATE_OR_REMOVE_NAME(name), &className::GetCountFunction, &className::GetDataMemberFunction, &className::GetDataMemberFormatFunction, &className::ChangePriorityFunction),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::GROUP_DATAMEMBER_READONLY Macro

rage::GROUP_DATAMEMBER_READONLY Macro
rage Namespace
Show All
C++
#define GROUP_DATAMEMBER_READONLY(className, name, A, B, GetCountFunction, GetDataMemberFunction, C) rage_new GroupDataMember<className>( VALIDATE_OR_REMOVE_NAME(name), &className::GetCountFunction, &className::GetDataMemberFunction, NULL, NULL),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::INCREMENT_DEBUG_TASK_UPDATE_COUNTER Macro

rage::INCREMENT_DEBUG_TASK_UPDATE_COUNTER Macro
rage Namespace
Show All
C++
#define INCREMENT_DEBUG_TASK_UPDATE_COUNTER(x) ActionController::s_NoOfTaskUpdates += x;
Namespace

rage Namespace

File

ActionController.h

Links
rage Namespace


rage::INT_DATAMEMBER Macro

rage::INT_DATAMEMBER Macro
rage Namespace
Show All
C++
#define INT_DATAMEMBER(className, name, GetFunction, SetFunction) rage_new IntDataMember<className>( VALIDATE_OR_REMOVE_NAME(name), &className::GetFunction, RAW_ACT_FILE_SUPPORT_ORNULL(&className::SetFunction)),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::INT_DATAMEMBER_SIMPLE Macro

rage::INT_DATAMEMBER_SIMPLE Macro
rage Namespace
Show All
C++
#define INT_DATAMEMBER_SIMPLE(className, name) INT_DATAMEMBER(className, #name, Get##name, Set##name)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::INT_MIN_MAX_DATAMEMBER Macro

rage::INT_MIN_MAX_DATAMEMBER Macro
rage Namespace
Show All
C++
#define INT_MIN_MAX_DATAMEMBER(className, nameStr, name) rage_new IntDataMember<className>( VALIDATE_OR_REMOVE_NAME(nameStr), &className::Get##name, &className::Set##name, &className::GetMin##name, &className::GetMax##name),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::LENGTH_DATAMEMBER Macro

rage::LENGTH_DATAMEMBER Macro
rage Namespace
Show All
C++
#define LENGTH_DATAMEMBER(className, name, GetFunction, SetFunction) rage_new FloatDataMember<className>( VALIDATE_OR_REMOVE_NAME(name), &className::GetFunction, RAW_ACT_FILE_SUPPORT_ORNULL(&className::SetFunction), DataMember::DM_LENGTH),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::LENGTH_DATAMEMBER_SIMPLE Macro

rage::LENGTH_DATAMEMBER_SIMPLE Macro
rage Namespace
Show All
C++
#define LENGTH_DATAMEMBER_SIMPLE(className, name) LENGTH_DATAMEMBER(className, #name, Get##name, Set##name)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::LENGTH_MIN_MAX_DATAMEMBER Macro

rage::LENGTH_MIN_MAX_DATAMEMBER Macro
rage Namespace
Show All
C++
#define LENGTH_MIN_MAX_DATAMEMBER(className, nameStr, name) rage_new FloatDataMember<className>( VALIDATE_OR_REMOVE_NAME(nameStr), &className::Get##name, &className::Set##name, DataMember::DM_LENGTH, &className::GetMin##name, &className::GetMax##name),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::LENTH_DATAMEMBER Macro

rage::LENTH_DATAMEMBER Macro
rage Namespace
Show All
C++
#define LENTH_DATAMEMBER LENGTH_DATAMEMBER
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::MAGIC_NOPLACE Macro

rage::MAGIC_NOPLACE Macro
rage Namespace
Show All
C++
#define MAGIC_NOPLACE(A) DATAMEMEBERS_INTERFACE(A)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::MAGIC_NP_ENUM Macro

rage::MAGIC_NP_ENUM Macro
rage Namespace
Show All
C++
#define MAGIC_NP_ENUM(A,B) TRACK_PARAMETER_ENUM(A,B)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::MAGIC_NP_PADDING Macro

rage::MAGIC_NP_PADDING Macro
rage Namespace
Show All
C++
#define MAGIC_NP_PADDING(A,B) TRACK_PADDING(A,B)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::MAGIC_NP_PARAM Macro

rage::MAGIC_NP_PARAM Macro
rage Namespace
Show All
C++
#define MAGIC_NP_PARAM(A,B) TRACK_PARAMETER(A,B)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::MAGIC_NP_STRING Macro

rage::MAGIC_NP_STRING Macro
rage Namespace
Show All
C++
#define MAGIC_NP_STRING(A) TRACK_PARAMETER_STRING(A)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::MAX_HASH_STRING Macro

rage::MAX_HASH_STRING Macro
rage Namespace
Show All
C++
#define MAX_HASH_STRING 1024
Namespace

rage Namespace

File

CName.h

Links
rage Namespace


rage::NEW_CORE_TASK Macro

rage::NEW_CORE_TASK Macro
rage Namespace
Show All
C++
#define NEW_CORE_TASK(taskName) NewGameTask< taskName >( context, this )
Namespace

rage Namespace

File

Tracks.h

Links
rage Namespace


rage::NEW_GAME_TASK Macro

rage::NEW_GAME_TASK Macro
rage Namespace
Show All

RESOURCECOMPILER

C++
#define NEW_GAME_TASK(taskName) rage_new StubTask(this)
Namespace

rage Namespace

File

Tracks.h

Links
rage Namespace


rage::NODE_REFERENCE_DATAMEMBER Macro

rage::NODE_REFERENCE_DATAMEMBER Macro
rage Namespace
Show All
C++
#define NODE_REFERENCE_DATAMEMBER(className, name, GetFunction, SetFunction, GetFullPath, IsResolved) rage_new NodeReferenceDataMember<className>( VALIDATE_OR_REMOVE_NAME(name), 0, RAW_ACT_FILE_SUPPORT_ORNULL(&className::SetFunction), 0, 0),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::NODE_REFERENCE_DATAMEMBER_SIMPLE Macro

rage::NODE_REFERENCE_DATAMEMBER_SIMPLE Macro
rage Namespace
Show All
C++
#define NODE_REFERENCE_DATAMEMBER_SIMPLE(className, name, GetFullPath, IsResolved) NODE_REFERENCE_DATAMEMBER(className, #name, Get##name, Set##name, GetFullPath, IsResolved)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::NODENAMELEN Macro

rage::NODENAMELEN Macro
rage Namespace
Show All
C++
#define NODENAMELEN 64
Namespace

rage Namespace

File

ActionController.h

Links
rage Namespace


rage::PFSTAT_ONLY Macro

rage::PFSTAT_ONLY Macro
rage Namespace
Show All
C++
#define PFSTAT_ONLY(A)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::PLAY_HISTORY_DEBUG Macro

rage::PLAY_HISTORY_DEBUG Macro
rage Namespace
Show All
C++
#define PLAY_HISTORY_DEBUG 0
Namespace

rage Namespace

File

ActionController.h

Links
rage Namespace


rage::spewdrvDisplayf Macro

rage::spewdrvDisplayf Macro
rage Namespace
Show All
C++
#define spewdrvDisplayf(fmt,...) RAGE_DISPLAYF(spewdrv,fmt,##__VA_ARGS__)
Namespace

rage Namespace

File

ActionNodeTracks.h

Links
rage Namespace


rage::STRING_DATAMEMBER Macro

rage::STRING_DATAMEMBER Macro
rage Namespace
Show All
C++
#define STRING_DATAMEMBER(className, name, GetFunction, SetFunction) rage_new StringDataMember<className>( VALIDATE_OR_REMOVE_NAME(name), &className::GetFunction, RAW_ACT_FILE_SUPPORT_ORNULL(&className::SetFunction)),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::STRING_DATAMEMBER_SIMPLE Macro

rage::STRING_DATAMEMBER_SIMPLE Macro
rage Namespace
Show All
C++
#define STRING_DATAMEMBER_SIMPLE(className, name) STRING_DATAMEMBER(className, #name, Get##name, Set##name)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TASK_POOL_FUNCTIONS Macro

rage::TASK_POOL_FUNCTIONS Macro
rage Namespace
Show All
C++
#define TASK_POOL_FUNCTIONS(_poolindex) ATask *GameTaskManager::AllocateTask##_poolindex() { return (ATask *) &m_TaskPool##_poolindex.CreateObject(); } void GameTaskManager::FreeTask##_poolindex(DummyTaskHeader *task) { m_TaskPool##_poolindex.DestroyObject((DummyTask##_poolindex &) *task);
}
Namespace

rage Namespace

File

Tracks.cpp

Links
rage Namespace


rage::TIME_DATAMEMBER Macro

rage::TIME_DATAMEMBER Macro
rage Namespace
Show All
C++
#define TIME_DATAMEMBER(className, name, GetFunction, SetFunction) rage_new FloatDataMember<className>( VALIDATE_OR_REMOVE_NAME(name), &className::GetFunction, RAW_ACT_FILE_SUPPORT_ORNULL(&className::SetFunction), DataMember::DM_TIME),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TIME_DATAMEMBER_SIMPLE Macro

rage::TIME_DATAMEMBER_SIMPLE Macro
rage Namespace
Show All
C++
#define TIME_DATAMEMBER_SIMPLE(className, name) TIME_DATAMEMBER(className, #name, Get##name, Set##name)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TIME_END_NOT_INSERTED Macro

rage::TIME_END_NOT_INSERTED Macro
rage Namespace
Show All

Magic number for ATask::m_TimeEnd

C++
#define TIME_END_NOT_INSERTED (-10000.0f)
Namespace

rage Namespace

File

ATask.h

Links
rage Namespace


rage::TIME_MIN_MAX_DATAMEMBER Macro

rage::TIME_MIN_MAX_DATAMEMBER Macro
rage Namespace
Show All
C++
#define TIME_MIN_MAX_DATAMEMBER(className, nameStr, name) rage_new FloatDataMember<className>( VALIDATE_OR_REMOVE_NAME(nameStr), &className::Get##name, &className::Set##name, DataMember::DM_TIME, &className::GetMin##name, &className::GetMax##name),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_MEMBER Macro

rage::TRACK_MEMBER Macro
rage Namespace
Show All
C++
#define TRACK_MEMBER(type, name) protected: type m_##name;
public:
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_MEMBER_ENUM Macro

rage::TRACK_MEMBER_ENUM Macro
rage Namespace
Show All
C++
#define TRACK_MEMBER_ENUM TRACK_MEMBER
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_PADDING Macro

rage::TRACK_PADDING Macro
rage Namespace
Show All
C++
#define TRACK_PADDING(id, bytes) rage::datPadding<bytes> m_Pad##id;
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_PARAMETER Macro

rage::TRACK_PARAMETER Macro
rage Namespace
Show All

Helper MACRO for simple track param definitions in class

C++
#define TRACK_PARAMETER(type, name) public: RAW_ACT_FILE_SUPPORT_ONLY(void Set##name(type value){ m_##name = value; }) type Get##name(void){ return(m_##name); }
protected: type m_##name;
public:
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_PARAMETER_CNAME Macro

rage::TRACK_PARAMETER_CNAME Macro
rage Namespace
Show All
C++
#define TRACK_PARAMETER_CNAME(name) public: const CName& Get##name(void){return(m_##name);} const unsigned int GetID##name(void){return(m_##name.GetID());} void SetString##name(const char* value){ m_##name.SetString(value); } const char* GetString##name(void){ return(m_##name.GetString()); }
protected: CName m_##name;
public:
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_PARAMETER_ENUM Macro

rage::TRACK_PARAMETER_ENUM Macro
rage Namespace
Show All
C++
#define TRACK_PARAMETER_ENUM(type, name) public: void Set##name(int value){ m_##name = (type)value; } int Get##name(void){ return((int)m_##name); }
protected: type m_##name;
public:
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_PARAMETER_ENUM_STATIC Macro

rage::TRACK_PARAMETER_ENUM_STATIC Macro
rage Namespace
Show All
C++
#define TRACK_PARAMETER_ENUM_STATIC(type, name) public: static void Set##name(int value){ m_##name = (type)value; } static int Get##name(void){ return((int)m_##name); }
protected: static type m_##name;
public:
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_PARAMETER_MIN_MAX Macro

rage::TRACK_PARAMETER_MIN_MAX Macro
rage Namespace
Show All
C++
#define TRACK_PARAMETER_MIN_MAX(type, name, minVal, maxVal) public: void Set##name(type value) { m_##name = rage::Clamp(value, GetMin##name(), GetMax##name()); } type Get##name(void){ return(m_##name); } type GetMin##name() { return (minVal); } type GetMax##name() { return (maxVal); }
protected: type m_##name;
public:
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_PARAMETER_sMIN_sMAX Macro

rage::TRACK_PARAMETER_sMIN_sMAX Macro
rage Namespace
Show All

Static min/max

C++
#define TRACK_PARAMETER_sMIN_sMAX(type, name) public: void Set##name(type value) { m_##name = rage::Clamp(value, GetMin##name(), GetMax##name()); } type Get##name(void){ return(m_##name); } type GetMin##name() { return (sm_Min##name); } type GetMax##name() { return (sm_Max##name); }
protected: type m_##name; static type sm_Min##name; static type sm_Max##name;
public:
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_PARAMETER_STATIC Macro

rage::TRACK_PARAMETER_STATIC Macro
rage Namespace
Show All
C++
#define TRACK_PARAMETER_STATIC(type, name) public: static void Set##name(type value){ m_##name = value; } static type Get##name(void){ return(m_##name); }
protected: static type m_##name;
public:
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_PARAMETER_STRING Macro

rage::TRACK_PARAMETER_STRING Macro
rage Namespace
Show All
C++
#define TRACK_PARAMETER_STRING(name) public: void Set##name(const char* value){ StringCopyNew(m_##name, value); } const char* Get##name(void){ return(m_##name); }
protected: char* m_##name;
public:
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_PARAMETER_STRING_STATIC Macro

rage::TRACK_PARAMETER_STRING_STATIC Macro
rage Namespace
Show All
C++
#define TRACK_PARAMETER_STRING_STATIC(name) public: static void Set##name(const char* value){ StringCopyNew(m_##name, value); } static const char* Get##name(void){ return(m_##name); }
protected: static char* m_##name;
public:
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_PARAMETER_VECTOR2 Macro

rage::TRACK_PARAMETER_VECTOR2 Macro
rage Namespace
Show All
C++
#define TRACK_PARAMETER_VECTOR2(name) public: void Set##name(const Vector2 &v) { m_##name.Set(v); } void Get##name(Vector2 &outV) { outV.Set(m_##name); } const rage::Vector2 & Get##name() { return (m_##name); }
protected: Vector2 m_##name;
public:
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_PARAMETER_VECTOR2_STATIC Macro

rage::TRACK_PARAMETER_VECTOR2_STATIC Macro
rage Namespace
Show All
C++
#define TRACK_PARAMETER_VECTOR2_STATIC(name) public: static void Set##name(const Vector2 &v) { m_##name.Set(v); } static void Get##name(Vector2 &outV) { outV.Set(m_##name); } const rage::Vector2 & Get##name() { return (m_##name); }
protected: static Vector2 m_##name;
public:
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_PARAMETER_VECTOR3 Macro

rage::TRACK_PARAMETER_VECTOR3 Macro
rage Namespace
Show All
C++
#define TRACK_PARAMETER_VECTOR3(name) public: void Set##name(const rage::Vector3 &v) { m_##name.Set(v); } void Get##name(rage::Vector3 &outV) { outV.Set(m_##name); } const rage::Vector3 & Get##name() { return (m_##name); }
protected: rage::Vector3 m_##name;
public:
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_PARAMETER_VECTOR3_STATIC Macro

rage::TRACK_PARAMETER_VECTOR3_STATIC Macro
rage Namespace
Show All
C++
#define TRACK_PARAMETER_VECTOR3_STATIC(name) public: static void Set##name(const rage::Vector3 &v) { m_##name.Set(v); } static void Get##name(rage::Vector3 &outV) { outV.Set(m_##name); } static const rage::Vector3 & Get##name() { return (m_##name); }
protected: static rage::Vector3 m_##name;
public:
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_TIME_DATAMEMBER Macro

rage::TRACK_TIME_DATAMEMBER Macro
rage Namespace
Show All
C++
#define TRACK_TIME_DATAMEMBER(className, name, GetFunction, SetFunction) rage_new FloatDataMember<className>( VALIDATE_OR_REMOVE_NAME(name), &className::GetFunction, RAW_ACT_FILE_SUPPORT_ORNULL(&className::SetFunction), DataMember::DM_TRACK_TIME),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_TIME_DATAMEMBER_SIMPLE Macro

rage::TRACK_TIME_DATAMEMBER_SIMPLE Macro
rage Namespace
Show All
C++
#define TRACK_TIME_DATAMEMBER_SIMPLE(className, name) TRACK_TIME_DATAMEMBER(className, #name, Get##name, Set##name)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACK_TIME_MIN_MAX_DATAMEMBER Macro

rage::TRACK_TIME_MIN_MAX_DATAMEMBER Macro
rage Namespace
Show All
C++
#define TRACK_TIME_MIN_MAX_DATAMEMBER(className, nameStr, name) rage_new FloatDataMember<className>( VALIDATE_OR_REMOVE_NAME(nameStr), &className::Get##name, &className::Set##name, DataMember::DM_TRACK_TIME, &className::GetMin##name, &className::GetMax##name),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::TRACKMSG Macro

rage::TRACKMSG Macro
rage Namespace
Show All
C++
#define TRACKMSG(x,y)
Namespace

rage Namespace

File

ActionController.h

Links
rage Namespace


rage::VECTOR2_DATAMEMBER Macro

rage::VECTOR2_DATAMEMBER Macro
rage Namespace
Show All
C++
#define VECTOR2_DATAMEMBER(className, name, GetFunction, SetFunction) rage_new Vector2DataMember<className>( VALIDATE_OR_REMOVE_NAME(name), &className::GetFunction, RAW_ACT_FILE_SUPPORT_ORNULL(&className::SetFunction)),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::VECTOR3_DATAMEMBER Macro

rage::VECTOR3_DATAMEMBER Macro
rage Namespace
Show All
C++
#define VECTOR3_DATAMEMBER(className, name, GetFunction, SetFunction) rage_new Vector3DataMember<className>( VALIDATE_OR_REMOVE_NAME(name), &className::GetFunction, RAW_ACT_FILE_SUPPORT_ORNULL(&className::SetFunction)),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::VECTOR3_DATAMEMBER_SIMPLE Macro

rage::VECTOR3_DATAMEMBER_SIMPLE Macro
rage Namespace
Show All
C++
#define VECTOR3_DATAMEMBER_SIMPLE(className, name) VECTOR3_DATAMEMBER(className, #name, Get##name, Set##name)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::VELOCITY_DATAMEMBER Macro

rage::VELOCITY_DATAMEMBER Macro
rage Namespace
Show All
C++
#define VELOCITY_DATAMEMBER(className, name, GetFunction, SetFunction) rage_new FloatDataMember<className>( VALIDATE_OR_REMOVE_NAME(name), &className::GetFunction, RAW_ACT_FILE_SUPPORT_ORNULL(&className::SetFunction), DataMember::DM_VELOCITY),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::VELOCITY_DATAMEMBER_SIMPLE Macro

rage::VELOCITY_DATAMEMBER_SIMPLE Macro
rage Namespace
Show All
C++
#define VELOCITY_DATAMEMBER_SIMPLE(className, name) VELOCITY_DATAMEMBER(className, #name, Get##name, Set##name)
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


rage::VELOCITY_MIN_MAX_DATAMEMBER Macro

rage::VELOCITY_MIN_MAX_DATAMEMBER Macro
rage Namespace
Show All
C++
#define VELOCITY_MIN_MAX_DATAMEMBER(className, nameStr, name) rage_new FloatDataMember<className>( VALIDATE_OR_REMOVE_NAME(nameStr), &className::Get##name, &className::Set##name, DataMember::DM_VELOCITY, &className::GetMin##name, &className::GetMax##name),
Namespace

rage Namespace

File

datamember.h

Links
rage Namespace


ValFunc Function

ValFunc Function
C++
const char * ValFunc(
    const char * name_no_spaces
);
File

datamember.h


ActionController::s_BeginBreakPoint Variable

ActionController::s_BeginBreakPoint Variable
C++
bool ActionController::s_BeginBreakPoint = true;
File

ActionController.cpp

Send comments on this topic.


ActionController::s_EndBreakPoint Variable

ActionController::s_EndBreakPoint Variable
C++
bool ActionController::s_EndBreakPoint = true;
File

ActionController.cpp

Send comments on this topic.


ActionController::s_NoOfTaskUpdates Variable

ActionController::s_NoOfTaskUpdates Variable
C++
int ActionController::s_NoOfTaskUpdates = 0;
File

ActionController.cpp

Send comments on this topic.


ActionController::s_UpDateBreakPoint Variable

ActionController::s_UpDateBreakPoint Variable
C++
bool ActionController::s_UpDateBreakPoint = true;
File

ActionController.cpp

Send comments on this topic.


ActionTreeLog::s_theActionTreeLog Variable

ActionTreeLog::s_theActionTreeLog Variable
C++
ActionTreeLog* ActionTreeLog::s_theActionTreeLog = NULL;
File

SubjectObserver.cpp

Send comments on this topic.


CNamePath::s_CNameTraverseDown Variable

CNamePath::s_CNameTraverseDown Variable
C++
CName CNamePath::s_CNameTraverseDown;
File

CName.cpp

Send comments on this topic.


CNamePath::s_CNameTraverseUp Variable

CNamePath::s_CNameTraverseUp Variable

CNamePath So we dont have to keep strings around for resolving references

C++
CName CNamePath::s_CNameTraverseUp;
File

CName.cpp

Send comments on this topic.


Condition::m_TrackRegistry Variable

Condition::m_TrackRegistry Variable
C++
TrackRegistry Condition::m_TrackRegistry;
File

Condition.cpp

Send comments on this topic.


ConditionRandom::sm_RandFunc Variable

ConditionRandom::sm_RandFunc Variable
C++
ConditionRandom::ConditionRandFunc ConditionRandom::sm_RandFunc = 0;
File

Condition.cpp

Send comments on this topic.


ConditionRandom::sm_RandomNum Variable

ConditionRandom::sm_RandomNum Variable
C++
int ConditionRandom::sm_RandomNum = 0;
File

Condition.cpp

Send comments on this topic.


ConditionRandom::sm_RandomUsed Variable

ConditionRandom::sm_RandomUsed Variable
C++
bool ConditionRandom::sm_RandomUsed = true;
File

Condition.cpp

Send comments on this topic.


DataMember::m_WriteBuff Variable

DataMember::m_WriteBuff Variable
C++
char DataMember::m_WriteBuff[2048];
File

datamember.cpp


g_PrintChannelNames Variable

g_PrintChannelNames Variable

ConditionPrint

C++
const char* g_PrintChannelNames[];
File

ActionNodeTracks.cpp

Send comments on this topic.


g_PrintChannelNamesNum Variable

g_PrintChannelNamesNum Variable
C++
int g_PrintChannelNamesNum;
File

ActionNodeTracks.cpp

Send comments on this topic.


gCanOutputFalseCond Variable

gCanOutputFalseCond Variable
C++
bool gCanOutputFalseCond = false;
File

ActionController.cpp

Send comments on this topic.


gCanOutputTrueCond Variable

gCanOutputTrueCond Variable
C++
bool gCanOutputTrueCond = false;
File

ActionController.cpp

Send comments on this topic.


gCNameLog Variable

gCNameLog Variable
C++
fiStream* gCNameLog = NULL;
File

CName.cpp

Send comments on this topic.


gCNameTable Variable

gCNameTable Variable
C++
atMap<u32, const char*> gCNameTable;
File

CName.cpp

Send comments on this topic.


gCNameTableLoaded Variable

gCNameTableLoaded Variable

!__RESOURCECOMPILER

C++
bool gCNameTableLoaded = false;
File

CName.cpp

Send comments on this topic.


gCollapseConditionGroupsToNewLogicPrimatives Variable

gCollapseConditionGroupsToNewLogicPrimatives Variable
C++
bool gCollapseConditionGroupsToNewLogicPrimatives = false;
File

Condition.cpp

Send comments on this topic.


gDebugLevel Variable

gDebugLevel Variable
C++
const u32 gDebugLevel = 5;
File

ActionController.cpp

Send comments on this topic.


gDebugOn Variable

gDebugOn Variable
C++
const bool gDebugOn = true;
File

ActionController.cpp

Send comments on this topic.


gEvalTaskNames Variable

gEvalTaskNames Variable
C++
const char* gEvalTaskNames[MAX_EVAL];
File

ActionController.cpp

Send comments on this topic.


gEvaluatedTasks Variable

gEvaluatedTasks Variable
C++
int gEvaluatedTasks;
File

ActionController.cpp

Send comments on this topic.


iCurrentLevel Variable

iCurrentLevel Variable
C++
u32 iCurrentLevel = 0;
File

ActionController.cpp

Send comments on this topic.


initDebugOut Variable

initDebugOut Variable

Can't be static or else gcc complains. But not safe to remove because I assume it expects InitDebug to get called.

C++
bool initDebugOut = InitDebug();
File

ActionController.cpp

Send comments on this topic.


MAX_EVAL Variable

MAX_EVAL Variable
C++
static const int MAX_EVAL = 4096;
File

ActionController.cpp

Send comments on this topic.


pGroupPtr Variable

pGroupPtr Variable
C++
::rage::pfGroup* pGroupPtr = NULL;
File

datamember.cpp


PrintTrack::sm_PrintChannelEnabled Variable

PrintTrack::sm_PrintChannelEnabled Variable
C++
bool PrintTrack::sm_PrintChannelEnabled[PrintTrack::NUM_PRINT_CHANNELS] = {false, false, false, false };
File

ActionNodeTracks.cpp

Send comments on this topic.


RandomModeNames Variable

RandomModeNames Variable

ConditionRandom

C++
static const char * RandomModeNames[] = {"DirectOdds","PercentageSuccess"};
File

Condition.cpp

Send comments on this topic.


sUseNameStrings Variable

sUseNameStrings Variable
C++
bool sUseNameStrings = INCLUDE_STRINGS;
File

CName.cpp

Send comments on this topic.


TOO_LONG Variable

TOO_LONG Variable
C++
const float TOO_LONG = 0.5f;
File

ActionController.cpp

Send comments on this topic.


ACTION_NODE_HPP Macro

ACTION_NODE_HPP Macro
C++
#define ACTION_NODE_HPP
File

ActionNode.h

Send comments on this topic.


ACTIONNODETRACKS_HPP Macro

ACTIONNODETRACKS_HPP Macro
C++
#define ACTIONNODETRACKS_HPP
File

ActionNodeTracks.h

Send comments on this topic.


ALL_ACTIONTREE_CONDITIONS Macro

ALL_ACTIONTREE_CONDITIONS Macro
C++
#define ALL_ACTIONTREE_CONDITIONS ACTIONTREE_CONDITION(ConditionActionNodePlayTime, "ActionNodePlayTime") ACTIONTREE_CONDITION(ConditionGroupCondition, "ConditionGroup") ACTIONTREE_CONDITION(ConditionFalse, "False") ACTIONTREE_CONDITION(ConditionNOT, "NOT") ACTIONTREE_CONDITION(ConditionOR, "OR") ACTIONTREE_CONDITION(ConditionPrint, "Print") ACTIONTREE_CONDITION(ConditionRandom, "Random") ACTIONTREE_CONDITION(ConditionTrue, "True") ACTIONTREE_CONDITION(ConditionGroupConditionOr, "ConditionGroupOr") ACTIONTREE_CONDITION(ConditionGroupConditionAnd, "ConditionGroupAnd") ACTIONTREE_CONDITION(ConditionGroupConditionNot, "ConditionGroupNot") ACTIONTREE_CONDITION(ConditionGroupConditionOnly, "ConditionGroupOnly")
Notes

When adding new tracks/conditions

----------------------------------------------------------------------------

Try to use TrackNames that Group well... typicaly this is: NOUN_VERB: E.G. "WeaponAmmo" "WeaponEquiped" This makes it easier to find and use the Tracks/Conditions Also... you dont need to worry about registering in Alphabetical order anymore... A sort at the end takes care of that for the tool

File

Condition.cpp

Send comments on this topic.


BEGIN_TASK Macro

BEGIN_TASK Macro
C++
#define BEGIN_TASK(task) task->Begin();
File

ActionController.cpp

Send comments on this topic.


CHECK_TASK_LENGTH Macro

CHECK_TASK_LENGTH Macro
C++
#define CHECK_TASK_LENGTH (__ASSERT)
File

ActionController.cpp

Send comments on this topic.


CNAME_HPP Macro

CNAME_HPP Macro
C++
#define CNAME_HPP
File

CName.h

Send comments on this topic.


CONDITION_HPP Macro

CONDITION_HPP Macro
C++
#define CONDITION_HPP
File

Condition.h

Send comments on this topic.


CORETASK_HPP Macro

CORETASK_HPP Macro
C++
#define CORETASK_HPP
File

CoreTask.h

Send comments on this topic.


DATAMEMBER_HPP Macro

DATAMEMBER_HPP Macro
C++
#define DATAMEMBER_HPP
File

datamember.h


DOUBLE_QUOTE Macro

DOUBLE_QUOTE Macro

metrowerks editor cant handle the real thing

C++
#define DOUBLE_QUOTE '\x22'
File

TextParser.cpp

Send comments on this topic.


ENABLE_INGAME_ACT_TEXT_LOADING Macro

ENABLE_INGAME_ACT_TEXT_LOADING Macro
C++
#define ENABLE_INGAME_ACT_TEXT_LOADING (__BANK)
File

datamember.h


ENABLE_PF_TIMERS Macro

ENABLE_PF_TIMERS Macro

BANK && !__TOOL && !__FINAL /// this isn't thread safe because motion trees update weapons which have action controllers that can update simultaneously

C++
#define ENABLE_PF_TIMERS 0
File

ActionController.cpp

Send comments on this topic.


END_TASK Macro

END_TASK Macro
C++
#define END_TASK(task) task->End();
File

ActionController.cpp

Send comments on this topic.


INCLUDE_STRINGS Macro

INCLUDE_STRINGS Macro
C++
#define INCLUDE_STRINGS (!__RESOURCECOMPILER)
File

CName.cpp

Send comments on this topic.


NOTRAW_ACT_FILE_SUPPORT_ONLY Macro

NOTRAW_ACT_FILE_SUPPORT_ONLY Macro
C++
#define NOTRAW_ACT_FILE_SUPPORT_ONLY(A) A
File

datamember.h


NOTTOOL_AND_ASSERT_ONLY Macro

NOTTOOL_AND_ASSERT_ONLY Macro
C++
#define NOTTOOL_AND_ASSERT_ONLY(x)
File

Condition.cpp

Send comments on this topic.


RAW_ACT_FILE_SUPPORT Macro

RAW_ACT_FILE_SUPPORT Macro
C++
#define RAW_ACT_FILE_SUPPORT (__TOOL || __RESOURCECOMPILER || ENABLE_INGAME_ACT_TEXT_LOADING)
File

datamember.h


RAW_ACT_FILE_SUPPORT_ONLY Macro

RAW_ACT_FILE_SUPPORT_ONLY Macro
C++
#define RAW_ACT_FILE_SUPPORT_ONLY(A)
File

datamember.h


RAW_ACT_FILE_SUPPORT_ORNULL Macro

RAW_ACT_FILE_SUPPORT_ORNULL Macro
C++
#define RAW_ACT_FILE_SUPPORT_ORNULL(A) NULL
File

datamember.h


TEXTPARSER_HPP Macro

TEXTPARSER_HPP Macro
C++
#define TEXTPARSER_HPP
File

TextParser.h

Send comments on this topic.


TIME_TASK_UPDATES Macro

TIME_TASK_UPDATES Macro

this actually has a non-trivial cost

C++
#define TIME_TASK_UPDATES 0
File

ActionController.cpp

Send comments on this topic.


TIMER_START_BEGIN Macro

TIMER_START_BEGIN Macro
C++
#define TIMER_START_BEGIN(task)
File

ActionController.cpp

Send comments on this topic.


TIMER_START_END Macro

TIMER_START_END Macro
C++
#define TIMER_START_END(task)
File

ActionController.cpp

Send comments on this topic.


TIMER_START_UPDATE Macro

TIMER_START_UPDATE Macro
C++
#define TIMER_START_UPDATE(task)
File

ActionController.cpp

Send comments on this topic.


TIMER_STOP_BEGIN Macro

TIMER_STOP_BEGIN Macro
C++
#define TIMER_STOP_BEGIN(task)
File

ActionController.cpp

Send comments on this topic.


TIMER_STOP_END Macro

TIMER_STOP_END Macro
C++
#define TIMER_STOP_END(task)
File

ActionController.cpp

Send comments on this topic.


TIMER_STOP_UPDATE Macro

TIMER_STOP_UPDATE Macro
C++
#define TIMER_STOP_UPDATE(task)
File

ActionController.cpp

Send comments on this topic.


TRACK_EVALUATED_TRACKS_AND_CONDITIONS Macro

TRACK_EVALUATED_TRACKS_AND_CONDITIONS Macro

needs to match actioncontroller.cpp define

C++
#define TRACK_EVALUATED_TRACKS_AND_CONDITIONS 0
File

ActionController.cpp

Send comments on this topic.


TRACKED_MATCH Macro

TRACKED_MATCH Macro
C++
#define TRACKED_MATCH(A, B) A->Match(B)
File

Condition.cpp

Send comments on this topic.


TRACKS_HPP Macro

TRACKS_HPP Macro
C++
#define TRACKS_HPP
File

Tracks.h

Send comments on this topic.


UPDATE_TASK Macro

UPDATE_TASK Macro
C++
#define UPDATE_TASK(task, timeDelta) task->Update(timeDelta);
File

ActionController.cpp

Send comments on this topic.


VALIDATE_OR_REMOVE_NAME Macro

VALIDATE_OR_REMOVE_NAME Macro
C++
#define VALIDATE_OR_REMOVE_NAME( x ) NULL
File

datamember.h


rage Namespace Classes

rage Namespace Classes
rage Namespace
Classes
Class | Description
ActionCallbackContext |
ActionContext |
ActionController | ActionController
ActionIntention | ActionIntention
ActionNode |
ActionNodeBank | ActionNodeBank Matching a Playable Node will also include the tracks of this Bank during Playback
ActionNodeFileReference |
ActionNodeImplementation | ActionNodeImplementation
ActionNodeLwRef |
ActionNodePlayable |
ActionNodeReference | ActionNodeReference
ActionNodeTree |
ActionNodeTreeHandle |
ActionNodeUnresolvedRef |
ActionTreeLog | Simple Log class that notifies Observers when there is a new message
actTreeDebugOut |
ArchiveFileRecord |
ATask |
CBasicString | Helper for paths
CFastNamePath |
CName |
CNamePath | Helper for paths
Condition |
ConditionActionNodePlayTime |
Conditional | EQUITY AND RELATIONAL OPERATORS... And some compare helper functions
ConditionFalse |
ConditionGroup |
ConditionGroupCondition |
ConditionGroupConditionAnd |
ConditionGroupConditionNot |
ConditionGroupConditionOnly |
ConditionGroupConditionOr |
ConditionNOT |
ConditionOR |
ConditionPrint |
ConditionRandom |
ConditionTrue |
CSubject |
DataMember |
ExecuteTask |
ExecuteTrack |
GameTaskManager |
IArchive |
IBoolDataMember |
ICommandDataMember |
IDataMembers |
IEnumDataMember |
IFloatDataMember |
IGroupDataMember |
IIntDataMember |
IMultiNodeReferenceTrack |
IName |
INodeReferenceDataMember |
INodeReferenceTrack |
InstancedActionController |
IObserver |
IStringDataMember |
ITrackFactory |
IVector2DataMember |
IVector3DataMember |
NodeReferenceTrack |
OpportunityRandomLatchTask | OpportunityRandomLatchTask
OpportunityRandomLatchTrack | OpportunityRandomLatchTrack
OpportunityTask |
OpportunityTrack |
PrintTask |
PrintTrack |
SequenceTask |
SequenceTrack |
SpawnActionController | this makes the big assumption that spawn tracks are inside nodes that would already be referenced counted through other mechanisms
SpawnTask |
SpawnTrack |
StubTask |
TextBuffer |
TextParser |
Track |
TrackOrCondition |
TrackRegistry |


rage Namespace Enumerations

rage Namespace Enumerations
rage Namespace
Enumerations
Enumeration | Description
eActionNodeResolveMode |


rage Namespace Functions

rage Namespace Functions
rage Namespace
Functions
Function | Description
!= |
== |
HashUCstring | string is upper cased
RAGE_DECLARE_CHANNEL |
StringCopyNew | Helper Function


rage Namespace Macros

rage Namespace Macros
rage Namespace
Macros
Macro | Description
ACCELERATION_DATAMEMBER |
ACCELERATION_DATAMEMBER_SIMPLE |
ACCELERATION_MIN_MAX_DATAMEMBER |
ACT_DEBUG_CODE |
ACT_DEBUG_DEF |
ACTIONTREE_CNAME_USE_ATSTRINGHASH |
ACTIONTREE_CNAME_USE_HASH_ASM | For the brave, there is a slightly faster assembly language version of HashUCstring() for Xenon, in 'CName.cpp', which can be enabled by setting this to 1. /FF
actTreeDebug |
actTreeDebugPop |
actTreeDebugPush | NO_OUTPUT
ALL_ACTIONTREE_TRACKS |
ANGLE_DATAMEMBER |
ANGLE_DATAMEMBER_SIMPLE |
ANGLE_MIN_MAX_DATAMEMBER |
BEGIN_DATAMEMBERS |
BEGIN_DATAMEMBERS_NO_BREAKPOINT |
BEGIN_DATAMEMBERS_NO_MEMBERS | Data Members MACROS for registering with the class
BEGIN_DATAMEMBERS_NO_MEMBERS_NO_NAME |
BEGIN_DATAMEMBERS_NO_NAME |
BEGIN_DATAMEMBERS_NOT_TRACK |
BOOL_DATAMEMBER |
BOOL_DATAMEMBER_SIMPLE |
COMMAND_DATAMEMBER |
COMMAND_DATAMEMBER_SIMPLE |
COMMENT_DATAMEMBER |
CONTROL_CONTEXT_ENABLED |
DATAMEMBERS_INTERFACE_RESOURCE_CTOR |
DATAMEMEBERS_INTERFACE |
DATAMEMEBERS_INTERFACE_NAME | ... was classname
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE |
DATAMEMEBERS_INTERFACE_NO_PLACE |
DATAMEMEBERS_INTERFACE_NO_PLACE_NO_NAME |
DATAMEMEBERS_INTERFACE_PLACE |
DATAMEMEBERS_INTERFACE_STRUCT | DECLARESTRUCT
DEBUG_BREAK |
DEBUGTASKS | define this to enable 'task tracking' debug functionality
DEFINE_sMIN_sMAX | Static min/max definitions -- this must go in the .cpp file when you use the TRACK_PARAMETER_sMIN_sMAX macro.
DELETE_CORE_TASK |
DELETE_GAME_TASK |
DELETE_GAME_TASK_ON_END | This is to replace the calls to delete running tasks when ending This allows tracks/task to control when they actually get deleted by the actionController... mainly to support animation blend control
ENABLE_TRACK_TIMERS |
END_DATAMEMBERS |
END_DATAMEMBERS_LITE |
ENUM_DATAMEMBER |
ENUM_DATAMEMBER_SIMPLE |
FLOAT_DATAMEMBER |
FLOAT_DATAMEMBER_SIMPLE |
FLOAT_MIN_MAX_DATAMEMBER |
GROUP_DATAMEMBER |
GROUP_DATAMEMBER_NO_INTERFACE |
GROUP_DATAMEMBER_READONLY |
INCREMENT_DEBUG_TASK_UPDATE_COUNTER |
INT_DATAMEMBER |
INT_DATAMEMBER_SIMPLE |
INT_MIN_MAX_DATAMEMBER |
LENGTH_DATAMEMBER |
LENGTH_DATAMEMBER_SIMPLE |
LENGTH_MIN_MAX_DATAMEMBER |
LENTH_DATAMEMBER |
MAGIC_NOPLACE |
MAGIC_NP_ENUM |
MAGIC_NP_PADDING |
MAGIC_NP_PARAM |
MAGIC_NP_STRING |
MAX_HASH_STRING |
NEW_CORE_TASK |
NEW_GAME_TASK | RESOURCECOMPILER
NODE_REFERENCE_DATAMEMBER |
NODE_REFERENCE_DATAMEMBER_SIMPLE |
NODENAMELEN |
PFSTAT_ONLY |
PLAY_HISTORY_DEBUG |
spewdrvDisplayf |
STRING_DATAMEMBER |
STRING_DATAMEMBER_SIMPLE |
TASK_POOL_FUNCTIONS |
TIME_DATAMEMBER |
TIME_DATAMEMBER_SIMPLE |
TIME_END_NOT_INSERTED | Magic number for ATask::m_TimeEnd
TIME_MIN_MAX_DATAMEMBER |
TRACK_MEMBER |
TRACK_MEMBER_ENUM |
TRACK_PADDING |
TRACK_PARAMETER | Helper MACRO for simple track param definitions in class
TRACK_PARAMETER_CNAME |
TRACK_PARAMETER_ENUM |
TRACK_PARAMETER_ENUM_STATIC |
TRACK_PARAMETER_MIN_MAX |
TRACK_PARAMETER_sMIN_sMAX | Static min/max
TRACK_PARAMETER_STATIC |
TRACK_PARAMETER_STRING |
TRACK_PARAMETER_STRING_STATIC |
TRACK_PARAMETER_VECTOR2 |
TRACK_PARAMETER_VECTOR2_STATIC |
TRACK_PARAMETER_VECTOR3 |
TRACK_PARAMETER_VECTOR3_STATIC |
TRACK_TIME_DATAMEMBER |
TRACK_TIME_DATAMEMBER_SIMPLE |
TRACK_TIME_MIN_MAX_DATAMEMBER |
TRACKMSG |
VECTOR2_DATAMEMBER |
VECTOR3_DATAMEMBER |
VECTOR3_DATAMEMBER_SIMPLE |
VELOCITY_DATAMEMBER |
VELOCITY_DATAMEMBER_SIMPLE |
VELOCITY_MIN_MAX_DATAMEMBER |


rage Namespace Namespaces

rage Namespace Namespaces
rage Namespace
Namespaces
Namespace | Description
actDebug |
condEKG |


rage Namespace Structs

rage Namespace Structs
rage Namespace
Structs
Struct | Description
ActionContextDebugDepth | : helper class to keep track of the call depth into important functions like Play, Match, Update
ActionNodeDebugName | : helper class to extract the name of the action node consistently.


rage Namespace Templates

rage Namespace Templates
rage Namespace
Templates
Template | Description
BoolDataMember |
CommandDataMember |
EnumDataMember |
FloatDataMember |
GroupDataMember |
GroupDataMemberNoInterface |
IntDataMember |
NodeReferenceDataMember |
StringDataMember |
TaskSizeCompileTimeAssert | Class template to facilitate size checking
TaskSizeCompileTimeAssert<SpawnTask> | Special case for Spawn, because this sucker's massive.
TrackFactory |
Vector2DataMember |
Vector3DataMember |


rage Namespace Types

rage Namespace Types
rage Namespace
Types
Type | Description
ActionNodeTreePtr |
ActionVistorCallBack |
DebugOutputFunctor | ok to define type outside of debug builds.
FactoryIArchive |


rage Namespace Variables

rage Namespace Variables
rage Namespace
Variables
Variable | Description
gDebugActTreeOut |
gTempHashString |


rage::actDebug Namespace Functions

rage::actDebug Namespace Functions
rage::actDebug Namespace
Functions
Function | Description
CanOutputDebug | : checks if we can output the actiontree module debug : checks if we can output the act controller debug
CanOutputDebug | : checks if we can output the actiontree module debug for the given context object : checks if we can output the actiontree module debug
CanOutputDebug | : checks if we can output the actiontree module debug for the given context object : checks if we can output the actiontree module debug
ExtractPathAndNodeName | : extracts the name of the action node
GetActDebugLevel | : gets the debug level for the actiontree module. : gets the debug level for the act controller
OutputFullNameEumeration | : checks if we need to output the full name for the nodes : return true if we want to see the full name enumeration, need to make this a configuration TODO(ddn)
SetConditionFilter | : sets the debug condition filters : sets the debug condition filters


ActionCallbackContext Class Constructors

ActionCallbackContext Class Constructors
ActionCallbackContext Class
Constructors
Constructor | Description
ActionCallbackContext |


Constructors

Legend
Method


ActionCallbackContext Class Destructors

ActionCallbackContext Class Destructors
ActionCallbackContext Class
Destructors
Destructor | Description
~ActionCallbackContext |


Destructors

Legend
Method
virtual


Legend

Legend
ActionCallbackContext Class
Legend
Method
virtual


ActionCallbackContext Class Members

ActionCallbackContext Class Members
ActionCallbackContext Class
Members
Constructors
Constructor | Description
ActionCallbackContext |
Destructors
Destructor | Description
~ActionCallbackContext |
Methods
Method | Description
Bind | : binds this object to the controller it is hooking
GetController | : gets the controller this callback context hooks
OnEndTask |
OnNodeCleanup |
OnPlay | : callback hooks
OnPlayTracks |
OnSequence |
OnStop |
Update | : update function allows callback context to execute logic, ext code must update this object.


Members

Legend
Method
virtual


ActionCallbackContext Class Methods

ActionCallbackContext Class Methods
ActionCallbackContext Class
Methods
Method | Description
Bind | : binds this object to the controller it is hooking
GetController | : gets the controller this callback context hooks
OnEndTask |
OnNodeCleanup |
OnPlay | : callback hooks
OnPlayTracks |
OnSequence |
OnStop |
Update | : update function allows callback context to execute logic, ext code must update this object.


Methods

Legend
Method
virtual


Inheritance Hierarchy

Inheritance Hierarchy
ActionCallbackContext Class
Inheritance Hierarchy
ActionCallbackContext


ActionContext Class Constructors

ActionContext Class Constructors
ActionContext Class
Constructors
Constructor | Description
ActionContext |


ActionContext Class Data Members

ActionContext Class Data Members
ActionContext Class
Data Members
Data Member | Description
m_ActionController |
m_Actor | you probably will want to create your own derived version of this have this system do anything useful...
m_CurrentAction | the current action node for a given operation. Useful to identify the originating state for an operation.
m_CurrentMatchingNode | only valid while a node or bank's condition group is being evaluated
m_Debug | boolean to turn on/off debugging for individual objects
m_DebugContextClBk | external callback used for hooking the debugging of this object
m_Depth | used to identify how deep the call stack is for the context
m_Entity | general purpose information
m_OpeningBranch | This is basically a replacement for an opening branch the sequences to a start point when there are no nodes to sequence


Data Members

Legend
Data Member


ActionContext Class Destructors

ActionContext Class Destructors
ActionContext Class
Destructors
Destructor | Description
~ActionContext |


Legend

Legend
ActionContext Class
Legend
Data Member
Method
virtual


ActionContext Class Members

ActionContext Class Members
ActionContext Class
Members
Data Members
Data Member | Description
m_ActionController |
m_Actor | you probably will want to create your own derived version of this have this system do anything useful...
m_CurrentAction | the current action node for a given operation. Useful to identify the originating state for an operation.
m_CurrentMatchingNode | only valid while a node or bank's condition group is being evaluated
m_Debug | boolean to turn on/off debugging for individual objects
m_DebugContextClBk | external callback used for hooking the debugging of this object
m_Depth | used to identify how deep the call stack is for the context
m_Entity | general purpose information
m_OpeningBranch | This is basically a replacement for an opening branch the sequences to a start point when there are no nodes to sequence
Constructors
Constructor | Description
ActionContext |
Destructors
Destructor | Description
~ActionContext |
Methods
Method | Description
Clone | Create a copy of pContext:
GetActorName |
NullOp |
OnACTError |
OnStopPostTaskEnd | Called from ActionController::Stop(), after all tasks have ended.
PreUpdate | optional project specific
ResetDebug |
VerifyNewNode | __DEV only callback on new node selection for verification purposes
Nested Types
Nested Type | Description
DebugActionContextCB | ok to define type outside of debug builds.


Members

Legend
Data Member
Method
virtual


ActionContext Class Methods

ActionContext Class Methods
ActionContext Class
Methods
Method | Description
Clone | Create a copy of pContext:
GetActorName |
NullOp |
OnACTError |
OnStopPostTaskEnd | Called from ActionController::Stop(), after all tasks have ended.
PreUpdate | optional project specific
ResetDebug |
VerifyNewNode | __DEV only callback on new node selection for verification purposes


ActionContext Class Nested Types

ActionContext Class Nested Types
ActionContext Class
Nested Types
Nested Type | Description
DebugActionContextCB | ok to define type outside of debug builds.


Inheritance Hierarchy

Inheritance Hierarchy
ActionContext Class
Inheritance Hierarchy
ActionContext


ActionContextDebugDepth Struct Constructors

ActionContextDebugDepth Struct Constructors
ActionContextDebugDepth Struct
Constructors
Constructor | Description
ActionContextDebugDepth |


ActionContextDebugDepth Struct Data Members

ActionContextDebugDepth Struct Data Members
ActionContextDebugDepth Struct
Data Members
Data Member | Description
m_Ctx |
m_Op |
m_PrevNode |


ActionContextDebugDepth Struct Destructors

ActionContextDebugDepth Struct Destructors
ActionContextDebugDepth Struct
Destructors
Destructor | Description
~ActionContextDebugDepth |


Destructors

Legend
Method


Legend

Legend
ActionContextDebugDepth Struct
Legend
Data Member
Method


ActionContextDebugDepth Struct Members

ActionContextDebugDepth Struct Members
ActionContextDebugDepth Struct
Members
Data Members
Data Member | Description
m_Ctx |
m_Op |
m_PrevNode |
Constructors
Constructor | Description
ActionContextDebugDepth |
Destructors
Destructor | Description
~ActionContextDebugDepth |


Members

Legend
Data Member
Method


Inheritance Hierarchy

Inheritance Hierarchy
ActionContextDebugDepth Struct
Inheritance Hierarchy
ActionContextDebugDepth


ActionController Class Constructors

ActionController Class Constructors
ActionController Class
Constructors
Constructor | Description
ActionController |


ActionController Class Data Members

ActionController Class Data Members
ActionController Class
Data Members
Data Member | Description
s_NoOfTaskUpdates |


ActionController Class Destructors

ActionController Class Destructors
ActionController Class
Destructors
Destructor | Description
~ActionController |


Legend

Legend
ActionController Class
Legend
Data Member
Method
virtual
protected


ActionController Class Members

ActionController Class Members
ActionController Class
Members
Data Members
Data Member | Description
s_NoOfTaskUpdates |
Constructors
Constructor | Description
ActionController |
Destructors
Destructor | Description
~ActionController |
Methods
Method | Description
BeginDebugTask |
clearAll |
EndDebugTask |
EndTask |
GetBeginBreakPoint |
GetContext |
GetControlContext |
GetCurrentNodePlayTime |
GetCurrentPlayCount |
GetCurrentPlayingNode |
GetDebug |
GetEndBreakPoint |
GetPlayHistory |
GetRequestedNode |
GetRunningTaskRoot |
GetUpDateBreakPoint |
IsBusy | const ActionNode * GetCurrentSequencedNode(void)const{return(m_SequencedNode); short GetSequencedPriority(void)const{return(m_SequencedPriority);
Play | These deal with ActionNodes so Banks can be sequenced or played The PlayActionNode will search for playable NODE to sequence!
PlayRemote | : used by the mutli-player function to execute remote actions. keeps a signature to prevent multiple plays of same action.
PlayTracks |
RemoveTask |
Sequence |
SetBeginBreakPoint | These are for hooking in BreakPoints on Track/Task instances
SetContext |
SetControlContext | does nothing CONTROL_CONTEXT_ENABLED
SetDebug |
SetEndBreakPoint |
SetRequestedNode |
SetUpDateBreakPoint |
StartSequencedTracks |
Stop |
TRACKMSG |
Update | Normally only update is called
UpdateDebugTask |
UpdateTasks |
UpdateTasksTimeEnd |
UpdateWithKeepAlive |


Members

Legend
Data Member
Method
virtual
protected


ActionController Class Methods

ActionController Class Methods
ActionController Class
Methods
Method | Description
BeginDebugTask |
clearAll |
EndDebugTask |
EndTask |
GetBeginBreakPoint |
GetContext |
GetControlContext |
GetCurrentNodePlayTime |
GetCurrentPlayCount |
GetCurrentPlayingNode |
GetDebug |
GetEndBreakPoint |
GetPlayHistory |
GetRequestedNode |
GetRunningTaskRoot |
GetUpDateBreakPoint |
IsBusy | const ActionNode * GetCurrentSequencedNode(void)const{return(m_SequencedNode); short GetSequencedPriority(void)const{return(m_SequencedPriority);
Play | These deal with ActionNodes so Banks can be sequenced or played The PlayActionNode will search for playable NODE to sequence!
PlayRemote | : used by the mutli-player function to execute remote actions. keeps a signature to prevent multiple plays of same action.
PlayTracks |
RemoveTask |
Sequence |
SetBeginBreakPoint | These are for hooking in BreakPoints on Track/Task instances
SetContext |
SetControlContext | does nothing CONTROL_CONTEXT_ENABLED
SetDebug |
SetEndBreakPoint |
SetRequestedNode |
SetUpDateBreakPoint |
StartSequencedTracks |
Stop |
TRACKMSG |
Update | Normally only update is called
UpdateDebugTask |
UpdateTasks |
UpdateTasksTimeEnd |
UpdateWithKeepAlive |


Methods

Legend
Method
protected


Inheritance Hierarchy

Inheritance Hierarchy
ActionController Class
Inheritance Hierarchy
ActionController
    rage::InstancedActionController
    rage::SpawnActionController


ActionIntention Class Constructors

ActionIntention Class Constructors
ActionIntention Class
Constructors
Constructor | Description
ActionIntention |


ActionIntention Class Destructors

ActionIntention Class Destructors
ActionIntention Class
Destructors
Destructor | Description
~ActionIntention |


Legend

Legend
ActionIntention Class
Legend
Method
virtual


ActionIntention Class Members

ActionIntention Class Members
ActionIntention Class
Members
Constructors
Constructor | Description
ActionIntention |
Destructors
Destructor | Description
~ActionIntention |
Methods
Method | Description
Clear |
Update |


ActionIntention Class Methods

ActionIntention Class Methods
ActionIntention Class
Methods
Method | Description
Clear |
Update |


Methods

Legend
Method


Inheritance Hierarchy

Inheritance Hierarchy
ActionIntention Class
Inheritance Hierarchy
ActionIntention


ActionNode Class Constructors

ActionNode Class Constructors
ActionNode Class
Constructors
Constructor | Description
ActionNode |
IArchive |


ActionNode Class Data Members

ActionNode Class Data Members
ActionNode Class
Data Members
Data Member | Description
m_bUpdatedOnce |
m_bViewExpanded |
m_childNodes |
m_FileRoot | Points to root node of file for ref counting fun
m_GlobalEditPriority |
m_OnLoad |
m_OnUnload |
m_Pad |
m_parent |
m_PathCRC | used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed
m_Root |
m_Type |
RORC_VERSION | Don't forget to bump this whenever this structure changes
sm_ActFullPath |
sm_ActPath |
sm_OnTreeUnloadCallback |
sm_PostLoadCallback |
sm_RscFirstPass | set to false the second time through


Data Members

Legend
Data Member
protected


ActionNode Class Destructors

ActionNode Class Destructors
ActionNode Class
Destructors
Destructor | Description
~ActionNode |
~IArchive |
~IName |


ActionNode Class Friends

ActionNode Class Friends
ActionNode Class
Friends
Friend | Description
class ActionNodeReference | need to be able to access private data
class ActionNodeTree |


Legend

Legend
ActionNode Class
Legend
Data Member
protected
Method
virtual
abstract


ActionNode Class Members

ActionNode Class Members
ActionNode Class
Members
Data Members
Data Member | Description
m_bUpdatedOnce |
m_bViewExpanded |
m_childNodes |
m_FileRoot | Points to root node of file for ref counting fun
m_GlobalEditPriority |
m_OnLoad |
m_OnUnload |
m_Pad |
m_parent |
m_PathCRC | used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed
m_Root |
m_Type |
RORC_VERSION | Don't forget to bump this whenever this structure changes
sm_ActFullPath |
sm_ActPath |
sm_OnTreeUnloadCallback |
sm_PostLoadCallback |
sm_RscFirstPass | set to false the second time through
Structs
Struct | Description
ActionTreeTaskParams |
Constructors
Constructor | Description
ActionNode |
IArchive |
Destructors
Destructor | Description
~ActionNode |
~IArchive |
~IName |
Methods
Method | Description
AddBranch | Add Resources
AddChildActionNode |
AddChildActionNodes |
AddCondition |
AddRoot |
AddStuff |
AddTrack |
AddTracksBank |
BalanceWeights |
ChangeChildPriority |
ChangeConditionPriority |
ChangePriority |
ChangeTrackPriority |
ClearChildNodes | never call clear in the real game, only in resource compiler outside of Begin/EndBuild
ClearRoots |
Create |
CreateIArchive |
DATAMEMEBERS_INTERFACE_NO_NAME |
DeInit |
DeleteChildActionNodes | Remove Resources
DeleteCondition |
DeleteTrack |
DumpTiming |
DumpTimingRecursive |
EvalRemote | : evalutes the remtoe conditions for this node. Return false if any condition objects.
EvalRemoteTransition | : evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.
Find |
FindChildNode |
FindFirstPlayable |
FindRoot | Find methods... should rework this
GetChild |
GetChildCount | Traversal
GetCNamePath | Get Resource for views
GetCondition |
GetConditionCount |
GetConditionGroup |
GetCondtionFormat |
GetFileRoot |
GetName |
GetName |
GetNameFullPath |
GetNameFullPathDebug |
GetParent |
GetPathCRC | MP functionality
GetPriority | Sibling Position Child Priority
GetRefCount |
GetRoot |
GetTrack |
GetTrackCount |
GetTrackFormat |
GetType |
IncRefCount |
Init |
IsDescendantOf |
Load |
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
OnTreeUnload |
OperateAllNodes |
OperateChildOnNodes | Helper for recursive visit function
PrintAllNodes |
ReadConditionGroup |
RecursSetFileRoots |
RemoveChildActionNode |
ReserveTracks |
ResetTiming |
ResetTimingRecursive |
ResolveAllTrackReferences |
ResolveAllWeights |
ResolveTrackReferences |
ResolveWeights |
SetOnLoad |
SetOnUnload |
SetParent |
TaskLoadActionNode |
TokenName | Write to buffer
TRACK_PARAMETER_STRING |
UnLoad |
UnLoadAll |
Write |
Write |
writeBegin |
writeChildren |
writeComment |
WriteCondition |
writeConditions |
writeEnd |
writeTracks |
Friends
Friend | Description
class ActionNodeReference | need to be able to access private data
class ActionNodeTree |


Members

Legend
Data Member
protected
Method
virtual
abstract


ActionNode Class Methods

ActionNode Class Methods
ActionNode Class
Methods
Method | Description
AddBranch | Add Resources
AddChildActionNode |
AddChildActionNodes |
AddCondition |
AddRoot |
AddStuff |
AddTrack |
AddTracksBank |
BalanceWeights |
ChangeChildPriority |
ChangeConditionPriority |
ChangePriority |
ChangeTrackPriority |
ClearChildNodes | never call clear in the real game, only in resource compiler outside of Begin/EndBuild
ClearRoots |
Create |
CreateIArchive |
DATAMEMEBERS_INTERFACE_NO_NAME |
DeInit |
DeleteChildActionNodes | Remove Resources
DeleteCondition |
DeleteTrack |
DumpTiming |
DumpTimingRecursive |
EvalRemote | : evalutes the remtoe conditions for this node. Return false if any condition objects.
EvalRemoteTransition | : evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.
Find |
FindChildNode |
FindFirstPlayable |
FindRoot | Find methods... should rework this
GetChild |
GetChildCount | Traversal
GetCNamePath | Get Resource for views
GetCondition |
GetConditionCount |
GetConditionGroup |
GetCondtionFormat |
GetFileRoot |
GetName |
GetName |
GetNameFullPath |
GetNameFullPathDebug |
GetParent |
GetPathCRC | MP functionality
GetPriority | Sibling Position Child Priority
GetRefCount |
GetRoot |
GetTrack |
GetTrackCount |
GetTrackFormat |
GetType |
IncRefCount |
Init |
IsDescendantOf |
Load |
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
OnTreeUnload |
OperateAllNodes |
OperateChildOnNodes | Helper for recursive visit function
PrintAllNodes |
ReadConditionGroup |
RecursSetFileRoots |
RemoveChildActionNode |
ReserveTracks |
ResetTiming |
ResetTimingRecursive |
ResolveAllTrackReferences |
ResolveAllWeights |
ResolveTrackReferences |
ResolveWeights |
SetOnLoad |
SetOnUnload |
SetParent |
TaskLoadActionNode |
TokenName | Write to buffer
TRACK_PARAMETER_STRING |
UnLoad |
UnLoadAll |
Write |
Write |
writeBegin |
writeChildren |
writeComment |
WriteCondition |
writeConditions |
writeEnd |
writeTracks |


Methods

Legend
Method
abstract
virtual
protected


ActionNode Class Structs

ActionNode Class Structs
ActionNode Class
Structs
Struct | Description
ActionTreeTaskParams |


Inheritance Hierarchy

Inheritance Hierarchy
ActionNode Class
Inheritance Hierarchy
rage::IName
    rage::IArchive
        ActionNode
            rage::ActionNodeImplementation
            rage::ActionNodeReference


ActionNodeBank Class Constructors

ActionNodeBank Class Constructors
ActionNodeBank Class
Constructors
Constructor | Description
ActionNode |
ActionNodeBank |
ActionNodeImplementation |
IArchive |


ActionNodeBank Class Data Members

ActionNodeBank Class Data Members
ActionNodeBank Class
Data Members
Data Member | Description
m_bUpdatedOnce |
m_bViewExpanded |
m_childNodes |
m_Conditions |
m_FileRoot | Points to root node of file for ref counting fun
m_GlobalEditPriority |
m_Name |
m_OnLoad |
m_OnUnload |
m_Pad |
m_parent |
m_PathCRC | used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed
m_Root |
m_tracks |
m_Type |
RORC_VERSION | Don't forget to bump this whenever this structure changes
sm_ActFullPath |
sm_ActPath |
sm_OnTreeUnloadCallback |
sm_PostLoadCallback |
sm_RscFirstPass | set to false the second time through


ActionNodeBank Class Destructors

ActionNodeBank Class Destructors
ActionNodeBank Class
Destructors
Destructor | Description
~ActionNode |
~ActionNodeBank |
~ActionNodeImplementation |
~IArchive |
~IName |


ActionNodeBank Class Friends

ActionNodeBank Class Friends
ActionNodeBank Class
Friends
Friend | Description
class ActionNodeReference | need to be able to access private data
class ActionNodeTree |


Legend

Legend
ActionNodeBank Class
Legend
Method
virtual
abstract
protected
Data Member


ActionNodeBank Class Members

ActionNodeBank Class Members
ActionNodeBank Class
Members
Constructors
Constructor | Description
ActionNode |
ActionNodeBank |
ActionNodeImplementation |
IArchive |
Destructors
Destructor | Description
~ActionNode |
~ActionNodeBank |
~ActionNodeImplementation |
~IArchive |
~IName |
Methods
Method | Description
AddBranch | Add Resources
AddChildActionNode |
AddChildActionNodes |
AddCondition |
AddCondition |
AddRoot |
AddStuff |
AddTrack |
AddTrack |
AddTracksBank |
BalanceWeights |
ChangeChildPriority |
ChangeConditionPriority |
ChangeConditionPriority |
ChangePriority |
ChangeTrackPriority |
ChangeTrackPriority |
ClearChildNodes | never call clear in the real game, only in resource compiler outside of Begin/EndBuild
ClearRoots |
Create |
CreateIArchive |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DeInit |
DeleteChildActionNodes | Remove Resources
DeleteCondition |
DeleteCondition |
DeleteTrack |
DeleteTrack |
DumpTiming |
DumpTimingRecursive |
EvalRemote | : evalutes the remtoe conditions for this node. Return false if any condition objects.
EvalRemoteTransition | : evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.
Find |
FindChildNode |
FindFirstPlayable |
FindRoot | Find methods... should rework this
GetChild |
GetChildCount | Traversal
GetCNamePath | Get Resource for views
GetCondition |
GetCondition |
GetConditionCount |
GetConditionCount | Get Resource for views
GetConditionGroup |
GetConditionGroup |
GetCondtionFormat |
GetCondtionFormat |
GetFileRoot |
GetName |
GetName |
GetName |
GetNameFullPath |
GetNameFullPathDebug |
GetParent |
GetPathCRC | MP functionality
GetPriority | Sibling Position Child Priority
GetRefCount |
GetRoot |
GetTrack |
GetTrack |
GetTrackCount |
GetTrackCount |
GetTrackFormat |
GetTrackFormat |
GetType |
IncRefCount |
Init |
IsDescendantOf |
Load |
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
OnTreeUnload |
OperateAllNodes |
OperateChildOnNodes | Helper for recursive visit function
PrintAllNodes |
ReadConditionGroup |
ReadConditionGroup |
RecursSetFileRoots |
RemoveChildActionNode |
ReserveTracks |
ReserveTracks |
ResetTiming |
ResetTimingRecursive |
ResolveAllTrackReferences |
ResolveAllWeights |
ResolveTrackReferences |
ResolveWeights |
ResolveWeights |
SetOnLoad |
SetOnUnload |
SetParent |
TaskLoadActionNode |
TokenName | Write to buffer
TokenName | Write to buffer
TRACK_PARAMETER_STRING |
UnLoad |
UnLoadAll |
Write |
Write |
writeBegin |
writeChildren |
writeComment |
WriteCondition |
WriteCondition |
writeConditions |
writeEnd |
writeTracks |
Data Members
Data Member | Description
m_bUpdatedOnce |
m_bViewExpanded |
m_childNodes |
m_Conditions |
m_FileRoot | Points to root node of file for ref counting fun
m_GlobalEditPriority |
m_Name |
m_OnLoad |
m_OnUnload |
m_Pad |
m_parent |
m_PathCRC | used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed
m_Root |
m_tracks |
m_Type |
RORC_VERSION | Don't forget to bump this whenever this structure changes
sm_ActFullPath |
sm_ActPath |
sm_OnTreeUnloadCallback |
sm_PostLoadCallback |
sm_RscFirstPass | set to false the second time through
Structs
Struct | Description
ActionTreeTaskParams |
Friends
Friend | Description
class ActionNodeReference | need to be able to access private data
class ActionNodeTree |


Members

Legend
Method
virtual
abstract
protected
Data Member


ActionNodeBank Class Methods

ActionNodeBank Class Methods
ActionNodeBank Class
Methods
Method | Description
AddBranch | Add Resources
AddChildActionNode |
AddChildActionNodes |
AddCondition |
AddCondition |
AddRoot |
AddStuff |
AddTrack |
AddTrack |
AddTracksBank |
BalanceWeights |
ChangeChildPriority |
ChangeConditionPriority |
ChangeConditionPriority |
ChangePriority |
ChangeTrackPriority |
ChangeTrackPriority |
ClearChildNodes | never call clear in the real game, only in resource compiler outside of Begin/EndBuild
ClearRoots |
Create |
CreateIArchive |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DeInit |
DeleteChildActionNodes | Remove Resources
DeleteCondition |
DeleteCondition |
DeleteTrack |
DeleteTrack |
DumpTiming |
DumpTimingRecursive |
EvalRemote | : evalutes the remtoe conditions for this node. Return false if any condition objects.
EvalRemoteTransition | : evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.
Find |
FindChildNode |
FindFirstPlayable |
FindRoot | Find methods... should rework this
GetChild |
GetChildCount | Traversal
GetCNamePath | Get Resource for views
GetCondition |
GetCondition |
GetConditionCount |
GetConditionCount | Get Resource for views
GetConditionGroup |
GetConditionGroup |
GetCondtionFormat |
GetCondtionFormat |
GetFileRoot |
GetName |
GetName |
GetName |
GetNameFullPath |
GetNameFullPathDebug |
GetParent |
GetPathCRC | MP functionality
GetPriority | Sibling Position Child Priority
GetRefCount |
GetRoot |
GetTrack |
GetTrack |
GetTrackCount |
GetTrackCount |
GetTrackFormat |
GetTrackFormat |
GetType |
IncRefCount |
Init |
IsDescendantOf |
Load |
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
OnTreeUnload |
OperateAllNodes |
OperateChildOnNodes | Helper for recursive visit function
PrintAllNodes |
ReadConditionGroup |
ReadConditionGroup |
RecursSetFileRoots |
RemoveChildActionNode |
ReserveTracks |
ReserveTracks |
ResetTiming |
ResetTimingRecursive |
ResolveAllTrackReferences |
ResolveAllWeights |
ResolveTrackReferences |
ResolveWeights |
ResolveWeights |
SetOnLoad |
SetOnUnload |
SetParent |
TaskLoadActionNode |
TokenName | Write to buffer
TokenName | Write to buffer
TRACK_PARAMETER_STRING |
UnLoad |
UnLoadAll |
Write |
Write |
writeBegin |
writeChildren |
writeComment |
WriteCondition |
WriteCondition |
writeConditions |
writeEnd |
writeTracks |


ActionNodeBank Class Structs

ActionNodeBank Class Structs
ActionNodeBank Class
Structs
Struct | Description
ActionTreeTaskParams |


Inheritance Hierarchy

Inheritance Hierarchy
ActionNodeBank Class
Inheritance Hierarchy
rage::IName
    rage::IArchive
        rage::ActionNode
            rage::ActionNodeImplementation
                ActionNodeBank


ActionNodeDebugName Struct Constructors

ActionNodeDebugName Struct Constructors
ActionNodeDebugName Struct
Constructors
Constructor | Description
ActionNodeDebugName |


ActionNodeDebugName Struct Data Members

ActionNodeDebugName Struct Data Members
ActionNodeDebugName Struct
Data Members
Data Member | Description
m_Name |


Legend

Legend
ActionNodeDebugName Struct
Legend
Data Member
Method


ActionNodeDebugName Struct Members

ActionNodeDebugName Struct Members
ActionNodeDebugName Struct
Members
Data Members
Data Member | Description
m_Name |
Constructors
Constructor | Description
ActionNodeDebugName |
Operators
Operator | Description
() |


ActionNodeDebugName Struct Operators

ActionNodeDebugName Struct Operators
ActionNodeDebugName Struct
Operators
Operator | Description
() |


Operators

Legend
Method


Inheritance Hierarchy

Inheritance Hierarchy
ActionNodeDebugName Struct
Inheritance Hierarchy
ActionNodeDebugName


ActionNodeFileReference Class Constructors

ActionNodeFileReference Class Constructors
ActionNodeFileReference Class
Constructors
Constructor | Description
ActionNode |
ActionNodeFileReference |
ActionNodeReference |
IArchive |
IDataMembers |


ActionNodeFileReference Class Data Members

ActionNodeFileReference Class Data Members
ActionNodeFileReference Class
Data Members
Data Member | Description
m_bUpdatedOnce |
m_bViewExpanded |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_childNodes |
m_FileRoot | Points to root node of file for ref counting fun
m_GlobalEditPriority |
m_nameFullPath |
m_OnLoad |
m_OnUnload |
m_Pad |
m_parent |
m_PathCRC | used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed
m_referenceName |
m_referenceNode |
m_Root |
m_Type |
RORC_VERSION | Don't forget to bump this whenever this structure changes
sm_ActFullPath |
sm_ActPath |
sm_OnTreeUnloadCallback |
sm_PostLoadCallback |
sm_RscFirstPass | set to false the second time through


ActionNodeFileReference Class Destructors

ActionNodeFileReference Class Destructors
ActionNodeFileReference Class
Destructors
Destructor | Description
~ActionNode |
~ActionNodeFileReference |
~ActionNodeReference |
~IArchive |
~IDataMembers |
~IName |


ActionNodeFileReference Class Friends

ActionNodeFileReference Class Friends
ActionNodeFileReference Class
Friends
Friend | Description
class ActionNodeReference | need to be able to access private data
class ActionNodeTree |


Legend

Legend
ActionNodeFileReference Class
Legend
Method
virtual
abstract
protected
Data Member


ActionNodeFileReference Class Members

ActionNodeFileReference Class Members
ActionNodeFileReference Class
Members
Constructors
Constructor | Description
ActionNode |
ActionNodeFileReference |
ActionNodeReference |
IArchive |
IDataMembers |
Destructors
Destructor | Description
~ActionNode |
~ActionNodeFileReference |
~ActionNodeReference |
~IArchive |
~IDataMembers |
~IName |
Methods
Method | Description
AddBranch | Add Resources
AddChildActionNode |
AddChildActionNodes |
AddCondition |
AddCondition |
AddRoot |
AddStuff |
AddTrack |
AddTrack |
AddTracksBank |
BalanceWeights |
ChangeChildPriority |
ChangeConditionPriority |
ChangePriority |
ChangeTrackPriority |
ClearChildNodes | never call clear in the real game, only in resource compiler outside of Begin/EndBuild
ClearRoots |
Create |
CreateIArchive |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DeclareStruct |
DeInit |
DeleteChildActionNodes | Remove Resources
DeleteCondition |
DeleteCondition |
DeleteTrack |
DumpTiming |
DumpTimingRecursive |
EvalRemote | : evalutes the remtoe conditions for this node. Return false if any condition objects.
EvalRemoteTransition | : evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.
Find |
FindChildNode |
FindFirstPlayable |
FindRoot | Find methods... should rework this
GetActionNode |
GetArchiveFileRecord | FileArchive interfaces
GetChild |
GetChild |
GetChildCount | Traversal
GetChildCount | Traversal
GetCNamePath | Get Resource for views
GetCondition |
GetCondition |
GetConditionCount |
GetConditionCount | Get Resource for views
GetConditionGroup |
GetConditionGroup |
GetCondtionFormat |
GetCondtionFormat |
GetFileName |
GetFileRoot |
GetFullPathName |
GetMember |
GetName |
GetName |
GetName |
GetNameFullPath |
GetNameFullPathDebug |
GetNumMembers |
GetParent |
GetPathCRC | MP functionality
GetPathName |
GetPriority | Sibling Position Child Priority
GetRefCount |
GetReferenceFullPath |
GetReferenceName |
GetRoot |
GetTrack |
GetTrack |
GetTrackCount |
GetTrackCount |
GetTrackFormat |
GetTrackFormat |
GetType |
IncRefCount |
Init |
IsDescendantOf |
IsNull |
Load |
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
OnTreeUnload |
OperateAllNodes |
OperateChildOnNodes | Helper for recursive visit function
PrintAllNodes |
Read |
Read |
ReadConditionGroup |
ReadConditionGroup |
ReadFile | The Actual SubTreeFile
RecursSetFileRoots |
RecursSetFileRoots |
RemoveChildActionNode |
ReserveTracks |
ReserveTracks |
Reset |
ResetTiming |
ResetTimingRecursive |
ResolveAllTrackReferences |
ResolveAllWeights |
ResolveReference | Try to find a node to connect to...
ResolveTrackReferences |
ResolveWeights |
SetActionNode |
SetFileName |
SetFullPathName |
SetOnLoad |
SetOnUnload |
SetParent |
SetPathName |
SetReferenceName |
TaskLoadActionNode |
TokenName | Write to buffer
TokenName | Write to buffer
TRACK_PARAMETER_STRING |
UnLoad |
UnLoadAll |
Write |
Write |
Write |
Write |
writeBegin |
writeChildren |
writeComment |
WriteCondition |
WriteCondition |
writeConditions |
writeEnd |
writeTracks |
Data Members
Data Member | Description
m_bUpdatedOnce |
m_bViewExpanded |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_childNodes |
m_FileRoot | Points to root node of file for ref counting fun
m_GlobalEditPriority |
m_nameFullPath |
m_OnLoad |
m_OnUnload |
m_Pad |
m_parent |
m_PathCRC | used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed
m_referenceName |
m_referenceNode |
m_Root |
m_Type |
RORC_VERSION | Don't forget to bump this whenever this structure changes
sm_ActFullPath |
sm_ActPath |
sm_OnTreeUnloadCallback |
sm_PostLoadCallback |
sm_RscFirstPass | set to false the second time through
Structs
Struct | Description
ActionTreeTaskParams |
Friends
Friend | Description
class ActionNodeReference | need to be able to access private data
class ActionNodeTree |


ActionNodeFileReference Class Methods

ActionNodeFileReference Class Methods
ActionNodeFileReference Class
Methods
Method | Description
AddBranch | Add Resources
AddChildActionNode |
AddChildActionNodes |
AddCondition |
AddCondition |
AddRoot |
AddStuff |
AddTrack |
AddTrack |
AddTracksBank |
BalanceWeights |
ChangeChildPriority |
ChangeConditionPriority |
ChangePriority |
ChangeTrackPriority |
ClearChildNodes | never call clear in the real game, only in resource compiler outside of Begin/EndBuild
ClearRoots |
Create |
CreateIArchive |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DeclareStruct |
DeInit |
DeleteChildActionNodes | Remove Resources
DeleteCondition |
DeleteCondition |
DeleteTrack |
DumpTiming |
DumpTimingRecursive |
EvalRemote | : evalutes the remtoe conditions for this node. Return false if any condition objects.
EvalRemoteTransition | : evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.
Find |
FindChildNode |
FindFirstPlayable |
FindRoot | Find methods... should rework this
GetActionNode |
GetArchiveFileRecord | FileArchive interfaces
GetChild |
GetChild |
GetChildCount | Traversal
GetChildCount | Traversal
GetCNamePath | Get Resource for views
GetCondition |
GetCondition |
GetConditionCount |
GetConditionCount | Get Resource for views
GetConditionGroup |
GetConditionGroup |
GetCondtionFormat |
GetCondtionFormat |
GetFileName |
GetFileRoot |
GetFullPathName |
GetMember |
GetName |
GetName |
GetName |
GetNameFullPath |
GetNameFullPathDebug |
GetNumMembers |
GetParent |
GetPathCRC | MP functionality
GetPathName |
GetPriority | Sibling Position Child Priority
GetRefCount |
GetReferenceFullPath |
GetReferenceName |
GetRoot |
GetTrack |
GetTrack |
GetTrackCount |
GetTrackCount |
GetTrackFormat |
GetTrackFormat |
GetType |
IncRefCount |
Init |
IsDescendantOf |
IsNull |
Load |
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
OnTreeUnload |
OperateAllNodes |
OperateChildOnNodes | Helper for recursive visit function
PrintAllNodes |
Read |
Read |
ReadConditionGroup |
ReadConditionGroup |
ReadFile | The Actual SubTreeFile
RecursSetFileRoots |
RecursSetFileRoots |
RemoveChildActionNode |
ReserveTracks |
ReserveTracks |
Reset |
ResetTiming |
ResetTimingRecursive |
ResolveAllTrackReferences |
ResolveAllWeights |
ResolveReference | Try to find a node to connect to...
ResolveTrackReferences |
ResolveWeights |
SetActionNode |
SetFileName |
SetFullPathName |
SetOnLoad |
SetOnUnload |
SetParent |
SetPathName |
SetReferenceName |
TaskLoadActionNode |
TokenName | Write to buffer
TokenName | Write to buffer
TRACK_PARAMETER_STRING |
UnLoad |
UnLoadAll |
Write |
Write |
Write |
Write |
writeBegin |
writeChildren |
writeComment |
WriteCondition |
WriteCondition |
writeConditions |
writeEnd |
writeTracks |


ActionNodeFileReference Class Structs

ActionNodeFileReference Class Structs
ActionNodeFileReference Class
Structs
Struct | Description
ActionTreeTaskParams |


Inheritance Hierarchy

Inheritance Hierarchy
ActionNodeFileReference Class
Inheritance Hierarchy
rage::IName
    rage::IArchive
        rage::ActionNode
            rage::ActionNodeReference, rage::IDataMembers
                    ActionNodeFileReference


ActionNodeImplementation Class Constructors

ActionNodeImplementation Class Constructors
ActionNodeImplementation Class
Constructors
Constructor | Description
ActionNode |
ActionNodeImplementation |
IArchive |


ActionNodeImplementation Class Data Members

ActionNodeImplementation Class Data Members
ActionNodeImplementation Class
Data Members
Data Member | Description
m_bUpdatedOnce |
m_bViewExpanded |
m_childNodes |
m_Conditions |
m_FileRoot | Points to root node of file for ref counting fun
m_GlobalEditPriority |
m_Name |
m_OnLoad |
m_OnUnload |
m_Pad |
m_parent |
m_PathCRC | used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed
m_Root |
m_tracks |
m_Type |
RORC_VERSION | Don't forget to bump this whenever this structure changes
sm_ActFullPath |
sm_ActPath |
sm_OnTreeUnloadCallback |
sm_PostLoadCallback |
sm_RscFirstPass | set to false the second time through


ActionNodeImplementation Class Destructors

ActionNodeImplementation Class Destructors
ActionNodeImplementation Class
Destructors
Destructor | Description
~ActionNode |
~ActionNodeImplementation |
~IArchive |
~IName |


ActionNodeImplementation Class Friends

ActionNodeImplementation Class Friends
ActionNodeImplementation Class
Friends
Friend | Description
class ActionNodeReference | need to be able to access private data
class ActionNodeTree |


Legend

Legend
ActionNodeImplementation Class
Legend
Data Member
protected
Method
virtual
abstract


ActionNodeImplementation Class Members

ActionNodeImplementation Class Members
ActionNodeImplementation Class
Members
Data Members
Data Member | Description
m_bUpdatedOnce |
m_bViewExpanded |
m_childNodes |
m_Conditions |
m_FileRoot | Points to root node of file for ref counting fun
m_GlobalEditPriority |
m_Name |
m_OnLoad |
m_OnUnload |
m_Pad |
m_parent |
m_PathCRC | used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed
m_Root |
m_tracks |
m_Type |
RORC_VERSION | Don't forget to bump this whenever this structure changes
sm_ActFullPath |
sm_ActPath |
sm_OnTreeUnloadCallback |
sm_PostLoadCallback |
sm_RscFirstPass | set to false the second time through
Constructors
Constructor | Description
ActionNode |
ActionNodeImplementation |
IArchive |
Destructors
Destructor | Description
~ActionNode |
~ActionNodeImplementation |
~IArchive |
~IName |
Methods
Method | Description
AddBranch | Add Resources
AddChildActionNode |
AddChildActionNodes |
AddCondition |
AddCondition |
AddRoot |
AddStuff |
AddTrack |
AddTrack |
AddTracksBank |
BalanceWeights |
ChangeChildPriority |
ChangeConditionPriority |
ChangeConditionPriority |
ChangePriority |
ChangeTrackPriority |
ChangeTrackPriority |
ClearChildNodes | never call clear in the real game, only in resource compiler outside of Begin/EndBuild
ClearRoots |
Create |
CreateIArchive |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DeInit |
DeleteChildActionNodes | Remove Resources
DeleteCondition |
DeleteCondition |
DeleteTrack |
DeleteTrack |
DumpTiming |
DumpTimingRecursive |
EvalRemote | : evalutes the remtoe conditions for this node. Return false if any condition objects.
EvalRemoteTransition | : evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.
Find |
FindChildNode |
FindFirstPlayable |
FindRoot | Find methods... should rework this
GetChild |
GetChildCount | Traversal
GetCNamePath | Get Resource for views
GetCondition |
GetCondition |
GetConditionCount |
GetConditionCount | Get Resource for views
GetConditionGroup |
GetConditionGroup |
GetCondtionFormat |
GetCondtionFormat |
GetFileRoot |
GetName |
GetName |
GetName |
GetNameFullPath |
GetNameFullPathDebug |
GetParent |
GetPathCRC | MP functionality
GetPriority | Sibling Position Child Priority
GetRefCount |
GetRoot |
GetTrack |
GetTrack |
GetTrackCount |
GetTrackCount |
GetTrackFormat |
GetTrackFormat |
GetType |
IncRefCount |
Init |
IsDescendantOf |
Load |
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
OnTreeUnload |
OperateAllNodes |
OperateChildOnNodes | Helper for recursive visit function
PrintAllNodes |
ReadConditionGroup |
ReadConditionGroup |
RecursSetFileRoots |
RemoveChildActionNode |
ReserveTracks |
ReserveTracks |
ResetTiming |
ResetTimingRecursive |
ResolveAllTrackReferences |
ResolveAllWeights |
ResolveTrackReferences |
ResolveWeights |
SetOnLoad |
SetOnUnload |
SetParent |
TaskLoadActionNode |
TokenName | Write to buffer
TRACK_PARAMETER_STRING |
UnLoad |
UnLoadAll |
Write |
Write |
writeBegin |
writeChildren |
writeComment |
WriteCondition |
WriteCondition |
writeConditions |
writeEnd |
writeTracks |
Structs
Struct | Description
ActionTreeTaskParams |
Friends
Friend | Description
class ActionNodeReference | need to be able to access private data
class ActionNodeTree |


ActionNodeImplementation Class Methods

ActionNodeImplementation Class Methods
ActionNodeImplementation Class
Methods
Method | Description
AddBranch | Add Resources
AddChildActionNode |
AddChildActionNodes |
AddCondition |
AddCondition |
AddRoot |
AddStuff |
AddTrack |
AddTrack |
AddTracksBank |
BalanceWeights |
ChangeChildPriority |
ChangeConditionPriority |
ChangeConditionPriority |
ChangePriority |
ChangeTrackPriority |
ChangeTrackPriority |
ClearChildNodes | never call clear in the real game, only in resource compiler outside of Begin/EndBuild
ClearRoots |
Create |
CreateIArchive |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DeInit |
DeleteChildActionNodes | Remove Resources
DeleteCondition |
DeleteCondition |
DeleteTrack |
DeleteTrack |
DumpTiming |
DumpTimingRecursive |
EvalRemote | : evalutes the remtoe conditions for this node. Return false if any condition objects.
EvalRemoteTransition | : evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.
Find |
FindChildNode |
FindFirstPlayable |
FindRoot | Find methods... should rework this
GetChild |
GetChildCount | Traversal
GetCNamePath | Get Resource for views
GetCondition |
GetCondition |
GetConditionCount |
GetConditionCount | Get Resource for views
GetConditionGroup |
GetConditionGroup |
GetCondtionFormat |
GetCondtionFormat |
GetFileRoot |
GetName |
GetName |
GetName |
GetNameFullPath |
GetNameFullPathDebug |
GetParent |
GetPathCRC | MP functionality
GetPriority | Sibling Position Child Priority
GetRefCount |
GetRoot |
GetTrack |
GetTrack |
GetTrackCount |
GetTrackCount |
GetTrackFormat |
GetTrackFormat |
GetType |
IncRefCount |
Init |
IsDescendantOf |
Load |
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
OnTreeUnload |
OperateAllNodes |
OperateChildOnNodes | Helper for recursive visit function
PrintAllNodes |
ReadConditionGroup |
ReadConditionGroup |
RecursSetFileRoots |
RemoveChildActionNode |
ReserveTracks |
ReserveTracks |
ResetTiming |
ResetTimingRecursive |
ResolveAllTrackReferences |
ResolveAllWeights |
ResolveTrackReferences |
ResolveWeights |
SetOnLoad |
SetOnUnload |
SetParent |
TaskLoadActionNode |
TokenName | Write to buffer
TRACK_PARAMETER_STRING |
UnLoad |
UnLoadAll |
Write |
Write |
writeBegin |
writeChildren |
writeComment |
WriteCondition |
WriteCondition |
writeConditions |
writeEnd |
writeTracks |


ActionNodeImplementation Class Structs

ActionNodeImplementation Class Structs
ActionNodeImplementation Class
Structs
Struct | Description
ActionTreeTaskParams |


Inheritance Hierarchy

Inheritance Hierarchy
ActionNodeImplementation Class
Inheritance Hierarchy
rage::IName
    rage::IArchive
        rage::ActionNode
            ActionNodeImplementation
                rage::ActionNodeBank
                rage::ActionNodePlayable


ActionNodeLwRef Class Constructors

ActionNodeLwRef Class Constructors
ActionNodeLwRef Class
Constructors
Constructor | Description
ActionNodeLwRef |


ActionNodeLwRef Class Destructors

ActionNodeLwRef Class Destructors
ActionNodeLwRef Class
Destructors
Destructor | Description
~ActionNodeLwRef |


Legend

Legend
ActionNodeLwRef Class
Legend
Method


ActionNodeLwRef Class Members

ActionNodeLwRef Class Members
ActionNodeLwRef Class
Members
Constructors
Constructor | Description
ActionNodeLwRef |
Destructors
Destructor | Description
~ActionNodeLwRef |
Methods
Method | Description
DeclareStruct |
GetActionNode |
IMPLEMENT_PLACE_INLINE |
IsNull |
SetActionNode |
SetParent |
SetReferenceName |


Members

Legend
Method


ActionNodeLwRef Class Methods

ActionNodeLwRef Class Methods
ActionNodeLwRef Class
Methods
Method | Description
DeclareStruct |
GetActionNode |
IMPLEMENT_PLACE_INLINE |
IsNull |
SetActionNode |
SetParent |
SetReferenceName |


Inheritance Hierarchy

Inheritance Hierarchy
ActionNodeLwRef Class
Inheritance Hierarchy
ActionNodeLwRef


ActionNodePlayable Class Constructors

ActionNodePlayable Class Constructors
ActionNodePlayable Class
Constructors
Constructor | Description
ActionNode |
ActionNodeImplementation |
ActionNodePlayable |
IArchive |


ActionNodePlayable Class Data Members

ActionNodePlayable Class Data Members
ActionNodePlayable Class
Data Members
Data Member | Description
m_bUpdatedOnce |
m_bViewExpanded |
m_childNodes |
m_Conditions |
m_FileRoot | Points to root node of file for ref counting fun
m_GlobalEditPriority |
m_Name |
m_OnLoad |
m_OnUnload |
m_Pad |
m_parent |
m_PathCRC | used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed
m_Root |
m_tracks |
m_Type |
RORC_VERSION | Don't forget to bump this whenever this structure changes
sm_ActFullPath |
sm_ActPath |
sm_OnTreeUnloadCallback |
sm_PostLoadCallback |
sm_RscFirstPass | set to false the second time through


ActionNodePlayable Class Destructors

ActionNodePlayable Class Destructors
ActionNodePlayable Class
Destructors
Destructor | Description
~ActionNode |
~ActionNodeImplementation |
~ActionNodePlayable |
~IArchive |
~IName |


ActionNodePlayable Class Friends

ActionNodePlayable Class Friends
ActionNodePlayable Class
Friends
Friend | Description
class ActionNodeReference | need to be able to access private data
class ActionNodeTree |


Legend

Legend
ActionNodePlayable Class
Legend
Method
virtual
abstract
protected
Data Member


ActionNodePlayable Class Members

ActionNodePlayable Class Members
ActionNodePlayable Class
Members
Constructors
Constructor | Description
ActionNode |
ActionNodeImplementation |
ActionNodePlayable |
IArchive |
Destructors
Destructor | Description
~ActionNode |
~ActionNodeImplementation |
~ActionNodePlayable |
~IArchive |
~IName |
Methods
Method | Description
AddBranch | Add Resources
AddChildActionNode |
AddChildActionNodes |
AddCondition |
AddCondition |
AddRoot |
AddStuff |
AddStuff |
AddTrack |
AddTrack |
AddTrack |
AddTracksBank |
BalanceWeights |
ChangeChildPriority |
ChangeConditionPriority |
ChangeConditionPriority |
ChangePriority |
ChangeTrackPriority |
ChangeTrackPriority |
ClearChildNodes | never call clear in the real game, only in resource compiler outside of Begin/EndBuild
ClearRoots |
Create |
CreateIArchive |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE | This is only for editing reasons. This is a level that aids in production flow. By assigning certain editing tasks with a "Priority" you can hand off work to different people and track changes made at lesser priority levels We'll use an increasing number for higher priority: E.G. Default:0 Visual Effects:1 Sound:2
DECLARE_PLACE |
DeclareStruct |
DeInit |
DeleteChildActionNodes | Remove Resources
DeleteCondition |
DeleteCondition |
DeleteTrack |
DeleteTrack |
DumpTiming |
DumpTimingRecursive |
EvalRemote | : evalutes the remtoe conditions for this node. Return false if any condition objects.
EvalRemoteTransition | : evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.
Find |
FindChildNode |
FindFirstPlayable |
FindRoot | Find methods... should rework this
GetChild |
GetChildCount | Traversal
GetCNamePath | Get Resource for views
GetCondition |
GetCondition |
GetConditionCount |
GetConditionCount | Get Resource for views
GetConditionGroup |
GetConditionGroup |
GetCondtionFormat |
GetCondtionFormat |
GetEditPriority |
GetFileRoot |
GetName |
GetName |
GetName |
GetNameFullPath |
GetNameFullPathDebug |
GetParent |
GetPathCRC | MP functionality
GetPriority | Sibling Position Child Priority
GetRefCount |
GetRoot |
GetTrack |
GetTrack |
GetTrackCount |
GetTrackCount |
GetTrackFormat |
GetTrackFormat |
GetType |
IncRefCount |
Init |
IsDescendantOf |
Load |
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
OnTreeUnload |
OperateAllNodes |
OperateChildOnNodes | Helper for recursive visit function
PrintAllNodes |
ReadConditionGroup |
ReadConditionGroup |
RecursSetFileRoots |
RemoveChildActionNode |
ReserveTracks |
ReserveTracks |
ResetTiming |
ResetTimingRecursive |
ResolveAllTrackReferences |
ResolveAllWeights |
ResolveTrackReferences |
ResolveWeights |
SetEditPriority |
SetOnLoad |
SetOnUnload |
SetParent |
TaskLoadActionNode |
TokenName | Write to buffer
TokenName | Write to buffer
TRACK_PARAMETER_STRING |
UnLoad |
UnLoadAll |
Update | Observer Interface for EditPriority
UpdateDetach |
Write |
Write |
Write |
writeBegin |
writeChildren |
writeComment |
WriteCondition |
WriteCondition |
writeConditions |
writeEnd |
writeTracks |
Data Members
Data Member | Description
m_bUpdatedOnce |
m_bViewExpanded |
m_childNodes |
m_Conditions |
m_FileRoot | Points to root node of file for ref counting fun
m_GlobalEditPriority |
m_Name |
m_OnLoad |
m_OnUnload |
m_Pad |
m_parent |
m_PathCRC | used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed
m_Root |
m_tracks |
m_Type |
RORC_VERSION | Don't forget to bump this whenever this structure changes
sm_ActFullPath |
sm_ActPath |
sm_OnTreeUnloadCallback |
sm_PostLoadCallback |
sm_RscFirstPass | set to false the second time through
Structs
Struct | Description
ActionTreeTaskParams |
Friends
Friend | Description
class ActionNodeReference | need to be able to access private data
class ActionNodeTree |


ActionNodePlayable Class Methods

ActionNodePlayable Class Methods
ActionNodePlayable Class
Methods
Method | Description
AddBranch | Add Resources
AddChildActionNode |
AddChildActionNodes |
AddCondition |
AddCondition |
AddRoot |
AddStuff |
AddStuff |
AddTrack |
AddTrack |
AddTrack |
AddTracksBank |
BalanceWeights |
ChangeChildPriority |
ChangeConditionPriority |
ChangeConditionPriority |
ChangePriority |
ChangeTrackPriority |
ChangeTrackPriority |
ClearChildNodes | never call clear in the real game, only in resource compiler outside of Begin/EndBuild
ClearRoots |
Create |
CreateIArchive |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE | This is only for editing reasons. This is a level that aids in production flow. By assigning certain editing tasks with a "Priority" you can hand off work to different people and track changes made at lesser priority levels We'll use an increasing number for higher priority: E.G. Default:0 Visual Effects:1 Sound:2
DECLARE_PLACE |
DeclareStruct |
DeInit |
DeleteChildActionNodes | Remove Resources
DeleteCondition |
DeleteCondition |
DeleteTrack |
DeleteTrack |
DumpTiming |
DumpTimingRecursive |
EvalRemote | : evalutes the remtoe conditions for this node. Return false if any condition objects.
EvalRemoteTransition | : evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.
Find |
FindChildNode |
FindFirstPlayable |
FindRoot | Find methods... should rework this
GetChild |
GetChildCount | Traversal
GetCNamePath | Get Resource for views
GetCondition |
GetCondition |
GetConditionCount |
GetConditionCount | Get Resource for views
GetConditionGroup |
GetConditionGroup |
GetCondtionFormat |
GetCondtionFormat |
GetEditPriority |
GetFileRoot |
GetName |
GetName |
GetName |
GetNameFullPath |
GetNameFullPathDebug |
GetParent |
GetPathCRC | MP functionality
GetPriority | Sibling Position Child Priority
GetRefCount |
GetRoot |
GetTrack |
GetTrack |
GetTrackCount |
GetTrackCount |
GetTrackFormat |
GetTrackFormat |
GetType |
IncRefCount |
Init |
IsDescendantOf |
Load |
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
OnTreeUnload |
OperateAllNodes |
OperateChildOnNodes | Helper for recursive visit function
PrintAllNodes |
ReadConditionGroup |
ReadConditionGroup |
RecursSetFileRoots |
RemoveChildActionNode |
ReserveTracks |
ReserveTracks |
ResetTiming |
ResetTimingRecursive |
ResolveAllTrackReferences |
ResolveAllWeights |
ResolveTrackReferences |
ResolveWeights |
SetEditPriority |
SetOnLoad |
SetOnUnload |
SetParent |
TaskLoadActionNode |
TokenName | Write to buffer
TokenName | Write to buffer
TRACK_PARAMETER_STRING |
UnLoad |
UnLoadAll |
Update | Observer Interface for EditPriority
UpdateDetach |
Write |
Write |
Write |
writeBegin |
writeChildren |
writeComment |
WriteCondition |
WriteCondition |
writeConditions |
writeEnd |
writeTracks |


ActionNodePlayable Class Structs

ActionNodePlayable Class Structs
ActionNodePlayable Class
Structs
Struct | Description
ActionTreeTaskParams |


Inheritance Hierarchy

Inheritance Hierarchy
ActionNodePlayable Class
Inheritance Hierarchy
rage::IName
    rage::IArchive
        rage::ActionNode
            rage::ActionNodeImplementation
                ActionNodePlayable


ActionNodeReference Class Constructors

ActionNodeReference Class Constructors
ActionNodeReference Class
Constructors
Constructor | Description
ActionNode |
ActionNodeReference |
IArchive |


ActionNodeReference Class Data Members

ActionNodeReference Class Data Members
ActionNodeReference Class
Data Members
Data Member | Description
m_bUpdatedOnce |
m_bViewExpanded |
m_childNodes |
m_FileRoot | Points to root node of file for ref counting fun
m_GlobalEditPriority |
m_nameFullPath |
m_OnLoad |
m_OnUnload |
m_Pad |
m_parent |
m_PathCRC | used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed
m_referenceName |
m_referenceNode |
m_Root |
m_Type |
RORC_VERSION | Don't forget to bump this whenever this structure changes
sm_ActFullPath |
sm_ActPath |
sm_OnTreeUnloadCallback |
sm_PostLoadCallback |
sm_RscFirstPass | set to false the second time through


ActionNodeReference Class Destructors

ActionNodeReference Class Destructors
ActionNodeReference Class
Destructors
Destructor | Description
~ActionNode |
~ActionNodeReference |
~IArchive |
~IName |


ActionNodeReference Class Friends

ActionNodeReference Class Friends
ActionNodeReference Class
Friends
Friend | Description
class ActionNodeReference | need to be able to access private data
class ActionNodeTree |


Legend

Legend
ActionNodeReference Class
Legend
Data Member
protected
Method
virtual
abstract


ActionNodeReference Class Members

ActionNodeReference Class Members
ActionNodeReference Class
Members
Data Members
Data Member | Description
m_bUpdatedOnce |
m_bViewExpanded |
m_childNodes |
m_FileRoot | Points to root node of file for ref counting fun
m_GlobalEditPriority |
m_nameFullPath |
m_OnLoad |
m_OnUnload |
m_Pad |
m_parent |
m_PathCRC | used by MP system to quickly ID a nodes path. Can be precalcuated but for now only done as needed
m_referenceName |
m_referenceNode |
m_Root |
m_Type |
RORC_VERSION | Don't forget to bump this whenever this structure changes
sm_ActFullPath |
sm_ActPath |
sm_OnTreeUnloadCallback |
sm_PostLoadCallback |
sm_RscFirstPass | set to false the second time through
Constructors
Constructor | Description
ActionNode |
ActionNodeReference |
IArchive |
Destructors
Destructor | Description
~ActionNode |
~ActionNodeReference |
~IArchive |
~IName |
Methods
Method | Description
AddBranch | Add Resources
AddChildActionNode |
AddChildActionNodes |
AddCondition |
AddCondition |
AddRoot |
AddStuff |
AddTrack |
AddTrack |
AddTracksBank |
BalanceWeights |
ChangeChildPriority |
ChangeConditionPriority |
ChangePriority |
ChangeTrackPriority |
ClearChildNodes | never call clear in the real game, only in resource compiler outside of Begin/EndBuild
ClearRoots |
Create |
CreateIArchive |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DeInit |
DeleteChildActionNodes | Remove Resources
DeleteCondition |
DeleteCondition |
DeleteTrack |
DumpTiming |
DumpTimingRecursive |
EvalRemote | : evalutes the remtoe conditions for this node. Return false if any condition objects.
EvalRemoteTransition | : evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.
Find |
FindChildNode |
FindFirstPlayable |
FindRoot | Find methods... should rework this
GetActionNode |
GetChild |
GetChild |
GetChildCount | Traversal
GetChildCount | Traversal
GetCNamePath | Get Resource for views
GetCondition |
GetCondition |
GetConditionCount |
GetConditionCount | Get Resource for views
GetConditionGroup |
GetConditionGroup |
GetCondtionFormat |
GetCondtionFormat |
GetFileRoot |
GetName |
GetName |
GetName |
GetNameFullPath |
GetNameFullPathDebug |
GetParent |
GetPathCRC | MP functionality
GetPriority | Sibling Position Child Priority
GetRefCount |
GetReferenceFullPath |
GetReferenceName |
GetRoot |
GetTrack |
GetTrack |
GetTrackCount |
GetTrackCount |
GetTrackFormat |
GetTrackFormat |
GetType |
IncRefCount |
Init |
IsDescendantOf |
IsNull |
Load |
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
OnTreeUnload |
OperateAllNodes |
OperateChildOnNodes | Helper for recursive visit function
PrintAllNodes |
ReadConditionGroup |
ReadConditionGroup |
RecursSetFileRoots |
RemoveChildActionNode |
ReserveTracks |
ReserveTracks |
ResetTiming |
ResetTimingRecursive |
ResolveAllTrackReferences |
ResolveAllWeights |
ResolveReference | Try to find a node to connect to...
ResolveTrackReferences |
ResolveWeights |
SetActionNode |
SetOnLoad |
SetOnUnload |
SetParent |
SetReferenceName |
TaskLoadActionNode |
TokenName | Write to buffer
TRACK_PARAMETER_STRING |
UnLoad |
UnLoadAll |
Write |
Write |
writeBegin |
writeChildren |
writeComment |
WriteCondition |
WriteCondition |
writeConditions |
writeEnd |
writeTracks |
Structs
Struct | Description
ActionTreeTaskParams |
Friends
Friend | Description
class ActionNodeReference | need to be able to access private data
class ActionNodeTree |


ActionNodeReference Class Methods

ActionNodeReference Class Methods
ActionNodeReference Class
Methods
Method | Description
AddBranch | Add Resources
AddChildActionNode |
AddChildActionNodes |
AddCondition |
AddCondition |
AddRoot |
AddStuff |
AddTrack |
AddTrack |
AddTracksBank |
BalanceWeights |
ChangeChildPriority |
ChangeConditionPriority |
ChangePriority |
ChangeTrackPriority |
ClearChildNodes | never call clear in the real game, only in resource compiler outside of Begin/EndBuild
ClearRoots |
Create |
CreateIArchive |
DATAMEMEBERS_INTERFACE_NO_NAME |
DATAMEMEBERS_INTERFACE_NO_NAME |
DeInit |
DeleteChildActionNodes | Remove Resources
DeleteCondition |
DeleteCondition |
DeleteTrack |
DumpTiming |
DumpTimingRecursive |
EvalRemote | : evalutes the remtoe conditions for this node. Return false if any condition objects.
EvalRemoteTransition | : evaluates the remote transition state from this->parent until we reach the top. If any node along the way objects to the transition, it will return false.
Find |
FindChildNode |
FindFirstPlayable |
FindRoot | Find methods... should rework this
GetActionNode |
GetChild |
GetChild |
GetChildCount | Traversal
GetChildCount | Traversal
GetCNamePath | Get Resource for views
GetCondition |
GetCondition |
GetConditionCount |
GetConditionCount | Get Resource for views
GetConditionGroup |
GetConditionGroup |
GetCondtionFormat |
GetCondtionFormat |
GetFileRoot |
GetName |
GetName |
GetName |
GetNameFullPath |
GetNameFullPathDebug |
GetParent |
GetPathCRC | MP functionality
GetPriority | Sibling Position Child Priority
GetRefCount |
GetReferenceFullPath |
GetReferenceName |
GetRoot |
GetTrack |
GetTrack |
GetTrackCount |
GetTrackCount |
GetTrackFormat |
GetTrackFormat |
GetType |
IncRefCount |
Init |
IsDescendantOf |
IsNull |
Load |
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
Match | Match function to replace callers only calling Match on the ConditionGroup of this node Banks need to have conditions evaluated through to all child playable nodes unless a valid node is found
OnTreeUnload |
OperateAllNodes |
OperateChildOnNodes | Helper for recursive visit function
PrintAllNodes |
ReadConditionGroup |
ReadConditionGroup |
RecursSetFileRoots |
RemoveChildActionNode |
ReserveTracks |
ReserveTracks |
ResetTiming |
ResetTimingRecursive |
ResolveAllTrackReferences |
ResolveAllWeights |
ResolveReference | Try to find a node to connect to...
ResolveTrackReferences |
ResolveWeights |
SetActionNode |
SetOnLoad |
SetOnUnload |
SetParent |
SetReferenceName |
TaskLoadActionNode |
TokenName | Write to buffer
TRACK_PARAMETER_STRING |
UnLoad |
UnLoadAll |
Write |
Write |
writeBegin |
writeChildren |
writeComment |
WriteCondition |
WriteCondition |
writeConditions |
writeEnd |
writeTracks |


ActionNodeReference Class Structs

ActionNodeReference Class Structs
ActionNodeReference Class
Structs
Struct | Description
ActionTreeTaskParams |


Inheritance Hierarchy

Inheritance Hierarchy
ActionNodeReference Class
Inheritance Hierarchy
rage::IName
    rage::IArchive
        rage::ActionNode
            ActionNodeReference
                rage::ActionNodeFileReference


ActionNodeTree Class Constructors

ActionNodeTree Class Constructors
ActionNodeTree Class
Constructors
Constructor | Description
ActionNodeTree |


ActionNodeTree Class Destructors

ActionNodeTree Class Destructors
ActionNodeTree Class
Destructors
Destructor | Description
~ActionNodeTree |


ActionNodeTree Class Friends

ActionNodeTree Class Friends
ActionNodeTree Class
Friends
Friend | Description
class ActionNodeTreeHandle |
class pgStreamable<ActionNodeTree> |


Legend

Legend
ActionNodeTree Class
Legend
Method


ActionNodeTree Class Members

ActionNodeTree Class Members
ActionNodeTree Class
Members
Constructors
Constructor | Description
ActionNodeTree |
Destructors
Destructor | Description
~ActionNodeTree |
Methods
Method | Description
DECLARE_PLACE |
DECLARE_THREADED_PLACE |
DeclareStruct |
GetRoot |
GetRorcVersion |
ResolveReferences |
SetRoot |
Friends
Friend | Description
class ActionNodeTreeHandle |
class pgStreamable<ActionNodeTree> |


ActionNodeTree Class Methods

ActionNodeTree Class Methods
ActionNodeTree Class
Methods
Method | Description
DECLARE_PLACE |
DECLARE_THREADED_PLACE |
DeclareStruct |
GetRoot |
GetRorcVersion |
ResolveReferences |
SetRoot |


Inheritance Hierarchy

Inheritance Hierarchy
ActionNodeTree Class
Inheritance Hierarchy
pgBase
    ActionNodeTree


ActionNodeTreeHandle Class Data Members

ActionNodeTreeHandle Class Data Members
ActionNodeTreeHandle Class
Data Members
Data Member | Description
sm_LoadFromResources |


ActionNodeTreeHandle Class Friends

ActionNodeTreeHandle Class Friends
ActionNodeTreeHandle Class
Friends
Friend | Description
class ActionNode |
class ActionNodeTree | Should not be necessary except because of this stupid GetActionNodeTree hack.
class atPtr<ActionNodeTreeHandle> |


Legend

Legend
ActionNodeTreeHandle Class
Legend
Data Member
Method
virtual


ActionNodeTreeHandle Class Members

ActionNodeTreeHandle Class Members
ActionNodeTreeHandle Class
Members
Data Members
Data Member | Description
sm_LoadFromResources |
Methods
Method | Description
AddRef |
Cleanup |
DecRefCount |
ForceLoad |
Get |
GetName |
GetObject |
GetRefCount |
GetRoot |
GetStreamable | This is for debugging only.
IncRefCount |
IsDeleted |
IsResident |
IsStreamingOrResident |
IsValid |
Kill | Delete this object (including the handle itself), regardless what the reference count says.
PagedIn |
SetStreamingPriority |
Friends
Friend | Description
class ActionNode |
class ActionNodeTree | Should not be necessary except because of this stupid GetActionNodeTree hack.
class atPtr<ActionNodeTreeHandle> |
Nested Types
Nested Type | Description
SetMap |


ActionNodeTreeHandle Class Methods

ActionNodeTreeHandle Class Methods
ActionNodeTreeHandle Class
Methods
Method | Description
AddRef |
Cleanup |
DecRefCount |
ForceLoad |
Get |
GetName |
GetObject |
GetRefCount |
GetRoot |
GetStreamable | This is for debugging only.
IncRefCount |
IsDeleted |
IsResident |
IsStreamingOrResident |
IsValid |
Kill | Delete this object (including the handle itself), regardless what the reference count says.
PagedIn |
SetStreamingPriority |


ActionNodeTreeHandle Class Nested Types

ActionNodeTreeHandle Class Nested Types
ActionNodeTreeHandle Class
Nested Types
Nested Type | Description
SetMap |


Inheritance Hierarchy

Inheritance Hierarchy
ActionNodeTreeHandle Class
Inheritance Hierarchy
pgStreamableRef
    ActionNodeTreeHandle


ActionNodeUnresolvedRef Class Constructors

ActionNodeUnresolvedRef Class Constructors
ActionNodeUnresolvedRef Class
Constructors
Constructor | Description
ActionNodeUnresolvedRef |


ActionNodeUnresolvedRef Class Friends

ActionNodeUnresolvedRef Class Friends
ActionNodeUnresolvedRef Class
Friends
Friend | Description
class ActionNodeLwRef |
class ActionNodeTree |


Legend

Legend
ActionNodeUnresolvedRef Class
Legend
Method


ActionNodeUnresolvedRef Class Members

ActionNodeUnresolvedRef Class Members
ActionNodeUnresolvedRef Class
Members
Constructors
Constructor | Description
ActionNodeUnresolvedRef |
Methods
Method | Description
DECLARE_PLACE |
DeclareStruct |
Friends
Friend | Description
class ActionNodeLwRef |
class ActionNodeTree |


ActionNodeUnresolvedRef Class Methods

ActionNodeUnresolvedRef Class Methods
ActionNodeUnresolvedRef Class
Methods
Method | Description
DECLARE_PLACE |
DeclareStruct |


Inheritance Hierarchy

Inheritance Hierarchy
ActionNodeUnresolvedRef Class
Inheritance Hierarchy
ActionNodeUnresolvedRef


ActionTreeLog Class Constructors

ActionTreeLog Class Constructors
ActionTreeLog Class
Constructors
Constructor | Description
CSubject |


ActionTreeLog Class Data Members

ActionTreeLog Class Data Members
ActionTreeLog Class
Data Members
Data Member | Description
m_Observers |


Data Members

Legend
protected
Data Member


ActionTreeLog Class Destructors

ActionTreeLog Class Destructors
ActionTreeLog Class
Destructors
Destructor | Description
~CSubject |


Legend

Legend
ActionTreeLog Class
Legend
Method
virtual
protected
Data Member


ActionTreeLog Class Members

ActionTreeLog Class Members
ActionTreeLog Class
Members
Methods
Method | Description
Attach |
Dettach |
GetInstance |
GetMessage |
Log |
Notify |
Warn |
Data Members
Data Member | Description
m_Observers |
Constructors
Constructor | Description
CSubject |
Destructors
Destructor | Description
~CSubject |


Members

Legend
Method
virtual
protected
Data Member


ActionTreeLog Class Methods

ActionTreeLog Class Methods
ActionTreeLog Class
Methods
Method | Description
Attach |
Dettach |
GetInstance |
GetMessage |
Log |
Notify |
Warn |


Inheritance Hierarchy

Inheritance Hierarchy
ActionTreeLog Class
Inheritance Hierarchy
rage::CSubject
    ActionTreeLog


actTreeDebugOut Class Constructors

actTreeDebugOut Class Constructors
actTreeDebugOut Class
Constructors
Constructor | Description
actTreeDebugOut |


Legend

Legend
actTreeDebugOut Class
Legend
Method


actTreeDebugOut Class Members

actTreeDebugOut Class Members
actTreeDebugOut Class
Members
Constructors
Constructor | Description
actTreeDebugOut |
Methods
Method | Description
GetRef |
Out |


actTreeDebugOut Class Methods

actTreeDebugOut Class Methods
actTreeDebugOut Class
Methods
Method | Description
GetRef |
Out |


Inheritance Hierarchy

Inheritance Hierarchy
actTreeDebugOut Class
Inheritance Hierarchy
actTreeDebugOut


ArchiveFileRecord Class Constructors

ArchiveFileRecord Class Constructors
ArchiveFileRecord Class
Constructors
Constructor | Description
ArchiveFileRecord |


ArchiveFileRecord Class Destructors

ArchiveFileRecord Class Destructors
ArchiveFileRecord Class
Destructors
Destructor | Description
~ArchiveFileRecord |


Legend

Legend
ArchiveFileRecord Class
Legend
Method
virtual


ArchiveFileRecord Class Members

ArchiveFileRecord Class Members
ArchiveFileRecord Class
Members
Constructors
Constructor | Description
ArchiveFileRecord |
Destructors
Destructor | Description
~ArchiveFileRecord |
Methods
Method | Description
GetArchiveObject |
GetFileName |
GetFullPathName |
GetPathName |
Init |
IsFileChangedOnDisk |
IsFileWriteAble |
ReadFromFile |
SetArchiveObject |
SetFactoryIArchive | Redirect how the Object gets created
SetFileName |
SetFullPathName |
SetPathName |
WriteToFile |


ArchiveFileRecord Class Methods

ArchiveFileRecord Class Methods
ArchiveFileRecord Class
Methods
Method | Description
GetArchiveObject |
GetFileName |
GetFullPathName |
GetPathName |
Init |
IsFileChangedOnDisk |
IsFileWriteAble |
ReadFromFile |
SetArchiveObject |
SetFactoryIArchive | Redirect how the Object gets created
SetFileName |
SetFullPathName |
SetPathName |
WriteToFile |


Inheritance Hierarchy

Inheritance Hierarchy
ArchiveFileRecord Class
Inheritance Hierarchy
ArchiveFileRecord


ATask Class Constructors

ATask Class Constructors
ATask Class
Constructors
Constructor | Description
ATask |


ATask Class Data Members

ATask Class Data Members
ATask Class
Data Members
Data Member | Description
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted


ATask Class Destructors

ATask Class Destructors
ATask Class
Destructors
Destructor | Description
~ATask |


Legend

Legend
ATask Class
Legend
Data Member
Method
virtual
abstract


ATask Class Members

ATask Class Members
ATask Class
Members
Data Members
Data Member | Description
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted
Constructors
Constructor | Description
ATask |
Destructors
Destructor | Description
~ATask |
Methods
Method | Description
Begin |
End |
GetActionController |
GetMyContext |
GetTrack |
Update |


Members

Legend
Data Member
Method
virtual
abstract


ATask Class Methods

ATask Class Methods
ATask Class
Methods
Method | Description
Begin |
End |
GetActionController |
GetMyContext |
GetTrack |
Update |


Methods

Legend
Method
virtual
abstract


Inheritance Hierarchy

Inheritance Hierarchy
ATask Class
Inheritance Hierarchy
ATask
    rage::ExecuteTask
    rage::OpportunityTask
    rage::PrintTask
    rage::SequenceTask
    rage::SpawnTask
    rage::StubTask


BoolDataMember Template Constructors

BoolDataMember Template Constructors
BoolDataMember Template
Constructors
Constructor | Description
BoolDataMember |
DataMember |
IBoolDataMember |


BoolDataMember Template Data Members

BoolDataMember Template Data Members
BoolDataMember Template
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


BoolDataMember Template Destructors

BoolDataMember Template Destructors
BoolDataMember Template
Destructors
Destructor | Description
~BoolDataMember |
~DataMember | RAW_ACT_FILE_SUPPORT
~IBoolDataMember | RAW_ACT_FILE_SUPPORT
~IName |


BoolDataMember Template Enumerations

BoolDataMember Template Enumerations
BoolDataMember Template
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
BoolDataMember Template
Legend
Method
virtual
abstract
protected
Data Member


BoolDataMember Template Members

BoolDataMember Template Members
BoolDataMember Template
Members
Constructors
Constructor | Description
BoolDataMember |
DataMember |
IBoolDataMember |
Destructors
Destructor | Description
~BoolDataMember |
~DataMember | RAW_ACT_FILE_SUPPORT
~IBoolDataMember | RAW_ACT_FILE_SUPPORT
~IName |
Methods
Method | Description
GetBool |
GetBool |
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
IsDefault |
Read |
Read |
Set_GetFunction |
SetBool |
SetBool |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |


BoolDataMember Template Methods

BoolDataMember Template Methods
BoolDataMember Template
Methods
Method | Description
GetBool |
GetBool |
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
IsDefault |
Read |
Read |
Set_GetFunction |
SetBool |
SetBool |
Write |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
BoolDataMember Template
Inheritance Hierarchy
rage::IName
    rage::DataMember
        rage::IBoolDataMember
            BoolDataMember


CBasicString Class Constructors

CBasicString Class Constructors
CBasicString Class
Constructors
Constructor | Description
CBasicString |


CBasicString Class Destructors

CBasicString Class Destructors
CBasicString Class
Destructors
Destructor | Description
~CBasicString |


Legend

Legend
CBasicString Class
Legend
Method


CBasicString Class Members

CBasicString Class Members
CBasicString Class
Members
Constructors
Constructor | Description
CBasicString |
Destructors
Destructor | Description
~CBasicString |
Methods
Method | Description
DECLARE_PLACE |
DeclareStruct |
GetString |
SetString |
Operators
Operator | Description
= |
== |


CBasicString Class Methods

CBasicString Class Methods
CBasicString Class
Methods
Method | Description
DECLARE_PLACE |
DeclareStruct |
GetString |
SetString |


CBasicString Class Operators

CBasicString Class Operators
CBasicString Class
Operators
Operator | Description
= |
== |


Inheritance Hierarchy

Inheritance Hierarchy
CBasicString Class
Inheritance Hierarchy
CBasicString


CFastNamePath Class Constructors

CFastNamePath Class Constructors
CFastNamePath Class
Constructors
Constructor | Description
CFastNamePath |


Legend

Legend
CFastNamePath Class
Legend
Method


CFastNamePath Class Members

CFastNamePath Class Members
CFastNamePath Class
Members
Constructors
Constructor | Description
CFastNamePath |
Methods
Method | Description
GetNameHash |
GetNumElements |
SetPath |


CFastNamePath Class Methods

CFastNamePath Class Methods
CFastNamePath Class
Methods
Method | Description
GetNameHash |
GetNumElements |
SetPath |


Inheritance Hierarchy

Inheritance Hierarchy
CFastNamePath Class
Inheritance Hierarchy
CFastNamePath


CName Class Constructors

CName Class Constructors
CName Class
Constructors
Constructor | Description
CName |


CName Class Destructors

CName Class Destructors
CName Class
Destructors
Destructor | Description
~CName |


Legend

Legend
CName Class
Legend
Method


CName Class Members

CName Class Members
CName Class
Members
Constructors
Constructor | Description
CName |
Destructors
Destructor | Description
~CName |
Methods
Method | Description
DECLARE_PLACE |
DeclareStruct |
GetID |
GetString |
Hash | This is here so you can change what CName Uses for Hashing... and also know which one it uses internally on the client side
SetID |
SetString |
Operators
Operator | Description
= |
== |


CName Class Methods

CName Class Methods
CName Class
Methods
Method | Description
DECLARE_PLACE |
DeclareStruct |
GetID |
GetString |
Hash | This is here so you can change what CName Uses for Hashing... and also know which one it uses internally on the client side
SetID |
SetString |


CName Class Operators

CName Class Operators
CName Class
Operators
Operator | Description
= |
== |


Inheritance Hierarchy

Inheritance Hierarchy
CName Class
Inheritance Hierarchy
CName


CNamePath Class Constructors

CNamePath Class Constructors
CNamePath Class
Constructors
Constructor | Description
CNamePath |


CNamePath Class Data Members

CNamePath Class Data Members
CNamePath Class
Data Members
Data Member | Description
s_CNameTraverseDown |
s_CNameTraverseUp |


Legend

Legend
CNamePath Class
Legend
Data Member
Method


CNamePath Class Members

CNamePath Class Members
CNamePath Class
Members
Data Members
Data Member | Description
s_CNameTraverseDown |
s_CNameTraverseUp |
Constructors
Constructor | Description
CNamePath |
Methods
Method | Description
CatName |
CatNameID |
DECLARE_PLACE |
DeclareStruct |
DeInitStatic |
GetFullPathDebug |
GetName |
GetNumElements |
InitStatic |
SetPath |


CNamePath Class Methods

CNamePath Class Methods
CNamePath Class
Methods
Method | Description
CatName |
CatNameID |
DECLARE_PLACE |
DeclareStruct |
DeInitStatic |
GetFullPathDebug |
GetName |
GetNumElements |
InitStatic |
SetPath |


Inheritance Hierarchy

Inheritance Hierarchy
CNamePath Class
Inheritance Hierarchy
CNamePath


CommandDataMember Template Constructors

CommandDataMember Template Constructors
CommandDataMember Template
Constructors
Constructor | Description
CommandDataMember |
DataMember |
ICommandDataMember |
IStringDataMember |


CommandDataMember Template Data Members

CommandDataMember Template Data Members
CommandDataMember Template
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


CommandDataMember Template Destructors

CommandDataMember Template Destructors
CommandDataMember Template
Destructors
Destructor | Description
~CommandDataMember |
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |


CommandDataMember Template Enumerations

CommandDataMember Template Enumerations
CommandDataMember Template
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
CommandDataMember Template
Legend
Method
virtual
abstract
protected
Data Member


CommandDataMember Template Members

CommandDataMember Template Members
CommandDataMember Template
Members
Constructors
Constructor | Description
CommandDataMember |
DataMember |
ICommandDataMember |
IStringDataMember |
Destructors
Destructor | Description
~CommandDataMember |
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Methods
Method | Description
Execute |
Execute |
GetName |
GetName |
GetPfGroupActTracks |
GetString |
GetString |
GetType |
GetType |
GetType |
IsDefault |
Read |
Read |
SetString |
SetString |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |


CommandDataMember Template Methods

CommandDataMember Template Methods
CommandDataMember Template
Methods
Method | Description
Execute |
Execute |
GetName |
GetName |
GetPfGroupActTracks |
GetString |
GetString |
GetType |
GetType |
GetType |
IsDefault |
Read |
Read |
SetString |
SetString |
Write |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
CommandDataMember Template
Inheritance Hierarchy
rage::IName
    rage::DataMember
        rage::IStringDataMember
            rage::ICommandDataMember
                CommandDataMember


rage::condEKG Namespace Functions

rage::condEKG Namespace Functions
rage::condEKG Namespace
Functions
Function | Description
EXT_PF_GROUP |
PF_GROUP |
PF_LINK |
PF_PAGE |
PF_PAGE |
PF_TIMER |
PF_TIMER |
PF_TIMER |
PF_TIMER |
PFPAGELINK_ACTTRACKS |


Condition Class Constructors

Condition Class Constructors
Condition Class
Constructors
Constructor | Description
Condition |
IDataMembers |
TrackOrCondition |


Condition Class Data Members

Condition Class Data Members
Condition Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified


Condition Class Destructors

Condition Class Destructors
Condition Class
Destructors
Destructor | Description
~Condition |
~IDataMembers |


Condition Class Enumerations

Condition Class Enumerations
Condition Class
Enumerations
Enumeration | Description
Logical |


Legend

Legend
Condition Class
Legend
Data Member
Method
virtual
protected
abstract


Condition Class Members

Condition Class Members
Condition Class
Members
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Constructors
Constructor | Description
Condition |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~IDataMembers |
Methods
Method | Description
Break |
Create |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
Write |
Write | lint !e1735
Enumerations
Enumeration | Description
Logical |


Members

Legend
Data Member
Method
virtual
protected
abstract


Condition Class Methods

Condition Class Methods
Condition Class
Methods
Method | Description
Break |
Create |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
Write |
Write | lint !e1735


Methods

Legend
Method
virtual
protected
abstract


Inheritance Hierarchy

Inheritance Hierarchy
Condition Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            Condition
                rage::ConditionActionNodePlayTime
                rage::ConditionFalse
                rage::ConditionGroupCondition
                rage::ConditionNOT
                rage::ConditionOR
                rage::ConditionPrint
                rage::ConditionRandom
                rage::ConditionTrue


ConditionActionNodePlayTime Class Constructors

ConditionActionNodePlayTime Class Constructors
ConditionActionNodePlayTime Class
Constructors
Constructor | Description
Condition |
ConditionActionNodePlayTime |
IDataMembers |
TrackOrCondition |


ConditionActionNodePlayTime Class Data Members

ConditionActionNodePlayTime Class Data Members
ConditionActionNodePlayTime Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified


ConditionActionNodePlayTime Class Destructors

ConditionActionNodePlayTime Class Destructors
ConditionActionNodePlayTime Class
Destructors
Destructor | Description
~Condition |
~ConditionActionNodePlayTime |
~IDataMembers |


ConditionActionNodePlayTime Class Enumerations

ConditionActionNodePlayTime Class Enumerations
ConditionActionNodePlayTime Class
Enumerations
Enumeration | Description
Logical |


Legend

Legend
ConditionActionNodePlayTime Class
Legend
Method
virtual
protected
abstract
Data Member


ConditionActionNodePlayTime Class Members

ConditionActionNodePlayTime Class Members
ConditionActionNodePlayTime Class
Members
Constructors
Constructor | Description
Condition |
ConditionActionNodePlayTime |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionActionNodePlayTime |
~IDataMembers |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
TRACK_PARAMETER |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |


Members

Legend
Method
virtual
protected
abstract
Data Member


ConditionActionNodePlayTime Class Methods

ConditionActionNodePlayTime Class Methods
ConditionActionNodePlayTime Class
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
TRACK_PARAMETER |
Write |
Write | lint !e1735


Inheritance Hierarchy

Inheritance Hierarchy
ConditionActionNodePlayTime Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                ConditionActionNodePlayTime


Conditional Class Data Members

Conditional Class Data Members
Conditional Class
Data Members
Data Member | Description
m_ConditionalStringName | Conditional
m_ConditionalStringNameSize |


Conditional Class Enumerations

Conditional Class Enumerations
Conditional Class
Enumerations
Enumeration | Description
Operators |


Legend

Legend
Conditional Class
Legend
Data Member
Method


Conditional Class Members

Conditional Class Members
Conditional Class
Members
Data Members
Data Member | Description
m_ConditionalStringName | Conditional
m_ConditionalStringNameSize |
Methods
Method | Description
CompareFloat |
CompareInt |
Enumerations
Enumeration | Description
Operators |


Conditional Class Methods

Conditional Class Methods
Conditional Class
Methods
Method | Description
CompareFloat |
CompareInt |


Inheritance Hierarchy

Inheritance Hierarchy
Conditional Class
Inheritance Hierarchy
Conditional


ConditionFalse Class Constructors

ConditionFalse Class Constructors
ConditionFalse Class
Constructors
Constructor | Description
Condition |
ConditionFalse |
IDataMembers |
TrackOrCondition |


ConditionFalse Class Data Members

ConditionFalse Class Data Members
ConditionFalse Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified


ConditionFalse Class Destructors

ConditionFalse Class Destructors
ConditionFalse Class
Destructors
Destructor | Description
~Condition |
~ConditionFalse |
~IDataMembers |


ConditionFalse Class Enumerations

ConditionFalse Class Enumerations
ConditionFalse Class
Enumerations
Enumeration | Description
Logical |


Legend

Legend
ConditionFalse Class
Legend
Method
virtual
protected
abstract
Data Member


ConditionFalse Class Members

ConditionFalse Class Members
ConditionFalse Class
Members
Constructors
Constructor | Description
Condition |
ConditionFalse |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionFalse |
~IDataMembers |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |


ConditionFalse Class Methods

ConditionFalse Class Methods
ConditionFalse Class
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
Write |
Write | lint !e1735


Inheritance Hierarchy

Inheritance Hierarchy
ConditionFalse Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                ConditionFalse


ConditionGroup Class Constructors

ConditionGroup Class Constructors
ConditionGroup Class
Constructors
Constructor | Description
ConditionGroup |


ConditionGroup Class Destructors

ConditionGroup Class Destructors
ConditionGroup Class
Destructors
Destructor | Description
~ConditionGroup |


Legend

Legend
ConditionGroup Class
Legend
Method


ConditionGroup Class Members

ConditionGroup Class Members
ConditionGroup Class
Members
Constructors
Constructor | Description
ConditionGroup |
Destructors
Destructor | Description
~ConditionGroup |
Methods
Method | Description
AddCondition |
AddConditions |
ChangeConditionPriority |
DECLARE_PLACE |
DeclareStruct |
DeleteCondition |
EvalRemote |
GetCondition |
GetConditionCount |
Match |
Read |
Write |


ConditionGroup Class Methods

ConditionGroup Class Methods
ConditionGroup Class
Methods
Method | Description
AddCondition |
AddConditions |
ChangeConditionPriority |
DECLARE_PLACE |
DeclareStruct |
DeleteCondition |
EvalRemote |
GetCondition |
GetConditionCount |
Match |
Read |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
ConditionGroup Class
Inheritance Hierarchy
ConditionGroup


ConditionGroupCondition Class Constructors

ConditionGroupCondition Class Constructors
ConditionGroupCondition Class
Constructors
Constructor | Description
Condition |
ConditionGroupCondition |
IDataMembers |
TrackOrCondition |


ConditionGroupCondition Class Data Members

ConditionGroupCondition Class Data Members
ConditionGroupCondition Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified


ConditionGroupCondition Class Destructors

ConditionGroupCondition Class Destructors
ConditionGroupCondition Class
Destructors
Destructor | Description
~Condition |
~ConditionGroupCondition |
~IDataMembers |


ConditionGroupCondition Class Enumerations

ConditionGroupCondition Class Enumerations
ConditionGroupCondition Class
Enumerations
Enumeration | Description
Logical |


Legend

Legend
ConditionGroupCondition Class
Legend
Method
virtual
protected
abstract
Data Member


ConditionGroupCondition Class Members

ConditionGroupCondition Class Members
ConditionGroupCondition Class
Members
Constructors
Constructor | Description
Condition |
ConditionGroupCondition |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionGroupCondition |
~IDataMembers |
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
EvalRemote | Evaluates the remote condition
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup |
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read | if __RESOURCECOMPILER
Read |
ReadConditionGroup |
Reset |
SetConditionGroup | In order to have a local ConditionGroup
SetDebugBreakPoint |
SetEnableBreakPoints |
TRACK_MEMBER |
TRACK_PADDING |
Write |
Write | lint !e1735
WriteCondition |
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |


ConditionGroupCondition Class Methods

ConditionGroupCondition Class Methods
ConditionGroupCondition Class
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
EvalRemote | Evaluates the remote condition
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup |
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read | if __RESOURCECOMPILER
Read |
ReadConditionGroup |
Reset |
SetConditionGroup | In order to have a local ConditionGroup
SetDebugBreakPoint |
SetEnableBreakPoints |
TRACK_MEMBER |
TRACK_PADDING |
Write |
Write | lint !e1735
WriteCondition |


Inheritance Hierarchy

Inheritance Hierarchy
ConditionGroupCondition Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                ConditionGroupCondition
                    rage::ConditionGroupConditionAnd
                    rage::ConditionGroupConditionNot
                    rage::ConditionGroupConditionOnly
                    rage::ConditionGroupConditionOr


ConditionGroupConditionAnd Class Constructors

ConditionGroupConditionAnd Class Constructors
ConditionGroupConditionAnd Class
Constructors
Constructor | Description
Condition |
ConditionGroupCondition |
ConditionGroupConditionAnd |
IDataMembers |
TrackOrCondition |


ConditionGroupConditionAnd Class Data Members

ConditionGroupConditionAnd Class Data Members
ConditionGroupConditionAnd Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified


ConditionGroupConditionAnd Class Destructors

ConditionGroupConditionAnd Class Destructors
ConditionGroupConditionAnd Class
Destructors
Destructor | Description
~Condition |
~ConditionGroupCondition |
~ConditionGroupConditionAnd |
~IDataMembers |


ConditionGroupConditionAnd Class Enumerations

ConditionGroupConditionAnd Class Enumerations
ConditionGroupConditionAnd Class
Enumerations
Enumeration | Description
Logical |


Legend

Legend
ConditionGroupConditionAnd Class
Legend
Method
virtual
protected
abstract
Data Member


ConditionGroupConditionAnd Class Members

ConditionGroupConditionAnd Class Members
ConditionGroupConditionAnd Class
Members
Constructors
Constructor | Description
Condition |
ConditionGroupCondition |
ConditionGroupConditionAnd |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionGroupCondition |
~ConditionGroupConditionAnd |
~IDataMembers |
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
EvalRemote | Evaluates the remote condition
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup |
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
Match |
NewTask |
Read | if __RESOURCECOMPILER
Read |
ReadConditionGroup |
Reset |
SetConditionGroup | In order to have a local ConditionGroup
SetDebugBreakPoint |
SetEnableBreakPoints |
TRACK_MEMBER |
TRACK_PADDING |
Write |
Write | lint !e1735
WriteCondition |
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |


ConditionGroupConditionAnd Class Methods

ConditionGroupConditionAnd Class Methods
ConditionGroupConditionAnd Class
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
EvalRemote | Evaluates the remote condition
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup |
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
Match |
NewTask |
Read | if __RESOURCECOMPILER
Read |
ReadConditionGroup |
Reset |
SetConditionGroup | In order to have a local ConditionGroup
SetDebugBreakPoint |
SetEnableBreakPoints |
TRACK_MEMBER |
TRACK_PADDING |
Write |
Write | lint !e1735
WriteCondition |


Inheritance Hierarchy

Inheritance Hierarchy
ConditionGroupConditionAnd Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                rage::ConditionGroupCondition
                    ConditionGroupConditionAnd


ConditionGroupConditionNot Class Constructors

ConditionGroupConditionNot Class Constructors
ConditionGroupConditionNot Class
Constructors
Constructor | Description
Condition |
ConditionGroupCondition |
ConditionGroupConditionNot |
IDataMembers |
TrackOrCondition |


ConditionGroupConditionNot Class Data Members

ConditionGroupConditionNot Class Data Members
ConditionGroupConditionNot Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified


ConditionGroupConditionNot Class Destructors

ConditionGroupConditionNot Class Destructors
ConditionGroupConditionNot Class
Destructors
Destructor | Description
~Condition |
~ConditionGroupCondition |
~ConditionGroupConditionNot |
~IDataMembers |


ConditionGroupConditionNot Class Enumerations

ConditionGroupConditionNot Class Enumerations
ConditionGroupConditionNot Class
Enumerations
Enumeration | Description
Logical |


Legend

Legend
ConditionGroupConditionNot Class
Legend
Method
virtual
protected
abstract
Data Member


ConditionGroupConditionNot Class Members

ConditionGroupConditionNot Class Members
ConditionGroupConditionNot Class
Members
Constructors
Constructor | Description
Condition |
ConditionGroupCondition |
ConditionGroupConditionNot |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionGroupCondition |
~ConditionGroupConditionNot |
~IDataMembers |
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
EvalRemote | Evaluates the remote condition
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup |
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
Match |
NewTask |
Read | if __RESOURCECOMPILER
Read |
ReadConditionGroup |
Reset |
SetConditionGroup | In order to have a local ConditionGroup
SetDebugBreakPoint |
SetEnableBreakPoints |
TRACK_MEMBER |
TRACK_PADDING |
Write |
Write | lint !e1735
WriteCondition |
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |


ConditionGroupConditionNot Class Methods

ConditionGroupConditionNot Class Methods
ConditionGroupConditionNot Class
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
EvalRemote | Evaluates the remote condition
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup |
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
Match |
NewTask |
Read | if __RESOURCECOMPILER
Read |
ReadConditionGroup |
Reset |
SetConditionGroup | In order to have a local ConditionGroup
SetDebugBreakPoint |
SetEnableBreakPoints |
TRACK_MEMBER |
TRACK_PADDING |
Write |
Write | lint !e1735
WriteCondition |


Inheritance Hierarchy

Inheritance Hierarchy
ConditionGroupConditionNot Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                rage::ConditionGroupCondition
                    ConditionGroupConditionNot


ConditionGroupConditionOnly Class Constructors

ConditionGroupConditionOnly Class Constructors
ConditionGroupConditionOnly Class
Constructors
Constructor | Description
Condition |
ConditionGroupCondition |
ConditionGroupConditionOnly |
IDataMembers |
TrackOrCondition |


ConditionGroupConditionOnly Class Data Members

ConditionGroupConditionOnly Class Data Members
ConditionGroupConditionOnly Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified


ConditionGroupConditionOnly Class Destructors

ConditionGroupConditionOnly Class Destructors
ConditionGroupConditionOnly Class
Destructors
Destructor | Description
~Condition |
~ConditionGroupCondition |
~ConditionGroupConditionOnly |
~IDataMembers |


ConditionGroupConditionOnly Class Enumerations

ConditionGroupConditionOnly Class Enumerations
ConditionGroupConditionOnly Class
Enumerations
Enumeration | Description
Logical |


Legend

Legend
ConditionGroupConditionOnly Class
Legend
Method
virtual
protected
abstract
Data Member


ConditionGroupConditionOnly Class Members

ConditionGroupConditionOnly Class Members
ConditionGroupConditionOnly Class
Members
Constructors
Constructor | Description
Condition |
ConditionGroupCondition |
ConditionGroupConditionOnly |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionGroupCondition |
~ConditionGroupConditionOnly |
~IDataMembers |
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
EvalRemote | Evaluates the remote condition
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup |
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
Match |
NewTask |
Read | if __RESOURCECOMPILER
Read |
ReadConditionGroup |
Reset |
SetConditionGroup | In order to have a local ConditionGroup
SetDebugBreakPoint |
SetEnableBreakPoints |
TRACK_MEMBER |
TRACK_PADDING |
Write |
Write | lint !e1735
WriteCondition |
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |


ConditionGroupConditionOnly Class Methods

ConditionGroupConditionOnly Class Methods
ConditionGroupConditionOnly Class
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
EvalRemote | Evaluates the remote condition
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup |
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
Match |
NewTask |
Read | if __RESOURCECOMPILER
Read |
ReadConditionGroup |
Reset |
SetConditionGroup | In order to have a local ConditionGroup
SetDebugBreakPoint |
SetEnableBreakPoints |
TRACK_MEMBER |
TRACK_PADDING |
Write |
Write | lint !e1735
WriteCondition |


Inheritance Hierarchy

Inheritance Hierarchy
ConditionGroupConditionOnly Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                rage::ConditionGroupCondition
                    ConditionGroupConditionOnly


ConditionGroupConditionOr Class Constructors

ConditionGroupConditionOr Class Constructors
ConditionGroupConditionOr Class
Constructors
Constructor | Description
Condition |
ConditionGroupCondition |
ConditionGroupConditionOr |
IDataMembers |
TrackOrCondition |


ConditionGroupConditionOr Class Data Members

ConditionGroupConditionOr Class Data Members
ConditionGroupConditionOr Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified


ConditionGroupConditionOr Class Destructors

ConditionGroupConditionOr Class Destructors
ConditionGroupConditionOr Class
Destructors
Destructor | Description
~Condition |
~ConditionGroupCondition |
~ConditionGroupConditionOr |
~IDataMembers |


ConditionGroupConditionOr Class Enumerations

ConditionGroupConditionOr Class Enumerations
ConditionGroupConditionOr Class
Enumerations
Enumeration | Description
Logical |


Legend

Legend
ConditionGroupConditionOr Class
Legend
Method
virtual
protected
abstract
Data Member


ConditionGroupConditionOr Class Members

ConditionGroupConditionOr Class Members
ConditionGroupConditionOr Class
Members
Constructors
Constructor | Description
Condition |
ConditionGroupCondition |
ConditionGroupConditionOr |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionGroupCondition |
~ConditionGroupConditionOr |
~IDataMembers |
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
EvalRemote | Evaluates the remote condition
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup |
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
Match |
NewTask |
Read | if __RESOURCECOMPILER
Read |
ReadConditionGroup |
Reset |
SetConditionGroup | In order to have a local ConditionGroup
SetDebugBreakPoint |
SetEnableBreakPoints |
TRACK_MEMBER |
TRACK_PADDING |
Write |
Write | lint !e1735
WriteCondition |
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |


ConditionGroupConditionOr Class Methods

ConditionGroupConditionOr Class Methods
ConditionGroupConditionOr Class
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
EvalRemote | Evaluates the remote condition
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup |
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
Match |
NewTask |
Read | if __RESOURCECOMPILER
Read |
ReadConditionGroup |
Reset |
SetConditionGroup | In order to have a local ConditionGroup
SetDebugBreakPoint |
SetEnableBreakPoints |
TRACK_MEMBER |
TRACK_PADDING |
Write |
Write | lint !e1735
WriteCondition |


Inheritance Hierarchy

Inheritance Hierarchy
ConditionGroupConditionOr Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                rage::ConditionGroupCondition
                    ConditionGroupConditionOr


ConditionNOT Class Constructors

ConditionNOT Class Constructors
ConditionNOT Class
Constructors
Constructor | Description
Condition |
ConditionNOT |
IDataMembers |
TrackOrCondition |


ConditionNOT Class Data Members

ConditionNOT Class Data Members
ConditionNOT Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified


ConditionNOT Class Destructors

ConditionNOT Class Destructors
ConditionNOT Class
Destructors
Destructor | Description
~Condition |
~ConditionNOT |
~IDataMembers |


ConditionNOT Class Enumerations

ConditionNOT Class Enumerations
ConditionNOT Class
Enumerations
Enumeration | Description
Logical |


Legend

Legend
ConditionNOT Class
Legend
Method
virtual
protected
abstract
Data Member


ConditionNOT Class Members

ConditionNOT Class Members
ConditionNOT Class
Members
Constructors
Constructor | Description
Condition |
ConditionNOT |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionNOT |
~IDataMembers |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |


ConditionNOT Class Methods

ConditionNOT Class Methods
ConditionNOT Class
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
Write |
Write | lint !e1735


Inheritance Hierarchy

Inheritance Hierarchy
ConditionNOT Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                ConditionNOT


ConditionOR Class Constructors

ConditionOR Class Constructors
ConditionOR Class
Constructors
Constructor | Description
Condition |
ConditionOR |
IDataMembers |
TrackOrCondition |


ConditionOR Class Data Members

ConditionOR Class Data Members
ConditionOR Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified


ConditionOR Class Destructors

ConditionOR Class Destructors
ConditionOR Class
Destructors
Destructor | Description
~Condition |
~ConditionOR |
~IDataMembers |


ConditionOR Class Enumerations

ConditionOR Class Enumerations
ConditionOR Class
Enumerations
Enumeration | Description
Logical |


Legend

Legend
ConditionOR Class
Legend
Method
virtual
protected
abstract
Data Member


ConditionOR Class Members

ConditionOR Class Members
ConditionOR Class
Members
Constructors
Constructor | Description
Condition |
ConditionOR |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionOR |
~IDataMembers |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |


ConditionOR Class Methods

ConditionOR Class Methods
ConditionOR Class
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
Write |
Write | lint !e1735


Inheritance Hierarchy

Inheritance Hierarchy
ConditionOR Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                ConditionOR


ConditionPrint Class Constructors

ConditionPrint Class Constructors
ConditionPrint Class
Constructors
Constructor | Description
Condition |
ConditionPrint |
IDataMembers |
TrackOrCondition |


ConditionPrint Class Data Members

ConditionPrint Class Data Members
ConditionPrint Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified


ConditionPrint Class Destructors

ConditionPrint Class Destructors
ConditionPrint Class
Destructors
Destructor | Description
~Condition |
~ConditionPrint |
~IDataMembers |


ConditionPrint Class Enumerations

ConditionPrint Class Enumerations
ConditionPrint Class
Enumerations
Enumeration | Description
Logical |
PrintChannels | keep in sync with PrintTrack::PrintChannels


Legend

Legend
ConditionPrint Class
Legend
Method
virtual
protected
abstract
Data Member


ConditionPrint Class Members

ConditionPrint Class Members
ConditionPrint Class
Members
Constructors
Constructor | Description
Condition |
ConditionPrint |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionPrint |
~IDataMembers |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetText |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetText |
TRACK_MEMBER |
TRACK_PARAMETER_ENUM |
Write |
Write | lint !e1735
Enumerations
Enumeration | Description
Logical |
PrintChannels | keep in sync with PrintTrack::PrintChannels
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified


ConditionPrint Class Methods

ConditionPrint Class Methods
ConditionPrint Class
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetText |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetText |
TRACK_MEMBER |
TRACK_PARAMETER_ENUM |
Write |
Write | lint !e1735


Inheritance Hierarchy

Inheritance Hierarchy
ConditionPrint Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                ConditionPrint


ConditionRandom Class Constructors

ConditionRandom Class Constructors
ConditionRandom Class
Constructors
Constructor | Description
Condition |
ConditionRandom |
IDataMembers |
TrackOrCondition |


ConditionRandom Class Data Members

ConditionRandom Class Data Members
ConditionRandom Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
sm_RandomNum | shared across all instances
sm_RandomUsed | If used make a new one


ConditionRandom Class Destructors

ConditionRandom Class Destructors
ConditionRandom Class
Destructors
Destructor | Description
~Condition |
~IDataMembers |


ConditionRandom Class Enumerations

ConditionRandom Class Enumerations
ConditionRandom Class
Enumerations
Enumeration | Description
Logical |
RandomModes |


Legend

Legend
ConditionRandom Class
Legend
Data Member
Method
virtual
protected
abstract


ConditionRandom Class Members

ConditionRandom Class Members
ConditionRandom Class
Members
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
sm_RandomNum | shared across all instances
sm_RandomUsed | If used make a new one
Constructors
Constructor | Description
Condition |
ConditionRandom |
IDataMembers |
TrackOrCondition |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetRandFunc |
TRACK_PARAMETER |
TRACK_PARAMETER_ENUM |
Write |
Write | lint !e1735
Enumerations
Enumeration | Description
Logical |
RandomModes |
Nested Types
Nested Type | Description
ConditionRandFunc |
Destructors
Destructor | Description
~Condition |
~IDataMembers |


ConditionRandom Class Methods

ConditionRandom Class Methods
ConditionRandom Class
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetRandFunc |
TRACK_PARAMETER |
TRACK_PARAMETER_ENUM |
Write |
Write | lint !e1735


ConditionRandom Class Nested Types

ConditionRandom Class Nested Types
ConditionRandom Class
Nested Types
Nested Type | Description
ConditionRandFunc |


Inheritance Hierarchy

Inheritance Hierarchy
ConditionRandom Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                ConditionRandom


ConditionTrue Class Constructors

ConditionTrue Class Constructors
ConditionTrue Class
Constructors
Constructor | Description
Condition |
ConditionTrue |
IDataMembers |
TrackOrCondition |


ConditionTrue Class Data Members

ConditionTrue Class Data Members
ConditionTrue Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified


ConditionTrue Class Destructors

ConditionTrue Class Destructors
ConditionTrue Class
Destructors
Destructor | Description
~Condition |
~ConditionTrue |
~IDataMembers |


ConditionTrue Class Enumerations

ConditionTrue Class Enumerations
ConditionTrue Class
Enumerations
Enumeration | Description
Logical |


Legend

Legend
ConditionTrue Class
Legend
Method
virtual
protected
abstract
Data Member


ConditionTrue Class Members

ConditionTrue Class Members
ConditionTrue Class
Members
Constructors
Constructor | Description
Condition |
ConditionTrue |
IDataMembers |
TrackOrCondition |
Destructors
Destructor | Description
~Condition |
~ConditionTrue |
~IDataMembers |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
RORC_VERSION | Don't forget to bump this whenever a RAGE condition is added or modified
Enumerations
Enumeration | Description
Logical |


ConditionTrue Class Methods

ConditionTrue Class Methods
ConditionTrue Class
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
EvalRemote | Evaluates the remote condition
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetLogical |
GetMember |
GetName |
GetNumConditions |
GetNumMembers |
GetNumRegistered |
GetPFTimer |
GetRegistered |
GetTrackRegistry | Used for games to register their own conditions
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Init |
IsRemoteCondition | : Checks if this is a remote condition
Match |
Match |
NewTask |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
Write |
Write | lint !e1735


Inheritance Hierarchy

Inheritance Hierarchy
ConditionTrue Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Condition
                ConditionTrue


CSubject Class Constructors

CSubject Class Constructors
CSubject Class
Constructors
Constructor | Description
CSubject |


CSubject Class Data Members

CSubject Class Data Members
CSubject Class
Data Members
Data Member | Description
m_Observers |


CSubject Class Destructors

CSubject Class Destructors
CSubject Class
Destructors
Destructor | Description
~CSubject |


Legend

Legend
CSubject Class
Legend
protected
Data Member
Method
virtual


CSubject Class Members

CSubject Class Members
CSubject Class
Members
Data Members
Data Member | Description
m_Observers |
Constructors
Constructor | Description
CSubject |
Destructors
Destructor | Description
~CSubject |
Methods
Method | Description
Attach |
Dettach |
Notify |


Members

Legend
protected
Data Member
Method
virtual


CSubject Class Methods

CSubject Class Methods
CSubject Class
Methods
Method | Description
Attach |
Dettach |
Notify |


Inheritance Hierarchy

Inheritance Hierarchy
CSubject Class
Inheritance Hierarchy
CSubject
    rage::ActionTreeLog


DataMember Class Constructors

DataMember Class Constructors
DataMember Class
Constructors
Constructor | Description
DataMember |


DataMember Class Data Members

DataMember Class Data Members
DataMember Class
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


DataMember Class Destructors

DataMember Class Destructors
DataMember Class
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |


DataMember Class Enumerations

DataMember Class Enumerations
DataMember Class
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
DataMember Class
Legend
protected
Data Member
Method
virtual
abstract


DataMember Class Members

DataMember Class Members
DataMember Class
Members
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Constructors
Constructor | Description
DataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetType |
IsDefault |
Read |
Write |
Enumerations
Enumeration | Description
TYPE |


Members

Legend
protected
Data Member
Method
virtual
abstract


DataMember Class Methods

DataMember Class Methods
DataMember Class
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetType |
IsDefault |
Read |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
DataMember Class
Inheritance Hierarchy
rage::IName
    DataMember
        rage::IBoolDataMember
        rage::IEnumDataMember
        rage::IFloatDataMember
        rage::IGroupDataMember
        rage::IIntDataMember
        rage::IStringDataMember
        rage::IVector2DataMember
        rage::IVector3DataMember


EnumDataMember Template Constructors

EnumDataMember Template Constructors
EnumDataMember Template
Constructors
Constructor | Description
DataMember |
EnumDataMember |
IEnumDataMember |


EnumDataMember Template Data Members

EnumDataMember Template Data Members
EnumDataMember Template
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


EnumDataMember Template Destructors

EnumDataMember Template Destructors
EnumDataMember Template
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~EnumDataMember |
~IName |


EnumDataMember Template Enumerations

EnumDataMember Template Enumerations
EnumDataMember Template
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
EnumDataMember Template
Legend
Method
virtual
abstract
protected
Data Member


EnumDataMember Template Members

EnumDataMember Template Members
EnumDataMember Template
Members
Constructors
Constructor | Description
DataMember |
EnumDataMember |
IEnumDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~EnumDataMember |
~IName |
Methods
Method | Description
GetEnum |
GetEnum |
GetEnumName |
GetName |
GetName |
GetNumEnums |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
IsDefault |
Read |
Read |
SetEnum |
SetEnum |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |


EnumDataMember Template Methods

EnumDataMember Template Methods
EnumDataMember Template
Methods
Method | Description
GetEnum |
GetEnum |
GetEnumName |
GetName |
GetName |
GetNumEnums |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
IsDefault |
Read |
Read |
SetEnum |
SetEnum |
Write |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
EnumDataMember Template
Inheritance Hierarchy
rage::IName
    rage::DataMember
        rage::IEnumDataMember
            EnumDataMember


ExecuteTask Class Constructors

ExecuteTask Class Constructors
ExecuteTask Class
Constructors
Constructor | Description
ATask |
ExecuteTask |


ExecuteTask Class Data Members

ExecuteTask Class Data Members
ExecuteTask Class
Data Members
Data Member | Description
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted


ExecuteTask Class Destructors

ExecuteTask Class Destructors
ExecuteTask Class
Destructors
Destructor | Description
~ATask |
~ExecuteTask |


Legend

Legend
ExecuteTask Class
Legend
Method
virtual
abstract
Data Member


ExecuteTask Class Members

ExecuteTask Class Members
ExecuteTask Class
Members
Constructors
Constructor | Description
ATask |
ExecuteTask |
Destructors
Destructor | Description
~ATask |
~ExecuteTask |
Methods
Method | Description
Begin |
Begin | ExecuteTask
End |
End |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
Update |
Update |
Data Members
Data Member | Description
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted


Members

Legend
Method
virtual
abstract
Data Member


ExecuteTask Class Methods

ExecuteTask Class Methods
ExecuteTask Class
Methods
Method | Description
Begin |
Begin | ExecuteTask
End |
End |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
Update |
Update |


Inheritance Hierarchy

Inheritance Hierarchy
ExecuteTask Class
Inheritance Hierarchy
rage::ATask
    ExecuteTask


ExecuteTrack Class Constructors

ExecuteTrack Class Constructors
ExecuteTrack Class
Constructors
Constructor | Description
ExecuteTrack |
IDataMembers |
INodeReferenceTrack |
NodeReferenceTrack |
Track |
TrackOrCondition |


ExecuteTrack Class Data Members

ExecuteTrack Class Data Members
ExecuteTrack Class
Data Members
Data Member | Description
m_ActionNodeRef |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |


ExecuteTrack Class Destructors

ExecuteTrack Class Destructors
ExecuteTrack Class
Destructors
Destructor | Description
~ExecuteTrack |
~IDataMembers |
~NodeReferenceTrack |
~Track |


Legend

Legend
ExecuteTrack Class
Legend
Method
virtual
protected
abstract
Data Member


ExecuteTrack Class Members

ExecuteTrack Class Members
ExecuteTrack Class
Members
Constructors
Constructor | Description
ExecuteTrack |
IDataMembers |
INodeReferenceTrack |
NodeReferenceTrack |
Track |
TrackOrCondition |
Destructors
Destructor | Description
~ExecuteTrack |
~IDataMembers |
~NodeReferenceTrack |
~Track |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
NewTask |
Read |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent |
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
UpdateFrame |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ActionNodeRef |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |
Structs
Struct | Description
Timer |


ExecuteTrack Class Methods

ExecuteTrack Class Methods
ExecuteTrack Class
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
NewTask |
Read |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent |
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
UpdateFrame |
Write |
Write | lint !e1735


ExecuteTrack Class Structs

ExecuteTrack Class Structs
ExecuteTrack Class
Structs
Struct | Description
Timer |


Inheritance Hierarchy

Inheritance Hierarchy
ExecuteTrack Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Track
                rage::INodeReferenceTrack
                    rage::NodeReferenceTrack
                        ExecuteTrack


FloatDataMember Template Constructors

FloatDataMember Template Constructors
FloatDataMember Template
Constructors
Constructor | Description
DataMember |
FloatDataMember |
IFloatDataMember |


FloatDataMember Template Data Members

FloatDataMember Template Data Members
FloatDataMember Template
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


FloatDataMember Template Destructors

FloatDataMember Template Destructors
FloatDataMember Template
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~FloatDataMember |
~IName |


FloatDataMember Template Enumerations

FloatDataMember Template Enumerations
FloatDataMember Template
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
FloatDataMember Template
Legend
Method
virtual
abstract
protected
Data Member


FloatDataMember Template Members

FloatDataMember Template Members
FloatDataMember Template
Members
Constructors
Constructor | Description
DataMember |
FloatDataMember |
IFloatDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~FloatDataMember |
~IName |
Methods
Method | Description
GetFloat |
GetFloat |
GetMinMaxFloat | RAW_ACT_FILE_SUPPORT
GetMinMaxFloat | RAW_ACT_FILE_SUPPORT
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
IsDefault |
Read |
Read |
SetFloat |
SetFloat |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |


FloatDataMember Template Methods

FloatDataMember Template Methods
FloatDataMember Template
Methods
Method | Description
GetFloat |
GetFloat |
GetMinMaxFloat | RAW_ACT_FILE_SUPPORT
GetMinMaxFloat | RAW_ACT_FILE_SUPPORT
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
IsDefault |
Read |
Read |
SetFloat |
SetFloat |
Write |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
FloatDataMember Template
Inheritance Hierarchy
rage::IName
    rage::DataMember
        rage::IFloatDataMember
            FloatDataMember


GameTaskManager Class Constructors

GameTaskManager Class Constructors
GameTaskManager Class
Constructors
Constructor | Description
GameTaskManager | GameTaskManager


GameTaskManager Class Data Members

GameTaskManager Class Data Members
GameTaskManager Class
Data Members
Data Member | Description
m_CriticalSection | Critical section to prevent collisions.
m_TaskPool0 | Our pool for the tasks.
m_TaskPool1 |
m_TaskPool2 |
sm_Instance |


GameTaskManager Class Destructors

GameTaskManager Class Destructors
GameTaskManager Class
Destructors
Destructor | Description
~GameTaskManager |


Legend

Legend
GameTaskManager Class
Legend
protected
Data Member
Method


GameTaskManager Class Members

GameTaskManager Class Members
GameTaskManager Class
Members
Data Members
Data Member | Description
m_CriticalSection | Critical section to prevent collisions.
m_TaskPool0 | Our pool for the tasks.
m_TaskPool1 |
m_TaskPool2 |
sm_Instance |
Structs
Struct | Description
DummyTask |
DummyTaskHeader | This is the dummy structure that is used in the pool. The templated version of AllocateTask will put the actual class in there.
Constructors
Constructor | Description
GameTaskManager | GameTaskManager
Destructors
Destructor | Description
~GameTaskManager |
Methods
Method | Description
AddWidgets |
AllocateTask |
DECLARE_TASK_POOL_FUNCTIONS |
DeleteTask |
GetDummyTask | Get the DummyTask that contains the ATask. Obviously, this may only be called for ATask objects that were created using AllocateTask.
GetInstance |
InitClass |
ShutdownClass |
Nested Types
Nested Type | Description
DummyTask0 |
DummyTask1 |
DummyTask2 |


Members

Legend
protected
Data Member
Method


GameTaskManager Class Methods

GameTaskManager Class Methods
GameTaskManager Class
Methods
Method | Description
AddWidgets |
AllocateTask |
DECLARE_TASK_POOL_FUNCTIONS |
DeleteTask |
GetDummyTask | Get the DummyTask that contains the ATask. Obviously, this may only be called for ATask objects that were created using AllocateTask.
GetInstance |
InitClass |
ShutdownClass |


GameTaskManager Class Nested Types

GameTaskManager Class Nested Types
GameTaskManager Class
Nested Types
Nested Type | Description
DummyTask0 |
DummyTask1 |
DummyTask2 |


GameTaskManager Class Structs

GameTaskManager Class Structs
GameTaskManager Class
Structs
Struct | Description
DummyTask |
DummyTaskHeader | This is the dummy structure that is used in the pool. The templated version of AllocateTask will put the actual class in there.


Inheritance Hierarchy

Inheritance Hierarchy
GameTaskManager Class
Inheritance Hierarchy
GameTaskManager


GroupDataMember Template Constructors

GroupDataMember Template Constructors
GroupDataMember Template
Constructors
Constructor | Description
DataMember |
GroupDataMember |
IGroupDataMember |


GroupDataMember Template Data Members

GroupDataMember Template Data Members
GroupDataMember Template
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


GroupDataMember Template Destructors

GroupDataMember Template Destructors
GroupDataMember Template
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~GroupDataMember |
~IName |


GroupDataMember Template Enumerations

GroupDataMember Template Enumerations
GroupDataMember Template
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
GroupDataMember Template
Legend
Method
virtual
abstract
protected
Data Member


GroupDataMember Template Members

GroupDataMember Template Members
GroupDataMember Template
Members
Constructors
Constructor | Description
DataMember |
GroupDataMember |
IGroupDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~GroupDataMember |
~IName |
Methods
Method | Description
Add |
Add |
ChangePriority |
ChangePriority |
Delete |
Delete |
GetCount |
GetCount |
GetDataMember |
GetDataMember |
GetDataMemberFormat |
GetDataMemberFormat |
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
Read |
Read |
ReadAllElements |
ReadAllElements |
Write |
Write |
WriteElements |
WriteElements |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |


GroupDataMember Template Methods

GroupDataMember Template Methods
GroupDataMember Template
Methods
Method | Description
Add |
Add |
ChangePriority |
ChangePriority |
Delete |
Delete |
GetCount |
GetCount |
GetDataMember |
GetDataMember |
GetDataMemberFormat |
GetDataMemberFormat |
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
Read |
Read |
ReadAllElements |
ReadAllElements |
Write |
Write |
WriteElements |
WriteElements |


Inheritance Hierarchy

Inheritance Hierarchy
GroupDataMember Template
Inheritance Hierarchy
rage::IName
    rage::DataMember
        rage::IGroupDataMember
            GroupDataMember
                rage::GroupDataMemberNoInterface


GroupDataMemberNoInterface Template Constructors

GroupDataMemberNoInterface Template Constructors
GroupDataMemberNoInterface Template
Constructors
Constructor | Description
DataMember |
GroupDataMember |
GroupDataMemberNoInterface |
IGroupDataMember |


GroupDataMemberNoInterface Template Data Members

GroupDataMemberNoInterface Template Data Members
GroupDataMemberNoInterface Template
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


GroupDataMemberNoInterface Template Destructors

GroupDataMemberNoInterface Template Destructors
GroupDataMemberNoInterface Template
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~GroupDataMember |
~IName |


GroupDataMemberNoInterface Template Enumerations

GroupDataMemberNoInterface Template Enumerations
GroupDataMemberNoInterface Template
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
GroupDataMemberNoInterface Template
Legend
Method
virtual
abstract
protected
Data Member


GroupDataMemberNoInterface Template Members

GroupDataMemberNoInterface Template Members
GroupDataMemberNoInterface Template
Members
Constructors
Constructor | Description
DataMember |
GroupDataMember |
GroupDataMemberNoInterface |
IGroupDataMember |
Methods
Method | Description
Add |
Add |
ChangePriority |
ChangePriority |
Delete |
Delete |
GetCount |
GetCount |
GetDataMember |
GetDataMember |
GetDataMemberFormat |
GetDataMemberFormat |
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
GetType |
IsDefault |
Read |
Read |
ReadAllElements |
ReadAllElements |
Write |
Write |
WriteElements |
WriteElements |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~GroupDataMember |
~IName |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |


GroupDataMemberNoInterface Template Methods

GroupDataMemberNoInterface Template Methods
GroupDataMemberNoInterface Template
Methods
Method | Description
Add |
Add |
ChangePriority |
ChangePriority |
Delete |
Delete |
GetCount |
GetCount |
GetDataMember |
GetDataMember |
GetDataMemberFormat |
GetDataMemberFormat |
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
GetType |
IsDefault |
Read |
Read |
ReadAllElements |
ReadAllElements |
Write |
Write |
WriteElements |
WriteElements |


Inheritance Hierarchy

Inheritance Hierarchy
GroupDataMemberNoInterface Template
Inheritance Hierarchy
rage::IName
    rage::DataMember
        rage::IGroupDataMember
            rage::GroupDataMember
                GroupDataMemberNoInterface


IArchive Class Constructors

IArchive Class Constructors
IArchive Class
Constructors
Constructor | Description
IArchive |


IArchive Class Destructors

IArchive Class Destructors
IArchive Class
Destructors
Destructor | Description
~IArchive |
~IName |


Legend

Legend
IArchive Class
Legend
Method
virtual
abstract


IArchive Class Members

IArchive Class Members
IArchive Class
Members
Constructors
Constructor | Description
IArchive |
Destructors
Destructor | Description
~IArchive |
~IName |
Methods
Method | Description
GetName |
Write |


Members

Legend
Method
virtual
abstract


IArchive Class Methods

IArchive Class Methods
IArchive Class
Methods
Method | Description
GetName |
Write |


Methods

Legend
Method
abstract


Inheritance Hierarchy

Inheritance Hierarchy
IArchive Class
Inheritance Hierarchy
rage::IName
    IArchive
        rage::ActionNode


IBoolDataMember Class Constructors

IBoolDataMember Class Constructors
IBoolDataMember Class
Constructors
Constructor | Description
DataMember |
IBoolDataMember |


IBoolDataMember Class Data Members

IBoolDataMember Class Data Members
IBoolDataMember Class
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


IBoolDataMember Class Destructors

IBoolDataMember Class Destructors
IBoolDataMember Class
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IBoolDataMember | RAW_ACT_FILE_SUPPORT
~IName |


IBoolDataMember Class Enumerations

IBoolDataMember Class Enumerations
IBoolDataMember Class
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
IBoolDataMember Class
Legend
Method
virtual
abstract
protected
Data Member


IBoolDataMember Class Members

IBoolDataMember Class Members
IBoolDataMember Class
Members
Constructors
Constructor | Description
DataMember |
IBoolDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IBoolDataMember | RAW_ACT_FILE_SUPPORT
~IName |
Methods
Method | Description
GetBool |
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
Read |
Read |
SetBool |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |


IBoolDataMember Class Methods

IBoolDataMember Class Methods
IBoolDataMember Class
Methods
Method | Description
GetBool |
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
Read |
Read |
SetBool |
Write |
Write |


Methods

Legend
Method
abstract
virtual


Inheritance Hierarchy

Inheritance Hierarchy
IBoolDataMember Class
Inheritance Hierarchy
rage::IName
    rage::DataMember
        IBoolDataMember
            rage::BoolDataMember


ICommandDataMember Class Constructors

ICommandDataMember Class Constructors
ICommandDataMember Class
Constructors
Constructor | Description
DataMember |
ICommandDataMember |
IStringDataMember |


ICommandDataMember Class Data Members

ICommandDataMember Class Data Members
ICommandDataMember Class
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


ICommandDataMember Class Destructors

ICommandDataMember Class Destructors
ICommandDataMember Class
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |


ICommandDataMember Class Enumerations

ICommandDataMember Class Enumerations
ICommandDataMember Class
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
ICommandDataMember Class
Legend
Method
abstract
virtual
protected
Data Member


ICommandDataMember Class Members

ICommandDataMember Class Members
ICommandDataMember Class
Members
Constructors
Constructor | Description
DataMember |
ICommandDataMember |
IStringDataMember |
Methods
Method | Description
Execute |
GetName |
GetName |
GetPfGroupActTracks |
GetString |
GetType |
GetType |
GetType |
IsDefault |
Read |
Read |
SetString |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Enumerations
Enumeration | Description
TYPE |


Members

Legend
Method
abstract
virtual
protected
Data Member


ICommandDataMember Class Methods

ICommandDataMember Class Methods
ICommandDataMember Class
Methods
Method | Description
Execute |
GetName |
GetName |
GetPfGroupActTracks |
GetString |
GetType |
GetType |
GetType |
IsDefault |
Read |
Read |
SetString |
Write |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
ICommandDataMember Class
Inheritance Hierarchy
rage::IName
    rage::DataMember
        rage::IStringDataMember
            ICommandDataMember
                rage::CommandDataMember


IDataMembers Class Constructors

IDataMembers Class Constructors
IDataMembers Class
Constructors
Constructor | Description
IDataMembers |
IDataMembers |


IDataMembers Class Data Members

IDataMembers Class Data Members
IDataMembers Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky


IDataMembers Class Destructors

IDataMembers Class Destructors
IDataMembers Class
Destructors
Destructor | Description
~IDataMembers |
~IDataMembers |


Legend

Legend
IDataMembers Class
Legend
Data Member
Method
virtual
abstract


IDataMembers Class Members

IDataMembers Class Members
IDataMembers Class
Members
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
Constructors
Constructor | Description
IDataMembers |
IDataMembers |
Destructors
Destructor | Description
~IDataMembers |
~IDataMembers |
Methods
Method | Description
DeclareStruct |
DeclareStruct |
GetMember |
GetMember |
GetNumMembers |
GetNumMembers |
Read |
Read |
Reset |
Reset |
Write |
Write |


IDataMembers Class Methods

IDataMembers Class Methods
IDataMembers Class
Methods
Method | Description
DeclareStruct |
DeclareStruct |
GetMember |
GetMember |
GetNumMembers |
GetNumMembers |
Read |
Read |
Reset |
Reset |
Write |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
IDataMembers Class
Inheritance Hierarchy
rage::IDataMembers
        IDataMembers
            rage::ActionNodeFileReference
            rage::IDataMembers
            rage::TrackOrCondition


IEnumDataMember Class Constructors

IEnumDataMember Class Constructors
IEnumDataMember Class
Constructors
Constructor | Description
DataMember |
IEnumDataMember |


IEnumDataMember Class Data Members

IEnumDataMember Class Data Members
IEnumDataMember Class
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


IEnumDataMember Class Destructors

IEnumDataMember Class Destructors
IEnumDataMember Class
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |


IEnumDataMember Class Enumerations

IEnumDataMember Class Enumerations
IEnumDataMember Class
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
IEnumDataMember Class
Legend
Method
abstract
virtual
protected
Data Member


IEnumDataMember Class Members

IEnumDataMember Class Members
IEnumDataMember Class
Members
Constructors
Constructor | Description
DataMember |
IEnumDataMember |
Methods
Method | Description
GetEnum |
GetEnumName |
GetName |
GetName |
GetNumEnums |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
Read |
Read |
SetEnum |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Enumerations
Enumeration | Description
TYPE |


IEnumDataMember Class Methods

IEnumDataMember Class Methods
IEnumDataMember Class
Methods
Method | Description
GetEnum |
GetEnumName |
GetName |
GetName |
GetNumEnums |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
Read |
Read |
SetEnum |
Write |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
IEnumDataMember Class
Inheritance Hierarchy
rage::IName
    rage::DataMember
        IEnumDataMember
            rage::EnumDataMember


IFloatDataMember Class Constructors

IFloatDataMember Class Constructors
IFloatDataMember Class
Constructors
Constructor | Description
DataMember |
IFloatDataMember |


IFloatDataMember Class Data Members

IFloatDataMember Class Data Members
IFloatDataMember Class
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


IFloatDataMember Class Destructors

IFloatDataMember Class Destructors
IFloatDataMember Class
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |


IFloatDataMember Class Enumerations

IFloatDataMember Class Enumerations
IFloatDataMember Class
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
IFloatDataMember Class
Legend
Method
abstract
virtual
protected
Data Member


IFloatDataMember Class Members

IFloatDataMember Class Members
IFloatDataMember Class
Members
Constructors
Constructor | Description
DataMember |
IFloatDataMember |
Methods
Method | Description
GetFloat |
GetMinMaxFloat | RAW_ACT_FILE_SUPPORT
GetName |
GetName |
GetPfGroupActTracks |
GetType |
IsDefault |
Read |
Read |
SetFloat |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Enumerations
Enumeration | Description
TYPE |


IFloatDataMember Class Methods

IFloatDataMember Class Methods
IFloatDataMember Class
Methods
Method | Description
GetFloat |
GetMinMaxFloat | RAW_ACT_FILE_SUPPORT
GetName |
GetName |
GetPfGroupActTracks |
GetType |
IsDefault |
Read |
Read |
SetFloat |
Write |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
IFloatDataMember Class
Inheritance Hierarchy
rage::IName
    rage::DataMember
        IFloatDataMember
            rage::FloatDataMember


IGroupDataMember Class Constructors

IGroupDataMember Class Constructors
IGroupDataMember Class
Constructors
Constructor | Description
DataMember |
IGroupDataMember |


IGroupDataMember Class Data Members

IGroupDataMember Class Data Members
IGroupDataMember Class
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


IGroupDataMember Class Destructors

IGroupDataMember Class Destructors
IGroupDataMember Class
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |


IGroupDataMember Class Enumerations

IGroupDataMember Class Enumerations
IGroupDataMember Class
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
IGroupDataMember Class
Legend
Method
abstract
virtual
protected
Data Member


IGroupDataMember Class Members

IGroupDataMember Class Members
IGroupDataMember Class
Members
Constructors
Constructor | Description
DataMember |
IGroupDataMember |
Methods
Method | Description
Add |
ChangePriority |
Delete |
GetCount |
GetDataMember |
GetDataMemberFormat |
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
Read |
Read |
ReadAllElements |
Write |
Write |
WriteElements |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Enumerations
Enumeration | Description
TYPE |


IGroupDataMember Class Methods

IGroupDataMember Class Methods
IGroupDataMember Class
Methods
Method | Description
Add |
ChangePriority |
Delete |
GetCount |
GetDataMember |
GetDataMemberFormat |
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
Read |
Read |
ReadAllElements |
Write |
Write |
WriteElements |


Inheritance Hierarchy

Inheritance Hierarchy
IGroupDataMember Class
Inheritance Hierarchy
rage::IName
    rage::DataMember
        IGroupDataMember
            rage::GroupDataMember


IIntDataMember Class Constructors

IIntDataMember Class Constructors
IIntDataMember Class
Constructors
Constructor | Description
DataMember |
IIntDataMember |


IIntDataMember Class Data Members

IIntDataMember Class Data Members
IIntDataMember Class
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


IIntDataMember Class Destructors

IIntDataMember Class Destructors
IIntDataMember Class
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |


IIntDataMember Class Enumerations

IIntDataMember Class Enumerations
IIntDataMember Class
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
IIntDataMember Class
Legend
Method
abstract
virtual
protected
Data Member


IIntDataMember Class Members

IIntDataMember Class Members
IIntDataMember Class
Members
Constructors
Constructor | Description
DataMember |
IIntDataMember |
Methods
Method | Description
GetInt |
GetMinMaxInt | RAW_ACT_FILE_SUPPORT
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
Read |
Read |
SetInt |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Enumerations
Enumeration | Description
TYPE |


IIntDataMember Class Methods

IIntDataMember Class Methods
IIntDataMember Class
Methods
Method | Description
GetInt |
GetMinMaxInt | RAW_ACT_FILE_SUPPORT
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
Read |
Read |
SetInt |
Write |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
IIntDataMember Class
Inheritance Hierarchy
rage::IName
    rage::DataMember
        IIntDataMember
            rage::IntDataMember


IMultiNodeReferenceTrack Class Constructors

IMultiNodeReferenceTrack Class Constructors
IMultiNodeReferenceTrack Class
Constructors
Constructor | Description
IDataMembers |
IMultiNodeReferenceTrack |
INodeReferenceTrack |
Track |
TrackOrCondition |


IMultiNodeReferenceTrack Class Data Members

IMultiNodeReferenceTrack Class Data Members
IMultiNodeReferenceTrack Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |


IMultiNodeReferenceTrack Class Destructors

IMultiNodeReferenceTrack Class Destructors
IMultiNodeReferenceTrack Class
Destructors
Destructor | Description
~IDataMembers |
~Track |


Legend

Legend
IMultiNodeReferenceTrack Class
Legend
Method
virtual
protected
abstract
Data Member


IMultiNodeReferenceTrack Class Members

IMultiNodeReferenceTrack Class Members
IMultiNodeReferenceTrack Class
Members
Constructors
Constructor | Description
IDataMembers |
IMultiNodeReferenceTrack |
INodeReferenceTrack |
Track |
TrackOrCondition |
Methods
Method | Description
Break |
Create |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRefs |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRef |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | (to eliminate the need for dynamic_cast
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
Read |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent | Sets the parent for *all* node references.
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
UpdateFrame |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |
Structs
Struct | Description
Timer |
Destructors
Destructor | Description
~IDataMembers |
~Track |


IMultiNodeReferenceTrack Class Methods

IMultiNodeReferenceTrack Class Methods
IMultiNodeReferenceTrack Class
Methods
Method | Description
Break |
Create |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRefs |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRef |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | (to eliminate the need for dynamic_cast
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
Read |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent | Sets the parent for *all* node references.
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
UpdateFrame |
Write |
Write | lint !e1735


IMultiNodeReferenceTrack Class Structs

IMultiNodeReferenceTrack Class Structs
IMultiNodeReferenceTrack Class
Structs
Struct | Description
Timer |


Inheritance Hierarchy

Inheritance Hierarchy
IMultiNodeReferenceTrack Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Track
                rage::INodeReferenceTrack
                    IMultiNodeReferenceTrack


IName Class Destructors

IName Class Destructors
IName Class
Destructors
Destructor | Description
~IName |


Legend

Legend
IName Class
Legend
Method
virtual
abstract


IName Class Members

IName Class Members
IName Class
Members
Destructors
Destructor | Description
~IName |
Methods
Method | Description
GetName |


IName Class Methods

IName Class Methods
IName Class
Methods
Method | Description
GetName |


Inheritance Hierarchy

Inheritance Hierarchy
IName Class
Inheritance Hierarchy
IName
    rage::DataMember
    rage::IArchive
    rage::ITrackFactory


INodeReferenceDataMember Class Constructors

INodeReferenceDataMember Class Constructors
INodeReferenceDataMember Class
Constructors
Constructor | Description
DataMember |
INodeReferenceDataMember |
IStringDataMember |


INodeReferenceDataMember Class Data Members

INodeReferenceDataMember Class Data Members
INodeReferenceDataMember Class
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


INodeReferenceDataMember Class Destructors

INodeReferenceDataMember Class Destructors
INodeReferenceDataMember Class
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |


INodeReferenceDataMember Class Enumerations

INodeReferenceDataMember Class Enumerations
INodeReferenceDataMember Class
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
INodeReferenceDataMember Class
Legend
Method
abstract
virtual
protected
Data Member


INodeReferenceDataMember Class Members

INodeReferenceDataMember Class Members
INodeReferenceDataMember Class
Members
Constructors
Constructor | Description
DataMember |
INodeReferenceDataMember |
IStringDataMember |
Methods
Method | Description
GetFullPath |
GetName |
GetName |
GetPfGroupActTracks |
GetString |
GetType |
GetType |
GetType |
IsDefault |
IsResolved |
Read |
Read |
SetString |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Enumerations
Enumeration | Description
TYPE |


INodeReferenceDataMember Class Methods

INodeReferenceDataMember Class Methods
INodeReferenceDataMember Class
Methods
Method | Description
GetFullPath |
GetName |
GetName |
GetPfGroupActTracks |
GetString |
GetType |
GetType |
GetType |
IsDefault |
IsResolved |
Read |
Read |
SetString |
Write |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
INodeReferenceDataMember Class
Inheritance Hierarchy
rage::IName
    rage::DataMember
        rage::IStringDataMember
            INodeReferenceDataMember
                rage::NodeReferenceDataMember


INodeReferenceTrack Class Constructors

INodeReferenceTrack Class Constructors
INodeReferenceTrack Class
Constructors
Constructor | Description
IDataMembers |
INodeReferenceTrack |
Track |
TrackOrCondition |


INodeReferenceTrack Class Data Members

INodeReferenceTrack Class Data Members
INodeReferenceTrack Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |


INodeReferenceTrack Class Destructors

INodeReferenceTrack Class Destructors
INodeReferenceTrack Class
Destructors
Destructor | Description
~IDataMembers |
~Track |


Legend

Legend
INodeReferenceTrack Class
Legend
Method
virtual
protected
abstract
Data Member


INodeReferenceTrack Class Members

INodeReferenceTrack Class Members
INodeReferenceTrack Class
Members
Constructors
Constructor | Description
IDataMembers |
INodeReferenceTrack |
Track |
TrackOrCondition |
Methods
Method | Description
Break |
Create |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeResolved |
NewTask |
Read |
Reset |
ResetTimers |
ResolveReference |
SetActionNodeParent |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
UpdateFrame |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |
Structs
Struct | Description
Timer |
Destructors
Destructor | Description
~IDataMembers |
~Track |


INodeReferenceTrack Class Methods

INodeReferenceTrack Class Methods
INodeReferenceTrack Class
Methods
Method | Description
Break |
Create |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeResolved |
NewTask |
Read |
Reset |
ResetTimers |
ResolveReference |
SetActionNodeParent |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
UpdateFrame |
Write |
Write | lint !e1735


INodeReferenceTrack Class Structs

INodeReferenceTrack Class Structs
INodeReferenceTrack Class
Structs
Struct | Description
Timer |


Inheritance Hierarchy

Inheritance Hierarchy
INodeReferenceTrack Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Track
                INodeReferenceTrack
                    rage::IMultiNodeReferenceTrack
                    rage::NodeReferenceTrack


InstancedActionController Class Constructors

InstancedActionController Class Constructors
InstancedActionController Class
Constructors
Constructor | Description
ActionController |


InstancedActionController Class Data Members

InstancedActionController Class Data Members
InstancedActionController Class
Data Members
Data Member | Description
m_SequencedTracks |
s_NoOfTaskUpdates |


InstancedActionController Class Destructors

InstancedActionController Class Destructors
InstancedActionController Class
Destructors
Destructor | Description
~ActionController |
~InstancedActionController |


Legend

Legend
InstancedActionController Class
Legend
protected
Data Member
Method
virtual


InstancedActionController Class Members

InstancedActionController Class Members
InstancedActionController Class
Members
Data Members
Data Member | Description
m_SequencedTracks |
s_NoOfTaskUpdates |
Structs
Struct | Description
refCountingTracks |
Destructors
Destructor | Description
~ActionController |
~InstancedActionController |
Methods
Method | Description
AddSequncedTrack |
BeginDebugTask |
clearAll |
ClearSequencedTrack |
clearSequencedTracks |
DeleteSequencedTrack |
EndDebugTask |
EndTask |
GetBeginBreakPoint |
GetContext |
GetControlContext |
GetCurrentNodePlayTime |
GetCurrentPlayCount |
GetCurrentPlayingNode |
GetDebug |
GetEndBreakPoint |
GetNumSequencedTracks |
GetPlayHistory |
GetRequestedNode |
GetRunningTaskRoot |
GetSequencedTrack | implement this in the subclasses
GetUpDateBreakPoint |
IsBusy | const ActionNode * GetCurrentSequencedNode(void)const{return(m_SequencedNode); short GetSequencedPriority(void)const{return(m_SequencedPriority);
Play | These deal with ActionNodes so Banks can be sequenced or played The PlayActionNode will search for playable NODE to sequence!
PlayRemote | : used by the mutli-player function to execute remote actions. keeps a signature to prevent multiple plays of same action.
PlayTracks |
RemoveTask |
Sequence |
SetBeginBreakPoint | These are for hooking in BreakPoints on Track/Task instances
SetContext |
SetControlContext | does nothing CONTROL_CONTEXT_ENABLED
SetDebug |
SetEndBreakPoint |
SetRequestedNode |
SetUpDateBreakPoint |
StartSequencedTracks |
Stop |
TRACKMSG |
Update | Normally only update is called
UpdateDebugTask |
UpdateTasks |
UpdateTasksTimeEnd |
UpdateWithKeepAlive |
Constructors
Constructor | Description
ActionController |


InstancedActionController Class Methods

InstancedActionController Class Methods
InstancedActionController Class
Methods
Method | Description
AddSequncedTrack |
BeginDebugTask |
clearAll |
ClearSequencedTrack |
clearSequencedTracks |
DeleteSequencedTrack |
EndDebugTask |
EndTask |
GetBeginBreakPoint |
GetContext |
GetControlContext |
GetCurrentNodePlayTime |
GetCurrentPlayCount |
GetCurrentPlayingNode |
GetDebug |
GetEndBreakPoint |
GetNumSequencedTracks |
GetPlayHistory |
GetRequestedNode |
GetRunningTaskRoot |
GetSequencedTrack | implement this in the subclasses
GetUpDateBreakPoint |
IsBusy | const ActionNode * GetCurrentSequencedNode(void)const{return(m_SequencedNode); short GetSequencedPriority(void)const{return(m_SequencedPriority);
Play | These deal with ActionNodes so Banks can be sequenced or played The PlayActionNode will search for playable NODE to sequence!
PlayRemote | : used by the mutli-player function to execute remote actions. keeps a signature to prevent multiple plays of same action.
PlayTracks |
RemoveTask |
Sequence |
SetBeginBreakPoint | These are for hooking in BreakPoints on Track/Task instances
SetContext |
SetControlContext | does nothing CONTROL_CONTEXT_ENABLED
SetDebug |
SetEndBreakPoint |
SetRequestedNode |
SetUpDateBreakPoint |
StartSequencedTracks |
Stop |
TRACKMSG |
Update | Normally only update is called
UpdateDebugTask |
UpdateTasks |
UpdateTasksTimeEnd |
UpdateWithKeepAlive |


Methods

Legend
protected
Method
virtual


InstancedActionController Class Structs

InstancedActionController Class Structs
InstancedActionController Class
Structs
Struct | Description
refCountingTracks |


Inheritance Hierarchy

Inheritance Hierarchy
InstancedActionController Class
Inheritance Hierarchy
rage::ActionController
    InstancedActionController


IntDataMember Template Constructors

IntDataMember Template Constructors
IntDataMember Template
Constructors
Constructor | Description
DataMember |
IIntDataMember |
IntDataMember |


IntDataMember Template Data Members

IntDataMember Template Data Members
IntDataMember Template
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


IntDataMember Template Destructors

IntDataMember Template Destructors
IntDataMember Template
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
~IntDataMember |


IntDataMember Template Enumerations

IntDataMember Template Enumerations
IntDataMember Template
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
IntDataMember Template
Legend
Method
virtual
abstract
protected
Data Member


IntDataMember Template Members

IntDataMember Template Members
IntDataMember Template
Members
Constructors
Constructor | Description
DataMember |
IIntDataMember |
IntDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
~IntDataMember |
Methods
Method | Description
GetInt |
GetInt |
GetMinMaxInt | RAW_ACT_FILE_SUPPORT
GetMinMaxInt | RAW_ACT_FILE_SUPPORT
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
IsDefault |
Read |
Read |
SetInt |
SetInt |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |


IntDataMember Template Methods

IntDataMember Template Methods
IntDataMember Template
Methods
Method | Description
GetInt |
GetInt |
GetMinMaxInt | RAW_ACT_FILE_SUPPORT
GetMinMaxInt | RAW_ACT_FILE_SUPPORT
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
IsDefault |
IsDefault |
Read |
Read |
SetInt |
SetInt |
Write |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
IntDataMember Template
Inheritance Hierarchy
rage::IName
    rage::DataMember
        rage::IIntDataMember
            IntDataMember


IObserver Class Destructors

IObserver Class Destructors
IObserver Class
Destructors
Destructor | Description
~IObserver | in tool this results in a pure virtual function call


Legend

Legend
IObserver Class
Legend
Method
virtual
abstract


IObserver Class Members

IObserver Class Members
IObserver Class
Members
Destructors
Destructor | Description
~IObserver | in tool this results in a pure virtual function call
Methods
Method | Description
HandleMessage |
Update |
UpdateDetach |


IObserver Class Methods

IObserver Class Methods
IObserver Class
Methods
Method | Description
HandleMessage |
Update |
UpdateDetach |


Inheritance Hierarchy

Inheritance Hierarchy
IObserver Class
Inheritance Hierarchy
IObserver


IStringDataMember Class Constructors

IStringDataMember Class Constructors
IStringDataMember Class
Constructors
Constructor | Description
DataMember |
IStringDataMember |


IStringDataMember Class Data Members

IStringDataMember Class Data Members
IStringDataMember Class
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


IStringDataMember Class Destructors

IStringDataMember Class Destructors
IStringDataMember Class
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |


IStringDataMember Class Enumerations

IStringDataMember Class Enumerations
IStringDataMember Class
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
IStringDataMember Class
Legend
Method
virtual
abstract
protected
Data Member


IStringDataMember Class Members

IStringDataMember Class Members
IStringDataMember Class
Members
Constructors
Constructor | Description
DataMember |
IStringDataMember |
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetString |
GetType |
GetType |
IsDefault |
Read |
Read |
SetString |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Enumerations
Enumeration | Description
TYPE |


IStringDataMember Class Methods

IStringDataMember Class Methods
IStringDataMember Class
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetString |
GetType |
GetType |
IsDefault |
Read |
Read |
SetString |
Write |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
IStringDataMember Class
Inheritance Hierarchy
rage::IName
    rage::DataMember
        IStringDataMember
            rage::ICommandDataMember
            rage::INodeReferenceDataMember
            rage::StringDataMember


ITrackFactory Class Constructors

ITrackFactory Class Constructors
ITrackFactory Class
Constructors
Constructor | Description
ITrackFactory |


ITrackFactory Class Destructors

ITrackFactory Class Destructors
ITrackFactory Class
Destructors
Destructor | Description
~IName |
~ITrackFactory |


Legend

Legend
ITrackFactory Class
Legend
Method
virtual
abstract


ITrackFactory Class Members

ITrackFactory Class Members
ITrackFactory Class
Members
Constructors
Constructor | Description
ITrackFactory |
Destructors
Destructor | Description
~IName |
~ITrackFactory |
Methods
Method | Description
GetName |
GetRorcChecksum |
GetTrackType |
NewTrack |
Place |
SetTypeId | RAW_ACT_FILE_SUPPORT


ITrackFactory Class Methods

ITrackFactory Class Methods
ITrackFactory Class
Methods
Method | Description
GetName |
GetRorcChecksum |
GetTrackType |
NewTrack |
Place |
SetTypeId | RAW_ACT_FILE_SUPPORT


Inheritance Hierarchy

Inheritance Hierarchy
ITrackFactory Class
Inheritance Hierarchy
rage::IName
    ITrackFactory
        rage::TrackFactory


IVector2DataMember Class Constructors

IVector2DataMember Class Constructors
IVector2DataMember Class
Constructors
Constructor | Description
DataMember |
IVector2DataMember |


IVector2DataMember Class Data Members

IVector2DataMember Class Data Members
IVector2DataMember Class
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


IVector2DataMember Class Destructors

IVector2DataMember Class Destructors
IVector2DataMember Class
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |


IVector2DataMember Class Enumerations

IVector2DataMember Class Enumerations
IVector2DataMember Class
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
IVector2DataMember Class
Legend
Method
virtual
abstract
protected
Data Member


IVector2DataMember Class Members

IVector2DataMember Class Members
IVector2DataMember Class
Members
Constructors
Constructor | Description
DataMember |
IVector2DataMember |
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetVector2 |
IsDefault |
Read |
Read |
SetVector2 |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Enumerations
Enumeration | Description
TYPE |


IVector2DataMember Class Methods

IVector2DataMember Class Methods
IVector2DataMember Class
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetVector2 |
IsDefault |
Read |
Read |
SetVector2 |
Write |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
IVector2DataMember Class
Inheritance Hierarchy
rage::IName
    rage::DataMember
        IVector2DataMember
            rage::Vector2DataMember


IVector3DataMember Class Constructors

IVector3DataMember Class Constructors
IVector3DataMember Class
Constructors
Constructor | Description
DataMember |
IVector3DataMember |


IVector3DataMember Class Data Members

IVector3DataMember Class Data Members
IVector3DataMember Class
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


IVector3DataMember Class Destructors

IVector3DataMember Class Destructors
IVector3DataMember Class
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |


IVector3DataMember Class Enumerations

IVector3DataMember Class Enumerations
IVector3DataMember Class
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
IVector3DataMember Class
Legend
Method
virtual
abstract
protected
Data Member


IVector3DataMember Class Members

IVector3DataMember Class Members
IVector3DataMember Class
Members
Constructors
Constructor | Description
DataMember |
IVector3DataMember |
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetVector3 |
IsDefault |
Read |
Read |
SetVector3 |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
Enumerations
Enumeration | Description
TYPE |


IVector3DataMember Class Methods

IVector3DataMember Class Methods
IVector3DataMember Class
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetVector3 |
IsDefault |
Read |
Read |
SetVector3 |
Write |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
IVector3DataMember Class
Inheritance Hierarchy
rage::IName
    rage::DataMember
        IVector3DataMember
            rage::Vector3DataMember


NodeReferenceDataMember Template Constructors

NodeReferenceDataMember Template Constructors
NodeReferenceDataMember Template
Constructors
Constructor | Description
DataMember |
INodeReferenceDataMember |
IStringDataMember |
NodeReferenceDataMember |


NodeReferenceDataMember Template Data Members

NodeReferenceDataMember Template Data Members
NodeReferenceDataMember Template
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


NodeReferenceDataMember Template Destructors

NodeReferenceDataMember Template Destructors
NodeReferenceDataMember Template
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
~NodeReferenceDataMember |


NodeReferenceDataMember Template Enumerations

NodeReferenceDataMember Template Enumerations
NodeReferenceDataMember Template
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
NodeReferenceDataMember Template
Legend
Method
virtual
abstract
protected
Data Member


NodeReferenceDataMember Template Members

NodeReferenceDataMember Template Members
NodeReferenceDataMember Template
Members
Constructors
Constructor | Description
DataMember |
INodeReferenceDataMember |
IStringDataMember |
NodeReferenceDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
~NodeReferenceDataMember |
Methods
Method | Description
GetFullPath |
GetFullPath | RAW_ACT_FILE_SUPPORT
GetName |
GetName |
GetPfGroupActTracks |
GetString |
GetString |
GetType |
GetType |
GetType |
IsDefault |
IsDefault |
IsResolved |
IsResolved |
Read |
Read |
SetString |
SetString |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |


NodeReferenceDataMember Template Methods

NodeReferenceDataMember Template Methods
NodeReferenceDataMember Template
Methods
Method | Description
GetFullPath |
GetFullPath | RAW_ACT_FILE_SUPPORT
GetName |
GetName |
GetPfGroupActTracks |
GetString |
GetString |
GetType |
GetType |
GetType |
IsDefault |
IsDefault |
IsResolved |
IsResolved |
Read |
Read |
SetString |
SetString |
Write |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
NodeReferenceDataMember Template
Inheritance Hierarchy
rage::IName
    rage::DataMember
        rage::IStringDataMember
            rage::INodeReferenceDataMember
                NodeReferenceDataMember


NodeReferenceTrack Class Constructors

NodeReferenceTrack Class Constructors
NodeReferenceTrack Class
Constructors
Constructor | Description
IDataMembers |
INodeReferenceTrack |
NodeReferenceTrack |
Track |
TrackOrCondition |


NodeReferenceTrack Class Data Members

NodeReferenceTrack Class Data Members
NodeReferenceTrack Class
Data Members
Data Member | Description
m_ActionNodeRef |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |


NodeReferenceTrack Class Destructors

NodeReferenceTrack Class Destructors
NodeReferenceTrack Class
Destructors
Destructor | Description
~IDataMembers |
~NodeReferenceTrack |
~Track |


Legend

Legend
NodeReferenceTrack Class
Legend
protected
Data Member
Method
virtual
abstract


NodeReferenceTrack Class Members

NodeReferenceTrack Class Members
NodeReferenceTrack Class
Members
Data Members
Data Member | Description
m_ActionNodeRef |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |
Constructors
Constructor | Description
IDataMembers |
INodeReferenceTrack |
NodeReferenceTrack |
Track |
TrackOrCondition |
Destructors
Destructor | Description
~IDataMembers |
~NodeReferenceTrack |
~Track |
Methods
Method | Description
Break |
Create |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
Read |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent |
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
UpdateFrame |
Write |
Write | lint !e1735
Structs
Struct | Description
Timer |


NodeReferenceTrack Class Methods

NodeReferenceTrack Class Methods
NodeReferenceTrack Class
Methods
Method | Description
Break |
Create |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
Read |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent |
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
UpdateFrame |
Write |
Write | lint !e1735


NodeReferenceTrack Class Structs

NodeReferenceTrack Class Structs
NodeReferenceTrack Class
Structs
Struct | Description
Timer |


Inheritance Hierarchy

Inheritance Hierarchy
NodeReferenceTrack Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Track
                rage::INodeReferenceTrack
                    NodeReferenceTrack
                        rage::ExecuteTrack
                        rage::OpportunityTrack
                        rage::SequenceTrack
                        rage::SpawnTrack


OpportunityRandomLatchTask Class Constructors

OpportunityRandomLatchTask Class Constructors
OpportunityRandomLatchTask Class
Constructors
Constructor | Description
ATask |
OpportunityRandomLatchTask |
OpportunityTask |


OpportunityRandomLatchTask Class Data Members

OpportunityRandomLatchTask Class Data Members
OpportunityRandomLatchTask Class
Data Members
Data Member | Description
m_AlreadyBreaked |
m_Context |
m_Latched |
m_latchedPlayable |
m_LatchTime | acquired latch time. Just grabbed from track in the superclass.
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted


OpportunityRandomLatchTask Class Destructors

OpportunityRandomLatchTask Class Destructors
OpportunityRandomLatchTask Class
Destructors
Destructor | Description
~ATask |
~OpportunityRandomLatchTask |
~OpportunityTask |


Legend

Legend
OpportunityRandomLatchTask Class
Legend
Method
virtual
protected
abstract
Data Member


OpportunityRandomLatchTask Class Members

OpportunityRandomLatchTask Class Members
OpportunityRandomLatchTask Class
Members
Constructors
Constructor | Description
ATask |
OpportunityRandomLatchTask |
OpportunityTask |
Destructors
Destructor | Description
~ATask |
~OpportunityRandomLatchTask |
~OpportunityTask |
Methods
Method | Description
AcquireLatchTime | allow latch time to be overridden, to allow for "OpportunityRandomLatch
AcquireLatchTime | allow latch time to be overridden, to allow for "OpportunityRandomLatch
Begin |
Begin |
End |
End |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
GetTrack |
Update |
Update |
Data Members
Data Member | Description
m_AlreadyBreaked |
m_Context |
m_Latched |
m_latchedPlayable |
m_LatchTime | acquired latch time. Just grabbed from track in the superclass.
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted


OpportunityRandomLatchTask Class Methods

OpportunityRandomLatchTask Class Methods
OpportunityRandomLatchTask Class
Methods
Method | Description
AcquireLatchTime | allow latch time to be overridden, to allow for "OpportunityRandomLatch
AcquireLatchTime | allow latch time to be overridden, to allow for "OpportunityRandomLatch
Begin |
Begin |
End |
End |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
GetTrack |
Update |
Update |


Inheritance Hierarchy

Inheritance Hierarchy
OpportunityRandomLatchTask Class
Inheritance Hierarchy
rage::ATask
    rage::OpportunityTask
        OpportunityRandomLatchTask


OpportunityRandomLatchTrack Class Constructors

OpportunityRandomLatchTrack Class Constructors
OpportunityRandomLatchTrack Class
Constructors
Constructor | Description
IDataMembers |
INodeReferenceTrack |
NodeReferenceTrack |
OpportunityRandomLatchTrack |
OpportunityTrack |
Track |
TrackOrCondition |


OpportunityRandomLatchTrack Class Data Members

OpportunityRandomLatchTrack Class Data Members
OpportunityRandomLatchTrack Class
Data Members
Data Member | Description
m_ActionNodeRef |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |


OpportunityRandomLatchTrack Class Destructors

OpportunityRandomLatchTrack Class Destructors
OpportunityRandomLatchTrack Class
Destructors
Destructor | Description
~IDataMembers |
~NodeReferenceTrack |
~OpportunityRandomLatchTrack |
~OpportunityTrack |
~Track |


Legend

Legend
OpportunityRandomLatchTrack Class
Legend
Method
virtual
protected
abstract
Data Member


OpportunityRandomLatchTrack Class Members

OpportunityRandomLatchTrack Class Members
OpportunityRandomLatchTrack Class
Members
Constructors
Constructor | Description
IDataMembers |
INodeReferenceTrack |
NodeReferenceTrack |
OpportunityRandomLatchTrack |
OpportunityTrack |
Track |
TrackOrCondition |
Destructors
Destructor | Description
~IDataMembers |
~NodeReferenceTrack |
~OpportunityRandomLatchTrack |
~OpportunityTrack |
~Track |
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup | In order to have a local ConditionGroup
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
NewTask |
NewTask |
Read |
ReadConditionGroup |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent |
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
TRACK_MEMBER |
TRACK_PADDING |
TRACK_PARAMETER |
TRACK_PARAMETER |
UpdateFrame |
Write |
Write | lint !e1735
WriteCondition |
Data Members
Data Member | Description
m_ActionNodeRef |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |
Structs
Struct | Description
Timer |


OpportunityRandomLatchTrack Class Methods

OpportunityRandomLatchTrack Class Methods
OpportunityRandomLatchTrack Class
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup | In order to have a local ConditionGroup
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
NewTask |
NewTask |
Read |
ReadConditionGroup |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent |
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
TRACK_MEMBER |
TRACK_PADDING |
TRACK_PARAMETER |
TRACK_PARAMETER |
UpdateFrame |
Write |
Write | lint !e1735
WriteCondition |


OpportunityRandomLatchTrack Class Structs

OpportunityRandomLatchTrack Class Structs
OpportunityRandomLatchTrack Class
Structs
Struct | Description
Timer |


Inheritance Hierarchy

Inheritance Hierarchy
OpportunityRandomLatchTrack Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Track
                rage::INodeReferenceTrack
                    rage::NodeReferenceTrack
                        rage::OpportunityTrack
                            OpportunityRandomLatchTrack


OpportunityTask Class Constructors

OpportunityTask Class Constructors
OpportunityTask Class
Constructors
Constructor | Description
ATask |
OpportunityTask |


OpportunityTask Class Data Members

OpportunityTask Class Data Members
OpportunityTask Class
Data Members
Data Member | Description
m_AlreadyBreaked |
m_Context |
m_Latched |
m_latchedPlayable |
m_LatchTime | acquired latch time. Just grabbed from track in the superclass.
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted


OpportunityTask Class Destructors

OpportunityTask Class Destructors
OpportunityTask Class
Destructors
Destructor | Description
~ATask |
~OpportunityTask |


Legend

Legend
OpportunityTask Class
Legend
protected
Data Member
Method
virtual
abstract


OpportunityTask Class Members

OpportunityTask Class Members
OpportunityTask Class
Members
Data Members
Data Member | Description
m_AlreadyBreaked |
m_Context |
m_Latched |
m_latchedPlayable |
m_LatchTime | acquired latch time. Just grabbed from track in the superclass.
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted
Constructors
Constructor | Description
ATask |
OpportunityTask |
Destructors
Destructor | Description
~ATask |
~OpportunityTask |
Methods
Method | Description
AcquireLatchTime | allow latch time to be overridden, to allow for "OpportunityRandomLatch
Begin |
Begin |
End |
End |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
Update |
Update |


OpportunityTask Class Methods

OpportunityTask Class Methods
OpportunityTask Class
Methods
Method | Description
AcquireLatchTime | allow latch time to be overridden, to allow for "OpportunityRandomLatch
Begin |
Begin |
End |
End |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
Update |
Update |


Methods

Legend
protected
Method
virtual
abstract


Inheritance Hierarchy

Inheritance Hierarchy
OpportunityTask Class
Inheritance Hierarchy
rage::ATask
    OpportunityTask
        rage::OpportunityRandomLatchTask


OpportunityTrack Class Constructors

OpportunityTrack Class Constructors
OpportunityTrack Class
Constructors
Constructor | Description
IDataMembers |
INodeReferenceTrack |
NodeReferenceTrack |
OpportunityTrack |
Track |
TrackOrCondition |


OpportunityTrack Class Data Members

OpportunityTrack Class Data Members
OpportunityTrack Class
Data Members
Data Member | Description
m_ActionNodeRef |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |


OpportunityTrack Class Destructors

OpportunityTrack Class Destructors
OpportunityTrack Class
Destructors
Destructor | Description
~IDataMembers |
~NodeReferenceTrack |
~OpportunityTrack |
~Track |


Legend

Legend
OpportunityTrack Class
Legend
Method
virtual
protected
abstract
Data Member


OpportunityTrack Class Members

OpportunityTrack Class Members
OpportunityTrack Class
Members
Constructors
Constructor | Description
IDataMembers |
INodeReferenceTrack |
NodeReferenceTrack |
OpportunityTrack |
Track |
TrackOrCondition |
Destructors
Destructor | Description
~IDataMembers |
~NodeReferenceTrack |
~OpportunityTrack |
~Track |
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup | In order to have a local ConditionGroup
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
NewTask |
Read |
ReadConditionGroup |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent |
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
TRACK_MEMBER |
TRACK_PARAMETER |
UpdateFrame |
Write |
Write | lint !e1735
WriteCondition |
Data Members
Data Member | Description
m_ActionNodeRef |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |
Structs
Struct | Description
Timer |


OpportunityTrack Class Methods

OpportunityTrack Class Methods
OpportunityTrack Class
Methods
Method | Description
AddCondition |
Break |
ChangeConditionPriority |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
DeleteCondition |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetCondition |
GetConditionCount |
GetConditionFormat |
GetConditionGroup | In order to have a local ConditionGroup
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
NewTask |
Read |
ReadConditionGroup |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent |
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
TRACK_MEMBER |
TRACK_PARAMETER |
UpdateFrame |
Write |
Write | lint !e1735
WriteCondition |


OpportunityTrack Class Structs

OpportunityTrack Class Structs
OpportunityTrack Class
Structs
Struct | Description
Timer |


Inheritance Hierarchy

Inheritance Hierarchy
OpportunityTrack Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Track
                rage::INodeReferenceTrack
                    rage::NodeReferenceTrack
                        OpportunityTrack
                            rage::OpportunityRandomLatchTrack


PrintTask Class Constructors

PrintTask Class Constructors
PrintTask Class
Constructors
Constructor | Description
ATask |
PrintTask |


PrintTask Class Data Members

PrintTask Class Data Members
PrintTask Class
Data Members
Data Member | Description
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted


PrintTask Class Destructors

PrintTask Class Destructors
PrintTask Class
Destructors
Destructor | Description
~ATask |
~PrintTask |


Legend

Legend
PrintTask Class
Legend
Method
virtual
abstract
Data Member


PrintTask Class Members

PrintTask Class Members
PrintTask Class
Members
Constructors
Constructor | Description
ATask |
PrintTask |
Destructors
Destructor | Description
~ATask |
~PrintTask |
Methods
Method | Description
Begin |
Begin | PrintTask
End |
End |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
Update |
Update |
Data Members
Data Member | Description
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted


PrintTask Class Methods

PrintTask Class Methods
PrintTask Class
Methods
Method | Description
Begin |
Begin | PrintTask
End |
End |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
Update |
Update |


Inheritance Hierarchy

Inheritance Hierarchy
PrintTask Class
Inheritance Hierarchy
rage::ATask
    PrintTask


PrintTrack Class Constructors

PrintTrack Class Constructors
PrintTrack Class
Constructors
Constructor | Description
IDataMembers |
PrintTrack |
Track |
TrackOrCondition |


PrintTrack Class Data Members

PrintTrack Class Data Members
PrintTrack Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_PrintChannelEnabled |
sm_TimerPool |


PrintTrack Class Destructors

PrintTrack Class Destructors
PrintTrack Class
Destructors
Destructor | Description
~IDataMembers |
~PrintTrack |
~Track |


PrintTrack Class Enumerations

PrintTrack Class Enumerations
PrintTrack Class
Enumerations
Enumeration | Description
PrintChannels | keep in sync with ConditionPrint::PrintChannels


Legend

Legend
PrintTrack Class
Legend
Data Member
protected
Method
virtual
abstract


PrintTrack Class Members

PrintTrack Class Members
PrintTrack Class
Members
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_PrintChannelEnabled |
sm_TimerPool |
Constructors
Constructor | Description
IDataMembers |
PrintTrack |
Track |
TrackOrCondition |
Destructors
Destructor | Description
~IDataMembers |
~PrintTrack |
~Track |
Methods
Method | Description
AddWidgets |
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetText |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
NewTask |
NewTask |
Read |
Reset |
ResetTimers |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetText |
SetTimeBegin |
SetTimeEnd |
ShouldPrint |
TimerStart |
TimerStop |
TRACK_MEMBER |
TRACK_PARAMETER |
TRACK_PARAMETER_ENUM |
UpdateFrame |
Write |
Write | lint !e1735
Enumerations
Enumeration | Description
PrintChannels | keep in sync with ConditionPrint::PrintChannels
Structs
Struct | Description
Timer |


PrintTrack Class Methods

PrintTrack Class Methods
PrintTrack Class
Methods
Method | Description
AddWidgets |
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetText |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
NewTask |
NewTask |
Read |
Reset |
ResetTimers |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetText |
SetTimeBegin |
SetTimeEnd |
ShouldPrint |
TimerStart |
TimerStop |
TRACK_MEMBER |
TRACK_PARAMETER |
TRACK_PARAMETER_ENUM |
UpdateFrame |
Write |
Write | lint !e1735


PrintTrack Class Structs

PrintTrack Class Structs
PrintTrack Class
Structs
Struct | Description
Timer |


Inheritance Hierarchy

Inheritance Hierarchy
PrintTrack Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Track
                PrintTrack


SequenceTask Class Constructors

SequenceTask Class Constructors
SequenceTask Class
Constructors
Constructor | Description
ATask |
SequenceTask |


SequenceTask Class Data Members

SequenceTask Class Data Members
SequenceTask Class
Data Members
Data Member | Description
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted


SequenceTask Class Destructors

SequenceTask Class Destructors
SequenceTask Class
Destructors
Destructor | Description
~ATask |
~SequenceTask |


Legend

Legend
SequenceTask Class
Legend
Method
virtual
abstract
Data Member


SequenceTask Class Members

SequenceTask Class Members
SequenceTask Class
Members
Constructors
Constructor | Description
ATask |
SequenceTask |
Destructors
Destructor | Description
~ATask |
~SequenceTask |
Methods
Method | Description
Begin |
End |
End |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
Update |
Data Members
Data Member | Description
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted


SequenceTask Class Methods

SequenceTask Class Methods
SequenceTask Class
Methods
Method | Description
Begin |
End |
End |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
Update |


Inheritance Hierarchy

Inheritance Hierarchy
SequenceTask Class
Inheritance Hierarchy
rage::ATask
    SequenceTask


SequenceTrack Class Constructors

SequenceTrack Class Constructors
SequenceTrack Class
Constructors
Constructor | Description
IDataMembers |
INodeReferenceTrack |
NodeReferenceTrack |
SequenceTrack |
Track |
TrackOrCondition |


SequenceTrack Class Data Members

SequenceTrack Class Data Members
SequenceTrack Class
Data Members
Data Member | Description
m_ActionNodeRef |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |


SequenceTrack Class Destructors

SequenceTrack Class Destructors
SequenceTrack Class
Destructors
Destructor | Description
~IDataMembers |
~NodeReferenceTrack |
~SequenceTrack |
~Track |


Legend

Legend
SequenceTrack Class
Legend
Method
virtual
protected
abstract
Data Member


SequenceTrack Class Members

SequenceTrack Class Members
SequenceTrack Class
Members
Constructors
Constructor | Description
IDataMembers |
INodeReferenceTrack |
NodeReferenceTrack |
SequenceTrack |
Track |
TrackOrCondition |
Destructors
Destructor | Description
~IDataMembers |
~NodeReferenceTrack |
~SequenceTrack |
~Track |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
NewTask |
Read |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent |
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
UpdateFrame |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ActionNodeRef |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |
Structs
Struct | Description
Timer |


SequenceTrack Class Methods

SequenceTrack Class Methods
SequenceTrack Class
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
NewTask |
Read |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent |
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
UpdateFrame |
Write |
Write | lint !e1735


SequenceTrack Class Structs

SequenceTrack Class Structs
SequenceTrack Class
Structs
Struct | Description
Timer |


Inheritance Hierarchy

Inheritance Hierarchy
SequenceTrack Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Track
                rage::INodeReferenceTrack
                    rage::NodeReferenceTrack
                        SequenceTrack


SpawnActionController Class Constructors

SpawnActionController Class Constructors
SpawnActionController Class
Constructors
Constructor | Description
ActionController |


SpawnActionController Class Data Members

SpawnActionController Class Data Members
SpawnActionController Class
Data Members
Data Member | Description
m_SequencedTracks |
s_NoOfTaskUpdates |


SpawnActionController Class Destructors

SpawnActionController Class Destructors
SpawnActionController Class
Destructors
Destructor | Description
~ActionController |
~SpawnActionController |


Legend

Legend
SpawnActionController Class
Legend
protected
Data Member
Method
virtual


SpawnActionController Class Members

SpawnActionController Class Members
SpawnActionController Class
Members
Data Members
Data Member | Description
m_SequencedTracks |
s_NoOfTaskUpdates |
Destructors
Destructor | Description
~ActionController |
~SpawnActionController |
Methods
Method | Description
AddSequncedTrack |
BeginDebugTask |
clearAll |
clearSequencedTracks |
DeleteSequencedTrack |
EndDebugTask |
EndTask |
GetBeginBreakPoint |
GetContext |
GetControlContext |
GetCurrentNodePlayTime |
GetCurrentPlayCount |
GetCurrentPlayingNode |
GetDebug |
GetEndBreakPoint |
GetNumSequencedTracks |
GetPlayHistory |
GetRequestedNode |
GetRunningTaskRoot |
GetSequencedTrack | implement this in the subclasses
GetUpDateBreakPoint |
IsBusy | const ActionNode * GetCurrentSequencedNode(void)const{return(m_SequencedNode); short GetSequencedPriority(void)const{return(m_SequencedPriority);
Play | These deal with ActionNodes so Banks can be sequenced or played The PlayActionNode will search for playable NODE to sequence!
PlayRemote | : used by the mutli-player function to execute remote actions. keeps a signature to prevent multiple plays of same action.
PlayTracks |
RemoveTask |
Sequence |
SetBeginBreakPoint | These are for hooking in BreakPoints on Track/Task instances
SetContext |
SetControlContext | does nothing CONTROL_CONTEXT_ENABLED
SetDebug |
SetEndBreakPoint |
SetRequestedNode |
SetUpDateBreakPoint |
StartSequencedTracks |
Stop |
TRACKMSG |
Update | Normally only update is called
UpdateDebugTask |
UpdateTasks |
UpdateTasksTimeEnd |
UpdateWithKeepAlive |
Constructors
Constructor | Description
ActionController |


SpawnActionController Class Methods

SpawnActionController Class Methods
SpawnActionController Class
Methods
Method | Description
AddSequncedTrack |
BeginDebugTask |
clearAll |
clearSequencedTracks |
DeleteSequencedTrack |
EndDebugTask |
EndTask |
GetBeginBreakPoint |
GetContext |
GetControlContext |
GetCurrentNodePlayTime |
GetCurrentPlayCount |
GetCurrentPlayingNode |
GetDebug |
GetEndBreakPoint |
GetNumSequencedTracks |
GetPlayHistory |
GetRequestedNode |
GetRunningTaskRoot |
GetSequencedTrack | implement this in the subclasses
GetUpDateBreakPoint |
IsBusy | const ActionNode * GetCurrentSequencedNode(void)const{return(m_SequencedNode); short GetSequencedPriority(void)const{return(m_SequencedPriority);
Play | These deal with ActionNodes so Banks can be sequenced or played The PlayActionNode will search for playable NODE to sequence!
PlayRemote | : used by the mutli-player function to execute remote actions. keeps a signature to prevent multiple plays of same action.
PlayTracks |
RemoveTask |
Sequence |
SetBeginBreakPoint | These are for hooking in BreakPoints on Track/Task instances
SetContext |
SetControlContext | does nothing CONTROL_CONTEXT_ENABLED
SetDebug |
SetEndBreakPoint |
SetRequestedNode |
SetUpDateBreakPoint |
StartSequencedTracks |
Stop |
TRACKMSG |
Update | Normally only update is called
UpdateDebugTask |
UpdateTasks |
UpdateTasksTimeEnd |
UpdateWithKeepAlive |


Inheritance Hierarchy

Inheritance Hierarchy
SpawnActionController Class
Inheritance Hierarchy
rage::ActionController
    SpawnActionController


SpawnTask Class Constructors

SpawnTask Class Constructors
SpawnTask Class
Constructors
Constructor | Description
ATask |
SpawnTask | SpawnTask


SpawnTask Class Data Members

SpawnTask Class Data Members
SpawnTask Class
Data Members
Data Member | Description
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted


SpawnTask Class Destructors

SpawnTask Class Destructors
SpawnTask Class
Destructors
Destructor | Description
~ATask |
~SpawnTask |


Legend

Legend
SpawnTask Class
Legend
Method
virtual
abstract
Data Member


SpawnTask Class Members

SpawnTask Class Members
SpawnTask Class
Members
Constructors
Constructor | Description
ATask |
SpawnTask | SpawnTask
Destructors
Destructor | Description
~ATask |
~SpawnTask |
Methods
Method | Description
Begin |
Begin |
End |
End |
GetActionController |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
Update |
Update |
Data Members
Data Member | Description
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted


SpawnTask Class Methods

SpawnTask Class Methods
SpawnTask Class
Methods
Method | Description
Begin |
Begin |
End |
End |
GetActionController |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
Update |
Update |


Inheritance Hierarchy

Inheritance Hierarchy
SpawnTask Class
Inheritance Hierarchy
rage::ATask
    SpawnTask


SpawnTrack Class Constructors

SpawnTrack Class Constructors
SpawnTrack Class
Constructors
Constructor | Description
IDataMembers |
INodeReferenceTrack |
NodeReferenceTrack |
SpawnTrack |
Track |
TrackOrCondition |


SpawnTrack Class Data Members

SpawnTrack Class Data Members
SpawnTrack Class
Data Members
Data Member | Description
m_ActionNodeRef |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |


SpawnTrack Class Destructors

SpawnTrack Class Destructors
SpawnTrack Class
Destructors
Destructor | Description
~IDataMembers |
~NodeReferenceTrack |
~SpawnTrack |
~Track |


Legend

Legend
SpawnTrack Class
Legend
Method
virtual
protected
abstract
Data Member


SpawnTrack Class Members

SpawnTrack Class Members
SpawnTrack Class
Members
Constructors
Constructor | Description
IDataMembers |
INodeReferenceTrack |
NodeReferenceTrack |
SpawnTrack |
Track |
TrackOrCondition |
Destructors
Destructor | Description
~IDataMembers |
~NodeReferenceTrack |
~SpawnTrack |
~Track |
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
NewTask |
Read |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent |
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
TRACK_PARAMETER |
UpdateFrame |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ActionNodeRef |
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |
Structs
Struct | Description
Timer |


SpawnTrack Class Methods

SpawnTrack Class Methods
SpawnTrack Class
Methods
Method | Description
Break |
Create |
DATAMEMEBERS_INTERFACE |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetActionNode |
GetActionNodeReference |
GetActionNodeReferenceFullPath |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 2 = INodeReferenceTrack (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
IsActionNodeReferenceNull |
IsActionNodeResolved |
IsActionNodeResolved |
NewTask |
NewTask |
Read |
Reset |
ResetTimers |
ResolveReference |
ResolveReference |
SetActionNode |
SetActionNodeParent |
SetActionNodeParent |
SetActionNodeReference |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
TRACK_PARAMETER |
UpdateFrame |
Write |
Write | lint !e1735


SpawnTrack Class Structs

SpawnTrack Class Structs
SpawnTrack Class
Structs
Struct | Description
Timer |


Inheritance Hierarchy

Inheritance Hierarchy
SpawnTrack Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            rage::Track
                rage::INodeReferenceTrack
                    rage::NodeReferenceTrack
                        SpawnTrack


StringDataMember Template Constructors

StringDataMember Template Constructors
StringDataMember Template
Constructors
Constructor | Description
DataMember |
IStringDataMember |
StringDataMember |


StringDataMember Template Data Members

StringDataMember Template Data Members
StringDataMember Template
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


StringDataMember Template Destructors

StringDataMember Template Destructors
StringDataMember Template
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
~StringDataMember |


StringDataMember Template Enumerations

StringDataMember Template Enumerations
StringDataMember Template
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
StringDataMember Template
Legend
Method
virtual
abstract
protected
Data Member


StringDataMember Template Members

StringDataMember Template Members
StringDataMember Template
Members
Constructors
Constructor | Description
DataMember |
IStringDataMember |
StringDataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
~StringDataMember |
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetString |
GetString |
GetType |
GetType |
IsDefault |
IsDefault |
Read |
Read |
SetString |
SetString |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |


StringDataMember Template Methods

StringDataMember Template Methods
StringDataMember Template
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetString |
GetString |
GetType |
GetType |
IsDefault |
IsDefault |
Read |
Read |
SetString |
SetString |
Write |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
StringDataMember Template
Inheritance Hierarchy
rage::IName
    rage::DataMember
        rage::IStringDataMember
            StringDataMember


StubTask Class Constructors

StubTask Class Constructors
StubTask Class
Constructors
Constructor | Description
ATask |
StubTask |


StubTask Class Data Members

StubTask Class Data Members
StubTask Class
Data Members
Data Member | Description
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted


StubTask Class Destructors

StubTask Class Destructors
StubTask Class
Destructors
Destructor | Description
~ATask |
~StubTask |


Legend

Legend
StubTask Class
Legend
Method
virtual
abstract
Data Member


StubTask Class Members

StubTask Class Members
StubTask Class
Members
Constructors
Constructor | Description
ATask |
StubTask |
Destructors
Destructor | Description
~ATask |
~StubTask |
Methods
Method | Description
Begin |
Begin |
End |
End |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
Update |
Update |
Data Members
Data Member | Description
m_NextRunningTask | Next in the linked list of running tasks
m_TimeEnd | Cached time end value, can be TIME_END_NOT_INSERTED if this element is not inserted


StubTask Class Methods

StubTask Class Methods
StubTask Class
Methods
Method | Description
Begin |
Begin |
End |
End |
GetActionController |
GetMyContext |
GetTrack |
GetTrack |
Update |
Update |


Inheritance Hierarchy

Inheritance Hierarchy
StubTask Class
Inheritance Hierarchy
rage::ATask
    StubTask


TaskSizeCompileTimeAssert Template Constructors

TaskSizeCompileTimeAssert Template Constructors
TaskSizeCompileTimeAssert Template
Constructors
Constructor | Description
TaskSizeCompileTimeAssert |


Legend

Legend
TaskSizeCompileTimeAssert Template
Legend
Method


TaskSizeCompileTimeAssert Template Members

TaskSizeCompileTimeAssert Template Members
TaskSizeCompileTimeAssert Template
Members
Constructors
Constructor | Description
TaskSizeCompileTimeAssert |


Inheritance Hierarchy

Inheritance Hierarchy
TaskSizeCompileTimeAssert Template
Inheritance Hierarchy
TaskSizeCompileTimeAssert


Legend

Legend
TaskSizeCompileTimeAssert<SpawnTask> Template
Legend
Method


TaskSizeCompileTimeAssert<SpawnTask> Template Members

TaskSizeCompileTimeAssert<SpawnTask> Template Members
TaskSizeCompileTimeAssert<SpawnTask> Template
Members
Methods
Method | Description
TaskSizeCompileTimeAssert |


TaskSizeCompileTimeAssert<SpawnTask> Template Methods

TaskSizeCompileTimeAssert<SpawnTask> Template Methods
TaskSizeCompileTimeAssert<SpawnTask> Template
Methods
Method | Description
TaskSizeCompileTimeAssert |


Inheritance Hierarchy

Inheritance Hierarchy
TaskSizeCompileTimeAssert<SpawnTask> Template
Inheritance Hierarchy
TaskSizeCompileTimeAssert<SpawnTask>


TextBuffer Class Constructors

TextBuffer Class Constructors
TextBuffer Class
Constructors
Constructor | Description
TextBuffer |


TextBuffer Class Destructors

TextBuffer Class Destructors
TextBuffer Class
Destructors
Destructor | Description
~TextBuffer |


Legend

Legend
TextBuffer Class
Legend
Method


TextBuffer Class Members

TextBuffer Class Members
TextBuffer Class
Members
Constructors
Constructor | Description
TextBuffer |
Destructors
Destructor | Description
~TextBuffer |
Methods
Method | Description
AddNewLine |
DecreaseIndent |
GetBuffer |
GetWrittenLength |
IncreaseIndent |
Reset |
Write |


TextBuffer Class Methods

TextBuffer Class Methods
TextBuffer Class
Methods
Method | Description
AddNewLine |
DecreaseIndent |
GetBuffer |
GetWrittenLength |
IncreaseIndent |
Reset |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
TextBuffer Class
Inheritance Hierarchy
TextBuffer


TextParser Class Constructors

TextParser Class Constructors
TextParser Class
Constructors
Constructor | Description
TextParser | Create a text parser that can be used to move over a string as a stream of tokens. The seperators string is NOT copied, and is usually expected to be a string constant ala "\/ "


TextParser Class Destructors

TextParser Class Destructors
TextParser Class
Destructors
Destructor | Description
~TextParser |


Legend

Legend
TextParser Class
Legend
Method


TextParser Class Members

TextParser Class Members
TextParser Class
Members
Constructors
Constructor | Description
TextParser | Create a text parser that can be used to move over a string as a stream of tokens. The seperators string is NOT copied, and is usually expected to be a string constant ala "\/ "
Destructors
Destructor | Description
~TextParser |
Methods
Method | Description
AddvanceToToken |
advanceToQuote |
EndOfText |
GetCurrentReadPosition |
GetNextToken |
GetQuotedString | Parse a quoted string into the given buffer; return true on success, false if the buffer was too small.
GetTokenAsFloat |
GetTokenAsInt |
GetTokenString | Return the next token in the given buffer; return true on success, false if the buffer was too small.
IsParsingFile |
MatchCurrentToken |
MatchCurrentTokenCaseInsensitive |
NeedToSpecialParseQuotedString |
PopReadPosition |
PushReadPosition |
SetCurrentReadPosition |


TextParser Class Methods

TextParser Class Methods
TextParser Class
Methods
Method | Description
AddvanceToToken |
advanceToQuote |
EndOfText |
GetCurrentReadPosition |
GetNextToken |
GetQuotedString | Parse a quoted string into the given buffer; return true on success, false if the buffer was too small.
GetTokenAsFloat |
GetTokenAsInt |
GetTokenString | Return the next token in the given buffer; return true on success, false if the buffer was too small.
IsParsingFile |
MatchCurrentToken |
MatchCurrentTokenCaseInsensitive |
NeedToSpecialParseQuotedString |
PopReadPosition |
PushReadPosition |
SetCurrentReadPosition |


Inheritance Hierarchy

Inheritance Hierarchy
TextParser Class
Inheritance Hierarchy
TextParser


Track Class Constructors

Track Class Constructors
Track Class
Constructors
Constructor | Description
IDataMembers |
Track |
TrackOrCondition |


Track Class Data Members

Track Class Data Members
Track Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |


Track Class Destructors

Track Class Destructors
Track Class
Destructors
Destructor | Description
~IDataMembers |
~Track |


Legend

Legend
Track Class
Legend
Data Member
protected
Method
virtual
abstract


Track Class Members

Track Class Members
Track Class
Members
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
m_FrameCount |
m_Master |
m_Pad |
m_TimeBegin |
m_TimeEnd |
m_TimerId |
RORC_VERSION | Don't forget to bump this whenever a RAGE track is added or modified
sm_TimerPool |
Structs
Struct | Description
Timer |
Constructors
Constructor | Description
IDataMembers |
Track |
TrackOrCondition |
Destructors
Destructor | Description
~IDataMembers |
~Track |
Methods
Method | Description
Break |
Create |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
NewTask |
Read |
Reset |
ResetTimers |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
UpdateFrame |
Write |
Write | lint !e1735


Track Class Methods

Track Class Methods
Track Class
Methods
Method | Description
Break |
Create |
DECLARE_PLACE |
DeclareStruct |
DeclareStruct |
DeclareStruct |
DeInit |
GetAverageTime |
GetConditionGroup |
GetDebugBreakPoint |
GetDuration |
GetEnableBreakPoints |
GetFrameCount |
GetMaster | Timing for playback
GetMember |
GetName |
GetNumMembers |
GetNumRegistered |
GetNumTracks |
GetPFTimer |
GetRegistered |
GetRegisteredTrackType |
GetTimeBegin |
GetTimeEnd |
GetTimer |
GetTotalTime |
GetTrackRegistry | Used for games to register their own tracks
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTrackTypeStatic |
GetTypeId |
Init |
NewTask |
Read |
Reset |
ResetTimers |
SetDebugBreakPoint |
SetEnableBreakPoints |
SetMaster |
SetTimeBegin |
SetTimeEnd |
TimerStart |
TimerStop |
UpdateFrame |
Write |
Write | lint !e1735


Track Class Structs

Track Class Structs
Track Class
Structs
Struct | Description
Timer |


Inheritance Hierarchy

Inheritance Hierarchy
Track Class
Inheritance Hierarchy
rage::IDataMembers
        rage::TrackOrCondition
            Track
                rage::INodeReferenceTrack
                rage::PrintTrack


Track::Timer Struct Data Members

Track::Timer Struct Data Members
Track::Timer Struct
Data Members
Data Member | Description
m_Count |
m_StartTime |
m_Time |


Legend

Legend
Track::Timer Struct
Legend
Data Member
Method


Track::Timer Struct Members

Track::Timer Struct Members
Track::Timer Struct
Members
Data Members
Data Member | Description
m_Count |
m_StartTime |
m_Time |
Methods
Method | Description
GetAverage |
GetTime |
GetTotal |
Reset |
Start |
Stop |


Track::Timer Struct Methods

Track::Timer Struct Methods
Track::Timer Struct
Methods
Method | Description
GetAverage |
GetTime |
GetTotal |
Reset |
Start |
Stop |


Inheritance Hierarchy

Inheritance Hierarchy
Track::Timer Struct
Inheritance Hierarchy
Track::Timer


TrackFactory Template Constructors

TrackFactory Template Constructors
TrackFactory Template
Constructors
Constructor | Description
ITrackFactory |
TrackFactory |


TrackFactory Template Destructors

TrackFactory Template Destructors
TrackFactory Template
Destructors
Destructor | Description
~IName |
~ITrackFactory |
~TrackFactory |


Legend

Legend
TrackFactory Template
Legend
Method
virtual
abstract


TrackFactory Template Members

TrackFactory Template Members
TrackFactory Template
Members
Constructors
Constructor | Description
ITrackFactory |
TrackFactory |
Destructors
Destructor | Description
~IName |
~ITrackFactory |
~TrackFactory |
Methods
Method | Description
GetName |
GetName |
GetRorcChecksum |
GetRorcChecksum |
GetTrackType |
GetTrackType |
NewTrack |
NewTrack |
Place |
Place |
SetTypeId | RAW_ACT_FILE_SUPPORT
SetTypeId | RAW_ACT_FILE_SUPPORT


TrackFactory Template Methods

TrackFactory Template Methods
TrackFactory Template
Methods
Method | Description
GetName |
GetName |
GetRorcChecksum |
GetRorcChecksum |
GetTrackType |
GetTrackType |
NewTrack |
NewTrack |
Place |
Place |
SetTypeId | RAW_ACT_FILE_SUPPORT
SetTypeId | RAW_ACT_FILE_SUPPORT


Inheritance Hierarchy

Inheritance Hierarchy
TrackFactory Template
Inheritance Hierarchy
rage::IName
    rage::ITrackFactory
        TrackFactory


TrackOrCondition Class Constructors

TrackOrCondition Class Constructors
TrackOrCondition Class
Constructors
Constructor | Description
IDataMembers |
TrackOrCondition |


TrackOrCondition Class Data Members

TrackOrCondition Class Data Members
TrackOrCondition Class
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky


TrackOrCondition Class Destructors

TrackOrCondition Class Destructors
TrackOrCondition Class
Destructors
Destructor | Description
~IDataMembers |


Legend

Legend
TrackOrCondition Class
Legend
Method
protected
virtual
abstract
Data Member


TrackOrCondition Class Members

TrackOrCondition Class Members
TrackOrCondition Class
Members
Constructors
Constructor | Description
IDataMembers |
TrackOrCondition |
Methods
Method | Description
Break |
DeclareStruct |
DeclareStruct |
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetMember |
GetName |
GetNumMembers |
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
Write |
Write | lint !e1735
Data Members
Data Member | Description
m_ChangedMember | This is the last DataMember that changed... should be ONLY used on update... sortof hacky
Destructors
Destructor | Description
~IDataMembers |


Members

Legend
Method
protected
virtual
abstract
Data Member


TrackOrCondition Class Methods

TrackOrCondition Class Methods
TrackOrCondition Class
Methods
Method | Description
Break |
DeclareStruct |
DeclareStruct |
GetConditionGroup |
GetDebugBreakPoint |
GetEnableBreakPoints |
GetMember |
GetName |
GetNumMembers |
GetTrackType | 1 = Track (to eliminate the need for dynamic_cast
GetTrackTypeStatic |
GetTypeId |
Read |
Reset |
SetDebugBreakPoint |
SetEnableBreakPoints |
Write |
Write | lint !e1735


Methods

Legend
Method
protected
virtual
abstract


Inheritance Hierarchy

Inheritance Hierarchy
TrackOrCondition Class
Inheritance Hierarchy
rage::IDataMembers
        TrackOrCondition
            rage::Condition
            rage::Track


TrackRegistry Class Constructors

TrackRegistry Class Constructors
TrackRegistry Class
Constructors
Constructor | Description
TrackRegistry |


TrackRegistry Class Destructors

TrackRegistry Class Destructors
TrackRegistry Class
Destructors
Destructor | Description
~TrackRegistry |


Legend

Legend
TrackRegistry Class
Legend
Method
virtual


TrackRegistry Class Members

TrackRegistry Class Members
TrackRegistry Class
Members
Constructors
Constructor | Description
TrackRegistry |
Destructors
Destructor | Description
~TrackRegistry |
Methods
Method | Description
Create |
DegisterTrackFactorys |
DeInit |
GetDictionary |
GetNumRegisteredTracks |
GetRegisteredTrackName |
GetRegisteredTrackType |
GetRorcChecksum |
Init |
Place |
RegisterTrackFactory |
ResetDictionary |
Sort |


TrackRegistry Class Methods

TrackRegistry Class Methods
TrackRegistry Class
Methods
Method | Description
Create |
DegisterTrackFactorys |
DeInit |
GetDictionary |
GetNumRegisteredTracks |
GetRegisteredTrackName |
GetRegisteredTrackType |
GetRorcChecksum |
Init |
Place |
RegisterTrackFactory |
ResetDictionary |
Sort |


Inheritance Hierarchy

Inheritance Hierarchy
TrackRegistry Class
Inheritance Hierarchy
TrackRegistry


Vector2DataMember Template Constructors

Vector2DataMember Template Constructors
Vector2DataMember Template
Constructors
Constructor | Description
DataMember |
IVector2DataMember |
Vector2DataMember |


Vector2DataMember Template Data Members

Vector2DataMember Template Data Members
Vector2DataMember Template
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


Vector2DataMember Template Destructors

Vector2DataMember Template Destructors
Vector2DataMember Template
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
~Vector2DataMember |


Vector2DataMember Template Enumerations

Vector2DataMember Template Enumerations
Vector2DataMember Template
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
Vector2DataMember Template
Legend
Method
virtual
abstract
protected
Data Member


Vector2DataMember Template Members

Vector2DataMember Template Members
Vector2DataMember Template
Members
Constructors
Constructor | Description
DataMember |
IVector2DataMember |
Vector2DataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
~Vector2DataMember |
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
GetVector2 |
GetVector2 |
IsDefault |
IsDefault |
Read |
Read |
SetVector2 |
SetVector2 |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |


Vector2DataMember Template Methods

Vector2DataMember Template Methods
Vector2DataMember Template
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
GetVector2 |
GetVector2 |
IsDefault |
IsDefault |
Read |
Read |
SetVector2 |
SetVector2 |
Write |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
Vector2DataMember Template
Inheritance Hierarchy
rage::IName
    rage::DataMember
        rage::IVector2DataMember
            Vector2DataMember


Vector3DataMember Template Constructors

Vector3DataMember Template Constructors
Vector3DataMember Template
Constructors
Constructor | Description
DataMember |
IVector3DataMember |
Vector3DataMember |


Vector3DataMember Template Data Members

Vector3DataMember Template Data Members
Vector3DataMember Template
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT


Vector3DataMember Template Destructors

Vector3DataMember Template Destructors
Vector3DataMember Template
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
~Vector3DataMember |


Vector3DataMember Template Enumerations

Vector3DataMember Template Enumerations
Vector3DataMember Template
Enumerations
Enumeration | Description
TYPE |


Legend

Legend
Vector3DataMember Template
Legend
Method
virtual
abstract
protected
Data Member


Vector3DataMember Template Members

Vector3DataMember Template Members
Vector3DataMember Template
Members
Constructors
Constructor | Description
DataMember |
IVector3DataMember |
Vector3DataMember |
Destructors
Destructor | Description
~DataMember | RAW_ACT_FILE_SUPPORT
~IName |
~Vector3DataMember |
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
GetVector3 |
GetVector3 |
IsDefault |
IsDefault |
Read |
Read |
SetVector3 |
SetVector3 |
Write |
Write |
Data Members
Data Member | Description
m_Name |
m_WriteBuff | RAW_ACT_FILE_SUPPORT
Enumerations
Enumeration | Description
TYPE |


Vector3DataMember Template Methods

Vector3DataMember Template Methods
Vector3DataMember Template
Methods
Method | Description
GetName |
GetName |
GetPfGroupActTracks |
GetType |
GetType |
GetVector3 |
GetVector3 |
IsDefault |
IsDefault |
Read |
Read |
SetVector3 |
SetVector3 |
Write |
Write |


Inheritance Hierarchy

Inheritance Hierarchy
Vector3DataMember Template
Inheritance Hierarchy
rage::IName
    rage::DataMember
        rage::IVector3DataMember
            Vector3DataMember


Contents

Contents
Overview
Components
Relationships
Command Line Options
Working Examples
Symbol Reference
rage Namespace
actDebug Namespace
CanOutputDebug Function ()
CanOutputDebug Function (const ActionContext&)
CanOutputDebug Function (const ActionContext*)
ExtractPathAndNodeName Function
GetActDebugLevel Function
OutputFullNameEumeration Function
SetConditionFilter Function
condEKG Namespace
EXT_PF_GROUP Function
PF_GROUP Function
PF_LINK Function
PF_PAGE Function (actEKGPage, "action tree")
PF_PAGE Function (actEKGPage2, "action tree (detail)")
PF_TIMER Function (condition, actEKGGroup)
PF_TIMER Function (task_begin, actEKGGroup)
PF_TIMER Function (task_end, actEKGGroup)
PF_TIMER Function (task_update, actEKGGroup)
PFPAGELINK_ACTTRACKS Function
ActionCallbackContext Class
Constructors
ActionCallbackContext Constructor
Destructors
~ActionCallbackContext Destructor
Methods
Bind Method
GetController Method
OnEndTask Method
OnNodeCleanup Method
OnPlay Method
OnPlayTracks Method
OnSequence Method
OnStop Method
Update Method
ActionContext Class
Data Members
m_ActionController Data Member
m_Actor Data Member
m_CurrentAction Data Member
m_CurrentMatchingNode Data Member
m_Debug Data Member
m_DebugContextClBk Data Member
m_Depth Data Member
m_Entity Data Member
m_OpeningBranch Data Member
Constructors
ActionContext Constructor
Destructors
~ActionContext Destructor
Methods
Clone Method
GetActorName Method
NullOp Method
OnACTError Method
OnStopPostTaskEnd Method
PreUpdate Method
ResetDebug Method
VerifyNewNode Method
Nested Types
DebugActionContextCB Nested Type
ActionContextDebugDepth Struct
Data Members
m_Ctx Data Member
m_Op Data Member
m_PrevNode Data Member
Constructors
ActionContextDebugDepth Constructor
Destructors
~ActionContextDebugDepth Destructor
ActionController Class
Data Members
s_NoOfTaskUpdates Data Member
Constructors
ActionController Constructor
Destructors
~ActionController Destructor
Methods
BeginDebugTask Method
clearAll Method
EndDebugTask Method
EndTask Method
GetBeginBreakPoint Method
GetContext Method
GetControlContext Method
GetCurrentNodePlayTime Method
GetCurrentPlayCount Method
GetCurrentPlayingNode
GetCurrentPlayingNode Method (void)
GetCurrentPlayingNode Method (void)
GetDebug Method
GetEndBreakPoint Method
GetPlayHistory Method
GetRequestedNode Method
GetRunningTaskRoot Method
GetUpDateBreakPoint Method
IsBusy Method
Play Method
PlayRemote Method
PlayTracks Method
RemoveTask
RemoveTask Method (ATask *, ATask *)
RemoveTask Method (ATask *, ATask *, ATask *)
Sequence Method
SetBeginBreakPoint Method
SetContext Method
SetControlContext Method
SetDebug Method
SetEndBreakPoint Method
SetRequestedNode Method
SetUpDateBreakPoint Method
StartSequencedTracks Method
Stop Method
TRACKMSG
TRACKMSG Method (char *, ATask *)
TRACKMSG Method (char *, ActionNode *)
TRACKMSG Method (char *, Track *)
TRACKMSG Method (char *, char *, void *)
Update Method
UpdateDebugTask Method
UpdateTasks Method
UpdateTasksTimeEnd Method
UpdateWithKeepAlive Method
ActionIntention Class
Constructors
ActionIntention Constructor
Destructors
~ActionIntention Destructor
Methods
Clear Method
Update Method
ActionNode Class
Data Members
m_bUpdatedOnce Data Member
m_bViewExpanded Data Member
m_childNodes Data Member
m_FileRoot Data Member
m_GlobalEditPriority Data Member
m_OnLoad Data Member
m_OnUnload Data Member
m_Pad Data Member
m_parent Data Member
m_PathCRC Data Member
m_Root Data Member
m_Type Data Member
RORC_VERSION Data Member
sm_ActFullPath Data Member
sm_ActPath Data Member
sm_OnTreeUnloadCallback Data Member
sm_PostLoadCallback Data Member
sm_RscFirstPass Data Member
Structs
ActionTreeTaskParams Struct
Constructors
ActionNode Constructor
Destructors
~ActionNode Destructor
Methods
AddBranch Method
AddChildActionNode Method
AddChildActionNodes Method
AddCondition
AddCondition Method (TextParser&)
AddCondition Method (const char*)
AddRoot Method
AddStuff Method
AddTrack
AddTrack Method (TextParser&)
AddTrack Method (Track*)
AddTrack Method (const char*)
AddTracksBank Method
BalanceWeights Method
ChangeChildPriority Method
ChangeConditionPriority Method
ChangePriority Method
ChangeTrackPriority Method
ClearChildNodes Method
ClearRoots Method
Create Method
CreateIArchive Method
DATAMEMEBERS_INTERFACE_NO_NAME Method
DeInit Method
DeleteChildActionNodes Method
DeleteCondition
DeleteCondition Method (Condition*)
DeleteCondition Method (int)
DeleteTrack
DeleteTrack Method (Track*)
DeleteTrack Method (int)
DumpTiming Method
DumpTimingRecursive Method
EvalRemote Method
EvalRemoteTransition Method
Find
Find Method (const CFastNamePath&, ActionNode*)
Find Method (const CNamePath*, ActionNode*)
Find Method (const char*, ActionNode*)
Find Method (const int*, int, ActionNode*)
FindChildNode
FindChildNode Method (const char*)
FindChildNode Method (int)
FindFirstPlayable Method
FindRoot Method
GetChild Method
GetChildCount Method
GetCNamePath Method
GetCondition Method
GetConditionCount Method
GetConditionGroup Method
GetCondtionFormat Method
GetFileRoot
GetFileRoot Method ()
GetFileRoot Method (void)
GetName
GetName Method (void)
GetName Method (void)
GetNameFullPath
GetNameFullPath Method (char*, int)
GetNameFullPath Method (char*, int)
GetNameFullPathDebug Method
GetParent Method
GetPathCRC Method
GetPriority Method
GetRefCount Method
GetRoot Method
GetTrack Method
GetTrackCount Method
GetTrackFormat Method
GetType Method
IncRefCount Method
Init Method
IsDescendantOf
IsDescendantOf Method (const ActionNode *)
IsDescendantOf Method (const CName&)
IsDescendantOf Method (const char*)
Load Method
Match Method
OnTreeUnload Method
OperateAllNodes Method
OperateChildOnNodes Method
PrintAllNodes Method
ReadConditionGroup Method
RecursSetFileRoots Method
RemoveChildActionNode Method
ReserveTracks Method
ResetTiming Method
ResetTimingRecursive Method
ResolveAllTrackReferences Method
ResolveAllWeights Method
ResolveTrackReferences Method
ResolveWeights Method
SetOnLoad Method
SetOnUnload Method
SetParent Method
TaskLoadActionNode Method
TokenName Method
TRACK_PARAMETER_STRING Method
UnLoad
UnLoad Method (ActionNodeTreeHandle*)
UnLoad Method (const char*)
UnLoadAll Method
Write
Write Method (TextBuffer&)
Write Method (TextBuffer&, const char*)
writeBegin Method
writeChildren Method
writeComment Method
WriteCondition Method
writeConditions Method
writeEnd Method
writeTracks Method
Friends
class ActionNodeReference Friend
class ActionNodeTree Friend
ActionNodeBank Class
Constructors
ActionNodeBank
ActionNodeBank Constructor (const char*, int)
ActionNodeBank Constructor (int)
Destructors
~ActionNodeBank Destructor
Methods
DATAMEMEBERS_INTERFACE_NO_NAME Method
Match Method
ResolveWeights Method
TokenName Method
ActionNodeDebugName Struct
Data Members
m_Name Data Member
Constructors
ActionNodeDebugName Constructor
Operators
() Operator
ActionNodeFileReference Class
Constructors
ActionNodeFileReference
ActionNodeFileReference Constructor (ActionNodeFileReference&)
ActionNodeFileReference Constructor (const char*, int)
ActionNodeFileReference Constructor (int)
Destructors
~ActionNodeFileReference Destructor
Methods
DATAMEMEBERS_INTERFACE_NO_NAME Method
GetArchiveFileRecord Method
GetFileName Method
GetFullPathName Method
GetPathName Method
Read Method
ReadFile Method
RecursSetFileRoots Method
SetFileName Method
SetFullPathName Method
SetPathName Method
TokenName Method
Write
Write Method (TextBuffer&)
Write Method (TextBuffer&, const char*)
ActionNodeImplementation Class
Data Members
m_Conditions Data Member
m_Name Data Member
m_tracks Data Member
Constructors
ActionNodeImplementation
ActionNodeImplementation Constructor (const char*, int)
ActionNodeImplementation Constructor (int)
Destructors
~ActionNodeImplementation Destructor
Methods
AddCondition
AddCondition Method (TextParser&)
AddCondition Method (const char*)
AddTrack
AddTrack Method (TextParser&)
AddTrack Method (Track*)
AddTrack Method (const char*)
ChangeConditionPriority Method
ChangeTrackPriority Method
DATAMEMEBERS_INTERFACE_NO_NAME Method
DeleteCondition
DeleteCondition Method (Condition *)
DeleteCondition Method (int)
DeleteTrack
DeleteTrack Method (Track *)
DeleteTrack Method (int)
GetCondition Method
GetConditionCount Method
GetConditionGroup Method
GetCondtionFormat Method
GetName
GetName Method (void)
GetName Method (void)
GetTrack Method
GetTrackCount Method
GetTrackFormat Method
ReadConditionGroup Method
ReserveTracks Method
WriteCondition Method
ActionNodeLwRef Class
Constructors
ActionNodeLwRef
ActionNodeLwRef Constructor ()
ActionNodeLwRef Constructor (datResource&)
Destructors
~ActionNodeLwRef Destructor
Methods
DeclareStruct Method
GetActionNode Method
IMPLEMENT_PLACE_INLINE Method
IsNull Method
SetActionNode Method
SetParent Method
SetReferenceName Method
ActionNodePlayable Class
Constructors
ActionNodePlayable
ActionNodePlayable Constructor (const char*, int)
ActionNodePlayable Constructor (datResource&)
ActionNodePlayable Constructor (int)
Destructors
~ActionNodePlayable Destructor
Methods
AddStuff Method
AddTrack Method
DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE Method
DECLARE_PLACE Method
DeclareStruct Method
GetEditPriority Method
Match Method
SetEditPriority Method
TokenName Method
Update Method
UpdateDetach Method
Write
Write Method (TextBuffer&)
Write Method (TextBuffer&, const char*)
ActionNodeReference Class
Data Members
m_nameFullPath Data Member
m_referenceName Data Member
m_referenceNode Data Member
Constructors
ActionNodeReference
ActionNodeReference Constructor (const char*, int)
ActionNodeReference Constructor (int)
Destructors
~ActionNodeReference Destructor
Methods
AddCondition
AddCondition Method (TextParser&)
AddCondition Method (const char*)
AddTrack
AddTrack Method (TextParser&)
AddTrack Method (Track*)
AddTrack Method (const char*)
DATAMEMEBERS_INTERFACE_NO_NAME Method
DeleteCondition
DeleteCondition Method (Condition*)
DeleteCondition Method (int)
GetActionNode Method
GetChild Method
GetChildCount Method
GetCondition Method
GetConditionCount Method
GetConditionGroup Method
GetCondtionFormat Method
GetName
GetName Method (void)
GetName Method (void)
GetReferenceFullPath Method
GetReferenceName Method
GetTrack Method
GetTrackCount Method
GetTrackFormat Method
IsNull Method
Match Method
ReadConditionGroup Method
ReserveTracks Method
ResolveReference Method
SetActionNode Method
SetReferenceName Method
WriteCondition Method
ActionNodeTree Class
Constructors
ActionNodeTree
ActionNodeTree Constructor (ActionNode*)
ActionNodeTree Constructor (datResource&)
Destructors
~ActionNodeTree Destructor
Methods
DECLARE_PLACE Method
DECLARE_THREADED_PLACE Method
DeclareStruct Method
GetRoot Method
GetRorcVersion Method
ResolveReferences Method
SetRoot Method
Friends
class ActionNodeTreeHandle Friend
class pgStreamable<ActionNodeTree> Friend
ActionNodeTreeHandle Class
Data Members
sm_LoadFromResources Data Member
Methods
AddRef Method
Cleanup Method
DecRefCount Method
ForceLoad Method
Get Method
GetName Method
GetObject Method
GetRefCount Method
GetRoot Method
GetStreamable Method
IncRefCount Method
IsDeleted Method
IsResident Method
IsStreamingOrResident Method
IsValid Method
Kill Method
PagedIn Method
SetStreamingPriority Method
Friends
class ActionNode Friend
class ActionNodeTree Friend
class atPtr<ActionNodeTreeHandle> Friend
Nested Types
SetMap Nested Type
ActionNodeUnresolvedRef Class
Constructors
ActionNodeUnresolvedRef
ActionNodeUnresolvedRef Constructor ()
ActionNodeUnresolvedRef Constructor (datResource&)
Methods
DECLARE_PLACE Method
DeclareStruct Method
Friends
class ActionNodeLwRef Friend
class ActionNodeTree Friend
ActionTreeLog Class
Methods
GetInstance Method
GetMessage Method
Log Method
Warn Method
actTreeDebugOut Class
Constructors
actTreeDebugOut
actTreeDebugOut Constructor ()
actTreeDebugOut Constructor (const int, DebugOutputFunctor)
Methods
GetRef Method
Out Method
ArchiveFileRecord Class
Constructors
ArchiveFileRecord
ArchiveFileRecord Constructor ()
ArchiveFileRecord Constructor (const char*, const char*)
ArchiveFileRecord Constructor (rage::datResource&)
Destructors
~ArchiveFileRecord Destructor
Methods
GetArchiveObject Method
GetFileName Method
GetFullPathName Method
GetPathName Method
Init Method
IsFileChangedOnDisk Method
IsFileWriteAble Method
ReadFromFile Method
SetArchiveObject Method
SetFactoryIArchive Method
SetFileName Method
SetFullPathName Method
SetPathName Method
WriteToFile Method
ATask Class
Data Members
m_NextRunningTask Data Member
m_TimeEnd Data Member
Constructors
ATask Constructor
Destructors
~ATask Destructor
Methods
Begin Method
End Method
GetActionController
GetActionController Method ()
GetActionController Method ()
GetMyContext Method
GetTrack Method
Update Method
BoolDataMember Template
Constructors
BoolDataMember Constructor
Destructors
~BoolDataMember Destructor
Methods
GetBool Method
IsDefault Method
Set_GetFunction Method
SetBool Method
CBasicString Class
Constructors
CBasicString
CBasicString Constructor ()
CBasicString Constructor (const CBasicString&)
CBasicString Constructor (const char*)
CBasicString Constructor (rage::datResource&)
Destructors
~CBasicString Destructor
Methods
DECLARE_PLACE Method
DeclareStruct Method
GetString Method
SetString Method
Operators
= Operator
==
== Operator (const CBasicString&)
== Operator (const CName&)
== Operator (const char*)
CFastNamePath Class
Constructors
CFastNamePath
CFastNamePath Constructor ()
CFastNamePath Constructor (const char*)
Methods
GetNameHash
GetNameHash Method ()
GetNameHash Method (int)
GetNumElements Method
SetPath Method
CName Class
Constructors
CName
CName Constructor ()
CName Constructor (const CName&)
CName Constructor (const char*)
CName Constructor (const int)
CName Constructor (datResource&)
Destructors
~CName Destructor
Methods
DECLARE_PLACE Method
DeclareStruct Method
GetID Method
GetString Method
Hash Method
SetID Method
SetString Method
Operators
= Operator
==
== Operator (const CName&)
== Operator (const char*)
== Operator (const int)
CNamePath Class
Data Members
s_CNameTraverseDown Data Member
s_CNameTraverseUp Data Member
Constructors
CNamePath
CNamePath Constructor ()
CNamePath Constructor (const char*)
CNamePath Constructor (rage::datResource&)
Methods
CatName
CatName Method (const CName&)
CatName Method (const CName*)
CatNameID Method
DECLARE_PLACE Method
DeclareStruct Method
DeInitStatic Method
GetFullPathDebug Method
GetName
GetName Method (int)
GetName Method (int)
GetNumElements Method
InitStatic Method
SetPath Method
CommandDataMember Template
Constructors
CommandDataMember Constructor
Destructors
~CommandDataMember Destructor
Methods
Execute Method
GetString Method
SetString Method
Condition Class
Data Members
RORC_VERSION Data Member
Constructors
Condition
Condition Constructor ()
Condition Constructor (datResource&)
Destructors
~Condition Destructor
Methods
Create
Create Method (TextParser&)
Create Method (const char*)
DECLARE_PLACE Method
DeclareStruct Method
DeInit Method
EvalRemote Method
GetLogical Method
GetNumConditions Method
GetNumRegistered Method
GetPFTimer Method
GetRegistered Method
GetTrackRegistry Method
Init Method
IsRemoteCondition Method
Match Method
NewTask Method
Enumerations
Logical Enumeration
ConditionActionNodePlayTime Class
Constructors
ConditionActionNodePlayTime Constructor
Destructors
~ConditionActionNodePlayTime Destructor
Methods
DATAMEMEBERS_INTERFACE Method
Match Method
TRACK_PARAMETER Method
Conditional Class
Data Members
m_ConditionalStringName Data Member
m_ConditionalStringNameSize Data Member
Methods
CompareFloat Method
CompareInt Method
Enumerations
Operators Enumeration
ConditionFalse Class
Constructors
ConditionFalse Constructor
Destructors
~ConditionFalse Destructor
Methods
DATAMEMEBERS_INTERFACE Method
Match Method
ConditionGroup Class
Constructors
ConditionGroup
ConditionGroup Constructor ()
ConditionGroup Constructor (datResource &)
Destructors
~ConditionGroup Destructor
Methods
AddCondition Method
AddConditions Method
ChangeConditionPriority Method
DECLARE_PLACE Method
DeclareStruct Method
DeleteCondition Method
EvalRemote Method
GetCondition Method
GetConditionCount Method
Match Method
Read Method
Write Method
ConditionGroupCondition Class
Constructors
ConditionGroupCondition Constructor
Destructors
~ConditionGroupCondition Destructor
Methods
AddCondition
AddCondition Method (TextParser&)
AddCondition Method (const char*)
ChangeConditionPriority Method
DATAMEMEBERS_INTERFACE Method
DeleteCondition Method
GetCondition Method
GetConditionCount Method
GetConditionFormat Method
GetConditionGroup Method
Match Method
Read Method
ReadConditionGroup Method
SetConditionGroup Method
TRACK_MEMBER Method
TRACK_PADDING Method
WriteCondition Method
ConditionGroupConditionAnd Class
Constructors
ConditionGroupConditionAnd Constructor
Destructors
~ConditionGroupConditionAnd Destructor
Methods
DATAMEMEBERS_INTERFACE Method
Match Method
ConditionGroupConditionNot Class
Constructors
ConditionGroupConditionNot Constructor
Destructors
~ConditionGroupConditionNot Destructor
Methods
DATAMEMEBERS_INTERFACE Method
Match Method
ConditionGroupConditionOnly Class
Constructors
ConditionGroupConditionOnly Constructor
Destructors
~ConditionGroupConditionOnly Destructor
Methods
DATAMEMEBERS_INTERFACE Method
Match Method
ConditionGroupConditionOr Class
Constructors
ConditionGroupConditionOr Constructor
Destructors
~ConditionGroupConditionOr Destructor
Methods
DATAMEMEBERS_INTERFACE Method
Match Method
ConditionNOT Class
Constructors
ConditionNOT Constructor
Destructors
~ConditionNOT Destructor
Methods
DATAMEMEBERS_INTERFACE Method
GetLogical Method
Match Method
ConditionOR Class
Constructors
ConditionOR Constructor
Destructors
~ConditionOR Destructor
Methods
DATAMEMEBERS_INTERFACE Method
GetLogical Method
Match Method
ConditionPrint Class
Constructors
ConditionPrint Constructor
Destructors
~ConditionPrint Destructor
Methods
DATAMEMEBERS_INTERFACE Method
GetText Method
Match Method
SetText Method
TRACK_MEMBER Method
TRACK_PARAMETER_ENUM Method
Enumerations
PrintChannels Enumeration
ConditionRandom Class
Data Members
sm_RandomNum Data Member
sm_RandomUsed Data Member
Constructors
ConditionRandom Constructor
Methods
DATAMEMEBERS_INTERFACE Method
Match Method
SetRandFunc Method
TRACK_PARAMETER Method
TRACK_PARAMETER_ENUM Method
Enumerations
RandomModes Enumeration
Nested Types
ConditionRandFunc Nested Type
ConditionTrue Class
Constructors
ConditionTrue Constructor
Destructors
~ConditionTrue Destructor
Methods
DATAMEMEBERS_INTERFACE Method
Match Method
CSubject Class
Data Members
m_Observers Data Member
Constructors
CSubject Constructor
Destructors
~CSubject Destructor
Methods
Attach Method
Dettach Method
Notify Method
DataMember Class
Data Members
m_Name Data Member
m_WriteBuff Data Member
Constructors
DataMember
DataMember Constructor ()
DataMember Constructor (const char*)
Destructors
~DataMember Destructor
Methods
GetName
GetName Method (void)
GetName Method (void)
GetPfGroupActTracks Method
GetType Method
IsDefault Method
Read Method
Write Method
Enumerations
TYPE Enumeration
EnumDataMember Template
Constructors
EnumDataMember Constructor
Destructors
~EnumDataMember Destructor
Methods
GetEnum Method
IsDefault Method
SetEnum Method
ExecuteTask Class
Constructors
ExecuteTask Constructor
Destructors
~ExecuteTask Destructor
Methods
Begin Method
End Method
GetTrack Method
Update Method
ExecuteTrack Class
Constructors
ExecuteTrack Constructor
Destructors
~ExecuteTrack Destructor
Methods
DATAMEMEBERS_INTERFACE Method
NewTask Method
FloatDataMember Template
Constructors
FloatDataMember Constructor
Destructors
~FloatDataMember Destructor
Methods
GetFloat Method
GetMinMaxFloat Method
GetType Method
IsDefault Method
SetFloat Method
GameTaskManager Class
Data Members
m_CriticalSection Data Member
m_TaskPool0 Data Member
m_TaskPool1 Data Member
m_TaskPool2 Data Member
sm_Instance Data Member
Structs
DummyTask Struct
DummyTaskHeader Struct
Constructors
GameTaskManager Constructor
Destructors
~GameTaskManager Destructor
Methods
AddWidgets Method
AllocateTask Method
DECLARE_TASK_POOL_FUNCTIONS
DECLARE_TASK_POOL_FUNCTIONS Method (0)
DECLARE_TASK_POOL_FUNCTIONS Method (2)
DeleteTask Method
GetDummyTask Method
GetInstance Method
InitClass Method
ShutdownClass Method
Nested Types
DummyTask0 Nested Type
DummyTask1 Nested Type
DummyTask2 Nested Type
GroupDataMember Template
Constructors
GroupDataMember Constructor
Destructors
~GroupDataMember Destructor
Methods
Add
Add Method (IDataMembers*, TextParser&)
Add Method (IDataMembers*, const char*)
ChangePriority Method
Delete
Delete Method (IDataMembers*, IDataMembers*)
Delete Method (IDataMembers*, int)
GetCount Method
GetDataMember Method
GetDataMemberFormat Method
ReadAllElements Method
WriteElements Method
GroupDataMemberNoInterface Template
Constructors
GroupDataMemberNoInterface Constructor
Methods
GetType Method
IArchive Class
Constructors
IArchive Constructor
Destructors
~IArchive Destructor
Methods
Write Method
IBoolDataMember Class
Constructors
IBoolDataMember Constructor
Destructors
~IBoolDataMember Destructor
Methods
GetBool Method
GetType Method
Read Method
SetBool Method
Write Method
ICommandDataMember Class
Constructors
ICommandDataMember Constructor
Methods
Execute Method
GetType Method
IDataMembers Class
Data Members
m_ChangedMember Data Member
Constructors
IDataMembers Constructor
Destructors
~IDataMembers Destructor
Methods
DeclareStruct Method
GetMember Method
GetNumMembers Method
Read Method
Reset Method
Write Method
IEnumDataMember Class
Constructors
IEnumDataMember Constructor
Methods
GetEnum
GetEnum Method (IDataMembers*)
GetEnum Method (const char*)
GetEnumName Method
GetNumEnums Method
GetType Method
Read Method
SetEnum Method
Write Method
IFloatDataMember Class
Constructors
IFloatDataMember Constructor
Methods
GetFloat Method
GetMinMaxFloat Method
Read Method
SetFloat Method
Write Method
IGroupDataMember Class
Constructors
IGroupDataMember Constructor
Methods
Add
Add Method (IDataMembers*, TextParser&)
Add Method (IDataMembers*, const char*)
ChangePriority Method
Delete
Delete Method (IDataMembers*, IDataMembers*)
Delete Method (IDataMembers*, int)
GetCount Method
GetDataMember Method
GetDataMemberFormat Method
GetType Method
Read Method
ReadAllElements Method
Write Method
WriteElements Method
IIntDataMember Class
Constructors
IIntDataMember Constructor
Methods
GetInt Method
GetMinMaxInt Method
GetType Method
Read Method
SetInt Method
Write Method
IMultiNodeReferenceTrack Class
Constructors
IMultiNodeReferenceTrack
IMultiNodeReferenceTrack Constructor ()
IMultiNodeReferenceTrack Constructor (datResource&)
Methods
GetActionNode Method
GetActionNodeReference Method
GetActionNodeReferenceFullPath Method
GetNumRefs Method
GetRef Method
GetTrackType Method
GetTrackTypeStatic Method
IsActionNodeReferenceNull Method
IsActionNodeResolved
IsActionNodeResolved Method (eActionNodeResolveMode)
IsActionNodeResolved Method (int, eActionNodeResolveMode)
ResolveReference Method
SetActionNode Method
SetActionNodeParent Method
SetActionNodeReference Method
IName Class
Destructors
~IName Destructor
Methods
GetName
GetName Method (void)
GetName Method (void)
INodeReferenceDataMember Class
Constructors
INodeReferenceDataMember Constructor
Methods
GetFullPath Method
GetType Method
IsResolved Method
INodeReferenceTrack Class
Constructors
INodeReferenceTrack
INodeReferenceTrack Constructor ()
INodeReferenceTrack Constructor (datResource&)
Methods
GetTrackType Method
GetTrackTypeStatic Method
IsActionNodeResolved Method
ResolveReference Method
SetActionNodeParent Method
InstancedActionController Class
Data Members
m_SequencedTracks Data Member
Structs
refCountingTracks Struct
Destructors
~InstancedActionController Destructor
Methods
AddSequncedTrack Method
ClearSequencedTrack Method
clearSequencedTracks Method
DeleteSequencedTrack Method
GetNumSequencedTracks Method
GetSequencedTrack Method
IntDataMember Template
Constructors
IntDataMember Constructor
Destructors
~IntDataMember Destructor
Methods
GetInt Method
GetMinMaxInt Method
IsDefault Method
SetInt Method
IObserver Class
Destructors
~IObserver Destructor
Methods
HandleMessage Method
Update Method
UpdateDetach Method
IStringDataMember Class
Constructors
IStringDataMember Constructor
Methods
GetString Method
GetType Method
Read Method
SetString Method
Write Method
ITrackFactory Class
Constructors
ITrackFactory Constructor
Destructors
~ITrackFactory Destructor
Methods
GetRorcChecksum Method
GetTrackType Method
NewTrack Method
Place Method
SetTypeId Method
IVector2DataMember Class
Constructors
IVector2DataMember Constructor
Methods
GetVector2 Method
Read Method
SetVector2 Method
Write Method
IVector3DataMember Class
Constructors
IVector3DataMember Constructor
Methods
GetVector3 Method
Read Method
SetVector3 Method
Write Method
NodeReferenceDataMember Template
Constructors
NodeReferenceDataMember Constructor
Destructors
~NodeReferenceDataMember Destructor
Methods
GetFullPath Method
GetString Method
IsDefault Method
IsResolved Method
SetString Method
NodeReferenceTrack Class
Data Members
m_ActionNodeRef Data Member
Constructors
NodeReferenceTrack
NodeReferenceTrack Constructor ()
NodeReferenceTrack Constructor (datResource&)
Destructors
~NodeReferenceTrack Destructor
Methods
DeclareStruct Method
GetActionNode Method
GetActionNodeReference Method
GetActionNodeReferenceFullPath Method
IsActionNodeReferenceNull Method
IsActionNodeResolved
IsActionNodeResolved Method ()
IsActionNodeResolved Method (eActionNodeResolveMode)
ResolveReference Method
SetActionNode Method
SetActionNodeParent Method
SetActionNodeReference Method
OpportunityRandomLatchTask Class
Constructors
OpportunityRandomLatchTask Constructor
Destructors
~OpportunityRandomLatchTask Destructor
Methods
AcquireLatchTime Method
GetTrack Method
OpportunityRandomLatchTrack Class
Constructors
OpportunityRandomLatchTrack Constructor
Destructors
~OpportunityRandomLatchTrack Destructor
Methods
DATAMEMEBERS_INTERFACE Method
NewTask Method
TRACK_PADDING Method
TRACK_PARAMETER Method
OpportunityTask Class
Data Members
m_AlreadyBreaked Data Member
m_Context Data Member
m_Latched Data Member
m_latchedPlayable Data Member
m_LatchTime Data Member
Constructors
OpportunityTask Constructor
Destructors
~OpportunityTask Destructor
Methods
AcquireLatchTime Method
Begin Method
End Method
GetTrack Method
Update Method
OpportunityTrack Class
Constructors
OpportunityTrack Constructor
Destructors
~OpportunityTrack Destructor
Methods
AddCondition
AddCondition Method (TextParser&)
AddCondition Method (const char*)
ChangeConditionPriority Method
DATAMEMEBERS_INTERFACE Method
DeleteCondition Method
GetCondition Method
GetConditionCount Method
GetConditionFormat Method
GetConditionGroup Method
NewTask Method
ReadConditionGroup Method
TRACK_MEMBER Method
TRACK_PARAMETER
TRACK_PARAMETER Method (bool, Recycle)
TRACK_PARAMETER Method (float, TimeLatch)
WriteCondition Method
PrintTask Class
Constructors
PrintTask Constructor
Destructors
~PrintTask Destructor
Methods
Begin Method
End Method
GetTrack Method
Update Method
PrintTrack Class
Data Members
sm_PrintChannelEnabled Data Member
Constructors
PrintTrack Constructor
Destructors
~PrintTrack Destructor
Methods
AddWidgets Method
DATAMEMEBERS_INTERFACE Method
GetText Method
NewTask Method
SetText Method
ShouldPrint Method
TRACK_MEMBER Method
TRACK_PARAMETER Method
TRACK_PARAMETER_ENUM Method
Enumerations
PrintChannels Enumeration
SequenceTask Class
Constructors
SequenceTask Constructor
Destructors
~SequenceTask Destructor
Methods
End Method
GetTrack Method
SequenceTrack Class
Constructors
SequenceTrack Constructor
Destructors
~SequenceTrack Destructor
Methods
DATAMEMEBERS_INTERFACE Method
NewTask Method
SpawnActionController Class
Data Members
m_SequencedTracks Data Member
Destructors
~SpawnActionController Destructor
Methods
AddSequncedTrack Method
clearSequencedTracks Method
DeleteSequencedTrack Method
GetNumSequencedTracks Method
GetSequencedTrack Method
SpawnTask Class
Constructors
SpawnTask Constructor
Destructors
~SpawnTask Destructor
Methods
Begin Method
End Method
GetActionController
GetActionController Method ()
GetActionController Method ()
GetTrack Method
Update Method
SpawnTrack Class
Constructors
SpawnTrack Constructor
Destructors
~SpawnTrack Destructor
Methods
DATAMEMEBERS_INTERFACE Method
NewTask Method
TRACK_PARAMETER Method
StringDataMember Template
Constructors
StringDataMember Constructor
Destructors
~StringDataMember Destructor
Methods
GetString Method
IsDefault Method
SetString Method
StubTask Class
Constructors
StubTask Constructor
Destructors
~StubTask Destructor
Methods
Begin Method
End Method
GetTrack Method
Update Method
TaskSizeCompileTimeAssert Template
Constructors
TaskSizeCompileTimeAssert Constructor
TaskSizeCompileTimeAssert<SpawnTask> Template
Methods
TaskSizeCompileTimeAssert Method
TextBuffer Class
Constructors
TextBuffer Constructor
Destructors
~TextBuffer Destructor
Methods
AddNewLine Method
DecreaseIndent Method
GetBuffer Method
GetWrittenLength Method
IncreaseIndent Method
Reset Method
Write
Write Method (const char*)
Write Method (const char*, const char*, const char)
Write Method (const char*, float, const char)
Write Method (const char*, int, const char)
Write Method (float)
Write Method (int)
TextParser Class
Constructors
TextParser
TextParser Constructor (const char*, char*)
TextParser Constructor (rage::fiStream*, char*)
Destructors
~TextParser Destructor
Methods
AddvanceToToken Method
advanceToQuote Method
EndOfText Method
GetCurrentReadPosition Method
GetNextToken Method
GetQuotedString
GetQuotedString Method (char *, size_t)
GetQuotedString Method (void)
GetTokenAsFloat Method
GetTokenAsInt Method
GetTokenString
GetTokenString Method (char *, size_t)
GetTokenString Method (void)
IsParsingFile Method
MatchCurrentToken
MatchCurrentToken Method (const char*)
MatchCurrentToken Method (const char*, bool)
MatchCurrentTokenCaseInsensitive Method
NeedToSpecialParseQuotedString Method
PopReadPosition Method
PushReadPosition Method
SetCurrentReadPosition Method
Track Class
Data Members
m_FrameCount Data Member
m_Master Data Member
m_Pad Data Member
m_TimeBegin Data Member
m_TimeEnd Data Member
m_TimerId Data Member
RORC_VERSION Data Member
sm_TimerPool Data Member
Structs
Timer Struct
Data Members
m_Count Data Member
m_StartTime Data Member
m_Time Data Member
Methods
GetAverage Method
GetTime Method
GetTotal Method
Reset Method
Start Method
Stop Method
Constructors
Track
Track Constructor ()
Track Constructor (datResource&)
Destructors
~Track Destructor
Methods
Create
Create Method (TextParser&)
Create Method (const char*)
DECLARE_PLACE Method
DeclareStruct Method
DeInit Method
GetAverageTime Method
GetDuration Method
GetFrameCount Method
GetMaster Method
GetNumRegistered Method
GetNumTracks Method
GetPFTimer Method
GetRegistered Method
GetRegisteredTrackType Method
GetTimeBegin Method
GetTimeEnd Method
GetTimer Method
GetTotalTime Method
GetTrackRegistry Method
GetTrackType Method
GetTrackTypeStatic Method
Init Method
NewTask Method
ResetTimers Method
SetMaster Method
SetTimeBegin Method
SetTimeEnd Method
TimerStart Method
TimerStop Method
UpdateFrame Method
TrackFactory Template
Constructors
TrackFactory Constructor
Destructors
~TrackFactory Destructor
Methods
GetName
GetName Method (void)
GetName Method (void)
GetRorcChecksum Method
GetTrackType Method
NewTrack Method
Place Method
SetTypeId Method
TrackOrCondition Class
Constructors
TrackOrCondition Constructor
Methods
Break Method
DeclareStruct Method
GetConditionGroup Method
GetDebugBreakPoint Method
GetEnableBreakPoints Method
GetName
GetName Method (void)
GetName Method (void)
GetTrackType Method
GetTrackTypeStatic Method
GetTypeId Method
SetDebugBreakPoint Method
SetEnableBreakPoints Method
Write Method
TrackRegistry Class
Constructors
TrackRegistry Constructor
Destructors
~TrackRegistry Destructor
Methods
Create
Create Method (TextParser&)
Create Method (const char*)
DegisterTrackFactorys Method
DeInit Method
GetDictionary Method
GetNumRegisteredTracks Method
GetRegisteredTrackName Method
GetRegisteredTrackType Method
GetRorcChecksum Method
Init Method
Place Method
RegisterTrackFactory Method
ResetDictionary Method
Sort Method
Vector2DataMember Template
Constructors
Vector2DataMember Constructor
Destructors
~Vector2DataMember Destructor
Methods
GetType Method
GetVector2 Method
IsDefault Method
SetVector2 Method
Vector3DataMember Template
Constructors
Vector3DataMember Constructor
Destructors
~Vector3DataMember Destructor
Methods
GetType Method
GetVector3 Method
IsDefault Method
SetVector3 Method
eActionNodeResolveMode Enumeration
!= Function
== Function
HashUCstring Function
RAGE_DECLARE_CHANNEL Function
StringCopyNew Function
ActionNodeTreePtr Type
ActionVistorCallBack Type
DebugOutputFunctor Type
FactoryIArchive Type
gDebugActTreeOut Variable
gTempHashString Variable
ACCELERATION_DATAMEMBER Macro
ACCELERATION_DATAMEMBER_SIMPLE Macro
ACCELERATION_MIN_MAX_DATAMEMBER Macro
ACT_DEBUG_CODE Macro
ACT_DEBUG_DEF Macro
ACTIONTREE_CNAME_USE_ATSTRINGHASH Macro
ACTIONTREE_CNAME_USE_HASH_ASM Macro
actTreeDebug Macro
actTreeDebugPop Macro
actTreeDebugPush Macro
ALL_ACTIONTREE_TRACKS Macro
ANGLE_DATAMEMBER Macro
ANGLE_DATAMEMBER_SIMPLE Macro
ANGLE_MIN_MAX_DATAMEMBER Macro
BEGIN_DATAMEMBERS Macro
BEGIN_DATAMEMBERS_NO_BREAKPOINT Macro
BEGIN_DATAMEMBERS_NO_MEMBERS Macro
BEGIN_DATAMEMBERS_NO_MEMBERS_NO_NAME Macro
BEGIN_DATAMEMBERS_NO_NAME Macro
BEGIN_DATAMEMBERS_NOT_TRACK Macro
BOOL_DATAMEMBER Macro
BOOL_DATAMEMBER_SIMPLE Macro
COMMAND_DATAMEMBER Macro
COMMAND_DATAMEMBER_SIMPLE Macro
COMMENT_DATAMEMBER Macro
CONTROL_CONTEXT_ENABLED Macro
DATAMEMBERS_INTERFACE_RESOURCE_CTOR Macro
DATAMEMEBERS_INTERFACE Macro
DATAMEMEBERS_INTERFACE_NAME Macro
DATAMEMEBERS_INTERFACE_NO_NAME Macro
DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE Macro
DATAMEMEBERS_INTERFACE_NO_PLACE Macro
DATAMEMEBERS_INTERFACE_NO_PLACE_NO_NAME Macro
DATAMEMEBERS_INTERFACE_PLACE Macro
DATAMEMEBERS_INTERFACE_STRUCT Macro
DEBUG_BREAK Macro
DEBUGTASKS Macro
DEFINE_sMIN_sMAX Macro
DELETE_CORE_TASK Macro
DELETE_GAME_TASK Macro
DELETE_GAME_TASK_ON_END Macro
ENABLE_TRACK_TIMERS Macro
END_DATAMEMBERS Macro
END_DATAMEMBERS_LITE Macro
ENUM_DATAMEMBER Macro
ENUM_DATAMEMBER_SIMPLE Macro
FLOAT_DATAMEMBER Macro
FLOAT_DATAMEMBER_SIMPLE Macro
FLOAT_MIN_MAX_DATAMEMBER Macro
GROUP_DATAMEMBER Macro
GROUP_DATAMEMBER_NO_INTERFACE Macro
GROUP_DATAMEMBER_READONLY Macro
INCREMENT_DEBUG_TASK_UPDATE_COUNTER Macro
INT_DATAMEMBER Macro
INT_DATAMEMBER_SIMPLE Macro
INT_MIN_MAX_DATAMEMBER Macro
LENGTH_DATAMEMBER Macro
LENGTH_DATAMEMBER_SIMPLE Macro
LENGTH_MIN_MAX_DATAMEMBER Macro
LENTH_DATAMEMBER Macro
MAGIC_NOPLACE Macro
MAGIC_NP_ENUM Macro
MAGIC_NP_PADDING Macro
MAGIC_NP_PARAM Macro
MAGIC_NP_STRING Macro
MAX_HASH_STRING Macro
NEW_CORE_TASK Macro
NEW_GAME_TASK Macro
NODE_REFERENCE_DATAMEMBER Macro
NODE_REFERENCE_DATAMEMBER_SIMPLE Macro
NODENAMELEN Macro
PFSTAT_ONLY Macro
PLAY_HISTORY_DEBUG Macro
spewdrvDisplayf Macro
STRING_DATAMEMBER Macro
STRING_DATAMEMBER_SIMPLE Macro
TASK_POOL_FUNCTIONS Macro
TIME_DATAMEMBER Macro
TIME_DATAMEMBER_SIMPLE Macro
TIME_END_NOT_INSERTED Macro
TIME_MIN_MAX_DATAMEMBER Macro
TRACK_MEMBER Macro
TRACK_MEMBER_ENUM Macro
TRACK_PADDING Macro
TRACK_PARAMETER Macro
TRACK_PARAMETER_CNAME Macro
TRACK_PARAMETER_ENUM Macro
TRACK_PARAMETER_ENUM_STATIC Macro
TRACK_PARAMETER_MIN_MAX Macro
TRACK_PARAMETER_sMIN_sMAX Macro
TRACK_PARAMETER_STATIC Macro
TRACK_PARAMETER_STRING Macro
TRACK_PARAMETER_STRING_STATIC Macro
TRACK_PARAMETER_VECTOR2 Macro
TRACK_PARAMETER_VECTOR2_STATIC Macro
TRACK_PARAMETER_VECTOR3 Macro
TRACK_PARAMETER_VECTOR3_STATIC Macro
TRACK_TIME_DATAMEMBER Macro
TRACK_TIME_DATAMEMBER_SIMPLE Macro
TRACK_TIME_MIN_MAX_DATAMEMBER Macro
TRACKMSG Macro
VECTOR2_DATAMEMBER Macro
VECTOR3_DATAMEMBER Macro
VECTOR3_DATAMEMBER_SIMPLE Macro
VELOCITY_DATAMEMBER Macro
VELOCITY_DATAMEMBER_SIMPLE Macro
VELOCITY_MIN_MAX_DATAMEMBER Macro
Functions
ValFunc Function
Variables
ActionController::s_BeginBreakPoint Variable
ActionController::s_EndBreakPoint Variable
ActionController::s_NoOfTaskUpdates Variable
ActionController::s_UpDateBreakPoint Variable
ActionTreeLog::s_theActionTreeLog Variable
CNamePath::s_CNameTraverseDown Variable
CNamePath::s_CNameTraverseUp Variable
Condition::m_TrackRegistry Variable
ConditionRandom::sm_RandFunc Variable
ConditionRandom::sm_RandomNum Variable
ConditionRandom::sm_RandomUsed Variable
DataMember::m_WriteBuff Variable
g_PrintChannelNames Variable
g_PrintChannelNamesNum Variable
gCanOutputFalseCond Variable
gCanOutputTrueCond Variable
gCNameLog Variable
gCNameTable Variable
gCNameTableLoaded Variable
gCollapseConditionGroupsToNewLogicPrimatives Variable
gDebugLevel Variable
gDebugOn Variable
gEvalTaskNames Variable
gEvaluatedTasks Variable
iCurrentLevel Variable
initDebugOut Variable
MAX_EVAL Variable
pGroupPtr Variable
PrintTrack::sm_PrintChannelEnabled Variable
RandomModeNames Variable
sUseNameStrings Variable
TOO_LONG Variable
Macros
ACTION_NODE_HPP Macro
ACTIONNODETRACKS_HPP Macro
ALL_ACTIONTREE_CONDITIONS Macro
BEGIN_TASK Macro
CHECK_TASK_LENGTH Macro
CNAME_HPP Macro
CONDITION_HPP Macro
CORETASK_HPP Macro
DATAMEMBER_HPP Macro
DOUBLE_QUOTE Macro
ENABLE_INGAME_ACT_TEXT_LOADING Macro
ENABLE_PF_TIMERS Macro
END_TASK Macro
INCLUDE_STRINGS Macro
NOTRAW_ACT_FILE_SUPPORT_ONLY Macro
NOTTOOL_AND_ASSERT_ONLY Macro
RAW_ACT_FILE_SUPPORT Macro
RAW_ACT_FILE_SUPPORT_ONLY Macro
RAW_ACT_FILE_SUPPORT_ORNULL Macro
TEXTPARSER_HPP Macro
TIME_TASK_UPDATES Macro
TIMER_START_BEGIN Macro
TIMER_START_END Macro
TIMER_START_UPDATE Macro
TIMER_STOP_BEGIN Macro
TIMER_STOP_END Macro
TIMER_STOP_UPDATE Macro
TRACK_EVALUATED_TRACKS_AND_CONDITIONS Macro
TRACKED_MATCH Macro
TRACKS_HPP Macro
UPDATE_TASK Macro
VALIDATE_OR_REMOVE_NAME Macro


Index

Index
( | ~ | = | A | B | C | D | E | F | G | H | I | K | L | M | N | O | P | R | S | T | U | V | W
(
()
~
~ActionCallbackContext
~ActionContext
~ActionContextDebugDepth
~ActionController
~ActionIntention
~ActionNode
~ActionNodeBank
~ActionNodeFileReference
~ActionNodeImplementation
~ActionNodeLwRef
~ActionNodePlayable
~ActionNodeReference
~ActionNodeTree
~ArchiveFileRecord
~ATask
~BoolDataMember
~CBasicString
~CName
~CommandDataMember
~Condition
~ConditionActionNodePlayTime
~ConditionFalse
~ConditionGroup
~ConditionGroupCondition
~ConditionGroupConditionAnd
~ConditionGroupConditionNot
~ConditionGroupConditionOnly
~ConditionGroupConditionOr
~ConditionNOT
~ConditionOR
~ConditionPrint
~ConditionTrue
~CSubject
~DataMember
~EnumDataMember
~ExecuteTask
~ExecuteTrack
~FloatDataMember
~GameTaskManager
~GroupDataMember
~IArchive
~IBoolDataMember
~IDataMembers
~IName
~InstancedActionController
~IntDataMember
~IObserver
~ITrackFactory
~NodeReferenceDataMember
~NodeReferenceTrack
~OpportunityRandomLatchTask
~OpportunityRandomLatchTrack
~OpportunityTask
~OpportunityTrack
~PrintTask
~PrintTrack
~SequenceTask
~SequenceTrack
~SpawnActionController
~SpawnTask
~SpawnTrack
~StringDataMember
~StubTask
~TextBuffer
~TextParser
~Track
~TrackFactory
~TrackRegistry
~Vector2DataMember
~Vector3DataMember
=
=
==
A
AcquireLatchTime
ACTION_NODE_HPP
ACTION_NODE_HPP macro
ActionCallbackContext
ActionCallbackContext class
~ActionCallbackContext
ActionCallbackContext
Bind
GetController
OnEndTask
OnNodeCleanup
OnPlay
OnPlayTracks
OnSequence
OnStop
Update
ActionCallbackContext::~ActionCallbackContext destructor
ActionCallbackContext::ActionCallbackContext constructor
ActionCallbackContext::Bind method
ActionCallbackContext::GetController method
ActionCallbackContext::OnEndTask method
ActionCallbackContext::OnNodeCleanup method
ActionCallbackContext::OnPlay method
ActionCallbackContext::OnPlayTracks method
ActionCallbackContext::OnSequence method
ActionCallbackContext::OnStop method
ActionCallbackContext::Update method
ActionContext
ActionContext class
~ActionContext
ActionContext
Clone
DebugActionContextCB
GetActorName
m_ActionController
m_Actor
m_CurrentAction
m_CurrentMatchingNode
m_Debug
m_DebugContextClBk
m_Depth
m_Entity
m_OpeningBranch
NullOp
OnACTError
OnStopPostTaskEnd
PreUpdate
ResetDebug
VerifyNewNode
ActionContext::~ActionContext destructor
ActionContext::ActionContext constructor
ActionContext::Clone method
ActionContext::DebugActionContextCB nested type
ActionContext::GetActorName method
ActionContext::m_ActionController data member
ActionContext::m_Actor data member
ActionContext::m_CurrentAction data member
ActionContext::m_CurrentMatchingNode data member
ActionContext::m_Debug data member
ActionContext::m_DebugContextClBk data member
ActionContext::m_Depth data member
ActionContext::m_Entity data member
ActionContext::m_OpeningBranch data member
ActionContext::NullOp method
ActionContext::OnACTError method
ActionContext::OnStopPostTaskEnd method
ActionContext::PreUpdate method
ActionContext::ResetDebug method
ActionContext::VerifyNewNode method
ActionContextDebugDepth
ActionContextDebugDepth struct
~ActionContextDebugDepth
ActionContextDebugDepth
m_Ctx
m_Op
m_PrevNode
ActionContextDebugDepth::~ActionContextDebugDepth destructor
ActionContextDebugDepth::ActionContextDebugDepth constructor
ActionContextDebugDepth::m_Ctx data member
ActionContextDebugDepth::m_Op data member
ActionContextDebugDepth::m_PrevNode data member
ActionController
ActionController class
~ActionController
ActionController
BeginDebugTask
clearAll
EndDebugTask
EndTask
GetBeginBreakPoint
GetContext
GetControlContext
GetCurrentNodePlayTime
GetCurrentPlayCount
GetCurrentPlayingNode
GetCurrentPlayingNode
GetDebug
GetEndBreakPoint
GetPlayHistory
GetRequestedNode
GetRunningTaskRoot
GetUpDateBreakPoint
IsBusy
Play
PlayRemote
PlayTracks
RemoveTask
RemoveTask
s_NoOfTaskUpdates
Sequence
SetBeginBreakPoint
SetContext
SetControlContext
SetDebug
SetEndBreakPoint
SetRequestedNode
SetUpDateBreakPoint
StartSequencedTracks
Stop
TRACKMSG
TRACKMSG
TRACKMSG
TRACKMSG
Update
UpdateDebugTask
UpdateTasks
UpdateTasksTimeEnd
UpdateWithKeepAlive
ActionController::~ActionController destructor
ActionController::ActionController constructor
ActionController::BeginDebugTask method
ActionController::clearAll method
ActionController::EndDebugTask method
ActionController::EndTask method
ActionController::GetBeginBreakPoint method
ActionController::GetContext method
ActionController::GetControlContext method
ActionController::GetCurrentNodePlayTime method
ActionController::GetCurrentPlayCount method
ActionController::GetCurrentPlayingNode method
ActionController::GetDebug method
ActionController::GetEndBreakPoint method
ActionController::GetPlayHistory method
ActionController::GetRequestedNode method
ActionController::GetRunningTaskRoot method
ActionController::GetUpDateBreakPoint method
ActionController::IsBusy method
ActionController::Play method
ActionController::PlayRemote method
ActionController::PlayTracks method
ActionController::RemoveTask method
ActionController::s_BeginBreakPoint
ActionController::s_BeginBreakPoint variable
ActionController::s_EndBreakPoint
ActionController::s_EndBreakPoint variable
ActionController::s_NoOfTaskUpdates
ActionController::s_NoOfTaskUpdates data member
ActionController::s_NoOfTaskUpdates variable
ActionController::s_UpDateBreakPoint
ActionController::s_UpDateBreakPoint variable
ActionController::Sequence method
ActionController::SetBeginBreakPoint method
ActionController::SetContext method
ActionController::SetControlContext method
ActionController::SetDebug method
ActionController::SetEndBreakPoint method
ActionController::SetRequestedNode method
ActionController::SetUpDateBreakPoint method
ActionController::StartSequencedTracks method
ActionController::Stop method
ActionController::TRACKMSG method
ActionController::Update method
ActionController::UpdateDebugTask method
ActionController::UpdateTasks method
ActionController::UpdateTasksTimeEnd method
ActionController::UpdateWithKeepAlive method
ActionIntention
ActionIntention class
~ActionIntention
ActionIntention
Clear
Update
ActionIntention::~ActionIntention destructor
ActionIntention::ActionIntention constructor
ActionIntention::Clear method
ActionIntention::Update method
ActionNode
ActionNode class
~ActionNode
ActionNode
AddBranch
AddChildActionNode
AddChildActionNodes
AddCondition
AddCondition
AddRoot
AddStuff
AddTrack
AddTrack
AddTrack
AddTracksBank
BalanceWeights
ChangeChildPriority
ChangeConditionPriority
ChangePriority
ChangeTrackPriority
class ActionNodeReference
class ActionNodeTree
ClearChildNodes
ClearRoots
Create
CreateIArchive
DATAMEMEBERS_INTERFACE_NO_NAME
DeInit
DeleteChildActionNodes
DeleteCondition
DeleteCondition
DeleteTrack
DeleteTrack
DumpTiming
DumpTimingRecursive
EvalRemote
EvalRemoteTransition
Find
Find
Find
Find
FindChildNode
FindChildNode
FindFirstPlayable
FindRoot
GetChild
GetChildCount
GetCNamePath
GetCondition
GetConditionCount
GetConditionGroup
GetCondtionFormat
GetFileRoot
GetFileRoot
GetName
GetName
GetNameFullPath
GetNameFullPath
GetNameFullPathDebug
GetParent
GetPathCRC
GetPriority
GetRefCount
GetRoot
GetTrack
GetTrackCount
GetTrackFormat
GetType
IncRefCount
Init
IsDescendantOf
IsDescendantOf
IsDescendantOf
Load
m_bUpdatedOnce
m_bViewExpanded
m_childNodes
m_FileRoot
m_GlobalEditPriority
m_OnLoad
m_OnUnload
m_Pad
m_parent
m_PathCRC
m_Root
m_Type
Match
OnTreeUnload
OperateAllNodes
OperateChildOnNodes
PrintAllNodes
ReadConditionGroup
RecursSetFileRoots
RemoveChildActionNode
ReserveTracks
ResetTiming
ResetTimingRecursive
ResolveAllTrackReferences
ResolveAllWeights
ResolveTrackReferences
ResolveWeights
RORC_VERSION
SetOnLoad
SetOnUnload
SetParent
sm_ActFullPath
sm_ActPath
sm_OnTreeUnloadCallback
sm_PostLoadCallback
sm_RscFirstPass
TaskLoadActionNode
TokenName
TRACK_PARAMETER_STRING
UnLoad
UnLoad
UnLoadAll
Write
Write
writeBegin
writeChildren
writeComment
WriteCondition
writeConditions
writeEnd
writeTracks
ActionNode::~ActionNode destructor
ActionNode::ActionNode constructor
ActionNode::AddBranch method
ActionNode::AddChildActionNode method
ActionNode::AddChildActionNodes method
ActionNode::AddCondition method
ActionNode::AddRoot method
ActionNode::AddStuff method
ActionNode::AddTrack method
ActionNode::AddTracksBank method
ActionNode::BalanceWeights method
ActionNode::ChangeChildPriority method
ActionNode::ChangeConditionPriority method
ActionNode::ChangePriority method
ActionNode::ChangeTrackPriority method
ActionNode::ClearChildNodes method
ActionNode::ClearRoots method
ActionNode::Create method
ActionNode::CreateIArchive method
ActionNode::DATAMEMEBERS_INTERFACE_NO_NAME method
ActionNode::DeInit method
ActionNode::DeleteChildActionNodes method
ActionNode::DeleteCondition method
ActionNode::DeleteTrack method
ActionNode::DumpTiming method
ActionNode::DumpTimingRecursive method
ActionNode::EvalRemote method
ActionNode::EvalRemoteTransition method
ActionNode::Find method
ActionNode::FindChildNode method
ActionNode::FindFirstPlayable method
ActionNode::FindRoot method
ActionNode::GetChild method
ActionNode::GetChildCount method
ActionNode::GetCNamePath method
ActionNode::GetCondition method
ActionNode::GetConditionCount method
ActionNode::GetConditionGroup method
ActionNode::GetCondtionFormat method
ActionNode::GetFileRoot method
ActionNode::GetName method
ActionNode::GetNameFullPath method
ActionNode::GetNameFullPathDebug method
ActionNode::GetParent method
ActionNode::GetPathCRC method
ActionNode::GetPriority method
ActionNode::GetRefCount method
ActionNode::GetRoot method
ActionNode::GetTrack method
ActionNode::GetTrackCount method
ActionNode::GetTrackFormat method
ActionNode::GetType method
ActionNode::IncRefCount method
ActionNode::Init method
ActionNode::IsDescendantOf method
ActionNode::Load method
ActionNode::m_bUpdatedOnce data member
ActionNode::m_bViewExpanded data member
ActionNode::m_childNodes data member
ActionNode::m_FileRoot data member
ActionNode::m_GlobalEditPriority data member
ActionNode::m_OnLoad data member
ActionNode::m_OnUnload data member
ActionNode::m_Pad data member
ActionNode::m_parent data member
ActionNode::m_PathCRC data member
ActionNode::m_Root data member
ActionNode::m_Type data member
ActionNode::Match method
ActionNode::OnTreeUnload method
ActionNode::OperateAllNodes method
ActionNode::OperateChildOnNodes method
ActionNode::PrintAllNodes method
ActionNode::ReadConditionGroup method
ActionNode::RecursSetFileRoots method
ActionNode::RemoveChildActionNode method
ActionNode::ReserveTracks method
ActionNode::ResetTiming method
ActionNode::ResetTimingRecursive method
ActionNode::ResolveAllTrackReferences method
ActionNode::ResolveAllWeights method
ActionNode::ResolveTrackReferences method
ActionNode::ResolveWeights method
ActionNode::RORC_VERSION data member
ActionNode::SetOnLoad method
ActionNode::SetOnUnload method
ActionNode::SetParent method
ActionNode::sm_ActFullPath data member
ActionNode::sm_ActPath data member
ActionNode::sm_OnTreeUnloadCallback data member
ActionNode::sm_PostLoadCallback data member
ActionNode::sm_RscFirstPass data member
ActionNode::TaskLoadActionNode method
ActionNode::TokenName method
ActionNode::TRACK_PARAMETER_STRING method
ActionNode::UnLoad method
ActionNode::UnLoadAll method
ActionNode::Write method
ActionNode::writeBegin method
ActionNode::writeChildren method
ActionNode::writeComment method
ActionNode::WriteCondition method
ActionNode::writeConditions method
ActionNode::writeEnd method
ActionNode::writeTracks method
ActionNodeBank
ActionNodeBank class
~ActionNodeBank
ActionNodeBank
ActionNodeBank
DATAMEMEBERS_INTERFACE_NO_NAME
Match
ResolveWeights
TokenName
ActionNodeBank::~ActionNodeBank destructor
ActionNodeBank::ActionNodeBank constructor
ActionNodeBank::DATAMEMEBERS_INTERFACE_NO_NAME method
ActionNodeBank::Match method
ActionNodeBank::ResolveWeights method
ActionNodeBank::TokenName method
ActionNodeDebugName
ActionNodeDebugName struct
()
ActionNodeDebugName
m_Name
ActionNodeDebugName::() operator
ActionNodeDebugName::ActionNodeDebugName constructor
ActionNodeDebugName::m_Name data member
ActionNodeFileReference
ActionNodeFileReference class
~ActionNodeFileReference
ActionNodeFileReference
ActionNodeFileReference
ActionNodeFileReference
DATAMEMEBERS_INTERFACE_NO_NAME
GetArchiveFileRecord
GetFileName
GetFullPathName
GetPathName
Read
ReadFile
RecursSetFileRoots
SetFileName
SetFullPathName
SetPathName
TokenName
Write
Write
ActionNodeFileReference::~ActionNodeFileReference destructor
ActionNodeFileReference::ActionNodeFileReference constructor
ActionNodeFileReference::DATAMEMEBERS_INTERFACE_NO_NAME method
ActionNodeFileReference::GetArchiveFileRecord method
ActionNodeFileReference::GetFileName method
ActionNodeFileReference::GetFullPathName method
ActionNodeFileReference::GetPathName method
ActionNodeFileReference::Read method
ActionNodeFileReference::ReadFile method
ActionNodeFileReference::RecursSetFileRoots method
ActionNodeFileReference::SetFileName method
ActionNodeFileReference::SetFullPathName method
ActionNodeFileReference::SetPathName method
ActionNodeFileReference::TokenName method
ActionNodeFileReference::Write method
ActionNodeImplementation
ActionNodeImplementation class
~ActionNodeImplementation
ActionNodeImplementation
ActionNodeImplementation
AddCondition
AddCondition
AddTrack
AddTrack
AddTrack
ChangeConditionPriority
ChangeTrackPriority
DATAMEMEBERS_INTERFACE_NO_NAME
DeleteCondition
DeleteCondition
DeleteTrack
DeleteTrack
GetCondition
GetConditionCount
GetConditionGroup
GetCondtionFormat
GetName
GetName
GetTrack
GetTrackCount
GetTrackFormat
m_Conditions
m_Name
m_tracks
ReadConditionGroup
ReserveTracks
WriteCondition
ActionNodeImplementation::~ActionNodeImplementation destructor
ActionNodeImplementation::ActionNodeImplementation constructor
ActionNodeImplementation::AddCondition method
ActionNodeImplementation::AddTrack method
ActionNodeImplementation::ChangeConditionPriority method
ActionNodeImplementation::ChangeTrackPriority method
ActionNodeImplementation::DATAMEMEBERS_INTERFACE_NO_NAME method
ActionNodeImplementation::DeleteCondition method
ActionNodeImplementation::DeleteTrack method
ActionNodeImplementation::GetCondition method
ActionNodeImplementation::GetConditionCount method
ActionNodeImplementation::GetConditionGroup method
ActionNodeImplementation::GetCondtionFormat method
ActionNodeImplementation::GetName method
ActionNodeImplementation::GetTrack method
ActionNodeImplementation::GetTrackCount method
ActionNodeImplementation::GetTrackFormat method
ActionNodeImplementation::m_Conditions data member
ActionNodeImplementation::m_Name data member
ActionNodeImplementation::m_tracks data member
ActionNodeImplementation::ReadConditionGroup method
ActionNodeImplementation::ReserveTracks method
ActionNodeImplementation::WriteCondition method
ActionNodeLwRef
ActionNodeLwRef class
~ActionNodeLwRef
ActionNodeLwRef
ActionNodeLwRef
DeclareStruct
GetActionNode
IMPLEMENT_PLACE_INLINE
IsNull
SetActionNode
SetParent
SetReferenceName
ActionNodeLwRef::~ActionNodeLwRef destructor
ActionNodeLwRef::ActionNodeLwRef constructor
ActionNodeLwRef::DeclareStruct method
ActionNodeLwRef::GetActionNode method
ActionNodeLwRef::IMPLEMENT_PLACE_INLINE method
ActionNodeLwRef::IsNull method
ActionNodeLwRef::SetActionNode method
ActionNodeLwRef::SetParent method
ActionNodeLwRef::SetReferenceName method
ActionNodePlayable
ActionNodePlayable class
~ActionNodePlayable
ActionNodePlayable
ActionNodePlayable
ActionNodePlayable
AddStuff
AddTrack
DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE
DECLARE_PLACE
DeclareStruct
GetEditPriority
Match
SetEditPriority
TokenName
Update
UpdateDetach
Write
Write
ActionNodePlayable::~ActionNodePlayable destructor
ActionNodePlayable::ActionNodePlayable constructor
ActionNodePlayable::AddStuff method
ActionNodePlayable::AddTrack method
ActionNodePlayable::DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE method
ActionNodePlayable::DECLARE_PLACE method
ActionNodePlayable::DeclareStruct method
ActionNodePlayable::GetEditPriority method
ActionNodePlayable::Match method
ActionNodePlayable::SetEditPriority method
ActionNodePlayable::TokenName method
ActionNodePlayable::Update method
ActionNodePlayable::UpdateDetach method
ActionNodePlayable::Write method
ActionNodeReference
ActionNodeReference class
~ActionNodeReference
ActionNodeReference
ActionNodeReference
AddCondition
AddCondition
AddTrack
AddTrack
AddTrack
DATAMEMEBERS_INTERFACE_NO_NAME
DeleteCondition
DeleteCondition
GetActionNode
GetChild
GetChildCount
GetCondition
GetConditionCount
GetConditionGroup
GetCondtionFormat
GetName
GetName
GetReferenceFullPath
GetReferenceName
GetTrack
GetTrackCount
GetTrackFormat
IsNull
m_nameFullPath
m_referenceName
m_referenceNode
Match
ReadConditionGroup
ReserveTracks
ResolveReference
SetActionNode
SetReferenceName
WriteCondition
ActionNodeReference::~ActionNodeReference destructor
ActionNodeReference::ActionNodeReference constructor
ActionNodeReference::AddCondition method
ActionNodeReference::AddTrack method
ActionNodeReference::DATAMEMEBERS_INTERFACE_NO_NAME method
ActionNodeReference::DeleteCondition method
ActionNodeReference::GetActionNode method
ActionNodeReference::GetChild method
ActionNodeReference::GetChildCount method
ActionNodeReference::GetCondition method
ActionNodeReference::GetConditionCount method
ActionNodeReference::GetConditionGroup method
ActionNodeReference::GetCondtionFormat method
ActionNodeReference::GetName method
ActionNodeReference::GetReferenceFullPath method
ActionNodeReference::GetReferenceName method
ActionNodeReference::GetTrack method
ActionNodeReference::GetTrackCount method
ActionNodeReference::GetTrackFormat method
ActionNodeReference::IsNull method
ActionNodeReference::m_nameFullPath data member
ActionNodeReference::m_referenceName data member
ActionNodeReference::m_referenceNode data member
ActionNodeReference::Match method
ActionNodeReference::ReadConditionGroup method
ActionNodeReference::ReserveTracks method
ActionNodeReference::ResolveReference method
ActionNodeReference::SetActionNode method
ActionNodeReference::SetReferenceName method
ActionNodeReference::WriteCondition method
ACTIONNODETRACKS_HPP
ACTIONNODETRACKS_HPP macro
ActionNodeTree
ActionNodeTree class
~ActionNodeTree
ActionNodeTree
ActionNodeTree
class ActionNodeTreeHandle
class pgStreamable<ActionNodeTree>
DECLARE_PLACE
DECLARE_THREADED_PLACE
DeclareStruct
GetRoot
GetRorcVersion
ResolveReferences
SetRoot
ActionNodeTree::~ActionNodeTree destructor
ActionNodeTree::ActionNodeTree constructor
ActionNodeTree::DECLARE_PLACE method
ActionNodeTree::DECLARE_THREADED_PLACE method
ActionNodeTree::DeclareStruct method
ActionNodeTree::GetRoot method
ActionNodeTree::GetRorcVersion method
ActionNodeTree::ResolveReferences method
ActionNodeTree::SetRoot method
ActionNodeTreeHandle class
AddRef
class ActionNode
class ActionNodeTree
class atPtr<ActionNodeTreeHandle>
Cleanup
DecRefCount
ForceLoad
Get
GetName
GetObject
GetRefCount
GetRoot
GetStreamable
IncRefCount
IsDeleted
IsResident
IsStreamingOrResident
IsValid
Kill
PagedIn
SetMap
SetStreamingPriority
sm_LoadFromResources
ActionNodeTreeHandle::AddRef method
ActionNodeTreeHandle::Cleanup method
ActionNodeTreeHandle::DecRefCount method
ActionNodeTreeHandle::ForceLoad method
ActionNodeTreeHandle::Get method
ActionNodeTreeHandle::GetName method
ActionNodeTreeHandle::GetObject method
ActionNodeTreeHandle::GetRefCount method
ActionNodeTreeHandle::GetRoot method
ActionNodeTreeHandle::GetStreamable method
ActionNodeTreeHandle::IncRefCount method
ActionNodeTreeHandle::IsDeleted method
ActionNodeTreeHandle::IsResident method
ActionNodeTreeHandle::IsStreamingOrResident method
ActionNodeTreeHandle::IsValid method
ActionNodeTreeHandle::Kill method
ActionNodeTreeHandle::PagedIn method
ActionNodeTreeHandle::SetMap nested type
ActionNodeTreeHandle::SetStreamingPriority method
ActionNodeTreeHandle::sm_LoadFromResources data member
ActionNodeUnresolvedRef
ActionNodeUnresolvedRef class
ActionNodeUnresolvedRef
ActionNodeUnresolvedRef
class ActionNodeLwRef
class ActionNodeTree
DECLARE_PLACE
DeclareStruct
ActionNodeUnresolvedRef::ActionNodeUnresolvedRef constructor
ActionNodeUnresolvedRef::DECLARE_PLACE method
ActionNodeUnresolvedRef::DeclareStruct method
ActionTreeLog class
GetInstance
GetMessage
Log
Warn
ActionTreeLog::GetInstance method
ActionTreeLog::GetMessage method
ActionTreeLog::Log method
ActionTreeLog::s_theActionTreeLog
ActionTreeLog::s_theActionTreeLog variable
ActionTreeLog::Warn method
actTreeDebugOut
actTreeDebugOut class
actTreeDebugOut
actTreeDebugOut
GetRef
Out
actTreeDebugOut::actTreeDebugOut constructor
actTreeDebugOut::GetRef method
actTreeDebugOut::Out method
Add
AddBranch
AddChildActionNode
AddChildActionNodes
AddCondition
AddConditions
AddNewLine
AddRef
AddRoot
AddSequncedTrack
AddStuff
AddTrack
AddTracksBank
AddvanceToToken
AddWidgets
advanceToQuote
ALL_ACTIONTREE_CONDITIONS
ALL_ACTIONTREE_CONDITIONS macro
AllocateTask
ArchiveFileRecord
ArchiveFileRecord class
~ArchiveFileRecord
ArchiveFileRecord
ArchiveFileRecord
ArchiveFileRecord
GetArchiveObject
GetFileName
GetFullPathName
GetPathName
Init
IsFileChangedOnDisk
IsFileWriteAble
ReadFromFile
SetArchiveObject
SetFactoryIArchive
SetFileName
SetFullPathName
SetPathName
WriteToFile
ArchiveFileRecord::~ArchiveFileRecord destructor
ArchiveFileRecord::ArchiveFileRecord constructor
ArchiveFileRecord::GetArchiveObject method
ArchiveFileRecord::GetFileName method
ArchiveFileRecord::GetFullPathName method
ArchiveFileRecord::GetPathName method
ArchiveFileRecord::Init method
ArchiveFileRecord::IsFileChangedOnDisk method
ArchiveFileRecord::IsFileWriteAble method
ArchiveFileRecord::ReadFromFile method
ArchiveFileRecord::SetArchiveObject method
ArchiveFileRecord::SetFactoryIArchive method
ArchiveFileRecord::SetFileName method
ArchiveFileRecord::SetFullPathName method
ArchiveFileRecord::SetPathName method
ArchiveFileRecord::WriteToFile method
ATask
ATask class
~ATask
ATask
Begin
End
GetActionController
GetActionController
GetMyContext
GetTrack
m_NextRunningTask
m_TimeEnd
Update
ATask::~ATask destructor
ATask::ATask constructor
ATask::Begin method
ATask::End method
ATask::GetActionController method
ATask::GetMyContext method
ATask::GetTrack method
ATask::m_NextRunningTask data member
ATask::m_TimeEnd data member
ATask::Update method
Attach
B
BalanceWeights
Begin
BEGIN_TASK
BEGIN_TASK macro
BeginDebugTask
Bind
BoolDataMember
BoolDataMember template
~BoolDataMember
BoolDataMember
GetBool
IsDefault
Set_GetFunction
SetBool
BoolDataMember::~BoolDataMember destructor
BoolDataMember::BoolDataMember constructor
BoolDataMember::GetBool method
BoolDataMember::IsDefault method
BoolDataMember::Set_GetFunction method
BoolDataMember::SetBool method
Break
C
CatName
CatNameID
CBasicString
CBasicString class
~CBasicString
=
==
==
==
CBasicString
CBasicString
CBasicString
CBasicString
DECLARE_PLACE
DeclareStruct
GetString
SetString
CBasicString::~CBasicString destructor
CBasicString::= operator
CBasicString::== operator
CBasicString::CBasicString constructor
CBasicString::DECLARE_PLACE method
CBasicString::DeclareStruct method
CBasicString::GetString method
CBasicString::SetString method
CFastNamePath
CFastNamePath class
CFastNamePath
CFastNamePath
GetNameHash
GetNameHash
GetNumElements
SetPath
CFastNamePath::CFastNamePath constructor
CFastNamePath::GetNameHash method
CFastNamePath::GetNumElements method
CFastNamePath::SetPath method
ChangeChildPriority
ChangeConditionPriority
ChangePriority
ChangeTrackPriority
CHECK_TASK_LENGTH
CHECK_TASK_LENGTH macro
class ActionNode
class ActionNodeLwRef
class ActionNodeReference
class ActionNodeTree
class ActionNodeTreeHandle
class atPtr<ActionNodeTreeHandle>
class pgStreamable<ActionNodeTree>
Cleanup
Clear
clearAll
ClearChildNodes
ClearRoots
ClearSequencedTrack
clearSequencedTracks
Clone
CName
CName class
~CName
=
==
==
==
CName
CName
CName
CName
CName
DECLARE_PLACE
DeclareStruct
GetID
GetString
Hash
SetID
SetString
CName::~CName destructor
CName::= operator
CName::== operator
CName::CName constructor
CName::DECLARE_PLACE method
CName::DeclareStruct method
CName::GetID method
CName::GetString method
CName::Hash method
CName::SetID method
CName::SetString method
CNAME_HPP
CNAME_HPP macro
CNamePath
CNamePath class
CatName
CatName
CatNameID
CNamePath
CNamePath
CNamePath
DECLARE_PLACE
DeclareStruct
DeInitStatic
GetFullPathDebug
GetName
GetName
GetNumElements
InitStatic
s_CNameTraverseDown
s_CNameTraverseUp
SetPath
CNamePath::CatName method
CNamePath::CatNameID method
CNamePath::CNamePath constructor
CNamePath::DECLARE_PLACE method
CNamePath::DeclareStruct method
CNamePath::DeInitStatic method
CNamePath::GetFullPathDebug method
CNamePath::GetName method
CNamePath::GetNumElements method
CNamePath::InitStatic method
CNamePath::s_CNameTraverseDown
CNamePath::s_CNameTraverseDown data member
CNamePath::s_CNameTraverseDown variable
CNamePath::s_CNameTraverseUp
CNamePath::s_CNameTraverseUp data member
CNamePath::s_CNameTraverseUp variable
CNamePath::SetPath method
Command Line Options
CommandDataMember
CommandDataMember template
~CommandDataMember
CommandDataMember
Execute
GetString
SetString
CommandDataMember::~CommandDataMember destructor
CommandDataMember::CommandDataMember constructor
CommandDataMember::Execute method
CommandDataMember::GetString method
CommandDataMember::SetString method
CompareFloat
CompareInt
Components
Condition
Condition class
~Condition
Condition
Condition
Create
Create
DECLARE_PLACE
DeclareStruct
DeInit
EvalRemote
GetLogical
GetNumConditions
GetNumRegistered
GetPFTimer
GetRegistered
GetTrackRegistry
Init
IsRemoteCondition
Match
NewTask
RORC_VERSION
Condition::~Condition destructor
Condition::Condition constructor
Condition::Create method
Condition::DECLARE_PLACE method
Condition::DeclareStruct method
Condition::DeInit method
Condition::EvalRemote method
Condition::GetLogical method
Condition::GetNumConditions method
Condition::GetNumRegistered method
Condition::GetPFTimer method
Condition::GetRegistered method
Condition::GetTrackRegistry method
Condition::Init method
Condition::IsRemoteCondition method
Condition::m_TrackRegistry
Condition::m_TrackRegistry variable
Condition::Match method
Condition::NewTask method
Condition::RORC_VERSION data member
CONDITION_HPP
CONDITION_HPP macro
ConditionActionNodePlayTime
ConditionActionNodePlayTime class
~ConditionActionNodePlayTime
ConditionActionNodePlayTime
DATAMEMEBERS_INTERFACE
Match
TRACK_PARAMETER
ConditionActionNodePlayTime::~ConditionActionNodePlayTime destructor
ConditionActionNodePlayTime::ConditionActionNodePlayTime constructor
ConditionActionNodePlayTime::DATAMEMEBERS_INTERFACE method
ConditionActionNodePlayTime::Match method
ConditionActionNodePlayTime::TRACK_PARAMETER method
Conditional class
CompareFloat
CompareInt
m_ConditionalStringName
m_ConditionalStringNameSize
Conditional::CompareFloat method
Conditional::CompareInt method
Conditional::m_ConditionalStringName data member
Conditional::m_ConditionalStringNameSize data member
ConditionFalse
ConditionFalse class
~ConditionFalse
ConditionFalse
DATAMEMEBERS_INTERFACE
Match
ConditionFalse::~ConditionFalse destructor
ConditionFalse::ConditionFalse constructor
ConditionFalse::DATAMEMEBERS_INTERFACE method
ConditionFalse::Match method
ConditionGroup
ConditionGroup class
~ConditionGroup
AddCondition
AddConditions
ChangeConditionPriority
ConditionGroup
ConditionGroup
DECLARE_PLACE
DeclareStruct
DeleteCondition
EvalRemote
GetCondition
GetConditionCount
Match
Read
Write
ConditionGroup::~ConditionGroup destructor
ConditionGroup::AddCondition method
ConditionGroup::AddConditions method
ConditionGroup::ChangeConditionPriority method
ConditionGroup::ConditionGroup constructor
ConditionGroup::DECLARE_PLACE method
ConditionGroup::DeclareStruct method
ConditionGroup::DeleteCondition method
ConditionGroup::EvalRemote method
ConditionGroup::GetCondition method
ConditionGroup::GetConditionCount method
ConditionGroup::Match method
ConditionGroup::Read method
ConditionGroup::Write method
ConditionGroupCondition
ConditionGroupCondition class
~ConditionGroupCondition
AddCondition
AddCondition
ChangeConditionPriority
ConditionGroupCondition
DATAMEMEBERS_INTERFACE
DeleteCondition
GetCondition
GetConditionCount
GetConditionFormat
GetConditionGroup
Match
Read
ReadConditionGroup
SetConditionGroup
TRACK_MEMBER
TRACK_PADDING
WriteCondition
ConditionGroupCondition::~ConditionGroupCondition destructor
ConditionGroupCondition::AddCondition method
ConditionGroupCondition::ChangeConditionPriority method
ConditionGroupCondition::ConditionGroupCondition constructor
ConditionGroupCondition::DATAMEMEBERS_INTERFACE method
ConditionGroupCondition::DeleteCondition method
ConditionGroupCondition::GetCondition method
ConditionGroupCondition::GetConditionCount method
ConditionGroupCondition::GetConditionFormat method
ConditionGroupCondition::GetConditionGroup method
ConditionGroupCondition::Match method
ConditionGroupCondition::Read method
ConditionGroupCondition::ReadConditionGroup method
ConditionGroupCondition::SetConditionGroup method
ConditionGroupCondition::TRACK_MEMBER method
ConditionGroupCondition::TRACK_PADDING method
ConditionGroupCondition::WriteCondition method
ConditionGroupConditionAnd
ConditionGroupConditionAnd class
~ConditionGroupConditionAnd
ConditionGroupConditionAnd
DATAMEMEBERS_INTERFACE
Match
ConditionGroupConditionAnd::~ConditionGroupConditionAnd destructor
ConditionGroupConditionAnd::ConditionGroupConditionAnd constructor
ConditionGroupConditionAnd::DATAMEMEBERS_INTERFACE method
ConditionGroupConditionAnd::Match method
ConditionGroupConditionNot
ConditionGroupConditionNot class
~ConditionGroupConditionNot
ConditionGroupConditionNot
DATAMEMEBERS_INTERFACE
Match
ConditionGroupConditionNot::~ConditionGroupConditionNot destructor
ConditionGroupConditionNot::ConditionGroupConditionNot constructor
ConditionGroupConditionNot::DATAMEMEBERS_INTERFACE method
ConditionGroupConditionNot::Match method
ConditionGroupConditionOnly
ConditionGroupConditionOnly class
~ConditionGroupConditionOnly
ConditionGroupConditionOnly
DATAMEMEBERS_INTERFACE
Match
ConditionGroupConditionOnly::~ConditionGroupConditionOnly destructor
ConditionGroupConditionOnly::ConditionGroupConditionOnly constructor
ConditionGroupConditionOnly::DATAMEMEBERS_INTERFACE method
ConditionGroupConditionOnly::Match method
ConditionGroupConditionOr
ConditionGroupConditionOr class
~ConditionGroupConditionOr
ConditionGroupConditionOr
DATAMEMEBERS_INTERFACE
Match
ConditionGroupConditionOr::~ConditionGroupConditionOr destructor
ConditionGroupConditionOr::ConditionGroupConditionOr constructor
ConditionGroupConditionOr::DATAMEMEBERS_INTERFACE method
ConditionGroupConditionOr::Match method
ConditionNOT
ConditionNOT class
~ConditionNOT
ConditionNOT
DATAMEMEBERS_INTERFACE
GetLogical
Match
ConditionNOT::~ConditionNOT destructor
ConditionNOT::ConditionNOT constructor
ConditionNOT::DATAMEMEBERS_INTERFACE method
ConditionNOT::GetLogical method
ConditionNOT::Match method
ConditionOR
ConditionOR class
~ConditionOR
ConditionOR
DATAMEMEBERS_INTERFACE
GetLogical
Match
ConditionOR::~ConditionOR destructor
ConditionOR::ConditionOR constructor
ConditionOR::DATAMEMEBERS_INTERFACE method
ConditionOR::GetLogical method
ConditionOR::Match method
ConditionPrint
ConditionPrint class
~ConditionPrint
ConditionPrint
DATAMEMEBERS_INTERFACE
GetText
Match
SetText
TRACK_MEMBER
TRACK_PARAMETER_ENUM
ConditionPrint::~ConditionPrint destructor
ConditionPrint::ConditionPrint constructor
ConditionPrint::DATAMEMEBERS_INTERFACE method
ConditionPrint::GetText method
ConditionPrint::Match method
ConditionPrint::SetText method
ConditionPrint::TRACK_MEMBER method
ConditionPrint::TRACK_PARAMETER_ENUM method
ConditionRandFunc
ConditionRandom
ConditionRandom class
ConditionRandFunc
ConditionRandom
DATAMEMEBERS_INTERFACE
Match
SetRandFunc
sm_RandomNum
sm_RandomUsed
TRACK_PARAMETER
TRACK_PARAMETER_ENUM
ConditionRandom::ConditionRandFunc nested type
ConditionRandom::ConditionRandom constructor
ConditionRandom::DATAMEMEBERS_INTERFACE method
ConditionRandom::Match method
ConditionRandom::SetRandFunc method
ConditionRandom::sm_RandFunc
ConditionRandom::sm_RandFunc variable
ConditionRandom::sm_RandomNum
ConditionRandom::sm_RandomNum data member
ConditionRandom::sm_RandomNum variable
ConditionRandom::sm_RandomUsed
ConditionRandom::sm_RandomUsed data member
ConditionRandom::sm_RandomUsed variable
ConditionRandom::TRACK_PARAMETER method
ConditionRandom::TRACK_PARAMETER_ENUM method
ConditionTrue
ConditionTrue class
~ConditionTrue
ConditionTrue
DATAMEMEBERS_INTERFACE
Match
ConditionTrue::~ConditionTrue destructor
ConditionTrue::ConditionTrue constructor
ConditionTrue::DATAMEMEBERS_INTERFACE method
ConditionTrue::Match method
CORETASK_HPP
CORETASK_HPP macro
Create
CreateIArchive
CSubject
CSubject class
~CSubject
Attach
CSubject
Dettach
m_Observers
Notify
CSubject::~CSubject destructor
CSubject::Attach method
CSubject::CSubject constructor
CSubject::Dettach method
CSubject::m_Observers data member
CSubject::Notify method
D
DataMember
DataMember class
~DataMember
DataMember
DataMember
GetName
GetName
GetPfGroupActTracks
GetType
IsDefault
m_Name
m_WriteBuff
Read
Write
DataMember::~DataMember destructor
DataMember::DataMember constructor
DataMember::GetName method
DataMember::GetPfGroupActTracks method
DataMember::GetType method
DataMember::IsDefault method
DataMember::m_Name data member
DataMember::m_WriteBuff
DataMember::m_WriteBuff data member
DataMember::m_WriteBuff variable
DataMember::Read method
DataMember::Write method
DATAMEMBER_HPP
DATAMEMBER_HPP macro
DATAMEMEBERS_INTERFACE
DATAMEMEBERS_INTERFACE_NO_NAME
DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE
DebugActionContextCB
DECLARE_PLACE
DECLARE_TASK_POOL_FUNCTIONS
DECLARE_THREADED_PLACE
DeclareStruct
DecreaseIndent
DecRefCount
DegisterTrackFactorys
DeInit
DeInitStatic
Delete
DeleteChildActionNodes
DeleteCondition
DeleteSequencedTrack
DeleteTask
DeleteTrack
Dettach
DOUBLE_QUOTE
DOUBLE_QUOTE macro
DummyTask0
DummyTask1
DummyTask2
DumpTiming
DumpTimingRecursive
E
ENABLE_INGAME_ACT_TEXT_LOADING
ENABLE_INGAME_ACT_TEXT_LOADING macro
ENABLE_PF_TIMERS
ENABLE_PF_TIMERS macro
End
END_TASK
END_TASK macro
EndDebugTask
EndOfText
EndTask
EnumDataMember
EnumDataMember template
~EnumDataMember
EnumDataMember
GetEnum
IsDefault
SetEnum
EnumDataMember::~EnumDataMember destructor
EnumDataMember::EnumDataMember constructor
EnumDataMember::GetEnum method
EnumDataMember::IsDefault method
EnumDataMember::SetEnum method
EvalRemote
EvalRemoteTransition
Execute
ExecuteTask
ExecuteTask class
~ExecuteTask
Begin
End
ExecuteTask
GetTrack
Update
ExecuteTask::~ExecuteTask destructor
ExecuteTask::Begin method
ExecuteTask::End method
ExecuteTask::ExecuteTask constructor
ExecuteTask::GetTrack method
ExecuteTask::Update method
ExecuteTrack
ExecuteTrack class
~ExecuteTrack
DATAMEMEBERS_INTERFACE
ExecuteTrack
NewTask
ExecuteTrack::~ExecuteTrack destructor
ExecuteTrack::DATAMEMEBERS_INTERFACE method
ExecuteTrack::ExecuteTrack constructor
ExecuteTrack::NewTask method
F
Find
FindChildNode
FindFirstPlayable
FindRoot
FloatDataMember
FloatDataMember template
~FloatDataMember
FloatDataMember
GetFloat
GetMinMaxFloat
GetType
IsDefault
SetFloat
FloatDataMember::~FloatDataMember destructor
FloatDataMember::FloatDataMember constructor
FloatDataMember::GetFloat method
FloatDataMember::GetMinMaxFloat method
FloatDataMember::GetType method
FloatDataMember::IsDefault method
FloatDataMember::SetFloat method
ForceLoad
friend class ActionNode
friend class ActionNode friend
friend class ActionNodeLwRef
friend class ActionNodeLwRef friend
friend class ActionNodeReference
friend class ActionNodeReference friend
friend class ActionNodeTree
friend class ActionNodeTree friend
friend class ActionNodeTreeHandle
friend class ActionNodeTreeHandle friend
friend class atPtr<ActionNodeTreeHandle>
friend class atPtr<ActionNodeTreeHandle> friend
friend class pgStreamable<ActionNodeTree>
friend class pgStreamable<ActionNodeTree> friend
G
g_PrintChannelNames
g_PrintChannelNames variable
g_PrintChannelNamesNum
g_PrintChannelNamesNum variable
GameTaskManager
GameTaskManager class
~GameTaskManager
AddWidgets
AllocateTask
DECLARE_TASK_POOL_FUNCTIONS
DECLARE_TASK_POOL_FUNCTIONS
DeleteTask
DummyTask0
DummyTask1
DummyTask2
GameTaskManager
GetDummyTask
GetInstance
InitClass
m_CriticalSection
m_TaskPool0
m_TaskPool1
m_TaskPool2
ShutdownClass
sm_Instance
GameTaskManager::~GameTaskManager destructor
GameTaskManager::AddWidgets method
GameTaskManager::AllocateTask method
GameTaskManager::DECLARE_TASK_POOL_FUNCTIONS method
GameTaskManager::DeleteTask method
GameTaskManager::DummyTask0 nested type
GameTaskManager::DummyTask1 nested type
GameTaskManager::DummyTask2 nested type
GameTaskManager::GameTaskManager constructor
GameTaskManager::GetDummyTask method
GameTaskManager::GetInstance method
GameTaskManager::InitClass method
GameTaskManager::m_CriticalSection data member
GameTaskManager::m_TaskPool0 data member
GameTaskManager::m_TaskPool1 data member
GameTaskManager::m_TaskPool2 data member
GameTaskManager::ShutdownClass method
GameTaskManager::sm_Instance data member
gCanOutputFalseCond
gCanOutputFalseCond variable
gCanOutputTrueCond
gCanOutputTrueCond variable
gCNameLog
gCNameLog variable
gCNameTable
gCNameTable variable
gCNameTableLoaded
gCNameTableLoaded variable
gCollapseConditionGroupsToNewLogicPrimatives
gCollapseConditionGroupsToNewLogicPrimatives variable
gDebugLevel
gDebugLevel variable
gDebugOn
gDebugOn variable
Get
GetActionController
GetActionNode
GetActionNodeReference
GetActionNodeReferenceFullPath
GetActorName
GetArchiveFileRecord
GetArchiveObject
GetAverage
GetAverageTime
GetBeginBreakPoint
GetBool
GetBuffer
GetChild
GetChildCount
GetCNamePath
GetCondition
GetConditionCount
GetConditionFormat
GetConditionGroup
GetCondtionFormat
GetContext
GetControlContext
GetController
GetCount
GetCurrentNodePlayTime
GetCurrentPlayCount
GetCurrentPlayingNode
GetCurrentReadPosition
GetDataMember
GetDataMemberFormat
GetDebug
GetDebugBreakPoint
GetDictionary
GetDummyTask
GetDuration
GetEditPriority
GetEnableBreakPoints
GetEndBreakPoint
GetEnum
GetEnumName
GetFileName
GetFileRoot
GetFloat
GetFrameCount
GetFullPath
GetFullPathDebug
GetFullPathName
GetID
GetInstance
GetInt
GetLogical
GetMaster
GetMember
GetMessage
GetMinMaxFloat
GetMinMaxInt
GetMyContext
GetName
GetNameFullPath
GetNameFullPathDebug
GetNameHash
GetNextToken
GetNumConditions
GetNumElements
GetNumEnums
GetNumMembers
GetNumRefs
GetNumRegistered
GetNumRegisteredTracks
GetNumSequencedTracks
GetNumTracks
GetObject
GetParent
GetPathCRC
GetPathName
GetPfGroupActTracks
GetPFTimer
GetPlayHistory
GetPriority
GetQuotedString
GetRef
GetRefCount
GetReferenceFullPath
GetReferenceName
GetRegistered
GetRegisteredTrackName
GetRegisteredTrackType
GetRequestedNode
GetRoot
GetRorcChecksum
GetRorcVersion
GetRunningTaskRoot
GetSequencedTrack
GetStreamable
GetString
GetText
GetTime
GetTimeBegin
GetTimeEnd
GetTimer
GetTokenAsFloat
GetTokenAsInt
GetTokenString
GetTotal
GetTotalTime
GetTrack
GetTrackCount
GetTrackFormat
GetTrackRegistry
GetTrackType
GetTrackTypeStatic
GetType
GetTypeId
GetUpDateBreakPoint
GetVector2
GetVector3
GetWrittenLength
gEvalTaskNames
gEvalTaskNames variable
gEvaluatedTasks
gEvaluatedTasks variable
GroupDataMember
GroupDataMember template
~GroupDataMember
Add
Add
ChangePriority
Delete
Delete
GetCount
GetDataMember
GetDataMemberFormat
GroupDataMember
ReadAllElements
WriteElements
GroupDataMember::~GroupDataMember destructor
GroupDataMember::Add method
GroupDataMember::ChangePriority method
GroupDataMember::Delete method
GroupDataMember::GetCount method
GroupDataMember::GetDataMember method
GroupDataMember::GetDataMemberFormat method
GroupDataMember::GroupDataMember constructor
GroupDataMember::ReadAllElements method
GroupDataMember::WriteElements method
GroupDataMemberNoInterface
GroupDataMemberNoInterface template
GetType
GroupDataMemberNoInterface
GroupDataMemberNoInterface::GetType method
GroupDataMemberNoInterface::GroupDataMemberNoInterface constructor
H
HandleMessage
Hash
I
IArchive
IArchive class
~IArchive
IArchive
Write
IArchive::~IArchive destructor
IArchive::IArchive constructor
IArchive::Write method
IBoolDataMember
IBoolDataMember class
~IBoolDataMember
GetBool
GetType
IBoolDataMember
Read
SetBool
Write
IBoolDataMember::~IBoolDataMember destructor
IBoolDataMember::GetBool method
IBoolDataMember::GetType method
IBoolDataMember::IBoolDataMember constructor
IBoolDataMember::Read method
IBoolDataMember::SetBool method
IBoolDataMember::Write method
ICommandDataMember
ICommandDataMember class
Execute
GetType
ICommandDataMember
ICommandDataMember::Execute method
ICommandDataMember::GetType method
ICommandDataMember::ICommandDataMember constructor
iCurrentLevel
iCurrentLevel variable
IDataMembers
IDataMembers class
~IDataMembers
DeclareStruct
GetMember
GetNumMembers
IDataMembers
m_ChangedMember
Read
Reset
Write
IDataMembers::~IDataMembers destructor
IDataMembers::DeclareStruct method
IDataMembers::GetMember method
IDataMembers::GetNumMembers method
IDataMembers::IDataMembers constructor
IDataMembers::m_ChangedMember data member
IDataMembers::Read method
IDataMembers::Reset method
IDataMembers::Write method
IEnumDataMember
IEnumDataMember class
GetEnum
GetEnum
GetEnumName
GetNumEnums
GetType
IEnumDataMember
Read
SetEnum
Write
IEnumDataMember::GetEnum method
IEnumDataMember::GetEnumName method
IEnumDataMember::GetNumEnums method
IEnumDataMember::GetType method
IEnumDataMember::IEnumDataMember constructor
IEnumDataMember::Read method
IEnumDataMember::SetEnum method
IEnumDataMember::Write method
IFloatDataMember
IFloatDataMember class
GetFloat
GetMinMaxFloat
IFloatDataMember
Read
SetFloat
Write
IFloatDataMember::GetFloat method
IFloatDataMember::GetMinMaxFloat method
IFloatDataMember::IFloatDataMember constructor
IFloatDataMember::Read method
IFloatDataMember::SetFloat method
IFloatDataMember::Write method
IGroupDataMember
IGroupDataMember class
Add
Add
ChangePriority
Delete
Delete
GetCount
GetDataMember
GetDataMemberFormat
GetType
IGroupDataMember
Read
ReadAllElements
Write
WriteElements
IGroupDataMember::Add method
IGroupDataMember::ChangePriority method
IGroupDataMember::Delete method
IGroupDataMember::GetCount method
IGroupDataMember::GetDataMember method
IGroupDataMember::GetDataMemberFormat method
IGroupDataMember::GetType method
IGroupDataMember::IGroupDataMember constructor
IGroupDataMember::Read method
IGroupDataMember::ReadAllElements method
IGroupDataMember::Write method
IGroupDataMember::WriteElements method
IIntDataMember
IIntDataMember class
GetInt
GetMinMaxInt
GetType
IIntDataMember
Read
SetInt
Write
IIntDataMember::GetInt method
IIntDataMember::GetMinMaxInt method
IIntDataMember::GetType method
IIntDataMember::IIntDataMember constructor
IIntDataMember::Read method
IIntDataMember::SetInt method
IIntDataMember::Write method
IMPLEMENT_PLACE_INLINE
IMultiNodeReferenceTrack
IMultiNodeReferenceTrack class
GetActionNode
GetActionNodeReference
GetActionNodeReferenceFullPath
GetNumRefs
GetRef
GetTrackType
GetTrackTypeStatic
IMultiNodeReferenceTrack
IMultiNodeReferenceTrack
IsActionNodeReferenceNull
IsActionNodeResolved
IsActionNodeResolved
ResolveReference
SetActionNode
SetActionNodeParent
SetActionNodeReference
IMultiNodeReferenceTrack::GetActionNode method
IMultiNodeReferenceTrack::GetActionNodeReference method
IMultiNodeReferenceTrack::GetActionNodeReferenceFullPath method
IMultiNodeReferenceTrack::GetNumRefs method
IMultiNodeReferenceTrack::GetRef method
IMultiNodeReferenceTrack::GetTrackType method
IMultiNodeReferenceTrack::GetTrackTypeStatic method
IMultiNodeReferenceTrack::IMultiNodeReferenceTrack constructor
IMultiNodeReferenceTrack::IsActionNodeReferenceNull method
IMultiNodeReferenceTrack::IsActionNodeResolved method
IMultiNodeReferenceTrack::ResolveReference method
IMultiNodeReferenceTrack::SetActionNode method
IMultiNodeReferenceTrack::SetActionNodeParent method
IMultiNodeReferenceTrack::SetActionNodeReference method
IName class
~IName
GetName
GetName
IName::~IName destructor
IName::GetName method
INCLUDE_STRINGS
INCLUDE_STRINGS macro
IncreaseIndent
IncRefCount
Init
InitClass
initDebugOut
initDebugOut variable
InitStatic
INodeReferenceDataMember
INodeReferenceDataMember class
GetFullPath
GetType
INodeReferenceDataMember
IsResolved
INodeReferenceDataMember::GetFullPath method
INodeReferenceDataMember::GetType method
INodeReferenceDataMember::INodeReferenceDataMember constructor
INodeReferenceDataMember::IsResolved method
INodeReferenceTrack
INodeReferenceTrack class
GetTrackType
GetTrackTypeStatic
INodeReferenceTrack
INodeReferenceTrack
IsActionNodeResolved
ResolveReference
SetActionNodeParent
INodeReferenceTrack::GetTrackType method
INodeReferenceTrack::GetTrackTypeStatic method
INodeReferenceTrack::INodeReferenceTrack constructor
INodeReferenceTrack::IsActionNodeResolved method
INodeReferenceTrack::ResolveReference method
INodeReferenceTrack::SetActionNodeParent method
InstancedActionController class
~InstancedActionController
AddSequncedTrack
ClearSequencedTrack
clearSequencedTracks
DeleteSequencedTrack
GetNumSequencedTracks
GetSequencedTrack
m_SequencedTracks
InstancedActionController::~InstancedActionController destructor
InstancedActionController::AddSequncedTrack method
InstancedActionController::ClearSequencedTrack method
InstancedActionController::clearSequencedTracks method
InstancedActionController::DeleteSequencedTrack method
InstancedActionController::GetNumSequencedTracks method
InstancedActionController::GetSequencedTrack method
InstancedActionController::m_SequencedTracks data member
IntDataMember
IntDataMember template
~IntDataMember
GetInt
GetMinMaxInt
IntDataMember
IsDefault
SetInt
IntDataMember::~IntDataMember destructor
IntDataMember::GetInt method
IntDataMember::GetMinMaxInt method
IntDataMember::IntDataMember constructor
IntDataMember::IsDefault method
IntDataMember::SetInt method
IObserver class
~IObserver
HandleMessage
Update
UpdateDetach
IObserver::~IObserver destructor
IObserver::HandleMessage method
IObserver::Update method
IObserver::UpdateDetach method
IsActionNodeReferenceNull
IsActionNodeResolved
IsBusy
IsDefault
IsDeleted
IsDescendantOf
IsFileChangedOnDisk
IsFileWriteAble
IsNull
IsParsingFile
IsRemoteCondition
IsResident
IsResolved
IsStreamingOrResident
IStringDataMember
IStringDataMember class
GetString
GetType
IStringDataMember
Read
SetString
Write
IStringDataMember::GetString method
IStringDataMember::GetType method
IStringDataMember::IStringDataMember constructor
IStringDataMember::Read method
IStringDataMember::SetString method
IStringDataMember::Write method
IsValid
ITrackFactory
ITrackFactory class
~ITrackFactory
GetRorcChecksum
GetTrackType
ITrackFactory
NewTrack
Place
SetTypeId
ITrackFactory::~ITrackFactory destructor
ITrackFactory::GetRorcChecksum method
ITrackFactory::GetTrackType method
ITrackFactory::ITrackFactory constructor
ITrackFactory::NewTrack method
ITrackFactory::Place method
ITrackFactory::SetTypeId method
IVector2DataMember
IVector2DataMember class
GetVector2
IVector2DataMember
Read
SetVector2
Write
IVector2DataMember::GetVector2 method
IVector2DataMember::IVector2DataMember constructor
IVector2DataMember::Read method
IVector2DataMember::SetVector2 method
IVector2DataMember::Write method
IVector3DataMember
IVector3DataMember class
GetVector3
IVector3DataMember
Read
SetVector3
Write
IVector3DataMember::GetVector3 method
IVector3DataMember::IVector3DataMember constructor
IVector3DataMember::Read method
IVector3DataMember::SetVector3 method
IVector3DataMember::Write method
K
Kill
L
Load
Log
M
m_ActionController
m_ActionNodeRef
m_Actor
m_AlreadyBreaked
m_bUpdatedOnce
m_bViewExpanded
m_ChangedMember
m_childNodes
m_ConditionalStringName
m_ConditionalStringNameSize
m_Conditions
m_Context
m_Count
m_CriticalSection
m_Ctx
m_CurrentAction
m_CurrentMatchingNode
m_Debug
m_DebugContextClBk
m_Depth
m_Entity
m_FileRoot
m_FrameCount
m_GlobalEditPriority
m_Latched
m_latchedPlayable
m_LatchTime
m_Master
m_Name
m_nameFullPath
m_NextRunningTask
m_Observers
m_OnLoad
m_OnUnload
m_Op
m_OpeningBranch
m_Pad
m_parent
m_PathCRC
m_PrevNode
m_referenceName
m_referenceNode
m_Root
m_SequencedTracks
m_StartTime
m_TaskPool0
m_TaskPool1
m_TaskPool2
m_Time
m_TimeBegin
m_TimeEnd
m_TimerId
m_tracks
m_Type
m_WriteBuff
Match
MatchCurrentToken
MatchCurrentTokenCaseInsensitive
MAX_EVAL
MAX_EVAL variable
N
NeedToSpecialParseQuotedString
NewTask
NewTrack
NodeReferenceDataMember
NodeReferenceDataMember template
~NodeReferenceDataMember
GetFullPath
GetString
IsDefault
IsResolved
NodeReferenceDataMember
SetString
NodeReferenceDataMember::~NodeReferenceDataMember destructor
NodeReferenceDataMember::GetFullPath method
NodeReferenceDataMember::GetString method
NodeReferenceDataMember::IsDefault method
NodeReferenceDataMember::IsResolved method
NodeReferenceDataMember::NodeReferenceDataMember constructor
NodeReferenceDataMember::SetString method
NodeReferenceTrack
NodeReferenceTrack class
~NodeReferenceTrack
DeclareStruct
GetActionNode
GetActionNodeReference
GetActionNodeReferenceFullPath
IsActionNodeReferenceNull
IsActionNodeResolved
IsActionNodeResolved
m_ActionNodeRef
NodeReferenceTrack
NodeReferenceTrack
ResolveReference
SetActionNode
SetActionNodeParent
SetActionNodeReference
NodeReferenceTrack::~NodeReferenceTrack destructor
NodeReferenceTrack::DeclareStruct method
NodeReferenceTrack::GetActionNode method
NodeReferenceTrack::GetActionNodeReference method
NodeReferenceTrack::GetActionNodeReferenceFullPath method
NodeReferenceTrack::IsActionNodeReferenceNull method
NodeReferenceTrack::IsActionNodeResolved method
NodeReferenceTrack::m_ActionNodeRef data member
NodeReferenceTrack::NodeReferenceTrack constructor
NodeReferenceTrack::ResolveReference method
NodeReferenceTrack::SetActionNode method
NodeReferenceTrack::SetActionNodeParent method
NodeReferenceTrack::SetActionNodeReference method
Notify
NOTRAW_ACT_FILE_SUPPORT_ONLY
NOTRAW_ACT_FILE_SUPPORT_ONLY macro
NOTTOOL_AND_ASSERT_ONLY
NOTTOOL_AND_ASSERT_ONLY macro
NullOp
O
OnACTError
OnEndTask
OnNodeCleanup
OnPlay
OnPlayTracks
OnSequence
OnStop
OnStopPostTaskEnd
OnTreeUnload
OperateAllNodes
OperateChildOnNodes
OpportunityRandomLatchTask
OpportunityRandomLatchTask class
~OpportunityRandomLatchTask
AcquireLatchTime
GetTrack
OpportunityRandomLatchTask
OpportunityRandomLatchTask::~OpportunityRandomLatchTask destructor
OpportunityRandomLatchTask::AcquireLatchTime method
OpportunityRandomLatchTask::GetTrack method
OpportunityRandomLatchTask::OpportunityRandomLatchTask constructor
OpportunityRandomLatchTrack
OpportunityRandomLatchTrack class
~OpportunityRandomLatchTrack
DATAMEMEBERS_INTERFACE
NewTask
OpportunityRandomLatchTrack
TRACK_PADDING
TRACK_PARAMETER
OpportunityRandomLatchTrack::~OpportunityRandomLatchTrack destructor
OpportunityRandomLatchTrack::DATAMEMEBERS_INTERFACE method
OpportunityRandomLatchTrack::NewTask method
OpportunityRandomLatchTrack::OpportunityRandomLatchTrack constructor
OpportunityRandomLatchTrack::TRACK_PADDING method
OpportunityRandomLatchTrack::TRACK_PARAMETER method
OpportunityTask
OpportunityTask class
~OpportunityTask
AcquireLatchTime
Begin
End
GetTrack
m_AlreadyBreaked
m_Context
m_Latched
m_latchedPlayable
m_LatchTime
OpportunityTask
Update
OpportunityTask::~OpportunityTask destructor
OpportunityTask::AcquireLatchTime method
OpportunityTask::Begin method
OpportunityTask::End method
OpportunityTask::GetTrack method
OpportunityTask::m_AlreadyBreaked data member
OpportunityTask::m_Context data member
OpportunityTask::m_Latched data member
OpportunityTask::m_latchedPlayable data member
OpportunityTask::m_LatchTime data member
OpportunityTask::OpportunityTask constructor
OpportunityTask::Update method
OpportunityTrack
OpportunityTrack class
~OpportunityTrack
AddCondition
AddCondition
ChangeConditionPriority
DATAMEMEBERS_INTERFACE
DeleteCondition
GetCondition
GetConditionCount
GetConditionFormat
GetConditionGroup
NewTask
OpportunityTrack
ReadConditionGroup
TRACK_MEMBER
TRACK_PARAMETER
TRACK_PARAMETER
WriteCondition
OpportunityTrack::~OpportunityTrack destructor
OpportunityTrack::AddCondition method
OpportunityTrack::ChangeConditionPriority method
OpportunityTrack::DATAMEMEBERS_INTERFACE method
OpportunityTrack::DeleteCondition method
OpportunityTrack::GetCondition method
OpportunityTrack::GetConditionCount method
OpportunityTrack::GetConditionFormat method
OpportunityTrack::GetConditionGroup method
OpportunityTrack::NewTask method
OpportunityTrack::OpportunityTrack constructor
OpportunityTrack::ReadConditionGroup method
OpportunityTrack::TRACK_MEMBER method
OpportunityTrack::TRACK_PARAMETER method
OpportunityTrack::WriteCondition method
Out
Overview
P
PagedIn
pGroupPtr
pGroupPtr variable
Place
Play
PlayRemote
PlayTracks
PopReadPosition
PreUpdate
PrintAllNodes
PrintTask
PrintTask class
~PrintTask
Begin
End
GetTrack
PrintTask
Update
PrintTask::~PrintTask destructor
PrintTask::Begin method
PrintTask::End method
PrintTask::GetTrack method
PrintTask::PrintTask constructor
PrintTask::Update method
PrintTrack
PrintTrack class
~PrintTrack
AddWidgets
DATAMEMEBERS_INTERFACE
GetText
NewTask
PrintTrack
SetText
ShouldPrint
sm_PrintChannelEnabled
TRACK_MEMBER
TRACK_PARAMETER
TRACK_PARAMETER_ENUM
PrintTrack::~PrintTrack destructor
PrintTrack::AddWidgets method
PrintTrack::DATAMEMEBERS_INTERFACE method
PrintTrack::GetText method
PrintTrack::NewTask method
PrintTrack::PrintTrack constructor
PrintTrack::SetText method
PrintTrack::ShouldPrint method
PrintTrack::sm_PrintChannelEnabled
PrintTrack::sm_PrintChannelEnabled data member
PrintTrack::sm_PrintChannelEnabled variable
PrintTrack::TRACK_MEMBER method
PrintTrack::TRACK_PARAMETER method
PrintTrack::TRACK_PARAMETER_ENUM method
PushReadPosition
R
rage
rage namespace
rage::!=
rage::!= function
rage::==
rage::== function
rage::ACCELERATION_DATAMEMBER
rage::ACCELERATION_DATAMEMBER macro
rage::ACCELERATION_DATAMEMBER_SIMPLE
rage::ACCELERATION_DATAMEMBER_SIMPLE macro
rage::ACCELERATION_MIN_MAX_DATAMEMBER
rage::ACCELERATION_MIN_MAX_DATAMEMBER macro
rage::ACT_DEBUG_CODE
rage::ACT_DEBUG_CODE macro
rage::ACT_DEBUG_DEF
rage::ACT_DEBUG_DEF macro
rage::actDebug
rage::actDebug namespace
rage::actDebug::CanOutputDebug
rage::actDebug::CanOutputDebug function
rage::actDebug::ExtractPathAndNodeName
rage::actDebug::ExtractPathAndNodeName function
rage::actDebug::GetActDebugLevel
rage::actDebug::GetActDebugLevel function
rage::actDebug::OutputFullNameEumeration
rage::actDebug::OutputFullNameEumeration function
rage::actDebug::SetConditionFilter
rage::actDebug::SetConditionFilter function
rage::ActionCallbackContext
rage::ActionCallbackContext::~ActionCallbackContext
rage::ActionCallbackContext::ActionCallbackContext
rage::ActionCallbackContext::Bind
rage::ActionCallbackContext::GetController
rage::ActionCallbackContext::OnEndTask
rage::ActionCallbackContext::OnNodeCleanup
rage::ActionCallbackContext::OnPlay
rage::ActionCallbackContext::OnPlayTracks
rage::ActionCallbackContext::OnSequence
rage::ActionCallbackContext::OnStop
rage::ActionCallbackContext::Update
rage::ActionContext
rage::ActionContext::~ActionContext
rage::ActionContext::ActionContext
rage::ActionContext::Clone
rage::ActionContext::DebugActionContextCB
rage::ActionContext::GetActorName
rage::ActionContext::m_ActionController
rage::ActionContext::m_Actor
rage::ActionContext::m_CurrentAction
rage::ActionContext::m_CurrentMatchingNode
rage::ActionContext::m_Debug
rage::ActionContext::m_DebugContextClBk
rage::ActionContext::m_Depth
rage::ActionContext::m_Entity
rage::ActionContext::m_OpeningBranch
rage::ActionContext::NullOp
rage::ActionContext::OnACTError
rage::ActionContext::OnStopPostTaskEnd
rage::ActionContext::PreUpdate
rage::ActionContext::ResetDebug
rage::ActionContext::VerifyNewNode
rage::ActionContextDebugDepth
rage::ActionContextDebugDepth::~ActionContextDebugDepth
rage::ActionContextDebugDepth::ActionContextDebugDepth
rage::ActionContextDebugDepth::m_Ctx
rage::ActionContextDebugDepth::m_Op
rage::ActionContextDebugDepth::m_PrevNode
rage::ActionController
rage::ActionController::~ActionController
rage::ActionController::ActionController
rage::ActionController::BeginDebugTask
rage::ActionController::clearAll
rage::ActionController::EndDebugTask
rage::ActionController::EndTask
rage::ActionController::GetBeginBreakPoint
rage::ActionController::GetContext
rage::ActionController::GetControlContext
rage::ActionController::GetCurrentNodePlayTime
rage::ActionController::GetCurrentPlayCount
rage::ActionController::GetCurrentPlayingNode
rage::ActionController::GetDebug
rage::ActionController::GetEndBreakPoint
rage::ActionController::GetPlayHistory
rage::ActionController::GetRequestedNode
rage::ActionController::GetRunningTaskRoot
rage::ActionController::GetUpDateBreakPoint
rage::ActionController::IsBusy
rage::ActionController::Play
rage::ActionController::PlayRemote
rage::ActionController::PlayTracks
rage::ActionController::RemoveTask
rage::ActionController::s_NoOfTaskUpdates
rage::ActionController::Sequence
rage::ActionController::SetBeginBreakPoint
rage::ActionController::SetContext
rage::ActionController::SetControlContext
rage::ActionController::SetDebug
rage::ActionController::SetEndBreakPoint
rage::ActionController::SetRequestedNode
rage::ActionController::SetUpDateBreakPoint
rage::ActionController::StartSequencedTracks
rage::ActionController::Stop
rage::ActionController::TRACKMSG
rage::ActionController::Update
rage::ActionController::UpdateDebugTask
rage::ActionController::UpdateTasks
rage::ActionController::UpdateTasksTimeEnd
rage::ActionController::UpdateWithKeepAlive
rage::ActionIntention
rage::ActionIntention::~ActionIntention
rage::ActionIntention::ActionIntention
rage::ActionIntention::Clear
rage::ActionIntention::Update
rage::ActionNode
rage::ActionNode::~ActionNode
rage::ActionNode::ActionNode
rage::ActionNode::ActionTreeTaskParams
rage::ActionNode::ActionTreeTaskParams struct
rage::ActionNode::AddBranch
rage::ActionNode::AddChildActionNode
rage::ActionNode::AddChildActionNodes
rage::ActionNode::AddCondition
rage::ActionNode::AddRoot
rage::ActionNode::AddStuff
rage::ActionNode::AddTrack
rage::ActionNode::AddTracksBank
rage::ActionNode::BalanceWeights
rage::ActionNode::ChangeChildPriority
rage::ActionNode::ChangeConditionPriority
rage::ActionNode::ChangePriority
rage::ActionNode::ChangeTrackPriority
rage::ActionNode::ClearChildNodes
rage::ActionNode::ClearRoots
rage::ActionNode::Create
rage::ActionNode::CreateIArchive
rage::ActionNode::DATAMEMEBERS_INTERFACE_NO_NAME
rage::ActionNode::DeInit
rage::ActionNode::DeleteChildActionNodes
rage::ActionNode::DeleteCondition
rage::ActionNode::DeleteTrack
rage::ActionNode::DumpTiming
rage::ActionNode::DumpTimingRecursive
rage::ActionNode::EvalRemote
rage::ActionNode::EvalRemoteTransition
rage::ActionNode::Find
rage::ActionNode::FindChildNode
rage::ActionNode::FindFirstPlayable
rage::ActionNode::FindRoot
rage::ActionNode::GetChild
rage::ActionNode::GetChildCount
rage::ActionNode::GetCNamePath
rage::ActionNode::GetCondition
rage::ActionNode::GetConditionCount
rage::ActionNode::GetConditionGroup
rage::ActionNode::GetCondtionFormat
rage::ActionNode::GetFileRoot
rage::ActionNode::GetName
rage::ActionNode::GetNameFullPath
rage::ActionNode::GetNameFullPathDebug
rage::ActionNode::GetParent
rage::ActionNode::GetPathCRC
rage::ActionNode::GetPriority
rage::ActionNode::GetRefCount
rage::ActionNode::GetRoot
rage::ActionNode::GetTrack
rage::ActionNode::GetTrackCount
rage::ActionNode::GetTrackFormat
rage::ActionNode::GetType
rage::ActionNode::IncRefCount
rage::ActionNode::Init
rage::ActionNode::IsDescendantOf
rage::ActionNode::Load
rage::ActionNode::m_bUpdatedOnce
rage::ActionNode::m_bViewExpanded
rage::ActionNode::m_childNodes
rage::ActionNode::m_FileRoot
rage::ActionNode::m_GlobalEditPriority
rage::ActionNode::m_OnLoad
rage::ActionNode::m_OnUnload
rage::ActionNode::m_Pad
rage::ActionNode::m_parent
rage::ActionNode::m_PathCRC
rage::ActionNode::m_Root
rage::ActionNode::m_Type
rage::ActionNode::Match
rage::ActionNode::OnTreeUnload
rage::ActionNode::OperateAllNodes
rage::ActionNode::OperateChildOnNodes
rage::ActionNode::PrintAllNodes
rage::ActionNode::ReadConditionGroup
rage::ActionNode::RecursSetFileRoots
rage::ActionNode::RemoveChildActionNode
rage::ActionNode::ReserveTracks
rage::ActionNode::ResetTiming
rage::ActionNode::ResetTimingRecursive
rage::ActionNode::ResolveAllTrackReferences
rage::ActionNode::ResolveAllWeights
rage::ActionNode::ResolveTrackReferences
rage::ActionNode::ResolveWeights
rage::ActionNode::RORC_VERSION
rage::ActionNode::SetOnLoad
rage::ActionNode::SetOnUnload
rage::ActionNode::SetParent
rage::ActionNode::sm_ActFullPath
rage::ActionNode::sm_ActPath
rage::ActionNode::sm_OnTreeUnloadCallback
rage::ActionNode::sm_PostLoadCallback
rage::ActionNode::sm_RscFirstPass
rage::ActionNode::TaskLoadActionNode
rage::ActionNode::TokenName
rage::ActionNode::TRACK_PARAMETER_STRING
rage::ActionNode::UnLoad
rage::ActionNode::UnLoadAll
rage::ActionNode::Write
rage::ActionNode::writeBegin
rage::ActionNode::writeChildren
rage::ActionNode::writeComment
rage::ActionNode::WriteCondition
rage::ActionNode::writeConditions
rage::ActionNode::writeEnd
rage::ActionNode::writeTracks
rage::ActionNodeBank
rage::ActionNodeBank::~ActionNodeBank
rage::ActionNodeBank::ActionNodeBank
rage::ActionNodeBank::DATAMEMEBERS_INTERFACE_NO_NAME
rage::ActionNodeBank::Match
rage::ActionNodeBank::ResolveWeights
rage::ActionNodeBank::TokenName
rage::ActionNodeDebugName
rage::ActionNodeDebugName::()
rage::ActionNodeDebugName::ActionNodeDebugName
rage::ActionNodeDebugName::m_Name
rage::ActionNodeFileReference
rage::ActionNodeFileReference::~ActionNodeFileReference
rage::ActionNodeFileReference::ActionNodeFileReference
rage::ActionNodeFileReference::DATAMEMEBERS_INTERFACE_NO_NAME
rage::ActionNodeFileReference::GetArchiveFileRecord
rage::ActionNodeFileReference::GetFileName
rage::ActionNodeFileReference::GetFullPathName
rage::ActionNodeFileReference::GetPathName
rage::ActionNodeFileReference::Read
rage::ActionNodeFileReference::ReadFile
rage::ActionNodeFileReference::RecursSetFileRoots
rage::ActionNodeFileReference::SetFileName
rage::ActionNodeFileReference::SetFullPathName
rage::ActionNodeFileReference::SetPathName
rage::ActionNodeFileReference::TokenName
rage::ActionNodeFileReference::Write
rage::ActionNodeImplementation
rage::ActionNodeImplementation::~ActionNodeImplementation
rage::ActionNodeImplementation::ActionNodeImplementation
rage::ActionNodeImplementation::AddCondition
rage::ActionNodeImplementation::AddTrack
rage::ActionNodeImplementation::ChangeConditionPriority
rage::ActionNodeImplementation::ChangeTrackPriority
rage::ActionNodeImplementation::DATAMEMEBERS_INTERFACE_NO_NAME
rage::ActionNodeImplementation::DeleteCondition
rage::ActionNodeImplementation::DeleteTrack
rage::ActionNodeImplementation::GetCondition
rage::ActionNodeImplementation::GetConditionCount
rage::ActionNodeImplementation::GetConditionGroup
rage::ActionNodeImplementation::GetCondtionFormat
rage::ActionNodeImplementation::GetName
rage::ActionNodeImplementation::GetTrack
rage::ActionNodeImplementation::GetTrackCount
rage::ActionNodeImplementation::GetTrackFormat
rage::ActionNodeImplementation::m_Conditions
rage::ActionNodeImplementation::m_Name
rage::ActionNodeImplementation::m_tracks
rage::ActionNodeImplementation::ReadConditionGroup
rage::ActionNodeImplementation::ReserveTracks
rage::ActionNodeImplementation::WriteCondition
rage::ActionNodeLwRef
rage::ActionNodeLwRef::~ActionNodeLwRef
rage::ActionNodeLwRef::ActionNodeLwRef
rage::ActionNodeLwRef::DeclareStruct
rage::ActionNodeLwRef::GetActionNode
rage::ActionNodeLwRef::IMPLEMENT_PLACE_INLINE
rage::ActionNodeLwRef::IsNull
rage::ActionNodeLwRef::SetActionNode
rage::ActionNodeLwRef::SetParent
rage::ActionNodeLwRef::SetReferenceName
rage::ActionNodePlayable
rage::ActionNodePlayable::~ActionNodePlayable
rage::ActionNodePlayable::ActionNodePlayable
rage::ActionNodePlayable::AddStuff
rage::ActionNodePlayable::AddTrack
rage::ActionNodePlayable::DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE
rage::ActionNodePlayable::DECLARE_PLACE
rage::ActionNodePlayable::DeclareStruct
rage::ActionNodePlayable::GetEditPriority
rage::ActionNodePlayable::Match
rage::ActionNodePlayable::SetEditPriority
rage::ActionNodePlayable::TokenName
rage::ActionNodePlayable::Update
rage::ActionNodePlayable::UpdateDetach
rage::ActionNodePlayable::Write
rage::ActionNodeReference
rage::ActionNodeReference::~ActionNodeReference
rage::ActionNodeReference::ActionNodeReference
rage::ActionNodeReference::AddCondition
rage::ActionNodeReference::AddTrack
rage::ActionNodeReference::DATAMEMEBERS_INTERFACE_NO_NAME
rage::ActionNodeReference::DeleteCondition
rage::ActionNodeReference::GetActionNode
rage::ActionNodeReference::GetChild
rage::ActionNodeReference::GetChildCount
rage::ActionNodeReference::GetCondition
rage::ActionNodeReference::GetConditionCount
rage::ActionNodeReference::GetConditionGroup
rage::ActionNodeReference::GetCondtionFormat
rage::ActionNodeReference::GetName
rage::ActionNodeReference::GetReferenceFullPath
rage::ActionNodeReference::GetReferenceName
rage::ActionNodeReference::GetTrack
rage::ActionNodeReference::GetTrackCount
rage::ActionNodeReference::GetTrackFormat
rage::ActionNodeReference::IsNull
rage::ActionNodeReference::m_nameFullPath
rage::ActionNodeReference::m_referenceName
rage::ActionNodeReference::m_referenceNode
rage::ActionNodeReference::Match
rage::ActionNodeReference::ReadConditionGroup
rage::ActionNodeReference::ReserveTracks
rage::ActionNodeReference::ResolveReference
rage::ActionNodeReference::SetActionNode
rage::ActionNodeReference::SetReferenceName
rage::ActionNodeReference::WriteCondition
rage::ActionNodeTree
rage::ActionNodeTree::~ActionNodeTree
rage::ActionNodeTree::ActionNodeTree
rage::ActionNodeTree::DECLARE_PLACE
rage::ActionNodeTree::DECLARE_THREADED_PLACE
rage::ActionNodeTree::DeclareStruct
rage::ActionNodeTree::GetRoot
rage::ActionNodeTree::GetRorcVersion
rage::ActionNodeTree::ResolveReferences
rage::ActionNodeTree::SetRoot
rage::ActionNodeTreeHandle
rage::ActionNodeTreeHandle::AddRef
rage::ActionNodeTreeHandle::Cleanup
rage::ActionNodeTreeHandle::DecRefCount
rage::ActionNodeTreeHandle::ForceLoad
rage::ActionNodeTreeHandle::Get
rage::ActionNodeTreeHandle::GetName
rage::ActionNodeTreeHandle::GetObject
rage::ActionNodeTreeHandle::GetRefCount
rage::ActionNodeTreeHandle::GetRoot
rage::ActionNodeTreeHandle::GetStreamable
rage::ActionNodeTreeHandle::IncRefCount
rage::ActionNodeTreeHandle::IsDeleted
rage::ActionNodeTreeHandle::IsResident
rage::ActionNodeTreeHandle::IsStreamingOrResident
rage::ActionNodeTreeHandle::IsValid
rage::ActionNodeTreeHandle::Kill
rage::ActionNodeTreeHandle::PagedIn
rage::ActionNodeTreeHandle::SetMap
rage::ActionNodeTreeHandle::SetStreamingPriority
rage::ActionNodeTreeHandle::sm_LoadFromResources
rage::ActionNodeTreePtr
rage::ActionNodeTreePtr type
rage::ActionNodeUnresolvedRef
rage::ActionNodeUnresolvedRef::ActionNodeUnresolvedRef
rage::ActionNodeUnresolvedRef::DECLARE_PLACE
rage::ActionNodeUnresolvedRef::DeclareStruct
rage::ACTIONTREE_CNAME_USE_ATSTRINGHASH
rage::ACTIONTREE_CNAME_USE_ATSTRINGHASH macro
rage::ACTIONTREE_CNAME_USE_HASH_ASM
rage::ACTIONTREE_CNAME_USE_HASH_ASM macro
rage::ActionTreeLog
rage::ActionTreeLog::GetInstance
rage::ActionTreeLog::GetMessage
rage::ActionTreeLog::Log
rage::ActionTreeLog::Warn
rage::ActionVistorCallBack
rage::ActionVistorCallBack type
rage::actTreeDebug
rage::actTreeDebug macro
rage::actTreeDebugOut
rage::actTreeDebugOut::actTreeDebugOut
rage::actTreeDebugOut::GetRef
rage::actTreeDebugOut::Out
rage::actTreeDebugPop
rage::actTreeDebugPop macro
rage::actTreeDebugPush
rage::actTreeDebugPush macro
rage::ALL_ACTIONTREE_TRACKS
rage::ALL_ACTIONTREE_TRACKS macro
rage::ANGLE_DATAMEMBER
rage::ANGLE_DATAMEMBER macro
rage::ANGLE_DATAMEMBER_SIMPLE
rage::ANGLE_DATAMEMBER_SIMPLE macro
rage::ANGLE_MIN_MAX_DATAMEMBER
rage::ANGLE_MIN_MAX_DATAMEMBER macro
rage::ArchiveFileRecord
rage::ArchiveFileRecord::~ArchiveFileRecord
rage::ArchiveFileRecord::ArchiveFileRecord
rage::ArchiveFileRecord::GetArchiveObject
rage::ArchiveFileRecord::GetFileName
rage::ArchiveFileRecord::GetFullPathName
rage::ArchiveFileRecord::GetPathName
rage::ArchiveFileRecord::Init
rage::ArchiveFileRecord::IsFileChangedOnDisk
rage::ArchiveFileRecord::IsFileWriteAble
rage::ArchiveFileRecord::ReadFromFile
rage::ArchiveFileRecord::SetArchiveObject
rage::ArchiveFileRecord::SetFactoryIArchive
rage::ArchiveFileRecord::SetFileName
rage::ArchiveFileRecord::SetFullPathName
rage::ArchiveFileRecord::SetPathName
rage::ArchiveFileRecord::WriteToFile
rage::ATask
rage::ATask::~ATask
rage::ATask::ATask
rage::ATask::Begin
rage::ATask::End
rage::ATask::GetActionController
rage::ATask::GetMyContext
rage::ATask::GetTrack
rage::ATask::m_NextRunningTask
rage::ATask::m_TimeEnd
rage::ATask::Update
rage::BEGIN_DATAMEMBERS
rage::BEGIN_DATAMEMBERS macro
rage::BEGIN_DATAMEMBERS_NO_BREAKPOINT
rage::BEGIN_DATAMEMBERS_NO_BREAKPOINT macro
rage::BEGIN_DATAMEMBERS_NO_MEMBERS
rage::BEGIN_DATAMEMBERS_NO_MEMBERS macro
rage::BEGIN_DATAMEMBERS_NO_MEMBERS_NO_NAME
rage::BEGIN_DATAMEMBERS_NO_MEMBERS_NO_NAME macro
rage::BEGIN_DATAMEMBERS_NO_NAME
rage::BEGIN_DATAMEMBERS_NO_NAME macro
rage::BEGIN_DATAMEMBERS_NOT_TRACK
rage::BEGIN_DATAMEMBERS_NOT_TRACK macro
rage::BOOL_DATAMEMBER
rage::BOOL_DATAMEMBER macro
rage::BOOL_DATAMEMBER_SIMPLE
rage::BOOL_DATAMEMBER_SIMPLE macro
rage::BoolDataMember
rage::BoolDataMember::~BoolDataMember
rage::BoolDataMember::BoolDataMember
rage::BoolDataMember::GetBool
rage::BoolDataMember::IsDefault
rage::BoolDataMember::Set_GetFunction
rage::BoolDataMember::SetBool
rage::CBasicString
rage::CBasicString::~CBasicString
rage::CBasicString::=
rage::CBasicString::==
rage::CBasicString::CBasicString
rage::CBasicString::DECLARE_PLACE
rage::CBasicString::DeclareStruct
rage::CBasicString::GetString
rage::CBasicString::SetString
rage::CFastNamePath
rage::CFastNamePath::CFastNamePath
rage::CFastNamePath::GetNameHash
rage::CFastNamePath::GetNumElements
rage::CFastNamePath::SetPath
rage::CName
rage::CName::~CName
rage::CName::=
rage::CName::==
rage::CName::CName
rage::CName::DECLARE_PLACE
rage::CName::DeclareStruct
rage::CName::GetID
rage::CName::GetString
rage::CName::Hash
rage::CName::SetID
rage::CName::SetString
rage::CNamePath
rage::CNamePath::CatName
rage::CNamePath::CatNameID
rage::CNamePath::CNamePath
rage::CNamePath::DECLARE_PLACE
rage::CNamePath::DeclareStruct
rage::CNamePath::DeInitStatic
rage::CNamePath::GetFullPathDebug
rage::CNamePath::GetName
rage::CNamePath::GetNumElements
rage::CNamePath::InitStatic
rage::CNamePath::s_CNameTraverseDown
rage::CNamePath::s_CNameTraverseUp
rage::CNamePath::SetPath
rage::COMMAND_DATAMEMBER
rage::COMMAND_DATAMEMBER macro
rage::COMMAND_DATAMEMBER_SIMPLE
rage::COMMAND_DATAMEMBER_SIMPLE macro
rage::CommandDataMember
rage::CommandDataMember::~CommandDataMember
rage::CommandDataMember::CommandDataMember
rage::CommandDataMember::Execute
rage::CommandDataMember::GetString
rage::CommandDataMember::SetString
rage::COMMENT_DATAMEMBER
rage::COMMENT_DATAMEMBER macro
rage::condEKG
rage::condEKG namespace
rage::condEKG::EXT_PF_GROUP
rage::condEKG::EXT_PF_GROUP function
rage::condEKG::PF_GROUP
rage::condEKG::PF_GROUP function
rage::condEKG::PF_LINK
rage::condEKG::PF_LINK function
rage::condEKG::PF_PAGE
rage::condEKG::PF_PAGE function
rage::condEKG::PF_TIMER
rage::condEKG::PF_TIMER function
rage::condEKG::PFPAGELINK_ACTTRACKS
rage::condEKG::PFPAGELINK_ACTTRACKS function
rage::Condition
rage::Condition::~Condition
rage::Condition::Condition
rage::Condition::Create
rage::Condition::DECLARE_PLACE
rage::Condition::DeclareStruct
rage::Condition::DeInit
rage::Condition::EvalRemote
rage::Condition::GetLogical
rage::Condition::GetNumConditions
rage::Condition::GetNumRegistered
rage::Condition::GetPFTimer
rage::Condition::GetRegistered
rage::Condition::GetTrackRegistry
rage::Condition::Init
rage::Condition::IsRemoteCondition
rage::Condition::Logical
rage::Condition::Logical enumeration
rage::Condition::Match
rage::Condition::NewTask
rage::Condition::RORC_VERSION
rage::ConditionActionNodePlayTime
rage::ConditionActionNodePlayTime::~ConditionActionNodePlayTime
rage::ConditionActionNodePlayTime::ConditionActionNodePlayTime
rage::ConditionActionNodePlayTime::DATAMEMEBERS_INTERFACE
rage::ConditionActionNodePlayTime::Match
rage::ConditionActionNodePlayTime::TRACK_PARAMETER
rage::Conditional
rage::Conditional::CompareFloat
rage::Conditional::CompareInt
rage::Conditional::m_ConditionalStringName
rage::Conditional::m_ConditionalStringNameSize
rage::Conditional::Operators
rage::Conditional::Operators enumeration
rage::ConditionFalse
rage::ConditionFalse::~ConditionFalse
rage::ConditionFalse::ConditionFalse
rage::ConditionFalse::DATAMEMEBERS_INTERFACE
rage::ConditionFalse::Match
rage::ConditionGroup
rage::ConditionGroup::~ConditionGroup
rage::ConditionGroup::AddCondition
rage::ConditionGroup::AddConditions
rage::ConditionGroup::ChangeConditionPriority
rage::ConditionGroup::ConditionGroup
rage::ConditionGroup::DECLARE_PLACE
rage::ConditionGroup::DeclareStruct
rage::ConditionGroup::DeleteCondition
rage::ConditionGroup::EvalRemote
rage::ConditionGroup::GetCondition
rage::ConditionGroup::GetConditionCount
rage::ConditionGroup::Match
rage::ConditionGroup::Read
rage::ConditionGroup::Write
rage::ConditionGroupCondition
rage::ConditionGroupCondition::~ConditionGroupCondition
rage::ConditionGroupCondition::AddCondition
rage::ConditionGroupCondition::ChangeConditionPriority
rage::ConditionGroupCondition::ConditionGroupCondition
rage::ConditionGroupCondition::DATAMEMEBERS_INTERFACE
rage::ConditionGroupCondition::DeleteCondition
rage::ConditionGroupCondition::GetCondition
rage::ConditionGroupCondition::GetConditionCount
rage::ConditionGroupCondition::GetConditionFormat
rage::ConditionGroupCondition::GetConditionGroup
rage::ConditionGroupCondition::Match
rage::ConditionGroupCondition::Read
rage::ConditionGroupCondition::ReadConditionGroup
rage::ConditionGroupCondition::SetConditionGroup
rage::ConditionGroupCondition::TRACK_MEMBER
rage::ConditionGroupCondition::TRACK_PADDING
rage::ConditionGroupCondition::WriteCondition
rage::ConditionGroupConditionAnd
rage::ConditionGroupConditionAnd::~ConditionGroupConditionAnd
rage::ConditionGroupConditionAnd::ConditionGroupConditionAnd
rage::ConditionGroupConditionAnd::DATAMEMEBERS_INTERFACE
rage::ConditionGroupConditionAnd::Match
rage::ConditionGroupConditionNot
rage::ConditionGroupConditionNot::~ConditionGroupConditionNot
rage::ConditionGroupConditionNot::ConditionGroupConditionNot
rage::ConditionGroupConditionNot::DATAMEMEBERS_INTERFACE
rage::ConditionGroupConditionNot::Match
rage::ConditionGroupConditionOnly
rage::ConditionGroupConditionOnly::~ConditionGroupConditionOnly
rage::ConditionGroupConditionOnly::ConditionGroupConditionOnly
rage::ConditionGroupConditionOnly::DATAMEMEBERS_INTERFACE
rage::ConditionGroupConditionOnly::Match
rage::ConditionGroupConditionOr
rage::ConditionGroupConditionOr::~ConditionGroupConditionOr
rage::ConditionGroupConditionOr::ConditionGroupConditionOr
rage::ConditionGroupConditionOr::DATAMEMEBERS_INTERFACE
rage::ConditionGroupConditionOr::Match
rage::ConditionNOT
rage::ConditionNOT::~ConditionNOT
rage::ConditionNOT::ConditionNOT
rage::ConditionNOT::DATAMEMEBERS_INTERFACE
rage::ConditionNOT::GetLogical
rage::ConditionNOT::Match
rage::ConditionOR
rage::ConditionOR::~ConditionOR
rage::ConditionOR::ConditionOR
rage::ConditionOR::DATAMEMEBERS_INTERFACE
rage::ConditionOR::GetLogical
rage::ConditionOR::Match
rage::ConditionPrint
rage::ConditionPrint::~ConditionPrint
rage::ConditionPrint::ConditionPrint
rage::ConditionPrint::DATAMEMEBERS_INTERFACE
rage::ConditionPrint::GetText
rage::ConditionPrint::Match
rage::ConditionPrint::PrintChannels
rage::ConditionPrint::PrintChannels enumeration
rage::ConditionPrint::SetText
rage::ConditionPrint::TRACK_MEMBER
rage::ConditionPrint::TRACK_PARAMETER_ENUM
rage::ConditionRandom
rage::ConditionRandom::ConditionRandFunc
rage::ConditionRandom::ConditionRandom
rage::ConditionRandom::DATAMEMEBERS_INTERFACE
rage::ConditionRandom::Match
rage::ConditionRandom::RandomModes
rage::ConditionRandom::RandomModes enumeration
rage::ConditionRandom::SetRandFunc
rage::ConditionRandom::sm_RandomNum
rage::ConditionRandom::sm_RandomUsed
rage::ConditionRandom::TRACK_PARAMETER
rage::ConditionRandom::TRACK_PARAMETER_ENUM
rage::ConditionTrue
rage::ConditionTrue::~ConditionTrue
rage::ConditionTrue::ConditionTrue
rage::ConditionTrue::DATAMEMEBERS_INTERFACE
rage::ConditionTrue::Match
rage::CONTROL_CONTEXT_ENABLED
rage::CONTROL_CONTEXT_ENABLED macro
rage::CSubject
rage::CSubject::~CSubject
rage::CSubject::Attach
rage::CSubject::CSubject
rage::CSubject::Dettach
rage::CSubject::m_Observers
rage::CSubject::Notify
rage::DataMember
rage::DataMember::~DataMember
rage::DataMember::DataMember
rage::DataMember::GetName
rage::DataMember::GetPfGroupActTracks
rage::DataMember::GetType
rage::DataMember::IsDefault
rage::DataMember::m_Name
rage::DataMember::m_WriteBuff
rage::DataMember::Read
rage::DataMember::TYPE
rage::DataMember::TYPE enumeration
rage::DataMember::Write
rage::DATAMEMBERS_INTERFACE_RESOURCE_CTOR
rage::DATAMEMBERS_INTERFACE_RESOURCE_CTOR macro
rage::DATAMEMEBERS_INTERFACE
rage::DATAMEMEBERS_INTERFACE macro
rage::DATAMEMEBERS_INTERFACE_NAME
rage::DATAMEMEBERS_INTERFACE_NAME macro
rage::DATAMEMEBERS_INTERFACE_NO_NAME
rage::DATAMEMEBERS_INTERFACE_NO_NAME macro
rage::DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE
rage::DATAMEMEBERS_INTERFACE_NO_NAME_NO_RESOURCE macro
rage::DATAMEMEBERS_INTERFACE_NO_PLACE
rage::DATAMEMEBERS_INTERFACE_NO_PLACE macro
rage::DATAMEMEBERS_INTERFACE_NO_PLACE_NO_NAME
rage::DATAMEMEBERS_INTERFACE_NO_PLACE_NO_NAME macro
rage::DATAMEMEBERS_INTERFACE_PLACE
rage::DATAMEMEBERS_INTERFACE_PLACE macro
rage::DATAMEMEBERS_INTERFACE_STRUCT
rage::DATAMEMEBERS_INTERFACE_STRUCT macro
rage::DEBUG_BREAK
rage::DEBUG_BREAK macro
rage::DebugOutputFunctor
rage::DebugOutputFunctor type
rage::DEBUGTASKS
rage::DEBUGTASKS macro
rage::DEFINE_sMIN_sMAX
rage::DEFINE_sMIN_sMAX macro
rage::DELETE_CORE_TASK
rage::DELETE_CORE_TASK macro
rage::DELETE_GAME_TASK
rage::DELETE_GAME_TASK macro
rage::DELETE_GAME_TASK_ON_END
rage::DELETE_GAME_TASK_ON_END macro
rage::eActionNodeResolveMode
rage::eActionNodeResolveMode enumeration
rage::ENABLE_TRACK_TIMERS
rage::ENABLE_TRACK_TIMERS macro
rage::END_DATAMEMBERS
rage::END_DATAMEMBERS macro
rage::END_DATAMEMBERS_LITE
rage::END_DATAMEMBERS_LITE macro
rage::ENUM_DATAMEMBER
rage::ENUM_DATAMEMBER macro
rage::ENUM_DATAMEMBER_SIMPLE
rage::ENUM_DATAMEMBER_SIMPLE macro
rage::EnumDataMember
rage::EnumDataMember::~EnumDataMember
rage::EnumDataMember::EnumDataMember
rage::EnumDataMember::GetEnum
rage::EnumDataMember::IsDefault
rage::EnumDataMember::SetEnum
rage::ExecuteTask
rage::ExecuteTask::~ExecuteTask
rage::ExecuteTask::Begin
rage::ExecuteTask::End
rage::ExecuteTask::ExecuteTask
rage::ExecuteTask::GetTrack
rage::ExecuteTask::Update
rage::ExecuteTrack
rage::ExecuteTrack::~ExecuteTrack
rage::ExecuteTrack::DATAMEMEBERS_INTERFACE
rage::ExecuteTrack::ExecuteTrack
rage::ExecuteTrack::NewTask
rage::FactoryIArchive
rage::FactoryIArchive type
rage::FLOAT_DATAMEMBER
rage::FLOAT_DATAMEMBER macro
rage::FLOAT_DATAMEMBER_SIMPLE
rage::FLOAT_DATAMEMBER_SIMPLE macro
rage::FLOAT_MIN_MAX_DATAMEMBER
rage::FLOAT_MIN_MAX_DATAMEMBER macro
rage::FloatDataMember
rage::FloatDataMember::~FloatDataMember
rage::FloatDataMember::FloatDataMember
rage::FloatDataMember::GetFloat
rage::FloatDataMember::GetMinMaxFloat
rage::FloatDataMember::GetType
rage::FloatDataMember::IsDefault
rage::FloatDataMember::SetFloat
rage::GameTaskManager
rage::GameTaskManager::~GameTaskManager
rage::GameTaskManager::AddWidgets
rage::GameTaskManager::AllocateTask
rage::GameTaskManager::DECLARE_TASK_POOL_FUNCTIONS
rage::GameTaskManager::DeleteTask
rage::GameTaskManager::DummyTask
rage::GameTaskManager::DummyTask struct
rage::GameTaskManager::DummyTask0
rage::GameTaskManager::DummyTask1
rage::GameTaskManager::DummyTask2
rage::GameTaskManager::DummyTaskHeader
rage::GameTaskManager::DummyTaskHeader struct
rage::GameTaskManager::GameTaskManager
rage::GameTaskManager::GetDummyTask
rage::GameTaskManager::GetInstance
rage::GameTaskManager::InitClass
rage::GameTaskManager::m_CriticalSection
rage::GameTaskManager::m_TaskPool0
rage::GameTaskManager::m_TaskPool1
rage::GameTaskManager::m_TaskPool2
rage::GameTaskManager::ShutdownClass
rage::GameTaskManager::sm_Instance
rage::gDebugActTreeOut
rage::gDebugActTreeOut variable
rage::GROUP_DATAMEMBER
rage::GROUP_DATAMEMBER macro
rage::GROUP_DATAMEMBER_NO_INTERFACE
rage::GROUP_DATAMEMBER_NO_INTERFACE macro
rage::GROUP_DATAMEMBER_READONLY
rage::GROUP_DATAMEMBER_READONLY macro
rage::GroupDataMember
rage::GroupDataMember::~GroupDataMember
rage::GroupDataMember::Add
rage::GroupDataMember::ChangePriority
rage::GroupDataMember::Delete
rage::GroupDataMember::GetCount
rage::GroupDataMember::GetDataMember
rage::GroupDataMember::GetDataMemberFormat
rage::GroupDataMember::GroupDataMember
rage::GroupDataMember::ReadAllElements
rage::GroupDataMember::WriteElements
rage::GroupDataMemberNoInterface
rage::GroupDataMemberNoInterface::GetType
rage::GroupDataMemberNoInterface::GroupDataMemberNoInterface
rage::gTempHashString
rage::gTempHashString variable
rage::HashUCstring
rage::HashUCstring function
rage::IArchive
rage::IArchive::~IArchive
rage::IArchive::IArchive
rage::IArchive::Write
rage::IBoolDataMember
rage::IBoolDataMember::~IBoolDataMember
rage::IBoolDataMember::GetBool
rage::IBoolDataMember::GetType
rage::IBoolDataMember::IBoolDataMember
rage::IBoolDataMember::Read
rage::IBoolDataMember::SetBool
rage::IBoolDataMember::Write
rage::ICommandDataMember
rage::ICommandDataMember::Execute
rage::ICommandDataMember::GetType
rage::ICommandDataMember::ICommandDataMember
rage::IDataMembers
rage::IDataMembers::~IDataMembers
rage::IDataMembers::DeclareStruct
rage::IDataMembers::GetMember
rage::IDataMembers::GetNumMembers
rage::IDataMembers::IDataMembers
rage::IDataMembers::m_ChangedMember
rage::IDataMembers::Read
rage::IDataMembers::Reset
rage::IDataMembers::Write
rage::IEnumDataMember
rage::IEnumDataMember::GetEnum
rage::IEnumDataMember::GetEnumName
rage::IEnumDataMember::GetNumEnums
rage::IEnumDataMember::GetType
rage::IEnumDataMember::IEnumDataMember
rage::IEnumDataMember::Read
rage::IEnumDataMember::SetEnum
rage::IEnumDataMember::Write
rage::IFloatDataMember
rage::IFloatDataMember::GetFloat
rage::IFloatDataMember::GetMinMaxFloat
rage::IFloatDataMember::IFloatDataMember
rage::IFloatDataMember::Read
rage::IFloatDataMember::SetFloat
rage::IFloatDataMember::Write
rage::IGroupDataMember
rage::IGroupDataMember::Add
rage::IGroupDataMember::ChangePriority
rage::IGroupDataMember::Delete
rage::IGroupDataMember::GetCount
rage::IGroupDataMember::GetDataMember
rage::IGroupDataMember::GetDataMemberFormat
rage::IGroupDataMember::GetType
rage::IGroupDataMember::IGroupDataMember
rage::IGroupDataMember::Read
rage::IGroupDataMember::ReadAllElements
rage::IGroupDataMember::Write
rage::IGroupDataMember::WriteElements
rage::IIntDataMember
rage::IIntDataMember::GetInt
rage::IIntDataMember::GetMinMaxInt
rage::IIntDataMember::GetType
rage::IIntDataMember::IIntDataMember
rage::IIntDataMember::Read
rage::IIntDataMember::SetInt
rage::IIntDataMember::Write
rage::IMultiNodeReferenceTrack
rage::IMultiNodeReferenceTrack::GetActionNode
rage::IMultiNodeReferenceTrack::GetActionNodeReference
rage::IMultiNodeReferenceTrack::GetActionNodeReferenceFullPath
rage::IMultiNodeReferenceTrack::GetNumRefs
rage::IMultiNodeReferenceTrack::GetRef
rage::IMultiNodeReferenceTrack::GetTrackType
rage::IMultiNodeReferenceTrack::GetTrackTypeStatic
rage::IMultiNodeReferenceTrack::IMultiNodeReferenceTrack
rage::IMultiNodeReferenceTrack::IsActionNodeReferenceNull
rage::IMultiNodeReferenceTrack::IsActionNodeResolved
rage::IMultiNodeReferenceTrack::ResolveReference
rage::IMultiNodeReferenceTrack::SetActionNode
rage::IMultiNodeReferenceTrack::SetActionNodeParent
rage::IMultiNodeReferenceTrack::SetActionNodeReference
rage::IName
rage::IName::~IName
rage::IName::GetName
rage::INCREMENT_DEBUG_TASK_UPDATE_COUNTER
rage::INCREMENT_DEBUG_TASK_UPDATE_COUNTER macro
rage::INodeReferenceDataMember
rage::INodeReferenceDataMember::GetFullPath
rage::INodeReferenceDataMember::GetType
rage::INodeReferenceDataMember::INodeReferenceDataMember
rage::INodeReferenceDataMember::IsResolved
rage::INodeReferenceTrack
rage::INodeReferenceTrack::GetTrackType
rage::INodeReferenceTrack::GetTrackTypeStatic
rage::INodeReferenceTrack::INodeReferenceTrack
rage::INodeReferenceTrack::IsActionNodeResolved
rage::INodeReferenceTrack::ResolveReference
rage::INodeReferenceTrack::SetActionNodeParent
rage::InstancedActionController
rage::InstancedActionController::~InstancedActionController
rage::InstancedActionController::AddSequncedTrack
rage::InstancedActionController::ClearSequencedTrack
rage::InstancedActionController::clearSequencedTracks
rage::InstancedActionController::DeleteSequencedTrack
rage::InstancedActionController::GetNumSequencedTracks
rage::InstancedActionController::GetSequencedTrack
rage::InstancedActionController::m_SequencedTracks
rage::InstancedActionController::refCountingTracks
rage::InstancedActionController::refCountingTracks struct
rage::INT_DATAMEMBER
rage::INT_DATAMEMBER macro
rage::INT_DATAMEMBER_SIMPLE
rage::INT_DATAMEMBER_SIMPLE macro
rage::INT_MIN_MAX_DATAMEMBER
rage::INT_MIN_MAX_DATAMEMBER macro
rage::IntDataMember
rage::IntDataMember::~IntDataMember
rage::IntDataMember::GetInt
rage::IntDataMember::GetMinMaxInt
rage::IntDataMember::IntDataMember
rage::IntDataMember::IsDefault
rage::IntDataMember::SetInt
rage::IObserver
rage::IObserver::~IObserver
rage::IObserver::HandleMessage
rage::IObserver::Update
rage::IObserver::UpdateDetach
rage::IStringDataMember
rage::IStringDataMember::GetString
rage::IStringDataMember::GetType
rage::IStringDataMember::IStringDataMember
rage::IStringDataMember::Read
rage::IStringDataMember::SetString
rage::IStringDataMember::Write
rage::ITrackFactory
rage::ITrackFactory::~ITrackFactory
rage::ITrackFactory::GetRorcChecksum
rage::ITrackFactory::GetTrackType
rage::ITrackFactory::ITrackFactory
rage::ITrackFactory::NewTrack
rage::ITrackFactory::Place
rage::ITrackFactory::SetTypeId
rage::IVector2DataMember
rage::IVector2DataMember::GetVector2
rage::IVector2DataMember::IVector2DataMember
rage::IVector2DataMember::Read
rage::IVector2DataMember::SetVector2
rage::IVector2DataMember::Write
rage::IVector3DataMember
rage::IVector3DataMember::GetVector3
rage::IVector3DataMember::IVector3DataMember
rage::IVector3DataMember::Read
rage::IVector3DataMember::SetVector3
rage::IVector3DataMember::Write
rage::LENGTH_DATAMEMBER
rage::LENGTH_DATAMEMBER macro
rage::LENGTH_DATAMEMBER_SIMPLE
rage::LENGTH_DATAMEMBER_SIMPLE macro
rage::LENGTH_MIN_MAX_DATAMEMBER
rage::LENGTH_MIN_MAX_DATAMEMBER macro
rage::LENTH_DATAMEMBER
rage::LENTH_DATAMEMBER macro
rage::MAGIC_NOPLACE
rage::MAGIC_NOPLACE macro
rage::MAGIC_NP_ENUM
rage::MAGIC_NP_ENUM macro
rage::MAGIC_NP_PADDING
rage::MAGIC_NP_PADDING macro
rage::MAGIC_NP_PARAM
rage::MAGIC_NP_PARAM macro
rage::MAGIC_NP_STRING
rage::MAGIC_NP_STRING macro
rage::MAX_HASH_STRING
rage::MAX_HASH_STRING macro
rage::NEW_CORE_TASK
rage::NEW_CORE_TASK macro
rage::NEW_GAME_TASK
rage::NEW_GAME_TASK macro
rage::NODE_REFERENCE_DATAMEMBER
rage::NODE_REFERENCE_DATAMEMBER macro
rage::NODE_REFERENCE_DATAMEMBER_SIMPLE
rage::NODE_REFERENCE_DATAMEMBER_SIMPLE macro
rage::NODENAMELEN
rage::NODENAMELEN macro
rage::NodeReferenceDataMember
rage::NodeReferenceDataMember::~NodeReferenceDataMember
rage::NodeReferenceDataMember::GetFullPath
rage::NodeReferenceDataMember::GetString
rage::NodeReferenceDataMember::IsDefault
rage::NodeReferenceDataMember::IsResolved
rage::NodeReferenceDataMember::NodeReferenceDataMember
rage::NodeReferenceDataMember::SetString
rage::NodeReferenceTrack
rage::NodeReferenceTrack::~NodeReferenceTrack
rage::NodeReferenceTrack::DeclareStruct
rage::NodeReferenceTrack::GetActionNode
rage::NodeReferenceTrack::GetActionNodeReference
rage::NodeReferenceTrack::GetActionNodeReferenceFullPath
rage::NodeReferenceTrack::IsActionNodeReferenceNull
rage::NodeReferenceTrack::IsActionNodeResolved
rage::NodeReferenceTrack::m_ActionNodeRef
rage::NodeReferenceTrack::NodeReferenceTrack
rage::NodeReferenceTrack::ResolveReference
rage::NodeReferenceTrack::SetActionNode
rage::NodeReferenceTrack::SetActionNodeParent
rage::NodeReferenceTrack::SetActionNodeReference
rage::OpportunityRandomLatchTask
rage::OpportunityRandomLatchTask::~OpportunityRandomLatchTask
rage::OpportunityRandomLatchTask::AcquireLatchTime
rage::OpportunityRandomLatchTask::GetTrack
rage::OpportunityRandomLatchTask::OpportunityRandomLatchTask
rage::OpportunityRandomLatchTrack
rage::OpportunityRandomLatchTrack::~OpportunityRandomLatchTrack
rage::OpportunityRandomLatchTrack::DATAMEMEBERS_INTERFACE
rage::OpportunityRandomLatchTrack::NewTask
rage::OpportunityRandomLatchTrack::OpportunityRandomLatchTrack
rage::OpportunityRandomLatchTrack::TRACK_PADDING
rage::OpportunityRandomLatchTrack::TRACK_PARAMETER
rage::OpportunityTask
rage::OpportunityTask::~OpportunityTask
rage::OpportunityTask::AcquireLatchTime
rage::OpportunityTask::Begin
rage::OpportunityTask::End
rage::OpportunityTask::GetTrack
rage::OpportunityTask::m_AlreadyBreaked
rage::OpportunityTask::m_Context
rage::OpportunityTask::m_Latched
rage::OpportunityTask::m_latchedPlayable
rage::OpportunityTask::m_LatchTime
rage::OpportunityTask::OpportunityTask
rage::OpportunityTask::Update
rage::OpportunityTrack
rage::OpportunityTrack::~OpportunityTrack
rage::OpportunityTrack::AddCondition
rage::OpportunityTrack::ChangeConditionPriority
rage::OpportunityTrack::DATAMEMEBERS_INTERFACE
rage::OpportunityTrack::DeleteCondition
rage::OpportunityTrack::GetCondition
rage::OpportunityTrack::GetConditionCount
rage::OpportunityTrack::GetConditionFormat
rage::OpportunityTrack::GetConditionGroup
rage::OpportunityTrack::NewTask
rage::OpportunityTrack::OpportunityTrack
rage::OpportunityTrack::ReadConditionGroup
rage::OpportunityTrack::TRACK_MEMBER
rage::OpportunityTrack::TRACK_PARAMETER
rage::OpportunityTrack::WriteCondition
rage::PFSTAT_ONLY
rage::PFSTAT_ONLY macro
rage::PLAY_HISTORY_DEBUG
rage::PLAY_HISTORY_DEBUG macro
rage::PrintTask
rage::PrintTask::~PrintTask
rage::PrintTask::Begin
rage::PrintTask::End
rage::PrintTask::GetTrack
rage::PrintTask::PrintTask
rage::PrintTask::Update
rage::PrintTrack
rage::PrintTrack::~PrintTrack
rage::PrintTrack::AddWidgets
rage::PrintTrack::DATAMEMEBERS_INTERFACE
rage::PrintTrack::GetText
rage::PrintTrack::NewTask
rage::PrintTrack::PrintChannels
rage::PrintTrack::PrintChannels enumeration
rage::PrintTrack::PrintTrack
rage::PrintTrack::SetText
rage::PrintTrack::ShouldPrint
rage::PrintTrack::sm_PrintChannelEnabled
rage::PrintTrack::TRACK_MEMBER
rage::PrintTrack::TRACK_PARAMETER
rage::PrintTrack::TRACK_PARAMETER_ENUM
rage::RAGE_DECLARE_CHANNEL
rage::RAGE_DECLARE_CHANNEL function
rage::SequenceTask
rage::SequenceTask::~SequenceTask
rage::SequenceTask::End
rage::SequenceTask::GetTrack
rage::SequenceTask::SequenceTask
rage::SequenceTrack
rage::SequenceTrack::~SequenceTrack
rage::SequenceTrack::DATAMEMEBERS_INTERFACE
rage::SequenceTrack::NewTask
rage::SequenceTrack::SequenceTrack
rage::SpawnActionController
rage::SpawnActionController::~SpawnActionController
rage::SpawnActionController::AddSequncedTrack
rage::SpawnActionController::clearSequencedTracks
rage::SpawnActionController::DeleteSequencedTrack
rage::SpawnActionController::GetNumSequencedTracks
rage::SpawnActionController::GetSequencedTrack
rage::SpawnActionController::m_SequencedTracks
rage::SpawnTask
rage::SpawnTask::~SpawnTask
rage::SpawnTask::Begin
rage::SpawnTask::End
rage::SpawnTask::GetActionController
rage::SpawnTask::GetTrack
rage::SpawnTask::SpawnTask
rage::SpawnTask::Update
rage::SpawnTrack
rage::SpawnTrack::~SpawnTrack
rage::SpawnTrack::DATAMEMEBERS_INTERFACE
rage::SpawnTrack::NewTask
rage::SpawnTrack::SpawnTrack
rage::SpawnTrack::TRACK_PARAMETER
rage::spewdrvDisplayf
rage::spewdrvDisplayf macro
rage::STRING_DATAMEMBER
rage::STRING_DATAMEMBER macro
rage::STRING_DATAMEMBER_SIMPLE
rage::STRING_DATAMEMBER_SIMPLE macro
rage::StringCopyNew
rage::StringCopyNew function
rage::StringDataMember
rage::StringDataMember::~StringDataMember
rage::StringDataMember::GetString
rage::StringDataMember::IsDefault
rage::StringDataMember::SetString
rage::StringDataMember::StringDataMember
rage::StubTask
rage::StubTask::~StubTask
rage::StubTask::Begin
rage::StubTask::End
rage::StubTask::GetTrack
rage::StubTask::StubTask
rage::StubTask::Update
rage::TASK_POOL_FUNCTIONS
rage::TASK_POOL_FUNCTIONS macro
rage::TaskSizeCompileTimeAssert
rage::TaskSizeCompileTimeAssert::TaskSizeCompileTimeAssert
rage::TaskSizeCompileTimeAssert<SpawnTask>
rage::TaskSizeCompileTimeAssert<SpawnTask>::TaskSizeCompileTimeAssert
rage::TextBuffer
rage::TextBuffer::~TextBuffer
rage::TextBuffer::AddNewLine
rage::TextBuffer::DecreaseIndent
rage::TextBuffer::GetBuffer
rage::TextBuffer::GetWrittenLength
rage::TextBuffer::IncreaseIndent
rage::TextBuffer::Reset
rage::TextBuffer::TextBuffer
rage::TextBuffer::Write
rage::TextParser
rage::TextParser::~TextParser
rage::TextParser::AddvanceToToken
rage::TextParser::advanceToQuote
rage::TextParser::EndOfText
rage::TextParser::GetCurrentReadPosition
rage::TextParser::GetNextToken
rage::TextParser::GetQuotedString
rage::TextParser::GetTokenAsFloat
rage::TextParser::GetTokenAsInt
rage::TextParser::GetTokenString
rage::TextParser::IsParsingFile
rage::TextParser::MatchCurrentToken
rage::TextParser::MatchCurrentTokenCaseInsensitive
rage::TextParser::NeedToSpecialParseQuotedString
rage::TextParser::PopReadPosition
rage::TextParser::PushReadPosition
rage::TextParser::SetCurrentReadPosition
rage::TextParser::TextParser
rage::TIME_DATAMEMBER
rage::TIME_DATAMEMBER macro
rage::TIME_DATAMEMBER_SIMPLE
rage::TIME_DATAMEMBER_SIMPLE macro
rage::TIME_END_NOT_INSERTED
rage::TIME_END_NOT_INSERTED macro
rage::TIME_MIN_MAX_DATAMEMBER
rage::TIME_MIN_MAX_DATAMEMBER macro
rage::Track
rage::Track::~Track
rage::Track::Create
rage::Track::DECLARE_PLACE
rage::Track::DeclareStruct
rage::Track::DeInit
rage::Track::GetAverageTime
rage::Track::GetDuration
rage::Track::GetFrameCount
rage::Track::GetMaster
rage::Track::GetNumRegistered
rage::Track::GetNumTracks
rage::Track::GetPFTimer
rage::Track::GetRegistered
rage::Track::GetRegisteredTrackType
rage::Track::GetTimeBegin
rage::Track::GetTimeEnd
rage::Track::GetTimer
rage::Track::GetTotalTime
rage::Track::GetTrackRegistry
rage::Track::GetTrackType
rage::Track::GetTrackTypeStatic
rage::Track::Init
rage::Track::m_FrameCount
rage::Track::m_Master
rage::Track::m_Pad
rage::Track::m_TimeBegin
rage::Track::m_TimeEnd
rage::Track::m_TimerId
rage::Track::NewTask
rage::Track::ResetTimers
rage::Track::RORC_VERSION
rage::Track::SetMaster
rage::Track::SetTimeBegin
rage::Track::SetTimeEnd
rage::Track::sm_TimerPool
rage::Track::Timer
rage::Track::Timer::GetAverage
rage::Track::Timer::GetTime
rage::Track::Timer::GetTotal
rage::Track::Timer::m_Count
rage::Track::Timer::m_StartTime
rage::Track::Timer::m_Time
rage::Track::Timer::Reset
rage::Track::Timer::Start
rage::Track::Timer::Stop
rage::Track::TimerStart
rage::Track::TimerStop
rage::Track::Track
rage::Track::UpdateFrame
rage::TRACK_MEMBER
rage::TRACK_MEMBER macro
rage::TRACK_MEMBER_ENUM
rage::TRACK_MEMBER_ENUM macro
rage::TRACK_PADDING
rage::TRACK_PADDING macro
rage::TRACK_PARAMETER
rage::TRACK_PARAMETER macro
rage::TRACK_PARAMETER_CNAME
rage::TRACK_PARAMETER_CNAME macro
rage::TRACK_PARAMETER_ENUM
rage::TRACK_PARAMETER_ENUM macro
rage::TRACK_PARAMETER_ENUM_STATIC
rage::TRACK_PARAMETER_ENUM_STATIC macro
rage::TRACK_PARAMETER_MIN_MAX
rage::TRACK_PARAMETER_MIN_MAX macro
rage::TRACK_PARAMETER_sMIN_sMAX
rage::TRACK_PARAMETER_sMIN_sMAX macro
rage::TRACK_PARAMETER_STATIC
rage::TRACK_PARAMETER_STATIC macro
rage::TRACK_PARAMETER_STRING
rage::TRACK_PARAMETER_STRING macro
rage::TRACK_PARAMETER_STRING_STATIC
rage::TRACK_PARAMETER_STRING_STATIC macro
rage::TRACK_PARAMETER_VECTOR2
rage::TRACK_PARAMETER_VECTOR2 macro
rage::TRACK_PARAMETER_VECTOR2_STATIC
rage::TRACK_PARAMETER_VECTOR2_STATIC macro
rage::TRACK_PARAMETER_VECTOR3
rage::TRACK_PARAMETER_VECTOR3 macro
rage::TRACK_PARAMETER_VECTOR3_STATIC
rage::TRACK_PARAMETER_VECTOR3_STATIC macro
rage::TRACK_TIME_DATAMEMBER
rage::TRACK_TIME_DATAMEMBER macro
rage::TRACK_TIME_DATAMEMBER_SIMPLE
rage::TRACK_TIME_DATAMEMBER_SIMPLE macro
rage::TRACK_TIME_MIN_MAX_DATAMEMBER
rage::TRACK_TIME_MIN_MAX_DATAMEMBER macro
rage::TrackFactory
rage::TrackFactory::~TrackFactory
rage::TrackFactory::GetName
rage::TrackFactory::GetRorcChecksum
rage::TrackFactory::GetTrackType
rage::TrackFactory::NewTrack
rage::TrackFactory::Place
rage::TrackFactory::SetTypeId
rage::TrackFactory::TrackFactory
rage::TRACKMSG
rage::TRACKMSG macro
rage::TrackOrCondition
rage::TrackOrCondition::Break
rage::TrackOrCondition::DeclareStruct
rage::TrackOrCondition::GetConditionGroup
rage::TrackOrCondition::GetDebugBreakPoint
rage::TrackOrCondition::GetEnableBreakPoints
rage::TrackOrCondition::GetName
rage::TrackOrCondition::GetTrackType
rage::TrackOrCondition::GetTrackTypeStatic
rage::TrackOrCondition::GetTypeId
rage::TrackOrCondition::SetDebugBreakPoint
rage::TrackOrCondition::SetEnableBreakPoints
rage::TrackOrCondition::TrackOrCondition
rage::TrackOrCondition::Write
rage::TrackRegistry
rage::TrackRegistry::~TrackRegistry
rage::TrackRegistry::Create
rage::TrackRegistry::DegisterTrackFactorys
rage::TrackRegistry::DeInit
rage::TrackRegistry::GetDictionary
rage::TrackRegistry::GetNumRegisteredTracks
rage::TrackRegistry::GetRegisteredTrackName
rage::TrackRegistry::GetRegisteredTrackType
rage::TrackRegistry::GetRorcChecksum
rage::TrackRegistry::Init
rage::TrackRegistry::Place
rage::TrackRegistry::RegisterTrackFactory
rage::TrackRegistry::ResetDictionary
rage::TrackRegistry::Sort
rage::TrackRegistry::TrackRegistry
rage::VECTOR2_DATAMEMBER
rage::VECTOR2_DATAMEMBER macro
rage::Vector2DataMember
rage::Vector2DataMember::~Vector2DataMember
rage::Vector2DataMember::GetType
rage::Vector2DataMember::GetVector2
rage::Vector2DataMember::IsDefault
rage::Vector2DataMember::SetVector2
rage::Vector2DataMember::Vector2DataMember
rage::VECTOR3_DATAMEMBER
rage::VECTOR3_DATAMEMBER macro
rage::VECTOR3_DATAMEMBER_SIMPLE
rage::VECTOR3_DATAMEMBER_SIMPLE macro
rage::Vector3DataMember
rage::Vector3DataMember::~Vector3DataMember
rage::Vector3DataMember::GetType
rage::Vector3DataMember::GetVector3
rage::Vector3DataMember::IsDefault
rage::Vector3DataMember::SetVector3
rage::Vector3DataMember::Vector3DataMember
rage::VELOCITY_DATAMEMBER
rage::VELOCITY_DATAMEMBER macro
rage::VELOCITY_DATAMEMBER_SIMPLE
rage::VELOCITY_DATAMEMBER_SIMPLE macro
rage::VELOCITY_MIN_MAX_DATAMEMBER
rage::VELOCITY_MIN_MAX_DATAMEMBER macro
RandomModeNames
RandomModeNames variable
RAW_ACT_FILE_SUPPORT
RAW_ACT_FILE_SUPPORT macro
RAW_ACT_FILE_SUPPORT_ONLY
RAW_ACT_FILE_SUPPORT_ONLY macro
RAW_ACT_FILE_SUPPORT_ORNULL
RAW_ACT_FILE_SUPPORT_ORNULL macro
Read
ReadAllElements
ReadConditionGroup
ReadFile
ReadFromFile
RecursSetFileRoots
RegisterTrackFactory
Relationships
RemoveChildActionNode
RemoveTask
ReserveTracks
Reset
ResetDebug
ResetDictionary
ResetTimers
ResetTiming
ResetTimingRecursive
ResolveAllTrackReferences
ResolveAllWeights
ResolveReference
ResolveReferences
ResolveTrackReferences
ResolveWeights
RORC_VERSION
S
s_CNameTraverseDown
s_CNameTraverseUp
s_NoOfTaskUpdates
Sequence
SequenceTask
SequenceTask class
~SequenceTask
End
GetTrack
SequenceTask
SequenceTask::~SequenceTask destructor
SequenceTask::End method
SequenceTask::GetTrack method
SequenceTask::SequenceTask constructor
SequenceTrack
SequenceTrack class
~SequenceTrack
DATAMEMEBERS_INTERFACE
NewTask
SequenceTrack
SequenceTrack::~SequenceTrack destructor
SequenceTrack::DATAMEMEBERS_INTERFACE method
SequenceTrack::NewTask method
SequenceTrack::SequenceTrack constructor
Set_GetFunction
SetActionNode
SetActionNodeParent
SetActionNodeReference
SetArchiveObject
SetBeginBreakPoint
SetBool
SetConditionGroup
SetContext
SetControlContext
SetCurrentReadPosition
SetDebug
SetDebugBreakPoint
SetEditPriority
SetEnableBreakPoints
SetEndBreakPoint
SetEnum
SetFactoryIArchive
SetFileName
SetFloat
SetFullPathName
SetID
SetInt
SetMap
SetMaster
SetOnLoad
SetOnUnload
SetParent
SetPath
SetPathName
SetRandFunc
SetReferenceName
SetRequestedNode
SetRoot
SetStreamingPriority
SetString
SetText
SetTimeBegin
SetTimeEnd
SetTypeId
SetUpDateBreakPoint
SetVector2
SetVector3
ShouldPrint
ShutdownClass
sm_ActFullPath
sm_ActPath
sm_Instance
sm_LoadFromResources
sm_OnTreeUnloadCallback
sm_PostLoadCallback
sm_PrintChannelEnabled
sm_RandomNum
sm_RandomUsed
sm_RscFirstPass
sm_TimerPool
Sort
SpawnActionController class
~SpawnActionController
AddSequncedTrack
clearSequencedTracks
DeleteSequencedTrack
GetNumSequencedTracks
GetSequencedTrack
m_SequencedTracks
SpawnActionController::~SpawnActionController destructor
SpawnActionController::AddSequncedTrack method
SpawnActionController::clearSequencedTracks method
SpawnActionController::DeleteSequencedTrack method
SpawnActionController::GetNumSequencedTracks method
SpawnActionController::GetSequencedTrack method
SpawnActionController::m_SequencedTracks data member
SpawnTask
SpawnTask class
~SpawnTask
Begin
End
GetActionController
GetActionController
GetTrack
SpawnTask
Update
SpawnTask::~SpawnTask destructor
SpawnTask::Begin method
SpawnTask::End method
SpawnTask::GetActionController method
SpawnTask::GetTrack method
SpawnTask::SpawnTask constructor
SpawnTask::Update method
SpawnTrack
SpawnTrack class
~SpawnTrack
DATAMEMEBERS_INTERFACE
NewTask
SpawnTrack
TRACK_PARAMETER
SpawnTrack::~SpawnTrack destructor
SpawnTrack::DATAMEMEBERS_INTERFACE method
SpawnTrack::NewTask method
SpawnTrack::SpawnTrack constructor
SpawnTrack::TRACK_PARAMETER method
Start
StartSequencedTracks
Stop
StringDataMember
StringDataMember template
~StringDataMember
GetString
IsDefault
SetString
StringDataMember
StringDataMember::~StringDataMember destructor
StringDataMember::GetString method
StringDataMember::IsDefault method
StringDataMember::SetString method
StringDataMember::StringDataMember constructor
StubTask
StubTask class
~StubTask
Begin
End
GetTrack
StubTask
Update
StubTask::~StubTask destructor
StubTask::Begin method
StubTask::End method
StubTask::GetTrack method
StubTask::StubTask constructor
StubTask::Update method
sUseNameStrings
sUseNameStrings variable
T
TaskLoadActionNode
TaskSizeCompileTimeAssert
TaskSizeCompileTimeAssert template
TaskSizeCompileTimeAssert
TaskSizeCompileTimeAssert::TaskSizeCompileTimeAssert constructor
TaskSizeCompileTimeAssert<SpawnTask> template
TaskSizeCompileTimeAssert
TaskSizeCompileTimeAssert<SpawnTask>::TaskSizeCompileTimeAssert method
TextBuffer
TextBuffer class
~TextBuffer
AddNewLine
DecreaseIndent
GetBuffer
GetWrittenLength
IncreaseIndent
Reset
TextBuffer
Write
Write
Write
Write
Write
Write
TextBuffer::~TextBuffer destructor
TextBuffer::AddNewLine method
TextBuffer::DecreaseIndent method
TextBuffer::GetBuffer method
TextBuffer::GetWrittenLength method
TextBuffer::IncreaseIndent method
TextBuffer::Reset method
TextBuffer::TextBuffer constructor
TextBuffer::Write method
TextParser
TextParser class
~TextParser
AddvanceToToken
advanceToQuote
EndOfText
GetCurrentReadPosition
GetNextToken
GetQuotedString
GetQuotedString
GetTokenAsFloat
GetTokenAsInt
GetTokenString
GetTokenString
IsParsingFile
MatchCurrentToken
MatchCurrentToken
MatchCurrentTokenCaseInsensitive
NeedToSpecialParseQuotedString
PopReadPosition
PushReadPosition
SetCurrentReadPosition
TextParser
TextParser
TextParser::~TextParser destructor
TextParser::AddvanceToToken method
TextParser::advanceToQuote method
TextParser::EndOfText method
TextParser::GetCurrentReadPosition method
TextParser::GetNextToken method
TextParser::GetQuotedString method
TextParser::GetTokenAsFloat method
TextParser::GetTokenAsInt method
TextParser::GetTokenString method
TextParser::IsParsingFile method
TextParser::MatchCurrentToken method
TextParser::MatchCurrentTokenCaseInsensitive method
TextParser::NeedToSpecialParseQuotedString method
TextParser::PopReadPosition method
TextParser::PushReadPosition method
TextParser::SetCurrentReadPosition method
TextParser::TextParser constructor
TEXTPARSER_HPP
TEXTPARSER_HPP macro
TIME_TASK_UPDATES
TIME_TASK_UPDATES macro
TIMER_START_BEGIN
TIMER_START_BEGIN macro
TIMER_START_END
TIMER_START_END macro
TIMER_START_UPDATE
TIMER_START_UPDATE macro
TIMER_STOP_BEGIN
TIMER_STOP_BEGIN macro
TIMER_STOP_END
TIMER_STOP_END macro
TIMER_STOP_UPDATE
TIMER_STOP_UPDATE macro
TimerStart
TimerStop
TokenName
TOO_LONG
TOO_LONG variable
Track
Track class
~Track
Create
Create
DECLARE_PLACE
DeclareStruct
DeInit
GetAverageTime
GetDuration
GetFrameCount
GetMaster
GetNumRegistered
GetNumTracks
GetPFTimer
GetRegistered
GetRegisteredTrackType
GetTimeBegin
GetTimeEnd
GetTimer
GetTotalTime
GetTrackRegistry
GetTrackType
GetTrackTypeStatic
Init
m_FrameCount
m_Master
m_Pad
m_TimeBegin
m_TimeEnd
m_TimerId
NewTask
ResetTimers
RORC_VERSION
SetMaster
SetTimeBegin
SetTimeEnd
sm_TimerPool
TimerStart
TimerStop
Track
Track
UpdateFrame
Track::~Track destructor
Track::Create method
Track::DECLARE_PLACE method
Track::DeclareStruct method
Track::DeInit method
Track::GetAverageTime method
Track::GetDuration method
Track::GetFrameCount method
Track::GetMaster method
Track::GetNumRegistered method
Track::GetNumTracks method
Track::GetPFTimer method
Track::GetRegistered method
Track::GetRegisteredTrackType method
Track::GetTimeBegin method
Track::GetTimeEnd method
Track::GetTimer method
Track::GetTotalTime method
Track::GetTrackRegistry method
Track::GetTrackType method
Track::GetTrackTypeStatic method
Track::Init method
Track::m_FrameCount data member
Track::m_Master data member
Track::m_Pad data member
Track::m_TimeBegin data member
Track::m_TimeEnd data member
Track::m_TimerId data member
Track::NewTask method
Track::ResetTimers method
Track::RORC_VERSION data member
Track::SetMaster method
Track::SetTimeBegin method
Track::SetTimeEnd method
Track::sm_TimerPool data member
Track::Timer struct
GetAverage
GetTime
GetTotal
m_Count
m_StartTime
m_Time
Reset
Start
Stop
Track::Timer::GetAverage method
Track::Timer::GetTime method
Track::Timer::GetTotal method
Track::Timer::m_Count data member
Track::Timer::m_StartTime data member
Track::Timer::m_Time data member
Track::Timer::Reset method
Track::Timer::Start method
Track::Timer::Stop method
Track::TimerStart method
Track::TimerStop method
Track::Track constructor
Track::UpdateFrame method
TRACK_EVALUATED_TRACKS_AND_CONDITIONS
TRACK_EVALUATED_TRACKS_AND_CONDITIONS macro
TRACK_MEMBER
TRACK_PADDING
TRACK_PARAMETER
TRACK_PARAMETER_ENUM
TRACK_PARAMETER_STRING
TRACKED_MATCH
TRACKED_MATCH macro
TrackFactory
TrackFactory template
~TrackFactory
GetName
GetName
GetRorcChecksum
GetTrackType
NewTrack
Place
SetTypeId
TrackFactory
TrackFactory::~TrackFactory destructor
TrackFactory::GetName method
TrackFactory::GetRorcChecksum method
TrackFactory::GetTrackType method
TrackFactory::NewTrack method
TrackFactory::Place method
TrackFactory::SetTypeId method
TrackFactory::TrackFactory constructor
TRACKMSG
TrackOrCondition
TrackOrCondition class
Break
DeclareStruct
GetConditionGroup
GetDebugBreakPoint
GetEnableBreakPoints
GetName
GetName
GetTrackType
GetTrackTypeStatic
GetTypeId
SetDebugBreakPoint
SetEnableBreakPoints
TrackOrCondition
Write
TrackOrCondition::Break method
TrackOrCondition::DeclareStruct method
TrackOrCondition::GetConditionGroup method
TrackOrCondition::GetDebugBreakPoint method
TrackOrCondition::GetEnableBreakPoints method
TrackOrCondition::GetName method
TrackOrCondition::GetTrackType method
TrackOrCondition::GetTrackTypeStatic method
TrackOrCondition::GetTypeId method
TrackOrCondition::SetDebugBreakPoint method
TrackOrCondition::SetEnableBreakPoints method
TrackOrCondition::TrackOrCondition constructor
TrackOrCondition::Write method
TrackRegistry
TrackRegistry class
~TrackRegistry
Create
Create
DegisterTrackFactorys
DeInit
GetDictionary
GetNumRegisteredTracks
GetRegisteredTrackName
GetRegisteredTrackType
GetRorcChecksum
Init
Place
RegisterTrackFactory
ResetDictionary
Sort
TrackRegistry
TrackRegistry::~TrackRegistry destructor
TrackRegistry::Create method
TrackRegistry::DegisterTrackFactorys method
TrackRegistry::DeInit method
TrackRegistry::GetDictionary method
TrackRegistry::GetNumRegisteredTracks method
TrackRegistry::GetRegisteredTrackName method
TrackRegistry::GetRegisteredTrackType method
TrackRegistry::GetRorcChecksum method
TrackRegistry::Init method
TrackRegistry::Place method
TrackRegistry::RegisterTrackFactory method
TrackRegistry::ResetDictionary method
TrackRegistry::Sort method
TrackRegistry::TrackRegistry constructor
TRACKS_HPP
TRACKS_HPP macro
U
UnLoad
UnLoadAll
Update
UPDATE_TASK
UPDATE_TASK macro
UpdateDebugTask
UpdateDetach
UpdateFrame
UpdateTasks
UpdateTasksTimeEnd
UpdateWithKeepAlive
V
ValFunc
ValFunc function
VALIDATE_OR_REMOVE_NAME
VALIDATE_OR_REMOVE_NAME macro
Vector2DataMember
Vector2DataMember template
~Vector2DataMember
GetType
GetVector2
IsDefault
SetVector2
Vector2DataMember
Vector2DataMember::~Vector2DataMember destructor
Vector2DataMember::GetType method
Vector2DataMember::GetVector2 method
Vector2DataMember::IsDefault method
Vector2DataMember::SetVector2 method
Vector2DataMember::Vector2DataMember constructor
Vector3DataMember
Vector3DataMember template
~Vector3DataMember
GetType
GetVector3
IsDefault
SetVector3
Vector3DataMember
Vector3DataMember::~Vector3DataMember destructor
Vector3DataMember::GetType method
Vector3DataMember::GetVector3 method
Vector3DataMember::IsDefault method
Vector3DataMember::SetVector3 method
Vector3DataMember::Vector3DataMember constructor
VerifyNewNode
W
Warn
Working Examples
Write
writeBegin
writeChildren
writeComment
WriteCondition
writeConditions
WriteElements
writeEnd
WriteToFile
writeTracks