asset

file Documentation
Contents | Index
asset
Show All

Put this in its own namespace so that we don't get duplicate symbol errors.

Send comments on this topic.
Copyright (c) 2003-2008 Rockstar San Diego. All rights reserved.


Overview

Overview
Show All
Origin Of Module Name

File stands for "FILE input/output".

Overview

The file module supplies basic file input and output. It is built up in three layers:

  • fiDevice is the device driver abstraction; a device driver accepts a filname and returns a handle in its Open and Create calls that is used by its other functions to perform unbuffered Read, Write, and Seek operations.
  • fiStream adds buffering on top of an fiDevice. It also supplies endian-neutral binary read and write routines.
  • fiAssetManager adds the notion of a current folder on top of an fiStream. It is used only to open or create the stream, after which you can just use the other fiStream functions directly.

The file module is also home to a simple toknizing class fiTokenizer which can be used for basic text file parsing. It will be deprecated in the future once we have a unified parsing solution.

Send comments on this topic.


Components

Components

Here's a table listing the primary components of this module.


Relationships

Relationships

Insert text with inheritance and dependency info for the classes in this library. Ideally, include UML diagrams (as a GIF) followed by any additional explanations.


Command Line Options

Command Line Options
Parameter Name | In File | Description
disablerfscaching | X:gta5srcdevragebasesrcfileremote.cpp | [file] Don't use the directory caching with SysTrayRFS
dumprpfinfo | X:gta5srcdevragebasesrcfilepackfile.cpp | Dump RPF file info at mount time
enablefatalreaderror | X:gta5srcdevragebasesrcfiledevice_psn.cpp | Enable fatal read errors (use -toggleN=enablefatalreaderror)
hddfreespace | X:gta5srcdevragebasesrcfilesavegame_psn.cpp | Fake the amount of free space available on the hard disk
installstat | X:gta5srcdevragebasesrcfiledevice_installer.cpp | Output some network stats during install
missingfilesarefatal | X:gta5srcdevragebasesrcfilestream.cpp | [system] If set, any file open failure is considered a fatal abort.
nameheapshift | X:gta5srcdevragebasesrcfilepackfile_builder.cpp | Specify name heap shift (default=0, 64k max size, can be up to 3 for 512k max size)
path | X:gta5srcdevragebasesrcfileasset.cpp | [RAGE] Set default asset path root
rfschunksize | X:gta5srcdevragebasesrcfileremote.cpp | [file] Size of chunk to use when transfering data, in bytes
rfsport | X:gta5srcdevragebasesrcfileremote.cpp | [startup] Specify non-default port for rfs usage.
update | X:gta5srcdevragebasesrcfiledevice_common.cpp | Set path to titleupdate folder


Working Examples

Working Examples
Send comments on this topic.


rage Namespace

rage Namespace
Namespaces | Classes | Structs | Types | Functions | Variables | Enumerations | Macros
Show All
Namespaces
Namespace | Description
fiSaveGameState |
Classes
Class
Description
fiArchive
fiAsciiTokenizer
fiAsciiTokenizer implements a concrete subclass of fiTokenizer for handling text files.
fiAssetManager
fiAssetManager defines the notion of an asset root directory and a current asset folder. The folders can be stacked up to eight levels deep. The class acts as a virtual class factory for fiStream objects, applying several rules for inserting an implicit leading path and a file extension. See the documentation of PushFolder and FullPath for details of the rules.
fiAsynchStream
This class implements a wrapper that allows code to asynchronously read a file into memory (via a polling interface) and then, once the operation is complete, present a normal fiStream* object that is a memory stream that will automatically free itself when the file is closed.
fiBaseTokenizer
fiBaseTokenizer implements a simple word-based file tokenizer.
Its use is deprecated in new code so it will not be documented further.
fiBinTokenizer
fiBinTokenizer implements a concrete subclass of fiTokenizer for handling binary files.
fiCachedDevice
fiCachePartition
fiCollection
fiCompressionData
Class for compressing and decompressing with the fiCompress and fiDecompress methods. Mirrored in C# in rage/base/tools/ragCompression, this class is an interface between the game and Rag.
fiDevice
Implements a device driver abstraction for the filesystem so that higher level code can access persistent storage portably. All filenames are assumed to start with some sort of device id which is used to route the file to the approperiate device. This may be something like cdrom0: or even a drive letter like D:; furthermore, we will tend to fall back on fiDeviceLocal if no other device match is found.
fiDeviceCount
fiDeviceGrowBuffer
fiDeviceInstaller
name: fiDeviceRelative
fiDeviceLocal
Concrete subclass of fiDevice which implements the local filesystem
fiDeviceLocalDrm
Concrete subclass of fiDeviceLocal which implements the local filesystem with DRM support (i.e. PS3 downloadable content)
fiDeviceMemory
Concrete subclass of fiDevice which implements memory-base streaming. The filename passed to Open must be of the form "memory:%u,%u,%d:comment" where the first value is the memory buffer and the second value is the size of the buffer. The memory is assumed to be allocated by operator new (and will be freed on close) if the third parameter is nonzero.
fiDeviceRelative
name: fiDeviceRelative
fiDeviceRemote
Concrete subclass of fiDevice which implements a simple TCP/IP-based remote filesystem. Intended for Xbox and Xenon, neither of which support simple read/write access to your host PC.
fiDeviceTcpIp
fiDeviceXContent
fiDiskCache
fiEmbeddedFile
These auto-register themselves but you still need to make sure they piggyback onto a .cpp file that is being used so that they don't get ignored by the linker.
fiMultiTokenizer
fiMultiTokenizer allows
fiPackfile
The fiPackfile device implements read-only zipfile access with compression support. Higher-level code is expected to call fiDevice::Mount with a new instance of fiPackfile that has succeeded in its Init call. The zipfile will remember the device and handle of its original filename without consuming an fiStream permanently; in theory it is possible to even nest zipfiles within zipfiles -- which can be useful if you're trying to save memory, because the entire zipfile directory structure is kept resident in memory at all times.
The file format is custom, and is created by the zip2rpf tool.
Internally each element of a pathname is stored separately (like a real filesystem would) so deep directory structures are not any more expensive, particularly if they result in shorter element names. For example, prop_sandiego_lamppost_01 would be stored more efficiently as prop/sandiego/lamppost_01 if there were many other props in sandiego.
fiRpf7Builder
fiSafeStream
Pass the result of a fiStream::Open or ASSET.Open to this class and it will assume ownership of the stream for you; its destructor will guarantee that the stream is properly closed. Use it anywhere you would use a fiStream*, it has the appropriate implicit conversion operators.
fiSaveGame
fiSaveGame manages independent save state for up to four different players.
The class is designed to be polled every frame depending on what higher-level operation is in progress.
To select the current device for load/save, call BeginSelectDevice. If it returns true, keep calling CheckSelectDevice every frame until it returns true, at which point you should call EndSelectDevice.
To enumerate all savegames on the current device, call BeginEnumeration with the largest number of content items you expect to handle. If it returns true, keep calling CheckEnumeration every frame until it returns true, at which point you can call GetEnumerationCount and GetEnumerationData. When you're done with the data, call EndEnumeration.
To save a game, call BeginSave with the display name to associate with the content and a filename to use internally and the actual save data. If it returns true, keep calling CheckSave every frame until it returns true, at which point it will also tell you if the save was successful. Next call EndSave to return to the idle state.
To load a game, call BeginLoad with the display name to associate with the content and a filename to use internally and the load data buffer. If it returns true, keep calling CheckLoad every frame until it returns true, at which point it will also tell you the amount of data read. Next call EndLoad to return to the idle state.
Note that the display name is actually internally converted into a directory name, so you can actually do multiple savegames under the same display name if you use a different filename each time. You cannot currently individually delete files under the content directory though. Also note that the system browser only lets you manipulate top-level content objects, not files within the content directory.
Any error detected causes the system to enter an error state which can only be left by doing BeginSelectDevice. The most common cause of errors is removing a memory card device.
fiSerialize
fiStream
This implements functions to do the file I/O work. Implements buffered file I/O; should be used instead of FILE in stdio.h if portability is desired.
Where practical, stdio-style interfaces are supported; most use inlines to translate into the particular member function call.
fiTokenizer
This class is to keep current code compiling:
fiZipfile
The fiZipfile device implements read-only zipfile access with compression support. Higher-level code is expected to call fiDevice::Mount with a new instance of fiZipfile that has succeeded in its Init call. The zipfile will remember the device and handle of its original filename without consuming an fiStream permanently; in theory it is possible to even nest zipfiles within zipfiles -- which can be useful if you're trying to save memory, because the entire zipfile directory structure is kept resident in memory at all times.
Internally each element of a pathname is stored separately (like a real filesystem would) so deep directory structures are not any more expensive, particularly if they result in shorter element names. For example, prop_sandiego_lamppost_01 would be stored more efficiently as prop/sandiego/lamppost_01 if there were many other props in sandiego.
Header
XenonProfile
Structs
Struct | Description
fiDeviceProfiler |
fiPackEntry | Big-endian
fiPackfileState |
fiRpf7Entry | Needed during construction only
fiZipfileState |
Mount_t |
MsDosDate |
MsDosTime |
zipDirEntry |
CacheHeader |
DeviceMemoryState |
EncoderState |
fiFindData | Structure returned by FindFileBegin / FindFileNext
File |
fiPackHeader | Little-endian
fiRemoteDirEntry |
node |
sInstallProgress |
Slot | Entry zero is actually the file header.
Types
Type | Description
StreamCloseCallback |
StreamCreateCallback |
StreamOpenCallback |
Functions
Function | Description
atou | Some addresses have their sign bit set, and atoi on Xenon at least will clamp!
CompileTimeAssertSize |
fgetline | Like fgets, but strips off whitespace at end of line
fgets |
fiCompress | PURPOSE Compress data using a sliding window algorithm PARAMS dest - Destination buffer destSize - Size of destination buffer; should be slightly larger than input for worse-case. Adding 1k should be sufficient. src - Source buffer (data to compress) srcSize - Amount of data to compress lookback - Maximum lookback (log2). 15 or 16 is pretty fast and still yields very good results. fullUpdate - If true, does more exhaustive table update which is substantially more expensive but improves compression by about 10% or so. Varies by data. RETURNS Number of bytes written to destination buffer. If this is greater than or equal to srcSize, calling code should assume the compression failed (common with very small datasets)
fiCompressUpperBound | PURPOSE Compute a reasonable upper bound on the compression space needed PARAMS srcSize - Size of source buffer RETURNS Estimated upper bound (for use in fiCompress destSize)
fiDecompress | PURPOSE Decompress data compressed with fiCompress PARAMS dest - Output buffer destSize - size of output buffer src - Compressed data stream srcSize - Size of input compressed data stream RETURNS True if decompression was successful, or false on failure (due to bad input data). Should never crash on malformed inputs.
fiFtpServer |
fiGetFramesSinceLastMessageBox | Return the number of frames since a message box was shown the last time.
fiLaunchFtpServerThread | Launch a thread that runs fiFtpServer
fiRemoteExec | Invoke a process; use sysExec instead of this directly.
fiRemoteGetEnv | Get env var; use sysGetEnv instead of this directly.
fiRemoteResetFiles | Reset all open files; intended only for use by rfs itself.
fiRemoteServer | Install a remote file server on specified port
fiRemoteShowAssertMessageBox | Shows a message box with the option of logging a bug on the remote PC (as per Win32 API MessageBox call)
fiRemoteShowMessageBox | Shows a message box on the remote PC (as per Win32 API MessageBox call)
fiRemoteTty | Send remote tty.
FlushCacheHeader |
fprintf |
fseek | extern fiStream* fopen(char *,char *);
GetDisplayName |
GetSaveFilePath |
MakeNewest |
MakeOldest |
NOSTRIP_PARAM |
NOSTRIP_PARAM |
NOSTRIP_XPARAM |
Quitf |
ResetCache |
StringLength | lint !e18
Variables
Variable | Description
ASSET |
CACHE_BLOCK_COUNT | Slot zero is used for magic and linked list. Because of max size limits on PS3, this cannot be 4096.
CACHE_BLOCK_MASK |
CACHE_BLOCK_MAX |
CACHE_BLOCK_SHIFT | Note that FlushCacheHeader creates a structure roughly 8*CACHE_BLOCK_MAX on the stack so we need to watch the size.
CACHE_BLOCK_SIZE |
CACHE_FILE_BLOCK_COUNT |
CACHE_FILE_COUNT |
CACHE_FILE_HEADER_SIZE |
CACHE_FILE_MAGIC | Change this magic number (last digit) if you make any structural or semantic changes to the s_Header. In particular, changing either CACHE_BLOCK_COUNT, CACHE_BLOCK_SHIFT, CACHE_FILE_COUNT, or CACHE_FILE_SHIFT require a new magic number to avoid crashing on old cache files.
CACHE_FILE_SIZE |
CACHE_FILE_VERSION |
CACHE_PADDING |
CACHE_SUBFILE_COUNT | number of cache files
CACHE_SUBFILE_MASK |
CACHE_SUBFILE_SHIFT | number of bits per cache file
CENTINANOSECONDS_PER_SECOND |
fiIsShowingMessageBox | Indicates whether a message box is currently being displayed or not (useful for avoiding timeouts)
FileName |
FILETIME_2000 | #include #include #include void main() { SYSTEMTIME _2000 = { 2000, 1, 0, 1, 0, 0, 0, 0 }; unsigned __int64 ft; SystemTimeToFileTime(&_2000, (FILETIME*)&ft); char buffer[100]; _ui64toa(ft,buffer,10); printf("filetime of 2000 %sn",buffer); } Seconds since January 1, 2000 gives us a reach of 136 years.
fiRemoteServerIsRunning | Indicates whether rfs is properly installed or not; valid after fiDeviceRemote::InitClass is called.
g_AES |
g_enumeratedContent |
g_fiCaseSensitive |
g_IsExiting |
g_numContent |
g_SaveGameState | Changelist 129860 by Adam Implemented savegame state and also assert on calling the wrong functions based on what the savegame state is
gExitThread |
info_table |
m_State |
MAX_RPFS |
maxMem |
MaxPackfiles | If we raise this past 256 we'll need to decrement fiCollection::ArchiveShift again.
messageToken |
nameheap |
nameshift |
pgStreamingLog |
pgStreamingLogToken |
pIconImage |
RAGE_MAX_PATH | Maximum length of a path, including the terminating NUL character.
s_bCalculateSizeOnDisk |
s_bCheckForUserBindErrors |
s_bCheckingForFreeSpace | HACK_GTA4
s_bFileMissing | MP3MOD
s_bHasCreator |
s_bIsCreator |
s_CacheBlockFiles |
s_CachedDevices | Final builds always have monolithic rpfs. Other builds may have more.
s_CacheFile |
s_CachePath | typically /dev_hdd1 but we're not supposed to count on that.
s_CacheWorkerThread |
s_Container |
s_Content |
s_ContentMax |
s_count |
s_Counts |
s_Data |
s_DataSize |
s_DefaultDevice |
s_DefaultDeviceReadOnly |
s_Device |
s_DeviceCount |
s_DeviceGrowBuffer |
s_DeviceLocal |
s_DeviceMemory |
s_DeviceUpdateDebug |
s_DirName |
s_DisplayName |
s_Done |
s_DummyProfiler |
s_EnumCount |
s_eSaveProcessToPerform |
s_FileExists |
s_FilenameBuf |
s_FileProgress |
s_fileSize |
s_FileSize |
s_filetime | in seconds
s_Handle |
s_hddFreeSizeKB | HACK_GTA4
s_Header |
s_Header_CritSec |
s_HoldoffDelta |
s_HoldoffTime |
s_IsCachePrimed | Assume the cache is primed if you never called fiDiskCache::InitClass, so that normal (non-megarpf) development will still get random start screens, etc.
s_IsValid |
s_LastError |
s_lastErrorCode |
s_LastThreadOwner |
s_Loads |
s_LocalHost |
s_location |
s_MaxNumberOfDirectories |
s_MemoryState |
s_ModifiedTimeHigh |
s_ModifiedTimeLow |
s_Mounts |
s_netError | see
s_netErrorCount |
s_NumInProgressBlocks |
s_numRpfs |
s_NumValidBlocks |
s_pDeviceUpdate |
s_PendingState |
s_Profiles |
s_Reader |
s_ResidentMap | Data structure which maps a source block to the cache block tracking it (the cache block itself may be either resident or pending)
s_SaveGameSizes |
s_Saves |
s_Selects |
s_setBuf |
s_setList |
s_ShutdownCacheWorkerThread |
s_SizeOfIconAndSystemFiles |
s_SizeOfSystemOverheads |
s_SpaceRequired |
s_SpaceRequiredToSaveThisFile |
s_States |
s_TcpIpInstance |
s_TcpIpLastError |
s_ThreadId |
s_TitleIdForSavesFolder |
s_TitleString |
s_TotalHDDFreeSize |
s_UserBindErrorMsg |
s_ZipfileOpen |
s_ZipOpen |
s_ZipStates |
SAVEGAME |
secureFileId |
SizeOfIconImage |
sm_ExtraSpaceRequired |
sm_FallbackToDefaultDevice |
sm_IsLoadedDataValid |
sm_MatchLongestPath |
sm_MatchNewest |
tls_Uncached | HACK HACK HACK
XCONTENT_DATA_SIZE |
XEX_TITLE_ID | HACK_GTA4
Enumerations
Enumeration | Description
eInstallDeviceStatus | the order of these enums makes it easier to combine several results into an overall one by taking the smallest value. this will indicate what's left to wait for or the "worst" result
eTypeOfSaveProcess | Changelist 130919 by Graeme Added ExtraSpaceCheck. It's almost identical to FreeSpaceCheck but gives a bit more information that I require when checking if there is enough space for save games and a profile file at the start of a PS3 game.
eTypeOfSpaceCheck | Changelist 130919 by Graeme - Added ExtraSpaceCheck. It's almost identical to FreeSpaceCheck but gives a bit more information that I require when checking if there is enough space for 13 save games and a profile file at the start of a PS3 game.
fiSeekWhence | Enumerant passed to fiDevice::Seek which determines the origin (start point) of the seek operation
Macros
Macro | Description
__ENABLE_RFS |
ASYNC_CACHE_COPIES | Whether cache misses are serviced asynchronously or not based on holdoff time.
CACHE_BLOCK_HANDLE |
CACHEDEV |
CORRUPT_FILE_CODE |
COULD_NOT_MAP_DEVICE_CODE |
dcDebugf1 | printf("[DiskCache] Debug1: " fmt "n",##__VA_ARGS__)
dcDebugf2 | printf("[DiskCache] Debug2: " fmt "n",##__VA_ARGS__)
dcDebugf3 | printf("[DiskCache] Debug3: " fmt "n",##__VA_ARGS__)
dcDisplayf |
dcErrorf |
dcWarningf |
DECLARE_STREAM_BUFFERS |
DIALOG_MODE | HACK_GTA4
DVD_DEVICE_NAME |
ENABLE_GAMEDATA_FOR_DISKCACHE |
FILE_ATTRIBUTE_ARCHIVE |
FILE_ATTRIBUTE_COMPRESSED |
FILE_ATTRIBUTE_DIRECTORY |
FILE_ATTRIBUTE_HIDDEN |
FILE_ATTRIBUTE_INVALID |
FILE_ATTRIBUTE_NORMAL |
FILE_ATTRIBUTE_NOT_CONTENT_INDEXED |
FILE_ATTRIBUTE_OFFLINE |
FILE_ATTRIBUTE_READONLY |
FILE_ATTRIBUTE_REPARSE_POINT |
FILE_ATTRIBUTE_SPARSE_FILE |
FILE_ATTRIBUTE_SYSTEM |
FILE_ATTRIBUTE_TEMPORARY |
IDABORT | Abort
IDCANCEL | Cancel
IDCONTINUE |
IDCUSTOM1 | following 4 ids MUST be sequential
IDCUSTOM2 |
IDCUSTOM3 |
IDCUSTOM4 |
IDIGNORE | Ignore
IDNO | No
IDOK | Ok
IDRETRY | Retry
IDTRYAGAIN |
IDYES | Yes
INSTALL_SLICE_NUM |
INSTALL_SLICE_SIZE |
MAX_CHARS_IN_TITLE_ID_FOR_SAVES_FOLDER | should never actually need more than 10 (9 + the null character)
MAX_DEVICE_NAME_LENGTH |
MAX_PARTITION_SIZE | 2 Gb per partition
MAX_XCONTENT_HANDLES |
MB_ABORTRETRYIGNORE | Abort / Retry / Ignore buttons
MB_APPLMODAL |
MB_CANCELTRYCONTINUE |
MB_DEFAULT_DESKTOP_ONLY |
MB_DEFBUTTON1 |
MB_DEFBUTTON2 |
MB_DEFBUTTON3 |
MB_DEFBUTTON4 |
MB_HELP | Help Button
MB_ICONASTERISK | Display asterisk icon
MB_ICONERROR | Display hand icon
MB_ICONHAND | Display hand icon
MB_ICONINFORMATION |
MB_ICONQUESTION | Display question icon
MB_NOFOCUS |
MB_OK | Ok button only
MB_OKCANCEL | Ok and cancel buttons
MB_RETRYCANCEL |
MB_RIGHT |
MB_SETFOREGROUND | Force to foreground window
MB_SYSTEMMODAL |
MB_TASKMODAL |
MB_TOPMOST | Force to topmost window
MB_YESNO | Yes / No buttons
MB_YESNOCANCEL | Yes / No / Cancel buttons
MULTIPLE_CACHE_FILES |
NO_FILES_EXIST_CODE |
PS3_FILE_HANDLE_HACK | TEMP: this only allows 240 rpfs to be installed and then it blocks the rest. temporary until we merge some of the rpfs, or make sony use a short
READ_PROGRESS_WATCHDOG |
READ_PROGRESS_WATCHDOG_ERROR_LIMIT_SECONDS |
REPLAY_SAVE_FILENAME |
s_Files |
s_Magic | The head and tail of the list simply live in slot zero, keeping the data simple.
s_Newest |
s_Oldest |
s_Slots |
SAVEGAME_STACK_SIZE |
SAVEGAME_STACK_SIZE_FOR_ENUMERATION |
sgDebug1 |
sgDebug2 |
sgDebug3 |
sgError |
sgWarning |
STATIC_STATE_BUFFERS |
STREAM_STORE_NAME |
THE_DEVICE_IS_NOT_READY_CODE |
USER_CANCELLED_DEVICE_SELECTION_CODE | define Xenon specific error codes
Links
Namespaces, Classes, Structs, Types, Functions, Variables, Enumerations, Macros


rage::fiSaveGameState Namespace

rage::fiSaveGameState Namespace
Enumerations | rage Namespace
Show All
Enumerations
Enumeration | Description
State |
Namespace

rage Namespace

Links
Enumerations, rage Namespace
Send comments on this topic.


rage::fiSaveGameState::State Enumeration

rage::fiSaveGameState::State Enumeration
rage::fiSaveGameState Namespace
Show All
C++
public: enum State {
  public: IDLE,
  public: HAD_ERROR,
  public: SELECTING_DEVICE,
  public: SELECTED_DEVICE,
  public: ENUMERATING_CONTENT,
  public: ENUMERATED_CONTENT,
  public: SAVING_CONTENT,
  public: SAVED_CONTENT,
  public: LOADING_CONTENT,
  public: LOADED_CONTENT,
  public: SAVING_ICON,
  public: SAVED_ICON,
  public: VERIFYING_CONTENT,
  public: VERIFIED_CONTENT,
  public: DELETING_CONTENT,
  public: DELETED_CONTENT,
  public: DELETING_CONTENT_FROM_LIST,
  public: DELETED_CONTENT_FROM_LIST,
  public: CHECKING_FREE_SPACE_NO_EXISTING_FILE,
  public: CHECKING_FREE_SPACE,
  public: HAVE_CHECKED_FREE_SPACE,
  public: CHECKING_EXTRA_SPACE_NO_EXISTING_FILE,
  public: CHECKING_EXTRA_SPACE,
  public: HAVE_CHECKED_EXTRA_SPACE,
  public: READING_NAMES_AND_SIZES_OF_ALL_SAVE_GAMES,
  public: HAVE_READ_NAMES_AND_SIZES_OF_ALL_SAVE_GAMES,
  public: GETTING_CREATOR,
  public: GOT_CREATOR,
  public: GETTING_FILE_SIZE,
  public: HAVE_GOT_FILE_SIZE,
  public: GETTING_FILE_MODIFIED_TIME,
  public: HAVE_GOT_FILE_MODIFIED_TIME
};
Members

GETTING_CREATOR
HACK_GTA4

Namespace

rage::fiSaveGameState Namespace

File

savegame.h

Links
rage::fiSaveGameState Namespace


fiArchive Class

fiArchive Class
Constructors | Members | Methods | Operators | rage Namespace | Inheritance Hierarchy
Show All
fiArchive
C++
public: class fiArchive;
Constructors
Constructor | Description
fiArchive |
Methods
Method | Description
GetVersion |
IsLoading |
IsStoring |
Operators
Operator | Description
& |
Namespace

rage Namespace

File

archive.h

Links
Constructors, Members, Methods, Operators, rage Namespace, Inheritance Hierarchy


fiArchive::fiArchive Constructor

fiArchive::fiArchive Constructor
fiArchive Class
Show All
C++
public: fiArchive(
    fiStream* f,
    bool loading,
    u16 version
);
Class

fiArchive Class

File

archive.h

Links
fiArchive Class


fiArchive::GetVersion Method

fiArchive::GetVersion Method
fiArchive Class
Show All
C++
public: u16 GetVersion() const;
Class

fiArchive Class

File

archive.h

Links
fiArchive Class


fiArchive::IsLoading Method

fiArchive::IsLoading Method
fiArchive Class
Show All
C++
public: bool IsLoading() const;
Class

fiArchive Class

File

archive.h

Links
fiArchive Class


fiArchive::IsStoring Method

fiArchive::IsStoring Method
fiArchive Class
Show All
C++
public: bool IsStoring() const;
Class

fiArchive Class

File

archive.h

Links
fiArchive Class


fiArchive::& Operator (Quaternion&)

fiArchive::& Operator (Quaternion&)
fiArchive Class
Show All
C++
public: void operator &(
    Quaternion& q
);
Class

fiArchive Class

File

archive.h

Links
fiArchive Class


fiArchive::& Operator (T&)

fiArchive::& Operator (T&)
fiArchive Class
Show All

Default serialization operator that calls a user defined member function. If the compiler fails here, then your data could not be serialized by any of the functions above, so try writing a custom function: void Serialize(rage::fiArchive&);

C++
public: template <class T> void operator &(
    T& t
);
Class

fiArchive Class

File

archive.h

Links
fiArchive Class


fiArchive::& Operator (Vector3&)

fiArchive::& Operator (Vector3&)
fiArchive Class
Show All
C++
public: void operator &(
    Vector3& v
);
Class

fiArchive Class

File

archive.h

Links
fiArchive Class


fiArchive::& Operator (char&)

fiArchive::& Operator (char&)
fiArchive Class
Show All
C++
public: void operator &(
    char& c
);
Class

fiArchive Class

File

archive.h

Links
fiArchive Class


fiArchive::& Operator (float&)

fiArchive::& Operator (float&)
fiArchive Class
Show All
C++
public: void operator &(
    float& f
);
Class

fiArchive Class

File

archive.h

Links
fiArchive Class


fiArchive::& Operator (int&)

fiArchive::& Operator (int&)
fiArchive Class
Show All
C++
public: void operator &(
    int& i
);
Class

fiArchive Class

File

archive.h

Links
fiArchive Class


fiArchive::& Operator (short&)

fiArchive::& Operator (short&)
fiArchive Class
Show All
C++
public: void operator &(
    short& i
);
Class

fiArchive Class

File

archive.h

Links
fiArchive Class


fiArchive::& Operator (std::pair<X, Y>&)

fiArchive::& Operator (std::pair<X, Y>&)
fiArchive Class
Show All

Serialize arbitrary STL pairs.

C++
public: template <class X, class Y> void operator &(
    std::pair<X, Y>& tuple
);
Class

fiArchive Class

File

archive.h

Links
fiArchive Class


fiArchive::& Operator (std::vector<T>&)

fiArchive::& Operator (std::vector<T>&)
fiArchive Class
Show All

Serialize arbitrary STL vectors.

C++
public: template <class T> void operator &(
    std::vector<T>& array
);
Class

fiArchive Class

File

archive.h

Links
fiArchive Class


fiArchive::& Operator (unsigned char&)

fiArchive::& Operator (unsigned char&)
fiArchive Class
Show All
C++
public: void operator &(
    unsigned char& c
);
Class

fiArchive Class

File

archive.h

Links
fiArchive Class


fiArchive::& Operator (unsigned int&)

fiArchive::& Operator (unsigned int&)
fiArchive Class
Show All
C++
public: void operator &(
    unsigned int& i
);
Class

fiArchive Class

File

archive.h

Links
fiArchive Class


fiArchive::& Operator (unsigned short&)

fiArchive::& Operator (unsigned short&)
fiArchive Class
Show All
C++
public: void operator &(
    unsigned short& i
);
Class

fiArchive Class

File

archive.h

Links
fiArchive Class


fiAsciiTokenizer Class

fiAsciiTokenizer Class Component
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All

fiAsciiTokenizer implements a concrete subclass of fiTokenizer for handling text files.

rage::fiBaseTokenizer
    fiAsciiTokenizer
        rage::fiTokenizer
C++
public: class fiAsciiTokenizer : public fiBaseTokenizer;
Constructors
Constructor | Description
fiAsciiTokenizer |
Destructors
Destructor | Description
~fiBaseTokenizer |
Methods
Method | Description
CheckIToken |
CheckToken |
EndBlock | Decreases the tab by one
EndBlock | Decreases the tab by one
EndLine | Starts a new line
EndLine | Starts a new line
EndOfFile |
GetBlock | get a block of "length" characters
GetByte | read functions:
GetByte | Reads a numerical value and returns it
GetDelimiter |
GetDelimiter |
GetFloat | Reads a numerical value and returns it
GetFloat | Reads a numerical value and returns it
GetHexU32 |
GetInt | Reads a numerical value and returns it
GetInt | Reads a numerical value and returns it
GetLine |
GetName |
GetNextCh |
GetShort | Reads a numerical value and returns it
GetShort | Reads a numerical value and returns it
GetStream |
GetStreamPosition |
GetToken | read functions:
GetTokenCh |
GetTokenToChar |
GetTokenToChars |
GetVector | Reads a numerical value and returns it
GetVector | Reads a numerical value and returns it
GetWriteState |
IgnoreToken |
Indent |
Indent |
Init |
IsBinary |
IsBinary |
iswhitespace |
MatchFloat |
MatchFloat |
MatchIFloat |
MatchIFloat |
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchIToken |
MatchIVector |
MatchIVector |
MatchToken |
MatchVector |
MatchVector |
Pop | pop the current block as defined by "{" and "}" delimiters. this will also pop any sub-blocks. useful for file formats in a state of flux.
Put |
Put |
PutByte |
PutByte |
PutDelimiter |
PutDelimiter |
PutShort |
PutShort |
PutStr |
PutStrLine | convenience functions
Reset |
SetNextCh |
SetStreamPosition |
SetTerminators | Sets a list of characters that should be used for terminating tokens and skipped over.
SetWriteState |
SkipComment |
SkipToEndOfLine |
StartBlock | Increases the tab by one
StartBlock | Increases the tab by one
StartLine | Indents by tab
StartLine | Indents by tab
WriteTabs |
Data Members
Data Member | Description
CommentChar |
filename |
line |
m_nNumTabs | Holds the current indentation tabs
m_WriteState |
nextch |
S |
Enumerations
Enumeration | Description
enState |
Namespace

rage Namespace

File

token.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


fiAsciiTokenizer::m_nNumTabs Data Member

fiAsciiTokenizer::m_nNumTabs Data Member
fiAsciiTokenizer Class
Show All

Holds the current indentation tabs

C++
protected: int m_nNumTabs;
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::fiAsciiTokenizer Constructor

fiAsciiTokenizer::fiAsciiTokenizer Constructor
fiAsciiTokenizer Class
Show All
C++
public: fiAsciiTokenizer();
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::EndBlock Method

fiAsciiTokenizer::EndBlock Method
fiAsciiTokenizer Class
Show All

Decreases the tab by one

C++
public: virtual void EndBlock();
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::EndLine Method

fiAsciiTokenizer::EndLine Method
fiAsciiTokenizer Class
Show All

Starts a new line

C++
public: virtual void EndLine();
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::GetByte Method

fiAsciiTokenizer::GetByte Method
fiAsciiTokenizer Class
Show All

read functions:

C++
public: int GetByte(
    const bool error = true
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::GetDelimiter Method

fiAsciiTokenizer::GetDelimiter Method
fiAsciiTokenizer Class
Show All
C++
public: void GetDelimiter(
    const char* de
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::GetHexU32 Method

fiAsciiTokenizer::GetHexU32 Method
fiAsciiTokenizer Class
Show All
C++
public: u32 GetHexU32(
    const bool error = true
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::Indent Method

fiAsciiTokenizer::Indent Method
fiAsciiTokenizer Class
Show All
C++
public: virtual void Indent(
    int i
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::IsBinary Method

fiAsciiTokenizer::IsBinary Method
fiAsciiTokenizer Class
Show All
C++
public: bool IsBinary() const;
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::MatchFloat Method

fiAsciiTokenizer::MatchFloat Method
fiAsciiTokenizer Class
Show All
C++
public: float MatchFloat(
    const char * match
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::MatchIFloat Method

fiAsciiTokenizer::MatchIFloat Method
fiAsciiTokenizer Class
Show All
C++
public: float MatchIFloat(
    const char * match
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::MatchIInt Method

fiAsciiTokenizer::MatchIInt Method
fiAsciiTokenizer Class
Show All

Case insensitive version of Match*. Match a token and return the subsequent value

C++
public: int MatchIInt(
    const char * match
);
Parameters

match
The token to match (matching is not case sensitive)
v
(if present) The vector return value

Returns

The matched value (for non-vector Match* calls)

Notes

For reading values in a format like "MaxVelocity 10.0"

Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::MatchInt Method

fiAsciiTokenizer::MatchInt Method
fiAsciiTokenizer Class
Show All

Match a token and return the subsequent value

C++
public: int MatchInt(
    const char * match
);
Parameters

match
The token to match (matching is case sensitive)
v
(if present) The vector return value

Returns

The matched value (for non-vector Match* calls)

Notes

For reading values in a format like "MaxVelocity 10.0"

Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::MatchIVector Method (const char *, Vec_xyz&)

fiAsciiTokenizer::MatchIVector Method (const char *, Vec_xyz&)
fiAsciiTokenizer Class
Show All
C++
public: void MatchIVector(
    const char * match,
    Vec_xyz& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::MatchIVector Method (const char *, Vec_xyzw&)

fiAsciiTokenizer::MatchIVector Method (const char *, Vec_xyzw&)
fiAsciiTokenizer Class
Show All
C++
public: void MatchIVector(
    const char * match,
    Vec_xyzw& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::MatchIVector Method (const char *, Vector2&)

fiAsciiTokenizer::MatchIVector Method (const char *, Vector2&)
fiAsciiTokenizer Class
Show All
C++
public: void MatchIVector(
    const char * match,
    Vector2& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::MatchIVector Method (const char *, Vector3&)

fiAsciiTokenizer::MatchIVector Method (const char *, Vector3&)
fiAsciiTokenizer Class
Show All
C++
public: void MatchIVector(
    const char * match,
    Vector3& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::MatchIVector Method (const char *, Vector4&)

fiAsciiTokenizer::MatchIVector Method (const char *, Vector4&)
fiAsciiTokenizer Class
Show All
C++
public: void MatchIVector(
    const char * match,
    Vector4& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::MatchVector Method (const char *, Vec_xyz&)

fiAsciiTokenizer::MatchVector Method (const char *, Vec_xyz&)
fiAsciiTokenizer Class
Show All
C++
public: void MatchVector(
    const char * match,
    Vec_xyz& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::MatchVector Method (const char *, Vec_xyzw&)

fiAsciiTokenizer::MatchVector Method (const char *, Vec_xyzw&)
fiAsciiTokenizer Class
Show All
C++
public: void MatchVector(
    const char * match,
    Vec_xyzw& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::MatchVector Method (const char *, Vector2&)

fiAsciiTokenizer::MatchVector Method (const char *, Vector2&)
fiAsciiTokenizer Class
Show All
C++
public: void MatchVector(
    const char * match,
    Vector2& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::MatchVector Method (const char *, Vector3&)

fiAsciiTokenizer::MatchVector Method (const char *, Vector3&)
fiAsciiTokenizer Class
Show All
C++
public: void MatchVector(
    const char * match,
    Vector3& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::MatchVector Method (const char *, Vector4&)

fiAsciiTokenizer::MatchVector Method (const char *, Vector4&)
fiAsciiTokenizer Class
Show All
C++
public: void MatchVector(
    const char * match,
    Vector4& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::Put Method (const Mat33V&)

fiAsciiTokenizer::Put Method (const Mat33V&)
fiAsciiTokenizer Class
Show All
C++
public: bool Put(
    const Mat33V& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::Put Method (const Mat34V&)

fiAsciiTokenizer::Put Method (const Mat34V&)
fiAsciiTokenizer Class
Show All
C++
public: bool Put(
    const Mat34V& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::Put Method (const ScalarV&)

fiAsciiTokenizer::Put Method (const ScalarV&)
fiAsciiTokenizer Class
Show All
C++
public: bool Put(
    const ScalarV& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::Put Method (const Vec2V&)

fiAsciiTokenizer::Put Method (const Vec2V&)
fiAsciiTokenizer Class
Show All
C++
public: bool Put(
    const Vec2V& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::Put Method (const Vec3V&)

fiAsciiTokenizer::Put Method (const Vec3V&)
fiAsciiTokenizer Class
Show All
C++
public: bool Put(
    const Vec3V& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::Put Method (const Vec4V&)

fiAsciiTokenizer::Put Method (const Vec4V&)
fiAsciiTokenizer Class
Show All
C++
public: bool Put(
    const Vec4V& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::Put Method (const Vector2&)

fiAsciiTokenizer::Put Method (const Vector2&)
fiAsciiTokenizer Class
Show All
C++
public: bool Put(
    const Vector2& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::Put Method (const Vector3&)

fiAsciiTokenizer::Put Method (const Vector3&)
fiAsciiTokenizer Class
Show All
C++
public: bool Put(
    const Vector3& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::Put Method (const Vector4&)

fiAsciiTokenizer::Put Method (const Vector4&)
fiAsciiTokenizer Class
Show All
C++
public: bool Put(
    const Vector4& v
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::Put Method (const char*, unsigned int)

fiAsciiTokenizer::Put Method (const char*, unsigned int)
fiAsciiTokenizer Class
Show All

write functions:

C++
public: bool Put(
    const char* src,
    unsigned int tabs = 0
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::Put Method (float)

fiAsciiTokenizer::Put Method (float)
fiAsciiTokenizer Class
Show All
C++
public: bool Put(
    float f
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::Put Method (int)

fiAsciiTokenizer::Put Method (int)
fiAsciiTokenizer Class
Show All
C++
public: bool Put(
    int i
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::PutByte Method

fiAsciiTokenizer::PutByte Method
fiAsciiTokenizer Class
Show All
C++
public: bool PutByte(
    int i
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::PutDelimiter Method

fiAsciiTokenizer::PutDelimiter Method
fiAsciiTokenizer Class
Show All
C++
public: bool PutDelimiter(
    const char* de
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::PutShort Method

fiAsciiTokenizer::PutShort Method
fiAsciiTokenizer Class
Show All
C++
public: bool PutShort(
    int i
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::StartBlock Method

fiAsciiTokenizer::StartBlock Method
fiAsciiTokenizer Class
Show All

Increases the tab by one

C++
public: virtual void StartBlock();
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::StartLine Method

fiAsciiTokenizer::StartLine Method
fiAsciiTokenizer Class
Show All

Indents by tab

C++
public: virtual void StartLine();
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAsciiTokenizer::WriteTabs Method

fiAsciiTokenizer::WriteTabs Method
fiAsciiTokenizer Class
Show All
C++
protected: void WriteTabs(
    int nNumTabs
);
Class

fiAsciiTokenizer Class

File

token.h

Links
fiAsciiTokenizer Class


fiAssetManager Class

fiAssetManager Class Component
Structs | Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All

fiAssetManager defines the notion of an asset root directory and a current asset folder. The folders can be stacked up to eight levels deep. The class acts as a virtual class factory for fiStream objects, applying several rules for inserting an implicit leading path and a file extension. See the documentation of PushFolder and FullPath for details of the rules.

fiAssetManager
C++
public: class fiAssetManager;
Structs
Struct | Description
Entry |
Constructors
Constructor | Description
fiAssetManager | Constructor
Destructors
Destructor | Description
~fiAssetManager | Destructor
Methods
Method | Description
AddExtension | Appends the "base.ext" to the dest buffer (unless base already ended with the right extensions) and normalizes slashes
BaseName | Utility function which returns the base name of a fully-qualified name.
ClearAttributes | Clear specific attributes of an asset
Create | Attempts to create a file
CreateLeadingPath | Creates any intermediate directories necessary for 'filename'
EnumFiles | Enumerate all files in a given directory through a user-supplied callback
Exists | Attempts to determine if a file exists
FileName | Utility function which returns the filename portion of a fully-qualified name.
FindExtensionInPath | Finds file extension in the specified filename.
FindPath | Returns the index of the path that contains the file given. Give this index to FullPath so that the appropriate full path is used, when there is more than one.
FullPath | Returns a fully-qualified pathname based on the input base name, input extension, current asset root, and current asset folder.
FullReadPath | Returns a fully-qualified pathname based on the input base name, input extension, current asset root, and current asset folder. Will search through all registered paths in order for the first match.
FullWritePath | Returns a fully-qualified pathname based on the input base name, input extension, current asset root, and current asset folder. Always uses the current write path (which is usually the first element, but that can be changed via the '*' special marker).
GetAttributes | Retrieve file attributes of an asset
GetPath |
GetPathCount |
GetStackedPath |
InsertPathElement | Inserts a path element between the path part (if present) and the filename part.
IsAbsolutePath | Returns true if the path name is an absolute path
MakeFolderRelative | Returns a folder relative path to an existing file based on the current path roots and pushed folders (if possible)
MakeRelative | Returns a relative path to an existing file based on the current path roots (if possible)
Open | Attempts to open a file
PopFolder | Pops the last folder off of the current asset folder stack.
PushFolder | Pushes new folder onto current asset folder stack
RemoveExtensionFromPath | Removes the extension from the specified filename if present. This function is more robust that just using strrchr because it stops at the first slash character so it doesn't screw up relative pathnames.
RemoveNameFromPath | Removes the last name in the path (and the resulting trailing slash or backslash)
SetAttributes | Set file attributes of an asset
SetPath | Sets the asset root path.
Data Members
Data Member | Description
MAX_FILENAME_LENGTH | Maximum length of the filename part of the filename on all supported platforms. Note that the entire pathname can be longer, this is just the longest allowed on any one segment of it. Limit is currently tied to Xbox FATX limit.
Namespace

rage Namespace

File

asset.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


fiAssetManager::MAX_FILENAME_LENGTH Data Member

fiAssetManager::MAX_FILENAME_LENGTH Data Member
fiAssetManager Class
Show All

Maximum length of the filename part of the filename on all supported platforms. Note that the entire pathname can be longer, this is just the longest allowed on any one segment of it. Limit is currently tied to Xbox FATX limit.

C++
public: static const int MAX_FILENAME_LENGTH = 42;
Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


rage::fiAssetManager::Entry Struct

rage::fiAssetManager::Entry Struct
fiAssetManager Class
Show All
C++
private: struct Entry {
  public: char folder[RAGE_MAX_PATH];
};
Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::fiAssetManager Constructor

fiAssetManager::fiAssetManager Constructor
fiAssetManager Class
Show All

Constructor

C++
public: fiAssetManager();
Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::~fiAssetManager Destructor

fiAssetManager::~fiAssetManager Destructor
fiAssetManager Class
Show All

Destructor

C++
public: ~fiAssetManager();
Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::AddExtension Method

fiAssetManager::AddExtension Method
fiAssetManager Class
Show All

Appends the "base.ext" to the dest buffer (unless base already ended with the right extensions) and normalizes slashes

C++
public: void AddExtension(
    char* dest,
    int maxLen,
    const char* base,
    const char * ext
);
Parameters

dest
Input and output buffer
base
Source filename
ext
the extension to append
destSize
sizeof(dest)

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::BaseName Method

fiAssetManager::BaseName Method
fiAssetManager Class
Show All

Utility function which returns the base name of a fully-qualified name.

C++
public: static void BaseName(
    char * outBase,
    int bufSize,
    const char * name
);
Parameters

outBase
Output buffer
bufSize
sizeof(outBase)
name
Input name

Notes

Simply copies name up to the first '.' character, so it doesn't deal with relative pathnames the way you'd expect.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::ClearAttributes Method

fiAssetManager::ClearAttributes Method
fiAssetManager Class
Show All

Clear specific attributes of an asset

C++
public: bool ClearAttributes(
    const char * name,
    const char * ext,
    u32 attrToClear
);
Parameters

name
Base name (as per FullPath)
ext
Extension (as per FullPath)
attrToClear
Attributes to clear on file

Returns

True on success, else false.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::Create Method

fiAssetManager::Create Method
fiAssetManager Class
Show All

Attempts to create a file

C++
public: fiStream * Create(
    const char * base,
    const char * ext,
    bool probeOnly = false
);
Parameters

base
Base name of file as per FullPath
ext
Extension of file as per FullPath
probeOnly
If false (the default), report missing files to tty.

Returns

Pointer to stream or NULL on failure.

Notes

Only uses the "write path", which is normally the first one listed in the SetPath call, but this can be changed by putting '*' in front of the path element you want write paths to go to.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::CreateLeadingPath Method

fiAssetManager::CreateLeadingPath Method
fiAssetManager Class
Show All

Creates any intermediate directories necessary for 'filename'

C++
public: bool CreateLeadingPath(
    const char * filename
);
Parameters

filename
Path to create (last part is ignored)

Returns

True on success

Notes

CreateLeadingPath("$/some/path/name") will create directory some/path, NOT some/path/name. This is so that you can pass the same name to ASSET.Create immediately after calling this function.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::EnumFiles Method

fiAssetManager::EnumFiles Method
fiAssetManager Class
Show All

Enumerate all files in a given directory through a user-supplied callback

C++
public: int EnumFiles(
    const char * directory,
    void (*callback)(const fiFindData &data,void *userArg),
    void * userArg
);
Parameters

directory
Directory to enumerate
userArg
closure for user callback
callback
Callback function to invoke

Returns

Total number of files enumerated (ie number of times callback was invoked)

Notes

You will need to #include "file/device.h" to get the definition of fiFindData. We don't include it here to reduce dependencies.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::Exists Method

fiAssetManager::Exists Method
fiAssetManager Class
Show All

Attempts to determine if a file exists

C++
public: bool Exists(
    const char * base,
    const char * ext
);
Parameters

base
Base name of file as per FullPath
ext
Extension of file as per FullPath

Returns

True if file exists.

Notes

This function internally calls FullReadPath, which doesn't actually open the file; instead, it just checks that it can successfully retrieve file attributes.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::FileName Method

fiAssetManager::FileName Method
fiAssetManager Class
Show All

Utility function which returns the filename portion of a fully-qualified name.

C++
public: static const char * FileName(
    const char * name
);
Parameters

name
filename to scan

Returns

Pointer to filename portion of the name; this is always within name itself and is simply the first character after the last slash in the string.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::FindExtensionInPath Method

fiAssetManager::FindExtensionInPath Method
fiAssetManager Class
Show All

Finds file extension in the specified filename.

C++
public: static const char* FindExtensionInPath(
    const char* path
);
Parameters

path
the path to search for the file extension

Returns

NULL if the extension isn't found, otherwise a pointer to the extension including the '.'.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::FindPath Method

fiAssetManager::FindPath Method
fiAssetManager Class
Show All

Returns the index of the path that contains the file given. Give this index to FullPath so that the appropriate full path is used, when there is more than one.

C++
public: int FindPath(
    const char* base,
    const char* ext,
    bool printFailures = false
);
Parameters

base
base name of file
ext
extension for file printFailures (optional)

Returns

-1 = file not found in any paths 0+ = the index of the path that the file was found in

Notes

When multiple paths are used by the game ("-path=T:rdr2game;*T:rdr2assets") FullPath only uses the first one. This is because FullPath has no way of knowing which one is correct (Open() in contrast scans them all because it knows exactly what file it's looking for). This is a huge problem when game code tries to expand a relative path before searching for files. And while FullPath lets the calling code ask for a particular path index, the game may not know (for example, FILE A doesn't know which zips were mounted by FILE B, and even if it does, it doesn't know what internal "index" code this class is using for them). Using this function, game code can determine that index code by passing a filename known to exist in the archive.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::FullPath Method

fiAssetManager::FullPath Method
fiAssetManager Class
Show All

Returns a fully-qualified pathname based on the input base name, input extension, current asset root, and current asset folder.

C++
public: void FullPath(
    char * outDest,
    int maxLen,
    const char * base,
    const char * ext,
    int pathIndex = 0
);
Parameters

outDest
Destination buffer to receive fully-qualified filename
maxLen
sizeof(outDest)
base
base name of file
ext
extension for file.
pathIndex
Which path (starting from zero) to use

Notes

If base begins with a drive letter, a slash, or "..", it is treated as an absolute path and does not have the asset root or current asset folder inserted before it; otherwise, if base begins with '$' it has the asset root inserted before it but not the current asset folder. Otherwise, if it is not an absolute path and does not begin with '$', both the asset root and current asset folder are inserted. Finally, if ext is not an empty string and base does not already have an extension, or the extension it has does not match ext, ext is appended to the resulting filename. If the asset root is "c:/assets" and the topmost folder is "textures" then:

  • FullPath(...,"image","dds") will be "c:/assets/textures/image.dds".
  • FullPath(...,"image.dds","dds") will be "c:/assets/textures/image.dds".
  • FullPath(...,"c:/whatever/image.dds","") will be "c:/whatever/image.dds".
  • FullPath(...,"$/tuning.txt","txt") will be "c:/assets/tuning.txt".
Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::FullReadPath Method

fiAssetManager::FullReadPath Method
fiAssetManager Class
Show All

Returns a fully-qualified pathname based on the input base name, input extension, current asset root, and current asset folder. Will search through all registered paths in order for the first match.

C++
public: bool FullReadPath(
    char * outDest,
    int maxLen,
    const char * base,
    const char * ext
);
Parameters

outDest
Destination buffer to receive fully-qualified filename
maxLen
sizeof(outDest)
base
base name of file
ext
extension for file.

Returns

True if the file could be found.

Notes

See FullPath notes for details on exact algorithm.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::FullWritePath Method

fiAssetManager::FullWritePath Method
fiAssetManager Class
Show All

Returns a fully-qualified pathname based on the input base name, input extension, current asset root, and current asset folder. Always uses the current write path (which is usually the first element, but that can be changed via the '*' special marker).

C++
public: void FullWritePath(
    char * outDest,
    int maxLen,
    const char * base,
    const char * ext
);
Parameters

outDest
Destination buffer to receive fully-qualified filename
maxLen
sizeof(outDest)
base
base name of file
ext
extension for file.

Notes

See FullPath notes for details on exact algorithm.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::GetAttributes Method

fiAssetManager::GetAttributes Method
fiAssetManager Class
Show All

Retrieve file attributes of an asset

C++
public: u32 GetAttributes(
    const char * name,
    const char * ext
);
Parameters

name
Base name (as per FullPath)
ext
Extension (as per FullPath)

Returns

FILE_ATTRIBUTE_INVALID on failure, or current file attributes.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::GetPath Method

fiAssetManager::GetPath Method
fiAssetManager Class
Show All
C++
public: inline const char * GetPath(
    int pathIndex = 0
);
Returns

Current asset root path (index based at zero)

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::GetPathCount Method

fiAssetManager::GetPathCount Method
fiAssetManager Class
Show All
C++
public: inline int GetPathCount() const;
Returns

Number of paths

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::GetStackedPath Method

fiAssetManager::GetStackedPath Method
fiAssetManager Class
Show All
C++
public: void GetStackedPath(
    char * dest,
    int maxLen,
    int pathIndex = 0
);
Returns

Current asset root path plus Pushed entries (if any)

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::InsertPathElement Method

fiAssetManager::InsertPathElement Method
fiAssetManager Class
Show All

Inserts a path element between the path part (if present) and the filename part.

C++
public: static bool InsertPathElement(
    char * inoutBuffer,
    int bufferSize,
    const char * insert,
    const char* insertAfter = NULL
);
Parameters

inoutBuffer
Buffer containing the path
bufferSize
Size of the buffer
insert
String to insert
insertAfter
place in inoutBuffer after which insert will be added (NULL means after last '/')

Returns

False if name would become too long, else true on success

Notes

The input buffer should already be normalized to forward slashes (ie probably the output of ASSET.FullPath) and the insert string should not start or end with a slash)

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::IsAbsolutePath Method

fiAssetManager::IsAbsolutePath Method
fiAssetManager Class
Show All

Returns true if the path name is an absolute path

C++
public: bool IsAbsolutePath(
    const char* path
);
Parameters

path
Path to a file or directory

Returns

True if the path name is absolute

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::MakeFolderRelative Method

fiAssetManager::MakeFolderRelative Method
fiAssetManager Class
Show All

Returns a folder relative path to an existing file based on the current path roots and pushed folders (if possible)

C++
public: bool MakeFolderRelative(
    char* dest,
    int destSize,
    const char* src
);
Parameters

dest
Output buffer
destSize
sizeof(dest)
src
Source filename

Returns

True if the result path is relative

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::MakeRelative Method

fiAssetManager::MakeRelative Method
fiAssetManager Class
Show All

Returns a relative path to an existing file based on the current path roots (if possible)

C++
public: bool MakeRelative(
    char* dest,
    int destSize,
    const char* src
);
Parameters

dest
Output buffer
destSize
sizeof(dest)
src
Source filename

Returns

True if the result path is relative

Notes

This function will assert if the result of MakeRelative would actually point to a different file than the input. For example your path was "T:/dir/;N:/dir/" both roots had a file named file.file and you called MakeRelative with "N:/dir/file.file"

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::Open Method

fiAssetManager::Open Method
fiAssetManager Class
Show All

Attempts to open a file

C++
public: fiStream * Open(
    const char * base,
    const char * ext,
    bool probeOnly = false,
    bool readOnly = true
);
Parameters

base
Base name of file as per FullPath
ext
Extension of file as per FullPath
probeOnly
If false (the default), report missing files to tty.
readOnly
If true (the default), open file for read-only access.

Returns

Pointer to stream or NULL on failure.

Notes

Tries all known path entries in order listed.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::PopFolder Method

fiAssetManager::PopFolder Method
fiAssetManager Class
Show All

Pops the last folder off of the current asset folder stack.

C++
public: void PopFolder();
Notes

Will assert out on stack underflow.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::PushFolder Method

fiAssetManager::PushFolder Method
fiAssetManager Class
Show All

Pushes new folder onto current asset folder stack

C++
public: void PushFolder(
    const char * folder
);
Parameters

folder
New folder

Notes

If folder begins with '$', it is treated as being relative to the path specified by SetPath. Otherwise, it is treated as being relative to the next folder up the stack (or the empty string if the folder stack is empty). The stack is currently a maximum of eight levels deep and will assert if you overflow it.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::RemoveExtensionFromPath Method

fiAssetManager::RemoveExtensionFromPath Method
fiAssetManager Class
Show All

Removes the extension from the specified filename if present. This function is more robust that just using strrchr because it stops at the first slash character so it doesn't screw up relative pathnames.

C++
public: static void RemoveExtensionFromPath(
    char * dest,
    int destSize,
    const char * src
);
Parameters

dest
Output buffer
destSize
sizeof(dest)
src
Source filename

Notes

dest and src can be the same.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::RemoveNameFromPath Method

fiAssetManager::RemoveNameFromPath Method
fiAssetManager Class
Show All

Removes the last name in the path (and the resulting trailing slash or backslash)

C++
public: static void RemoveNameFromPath(
    char * dest,
    int destSize,
    const char * src
);
Parameters

dest
Output buffer
destSize
sizeof(dest)
src
Source filename

Notes

dest and src can be the same.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::SetAttributes Method

fiAssetManager::SetAttributes Method
fiAssetManager Class
Show All

Set file attributes of an asset

C++
public: bool SetAttributes(
    const char * name,
    const char * ext,
    u32 attributes
);
Parameters

name
Base name (as per FullPath)
ext
Extension (as per FullPath)
attributes
New attributes to set on file

Returns

True on success, else false.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAssetManager::SetPath Method

fiAssetManager::SetPath Method
fiAssetManager Class
Show All

Sets the asset root path.

C++
public: void SetPath(
    const char * path
);
Parameters

path
New fully-qualified asset root path.

Notes

In general, you should point SetPath at the root of your game asset directory tree and use PushFolder and PopFolder to change your current working directory. You can pass multiple locations in a single string by separating them with semicolons; they will be searched in order in any Open call. All Create calls use only the first element listed by default, although you can switch to a different element by putting an '*' sign before the path: for example, -path=game:assets;*t:gameassets.

Class

fiAssetManager Class

File

asset.h

Links
fiAssetManager Class


fiAsynchStream Class

fiAsynchStream Class
Constructors | Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All

This class implements a wrapper that allows code to asynchronously read a file into memory (via a polling interface) and then, once the operation is complete, present a normal fiStream* object that is a memory stream that will automatically free itself when the file is closed.

fiAsynchStream
C++
public: class fiAsynchStream;
Constructors
Constructor | Description
fiAsynchStream |
Destructors
Destructor | Description
~fiAsynchStream |
Methods
Method | Description
GetMemoryFileName | If the file has finished streaming in, returns a suitable memory filename that can be passed to any function that expects a filename. PARMS: dest - Destination buffer for name destSize - sizeof(dest);
GetSize |
Init | Uses ASSET.Open semantics to attempt to asynchronously schedule the file open. Will not block if (and only if) you're using archives.
Poll | Determine if the file operation has completed yet.
Namespace

rage Namespace

File

asynchstream.h

Links
Constructors, Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


fiAsynchStream::fiAsynchStream Constructor

fiAsynchStream::fiAsynchStream Constructor
fiAsynchStream Class
Show All
C++
public: fiAsynchStream();
Class

fiAsynchStream Class

File

asynchstream.h

Links
fiAsynchStream Class


fiAsynchStream::~fiAsynchStream Destructor

fiAsynchStream::~fiAsynchStream Destructor
fiAsynchStream Class
Show All
C++
public: ~fiAsynchStream();
Class

fiAsynchStream Class

File

asynchstream.h

Links
fiAsynchStream Class


fiAsynchStream::GetMemoryFileName Method

fiAsynchStream::GetMemoryFileName Method
fiAsynchStream Class
Show All

If the file has finished streaming in, returns a suitable memory filename that can be passed to any function that expects a filename. PARMS: dest - Destination buffer for name destSize - sizeof(dest);

C++
public: bool GetMemoryFileName(
    char * dest,
    int destSize
);
Returns

True if the file loading is complete (and fills in the name), else false.

Notes

The memory for the file will be automatically freed after the file is closed. Note that if the file doesn't open properly for some reason, you will get a memory leak. It may be better to use Poll instead, which calls this function internally and automatically frees the storage memory if the file couldn't be opened for some reason.

Class

fiAsynchStream Class

File

asynchstream.h

Links
fiAsynchStream Class


fiAsynchStream::GetSize Method

fiAsynchStream::GetSize Method
fiAsynchStream Class
Show All
C++
public: u32 GetSize() const;
Returns

Size of file (only valid if Init returned true)

Class

fiAsynchStream Class

File

asynchstream.h

Links
fiAsynchStream Class


fiAsynchStream::Init Method (const char *, const char *)

fiAsynchStream::Init Method (const char *, const char *)
fiAsynchStream Class
Show All

Uses ASSET.Open semantics to attempt to asynchronously schedule the file open. Will not block if (and only if) you're using archives.

C++
public: bool Init(
    const char * filename,
    const char * ext
);
Parameters

filename
as per ASSET.Open
ext
as per ASSET.Open

Returns

True if the file could be found (and scheduled), else false

Class

fiAsynchStream Class

File

asynchstream.h

Links
fiAsynchStream Class


fiAsynchStream::Init Method (const char *, const char *, int, int)

fiAsynchStream::Init Method (const char *, const char *, int, int)
fiAsynchStream Class
Show All
C++
public: bool Init(
    const char * filename,
    const char * ext,
    int offset,
    int size
);
Class

fiAsynchStream Class

File

asynchstream.h

Links
fiAsynchStream Class


fiAsynchStream::Poll Method

fiAsynchStream::Poll Method
fiAsynchStream Class
Show All

Determine if the file operation has completed yet.

C++
public: fiStream * Poll();
Returns

Valid fiStream if the operation completed, else NULL.

Notes

You must close the resulting stream or you'll get a memory leak.

Class

fiAsynchStream Class

File

asynchstream.h

Links
fiAsynchStream Class


fiBaseTokenizer Class

fiBaseTokenizer Class Component
Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All

fiBaseTokenizer implements a simple word-based file tokenizer.

Its use is deprecated in new code so it will not be documented further.

fiBaseTokenizer
    rage::fiAsciiTokenizer
    rage::fiBinTokenizer
C++
public: class fiBaseTokenizer;
Destructors
Destructor | Description
~fiBaseTokenizer |
Methods
Method | Description
CheckIToken |
CheckToken |
EndBlock | Decreases the tab by one
EndLine | Starts a new line
EndOfFile |
GetBlock | get a block of "length" characters
GetByte | Reads a numerical value and returns it
GetDelimiter |
GetFloat | Reads a numerical value and returns it
GetInt | Reads a numerical value and returns it
GetLine |
GetName |
GetNextCh |
GetShort | Reads a numerical value and returns it
GetStream |
GetStreamPosition |
GetToken | read functions:
GetTokenCh |
GetTokenToChar |
GetTokenToChars |
GetVector | Reads a numerical value and returns it
GetWriteState |
IgnoreToken |
Indent |
Init |
IsBinary |
iswhitespace |
MatchFloat |
MatchIFloat |
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchIToken |
MatchIVector |
MatchToken |
MatchVector |
Pop | pop the current block as defined by "{" and "}" delimiters. this will also pop any sub-blocks. useful for file formats in a state of flux.
Put |
PutByte |
PutDelimiter |
PutShort |
PutStr |
PutStrLine | convenience functions
Reset |
SetNextCh |
SetStreamPosition |
SetTerminators | Sets a list of characters that should be used for terminating tokens and skipped over.
SetWriteState |
SkipComment |
SkipToEndOfLine |
StartBlock | Increases the tab by one
StartLine | Indents by tab
Data Members
Data Member | Description
CommentChar |
filename |
line |
m_WriteState |
nextch |
S |
Enumerations
Enumeration | Description
enState |
Namespace

rage Namespace

File

token.h

Links
Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


fiBaseTokenizer::CommentChar Data Member

fiBaseTokenizer::CommentChar Data Member
fiBaseTokenizer Class
Show All
C++
public: static int CommentChar;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::filename Data Member

fiBaseTokenizer::filename Data Member
fiBaseTokenizer Class
Show All
C++
public: const char * filename;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::line Data Member

fiBaseTokenizer::line Data Member
fiBaseTokenizer Class
Show All
C++
public: int line;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::m_WriteState Data Member

fiBaseTokenizer::m_WriteState Data Member
fiBaseTokenizer Class
Show All
C++
protected: protected: enum enState {
  public: OTHER,
  public: STARTLINE,
  public: ENDLINE
} m_WriteState;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::nextch Data Member

fiBaseTokenizer::nextch Data Member
fiBaseTokenizer Class
Show All
C++
protected: int nextch;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::S Data Member

fiBaseTokenizer::S Data Member
fiBaseTokenizer Class
Show All
C++
protected: fiStream * S;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::~fiBaseTokenizer Destructor

fiBaseTokenizer::~fiBaseTokenizer Destructor
fiBaseTokenizer Class
Show All
C++
public: virtual ~fiBaseTokenizer();
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::CheckIToken Method

fiBaseTokenizer::CheckIToken Method
fiBaseTokenizer Class
Show All
C++
public: bool CheckIToken(
    const char * check,
    bool consume = true
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::CheckToken Method

fiBaseTokenizer::CheckToken Method
fiBaseTokenizer Class
Show All
C++
public: bool CheckToken(
    const char * check,
    bool consume = true
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::EndBlock Method

fiBaseTokenizer::EndBlock Method
fiBaseTokenizer Class
Show All

Decreases the tab by one

C++
public: virtual void EndBlock();
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::EndLine Method

fiBaseTokenizer::EndLine Method
fiBaseTokenizer Class
Show All

Starts a new line

C++
public: virtual void EndLine();
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::EndOfFile Method

fiBaseTokenizer::EndOfFile Method
fiBaseTokenizer Class
Show All
C++
public: virtual bool EndOfFile();
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::GetBlock Method

fiBaseTokenizer::GetBlock Method
fiBaseTokenizer Class
Show All

get a block of "length" characters

C++
public: int GetBlock(
    char * dest,
    int length
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::GetByte Method

fiBaseTokenizer::GetByte Method
fiBaseTokenizer Class
Show All

Reads a numerical value and returns it

C++
public: virtual int GetByte(
    const bool error = true
) = 0;
Parameters

v
(if present) The vector return value

Returns

The value read in (for non-vector Get* calls)

Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::GetDelimiter Method

fiBaseTokenizer::GetDelimiter Method
fiBaseTokenizer Class
Show All
C++
public: virtual void GetDelimiter(
    const char* de
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::GetLine Method

fiBaseTokenizer::GetLine Method
fiBaseTokenizer Class
Show All
C++
public: int GetLine(
    char * dest,
    int maxLen,
    bool stripWhiteSpace = true
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::GetName Method

fiBaseTokenizer::GetName Method
fiBaseTokenizer Class
Show All
C++
public: const char * GetName();
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::GetNextCh Method

fiBaseTokenizer::GetNextCh Method
fiBaseTokenizer Class
Show All
C++
public: int GetNextCh() const;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::GetStream Method

fiBaseTokenizer::GetStream Method
fiBaseTokenizer Class
Show All
C++
public: fiStream * GetStream();
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::GetStreamPosition Method

fiBaseTokenizer::GetStreamPosition Method
fiBaseTokenizer Class
Show All
C++
public: int GetStreamPosition();
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::GetToken Method

fiBaseTokenizer::GetToken Method
fiBaseTokenizer Class
Show All

read functions:

C++
public: virtual int GetToken(
    char * dest,
    int maxLen
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::GetTokenCh Method

fiBaseTokenizer::GetTokenCh Method
fiBaseTokenizer Class
Show All
C++
protected: int GetTokenCh();
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::GetTokenToChar Method

fiBaseTokenizer::GetTokenToChar Method
fiBaseTokenizer Class
Show All
C++
public: int GetTokenToChar(
    char * dest,
    int maxLen,
    char terminator,
    bool stripWhiteSpace = true
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::GetTokenToChars Method

fiBaseTokenizer::GetTokenToChars Method
fiBaseTokenizer Class
Show All
C++
public: int GetTokenToChars(
    char * dest,
    int maxLen,
    const char* terminators,
    int numTerminators,
    char& terminator,
    bool stripWhiteSpace = true
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::GetWriteState Method

fiBaseTokenizer::GetWriteState Method
fiBaseTokenizer Class
Show All
C++
public: int GetWriteState() const;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::IgnoreToken Method

fiBaseTokenizer::IgnoreToken Method
fiBaseTokenizer Class
Show All
C++
public: void IgnoreToken();
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::Indent Method

fiBaseTokenizer::Indent Method
fiBaseTokenizer Class
Show All
C++
public: virtual void Indent(
    int
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::Init Method

fiBaseTokenizer::Init Method
fiBaseTokenizer Class
Show All
C++
public: void Init(
    const char * name,
    fiStream * s
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::IsBinary Method

fiBaseTokenizer::IsBinary Method
fiBaseTokenizer Class
Show All
C++
public: virtual bool IsBinary() = 0 const;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::iswhitespace Method

fiBaseTokenizer::iswhitespace Method
fiBaseTokenizer Class
Show All
C++
protected: inline int iswhitespace(
    int ch
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::MatchFloat Method

fiBaseTokenizer::MatchFloat Method
fiBaseTokenizer Class
Show All
C++
public: virtual float MatchFloat(
    const char * match
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::MatchIFloat Method

fiBaseTokenizer::MatchIFloat Method
fiBaseTokenizer Class
Show All
C++
public: virtual float MatchIFloat(
    const char * match
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::MatchIInt Method

fiBaseTokenizer::MatchIInt Method
fiBaseTokenizer Class
Show All

Case insensitive version of Match*. Match a token and return the subsequent value

C++
public: virtual int MatchIInt(
    const char * match
) = 0;
Parameters

match
The token to match (matching is not case sensitive)
v
(if present) The vector return value

Returns

The matched value (for non-vector Match* calls)

Notes

For reading values in a format like "MaxVelocity 10.0"

Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::MatchInt Method

fiBaseTokenizer::MatchInt Method
fiBaseTokenizer Class
Show All

Match a token and return the subsequent value

C++
public: virtual int MatchInt(
    const char * match
) = 0;
Parameters

match
The token to match (matching is case sensitive)
v
(if present) The vector return value

Returns

The matched value (for non-vector Match* calls)

Notes

For reading values in a format like "MaxVelocity 10.0"

Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::MatchIToken Method

fiBaseTokenizer::MatchIToken Method
fiBaseTokenizer Class
Show All
C++
public: void MatchIToken(
    const char * match
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::MatchIVector Method (const char *, Vec_xyz&)

fiBaseTokenizer::MatchIVector Method (const char *, Vec_xyz&)
fiBaseTokenizer Class
Show All
C++
public: virtual void MatchIVector(
    const char * match,
    Vec_xyz& v
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::MatchIVector Method (const char *, Vec_xyzw&)

fiBaseTokenizer::MatchIVector Method (const char *, Vec_xyzw&)
fiBaseTokenizer Class
Show All
C++
public: virtual void MatchIVector(
    const char * match,
    Vec_xyzw& v
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::MatchIVector Method (const char *, Vector2&)

fiBaseTokenizer::MatchIVector Method (const char *, Vector2&)
fiBaseTokenizer Class
Show All
C++
public: virtual void MatchIVector(
    const char * match,
    Vector2& v
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::MatchIVector Method (const char *, Vector3&)

fiBaseTokenizer::MatchIVector Method (const char *, Vector3&)
fiBaseTokenizer Class
Show All
C++
public: virtual void MatchIVector(
    const char * match,
    Vector3& v
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::MatchIVector Method (const char *, Vector4&)

fiBaseTokenizer::MatchIVector Method (const char *, Vector4&)
fiBaseTokenizer Class
Show All
C++
public: virtual void MatchIVector(
    const char * match,
    Vector4& v
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::MatchToken Method

fiBaseTokenizer::MatchToken Method
fiBaseTokenizer Class
Show All
C++
public: void MatchToken(
    const char * match
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::MatchVector Method (const char *, Vec_xyz&)

fiBaseTokenizer::MatchVector Method (const char *, Vec_xyz&)
fiBaseTokenizer Class
Show All
C++
public: virtual void MatchVector(
    const char * match,
    Vec_xyz& v
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::MatchVector Method (const char *, Vec_xyzw&)

fiBaseTokenizer::MatchVector Method (const char *, Vec_xyzw&)
fiBaseTokenizer Class
Show All
C++
public: virtual void MatchVector(
    const char * match,
    Vec_xyzw& v
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::MatchVector Method (const char *, Vector2&)

fiBaseTokenizer::MatchVector Method (const char *, Vector2&)
fiBaseTokenizer Class
Show All
C++
public: virtual void MatchVector(
    const char * match,
    Vector2& v
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::MatchVector Method (const char *, Vector3&)

fiBaseTokenizer::MatchVector Method (const char *, Vector3&)
fiBaseTokenizer Class
Show All
C++
public: virtual void MatchVector(
    const char * match,
    Vector3& v
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::MatchVector Method (const char *, Vector4&)

fiBaseTokenizer::MatchVector Method (const char *, Vector4&)
fiBaseTokenizer Class
Show All
C++
public: virtual void MatchVector(
    const char * match,
    Vector4& v
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::Pop Method

fiBaseTokenizer::Pop Method
fiBaseTokenizer Class
Show All

pop the current block as defined by "{" and "}" delimiters. this will also pop any sub-blocks. useful for file formats in a state of flux.

C++
public: void Pop();
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::Put Method (bool)

fiBaseTokenizer::Put Method (bool)
fiBaseTokenizer Class
Show All
C++
public: bool Put(
    bool b
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::Put Method (char)

fiBaseTokenizer::Put Method (char)
fiBaseTokenizer Class
Show All

virtual

C++
public: bool Put(
    char c
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::Put Method (const Vector2&)

fiBaseTokenizer::Put Method (const Vector2&)
fiBaseTokenizer Class
Show All
C++
public: virtual bool Put(
    const Vector2& f
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::Put Method (const Vector3&)

fiBaseTokenizer::Put Method (const Vector3&)
fiBaseTokenizer Class
Show All
C++
public: virtual bool Put(
    const Vector3& f
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::Put Method (const Vector4&)

fiBaseTokenizer::Put Method (const Vector4&)
fiBaseTokenizer Class
Show All
C++
public: virtual bool Put(
    const Vector4& f
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::Put Method (const char*, unsigned int)

fiBaseTokenizer::Put Method (const char*, unsigned int)
fiBaseTokenizer Class
Show All

write functions:

C++
public: virtual bool Put(
    const char* src,
    unsigned int tabs = 0
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::Put Method (float)

fiBaseTokenizer::Put Method (float)
fiBaseTokenizer Class
Show All
C++
public: virtual bool Put(
    float f
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::Put Method (int)

fiBaseTokenizer::Put Method (int)
fiBaseTokenizer Class
Show All
C++
public: virtual bool Put(
    int i
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::PutByte Method

fiBaseTokenizer::PutByte Method
fiBaseTokenizer Class
Show All
C++
public: virtual bool PutByte(
    int i
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::PutDelimiter Method

fiBaseTokenizer::PutDelimiter Method
fiBaseTokenizer Class
Show All
C++
public: virtual bool PutDelimiter(
    const char* de
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::PutShort Method

fiBaseTokenizer::PutShort Method
fiBaseTokenizer Class
Show All
C++
public: virtual bool PutShort(
    int i
) = 0;
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::PutStr Method

fiBaseTokenizer::PutStr Method
fiBaseTokenizer Class
Show All
C++
public: bool PutStr(
    const char* fmt,
    ...
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::PutStrLine Method

fiBaseTokenizer::PutStrLine Method
fiBaseTokenizer Class
Show All

convenience functions

C++
public: bool PutStrLine(
    const char* fmt,
    ...
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::Reset Method

fiBaseTokenizer::Reset Method
fiBaseTokenizer Class
Show All
C++
public: void Reset();
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::SetNextCh Method

fiBaseTokenizer::SetNextCh Method
fiBaseTokenizer Class
Show All
C++
public: void SetNextCh(
    int nextchvalue
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::SetStreamPosition Method

fiBaseTokenizer::SetStreamPosition Method
fiBaseTokenizer Class
Show All
C++
public: void SetStreamPosition(
    int position
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::SetTerminators Method

fiBaseTokenizer::SetTerminators Method
fiBaseTokenizer Class
Show All

Sets a list of characters that should be used for terminating tokens and skipped over.

C++
public: void SetTerminators(
    const char* t
);
Notes

This *must* be a pointer to static string storage (ie a C string constant such as ",:/")

Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::SetWriteState Method

fiBaseTokenizer::SetWriteState Method
fiBaseTokenizer Class
Show All
C++
public: void SetWriteState(
    int writestate
);
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::SkipComment Method

fiBaseTokenizer::SkipComment Method
fiBaseTokenizer Class
Show All
C++
protected: void SkipComment();
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::SkipToEndOfLine Method

fiBaseTokenizer::SkipToEndOfLine Method
fiBaseTokenizer Class
Show All
C++
public: void SkipToEndOfLine();
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::StartBlock Method

fiBaseTokenizer::StartBlock Method
fiBaseTokenizer Class
Show All

Increases the tab by one

C++
public: virtual void StartBlock();
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBaseTokenizer::StartLine Method

fiBaseTokenizer::StartLine Method
fiBaseTokenizer Class
Show All

Indents by tab

C++
public: virtual void StartLine();
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


rage::fiBaseTokenizer::enState Enumeration

rage::fiBaseTokenizer::enState Enumeration
fiBaseTokenizer Class
Show All
C++
protected: enum enState {
  public: OTHER,
  public: STARTLINE,
  public: ENDLINE
};
Class

fiBaseTokenizer Class

File

token.h

Links
fiBaseTokenizer Class


fiBinTokenizer Class

fiBinTokenizer Class Component
Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All

fiBinTokenizer implements a concrete subclass of fiTokenizer for handling binary files.

rage::fiBaseTokenizer
    fiBinTokenizer
C++
public: class fiBinTokenizer : public fiBaseTokenizer;
Destructors
Destructor | Description
~fiBaseTokenizer |
Methods
Method | Description
CheckIToken |
CheckToken |
EndBlock | Decreases the tab by one
EndLine | Starts a new line
EndOfFile |
GetBlock | get a block of "length" characters
GetByte | Reads a numerical value and returns it
GetByte | read functions:
GetDelimiter |
GetDelimiter |
GetFloat | Reads a numerical value and returns it
GetFloat | Reads a numerical value and returns it
GetInt | Reads a numerical value and returns it
GetInt | Reads a numerical value and returns it
GetLine |
GetName |
GetNextCh |
GetShort | Reads a numerical value and returns it
GetShort | Reads a numerical value and returns it
GetStream |
GetStreamPosition |
GetToken | read functions:
GetTokenCh |
GetTokenToChar |
GetTokenToChars |
GetVector | Reads a numerical value and returns it
GetVector | Reads a numerical value and returns it
GetWriteState |
IgnoreToken |
Indent |
Init |
IsBinary |
IsBinary |
iswhitespace |
MatchFloat |
MatchFloat |
MatchIFloat |
MatchIFloat |
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchIToken |
MatchIVector |
MatchIVector |
MatchToken |
MatchVector |
MatchVector |
Pop | pop the current block as defined by "{" and "}" delimiters. this will also pop any sub-blocks. useful for file formats in a state of flux.
Put |
Put |
PutByte |
PutByte |
PutDelimiter |
PutDelimiter |
PutShort |
PutShort |
PutStr |
PutStrLine | convenience functions
Reset |
SetNextCh |
SetStreamPosition |
SetTerminators | Sets a list of characters that should be used for terminating tokens and skipped over.
SetWriteState |
SkipComment |
SkipToEndOfLine |
StartBlock | Increases the tab by one
StartLine | Indents by tab
Data Members
Data Member | Description
CommentChar |
filename |
line |
m_WriteState |
nextch |
S |
Enumerations
Enumeration | Description
enState |
Namespace

rage Namespace

File

token.h

Links
Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


fiBinTokenizer::GetByte Method

fiBinTokenizer::GetByte Method
fiBinTokenizer Class
Show All

read functions:

C++
public: int GetByte(
    const bool error = true
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::GetDelimiter Method

fiBinTokenizer::GetDelimiter Method
fiBinTokenizer Class
Show All
C++
public: void GetDelimiter(
    const char* de
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::IsBinary Method

fiBinTokenizer::IsBinary Method
fiBinTokenizer Class
Show All
C++
public: bool IsBinary() const;
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::MatchFloat Method

fiBinTokenizer::MatchFloat Method
fiBinTokenizer Class
Show All
C++
public: float MatchFloat(
    const char * match
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::MatchIFloat Method

fiBinTokenizer::MatchIFloat Method
fiBinTokenizer Class
Show All
C++
public: float MatchIFloat(
    const char * match
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::MatchIInt Method

fiBinTokenizer::MatchIInt Method
fiBinTokenizer Class
Show All

Case insensitive version of Match*. Match a token and return the subsequent value

C++
public: int MatchIInt(
    const char * match
);
Parameters

match
The token to match (matching is not case sensitive)
v
(if present) The vector return value

Returns

The matched value (for non-vector Match* calls)

Notes

For reading values in a format like "MaxVelocity 10.0"

Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::MatchInt Method

fiBinTokenizer::MatchInt Method
fiBinTokenizer Class
Show All

Match a token and return the subsequent value

C++
public: int MatchInt(
    const char * match
);
Parameters

match
The token to match (matching is case sensitive)
v
(if present) The vector return value

Returns

The matched value (for non-vector Match* calls)

Notes

For reading values in a format like "MaxVelocity 10.0"

Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::MatchIVector Method (const char *, Vec_xyz&)

fiBinTokenizer::MatchIVector Method (const char *, Vec_xyz&)
fiBinTokenizer Class
Show All
C++
public: void MatchIVector(
    const char * match,
    Vec_xyz& v
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::MatchIVector Method (const char *, Vec_xyzw&)

fiBinTokenizer::MatchIVector Method (const char *, Vec_xyzw&)
fiBinTokenizer Class
Show All
C++
public: void MatchIVector(
    const char * match,
    Vec_xyzw& v
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::MatchIVector Method (const char *, Vector2&)

fiBinTokenizer::MatchIVector Method (const char *, Vector2&)
fiBinTokenizer Class
Show All
C++
public: void MatchIVector(
    const char * match,
    Vector2& v
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::MatchIVector Method (const char *, Vector3&)

fiBinTokenizer::MatchIVector Method (const char *, Vector3&)
fiBinTokenizer Class
Show All
C++
public: void MatchIVector(
    const char * match,
    Vector3& v
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::MatchIVector Method (const char *, Vector4&)

fiBinTokenizer::MatchIVector Method (const char *, Vector4&)
fiBinTokenizer Class
Show All
C++
public: void MatchIVector(
    const char * match,
    Vector4& v
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::MatchVector Method (const char *, Vec_xyz&)

fiBinTokenizer::MatchVector Method (const char *, Vec_xyz&)
fiBinTokenizer Class
Show All
C++
public: void MatchVector(
    const char * match,
    Vec_xyz& v
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::MatchVector Method (const char *, Vec_xyzw&)

fiBinTokenizer::MatchVector Method (const char *, Vec_xyzw&)
fiBinTokenizer Class
Show All
C++
public: void MatchVector(
    const char * match,
    Vec_xyzw& v
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::MatchVector Method (const char *, Vector2&)

fiBinTokenizer::MatchVector Method (const char *, Vector2&)
fiBinTokenizer Class
Show All
C++
public: void MatchVector(
    const char * match,
    Vector2& v
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::MatchVector Method (const char *, Vector3&)

fiBinTokenizer::MatchVector Method (const char *, Vector3&)
fiBinTokenizer Class
Show All
C++
public: void MatchVector(
    const char * match,
    Vector3& v
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::MatchVector Method (const char *, Vector4&)

fiBinTokenizer::MatchVector Method (const char *, Vector4&)
fiBinTokenizer Class
Show All
C++
public: void MatchVector(
    const char * match,
    Vector4& v
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::Put Method (const Vector2&)

fiBinTokenizer::Put Method (const Vector2&)
fiBinTokenizer Class
Show All
C++
public: bool Put(
    const Vector2& v
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::Put Method (const Vector3&)

fiBinTokenizer::Put Method (const Vector3&)
fiBinTokenizer Class
Show All
C++
public: bool Put(
    const Vector3& v
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::Put Method (const Vector4&)

fiBinTokenizer::Put Method (const Vector4&)
fiBinTokenizer Class
Show All
C++
public: bool Put(
    const Vector4& v
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::Put Method (const char*, unsigned int)

fiBinTokenizer::Put Method (const char*, unsigned int)
fiBinTokenizer Class
Show All

write functions:

C++
public: bool Put(
    const char* src,
    unsigned int tabs = 0
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::Put Method (float)

fiBinTokenizer::Put Method (float)
fiBinTokenizer Class
Show All
C++
public: bool Put(
    float f
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::Put Method (int)

fiBinTokenizer::Put Method (int)
fiBinTokenizer Class
Show All
C++
public: bool Put(
    int i
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::PutByte Method

fiBinTokenizer::PutByte Method
fiBinTokenizer Class
Show All
C++
public: bool PutByte(
    int i
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::PutDelimiter Method

fiBinTokenizer::PutDelimiter Method
fiBinTokenizer Class
Show All
C++
public: bool PutDelimiter(
    const char* de
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiBinTokenizer::PutShort Method

fiBinTokenizer::PutShort Method
fiBinTokenizer Class
Show All
C++
public: bool PutShort(
    int i
);
Class

fiBinTokenizer Class

File

token.h

Links
fiBinTokenizer Class


fiCachedDevice Class

fiCachedDevice Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Enumerations | Friends | rage Namespace | Inheritance Hierarchy
Show All
rage::fiDevice
    fiCachedDevice
C++
public: class fiCachedDevice : public fiDevice;
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
Destructors
Destructor | Description
~fiDevice |
Methods
Method | Description
Close |
Close | Close a file
CloseBulk |
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create |
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetBlockPhysicalSortKey |
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open |
Open | Attempt to open a file on this device
OpenBulk |
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
Prefetch |
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read |
Read | Read binary data from file
ReadBulk |
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek |
Seek | Seek to a location in file
Seek64 |
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime |
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write |
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options
Friends
Friend | Description
class fiDiskCache |
Namespace

rage Namespace

File

diskcache.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Enumerations, Friends, rage Namespace, Inheritance Hierarchy


fiCachedDevice::Close Method

fiCachedDevice::Close Method
fiCachedDevice Class
Show All
C++
public: virtual int Close(
    fiHandle handle
) const;
Class

fiCachedDevice Class

File

diskcache.h

Links
fiCachedDevice Class


fiCachedDevice::CloseBulk Method

fiCachedDevice::CloseBulk Method
fiCachedDevice Class
Show All
C++
public: virtual int CloseBulk(
    fiHandle handle
) const;
Class

fiCachedDevice Class

File

diskcache.h

Links
fiCachedDevice Class


fiCachedDevice::Create Method

fiCachedDevice::Create Method
fiCachedDevice Class
Show All
C++
public: virtual fiHandle Create(
    const char * filename
) const;
Class

fiCachedDevice Class

File

diskcache.h

Links
fiCachedDevice Class


fiCachedDevice::GetBlockPhysicalSortKey Method

fiCachedDevice::GetBlockPhysicalSortKey Method
fiCachedDevice Class
Show All
C++
public: u32 GetBlockPhysicalSortKey(
    u64 offset,
    int count
) const;
Returns

LSN of the request; will be relative to original location if the file isn't cached

Class

fiCachedDevice Class

File

diskcache.h

Links
fiCachedDevice Class


fiCachedDevice::GetDebugName Method

fiCachedDevice::GetDebugName Method
fiCachedDevice Class
Show All
C++
public: virtual const char * GetDebugName() const;
Class

fiCachedDevice Class

File

diskcache.h

Links
fiCachedDevice Class


fiCachedDevice::GetFileSize Method

fiCachedDevice::GetFileSize Method
fiCachedDevice Class
Show All

Determine size of file

C++
public: virtual u64 GetFileSize(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Size of the file

Notes

Base class implements this as three calls to Seek, subclasses that may know the size of the file ahead of time are encouraged to improve upon this.

Class

fiCachedDevice Class

File

diskcache.h

Links
fiCachedDevice Class


fiCachedDevice::GetFileTime Method

fiCachedDevice::GetFileTime Method
fiCachedDevice Class
Show All

Return time-of-date information for a file

C++
public: virtual u64 GetFileTime(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Large integer (in unspecified units) which represents the file time. Will return 0 if a file did not exist. If a filetime fa is larger than another filetime fb then fa is newer than fb.

Class

fiCachedDevice Class

File

diskcache.h

Links
fiCachedDevice Class


fiCachedDevice::Open Method

fiCachedDevice::Open Method
fiCachedDevice Class
Show All
C++
public: virtual fiHandle Open(
    const char * filename,
    bool readOnly
) const;
Class

fiCachedDevice Class

File

diskcache.h

Links
fiCachedDevice Class


fiCachedDevice::OpenBulk Method

fiCachedDevice::OpenBulk Method
fiCachedDevice Class
Show All
C++
public: virtual fiHandle OpenBulk(
    const char * filename,
    u64 & outBias
) const;
Class

fiCachedDevice Class

File

diskcache.h

Links
fiCachedDevice Class


fiCachedDevice::Prefetch Method

fiCachedDevice::Prefetch Method
fiCachedDevice Class
Show All
C++
public: bool Prefetch(
    u64 offset,
    int count
) const;
Returns

True if the data is already in the cache, or false if it wasn't (and schedules it to become resident)

Class

fiCachedDevice Class

File

diskcache.h

Links
fiCachedDevice Class


fiCachedDevice::Read Method

fiCachedDevice::Read Method
fiCachedDevice Class
Show All
C++
public: virtual int Read(
    fiHandle handle,
    void * outBuffer,
    int bufferSize
) const;
Class

fiCachedDevice Class

File

diskcache.h

Links
fiCachedDevice Class


fiCachedDevice::ReadBulk Method

fiCachedDevice::ReadBulk Method
fiCachedDevice Class
Show All
C++
public: virtual int ReadBulk(
    fiHandle handle,
    u64 offset,
    void * outBuffer,
    int bufferSize
) const;
Class

fiCachedDevice Class

File

diskcache.h

Links
fiCachedDevice Class


fiCachedDevice::Seek Method

fiCachedDevice::Seek Method
fiCachedDevice Class
Show All
C++
public: virtual int Seek(
    fiHandle handle,
    int offset,
    fiSeekWhence whence
) const;
Class

fiCachedDevice Class

File

diskcache.h

Links
fiCachedDevice Class


fiCachedDevice::Seek64 Method

fiCachedDevice::Seek64 Method
fiCachedDevice Class
Show All
C++
public: virtual u64 Seek64(
    fiHandle handle,
    s64 offset,
    fiSeekWhence whence
) const;
Class

fiCachedDevice Class

File

diskcache.h

Links
fiCachedDevice Class


fiCachedDevice::SetFileTime Method

fiCachedDevice::SetFileTime Method
fiCachedDevice Class
Show All
C++
public: virtual bool SetFileTime(
    const char * filename,
    u64 timestamp
) const;
Class

fiCachedDevice Class

File

diskcache.h

Links
fiCachedDevice Class


fiCachedDevice::Write Method

fiCachedDevice::Write Method
fiCachedDevice Class
Show All
C++
public: virtual int Write(
    fiHandle handle,
    const void * buffer,
    int bufferSize
) const;
Class

fiCachedDevice Class

File

diskcache.h

Links
fiCachedDevice Class


friend class fiDiskCache Friend

friend class fiDiskCache Friend
fiCachedDevice Class
Show All
C++
public: friend class fiDiskCache;
Class

fiCachedDevice Class

File

diskcache.h

Links
fiCachedDevice Class


fiCachePartition Class

fiCachePartition Class
Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
fiCachePartition
C++
public: class fiCachePartition;
Methods
Method | Description
GetCachePrefix |
Init |
IsAvailable |
Reset |
Shutdown |
Namespace

rage Namespace

File

cachepartition.h

Links
Members, Methods, rage Namespace, Inheritance Hierarchy


fiCachePartition::GetCachePrefix Method

fiCachePartition::GetCachePrefix Method
fiCachePartition Class
Show All
C++
public: static const char * GetCachePrefix();
Returns

Cache drive prefix (including trailing slash if necessary)

Class

fiCachePartition Class

File

cachepartition.h

Links
fiCachePartition Class


fiCachePartition::Init Method

fiCachePartition::Init Method
fiCachePartition Class
Show All
C++
public: static bool Init(
    bool forceClean = false
);
Parameters

forceClean
True to force partition to be reset during mount. Note that this is ignored if you were not the first client of the cache.

Returns

True if cache partition could be mounted. Safe to call multiple times; just make sure you have matching calls to fiShutdownCachePartition. Note that even if the game was installed to a hard drive on 360, this function will still work properly.

Class

fiCachePartition Class

File

cachepartition.h

Links
fiCachePartition Class


fiCachePartition::IsAvailable Method

fiCachePartition::IsAvailable Method
fiCachePartition Class
Show All
C++
public: static bool IsAvailable();
Returns

True if Init succeeded.

Class

fiCachePartition Class

File

cachepartition.h

Links
fiCachePartition Class


fiCachePartition::Reset Method

fiCachePartition::Reset Method
fiCachePartition Class
Show All
C++
public: static bool Reset();
Returns

True if cache could be reset. Note that you are not allowed to reset the cache drive unless you are the only client.

Class

fiCachePartition Class

File

cachepartition.h

Links
fiCachePartition Class


fiCachePartition::Shutdown Method

fiCachePartition::Shutdown Method
fiCachePartition Class
Show All
C++
public: static void Shutdown();
Notes

This should be called when you're done with the partition but only call it if the init function returns true. Current only does something on 360.

Class

fiCachePartition Class

File

cachepartition.h

Links
fiCachePartition Class


fiCollection Class

fiCollection Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::fiDevice
    fiCollection
        rage::fiPackfile
C++
public: class fiCollection : public fiDevice;
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiCollection |
fiDevice |
Destructors
Destructor | Description
~fiDevice |
Methods
Method | Description
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetBasePhysicalSortKey |
GetBulkOffset |
GetCollection |
GetCollectionIndex |
GetDebugName |
GetDevice | Returns appropriate device for file
GetEntryFullName | Slower
GetEntryIndex |
GetEntryInfo |
GetEntryName |
GetEntryPhysicalSortKey |
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsPackfile |
IsRpf |
IsStreaming |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeHandle |
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
OpenBulkFromHandle |
Prefetch |
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
SetStreaming |
Shutdown |
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
ArchiveMask |
ArchiveShift |
EntryMask |
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
m_isStreaming |
sm_Collections | Entry 0 is never used. (except by the pgRawStreamer)
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options
Namespace

rage Namespace

File

packfile.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


fiCollection::ArchiveMask Data Member

fiCollection::ArchiveMask Data Member
fiCollection Class
Show All
C++
protected: static const u32 ArchiveMask = 0xFFFF;
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::ArchiveShift Data Member

fiCollection::ArchiveShift Data Member
fiCollection Class
Show All
C++
protected: static const int ArchiveShift = 16;
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::EntryMask Data Member

fiCollection::EntryMask Data Member
fiCollection Class
Show All
C++
protected: static const u32 EntryMask = 0xFFFF;
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::m_isStreaming Data Member

fiCollection::m_isStreaming Data Member
fiCollection Class
Show All
C++
protected: bool m_isStreaming;
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::sm_Collections Data Member

fiCollection::sm_Collections Data Member
fiCollection Class
Show All

Entry 0 is never used. (except by the pgRawStreamer)

C++
protected: static fiCollection * sm_Collections[];
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::fiCollection Constructor

fiCollection::fiCollection Constructor
fiCollection Class
Show All
C++
public: fiCollection();
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::GetBasePhysicalSortKey Method

fiCollection::GetBasePhysicalSortKey Method
fiCollection Class
Show All
C++
public: virtual u32 GetBasePhysicalSortKey() = 0 const;
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::GetCollection Method

fiCollection::GetCollection Method
fiCollection Class
Show All
C++
public: static fiCollection* GetCollection(
    u32 handle
);
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::GetCollectionIndex Method

fiCollection::GetCollectionIndex Method
fiCollection Class
Show All
C++
public: static int GetCollectionIndex(
    u32 handle
);
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::GetEntryFullName Method

fiCollection::GetEntryFullName Method
fiCollection Class
Show All

Slower

C++
public: virtual const char * GetEntryFullName(
    u32 handle,
    char * dest,
    int destSize
) = 0 const;
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::GetEntryIndex Method

fiCollection::GetEntryIndex Method
fiCollection Class
Show All
C++
public: virtual int GetEntryIndex(
    const char * name
) = 0 const;
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::GetEntryInfo Method

fiCollection::GetEntryInfo Method
fiCollection Class
Show All
C++
public: virtual const fiPackEntry& GetEntryInfo(
    u32 handle
) = 0 const;
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::GetEntryName Method

fiCollection::GetEntryName Method
fiCollection Class
Show All
C++
public: virtual const char * GetEntryName(
    u32 handle
) = 0 const;
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::GetEntryPhysicalSortKey Method

fiCollection::GetEntryPhysicalSortKey Method
fiCollection Class
Show All
C++
public: virtual u32 GetEntryPhysicalSortKey(
    u32 handle,
    bool uncached
) = 0 const;
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::IsPackfile Method

fiCollection::IsPackfile Method
fiCollection Class
Show All
C++
public: virtual bool IsPackfile() const;
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::IsStreaming Method

fiCollection::IsStreaming Method
fiCollection Class
Show All
C++
public: virtual bool IsStreaming() const;
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::MakeHandle Method

fiCollection::MakeHandle Method
fiCollection Class
Show All
C++
public: static u32 MakeHandle(
    u32 archiveIndex,
    u32 entryIndex
);
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::OpenBulkFromHandle Method

fiCollection::OpenBulkFromHandle Method
fiCollection Class
Show All
C++
public: virtual fiHandle OpenBulkFromHandle(
    u32 handle,
    u64 & offset
) = 0 const;
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::Prefetch Method

fiCollection::Prefetch Method
fiCollection Class
Show All
C++
public: virtual bool Prefetch(
    u32 handle
) = 0 const;
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::SetStreaming Method

fiCollection::SetStreaming Method
fiCollection Class
Show All
C++
public: virtual void SetStreaming(
    bool val
);
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCollection::Shutdown Method

fiCollection::Shutdown Method
fiCollection Class
Show All
C++
public: virtual void Shutdown();
Class

fiCollection Class

File

packfile.h

Links
fiCollection Class


fiCompressionData Class

fiCompressionData Class
Constructors | Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All

Class for compressing and decompressing with the fiCompress and fiDecompress methods. Mirrored in C# in rage/base/tools/ragCompression, this class is an interface between the game and Rag.

sysCompressionData
    fiCompressionData
C++
public: class fiCompressionData : public sysCompressionData;
Constructors
Constructor | Description
fiCompressionData |
Destructors
Destructor | Description
~fiCompressionData |
Methods
Method | Description
BuildHeader | Builds the header section for the Compression Factory
Compress | Compresses the data into a buffer using fiCompress
CreateNewInstance | Creates a new instance of this class to be used by the sysCompressionFactory
Decompress | Decompresses the data into a buffer of the specified length using fiDecompress
GetCompressUpperBound | Retrieves an estimate of the maximum length the of the compressed data with the given size using fiCompressUpperBound
GetHeaderPrefix | Retrieves the unique header prefix string so the Compression Factory can find the start of a CompressedData set
GetHeaderSize | Retrieves the size of this class's header data
GetStaticHeaderPrefix | Retrieves the unique header prefix string so the Compression Factory can find the start of a CompressedData set Useful when calling for sysCompressionFactory::CompressData( const char*, u8*, u32, u32& ).
ParseHeader | Assuming compressedData starts with a valid header, retrieves the compressed data size and decompressed data size
Namespace

rage Namespace

File

ficompressiondata.h

Links
Constructors, Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


fiCompressionData::fiCompressionData Constructor

fiCompressionData::fiCompressionData Constructor
fiCompressionData Class
Show All
C++
public: fiCompressionData();
Class

fiCompressionData Class

File

ficompressiondata.h

Links
fiCompressionData Class


fiCompressionData::~fiCompressionData Destructor

fiCompressionData::~fiCompressionData Destructor
fiCompressionData Class
Show All
C++
public: ~fiCompressionData();
Class

fiCompressionData Class

File

ficompressiondata.h

Links
fiCompressionData Class


fiCompressionData::BuildHeader Method

fiCompressionData::BuildHeader Method
fiCompressionData Class
Show All

Builds the header section for the Compression Factory

C++
public: int BuildHeader(
    u8* buf,
    int length
) const;
Parameters

buf
buffer to write to
length
length of buffer to make sure we don't write past the end

Returns

length of header

Class

fiCompressionData Class

File

ficompressiondata.h

Links
fiCompressionData Class


fiCompressionData::Compress Method

fiCompressionData::Compress Method
fiCompressionData Class
Show All

Compresses the data into a buffer using fiCompress

C++
public: u32 Compress(
    u8* compressedData,
    u32 compressedDataLength,
    u8* uncompressedData,
    u32 uncompressedSize
);
Parameters

compressedData
buffer to write the compressed data to
compressedDataLength
length of the buffer
uncompressedData
data that we want to compress
uncompressedSize
number of bytes to be compressed

Returns

the number of bytes compressed to compressedData. 0 on error.

Class

fiCompressionData Class

File

ficompressiondata.h

Links
fiCompressionData Class


fiCompressionData::CreateNewInstance Method

fiCompressionData::CreateNewInstance Method
fiCompressionData Class
Show All

Creates a new instance of this class to be used by the sysCompressionFactory

C++
public: fiCompressionData* CreateNewInstance() const;
Returns

pointer to new instance

Class

fiCompressionData Class

File

ficompressiondata.h

Links
fiCompressionData Class


fiCompressionData::Decompress Method

fiCompressionData::Decompress Method
fiCompressionData Class
Show All

Decompresses the data into a buffer of the specified length using fiDecompress

C++
public: bool Decompress(
    u8* decompressedData,
    u32 decompressedSize,
    u8* compressedData,
    u32 compressedSize
);
Parameters

decompressedData
buffer to decompress the data to
decompressedSize
number of bytes in the uncompressed stream (the original DecompressedSize)
compressedData
data to be decompressed
compressedSize
number of bytes to be decompressed

Returns

true on success

Class

fiCompressionData Class

File

ficompressiondata.h

Links
fiCompressionData Class


fiCompressionData::GetCompressUpperBound Method

fiCompressionData::GetCompressUpperBound Method
fiCompressionData Class
Show All

Retrieves an estimate of the maximum length the of the compressed data with the given size using fiCompressUpperBound

C++
public: u32 GetCompressUpperBound(
    u32 uncompressedSize
) const;
Parameters

uncompressedSize
size of the data to be compressed

Returns

maximum length of compressedData

Class

fiCompressionData Class

File

ficompressiondata.h

Links
fiCompressionData Class


fiCompressionData::GetHeaderPrefix Method

fiCompressionData::GetHeaderPrefix Method
fiCompressionData Class
Show All

Retrieves the unique header prefix string so the Compression Factory can find the start of a CompressedData set

C++
public: const char* GetHeaderPrefix() const;
Returns

header prefix string

Class

fiCompressionData Class

File

ficompressiondata.h

Links
fiCompressionData Class


fiCompressionData::GetHeaderSize Method

fiCompressionData::GetHeaderSize Method
fiCompressionData Class
Show All

Retrieves the size of this class's header data

C++
public: int GetHeaderSize() const;
Returns

number of bytes of header data

Class

fiCompressionData Class

File

ficompressiondata.h

Links
fiCompressionData Class


fiCompressionData::GetStaticHeaderPrefix Method

fiCompressionData::GetStaticHeaderPrefix Method
fiCompressionData Class
Show All

Retrieves the unique header prefix string so the Compression Factory can find the start of a CompressedData set Useful when calling for sysCompressionFactory::CompressData( const char*, u8*, u32, u32& ).

C++
public: static const char* GetStaticHeaderPrefix();
Returns

header prefix string

Class

fiCompressionData Class

File

ficompressiondata.h

Links
fiCompressionData Class


fiCompressionData::ParseHeader Method

fiCompressionData::ParseHeader Method
fiCompressionData Class
Show All

Assuming compressedData starts with a valid header, retrieves the compressed data size and decompressed data size

C++
public: bool ParseHeader(
    u8* data,
    u32 dataLength
);
Parameters

data
compressed data, starting with the header prefix
dataLength
length of compressedData

Returns

true if the header was parsed correctly

Class

fiCompressionData Class

File

ficompressiondata.h

Links
fiCompressionData Class


fiDevice Class

fiDevice Class Component
Structs | Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All

Implements a device driver abstraction for the filesystem so that higher level code can access persistent storage portably. All filenames are assumed to start with some sort of device id which is used to route the file to the approperiate device. This may be something like cdrom0: or even a drive letter like D:; furthermore, we will tend to fall back on fiDeviceLocal if no other device match is found.

fiDevice
    rage::fiCachedDevice
    rage::fiCollection
    rage::fiDeviceCount
    rage::fiDeviceGrowBuffer
    rage::fiDeviceInstaller
    rage::fiDeviceLocal
    rage::fiDeviceMemory
    rage::fiDeviceRelative
    rage::fiDeviceRemote
    rage::fiDeviceTcpIp
    rage::fiZipfile
C++
public: class fiDevice;
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
Destructors
Destructor | Description
~fiDevice |
Methods
Method | Description
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options
Namespace

rage Namespace

File

device.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


fiDevice::HARDDRIVE_LSN Data Member

fiDevice::HARDDRIVE_LSN Data Member
fiDevice Class
Show All

Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.

C++
public: static const u32 HARDDRIVE_LSN = 0x40000000;
Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::LAYER1_LSN Data Member

fiDevice::LAYER1_LSN Data Member
fiDevice Class
Show All

Unknown.

C++
public: static const u32 LAYER1_LSN = 0;
Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::sm_DeviceProfiler Data Member

fiDevice::sm_DeviceProfiler Data Member
fiDevice Class
Show All
C++
protected: static fiDeviceProfiler * sm_DeviceProfiler;
Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::sm_FatalReadError Data Member

fiDevice::sm_FatalReadError Data Member
fiDevice Class
Show All

Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."

C++
public: static void (* sm_FatalReadError)(void);
Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::sm_InjectReadError Data Member

fiDevice::sm_InjectReadError Data Member
fiDevice Class
Show All

Set this to nonzero and it will inject a read error once the counter reaches zero again.

C++
public: static u32 sm_InjectReadError;
Class

fiDevice Class

File

device.h

Links
fiDevice Class


rage::fiDevice::SystemTime Struct

rage::fiDevice::SystemTime Struct
fiDevice Class
Show All

__DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)

C++
public: struct SystemTime {
  public: u16 wYear;
  public: u16 wMonth;
  public: u16 wDayOfWeek;
  public: u16 wDay;
  public: u16 wHour;
  public: u16 wMinute;
  public: u16 wSecond;
  public: u16 wMilliseconds;
};
Members

wYear
Two digit year
wMonth
1=Jan, 2=Feb, etc
wDayOfWeek
0=Sun, 1=Mon, etc.
wDay
Day of month (1, 2, 3..)

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::fiDevice Constructor

fiDevice::fiDevice Constructor
fiDevice Class
Show All
C++
public: fiDevice();
Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::~fiDevice Destructor

fiDevice::~fiDevice Destructor
fiDevice Class
Show All
C++
public: virtual ~fiDevice();
Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Close Method

fiDevice::Close Method
fiDevice Class
Show All

Close a file

C++
public: virtual int Close(
    fiHandle handle
) = 0 const;
Parameters

handle
Handle of file to close (must have been opened or created with the same device).

Returns

zero if the call succeeded, non-zero if it failed

Notes

You must eventually Close any handle successfully returned by an Open or Create call or else you will have a resource leak.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::CloseBulk Method

fiDevice::CloseBulk Method
fiDevice Class
Show All

Close a file opened via OpenBulk

C++
public: virtual int CloseBulk(
    fiHandle handle
) const;
Parameters

handle
Handle of file to close (must have been opened or created with the same device via OpenBulk

Returns

zero if the call succeeded, non-zero if it failed

Notes

You must eventually Close any handle successfully returned by an Open or Create call or else you will have a resource leak.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::ConvertFileTimeToSystemTime Method

fiDevice::ConvertFileTimeToSystemTime Method
fiDevice Class
Show All

Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.

C++
public: static void ConvertFileTimeToSystemTime(
    u64 inTime,
    SystemTime & outTime
);
Notes

Assumes input is in UTC, and output compensates for current local time zone. wDayOfWeek is WIN32 only, always 0 on other platforms

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::CopyDirectory Method

fiDevice::CopyDirectory Method
fiDevice Class
Show All

Copy a directory and all its contents

C++
public: static bool CopyDirectory(
    const char * fromDirectory,
    const char * toDirectory
);
Parameters

fromDirectory
Name of the directory to copy from
toDirectory
Name of the directory to copy to

Returns

True on success, false on failure (invalid path)

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::CopySingleFile Method

fiDevice::CopySingleFile Method
fiDevice Class
Show All

Copy a file

C++
public: static bool CopySingleFile(
    const char * fromFile,
    const char * toFile
);
Parameters

fromFile
Name of the file to copy from
toFile
Name of the file to copy to

Returns

True on success, false on failure (invalid path, insufficient space, etc)

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Create Method

fiDevice::Create Method
fiDevice Class
Show All

Attempt to create a file on this device

C++
public: virtual fiHandle Create(
    const char * filename
) = 0 const;
Parameters

filename
Name of file to open (including device id)
readOnly
True if file will be read-only, else false.

Returns

Non-negative handle value on success, negative value on error.

Notes

If this function returns a value file handle, you must eventually call Close on this device with that handle or else you would suffer a resource leak.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::CreateBulk Method

fiDevice::CreateBulk Method
fiDevice Class
Show All

Attempt to open a file on this device for bulk write

C++
public: virtual fiHandle CreateBulk(
    const char * filename
) const;
Parameters

filename
Name of file to open (including device id)

Returns

Non-negative handle value on success, negative value on error.

Notes

The handle returned by this function can only be used with ReadBulk, WriteBulk, and CloseBulk.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::DefaultGetDevice Method

fiDevice::DefaultGetDevice Method
fiDevice Class
Show All

Default implementation of GetDevice function

C++
public: static const fiDevice& DefaultGetDevice(
    const char * filename,
    bool readonly
);
Parameters

filename
Name of file, including device id
readOnly
True if file is being opened for readonly access

Returns

Reference to appropriate fiDevice subclass.

Notes

This is used by RFS support to patch into the device chain. We could generalize this to some sort of device list but that may be overkill for our needs.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Delete Method

fiDevice::Delete Method
fiDevice Class
Show All

Delete a file from device

C++
public: virtual bool Delete(
    const char * filename
) const;
Parameters

filename
Name of file to delete

Returns

True on success (file deleted), or false on failure (file not found, marked read-only, etc)

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::DeleteDirectory Method

fiDevice::DeleteDirectory Method
fiDevice Class
Show All

Remove a directory and optionally all of its contents from a device

C++
public: static bool DeleteDirectory(
    const char * pathname,
    bool deleteContents = false,
    bool ignoreReadOnly = true
);
Parameters

pathname
Name of the directory to remove
deleteContents
auto delete everything inside the directory as well

Returns

True on success, false on failure (invalid path, deleteContents is false but directory isn't empty, etc.)

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::FindFile Method

fiDevice::FindFile Method
fiDevice Class
Show All
C++
public: const char * FindFile(
    const char * path,
    const char * filename,
    u32 options = FINDFILE_ALL
) const;
Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::FindFileBegin Method

fiDevice::FindFileBegin Method
fiDevice Class
Show All

Iterate over all files in a directory

C++
public: virtual fiHandle FindFileBegin(
    const char * directoryName,
    fiFindData & outData
) const;
Parameters

directoryName
Name of the directory to search (no wildcard necessary or supported; do filtering yourself in higher-level code).
outData
Info for first matching file (if return value was not -1)

Returns

A "find handle" that is used to identify this search so that more that one can be in progress at a time, or -1 if we were unable to find any matches. Must eventually call FindFileEnd on this handle if it did not return -1.

Notes

Some platforms will return "." and ".." and some will not, so make sure you handle them properly.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::FindFileEnd Method

fiDevice::FindFileEnd Method
fiDevice Class
Show All

Close a search begun with FindFileBegin

C++
public: virtual int FindFileEnd(
    fiHandle handle
) const;
Parameters

handle
Find handle to close

Returns

Zero if the call succeeded, non-zero otherwise.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::FindFileNext Method

fiDevice::FindFileNext Method
fiDevice Class
Show All

Continue a search begun with FindFileBegin

C++
public: virtual bool FindFileNext(
    fiHandle handle,
    fiFindData & outData
) const;
Parameters

handle
Find handle returned by FindFileBegin
outData
Info for next match file (if return value was not false)

Returns

True on success (outData is valid), or false if there were no more matches

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::FixRelativeName Method

fiDevice::FixRelativeName Method
fiDevice Class
Show All
C++
public: virtual char* FixRelativeName(
    char* dest,
    int destSize,
    const char* src
) const;
Returns

The name of this file according to the "low level" device

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Flush Method

fiDevice::Flush Method
fiDevice Class
Show All

Flushes all file data

C++
public: virtual int Flush(
    fiHandle handle
) const;
Parameters

handle
Handle of file to flush (must have been opened or created with the same device)

Returns

Zero on success, negative value on error

Notes

This is intended for removable media like memory cards.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::GetAttributes Method

fiDevice::GetAttributes Method
fiDevice Class
Show All

Retrieves file attributes

C++
public: virtual u32 GetAttributes(
    const char * filename
) const;
Parameters

filename
name of file to retrieve attributes

Returns

File attributes (see FILE_ATTRIBUTE_...) or FILE_ATTRIBUTE_INVALID (~0U) if file doesn't exist.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::GetBulkOffset Method

fiDevice::GetBulkOffset Method
fiDevice Class
Show All
C++
public: virtual u64 GetBulkOffset(
    const char*
) const;
Returns

Bulk offset of file, if found (can skip OpenBulk and just call ReadBulk directly)

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::GetDebugName Method

fiDevice::GetDebugName Method
fiDevice Class
Show All
C++
public: virtual const char * GetDebugName() = 0 const;
Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::GetDevice Method

fiDevice::GetDevice Method
fiDevice Class
Show All

Returns appropriate device for file

C++
public: static const fiDevice* GetDevice(
    const char * filename,
    bool readOnly = true
);
Parameters

filename
Name of file, including device id
readOnly
True if file is being opened for readonly access

Returns

Reference to appropriate fiDevice subclass, or NULL if no device found (bad path, or device is mounted readonly)

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::GetFileSize Method

fiDevice::GetFileSize Method
fiDevice Class
Show All

Determine size of file

C++
public: virtual u64 GetFileSize(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Size of the file

Notes

Base class implements this as three calls to Seek, subclasses that may know the size of the file ahead of time are encouraged to improve upon this.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::GetFileTime Method

fiDevice::GetFileTime Method
fiDevice Class
Show All

Return time-of-date information for a file

C++
public: virtual u64 GetFileTime(
    const char * filename
) = 0 const;
Parameters

filename
Name of file to request timestamp for

Returns

Large integer (in unspecified units) which represents the file time. Will return 0 if a file did not exist. If a filetime fa is larger than another filetime fb then fa is newer than fb.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::GetLocalSystemTime Method

fiDevice::GetLocalSystemTime Method
fiDevice Class
Show All

Gets the local time from the console

C++
public: static void GetLocalSystemTime(
    SystemTime & outTime
);
Notes

wDayOfWeek is WIN32 only, always 0 on other platforms

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::GetLowLevelDevice Method

fiDevice::GetLowLevelDevice Method
fiDevice Class
Show All

Get the actual low-level device that drives I/O on this device.

C++
public: virtual const fiDevice * GetLowLevelDevice() const;
Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::GetPackfileIndex Method

fiDevice::GetPackfileIndex Method
fiDevice Class
Show All

Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.

C++
public: virtual u32 GetPackfileIndex() const;
Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::GetPhysicalSortKey Method

fiDevice::GetPhysicalSortKey Method
fiDevice Class
Show All
C++
public: virtual u32 GetPhysicalSortKey(
    const char*
) const;
Returns

Returns a sort key for file on device. For DVD this would be sector address. If it's HARDDRIVE_LSN, we don't know anything about it, or it's on a hard drive.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::GetResourceInfo Method

fiDevice::GetResourceInfo Method
fiDevice Class
Show All

Retrieve resource information for a file. It only works files that have a standard resource header.

C++
public: virtual int GetResourceInfo(
    const char * name,
    datResourceInfo & outHeader
) const;
Parameters

name
Name of file to query
outHeader
If return value is nonzero, contains header information

Returns

Nonzero if file exists and has a standard resource header, else zero. A return of -1 means it's a valid resource but the version number is unavailable.

Notes

For raw files, it reads the header (which would cause tons of seeking on final media). For archived files, it (will eventually) use the metadata present in the directory structure.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::GetRpfDevice Method

fiDevice::GetRpfDevice Method
fiDevice Class
Show All
C++
public: virtual const fiDevice* GetRpfDevice() const;
Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::InitClass Method

fiDevice::InitClass Method
fiDevice Class
Show All
C++
public: static void InitClass();
Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::IsCloud Method

fiDevice::IsCloud Method
fiDevice Class
Show All
C++
public: virtual bool IsCloud() const;
Returns

True if the device is a fiDeviceCloud. See rline/cloud/rlcloud.h

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::IsOutOfDate Method

fiDevice::IsOutOfDate Method
fiDevice Class
Show All

Convenience function which compares to files.

C++
public: static bool IsOutOfDate(
    const char * original,
    const char * dependent
);
Parameters

original
Original file (source data)
dependent
Dependent file (data derived from and dependent upon original)

Returns

True if original is newer than dependent or original does not exist while dependent does. Otherwise returns false (including when neither file exists)

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::IsRpf Method

fiDevice::IsRpf Method
fiDevice Class
Show All
C++
public: virtual bool IsRpf() const;
Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Lock Method

fiDevice::Lock Method
fiDevice Class
Show All

Lock the filesystem (for serialization).

C++
public: static void Lock();
Notes

Only necessary on PS2 when doing file access with other Sony routines or the CDVD library. No operation on other platforms.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::MakeDirectory Method

fiDevice::MakeDirectory Method
fiDevice Class
Show All

Make a directory on device

C++
public: virtual bool MakeDirectory(
    const char * pathname
) const;
Parameters

pathname
Name of directory to create

Returns

True on success, or false on failure (directory already existed, etc)

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::MakeGrowBufferFileName Method

fiDevice::MakeGrowBufferFileName Method
fiDevice Class
Show All

Create a filename that can be used to reference a growable buffer

C++
public: static void MakeGrowBufferFileName(
    char* dest,
    const int destSize,
    datGrowBuffer* gb
);
Parameters

dest
Destination buffer
destSize
sizeof(dest)
gb
The growbuffer that contains the file data

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::MakeMemoryFileName Method

fiDevice::MakeMemoryFileName Method
fiDevice Class
Show All

Create a filename that can be used to reference a file in memory

C++
public: static void MakeMemoryFileName(
    char * dest,
    int destSize,
    const void * data,
    size_t dataSize,
    bool freeOnClose,
    const char * comment
);
Parameters

dest
Destination buffer
destSize
sizeof(dest)
data
Pointer to the file data
dataSize
size of the file data
freeOnClose
True if we should reclaim the memory with delete[] when the file is closed.
comment
Arbitrary comment, the original filename would make most sense here

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Mount Method

fiDevice::Mount Method
fiDevice Class
Show All

Establish a mount point in the global file namespace

C++
public: static bool Mount(
    const char * sourcePath,
    const fiDevice & device,
    bool readonly
);
Parameters

sourcePath
Pathname of the directory to mount (or "default")
device
Reference to device to associate with this source path
readonly
True if this device is mounted for read-only access

Returns

True on success, false on failure (possibly already mounted)

Notes

The sourcePath "default" is special, and determines the device to use when the supplied filename doesn't match any mount point. If no default device is mounted, GetDevice will throw an assert/ By default, the local file device is mounted by default but if RFS is enabled the startup code will use that instead by default, except for the D: drive which is still mounted locally.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Normalize Method

fiDevice::Normalize Method
fiDevice Class
Show All

Normalize a filename in-place

C++
public: static void Normalize(
    char * buffer
);
Notes

Converts all letters to lower-case, and changes all slashes to be appropriate for the platform's native filesystem.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Open Method

fiDevice::Open Method
fiDevice Class
Show All

Attempt to open a file on this device

C++
public: virtual fiHandle Open(
    const char * filename,
    bool readOnly
) = 0 const;
Parameters

filename
Name of file to open (including device id)
readOnly
True if file will be read-only, else false.

Returns

Non-negative handle value on success, negative value on error.

Notes

If a file is read-only, we attempt to open in a sharing-friendly manner. If this function returns a value file handle, you must eventually call Close on this device with that handle or else you would suffer a resource leak.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::OpenBulk Method

fiDevice::OpenBulk Method
fiDevice Class
Show All

Attempt to open a file on this device for bulk read

C++
public: virtual fiHandle OpenBulk(
    const char * filename,
    u64 & outBias
) const;
Parameters

filename
Name of file to open (including device id)
outBias
Reference to a u64 containing a bias you should add to any ReadBulk call using this handle. Allows archives to avoid having to maintain any internal state when using uncompressed files.

Returns

Non-negative handle value on success, negative value on error.

Notes

The handle returned by this function can only be used with ReadBulk and CloseBulk.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::OpenBulkDrm Method

fiDevice::OpenBulkDrm Method
fiDevice Class
Show All

Attempt to open a drm secured file on this device for bulk read

C++
public: virtual fiHandle OpenBulkDrm(
    const char * filename,
    u64 & outBias,
    const void * pDrmKey
) const;
Parameters

filename
Name of file to open (including device id)
outBias
Reference to a u64 containing a bias you should add to any ReadBulk call using this handle. Allows archives to avoid having to maintain any internal state when using uncompressed files.
pDrmKey
pointer to the drm key we will attempt to use to decrypt/unlock this file can be passed NULL in which case OpenBulk is called

Returns

Non-negative handle value on success, negative value on error.

Notes

The handle returned by this function can only be used with ReadBulk and CloseBulk.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::PrefetchDir Method

fiDevice::PrefetchDir Method
fiDevice Class
Show All

Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.

C++
public: virtual bool PrefetchDir(
    const char *
) const;
Parameters

filename
name of directory to parse

Returns

True if successful, false otherwise.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Read Method

fiDevice::Read Method
fiDevice Class
Show All

Read binary data from file

C++
public: virtual int Read(
    fiHandle handle,
    void * outBuffer,
    int bufferSize
) = 0 const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
outBuffer
Destination to receive data that is read
bufferSize
Maximum amount of data to read

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::ReadBulk Method

fiDevice::ReadBulk Method
fiDevice Class
Show All

Seek and read binary data from file

C++
public: virtual int ReadBulk(
    fiHandle handle,
    u64 offset,
    void * outBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
File offset, must be multiple of block size (2048 is safest) Note that you should add any bias returned by OpenBulk in here yourself.
outBuffer
Destination to receive data that is read (should be aligned to cache line for maximum speed)
bufferSize
Maximum amount of data to read, must be multiple of block size (again, 2048 is safest)

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data. The data is not cached.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Remount Method

fiDevice::Remount Method
fiDevice Class
Show All

Re-establish a mount point in the global file namespace for an existing device.

C++
public: static bool Remount(
    const fiDevice & newdevice,
    const fiDevice & olddevice,
    bool readonly
);
Parameters

newdevice
Reference to device to associate with this source path
olddevice
Reference to device to be replaced with this source path and new device
readonly
True if this device is mounted for read-only access

Returns

True on success, false on failure (possibly already mounted)

Notes

The sourcePath "default" is special, and determines the device to use when the supplied filename doesn't match any mount point. If no default device is mounted, GetDevice will throw an assert/ By default, the local file device is mounted by default but if RFS is enabled the startup code will use that instead by default, except for the D: drive which is still mounted locally.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Rename Method

fiDevice::Rename Method
fiDevice Class
Show All

Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.

C++
public: virtual bool Rename(
    const char * from,
    const char * to
) const;
Parameters

from
Original filename
to
New name for file

Returns

True on success (file renamed), or false on failure (file not found, etc)

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::SafeRead Method

fiDevice::SafeRead Method
fiDevice Class
Show All

Read data from file, with retry until error

Safe version of coreRawReadFile.

C++
public: virtual bool SafeRead(
    fiHandle handle,
    void * outBuffer,
    int size
) const;
Parameters

handle
handle of file to read file handle.
outBuffer
Destination buffer for read data
size
Number of bytes to read the data size to read.
buffer
where data to save.

Returns

True if exactly size bytes could be read, false if Read returned negative value at any time.

0 if success.

Notes

This is useful for things like named pipes and TCP connections where data sometimes arrives in smaller pieces than we expect.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::SafeWrite Method

fiDevice::SafeWrite Method
fiDevice Class
Show All

Write data to file, with retry until error

Safe version of coreRawWriteFile.

C++
public: virtual bool SafeWrite(
    fiHandle handle,
    const void * buffer,
    int size
) const;
Parameters

handle
handle of file to read file handle.
buffer
Source buffer for written data data to write to file.
size
Number of bytes to write the data size to be written.

Returns

True if exactly size bytes could be written, false if Write returned negative value at any time.

true if success.

Notes

This is useful for things like named pipes and TCP connections where data is sometimes consumed in smaller pieces than we expect.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Seek Method

fiDevice::Seek Method
fiDevice Class
Show All

Seek to a location in file

C++
public: virtual int Seek(
    fiHandle handle,
    int offset,
    fiSeekWhence whence
) = 0 const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

Lower 32 bits of new file position, or -1 on error

Notes

Not all devices can implement seek (pipes, etc)

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Seek64 Method

fiDevice::Seek64 Method
fiDevice Class
Show All

Seek to a location in file

C++
public: virtual u64 Seek64(
    fiHandle handle,
    s64 offset,
    fiSeekWhence whence
) = 0 const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

New file position, or 0xFFFF FFFF FFFF FFFF on error.

Notes

Not all devices can implement seek (pipes, etc)

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::SetAttributes Method

fiDevice::SetAttributes Method
fiDevice Class
Show All

Sets file attributes

C++
public: virtual bool SetAttributes(
    const char * filename,
    u32 attributes
) const;
Parameters

filename
name of file to set attributes for
attributes
new attributes for file

Returns

True on success, false on failure.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::SetDeviceProfiler Method

fiDevice::SetDeviceProfiler Method
fiDevice Class
Show All
C++
public: static void SetDeviceProfiler(
    fiDeviceProfiler * profiler
);
Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::SetEndOfFile Method

fiDevice::SetEndOfFile Method
fiDevice Class
Show All

Sets the end of the file to the current file position.

C++
public: virtual bool SetEndOfFile(
    fiHandle handle
) const;
Parameters

handle
File handle to set the eof marker to

Returns

Zero if the call succeeded, non-zero otherwise.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::SetFileTime Method

fiDevice::SetFileTime Method
fiDevice Class
Show All

Set time-of-date information for a file

C++
public: virtual bool SetFileTime(
    const char * filename,
    u64 timestamp
) = 0 const;
Parameters

filename
Name of file to request timestamp for
timestamp
Timestamp to set

Returns

True on success, else false on failure.

Notes

The only portable way to set a filetime is from a previous GetFileTime result.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::SetFindNewest Method

fiDevice::SetFindNewest Method
fiDevice Class
Show All

Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp

C++
public: static void SetFindNewest(
    bool findNewest
);
Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::SetMaxMounts Method

fiDevice::SetMaxMounts Method
fiDevice Class
Show All

Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.

C++
public: static void SetMaxMounts(
    int mounts
);
Parameters

mounts
maximum number of archives that can be mounted.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Size Method

fiDevice::Size Method
fiDevice Class
Show All

Determine size of file

C++
public: virtual int Size(
    fiHandle handle
) const;
Parameters

handle
Handle of file to determine size of (must have been opened or created with the same device)

Returns

Size of the file

Notes

Base class implements this as three calls to Seek, subclasses that may know the size of the file ahead of time are encouraged to improve upon this.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Size64 Method

fiDevice::Size64 Method
fiDevice Class
Show All

Determine size of file

C++
public: virtual u64 Size64(
    fiHandle handle
) const;
Parameters

handle
Handle of file to determine size of (must have been opened or created with the same device)

Returns

Size of the file

Notes

Base class implements this as three calls to Seek, subclasses that may know the size of the file ahead of time are encouraged to improve upon this.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Unlock Method

fiDevice::Unlock Method
fiDevice Class
Show All

Unlock the filesystem (for serialization).

C++
public: static void Unlock();
Notes

Only necessary on PS2 when doing file access with other Sony routines or the CDVD library. No operation on other platforms.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::UnmakeDirectory Method

fiDevice::UnmakeDirectory Method
fiDevice Class
Show All

Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK

C++
public: virtual bool UnmakeDirectory(
    const char * pathname
) const;
Parameters

pathname
Name of directory to remove

Returns

True on success, or false on failure (directory not empty, etc)

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Unmount Method (const char *)

fiDevice::Unmount Method (const char *)
fiDevice Class
Show All

Remove a previously established mount point

C++
public: static bool Unmount(
    const char * sourcePath
);
Parameters

sourcePath
Pathname of directory to unmount (as per Mount)

Returns

True on success, false on failure (didn't match anything already mounted, or there are open files on the mount)

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Unmount Method (const fiDevice &)

fiDevice::Unmount Method (const fiDevice &)
fiDevice Class
Show All

Remove a previously mounted device

C++
public: static bool Unmount(
    const fiDevice & olddevice
);
Parameters

device
Pathname of directory to unmount (as per Mount)

Returns

True on success, false on failure (didn't match anything already mounted, or there are open files on the mount)

Notes

Unmount does not delete the device, it just removes it from the

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::Write Method

fiDevice::Write Method
fiDevice Class
Show All

Write binary data to file

C++
public: virtual int Write(
    fiHandle handle,
    const void * buffer,
    int bufferSize
) = 0 const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
buffer
Source buffer for data to write
bufferSize
Maximum amount of data to read

Returns

Non-negative integer on success representing number of bytes of data written (zero typically means media full). Negative integer indicates an error.

Notes

No translation of any kind is done on the data.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDevice::WriteBulk Method

fiDevice::WriteBulk Method
fiDevice Class
Show All

Seek and write binary data to file

C++
public: virtual int WriteBulk(
    fiHandle handle,
    u64 offset,
    const void * inBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
File offset, must be multiple of block size (2048 is safest) Note that you should add any bias returned by OpenBulk in here yourself.
inBuffer
Source for data that is written (should be aligned to cache line for maximum speed)
bufferSize
Maximum amount of data to write, must be multiple of block size (again, 2048 is safest)

Returns

Non-negative integer on success representing number of bytes of data written (zero typically means disk full). Negative integer indicates an error.

Notes

No translation of any kind is done on the data. The data is not cached.

Class

fiDevice Class

File

device.h

Links
fiDevice Class


rage::fiDevice::eFindFileOptions Enumeration

rage::fiDevice::eFindFileOptions Enumeration
fiDevice Class
Show All

Find File in a directory by name and other options

C++
public: enum eFindFileOptions {
  public: FINDFILE_ALL = 0,
  public: FINDFILE_TGA = 1<<1,
  public: FINDFILE_JPG = 1<<2,
  public: FINDFILE_BMP = 1<<3,
  public: FINDFILE_DDS = 1<<4,
  public: FINDFILE_IMAGES = FINDFILE_TGA|FINDFILE_JPG|FINDFILE_BMP|FINDFILE_DDS
};
Parameters

path
Name of the directory to look in
filename
the filename to check against
options
bit flags for additional options

Returns

full filepath on success, NULL on failure

Class

fiDevice Class

File

device.h

Links
fiDevice Class


fiDeviceCount Class

fiDeviceCount Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::fiDevice
    fiDeviceCount
C++
public: class fiDeviceCount : public fiDevice;
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
Destructors
Destructor | Description
~fiDevice |
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime |
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open |
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read |
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime |
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size | Determine size of file
Size64 | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write |
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options
Namespace

rage Namespace

File

device.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


fiDeviceCount::Close Method

fiDeviceCount::Close Method
fiDeviceCount Class
Show All

Close a file

C++
public: virtual int Close(
    fiHandle handle
) const;
Parameters

handle
Handle of file to close (must have been opened or created with the same device).

Returns

zero if the call succeeded, non-zero if it failed

Notes

You must eventually Close any handle successfully returned by an Open or Create call or else you will have a resource leak.

Class

fiDeviceCount Class

File

device.h

Links
fiDeviceCount Class


fiDeviceCount::Create Method

fiDeviceCount::Create Method
fiDeviceCount Class
Show All

Attempt to create a file on this device

C++
public: virtual fiHandle Create(
    const char * filename
) const;
Parameters

filename
Name of file to open (including device id)
readOnly
True if file will be read-only, else false.

Returns

Non-negative handle value on success, negative value on error.

Notes

If this function returns a value file handle, you must eventually call Close on this device with that handle or else you would suffer a resource leak.

Class

fiDeviceCount Class

File

device.h

Links
fiDeviceCount Class


fiDeviceCount::GetDebugName Method

fiDeviceCount::GetDebugName Method
fiDeviceCount Class
Show All
C++
public: virtual const char * GetDebugName() const;
Class

fiDeviceCount Class

File

device.h

Links
fiDeviceCount Class


fiDeviceCount::GetFileTime Method

fiDeviceCount::GetFileTime Method
fiDeviceCount Class
Show All
C++
public: virtual u64 GetFileTime(
    const char * filename
) const;
Class

fiDeviceCount Class

File

device.h

Links
fiDeviceCount Class


fiDeviceCount::GetInstance Method

fiDeviceCount::GetInstance Method
fiDeviceCount Class
Show All

Singleton accessor

C++
public: static const fiDevice& GetInstance();
Class

fiDeviceCount Class

File

device.h

Links
fiDeviceCount Class


fiDeviceCount::Open Method

fiDeviceCount::Open Method
fiDeviceCount Class
Show All
C++
public: virtual fiHandle Open(
    const char * filename,
    bool readOnly
) const;
Class

fiDeviceCount Class

File

device.h

Links
fiDeviceCount Class


fiDeviceCount::Read Method

fiDeviceCount::Read Method
fiDeviceCount Class
Show All
C++
public: virtual int Read(
    fiHandle handle,
    void * outBuffer,
    int bufferSize
) const;
Class

fiDeviceCount Class

File

device.h

Links
fiDeviceCount Class


fiDeviceCount::Seek Method

fiDeviceCount::Seek Method
fiDeviceCount Class
Show All

Seek to a location in file

C++
public: virtual int Seek(
    fiHandle handle,
    int offset,
    fiSeekWhence whence
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

Lower 32 bits of new file position, or -1 on error

Notes

Not all devices can implement seek (pipes, etc)

Class

fiDeviceCount Class

File

device.h

Links
fiDeviceCount Class


fiDeviceCount::Seek64 Method

fiDeviceCount::Seek64 Method
fiDeviceCount Class
Show All

Seek to a location in file

C++
public: virtual u64 Seek64(
    fiHandle handle,
    s64 offset,
    fiSeekWhence whence
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

New file position, or 0xFFFF FFFF FFFF FFFF on error.

Notes

Not all devices can implement seek (pipes, etc)

Class

fiDeviceCount Class

File

device.h

Links
fiDeviceCount Class


fiDeviceCount::SetFileTime Method

fiDeviceCount::SetFileTime Method
fiDeviceCount Class
Show All
C++
public: virtual bool SetFileTime(
    const char * filename,
    u64 timestamp
) const;
Class

fiDeviceCount Class

File

device.h

Links
fiDeviceCount Class


fiDeviceCount::Size Method

fiDeviceCount::Size Method
fiDeviceCount Class
Show All

Determine size of file

C++
public: virtual int Size(
    fiHandle handle
) const;
Parameters

handle
Handle of file to determine size of (must have been opened or created with the same device)

Returns

Size of the file

Notes

Base class implements this as three calls to Seek, subclasses that may know the size of the file ahead of time are encouraged to improve upon this.

Class

fiDeviceCount Class

File

device.h

Links
fiDeviceCount Class


fiDeviceCount::Size64 Method

fiDeviceCount::Size64 Method
fiDeviceCount Class
Show All

Determine size of file

C++
public: virtual u64 Size64(
    fiHandle handle
) const;
Parameters

handle
Handle of file to determine size of (must have been opened or created with the same device)

Returns

Size of the file

Notes

Base class implements this as three calls to Seek, subclasses that may know the size of the file ahead of time are encouraged to improve upon this.

Class

fiDeviceCount Class

File

device.h

Links
fiDeviceCount Class


fiDeviceCount::Write Method

fiDeviceCount::Write Method
fiDeviceCount Class
Show All
C++
public: virtual int Write(
    fiHandle handle,
    const void * buffer,
    int bufferSize
) const;
Class

fiDeviceCount Class

File

device.h

Links
fiDeviceCount Class


fiDeviceGrowBuffer Class

fiDeviceGrowBuffer Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::fiDevice
    fiDeviceGrowBuffer
C++
public: class fiDeviceGrowBuffer : public fiDevice;
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
Destructors
Destructor | Description
~fiDevice |
Methods
Method | Description
Close | Close a file
Close |
CloseBulk | Close a file opened via OpenBulk
CloseBulk |
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes |
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek |
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options
Namespace

rage Namespace

File

device.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


fiDeviceGrowBuffer::Close Method

fiDeviceGrowBuffer::Close Method
fiDeviceGrowBuffer Class
Show All
C++
public: virtual int Close(
    fiHandle handle
) const;
Class

fiDeviceGrowBuffer Class

File

device.h

Links
fiDeviceGrowBuffer Class


fiDeviceGrowBuffer::CloseBulk Method

fiDeviceGrowBuffer::CloseBulk Method
fiDeviceGrowBuffer Class
Show All
C++
public: virtual int CloseBulk(
    fiHandle handle
) const;
Class

fiDeviceGrowBuffer Class

File

device.h

Links
fiDeviceGrowBuffer Class


fiDeviceGrowBuffer::Create Method

fiDeviceGrowBuffer::Create Method
fiDeviceGrowBuffer Class
Show All

Attempt to create a file on this device

C++
public: virtual fiHandle Create(
    const char * filename
) const;
Parameters

filename
Name of file to open (including device id)
readOnly
True if file will be read-only, else false.

Returns

Non-negative handle value on success, negative value on error.

Notes

If this function returns a value file handle, you must eventually call Close on this device with that handle or else you would suffer a resource leak.

Class

fiDeviceGrowBuffer Class

File

device.h

Links
fiDeviceGrowBuffer Class


fiDeviceGrowBuffer::GetAttributes Method

fiDeviceGrowBuffer::GetAttributes Method
fiDeviceGrowBuffer Class
Show All
C++
public: virtual u32 GetAttributes(
    const char*
) const;
Class

fiDeviceGrowBuffer Class

File

device.h

Links
fiDeviceGrowBuffer Class


fiDeviceGrowBuffer::GetDebugName Method

fiDeviceGrowBuffer::GetDebugName Method
fiDeviceGrowBuffer Class
Show All
C++
public: virtual const char * GetDebugName() const;
Class

fiDeviceGrowBuffer Class

File

device.h

Links
fiDeviceGrowBuffer Class


fiDeviceGrowBuffer::GetFileSize Method

fiDeviceGrowBuffer::GetFileSize Method
fiDeviceGrowBuffer Class
Show All

Determine size of file

C++
public: virtual u64 GetFileSize(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Size of the file

Notes

Base class implements this as three calls to Seek, subclasses that may know the size of the file ahead of time are encouraged to improve upon this.

Class

fiDeviceGrowBuffer Class

File

device.h

Links
fiDeviceGrowBuffer Class


fiDeviceGrowBuffer::GetFileTime Method

fiDeviceGrowBuffer::GetFileTime Method
fiDeviceGrowBuffer Class
Show All

Return time-of-date information for a file

C++
public: virtual u64 GetFileTime(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Large integer (in unspecified units) which represents the file time. Will return 0 if a file did not exist. If a filetime fa is larger than another filetime fb then fa is newer than fb.

Class

fiDeviceGrowBuffer Class

File

device.h

Links
fiDeviceGrowBuffer Class


fiDeviceGrowBuffer::GetInstance Method

fiDeviceGrowBuffer::GetInstance Method
fiDeviceGrowBuffer Class
Show All

Singleton accessor

C++
public: static const fiDevice& GetInstance();
Class

fiDeviceGrowBuffer Class

File

device.h

Links
fiDeviceGrowBuffer Class


fiDeviceGrowBuffer::Open Method

fiDeviceGrowBuffer::Open Method
fiDeviceGrowBuffer Class
Show All

Attempt to open a file on this device

C++
public: virtual fiHandle Open(
    const char * filename,
    bool readOnly
) const;
Parameters

filename
Name of file to open (including device id)
readOnly
True if file will be read-only, else false.

Returns

Non-negative handle value on success, negative value on error.

Notes

If a file is read-only, we attempt to open in a sharing-friendly manner. If this function returns a value file handle, you must eventually call Close on this device with that handle or else you would suffer a resource leak.

Class

fiDeviceGrowBuffer Class

File

device.h

Links
fiDeviceGrowBuffer Class


fiDeviceGrowBuffer::OpenBulk Method

fiDeviceGrowBuffer::OpenBulk Method
fiDeviceGrowBuffer Class
Show All

Attempt to open a file on this device for bulk read

C++
public: virtual fiHandle OpenBulk(
    const char * filename,
    u64 & outBias
) const;
Parameters

filename
Name of file to open (including device id)
outBias
Reference to a u64 containing a bias you should add to any ReadBulk call using this handle. Allows archives to avoid having to maintain any internal state when using uncompressed files.

Returns

Non-negative handle value on success, negative value on error.

Notes

The handle returned by this function can only be used with ReadBulk and CloseBulk.

Class

fiDeviceGrowBuffer Class

File

device.h

Links
fiDeviceGrowBuffer Class


fiDeviceGrowBuffer::Read Method

fiDeviceGrowBuffer::Read Method
fiDeviceGrowBuffer Class
Show All

Read binary data from file

C++
public: virtual int Read(
    fiHandle handle,
    void * outBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
outBuffer
Destination to receive data that is read
bufferSize
Maximum amount of data to read

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data.

Class

fiDeviceGrowBuffer Class

File

device.h

Links
fiDeviceGrowBuffer Class


fiDeviceGrowBuffer::ReadBulk Method

fiDeviceGrowBuffer::ReadBulk Method
fiDeviceGrowBuffer Class
Show All

Seek and read binary data from file

C++
public: virtual int ReadBulk(
    fiHandle handle,
    u64 offset,
    void * outBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
File offset, must be multiple of block size (2048 is safest) Note that you should add any bias returned by OpenBulk in here yourself.
outBuffer
Destination to receive data that is read (should be aligned to cache line for maximum speed)
bufferSize
Maximum amount of data to read, must be multiple of block size (again, 2048 is safest)

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data. The data is not cached.

Class

fiDeviceGrowBuffer Class

File

device.h

Links
fiDeviceGrowBuffer Class


fiDeviceGrowBuffer::SafeRead Method

fiDeviceGrowBuffer::SafeRead Method
fiDeviceGrowBuffer Class
Show All

Read data from file, with retry until error

Safe version of coreRawReadFile.

C++
public: virtual bool SafeRead(
    fiHandle handle,
    void * outBuffer,
    int size
) const;
Parameters

handle
handle of file to read file handle.
outBuffer
Destination buffer for read data
size
Number of bytes to read the data size to read.
buffer
where data to save.

Returns

True if exactly size bytes could be read, false if Read returned negative value at any time.

0 if success.

Notes

This is useful for things like named pipes and TCP connections where data sometimes arrives in smaller pieces than we expect.

Class

fiDeviceGrowBuffer Class

File

device.h

Links
fiDeviceGrowBuffer Class


fiDeviceGrowBuffer::SafeWrite Method

fiDeviceGrowBuffer::SafeWrite Method
fiDeviceGrowBuffer Class
Show All

Write data to file, with retry until error

Safe version of coreRawWriteFile.

C++
public: virtual bool SafeWrite(
    fiHandle handle,
    const void * buffer,
    int size
) const;
Parameters

handle
handle of file to read file handle.
buffer
Source buffer for written data data to write to file.
size
Number of bytes to write the data size to be written.

Returns

True if exactly size bytes could be written, false if Write returned negative value at any time.

true if success.

Notes

This is useful for things like named pipes and TCP connections where data is sometimes consumed in smaller pieces than we expect.

Class

fiDeviceGrowBuffer Class

File

device.h

Links
fiDeviceGrowBuffer Class


fiDeviceGrowBuffer::Seek Method

fiDeviceGrowBuffer::Seek Method
fiDeviceGrowBuffer Class
Show All
C++
public: virtual int Seek(
    fiHandle handle,
    int offset,
    fiSeekWhence whence
) const;
Class

fiDeviceGrowBuffer Class

File

device.h

Links
fiDeviceGrowBuffer Class


fiDeviceGrowBuffer::Seek64 Method

fiDeviceGrowBuffer::Seek64 Method
fiDeviceGrowBuffer Class
Show All

Seek to a location in file

C++
public: virtual u64 Seek64(
    fiHandle handle,
    s64 offset,
    fiSeekWhence whence
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

New file position, or 0xFFFF FFFF FFFF FFFF on error.

Notes

Not all devices can implement seek (pipes, etc)

Class

fiDeviceGrowBuffer Class

File

device.h

Links
fiDeviceGrowBuffer Class


fiDeviceGrowBuffer::SetFileTime Method

fiDeviceGrowBuffer::SetFileTime Method
fiDeviceGrowBuffer Class
Show All

Set time-of-date information for a file

C++
public: virtual bool SetFileTime(
    const char * filename,
    u64 timestamp
) const;
Parameters

filename
Name of file to request timestamp for
timestamp
Timestamp to set

Returns

True on success, else false on failure.

Notes

The only portable way to set a filetime is from a previous GetFileTime result.

Class

fiDeviceGrowBuffer Class

File

device.h

Links
fiDeviceGrowBuffer Class


fiDeviceGrowBuffer::Write Method

fiDeviceGrowBuffer::Write Method
fiDeviceGrowBuffer Class
Show All

Write binary data to file

C++
public: virtual int Write(
    fiHandle handle,
    const void * buffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
buffer
Source buffer for data to write
bufferSize
Maximum amount of data to read

Returns

Non-negative integer on success representing number of bytes of data written (zero typically means media full). Negative integer indicates an error.

Notes

No translation of any kind is done on the data.

Class

fiDeviceGrowBuffer Class

File

device.h

Links
fiDeviceGrowBuffer Class


fiDeviceInstaller Class

fiDeviceInstaller Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All

Specialised version of device that can install whole rpfs to a harddrive when explicitly asked.

Purpose

name: fiDeviceRelative

rage::fiDevice
    fiDeviceInstaller
C++
public: class fiDeviceInstaller : public fiDevice;
Notes

The device should be used when running off a disc. It will initially point at partition rpfs on the disc. When told to, it will create partitions on the harddrive and install these rpfs to their respective partitions, at which point the mount will point to the rpfs on the HDD.

Structs
Struct | Description
HddFile |
InitData |
InitDataList |
InstallFile |
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
fiDeviceInstaller |
Destructors
Destructor | Description
~fiDevice |
~fiDeviceInstaller |
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyContentInfoFile |
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
DoFileSizesMatch |
DoTimestampsMatch |
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FinishInstall |
FixName |
FixRelativeName |
FlagInstalledRpfs |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstallName |
GetInstallProgress |
GetInstallStatus |
GetIsBootedFromHdd |
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPackFileSize |
GetPartitionName |
GetPhysicalSortKey |
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetResourceInfo |
GetRpfDevice |
GetRpfDevice |
Init |
InitClass |
InitInstall |
InitPartitionDevice |
InstallerThread |
InstallProgress |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsPartitionPath |
IsRpf |
IsRpf |
IsTargetDeviceValid |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
MountAs |
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk |
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PauseDiscRead |
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
ReadInstallFile |
RegisterFileDoneCallback |
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
ResumeDiscRead |
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
ScheduleFile |
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAsync |
SetAttributes | Sets file attributes
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetIsBootedFromHdd |
SetKeepaliveCallback |
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
StartInstall |
StorePackageTimestamp |
StripPath |
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
WriteInstallFile |
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options
Namespace

rage Namespace

File

device_installer.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


rage::fiDeviceInstaller::HddFile Struct

rage::fiDeviceInstaller::HddFile Struct
fiDeviceInstaller Class
Show All
C++
private: struct HddFile {
  public: u64 fileSize;
  public: const fiDeviceInstaller* partition;
  public: const char* fileName;
  public: bool success;
  public: bool blocking;
};
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


rage::fiDeviceInstaller::InitData Struct

rage::fiDeviceInstaller::InitData Struct
fiDeviceInstaller Class
Show All
C++
private: struct InitData {
  public: ConstString m_sourceFile;
  public: ConstString m_partitionName;
  public: ConstString m_partitionDesc;
  public: ConstString m_mount;
  public: bool m_readOnly;
};
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


rage::fiDeviceInstaller::InitDataList Struct

rage::fiDeviceInstaller::InitDataList Struct
fiDeviceInstaller Class
Show All
C++
private: struct InitDataList {
  public: atArray<InitData> m_initDatas;
};
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


rage::fiDeviceInstaller::InstallFile Struct

rage::fiDeviceInstaller::InstallFile Struct
fiDeviceInstaller Class
Show All
C++
private: struct InstallFile {
  public: char filename[128];
  public: u64 filesize;
};
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::fiDeviceInstaller Constructor

fiDeviceInstaller::fiDeviceInstaller Constructor
fiDeviceInstaller Class
Show All
C++
public: fiDeviceInstaller();
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::~fiDeviceInstaller Destructor

fiDeviceInstaller::~fiDeviceInstaller Destructor
fiDeviceInstaller Class
Show All
C++
public: virtual ~fiDeviceInstaller();
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::Close Method

fiDeviceInstaller::Close Method
fiDeviceInstaller Class
Show All

Close a file

C++
public: virtual int Close(
    fiHandle handle
) const;
Parameters

handle
Handle of file to close (must have been opened or created with the same device).

Returns

zero if the call succeeded, non-zero if it failed

Notes

You must eventually Close any handle successfully returned by an Open or Create call or else you will have a resource leak.

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::CloseBulk Method

fiDeviceInstaller::CloseBulk Method
fiDeviceInstaller Class
Show All

Close a file opened via OpenBulk

C++
public: virtual int CloseBulk(
    fiHandle handle
) const;
Parameters

handle
Handle of file to close (must have been opened or created with the same device via OpenBulk

Returns

zero if the call succeeded, non-zero if it failed

Notes

You must eventually Close any handle successfully returned by an Open or Create call or else you will have a resource leak.

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::CopyContentInfoFile Method

fiDeviceInstaller::CopyContentInfoFile Method
fiDeviceInstaller Class
Show All
C++
protected: bool CopyContentInfoFile(
    const char* filename,
    const char* contentInfoPath
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::Create Method

fiDeviceInstaller::Create Method
fiDeviceInstaller Class
Show All

Attempt to create a file on this device

C++
public: virtual fiHandle Create(
    const char * filename
) const;
Parameters

filename
Name of file to open (including device id)
readOnly
True if file will be read-only, else false.

Returns

Non-negative handle value on success, negative value on error.

Notes

If this function returns a value file handle, you must eventually call Close on this device with that handle or else you would suffer a resource leak.

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::Delete Method

fiDeviceInstaller::Delete Method
fiDeviceInstaller Class
Show All

Delete a file from device

C++
public: virtual bool Delete(
    const char * filename
) const;
Parameters

filename
Name of file to delete

Returns

True on success (file deleted), or false on failure (file not found, marked read-only, etc)

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::DoFileSizesMatch Method

fiDeviceInstaller::DoFileSizesMatch Method
fiDeviceInstaller Class
Show All
C++
protected: bool DoFileSizesMatch(
    const char* oddFile,
    const char* hddFile
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::DoTimestampsMatch Method

fiDeviceInstaller::DoTimestampsMatch Method
fiDeviceInstaller Class
Show All
C++
protected: bool DoTimestampsMatch(
    const char* oddFile,
    const char* hddFile
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::FindFileBegin Method

fiDeviceInstaller::FindFileBegin Method
fiDeviceInstaller Class
Show All

Iterate over all files in a directory

C++
public: virtual fiHandle FindFileBegin(
    const char * filename,
    fiFindData & outData
) const;
Parameters

directoryName
Name of the directory to search (no wildcard necessary or supported; do filtering yourself in higher-level code).
outData
Info for first matching file (if return value was not -1)

Returns

A "find handle" that is used to identify this search so that more that one can be in progress at a time, or -1 if we were unable to find any matches. Must eventually call FindFileEnd on this handle if it did not return -1.

Notes

Some platforms will return "." and ".." and some will not, so make sure you handle them properly.

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::FindFileEnd Method

fiDeviceInstaller::FindFileEnd Method
fiDeviceInstaller Class
Show All

Close a search begun with FindFileBegin

C++
public: virtual int FindFileEnd(
    fiHandle handle
) const;
Parameters

handle
Find handle to close

Returns

Zero if the call succeeded, non-zero otherwise.

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::FindFileNext Method

fiDeviceInstaller::FindFileNext Method
fiDeviceInstaller Class
Show All

Continue a search begun with FindFileBegin

C++
public: virtual bool FindFileNext(
    fiHandle handle,
    fiFindData & outData
) const;
Parameters

handle
Find handle returned by FindFileBegin
outData
Info for next match file (if return value was not false)

Returns

True on success (outData is valid), or false if there were no more matches

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::FinishInstall Method

fiDeviceInstaller::FinishInstall Method
fiDeviceInstaller Class
Show All
C++
public: static void FinishInstall();
Notes

this function isn't safe to call while files are held open through this device

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::FixName Method

fiDeviceInstaller::FixName Method
fiDeviceInstaller Class
Show All
C++
public: const char * FixName(
    char * dest,
    int destSize,
    const char * src
) const;
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::FlagInstalledRpfs Method

fiDeviceInstaller::FlagInstalledRpfs Method
fiDeviceInstaller Class
Show All
C++
protected: void FlagInstalledRpfs() const;
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::GetAttributes Method

fiDeviceInstaller::GetAttributes Method
fiDeviceInstaller Class
Show All

Retrieves file attributes

C++
public: virtual u32 GetAttributes(
    const char * filename
) const;
Parameters

filename
name of file to retrieve attributes

Returns

File attributes (see FILE_ATTRIBUTE_...) or FILE_ATTRIBUTE_INVALID (~0U) if file doesn't exist.

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::GetBulkOffset Method

fiDeviceInstaller::GetBulkOffset Method
fiDeviceInstaller Class
Show All
C++
public: virtual u64 GetBulkOffset(
    const char* name
) const;
Returns

Bulk offset of file, if found (can skip OpenBulk and just call ReadBulk directly)

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::GetDebugName Method

fiDeviceInstaller::GetDebugName Method
fiDeviceInstaller Class
Show All
C++
public: virtual const char * GetDebugName() const;
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::GetFileSize Method

fiDeviceInstaller::GetFileSize Method
fiDeviceInstaller Class
Show All

Determine size of file

C++
public: virtual u64 GetFileSize(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Size of the file

Notes

Base class implements this as three calls to Seek, subclasses that may know the size of the file ahead of time are encouraged to improve upon this.

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::GetFileTime Method

fiDeviceInstaller::GetFileTime Method
fiDeviceInstaller Class
Show All

Return time-of-date information for a file

C++
public: virtual u64 GetFileTime(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Large integer (in unspecified units) which represents the file time. Will return 0 if a file did not exist. If a filetime fa is larger than another filetime fb then fa is newer than fb.

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::GetInstallName Method

fiDeviceInstaller::GetInstallName Method
fiDeviceInstaller Class
Show All
C++
protected: void GetInstallName(
    char* dst,
    s32 dstSize,
    const char* src
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::GetInstallProgress Method

fiDeviceInstaller::GetInstallProgress Method
fiDeviceInstaller Class
Show All
C++
public: static const sInstallProgress& GetInstallProgress();
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::GetInstallStatus Method

fiDeviceInstaller::GetInstallStatus Method
fiDeviceInstaller Class
Show All
C++
public: eInstallDeviceStatus GetInstallStatus() const;
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::GetIsBootedFromHdd Method

fiDeviceInstaller::GetIsBootedFromHdd Method
fiDeviceInstaller Class
Show All
C++
public: static bool GetIsBootedFromHdd();
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::GetPackFileSize Method

fiDeviceInstaller::GetPackFileSize Method
fiDeviceInstaller Class
Show All
C++
public: u64 GetPackFileSize();
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::GetPartitionName Method

fiDeviceInstaller::GetPartitionName Method
fiDeviceInstaller Class
Show All
C++
public: const char* GetPartitionName() const;
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::GetPhysicalSortKey Method

fiDeviceInstaller::GetPhysicalSortKey Method
fiDeviceInstaller Class
Show All
C++
public: virtual u32 GetPhysicalSortKey(
    const char* filename
) const;
Returns

Returns a sort key for file on device. For DVD this would be sector address. If it's HARDDRIVE_LSN, we don't know anything about it, or it's on a hard drive.

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::GetResourceInfo Method

fiDeviceInstaller::GetResourceInfo Method
fiDeviceInstaller Class
Show All
C++
public: virtual int GetResourceInfo(
    const char* name,
    datResourceInfo & info
) const;
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::GetRpfDevice Method

fiDeviceInstaller::GetRpfDevice Method
fiDeviceInstaller Class
Show All
C++
public: virtual const fiDevice* GetRpfDevice() const;
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::Init Method

fiDeviceInstaller::Init Method
fiDeviceInstaller Class
Show All
C++
public: bool Init(
    const InitData& data,
    const atArray<const char*>* fileList,
    const char* overridePath
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::InitInstall Method

fiDeviceInstaller::InitInstall Method
fiDeviceInstaller Class
Show All
C++
protected: virtual bool InitInstall(
    const atArray<const char*>* fileList,
    const char* origSourceFile
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::InitPartitionDevice Method

fiDeviceInstaller::InitPartitionDevice Method
fiDeviceInstaller Class
Show All
C++
protected: bool InitPartitionDevice(
    const char* archiveFile
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::InstallerThread Method

fiDeviceInstaller::InstallerThread Method
fiDeviceInstaller Class
Show All
C++
public: static void InstallerThread(
    void* ptr
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::InstallProgress Method

fiDeviceInstaller::InstallProgress Method
fiDeviceInstaller Class
Show All
C++
protected: static void InstallProgress(
    u64 fileSize,
    u64 fileTransferredSize,
    u64 totalTransferredSize
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::IsPartitionPath Method

fiDeviceInstaller::IsPartitionPath Method
fiDeviceInstaller Class
Show All
C++
public: static bool IsPartitionPath(
    const char* filename
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::IsRpf Method

fiDeviceInstaller::IsRpf Method
fiDeviceInstaller Class
Show All
C++
public: virtual bool IsRpf() const;
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::IsTargetDeviceValid Method

fiDeviceInstaller::IsTargetDeviceValid Method
fiDeviceInstaller Class
Show All
C++
public: bool IsTargetDeviceValid() const;
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::MakeDirectory Method

fiDeviceInstaller::MakeDirectory Method
fiDeviceInstaller Class
Show All

Make a directory on device

C++
public: virtual bool MakeDirectory(
    const char * filename
) const;
Parameters

pathname
Name of directory to create

Returns

True on success, or false on failure (directory already existed, etc)

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::MountAs Method

fiDeviceInstaller::MountAs Method
fiDeviceInstaller Class
Show All
C++
public: bool MountAs(
    const char * path,
    bool mountDevice
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::Open Method

fiDeviceInstaller::Open Method
fiDeviceInstaller Class
Show All

Attempt to open a file on this device

C++
public: virtual fiHandle Open(
    const char * filename,
    bool readOnly
) const;
Parameters

filename
Name of file to open (including device id)
readOnly
True if file will be read-only, else false.

Returns

Non-negative handle value on success, negative value on error.

Notes

If a file is read-only, we attempt to open in a sharing-friendly manner. If this function returns a value file handle, you must eventually call Close on this device with that handle or else you would suffer a resource leak.

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::OpenBulk Method

fiDeviceInstaller::OpenBulk Method
fiDeviceInstaller Class
Show All
C++
public: virtual fiHandle OpenBulk(
    const char * filename,
    u64& bias
) const;
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::PauseDiscRead Method

fiDeviceInstaller::PauseDiscRead Method
fiDeviceInstaller Class
Show All
C++
public: static void PauseDiscRead();
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::Read Method

fiDeviceInstaller::Read Method
fiDeviceInstaller Class
Show All

Read binary data from file

C++
public: virtual int Read(
    fiHandle handle,
    void * outBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
outBuffer
Destination to receive data that is read
bufferSize
Maximum amount of data to read

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data.

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::ReadBulk Method

fiDeviceInstaller::ReadBulk Method
fiDeviceInstaller Class
Show All

Seek and read binary data from file

C++
public: virtual int ReadBulk(
    fiHandle handle,
    u64 offset,
    void * outBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
File offset, must be multiple of block size (2048 is safest) Note that you should add any bias returned by OpenBulk in here yourself.
outBuffer
Destination to receive data that is read (should be aligned to cache line for maximum speed)
bufferSize
Maximum amount of data to read, must be multiple of block size (again, 2048 is safest)

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data. The data is not cached.

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::ReadInstallFile Method

fiDeviceInstaller::ReadInstallFile Method
fiDeviceInstaller Class
Show All
C++
public: static bool ReadInstallFile(
    fiDeviceInstaller* partition,
    sysTimer& progressTimer
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::RegisterFileDoneCallback Method

fiDeviceInstaller::RegisterFileDoneCallback Method
fiDeviceInstaller Class
Show All
C++
public: static void RegisterFileDoneCallback(
    datCallback callback
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::Rename Method

fiDeviceInstaller::Rename Method
fiDeviceInstaller Class
Show All

Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.

C++
public: virtual bool Rename(
    const char * from,
    const char * to
) const;
Parameters

from
Original filename
to
New name for file

Returns

True on success (file renamed), or false on failure (file not found, etc)

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::ResumeDiscRead Method

fiDeviceInstaller::ResumeDiscRead Method
fiDeviceInstaller Class
Show All
C++
public: static void ResumeDiscRead();
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::ScheduleFile Method

fiDeviceInstaller::ScheduleFile Method
fiDeviceInstaller Class
Show All
C++
protected: void ScheduleFile(
    const char* filename
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::Seek Method

fiDeviceInstaller::Seek Method
fiDeviceInstaller Class
Show All

Seek to a location in file

C++
public: virtual int Seek(
    fiHandle handle,
    int offset,
    fiSeekWhence whence
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

Lower 32 bits of new file position, or -1 on error

Notes

Not all devices can implement seek (pipes, etc)

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::Seek64 Method

fiDeviceInstaller::Seek64 Method
fiDeviceInstaller Class
Show All

Seek to a location in file

C++
public: virtual u64 Seek64(
    fiHandle handle,
    s64 offset,
    fiSeekWhence whence
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

New file position, or 0xFFFF FFFF FFFF FFFF on error.

Notes

Not all devices can implement seek (pipes, etc)

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::SetAsync Method

fiDeviceInstaller::SetAsync Method
fiDeviceInstaller Class
Show All
C++
public: static void SetAsync(
    bool val
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::SetAttributes Method

fiDeviceInstaller::SetAttributes Method
fiDeviceInstaller Class
Show All

Sets file attributes

C++
public: virtual bool SetAttributes(
    const char * filename,
    u32 attributes
) const;
Parameters

filename
name of file to set attributes for
attributes
new attributes for file

Returns

True on success, false on failure.

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::SetEndOfFile Method

fiDeviceInstaller::SetEndOfFile Method
fiDeviceInstaller Class
Show All

Sets the end of the file to the current file position.

C++
public: virtual bool SetEndOfFile(
    fiHandle handle
) const;
Parameters

handle
File handle to set the eof marker to

Returns

Zero if the call succeeded, non-zero otherwise.

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::SetFileTime Method

fiDeviceInstaller::SetFileTime Method
fiDeviceInstaller Class
Show All

Set time-of-date information for a file

C++
public: virtual bool SetFileTime(
    const char * filename,
    u64 timestamp
) const;
Parameters

filename
Name of file to request timestamp for
timestamp
Timestamp to set

Returns

True on success, else false on failure.

Notes

The only portable way to set a filetime is from a previous GetFileTime result.

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::SetIsBootedFromHdd Method

fiDeviceInstaller::SetIsBootedFromHdd Method
fiDeviceInstaller Class
Show All
C++
public: static void SetIsBootedFromHdd(
    bool val,
    const char * hddPath
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::SetKeepaliveCallback Method

fiDeviceInstaller::SetKeepaliveCallback Method
fiDeviceInstaller Class
Show All
C++
public: static void SetKeepaliveCallback(
    datCallback callback,
    u32 interval
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::StartInstall Method

fiDeviceInstaller::StartInstall Method
fiDeviceInstaller Class
Show All
C++
public: static void StartInstall(
    XENON_ONLY(XCONTENTDEVICEID device)
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::StorePackageTimestamp Method

fiDeviceInstaller::StorePackageTimestamp Method
fiDeviceInstaller Class
Show All
C++
public: void StorePackageTimestamp();
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::StripPath Method

fiDeviceInstaller::StripPath Method
fiDeviceInstaller Class
Show All
C++
protected: const char* StripPath(
    const char* fullpath
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::UnmakeDirectory Method

fiDeviceInstaller::UnmakeDirectory Method
fiDeviceInstaller Class
Show All

Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK

C++
public: virtual bool UnmakeDirectory(
    const char * filename
) const;
Parameters

pathname
Name of directory to remove

Returns

True on success, or false on failure (directory not empty, etc)

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::Write Method

fiDeviceInstaller::Write Method
fiDeviceInstaller Class
Show All

Write binary data to file

C++
public: virtual int Write(
    fiHandle handle,
    const void * buffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
buffer
Source buffer for data to write
bufferSize
Maximum amount of data to read

Returns

Non-negative integer on success representing number of bytes of data written (zero typically means media full). Negative integer indicates an error.

Notes

No translation of any kind is done on the data.

Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceInstaller::WriteInstallFile Method

fiDeviceInstaller::WriteInstallFile Method
fiDeviceInstaller Class
Show All
C++
public: static void WriteInstallFile(
    void* ptr
);
Class

fiDeviceInstaller Class

File

device_installer.h

Links
fiDeviceInstaller Class


fiDeviceLocal Class

fiDeviceLocal Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All

Concrete subclass of fiDevice which implements the local filesystem

rage::fiDevice
    fiDeviceLocal
        rage::fiDeviceLocalDrm
        rage::fiDeviceXContent
C++
public: class fiDeviceLocal : public fiDevice;
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
Destructors
Destructor | Description
~fiDevice |
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixName | Normalize a name for the underlying local device (insert host0:, change forward slashes to backslashes, etc)
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
OnDiscSwap |
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options
Namespace

rage Namespace

File

device.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


fiDeviceLocal::Close Method

fiDeviceLocal::Close Method
fiDeviceLocal Class
Show All

Close a file

C++
public: virtual int Close(
    fiHandle handle
) const;
Parameters

handle
Handle of file to close (must have been opened or created with the same device).

Returns

zero if the call succeeded, non-zero if it failed

Notes

You must eventually Close any handle successfully returned by an Open or Create call or else you will have a resource leak.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::CloseBulk Method

fiDeviceLocal::CloseBulk Method
fiDeviceLocal Class
Show All

Close a file opened via OpenBulk

C++
public: virtual int CloseBulk(
    fiHandle handle
) const;
Parameters

handle
Handle of file to close (must have been opened or created with the same device via OpenBulk

Returns

zero if the call succeeded, non-zero if it failed

Notes

You must eventually Close any handle successfully returned by an Open or Create call or else you will have a resource leak.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::Create Method

fiDeviceLocal::Create Method
fiDeviceLocal Class
Show All

Attempt to create a file on this device

C++
public: virtual fiHandle Create(
    const char * filename
) const;
Parameters

filename
Name of file to open (including device id)
readOnly
True if file will be read-only, else false.

Returns

Non-negative handle value on success, negative value on error.

Notes

If this function returns a value file handle, you must eventually call Close on this device with that handle or else you would suffer a resource leak.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::CreateBulk Method

fiDeviceLocal::CreateBulk Method
fiDeviceLocal Class
Show All

Attempt to open a file on this device for bulk write

C++
public: virtual fiHandle CreateBulk(
    const char * filename
) const;
Parameters

filename
Name of file to open (including device id)

Returns

Non-negative handle value on success, negative value on error.

Notes

The handle returned by this function can only be used with ReadBulk, WriteBulk, and CloseBulk.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::Delete Method

fiDeviceLocal::Delete Method
fiDeviceLocal Class
Show All

Delete a file from device

C++
public: virtual bool Delete(
    const char * filename
) const;
Parameters

filename
Name of file to delete

Returns

True on success (file deleted), or false on failure (file not found, marked read-only, etc)

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::FindFileBegin Method

fiDeviceLocal::FindFileBegin Method
fiDeviceLocal Class
Show All

Iterate over all files in a directory

C++
public: virtual fiHandle FindFileBegin(
    const char * filename,
    fiFindData & outData
) const;
Parameters

directoryName
Name of the directory to search (no wildcard necessary or supported; do filtering yourself in higher-level code).
outData
Info for first matching file (if return value was not -1)

Returns

A "find handle" that is used to identify this search so that more that one can be in progress at a time, or -1 if we were unable to find any matches. Must eventually call FindFileEnd on this handle if it did not return -1.

Notes

Some platforms will return "." and ".." and some will not, so make sure you handle them properly.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::FindFileEnd Method

fiDeviceLocal::FindFileEnd Method
fiDeviceLocal Class
Show All

Close a search begun with FindFileBegin

C++
public: virtual int FindFileEnd(
    fiHandle handle
) const;
Parameters

handle
Find handle to close

Returns

Zero if the call succeeded, non-zero otherwise.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::FindFileNext Method

fiDeviceLocal::FindFileNext Method
fiDeviceLocal Class
Show All

Continue a search begun with FindFileBegin

C++
public: virtual bool FindFileNext(
    fiHandle handle,
    fiFindData & outData
) const;
Parameters

handle
Find handle returned by FindFileBegin
outData
Info for next match file (if return value was not false)

Returns

True on success (outData is valid), or false if there were no more matches

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::FixName Method

fiDeviceLocal::FixName Method
fiDeviceLocal Class
Show All

Normalize a name for the underlying local device (insert host0:, change forward slashes to backslashes, etc)

C++
public: static const char * FixName(
    char * dest,
    int destSize,
    const char * src
);
Parameters

dest
Destination buffer
destSize
sizeof(dest)
src
Source buffer

Returns

dest

Notes

dest and src are NOT allowed to overlap.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::GetAttributes Method

fiDeviceLocal::GetAttributes Method
fiDeviceLocal Class
Show All

Retrieves file attributes

C++
public: virtual u32 GetAttributes(
    const char * filename
) const;
Parameters

filename
name of file to retrieve attributes

Returns

File attributes (see FILE_ATTRIBUTE_...) or FILE_ATTRIBUTE_INVALID (~0U) if file doesn't exist.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::GetDebugName Method

fiDeviceLocal::GetDebugName Method
fiDeviceLocal Class
Show All
C++
public: virtual const char * GetDebugName() const;
Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::GetFileSize Method

fiDeviceLocal::GetFileSize Method
fiDeviceLocal Class
Show All

Determine size of file

C++
public: virtual u64 GetFileSize(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Size of the file

Notes

Base class implements this as three calls to Seek, subclasses that may know the size of the file ahead of time are encouraged to improve upon this.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::GetFileTime Method

fiDeviceLocal::GetFileTime Method
fiDeviceLocal Class
Show All

Return time-of-date information for a file

C++
public: virtual u64 GetFileTime(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Large integer (in unspecified units) which represents the file time. Will return 0 if a file did not exist. If a filetime fa is larger than another filetime fb then fa is newer than fb.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::GetInstance Method

fiDeviceLocal::GetInstance Method
fiDeviceLocal Class
Show All

Singleton accessor

C++
public: static const fiDevice& GetInstance();
Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::GetPhysicalSortKey Method

fiDeviceLocal::GetPhysicalSortKey Method
fiDeviceLocal Class
Show All
C++
public: virtual u32 GetPhysicalSortKey(
    const char* filename
) const;
Returns

Returns a sort key for file on device. For DVD this would be sector address. If it's HARDDRIVE_LSN, we don't know anything about it, or it's on a hard drive.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::MakeDirectory Method

fiDeviceLocal::MakeDirectory Method
fiDeviceLocal Class
Show All

Make a directory on device

C++
public: virtual bool MakeDirectory(
    const char * filename
) const;
Parameters

pathname
Name of directory to create

Returns

True on success, or false on failure (directory already existed, etc)

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::OnDiscSwap Method

fiDeviceLocal::OnDiscSwap Method
fiDeviceLocal Class
Show All
C++
public: static void OnDiscSwap();
Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::Open Method

fiDeviceLocal::Open Method
fiDeviceLocal Class
Show All

Attempt to open a file on this device

C++
public: virtual fiHandle Open(
    const char * filename,
    bool readOnly
) const;
Parameters

filename
Name of file to open (including device id)
readOnly
True if file will be read-only, else false.

Returns

Non-negative handle value on success, negative value on error.

Notes

If a file is read-only, we attempt to open in a sharing-friendly manner. If this function returns a value file handle, you must eventually call Close on this device with that handle or else you would suffer a resource leak.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::OpenBulk Method

fiDeviceLocal::OpenBulk Method
fiDeviceLocal Class
Show All

Attempt to open a file on this device for bulk read

C++
public: virtual fiHandle OpenBulk(
    const char * filename,
    u64 & outBias
) const;
Parameters

filename
Name of file to open (including device id)
outBias
Reference to a u64 containing a bias you should add to any ReadBulk call using this handle. Allows archives to avoid having to maintain any internal state when using uncompressed files.

Returns

Non-negative handle value on success, negative value on error.

Notes

The handle returned by this function can only be used with ReadBulk and CloseBulk.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::Read Method

fiDeviceLocal::Read Method
fiDeviceLocal Class
Show All

Read binary data from file

C++
public: virtual int Read(
    fiHandle handle,
    void * outBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
outBuffer
Destination to receive data that is read
bufferSize
Maximum amount of data to read

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::ReadBulk Method

fiDeviceLocal::ReadBulk Method
fiDeviceLocal Class
Show All

Seek and read binary data from file

C++
public: virtual int ReadBulk(
    fiHandle handle,
    u64 offset,
    void * outBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
File offset, must be multiple of block size (2048 is safest) Note that you should add any bias returned by OpenBulk in here yourself.
outBuffer
Destination to receive data that is read (should be aligned to cache line for maximum speed)
bufferSize
Maximum amount of data to read, must be multiple of block size (again, 2048 is safest)

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data. The data is not cached.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::Rename Method

fiDeviceLocal::Rename Method
fiDeviceLocal Class
Show All

Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.

C++
public: virtual bool Rename(
    const char * from,
    const char * to
) const;
Parameters

from
Original filename
to
New name for file

Returns

True on success (file renamed), or false on failure (file not found, etc)

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::Seek Method

fiDeviceLocal::Seek Method
fiDeviceLocal Class
Show All

Seek to a location in file

C++
public: virtual int Seek(
    fiHandle handle,
    int offset,
    fiSeekWhence whence
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

Lower 32 bits of new file position, or -1 on error

Notes

Not all devices can implement seek (pipes, etc)

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::Seek64 Method

fiDeviceLocal::Seek64 Method
fiDeviceLocal Class
Show All

Seek to a location in file

C++
public: virtual u64 Seek64(
    fiHandle handle,
    s64 offset,
    fiSeekWhence whence
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

New file position, or 0xFFFF FFFF FFFF FFFF on error.

Notes

Not all devices can implement seek (pipes, etc)

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::SetAttributes Method

fiDeviceLocal::SetAttributes Method
fiDeviceLocal Class
Show All

Sets file attributes

C++
public: virtual bool SetAttributes(
    const char * filename,
    u32 attributes
) const;
Parameters

filename
name of file to set attributes for
attributes
new attributes for file

Returns

True on success, false on failure.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::SetEndOfFile Method

fiDeviceLocal::SetEndOfFile Method
fiDeviceLocal Class
Show All

Sets the end of the file to the current file position.

C++
public: virtual bool SetEndOfFile(
    fiHandle handle
) const;
Parameters

handle
File handle to set the eof marker to

Returns

Zero if the call succeeded, non-zero otherwise.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::SetFileTime Method

fiDeviceLocal::SetFileTime Method
fiDeviceLocal Class
Show All

Set time-of-date information for a file

C++
public: virtual bool SetFileTime(
    const char * filename,
    u64 timestamp
) const;
Parameters

filename
Name of file to request timestamp for
timestamp
Timestamp to set

Returns

True on success, else false on failure.

Notes

The only portable way to set a filetime is from a previous GetFileTime result.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::UnmakeDirectory Method

fiDeviceLocal::UnmakeDirectory Method
fiDeviceLocal Class
Show All

Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK

C++
public: virtual bool UnmakeDirectory(
    const char * filename
) const;
Parameters

pathname
Name of directory to remove

Returns

True on success, or false on failure (directory not empty, etc)

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::Write Method

fiDeviceLocal::Write Method
fiDeviceLocal Class
Show All

Write binary data to file

C++
public: virtual int Write(
    fiHandle handle,
    const void * buffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
buffer
Source buffer for data to write
bufferSize
Maximum amount of data to read

Returns

Non-negative integer on success representing number of bytes of data written (zero typically means media full). Negative integer indicates an error.

Notes

No translation of any kind is done on the data.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocal::WriteBulk Method

fiDeviceLocal::WriteBulk Method
fiDeviceLocal Class
Show All

Seek and write binary data to file

C++
public: virtual int WriteBulk(
    fiHandle handle,
    u64 offset,
    const void * inBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
File offset, must be multiple of block size (2048 is safest) Note that you should add any bias returned by OpenBulk in here yourself.
inBuffer
Source for data that is written (should be aligned to cache line for maximum speed)
bufferSize
Maximum amount of data to write, must be multiple of block size (again, 2048 is safest)

Returns

Non-negative integer on success representing number of bytes of data written (zero typically means disk full). Negative integer indicates an error.

Notes

No translation of any kind is done on the data. The data is not cached.

Class

fiDeviceLocal Class

File

device.h

Links
fiDeviceLocal Class


fiDeviceLocalDrm Class

fiDeviceLocalDrm Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All

Concrete subclass of fiDeviceLocal which implements the local filesystem with DRM support (i.e. PS3 downloadable content)

rage::fiDevice
    rage::fiDeviceLocal
        fiDeviceLocalDrm
C++
public: class fiDeviceLocalDrm : public fiDeviceLocal;
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
Destructors
Destructor | Description
~fiDevice |
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixName | Normalize a name for the underlying local device (insert host0:, change forward slashes to backslashes, etc)
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
OnDiscSwap |
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options
Namespace

rage Namespace

File

device.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


fiDeviceLocalDrm::OpenBulkDrm Method

fiDeviceLocalDrm::OpenBulkDrm Method
fiDeviceLocalDrm Class
Show All

Attempt to open a drm secured file on this device for bulk read

C++
public: virtual fiHandle OpenBulkDrm(
    const char * filename,
    u64 & outBias,
    const void * pDrmKey
) const;
Parameters

filename
Name of file to open (including device id)
outBias
Reference to a u64 containing a bias you should add to any ReadBulk call using this handle. Allows archives to avoid having to maintain any internal state when using uncompressed files.
pDrmKey
pointer to the drm key we will attempt to use to decrypt/unlock this file can be passed NULL in which case OpenBulk is called

Returns

Non-negative handle value on success, negative value on error.

Notes

The handle returned by this function can only be used with ReadBulk and CloseBulk.

Class

fiDeviceLocalDrm Class

File

device.h

Links
fiDeviceLocalDrm Class


fiDeviceMemory Class

fiDeviceMemory Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All

Concrete subclass of fiDevice which implements memory-base streaming. The filename passed to Open must be of the form "memory:%u,%u,%d:comment" where the first value is the memory buffer and the second value is the size of the buffer. The memory is assumed to be allocated by operator new (and will be freed on close) if the third parameter is nonzero.

rage::fiDevice
    fiDeviceMemory
C++
public: class fiDeviceMemory : public fiDevice;
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
Destructors
Destructor | Description
~fiDevice |
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk |
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes |
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options
Namespace

rage Namespace

File

device.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


fiDeviceMemory::Close Method

fiDeviceMemory::Close Method
fiDeviceMemory Class
Show All

Close a file

C++
public: virtual int Close(
    fiHandle handle
) const;
Parameters

handle
Handle of file to close (must have been opened or created with the same device).

Returns

zero if the call succeeded, non-zero if it failed

Notes

You must eventually Close any handle successfully returned by an Open or Create call or else you will have a resource leak.

Class

fiDeviceMemory Class

File

device.h

Links
fiDeviceMemory Class


fiDeviceMemory::CloseBulk Method

fiDeviceMemory::CloseBulk Method
fiDeviceMemory Class
Show All
C++
public: virtual int CloseBulk(
    fiHandle handle
) const;
Class

fiDeviceMemory Class

File

device.h

Links
fiDeviceMemory Class


fiDeviceMemory::Create Method

fiDeviceMemory::Create Method
fiDeviceMemory Class
Show All

Attempt to create a file on this device

C++
public: virtual fiHandle Create(
    const char * filename
) const;
Parameters

filename
Name of file to open (including device id)
readOnly
True if file will be read-only, else false.

Returns

Non-negative handle value on success, negative value on error.

Notes

If this function returns a value file handle, you must eventually call Close on this device with that handle or else you would suffer a resource leak.

Class

fiDeviceMemory Class

File

device.h

Links
fiDeviceMemory Class


fiDeviceMemory::GetAttributes Method

fiDeviceMemory::GetAttributes Method
fiDeviceMemory Class
Show All
C++
public: virtual u32 GetAttributes(
    const char*
) const;
Class

fiDeviceMemory Class

File

device.h

Links
fiDeviceMemory Class


fiDeviceMemory::GetDebugName Method

fiDeviceMemory::GetDebugName Method
fiDeviceMemory Class
Show All
C++
public: virtual const char * GetDebugName() const;
Class

fiDeviceMemory Class

File

device.h

Links
fiDeviceMemory Class


fiDeviceMemory::GetFileSize Method

fiDeviceMemory::GetFileSize Method
fiDeviceMemory Class
Show All

Determine size of file

C++
public: virtual u64 GetFileSize(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Size of the file

Notes

Base class implements this as three calls to Seek, subclasses that may know the size of the file ahead of time are encouraged to improve upon this.

Class

fiDeviceMemory Class

File

device.h

Links
fiDeviceMemory Class


fiDeviceMemory::GetFileTime Method

fiDeviceMemory::GetFileTime Method
fiDeviceMemory Class
Show All

Return time-of-date information for a file

C++
public: virtual u64 GetFileTime(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Large integer (in unspecified units) which represents the file time. Will return 0 if a file did not exist. If a filetime fa is larger than another filetime fb then fa is newer than fb.

Class

fiDeviceMemory Class

File

device.h

Links
fiDeviceMemory Class


fiDeviceMemory::GetInstance Method

fiDeviceMemory::GetInstance Method
fiDeviceMemory Class
Show All

Singleton accessor

C++
public: static const fiDevice& GetInstance();
Class

fiDeviceMemory Class

File

device.h

Links
fiDeviceMemory Class


fiDeviceMemory::Open Method

fiDeviceMemory::Open Method
fiDeviceMemory Class
Show All

Attempt to open a file on this device

C++
public: virtual fiHandle Open(
    const char * filename,
    bool readOnly
) const;
Parameters

filename
Name of file to open (including device id)
readOnly
True if file will be read-only, else false.

Returns

Non-negative handle value on success, negative value on error.

Notes

If a file is read-only, we attempt to open in a sharing-friendly manner. If this function returns a value file handle, you must eventually call Close on this device with that handle or else you would suffer a resource leak.

Class

fiDeviceMemory Class

File

device.h

Links
fiDeviceMemory Class


fiDeviceMemory::OpenBulk Method

fiDeviceMemory::OpenBulk Method
fiDeviceMemory Class
Show All

Attempt to open a file on this device for bulk read

C++
public: virtual fiHandle OpenBulk(
    const char * filename,
    u64 & outBias
) const;
Parameters

filename
Name of file to open (including device id)
outBias
Reference to a u64 containing a bias you should add to any ReadBulk call using this handle. Allows archives to avoid having to maintain any internal state when using uncompressed files.

Returns

Non-negative handle value on success, negative value on error.

Notes

The handle returned by this function can only be used with ReadBulk and CloseBulk.

Class

fiDeviceMemory Class

File

device.h

Links
fiDeviceMemory Class


fiDeviceMemory::Read Method

fiDeviceMemory::Read Method
fiDeviceMemory Class
Show All

Read binary data from file

C++
public: virtual int Read(
    fiHandle handle,
    void * outBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
outBuffer
Destination to receive data that is read
bufferSize
Maximum amount of data to read

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data.

Class

fiDeviceMemory Class

File

device.h

Links
fiDeviceMemory Class


fiDeviceMemory::ReadBulk Method

fiDeviceMemory::ReadBulk Method
fiDeviceMemory Class
Show All

Seek and read binary data from file

C++
public: virtual int ReadBulk(
    fiHandle handle,
    u64 offset,
    void * outBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
File offset, must be multiple of block size (2048 is safest) Note that you should add any bias returned by OpenBulk in here yourself.
outBuffer
Destination to receive data that is read (should be aligned to cache line for maximum speed)
bufferSize
Maximum amount of data to read, must be multiple of block size (again, 2048 is safest)

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data. The data is not cached.

Class

fiDeviceMemory Class

File

device.h

Links
fiDeviceMemory Class


fiDeviceMemory::SafeRead Method

fiDeviceMemory::SafeRead Method
fiDeviceMemory Class
Show All

Read data from file, with retry until error

Safe version of coreRawReadFile.

C++
public: virtual bool SafeRead(
    fiHandle handle,
    void * outBuffer,
    int size
) const;
Parameters

handle
handle of file to read file handle.
outBuffer
Destination buffer for read data
size
Number of bytes to read the data size to read.
buffer
where data to save.

Returns

True if exactly size bytes could be read, false if Read returned negative value at any time.

0 if success.

Notes

This is useful for things like named pipes and TCP connections where data sometimes arrives in smaller pieces than we expect.

Class

fiDeviceMemory Class

File

device.h

Links
fiDeviceMemory Class


fiDeviceMemory::SafeWrite Method

fiDeviceMemory::SafeWrite Method
fiDeviceMemory Class
Show All

Write data to file, with retry until error

Safe version of coreRawWriteFile.

C++
public: virtual bool SafeWrite(
    fiHandle handle,
    const void * buffer,
    int size
) const;
Parameters

handle
handle of file to read file handle.
buffer
Source buffer for written data data to write to file.
size
Number of bytes to write the data size to be written.

Returns

True if exactly size bytes could be written, false if Write returned negative value at any time.

true if success.

Notes

This is useful for things like named pipes and TCP connections where data is sometimes consumed in smaller pieces than we expect.

Class

fiDeviceMemory Class

File

device.h

Links
fiDeviceMemory Class


fiDeviceMemory::Seek Method

fiDeviceMemory::Seek Method
fiDeviceMemory Class
Show All

Seek to a location in file

C++
public: virtual int Seek(
    fiHandle handle,
    int offset,
    fiSeekWhence whence
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

Lower 32 bits of new file position, or -1 on error

Notes

Not all devices can implement seek (pipes, etc)

Class

fiDeviceMemory Class

File

device.h

Links
fiDeviceMemory Class


fiDeviceMemory::Seek64 Method

fiDeviceMemory::Seek64 Method
fiDeviceMemory Class
Show All

Seek to a location in file

C++
public: virtual u64 Seek64(
    fiHandle handle,
    s64 offset,
    fiSeekWhence whence
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

New file position, or 0xFFFF FFFF FFFF FFFF on error.

Notes

Not all devices can implement seek (pipes, etc)

Class

fiDeviceMemory Class

File

device.h

Links
fiDeviceMemory Class


fiDeviceMemory::SetFileTime Method

fiDeviceMemory::SetFileTime Method
fiDeviceMemory Class
Show All

Set time-of-date information for a file

C++
public: virtual bool SetFileTime(
    const char * filename,
    u64 timestamp
) const;
Parameters

filename
Name of file to request timestamp for
timestamp
Timestamp to set

Returns

True on success, else false on failure.

Notes

The only portable way to set a filetime is from a previous GetFileTime result.

Class

fiDeviceMemory Class

File

device.h

Links
fiDeviceMemory Class


fiDeviceMemory::Write Method

fiDeviceMemory::Write Method
fiDeviceMemory Class
Show All

Write binary data to file

C++
public: virtual int Write(
    fiHandle handle,
    const void * buffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
buffer
Source buffer for data to write
bufferSize
Maximum amount of data to read

Returns

Non-negative integer on success representing number of bytes of data written (zero typically means media full). Negative integer indicates an error.

Notes

No translation of any kind is done on the data.

Class

fiDeviceMemory Class

File

device.h

Links
fiDeviceMemory Class


fiDeviceProfiler Struct

fiDeviceProfiler Struct
Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
fiDeviceProfiler
C++
public: struct fiDeviceProfiler {
};
Destructors
Destructor | Description
~fiDeviceProfiler |
Methods
Method | Description
OnClose |
OnOpen |
OnRead |
OnReadEnd |
OnSeek |
OnWrite |
Namespace

rage Namespace

File

device.h

Links
Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


fiDeviceProfiler::~fiDeviceProfiler Destructor

fiDeviceProfiler::~fiDeviceProfiler Destructor
fiDeviceProfiler Struct
Show All
C++
public: virtual ~fiDeviceProfiler();
Struct

fiDeviceProfiler Struct

File

device.h

Links
fiDeviceProfiler Struct


fiDeviceProfiler::OnClose Method

fiDeviceProfiler::OnClose Method
fiDeviceProfiler Struct
Show All
C++
public: virtual void OnClose(
    fiHandle
);
Struct

fiDeviceProfiler Struct

File

device.h

Links
fiDeviceProfiler Struct


fiDeviceProfiler::OnOpen Method

fiDeviceProfiler::OnOpen Method
fiDeviceProfiler Struct
Show All
C++
public: virtual void OnOpen(
    fiHandle,
    const char *
);
Struct

fiDeviceProfiler Struct

File

device.h

Links
fiDeviceProfiler Struct


fiDeviceProfiler::OnRead Method

fiDeviceProfiler::OnRead Method
fiDeviceProfiler Struct
Show All
C++
public: virtual void OnRead(
    fiHandle,
    size_t,
    u64
);
Struct

fiDeviceProfiler Struct

File

device.h

Links
fiDeviceProfiler Struct


fiDeviceProfiler::OnReadEnd Method

fiDeviceProfiler::OnReadEnd Method
fiDeviceProfiler Struct
Show All
C++
public: virtual void OnReadEnd(
    fiHandle
);
Struct

fiDeviceProfiler Struct

File

device.h

Links
fiDeviceProfiler Struct


fiDeviceProfiler::OnSeek Method

fiDeviceProfiler::OnSeek Method
fiDeviceProfiler Struct
Show All
C++
public: virtual void OnSeek(
    fiHandle,
    u64
);
Struct

fiDeviceProfiler Struct

File

device.h

Links
fiDeviceProfiler Struct


fiDeviceProfiler::OnWrite Method

fiDeviceProfiler::OnWrite Method
fiDeviceProfiler Struct
Show All
C++
public: virtual void OnWrite(
    fiHandle,
    size_t
);
Struct

fiDeviceProfiler Struct

File

device.h

Links
fiDeviceProfiler Struct


fiDeviceRelative Class

fiDeviceRelative Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All

Specialised version of device that uses a relative path from another device Notes from Adam Fowler: The "platform:" device name is just specific to GTA. We are in the process of changing the structure of our build folder so that all the files common to all platforms are in one directory tree and all the files that are platform dependent have another directory tree per platform eg Gta/ Common files/ Pc files/ Ps3 files/ 360 files/

I used the class to define two devices common:/ and platform:/ to define where the different sets of data go.

// setup relative common data device gCommonDevice.Init("", false); gCommonDevice.MountAs("common:/"); // setup relative platform data device gPlatformDevice.Init(", false); gPlatformDevice.MountAs("platform:/");

I did a quick test after setting this up of packing the common file tree into a packfile and mounting that instead of the file tree and the game worked straight off the pack file.

Purpose

name: fiDeviceRelative

rage::fiDevice
    fiDeviceRelative
C++
public: class fiDeviceRelative : public fiDevice;
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
fiDeviceRelative |
Destructors
Destructor | Description
~fiDevice |
~fiDeviceRelative |
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixName |
FixRelativeName |
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetResourceInfo |
GetRpfDevice |
Init |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
MountAs |
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk |
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
m_pDevice |
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options
Namespace

rage Namespace

File

device_relative.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


fiDeviceRelative::m_pDevice Data Member

fiDeviceRelative::m_pDevice Data Member
fiDeviceRelative Class
Show All
C++
protected: const fiDevice* m_pDevice;
Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::fiDeviceRelative Constructor

fiDeviceRelative::fiDeviceRelative Constructor
fiDeviceRelative Class
Show All
C++
public: fiDeviceRelative();
Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::~fiDeviceRelative Destructor

fiDeviceRelative::~fiDeviceRelative Destructor
fiDeviceRelative Class
Show All
C++
public: virtual ~fiDeviceRelative();
Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::Close Method

fiDeviceRelative::Close Method
fiDeviceRelative Class
Show All

Close a file

C++
public: virtual int Close(
    fiHandle handle
) const;
Parameters

handle
Handle of file to close (must have been opened or created with the same device).

Returns

zero if the call succeeded, non-zero if it failed

Notes

You must eventually Close any handle successfully returned by an Open or Create call or else you will have a resource leak.

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::CloseBulk Method

fiDeviceRelative::CloseBulk Method
fiDeviceRelative Class
Show All

Close a file opened via OpenBulk

C++
public: virtual int CloseBulk(
    fiHandle handle
) const;
Parameters

handle
Handle of file to close (must have been opened or created with the same device via OpenBulk

Returns

zero if the call succeeded, non-zero if it failed

Notes

You must eventually Close any handle successfully returned by an Open or Create call or else you will have a resource leak.

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::Create Method

fiDeviceRelative::Create Method
fiDeviceRelative Class
Show All

Attempt to create a file on this device

C++
public: virtual fiHandle Create(
    const char * filename
) const;
Parameters

filename
Name of file to open (including device id)
readOnly
True if file will be read-only, else false.

Returns

Non-negative handle value on success, negative value on error.

Notes

If this function returns a value file handle, you must eventually call Close on this device with that handle or else you would suffer a resource leak.

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::Delete Method

fiDeviceRelative::Delete Method
fiDeviceRelative Class
Show All

Delete a file from device

C++
public: virtual bool Delete(
    const char * filename
) const;
Parameters

filename
Name of file to delete

Returns

True on success (file deleted), or false on failure (file not found, marked read-only, etc)

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::FindFileBegin Method

fiDeviceRelative::FindFileBegin Method
fiDeviceRelative Class
Show All

Iterate over all files in a directory

C++
public: virtual fiHandle FindFileBegin(
    const char * filename,
    fiFindData & outData
) const;
Parameters

directoryName
Name of the directory to search (no wildcard necessary or supported; do filtering yourself in higher-level code).
outData
Info for first matching file (if return value was not -1)

Returns

A "find handle" that is used to identify this search so that more that one can be in progress at a time, or -1 if we were unable to find any matches. Must eventually call FindFileEnd on this handle if it did not return -1.

Notes

Some platforms will return "." and ".." and some will not, so make sure you handle them properly.

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::FindFileEnd Method

fiDeviceRelative::FindFileEnd Method
fiDeviceRelative Class
Show All

Close a search begun with FindFileBegin

C++
public: virtual int FindFileEnd(
    fiHandle handle
) const;
Parameters

handle
Find handle to close

Returns

Zero if the call succeeded, non-zero otherwise.

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::FindFileNext Method

fiDeviceRelative::FindFileNext Method
fiDeviceRelative Class
Show All

Continue a search begun with FindFileBegin

C++
public: virtual bool FindFileNext(
    fiHandle handle,
    fiFindData & outData
) const;
Parameters

handle
Find handle returned by FindFileBegin
outData
Info for next match file (if return value was not false)

Returns

True on success (outData is valid), or false if there were no more matches

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::FixName Method

fiDeviceRelative::FixName Method
fiDeviceRelative Class
Show All
C++
public: const char * FixName(
    char * dest,
    int destSize,
    const char * src
) const;
Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::FixRelativeName Method

fiDeviceRelative::FixRelativeName Method
fiDeviceRelative Class
Show All
C++
public: virtual char* FixRelativeName(
    char * dest,
    int destSize,
    const char * src
) const;
Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::GetAttributes Method

fiDeviceRelative::GetAttributes Method
fiDeviceRelative Class
Show All

Retrieves file attributes

C++
public: virtual u32 GetAttributes(
    const char * filename
) const;
Parameters

filename
name of file to retrieve attributes

Returns

File attributes (see FILE_ATTRIBUTE_...) or FILE_ATTRIBUTE_INVALID (~0U) if file doesn't exist.

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::GetBulkOffset Method

fiDeviceRelative::GetBulkOffset Method
fiDeviceRelative Class
Show All
C++
public: virtual u64 GetBulkOffset(
    const char* name
) const;
Returns

Bulk offset of file, if found (can skip OpenBulk and just call ReadBulk directly)

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::GetDebugName Method

fiDeviceRelative::GetDebugName Method
fiDeviceRelative Class
Show All
C++
public: virtual const char * GetDebugName() const;
Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::GetFileSize Method

fiDeviceRelative::GetFileSize Method
fiDeviceRelative Class
Show All

Determine size of file

C++
public: virtual u64 GetFileSize(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Size of the file

Notes

Base class implements this as three calls to Seek, subclasses that may know the size of the file ahead of time are encouraged to improve upon this.

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::GetFileTime Method

fiDeviceRelative::GetFileTime Method
fiDeviceRelative Class
Show All

Return time-of-date information for a file

C++
public: virtual u64 GetFileTime(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Large integer (in unspecified units) which represents the file time. Will return 0 if a file did not exist. If a filetime fa is larger than another filetime fb then fa is newer than fb.

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::GetLowLevelDevice Method

fiDeviceRelative::GetLowLevelDevice Method
fiDeviceRelative Class
Show All

Get the actual low-level device that drives I/O on this device.

C++
public: virtual const fiDevice * GetLowLevelDevice() const;
Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::GetPhysicalSortKey Method

fiDeviceRelative::GetPhysicalSortKey Method
fiDeviceRelative Class
Show All
C++
public: virtual u32 GetPhysicalSortKey(
    const char* filename
) const;
Returns

Returns a sort key for file on device. For DVD this would be sector address. If it's HARDDRIVE_LSN, we don't know anything about it, or it's on a hard drive.

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::GetResourceInfo Method

fiDeviceRelative::GetResourceInfo Method
fiDeviceRelative Class
Show All
C++
public: virtual int GetResourceInfo(
    const char* name,
    datResourceInfo & info
) const;
Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::Init Method

fiDeviceRelative::Init Method
fiDeviceRelative Class
Show All
C++
public: void Init(
    const char* pPath,
    bool readOnly = true,
    fiDevice* pDeviceOverride = NULL
);
Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::MakeDirectory Method

fiDeviceRelative::MakeDirectory Method
fiDeviceRelative Class
Show All

Make a directory on device

C++
public: virtual bool MakeDirectory(
    const char * filename
) const;
Parameters

pathname
Name of directory to create

Returns

True on success, or false on failure (directory already existed, etc)

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::MountAs Method

fiDeviceRelative::MountAs Method
fiDeviceRelative Class
Show All
C++
public: bool MountAs(
    const char * path
);
Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::Open Method

fiDeviceRelative::Open Method
fiDeviceRelative Class
Show All

Attempt to open a file on this device

C++
public: virtual fiHandle Open(
    const char * filename,
    bool readOnly
) const;
Parameters

filename
Name of file to open (including device id)
readOnly
True if file will be read-only, else false.

Returns

Non-negative handle value on success, negative value on error.

Notes

If a file is read-only, we attempt to open in a sharing-friendly manner. If this function returns a value file handle, you must eventually call Close on this device with that handle or else you would suffer a resource leak.

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::OpenBulk Method

fiDeviceRelative::OpenBulk Method
fiDeviceRelative Class
Show All
C++
public: virtual fiHandle OpenBulk(
    const char * filename,
    u64& bias
) const;
Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::OpenBulkDrm Method

fiDeviceRelative::OpenBulkDrm Method
fiDeviceRelative Class
Show All

Attempt to open a drm secured file on this device for bulk read

C++
public: virtual fiHandle OpenBulkDrm(
    const char * filename,
    u64 & outBias,
    const void * pDrmKey
) const;
Parameters

filename
Name of file to open (including device id)
outBias
Reference to a u64 containing a bias you should add to any ReadBulk call using this handle. Allows archives to avoid having to maintain any internal state when using uncompressed files.
pDrmKey
pointer to the drm key we will attempt to use to decrypt/unlock this file can be passed NULL in which case OpenBulk is called

Returns

Non-negative handle value on success, negative value on error.

Notes

The handle returned by this function can only be used with ReadBulk and CloseBulk.

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::PrefetchDir Method

fiDeviceRelative::PrefetchDir Method
fiDeviceRelative Class
Show All

Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.

C++
public: virtual bool PrefetchDir(
    const char * directory
) const;
Parameters

filename
name of directory to parse

Returns

True if successful, false otherwise.

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::Read Method

fiDeviceRelative::Read Method
fiDeviceRelative Class
Show All

Read binary data from file

C++
public: virtual int Read(
    fiHandle handle,
    void * outBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
outBuffer
Destination to receive data that is read
bufferSize
Maximum amount of data to read

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data.

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::ReadBulk Method

fiDeviceRelative::ReadBulk Method
fiDeviceRelative Class
Show All

Seek and read binary data from file

C++
public: virtual int ReadBulk(
    fiHandle handle,
    u64 offset,
    void * outBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
File offset, must be multiple of block size (2048 is safest) Note that you should add any bias returned by OpenBulk in here yourself.
outBuffer
Destination to receive data that is read (should be aligned to cache line for maximum speed)
bufferSize
Maximum amount of data to read, must be multiple of block size (again, 2048 is safest)

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data. The data is not cached.

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::Rename Method

fiDeviceRelative::Rename Method
fiDeviceRelative Class
Show All

Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.

C++
public: virtual bool Rename(
    const char * from,
    const char * to
) const;
Parameters

from
Original filename
to
New name for file

Returns

True on success (file renamed), or false on failure (file not found, etc)

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::Seek Method

fiDeviceRelative::Seek Method
fiDeviceRelative Class
Show All

Seek to a location in file

C++
public: virtual int Seek(
    fiHandle handle,
    int offset,
    fiSeekWhence whence
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

Lower 32 bits of new file position, or -1 on error

Notes

Not all devices can implement seek (pipes, etc)

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::Seek64 Method

fiDeviceRelative::Seek64 Method
fiDeviceRelative Class
Show All

Seek to a location in file

C++
public: virtual u64 Seek64(
    fiHandle handle,
    s64 offset,
    fiSeekWhence whence
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

New file position, or 0xFFFF FFFF FFFF FFFF on error.

Notes

Not all devices can implement seek (pipes, etc)

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::SetAttributes Method

fiDeviceRelative::SetAttributes Method
fiDeviceRelative Class
Show All

Sets file attributes

C++
public: virtual bool SetAttributes(
    const char * filename,
    u32 attributes
) const;
Parameters

filename
name of file to set attributes for
attributes
new attributes for file

Returns

True on success, false on failure.

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::SetEndOfFile Method

fiDeviceRelative::SetEndOfFile Method
fiDeviceRelative Class
Show All

Sets the end of the file to the current file position.

C++
public: virtual bool SetEndOfFile(
    fiHandle handle
) const;
Parameters

handle
File handle to set the eof marker to

Returns

Zero if the call succeeded, non-zero otherwise.

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::SetFileTime Method

fiDeviceRelative::SetFileTime Method
fiDeviceRelative Class
Show All

Set time-of-date information for a file

C++
public: virtual bool SetFileTime(
    const char * filename,
    u64 timestamp
) const;
Parameters

filename
Name of file to request timestamp for
timestamp
Timestamp to set

Returns

True on success, else false on failure.

Notes

The only portable way to set a filetime is from a previous GetFileTime result.

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::UnmakeDirectory Method

fiDeviceRelative::UnmakeDirectory Method
fiDeviceRelative Class
Show All

Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK

C++
public: virtual bool UnmakeDirectory(
    const char * filename
) const;
Parameters

pathname
Name of directory to remove

Returns

True on success, or false on failure (directory not empty, etc)

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRelative::Write Method

fiDeviceRelative::Write Method
fiDeviceRelative Class
Show All

Write binary data to file

C++
public: virtual int Write(
    fiHandle handle,
    const void * buffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
buffer
Source buffer for data to write
bufferSize
Maximum amount of data to read

Returns

Non-negative integer on success representing number of bytes of data written (zero typically means media full). Negative integer indicates an error.

Notes

No translation of any kind is done on the data.

Class

fiDeviceRelative Class

File

device_relative.h

Links
fiDeviceRelative Class


fiDeviceRemote Class

fiDeviceRemote Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All

Concrete subclass of fiDevice which implements a simple TCP/IP-based remote filesystem. Intended for Xbox and Xenon, neither of which support simple read/write access to your host PC.

rage::fiDevice
    fiDeviceRemote
C++
public: class fiDeviceRemote : public fiDevice;
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
Destructors
Destructor | Description
~fiDevice |
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
DeleteDirectory |
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetAttributesDir |
GetAverageThroughput |
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileCount |
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
InitClass |
InvalidateDirectoryCache |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
ShutdownClass |
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options
Namespace

rage Namespace

File

device.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


fiDeviceRemote::Close Method

fiDeviceRemote::Close Method
fiDeviceRemote Class
Show All

Close a file

C++
public: virtual int Close(
    fiHandle handle
) const;
Parameters

handle
Handle of file to close (must have been opened or created with the same device).

Returns

zero if the call succeeded, non-zero if it failed

Notes

You must eventually Close any handle successfully returned by an Open or Create call or else you will have a resource leak.

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::CloseBulk Method

fiDeviceRemote::CloseBulk Method
fiDeviceRemote Class
Show All

Close a file opened via OpenBulk

C++
public: virtual int CloseBulk(
    fiHandle handle
) const;
Parameters

handle
Handle of file to close (must have been opened or created with the same device via OpenBulk

Returns

zero if the call succeeded, non-zero if it failed

Notes

You must eventually Close any handle successfully returned by an Open or Create call or else you will have a resource leak.

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::Create Method

fiDeviceRemote::Create Method
fiDeviceRemote Class
Show All

Attempt to create a file on this device

C++
public: virtual fiHandle Create(
    const char * filename
) const;
Parameters

filename
Name of file to open (including device id)
readOnly
True if file will be read-only, else false.

Returns

Non-negative handle value on success, negative value on error.

Notes

If this function returns a value file handle, you must eventually call Close on this device with that handle or else you would suffer a resource leak.

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::Delete Method

fiDeviceRemote::Delete Method
fiDeviceRemote Class
Show All

Delete a file from device

C++
public: virtual bool Delete(
    const char * filename
) const;
Parameters

filename
Name of file to delete

Returns

True on success (file deleted), or false on failure (file not found, marked read-only, etc)

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::DeleteDirectory Method

fiDeviceRemote::DeleteDirectory Method
fiDeviceRemote Class
Show All
C++
public: virtual bool DeleteDirectory(
    const char * pathname,
    bool deleteContents = false
) const;
Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::FindFileBegin Method

fiDeviceRemote::FindFileBegin Method
fiDeviceRemote Class
Show All

Iterate over all files in a directory

C++
public: virtual fiHandle FindFileBegin(
    const char * filename,
    fiFindData & outData
) const;
Parameters

directoryName
Name of the directory to search (no wildcard necessary or supported; do filtering yourself in higher-level code).
outData
Info for first matching file (if return value was not -1)

Returns

A "find handle" that is used to identify this search so that more that one can be in progress at a time, or -1 if we were unable to find any matches. Must eventually call FindFileEnd on this handle if it did not return -1.

Notes

Some platforms will return "." and ".." and some will not, so make sure you handle them properly.

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::FindFileEnd Method

fiDeviceRemote::FindFileEnd Method
fiDeviceRemote Class
Show All

Close a search begun with FindFileBegin

C++
public: virtual int FindFileEnd(
    fiHandle handle
) const;
Parameters

handle
Find handle to close

Returns

Zero if the call succeeded, non-zero otherwise.

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::FindFileNext Method

fiDeviceRemote::FindFileNext Method
fiDeviceRemote Class
Show All

Continue a search begun with FindFileBegin

C++
public: virtual bool FindFileNext(
    fiHandle handle,
    fiFindData & outData
) const;
Parameters

handle
Find handle returned by FindFileBegin
outData
Info for next match file (if return value was not false)

Returns

True on success (outData is valid), or false if there were no more matches

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::GetAttributes Method

fiDeviceRemote::GetAttributes Method
fiDeviceRemote Class
Show All

Retrieves file attributes

C++
public: virtual u32 GetAttributes(
    const char * filename
) const;
Parameters

filename
name of file to retrieve attributes

Returns

File attributes (see FILE_ATTRIBUTE_...) or FILE_ATTRIBUTE_INVALID (~0U) if file doesn't exist.

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::GetAttributesDir Method

fiDeviceRemote::GetAttributesDir Method
fiDeviceRemote Class
Show All
C++
public: u32 GetAttributesDir(
    const char * directory,
    fiRemoteDirEntry * results,
    int resultCount
) const;
Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::GetAverageThroughput Method

fiDeviceRemote::GetAverageThroughput Method
fiDeviceRemote Class
Show All
C++
public: float GetAverageThroughput() const;
Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::GetDebugName Method

fiDeviceRemote::GetDebugName Method
fiDeviceRemote Class
Show All
C++
public: virtual const char * GetDebugName() const;
Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::GetFileCount Method

fiDeviceRemote::GetFileCount Method
fiDeviceRemote Class
Show All
C++
public: u32 GetFileCount(
    const char * directory
) const;
Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::GetFileSize Method

fiDeviceRemote::GetFileSize Method
fiDeviceRemote Class
Show All

Determine size of file

C++
public: virtual u64 GetFileSize(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Size of the file

Notes

Base class implements this as three calls to Seek, subclasses that may know the size of the file ahead of time are encouraged to improve upon this.

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::GetFileTime Method

fiDeviceRemote::GetFileTime Method
fiDeviceRemote Class
Show All

Return time-of-date information for a file

C++
public: virtual u64 GetFileTime(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Large integer (in unspecified units) which represents the file time. Will return 0 if a file did not exist. If a filetime fa is larger than another filetime fb then fa is newer than fb.

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::GetInstance Method

fiDeviceRemote::GetInstance Method
fiDeviceRemote Class
Show All

Singleton accessor

C++
public: static const fiDevice& GetInstance();
Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::GetResourceInfo Method

fiDeviceRemote::GetResourceInfo Method
fiDeviceRemote Class
Show All

Retrieve resource information for a file. It only works files that have a standard resource header.

C++
public: virtual int GetResourceInfo(
    const char * name,
    datResourceInfo & outHeader
) const;
Parameters

name
Name of file to query
outHeader
If return value is nonzero, contains header information

Returns

Nonzero if file exists and has a standard resource header, else zero. A return of -1 means it's a valid resource but the version number is unavailable.

Notes

For raw files, it reads the header (which would cause tons of seeking on final media). For archived files, it (will eventually) use the metadata present in the directory structure.

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::InitClass Method

fiDeviceRemote::InitClass Method
fiDeviceRemote Class
Show All
C++
public: static void InitClass(
    int argc,
    char ** argv
);
Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::InvalidateDirectoryCache Method

fiDeviceRemote::InvalidateDirectoryCache Method
fiDeviceRemote Class
Show All
C++
public: void InvalidateDirectoryCache(
    const char * directory
) const;
Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::MakeDirectory Method

fiDeviceRemote::MakeDirectory Method
fiDeviceRemote Class
Show All

Make a directory on device

C++
public: virtual bool MakeDirectory(
    const char * pathname
) const;
Parameters

pathname
Name of directory to create

Returns

True on success, or false on failure (directory already existed, etc)

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::Open Method

fiDeviceRemote::Open Method
fiDeviceRemote Class
Show All

Attempt to open a file on this device

C++
public: virtual fiHandle Open(
    const char * filename,
    bool readOnly
) const;
Parameters

filename
Name of file to open (including device id)
readOnly
True if file will be read-only, else false.

Returns

Non-negative handle value on success, negative value on error.

Notes

If a file is read-only, we attempt to open in a sharing-friendly manner. If this function returns a value file handle, you must eventually call Close on this device with that handle or else you would suffer a resource leak.

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::OpenBulk Method

fiDeviceRemote::OpenBulk Method
fiDeviceRemote Class
Show All

Attempt to open a file on this device for bulk read

C++
public: virtual fiHandle OpenBulk(
    const char * filename,
    u64 & outBias
) const;
Parameters

filename
Name of file to open (including device id)
outBias
Reference to a u64 containing a bias you should add to any ReadBulk call using this handle. Allows archives to avoid having to maintain any internal state when using uncompressed files.

Returns

Non-negative handle value on success, negative value on error.

Notes

The handle returned by this function can only be used with ReadBulk and CloseBulk.

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::PrefetchDir Method

fiDeviceRemote::PrefetchDir Method
fiDeviceRemote Class
Show All

Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.

C++
public: bool PrefetchDir(
    const char * directory
) const;
Parameters

filename
name of directory to parse

Returns

True if successful, false otherwise.

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::Read Method

fiDeviceRemote::Read Method
fiDeviceRemote Class
Show All

Read binary data from file

C++
public: virtual int Read(
    fiHandle handle,
    void * outBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
outBuffer
Destination to receive data that is read
bufferSize
Maximum amount of data to read

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data.

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::ReadBulk Method

fiDeviceRemote::ReadBulk Method
fiDeviceRemote Class
Show All

Seek and read binary data from file

C++
public: virtual int ReadBulk(
    fiHandle handle,
    u64 offset,
    void * outBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
File offset, must be multiple of block size (2048 is safest) Note that you should add any bias returned by OpenBulk in here yourself.
outBuffer
Destination to receive data that is read (should be aligned to cache line for maximum speed)
bufferSize
Maximum amount of data to read, must be multiple of block size (again, 2048 is safest)

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data. The data is not cached.

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::Seek Method

fiDeviceRemote::Seek Method
fiDeviceRemote Class
Show All

Seek to a location in file

C++
public: virtual int Seek(
    fiHandle handle,
    int offset,
    fiSeekWhence whence
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

Lower 32 bits of new file position, or -1 on error

Notes

Not all devices can implement seek (pipes, etc)

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::Seek64 Method

fiDeviceRemote::Seek64 Method
fiDeviceRemote Class
Show All

Seek to a location in file

C++
public: virtual u64 Seek64(
    fiHandle handle,
    s64 offset,
    fiSeekWhence whence
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

New file position, or 0xFFFF FFFF FFFF FFFF on error.

Notes

Not all devices can implement seek (pipes, etc)

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::SetAttributes Method

fiDeviceRemote::SetAttributes Method
fiDeviceRemote Class
Show All

Sets file attributes

C++
public: virtual bool SetAttributes(
    const char * filename,
    u32 attributes
) const;
Parameters

filename
name of file to set attributes for
attributes
new attributes for file

Returns

True on success, false on failure.

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::SetFileTime Method

fiDeviceRemote::SetFileTime Method
fiDeviceRemote Class
Show All

Set time-of-date information for a file

C++
public: virtual bool SetFileTime(
    const char * filename,
    u64 timestamp
) const;
Parameters

filename
Name of file to request timestamp for
timestamp
Timestamp to set

Returns

True on success, else false on failure.

Notes

The only portable way to set a filetime is from a previous GetFileTime result.

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::ShutdownClass Method

fiDeviceRemote::ShutdownClass Method
fiDeviceRemote Class
Show All
C++
public: static void ShutdownClass();
Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceRemote::Write Method

fiDeviceRemote::Write Method
fiDeviceRemote Class
Show All

Write binary data to file

C++
public: virtual int Write(
    fiHandle handle,
    const void * buffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
buffer
Source buffer for data to write
bufferSize
Maximum amount of data to read

Returns

Non-negative integer on success representing number of bytes of data written (zero typically means media full). Negative integer indicates an error.

Notes

No translation of any kind is done on the data.

Class

fiDeviceRemote Class

File

device.h

Links
fiDeviceRemote Class


fiDeviceTcpIp Class

fiDeviceTcpIp Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::fiDevice
    fiDeviceTcpIp
C++
public: class fiDeviceTcpIp : public fiDevice;
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
fiDeviceTcpIp |
Destructors
Destructor | Description
~fiDevice |
~fiDeviceTcpIp |
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
Connect | Connect to an existing server at an address and port.
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLastError | Return a string describing the last error that was detected.
GetLocalHost |
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetReadCount | Returns amount of data bytes waiting on the socket
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Listen | Install a listen socket on the specified port
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Filename format for fiDeviceTcpIp should be: "tcpip::" or "tcpip::LISTEN" e.g. "tcpip:1234:localhost", "tcpip:80:10.0.23.14", "tcpip:23:LISTEN"
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
Pickup | Pickup an incoming connection (for use on the server side)
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
PrintInterfaceState |
PrintNetStats |
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek |
Seek64 | Seek to a location in file
Seek64 |
SetAttributes | Sets file attributes
SetBlocking | Sets blocking mode for this socket - defaults to ON
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetLastError | Set the string that will be returned on the next call to GetLastError().
SetLocalHost |
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
ShutdownClass |
Size | Determine size of file
Size64 | Determine size of file
StaticWrite |
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
WaitForNetworkReady |
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options
Namespace

rage Namespace

File

tcpip.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


fiDeviceTcpIp::fiDeviceTcpIp Constructor

fiDeviceTcpIp::fiDeviceTcpIp Constructor
fiDeviceTcpIp Class
Show All
C++
public: fiDeviceTcpIp();
Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::~fiDeviceTcpIp Destructor

fiDeviceTcpIp::~fiDeviceTcpIp Destructor
fiDeviceTcpIp Class
Show All
C++
public: ~fiDeviceTcpIp();
Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::Close Method

fiDeviceTcpIp::Close Method
fiDeviceTcpIp Class
Show All

Close a file

C++
public: virtual int Close(
    fiHandle handle
) const;
Parameters

handle
Handle of file to close (must have been opened or created with the same device).

Returns

zero if the call succeeded, non-zero if it failed

Notes

You must eventually Close any handle successfully returned by an Open or Create call or else you will have a resource leak.

Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::Connect Method

fiDeviceTcpIp::Connect Method
fiDeviceTcpIp Class
Show All

Connect to an existing server at an address and port.

C++
public: static fiHandle Connect(
    const char * address,
    int port
);
Parameters

address
address of server; either hostname or raw ip dot address
port
port number to connect on

Returns

Valid handle if connection is successful, fiHandleInvalid if bad address, port, or other connection problem

Notes

Open and Create both call this function internally after parsing the name.

Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::Create Method

fiDeviceTcpIp::Create Method
fiDeviceTcpIp Class
Show All

Attempt to create a file on this device

C++
public: virtual fiHandle Create(
    const char * filename
) const;
Parameters

filename
Name of file to open (including device id)
readOnly
True if file will be read-only, else false.

Returns

Non-negative handle value on success, negative value on error.

Notes

If this function returns a value file handle, you must eventually call Close on this device with that handle or else you would suffer a resource leak.

Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::GetDebugName Method

fiDeviceTcpIp::GetDebugName Method
fiDeviceTcpIp Class
Show All
C++
public: virtual const char * GetDebugName() const;
Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::GetFileTime Method

fiDeviceTcpIp::GetFileTime Method
fiDeviceTcpIp Class
Show All

Return time-of-date information for a file

C++
public: virtual u64 GetFileTime(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Large integer (in unspecified units) which represents the file time. Will return 0 if a file did not exist. If a filetime fa is larger than another filetime fb then fa is newer than fb.

Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::GetInstance Method

fiDeviceTcpIp::GetInstance Method
fiDeviceTcpIp Class
Show All

Singleton accessor

C++
public: static const fiDeviceTcpIp& GetInstance();
Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::GetLastError Method

fiDeviceTcpIp::GetLastError Method
fiDeviceTcpIp Class
Show All

Return a string describing the last error that was detected.

C++
public: static const char * GetLastError();
Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::GetLocalHost Method

fiDeviceTcpIp::GetLocalHost Method
fiDeviceTcpIp Class
Show All
C++
public: static const char * GetLocalHost();
Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::GetReadCount Method

fiDeviceTcpIp::GetReadCount Method
fiDeviceTcpIp Class
Show All

Returns amount of data bytes waiting on the socket

C++
public: static int GetReadCount(
    fiHandle socket
);
Parameters

socket
socket to check

Returns

Number of bytes waiting to read, or zero if none available

Notes

Call this first to avoid blocking on a read.

Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::InitClass Method

fiDeviceTcpIp::InitClass Method
fiDeviceTcpIp Class
Show All
C++
public: static void InitClass(
    int argc,
    char** argv
);
Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::Listen Method

fiDeviceTcpIp::Listen Method
fiDeviceTcpIp Class
Show All

Install a listen socket on the specified port

C++
public: static fiHandle Listen(
    int port,
    int maxIncoming,
    const char * ip = NULL
);
Parameters

port
Port number to install connection on
maxIncoming
Maximum number of connections to allow
ip
If not null, bind on this named ip address instead of default; WIN32PC only.

Returns

Socket to pass to Pickup when waiting for a new connection, or fiHandleInvalid if it failed (most likely because the local port is already in use)

Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::Open Method

fiDeviceTcpIp::Open Method
fiDeviceTcpIp Class
Show All

Filename format for fiDeviceTcpIp should be: "tcpip::" or "tcpip::LISTEN" e.g. "tcpip:1234:localhost", "tcpip:80:10.0.23.14", "tcpip:23:LISTEN"

C++
public: virtual fiHandle Open(
    const char * filename,
    bool readOnly
) const;
Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::Pickup Method

fiDeviceTcpIp::Pickup Method
fiDeviceTcpIp Class
Show All

Pickup an incoming connection (for use on the server side)

C++
public: static fiHandle Pickup(
    fiHandle listenSocket
);
Parameters

listenSocket
Socket returned by Listen

Returns

New data connection socket we can send and receive data on, or fiHandleInvalid if something went wrong.

Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::PrintInterfaceState Method

fiDeviceTcpIp::PrintInterfaceState Method
fiDeviceTcpIp Class
Show All
C++
public: static int PrintInterfaceState();
Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::PrintNetStats Method

fiDeviceTcpIp::PrintNetStats Method
fiDeviceTcpIp Class
Show All
C++
public: static int PrintNetStats();
Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::Read Method

fiDeviceTcpIp::Read Method
fiDeviceTcpIp Class
Show All

Read binary data from file

C++
public: virtual int Read(
    fiHandle handle,
    void * outBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
outBuffer
Destination to receive data that is read
bufferSize
Maximum amount of data to read

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data.

Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::Seek Method

fiDeviceTcpIp::Seek Method
fiDeviceTcpIp Class
Show All
C++
public: virtual int Seek(
    fiHandle handle,
    int offset,
    fiSeekWhence whence
) const;
Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::Seek64 Method

fiDeviceTcpIp::Seek64 Method
fiDeviceTcpIp Class
Show All
C++
public: virtual u64 Seek64(
    fiHandle handle,
    s64 offset,
    fiSeekWhence whence
) const;
Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::SetBlocking Method

fiDeviceTcpIp::SetBlocking Method
fiDeviceTcpIp Class
Show All

Sets blocking mode for this socket - defaults to ON

C++
public: static void SetBlocking(
    fiHandle handle,
    bool blocking
);
Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::SetFileTime Method

fiDeviceTcpIp::SetFileTime Method
fiDeviceTcpIp Class
Show All

Set time-of-date information for a file

C++
public: virtual bool SetFileTime(
    const char * filename,
    u64 timestamp
) const;
Parameters

filename
Name of file to request timestamp for
timestamp
Timestamp to set

Returns

True on success, else false on failure.

Notes

The only portable way to set a filetime is from a previous GetFileTime result.

Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::SetLastError Method

fiDeviceTcpIp::SetLastError Method
fiDeviceTcpIp Class
Show All

Set the string that will be returned on the next call to GetLastError().

C++
public: static void SetLastError(
    const char * fmt,
    ...
);
Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::SetLocalHost Method

fiDeviceTcpIp::SetLocalHost Method
fiDeviceTcpIp Class
Show All
C++
public: static void SetLocalHost(
    const char * hostname
);
Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::ShutdownClass Method

fiDeviceTcpIp::ShutdownClass Method
fiDeviceTcpIp Class
Show All
C++
public: static void ShutdownClass();
Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::StaticWrite Method

fiDeviceTcpIp::StaticWrite Method
fiDeviceTcpIp Class
Show All
C++
public: static int StaticWrite(
    fiHandle handle,
    const void * buffer,
    int bufferSize
);
Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::WaitForNetworkReady Method

fiDeviceTcpIp::WaitForNetworkReady Method
fiDeviceTcpIp Class
Show All
C++
public: static void WaitForNetworkReady();
Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceTcpIp::Write Method

fiDeviceTcpIp::Write Method
fiDeviceTcpIp Class
Show All

Write binary data to file

C++
public: virtual int Write(
    fiHandle handle,
    const void * buffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
buffer
Source buffer for data to write
bufferSize
Maximum amount of data to read

Returns

Non-negative integer on success representing number of bytes of data written (zero typically means media full). Negative integer indicates an error.

Notes

No translation of any kind is done on the data.

Class

fiDeviceTcpIp Class

File

tcpip.h

Links
fiDeviceTcpIp Class


fiDeviceXContent Class

fiDeviceXContent Class
Structs | Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::fiDevice
    rage::fiDeviceLocal
        fiDeviceXContent
C++
public: class fiDeviceXContent : public fiDeviceLocal;
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
fiDeviceXContent |
Destructors
Destructor | Description
~fiDevice |
~fiDeviceXContent |
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixName | Normalize a name for the underlying local device (insert host0:, change forward slashes to backslashes, etc)
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
Init |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
MountAs |
Normalize | Normalize a filename in-place
OnDiscSwap |
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Shutdown |
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options
Namespace

rage Namespace

File

device_xcontent.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


fiDeviceXContent::fiDeviceXContent Constructor

fiDeviceXContent::fiDeviceXContent Constructor
fiDeviceXContent Class
Show All
C++
public: fiDeviceXContent();
Class

fiDeviceXContent Class

File

device_xcontent.h

Links
fiDeviceXContent Class


fiDeviceXContent::~fiDeviceXContent Destructor

fiDeviceXContent::~fiDeviceXContent Destructor
fiDeviceXContent Class
Show All
C++
public: ~fiDeviceXContent();
Class

fiDeviceXContent Class

File

device_xcontent.h

Links
fiDeviceXContent Class


fiDeviceXContent::Init Method

fiDeviceXContent::Init Method
fiDeviceXContent Class
Show All
C++
public: bool Init(
    s32 userIndex,
    _XCONTENT_DATA* pData
);
Class

fiDeviceXContent Class

File

device_xcontent.h

Links
fiDeviceXContent Class


fiDeviceXContent::MountAs Method

fiDeviceXContent::MountAs Method
fiDeviceXContent Class
Show All
C++
public: bool MountAs(
    const char* pName
);
Class

fiDeviceXContent Class

File

device_xcontent.h

Links
fiDeviceXContent Class


fiDeviceXContent::Shutdown Method

fiDeviceXContent::Shutdown Method
fiDeviceXContent Class
Show All
C++
public: void Shutdown();
Class

fiDeviceXContent Class

File

device_xcontent.h

Links
fiDeviceXContent Class


fiDiskCache Class

fiDiskCache Class
Members | Methods | Friends | rage Namespace | Inheritance Hierarchy
Show All
fiDiskCache
C++
public: class fiDiskCache;
Methods
Method | Description
GetCachedDevice | Obtain a cached device.
GetCacheInProgress | Returns a normalized float indicating the percent of the cache that is pending. Once the cache fills up, Occupancy plus progress will add up to 1.0; the progress percentage is capped to prevent too much cache churn.
GetCacheOccupancy | Returns a normalized float between 0.0 (no valid blocks) and 1.0 (all blocks in cache are valid). It's up to higher level code to know how to interpret this value. It's guaranteed to be zero if the cache is disabled or unavailable, and will always return 1.0 on 360 "Play From Hard Drive"
GetHoldoffTime |
GetLastCacheCopyCompletion | Returns a timestamp of the last cache copy completion, or zero if we haven't done one yet.
InitClass | Initialize the disk cache.
IsCacheCopying | Returns true if a cache copy is currently in progress.
IsCacheEnabled | Determine if the cache is enabled.
IsCachePrimed | Returns true if we either installed to hdd, or the cache was already present. It will return false if no cache is available, or it was regenerated.
LeaveBootMode | Higher-level code should call this when we're no longer reading load-ordered data. Cache misses incurred in boot mode have a higher priority than all other cache misses and will tend to be copied sooner.
SetHoldoffTime | Set the holdoff time.
ShutdownClass | Shuts the disk cache back down again.
Friends
Friend | Description
class fiCachedDevice |
Namespace

rage Namespace

File

diskcache.h

Links
Members, Methods, Friends, rage Namespace, Inheritance Hierarchy


fiDiskCache::GetCachedDevice Method

fiDiskCache::GetCachedDevice Method
fiDiskCache Class
Show All

Obtain a cached device.

C++
public: static const fiCachedDevice* GetCachedDevice(
    const char * fullPathName,
    const fiPackfile * pf
);
Parameters

fullPathName
Path to the inner device to be cached.
pf
Pointer to the packfile we will be managing (partially constructed at this time)

Returns

New cached device, or NULL if the cache was disabled or the original file wasn't accessible.

Notes

On a cached device, most operations are dummies or invalid. OpenBulk returns a valid handle that is otherwise ignored by all other functions. ReadBulk performs the actual cache maintenance.

Class

fiDiskCache Class

File

diskcache.h

Links
fiDiskCache Class


fiDiskCache::GetCacheInProgress Method

fiDiskCache::GetCacheInProgress Method
fiDiskCache Class
Show All

Returns a normalized float indicating the percent of the cache that is pending. Once the cache fills up, Occupancy plus progress will add up to 1.0; the progress percentage is capped to prevent too much cache churn.

C++
public: static float GetCacheInProgress();
Class

fiDiskCache Class

File

diskcache.h

Links
fiDiskCache Class


fiDiskCache::GetCacheOccupancy Method

fiDiskCache::GetCacheOccupancy Method
fiDiskCache Class
Show All

Returns a normalized float between 0.0 (no valid blocks) and 1.0 (all blocks in cache are valid). It's up to higher level code to know how to interpret this value. It's guaranteed to be zero if the cache is disabled or unavailable, and will always return 1.0 on 360 "Play From Hard Drive"

C++
public: static float GetCacheOccupancy();
Class

fiDiskCache Class

File

diskcache.h

Links
fiDiskCache Class


fiDiskCache::GetHoldoffTime Method

fiDiskCache::GetHoldoffTime Method
fiDiskCache Class
Show All
C++
public: static int GetHoldoffTime();
Returns

Current holdoff time, how many milliseconds optical drive goes idle before we attempt to background copy.

Class

fiDiskCache Class

File

diskcache.h

Links
fiDiskCache Class


fiDiskCache::GetLastCacheCopyCompletion Method

fiDiskCache::GetLastCacheCopyCompletion Method
fiDiskCache Class
Show All

Returns a timestamp of the last cache copy completion, or zero if we haven't done one yet.

C++
public: static unsigned GetLastCacheCopyCompletion();
Class

fiDiskCache Class

File

diskcache.h

Links
fiDiskCache Class


fiDiskCache::InitClass Method

fiDiskCache::InitClass Method
fiDiskCache Class
Show All

Initialize the disk cache.

C++
public: static bool InitClass(
    int XENON_ONLY(cpu),
    const char *PS3_ONLY(gameTitle)
);
Parameters

cpu
which cpu to run the disk cache on (360 only)
gameTitle
Human-readable game title (can be NULL for syscache)

Returns

True on success, false on some failure (with diagnostic sent to tty)

Notes

If the disk cache is never initialized, or this function returns false, then GetCachedDevice will just fall through to fiDevice::GetDevice. If gameTitle is NULL, we'll use syscache instead of gamedata for caching. gamedata is about 33% faster than syscache.

Class

fiDiskCache Class

File

diskcache.h

Links
fiDiskCache Class


fiDiskCache::IsCacheCopying Method

fiDiskCache::IsCacheCopying Method
fiDiskCache Class
Show All

Returns true if a cache copy is currently in progress.

C++
public: static bool IsCacheCopying();
Class

fiDiskCache Class

File

diskcache.h

Links
fiDiskCache Class


fiDiskCache::IsCacheEnabled Method

fiDiskCache::IsCacheEnabled Method
fiDiskCache Class
Show All

Determine if the cache is enabled.

C++
public: static bool IsCacheEnabled();
Class

fiDiskCache Class

File

diskcache.h

Links
fiDiskCache Class


fiDiskCache::IsCachePrimed Method

fiDiskCache::IsCachePrimed Method
fiDiskCache Class
Show All

Returns true if we either installed to hdd, or the cache was already present. It will return false if no cache is available, or it was regenerated.

C++
public: static bool IsCachePrimed();
Class

fiDiskCache Class

File

diskcache.h

Links
fiDiskCache Class


fiDiskCache::LeaveBootMode Method

fiDiskCache::LeaveBootMode Method
fiDiskCache Class
Show All

Higher-level code should call this when we're no longer reading load-ordered data. Cache misses incurred in boot mode have a higher priority than all other cache misses and will tend to be copied sooner.

C++
public: static void LeaveBootMode();
Class

fiDiskCache Class

File

diskcache.h

Links
fiDiskCache Class


fiDiskCache::SetHoldoffTime Method

fiDiskCache::SetHoldoffTime Method
fiDiskCache Class
Show All

Set the holdoff time.

C++
public: static void SetHoldoffTime(
    int ms
);
Parameters

ms
New holdoff time, in milliseconds. Default is 1000.

Class

fiDiskCache Class

File

diskcache.h

Links
fiDiskCache Class


fiDiskCache::ShutdownClass Method

fiDiskCache::ShutdownClass Method
fiDiskCache Class
Show All

Shuts the disk cache back down again.

C++
public: static void ShutdownClass();
Class

fiDiskCache Class

File

diskcache.h

Links
fiDiskCache Class


friend class fiCachedDevice Friend

friend class fiCachedDevice Friend
fiDiskCache Class
Show All
C++
public: friend class fiCachedDevice;
Class

fiDiskCache Class

File

diskcache.h

Links
fiDiskCache Class


fiEmbeddedFile Class

fiEmbeddedFile Class
Constructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All

These auto-register themselves but you still need to make sure they piggyback onto a .cpp file that is being used so that they don't get ignored by the linker.

fiEmbeddedFile
C++
public: class fiEmbeddedFile;
Constructors
Constructor | Description
fiEmbeddedFile |
Methods
Method | Description
Lookup |
Namespace

rage Namespace

File

embedded.h

Links
Constructors, Members, Methods, rage Namespace, Inheritance Hierarchy


fiEmbeddedFile::fiEmbeddedFile Constructor

fiEmbeddedFile::fiEmbeddedFile Constructor
fiEmbeddedFile Class
Show All
C++
public: fiEmbeddedFile(
    const char*,
    const unsigned char*,
    int
);
Class

fiEmbeddedFile Class

File

embedded.h

Links
fiEmbeddedFile Class


fiEmbeddedFile::Lookup Method

fiEmbeddedFile::Lookup Method
fiEmbeddedFile Class
Show All
C++
public: static bool Lookup(
    const char * name,
    const unsigned char *& data,
    int & dataSize
);
Class

fiEmbeddedFile Class

File

embedded.h

Links
fiEmbeddedFile Class


fiMultiTokenizer Class

fiMultiTokenizer Class
Constructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All

fiMultiTokenizer allows

fiMultiTokenizer
C++
public: class fiMultiTokenizer;
Constructors
Constructor | Description
fiMultiTokenizer |
Methods
Method | Description
GetReadTokenizer |
GetWriteTokenizer |
Namespace

rage Namespace

File

token.h

Links
Constructors, Members, Methods, rage Namespace, Inheritance Hierarchy


fiMultiTokenizer::fiMultiTokenizer Constructor

fiMultiTokenizer::fiMultiTokenizer Constructor
fiMultiTokenizer Class
Show All
C++
public: fiMultiTokenizer();
Class

fiMultiTokenizer Class

File

token.h

Links
fiMultiTokenizer Class


fiMultiTokenizer::GetReadTokenizer Method

fiMultiTokenizer::GetReadTokenizer Method
fiMultiTokenizer Class
Show All
C++
public: fiBaseTokenizer& GetReadTokenizer(
    const char* name,
    fiStream* s,
    const char* asciiString,
    const char* binString
);
Class

fiMultiTokenizer Class

File

token.h

Links
fiMultiTokenizer Class


fiMultiTokenizer::GetWriteTokenizer Method

fiMultiTokenizer::GetWriteTokenizer Method
fiMultiTokenizer Class
Show All
C++
public: fiBaseTokenizer& GetWriteTokenizer(
    const char* name,
    fiStream* s,
    bool bin,
    const char* versString
);
Class

fiMultiTokenizer Class

File

token.h

Links
fiMultiTokenizer Class


fiPackEntry Struct

fiPackEntry Struct
Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All

Big-endian

fiPackEntry
C++
public: struct fiPackEntry {
  public: static const u64 FileOffset_IsDir = (1<<23)-1;
  public: static const int FileOffset_Shift = 9;
  public: static const u32 MaxConsumedSize = 0xFFFFFF;
  public: union {
    public: struct file@1 file;
public:
    private: struct {
      public: u32 m_UncompressedSize;
      public: u32 m_Encrypted;
    }
    public: struct directory@1 directory;
public:
    private: struct {
      public: u32 m_DirectoryIndex;
      public: u32 m_DirectoryCount;
    }
    public: struct resource@1 resource;
public:
    private: struct {
      public: datResourceInfo m_Info;
    }
  } u;
};
Methods
Method | Description
DECLARE_BITFIELD_4 | nonzero if file is a resource
GetConsumedSize |
GetFileOffset |
GetUncompressedSize |
GetVersion |
IsCompressed |
IsDir |
IsFile |
IsResource |
SetFileOffset |
Data Members
Data Member | Description
FileOffset_IsDir |
FileOffset_Shift |
MaxConsumedSize |
u |
Namespace

rage Namespace

File

packfile.h

Links
Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


fiPackEntry::FileOffset_IsDir Data Member

fiPackEntry::FileOffset_IsDir Data Member
fiPackEntry Struct
Show All
C++
public: static const u64 FileOffset_IsDir = (1<<23)-1;
Struct

fiPackEntry Struct

File

packfile.h

Links
fiPackEntry Struct


fiPackEntry::FileOffset_Shift Data Member

fiPackEntry::FileOffset_Shift Data Member
fiPackEntry Struct
Show All
C++
public: static const int FileOffset_Shift = 9;
Struct

fiPackEntry Struct

File

packfile.h

Links
fiPackEntry Struct


fiPackEntry::MaxConsumedSize Data Member

fiPackEntry::MaxConsumedSize Data Member
fiPackEntry Struct
Show All
C++
public: static const u32 MaxConsumedSize = 0xFFFFFF;
Struct

fiPackEntry Struct

File

packfile.h

Links
fiPackEntry Struct


fiPackEntry::u Data Member

fiPackEntry::u Data Member
fiPackEntry Struct
Show All
C++
public: public: union {
  public: struct file@1 file;
public:
  private: struct {
    public: u32 m_UncompressedSize;
    public: u32 m_Encrypted;
  }
  public: struct directory@1 directory;
public:
  private: struct {
    public: u32 m_DirectoryIndex;
    public: u32 m_DirectoryCount;
  }
  public: struct resource@1 resource;
public:
  private: struct {
    public: datResourceInfo m_Info;
  }
} u;
Struct

fiPackEntry Struct

File

packfile.h

Links
fiPackEntry Struct


fiPackEntry::DECLARE_BITFIELD_4 Method

fiPackEntry::DECLARE_BITFIELD_4 Method
fiPackEntry Struct
Show All

nonzero if file is a resource

C++
public: u64 DECLARE_BITFIELD_4(
    m_NameOffset,
    16,
    m_ConsumedSize,
    24,
    m_FileOffset,
    23,
    m_IsResource,
    1
);
Struct

fiPackEntry Struct

File

packfile.h

Links
fiPackEntry Struct


fiPackEntry::GetConsumedSize Method

fiPackEntry::GetConsumedSize Method
fiPackEntry Struct
Show All
C++
public: u32 GetConsumedSize() const;
Struct

fiPackEntry Struct

File

packfile.h

Links
fiPackEntry Struct


fiPackEntry::GetFileOffset Method

fiPackEntry::GetFileOffset Method
fiPackEntry Struct
Show All
C++
public: u32 GetFileOffset() const;
Struct

fiPackEntry Struct

File

packfile.h

Links
fiPackEntry Struct


fiPackEntry::GetUncompressedSize Method

fiPackEntry::GetUncompressedSize Method
fiPackEntry Struct
Show All
C++
public: u32 GetUncompressedSize() const;
Struct

fiPackEntry Struct

File

packfile.h

Links
fiPackEntry Struct


fiPackEntry::GetVersion Method

fiPackEntry::GetVersion Method
fiPackEntry Struct
Show All
C++
public: int GetVersion() const;
Struct

fiPackEntry Struct

File

packfile.h

Links
fiPackEntry Struct


fiPackEntry::IsCompressed Method

fiPackEntry::IsCompressed Method
fiPackEntry Struct
Show All
C++
public: bool IsCompressed() const;
Struct

fiPackEntry Struct

File

packfile.h

Links
fiPackEntry Struct


fiPackEntry::IsDir Method

fiPackEntry::IsDir Method
fiPackEntry Struct
Show All
C++
public: bool IsDir() const;
Struct

fiPackEntry Struct

File

packfile.h

Links
fiPackEntry Struct


fiPackEntry::IsFile Method

fiPackEntry::IsFile Method
fiPackEntry Struct
Show All
C++
public: bool IsFile() const;
Struct

fiPackEntry Struct

File

packfile.h

Links
fiPackEntry Struct


fiPackEntry::IsResource Method

fiPackEntry::IsResource Method
fiPackEntry Struct
Show All
C++
public: bool IsResource() const;
Struct

fiPackEntry Struct

File

packfile.h

Links
fiPackEntry Struct


fiPackEntry::SetFileOffset Method

fiPackEntry::SetFileOffset Method
fiPackEntry Struct
Show All
C++
public: void SetFileOffset(
    u32 offset
);
Struct

fiPackEntry Struct

File

packfile.h

Links
fiPackEntry Struct


fiPackfile Class

fiPackfile Class COMPONENT
Structs | Nested Types | Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All

The fiPackfile device implements read-only zipfile access with compression support. Higher-level code is expected to call fiDevice::Mount with a new instance of fiPackfile that has succeeded in its Init call. The zipfile will remember the device and handle of its original filename without consuming an fiStream permanently; in theory it is possible to even nest zipfiles within zipfiles -- which can be useful if you're trying to save memory, because the entire zipfile directory structure is kept resident in memory at all times.

The file format is custom, and is created by the zip2rpf tool.

Internally each element of a pathname is stored separately (like a real filesystem would) so deep directory structures are not any more expensive, particularly if they result in shorter element names. For example, prop_sandiego_lamppost_01 would be stored more efficiently as prop/sandiego/lamppost_01 if there were many other props in sandiego.

rage::fiDevice
    rage::fiCollection
        fiPackfile
C++
public: class fiPackfile : public fiCollection;
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Nested Types
Nested Type | Description
ParentIndexType |
Constructors
Constructor | Description
fiCollection |
fiDevice |
fiPackfile |
Destructors
Destructor | Description
~fiDevice |
~fiPackfile |
Methods
Method | Description
ClearRelativeOffset |
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk |
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create |
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
ExtractFileToMemory |
FillData |
FillParentIndices |
FindEntry |
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBasePhysicalSortKey |
GetBasePhysicalSortKey |
GetBulkOffset |
GetBulkOffset |
GetCollection |
GetCollectionIndex |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetEntries |
GetEntryCount |
GetEntryFullName | Slower
GetEntryFullName | Slower
GetEntryIndex |
GetEntryIndex |
GetEntryInfo |
GetEntryInfo |
GetEntryName |
GetEntryName |
GetEntryPhysicalSortKey |
GetEntryPhysicalSortKey |
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetHeaderSize |
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetNameHeap |
GetNameShift |
GetPackfileHandle |
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPackfileSize |
GetPackfileTime |
GetPhysicalSortKey |
GetPhysicalSortKey |
GetRelativeOffset |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
Init |
InitClass |
InitFromImg | not in final builds.
InitFromZip |
IsCloud |
IsInitialized | Returns true if this packfile is initialized, false if UnInit() had been called on it.
IsOutOfDate | Convenience function which compares to files.
IsPackfile |
IsPackfile |
IsRpf |
IsRpf |
IsStreaming |
IsUserHeader |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeHandle |
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
MountAs |
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
OpenBulkFromHandle |
OpenBulkFromHandle |
OpenDirect |
OpenInternal |
Prefetch |
Prefetch |
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
ReadInternal |
ReadInternalBulk |
ReInit | Re-initialize a packfile after it has been UnInited().
Remount | Re-establish a mount point in the global file namespace for an existing device.
RemountDependentPackfiles | Call this function after having called Shutdown() and Init() on this packfile - it will look for all other packfiles depending on it and update their file handles.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetDrmKey |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime |
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
SetpackfileHandle |
SetPackfileTime |
SetReadAheadCacheCPU |
SetRelativePath |
SetStreaming |
Shutdown |
Shutdown |
Size | Determine size of file
Size | Determine size of file
Size64 | Determine size of file
Size64 | Determine size of file
UnInit | Free up the memory of the pack file header data, but don't close the handle.
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write |
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
ArchiveMask |
ArchiveShift |
EntryMask |
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
m_ArchiveBias | for nested zipfiles (sigh)
m_ArchiveSize |
m_CachedDataSize | Cached size for the header (including both the initial header as well as all entries).
m_CachedMetaDataSize | Cached meta data size, only valid after having called Init/ReInit() at least once.
m_Device | device the zipfile itself lives on
m_Entries | master entry table; entry 0 is the root directory
m_EntryCount |
m_FileTime | file time of the zipfile itself
m_Fullname |
m_Handle | (bulk) handle on the device of the zipfile itself
m_IsByteSwapped |
m_IsCached |
m_IsInstalled |
m_IsRpf |
m_isStreaming |
m_IsUserHeader | If true, the user provided the memory for the header data and is responsible for its clean-up.
m_IsXCompressed |
m_KeyId | Encryption key ID
m_MemoryBuffer | buffer to put packfile into if caching in memory
m_Name | debug name
m_NameHeap | nameheap for all filenames in the zipfile.
m_NameHeapInDebugHeap | If true, the name heap is in the debug heap. In this case, In this case, the name heap remains resident until Shutdown() is called. However, ReInit() with keepNameHeap set to true will reload the name heap. !__FINAL
m_NameShift |
m_ParentIndices |
m_pDrmKey | Drmkey used to decode drm content (ps3 only?)
m_RelativeOffset | amount of incoming pathname to strip off
m_SelfIndex |
m_SortKey | sort key used to define position on a DVD
sm_Collections | Entry 0 is never used. (except by the pgRawStreamer)
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Enumerations
Enumeration | Description
CacheMode |
eFindFileOptions | Find File in a directory by name and other options
Namespace

rage Namespace

File

packfile.h

Links
Structs, Nested Types, Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


fiPackfile::m_ArchiveBias Data Member

fiPackfile::m_ArchiveBias Data Member
fiPackfile Class
Show All

for nested zipfiles (sigh)

C++
protected: u64 m_ArchiveBias;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_ArchiveSize Data Member

fiPackfile::m_ArchiveSize Data Member
fiPackfile Class
Show All
C++
protected: u64 m_ArchiveSize;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_CachedDataSize Data Member

fiPackfile::m_CachedDataSize Data Member
fiPackfile Class
Show All

Cached size for the header (including both the initial header as well as all entries).

C++
protected: u32 m_CachedDataSize;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_CachedMetaDataSize Data Member

fiPackfile::m_CachedMetaDataSize Data Member
fiPackfile Class
Show All

Cached meta data size, only valid after having called Init/ReInit() at least once.

C++
protected: u32 m_CachedMetaDataSize;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_Device Data Member

fiPackfile::m_Device Data Member
fiPackfile Class
Show All

device the zipfile itself lives on

C++
protected: const fiDevice * m_Device;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_Entries Data Member

fiPackfile::m_Entries Data Member
fiPackfile Class
Show All

master entry table; entry 0 is the root directory

C++
protected: fiPackEntry * m_Entries;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_EntryCount Data Member

fiPackfile::m_EntryCount Data Member
fiPackfile Class
Show All
C++
protected: u32 m_EntryCount;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_FileTime Data Member

fiPackfile::m_FileTime Data Member
fiPackfile Class
Show All

file time of the zipfile itself

C++
protected: u64 m_FileTime;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_Fullname Data Member

fiPackfile::m_Fullname Data Member
fiPackfile Class
Show All
C++
protected: atString m_Fullname;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_Handle Data Member

fiPackfile::m_Handle Data Member
fiPackfile Class
Show All

(bulk) handle on the device of the zipfile itself

C++
protected: fiHandle m_Handle;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_IsByteSwapped Data Member

fiPackfile::m_IsByteSwapped Data Member
fiPackfile Class
Show All
C++
protected: bool m_IsByteSwapped;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_IsCached Data Member

fiPackfile::m_IsCached Data Member
fiPackfile Class
Show All
C++
protected: bool m_IsCached;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_IsInstalled Data Member

fiPackfile::m_IsInstalled Data Member
fiPackfile Class
Show All
C++
protected: bool m_IsInstalled;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_IsRpf Data Member

fiPackfile::m_IsRpf Data Member
fiPackfile Class
Show All
C++
protected: bool m_IsRpf;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_IsUserHeader Data Member

fiPackfile::m_IsUserHeader Data Member
fiPackfile Class
Show All

If true, the user provided the memory for the header data and is responsible for its clean-up.

C++
protected: bool m_IsUserHeader;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_IsXCompressed Data Member

fiPackfile::m_IsXCompressed Data Member
fiPackfile Class
Show All
C++
protected: bool m_IsXCompressed;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_KeyId Data Member

fiPackfile::m_KeyId Data Member
fiPackfile Class
Show All

Encryption key ID

C++
protected: u32 m_KeyId;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_MemoryBuffer Data Member

fiPackfile::m_MemoryBuffer Data Member
fiPackfile Class
Show All

buffer to put packfile into if caching in memory

C++
protected: char * m_MemoryBuffer;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_Name Data Member

fiPackfile::m_Name Data Member
fiPackfile Class
Show All

debug name

C++
protected: char m_Name[32];
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_NameHeap Data Member

fiPackfile::m_NameHeap Data Member
fiPackfile Class
Show All

nameheap for all filenames in the zipfile.

C++
protected: char * m_NameHeap;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_NameHeapInDebugHeap Data Member

fiPackfile::m_NameHeapInDebugHeap Data Member
fiPackfile Class
Show All

If true, the name heap is in the debug heap. In this case, In this case, the name heap remains resident until Shutdown() is called. However, ReInit() with keepNameHeap set to true will reload the name heap. !__FINAL

C++
protected: bool m_NameHeapInDebugHeap;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_NameShift Data Member

fiPackfile::m_NameShift Data Member
fiPackfile Class
Show All
C++
protected: unsigned char m_NameShift;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_ParentIndices Data Member

fiPackfile::m_ParentIndices Data Member
fiPackfile Class
Show All
C++
protected: ParentIndexType * m_ParentIndices;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_pDrmKey Data Member

fiPackfile::m_pDrmKey Data Member
fiPackfile Class
Show All

Drmkey used to decode drm content (ps3 only?)

C++
protected: const void * m_pDrmKey;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_RelativeOffset Data Member

fiPackfile::m_RelativeOffset Data Member
fiPackfile Class
Show All

amount of incoming pathname to strip off

C++
protected: int m_RelativeOffset;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_SelfIndex Data Member

fiPackfile::m_SelfIndex Data Member
fiPackfile Class
Show All
C++
protected: u16 m_SelfIndex;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::m_SortKey Data Member

fiPackfile::m_SortKey Data Member
fiPackfile Class
Show All

sort key used to define position on a DVD

C++
protected: u32 m_SortKey;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::fiPackfile Constructor

fiPackfile::fiPackfile Constructor
fiPackfile Class
Show All
C++
public: fiPackfile();
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::~fiPackfile Destructor

fiPackfile::~fiPackfile Destructor
fiPackfile Class
Show All
C++
public: virtual ~fiPackfile();
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::ClearRelativeOffset Method

fiPackfile::ClearRelativeOffset Method
fiPackfile Class
Show All
C++
public: void ClearRelativeOffset();
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::Close Method

fiPackfile::Close Method
fiPackfile Class
Show All

Close a file

C++
public: virtual int Close(
    fiHandle handle
) const;
Parameters

handle
Handle of file to close (must have been opened or created with the same device).

Returns

zero if the call succeeded, non-zero if it failed

Notes

You must eventually Close any handle successfully returned by an Open or Create call or else you will have a resource leak.

Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::CloseBulk Method

fiPackfile::CloseBulk Method
fiPackfile Class
Show All
C++
public: virtual int CloseBulk(
    fiHandle handle
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::Create Method

fiPackfile::Create Method
fiPackfile Class
Show All
C++
public: virtual fiHandle Create(
    const char * filename
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::ExtractFileToMemory Method

fiPackfile::ExtractFileToMemory Method
fiPackfile Class
Show All
C++
public: u8* ExtractFileToMemory(
    u32 handle,
    u32 & outSize
) const;
Returns

Returns NULL on error. Otherwise free the buffer with delete[] when done. Function only available on certain PC tool configurations, not for game-side use!

Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::FillData Method

fiPackfile::FillData Method
fiPackfile Class
Show All
C++
protected: void FillData(
    fiFindData & outData,
    u32 entryIndex
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::FillParentIndices Method

fiPackfile::FillParentIndices Method
fiPackfile Class
Show All
C++
protected: void FillParentIndices(
    int dirIdx
);
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::FindEntry Method

fiPackfile::FindEntry Method
fiPackfile Class
Show All
C++
public: virtual const fiPackEntry* FindEntry(
    const char * name
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::FindFileBegin Method

fiPackfile::FindFileBegin Method
fiPackfile Class
Show All

Iterate over all files in a directory

C++
public: virtual fiHandle FindFileBegin(
    const char * directoryName,
    fiFindData & outData
) const;
Parameters

directoryName
Name of the directory to search (no wildcard necessary or supported; do filtering yourself in higher-level code).
outData
Info for first matching file (if return value was not -1)

Returns

A "find handle" that is used to identify this search so that more that one can be in progress at a time, or -1 if we were unable to find any matches. Must eventually call FindFileEnd on this handle if it did not return -1.

Notes

Some platforms will return "." and ".." and some will not, so make sure you handle them properly.

Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::FindFileEnd Method

fiPackfile::FindFileEnd Method
fiPackfile Class
Show All

Close a search begun with FindFileBegin

C++
public: virtual int FindFileEnd(
    fiHandle handle
) const;
Parameters

handle
Find handle to close

Returns

Zero if the call succeeded, non-zero otherwise.

Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::FindFileNext Method

fiPackfile::FindFileNext Method
fiPackfile Class
Show All

Continue a search begun with FindFileBegin

C++
public: virtual bool FindFileNext(
    fiHandle handle,
    fiFindData & outData
) const;
Parameters

handle
Find handle returned by FindFileBegin
outData
Info for next match file (if return value was not false)

Returns

True on success (outData is valid), or false if there were no more matches

Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetAttributes Method

fiPackfile::GetAttributes Method
fiPackfile Class
Show All

Retrieves file attributes

C++
public: virtual u32 GetAttributes(
    const char * filename
) const;
Parameters

filename
name of file to retrieve attributes

Returns

File attributes (see FILE_ATTRIBUTE_...) or FILE_ATTRIBUTE_INVALID (~0U) if file doesn't exist.

Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetBasePhysicalSortKey Method

fiPackfile::GetBasePhysicalSortKey Method
fiPackfile Class
Show All
C++
public: virtual u32 GetBasePhysicalSortKey() const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetBulkOffset Method

fiPackfile::GetBulkOffset Method
fiPackfile Class
Show All
C++
public: virtual u64 GetBulkOffset(
    const char * name
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetDebugName Method

fiPackfile::GetDebugName Method
fiPackfile Class
Show All
C++
public: virtual const char * GetDebugName() const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetEntries Method

fiPackfile::GetEntries Method
fiPackfile Class
Show All
C++
public: const fiPackEntry* GetEntries() const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetEntryCount Method

fiPackfile::GetEntryCount Method
fiPackfile Class
Show All
C++
public: u32 GetEntryCount() const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetEntryFullName Method

fiPackfile::GetEntryFullName Method
fiPackfile Class
Show All

Slower

C++
public: virtual const char * GetEntryFullName(
    u32 handle,
    char * dest,
    int destSize
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetEntryIndex Method

fiPackfile::GetEntryIndex Method
fiPackfile Class
Show All
C++
public: virtual int GetEntryIndex(
    const char * name
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetEntryInfo Method

fiPackfile::GetEntryInfo Method
fiPackfile Class
Show All
C++
public: virtual const fiPackEntry& GetEntryInfo(
    u32 handle
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetEntryName Method

fiPackfile::GetEntryName Method
fiPackfile Class
Show All
C++
public: virtual const char * GetEntryName(
    u32 handle
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetEntryPhysicalSortKey Method

fiPackfile::GetEntryPhysicalSortKey Method
fiPackfile Class
Show All
C++
public: virtual u32 GetEntryPhysicalSortKey(
    u32 handle,
    bool
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetFileSize Method

fiPackfile::GetFileSize Method
fiPackfile Class
Show All

Determine size of file

C++
public: virtual u64 GetFileSize(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Size of the file

Notes

Base class implements this as three calls to Seek, subclasses that may know the size of the file ahead of time are encouraged to improve upon this.

Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetFileTime Method

fiPackfile::GetFileTime Method
fiPackfile Class
Show All

Return time-of-date information for a file

C++
public: virtual u64 GetFileTime(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Large integer (in unspecified units) which represents the file time. Will return 0 if a file did not exist. If a filetime fa is larger than another filetime fb then fa is newer than fb.

Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetHeaderSize Method

fiPackfile::GetHeaderSize Method
fiPackfile Class
Show All
C++
public: u32 GetHeaderSize(
    bool withMetaData
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetNameHeap Method

fiPackfile::GetNameHeap Method
fiPackfile Class
Show All
C++
public: const char* GetNameHeap() const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetNameShift Method

fiPackfile::GetNameShift Method
fiPackfile Class
Show All
C++
public: int GetNameShift() const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetPackfileHandle Method

fiPackfile::GetPackfileHandle Method
fiPackfile Class
Show All
C++
public: fiHandle GetPackfileHandle() const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetPackfileIndex Method

fiPackfile::GetPackfileIndex Method
fiPackfile Class
Show All

Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.

C++
public: virtual u32 GetPackfileIndex() const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetPackfileSize Method

fiPackfile::GetPackfileSize Method
fiPackfile Class
Show All
C++
public: u64 GetPackfileSize() const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetPackfileTime Method

fiPackfile::GetPackfileTime Method
fiPackfile Class
Show All
C++
public: u64 GetPackfileTime() const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetPhysicalSortKey Method

fiPackfile::GetPhysicalSortKey Method
fiPackfile Class
Show All
C++
public: virtual u32 GetPhysicalSortKey(
    const char* pName
) const;
Returns

Returns a sort key for file on device. For DVD this would be sector address. If it's HARDDRIVE_LSN, we don't know anything about it, or it's on a hard drive.

Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetRelativeOffset Method

fiPackfile::GetRelativeOffset Method
fiPackfile Class
Show All
C++
public: int GetRelativeOffset() const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::GetResourceInfo Method

fiPackfile::GetResourceInfo Method
fiPackfile Class
Show All

Retrieve resource information for a file. It only works files that have a standard resource header.

C++
public: virtual int GetResourceInfo(
    const char * name,
    datResourceInfo & outHeader
) const;
Parameters

name
Name of file to query
outHeader
If return value is nonzero, contains header information

Returns

Nonzero if file exists and has a standard resource header, else zero. A return of -1 means it's a valid resource but the version number is unavailable.

Notes

For raw files, it reads the header (which would cause tons of seeking on final media). For archived files, it (will eventually) use the metadata present in the directory structure.

Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::Init Method

fiPackfile::Init Method
fiPackfile Class
Show All
C++
public: bool Init(
    const char * filename,
    bool keepNameTable,
    CacheMode cacheMode,
    char * packfileData = NULL
);
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::InitFromImg Method

fiPackfile::InitFromImg Method
fiPackfile Class
Show All

not in final builds.

C++
protected: bool InitFromImg(
    const char * filename
);
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::InitFromZip Method

fiPackfile::InitFromZip Method
fiPackfile Class
Show All
C++
protected: bool InitFromZip(
    const char * filename,
    bool keepNameHeap
);
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::IsInitialized Method

fiPackfile::IsInitialized Method
fiPackfile Class
Show All

Returns true if this packfile is initialized, false if UnInit() had been called on it.

C++
public: bool IsInitialized() const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::IsPackfile Method

fiPackfile::IsPackfile Method
fiPackfile Class
Show All
C++
public: virtual bool IsPackfile() const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::IsRpf Method

fiPackfile::IsRpf Method
fiPackfile Class
Show All
C++
public: virtual bool IsRpf() const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::IsUserHeader Method

fiPackfile::IsUserHeader Method
fiPackfile Class
Show All
C++
public: bool IsUserHeader();
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::MountAs Method

fiPackfile::MountAs Method
fiPackfile Class
Show All
C++
public: bool MountAs(
    const char * filename
);
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::Open Method

fiPackfile::Open Method
fiPackfile Class
Show All

Attempt to open a file on this device

C++
public: virtual fiHandle Open(
    const char * filename,
    bool readOnly
) const;
Parameters

filename
Name of file to open (including device id)
readOnly
True if file will be read-only, else false.

Returns

Non-negative handle value on success, negative value on error.

Notes

If a file is read-only, we attempt to open in a sharing-friendly manner. If this function returns a value file handle, you must eventually call Close on this device with that handle or else you would suffer a resource leak.

Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::OpenBulk Method

fiPackfile::OpenBulk Method
fiPackfile Class
Show All

Attempt to open a file on this device for bulk read

C++
public: virtual fiHandle OpenBulk(
    const char * filename,
    u64 & outBias
) const;
Parameters

filename
Name of file to open (including device id)
outBias
Reference to a u64 containing a bias you should add to any ReadBulk call using this handle. Allows archives to avoid having to maintain any internal state when using uncompressed files.

Returns

Non-negative handle value on success, negative value on error.

Notes

The handle returned by this function can only be used with ReadBulk and CloseBulk.

Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::OpenBulkFromHandle Method

fiPackfile::OpenBulkFromHandle Method
fiPackfile Class
Show All
C++
public: virtual fiHandle OpenBulkFromHandle(
    u32 handle,
    u64 & offset
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::OpenDirect Method

fiPackfile::OpenDirect Method
fiPackfile Class
Show All
C++
public: virtual fiHandle OpenDirect(
    const char * filename,
    bool readOnly
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::OpenInternal Method

fiPackfile::OpenInternal Method
fiPackfile Class
Show All
C++
protected: fiHandle OpenInternal(
    const char * lookupName,
    bool readOnly
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::Prefetch Method

fiPackfile::Prefetch Method
fiPackfile Class
Show All
C++
public: virtual bool Prefetch(
    u32
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::Read Method

fiPackfile::Read Method
fiPackfile Class
Show All

Read binary data from file

C++
public: virtual int Read(
    fiHandle handle,
    void * outBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
outBuffer
Destination to receive data that is read
bufferSize
Maximum amount of data to read

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data.

Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::ReadBulk Method

fiPackfile::ReadBulk Method
fiPackfile Class
Show All

Seek and read binary data from file

C++
public: virtual int ReadBulk(
    fiHandle handle,
    u64 offset,
    void * outBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
File offset, must be multiple of block size (2048 is safest) Note that you should add any bias returned by OpenBulk in here yourself.
outBuffer
Destination to receive data that is read (should be aligned to cache line for maximum speed)
bufferSize
Maximum amount of data to read, must be multiple of block size (again, 2048 is safest)

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data. The data is not cached.

Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::ReadInternal Method

fiPackfile::ReadInternal Method
fiPackfile Class
Show All
C++
protected: int ReadInternal(
    fiPackfileState& state,
    void * outBuffer,
    int bufferSize
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::ReadInternalBulk Method

fiPackfile::ReadInternalBulk Method
fiPackfile Class
Show All
C++
protected: int ReadInternalBulk(
    const fiPackfileState& state,
    u32 relativeOffset,
    void * outBuffer,
    int bufferSize
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::ReInit Method

fiPackfile::ReInit Method
fiPackfile Class
Show All

Re-initialize a packfile after it has been UnInited().

C++
public: bool ReInit(
    const char * filename,
    bool keepNameHeap,
    void * headerdata
);
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::RemountDependentPackfiles Method

fiPackfile::RemountDependentPackfiles Method
fiPackfile Class
Show All

Call this function after having called Shutdown() and Init() on this packfile - it will look for all other packfiles depending on it and update their file handles.

C++
public: void RemountDependentPackfiles(
    fiHandle oldHandle
);
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::Seek Method

fiPackfile::Seek Method
fiPackfile Class
Show All

Seek to a location in file

C++
public: virtual int Seek(
    fiHandle handle,
    int offset,
    fiSeekWhence whence
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

Lower 32 bits of new file position, or -1 on error

Notes

Not all devices can implement seek (pipes, etc)

Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::Seek64 Method

fiPackfile::Seek64 Method
fiPackfile Class
Show All

Seek to a location in file

C++
public: virtual u64 Seek64(
    fiHandle handle,
    s64 offset,
    fiSeekWhence whence
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

New file position, or 0xFFFF FFFF FFFF FFFF on error.

Notes

Not all devices can implement seek (pipes, etc)

Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::SetDrmKey Method

fiPackfile::SetDrmKey Method
fiPackfile Class
Show All
C++
public: void SetDrmKey(
    const void * pDrmKey
);
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::SetFileTime Method

fiPackfile::SetFileTime Method
fiPackfile Class
Show All
C++
public: virtual bool SetFileTime(
    const char * filename,
    u64 timestamp
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::SetpackfileHandle Method

fiPackfile::SetpackfileHandle Method
fiPackfile Class
Show All
C++
public: void SetpackfileHandle(
    fiHandle handle
);
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::SetPackfileTime Method

fiPackfile::SetPackfileTime Method
fiPackfile Class
Show All
C++
public: void SetPackfileTime(
    u64 newFileTime
);
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::SetReadAheadCacheCPU Method

fiPackfile::SetReadAheadCacheCPU Method
fiPackfile Class
Show All
C++
public: static void SetReadAheadCacheCPU(
    int cpu
);
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::SetRelativePath Method

fiPackfile::SetRelativePath Method
fiPackfile Class
Show All
C++
public: void SetRelativePath(
    const char * path
);
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::Shutdown Method

fiPackfile::Shutdown Method
fiPackfile Class
Show All
C++
public: virtual void Shutdown();
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::Size Method

fiPackfile::Size Method
fiPackfile Class
Show All

Determine size of file

C++
public: virtual int Size(
    fiHandle handle
) const;
Parameters

handle
Handle of file to determine size of (must have been opened or created with the same device)

Returns

Size of the file

Notes

Base class implements this as three calls to Seek, subclasses that may know the size of the file ahead of time are encouraged to improve upon this.

Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::Size64 Method

fiPackfile::Size64 Method
fiPackfile Class
Show All

Determine size of file

C++
public: virtual u64 Size64(
    fiHandle handle
) const;
Parameters

handle
Handle of file to determine size of (must have been opened or created with the same device)

Returns

Size of the file

Notes

Base class implements this as three calls to Seek, subclasses that may know the size of the file ahead of time are encouraged to improve upon this.

Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::UnInit Method

fiPackfile::UnInit Method
fiPackfile Class
Show All

Free up the memory of the pack file header data, but don't close the handle.

C++
public: void UnInit();
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::Write Method

fiPackfile::Write Method
fiPackfile Class
Show All
C++
public: virtual int Write(
    fiHandle handle,
    const void * buffer,
    int bufferSize
) const;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


rage::fiPackfile::CacheMode Enumeration

rage::fiPackfile::CacheMode Enumeration
fiPackfile Class
Show All
C++
private: enum CacheMode {
  public: CACHE_NONE,
  public: CACHE_HARDDRIVE,
  public: CACHE_MEMORY,
  public: CACHE_INSTALLER_FILE
};
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfile::ParentIndexType Nested Type

fiPackfile::ParentIndexType Nested Type
fiPackfile Class
Show All
C++
public: typedef u16 ParentIndexType;
Class

fiPackfile Class

File

packfile.h

Links
fiPackfile Class


fiPackfileState Struct

fiPackfileState Struct
Constructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
fiPackfileState
C++
public: struct fiPackfileState {
  public: static const u32 BufferSize = 8192;
  public: char * m_Buffer;
  public: char m_DebugName[32];
  public: const fiPackEntry * m_Entry;
  public: u32 m_Offset;
  public: u32 m_CompOffset;
  public: XMEMDECOMPRESSION_CONTEXT m_xStream;
  public: void * next_in;
  public: u32 avail_in;
  public: z_stream m_zStream;
};
Constructors
Constructor | Description
fiPackfileState |
Methods
Method | Description
IsCompressed |
Reset |
Data Members
Data Member | Description
avail_in |
BufferSize |
m_Buffer |
m_CompOffset | Current offset within the compressed file
m_DebugName |
m_Entry | Pointer to the file directory entry
m_Offset | Current offset within the (virtual, uncompressed) file
m_xStream |
m_zStream | Stream object used by Zlib
next_in |
Namespace

rage Namespace

File

packfile.cpp

Links
Constructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


fiPackfileState::avail_in Data Member

fiPackfileState::avail_in Data Member
fiPackfileState Struct
Show All
C++
public: u32 avail_in;
Struct

fiPackfileState Struct

File

packfile.cpp

Links
fiPackfileState Struct


fiPackfileState::BufferSize Data Member

fiPackfileState::BufferSize Data Member
fiPackfileState Struct
Show All
C++
public: static const u32 BufferSize = 8192;
Struct

fiPackfileState Struct

File

packfile.cpp

Links
fiPackfileState Struct


fiPackfileState::m_Buffer Data Member

fiPackfileState::m_Buffer Data Member
fiPackfileState Struct
Show All
C++
public: char * m_Buffer;
Struct

fiPackfileState Struct

File

packfile.cpp

Links
fiPackfileState Struct


fiPackfileState::m_CompOffset Data Member

fiPackfileState::m_CompOffset Data Member
fiPackfileState Struct
Show All

Current offset within the compressed file

C++
public: u32 m_CompOffset;
Struct

fiPackfileState Struct

File

packfile.cpp

Links
fiPackfileState Struct


fiPackfileState::m_DebugName Data Member

fiPackfileState::m_DebugName Data Member
fiPackfileState Struct
Show All
C++
public: char m_DebugName[32];
Struct

fiPackfileState Struct

File

packfile.cpp

Links
fiPackfileState Struct


fiPackfileState::m_Entry Data Member

fiPackfileState::m_Entry Data Member
fiPackfileState Struct
Show All

Pointer to the file directory entry

C++
public: const fiPackEntry * m_Entry;
Struct

fiPackfileState Struct

File

packfile.cpp

Links
fiPackfileState Struct


fiPackfileState::m_Offset Data Member

fiPackfileState::m_Offset Data Member
fiPackfileState Struct
Show All

Current offset within the (virtual, uncompressed) file

C++
public: u32 m_Offset;
Struct

fiPackfileState Struct

File

packfile.cpp

Links
fiPackfileState Struct


fiPackfileState::m_xStream Data Member

fiPackfileState::m_xStream Data Member
fiPackfileState Struct
Show All
C++
public: XMEMDECOMPRESSION_CONTEXT m_xStream;
Struct

fiPackfileState Struct

File

packfile.cpp

Links
fiPackfileState Struct


fiPackfileState::m_zStream Data Member

fiPackfileState::m_zStream Data Member
fiPackfileState Struct
Show All

Stream object used by Zlib

C++
public: z_stream m_zStream;
Struct

fiPackfileState Struct

File

packfile.cpp

Links
fiPackfileState Struct


fiPackfileState::next_in Data Member

fiPackfileState::next_in Data Member
fiPackfileState Struct
Show All
C++
public: void * next_in;
Struct

fiPackfileState Struct

File

packfile.cpp

Links
fiPackfileState Struct


fiPackfileState::fiPackfileState Constructor

fiPackfileState::fiPackfileState Constructor
fiPackfileState Struct
Show All
C++
public: fiPackfileState();
Struct

fiPackfileState Struct

File

packfile.cpp

Links
fiPackfileState Struct


fiPackfileState::IsCompressed Method

fiPackfileState::IsCompressed Method
fiPackfileState Struct
Show All
C++
public: bool IsCompressed() const;
Struct

fiPackfileState Struct

File

packfile.cpp

Links
fiPackfileState Struct


fiPackfileState::Reset Method

fiPackfileState::Reset Method
fiPackfileState Struct
Show All
C++
public: void Reset();
Struct

fiPackfileState Struct

File

packfile.cpp

Links
fiPackfileState Struct


fiRpf7Builder Class

fiRpf7Builder Class
Constructors | Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
fiRpf7Builder
C++
public: class fiRpf7Builder;
Constructors
Constructor | Description
fiRpf7Builder | Constructor
Destructors
Destructor | Description
~fiRpf7Builder | Destructor
Methods
Method | Description
AddData | Data is assumed to be allocated by rage_new, and will be freed when the archive is written.
AddFile |
Save |
Namespace

rage Namespace

File

packfile_builder.h

Links
Constructors, Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


fiRpf7Builder::fiRpf7Builder Constructor

fiRpf7Builder::fiRpf7Builder Constructor
fiRpf7Builder Class
Show All

Constructor

C++
public: fiRpf7Builder(
    int shift
);
Class

fiRpf7Builder Class

File

packfile_builder.h

Links
fiRpf7Builder Class


fiRpf7Builder::~fiRpf7Builder Destructor

fiRpf7Builder::~fiRpf7Builder Destructor
fiRpf7Builder Class
Show All

Destructor

C++
public: ~fiRpf7Builder();
Class

fiRpf7Builder Class

File

packfile_builder.h

Links
fiRpf7Builder Class


fiRpf7Builder::AddData Method

fiRpf7Builder::AddData Method
fiRpf7Builder Class
Show All

Data is assumed to be allocated by rage_new, and will be freed when the archive is written.

C++
public: bool AddData(
    void * srcData,
    u32 dataSize,
    const char * destName,
    bool compressed
);
Class

fiRpf7Builder Class

File

packfile_builder.h

Links
fiRpf7Builder Class


fiRpf7Builder::AddFile Method

fiRpf7Builder::AddFile Method
fiRpf7Builder Class
Show All
C++
public: bool AddFile(
    const char * srcName,
    const char * destName
);
Class

fiRpf7Builder Class

File

packfile_builder.h

Links
fiRpf7Builder Class


fiRpf7Builder::Save Method

fiRpf7Builder::Save Method
fiRpf7Builder Class
Show All
C++
public: void Save(
    fiStream * dest
);
Notes

g_sysPlatform must be correct, and PARAM_aeskey needs to be correct or contain the full output path so we can identify the right project's key to use.

Class

fiRpf7Builder Class

File

packfile_builder.h

Links
fiRpf7Builder Class


fiRpf7Entry Struct

fiRpf7Entry Struct
Constructors | Destructors | Members | Data Members | rage Namespace | Inheritance Hierarchy
Show All

Needed during construction only

fiRpf7Entry
C++
public: struct fiRpf7Entry {
  public: u32 NameOffset;
  public: u32 DataSize : 31, Compressed: 1;
  public: char * SourceName;
  public: u32 Next, Child;
};
Constructors
Constructor | Description
fiRpf7Entry |
Destructors
Destructor | Description
~fiRpf7Entry |
Data Members
Data Member | Description
1 |
Child |
DataSize |
NameOffset |
Next |
SourceName | NULL if directory. Otherwise pointer to name if DataSize is 0, or actual data if DataSize is nonzero.
Namespace

rage Namespace

File

packfile_builder.h

Links
Constructors, Destructors, Members, Data Members, rage Namespace, Inheritance Hierarchy


fiRpf7Entry::1 Data Member

fiRpf7Entry::1 Data Member
fiRpf7Entry Struct
Show All
C++
public: u32 Compressed: 1 : 31;
Struct

fiRpf7Entry Struct

File

packfile_builder.h

Links
fiRpf7Entry Struct


fiRpf7Entry::Child Data Member

fiRpf7Entry::Child Data Member
fiRpf7Entry Struct
Show All
C++
public: u32 Child;
Struct

fiRpf7Entry Struct

File

packfile_builder.h

Links
fiRpf7Entry Struct


fiRpf7Entry::DataSize Data Member

fiRpf7Entry::DataSize Data Member
fiRpf7Entry Struct
Show All
C++
public: u32 DataSize : 31;
Struct

fiRpf7Entry Struct

File

packfile_builder.h

Links
fiRpf7Entry Struct


fiRpf7Entry::NameOffset Data Member

fiRpf7Entry::NameOffset Data Member
fiRpf7Entry Struct
Show All
C++
public: u32 NameOffset;
Struct

fiRpf7Entry Struct

File

packfile_builder.h

Links
fiRpf7Entry Struct


fiRpf7Entry::Next Data Member

fiRpf7Entry::Next Data Member
fiRpf7Entry Struct
Show All
C++
public: u32 Next;
Struct

fiRpf7Entry Struct

File

packfile_builder.h

Links
fiRpf7Entry Struct


fiRpf7Entry::SourceName Data Member

fiRpf7Entry::SourceName Data Member
fiRpf7Entry Struct
Show All

NULL if directory. Otherwise pointer to name if DataSize is 0, or actual data if DataSize is nonzero.

C++
public: char * SourceName;
Struct

fiRpf7Entry Struct

File

packfile_builder.h

Links
fiRpf7Entry Struct


fiRpf7Entry::fiRpf7Entry Constructor

fiRpf7Entry::fiRpf7Entry Constructor
fiRpf7Entry Struct
Show All
C++
public: fiRpf7Entry();
Struct

fiRpf7Entry Struct

File

packfile_builder.h

Links
fiRpf7Entry Struct


fiRpf7Entry::~fiRpf7Entry Destructor

fiRpf7Entry::~fiRpf7Entry Destructor
fiRpf7Entry Struct
Show All
C++
public: ~fiRpf7Entry();
Struct

fiRpf7Entry Struct

File

packfile_builder.h

Links
fiRpf7Entry Struct


fiSafeStream Class

fiSafeStream Class Component
Constructors | Destructors | Members | Operators | rage Namespace | Inheritance Hierarchy
Show All

Pass the result of a fiStream::Open or ASSET.Open to this class and it will assume ownership of the stream for you; its destructor will guarantee that the stream is properly closed. Use it anywhere you would use a fiStream*, it has the appropriate implicit conversion operators.

fiSafeStream
C++
public: class fiSafeStream;
Constructors
Constructor | Description
fiSafeStream | Creates a new safe stream that will close s when the safe stream object is destroyed.
Destructors
Destructor | Description
~fiSafeStream | The safe stream destructor will close the stream its holding on to
Operators
Operator | Description
-> | Returns the stream object, so that fiSafeStream can be used just like an fiStream
fiStream* | Implicit conversion to fiStream, so that fiSafeStream can be used just like an fiStream
Namespace

rage Namespace

File

stream.h

Links
Constructors, Destructors, Members, Operators, rage Namespace, Inheritance Hierarchy


fiSafeStream::fiSafeStream Constructor

fiSafeStream::fiSafeStream Constructor
fiSafeStream Class
Show All

Creates a new safe stream that will close s when the safe stream object is destroyed.

C++
public: fiSafeStream(
    fiStream* s
);
Class

fiSafeStream Class

File

stream.h

Links
fiSafeStream Class


fiSafeStream::~fiSafeStream Destructor

fiSafeStream::~fiSafeStream Destructor
fiSafeStream Class
Show All

The safe stream destructor will close the stream its holding on to

C++
public: ~fiSafeStream();
Class

fiSafeStream Class

File

stream.h

Links
fiSafeStream Class


fiSafeStream::-> Operator

fiSafeStream::-> Operator
fiSafeStream Class
Show All

Returns the stream object, so that fiSafeStream can be used just like an fiStream

C++
public: fiStream* operator ->();
Class

fiSafeStream Class

File

stream.h

Links
fiSafeStream Class


fiSafeStream::fiStream* Operator

fiSafeStream::fiStream* Operator
fiSafeStream Class
Show All

Implicit conversion to fiStream, so that fiSafeStream can be used just like an fiStream

C++
public: operator fiStream*();
Class

fiSafeStream Class

File

stream.h

Links
fiSafeStream Class


fiSaveGame Class

fiSaveGame Class
Structs | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All

fiSaveGame manages independent save state for up to four different players.

The class is designed to be polled every frame depending on what higher-level operation is in progress.

To select the current device for load/save, call BeginSelectDevice. If it returns true, keep calling CheckSelectDevice every frame until it returns true, at which point you should call EndSelectDevice.

To enumerate all savegames on the current device, call BeginEnumeration with the largest number of content items you expect to handle. If it returns true, keep calling CheckEnumeration every frame until it returns true, at which point you can call GetEnumerationCount and GetEnumerationData. When you're done with the data, call EndEnumeration.

To save a game, call BeginSave with the display name to associate with the content and a filename to use internally and the actual save data. If it returns true, keep calling CheckSave every frame until it returns true, at which point it will also tell you if the save was successful. Next call EndSave to return to the idle state.

To load a game, call BeginLoad with the display name to associate with the content and a filename to use internally and the load data buffer. If it returns true, keep calling CheckLoad every frame until it returns true, at which point it will also tell you the amount of data read. Next call EndLoad to return to the idle state.

Note that the display name is actually internally converted into a directory name, so you can actually do multiple savegames under the same display name if you use a different filename each time. You cannot currently individually delete files under the content directory though. Also note that the system browser only lets you manipulate top-level content objects, not files within the content directory.

Any error detected causes the system to enter an error state which can only be left by doing BeginSelectDevice. The most common cause of errors is removing a memory card device.

fiSaveGame
C++
public: class fiSaveGame;
Structs
Struct | Description
Content | Shadows XCONTENT_DATA structure
Device | Mirrors XDEVICE_DATA structure
Methods
Method | Description
BeginContentVerify | Verify saved content (this will probably be platform specific)
BeginDelete | Begin deleting content for the associated signInId
BeginDeleteFromList | Begin the PS3's delete from list function
BeginEnumeration | Begin enumerating content for the associated signInId
BeginExtraSpaceCheck | Begins a check to determine how much extra space is required to save a save game file This gives slightly more information than BeginFreeSpaceCheck. The extra info is needed in certain circumstances such as checking if there is enough free space for several save games before allowing the game to start.
BeginFreeSpaceCheck | Begins a check for sufficient free space to save a save game file
BeginGetCreator | Begin checking if the signed-in user is the creator of a save game file
BeginGetFileModifiedTime | Get the modified time of a file. Only implemented for PS3 so far. Called after a file is saved so that the game has an accurate record of the file's timestamp.
BeginGetFileSize | Get the size of a file so that we know how big a buffer we need to allocate to load the file On the 360, we use GetFileSize On the PS3, we read the size from listParam. This size will also include the size of the icon and system files
BeginIconSave | Begins an icon save
BeginLoad | Begins a content load
BeginReadNamesAndSizesOfAllSaveGames | This is an attempt to speed up the free space checks at the start of the game on PS3. cellSaveDataAutoSave2 is just too slow. I still need to call ExtraSpaceCheck once before this to get the total free space on the hard disk and the size of the system files. So call ExtraSpaceCheck for the profile and then call this for checking the save game slots. This is based on a suggestion of James Wang of SCEA Developer Support. We store the size of each file in the listparam string when a save is made and then read that in a Fixed Callback rather than sizeKB in a Stat Callback. This relies on the listparam being saved correctly with the file and the listparam not being needed for anything else. It also relies on sysSizeKB being the same for all files.
BeginSave | Begins a content save
BeginSelectDevice | Select the active content device
CalculateDataSizeOnDisk | returns the total space on file for data with the given size. Note that xenon and ps3 will increase the size of the file by adding headers, security, encryption, ect. This file returns the size of the file on disk after all modifications and additions are applied by the system.
CalculateSizeOfSaveGameFile | Calculates the actual PS3 HDD space required to store a file of the given size
CheckContentVerify | Checks if a content verify is complete
CheckDelete | Check if a deletion is complete
CheckDeleteFromList | Check if the PS3's delete from list function has finished
CheckEnumeration | Check if an enumeration is complete
CheckExtraSpaceCheck | Checks if an extra space check is complete
CheckFreeSpaceCheck | Checks if a free space check is complete
CheckGetCreator |
CheckGetFileModifiedTime | Checks if a get file modified time process is complete. Only implemented for PS3 so far
CheckGetFileSize | Checks if a get file size process is complete
CheckIconSave | Checks if an icon save is complete
CheckLoad | Checks if a content load is complete
CheckReadNamesAndSizesOfAllSaveGames | Checks if the names and sizes of all save games have been successfully read
CheckSave | Checks if a content save is complete
CheckSelectDevice | See if device selection has completed
EndContentVerify | Ends a content verify
EndDelete | Close a deletion successfully started via BeginDelete
EndDeleteFromList | Tidies up after the PS3's delete from list function has finished
EndEnumeration | Close an enumeration successfully started via BeginEnumeration
EndExtraSpaceCheck | Ends an extra space check
EndFreeSpaceCheck | Ends a free space check
EndGetCreator | Ends a GetCreator
EndGetFileModifiedTime | Ends a get file modified time process. Only implemented for PS3 so far
EndGetFileSize | Ends a get file size process
EndIconSave | Ends an icon save
EndLoad | Ends a content load
EndReadNamesAndSizesOfAllSaveGames | Ends the reading of the names and sizes of all save games
EndSave | Ends a content save
EndSelectDevice | Close down a device selection
FillDevice | fills the current device for testing purposes
GetCurrentDeviceData | Retrieves device data for the current device
GetDeviceData | Retrieves device data for the specified device
GetError | returns the error associated with the latest action
GetMaxUsers | gets the maximum number of users that can be signed into the system at one time (hardware specific)
GetSelectedDevice | Return currently selected device id
GetState | Returns current internal state.
GetTotalAvailableSpace | returns the total available space for the currently selected device
HasFileBeenAccessed | Checks to see if a file has been accessed (verified, loaded, or saved)
InitClass | Setup
IsCurrentDeviceValid | checks to see if the currently selected device is valid
IsDeviceValid | checks to see if the given device is valid
IsStorageDeviceChanged | checks to see if a storage device has been inserted or removed
IsStorageDeviceRemoved | checks to see if a storage device has been removed
SetCheckForUserBindErrors | Enables checking for bind errors and sets the string to display if a bind error occurs
SetIcon | Sets the PNG file to be used for the savegame icon on PS3
SetMaxNumberOfSaveGameFilesToEnumerate | Sets the maximum number of save files to enumerate on PS3
SetMountIndex | On Orbis, each user is given up to 16 mount indices per Title
SetSaveGameFolder | For ELC, we're going to use the savegame folder that is used by DLC. So we need to allow the game to specify the folder rather than just always using XEX_TITLE_ID
SetSaveGameTitle | On the PS3, this will set the Title of all subsequent save games. The display name of the individual save game will be the subtitle
SetSelectedDevice | Sets device id
SetSelectedDeviceToAny |
SetStateToIdle | set the current state to IDLE
SetUserServiceId | On Orbis, this will set the User Service Id for the given Index.
ShowDeleteDialog |
ShowLoadDialog |
ShowSaveDialog | On Orbis, performs a save mount enumeration and displays the system UI for selecting save mounts for save, load and delete. The system dialog causes a pad interupt.
ShutdownClass | Teardown
UpdateClass | Call this once per frame to keep asynchronous operations moving. Currently a NO-OP
Data Members
Data Member | Description
SIGNIN_COUNT | Last SignIn Reserved for Global User
Enumerations
Enumeration | Description
Errors | list of possible errors while saving,loading,ect..
Namespace

rage Namespace

File

savegame.h

Links
Structs, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


fiSaveGame::SIGNIN_COUNT Data Member

fiSaveGame::SIGNIN_COUNT Data Member
fiSaveGame Class
Show All

Last SignIn Reserved for Global User

C++
public: static const int SIGNIN_COUNT = 5;
Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


rage::fiSaveGame::Content Struct

rage::fiSaveGame::Content Struct
fiSaveGame Class
Show All

Shadows XCONTENT_DATA structure

C++
public: struct Content {
  public: union {
public:
    private: struct {
      public: u32 DeviceId;
      public: u32 ContentType;
    };
public:
    private: struct {
      public: u32 ModificationTimeHigh;
      public: u32 ModificationTimeLow;
    };
  };
  public: char16 DisplayName[128];
  public: char Filename[42];
};
Members

DeviceId
Valid on XENON
ContentType
Valid on XENON
ModificationTimeHigh
Valid on PS3
ModificationTimeLow
Valid on PS3

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


rage::fiSaveGame::Device Struct

rage::fiSaveGame::Device Struct
fiSaveGame Class
Show All

Mirrors XDEVICE_DATA structure

C++
public: struct Device {
  public: u32 DeviceId;
  public: u32 DeviceType;
  public: u64 DeviceBytes;
  public: u64 DeviceFreeBytes;
  public: char16 FriendlyName[27];
};
Members

DeviceType
either hard drive or memory unit
DeviceBytes
total capacity of the device
DeviceFreeBytes
number of free bytes
FriendlyName
27 == XCONTENTDEVICE_MAX_NAME_LENGTH

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::BeginContentVerify Method

fiSaveGame::BeginContentVerify Method
fiSaveGame Class
Show All

Verify saved content (this will probably be platform specific)

C++
public: bool BeginContentVerify(
    int signInId,
    u32 contentType,
    u32 deviceId,
    const char * filename
);
Parameters

signInId
Which profile (0-3) to use
contentType
the type of content
deviceId
Which device to use (get this from Content::DeviceId)
filename
filename within the container

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::BeginDelete Method

fiSaveGame::BeginDelete Method
fiSaveGame Class
Show All

Begin deleting content for the associated signInId

C++
public: bool BeginDelete(
    int signInId,
    u32 contentType,
    const char * filename
);
Parameters

signInId
Which profile (0-3) to use
contentType
the type of content
filename
filename within the container to delete

Returns

True if deletion was successfully started

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::BeginDeleteFromList Method

fiSaveGame::BeginDeleteFromList Method
fiSaveGame Class
Show All

Begin the PS3's delete from list function

C++
public: bool BeginDeleteFromList(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use - ignored on PS3

Returns

True if deletion was successfully started

Notes

PS3 only

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::BeginEnumeration Method

fiSaveGame::BeginEnumeration Method
fiSaveGame Class
Show All

Begin enumerating content for the associated signInId

C++
public: bool BeginEnumeration(
    int signInId,
    u32 contentType,
    Content * outContent,
    int maxCount
);
Parameters

signInId
Which profile (0-3) to use
contentType
the type of content
outContent
Pointer to maxCount Content elements to be filled in (must be persistent until EndEnumeration)
maxCount
Maximum number of items to return

Returns

True if enumeration was successfully started

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::BeginExtraSpaceCheck Method

fiSaveGame::BeginExtraSpaceCheck Method
fiSaveGame Class
Show All

Begins a check to determine how much extra space is required to save a save game file This gives slightly more information than BeginFreeSpaceCheck. The extra info is needed in certain circumstances such as checking if there is enough free space for several save games before allowing the game to start.

C++
public: bool BeginExtraSpaceCheck(
    int signInId,
    const char * filename,
    u32 saveSize
);
Parameters

signInId
Which profile (0-3) to use - ignored on PS3
filename
filename within the container to save under; must be DOS-style uppercase 8.3 name.
saveSize
Size of game data (cannot be zero) On 360, this is the size before calling CalculateDataSizeOnDisk

Returns

True if extra space check started successfully, false if there was a problem

Notes

Implemented for PS3 and 360 On PS3, the calculation of free space differs depending on whether the file already exists or not On 360, assume that if there is any problem opening an existing file with the same name then there is no existing file

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::BeginFreeSpaceCheck Method

fiSaveGame::BeginFreeSpaceCheck Method
fiSaveGame Class
Show All

Begins a check for sufficient free space to save a save game file

C++
public: bool BeginFreeSpaceCheck(
    int signInId,
    const char * filename,
    u32 saveSize
);
Parameters

signInId
Which profile (0-3) to use - ignored on PS3
filename
filename within the container to save under; must be DOS-style uppercase 8.3 name.
saveSize
Size of game data (cannot be zero) On 360, this is the size before calling CalculateDataSizeOnDisk

Returns

True if free space check started successfully, false if there was a problem

Notes

On PS3, the calculation of free space differs depending on whether the file already exists or not On 360, assume that if there is any problem opening an existing file with the same name then there is no existing file

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::BeginGetCreator Method

fiSaveGame::BeginGetCreator Method
fiSaveGame Class
Show All

Begin checking if the signed-in user is the creator of a save game file

C++
public: bool BeginGetCreator(
    int signInId,
    u32 contentType,
    u32 deviceId,
    const char * filename
);
Parameters

signInId
Which profile (0-3) to use
contentType
the type of content
deviceId
Which device to use (get this from Content::DeviceId)
filename
filename of the save game to check

Returns

True if started successfully

Notes

Xenon only Needed for TCRs

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::BeginGetFileModifiedTime Method

fiSaveGame::BeginGetFileModifiedTime Method
fiSaveGame Class
Show All

Get the modified time of a file. Only implemented for PS3 so far. Called after a file is saved so that the game has an accurate record of the file's timestamp.

C++
public: bool BeginGetFileModifiedTime(
    int signInId,
    const char * filename
);
Parameters

signInId
Which profile (0-3) to use (ignored on PS3)
filename
filename within the container

Returns

True if the get file modified time process began successfully, false if there was a problem

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::BeginGetFileSize Method

fiSaveGame::BeginGetFileSize Method
fiSaveGame Class
Show All

Get the size of a file so that we know how big a buffer we need to allocate to load the file On the 360, we use GetFileSize On the PS3, we read the size from listParam. This size will also include the size of the icon and system files

C++
public: bool BeginGetFileSize(
    int signInId,
    const char * filename,
    bool bCalculateSizeOnDisk
);
Parameters

signInId
Which profile (0-3) to use
filename
filename within the container
bCalculateSizeOnDisk
On 360, calling this with TRUE will use XContentCalculateSize to calculate the total size of the XContent package

Returns

True if the get file size process began successfully, false if there was a problem

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::BeginIconSave Method

fiSaveGame::BeginIconSave Method
fiSaveGame Class
Show All

Begins an icon save

C++
public: bool BeginIconSave(
    int signInId,
    u32 contentType,
    const char * filename,
    const void * iconData,
    u32 iconSize
);
Parameters

signInId
Which profile (0-3) to use
contentType
the type of content
filename
filename within the container to save under
iconData
icon image buffer (must persist until EndSave)
iconSize
size of icon image buffer (cannot be zero)

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::BeginLoad Method

fiSaveGame::BeginLoad Method
fiSaveGame Class
Show All

Begins a content load

C++
public: bool BeginLoad(
    int signInId,
    u32 contentType,
    u32 deviceId,
    const char * filename,
    void * loadData,
    u32 loadSize
);
Parameters

signInId
Which profile (0-3) to use
contentType
the type of content
deviceId
Which device to use (get this from Content::DeviceId)
filename
filename within the container to save under; must be DOS-style uppercase 8.3 name.
loadData
Load game data buffer (must persist until EndLoad)
loadSize
max size of game data (cannot be zero)

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::BeginReadNamesAndSizesOfAllSaveGames Method

fiSaveGame::BeginReadNamesAndSizesOfAllSaveGames Method
fiSaveGame Class
Show All

This is an attempt to speed up the free space checks at the start of the game on PS3. cellSaveDataAutoSave2 is just too slow. I still need to call ExtraSpaceCheck once before this to get the total free space on the hard disk and the size of the system files. So call ExtraSpaceCheck for the profile and then call this for checking the save game slots. This is based on a suggestion of James Wang of SCEA Developer Support. We store the size of each file in the listparam string when a save is made and then read that in a Fixed Callback rather than sizeKB in a Stat Callback. This relies on the listparam being saved correctly with the file and the listparam not being needed for anything else. It also relies on sysSizeKB being the same for all files.

C++
public: bool BeginReadNamesAndSizesOfAllSaveGames(
    int signInId,
    Content * outContent,
    int * outFileSizes,
    int maxCount
);
Parameters

signInId
Which profile (0-3) to use - ignored on PS3
outContent
Pointer to maxCount Content elements to be filled in (must be persistent until EndReadNamesAndSizesOfAllSaveGames)
outFileSizes
Pointer to maxCount int elements (to store the size of each file) (must be persistent until EndReadNamesAndSizesOfAllSaveGames)
maxCount
maximum size of the two arrays above

Notes

Only implemented for PS3 - does nothing on 360

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::BeginSave Method

fiSaveGame::BeginSave Method
fiSaveGame Class
Show All

Begins a content save

C++
public: bool BeginSave(
    int signInId,
    u32 contentType,
    const char16 * displayName,
    const char * filename,
    const void * saveData,
    u32 saveSize,
    bool overwrite
);
Parameters

signInId
Which profile (0-3) to use
contentType
the type of content
displayName
Human-readable name for content container
filename
filename within the container to save under; must be DOS-style uppercase 8.3 name.
saveData
Save game data (must persist until EndSave)
saveSize
Size of game data (cannot be zero)
overwrite
allows existing content to be overwritten when set to true

Notes

overwrite flag allows is for the actual file, not the content container - the content container will be opened if it exists, otherwise a new one will be created

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::BeginSelectDevice Method

fiSaveGame::BeginSelectDevice Method
fiSaveGame Class
Show All

Select the active content device

C++
public: bool BeginSelectDevice(
    int signInId,
    u32 contentType,
    u32 minSpaceAvailable = 0,
    bool forceShow = false,
    bool manageStorage = false
);
Parameters

signInId
Which profile (0-3) to use
contentType
the type of content
minSpaceAvailable
If nonzero, only devices with this much space available (in byte) are shown
forceShow
force the device selector to show even if the system reports only 1 available device
manageStorage
allows the user to select a Xenon storage device even if there is no free space - required for loading a saved game

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::CalculateDataSizeOnDisk Method

fiSaveGame::CalculateDataSizeOnDisk Method
fiSaveGame Class
Show All

returns the total space on file for data with the given size. Note that xenon and ps3 will increase the size of the file by adding headers, security, encryption, ect. This file returns the size of the file on disk after all modifications and additions are applied by the system.

C++
public: u64 CalculateDataSizeOnDisk(
    int signInId,
    u32 dataSize
);
Parameters

signInId
Which profile (0-3) to use
dataSize
The size of the data that will be saved/loaded

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::CalculateSizeOfSaveGameFile Method

fiSaveGame::CalculateSizeOfSaveGameFile Method
fiSaveGame Class
Show All

Calculates the actual PS3 HDD space required to store a file of the given size

C++
public: int CalculateSizeOfSaveGameFile(
    int DataSize,
    int SizeOfSystemFiles
);
Parameters

DataSize
size of the buffer to be saved
SizeOfSystemFiles
space required for PS3 system files that are stored along with each save game This value can be obtained by an earlier call of the ExtraSpaceCheck functions (I'm assuming that the system files take up the same amount of space for all files)

Returns

The actual PS3 HDD space required

Notes

Only implemented for PS3 - displays an error on 360

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::CheckContentVerify Method

fiSaveGame::CheckContentVerify Method
fiSaveGame Class
Show All

Checks if a content verify is complete

C++
public: bool CheckContentVerify(
    int signInId,
    bool & verified
);
Parameters

signInId
Which profile (0-3) to use

Returns

True if content verify is complete, and verified will be set to true if the operation was successful, or false if there was a failure.

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::CheckDelete Method

fiSaveGame::CheckDelete Method
fiSaveGame Class
Show All

Check if a deletion is complete

C++
public: bool CheckDelete(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use

Returns

True if content deletion is complete

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::CheckDeleteFromList Method

fiSaveGame::CheckDeleteFromList Method
fiSaveGame Class
Show All

Check if the PS3's delete from list function has finished

C++
public: bool CheckDeleteFromList(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use - ignored on PS3

Returns

True if finished - can't tell if the player actually chose to delete any files

Notes

PS3 only

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::CheckEnumeration Method

fiSaveGame::CheckEnumeration Method
fiSaveGame Class
Show All

Check if an enumeration is complete

C++
public: bool CheckEnumeration(
    int signInId,
    int & outCount
);
Parameters

signInId
Which profile (0-3) to use
outCount
Number of items retrieve

Returns

True if enumeration was completed (may not be valid), and outCount is set to number of items retrieved or -1 on an error

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::CheckExtraSpaceCheck Method

fiSaveGame::CheckExtraSpaceCheck Method
fiSaveGame Class
Show All

Checks if an extra space check is complete

C++
public: bool CheckExtraSpaceCheck(
    int signInId,
    int & ExtraSpaceRequired,
    int & TotalHDDFreeSizeKB,
    int & SizeOfSystemFileKB
);
Parameters

signInId
Which profile (0-3) to use - ignored on PS3

Returns

True if extra space check is complete. ExtraSpaceRequired gives the difference in size (in KB) between the new and existing file. It will be negative if the new file is smaller than the existing file. If a negative value is returned, you may want to treat it as if 0 had been returned so that you are not taking into account space that would only exist after the new file has overwritten the existing one. TotalHDDFreeSizeKB - This value is returned on both PS3 and 360 SizeOfSystemFileKB - On PS3, this is required for any subsequent calls to CalculateSizeOfSaveGameFile I'm assuming that sysSizeKB is the same for all files On 360, this parameter is not used

Notes

Implemented for PS3 and 360

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::CheckFreeSpaceCheck Method

fiSaveGame::CheckFreeSpaceCheck Method
fiSaveGame Class
Show All

Checks if a free space check is complete

C++
public: bool CheckFreeSpaceCheck(
    int signInId,
    int & ExtraSpaceRequired
);
Parameters

signInId
Which profile (0-3) to use - ignored on PS3

Returns

True if free space check is complete. ExtraSpaceRequired will be >= 0 if there is enough space to save the file on the hard disk. A negative value gives the amount of space required.

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::CheckGetCreator Method (int, bool &)

fiSaveGame::CheckGetCreator Method (int, bool &)
fiSaveGame Class
Show All
C++
public: bool CheckGetCreator(
    int signInId,
    bool & bIsCreator
);
Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::CheckGetCreator Method (int, bool &, bool&)

fiSaveGame::CheckGetCreator Method (int, bool &, bool&)
fiSaveGame Class
Show All
C++
public: bool CheckGetCreator(
    int signInId,
    bool & bIsCreator,
    bool& bHasCreator
);
Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::CheckGetFileModifiedTime Method

fiSaveGame::CheckGetFileModifiedTime Method
fiSaveGame Class
Show All

Checks if a get file modified time process is complete. Only implemented for PS3 so far

C++
public: bool CheckGetFileModifiedTime(
    int signInId,
    u32 & modTimeHigh,
    u32 & modTimeLow
);
Parameters

signInId
Which profile (0-3) to use (ignored on PS3) modTimeHigh and modTimeLow - the two parts of the 8 byte time

Returns

True if get file modified time is complete (successful or error) need to check GetState() for errors if successful then modTimeHigh and modTimeLow will contain the modified time False if it hasn't finished yet

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::CheckGetFileSize Method

fiSaveGame::CheckGetFileSize Method
fiSaveGame Class
Show All

Checks if a get file size process is complete

C++
public: bool CheckGetFileSize(
    int signInId,
    u64 & fileSize
);
Parameters

signInId
Which profile (0-3) to use
fileSize
the size of the file in bytes on 360, this will be the size of the XContent package if BeginGetFileSize was called with bCalculateSizeOnDisk = true on PS3, the size includes the size of the save icon and any system files

Returns

True if get file size is complete (successful or error) need to check GetState() for errors if successful then fileSize will contain the file size False if it hasn't finished yet

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::CheckIconSave Method

fiSaveGame::CheckIconSave Method
fiSaveGame Class
Show All

Checks if an icon save is complete

C++
public: bool CheckIconSave(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use

Returns

True if icon save is complete

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::CheckLoad Method

fiSaveGame::CheckLoad Method
fiSaveGame Class
Show All

Checks if a content load is complete

C++
public: bool CheckLoad(
    int signInId,
    bool & outIsValid,
    u32 & loadSize
);
Parameters

signInId
Which profile (0-3) to use

Returns

True if content load is complete, and loadSize will contain number of bytes read

Notes

loadSize is only changed if CheckLoad returned true (which will happen exactly once per Begin/End block)

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::CheckReadNamesAndSizesOfAllSaveGames Method

fiSaveGame::CheckReadNamesAndSizesOfAllSaveGames Method
fiSaveGame Class
Show All

Checks if the names and sizes of all save games have been successfully read

C++
public: bool CheckReadNamesAndSizesOfAllSaveGames(
    int signInId,
    int & outCount
);
Parameters

signInId
Which profile (0-3) to use - ignored on PS3

Returns

True if the reading of all names and sizes is complete. outCount - contains the total number of save game files that exist

Notes

Only implemented for PS3 - does nothing on 360

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::CheckSave Method

fiSaveGame::CheckSave Method
fiSaveGame Class
Show All

Checks if a content save is complete

C++
public: bool CheckSave(
    int signInId,
    bool & outIsValid,
    bool & fileExists
);
Parameters

signInId
Which profile (0-3) to use

Returns

True if content save is complete, and outIsValid will be set to true if the operation was successful, or false if there was a failure.

Notes

outIsValid is only changed if CheckSave returned true (which will happen exactly once per Begin/End block) fileExists set to true if the file already exists

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::CheckSelectDevice Method

fiSaveGame::CheckSelectDevice Method
fiSaveGame Class
Show All

See if device selection has completed

C++
public: bool CheckSelectDevice(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::EndContentVerify Method

fiSaveGame::EndContentVerify Method
fiSaveGame Class
Show All

Ends a content verify

C++
public: void EndContentVerify(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::EndDelete Method

fiSaveGame::EndDelete Method
fiSaveGame Class
Show All

Close a deletion successfully started via BeginDelete

C++
public: void EndDelete(
    int signInId
);
Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::EndDeleteFromList Method

fiSaveGame::EndDeleteFromList Method
fiSaveGame Class
Show All

Tidies up after the PS3's delete from list function has finished

C++
public: void EndDeleteFromList(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use - ignored on PS3

Notes

PS3 only

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::EndEnumeration Method

fiSaveGame::EndEnumeration Method
fiSaveGame Class
Show All

Close an enumeration successfully started via BeginEnumeration

C++
public: void EndEnumeration(
    int signInId
);
Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::EndExtraSpaceCheck Method

fiSaveGame::EndExtraSpaceCheck Method
fiSaveGame Class
Show All

Ends an extra space check

C++
public: void EndExtraSpaceCheck(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use - ignored on PS3

Notes

Implemented for PS3 and 360

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::EndFreeSpaceCheck Method

fiSaveGame::EndFreeSpaceCheck Method
fiSaveGame Class
Show All

Ends a free space check

C++
public: void EndFreeSpaceCheck(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use - ignored on PS3

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::EndGetCreator Method

fiSaveGame::EndGetCreator Method
fiSaveGame Class
Show All

Ends a GetCreator

C++
public: void EndGetCreator(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use

Notes

Xenon only Needed for TCRs

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::EndGetFileModifiedTime Method

fiSaveGame::EndGetFileModifiedTime Method
fiSaveGame Class
Show All

Ends a get file modified time process. Only implemented for PS3 so far

C++
public: void EndGetFileModifiedTime(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use (ignored on PS3)

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::EndGetFileSize Method

fiSaveGame::EndGetFileSize Method
fiSaveGame Class
Show All

Ends a get file size process

C++
public: void EndGetFileSize(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::EndIconSave Method

fiSaveGame::EndIconSave Method
fiSaveGame Class
Show All

Ends an icon save

C++
public: void EndIconSave(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::EndLoad Method

fiSaveGame::EndLoad Method
fiSaveGame Class
Show All

Ends a content load

C++
public: void EndLoad(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::EndReadNamesAndSizesOfAllSaveGames Method

fiSaveGame::EndReadNamesAndSizesOfAllSaveGames Method
fiSaveGame Class
Show All

Ends the reading of the names and sizes of all save games

C++
public: void EndReadNamesAndSizesOfAllSaveGames(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use - ignored on PS3

Notes

Only implemented for PS3 - does nothing on 360

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::EndSave Method

fiSaveGame::EndSave Method
fiSaveGame Class
Show All

Ends a content save

C++
public: void EndSave(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::EndSelectDevice Method

fiSaveGame::EndSelectDevice Method
fiSaveGame Class
Show All

Close down a device selection

C++
public: void EndSelectDevice(
    int signInId
);
Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::FillDevice Method

fiSaveGame::FillDevice Method
fiSaveGame Class
Show All

fills the current device for testing purposes

C++
public: void FillDevice(
    int signInId
);
Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::GetCurrentDeviceData Method

fiSaveGame::GetCurrentDeviceData Method
fiSaveGame Class
Show All

Retrieves device data for the current device

C++
public: bool GetCurrentDeviceData(
    int signInId,
    Device * outDevice
);
Parameters

signInId
Which profile (0-3) to use - ignored on PS3
outDevice
Space to write out device data for our current device

Returns

True if we got the data

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::GetDeviceData Method

fiSaveGame::GetDeviceData Method
fiSaveGame Class
Show All

Retrieves device data for the specified device

C++
public: bool GetDeviceData(
    int signInId,
    u32 deviceId,
    Device * outDevice
);
Parameters

signInId
Which profile (0-3) to use - ignored on PS3
deviceId
The device whose information we're looking up
outDevice
Space to write out device data for our chosen device

Returns

True if we got the data

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::GetError Method

fiSaveGame::GetError Method
fiSaveGame Class
Show All

returns the error associated with the latest action

C++
public: fiSaveGame::Errors GetError(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::GetMaxUsers Method

fiSaveGame::GetMaxUsers Method
fiSaveGame Class
Show All

gets the maximum number of users that can be signed into the system at one time (hardware specific)

C++
public: int GetMaxUsers();
Parameters

signInId
Which profile (0-3) to use

Returns

the maximum number of users that can be signed into the system at one time

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::GetSelectedDevice Method

fiSaveGame::GetSelectedDevice Method
fiSaveGame Class
Show All

Return currently selected device id

C++
public: u32 GetSelectedDevice(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::GetState Method

fiSaveGame::GetState Method
fiSaveGame Class
Show All

Returns current internal state.

C++
public: fiSaveGameState::State GetState(
    int signInId
) const;
Parameters

signInId
Which profile (0-3) to use

Notes

Whenever this returns the ERROR state, the only way to clear it again is to call BeginSelectDevice. This should also be reflected in some change in user-visible state.

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::GetTotalAvailableSpace Method

fiSaveGame::GetTotalAvailableSpace Method
fiSaveGame Class
Show All

returns the total available space for the currently selected device

C++
public: u64 GetTotalAvailableSpace(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::HasFileBeenAccessed Method

fiSaveGame::HasFileBeenAccessed Method
fiSaveGame Class
Show All

Checks to see if a file has been accessed (verified, loaded, or saved)

C++
public: bool HasFileBeenAccessed(
    int signInId,
    const char* filename
);
Parameters

signInId
Which profile (0-3) to use
filename
The filename to check against

Notes

Checks to see if the given file has been accessed. This function is usefull when verifying that a file has not been removed

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::InitClass Method

fiSaveGame::InitClass Method
fiSaveGame Class
Show All

Setup

C++
public: static void InitClass();
Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::IsCurrentDeviceValid Method

fiSaveGame::IsCurrentDeviceValid Method
fiSaveGame Class
Show All

checks to see if the currently selected device is valid

C++
public: bool IsCurrentDeviceValid(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use

Returns

True if device is valid, false otherwise

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::IsDeviceValid Method

fiSaveGame::IsDeviceValid Method
fiSaveGame Class
Show All

checks to see if the given device is valid

C++
public: bool IsDeviceValid(
    int signInId,
    u32 deviceId
);
Parameters

signInId
Which profile (0-3) to use

Returns

True if device is valid, false otherwise

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::IsStorageDeviceChanged Method

fiSaveGame::IsStorageDeviceChanged Method
fiSaveGame Class
Show All

checks to see if a storage device has been inserted or removed

C++
public: bool IsStorageDeviceChanged(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use

Returns

True if a device has changed, false otherwise

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::IsStorageDeviceRemoved Method

fiSaveGame::IsStorageDeviceRemoved Method
fiSaveGame Class
Show All

checks to see if a storage device has been removed

C++
public: bool IsStorageDeviceRemoved(
    int signInId
);
Parameters

signInId
Which profile (0-3) to use

Returns

True if a device has been removed, false otherwise

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::SetCheckForUserBindErrors Method

fiSaveGame::SetCheckForUserBindErrors Method
fiSaveGame Class
Show All

Enables checking for bind errors and sets the string to display if a bind error occurs

C++
public: void SetCheckForUserBindErrors(
    const char * pBindErrorMessage
);
Notes

Doesn't do anything on Xenon CELL_SAVEDATA_BINDSTAT_ERR_NOUSER always seems to occur unless the user is registered with the PLAYSTATION Network (and has been given a unique Account ID). This function won't be any use unless the game requires all players to be registered with the PLAYSTATION Network

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::SetIcon Method

fiSaveGame::SetIcon Method
fiSaveGame Class
Show All

Sets the PNG file to be used for the savegame icon on PS3

C++
public: void SetIcon(
    char * pIcon,
    const u32 SizeOfIconFile
);
Parameters

pIcon
pointer to memory holding the 320 x 176 PNG file

Notes

Doesn't do anything on Xenon

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::SetMaxNumberOfSaveGameFilesToEnumerate Method

fiSaveGame::SetMaxNumberOfSaveGameFilesToEnumerate Method
fiSaveGame Class
Show All

Sets the maximum number of save files to enumerate on PS3

C++
public: void SetMaxNumberOfSaveGameFilesToEnumerate(
    int MaxNumSaveGames
);
Parameters

MaxNumSaveGames
maximum number of save games that can be enumerated Should be the same as the maxCount parameter of BeginEnumeration

Notes

Doesn't do anything on Xenon

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::SetMountIndex Method

fiSaveGame::SetMountIndex Method
fiSaveGame Class
Show All

On Orbis, each user is given up to 16 mount indices per Title

C++
public: void SetMountIndex(
    int signInId,
    int index
);
Notes

Doesn't do anything on non-Orbis Platforms

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::SetSaveGameFolder Method

fiSaveGame::SetSaveGameFolder Method
fiSaveGame Class
Show All

For ELC, we're going to use the savegame folder that is used by DLC. So we need to allow the game to specify the folder rather than just always using XEX_TITLE_ID

C++
public: void SetSaveGameFolder(
    const char * pTitleIDForSaveGameFolder
);
Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::SetSaveGameTitle Method

fiSaveGame::SetSaveGameTitle Method
fiSaveGame Class
Show All

On the PS3, this will set the Title of all subsequent save games. The display name of the individual save game will be the subtitle

C++
public: void SetSaveGameTitle(
    const char * pSaveGameTitle
);
Notes

Doesn't do anything on Xenon

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::SetSelectedDevice Method

fiSaveGame::SetSelectedDevice Method
fiSaveGame Class
Show All

Sets device id

C++
public: void SetSelectedDevice(
    int signInId,
    u32 deviceId
);
Parameters

signInId
Which profile (0-3) to use
deviceId
Which device to use

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::SetSelectedDeviceToAny Method

fiSaveGame::SetSelectedDeviceToAny Method
fiSaveGame Class
Show All
C++
public: void SetSelectedDeviceToAny(
    int signInId
);
Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::SetStateToIdle Method

fiSaveGame::SetStateToIdle Method
fiSaveGame Class
Show All

set the current state to IDLE

C++
public: void SetStateToIdle(
    int signInId
);
Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::SetUserServiceId Method

fiSaveGame::SetUserServiceId Method
fiSaveGame Class
Show All

On Orbis, this will set the User Service Id for the given Index.

C++
public: void SetUserServiceId(
    int signInId,
    int userId
);
Notes

Doesn't do anything on non-Orbis Platforms

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::ShowDeleteDialog Method

fiSaveGame::ShowDeleteDialog Method
fiSaveGame Class
Show All
C++
public: void ShowDeleteDialog(
    int signInId
);
Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::ShowLoadDialog Method

fiSaveGame::ShowLoadDialog Method
fiSaveGame Class
Show All
C++
public: void ShowLoadDialog(
    int signInId
);
Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::ShowSaveDialog Method

fiSaveGame::ShowSaveDialog Method
fiSaveGame Class
Show All

On Orbis, performs a save mount enumeration and displays the system UI for selecting save mounts for save, load and delete. The system dialog causes a pad interupt.

C++
public: void ShowSaveDialog(
    int signInId
);
Notes

Doesn't do anything on non-Orbis platforms

Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::ShutdownClass Method

fiSaveGame::ShutdownClass Method
fiSaveGame Class
Show All

Teardown

C++
public: static void ShutdownClass();
Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSaveGame::UpdateClass Method

fiSaveGame::UpdateClass Method
fiSaveGame Class
Show All

Call this once per frame to keep asynchronous operations moving. Currently a NO-OP

C++
public: void UpdateClass();
Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


rage::fiSaveGame::Errors Enumeration

rage::fiSaveGame::Errors Enumeration
fiSaveGame Class
Show All

list of possible errors while saving,loading,ect..

C++
public: enum Errors {
  public: SAVE_GAME_SUCCESS,
  public: NOT_ENOUGH_FREE_SPACE_ON_DEVICE,
  public: USER_CANCELLED_DEVICE_SELECTION,
  public: FILE_CORRUPT,
  public: DEVICE_CORRUPT,
  public: NO_FILES_EXIST,
  public: PATH_NOT_FOUND,
  public: COULD_NOT_MAP_DEVICE,
  public: THE_DEVICE_IS_NOT_READY,
  public: PS3_ERROR_USER_CANCELLED,
  public: PS3_ERROR_CALLBACK_ERROR,
  public: PS3_ERROR_ACCESS,
  public: PS3_ERROR_INTERNAL,
  public: PS3_ERROR_PARAM,
  public: PS3_ERROR_FAILURE,
  public: PS3_ERROR_BUSY,
  public: UNKNOWN_ERROR,
  public: NUM_ERROR_TYPES
};
Class

fiSaveGame Class

File

savegame.h

Links
fiSaveGame Class


fiSerialize Class

fiSerialize Class
Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
datSerialize
    fiSerialize
C++
public: class fiSerialize : public datSerialize;
Constructors
Constructor | Description
fiSerialize |
Destructors
Destructor | Description
~fiSerialize |
Methods
Method | Description
Get | Unserialize a null-terminated string. Storage for the new string must be pre-allocated. UNLESS, size is 0, at which point the string is just discarded.
Put | Serialize a null-terminated string
Serialize |
Data Members
Data Member | Description
m_Stream | Used for binary files
m_Token | Used for ascii files
m_Version | Version of file
Namespace

rage Namespace

File

serialize.h

Links
Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


fiSerialize::m_Stream Data Member

fiSerialize::m_Stream Data Member
fiSerialize Class
Show All

Used for binary files

C++
protected: fiStream * m_Stream;
Class

fiSerialize Class

File

serialize.h

Links
fiSerialize Class


fiSerialize::m_Token Data Member

fiSerialize::m_Token Data Member
fiSerialize Class
Show All

Used for ascii files

C++
protected: fiAsciiTokenizer m_Token;
Class

fiSerialize Class

File

serialize.h

Links
fiSerialize Class


fiSerialize::m_Version Data Member

fiSerialize::m_Version Data Member
fiSerialize Class
Show All

Version of file

C++
protected: int m_Version;
Class

fiSerialize Class

File

serialize.h

Links
fiSerialize Class


fiSerialize::fiSerialize Constructor

fiSerialize::fiSerialize Constructor
fiSerialize Class
Show All
C++
public: fiSerialize(
    fiStream * stream,
    bool read,
    bool binary
);
Class

fiSerialize Class

File

serialize.h

Links
fiSerialize Class


fiSerialize::~fiSerialize Destructor

fiSerialize::~fiSerialize Destructor
fiSerialize Class
Show All
C++
public: virtual ~fiSerialize();
Class

fiSerialize Class

File

serialize.h

Links
fiSerialize Class


fiSerialize::Get Method

fiSerialize::Get Method
fiSerialize Class
Show All

Unserialize a null-terminated string. Storage for the new string must be pre-allocated. UNLESS, size is 0, at which point the string is just discarded.

C++
public: virtual void Get(
    char * outString,
    int size
);
Class

fiSerialize Class

File

serialize.h

Links
fiSerialize Class


fiSerialize::Put Method

fiSerialize::Put Method
fiSerialize Class
Show All

Serialize a null-terminated string

C++
public: virtual void Put(
    const char * string
);
Class

fiSerialize Class

File

serialize.h

Links
fiSerialize Class


fiSerialize::Serialize Method (bool &)

fiSerialize::Serialize Method (bool &)
fiSerialize Class
Show All
C++
public: virtual void Serialize(
    bool & val
);
Class

fiSerialize Class

File

serialize.h

Links
fiSerialize Class


fiSerialize::Serialize Method (f32 &)

fiSerialize::Serialize Method (f32 &)
fiSerialize Class
Show All
C++
public: virtual void Serialize(
    f32 & val
);
Class

fiSerialize Class

File

serialize.h

Links
fiSerialize Class


fiSerialize::Serialize Method (s16 &)

fiSerialize::Serialize Method (s16 &)
fiSerialize Class
Show All
C++
public: virtual void Serialize(
    s16 & val
);
Class

fiSerialize Class

File

serialize.h

Links
fiSerialize Class


fiSerialize::Serialize Method (s32 &)

fiSerialize::Serialize Method (s32 &)
fiSerialize Class
Show All
C++
public: virtual void Serialize(
    s32 & val
);
Class

fiSerialize Class

File

serialize.h

Links
fiSerialize Class


fiSerialize::Serialize Method (s8 &)

fiSerialize::Serialize Method (s8 &)
fiSerialize Class
Show All
C++
public: virtual void Serialize(
    s8 & val
);
Class

fiSerialize Class

File

serialize.h

Links
fiSerialize Class


fiSerialize::Serialize Method (u16 &)

fiSerialize::Serialize Method (u16 &)
fiSerialize Class
Show All
C++
public: virtual void Serialize(
    u16 & val
);
Class

fiSerialize Class

File

serialize.h

Links
fiSerialize Class


fiSerialize::Serialize Method (u32 &)

fiSerialize::Serialize Method (u32 &)
fiSerialize Class
Show All
C++
public: virtual void Serialize(
    u32 & val
);
Class

fiSerialize Class

File

serialize.h

Links
fiSerialize Class


fiSerialize::Serialize Method (u64 &)

fiSerialize::Serialize Method (u64 &)
fiSerialize Class
Show All
C++
public: virtual void Serialize(
    u64 & val
);
Class

fiSerialize Class

File

serialize.h

Links
fiSerialize Class


fiSerialize::Serialize Method (u8 &)

fiSerialize::Serialize Method (u8 &)
fiSerialize Class
Show All
C++
public: virtual void Serialize(
    u8 & val
);
Class

fiSerialize Class

File

serialize.h

Links
fiSerialize Class


fiStream Class

fiStream Class Component
Members | Methods | rage Namespace | Inheritance Hierarchy
Show All

This implements functions to do the file I/O work. Implements buffered file I/O; should be used instead of FILE in stdio.h if portability is desired.

Where practical, stdio-style interfaces are supported; most use inlines to translate into the particular member function call.

fiStream
C++
public: class fiStream;
Notes

It is not necessary to flush between reading and writing the same file.

Methods
Method | Description
AllowBlockingLoads | __ASSERT
AreBlockingLoadsAllowed |
Close | Closes the stream.
CloseOpenFiles | Close all open files
CloseShared | Closes the stream without closing the underlying handle (assuming it's shared) This flushes the buffers and frees our fiStream object without invalidating the handle.
Create | Attempts to create a file of the given name for read-write access, returning NULL on failure. All filenames are treated verbatim at this level. Uses the current "default create file method" to access the file.
DumpOpenFiles | Print information about open files
FastGetCh | Pulls next available character from the file stream. Returns -1 on EOF.
FastPutCh | Pushes supplied character into the file stream.
fdopen | Associates an already-existing device handle with a stream (which assumes ownership of the file and will close the handle when the stream is closed, unless you call CloseShared)
Flush | Flush any buffered data.
GetCh | Gets a single char from the stream, returns it.
GetCloseCallback | Returns the current stream-close callback
GetCreateCallback | Returns the current stream-create callback
GetLocalHandle |
GetName | Get the name of this stream (__DEV && __TOOL builds only)
GetOpenCallback | Returns the current stream-open callback
Open | Attempts to open a file of the given name, returning NULL on failure. All filenames are treated verbatim at this level; there is no notion of an asset path or anything like that. See data/asset.h for a higher-level way to open files. Uses the current "default open file method" to access the file.
OutputAllFileAccess | Turns on a bool that causes all file operations to print debug information
PreLoad | Fully loads a stream into memory. Will create a new stream and close the given one.
PutCh | Puts a single char to the string.
Read | Read the as many as "count" into the "dest".
ReadByte |
ReadFloat |
ReadInt |
ReadLong |
ReadShort |
ReadTChar |
Seek | Seeks directly to specified position in the file. No "whence" parameter is supported; use fiStream::Tell as necessary to implement relative file pointer movement.
Seek64 | Seeks directly to specified position in the file. No "whence" parameter is supported; use fiStream::Tell64 as necessary to implement relative file pointer movement.
SetCloseCallback | Sets a callback that gets called every time a stream is closed.
SetCreateCallback | Sets a callback that gets called every time a stream is created.
SetFaultInjectionPath | also for testing error handling by making certain folders fail loading
SetOpenCallback | Sets a callback that gets called every time a stream is opened.
Size | Returns the total size of the file.
Size64 | Returns the total size of the file.
Tell | Returns current file position (start + offset.)
Tell64 | Returns current file position (start + offset.)
TellStart |
Write | Write as many as "count" from src into buffer.
WriteByte |
WriteFloat |
WriteInt |
WriteLong |
WriteShort |
WriteTChar |
Namespace

rage Namespace

File

stream.h

Links
Members, Methods, rage Namespace, Inheritance Hierarchy


fiStream::AllowBlockingLoads Method

fiStream::AllowBlockingLoads Method
fiStream Class
Show All

__ASSERT

C++
public: static void AllowBlockingLoads(
    bool
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::AreBlockingLoadsAllowed Method

fiStream::AreBlockingLoadsAllowed Method
fiStream Class
Show All
C++
public: static bool AreBlockingLoadsAllowed();
Returns

TRUE if it's OK to do blocking loads.

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::Close Method

fiStream::Close Method
fiStream Class
Show All

Closes the stream.

C++
public: int Close();
Returns

0 if successful, non-zero on failure

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::CloseOpenFiles Method

fiStream::CloseOpenFiles Method
fiStream Class
Show All

Close all open files

C++
public: static void CloseOpenFiles();
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::CloseShared Method

fiStream::CloseShared Method
fiStream Class
Show All

Closes the stream without closing the underlying handle (assuming it's shared) This flushes the buffers and frees our fiStream object without invalidating the handle.

C++
public: int CloseShared();
Returns

0 if successful, non-zero on failure

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::Create Method (const char *)

fiStream::Create Method (const char *)
fiStream Class
Show All

Attempts to create a file of the given name for read-write access, returning NULL on failure. All filenames are treated verbatim at this level. Uses the current "default create file method" to access the file.

C++
public: static fiStream* Create(
    const char * file
);
Parameters

file
name of the file to open.

Returns

the pointer to the stream.

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::Create Method (const char *, const fiDevice &)

fiStream::Create Method (const char *, const fiDevice &)
fiStream Class
Show All

Attempts to create a file of the given name for read-write access, returning NULL on failure. All filenames are treated verbatim at this level. Uses the supplied coreFileMethods* pointer to determine how to actually create the file.

C++
public: static fiStream* Create(
    const char * file,
    const fiDevice & device
);
Parameters

file
file to create.
device
used to create a file.

Returns

The pointer to the stream.

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::DumpOpenFiles Method

fiStream::DumpOpenFiles Method
fiStream Class
Show All

Print information about open files

C++
public: static void DumpOpenFiles(
    const char * linePrefix = ""
);
Parameters

linePrefix
Text to prefix the Displayf() output with.

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::FastGetCh Method

fiStream::FastGetCh Method
fiStream Class
Show All

Pulls next available character from the file stream. Returns -1 on EOF.

C++
public: inline int FastGetCh();
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::FastPutCh Method

fiStream::FastPutCh Method
fiStream Class
Show All

Pushes supplied character into the file stream.

C++
public: inline int FastPutCh(
    u8 ch
);
Parameters

ch
The character to put into the stream

Returns

-1 on failure (disk full), ch otherwise.

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::fdopen Method

fiStream::fdopen Method
fiStream Class
Show All

Associates an already-existing device handle with a stream (which assumes ownership of the file and will close the handle when the stream is closed, unless you call CloseShared)

C++
public: static fiStream* fdopen(
    const char * file,
    fiHandle handle
);
Parameters

file
Filename (for debugging only, ie leaked streams)
handle
handle of the file, suitable for use by fiDeviceLocal

Returns

the pointer to the stream, or NULL on failure.

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::Flush Method

fiStream::Flush Method
fiStream Class
Show All

Flush any buffered data.

C++
public: int Flush();
Returns

Number of bytes flushed.

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::GetCh Method

fiStream::GetCh Method
fiStream Class
Show All

Gets a single char from the stream, returns it.

C++
public: int GetCh();
Returns

-1 on failure (EOF), a character from the stream otherwise.

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::GetCloseCallback Method

fiStream::GetCloseCallback Method
fiStream Class
Show All

Returns the current stream-close callback

C++
public: static StreamCloseCallback GetCloseCallback();
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::GetCreateCallback Method

fiStream::GetCreateCallback Method
fiStream Class
Show All

Returns the current stream-create callback

C++
public: static StreamCreateCallback GetCreateCallback();
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::GetLocalHandle Method

fiStream::GetLocalHandle Method
fiStream Class
Show All
C++
public: fiHandle GetLocalHandle() const;
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::GetName Method

fiStream::GetName Method
fiStream Class
Show All

Get the name of this stream (__DEV && __TOOL builds only)

C++
public: const char * GetName() const;
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::GetOpenCallback Method

fiStream::GetOpenCallback Method
fiStream Class
Show All

Returns the current stream-open callback

C++
public: static StreamOpenCallback GetOpenCallback();
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::Open Method (const char *, bool)

fiStream::Open Method (const char *, bool)
fiStream Class
Show All

Attempts to open a file of the given name, returning NULL on failure. All filenames are treated verbatim at this level; there is no notion of an asset path or anything like that. See data/asset.h for a higher-level way to open files. Uses the current "default open file method" to access the file.

C++
public: static fiStream* Open(
    const char * file,
    bool readOnly = true
);
Parameters

file
name of the file to open.
readOnly
read only if true.

Returns

the pointer to the stream.

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::Open Method (const char *, const fiDevice &, bool)

fiStream::Open Method (const char *, const fiDevice &, bool)
fiStream Class
Show All

Attempts to open a file of the given name, returning NULL on failure. All filenames are treated verbatim at this level; there is no notion of an asset path or anything like that. See data/asset.h for a higher-level way to open files. Uses the supplied coreFileMethods* pointer to determine how to actually open the file.

C++
public: static fiStream* Open(
    const char * file,
    const fiDevice & device,
    bool readOnly = true
);
Parameters

file
name of the file to open.
device
methods to open a file.
readOnly
read only if true.

Returns

the pointer to the stream.

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::OutputAllFileAccess Method

fiStream::OutputAllFileAccess Method
fiStream Class
Show All

Turns on a bool that causes all file operations to print debug information

C++
public: static void OutputAllFileAccess();
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::PreLoad Method

fiStream::PreLoad Method
fiStream Class
Show All

Fully loads a stream into memory. Will create a new stream and close the given one.

C++
public: static fiStream* PreLoad(
    fiStream* s
);
Parameters

s
The stream to be read from and then closed.

Returns

The pointer to the stream.

Notes

Read data from the stream S into a new buffer which will be the buffer of the new stream.

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::PutCh Method

fiStream::PutCh Method
fiStream Class
Show All

Puts a single char to the string.

C++
public: int PutCh(
    unsigned char ch
);
Parameters

ch
The character to put into the stream

Returns

The character, or -1 on EOF

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::Read Method

fiStream::Read Method
fiStream Class
Show All

Read the as many as "count" into the "dest".

C++
public: int Read(
    void* dest,
    int count
);
Parameters

dest
where to store the read.
count
how many to read.

Returns

Returns count of bytes read.

Notes

Large writes (more than 4K bypass buffering and are sent directly to the core file routine for handling.

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::ReadByte Method (char *, int)

fiStream::ReadByte Method (char *, int)
fiStream Class
Show All
C++
public: int ReadByte(
    char * dest,
    int num
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::ReadByte Method (unsigned char*, int)

fiStream::ReadByte Method (unsigned char*, int)
fiStream Class
Show All

Read one or more data items.

C++
public: int ReadByte(
    unsigned char* dest,
    int num
);
Parameters

dest
where to store the read data.
num
how many to read.

Returns

total items read.

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::ReadFloat Method

fiStream::ReadFloat Method
fiStream Class
Show All
C++
public: int ReadFloat(
    float * dest,
    int num
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::ReadInt Method (int *, int)

fiStream::ReadInt Method (int *, int)
fiStream Class
Show All
C++
public: int ReadInt(
    int * dest,
    int num
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::ReadInt Method (unsigned *, int)

fiStream::ReadInt Method (unsigned *, int)
fiStream Class
Show All
C++
public: int ReadInt(
    unsigned * dest,
    int num
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::ReadLong Method (s64 *, int)

fiStream::ReadLong Method (s64 *, int)
fiStream Class
Show All
C++
public: int ReadLong(
    s64 * dest,
    int num
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::ReadLong Method (u64 *, int)

fiStream::ReadLong Method (u64 *, int)
fiStream Class
Show All
C++
public: int ReadLong(
    u64 * dest,
    int num
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::ReadShort Method (short *, int)

fiStream::ReadShort Method (short *, int)
fiStream Class
Show All
C++
public: int ReadShort(
    short * dest,
    int num
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::ReadShort Method (unsigned short *, int)

fiStream::ReadShort Method (unsigned short *, int)
fiStream Class
Show All
C++
public: int ReadShort(
    unsigned short * dest,
    int num
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::ReadTChar Method

fiStream::ReadTChar Method
fiStream Class
Show All
C++
public: int ReadTChar(
    _TCHAR * dest,
    int num
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::Seek Method

fiStream::Seek Method
fiStream Class
Show All

Seeks directly to specified position in the file. No "whence" parameter is supported; use fiStream::Tell as necessary to implement relative file pointer movement.

C++
public: int Seek(
    int newPos
);
Parameters

newPos
the specified position

Returns

returns -1 if position is outside file boundary.

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::Seek64 Method

fiStream::Seek64 Method
fiStream Class
Show All

Seeks directly to specified position in the file. No "whence" parameter is supported; use fiStream::Tell64 as necessary to implement relative file pointer movement.

C++
public: u64 Seek64(
    u64 newPos
);
Parameters

newPos
the specified position

Returns

returns -1 if position is outside file boundary.

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::SetCloseCallback Method

fiStream::SetCloseCallback Method
fiStream Class
Show All

Sets a callback that gets called every time a stream is closed.

C++
public: static void SetCloseCallback(
    StreamCloseCallback callback
);
Parameters

callback
The callback function to call

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::SetCreateCallback Method

fiStream::SetCreateCallback Method
fiStream Class
Show All

Sets a callback that gets called every time a stream is created.

C++
public: static void SetCreateCallback(
    StreamCreateCallback callback
);
Parameters

callback
The callback function to call

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::SetFaultInjectionPath Method

fiStream::SetFaultInjectionPath Method
fiStream Class
Show All

also for testing error handling by making certain folders fail loading

C++
public: static void SetFaultInjectionPath(
    const char* path
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::SetOpenCallback Method

fiStream::SetOpenCallback Method
fiStream Class
Show All

Sets a callback that gets called every time a stream is opened.

C++
public: static void SetOpenCallback(
    StreamOpenCallback callback
);
Parameters

callback
The callback function to call

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::Size Method

fiStream::Size Method
fiStream Class
Show All

Returns the total size of the file.

C++
public: int Size();
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::Size64 Method

fiStream::Size64 Method
fiStream Class
Show All

Returns the total size of the file.

C++
public: u64 Size64();
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::Tell Method

fiStream::Tell Method
fiStream Class
Show All

Returns current file position (start + offset.)

C++
public: int Tell();
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::Tell64 Method

fiStream::Tell64 Method
fiStream Class
Show All

Returns current file position (start + offset.)

C++
public: u64 Tell64();
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::TellStart Method

fiStream::TellStart Method
fiStream Class
Show All
C++
public: int TellStart();
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::Write Method

fiStream::Write Method
fiStream Class
Show All

Write as many as "count" from src into buffer.

C++
public: int Write(
    const void* src,
    int count
);
Parameters

src
to be written.
count
total to be written.

Returns

Returns count of bytes written.

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::WriteByte Method (const char *, int)

fiStream::WriteByte Method (const char *, int)
fiStream Class
Show All
C++
public: int WriteByte(
    const char * src,
    int num
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::WriteByte Method (const unsigned char *, int)

fiStream::WriteByte Method (const unsigned char *, int)
fiStream Class
Show All

Write one or more data items.

C++
public: int WriteByte(
    const unsigned char * src,
    int num
);
Parameters

src
the data to be written.
num
number of items to be written.

Returns

total items written.

Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::WriteFloat Method

fiStream::WriteFloat Method
fiStream Class
Show All
C++
public: int WriteFloat(
    const float * src,
    int num
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::WriteInt Method (const int *, int)

fiStream::WriteInt Method (const int *, int)
fiStream Class
Show All
C++
public: int WriteInt(
    const int * src,
    int num
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::WriteInt Method (const unsigned *, int)

fiStream::WriteInt Method (const unsigned *, int)
fiStream Class
Show All
C++
public: int WriteInt(
    const unsigned * src,
    int num
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::WriteLong Method (const s64 *, int)

fiStream::WriteLong Method (const s64 *, int)
fiStream Class
Show All
C++
public: int WriteLong(
    const s64 * src,
    int num
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::WriteLong Method (const u64 *, int)

fiStream::WriteLong Method (const u64 *, int)
fiStream Class
Show All
C++
public: int WriteLong(
    const u64 * src,
    int num
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::WriteShort Method (const short *, int)

fiStream::WriteShort Method (const short *, int)
fiStream Class
Show All
C++
public: int WriteShort(
    const short * src,
    int num
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::WriteShort Method (const unsigned short *, int)

fiStream::WriteShort Method (const unsigned short *, int)
fiStream Class
Show All
C++
public: int WriteShort(
    const unsigned short * src,
    int num
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiStream::WriteTChar Method

fiStream::WriteTChar Method
fiStream Class
Show All
C++
public: int WriteTChar(
    const _TCHAR * src,
    int num
);
Class

fiStream Class

File

stream.h

Links
fiStream Class


fiTokenizer Class

fiTokenizer Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All

This class is to keep current code compiling:

rage::fiBaseTokenizer
    rage::fiAsciiTokenizer
        fiTokenizer
C++
public: class fiTokenizer : public fiAsciiTokenizer;
Constructors
Constructor | Description
fiAsciiTokenizer |
fiTokenizer |
Destructors
Destructor | Description
~fiBaseTokenizer |
Methods
Method | Description
CheckIToken |
CheckToken |
EndBlock | Decreases the tab by one
EndBlock | Decreases the tab by one
EndLine | Starts a new line
EndLine | Starts a new line
EndOfFile |
GetBlock | get a block of "length" characters
GetByte | read functions:
GetByte | Reads a numerical value and returns it
GetDelimiter |
GetDelimiter |
GetFloat | Reads a numerical value and returns it
GetFloat | Reads a numerical value and returns it
GetHexU32 |
GetInt | Reads a numerical value and returns it
GetInt | Reads a numerical value and returns it
GetLine |
GetName |
GetNextCh |
GetShort | Reads a numerical value and returns it
GetShort | Reads a numerical value and returns it
GetStream |
GetStreamPosition |
GetToken | read functions:
GetTokenCh |
GetTokenToChar |
GetTokenToChars |
GetVector | Reads a numerical value and returns it
GetVector | Reads a numerical value and returns it
GetWriteState |
IgnoreToken |
Indent |
Indent |
Init |
IsBinary |
IsBinary |
iswhitespace |
MatchFloat |
MatchFloat |
MatchIFloat |
MatchIFloat |
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchIToken |
MatchIVector |
MatchIVector |
MatchToken |
MatchVector |
MatchVector |
Pop | pop the current block as defined by "{" and "}" delimiters. this will also pop any sub-blocks. useful for file formats in a state of flux.
Put |
Put |
PutByte |
PutByte |
PutDelimiter |
PutDelimiter |
PutShort |
PutShort |
PutStr |
PutStrLine | convenience functions
Reset |
SetNextCh |
SetStreamPosition |
SetTerminators | Sets a list of characters that should be used for terminating tokens and skipped over.
SetWriteState |
SkipComment |
SkipToEndOfLine |
StartBlock | Increases the tab by one
StartBlock | Increases the tab by one
StartLine | Indents by tab
StartLine | Indents by tab
WriteTabs |
Data Members
Data Member | Description
CommentChar |
filename |
line |
m_nNumTabs | Holds the current indentation tabs
m_WriteState |
nextch |
S |
Enumerations
Enumeration | Description
enState |
Namespace

rage Namespace

File

token.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


fiTokenizer::fiTokenizer Constructor ()

fiTokenizer::fiTokenizer Constructor ()
fiTokenizer Class
Show All
C++
public: fiTokenizer();
Class

fiTokenizer Class

File

token.h

Links
fiTokenizer Class


fiTokenizer::fiTokenizer Constructor (const char *, fiStream *)

fiTokenizer::fiTokenizer Constructor (const char *, fiStream *)
fiTokenizer Class
Show All
C++
public: fiTokenizer(
    const char * name,
    fiStream * s
);
Class

fiTokenizer Class

File

token.h

Links
fiTokenizer Class


fiZipfile Class

fiZipfile Class COMPONENT
Structs | Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All

The fiZipfile device implements read-only zipfile access with compression support. Higher-level code is expected to call fiDevice::Mount with a new instance of fiZipfile that has succeeded in its Init call. The zipfile will remember the device and handle of its original filename without consuming an fiStream permanently; in theory it is possible to even nest zipfiles within zipfiles -- which can be useful if you're trying to save memory, because the entire zipfile directory structure is kept resident in memory at all times.

Internally each element of a pathname is stored separately (like a real filesystem would) so deep directory structures are not any more expensive, particularly if they result in shorter element names. For example, prop_sandiego_lamppost_01 would be stored more efficiently as prop/sandiego/lamppost_01 if there were many other props in sandiego.

rage::fiDevice
    fiZipfile
C++
public: class fiZipfile : public fiDevice;
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
fiZipfile |
Destructors
Destructor | Description
~fiDevice |
~fiZipfile |
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk |
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create |
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FillData |
FindEntry |
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
Init |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
MountAs |
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
OpenInternal |
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
ReadInternal |
ReadInternalBulk |
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime |
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size | Determine size of file
Size64 | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write |
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
m_ArchiveBias | for nested zipfiles (sigh)
m_ArchiveSize |
m_Device | device the zipfile itself lives on
m_Handle | (bulk) handle on the device of the zipfile itself
m_Name | debug name
m_RelativeOffset | amount of incoming pathname to strip off
m_Root |
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options
Namespace

rage Namespace

File

zipfile.h

Links
Structs, Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


fiZipfile::m_ArchiveBias Data Member

fiZipfile::m_ArchiveBias Data Member
fiZipfile Class
Show All

for nested zipfiles (sigh)

C++
protected: u64 m_ArchiveBias;
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::m_ArchiveSize Data Member

fiZipfile::m_ArchiveSize Data Member
fiZipfile Class
Show All
C++
protected: u64 m_ArchiveSize;
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::m_Device Data Member

fiZipfile::m_Device Data Member
fiZipfile Class
Show All

device the zipfile itself lives on

C++
protected: const fiDevice * m_Device;
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::m_Handle Data Member

fiZipfile::m_Handle Data Member
fiZipfile Class
Show All

(bulk) handle on the device of the zipfile itself

C++
protected: fiHandle m_Handle;
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::m_Name Data Member

fiZipfile::m_Name Data Member
fiZipfile Class
Show All

debug name

C++
protected: char m_Name[32];
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::m_RelativeOffset Data Member

fiZipfile::m_RelativeOffset Data Member
fiZipfile Class
Show All

amount of incoming pathname to strip off

C++
protected: int m_RelativeOffset;
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::m_Root Data Member

fiZipfile::m_Root Data Member
fiZipfile Class
Show All
C++
protected: zipDirEntry * m_Root;
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::fiZipfile Constructor

fiZipfile::fiZipfile Constructor
fiZipfile Class
Show All
C++
public: fiZipfile();
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::~fiZipfile Destructor

fiZipfile::~fiZipfile Destructor
fiZipfile Class
Show All
C++
public: ~fiZipfile();
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::Close Method

fiZipfile::Close Method
fiZipfile Class
Show All

Close a file

C++
public: virtual int Close(
    fiHandle handle
) const;
Parameters

handle
Handle of file to close (must have been opened or created with the same device).

Returns

zero if the call succeeded, non-zero if it failed

Notes

You must eventually Close any handle successfully returned by an Open or Create call or else you will have a resource leak.

Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::CloseBulk Method

fiZipfile::CloseBulk Method
fiZipfile Class
Show All
C++
public: virtual int CloseBulk(
    fiHandle
) const;
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::Create Method

fiZipfile::Create Method
fiZipfile Class
Show All
C++
public: virtual fiHandle Create(
    const char * filename
) const;
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::FillData Method

fiZipfile::FillData Method
fiZipfile Class
Show All
C++
protected: void FillData(
    fiFindData & outData,
    zipDirEntry * e
) const;
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::FindEntry Method

fiZipfile::FindEntry Method
fiZipfile Class
Show All
C++
protected: zipDirEntry* FindEntry(
    const char * name
) const;
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::FindFileBegin Method

fiZipfile::FindFileBegin Method
fiZipfile Class
Show All

Iterate over all files in a directory

C++
public: virtual fiHandle FindFileBegin(
    const char * directoryName,
    fiFindData & outData
) const;
Parameters

directoryName
Name of the directory to search (no wildcard necessary or supported; do filtering yourself in higher-level code).
outData
Info for first matching file (if return value was not -1)

Returns

A "find handle" that is used to identify this search so that more that one can be in progress at a time, or -1 if we were unable to find any matches. Must eventually call FindFileEnd on this handle if it did not return -1.

Notes

Some platforms will return "." and ".." and some will not, so make sure you handle them properly.

Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::FindFileEnd Method

fiZipfile::FindFileEnd Method
fiZipfile Class
Show All

Close a search begun with FindFileBegin

C++
public: virtual int FindFileEnd(
    fiHandle handle
) const;
Parameters

handle
Find handle to close

Returns

Zero if the call succeeded, non-zero otherwise.

Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::FindFileNext Method

fiZipfile::FindFileNext Method
fiZipfile Class
Show All

Continue a search begun with FindFileBegin

C++
public: virtual bool FindFileNext(
    fiHandle handle,
    fiFindData & outData
) const;
Parameters

handle
Find handle returned by FindFileBegin
outData
Info for next match file (if return value was not false)

Returns

True on success (outData is valid), or false if there were no more matches

Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::GetAttributes Method

fiZipfile::GetAttributes Method
fiZipfile Class
Show All

Retrieves file attributes

C++
public: virtual u32 GetAttributes(
    const char * filename
) const;
Parameters

filename
name of file to retrieve attributes

Returns

File attributes (see FILE_ATTRIBUTE_...) or FILE_ATTRIBUTE_INVALID (~0U) if file doesn't exist.

Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::GetDebugName Method

fiZipfile::GetDebugName Method
fiZipfile Class
Show All
C++
public: virtual const char * GetDebugName() const;
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::GetFileSize Method

fiZipfile::GetFileSize Method
fiZipfile Class
Show All

Determine size of file

C++
public: virtual u64 GetFileSize(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Size of the file

Notes

Base class implements this as three calls to Seek, subclasses that may know the size of the file ahead of time are encouraged to improve upon this.

Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::GetFileTime Method

fiZipfile::GetFileTime Method
fiZipfile Class
Show All

Return time-of-date information for a file

C++
public: virtual u64 GetFileTime(
    const char * filename
) const;
Parameters

filename
Name of file to request timestamp for

Returns

Large integer (in unspecified units) which represents the file time. Will return 0 if a file did not exist. If a filetime fa is larger than another filetime fb then fa is newer than fb.

Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::Init Method

fiZipfile::Init Method
fiZipfile Class
Show All
C++
public: bool Init(
    const char * filename
);
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::MountAs Method

fiZipfile::MountAs Method
fiZipfile Class
Show All
C++
public: bool MountAs(
    const char * filename
);
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::Open Method

fiZipfile::Open Method
fiZipfile Class
Show All

Attempt to open a file on this device

C++
public: virtual fiHandle Open(
    const char * filename,
    bool readOnly
) const;
Parameters

filename
Name of file to open (including device id)
readOnly
True if file will be read-only, else false.

Returns

Non-negative handle value on success, negative value on error.

Notes

If a file is read-only, we attempt to open in a sharing-friendly manner. If this function returns a value file handle, you must eventually call Close on this device with that handle or else you would suffer a resource leak.

Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::OpenBulk Method

fiZipfile::OpenBulk Method
fiZipfile Class
Show All

Attempt to open a file on this device for bulk read

C++
public: virtual fiHandle OpenBulk(
    const char * filename,
    u64 & outBias
) const;
Parameters

filename
Name of file to open (including device id)
outBias
Reference to a u64 containing a bias you should add to any ReadBulk call using this handle. Allows archives to avoid having to maintain any internal state when using uncompressed files.

Returns

Non-negative handle value on success, negative value on error.

Notes

The handle returned by this function can only be used with ReadBulk and CloseBulk.

Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::OpenInternal Method

fiZipfile::OpenInternal Method
fiZipfile Class
Show All
C++
protected: fiHandle OpenInternal(
    const char * lookupName,
    bool readOnly
) const;
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::Read Method

fiZipfile::Read Method
fiZipfile Class
Show All

Read binary data from file

C++
public: virtual int Read(
    fiHandle handle,
    void * outBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
outBuffer
Destination to receive data that is read
bufferSize
Maximum amount of data to read

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data.

Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::ReadBulk Method

fiZipfile::ReadBulk Method
fiZipfile Class
Show All

Seek and read binary data from file

C++
public: virtual int ReadBulk(
    fiHandle handle,
    u64 offset,
    void * outBuffer,
    int bufferSize
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
File offset, must be multiple of block size (2048 is safest) Note that you should add any bias returned by OpenBulk in here yourself.
outBuffer
Destination to receive data that is read (should be aligned to cache line for maximum speed)
bufferSize
Maximum amount of data to read, must be multiple of block size (again, 2048 is safest)

Returns

Non-negative integer on success representing number of bytes of data read (zero typically means end-of-file). Negative integer indicates an error.

Notes

No translation of any kind is done on the data. The data is not cached.

Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::ReadInternal Method

fiZipfile::ReadInternal Method
fiZipfile Class
Show All
C++
protected: int ReadInternal(
    fiZipfileState& state,
    void * outBuffer,
    int bufferSize
) const;
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::ReadInternalBulk Method

fiZipfile::ReadInternalBulk Method
fiZipfile Class
Show All
C++
protected: int ReadInternalBulk(
    const fiZipfileState& state,
    u32 relativeOffset,
    void * outBuffer,
    int bufferSize
) const;
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::Seek Method

fiZipfile::Seek Method
fiZipfile Class
Show All

Seek to a location in file

C++
public: virtual int Seek(
    fiHandle handle,
    int offset,
    fiSeekWhence whence
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

Lower 32 bits of new file position, or -1 on error

Notes

Not all devices can implement seek (pipes, etc)

Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::Seek64 Method

fiZipfile::Seek64 Method
fiZipfile Class
Show All

Seek to a location in file

C++
public: virtual u64 Seek64(
    fiHandle handle,
    s64 offset,
    fiSeekWhence whence
) const;
Parameters

handle
Handle for file (must have been opened or created with the same device)
offset
Offset from 'whence' to seek to
whence
Origin for seek operation (as per stdio fseek)

Returns

New file position, or 0xFFFF FFFF FFFF FFFF on error.

Notes

Not all devices can implement seek (pipes, etc)

Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::SetFileTime Method

fiZipfile::SetFileTime Method
fiZipfile Class
Show All
C++
public: virtual bool SetFileTime(
    const char * filename,
    u64 timestamp
) const;
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::Size Method

fiZipfile::Size Method
fiZipfile Class
Show All

Determine size of file

C++
public: virtual int Size(
    fiHandle handle
) const;
Parameters

handle
Handle of file to determine size of (must have been opened or created with the same device)

Returns

Size of the file

Notes

Base class implements this as three calls to Seek, subclasses that may know the size of the file ahead of time are encouraged to improve upon this.

Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::Size64 Method

fiZipfile::Size64 Method
fiZipfile Class
Show All

Determine size of file

C++
public: virtual u64 Size64(
    fiHandle handle
) const;
Parameters

handle
Handle of file to determine size of (must have been opened or created with the same device)

Returns

Size of the file

Notes

Base class implements this as three calls to Seek, subclasses that may know the size of the file ahead of time are encouraged to improve upon this.

Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfile::Write Method

fiZipfile::Write Method
fiZipfile Class
Show All
C++
public: virtual int Write(
    fiHandle handle,
    const void * buffer,
    int bufferSize
) const;
Class

fiZipfile Class

File

zipfile.h

Links
fiZipfile Class


fiZipfileState Struct

fiZipfileState Struct
Constructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
fiZipfileState
C++
public: struct fiZipfileState {
  public: static const u32 BufferSize = 8192;
  public: char * m_Buffer;
  public: char m_DebugName[32];
  public: zipDirEntry * m_Entry;
  public: u32 m_Offset;
  public: u32 m_CompOffset;
  public: z_stream m_zStream;
};
Constructors
Constructor | Description
fiZipfileState |
Methods
Method | Description
IsCompressed |
Reset |
Data Members
Data Member | Description
BufferSize |
m_Buffer |
m_CompOffset | Current offset within the compressed file
m_DebugName |
m_Entry | Pointer to the file directory entry
m_Offset | Current offset within the (virtual, uncompressed) file
m_zStream | Stream object used by Zlib
Namespace

rage Namespace

File

zipfile.cpp

Links
Constructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


fiZipfileState::BufferSize Data Member

fiZipfileState::BufferSize Data Member
fiZipfileState Struct
Show All
C++
public: static const u32 BufferSize = 8192;
Struct

fiZipfileState Struct

File

zipfile.cpp

Links
fiZipfileState Struct


fiZipfileState::m_Buffer Data Member

fiZipfileState::m_Buffer Data Member
fiZipfileState Struct
Show All
C++
public: char * m_Buffer;
Struct

fiZipfileState Struct

File

zipfile.cpp

Links
fiZipfileState Struct


fiZipfileState::m_CompOffset Data Member

fiZipfileState::m_CompOffset Data Member
fiZipfileState Struct
Show All

Current offset within the compressed file

C++
public: u32 m_CompOffset;
Struct

fiZipfileState Struct

File

zipfile.cpp

Links
fiZipfileState Struct


fiZipfileState::m_DebugName Data Member

fiZipfileState::m_DebugName Data Member
fiZipfileState Struct
Show All
C++
public: char m_DebugName[32];
Struct

fiZipfileState Struct

File

zipfile.cpp

Links
fiZipfileState Struct


fiZipfileState::m_Entry Data Member

fiZipfileState::m_Entry Data Member
fiZipfileState Struct
Show All

Pointer to the file directory entry

C++
public: zipDirEntry * m_Entry;
Struct

fiZipfileState Struct

File

zipfile.cpp

Links
fiZipfileState Struct


fiZipfileState::m_Offset Data Member

fiZipfileState::m_Offset Data Member
fiZipfileState Struct
Show All

Current offset within the (virtual, uncompressed) file

C++
public: u32 m_Offset;
Struct

fiZipfileState Struct

File

zipfile.cpp

Links
fiZipfileState Struct


fiZipfileState::m_zStream Data Member

fiZipfileState::m_zStream Data Member
fiZipfileState Struct
Show All

Stream object used by Zlib

C++
public: z_stream m_zStream;
Struct

fiZipfileState Struct

File

zipfile.cpp

Links
fiZipfileState Struct


fiZipfileState::fiZipfileState Constructor

fiZipfileState::fiZipfileState Constructor
fiZipfileState Struct
Show All
C++
public: fiZipfileState();
Struct

fiZipfileState Struct

File

zipfile.cpp

Links
fiZipfileState Struct


fiZipfileState::IsCompressed Method

fiZipfileState::IsCompressed Method
fiZipfileState Struct
Show All
C++
public: bool IsCompressed() const;
Struct

fiZipfileState Struct

File

zipfile.cpp

Links
fiZipfileState Struct


fiZipfileState::Reset Method

fiZipfileState::Reset Method
fiZipfileState Struct
Show All
C++
public: void Reset();
Struct

fiZipfileState Struct

File

zipfile.cpp

Links
fiZipfileState Struct


Header Class

Header Class
Constructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
Header
C++
public: class Header;
Constructors
Constructor | Description
Header |
Methods
Method | Description
CalculateHash |
Clear |
Export |
GetDisplayName |
GetExpectedVersion |
GetVersion |
Import |
Data Members
Data Member | Description
FILE_VERSION |
m_DisplayName |
m_Hash |
m_Version |
MAX_BYTE_SIZEOF_PAYLOAD | m_Hash
Namespace

rage Namespace

File

savegame_pc.cpp

Links
Constructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


Header::FILE_VERSION Data Member

Header::FILE_VERSION Data Member
Header Class
Show All
C++
public: static const unsigned FILE_VERSION = 1;
Class

Header Class

File

savegame_pc.cpp

Links
Header Class
Send comments on this topic.


Header::m_DisplayName Data Member

Header::m_DisplayName Data Member
Header Class
Show All
C++
public: char16 m_DisplayName[MAX_DISPLAY_NAME];
Class

Header Class

File

savegame_pc.cpp

Links
Header Class
Send comments on this topic.


Header::m_Hash Data Member

Header::m_Hash Data Member
Header Class
Show All
C++
public: u32 m_Hash;
Class

Header Class

File

savegame_pc.cpp

Links
Header Class
Send comments on this topic.


Header::m_Version Data Member

Header::m_Version Data Member
Header Class
Show All
C++
public: u32 m_Version;
Class

Header Class

File

savegame_pc.cpp

Links
Header Class
Send comments on this topic.


Header::MAX_BYTE_SIZEOF_PAYLOAD Data Member

Header::MAX_BYTE_SIZEOF_PAYLOAD Data Member
Header Class
Show All

m_Hash

C++
public: static const unsigned MAX_BYTE_SIZEOF_PAYLOAD = sizeof(u32) + sizeof(char16) * MAX_DISPLAY_NAME + sizeof(u32);
Class

Header Class

File

savegame_pc.cpp

Links
Header Class
Send comments on this topic.


Header::Header Constructor

Header::Header Constructor
Header Class
Show All
C++
public: Header();
Class

Header Class

File

savegame_pc.cpp

Links
Header Class
Send comments on this topic.


Header::CalculateHash Method

Header::CalculateHash Method
Header Class
Show All
C++
public: u32 CalculateHash(
    u32 version,
    const char16 (&displayName)[MAX_DISPLAY_NAME]
) const;
Class

Header Class

File

savegame_pc.cpp

Links
Header Class
Send comments on this topic.


Header::Clear Method

Header::Clear Method
Header Class
Show All
C++
public: void Clear();
Class

Header Class

File

savegame_pc.cpp

Links
Header Class
Send comments on this topic.


Header::Export Method

Header::Export Method
Header Class
Show All
C++
public: bool Export(
    const char16 (&displayName)[MAX_DISPLAY_NAME],
    void* buf,
    const unsigned sizeOfBuf,
    unsigned* size
) const;
Class

Header Class

File

savegame_pc.cpp

Links
Header Class
Send comments on this topic.


Header::GetDisplayName Method

Header::GetDisplayName Method
Header Class
Show All
C++
public: char16* GetDisplayName();
Class

Header Class

File

savegame_pc.cpp

Links
Header Class
Send comments on this topic.


Header::GetExpectedVersion Method

Header::GetExpectedVersion Method
Header Class
Show All
C++
public: u32 GetExpectedVersion() const;
Class

Header Class

File

savegame_pc.cpp

Links
Header Class
Send comments on this topic.


Header::GetVersion Method

Header::GetVersion Method
Header Class
Show All
C++
public: u32 GetVersion();
Class

Header Class

File

savegame_pc.cpp

Links
Header Class
Send comments on this topic.


Header::Import Method

Header::Import Method
Header Class
Show All
C++
public: bool Import(
    const void* buf,
    const unsigned sizeOfBuf,
    unsigned* size = 0
);
Class

Header Class

File

savegame_pc.cpp

Links
Header Class
Send comments on this topic.


Mount_t Struct

Mount_t Struct
Constructors | Members | Data Members | rage Namespace | Inheritance Hierarchy
Show All
Mount_t
C++
public: struct Mount_t {
  public: ConstString Path;
  public: u16 ReadOnly;
  public: u16 PathLen;
  public: atArray<const fiDevice *> Device;
};
Constructors
Constructor | Description
Mount_t |
Data Members
Data Member | Description
Device |
Path |
PathLen |
ReadOnly |
Namespace

rage Namespace

File

device_common.cpp

Links
Constructors, Members, Data Members, rage Namespace, Inheritance Hierarchy


Mount_t::Device Data Member

Mount_t::Device Data Member
Mount_t Struct
Show All
C++
public: atArray<const fiDevice *> Device;
Struct

Mount_t Struct

File

device_common.cpp

Links
Mount_t Struct
Send comments on this topic.


Mount_t::Path Data Member

Mount_t::Path Data Member
Mount_t Struct
Show All
C++
public: ConstString Path;
Struct

Mount_t Struct

File

device_common.cpp

Links
Mount_t Struct
Send comments on this topic.


Mount_t::PathLen Data Member

Mount_t::PathLen Data Member
Mount_t Struct
Show All
C++
public: u16 PathLen;
Struct

Mount_t Struct

File

device_common.cpp

Links
Mount_t Struct
Send comments on this topic.


Mount_t::ReadOnly Data Member

Mount_t::ReadOnly Data Member
Mount_t Struct
Show All
C++
public: u16 ReadOnly;
Struct

Mount_t Struct

File

device_common.cpp

Links
Mount_t Struct
Send comments on this topic.


Mount_t::Mount_t Constructor

Mount_t::Mount_t Constructor
Mount_t Struct
Show All
C++
public: Mount_t();
Struct

Mount_t Struct

File

device_common.cpp

Links
Mount_t Struct
Send comments on this topic.


MsDosDate Struct

MsDosDate Struct
Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
MsDosDate
C++
public: struct MsDosDate {
};
Methods
Method | Description
DECLARE_BITFIELD_3 | day is 1-31, month is 1-12
Namespace

rage Namespace

File

zipfile.cpp

Links
Members, Methods, rage Namespace, Inheritance Hierarchy


MsDosDate::DECLARE_BITFIELD_3 Method

MsDosDate::DECLARE_BITFIELD_3 Method
MsDosDate Struct
Show All

day is 1-31, month is 1-12

C++
public: u16 DECLARE_BITFIELD_3(
    day,
    5,
    month,
    4,
    yearsFrom1980,
    7
);
Struct

MsDosDate Struct

File

zipfile.cpp

Links
MsDosDate Struct
Send comments on this topic.


MsDosTime Struct

MsDosTime Struct
Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
MsDosTime
C++
public: struct MsDosTime {
};
Methods
Method | Description
DECLARE_BITFIELD_3 |
Namespace

rage Namespace

File

zipfile.cpp

Links
Members, Methods, rage Namespace, Inheritance Hierarchy


MsDosTime::DECLARE_BITFIELD_3 Method

MsDosTime::DECLARE_BITFIELD_3 Method
MsDosTime Struct
Show All
C++
public: u16 DECLARE_BITFIELD_3(
    second,
    5,
    minute,
    6,
    hour,
    5
);
Struct

MsDosTime Struct

File

zipfile.cpp

Links
MsDosTime Struct
Send comments on this topic.


XenonProfile Class

XenonProfile Class
Constructors | Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
XenonProfile
C++
public: class XenonProfile;
Constructors
Constructor | Description
XenonProfile |
Destructors
Destructor | Description
~XenonProfile |
Methods
Method | Description
BeginContentVerify |
BeginDelete |
BeginEnumeration |
BeginFreeSpaceCheck | HACK_GTA4 HACK_GTA4
BeginGetCreator |
BeginGetFileSize |
BeginIconSave |
BeginLoad |
BeginSave |
BeginSelectDevice |
CalculateDataSizeOnDisk |
CheckContentVerify |
CheckDelete |
CheckEnumeration |
CheckFreeSpaceCheck |
CheckGetCreator |
CheckGetFileSize |
CheckIconSave |
CheckLoad |
CheckSave |
CheckSelectDevice |
CompareTimestamps |
EndContentVerify |
EndDelete |
EndEnumeration |
EndFreeSpaceCheck |
EndGetCreator |
EndGetFileSize |
EndIconSave |
EndLoad |
EndSave |
EndSelectDevice |
FillDevice |
GetCurrentDeviceData |
GetDeviceData |
GetError |
GetLoadSize |
GetSaveSize |
GetSelectedDevice |
GetState |
GetTotalAvailableSpace |
HasFileBeenAccessed |
IsCurrentDeviceValid |
IsDeviceValid |
IsStorageDeviceChanged |
IsStorageDeviceRemoved |
SetSelectedDevice |
SetSelectedDeviceToAny |
SetStateToIdle |
Namespace

rage Namespace

File

savegame_xenon.cpp

Links
Constructors, Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


XenonProfile::XenonProfile Constructor

XenonProfile::XenonProfile Constructor
XenonProfile Class
Show All
C++
public: XenonProfile();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::~XenonProfile Destructor

XenonProfile::~XenonProfile Destructor
XenonProfile Class
Show All
C++
public: ~XenonProfile();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::BeginContentVerify Method

XenonProfile::BeginContentVerify Method
XenonProfile Class
Show All
C++
public: bool BeginContentVerify(
    u32 contentType,
    u32 deviceId,
    const char * filename
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::BeginDelete Method

XenonProfile::BeginDelete Method
XenonProfile Class
Show All
C++
public: bool BeginDelete(
    u32 contentType,
    const char * filename
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::BeginEnumeration Method

XenonProfile::BeginEnumeration Method
XenonProfile Class
Show All
C++
public: bool BeginEnumeration(
    u32 contentType,
    fiSaveGame::Content * outContent,
    int maxCount
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::BeginFreeSpaceCheck Method (const char *, u32)

XenonProfile::BeginFreeSpaceCheck Method (const char *, u32)
XenonProfile Class
Show All

HACK_GTA4

HACK_GTA4

C++
public: bool BeginFreeSpaceCheck(
    const char * filename,
    u32 saveSize
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::BeginFreeSpaceCheck Method (eTypeOfSpaceCheck, const char *, u32)

XenonProfile::BeginFreeSpaceCheck Method (eTypeOfSpaceCheck, const char *, u32)
XenonProfile Class
Show All
C++
public: bool BeginFreeSpaceCheck(
    eTypeOfSpaceCheck SpaceCheckType,
    const char * filename,
    u32 saveSize
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::BeginGetCreator Method

XenonProfile::BeginGetCreator Method
XenonProfile Class
Show All
C++
public: bool BeginGetCreator(
    u32 contentType,
    u32 deviceId,
    const char * filename
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::BeginGetFileSize Method

XenonProfile::BeginGetFileSize Method
XenonProfile Class
Show All
C++
public: bool BeginGetFileSize(
    const char * filename,
    bool bCalculateSizeOnDisk
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::BeginIconSave Method

XenonProfile::BeginIconSave Method
XenonProfile Class
Show All
C++
public: bool BeginIconSave(
    u32 contentType,
    const char * filename,
    const void * iconData,
    u32 iconSize
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::BeginLoad Method

XenonProfile::BeginLoad Method
XenonProfile Class
Show All
C++
public: bool BeginLoad(
    u32 contentType,
    u32 deviceId,
    const char * filename,
    void * loadData,
    u32 loadSize
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::BeginSave Method

XenonProfile::BeginSave Method
XenonProfile Class
Show All
C++
public: bool BeginSave(
    u32 contentType,
    const char16 * contentName,
    const char * filename,
    const void * saveData,
    u32 saveSize,
    bool overwrite
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::BeginSelectDevice Method

XenonProfile::BeginSelectDevice Method
XenonProfile Class
Show All
C++
public: bool BeginSelectDevice(
    u32 contentType,
    u32 minSpaceAvailable,
    bool forceShow,
    bool manageStorage
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::CalculateDataSizeOnDisk Method

XenonProfile::CalculateDataSizeOnDisk Method
XenonProfile Class
Show All
C++
public: u64 CalculateDataSizeOnDisk(
    u32 dataSize
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::CheckContentVerify Method

XenonProfile::CheckContentVerify Method
XenonProfile Class
Show All
C++
public: bool CheckContentVerify(
    bool & verified
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::CheckDelete Method

XenonProfile::CheckDelete Method
XenonProfile Class
Show All
C++
public: bool CheckDelete();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::CheckEnumeration Method

XenonProfile::CheckEnumeration Method
XenonProfile Class
Show All
C++
public: bool CheckEnumeration(
    int & outCount
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::CheckFreeSpaceCheck Method (eTypeOfSpaceCheck, int &, int &)

XenonProfile::CheckFreeSpaceCheck Method (eTypeOfSpaceCheck, int &, int &)
XenonProfile Class
Show All
C++
public: bool CheckFreeSpaceCheck(
    eTypeOfSpaceCheck SpaceCheckType,
    int & ExtraSpaceRequired,
    int & TotalHDDFreeSizeKB
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::CheckFreeSpaceCheck Method (int &)

XenonProfile::CheckFreeSpaceCheck Method (int &)
XenonProfile Class
Show All

HACK_GTA4

C++
public: bool CheckFreeSpaceCheck(
    int & ExtraSpaceRequired
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::CheckGetCreator Method

XenonProfile::CheckGetCreator Method
XenonProfile Class
Show All
C++
public: bool CheckGetCreator(
    bool & bIsCreator
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::CheckGetFileSize Method

XenonProfile::CheckGetFileSize Method
XenonProfile Class
Show All
C++
public: bool CheckGetFileSize(
    u64 & fileSize
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::CheckIconSave Method

XenonProfile::CheckIconSave Method
XenonProfile Class
Show All
C++
public: bool CheckIconSave();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::CheckLoad Method

XenonProfile::CheckLoad Method
XenonProfile Class
Show All
C++
public: bool CheckLoad(
    bool & outIsValid,
    u32 & loadSize
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::CheckSave Method

XenonProfile::CheckSave Method
XenonProfile Class
Show All
C++
public: bool CheckSave(
    bool & outIsValid,
    bool & fileExists
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::CheckSelectDevice Method

XenonProfile::CheckSelectDevice Method
XenonProfile Class
Show All
C++
public: bool CheckSelectDevice();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::CompareTimestamps Method

XenonProfile::CompareTimestamps Method
XenonProfile Class
Show All
C++
public: bool CompareTimestamps(
    HANDLE hFile
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::EndContentVerify Method

XenonProfile::EndContentVerify Method
XenonProfile Class
Show All
C++
public: void EndContentVerify();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::EndDelete Method

XenonProfile::EndDelete Method
XenonProfile Class
Show All
C++
public: void EndDelete();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::EndEnumeration Method

XenonProfile::EndEnumeration Method
XenonProfile Class
Show All
C++
public: void EndEnumeration();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::EndFreeSpaceCheck Method ()

XenonProfile::EndFreeSpaceCheck Method ()
XenonProfile Class
Show All
C++
public: void EndFreeSpaceCheck();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::EndFreeSpaceCheck Method (eTypeOfSpaceCheck)

XenonProfile::EndFreeSpaceCheck Method (eTypeOfSpaceCheck)
XenonProfile Class
Show All
C++
public: void EndFreeSpaceCheck(
    eTypeOfSpaceCheck SpaceCheckType
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::EndGetCreator Method

XenonProfile::EndGetCreator Method
XenonProfile Class
Show All
C++
public: void EndGetCreator();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::EndGetFileSize Method

XenonProfile::EndGetFileSize Method
XenonProfile Class
Show All
C++
public: void EndGetFileSize();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::EndIconSave Method

XenonProfile::EndIconSave Method
XenonProfile Class
Show All
C++
public: void EndIconSave();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::EndLoad Method

XenonProfile::EndLoad Method
XenonProfile Class
Show All
C++
public: void EndLoad();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::EndSave Method

XenonProfile::EndSave Method
XenonProfile Class
Show All
C++
public: void EndSave();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::EndSelectDevice Method

XenonProfile::EndSelectDevice Method
XenonProfile Class
Show All
C++
public: void EndSelectDevice();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::FillDevice Method

XenonProfile::FillDevice Method
XenonProfile Class
Show All
C++
public: void FillDevice();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::GetCurrentDeviceData Method

XenonProfile::GetCurrentDeviceData Method
XenonProfile Class
Show All
C++
public: bool GetCurrentDeviceData(
    fiSaveGame::Device * outDevice
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::GetDeviceData Method

XenonProfile::GetDeviceData Method
XenonProfile Class
Show All
C++
public: bool GetDeviceData(
    u32 deviceId,
    fiSaveGame::Device * outDevice
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::GetError Method

XenonProfile::GetError Method
XenonProfile Class
Show All
C++
public: fiSaveGame::Errors GetError();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::GetLoadSize Method

XenonProfile::GetLoadSize Method
XenonProfile Class
Show All
C++
public: u32 GetLoadSize() const;
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::GetSaveSize Method

XenonProfile::GetSaveSize Method
XenonProfile Class
Show All
C++
public: u32 GetSaveSize() const;
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::GetSelectedDevice Method

XenonProfile::GetSelectedDevice Method
XenonProfile Class
Show All
C++
public: u32 GetSelectedDevice() const;
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::GetState Method

XenonProfile::GetState Method
XenonProfile Class
Show All
C++
public: fiSaveGameState::State GetState() const;
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::GetTotalAvailableSpace Method

XenonProfile::GetTotalAvailableSpace Method
XenonProfile Class
Show All
C++
public: u64 GetTotalAvailableSpace();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::HasFileBeenAccessed Method

XenonProfile::HasFileBeenAccessed Method
XenonProfile Class
Show All
C++
public: bool HasFileBeenAccessed(
    const char* filename
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::IsCurrentDeviceValid Method

XenonProfile::IsCurrentDeviceValid Method
XenonProfile Class
Show All
C++
public: bool IsCurrentDeviceValid();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::IsDeviceValid Method

XenonProfile::IsDeviceValid Method
XenonProfile Class
Show All
C++
public: bool IsDeviceValid(
    u32 deviceId
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::IsStorageDeviceChanged Method

XenonProfile::IsStorageDeviceChanged Method
XenonProfile Class
Show All
C++
public: bool IsStorageDeviceChanged();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::IsStorageDeviceRemoved Method

XenonProfile::IsStorageDeviceRemoved Method
XenonProfile Class
Show All
C++
public: bool IsStorageDeviceRemoved();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::SetSelectedDevice Method

XenonProfile::SetSelectedDevice Method
XenonProfile Class
Show All
C++
public: void SetSelectedDevice(
    u32 deviceId
);
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::SetSelectedDeviceToAny Method

XenonProfile::SetSelectedDeviceToAny Method
XenonProfile Class
Show All
C++
public: void SetSelectedDeviceToAny();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


XenonProfile::SetStateToIdle Method

XenonProfile::SetStateToIdle Method
XenonProfile Class
Show All
C++
public: void SetStateToIdle();
Class

XenonProfile Class

File

savegame_xenon.cpp

Links
XenonProfile Class
Send comments on this topic.


zipDirEntry Struct

zipDirEntry Struct
Constructors | Destructors | Members | Methods | Data Members | rage Namespace | Inheritance Hierarchy
Show All
zipDirEntry
C++
public: struct zipDirEntry {
  public: zipDirEntry * * Next, * Child;
  public: u32 Hash;
  public: u32 Offset;
  public: u32 CompSize : 31, Compressed: 1, UncompSize;
  public: u64 FileTime;
  public: char Name[0];
};
Constructors
Constructor | Description
zipDirEntry |
Destructors
Destructor | Description
~zipDirEntry |
Methods
Method | Description
Dump |
Insert |
IsCompressed |
IsDir |
Data Members
Data Member | Description
1 |
Child |
CompSize |
FileTime | Only for files
Hash |
Name |
Next |
Offset | Only for files (zero if it's a directory)
UncompSize |
Namespace

rage Namespace

File

zipfile.cpp

Links
Constructors, Destructors, Members, Methods, Data Members, rage Namespace, Inheritance Hierarchy


zipDirEntry::1 Data Member

zipDirEntry::1 Data Member
zipDirEntry Struct
Show All
C++
public: u32 Compressed: 1 : 31;
Struct

zipDirEntry Struct

File

zipfile.cpp

Links
zipDirEntry Struct


zipDirEntry::Child Data Member

zipDirEntry::Child Data Member
zipDirEntry Struct
Show All
C++
public: zipDirEntry * Child;
Struct

zipDirEntry Struct

File

zipfile.cpp

Links
zipDirEntry Struct


zipDirEntry::CompSize Data Member

zipDirEntry::CompSize Data Member
zipDirEntry Struct
Show All
C++
public: u32 CompSize : 31;
Struct

zipDirEntry Struct

File

zipfile.cpp

Links
zipDirEntry Struct


zipDirEntry::FileTime Data Member

zipDirEntry::FileTime Data Member
zipDirEntry Struct
Show All

Only for files

C++
public: u64 FileTime;
Struct

zipDirEntry Struct

File

zipfile.cpp

Links
zipDirEntry Struct


zipDirEntry::Hash Data Member

zipDirEntry::Hash Data Member
zipDirEntry Struct
Show All
C++
public: u32 Hash;
Struct

zipDirEntry Struct

File

zipfile.cpp

Links
zipDirEntry Struct


zipDirEntry::Name Data Member

zipDirEntry::Name Data Member
zipDirEntry Struct
Show All
C++
public: char Name[0];
Struct

zipDirEntry Struct

File

zipfile.cpp

Links
zipDirEntry Struct


zipDirEntry::Next Data Member

zipDirEntry::Next Data Member
zipDirEntry Struct
Show All
C++
public: zipDirEntry * * Next;
Struct

zipDirEntry Struct

File

zipfile.cpp

Links
zipDirEntry Struct


zipDirEntry::Offset Data Member

zipDirEntry::Offset Data Member
zipDirEntry Struct
Show All

Only for files (zero if it's a directory)

C++
public: u32 Offset;
Struct

zipDirEntry Struct

File

zipfile.cpp

Links
zipDirEntry Struct


zipDirEntry::UncompSize Data Member

zipDirEntry::UncompSize Data Member
zipDirEntry Struct
Show All
C++
public: u32 UncompSize : 31;
Struct

zipDirEntry Struct

File

zipfile.cpp

Links
zipDirEntry Struct


zipDirEntry::zipDirEntry Constructor

zipDirEntry::zipDirEntry Constructor
zipDirEntry Struct
Show All
C++
public: zipDirEntry();
Struct

zipDirEntry Struct

File

zipfile.cpp

Links
zipDirEntry Struct


zipDirEntry::~zipDirEntry Destructor

zipDirEntry::~zipDirEntry Destructor
zipDirEntry Struct
Show All
C++
public: ~zipDirEntry();
Struct

zipDirEntry Struct

File

zipfile.cpp

Links
zipDirEntry Struct


zipDirEntry::Dump Method

zipDirEntry::Dump Method
zipDirEntry Struct
Show All
C++
public: static void Dump(
    zipDirEntry * entry,
    int intent
);
Struct

zipDirEntry Struct

File

zipfile.cpp

Links
zipDirEntry Struct


zipDirEntry::Insert Method

zipDirEntry::Insert Method
zipDirEntry Struct
Show All
C++
public: static void Insert(
    zipDirEntry ** nodeRef,
    const char * name,
    u32 offset,
    int compSize,
    int uncompSize,
    bool compressed,
    u64 filetime
);
Struct

zipDirEntry Struct

File

zipfile.cpp

Links
zipDirEntry Struct


zipDirEntry::IsCompressed Method

zipDirEntry::IsCompressed Method
zipDirEntry Struct
Show All
C++
public: bool IsCompressed() const;
Struct

zipDirEntry Struct

File

zipfile.cpp

Links
zipDirEntry Struct


zipDirEntry::IsDir Method

zipDirEntry::IsDir Method
zipDirEntry Struct
Show All
C++
public: bool IsDir() const;
Struct

zipDirEntry Struct

File

zipfile.cpp

Links
zipDirEntry Struct


rage::CacheHeader Struct

rage::CacheHeader Struct
rage Namespace
Show All
C++
public: struct CacheHeader {
  public: atRangeArray<Slot,CACHE_BLOCK_COUNT> Slots;
  public: atRangeArray<File,CACHE_FILE_COUNT> Files;
  public: atRangeArray<u32,CACHE_PADDING*2> Padding;
};
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::DeviceMemoryState Struct

rage::DeviceMemoryState Struct
rage Namespace
Show All
C++
public: struct DeviceMemoryState {
  public: const unsigned char * m_Storage;
  public: int m_Size;
  public: int m_Offset;
  public: bool m_FreeOnClose;
};
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::eInstallDeviceStatus Enumeration

rage::eInstallDeviceStatus Enumeration
rage Namespace
Show All

the order of these enums makes it easier to combine several results into an overall one by taking the smallest value. this will indicate what's left to wait for or the "worst" result

C++
public: enum eInstallDeviceStatus {
  public: IDS_FAILED = 0,
  public: IDS_INSTALLING,
  public: IDS_IDLE,
  public: IDS_INSTALLED
};
Namespace

rage Namespace

File

device_installer.h

Links
rage Namespace


rage::EncoderState Struct

rage::EncoderState Struct
rage Namespace
Show All
C++
public: struct EncoderState {
  public: u32 m_Accum;
  public: u32 m_NextAccum;
  public: u32 m_Offset;
  public: u8 * m_Output;
  public: u32 m_OutputSize;
};
Namespace

rage Namespace

File

ficompress.cpp

Links
rage Namespace


rage::eTypeOfSaveProcess Enumeration

rage::eTypeOfSaveProcess Enumeration
rage Namespace
Show All

Changelist 130919 by Graeme Added ExtraSpaceCheck. It's almost identical to FreeSpaceCheck but gives a bit more information that I require when checking if there is enough space for save games and a profile file at the start of a PS3 game.

C++
public: enum eTypeOfSaveProcess {
  public: CHECK_FOR_FREE_SPACE_FOR_THIS_FILE,
  public: CHECK_FOR_EXTRA_SPACE_FOR_THIS_FILE,
  public: SAVE_THIS_FILE
};
Members

CHECK_FOR_FREE_SPACE_FOR_THIS_FILE
Returns (hddFreeSizeKB - space required to save this file)
CHECK_FOR_EXTRA_SPACE_FOR_THIS_FILE
Returns hddFreeSizeKB and space required to save this file

Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::eTypeOfSpaceCheck Enumeration

rage::eTypeOfSpaceCheck Enumeration
rage Namespace
Show All

Changelist 130919 by Graeme - Added ExtraSpaceCheck. It's almost identical to FreeSpaceCheck but gives a bit more information that I require when checking if there is enough space for 13 save games and a profile file at the start of a PS3 game.

C++
public: enum eTypeOfSpaceCheck {
  public: FREE_SPACE_CHECK,
  public: EXTRA_SPACE_CHECK
};
Namespace

rage Namespace

File

savegame_xenon.cpp

Links
rage Namespace


rage::fiFindData Struct

rage::fiFindData Struct
rage Namespace
Show All

Structure returned by FindFileBegin / FindFileNext

C++
public: struct fiFindData {
  public: char m_Name[RAGE_MAX_PATH];
  public: u64 m_Size;
  public: u64 m_LastWriteTime;
  public: u32 m_Attributes;
};
Members

m_Name
Name of the file
m_Size
Size of the file
m_LastWriteTime
Last time the file was written
m_Attributes
Bitfield using the FILE_ATTRIBUTE_... values

Namespace

rage Namespace

File

device.h

Links
rage Namespace


rage::File Struct

rage::File Struct
rage Namespace
Show All
C++
public: struct File {
  public: u32 namehash;
  public: u32 sizetimehash;
};
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::fiPackHeader Struct

rage::fiPackHeader Struct
rage Namespace
Show All

Little-endian

C++
public: struct fiPackHeader {
  public: u32 m_Magic;
  public: u32 m_EntryCount;
  public: u32 m_NameHeapSize;
  public: u32 m_Encrypted;
};
Members

m_Magic
RPF7
m_EntryCount
number of fiPackEntry7 structures (immediately after this header)
m_NameHeapSize
Size allocated for name heap (always a multiple of 16, immediately after entries, can be up to 512k now)
m_Encrypted
AES encryption key id. Key is project-specific.

Namespace

rage Namespace

File

packfile.h

Links
rage Namespace


rage::fiRemoteDirEntry Struct

rage::fiRemoteDirEntry Struct
rage Namespace
Show All
C++
public: struct fiRemoteDirEntry {
  public: char m_Filename[96];
  public: u32 m_Attribute;
  public: u64 m_Filesize;
  public: u64 m_VirtSize;
  public: u64 m_PhysSize;
  public: datResourceFileHeader m_ResourceFileHeader;
};
Namespace

rage Namespace

File

device.h

Links
rage Namespace


rage::fiSeekWhence Enumeration

rage::fiSeekWhence Enumeration
rage Namespace
Show All

Enumerant passed to fiDevice::Seek which determines the origin (start point) of the seek operation

C++
public: enum fiSeekWhence {
  public: seekSet,
  public: seekCur,
  public: seekEnd
};
Members

seekSet
Position is relative to start of file
seekCur
Position is relative to current file position (can be negative)
seekEnd
Position is relative to end of file. Reliable operation is only guaranteed if pos is zero or negative

Namespace

rage Namespace

File

device.h

Links
rage Namespace


rage::node Struct

rage::node Struct
rage Namespace
Show All
C++
public: struct node {
  public: u32 offset;
  public: node * next;
};
Members

offset
offset of the two leader bytes
next
pointer to next node

Namespace

rage Namespace

File

ficompress.cpp

Links
rage Namespace


rage::sInstallProgress Struct

rage::sInstallProgress Struct
rage Namespace
Show All
C++
public: struct sInstallProgress {
  public: float fileTransferredSize;
  public: float fileSize;
  public: float totalTransferredSize;
  public: float totalSize;
  public: const char* currentFile;
  public: float readThroughput;
  public: float writeThroughput;
  public: float readWaited;
  public: float writeWaited;
  public: float remoteWaited;
  public: float totalTime;
};
Members

fileTransferredSize
in MB

Namespace

rage Namespace

File

device_installer.h

Links
rage Namespace


rage::Slot Struct

rage::Slot Struct
rage Namespace
Show All

Entry zero is actually the file header.

C++
public: struct Slot {
public:
  private: union {
public:
    private: struct {
      public: u32 srcBlock : 24, state: 4, state: 4;
    };
    public: u32 magic;
  };
  public: u16 older, newer;
};
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::atou Function

rage::atou Function
rage Namespace
Show All

Some addresses have their sign bit set, and atoi on Xenon at least will clamp!

C++
unsigned char* atou(
    const char * s
);
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::CompileTimeAssertSize Function

rage::CompileTimeAssertSize Function
rage Namespace
Show All
C++
CompileTimeAssertSize(
    datResourceFileHeader,
    16,
    16
);
Namespace

rage Namespace

File

packfile_builder.cpp

Links
rage Namespace


rage::fgetline Function

rage::fgetline Function
rage Namespace
Show All

Like fgets, but strips off whitespace at end of line

C++
int fgetline(
    char*,
    int,
    fiStream*
);
Returns

Count of characters stored, or 0 on EOF. Will silently consume empty lines.

Namespace

rage Namespace

File

stream.h

Links
rage Namespace


rage::fgets Function

rage::fgets Function
rage Namespace
Show All
C++
int fgets(
    char *,
    int,
    fiStream*
);
Namespace

rage Namespace

File

stream.h

Links
rage Namespace


rage::fiCompress Function

rage::fiCompress Function
rage Namespace
Show All

PURPOSE Compress data using a sliding window algorithm PARAMS dest - Destination buffer destSize - Size of destination buffer; should be slightly larger than input for worse-case. Adding 1k should be sufficient. src - Source buffer (data to compress) srcSize - Amount of data to compress lookback - Maximum lookback (log2). 15 or 16 is pretty fast and still yields very good results. fullUpdate - If true, does more exhaustive table update which is substantially more expensive but improves compression by about 10% or so. Varies by data. RETURNS Number of bytes written to destination buffer. If this is greater than or equal to srcSize, calling code should assume the compression failed (common with very small datasets)

C++
u32 fiCompress(
    u8 * dest,
    u32 destSize,
    const u8 * src,
    u32 srcSize,
    u32 lookback,
    bool fullUpdate
);
Namespace

rage Namespace

File

compress.h

Links
rage Namespace


rage::fiCompressUpperBound Function

rage::fiCompressUpperBound Function
rage Namespace
Show All

PURPOSE Compute a reasonable upper bound on the compression space needed PARAMS srcSize - Size of source buffer RETURNS Estimated upper bound (for use in fiCompress destSize)

C++
u32 fiCompressUpperBound(
    u32 srcSize
);
Namespace

rage Namespace

File

compress.h

Links
rage Namespace


rage::fiDecompress Function

rage::fiDecompress Function
rage Namespace
Show All

PURPOSE Decompress data compressed with fiCompress PARAMS dest - Output buffer destSize - size of output buffer src - Compressed data stream srcSize - Size of input compressed data stream RETURNS True if decompression was successful, or false on failure (due to bad input data). Should never crash on malformed inputs.

C++
bool fiDecompress(
    u8 * dest,
    u32 destSize,
    const u8 * src,
    u32 srcSize
);
Notes

The data format is defined as a series of blocks (calling code is assumed to know the uncompressed length of the data as that is our termination condition).

Each block starts with a length encoding: 1 -> 1 000 -> 2 001 -> 3 010 -> 4 0110xxxxxx -> 5-68 (field width is c_InitialWidth+c_WidthStep=6) 01110xxxxxxxxxx -> 69...1092 (field width is c_InitialWidth+2*c_WidthStep=10) 011110xxxxxxxxxx -> 1093... Each extra "1" after the initial 011 causes the field width (which starts at c_InitialWidth+c_WidthStep) to be extended by c_WidthStep more bits. The list of ones is terminated by a zero, followed by the field width. Note that each additional "1" also affects the bias of the field so that there is no redundancy (and therefore wasted space) in the representable length range.

Next a single type bit identifies the block as either a literal run or a window.

If the type bit is one, the block is a window, and the lookback value is encoded in a similar fashion to above: 0xx -> 1,2,3,4 (when c_InitialWidth=2) 10xxxxxx = 5-68 (and rest is as above). We copy "length+1" bytes from "lookback" bytes before the current output position forward into the output buffer. Note that this gives us trivial RLE (or pattern replication) when the length is longer than the lookback value.

If the type bit is zero, the block is a literal run, and "length" bytes of data are pulled from the source compressed stream and copied into the output.

Note that encodings of small values is different for lengths and lookback values; this is because a length value of one is very common, so we special-case it at the expense of runs bits or longer.

Some test data: 476193 byte text file compressed to 48058 bytes (versus 69501 bytes for zip) 56.25M resource file compressed to 8.63M bytes (versus 27.72M for zip)

8323316 bytes with max lookback of 1M, with proper update (very slow). 8898722 bytes with max loolback of 1M, no proper update (pretty quick -- 17.41 seconds) 8277993 bytes with max lookback of 64k, with proper update. 9035189 bytes with max lookback of 64k, no proper update (5 seconds)

9,035,189 output.dev (64k lookback) 8,608,704 output.rel.16M 8,191,677 output.rel.16M.full_lookback_update 8,898,723 output.rel.1M 8,323,317 output.rel.1M.full_lookback_update

I suspect we handily beat zip on very large files because we basically have unbounded lookup, so relatively long chains can be recycled cheaply.

Todo
  • Consider more permutations of c_InitialWidth and c_WidthStep, possibly using different values between lengths and offsets.
  • Consider compressing a file with several different permutations and then making a few of those parameters stored in the file itself and configurable during decompression setup.
Namespace

rage Namespace

File

decompress.h

Links
rage Namespace


rage::fiFtpServer Function

rage::fiFtpServer Function
rage Namespace
Show All
C++
void fiFtpServer(
    void* unused
);
Namespace

rage Namespace

File

ftpserver.h

Links
rage Namespace


rage::fiGetFramesSinceLastMessageBox Function

rage::fiGetFramesSinceLastMessageBox Function
rage Namespace
Show All

Return the number of frames since a message box was shown the last time.

C++
unsigned fiGetFramesSinceLastMessageBox();
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::fiLaunchFtpServerThread Function

rage::fiLaunchFtpServerThread Function
rage Namespace
Show All

Launch a thread that runs fiFtpServer

C++
void fiLaunchFtpServerThread();
Namespace

rage Namespace

File

ftpserver.h

Links
rage Namespace


rage::fiRemoteExec Function

rage::fiRemoteExec Function
rage Namespace
Show All

Invoke a process; use sysExec instead of this directly.

C++
int fiRemoteExec(
    const char * commandLine
);
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::fiRemoteGetEnv Function

rage::fiRemoteGetEnv Function
rage Namespace
Show All

Get env var; use sysGetEnv instead of this directly.

C++
int fiRemoteGetEnv(
    const char * env,
    char * dest,
    int destSize
);
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::fiRemoteResetFiles Function

rage::fiRemoteResetFiles Function
rage Namespace
Show All

Reset all open files; intended only for use by rfs itself.

C++
void fiRemoteResetFiles();
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::fiRemoteServer Function

rage::fiRemoteServer Function
rage Namespace
Show All

Install a remote file server on specified port

C++
void fiRemoteServer(
    int port,
    const char * ip
);
Parameters

port
Port number to install
ip
ip address to install on (or NULL for default)

Notes

This is generally running on a PC.

Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::fiRemoteShowAssertMessageBox Function

rage::fiRemoteShowAssertMessageBox Function
rage Namespace
Show All

Shows a message box with the option of logging a bug on the remote PC (as per Win32 API MessageBox call)

C++
unsigned fiRemoteShowAssertMessageBox(
    const char * message,
    const char * title,
    unsigned flags,
    unsigned defaultAnswer
);
Parameters

message
Contents of the message
title
Title of the message box
flags
MB_... flags as per Win32 API
defaultAnswer
Answer to return if the message box could not or should not be displayed

Returns

As per Win32 API (generally one of the MB_... button defines)

Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::fiRemoteShowMessageBox Function

rage::fiRemoteShowMessageBox Function
rage Namespace
Show All

Shows a message box on the remote PC (as per Win32 API MessageBox call)

C++
unsigned fiRemoteShowMessageBox(
    const char * message,
    const char * title,
    unsigned flags,
    unsigned defaultAnswer
);
Parameters

message
Contents of the message
title
Title of the message box
flags
MB_... flags as per Win32 API
defaultAnswer
Answer to return if the message box could not or should not be displayed

Returns

As per Win32 API (generally one of the MB_... button defines)

Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::fiRemoteTty Function

rage::fiRemoteTty Function
rage Namespace
Show All

Send remote tty.

C++
int fiRemoteTty(
    const char* msg
);
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::FlushCacheHeader Function

rage::FlushCacheHeader Function
rage Namespace
Show All
C++
static void FlushCacheHeader();
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::fprintf Function

rage::fprintf Function
rage Namespace
Show All
C++
void fprintf(
    fiStream*,
    const char*,
    ...
);
Namespace

rage Namespace

File

stream.h

Links
rage Namespace


rage::fseek Function

rage::fseek Function
rage Namespace
Show All

extern fiStream* fopen(char *,char *);

C++
int fseek(
    fiStream *,
    int,
    int
);
Namespace

rage Namespace

File

stream.h

Links
rage Namespace


rage::GetDisplayName Function

rage::GetDisplayName Function
rage Namespace
Show All
C++
bool GetDisplayName(
    u32 signInId,
    char16 (&outDisplayName)[MAX_DISPLAY_NAME],
    const char* fileName
);
Namespace

rage Namespace

File

savegame_pc.cpp

Links
rage Namespace


rage::GetSaveFilePath Function

rage::GetSaveFilePath Function
rage Namespace
Show All
C++
bool GetSaveFilePath(
    u32 signInId,
    char (&path)[RAGE_MAX_PATH],
    const char* strFileName
);
Namespace

rage Namespace

File

savegame_pc.cpp

Links
rage Namespace


rage::MakeNewest Function

rage::MakeNewest Function
rage Namespace
Show All
C++
static void MakeNewest(
    u32
);
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::MakeOldest Function

rage::MakeOldest Function
rage Namespace
Show All
C++
static void MakeOldest(
    u32
);
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::NOSTRIP_PARAM Function

rage::NOSTRIP_PARAM Function
rage Namespace
Show All
C++
NOSTRIP_PARAM(
    clearhddcache,
    "Force console disk cache to be cleared"
);
Namespace

rage Namespace

File

cachepartition.cpp

Links
rage Namespace


rage::NOSTRIP_PARAM Function

rage::NOSTRIP_PARAM Function
rage Namespace
Show All
C++
NOSTRIP_PARAM(
    xboxSecureNetworking,
    "If present use xbox secure networking ***RFS WON'T WORK***"
);
Namespace

rage Namespace

File

winsock.cpp

Links
rage Namespace


rage::NOSTRIP_XPARAM Function

rage::NOSTRIP_XPARAM Function
rage Namespace
Show All
C++
NOSTRIP_XPARAM(
    clearhddcache
);
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::Quitf Function

rage::Quitf Function
rage Namespace
Show All
C++
Quitf(
    "Mistake in logic of XenonProfile::CheckFreeSpaceCheck - should have hit a return before reaching the end of the function"
);
Namespace

rage Namespace

File

savegame_xenon.cpp

Links
rage Namespace


rage::ResetCache Function

rage::ResetCache Function
rage Namespace
Show All
C++
static void ResetCache();
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::StringLength Function

rage::StringLength Function
rage Namespace
Show All

lint !e18

C++
int StringLength(
    const char*
);
Namespace

rage Namespace

File

stream.h

Links
rage Namespace


rage::StreamCloseCallback Type

rage::StreamCloseCallback Type
rage Namespace
Show All
C++
typedef void (* StreamCloseCallback)(const char *filename);
Namespace

rage Namespace

File

stream.h

Links
rage Namespace


rage::StreamCreateCallback Type

rage::StreamCreateCallback Type
rage Namespace
Show All
C++
typedef bool (* StreamCreateCallback)(const char *filename);
Namespace

rage Namespace

File

stream.h

Links
rage Namespace


rage::StreamOpenCallback Type

rage::StreamOpenCallback Type
rage Namespace
Show All
C++
typedef bool (* StreamOpenCallback)(const char *filename,bool readonly);
Namespace

rage Namespace

File

stream.h

Links
rage Namespace


rage::ASSET Variable

rage::ASSET Variable
rage Namespace
Show All
C++
fiAssetManager ASSET;
Namespace

rage Namespace

File

asset.h

Links
rage Namespace


rage::CACHE_BLOCK_COUNT Variable

rage::CACHE_BLOCK_COUNT Variable
rage Namespace
Show All

Slot zero is used for magic and linked list. Because of max size limits on PS3, this cannot be 4096.

C++
const u32 CACHE_BLOCK_COUNT = CACHE_BLOCK_MAX - CACHE_FILE_COUNT - CACHE_PADDING;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::CACHE_BLOCK_MASK Variable

rage::CACHE_BLOCK_MASK Variable
rage Namespace
Show All
C++
const u32 CACHE_BLOCK_MASK = (CACHE_BLOCK_SIZE-1);
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::CACHE_BLOCK_MAX Variable

rage::CACHE_BLOCK_MAX Variable
rage Namespace
Show All
C++
const u32 CACHE_BLOCK_MAX = __XENON? 256 : 1024;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::CACHE_BLOCK_SHIFT Variable

rage::CACHE_BLOCK_SHIFT Variable
rage Namespace
Show All

Note that FlushCacheHeader creates a structure roughly 8*CACHE_BLOCK_MAX on the stack so we need to watch the size.

C++
const u32 CACHE_BLOCK_SHIFT = __XENON? 23 : 21;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::CACHE_BLOCK_SIZE Variable

rage::CACHE_BLOCK_SIZE Variable
rage Namespace
Show All
C++
const u32 CACHE_BLOCK_SIZE = (1<<CACHE_BLOCK_SHIFT);
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::CACHE_FILE_BLOCK_COUNT Variable

rage::CACHE_FILE_BLOCK_COUNT Variable
rage Namespace
Show All
C++
const u64 CACHE_FILE_BLOCK_COUNT = 1 << ((__XENON? 32 : 33) - CACHE_BLOCK_SHIFT);
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::CACHE_FILE_COUNT Variable

rage::CACHE_FILE_COUNT Variable
rage Namespace
Show All
C++
const u32 CACHE_FILE_COUNT = __XENON? 2 : 1;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::CACHE_FILE_HEADER_SIZE Variable

rage::CACHE_FILE_HEADER_SIZE Variable
rage Namespace
Show All
C++
const u32 CACHE_FILE_HEADER_SIZE = sizeof(CacheHeader);
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::CACHE_FILE_MAGIC Variable

rage::CACHE_FILE_MAGIC Variable
rage Namespace
Show All

Change this magic number (last digit) if you make any structural or semantic changes to the s_Header. In particular, changing either CACHE_BLOCK_COUNT, CACHE_BLOCK_SHIFT, CACHE_FILE_COUNT, or CACHE_FILE_SHIFT require a new magic number to avoid crashing on old cache files.

C++
const u32 CACHE_FILE_MAGIC = 'R*$8';
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::CACHE_FILE_SIZE Variable

rage::CACHE_FILE_SIZE Variable
rage Namespace
Show All
C++
const u32 CACHE_FILE_SIZE = CACHE_FILE_HEADER_SIZE + (CACHE_BLOCK_COUNT-1) * CACHE_BLOCK_SIZE;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::CACHE_FILE_VERSION Variable

rage::CACHE_FILE_VERSION Variable
rage Namespace
Show All
C++
u32 CACHE_FILE_VERSION;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::CACHE_PADDING Variable

rage::CACHE_PADDING Variable
rage Namespace
Show All
C++
const u32 CACHE_PADDING = 128 - CACHE_FILE_COUNT;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::CACHE_SUBFILE_COUNT Variable

rage::CACHE_SUBFILE_COUNT Variable
rage Namespace
Show All

number of cache files

C++
const u32 CACHE_SUBFILE_COUNT = 256;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::CACHE_SUBFILE_MASK Variable

rage::CACHE_SUBFILE_MASK Variable
rage Namespace
Show All
C++
const u32 CACHE_SUBFILE_MASK = (1 << CACHE_SUBFILE_SHIFT) - 1;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::CACHE_SUBFILE_SHIFT Variable

rage::CACHE_SUBFILE_SHIFT Variable
rage Namespace
Show All

number of bits per cache file

C++
const u32 CACHE_SUBFILE_SHIFT = 0;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::CENTINANOSECONDS_PER_SECOND Variable

rage::CENTINANOSECONDS_PER_SECOND Variable
rage Namespace
Show All
C++
static const u64 CENTINANOSECONDS_PER_SECOND = 10000000ULL;
Namespace

rage Namespace

File

packfile.cpp

Links
rage Namespace


rage::fiIsShowingMessageBox Variable

rage::fiIsShowingMessageBox Variable
rage Namespace
Show All

Indicates whether a message box is currently being displayed or not (useful for avoiding timeouts)

C++
volatile unsigned int fiIsShowingMessageBox;
Namespace

rage Namespace

File

remote.cpp

Links
rage Namespace


rage::FileName Variable

rage::FileName Variable
rage Namespace
Show All
C++
const char FileName[CELL_SAVEDATA_FILENAME_SIZE] = "RAGE.SAV";
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::FILETIME_2000 Variable

rage::FILETIME_2000 Variable
rage Namespace
Show All

#include #include #include void main() { SYSTEMTIME _2000 = { 2000, 1, 0, 1, 0, 0, 0, 0 }; unsigned __int64 ft; SystemTimeToFileTime(&_2000, (FILETIME*)&ft); char buffer[100]; _ui64toa(ft,buffer,10); printf("filetime of 2000 %sn",buffer); }

Seconds since January 1, 2000 gives us a reach of 136 years.

C++
static const u64 FILETIME_2000 = 125911584000000000ULL;
Namespace

rage Namespace

File

packfile.cpp

Links
rage Namespace


rage::fiRemoteServerIsRunning Variable

rage::fiRemoteServerIsRunning Variable
rage Namespace
Show All

Indicates whether rfs is properly installed or not; valid after fiDeviceRemote::InitClass is called.

C++
bool fiRemoteServerIsRunning;
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::g_AES Variable

rage::g_AES Variable
rage Namespace
Show All
C++
AES * g_AES;
Namespace

rage Namespace

File

packfile.cpp

Links
rage Namespace


rage::g_enumeratedContent Variable

rage::g_enumeratedContent Variable
rage Namespace
Show All
C++
static XCONTENT_DATA g_enumeratedContent[MAX_XCONTENT_HANDLES];
Namespace

rage Namespace

File

device_installer.cpp

Links
rage Namespace


rage::g_fiCaseSensitive Variable

rage::g_fiCaseSensitive Variable
rage Namespace
Show All
C++
bool g_fiCaseSensitive = false;
Namespace

rage Namespace

File

device_win32.cpp

Links
rage Namespace


rage::g_IsExiting Variable

rage::g_IsExiting Variable
rage Namespace
Show All
C++
bool g_IsExiting = false;
Namespace

rage Namespace

File

device_psn.cpp

Links
rage Namespace


rage::g_numContent Variable

rage::g_numContent Variable
rage Namespace
Show All
C++
static DWORD g_numContent = 0;
Namespace

rage Namespace

File

device_installer.cpp

Links
rage Namespace


rage::g_SaveGameState Variable

rage::g_SaveGameState Variable
rage Namespace
Show All

Changelist 129860 by Adam Implemented savegame state and also assert on calling the wrong functions based on what the savegame state is

C++
fiSaveGameState::State g_SaveGameState = fiSaveGameState::IDLE;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::gExitThread Variable

rage::gExitThread Variable
rage Namespace
Show All
C++
bool gExitThread = false;
Namespace

rage Namespace

File

device_installer.cpp

Links
rage Namespace


rage::info_table Variable

rage::info_table Variable
rage Namespace
Show All
C++
static struct sys_net_sockinfo_ex info_table[256];
Namespace

rage Namespace

File

tcpip_psn.cpp

Links
rage Namespace


rage::m_State Variable

rage::m_State Variable
rage Namespace
Show All
C++
static fiSaveGameState::State m_State = fiSaveGameState::IDLE;
Namespace

rage Namespace

File

savegame_pc.cpp

Links
rage Namespace


rage::MAX_RPFS Variable

rage::MAX_RPFS Variable
rage Namespace
Show All
C++
static const s32 MAX_RPFS = 240;
Namespace

rage Namespace

File

device_installer.cpp

Links
rage Namespace


rage::maxMem Variable

rage::maxMem Variable
rage Namespace
Show All
C++
const int maxMem = 16;
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::MaxPackfiles Variable

rage::MaxPackfiles Variable
rage Namespace
Show All

If we raise this past 256 we'll need to decrement fiCollection::ArchiveShift again.

C++
const int MaxPackfiles = 1024+256;
Namespace

rage Namespace

File

packfile.cpp

Links
rage Namespace


rage::messageToken Variable

rage::messageToken Variable
rage Namespace
Show All
C++
static sysCriticalSectionToken messageToken;
Namespace

rage Namespace

File

remote.cpp

Links
rage Namespace


rage::nameheap Variable

rage::nameheap Variable
rage Namespace
Show All
C++
static const char * nameheap;
Namespace

rage Namespace

File

packfile_builder.cpp

Links
rage Namespace


rage::nameshift Variable

rage::nameshift Variable
rage Namespace
Show All
C++
static int nameshift;
Namespace

rage Namespace

File

packfile_builder.cpp

Links
rage Namespace


rage::pgStreamingLog Variable

rage::pgStreamingLog Variable
rage Namespace
Show All
C++
fiStream * pgStreamingLog;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::pgStreamingLogToken Variable

rage::pgStreamingLogToken Variable
rage Namespace
Show All
C++
sysCriticalSectionToken pgStreamingLogToken;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::pIconImage Variable

rage::pIconImage Variable
rage Namespace
Show All
C++
char * pIconImage = NULL;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::RAGE_MAX_PATH Variable

rage::RAGE_MAX_PATH Variable
rage Namespace
Show All

Maximum length of a path, including the terminating NUL character.

C++
const int RAGE_MAX_PATH = 256;
Namespace

rage Namespace

File

limits.h

Links
rage Namespace


rage::s_bCalculateSizeOnDisk Variable

rage::s_bCalculateSizeOnDisk Variable
rage Namespace
Show All
C++
static bool s_bCalculateSizeOnDisk = false;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_bCheckForUserBindErrors Variable

rage::s_bCheckForUserBindErrors Variable
rage Namespace
Show All
C++
static bool s_bCheckForUserBindErrors = false;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_bCheckingForFreeSpace Variable

rage::s_bCheckingForFreeSpace Variable
rage Namespace
Show All

HACK_GTA4

C++
static bool s_bCheckingForFreeSpace = false;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_bFileMissing Variable

rage::s_bFileMissing Variable
rage Namespace
Show All

MP3MOD

C++
static bool s_bFileMissing = false, s_bFileCorrupt = false;
Namespace

rage Namespace

File

savegame_pc.cpp

Links
rage Namespace


rage::s_bHasCreator Variable

rage::s_bHasCreator Variable
rage Namespace
Show All
C++
static bool s_bHasCreator;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_bIsCreator Variable

rage::s_bIsCreator Variable
rage Namespace
Show All
C++
static bool s_bIsCreator;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_CacheBlockFiles Variable

rage::s_CacheBlockFiles Variable
rage Namespace
Show All
C++
static atRangeArray<fiHandle,CACHE_SUBFILE_COUNT> s_CacheBlockFiles;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_CachedDevices Variable

rage::s_CachedDevices Variable
rage Namespace
Show All

Final builds always have monolithic rpfs. Other builds may have more.

C++
atRangeArray<fiCachedDevice,CACHE_FILE_COUNT> s_CachedDevices;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_CacheFile Variable

rage::s_CacheFile Variable
rage Namespace
Show All
C++
static fiHandle s_CacheFile = fiHandleInvalid;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_CachePath Variable

rage::s_CachePath Variable
rage Namespace
Show All

typically /dev_hdd1 but we're not supposed to count on that.

C++
static char s_CachePath[32] = { "c:/cache_drive/" };
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_CacheWorkerThread Variable

rage::s_CacheWorkerThread Variable
rage Namespace
Show All
C++
static sysIpcThreadId s_CacheWorkerThread = sysIpcThreadIdInvalid;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_Container Variable

rage::s_Container Variable
rage Namespace
Show All
C++
const u32 s_Container = SYS_MEMORY_CONTAINER_ID_INVALID;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_Content Variable

rage::s_Content Variable
rage Namespace
Show All
C++
static fiSaveGame::Content * s_Content;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_ContentMax Variable

rage::s_ContentMax Variable
rage Namespace
Show All
C++
static int s_ContentMax;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_count Variable

rage::s_count Variable
rage Namespace
Show All
C++
static int s_count = 0;
Namespace

rage Namespace

File

tcpip_psn.cpp

Links
rage Namespace


rage::s_Counts Variable

rage::s_Counts Variable
rage Namespace
Show All
C++
static atRangeArray<int,fiSaveGame::SIGNIN_COUNT> s_Counts;
Namespace

rage Namespace

File

savegame_dummy.cpp

Links
rage Namespace


rage::s_Data Variable

rage::s_Data Variable
rage Namespace
Show All
C++
static void * s_Data;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_DataSize Variable

rage::s_DataSize Variable
rage Namespace
Show All
C++
static u32 s_DataSize;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_DefaultDevice Variable

rage::s_DefaultDevice Variable
rage Namespace
Show All
C++
const fiDevice* s_DefaultDevice = &s_DeviceLocal;
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::s_DefaultDeviceReadOnly Variable

rage::s_DefaultDeviceReadOnly Variable
rage Namespace
Show All
C++
static bool s_DefaultDeviceReadOnly = false;
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::s_Device Variable

rage::s_Device Variable
rage Namespace
Show All
C++
static const fiDevice* s_Device = NULL;
Namespace

rage Namespace

File

savegame_pc.cpp

Links
rage Namespace


rage::s_DeviceCount Variable

rage::s_DeviceCount Variable
rage Namespace
Show All
C++
static fiDeviceCount s_DeviceCount;
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::s_DeviceGrowBuffer Variable

rage::s_DeviceGrowBuffer Variable
rage Namespace
Show All
C++
static fiDeviceGrowBuffer s_DeviceGrowBuffer;
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::s_DeviceLocal Variable

rage::s_DeviceLocal Variable
rage Namespace
Show All
C++
fiDeviceLocal s_DeviceLocal;
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::s_DeviceMemory Variable

rage::s_DeviceMemory Variable
rage Namespace
Show All
C++
static fiDeviceMemory s_DeviceMemory;
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::s_DeviceUpdateDebug Variable

rage::s_DeviceUpdateDebug Variable
rage Namespace
Show All
C++
fiDeviceRelative s_DeviceUpdateDebug;
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::s_DirName Variable

rage::s_DirName Variable
rage Namespace
Show All
C++
static char s_DirName[CELL_SAVEDATA_DIRNAME_SIZE];
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_DisplayName Variable

rage::s_DisplayName Variable
rage Namespace
Show All
C++
static char s_DisplayName[CELL_SAVEDATA_SYSP_SUBTITLE_SIZE];
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_Done Variable

rage::s_Done Variable
rage Namespace
Show All
C++
static volatile bool s_Done;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_DummyProfiler Variable

rage::s_DummyProfiler Variable
rage Namespace
Show All
C++
static fiDeviceProfiler s_DummyProfiler;
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::s_EnumCount Variable

rage::s_EnumCount Variable
rage Namespace
Show All
C++
static volatile int s_EnumCount;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_eSaveProcessToPerform Variable

rage::s_eSaveProcessToPerform Variable
rage Namespace
Show All
C++
static eTypeOfSaveProcess s_eSaveProcessToPerform = SAVE_THIS_FILE;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_FileExists Variable

rage::s_FileExists Variable
rage Namespace
Show All
C++
static volatile bool s_FileExists;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_FilenameBuf Variable

rage::s_FilenameBuf Variable
rage Namespace
Show All
C++
static char s_FilenameBuf[CELL_SAVEDATA_FILENAME_SIZE];
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_FileProgress Variable

rage::s_FileProgress Variable
rage Namespace
Show All
C++
u32 s_FileProgress = 0;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_fileSize Variable

rage::s_fileSize Variable
rage Namespace
Show All
C++
static u64 s_fileSize;
Namespace

rage Namespace

File

savegame_pc.cpp

Links
rage Namespace


rage::s_FileSize Variable

rage::s_FileSize Variable
rage Namespace
Show All
C++
static int s_FileSize = 0;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_filetime Variable

rage::s_filetime Variable
rage Namespace
Show All

in seconds

C++
static u64 s_filetime;
Namespace

rage Namespace

File

savegame_pc.cpp

Links
rage Namespace


rage::s_Handle Variable

rage::s_Handle Variable
rage Namespace
Show All
C++
static fiHandle s_Handle = NULL;
Namespace

rage Namespace

File

savegame_pc.cpp

Links
rage Namespace


rage::s_hddFreeSizeKB Variable

rage::s_hddFreeSizeKB Variable
rage Namespace
Show All

HACK_GTA4

C++
static u64 s_hddFreeSizeKB = 0;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_Header Variable

rage::s_Header Variable
rage Namespace
Show All
C++
static CacheHeader * s_Header;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_Header_CritSec Variable

rage::s_Header_CritSec Variable
rage Namespace
Show All
C++
static sysCriticalSectionToken s_Header_CritSec;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_HoldoffDelta Variable

rage::s_HoldoffDelta Variable
rage Namespace
Show All
C++
static volatile utimer_t s_HoldoffDelta;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_HoldoffTime Variable

rage::s_HoldoffTime Variable
rage Namespace
Show All
C++
static int s_HoldoffTime;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_IsCachePrimed Variable

rage::s_IsCachePrimed Variable
rage Namespace
Show All

Assume the cache is primed if you never called fiDiskCache::InitClass, so that normal (non-megarpf) development will still get random start screens, etc.

C++
static bool s_IsCachePrimed = true;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_IsValid Variable

rage::s_IsValid Variable
rage Namespace
Show All
C++
static volatile bool s_IsValid;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_LastError Variable

rage::s_LastError Variable
rage Namespace
Show All
C++
static int s_LastError = CELL_SAVEDATA_RET_OK;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_lastErrorCode Variable

rage::s_lastErrorCode Variable
rage Namespace
Show All
C++
static int s_lastErrorCode = -1;
Namespace

rage Namespace

File

tcpip_psn.cpp

Links
rage Namespace


rage::s_LastThreadOwner Variable

rage::s_LastThreadOwner Variable
rage Namespace
Show All
C++
static const char * s_LastThreadOwner;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_Loads Variable

rage::s_Loads Variable
rage Namespace
Show All
C++
static atRangeArray<u32,fiSaveGame::SIGNIN_COUNT> s_Loads;
Namespace

rage Namespace

File

savegame_dummy.cpp

Links
rage Namespace


rage::s_LocalHost Variable

rage::s_LocalHost Variable
rage Namespace
Show All
C++
static char s_LocalHost[64] = "localhost";
Namespace

rage Namespace

File

tcpip_common.cpp

Links
rage Namespace


rage::s_location Variable

rage::s_location Variable
rage Namespace
Show All
C++
static const char* s_location = NULL;
Namespace

rage Namespace

File

tcpip_psn.cpp

Links
rage Namespace


rage::s_MaxNumberOfDirectories Variable

rage::s_MaxNumberOfDirectories Variable
rage Namespace
Show All
C++
static int s_MaxNumberOfDirectories = 16;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_MemoryState Variable

rage::s_MemoryState Variable
rage Namespace
Show All
C++
public: struct DeviceMemoryState {
  public: const unsigned char * m_Storage;
  public: int m_Size;
  public: int m_Offset;
  public: bool m_FreeOnClose;
} s_MemoryState[maxMem];
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::s_ModifiedTimeHigh Variable

rage::s_ModifiedTimeHigh Variable
rage Namespace
Show All
C++
static u32 s_ModifiedTimeHigh = 0;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_ModifiedTimeLow Variable

rage::s_ModifiedTimeLow Variable
rage Namespace
Show All
C++
static u32 s_ModifiedTimeLow = 0;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_Mounts Variable

rage::s_Mounts Variable
rage Namespace
Show All
C++
static atArray<Mount_t> s_Mounts;
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::s_netError Variable

rage::s_netError Variable
rage Namespace
Show All

see

C++
static const char* s_netError[] = { "UNKNOWN ERROR", "SYS_NET_EPERM", "SYS_NET_ENOENT", "SYS_NET_ESRCH", "SYS_NET_EINTR", "SYS_NET_EIO", "SYS_NET_ENXIO", "SYS_NET_E2BIG", "SYS_NET_ENOEXEC", "SYS_NET_EBADF", "SYS_NET_ECHILD", "SYS_NET_EDEADLK", "SYS_NET_ENOMEM", "SYS_NET_EACCES", "SYS_NET_EFAULT", "SYS_NET_ENOTBLK", "SYS_NET_EBUSY", "SYS_NET_EEXIST", "SYS_NET_EXDEV", "SYS_NET_ENODEV", "SYS_NET_ENOTDIR", "SYS_NET_EISDIR", "SYS_NET_EINVAL", "SYS_NET_ENFILE", "SYS_NET_EMFILE", "SYS_NET_ENOTTY", "SYS_NET_ETXTBSY", "SYS_NET_EFBIG", "SYS_NET_ENOSPC", "SYS_NET_ESPIPE", "SYS_NET_EROFS", "SYS_NET_EMLINK", "SYS_NET_EPIPE", "SYS_NET_EDOM", "SYS_NET_ERANGE", "SYS_NET_EAGAIN/SYS_NET_EWOULDBLOCK", "SYS_NET_EINPROGRESS", "SYS_NET_EALREADY", "SYS_NET_ENOTSOCK", "SYS_NET_EDESTADDRREQ", "SYS_NET_EMSGSIZE", "SYS_NET_EPROTOTYPE", "SYS_NET_ENOPROTOOPT", "SYS_NET_EPROTONOSUPPORT", "SYS_NET_ESOCKTNOSUPPORT", "SYS_NET_EOPNOTSUPP", "SYS_NET_EPFNOSUPPORT", "SYS_NET_EAFNOSUPPORT", "SYS_NET_EADDRINUSE", "SYS_NET_EADDRNOTAVAIL", "SYS_NET_ENETDOWN", "SYS_NET_ENETUNREACH", "SYS_NET_ENETRESET", "SYS_NET_ECONNABORTED", "SYS_NET_ECONNRESET", "SYS_NET_ENOBUFS", "SYS_NET_EISCONN", "SYS_NET_ENOTCONN", "SYS_NET_ESHUTDOWN", "SYS_NET_ETOOMANYREFS", "SYS_NET_ETIMEDOUT", "SYS_NET_ECONNREFUSED", "SYS_NET_ELOOP", "SYS_NET_ENAMETOOLONG", "SYS_NET_EHOSTDOWN", "SYS_NET_EHOSTUNREACH", "SYS_NET_ENOTEMPTY", "SYS_NET_EPROCLIM", "SYS_NET_EUSERS", "SYS_NET_EDQUOT", "SYS_NET_ESTALE", "SYS_NET_EREMOTE", "SYS_NET_EBADRPC", "SYS_NET_ERPCMISMATCH", "SYS_NET_EPROGUNAVAIL", "SYS_NET_EPROGMISMATCH", "SYS_NET_EPROCUNAVAIL", "SYS_NET_ENOLCK", "SYS_NET_ENOSYS", "SYS_NET_EFTYPE", "SYS_NET_EAUTH", "SYS_NET_ENEEDAUTH", "SYS_NET_EIDRM", "SYS_NET_ENOMSG", "SYS_NET_EOVERFLOW", "SYS_NET_EILSEQ", "SYS_NET_ENOTSUP", "SYS_NET_ECANCELED", "SYS_NET_EBADMSG", "SYS_NET_ENODATA", "SYS_NET_ENOSR", "SYS_NET_ENOSTR", "SYS_NET_ETIME", "SYS_NET_ELAST" };
Namespace

rage Namespace

File

tcpip_psn.cpp

Links
rage Namespace


rage::s_netErrorCount Variable

rage::s_netErrorCount Variable
rage Namespace
Show All
C++
static const int s_netErrorCount = sizeof(s_netError)/sizeof(s_netError[0]);
Namespace

rage Namespace

File

tcpip_psn.cpp

Links
rage Namespace


rage::s_NumInProgressBlocks Variable

rage::s_NumInProgressBlocks Variable
rage Namespace
Show All
C++
static volatile int s_NumInProgressBlocks;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_numRpfs Variable

rage::s_numRpfs Variable
rage Namespace
Show All
C++
static s32 s_numRpfs = 0;
Namespace

rage Namespace

File

device_installer.cpp

Links
rage Namespace


rage::s_NumValidBlocks Variable

rage::s_NumValidBlocks Variable
rage Namespace
Show All
C++
static volatile int s_NumValidBlocks;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_pDeviceUpdate Variable

rage::s_pDeviceUpdate Variable
rage Namespace
Show All
C++
fiDevice* s_pDeviceUpdate = &s_DeviceLocal;
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::s_PendingState Variable

rage::s_PendingState Variable
rage Namespace
Show All
C++
static u32 s_PendingState = STATE_PENDING_BOOT;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_Profiles Variable

rage::s_Profiles Variable
rage Namespace
Show All
C++
static atRangeArray<XenonProfile,fiSaveGame::SIGNIN_COUNT> s_Profiles;
Namespace

rage Namespace

File

savegame_xenon.cpp

Links
rage Namespace


rage::s_Reader Variable

rage::s_Reader Variable
rage Namespace
Show All
C++
static pgReadData s_Reader;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_ResidentMap Variable

rage::s_ResidentMap Variable
rage Namespace
Show All

Data structure which maps a source block to the cache block tracking it (the cache block itself may be either resident or pending)

C++
static atMultiRangeArray<u16,CACHE_FILE_COUNT,CACHE_FILE_BLOCK_COUNT> s_ResidentMap;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_SaveGameSizes Variable

rage::s_SaveGameSizes Variable
rage Namespace
Show All
C++
static int * s_SaveGameSizes;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_Saves Variable

rage::s_Saves Variable
rage Namespace
Show All
C++
static atRangeArray<bool*,fiSaveGame::SIGNIN_COUNT> s_Saves;
Namespace

rage Namespace

File

savegame_dummy.cpp

Links
rage Namespace


rage::s_Selects Variable

rage::s_Selects Variable
rage Namespace
Show All
C++
static atRangeArray<bool,fiSaveGame::SIGNIN_COUNT> s_Selects;
Namespace

rage Namespace

File

savegame_dummy.cpp

Links
rage Namespace


rage::s_setBuf Variable

rage::s_setBuf Variable
rage Namespace
Show All
C++
static CellSaveDataSetBuf s_setBuf;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_setList Variable

rage::s_setList Variable
rage Namespace
Show All
C++
static CellSaveDataSetList s_setList;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_ShutdownCacheWorkerThread Variable

rage::s_ShutdownCacheWorkerThread Variable
rage Namespace
Show All
C++
volatile bool s_ShutdownCacheWorkerThread;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_SizeOfIconAndSystemFiles Variable

rage::s_SizeOfIconAndSystemFiles Variable
rage Namespace
Show All
C++
static int s_SizeOfIconAndSystemFiles = 0;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_SizeOfSystemOverheads Variable

rage::s_SizeOfSystemOverheads Variable
rage Namespace
Show All
C++
static int s_SizeOfSystemOverheads = 0;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_SpaceRequired Variable

rage::s_SpaceRequired Variable
rage Namespace
Show All
C++
static int s_SpaceRequired = 0;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_SpaceRequiredToSaveThisFile Variable

rage::s_SpaceRequiredToSaveThisFile Variable
rage Namespace
Show All
C++
static int s_SpaceRequiredToSaveThisFile = 0;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_States Variable

rage::s_States Variable
rage Namespace
Show All
C++
atStaticPool<fiPackfileState,STATIC_STATE_BUFFERS? 4 : 16> s_States;
Namespace

rage Namespace

File

packfile.cpp

Links
rage Namespace


rage::s_TcpIpInstance Variable

rage::s_TcpIpInstance Variable
rage Namespace
Show All
C++
static fiDeviceTcpIp s_TcpIpInstance;
Namespace

rage Namespace

File

tcpip_win32.cpp

Links
rage Namespace


rage::s_TcpIpLastError Variable

rage::s_TcpIpLastError Variable
rage Namespace
Show All
C++
static char s_TcpIpLastError[128];
Namespace

rage Namespace

File

tcpip_common.cpp

Links
rage Namespace


rage::s_ThreadId Variable

rage::s_ThreadId Variable
rage Namespace
Show All
C++
static sysIpcThreadId s_ThreadId = sysIpcThreadIdInvalid;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_TitleIdForSavesFolder Variable

rage::s_TitleIdForSavesFolder Variable
rage Namespace
Show All
C++
static char s_TitleIdForSavesFolder[MAX_CHARS_IN_TITLE_ID_FOR_SAVES_FOLDER];
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_TitleString Variable

rage::s_TitleString Variable
rage Namespace
Show All
C++
static char s_TitleString[CELL_SAVEDATA_SYSP_TITLE_SIZE];
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_TotalHDDFreeSize Variable

rage::s_TotalHDDFreeSize Variable
rage Namespace
Show All
C++
static int s_TotalHDDFreeSize = 0;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_UserBindErrorMsg Variable

rage::s_UserBindErrorMsg Variable
rage Namespace
Show All
C++
static char s_UserBindErrorMsg[CELL_SAVEDATA_INVALIDMSG_MAX];
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::s_ZipfileOpen Variable

rage::s_ZipfileOpen Variable
rage Namespace
Show All
C++
static sysCriticalSectionToken s_ZipfileOpen;
Namespace

rage Namespace

File

zipfile.cpp

Links
rage Namespace


rage::s_ZipOpen Variable

rage::s_ZipOpen Variable
rage Namespace
Show All
C++
static sysCriticalSectionToken s_ZipOpen;
Namespace

rage Namespace

File

packfile.cpp

Links
rage Namespace


rage::s_ZipStates Variable

rage::s_ZipStates Variable
rage Namespace
Show All
C++
atStaticPool<fiZipfileState,16> s_ZipStates;
Namespace

rage Namespace

File

zipfile.cpp

Links
rage Namespace


rage::SAVEGAME Variable

rage::SAVEGAME Variable
rage Namespace
Show All
C++
fiSaveGame SAVEGAME;
Namespace

rage Namespace

File

savegame.h

Links
rage Namespace


rage::secureFileId Variable

rage::secureFileId Variable
rage Namespace
Show All
C++
static const char secureFileId[CELL_SAVEDATA_SECUREFILEID_SIZE] = { #include "savegame_psn_id.h" };
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::SizeOfIconImage Variable

rage::SizeOfIconImage Variable
rage Namespace
Show All
C++
u32 SizeOfIconImage = 0;
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::sm_ExtraSpaceRequired Variable

rage::sm_ExtraSpaceRequired Variable
rage Namespace
Show All
C++
static s32 sm_ExtraSpaceRequired = 0;
Namespace

rage Namespace

File

savegame_pc.cpp

Links
rage Namespace


rage::sm_FallbackToDefaultDevice Variable

rage::sm_FallbackToDefaultDevice Variable
rage Namespace
Show All
C++
bool sm_FallbackToDefaultDevice = false;
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::sm_IsLoadedDataValid Variable

rage::sm_IsLoadedDataValid Variable
rage Namespace
Show All
C++
static bool sm_IsLoadedDataValid;
Namespace

rage Namespace

File

savegame_pc.cpp

Links
rage Namespace


rage::sm_MatchLongestPath Variable

rage::sm_MatchLongestPath Variable
rage Namespace
Show All
C++
bool sm_MatchLongestPath = true;
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::sm_MatchNewest Variable

rage::sm_MatchNewest Variable
rage Namespace
Show All
C++
bool sm_MatchNewest = false;
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::tls_Uncached Variable

rage::tls_Uncached Variable
rage Namespace
Show All

HACK HACK HACK

C++
__THREAD bool tls_Uncached;
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::XCONTENT_DATA_SIZE Variable

rage::XCONTENT_DATA_SIZE Variable
rage Namespace
Show All
C++
const int XCONTENT_DATA_SIZE = (4+4+2*128+42+2);
Namespace

rage Namespace

File

device_xcontent.h

Links
rage Namespace


rage::XEX_TITLE_ID Variable

rage::XEX_TITLE_ID Variable
rage Namespace
Show All

HACK_GTA4

C++
char * XEX_TITLE_ID;
Namespace

rage Namespace

File

cachepartition.cpp

Links
rage Namespace


rage::__ENABLE_RFS Macro

rage::__ENABLE_RFS Macro
rage Namespace
Show All
C++
#define __ENABLE_RFS (!__FINAL)
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::ASYNC_CACHE_COPIES Macro

rage::ASYNC_CACHE_COPIES Macro
rage Namespace
Show All

Whether cache misses are serviced asynchronously or not based on holdoff time.

C++
#define ASYNC_CACHE_COPIES (__XENON || __PS3)
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::CACHE_BLOCK_HANDLE Macro

rage::CACHE_BLOCK_HANDLE Macro
rage Namespace
Show All
C++
#define CACHE_BLOCK_HANDLE(x) s_CacheFile
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::CACHEDEV Macro

rage::CACHEDEV Macro
rage Namespace
Show All
C++
#define CACHEDEV (fiDeviceLocal::GetInstance())
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::CORRUPT_FILE_CODE Macro

rage::CORRUPT_FILE_CODE Macro
rage Namespace
Show All
C++
#define CORRUPT_FILE_CODE 0x80070570
Namespace

rage Namespace

File

savegame_xenon.cpp

Links
rage Namespace


rage::COULD_NOT_MAP_DEVICE_CODE Macro

rage::COULD_NOT_MAP_DEVICE_CODE Macro
rage Namespace
Show All
C++
#define COULD_NOT_MAP_DEVICE_CODE 0x8007048f
Namespace

rage Namespace

File

savegame_xenon.cpp

Links
rage Namespace


rage::dcDebugf1 Macro

rage::dcDebugf1 Macro
rage Namespace
Show All

printf("[DiskCache] Debug1: " fmt "n",##__VA_ARGS__)

C++
#define dcDebugf1(fmt,...) RAGE_DEBUGF1(DiskCache,fmt,##__VA_ARGS__)
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::dcDebugf2 Macro

rage::dcDebugf2 Macro
rage Namespace
Show All

printf("[DiskCache] Debug2: " fmt "n",##__VA_ARGS__)

C++
#define dcDebugf2(fmt,...) RAGE_DEBUGF2(DiskCache,fmt,##__VA_ARGS__)
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::dcDebugf3 Macro

rage::dcDebugf3 Macro
rage Namespace
Show All

printf("[DiskCache] Debug3: " fmt "n",##__VA_ARGS__)

C++
#define dcDebugf3(fmt,...) RAGE_DEBUGF3(DiskCache,fmt,##__VA_ARGS__)
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::dcDisplayf Macro

rage::dcDisplayf Macro
rage Namespace
Show All
C++
#define dcDisplayf(fmt,...) RAGE_DISPLAYF(DiskCache,fmt,##__VA_ARGS__)
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::dcErrorf Macro

rage::dcErrorf Macro
rage Namespace
Show All
C++
#define dcErrorf(fmt,...) RAGE_ERRORF(DiskCache,fmt,##__VA_ARGS__)
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::dcWarningf Macro

rage::dcWarningf Macro
rage Namespace
Show All
C++
#define dcWarningf(fmt,...) RAGE_WARNINGF(DiskCache,fmt,##__VA_ARGS__)
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::DECLARE_STREAM_BUFFERS Macro

rage::DECLARE_STREAM_BUFFERS Macro
rage Namespace
Show All
C++
#define DECLARE_STREAM_BUFFERS(count) int fiStream::MaxStreams = (count); fiStream fiStream::sm_Streams[count]; char fiStream::sm_Buffers[count][BufferSize] ALIGNED(128);
Namespace

rage Namespace

File

stream.h

Links
rage Namespace


rage::DIALOG_MODE Macro

rage::DIALOG_MODE Macro
rage Namespace
Show All

HACK_GTA4

C++
#define DIALOG_MODE CELL_SAVEDATA_ERRDIALOG_NONE
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::DVD_DEVICE_NAME Macro

rage::DVD_DEVICE_NAME Macro
rage Namespace
Show All
C++
#define DVD_DEVICE_NAME ""
Namespace

rage Namespace

File

packfile.h

Links
rage Namespace


rage::ENABLE_GAMEDATA_FOR_DISKCACHE Macro

rage::ENABLE_GAMEDATA_FOR_DISKCACHE Macro
rage Namespace
Show All
C++
#define ENABLE_GAMEDATA_FOR_DISKCACHE (__PS3 && 0)
Namespace

rage Namespace

File

diskcache.h

Links
rage Namespace


rage::FILE_ATTRIBUTE_ARCHIVE Macro

rage::FILE_ATTRIBUTE_ARCHIVE Macro
rage Namespace
Show All
C++
#define FILE_ATTRIBUTE_ARCHIVE 0x00000020
Namespace

rage Namespace

File

device.h

Links
rage Namespace


rage::FILE_ATTRIBUTE_COMPRESSED Macro

rage::FILE_ATTRIBUTE_COMPRESSED Macro
rage Namespace
Show All
C++
#define FILE_ATTRIBUTE_COMPRESSED 0x00000800
Namespace

rage Namespace

File

device.h

Links
rage Namespace


rage::FILE_ATTRIBUTE_DIRECTORY Macro

rage::FILE_ATTRIBUTE_DIRECTORY Macro
rage Namespace
Show All
C++
#define FILE_ATTRIBUTE_DIRECTORY 0x00000010
Namespace

rage Namespace

File

device.h

Links
rage Namespace


rage::FILE_ATTRIBUTE_HIDDEN Macro

rage::FILE_ATTRIBUTE_HIDDEN Macro
rage Namespace
Show All
C++
#define FILE_ATTRIBUTE_HIDDEN 0x00000002
Namespace

rage Namespace

File

device.h

Links
rage Namespace


rage::FILE_ATTRIBUTE_INVALID Macro

rage::FILE_ATTRIBUTE_INVALID Macro
rage Namespace
Show All
C++
#define FILE_ATTRIBUTE_INVALID ~0U
Namespace

rage Namespace

File

device.h

Links
rage Namespace


rage::FILE_ATTRIBUTE_NORMAL Macro

rage::FILE_ATTRIBUTE_NORMAL Macro
rage Namespace
Show All
C++
#define FILE_ATTRIBUTE_NORMAL 0x00000080
Namespace

rage Namespace

File

device.h

Links
rage Namespace


rage::FILE_ATTRIBUTE_NOT_CONTENT_INDEXED Macro

rage::FILE_ATTRIBUTE_NOT_CONTENT_INDEXED Macro
rage Namespace
Show All
C++
#define FILE_ATTRIBUTE_NOT_CONTENT_INDEXED 0x00002000
Namespace

rage Namespace

File

device.h

Links
rage Namespace


rage::FILE_ATTRIBUTE_OFFLINE Macro

rage::FILE_ATTRIBUTE_OFFLINE Macro
rage Namespace
Show All
C++
#define FILE_ATTRIBUTE_OFFLINE 0x00001000
Namespace

rage Namespace

File

device.h

Links
rage Namespace


rage::FILE_ATTRIBUTE_READONLY Macro

rage::FILE_ATTRIBUTE_READONLY Macro
rage Namespace
Show All
C++
#define FILE_ATTRIBUTE_READONLY 0x00000001
Namespace

rage Namespace

File

device.h

Links
rage Namespace


rage::FILE_ATTRIBUTE_REPARSE_POINT Macro

rage::FILE_ATTRIBUTE_REPARSE_POINT Macro
rage Namespace
Show All
C++
#define FILE_ATTRIBUTE_REPARSE_POINT 0x00000400
Namespace

rage Namespace

File

device.h

Links
rage Namespace


rage::FILE_ATTRIBUTE_SPARSE_FILE Macro

rage::FILE_ATTRIBUTE_SPARSE_FILE Macro
rage Namespace
Show All
C++
#define FILE_ATTRIBUTE_SPARSE_FILE 0x00000200
Namespace

rage Namespace

File

device.h

Links
rage Namespace


rage::FILE_ATTRIBUTE_SYSTEM Macro

rage::FILE_ATTRIBUTE_SYSTEM Macro
rage Namespace
Show All
C++
#define FILE_ATTRIBUTE_SYSTEM 0x00000004
Namespace

rage Namespace

File

device.h

Links
rage Namespace


rage::FILE_ATTRIBUTE_TEMPORARY Macro

rage::FILE_ATTRIBUTE_TEMPORARY Macro
rage Namespace
Show All
C++
#define FILE_ATTRIBUTE_TEMPORARY 0x00000100
Namespace

rage Namespace

File

device.h

Links
rage Namespace


rage::IDABORT Macro

rage::IDABORT Macro
rage Namespace
Show All

Abort

C++
#define IDABORT 3
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::IDCANCEL Macro

rage::IDCANCEL Macro
rage Namespace
Show All

Cancel

C++
#define IDCANCEL 2
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::IDCONTINUE Macro

rage::IDCONTINUE Macro
rage Namespace
Show All
C++
#define IDCONTINUE 11
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::IDCUSTOM1 Macro

rage::IDCUSTOM1 Macro
rage Namespace
Show All

following 4 ids MUST be sequential

C++
#define IDCUSTOM1 23
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::IDCUSTOM2 Macro

rage::IDCUSTOM2 Macro
rage Namespace
Show All
C++
#define IDCUSTOM2 24
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::IDCUSTOM3 Macro

rage::IDCUSTOM3 Macro
rage Namespace
Show All
C++
#define IDCUSTOM3 25
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::IDCUSTOM4 Macro

rage::IDCUSTOM4 Macro
rage Namespace
Show All
C++
#define IDCUSTOM4 26
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::IDIGNORE Macro

rage::IDIGNORE Macro
rage Namespace
Show All

Ignore

C++
#define IDIGNORE 5
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::IDNO Macro

rage::IDNO Macro
rage Namespace
Show All

No

C++
#define IDNO 7
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::IDOK Macro

rage::IDOK Macro
rage Namespace
Show All

Ok

C++
#define IDOK 1
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::IDRETRY Macro

rage::IDRETRY Macro
rage Namespace
Show All

Retry

C++
#define IDRETRY 4
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::IDTRYAGAIN Macro

rage::IDTRYAGAIN Macro
rage Namespace
Show All
C++
#define IDTRYAGAIN 10
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::IDYES Macro

rage::IDYES Macro
rage Namespace
Show All

Yes

C++
#define IDYES 6
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::INSTALL_SLICE_NUM Macro

rage::INSTALL_SLICE_NUM Macro
rage Namespace
Show All
C++
#define INSTALL_SLICE_NUM 4
Namespace

rage Namespace

File

device_installer.h

Links
rage Namespace


rage::INSTALL_SLICE_SIZE Macro

rage::INSTALL_SLICE_SIZE Macro
rage Namespace
Show All
C++
#define INSTALL_SLICE_SIZE (32 * 1024)
Namespace

rage Namespace

File

device_installer.h

Links
rage Namespace


rage::MAX_CHARS_IN_TITLE_ID_FOR_SAVES_FOLDER Macro

rage::MAX_CHARS_IN_TITLE_ID_FOR_SAVES_FOLDER Macro
rage Namespace
Show All

should never actually need more than 10 (9 + the null character)

C++
#define MAX_CHARS_IN_TITLE_ID_FOR_SAVES_FOLDER (16)
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::MAX_DEVICE_NAME_LENGTH Macro

rage::MAX_DEVICE_NAME_LENGTH Macro
rage Namespace
Show All
C++
#define MAX_DEVICE_NAME_LENGTH 27
Namespace

rage Namespace

File

savegame_xenon.cpp

Links
rage Namespace


rage::MAX_PARTITION_SIZE Macro

rage::MAX_PARTITION_SIZE Macro
rage Namespace
Show All

2 Gb per partition

C++
#define MAX_PARTITION_SIZE 1024ULL * 1024 * 1024 * 2
Namespace

rage Namespace

File

device_installer.cpp

Links
rage Namespace


rage::MAX_XCONTENT_HANDLES Macro

rage::MAX_XCONTENT_HANDLES Macro
rage Namespace
Show All
C++
#define MAX_XCONTENT_HANDLES 64
Namespace

rage Namespace

File

device_installer.cpp

Links
rage Namespace


rage::MB_ABORTRETRYIGNORE Macro

rage::MB_ABORTRETRYIGNORE Macro
rage Namespace
Show All

Abort / Retry / Ignore buttons

C++
#define MB_ABORTRETRYIGNORE 0x00000002L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_APPLMODAL Macro

rage::MB_APPLMODAL Macro
rage Namespace
Show All
C++
#define MB_APPLMODAL 0x00000000L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_CANCELTRYCONTINUE Macro

rage::MB_CANCELTRYCONTINUE Macro
rage Namespace
Show All
C++
#define MB_CANCELTRYCONTINUE 0x00000006L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_DEFAULT_DESKTOP_ONLY Macro

rage::MB_DEFAULT_DESKTOP_ONLY Macro
rage Namespace
Show All
C++
#define MB_DEFAULT_DESKTOP_ONLY 0x00020000L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_DEFBUTTON1 Macro

rage::MB_DEFBUTTON1 Macro
rage Namespace
Show All
C++
#define MB_DEFBUTTON1 0x00000000L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_DEFBUTTON2 Macro

rage::MB_DEFBUTTON2 Macro
rage Namespace
Show All
C++
#define MB_DEFBUTTON2 0x00000100L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_DEFBUTTON3 Macro

rage::MB_DEFBUTTON3 Macro
rage Namespace
Show All
C++
#define MB_DEFBUTTON3 0x00000200L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_DEFBUTTON4 Macro

rage::MB_DEFBUTTON4 Macro
rage Namespace
Show All
C++
#define MB_DEFBUTTON4 0x00000300L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_HELP Macro

rage::MB_HELP Macro
rage Namespace
Show All

Help Button

C++
#define MB_HELP 0x00004000L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_ICONASTERISK Macro

rage::MB_ICONASTERISK Macro
rage Namespace
Show All

Display asterisk icon

C++
#define MB_ICONASTERISK 0x00000040L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_ICONERROR Macro

rage::MB_ICONERROR Macro
rage Namespace
Show All

Display hand icon

C++
#define MB_ICONERROR MB_ICONHAND
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_ICONHAND Macro

rage::MB_ICONHAND Macro
rage Namespace
Show All

Display hand icon

C++
#define MB_ICONHAND 0x00000010L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_ICONINFORMATION Macro

rage::MB_ICONINFORMATION Macro
rage Namespace
Show All
C++
#define MB_ICONINFORMATION MB_ICONASTERISK
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_ICONQUESTION Macro

rage::MB_ICONQUESTION Macro
rage Namespace
Show All

Display question icon

C++
#define MB_ICONQUESTION 0x00000020L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_NOFOCUS Macro

rage::MB_NOFOCUS Macro
rage Namespace
Show All
C++
#define MB_NOFOCUS 0x00008000L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_OK Macro

rage::MB_OK Macro
rage Namespace
Show All

Ok button only

C++
#define MB_OK 0x00000000L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_OKCANCEL Macro

rage::MB_OKCANCEL Macro
rage Namespace
Show All

Ok and cancel buttons

C++
#define MB_OKCANCEL 0x00000001L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_RETRYCANCEL Macro

rage::MB_RETRYCANCEL Macro
rage Namespace
Show All
C++
#define MB_RETRYCANCEL 0x00000005L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_RIGHT Macro

rage::MB_RIGHT Macro
rage Namespace
Show All
C++
#define MB_RIGHT 0x00080000L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_SETFOREGROUND Macro

rage::MB_SETFOREGROUND Macro
rage Namespace
Show All

Force to foreground window

C++
#define MB_SETFOREGROUND 0x00010000L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_SYSTEMMODAL Macro

rage::MB_SYSTEMMODAL Macro
rage Namespace
Show All
C++
#define MB_SYSTEMMODAL 0x00001000L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_TASKMODAL Macro

rage::MB_TASKMODAL Macro
rage Namespace
Show All
C++
#define MB_TASKMODAL 0x00002000L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_TOPMOST Macro

rage::MB_TOPMOST Macro
rage Namespace
Show All

Force to topmost window

C++
#define MB_TOPMOST 0x00040000L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_YESNO Macro

rage::MB_YESNO Macro
rage Namespace
Show All

Yes / No buttons

C++
#define MB_YESNO 0x00000004L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MB_YESNOCANCEL Macro

rage::MB_YESNOCANCEL Macro
rage Namespace
Show All

Yes / No / Cancel buttons

C++
#define MB_YESNOCANCEL 0x00000003L
Namespace

rage Namespace

File

remote.h

Links
rage Namespace


rage::MULTIPLE_CACHE_FILES Macro

rage::MULTIPLE_CACHE_FILES Macro
rage Namespace
Show All
C++
#define MULTIPLE_CACHE_FILES (__XENON && 1)
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::NO_FILES_EXIST_CODE Macro

rage::NO_FILES_EXIST_CODE Macro
rage Namespace
Show All
C++
#define NO_FILES_EXIST_CODE 0x80070012
Namespace

rage Namespace

File

savegame_xenon.cpp

Links
rage Namespace


rage::PS3_FILE_HANDLE_HACK Macro

rage::PS3_FILE_HANDLE_HACK Macro
rage Namespace
Show All

TEMP: this only allows 240 rpfs to be installed and then it blocks the rest. temporary until we merge some of the rpfs, or make sony use a short

C++
#define PS3_FILE_HANDLE_HACK __PS3
Namespace

rage Namespace

File

device_installer.cpp

Links
rage Namespace


rage::READ_PROGRESS_WATCHDOG Macro

rage::READ_PROGRESS_WATCHDOG Macro
rage Namespace
Show All
C++
#define READ_PROGRESS_WATCHDOG (!__NO_OUTPUT)
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::READ_PROGRESS_WATCHDOG_ERROR_LIMIT_SECONDS Macro

rage::READ_PROGRESS_WATCHDOG_ERROR_LIMIT_SECONDS Macro
rage Namespace
Show All
C++
#define READ_PROGRESS_WATCHDOG_ERROR_LIMIT_SECONDS (10.f)
Namespace

rage Namespace

File

device_common.cpp

Links
rage Namespace


rage::REPLAY_SAVE_FILENAME Macro

rage::REPLAY_SAVE_FILENAME Macro
rage Namespace
Show All
C++
#define REPLAY_SAVE_FILENAME "SGTA50000"
Namespace

rage Namespace

File

savegame_pc.cpp

Links
rage Namespace


rage::s_Files Macro

rage::s_Files Macro
rage Namespace
Show All
C++
#define s_Files (s_Header->Files)
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_Magic Macro

rage::s_Magic Macro
rage Namespace
Show All

The head and tail of the list simply live in slot zero, keeping the data simple.

C++
#define s_Magic (s_Header->Slots[0].magic)
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_Newest Macro

rage::s_Newest Macro
rage Namespace
Show All
C++
#define s_Newest (s_Header->Slots[0].newer)
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_Oldest Macro

rage::s_Oldest Macro
rage Namespace
Show All
C++
#define s_Oldest (s_Header->Slots[0].older)
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::s_Slots Macro

rage::s_Slots Macro
rage Namespace
Show All
C++
#define s_Slots (s_Header->Slots)
Namespace

rage Namespace

File

diskcache.cpp

Links
rage Namespace


rage::SAVEGAME_STACK_SIZE Macro

rage::SAVEGAME_STACK_SIZE Macro
rage Namespace
Show All
C++
#define SAVEGAME_STACK_SIZE 16384
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::SAVEGAME_STACK_SIZE_FOR_ENUMERATION Macro

rage::SAVEGAME_STACK_SIZE_FOR_ENUMERATION Macro
rage Namespace
Show All
C++
#define SAVEGAME_STACK_SIZE_FOR_ENUMERATION (20480)
Namespace

rage Namespace

File

savegame_psn.cpp

Links
rage Namespace


rage::sgDebug1 Macro

rage::sgDebug1 Macro
rage Namespace
Show All
C++
#define sgDebug1(fmt, ...) RAGE_DEBUGF1(savegamepc, fmt, ##__VA_ARGS__)
Namespace

rage Namespace

File

savegame_pc.cpp

Links
rage Namespace


rage::sgDebug2 Macro

rage::sgDebug2 Macro
rage Namespace
Show All
C++
#define sgDebug2(fmt, ...) RAGE_DEBUGF2(savegamepc, fmt, ##__VA_ARGS__)
Namespace

rage Namespace

File

savegame_pc.cpp

Links
rage Namespace


rage::sgDebug3 Macro

rage::sgDebug3 Macro
rage Namespace
Show All
C++
#define sgDebug3(fmt, ...) RAGE_DEBUGF3(savegamepc, fmt, ##__VA_ARGS__)
Namespace

rage Namespace

File

savegame_pc.cpp

Links
rage Namespace


rage::sgError Macro

rage::sgError Macro
rage Namespace
Show All
C++
#define sgError(fmt, ...) RAGE_ERRORF(savegamepc, fmt, ##__VA_ARGS__)
Namespace

rage Namespace

File

savegame_pc.cpp

Links
rage Namespace


rage::sgWarning Macro

rage::sgWarning Macro
rage Namespace
Show All
C++
#define sgWarning(fmt, ...) RAGE_WARNINGF(savegamepc, fmt, ##__VA_ARGS__)
Namespace

rage Namespace

File

savegame_pc.cpp

Links
rage Namespace


rage::STATIC_STATE_BUFFERS Macro

rage::STATIC_STATE_BUFFERS Macro
rage Namespace
Show All
C++
#define STATIC_STATE_BUFFERS (!__DEV && !__BANK && !__TOOL)
Namespace

rage Namespace

File

packfile.cpp

Links
rage Namespace


rage::STREAM_STORE_NAME Macro

rage::STREAM_STORE_NAME Macro
rage Namespace
Show All
C++
#define STREAM_STORE_NAME (__DEV || __TOOL)
Namespace

rage Namespace

File

stream.h

Links
rage Namespace


rage::THE_DEVICE_IS_NOT_READY_CODE Macro

rage::THE_DEVICE_IS_NOT_READY_CODE Macro
rage Namespace
Show All
C++
#define THE_DEVICE_IS_NOT_READY_CODE 0x80070015
Namespace

rage Namespace

File

savegame_xenon.cpp

Links
rage Namespace


rage::USER_CANCELLED_DEVICE_SELECTION_CODE Macro

rage::USER_CANCELLED_DEVICE_SELECTION_CODE Macro
rage Namespace
Show All

define Xenon specific error codes

C++
#define USER_CANCELLED_DEVICE_SELECTION_CODE 0x000004c7
Namespace

rage Namespace

File

savegame_xenon.cpp

Links
rage Namespace


AssertMessageBox Function

AssertMessageBox Function
C++
int AssertMessageBox(
    HWND hWnd,
    LPCSTR lpText,
    LPCSTR lpCaption,
    UINT uType
);
File

remote.cpp


InitWinSock Function

InitWinSock Function

Initialize windows sockets

C++
void InitWinSock(
    int argc = 0,
    char** argv = NULL
);
File

winsock.h


safe_recv Function

safe_recv Function

Receives data from a connected socket.

C++
int safe_recv(
    int s,
    char * buf,
    int len
);
Parameters

s
socket.
buf
data to be sent.
len
the length of data to be sent.

Returns

the amount of data to be received.

Notes

Keeps trying to recieve until len bytes have been read or an error occurs

File

winsock.h


safe_send Function

safe_send Function

Sends data on a connected socket.

C++
int safe_send(
    int s,
    const char * buf,
    int len
);
Parameters

s
socket.
buf
data to be sent.
len
the length of data to be sent.

Returns

the amount of data to be sent.

Notes

Keeps trying to send until len bytes have been sent or an error occurs

File

winsock.h


ShutdownWinSock Function

ShutdownWinSock Function

Terminate use of the WS2_32.dll

C++
void ShutdownWinSock();
File

winsock.h


FFData Struct

FFData Struct
C++
public: struct FFData {
  public: int fd, readOfs, readSiz;
  public: long bufSiz;
  public: char buf[0];
};
File

device_psp2.cpp


fiHandle Type

fiHandle Type

Needs to be at least as wide as a pointer

C++
typedef struct fiHandle__ * fiHandle;
File

handle.h


SOCKET Type

SOCKET Type
C++
typedef int SOCKET;
File

tcpip_psn.cpp


socklen_t Type

socklen_t Type
C++
typedef int socklen_t;
File

ftpserver.cpp


Variable

Variable
C++
(voidfiDevicesm_FatalReadErrorvoid )();
File

device_psn.cpp


__libnet_memory Variable

__libnet_memory Variable
C++
static char __libnet_memory[128 * 1024];
File

winsock.cpp


assetDebug Variable

assetDebug Variable
C++
int assetDebug;
File

asset.cpp


BINARY Variable

BINARY Variable
C++
static const int BINARY = 26;
File

serialize.cpp


c_InitialWidth Variable

c_InitialWidth Variable

Initial width currently has to be two so that initial bias is correct when invoked from encode_length

C++
const int c_InitialWidth = 2;
File

compress_internal.h


c_Magic_1 Variable

c_Magic_1 Variable

Magic number (to allow for future configurability)

C++
const rage::u8 c_Magic_1 = 0xDC;
File

compress_internal.h


c_Magic_2 Variable

c_Magic_2 Variable
C++
const rage::u8 c_Magic_2 = 0xE0;
File

compress_internal.h


c_WidthStep Variable

c_WidthStep Variable
C++
const int c_WidthStep = 2;
File

compress_internal.h


cellGameDataPath Variable

cellGameDataPath Variable
C++
static char cellGameDataPath[CELL_GAME_PATH_MAX];
File

device_psn.cpp


CENTINANOSECONDS_PER_SECOND Variable

CENTINANOSECONDS_PER_SECOND Variable
C++
static const u64 CENTINANOSECONDS_PER_SECOND = 10000000ULL;
File

device_psn.cpp


fiBaseTokenizer::CommentChar Variable

fiBaseTokenizer::CommentChar Variable
C++
int fiBaseTokenizer::CommentChar = ';';
File

token.cpp


fiDevice::sm_InjectReadError Variable

fiDevice::sm_InjectReadError Variable
C++
u32 fiDevice::sm_InjectReadError;
File

device_psn.cpp


FILE_VERSION Variable

FILE_VERSION Variable

Version History: 1 -- First RAGE release -- In ascii mode, simple behavior for strings, and relied on higher code to delimit text. 2 -- Relying on higher level code was bad, so serialized text not ending in whitespace will now append a space character. Also, any strings containing white- and non-whitespaced characters will be delimited by quotes (") to ensure complete string is retrieved from tokenizer. All of this valid only for ascii files.

C++
static const int FILE_VERSION = 2;
File

serialize.cpp


FILETIME_BIAS Variable

FILETIME_BIAS Variable
C++
static const u64 FILETIME_BIAS = 116444736000000000ULL;
File

device_psn.cpp


fiStream::m_bOutputAllFileAccess Variable

fiStream::m_bOutputAllFileAccess Variable
C++
bool fiStream::m_bOutputAllFileAccess = false;
File

stream.cpp


fiStream::sm_AllowBlockingLoads Variable

fiStream::sm_AllowBlockingLoads Variable
C++
bool fiStream::sm_AllowBlockingLoads = true;
File

stream.cpp


fiStream::sm_CloseCallback Variable

fiStream::sm_CloseCallback Variable
C++
StreamCloseCallback fiStream::sm_CloseCallback;
File

stream.cpp


fiStream::sm_CreateCallback Variable

fiStream::sm_CreateCallback Variable
C++
StreamCreateCallback fiStream::sm_CreateCallback;
File

stream.cpp


fiStream::sm_FaultInjectionPath Variable

fiStream::sm_FaultInjectionPath Variable
C++
const char * fiStream::sm_FaultInjectionPath = 0;
File

stream.cpp


fiStream::sm_OpenCallback Variable

fiStream::sm_OpenCallback Variable
C++
StreamOpenCallback fiStream::sm_OpenCallback;
File

stream.cpp


fiStream::sm_UnavailableString Variable

fiStream::sm_UnavailableString Variable
C++
const char * const fiStream::sm_UnavailableString = "unavailable";
File

stream.cpp


hEvent Variable

hEvent Variable
C++
__THREAD HANDLE hEvent;
File

device_win32.cpp


PREFIX_SIZE Variable

PREFIX_SIZE Variable
C++
const int PREFIX_SIZE = 0;
File

device_psn.cpp


s_AllocStream Variable

s_AllocStream Variable

Allocate a stream.

C++
static sysCriticalSectionToken s_AllocStream;
Parameters

filename
file name for __DEV & __TOOL use only.
fd
methods - the methods to be used.

Returns

the pointer to the stream.

File

stream.cpp


s_AssetCritSec Variable

s_AssetCritSec Variable
C++
static sysCriticalSectionToken s_AssetCritSec;
File

asset.cpp


s_LSNRange Variable

s_LSNRange Variable
C++
public: enum {
  public: LSN_RANGE_UNKNOWN,
  public: LSN_RANGE_NORMAL,
  public: LSN_RANGE_OVERSIZED
} s_LSNRange;
File

device_win32.cpp


s_RefCount Variable

s_RefCount Variable
C++
static int s_RefCount;
File

winsock.cpp


sMaxIndex Variable

sMaxIndex Variable
C++
static int sMaxIndex = - 1;
File

stream.cpp


streamDebug Variable

streamDebug Variable
C++
int streamDebug;
File

stream.cpp


__DEVPROF Macro

__DEVPROF Macro
C++
#define __DEVPROF (!__FINAL)
File

device.h


__GAMESPY_MATCHMAKING Macro

__GAMESPY_MATCHMAKING Macro
C++
#define __GAMESPY_MATCHMAKING (__GAMESPYPC)
File

file_config.h


__GAMESPY_NEEDS_REPLACEMENT Macro

__GAMESPY_NEEDS_REPLACEMENT Macro

temp define until we get Gamespy replacements for friends, etc.

C++
#define __GAMESPY_NEEDS_REPLACEMENT (0)
File

file_config.h


__GAMESPYPC Macro

__GAMESPYPC Macro
C++
#define __GAMESPYPC (1 && __WIN32PC)
File

file_config.h


__GFWL Macro

__GFWL Macro
C++
#define __GFWL (0 && __WIN32PC)
File

file_config.h


__LAUNCHER_CHECK Macro

__LAUNCHER_CHECK Macro

Turn this on when building for a PC platform that must be run from a launcher

C++
#define __LAUNCHER_CHECK (0 && __WIN32PC)
File

file_config.h


__LIVE Macro

__LIVE Macro
C++
#define __LIVE (__GFWL || __XENON)
File

file_config.h


__RGSC_DLL Macro

__RGSC_DLL Macro
C++
#define __RGSC_DLL (0)
File

file_config.h


__STEAM_BUILD Macro

__STEAM_BUILD Macro

Turn this on, only when building for the Steam platform.

C++
#define __STEAM_BUILD (0 && __WIN32PC)
File

file_config.h


__STEAM_COMMERCE_BUILD Macro

__STEAM_COMMERCE_BUILD Macro
C++
#define __STEAM_COMMERCE_BUILD (1 && __STEAM_BUILD)
File

file_config.h


__STEAM_KOREAN_BUILD Macro

__STEAM_KOREAN_BUILD Macro
C++
#define __STEAM_KOREAN_BUILD (0 && __WIN32PC)
File

file_config.h


__USE_TUS Macro

__USE_TUS Macro
C++
#define __USE_TUS (0)
File

file_config.h


_WINSOCKAPI_ Macro

_WINSOCKAPI_ Macro

GFWL

C++
#define _WINSOCKAPI_
File

file_config.h


CHECK Macro

CHECK Macro
C++
#define CHECK(tag,name,action) return action
File

asset.cpp


CheckForFatalError Macro

CheckForFatalError Macro
C++
#define CheckForFatalError(error) CheckForFatalError_(error,__LINE__)
File

device_psn.cpp


DBG Macro

DBG Macro
C++
#define DBG 0
File

file_config.h


ENABLE_NO_BUFFERING Macro

ENABLE_NO_BUFFERING Macro
C++
#define ENABLE_NO_BUFFERING 0
File

device_win32.cpp


ERRORF Macro

ERRORF Macro
C++
#define ERRORF Quitf
File

token.cpp


FieldAssign Macro

FieldAssign Macro
C++
#define FieldAssign(a,b) a = (b)
File

diskcache.cpp


fiHandleInvalid Macro

fiHandleInvalid Macro
C++
#define fiHandleInvalid ((fiHandle)-1)
File

handle.h


FILLDEVICE_MAX_FILE_SIZE Macro

FILLDEVICE_MAX_FILE_SIZE Macro
C++
#define FILLDEVICE_MAX_FILE_SIZE 0x0000000070000000
File

savegame_xenon.cpp


GAMESPYPC_ONLY Macro

GAMESPYPC_ONLY Macro
C++
#define GAMESPYPC_ONLY(x)
File

file_config.h


HANDLEFMT Macro

HANDLEFMT Macro
C++
#define HANDLEFMT "p"
File

handle.h


INC_DEVICE_XCONTENT_H_ Macro

INC_DEVICE_XCONTENT_H_ Macro
C++
#define INC_DEVICE_XCONTENT_H_
File

device_xcontent.h


INVALID_DEVICE Macro

INVALID_DEVICE Macro
C++
#define INVALID_DEVICE 0xFFFF
File

device_installer.h


IPV6_SOCKETS Macro

IPV6_SOCKETS Macro
C++
#define IPV6_SOCKETS (RSG_DURANGO)
Todo

NS - move define to more global location

File

tcpip_win32.cpp


LIVE_ONLY Macro

LIVE_ONLY Macro
C++
#define LIVE_ONLY(x)
File

file_config.h


LOCAL Macro

LOCAL Macro
C++
#define LOCAL fiDeviceLocal::GetInstance()
File

ftpserver.cpp


LOG_EVERYTHING Macro

LOG_EVERYTHING Macro
C++
#define LOG_EVERYTHING 0
File

compress_internal.h


LOG1 Macro

LOG1 Macro
C++
#define LOG1(a,b)
File

compress_internal.h


LOG2 Macro

LOG2 Macro
C++
#define LOG2(a,b,c)
File

compress_internal.h


MAX_DISPLAY_NAME Macro

MAX_DISPLAY_NAME Macro
C++
#define MAX_DISPLAY_NAME 128
File

savegame_pc.cpp


OTHER_SEPARATOR Macro

OTHER_SEPARATOR Macro
C++
#define OTHER_SEPARATOR '\\'
File

asset.cpp


PC_FILE_SIZE Macro

PC_FILE_SIZE Macro
C++
#define PC_FILE_SIZE 50
File

savegame_pc.cpp


RAGE_CELL_SAVEGAME_VERSION Macro

RAGE_CELL_SAVEGAME_VERSION Macro

CELL_SDK_VERSION >= 0x420001

C++
#define RAGE_CELL_SAVEGAME_VERSION CELL_SAVEDATA_VERSION_CURRENT
File

savegame_psn.cpp


RSG_DURANGO Macro

RSG_DURANGO Macro
C++
#define RSG_DURANGO 0
File

file_config.h


SCE_STM_RWU Macro

SCE_STM_RWU Macro
C++
#define SCE_STM_RWU 0600
File

device_psp2.cpp


SEPARATOR Macro

SEPARATOR Macro
C++
#define SEPARATOR '/'
File

asset.cpp


SEPARATOR_STRING Macro

SEPARATOR_STRING Macro
C++
#define SEPARATOR_STRING "/"
File

asset.cpp


STEAMBUILD_ONLY Macro

STEAMBUILD_ONLY Macro
C++
#define STEAMBUILD_ONLY(x)
File

file_config.h


STRICT Macro

STRICT Macro
C++
#define STRICT
File

winsock.cpp


SUPPORT_OTHER_PLATFORM Macro

SUPPORT_OTHER_PLATFORM Macro

For PC-based tools (leave out release builds for now)

C++
#define SUPPORT_OTHER_PLATFORM (__WIN32PC && (__TOOL || __DEV || __RESOURCECOMPILER))
File

packfile.cpp


SUPPORT_SDAT Macro

SUPPORT_SDAT Macro

No longer necessary now that rpf's are more fully encrypted

C++
#define SUPPORT_SDAT 0
File

device_psn.cpp


TCPIP Macro

TCPIP Macro
C++
#define TCPIP fiDeviceTcpIp::GetInstance()
File

ftpserver.cpp


USE_CACHED_DIRECTORY_INFO Macro

USE_CACHED_DIRECTORY_INFO Macro
C++
#define USE_CACHED_DIRECTORY_INFO 0
File

remote.cpp


USE_XCOMPRESS Macro

USE_XCOMPRESS Macro
C++
#define USE_XCOMPRESS (__XENON)
File

packfile.cpp


XCONTENT_MAX_NAME_LENGTH Macro

XCONTENT_MAX_NAME_LENGTH Macro
C++
#define XCONTENT_MAX_NAME_LENGTH XCONTENT_MAX_DISPLAYNAME_LENGTH
File

savegame_xenon.cpp


rage Namespace Classes

rage Namespace Classes
rage Namespace
Classes
Class
Description
fiArchive
fiAsciiTokenizer
fiAsciiTokenizer implements a concrete subclass of fiTokenizer for handling text files.
fiAssetManager
fiAssetManager defines the notion of an asset root directory and a current asset folder. The folders can be stacked up to eight levels deep. The class acts as a virtual class factory for fiStream objects, applying several rules for inserting an implicit leading path and a file extension. See the documentation of PushFolder and FullPath for details of the rules.
fiAsynchStream
This class implements a wrapper that allows code to asynchronously read a file into memory (via a polling interface) and then, once the operation is complete, present a normal fiStream* object that is a memory stream that will automatically free itself when the file is closed.
fiBaseTokenizer
fiBaseTokenizer implements a simple word-based file tokenizer.
Its use is deprecated in new code so it will not be documented further.
fiBinTokenizer
fiBinTokenizer implements a concrete subclass of fiTokenizer for handling binary files.
fiCachedDevice
fiCachePartition
fiCollection
fiCompressionData
Class for compressing and decompressing with the fiCompress and fiDecompress methods. Mirrored in C# in rage/base/tools/ragCompression, this class is an interface between the game and Rag.
fiDevice
Implements a device driver abstraction for the filesystem so that higher level code can access persistent storage portably. All filenames are assumed to start with some sort of device id which is used to route the file to the approperiate device. This may be something like cdrom0: or even a drive letter like D:; furthermore, we will tend to fall back on fiDeviceLocal if no other device match is found.
fiDeviceCount
fiDeviceGrowBuffer
fiDeviceInstaller
name: fiDeviceRelative
fiDeviceLocal
Concrete subclass of fiDevice which implements the local filesystem
fiDeviceLocalDrm
Concrete subclass of fiDeviceLocal which implements the local filesystem with DRM support (i.e. PS3 downloadable content)
fiDeviceMemory
Concrete subclass of fiDevice which implements memory-base streaming. The filename passed to Open must be of the form "memory:%u,%u,%d:comment" where the first value is the memory buffer and the second value is the size of the buffer. The memory is assumed to be allocated by operator new (and will be freed on close) if the third parameter is nonzero.
fiDeviceRelative
name: fiDeviceRelative
fiDeviceRemote
Concrete subclass of fiDevice which implements a simple TCP/IP-based remote filesystem. Intended for Xbox and Xenon, neither of which support simple read/write access to your host PC.
fiDeviceTcpIp
fiDeviceXContent
fiDiskCache
fiEmbeddedFile
These auto-register themselves but you still need to make sure they piggyback onto a .cpp file that is being used so that they don't get ignored by the linker.
fiMultiTokenizer
fiMultiTokenizer allows
fiPackfile
The fiPackfile device implements read-only zipfile access with compression support. Higher-level code is expected to call fiDevice::Mount with a new instance of fiPackfile that has succeeded in its Init call. The zipfile will remember the device and handle of its original filename without consuming an fiStream permanently; in theory it is possible to even nest zipfiles within zipfiles -- which can be useful if you're trying to save memory, because the entire zipfile directory structure is kept resident in memory at all times.
The file format is custom, and is created by the zip2rpf tool.
Internally each element of a pathname is stored separately (like a real filesystem would) so deep directory structures are not any more expensive, particularly if they result in shorter element names. For example, prop_sandiego_lamppost_01 would be stored more efficiently as prop/sandiego/lamppost_01 if there were many other props in sandiego.
fiRpf7Builder
fiSafeStream
Pass the result of a fiStream::Open or ASSET.Open to this class and it will assume ownership of the stream for you; its destructor will guarantee that the stream is properly closed. Use it anywhere you would use a fiStream*, it has the appropriate implicit conversion operators.
fiSaveGame
fiSaveGame manages independent save state for up to four different players.
The class is designed to be polled every frame depending on what higher-level operation is in progress.
To select the current device for load/save, call BeginSelectDevice. If it returns true, keep calling CheckSelectDevice every frame until it returns true, at which point you should call EndSelectDevice.
To enumerate all savegames on the current device, call BeginEnumeration with the largest number of content items you expect to handle. If it returns true, keep calling CheckEnumeration every frame until it returns true, at which point you can call GetEnumerationCount and GetEnumerationData. When you're done with the data, call EndEnumeration.
To save a game, call BeginSave with the display name to associate with the content and a filename to use internally and the actual save data. If it returns true, keep calling CheckSave every frame until it returns true, at which point it will also tell you if the save was successful. Next call EndSave to return to the idle state.
To load a game, call BeginLoad with the display name to associate with the content and a filename to use internally and the load data buffer. If it returns true, keep calling CheckLoad every frame until it returns true, at which point it will also tell you the amount of data read. Next call EndLoad to return to the idle state.
Note that the display name is actually internally converted into a directory name, so you can actually do multiple savegames under the same display name if you use a different filename each time. You cannot currently individually delete files under the content directory though. Also note that the system browser only lets you manipulate top-level content objects, not files within the content directory.
Any error detected causes the system to enter an error state which can only be left by doing BeginSelectDevice. The most common cause of errors is removing a memory card device.
fiSerialize
fiStream
This implements functions to do the file I/O work. Implements buffered file I/O; should be used instead of FILE in stdio.h if portability is desired.
Where practical, stdio-style interfaces are supported; most use inlines to translate into the particular member function call.
fiTokenizer
This class is to keep current code compiling:
fiZipfile
The fiZipfile device implements read-only zipfile access with compression support. Higher-level code is expected to call fiDevice::Mount with a new instance of fiZipfile that has succeeded in its Init call. The zipfile will remember the device and handle of its original filename without consuming an fiStream permanently; in theory it is possible to even nest zipfiles within zipfiles -- which can be useful if you're trying to save memory, because the entire zipfile directory structure is kept resident in memory at all times.
Internally each element of a pathname is stored separately (like a real filesystem would) so deep directory structures are not any more expensive, particularly if they result in shorter element names. For example, prop_sandiego_lamppost_01 would be stored more efficiently as prop/sandiego/lamppost_01 if there were many other props in sandiego.
Header
XenonProfile


rage Namespace Enumerations

rage Namespace Enumerations
rage Namespace
Enumerations
Enumeration | Description
eInstallDeviceStatus | the order of these enums makes it easier to combine several results into an overall one by taking the smallest value. this will indicate what's left to wait for or the "worst" result
eTypeOfSaveProcess | Changelist 130919 by Graeme Added ExtraSpaceCheck. It's almost identical to FreeSpaceCheck but gives a bit more information that I require when checking if there is enough space for save games and a profile file at the start of a PS3 game.
eTypeOfSpaceCheck | Changelist 130919 by Graeme - Added ExtraSpaceCheck. It's almost identical to FreeSpaceCheck but gives a bit more information that I require when checking if there is enough space for 13 save games and a profile file at the start of a PS3 game.
fiSeekWhence | Enumerant passed to fiDevice::Seek which determines the origin (start point) of the seek operation


rage Namespace Functions

rage Namespace Functions
rage Namespace
Functions
Function | Description
atou | Some addresses have their sign bit set, and atoi on Xenon at least will clamp!
CompileTimeAssertSize |
fgetline | Like fgets, but strips off whitespace at end of line
fgets |
fiCompress | PURPOSE Compress data using a sliding window algorithm PARAMS dest - Destination buffer destSize - Size of destination buffer; should be slightly larger than input for worse-case. Adding 1k should be sufficient. src - Source buffer (data to compress) srcSize - Amount of data to compress lookback - Maximum lookback (log2). 15 or 16 is pretty fast and still yields very good results. fullUpdate - If true, does more exhaustive table update which is substantially more expensive but improves compression by about 10% or so. Varies by data. RETURNS Number of bytes written to destination buffer. If this is greater than or equal to srcSize, calling code should assume the compression failed (common with very small datasets)
fiCompressUpperBound | PURPOSE Compute a reasonable upper bound on the compression space needed PARAMS srcSize - Size of source buffer RETURNS Estimated upper bound (for use in fiCompress destSize)
fiDecompress | PURPOSE Decompress data compressed with fiCompress PARAMS dest - Output buffer destSize - size of output buffer src - Compressed data stream srcSize - Size of input compressed data stream RETURNS True if decompression was successful, or false on failure (due to bad input data). Should never crash on malformed inputs.
fiFtpServer |
fiGetFramesSinceLastMessageBox | Return the number of frames since a message box was shown the last time.
fiLaunchFtpServerThread | Launch a thread that runs fiFtpServer
fiRemoteExec | Invoke a process; use sysExec instead of this directly.
fiRemoteGetEnv | Get env var; use sysGetEnv instead of this directly.
fiRemoteResetFiles | Reset all open files; intended only for use by rfs itself.
fiRemoteServer | Install a remote file server on specified port
fiRemoteShowAssertMessageBox | Shows a message box with the option of logging a bug on the remote PC (as per Win32 API MessageBox call)
fiRemoteShowMessageBox | Shows a message box on the remote PC (as per Win32 API MessageBox call)
fiRemoteTty | Send remote tty.
FlushCacheHeader |
fprintf |
fseek | extern fiStream* fopen(char *,char *);
GetDisplayName |
GetSaveFilePath |
MakeNewest |
MakeOldest |
NOSTRIP_PARAM |
NOSTRIP_PARAM |
NOSTRIP_XPARAM |
Quitf |
ResetCache |
StringLength | lint !e18


rage Namespace Macros

rage Namespace Macros
rage Namespace
Macros
Macro | Description
__ENABLE_RFS |
ASYNC_CACHE_COPIES | Whether cache misses are serviced asynchronously or not based on holdoff time.
CACHE_BLOCK_HANDLE |
CACHEDEV |
CORRUPT_FILE_CODE |
COULD_NOT_MAP_DEVICE_CODE |
dcDebugf1 | printf("[DiskCache] Debug1: " fmt "n",##__VA_ARGS__)
dcDebugf2 | printf("[DiskCache] Debug2: " fmt "n",##__VA_ARGS__)
dcDebugf3 | printf("[DiskCache] Debug3: " fmt "n",##__VA_ARGS__)
dcDisplayf |
dcErrorf |
dcWarningf |
DECLARE_STREAM_BUFFERS |
DIALOG_MODE | HACK_GTA4
DVD_DEVICE_NAME |
ENABLE_GAMEDATA_FOR_DISKCACHE |
FILE_ATTRIBUTE_ARCHIVE |
FILE_ATTRIBUTE_COMPRESSED |
FILE_ATTRIBUTE_DIRECTORY |
FILE_ATTRIBUTE_HIDDEN |
FILE_ATTRIBUTE_INVALID |
FILE_ATTRIBUTE_NORMAL |
FILE_ATTRIBUTE_NOT_CONTENT_INDEXED |
FILE_ATTRIBUTE_OFFLINE |
FILE_ATTRIBUTE_READONLY |
FILE_ATTRIBUTE_REPARSE_POINT |
FILE_ATTRIBUTE_SPARSE_FILE |
FILE_ATTRIBUTE_SYSTEM |
FILE_ATTRIBUTE_TEMPORARY |
IDABORT | Abort
IDCANCEL | Cancel
IDCONTINUE |
IDCUSTOM1 | following 4 ids MUST be sequential
IDCUSTOM2 |
IDCUSTOM3 |
IDCUSTOM4 |
IDIGNORE | Ignore
IDNO | No
IDOK | Ok
IDRETRY | Retry
IDTRYAGAIN |
IDYES | Yes
INSTALL_SLICE_NUM |
INSTALL_SLICE_SIZE |
MAX_CHARS_IN_TITLE_ID_FOR_SAVES_FOLDER | should never actually need more than 10 (9 + the null character)
MAX_DEVICE_NAME_LENGTH |
MAX_PARTITION_SIZE | 2 Gb per partition
MAX_XCONTENT_HANDLES |
MB_ABORTRETRYIGNORE | Abort / Retry / Ignore buttons
MB_APPLMODAL |
MB_CANCELTRYCONTINUE |
MB_DEFAULT_DESKTOP_ONLY |
MB_DEFBUTTON1 |
MB_DEFBUTTON2 |
MB_DEFBUTTON3 |
MB_DEFBUTTON4 |
MB_HELP | Help Button
MB_ICONASTERISK | Display asterisk icon
MB_ICONERROR | Display hand icon
MB_ICONHAND | Display hand icon
MB_ICONINFORMATION |
MB_ICONQUESTION | Display question icon
MB_NOFOCUS |
MB_OK | Ok button only
MB_OKCANCEL | Ok and cancel buttons
MB_RETRYCANCEL |
MB_RIGHT |
MB_SETFOREGROUND | Force to foreground window
MB_SYSTEMMODAL |
MB_TASKMODAL |
MB_TOPMOST | Force to topmost window
MB_YESNO | Yes / No buttons
MB_YESNOCANCEL | Yes / No / Cancel buttons
MULTIPLE_CACHE_FILES |
NO_FILES_EXIST_CODE |
PS3_FILE_HANDLE_HACK | TEMP: this only allows 240 rpfs to be installed and then it blocks the rest. temporary until we merge some of the rpfs, or make sony use a short
READ_PROGRESS_WATCHDOG |
READ_PROGRESS_WATCHDOG_ERROR_LIMIT_SECONDS |
REPLAY_SAVE_FILENAME |
s_Files |
s_Magic | The head and tail of the list simply live in slot zero, keeping the data simple.
s_Newest |
s_Oldest |
s_Slots |
SAVEGAME_STACK_SIZE |
SAVEGAME_STACK_SIZE_FOR_ENUMERATION |
sgDebug1 |
sgDebug2 |
sgDebug3 |
sgError |
sgWarning |
STATIC_STATE_BUFFERS |
STREAM_STORE_NAME |
THE_DEVICE_IS_NOT_READY_CODE |
USER_CANCELLED_DEVICE_SELECTION_CODE | define Xenon specific error codes


rage Namespace Namespaces

rage Namespace Namespaces
rage Namespace
Namespaces
Namespace | Description
fiSaveGameState |


rage Namespace Structs

rage Namespace Structs
rage Namespace
Structs
Struct | Description
fiDeviceProfiler |
fiPackEntry | Big-endian
fiPackfileState |
fiRpf7Entry | Needed during construction only
fiZipfileState |
Mount_t |
MsDosDate |
MsDosTime |
zipDirEntry |
CacheHeader |
DeviceMemoryState |
EncoderState |
fiFindData | Structure returned by FindFileBegin / FindFileNext
File |
fiPackHeader | Little-endian
fiRemoteDirEntry |
node |
sInstallProgress |
Slot | Entry zero is actually the file header.


rage Namespace Types

rage Namespace Types
rage Namespace
Types
Type | Description
StreamCloseCallback |
StreamCreateCallback |
StreamOpenCallback |


rage Namespace Variables

rage Namespace Variables
rage Namespace
Variables
Variable | Description
ASSET |
CACHE_BLOCK_COUNT | Slot zero is used for magic and linked list. Because of max size limits on PS3, this cannot be 4096.
CACHE_BLOCK_MASK |
CACHE_BLOCK_MAX |
CACHE_BLOCK_SHIFT | Note that FlushCacheHeader creates a structure roughly 8*CACHE_BLOCK_MAX on the stack so we need to watch the size.
CACHE_BLOCK_SIZE |
CACHE_FILE_BLOCK_COUNT |
CACHE_FILE_COUNT |
CACHE_FILE_HEADER_SIZE |
CACHE_FILE_MAGIC | Change this magic number (last digit) if you make any structural or semantic changes to the s_Header. In particular, changing either CACHE_BLOCK_COUNT, CACHE_BLOCK_SHIFT, CACHE_FILE_COUNT, or CACHE_FILE_SHIFT require a new magic number to avoid crashing on old cache files.
CACHE_FILE_SIZE |
CACHE_FILE_VERSION |
CACHE_PADDING |
CACHE_SUBFILE_COUNT | number of cache files
CACHE_SUBFILE_MASK |
CACHE_SUBFILE_SHIFT | number of bits per cache file
CENTINANOSECONDS_PER_SECOND |
fiIsShowingMessageBox | Indicates whether a message box is currently being displayed or not (useful for avoiding timeouts)
FileName |
FILETIME_2000 | #include #include #include void main() { SYSTEMTIME _2000 = { 2000, 1, 0, 1, 0, 0, 0, 0 }; unsigned __int64 ft; SystemTimeToFileTime(&_2000, (FILETIME*)&ft); char buffer[100]; _ui64toa(ft,buffer,10); printf("filetime of 2000 %sn",buffer); } Seconds since January 1, 2000 gives us a reach of 136 years.
fiRemoteServerIsRunning | Indicates whether rfs is properly installed or not; valid after fiDeviceRemote::InitClass is called.
g_AES |
g_enumeratedContent |
g_fiCaseSensitive |
g_IsExiting |
g_numContent |
g_SaveGameState | Changelist 129860 by Adam Implemented savegame state and also assert on calling the wrong functions based on what the savegame state is
gExitThread |
info_table |
m_State |
MAX_RPFS |
maxMem |
MaxPackfiles | If we raise this past 256 we'll need to decrement fiCollection::ArchiveShift again.
messageToken |
nameheap |
nameshift |
pgStreamingLog |
pgStreamingLogToken |
pIconImage |
RAGE_MAX_PATH | Maximum length of a path, including the terminating NUL character.
s_bCalculateSizeOnDisk |
s_bCheckForUserBindErrors |
s_bCheckingForFreeSpace | HACK_GTA4
s_bFileMissing | MP3MOD
s_bHasCreator |
s_bIsCreator |
s_CacheBlockFiles |
s_CachedDevices | Final builds always have monolithic rpfs. Other builds may have more.
s_CacheFile |
s_CachePath | typically /dev_hdd1 but we're not supposed to count on that.
s_CacheWorkerThread |
s_Container |
s_Content |
s_ContentMax |
s_count |
s_Counts |
s_Data |
s_DataSize |
s_DefaultDevice |
s_DefaultDeviceReadOnly |
s_Device |
s_DeviceCount |
s_DeviceGrowBuffer |
s_DeviceLocal |
s_DeviceMemory |
s_DeviceUpdateDebug |
s_DirName |
s_DisplayName |
s_Done |
s_DummyProfiler |
s_EnumCount |
s_eSaveProcessToPerform |
s_FileExists |
s_FilenameBuf |
s_FileProgress |
s_fileSize |
s_FileSize |
s_filetime | in seconds
s_Handle |
s_hddFreeSizeKB | HACK_GTA4
s_Header |
s_Header_CritSec |
s_HoldoffDelta |
s_HoldoffTime |
s_IsCachePrimed | Assume the cache is primed if you never called fiDiskCache::InitClass, so that normal (non-megarpf) development will still get random start screens, etc.
s_IsValid |
s_LastError |
s_lastErrorCode |
s_LastThreadOwner |
s_Loads |
s_LocalHost |
s_location |
s_MaxNumberOfDirectories |
s_MemoryState |
s_ModifiedTimeHigh |
s_ModifiedTimeLow |
s_Mounts |
s_netError | see
s_netErrorCount |
s_NumInProgressBlocks |
s_numRpfs |
s_NumValidBlocks |
s_pDeviceUpdate |
s_PendingState |
s_Profiles |
s_Reader |
s_ResidentMap | Data structure which maps a source block to the cache block tracking it (the cache block itself may be either resident or pending)
s_SaveGameSizes |
s_Saves |
s_Selects |
s_setBuf |
s_setList |
s_ShutdownCacheWorkerThread |
s_SizeOfIconAndSystemFiles |
s_SizeOfSystemOverheads |
s_SpaceRequired |
s_SpaceRequiredToSaveThisFile |
s_States |
s_TcpIpInstance |
s_TcpIpLastError |
s_ThreadId |
s_TitleIdForSavesFolder |
s_TitleString |
s_TotalHDDFreeSize |
s_UserBindErrorMsg |
s_ZipfileOpen |
s_ZipOpen |
s_ZipStates |
SAVEGAME |
secureFileId |
SizeOfIconImage |
sm_ExtraSpaceRequired |
sm_FallbackToDefaultDevice |
sm_IsLoadedDataValid |
sm_MatchLongestPath |
sm_MatchNewest |
tls_Uncached | HACK HACK HACK
XCONTENT_DATA_SIZE |
XEX_TITLE_ID | HACK_GTA4


fiArchive Class Constructors

fiArchive Class Constructors
fiArchive Class
Constructors
Constructor | Description
fiArchive |


Constructors

Legend
Method


Legend

Legend
fiArchive Class
Legend
Method


fiArchive Class Members

fiArchive Class Members
fiArchive Class
Members
Constructors
Constructor | Description
fiArchive |
Methods
Method | Description
GetVersion |
IsLoading |
IsStoring |
Operators
Operator | Description
& |


Members

Legend
Method


fiArchive Class Methods

fiArchive Class Methods
fiArchive Class
Methods
Method | Description
GetVersion |
IsLoading |
IsStoring |


Methods

Legend
Method


fiArchive Class Operators

fiArchive Class Operators
fiArchive Class
Operators
Operator | Description
& |


Operators

Legend
Method


Inheritance Hierarchy

Inheritance Hierarchy
fiArchive Class
Inheritance Hierarchy
fiArchive


fiAsciiTokenizer Class Constructors

fiAsciiTokenizer Class Constructors
fiAsciiTokenizer Class
Constructors
Constructor | Description
fiAsciiTokenizer |


fiAsciiTokenizer Class Data Members

fiAsciiTokenizer Class Data Members
fiAsciiTokenizer Class
Data Members
Data Member | Description
CommentChar |
filename |
line |
m_nNumTabs | Holds the current indentation tabs
m_WriteState |
nextch |
S |


Data Members

Legend
Data Member
protected


fiAsciiTokenizer Class Destructors

fiAsciiTokenizer Class Destructors
fiAsciiTokenizer Class
Destructors
Destructor | Description
~fiBaseTokenizer |


Destructors

Legend
Method
virtual


fiAsciiTokenizer Class Enumerations

fiAsciiTokenizer Class Enumerations
fiAsciiTokenizer Class
Enumerations
Enumeration | Description
enState |


Legend

Legend
fiAsciiTokenizer Class
Legend
Data Member
protected
Method
virtual
abstract


fiAsciiTokenizer Class Members

fiAsciiTokenizer Class Members
fiAsciiTokenizer Class
Members
Data Members
Data Member | Description
CommentChar |
filename |
line |
m_nNumTabs | Holds the current indentation tabs
m_WriteState |
nextch |
S |
Constructors
Constructor | Description
fiAsciiTokenizer |
Methods
Method | Description
CheckIToken |
CheckToken |
EndBlock | Decreases the tab by one
EndBlock | Decreases the tab by one
EndLine | Starts a new line
EndLine | Starts a new line
EndOfFile |
GetBlock | get a block of "length" characters
GetByte | read functions:
GetByte | Reads a numerical value and returns it
GetDelimiter |
GetDelimiter |
GetFloat | Reads a numerical value and returns it
GetFloat | Reads a numerical value and returns it
GetHexU32 |
GetInt | Reads a numerical value and returns it
GetInt | Reads a numerical value and returns it
GetLine |
GetName |
GetNextCh |
GetShort | Reads a numerical value and returns it
GetShort | Reads a numerical value and returns it
GetStream |
GetStreamPosition |
GetToken | read functions:
GetTokenCh |
GetTokenToChar |
GetTokenToChars |
GetVector | Reads a numerical value and returns it
GetVector | Reads a numerical value and returns it
GetWriteState |
IgnoreToken |
Indent |
Indent |
Init |
IsBinary |
IsBinary |
iswhitespace |
MatchFloat |
MatchFloat |
MatchIFloat |
MatchIFloat |
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchIToken |
MatchIVector |
MatchIVector |
MatchToken |
MatchVector |
MatchVector |
Pop | pop the current block as defined by "{" and "}" delimiters. this will also pop any sub-blocks. useful for file formats in a state of flux.
Put |
Put |
PutByte |
PutByte |
PutDelimiter |
PutDelimiter |
PutShort |
PutShort |
PutStr |
PutStrLine | convenience functions
Reset |
SetNextCh |
SetStreamPosition |
SetTerminators | Sets a list of characters that should be used for terminating tokens and skipped over.
SetWriteState |
SkipComment |
SkipToEndOfLine |
StartBlock | Increases the tab by one
StartBlock | Increases the tab by one
StartLine | Indents by tab
StartLine | Indents by tab
WriteTabs |
Destructors
Destructor | Description
~fiBaseTokenizer |
Enumerations
Enumeration | Description
enState |


Members

Legend
Data Member
protected
Method
virtual
abstract


fiAsciiTokenizer Class Methods

fiAsciiTokenizer Class Methods
fiAsciiTokenizer Class
Methods
Method | Description
CheckIToken |
CheckToken |
EndBlock | Decreases the tab by one
EndBlock | Decreases the tab by one
EndLine | Starts a new line
EndLine | Starts a new line
EndOfFile |
GetBlock | get a block of "length" characters
GetByte | read functions:
GetByte | Reads a numerical value and returns it
GetDelimiter |
GetDelimiter |
GetFloat | Reads a numerical value and returns it
GetFloat | Reads a numerical value and returns it
GetHexU32 |
GetInt | Reads a numerical value and returns it
GetInt | Reads a numerical value and returns it
GetLine |
GetName |
GetNextCh |
GetShort | Reads a numerical value and returns it
GetShort | Reads a numerical value and returns it
GetStream |
GetStreamPosition |
GetToken | read functions:
GetTokenCh |
GetTokenToChar |
GetTokenToChars |
GetVector | Reads a numerical value and returns it
GetVector | Reads a numerical value and returns it
GetWriteState |
IgnoreToken |
Indent |
Indent |
Init |
IsBinary |
IsBinary |
iswhitespace |
MatchFloat |
MatchFloat |
MatchIFloat |
MatchIFloat |
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchIToken |
MatchIVector |
MatchIVector |
MatchToken |
MatchVector |
MatchVector |
Pop | pop the current block as defined by "{" and "}" delimiters. this will also pop any sub-blocks. useful for file formats in a state of flux.
Put |
Put |
PutByte |
PutByte |
PutDelimiter |
PutDelimiter |
PutShort |
PutShort |
PutStr |
PutStrLine | convenience functions
Reset |
SetNextCh |
SetStreamPosition |
SetTerminators | Sets a list of characters that should be used for terminating tokens and skipped over.
SetWriteState |
SkipComment |
SkipToEndOfLine |
StartBlock | Increases the tab by one
StartBlock | Increases the tab by one
StartLine | Indents by tab
StartLine | Indents by tab
WriteTabs |


Methods

Legend
Method
virtual
abstract
protected


Inheritance Hierarchy

Inheritance Hierarchy
fiAsciiTokenizer Class
Inheritance Hierarchy
rage::fiBaseTokenizer
    fiAsciiTokenizer
        rage::fiTokenizer


fiAssetManager Class Constructors

fiAssetManager Class Constructors
fiAssetManager Class
Constructors
Constructor | Description
fiAssetManager | Constructor


fiAssetManager Class Data Members

fiAssetManager Class Data Members
fiAssetManager Class
Data Members
Data Member | Description
MAX_FILENAME_LENGTH | Maximum length of the filename part of the filename on all supported platforms. Note that the entire pathname can be longer, this is just the longest allowed on any one segment of it. Limit is currently tied to Xbox FATX limit.


Data Members

Legend
Data Member


fiAssetManager Class Destructors

fiAssetManager Class Destructors
fiAssetManager Class
Destructors
Destructor | Description
~fiAssetManager | Destructor


Destructors

Legend
Method


Legend

Legend
fiAssetManager Class
Legend
Data Member
Method


fiAssetManager Class Members

fiAssetManager Class Members
fiAssetManager Class
Members
Data Members
Data Member | Description
MAX_FILENAME_LENGTH | Maximum length of the filename part of the filename on all supported platforms. Note that the entire pathname can be longer, this is just the longest allowed on any one segment of it. Limit is currently tied to Xbox FATX limit.
Structs
Struct | Description
Entry |
Constructors
Constructor | Description
fiAssetManager | Constructor
Destructors
Destructor | Description
~fiAssetManager | Destructor
Methods
Method | Description
AddExtension | Appends the "base.ext" to the dest buffer (unless base already ended with the right extensions) and normalizes slashes
BaseName | Utility function which returns the base name of a fully-qualified name.
ClearAttributes | Clear specific attributes of an asset
Create | Attempts to create a file
CreateLeadingPath | Creates any intermediate directories necessary for 'filename'
EnumFiles | Enumerate all files in a given directory through a user-supplied callback
Exists | Attempts to determine if a file exists
FileName | Utility function which returns the filename portion of a fully-qualified name.
FindExtensionInPath | Finds file extension in the specified filename.
FindPath | Returns the index of the path that contains the file given. Give this index to FullPath so that the appropriate full path is used, when there is more than one.
FullPath | Returns a fully-qualified pathname based on the input base name, input extension, current asset root, and current asset folder.
FullReadPath | Returns a fully-qualified pathname based on the input base name, input extension, current asset root, and current asset folder. Will search through all registered paths in order for the first match.
FullWritePath | Returns a fully-qualified pathname based on the input base name, input extension, current asset root, and current asset folder. Always uses the current write path (which is usually the first element, but that can be changed via the '*' special marker).
GetAttributes | Retrieve file attributes of an asset
GetPath |
GetPathCount |
GetStackedPath |
InsertPathElement | Inserts a path element between the path part (if present) and the filename part.
IsAbsolutePath | Returns true if the path name is an absolute path
MakeFolderRelative | Returns a folder relative path to an existing file based on the current path roots and pushed folders (if possible)
MakeRelative | Returns a relative path to an existing file based on the current path roots (if possible)
Open | Attempts to open a file
PopFolder | Pops the last folder off of the current asset folder stack.
PushFolder | Pushes new folder onto current asset folder stack
RemoveExtensionFromPath | Removes the extension from the specified filename if present. This function is more robust that just using strrchr because it stops at the first slash character so it doesn't screw up relative pathnames.
RemoveNameFromPath | Removes the last name in the path (and the resulting trailing slash or backslash)
SetAttributes | Set file attributes of an asset
SetPath | Sets the asset root path.


Members

Legend
Data Member
Method


fiAssetManager Class Methods

fiAssetManager Class Methods
fiAssetManager Class
Methods
Method | Description
AddExtension | Appends the "base.ext" to the dest buffer (unless base already ended with the right extensions) and normalizes slashes
BaseName | Utility function which returns the base name of a fully-qualified name.
ClearAttributes | Clear specific attributes of an asset
Create | Attempts to create a file
CreateLeadingPath | Creates any intermediate directories necessary for 'filename'
EnumFiles | Enumerate all files in a given directory through a user-supplied callback
Exists | Attempts to determine if a file exists
FileName | Utility function which returns the filename portion of a fully-qualified name.
FindExtensionInPath | Finds file extension in the specified filename.
FindPath | Returns the index of the path that contains the file given. Give this index to FullPath so that the appropriate full path is used, when there is more than one.
FullPath | Returns a fully-qualified pathname based on the input base name, input extension, current asset root, and current asset folder.
FullReadPath | Returns a fully-qualified pathname based on the input base name, input extension, current asset root, and current asset folder. Will search through all registered paths in order for the first match.
FullWritePath | Returns a fully-qualified pathname based on the input base name, input extension, current asset root, and current asset folder. Always uses the current write path (which is usually the first element, but that can be changed via the '*' special marker).
GetAttributes | Retrieve file attributes of an asset
GetPath |
GetPathCount |
GetStackedPath |
InsertPathElement | Inserts a path element between the path part (if present) and the filename part.
IsAbsolutePath | Returns true if the path name is an absolute path
MakeFolderRelative | Returns a folder relative path to an existing file based on the current path roots and pushed folders (if possible)
MakeRelative | Returns a relative path to an existing file based on the current path roots (if possible)
Open | Attempts to open a file
PopFolder | Pops the last folder off of the current asset folder stack.
PushFolder | Pushes new folder onto current asset folder stack
RemoveExtensionFromPath | Removes the extension from the specified filename if present. This function is more robust that just using strrchr because it stops at the first slash character so it doesn't screw up relative pathnames.
RemoveNameFromPath | Removes the last name in the path (and the resulting trailing slash or backslash)
SetAttributes | Set file attributes of an asset
SetPath | Sets the asset root path.


fiAssetManager Class Structs

fiAssetManager Class Structs
fiAssetManager Class
Structs
Struct | Description
Entry |


Inheritance Hierarchy

Inheritance Hierarchy
fiAssetManager Class
Inheritance Hierarchy
fiAssetManager


fiAsynchStream Class Constructors

fiAsynchStream Class Constructors
fiAsynchStream Class
Constructors
Constructor | Description
fiAsynchStream |


fiAsynchStream Class Destructors

fiAsynchStream Class Destructors
fiAsynchStream Class
Destructors
Destructor | Description
~fiAsynchStream |


Legend

Legend
fiAsynchStream Class
Legend
Method


fiAsynchStream Class Members

fiAsynchStream Class Members
fiAsynchStream Class
Members
Constructors
Constructor | Description
fiAsynchStream |
Destructors
Destructor | Description
~fiAsynchStream |
Methods
Method | Description
GetMemoryFileName | If the file has finished streaming in, returns a suitable memory filename that can be passed to any function that expects a filename. PARMS: dest - Destination buffer for name destSize - sizeof(dest);
GetSize |
Init | Uses ASSET.Open semantics to attempt to asynchronously schedule the file open. Will not block if (and only if) you're using archives.
Poll | Determine if the file operation has completed yet.


fiAsynchStream Class Methods

fiAsynchStream Class Methods
fiAsynchStream Class
Methods
Method | Description
GetMemoryFileName | If the file has finished streaming in, returns a suitable memory filename that can be passed to any function that expects a filename. PARMS: dest - Destination buffer for name destSize - sizeof(dest);
GetSize |
Init | Uses ASSET.Open semantics to attempt to asynchronously schedule the file open. Will not block if (and only if) you're using archives.
Poll | Determine if the file operation has completed yet.


Inheritance Hierarchy

Inheritance Hierarchy
fiAsynchStream Class
Inheritance Hierarchy
fiAsynchStream


fiBaseTokenizer Class Data Members

fiBaseTokenizer Class Data Members
fiBaseTokenizer Class
Data Members
Data Member | Description
CommentChar |
filename |
line |
m_WriteState |
nextch |
S |


fiBaseTokenizer Class Destructors

fiBaseTokenizer Class Destructors
fiBaseTokenizer Class
Destructors
Destructor | Description
~fiBaseTokenizer |


fiBaseTokenizer Class Enumerations

fiBaseTokenizer Class Enumerations
fiBaseTokenizer Class
Enumerations
Enumeration | Description
enState |


Legend

Legend
fiBaseTokenizer Class
Legend
Data Member
protected
Method
virtual
abstract


fiBaseTokenizer Class Members

fiBaseTokenizer Class Members
fiBaseTokenizer Class
Members
Data Members
Data Member | Description
CommentChar |
filename |
line |
m_WriteState |
nextch |
S |
Destructors
Destructor | Description
~fiBaseTokenizer |
Methods
Method | Description
CheckIToken |
CheckToken |
EndBlock | Decreases the tab by one
EndLine | Starts a new line
EndOfFile |
GetBlock | get a block of "length" characters
GetByte | Reads a numerical value and returns it
GetDelimiter |
GetFloat | Reads a numerical value and returns it
GetInt | Reads a numerical value and returns it
GetLine |
GetName |
GetNextCh |
GetShort | Reads a numerical value and returns it
GetStream |
GetStreamPosition |
GetToken | read functions:
GetTokenCh |
GetTokenToChar |
GetTokenToChars |
GetVector | Reads a numerical value and returns it
GetWriteState |
IgnoreToken |
Indent |
Init |
IsBinary |
iswhitespace |
MatchFloat |
MatchIFloat |
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchIToken |
MatchIVector |
MatchToken |
MatchVector |
Pop | pop the current block as defined by "{" and "}" delimiters. this will also pop any sub-blocks. useful for file formats in a state of flux.
Put |
PutByte |
PutDelimiter |
PutShort |
PutStr |
PutStrLine | convenience functions
Reset |
SetNextCh |
SetStreamPosition |
SetTerminators | Sets a list of characters that should be used for terminating tokens and skipped over.
SetWriteState |
SkipComment |
SkipToEndOfLine |
StartBlock | Increases the tab by one
StartLine | Indents by tab
Enumerations
Enumeration | Description
enState |


fiBaseTokenizer Class Methods

fiBaseTokenizer Class Methods
fiBaseTokenizer Class
Methods
Method | Description
CheckIToken |
CheckToken |
EndBlock | Decreases the tab by one
EndLine | Starts a new line
EndOfFile |
GetBlock | get a block of "length" characters
GetByte | Reads a numerical value and returns it
GetDelimiter |
GetFloat | Reads a numerical value and returns it
GetInt | Reads a numerical value and returns it
GetLine |
GetName |
GetNextCh |
GetShort | Reads a numerical value and returns it
GetStream |
GetStreamPosition |
GetToken | read functions:
GetTokenCh |
GetTokenToChar |
GetTokenToChars |
GetVector | Reads a numerical value and returns it
GetWriteState |
IgnoreToken |
Indent |
Init |
IsBinary |
iswhitespace |
MatchFloat |
MatchIFloat |
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchIToken |
MatchIVector |
MatchToken |
MatchVector |
Pop | pop the current block as defined by "{" and "}" delimiters. this will also pop any sub-blocks. useful for file formats in a state of flux.
Put |
PutByte |
PutDelimiter |
PutShort |
PutStr |
PutStrLine | convenience functions
Reset |
SetNextCh |
SetStreamPosition |
SetTerminators | Sets a list of characters that should be used for terminating tokens and skipped over.
SetWriteState |
SkipComment |
SkipToEndOfLine |
StartBlock | Increases the tab by one
StartLine | Indents by tab


Inheritance Hierarchy

Inheritance Hierarchy
fiBaseTokenizer Class
Inheritance Hierarchy
fiBaseTokenizer
    rage::fiAsciiTokenizer
    rage::fiBinTokenizer


fiBinTokenizer Class Data Members

fiBinTokenizer Class Data Members
fiBinTokenizer Class
Data Members
Data Member | Description
CommentChar |
filename |
line |
m_WriteState |
nextch |
S |


fiBinTokenizer Class Destructors

fiBinTokenizer Class Destructors
fiBinTokenizer Class
Destructors
Destructor | Description
~fiBaseTokenizer |


fiBinTokenizer Class Enumerations

fiBinTokenizer Class Enumerations
fiBinTokenizer Class
Enumerations
Enumeration | Description
enState |


Legend

Legend
fiBinTokenizer Class
Legend
Method
virtual
abstract
protected
Data Member


fiBinTokenizer Class Members

fiBinTokenizer Class Members
fiBinTokenizer Class
Members
Methods
Method | Description
CheckIToken |
CheckToken |
EndBlock | Decreases the tab by one
EndLine | Starts a new line
EndOfFile |
GetBlock | get a block of "length" characters
GetByte | Reads a numerical value and returns it
GetByte | read functions:
GetDelimiter |
GetDelimiter |
GetFloat | Reads a numerical value and returns it
GetFloat | Reads a numerical value and returns it
GetInt | Reads a numerical value and returns it
GetInt | Reads a numerical value and returns it
GetLine |
GetName |
GetNextCh |
GetShort | Reads a numerical value and returns it
GetShort | Reads a numerical value and returns it
GetStream |
GetStreamPosition |
GetToken | read functions:
GetTokenCh |
GetTokenToChar |
GetTokenToChars |
GetVector | Reads a numerical value and returns it
GetVector | Reads a numerical value and returns it
GetWriteState |
IgnoreToken |
Indent |
Init |
IsBinary |
IsBinary |
iswhitespace |
MatchFloat |
MatchFloat |
MatchIFloat |
MatchIFloat |
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchIToken |
MatchIVector |
MatchIVector |
MatchToken |
MatchVector |
MatchVector |
Pop | pop the current block as defined by "{" and "}" delimiters. this will also pop any sub-blocks. useful for file formats in a state of flux.
Put |
Put |
PutByte |
PutByte |
PutDelimiter |
PutDelimiter |
PutShort |
PutShort |
PutStr |
PutStrLine | convenience functions
Reset |
SetNextCh |
SetStreamPosition |
SetTerminators | Sets a list of characters that should be used for terminating tokens and skipped over.
SetWriteState |
SkipComment |
SkipToEndOfLine |
StartBlock | Increases the tab by one
StartLine | Indents by tab
Data Members
Data Member | Description
CommentChar |
filename |
line |
m_WriteState |
nextch |
S |
Destructors
Destructor | Description
~fiBaseTokenizer |
Enumerations
Enumeration | Description
enState |


Members

Legend
Method
virtual
abstract
protected
Data Member


fiBinTokenizer Class Methods

fiBinTokenizer Class Methods
fiBinTokenizer Class
Methods
Method | Description
CheckIToken |
CheckToken |
EndBlock | Decreases the tab by one
EndLine | Starts a new line
EndOfFile |
GetBlock | get a block of "length" characters
GetByte | Reads a numerical value and returns it
GetByte | read functions:
GetDelimiter |
GetDelimiter |
GetFloat | Reads a numerical value and returns it
GetFloat | Reads a numerical value and returns it
GetInt | Reads a numerical value and returns it
GetInt | Reads a numerical value and returns it
GetLine |
GetName |
GetNextCh |
GetShort | Reads a numerical value and returns it
GetShort | Reads a numerical value and returns it
GetStream |
GetStreamPosition |
GetToken | read functions:
GetTokenCh |
GetTokenToChar |
GetTokenToChars |
GetVector | Reads a numerical value and returns it
GetVector | Reads a numerical value and returns it
GetWriteState |
IgnoreToken |
Indent |
Init |
IsBinary |
IsBinary |
iswhitespace |
MatchFloat |
MatchFloat |
MatchIFloat |
MatchIFloat |
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchIToken |
MatchIVector |
MatchIVector |
MatchToken |
MatchVector |
MatchVector |
Pop | pop the current block as defined by "{" and "}" delimiters. this will also pop any sub-blocks. useful for file formats in a state of flux.
Put |
Put |
PutByte |
PutByte |
PutDelimiter |
PutDelimiter |
PutShort |
PutShort |
PutStr |
PutStrLine | convenience functions
Reset |
SetNextCh |
SetStreamPosition |
SetTerminators | Sets a list of characters that should be used for terminating tokens and skipped over.
SetWriteState |
SkipComment |
SkipToEndOfLine |
StartBlock | Increases the tab by one
StartLine | Indents by tab


Inheritance Hierarchy

Inheritance Hierarchy
fiBinTokenizer Class
Inheritance Hierarchy
rage::fiBaseTokenizer
    fiBinTokenizer


fiCachedDevice Class Constructors

fiCachedDevice Class Constructors
fiCachedDevice Class
Constructors
Constructor | Description
fiDevice |


fiCachedDevice Class Data Members

fiCachedDevice Class Data Members
fiCachedDevice Class
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.


fiCachedDevice Class Destructors

fiCachedDevice Class Destructors
fiCachedDevice Class
Destructors
Destructor | Description
~fiDevice |


fiCachedDevice Class Enumerations

fiCachedDevice Class Enumerations
fiCachedDevice Class
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


fiCachedDevice Class Friends

fiCachedDevice Class Friends
fiCachedDevice Class
Friends
Friend | Description
class fiDiskCache |


Legend

Legend
fiCachedDevice Class
Legend
Method
virtual
abstract
Data Member
protected


fiCachedDevice Class Members

fiCachedDevice Class Members
fiCachedDevice Class
Members
Methods
Method | Description
Close |
Close | Close a file
CloseBulk |
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create |
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetBlockPhysicalSortKey |
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open |
Open | Attempt to open a file on this device
OpenBulk |
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
Prefetch |
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read |
Read | Read binary data from file
ReadBulk |
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek |
Seek | Seek to a location in file
Seek64 |
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime |
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write |
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
Friends
Friend | Description
class fiDiskCache |
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
Destructors
Destructor | Description
~fiDevice |
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


Members

Legend
Method
virtual
abstract
Data Member
protected


fiCachedDevice Class Methods

fiCachedDevice Class Methods
fiCachedDevice Class
Methods
Method | Description
Close |
Close | Close a file
CloseBulk |
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create |
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetBlockPhysicalSortKey |
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open |
Open | Attempt to open a file on this device
OpenBulk |
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
Prefetch |
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read |
Read | Read binary data from file
ReadBulk |
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek |
Seek | Seek to a location in file
Seek64 |
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime |
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write |
Write | Write binary data to file
WriteBulk | Seek and write binary data to file


Methods

Legend
Method
virtual
abstract


fiCachedDevice Class Structs

fiCachedDevice Class Structs
fiCachedDevice Class
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)


Inheritance Hierarchy

Inheritance Hierarchy
fiCachedDevice Class
Inheritance Hierarchy
rage::fiDevice
    fiCachedDevice


Legend

Legend
fiCachePartition Class
Legend
Method


fiCachePartition Class Members

fiCachePartition Class Members
fiCachePartition Class
Members
Methods
Method | Description
GetCachePrefix |
Init |
IsAvailable |
Reset |
Shutdown |


fiCachePartition Class Methods

fiCachePartition Class Methods
fiCachePartition Class
Methods
Method | Description
GetCachePrefix |
Init |
IsAvailable |
Reset |
Shutdown |


Inheritance Hierarchy

Inheritance Hierarchy
fiCachePartition Class
Inheritance Hierarchy
fiCachePartition


fiCollection Class Constructors

fiCollection Class Constructors
fiCollection Class
Constructors
Constructor | Description
fiCollection |
fiDevice |


fiCollection Class Data Members

fiCollection Class Data Members
fiCollection Class
Data Members
Data Member | Description
ArchiveMask |
ArchiveShift |
EntryMask |
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
m_isStreaming |
sm_Collections | Entry 0 is never used. (except by the pgRawStreamer)
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.


Data Members

Legend
protected
Data Member


fiCollection Class Destructors

fiCollection Class Destructors
fiCollection Class
Destructors
Destructor | Description
~fiDevice |


fiCollection Class Enumerations

fiCollection Class Enumerations
fiCollection Class
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


Legend

Legend
fiCollection Class
Legend
protected
Data Member
Method
abstract
virtual


fiCollection Class Members

fiCollection Class Members
fiCollection Class
Members
Data Members
Data Member | Description
ArchiveMask |
ArchiveShift |
EntryMask |
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
m_isStreaming |
sm_Collections | Entry 0 is never used. (except by the pgRawStreamer)
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Constructors
Constructor | Description
fiCollection |
fiDevice |
Methods
Method | Description
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetBasePhysicalSortKey |
GetBulkOffset |
GetCollection |
GetCollectionIndex |
GetDebugName |
GetDevice | Returns appropriate device for file
GetEntryFullName | Slower
GetEntryIndex |
GetEntryInfo |
GetEntryName |
GetEntryPhysicalSortKey |
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsPackfile |
IsRpf |
IsStreaming |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeHandle |
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
OpenBulkFromHandle |
Prefetch |
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
SetStreaming |
Shutdown |
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Destructors
Destructor | Description
~fiDevice |
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


Members

Legend
protected
Data Member
Method
abstract
virtual


fiCollection Class Methods

fiCollection Class Methods
fiCollection Class
Methods
Method | Description
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetBasePhysicalSortKey |
GetBulkOffset |
GetCollection |
GetCollectionIndex |
GetDebugName |
GetDevice | Returns appropriate device for file
GetEntryFullName | Slower
GetEntryIndex |
GetEntryInfo |
GetEntryName |
GetEntryPhysicalSortKey |
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsPackfile |
IsRpf |
IsStreaming |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeHandle |
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
OpenBulkFromHandle |
Prefetch |
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
SetStreaming |
Shutdown |
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
WriteBulk | Seek and write binary data to file


Methods

Legend
Method
abstract
virtual


fiCollection Class Structs

fiCollection Class Structs
fiCollection Class
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)


Inheritance Hierarchy

Inheritance Hierarchy
fiCollection Class
Inheritance Hierarchy
rage::fiDevice
    fiCollection
        rage::fiPackfile


fiCompressionData Class Constructors

fiCompressionData Class Constructors
fiCompressionData Class
Constructors
Constructor | Description
fiCompressionData |


fiCompressionData Class Destructors

fiCompressionData Class Destructors
fiCompressionData Class
Destructors
Destructor | Description
~fiCompressionData |


Legend

Legend
fiCompressionData Class
Legend
Method


fiCompressionData Class Members

fiCompressionData Class Members
fiCompressionData Class
Members
Constructors
Constructor | Description
fiCompressionData |
Destructors
Destructor | Description
~fiCompressionData |
Methods
Method | Description
BuildHeader | Builds the header section for the Compression Factory
Compress | Compresses the data into a buffer using fiCompress
CreateNewInstance | Creates a new instance of this class to be used by the sysCompressionFactory
Decompress | Decompresses the data into a buffer of the specified length using fiDecompress
GetCompressUpperBound | Retrieves an estimate of the maximum length the of the compressed data with the given size using fiCompressUpperBound
GetHeaderPrefix | Retrieves the unique header prefix string so the Compression Factory can find the start of a CompressedData set
GetHeaderSize | Retrieves the size of this class's header data
GetStaticHeaderPrefix | Retrieves the unique header prefix string so the Compression Factory can find the start of a CompressedData set Useful when calling for sysCompressionFactory::CompressData( const char*, u8*, u32, u32& ).
ParseHeader | Assuming compressedData starts with a valid header, retrieves the compressed data size and decompressed data size


fiCompressionData Class Methods

fiCompressionData Class Methods
fiCompressionData Class
Methods
Method | Description
BuildHeader | Builds the header section for the Compression Factory
Compress | Compresses the data into a buffer using fiCompress
CreateNewInstance | Creates a new instance of this class to be used by the sysCompressionFactory
Decompress | Decompresses the data into a buffer of the specified length using fiDecompress
GetCompressUpperBound | Retrieves an estimate of the maximum length the of the compressed data with the given size using fiCompressUpperBound
GetHeaderPrefix | Retrieves the unique header prefix string so the Compression Factory can find the start of a CompressedData set
GetHeaderSize | Retrieves the size of this class's header data
GetStaticHeaderPrefix | Retrieves the unique header prefix string so the Compression Factory can find the start of a CompressedData set Useful when calling for sysCompressionFactory::CompressData( const char*, u8*, u32, u32& ).
ParseHeader | Assuming compressedData starts with a valid header, retrieves the compressed data size and decompressed data size


Inheritance Hierarchy

Inheritance Hierarchy
fiCompressionData Class
Inheritance Hierarchy
sysCompressionData
    fiCompressionData


fiDevice Class Constructors

fiDevice Class Constructors
fiDevice Class
Constructors
Constructor | Description
fiDevice |


fiDevice Class Data Members

fiDevice Class Data Members
fiDevice Class
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.


fiDevice Class Destructors

fiDevice Class Destructors
fiDevice Class
Destructors
Destructor | Description
~fiDevice |


fiDevice Class Enumerations

fiDevice Class Enumerations
fiDevice Class
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


Legend

Legend
fiDevice Class
Legend
Data Member
protected
Method
virtual
abstract


fiDevice Class Members

fiDevice Class Members
fiDevice Class
Members
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
Destructors
Destructor | Description
~fiDevice |
Methods
Method | Description
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


fiDevice Class Methods

fiDevice Class Methods
fiDevice Class
Methods
Method | Description
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
WriteBulk | Seek and write binary data to file


fiDevice Class Structs

fiDevice Class Structs
fiDevice Class
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)


Inheritance Hierarchy

Inheritance Hierarchy
fiDevice Class
Inheritance Hierarchy
fiDevice
    rage::fiCachedDevice
    rage::fiCollection
    rage::fiDeviceCount
    rage::fiDeviceGrowBuffer
    rage::fiDeviceInstaller
    rage::fiDeviceLocal
    rage::fiDeviceMemory
    rage::fiDeviceRelative
    rage::fiDeviceRemote
    rage::fiDeviceTcpIp
    rage::fiZipfile


fiDeviceCount Class Constructors

fiDeviceCount Class Constructors
fiDeviceCount Class
Constructors
Constructor | Description
fiDevice |


fiDeviceCount Class Data Members

fiDeviceCount Class Data Members
fiDeviceCount Class
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.


fiDeviceCount Class Destructors

fiDeviceCount Class Destructors
fiDeviceCount Class
Destructors
Destructor | Description
~fiDevice |


fiDeviceCount Class Enumerations

fiDeviceCount Class Enumerations
fiDeviceCount Class
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


Legend

Legend
fiDeviceCount Class
Legend
Method
abstract
virtual
Data Member
protected


fiDeviceCount Class Members

fiDeviceCount Class Members
fiDeviceCount Class
Members
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime |
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open |
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read |
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime |
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size | Determine size of file
Size64 | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write |
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
Destructors
Destructor | Description
~fiDevice |
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


Members

Legend
Method
abstract
virtual
Data Member
protected


fiDeviceCount Class Methods

fiDeviceCount Class Methods
fiDeviceCount Class
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime |
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open |
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read |
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime |
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size | Determine size of file
Size64 | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write |
WriteBulk | Seek and write binary data to file


fiDeviceCount Class Structs

fiDeviceCount Class Structs
fiDeviceCount Class
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)


Inheritance Hierarchy

Inheritance Hierarchy
fiDeviceCount Class
Inheritance Hierarchy
rage::fiDevice
    fiDeviceCount


fiDeviceGrowBuffer Class Constructors

fiDeviceGrowBuffer Class Constructors
fiDeviceGrowBuffer Class
Constructors
Constructor | Description
fiDevice |


fiDeviceGrowBuffer Class Data Members

fiDeviceGrowBuffer Class Data Members
fiDeviceGrowBuffer Class
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.


fiDeviceGrowBuffer Class Destructors

fiDeviceGrowBuffer Class Destructors
fiDeviceGrowBuffer Class
Destructors
Destructor | Description
~fiDevice |


fiDeviceGrowBuffer Class Enumerations

fiDeviceGrowBuffer Class Enumerations
fiDeviceGrowBuffer Class
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


Legend

Legend
fiDeviceGrowBuffer Class
Legend
Method
abstract
virtual
Data Member
protected


fiDeviceGrowBuffer Class Members

fiDeviceGrowBuffer Class Members
fiDeviceGrowBuffer Class
Members
Methods
Method | Description
Close | Close a file
Close |
CloseBulk | Close a file opened via OpenBulk
CloseBulk |
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes |
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek |
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
Destructors
Destructor | Description
~fiDevice |
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


fiDeviceGrowBuffer Class Methods

fiDeviceGrowBuffer Class Methods
fiDeviceGrowBuffer Class
Methods
Method | Description
Close | Close a file
Close |
CloseBulk | Close a file opened via OpenBulk
CloseBulk |
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes |
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek |
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file


fiDeviceGrowBuffer Class Structs

fiDeviceGrowBuffer Class Structs
fiDeviceGrowBuffer Class
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)


Inheritance Hierarchy

Inheritance Hierarchy
fiDeviceGrowBuffer Class
Inheritance Hierarchy
rage::fiDevice
    fiDeviceGrowBuffer


fiDeviceInstaller Class Constructors

fiDeviceInstaller Class Constructors
fiDeviceInstaller Class
Constructors
Constructor | Description
fiDevice |
fiDeviceInstaller |


fiDeviceInstaller Class Data Members

fiDeviceInstaller Class Data Members
fiDeviceInstaller Class
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.


fiDeviceInstaller Class Destructors

fiDeviceInstaller Class Destructors
fiDeviceInstaller Class
Destructors
Destructor | Description
~fiDevice |
~fiDeviceInstaller |


fiDeviceInstaller Class Enumerations

fiDeviceInstaller Class Enumerations
fiDeviceInstaller Class
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


Legend

Legend
fiDeviceInstaller Class
Legend
Method
virtual
abstract
protected
Data Member


fiDeviceInstaller Class Members

fiDeviceInstaller Class Members
fiDeviceInstaller Class
Members
Structs
Struct | Description
HddFile |
InitData |
InitDataList |
InstallFile |
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
fiDeviceInstaller |
Destructors
Destructor | Description
~fiDevice |
~fiDeviceInstaller |
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyContentInfoFile |
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
DoFileSizesMatch |
DoTimestampsMatch |
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FinishInstall |
FixName |
FixRelativeName |
FlagInstalledRpfs |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstallName |
GetInstallProgress |
GetInstallStatus |
GetIsBootedFromHdd |
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPackFileSize |
GetPartitionName |
GetPhysicalSortKey |
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetResourceInfo |
GetRpfDevice |
GetRpfDevice |
Init |
InitClass |
InitInstall |
InitPartitionDevice |
InstallerThread |
InstallProgress |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsPartitionPath |
IsRpf |
IsRpf |
IsTargetDeviceValid |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
MountAs |
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk |
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PauseDiscRead |
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
ReadInstallFile |
RegisterFileDoneCallback |
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
ResumeDiscRead |
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
ScheduleFile |
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAsync |
SetAttributes | Sets file attributes
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetIsBootedFromHdd |
SetKeepaliveCallback |
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
StartInstall |
StorePackageTimestamp |
StripPath |
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
WriteInstallFile |
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


fiDeviceInstaller Class Methods

fiDeviceInstaller Class Methods
fiDeviceInstaller Class
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyContentInfoFile |
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
DoFileSizesMatch |
DoTimestampsMatch |
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FinishInstall |
FixName |
FixRelativeName |
FlagInstalledRpfs |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstallName |
GetInstallProgress |
GetInstallStatus |
GetIsBootedFromHdd |
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPackFileSize |
GetPartitionName |
GetPhysicalSortKey |
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetResourceInfo |
GetRpfDevice |
GetRpfDevice |
Init |
InitClass |
InitInstall |
InitPartitionDevice |
InstallerThread |
InstallProgress |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsPartitionPath |
IsRpf |
IsRpf |
IsTargetDeviceValid |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
MountAs |
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk |
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PauseDiscRead |
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
ReadInstallFile |
RegisterFileDoneCallback |
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
ResumeDiscRead |
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
ScheduleFile |
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAsync |
SetAttributes | Sets file attributes
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetIsBootedFromHdd |
SetKeepaliveCallback |
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
StartInstall |
StorePackageTimestamp |
StripPath |
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
WriteInstallFile |


Methods

Legend
Method
abstract
virtual
protected


fiDeviceInstaller Class Structs

fiDeviceInstaller Class Structs
fiDeviceInstaller Class
Structs
Struct | Description
HddFile |
InitData |
InitDataList |
InstallFile |
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)


Inheritance Hierarchy

Inheritance Hierarchy
fiDeviceInstaller Class
Inheritance Hierarchy
rage::fiDevice
    fiDeviceInstaller


fiDeviceLocal Class Constructors

fiDeviceLocal Class Constructors
fiDeviceLocal Class
Constructors
Constructor | Description
fiDevice |


fiDeviceLocal Class Data Members

fiDeviceLocal Class Data Members
fiDeviceLocal Class
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.


fiDeviceLocal Class Destructors

fiDeviceLocal Class Destructors
fiDeviceLocal Class
Destructors
Destructor | Description
~fiDevice |


fiDeviceLocal Class Enumerations

fiDeviceLocal Class Enumerations
fiDeviceLocal Class
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


Legend

Legend
fiDeviceLocal Class
Legend
Method
abstract
virtual
Data Member
protected


fiDeviceLocal Class Members

fiDeviceLocal Class Members
fiDeviceLocal Class
Members
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixName | Normalize a name for the underlying local device (insert host0:, change forward slashes to backslashes, etc)
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
OnDiscSwap |
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
Destructors
Destructor | Description
~fiDevice |
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


fiDeviceLocal Class Methods

fiDeviceLocal Class Methods
fiDeviceLocal Class
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixName | Normalize a name for the underlying local device (insert host0:, change forward slashes to backslashes, etc)
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
OnDiscSwap |
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
WriteBulk | Seek and write binary data to file


fiDeviceLocal Class Structs

fiDeviceLocal Class Structs
fiDeviceLocal Class
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)


Inheritance Hierarchy

Inheritance Hierarchy
fiDeviceLocal Class
Inheritance Hierarchy
rage::fiDevice
    fiDeviceLocal
        rage::fiDeviceLocalDrm
        rage::fiDeviceXContent


fiDeviceLocalDrm Class Constructors

fiDeviceLocalDrm Class Constructors
fiDeviceLocalDrm Class
Constructors
Constructor | Description
fiDevice |


fiDeviceLocalDrm Class Data Members

fiDeviceLocalDrm Class Data Members
fiDeviceLocalDrm Class
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.


fiDeviceLocalDrm Class Destructors

fiDeviceLocalDrm Class Destructors
fiDeviceLocalDrm Class
Destructors
Destructor | Description
~fiDevice |


fiDeviceLocalDrm Class Enumerations

fiDeviceLocalDrm Class Enumerations
fiDeviceLocalDrm Class
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


Legend

Legend
fiDeviceLocalDrm Class
Legend
Method
abstract
virtual
Data Member
protected


fiDeviceLocalDrm Class Members

fiDeviceLocalDrm Class Members
fiDeviceLocalDrm Class
Members
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixName | Normalize a name for the underlying local device (insert host0:, change forward slashes to backslashes, etc)
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
OnDiscSwap |
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
Destructors
Destructor | Description
~fiDevice |
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


fiDeviceLocalDrm Class Methods

fiDeviceLocalDrm Class Methods
fiDeviceLocalDrm Class
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixName | Normalize a name for the underlying local device (insert host0:, change forward slashes to backslashes, etc)
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
OnDiscSwap |
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
WriteBulk | Seek and write binary data to file


fiDeviceLocalDrm Class Structs

fiDeviceLocalDrm Class Structs
fiDeviceLocalDrm Class
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)


Inheritance Hierarchy

Inheritance Hierarchy
fiDeviceLocalDrm Class
Inheritance Hierarchy
rage::fiDevice
    rage::fiDeviceLocal
        fiDeviceLocalDrm


fiDeviceMemory Class Constructors

fiDeviceMemory Class Constructors
fiDeviceMemory Class
Constructors
Constructor | Description
fiDevice |


fiDeviceMemory Class Data Members

fiDeviceMemory Class Data Members
fiDeviceMemory Class
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.


fiDeviceMemory Class Destructors

fiDeviceMemory Class Destructors
fiDeviceMemory Class
Destructors
Destructor | Description
~fiDevice |


fiDeviceMemory Class Enumerations

fiDeviceMemory Class Enumerations
fiDeviceMemory Class
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


Legend

Legend
fiDeviceMemory Class
Legend
Method
abstract
virtual
Data Member
protected


fiDeviceMemory Class Members

fiDeviceMemory Class Members
fiDeviceMemory Class
Members
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk |
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes |
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
Destructors
Destructor | Description
~fiDevice |
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


fiDeviceMemory Class Methods

fiDeviceMemory Class Methods
fiDeviceMemory Class
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk |
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes |
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file


fiDeviceMemory Class Structs

fiDeviceMemory Class Structs
fiDeviceMemory Class
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)


Inheritance Hierarchy

Inheritance Hierarchy
fiDeviceMemory Class
Inheritance Hierarchy
rage::fiDevice
    fiDeviceMemory


fiDeviceProfiler Struct Destructors

fiDeviceProfiler Struct Destructors
fiDeviceProfiler Struct
Destructors
Destructor | Description
~fiDeviceProfiler |


Legend

Legend
fiDeviceProfiler Struct
Legend
Method
virtual


fiDeviceProfiler Struct Members

fiDeviceProfiler Struct Members
fiDeviceProfiler Struct
Members
Destructors
Destructor | Description
~fiDeviceProfiler |
Methods
Method | Description
OnClose |
OnOpen |
OnRead |
OnReadEnd |
OnSeek |
OnWrite |


Members

Legend
Method
virtual


fiDeviceProfiler Struct Methods

fiDeviceProfiler Struct Methods
fiDeviceProfiler Struct
Methods
Method | Description
OnClose |
OnOpen |
OnRead |
OnReadEnd |
OnSeek |
OnWrite |


Methods

Legend
Method
virtual


Inheritance Hierarchy

Inheritance Hierarchy
fiDeviceProfiler Struct
Inheritance Hierarchy
fiDeviceProfiler


fiDeviceRelative Class Constructors

fiDeviceRelative Class Constructors
fiDeviceRelative Class
Constructors
Constructor | Description
fiDevice |
fiDeviceRelative |


fiDeviceRelative Class Data Members

fiDeviceRelative Class Data Members
fiDeviceRelative Class
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
m_pDevice |
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.


fiDeviceRelative Class Destructors

fiDeviceRelative Class Destructors
fiDeviceRelative Class
Destructors
Destructor | Description
~fiDevice |
~fiDeviceRelative |


fiDeviceRelative Class Enumerations

fiDeviceRelative Class Enumerations
fiDeviceRelative Class
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


Legend

Legend
fiDeviceRelative Class
Legend
Data Member
protected
Method
virtual
abstract


fiDeviceRelative Class Members

fiDeviceRelative Class Members
fiDeviceRelative Class
Members
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
m_pDevice |
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Constructors
Constructor | Description
fiDevice |
fiDeviceRelative |
Destructors
Destructor | Description
~fiDevice |
~fiDeviceRelative |
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixName |
FixRelativeName |
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetResourceInfo |
GetRpfDevice |
Init |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
MountAs |
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk |
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


fiDeviceRelative Class Methods

fiDeviceRelative Class Methods
fiDeviceRelative Class
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixName |
FixRelativeName |
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetResourceInfo |
GetRpfDevice |
Init |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
MountAs |
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk |
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file


fiDeviceRelative Class Structs

fiDeviceRelative Class Structs
fiDeviceRelative Class
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)


Inheritance Hierarchy

Inheritance Hierarchy
fiDeviceRelative Class
Inheritance Hierarchy
rage::fiDevice
    fiDeviceRelative


fiDeviceRemote Class Constructors

fiDeviceRemote Class Constructors
fiDeviceRemote Class
Constructors
Constructor | Description
fiDevice |


fiDeviceRemote Class Data Members

fiDeviceRemote Class Data Members
fiDeviceRemote Class
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.


fiDeviceRemote Class Destructors

fiDeviceRemote Class Destructors
fiDeviceRemote Class
Destructors
Destructor | Description
~fiDevice |


fiDeviceRemote Class Enumerations

fiDeviceRemote Class Enumerations
fiDeviceRemote Class
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


Legend

Legend
fiDeviceRemote Class
Legend
Method
abstract
virtual
Data Member
protected


fiDeviceRemote Class Members

fiDeviceRemote Class Members
fiDeviceRemote Class
Members
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
DeleteDirectory |
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetAttributesDir |
GetAverageThroughput |
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileCount |
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
InitClass |
InvalidateDirectoryCache |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
ShutdownClass |
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Constructors
Constructor | Description
fiDevice |
Destructors
Destructor | Description
~fiDevice |
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


fiDeviceRemote Class Methods

fiDeviceRemote Class Methods
fiDeviceRemote Class
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
DeleteDirectory |
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetAttributesDir |
GetAverageThroughput |
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileCount |
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
InitClass |
InvalidateDirectoryCache |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
ShutdownClass |
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file


fiDeviceRemote Class Structs

fiDeviceRemote Class Structs
fiDeviceRemote Class
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)


Inheritance Hierarchy

Inheritance Hierarchy
fiDeviceRemote Class
Inheritance Hierarchy
rage::fiDevice
    fiDeviceRemote


fiDeviceTcpIp Class Constructors

fiDeviceTcpIp Class Constructors
fiDeviceTcpIp Class
Constructors
Constructor | Description
fiDevice |
fiDeviceTcpIp |


fiDeviceTcpIp Class Data Members

fiDeviceTcpIp Class Data Members
fiDeviceTcpIp Class
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.


fiDeviceTcpIp Class Destructors

fiDeviceTcpIp Class Destructors
fiDeviceTcpIp Class
Destructors
Destructor | Description
~fiDevice |
~fiDeviceTcpIp |


fiDeviceTcpIp Class Enumerations

fiDeviceTcpIp Class Enumerations
fiDeviceTcpIp Class
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


Legend

Legend
fiDeviceTcpIp Class
Legend
Method
virtual
abstract
Data Member
protected


fiDeviceTcpIp Class Members

fiDeviceTcpIp Class Members
fiDeviceTcpIp Class
Members
Constructors
Constructor | Description
fiDevice |
fiDeviceTcpIp |
Destructors
Destructor | Description
~fiDevice |
~fiDeviceTcpIp |
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
Connect | Connect to an existing server at an address and port.
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLastError | Return a string describing the last error that was detected.
GetLocalHost |
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetReadCount | Returns amount of data bytes waiting on the socket
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Listen | Install a listen socket on the specified port
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Filename format for fiDeviceTcpIp should be: "tcpip::" or "tcpip::LISTEN" e.g. "tcpip:1234:localhost", "tcpip:80:10.0.23.14", "tcpip:23:LISTEN"
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
Pickup | Pickup an incoming connection (for use on the server side)
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
PrintInterfaceState |
PrintNetStats |
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek |
Seek64 | Seek to a location in file
Seek64 |
SetAttributes | Sets file attributes
SetBlocking | Sets blocking mode for this socket - defaults to ON
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetLastError | Set the string that will be returned on the next call to GetLastError().
SetLocalHost |
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
ShutdownClass |
Size | Determine size of file
Size64 | Determine size of file
StaticWrite |
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
WaitForNetworkReady |
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


fiDeviceTcpIp Class Methods

fiDeviceTcpIp Class Methods
fiDeviceTcpIp Class
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
Connect | Connect to an existing server at an address and port.
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLastError | Return a string describing the last error that was detected.
GetLocalHost |
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetReadCount | Returns amount of data bytes waiting on the socket
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
InitClass |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Listen | Install a listen socket on the specified port
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Filename format for fiDeviceTcpIp should be: "tcpip::" or "tcpip::LISTEN" e.g. "tcpip:1234:localhost", "tcpip:80:10.0.23.14", "tcpip:23:LISTEN"
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
Pickup | Pickup an incoming connection (for use on the server side)
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
PrintInterfaceState |
PrintNetStats |
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek |
Seek64 | Seek to a location in file
Seek64 |
SetAttributes | Sets file attributes
SetBlocking | Sets blocking mode for this socket - defaults to ON
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetLastError | Set the string that will be returned on the next call to GetLastError().
SetLocalHost |
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
ShutdownClass |
Size | Determine size of file
Size64 | Determine size of file
StaticWrite |
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
WaitForNetworkReady |
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file


fiDeviceTcpIp Class Structs

fiDeviceTcpIp Class Structs
fiDeviceTcpIp Class
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)


Inheritance Hierarchy

Inheritance Hierarchy
fiDeviceTcpIp Class
Inheritance Hierarchy
rage::fiDevice
    fiDeviceTcpIp


fiDeviceXContent Class Constructors

fiDeviceXContent Class Constructors
fiDeviceXContent Class
Constructors
Constructor | Description
fiDevice |
fiDeviceXContent |


fiDeviceXContent Class Data Members

fiDeviceXContent Class Data Members
fiDeviceXContent Class
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.


fiDeviceXContent Class Destructors

fiDeviceXContent Class Destructors
fiDeviceXContent Class
Destructors
Destructor | Description
~fiDevice |
~fiDeviceXContent |


fiDeviceXContent Class Enumerations

fiDeviceXContent Class Enumerations
fiDeviceXContent Class
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


Legend

Legend
fiDeviceXContent Class
Legend
Method
virtual
abstract
Data Member
protected


fiDeviceXContent Class Members

fiDeviceXContent Class Members
fiDeviceXContent Class
Members
Constructors
Constructor | Description
fiDevice |
fiDeviceXContent |
Destructors
Destructor | Description
~fiDevice |
~fiDeviceXContent |
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixName | Normalize a name for the underlying local device (insert host0:, change forward slashes to backslashes, etc)
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
Init |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
MountAs |
Normalize | Normalize a filename in-place
OnDiscSwap |
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Shutdown |
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
WriteBulk | Seek and write binary data to file
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


fiDeviceXContent Class Methods

fiDeviceXContent Class Methods
fiDeviceXContent Class
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk | Close a file opened via OpenBulk
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create | Attempt to create a file on this device
CreateBulk | Attempt to open a file on this device for bulk write
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixName | Normalize a name for the underlying local device (insert host0:, change forward slashes to backslashes, etc)
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetInstance | Singleton accessor
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
Init |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
MountAs |
Normalize | Normalize a filename in-place
OnDiscSwap |
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime | Set time-of-date information for a file
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Shutdown |
Size | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write | Write binary data to file
WriteBulk | Seek and write binary data to file
WriteBulk | Seek and write binary data to file


fiDeviceXContent Class Structs

fiDeviceXContent Class Structs
fiDeviceXContent Class
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)


Inheritance Hierarchy

Inheritance Hierarchy
fiDeviceXContent Class
Inheritance Hierarchy
rage::fiDevice
    rage::fiDeviceLocal
        fiDeviceXContent


fiDiskCache Class Friends

fiDiskCache Class Friends
fiDiskCache Class
Friends
Friend | Description
class fiCachedDevice |


Legend

Legend
fiDiskCache Class
Legend
Method


fiDiskCache Class Members

fiDiskCache Class Members
fiDiskCache Class
Members
Methods
Method | Description
GetCachedDevice | Obtain a cached device.
GetCacheInProgress | Returns a normalized float indicating the percent of the cache that is pending. Once the cache fills up, Occupancy plus progress will add up to 1.0; the progress percentage is capped to prevent too much cache churn.
GetCacheOccupancy | Returns a normalized float between 0.0 (no valid blocks) and 1.0 (all blocks in cache are valid). It's up to higher level code to know how to interpret this value. It's guaranteed to be zero if the cache is disabled or unavailable, and will always return 1.0 on 360 "Play From Hard Drive"
GetHoldoffTime |
GetLastCacheCopyCompletion | Returns a timestamp of the last cache copy completion, or zero if we haven't done one yet.
InitClass | Initialize the disk cache.
IsCacheCopying | Returns true if a cache copy is currently in progress.
IsCacheEnabled | Determine if the cache is enabled.
IsCachePrimed | Returns true if we either installed to hdd, or the cache was already present. It will return false if no cache is available, or it was regenerated.
LeaveBootMode | Higher-level code should call this when we're no longer reading load-ordered data. Cache misses incurred in boot mode have a higher priority than all other cache misses and will tend to be copied sooner.
SetHoldoffTime | Set the holdoff time.
ShutdownClass | Shuts the disk cache back down again.
Friends
Friend | Description
class fiCachedDevice |


fiDiskCache Class Methods

fiDiskCache Class Methods
fiDiskCache Class
Methods
Method | Description
GetCachedDevice | Obtain a cached device.
GetCacheInProgress | Returns a normalized float indicating the percent of the cache that is pending. Once the cache fills up, Occupancy plus progress will add up to 1.0; the progress percentage is capped to prevent too much cache churn.
GetCacheOccupancy | Returns a normalized float between 0.0 (no valid blocks) and 1.0 (all blocks in cache are valid). It's up to higher level code to know how to interpret this value. It's guaranteed to be zero if the cache is disabled or unavailable, and will always return 1.0 on 360 "Play From Hard Drive"
GetHoldoffTime |
GetLastCacheCopyCompletion | Returns a timestamp of the last cache copy completion, or zero if we haven't done one yet.
InitClass | Initialize the disk cache.
IsCacheCopying | Returns true if a cache copy is currently in progress.
IsCacheEnabled | Determine if the cache is enabled.
IsCachePrimed | Returns true if we either installed to hdd, or the cache was already present. It will return false if no cache is available, or it was regenerated.
LeaveBootMode | Higher-level code should call this when we're no longer reading load-ordered data. Cache misses incurred in boot mode have a higher priority than all other cache misses and will tend to be copied sooner.
SetHoldoffTime | Set the holdoff time.
ShutdownClass | Shuts the disk cache back down again.


Inheritance Hierarchy

Inheritance Hierarchy
fiDiskCache Class
Inheritance Hierarchy
fiDiskCache


fiEmbeddedFile Class Constructors

fiEmbeddedFile Class Constructors
fiEmbeddedFile Class
Constructors
Constructor | Description
fiEmbeddedFile |


Legend

Legend
fiEmbeddedFile Class
Legend
Method


fiEmbeddedFile Class Members

fiEmbeddedFile Class Members
fiEmbeddedFile Class
Members
Constructors
Constructor | Description
fiEmbeddedFile |
Methods
Method | Description
Lookup |


fiEmbeddedFile Class Methods

fiEmbeddedFile Class Methods
fiEmbeddedFile Class
Methods
Method | Description
Lookup |


Inheritance Hierarchy

Inheritance Hierarchy
fiEmbeddedFile Class
Inheritance Hierarchy
fiEmbeddedFile


fiMultiTokenizer Class Constructors

fiMultiTokenizer Class Constructors
fiMultiTokenizer Class
Constructors
Constructor | Description
fiMultiTokenizer |


Legend

Legend
fiMultiTokenizer Class
Legend
Method


fiMultiTokenizer Class Members

fiMultiTokenizer Class Members
fiMultiTokenizer Class
Members
Constructors
Constructor | Description
fiMultiTokenizer |
Methods
Method | Description
GetReadTokenizer |
GetWriteTokenizer |


fiMultiTokenizer Class Methods

fiMultiTokenizer Class Methods
fiMultiTokenizer Class
Methods
Method | Description
GetReadTokenizer |
GetWriteTokenizer |


Inheritance Hierarchy

Inheritance Hierarchy
fiMultiTokenizer Class
Inheritance Hierarchy
fiMultiTokenizer


fiPackEntry Struct Data Members

fiPackEntry Struct Data Members
fiPackEntry Struct
Data Members
Data Member | Description
FileOffset_IsDir |
FileOffset_Shift |
MaxConsumedSize |
u |


Legend

Legend
fiPackEntry Struct
Legend
Data Member
Method


fiPackEntry Struct Members

fiPackEntry Struct Members
fiPackEntry Struct
Members
Data Members
Data Member | Description
FileOffset_IsDir |
FileOffset_Shift |
MaxConsumedSize |
u |
Methods
Method | Description
DECLARE_BITFIELD_4 | nonzero if file is a resource
GetConsumedSize |
GetFileOffset |
GetUncompressedSize |
GetVersion |
IsCompressed |
IsDir |
IsFile |
IsResource |
SetFileOffset |


fiPackEntry Struct Methods

fiPackEntry Struct Methods
fiPackEntry Struct
Methods
Method | Description
DECLARE_BITFIELD_4 | nonzero if file is a resource
GetConsumedSize |
GetFileOffset |
GetUncompressedSize |
GetVersion |
IsCompressed |
IsDir |
IsFile |
IsResource |
SetFileOffset |


Inheritance Hierarchy

Inheritance Hierarchy
fiPackEntry Struct
Inheritance Hierarchy
fiPackEntry


fiPackfile Class Constructors

fiPackfile Class Constructors
fiPackfile Class
Constructors
Constructor | Description
fiCollection |
fiDevice |
fiPackfile |


fiPackfile Class Data Members

fiPackfile Class Data Members
fiPackfile Class
Data Members
Data Member | Description
ArchiveMask |
ArchiveShift |
EntryMask |
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
m_ArchiveBias | for nested zipfiles (sigh)
m_ArchiveSize |
m_CachedDataSize | Cached size for the header (including both the initial header as well as all entries).
m_CachedMetaDataSize | Cached meta data size, only valid after having called Init/ReInit() at least once.
m_Device | device the zipfile itself lives on
m_Entries | master entry table; entry 0 is the root directory
m_EntryCount |
m_FileTime | file time of the zipfile itself
m_Fullname |
m_Handle | (bulk) handle on the device of the zipfile itself
m_IsByteSwapped |
m_IsCached |
m_IsInstalled |
m_IsRpf |
m_isStreaming |
m_IsUserHeader | If true, the user provided the memory for the header data and is responsible for its clean-up.
m_IsXCompressed |
m_KeyId | Encryption key ID
m_MemoryBuffer | buffer to put packfile into if caching in memory
m_Name | debug name
m_NameHeap | nameheap for all filenames in the zipfile.
m_NameHeapInDebugHeap | If true, the name heap is in the debug heap. In this case, In this case, the name heap remains resident until Shutdown() is called. However, ReInit() with keepNameHeap set to true will reload the name heap. !__FINAL
m_NameShift |
m_ParentIndices |
m_pDrmKey | Drmkey used to decode drm content (ps3 only?)
m_RelativeOffset | amount of incoming pathname to strip off
m_SelfIndex |
m_SortKey | sort key used to define position on a DVD
sm_Collections | Entry 0 is never used. (except by the pgRawStreamer)
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.


fiPackfile Class Destructors

fiPackfile Class Destructors
fiPackfile Class
Destructors
Destructor | Description
~fiDevice |
~fiPackfile |


fiPackfile Class Enumerations

fiPackfile Class Enumerations
fiPackfile Class
Enumerations
Enumeration | Description
CacheMode |
eFindFileOptions | Find File in a directory by name and other options


Legend

Legend
fiPackfile Class
Legend
protected
Data Member
Method
virtual
abstract


fiPackfile Class Members

fiPackfile Class Members
fiPackfile Class
Members
Data Members
Data Member | Description
ArchiveMask |
ArchiveShift |
EntryMask |
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
m_ArchiveBias | for nested zipfiles (sigh)
m_ArchiveSize |
m_CachedDataSize | Cached size for the header (including both the initial header as well as all entries).
m_CachedMetaDataSize | Cached meta data size, only valid after having called Init/ReInit() at least once.
m_Device | device the zipfile itself lives on
m_Entries | master entry table; entry 0 is the root directory
m_EntryCount |
m_FileTime | file time of the zipfile itself
m_Fullname |
m_Handle | (bulk) handle on the device of the zipfile itself
m_IsByteSwapped |
m_IsCached |
m_IsInstalled |
m_IsRpf |
m_isStreaming |
m_IsUserHeader | If true, the user provided the memory for the header data and is responsible for its clean-up.
m_IsXCompressed |
m_KeyId | Encryption key ID
m_MemoryBuffer | buffer to put packfile into if caching in memory
m_Name | debug name
m_NameHeap | nameheap for all filenames in the zipfile.
m_NameHeapInDebugHeap | If true, the name heap is in the debug heap. In this case, In this case, the name heap remains resident until Shutdown() is called. However, ReInit() with keepNameHeap set to true will reload the name heap. !__FINAL
m_NameShift |
m_ParentIndices |
m_pDrmKey | Drmkey used to decode drm content (ps3 only?)
m_RelativeOffset | amount of incoming pathname to strip off
m_SelfIndex |
m_SortKey | sort key used to define position on a DVD
sm_Collections | Entry 0 is never used. (except by the pgRawStreamer)
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Constructors
Constructor | Description
fiCollection |
fiDevice |
fiPackfile |
Destructors
Destructor | Description
~fiDevice |
~fiPackfile |
Methods
Method | Description
ClearRelativeOffset |
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk |
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create |
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
ExtractFileToMemory |
FillData |
FillParentIndices |
FindEntry |
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBasePhysicalSortKey |
GetBasePhysicalSortKey |
GetBulkOffset |
GetBulkOffset |
GetCollection |
GetCollectionIndex |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetEntries |
GetEntryCount |
GetEntryFullName | Slower
GetEntryFullName | Slower
GetEntryIndex |
GetEntryIndex |
GetEntryInfo |
GetEntryInfo |
GetEntryName |
GetEntryName |
GetEntryPhysicalSortKey |
GetEntryPhysicalSortKey |
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetHeaderSize |
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetNameHeap |
GetNameShift |
GetPackfileHandle |
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPackfileSize |
GetPackfileTime |
GetPhysicalSortKey |
GetPhysicalSortKey |
GetRelativeOffset |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
Init |
InitClass |
InitFromImg | not in final builds.
InitFromZip |
IsCloud |
IsInitialized | Returns true if this packfile is initialized, false if UnInit() had been called on it.
IsOutOfDate | Convenience function which compares to files.
IsPackfile |
IsPackfile |
IsRpf |
IsRpf |
IsStreaming |
IsUserHeader |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeHandle |
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
MountAs |
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
OpenBulkFromHandle |
OpenBulkFromHandle |
OpenDirect |
OpenInternal |
Prefetch |
Prefetch |
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
ReadInternal |
ReadInternalBulk |
ReInit | Re-initialize a packfile after it has been UnInited().
Remount | Re-establish a mount point in the global file namespace for an existing device.
RemountDependentPackfiles | Call this function after having called Shutdown() and Init() on this packfile - it will look for all other packfiles depending on it and update their file handles.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetDrmKey |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime |
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
SetpackfileHandle |
SetPackfileTime |
SetReadAheadCacheCPU |
SetRelativePath |
SetStreaming |
Shutdown |
Shutdown |
Size | Determine size of file
Size | Determine size of file
Size64 | Determine size of file
Size64 | Determine size of file
UnInit | Free up the memory of the pack file header data, but don't close the handle.
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write |
WriteBulk | Seek and write binary data to file
Enumerations
Enumeration | Description
CacheMode |
eFindFileOptions | Find File in a directory by name and other options
Nested Types
Nested Type | Description
ParentIndexType |
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)


Members

Legend
protected
Data Member
Method
virtual
abstract


fiPackfile Class Methods

fiPackfile Class Methods
fiPackfile Class
Methods
Method | Description
ClearRelativeOffset |
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk |
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create |
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
ExtractFileToMemory |
FillData |
FillParentIndices |
FindEntry |
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBasePhysicalSortKey |
GetBasePhysicalSortKey |
GetBulkOffset |
GetBulkOffset |
GetCollection |
GetCollectionIndex |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetEntries |
GetEntryCount |
GetEntryFullName | Slower
GetEntryFullName | Slower
GetEntryIndex |
GetEntryIndex |
GetEntryInfo |
GetEntryInfo |
GetEntryName |
GetEntryName |
GetEntryPhysicalSortKey |
GetEntryPhysicalSortKey |
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetHeaderSize |
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetNameHeap |
GetNameShift |
GetPackfileHandle |
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPackfileSize |
GetPackfileTime |
GetPhysicalSortKey |
GetPhysicalSortKey |
GetRelativeOffset |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
Init |
InitClass |
InitFromImg | not in final builds.
InitFromZip |
IsCloud |
IsInitialized | Returns true if this packfile is initialized, false if UnInit() had been called on it.
IsOutOfDate | Convenience function which compares to files.
IsPackfile |
IsPackfile |
IsRpf |
IsRpf |
IsStreaming |
IsUserHeader |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeHandle |
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
MountAs |
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
OpenBulkFromHandle |
OpenBulkFromHandle |
OpenDirect |
OpenInternal |
Prefetch |
Prefetch |
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
ReadInternal |
ReadInternalBulk |
ReInit | Re-initialize a packfile after it has been UnInited().
Remount | Re-establish a mount point in the global file namespace for an existing device.
RemountDependentPackfiles | Call this function after having called Shutdown() and Init() on this packfile - it will look for all other packfiles depending on it and update their file handles.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetDrmKey |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime |
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
SetpackfileHandle |
SetPackfileTime |
SetReadAheadCacheCPU |
SetRelativePath |
SetStreaming |
Shutdown |
Shutdown |
Size | Determine size of file
Size | Determine size of file
Size64 | Determine size of file
Size64 | Determine size of file
UnInit | Free up the memory of the pack file header data, but don't close the handle.
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write |
WriteBulk | Seek and write binary data to file


fiPackfile Class Nested Types

fiPackfile Class Nested Types
fiPackfile Class
Nested Types
Nested Type | Description
ParentIndexType |


fiPackfile Class Structs

fiPackfile Class Structs
fiPackfile Class
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)


Inheritance Hierarchy

Inheritance Hierarchy
fiPackfile Class
Inheritance Hierarchy
rage::fiDevice
    rage::fiCollection
        fiPackfile


fiPackfileState Struct Constructors

fiPackfileState Struct Constructors
fiPackfileState Struct
Constructors
Constructor | Description
fiPackfileState |


fiPackfileState Struct Data Members

fiPackfileState Struct Data Members
fiPackfileState Struct
Data Members
Data Member | Description
avail_in |
BufferSize |
m_Buffer |
m_CompOffset | Current offset within the compressed file
m_DebugName |
m_Entry | Pointer to the file directory entry
m_Offset | Current offset within the (virtual, uncompressed) file
m_xStream |
m_zStream | Stream object used by Zlib
next_in |


Legend

Legend
fiPackfileState Struct
Legend
Data Member
Method


fiPackfileState Struct Members

fiPackfileState Struct Members
fiPackfileState Struct
Members
Data Members
Data Member | Description
avail_in |
BufferSize |
m_Buffer |
m_CompOffset | Current offset within the compressed file
m_DebugName |
m_Entry | Pointer to the file directory entry
m_Offset | Current offset within the (virtual, uncompressed) file
m_xStream |
m_zStream | Stream object used by Zlib
next_in |
Constructors
Constructor | Description
fiPackfileState |
Methods
Method | Description
IsCompressed |
Reset |


fiPackfileState Struct Methods

fiPackfileState Struct Methods
fiPackfileState Struct
Methods
Method | Description
IsCompressed |
Reset |


Inheritance Hierarchy

Inheritance Hierarchy
fiPackfileState Struct
Inheritance Hierarchy
fiPackfileState


fiRpf7Builder Class Constructors

fiRpf7Builder Class Constructors
fiRpf7Builder Class
Constructors
Constructor | Description
fiRpf7Builder | Constructor


fiRpf7Builder Class Destructors

fiRpf7Builder Class Destructors
fiRpf7Builder Class
Destructors
Destructor | Description
~fiRpf7Builder | Destructor


Legend

Legend
fiRpf7Builder Class
Legend
Method


fiRpf7Builder Class Members

fiRpf7Builder Class Members
fiRpf7Builder Class
Members
Constructors
Constructor | Description
fiRpf7Builder | Constructor
Destructors
Destructor | Description
~fiRpf7Builder | Destructor
Methods
Method | Description
AddData | Data is assumed to be allocated by rage_new, and will be freed when the archive is written.
AddFile |
Save |


fiRpf7Builder Class Methods

fiRpf7Builder Class Methods
fiRpf7Builder Class
Methods
Method | Description
AddData | Data is assumed to be allocated by rage_new, and will be freed when the archive is written.
AddFile |
Save |


Inheritance Hierarchy

Inheritance Hierarchy
fiRpf7Builder Class
Inheritance Hierarchy
fiRpf7Builder


fiRpf7Entry Struct Constructors

fiRpf7Entry Struct Constructors
fiRpf7Entry Struct
Constructors
Constructor | Description
fiRpf7Entry |


fiRpf7Entry Struct Data Members

fiRpf7Entry Struct Data Members
fiRpf7Entry Struct
Data Members
Data Member | Description
1 |
Child |
DataSize |
NameOffset |
Next |
SourceName | NULL if directory. Otherwise pointer to name if DataSize is 0, or actual data if DataSize is nonzero.


fiRpf7Entry Struct Destructors

fiRpf7Entry Struct Destructors
fiRpf7Entry Struct
Destructors
Destructor | Description
~fiRpf7Entry |


Legend

Legend
fiRpf7Entry Struct
Legend
Data Member
Method


fiRpf7Entry Struct Members

fiRpf7Entry Struct Members
fiRpf7Entry Struct
Members
Data Members
Data Member | Description
1 |
Child |
DataSize |
NameOffset |
Next |
SourceName | NULL if directory. Otherwise pointer to name if DataSize is 0, or actual data if DataSize is nonzero.
Constructors
Constructor | Description
fiRpf7Entry |
Destructors
Destructor | Description
~fiRpf7Entry |


Inheritance Hierarchy

Inheritance Hierarchy
fiRpf7Entry Struct
Inheritance Hierarchy
fiRpf7Entry


fiSafeStream Class Constructors

fiSafeStream Class Constructors
fiSafeStream Class
Constructors
Constructor | Description
fiSafeStream | Creates a new safe stream that will close s when the safe stream object is destroyed.


fiSafeStream Class Destructors

fiSafeStream Class Destructors
fiSafeStream Class
Destructors
Destructor | Description
~fiSafeStream | The safe stream destructor will close the stream its holding on to


Legend

Legend
fiSafeStream Class
Legend
Method


fiSafeStream Class Members

fiSafeStream Class Members
fiSafeStream Class
Members
Constructors
Constructor | Description
fiSafeStream | Creates a new safe stream that will close s when the safe stream object is destroyed.
Destructors
Destructor | Description
~fiSafeStream | The safe stream destructor will close the stream its holding on to
Operators
Operator | Description
-> | Returns the stream object, so that fiSafeStream can be used just like an fiStream
fiStream* | Implicit conversion to fiStream, so that fiSafeStream can be used just like an fiStream


fiSafeStream Class Operators

fiSafeStream Class Operators
fiSafeStream Class
Operators
Operator | Description
-> | Returns the stream object, so that fiSafeStream can be used just like an fiStream
fiStream* | Implicit conversion to fiStream, so that fiSafeStream can be used just like an fiStream


Inheritance Hierarchy

Inheritance Hierarchy
fiSafeStream Class
Inheritance Hierarchy
fiSafeStream


fiSaveGame Class Data Members

fiSaveGame Class Data Members
fiSaveGame Class
Data Members
Data Member | Description
SIGNIN_COUNT | Last SignIn Reserved for Global User


fiSaveGame Class Enumerations

fiSaveGame Class Enumerations
fiSaveGame Class
Enumerations
Enumeration | Description
Errors | list of possible errors while saving,loading,ect..


Legend

Legend
fiSaveGame Class
Legend
Data Member
Method


fiSaveGame Class Members

fiSaveGame Class Members
fiSaveGame Class
Members
Data Members
Data Member | Description
SIGNIN_COUNT | Last SignIn Reserved for Global User
Structs
Struct | Description
Content | Shadows XCONTENT_DATA structure
Device | Mirrors XDEVICE_DATA structure
Methods
Method | Description
BeginContentVerify | Verify saved content (this will probably be platform specific)
BeginDelete | Begin deleting content for the associated signInId
BeginDeleteFromList | Begin the PS3's delete from list function
BeginEnumeration | Begin enumerating content for the associated signInId
BeginExtraSpaceCheck | Begins a check to determine how much extra space is required to save a save game file This gives slightly more information than BeginFreeSpaceCheck. The extra info is needed in certain circumstances such as checking if there is enough free space for several save games before allowing the game to start.
BeginFreeSpaceCheck | Begins a check for sufficient free space to save a save game file
BeginGetCreator | Begin checking if the signed-in user is the creator of a save game file
BeginGetFileModifiedTime | Get the modified time of a file. Only implemented for PS3 so far. Called after a file is saved so that the game has an accurate record of the file's timestamp.
BeginGetFileSize | Get the size of a file so that we know how big a buffer we need to allocate to load the file On the 360, we use GetFileSize On the PS3, we read the size from listParam. This size will also include the size of the icon and system files
BeginIconSave | Begins an icon save
BeginLoad | Begins a content load
BeginReadNamesAndSizesOfAllSaveGames | This is an attempt to speed up the free space checks at the start of the game on PS3. cellSaveDataAutoSave2 is just too slow. I still need to call ExtraSpaceCheck once before this to get the total free space on the hard disk and the size of the system files. So call ExtraSpaceCheck for the profile and then call this for checking the save game slots. This is based on a suggestion of James Wang of SCEA Developer Support. We store the size of each file in the listparam string when a save is made and then read that in a Fixed Callback rather than sizeKB in a Stat Callback. This relies on the listparam being saved correctly with the file and the listparam not being needed for anything else. It also relies on sysSizeKB being the same for all files.
BeginSave | Begins a content save
BeginSelectDevice | Select the active content device
CalculateDataSizeOnDisk | returns the total space on file for data with the given size. Note that xenon and ps3 will increase the size of the file by adding headers, security, encryption, ect. This file returns the size of the file on disk after all modifications and additions are applied by the system.
CalculateSizeOfSaveGameFile | Calculates the actual PS3 HDD space required to store a file of the given size
CheckContentVerify | Checks if a content verify is complete
CheckDelete | Check if a deletion is complete
CheckDeleteFromList | Check if the PS3's delete from list function has finished
CheckEnumeration | Check if an enumeration is complete
CheckExtraSpaceCheck | Checks if an extra space check is complete
CheckFreeSpaceCheck | Checks if a free space check is complete
CheckGetCreator |
CheckGetFileModifiedTime | Checks if a get file modified time process is complete. Only implemented for PS3 so far
CheckGetFileSize | Checks if a get file size process is complete
CheckIconSave | Checks if an icon save is complete
CheckLoad | Checks if a content load is complete
CheckReadNamesAndSizesOfAllSaveGames | Checks if the names and sizes of all save games have been successfully read
CheckSave | Checks if a content save is complete
CheckSelectDevice | See if device selection has completed
EndContentVerify | Ends a content verify
EndDelete | Close a deletion successfully started via BeginDelete
EndDeleteFromList | Tidies up after the PS3's delete from list function has finished
EndEnumeration | Close an enumeration successfully started via BeginEnumeration
EndExtraSpaceCheck | Ends an extra space check
EndFreeSpaceCheck | Ends a free space check
EndGetCreator | Ends a GetCreator
EndGetFileModifiedTime | Ends a get file modified time process. Only implemented for PS3 so far
EndGetFileSize | Ends a get file size process
EndIconSave | Ends an icon save
EndLoad | Ends a content load
EndReadNamesAndSizesOfAllSaveGames | Ends the reading of the names and sizes of all save games
EndSave | Ends a content save
EndSelectDevice | Close down a device selection
FillDevice | fills the current device for testing purposes
GetCurrentDeviceData | Retrieves device data for the current device
GetDeviceData | Retrieves device data for the specified device
GetError | returns the error associated with the latest action
GetMaxUsers | gets the maximum number of users that can be signed into the system at one time (hardware specific)
GetSelectedDevice | Return currently selected device id
GetState | Returns current internal state.
GetTotalAvailableSpace | returns the total available space for the currently selected device
HasFileBeenAccessed | Checks to see if a file has been accessed (verified, loaded, or saved)
InitClass | Setup
IsCurrentDeviceValid | checks to see if the currently selected device is valid
IsDeviceValid | checks to see if the given device is valid
IsStorageDeviceChanged | checks to see if a storage device has been inserted or removed
IsStorageDeviceRemoved | checks to see if a storage device has been removed
SetCheckForUserBindErrors | Enables checking for bind errors and sets the string to display if a bind error occurs
SetIcon | Sets the PNG file to be used for the savegame icon on PS3
SetMaxNumberOfSaveGameFilesToEnumerate | Sets the maximum number of save files to enumerate on PS3
SetMountIndex | On Orbis, each user is given up to 16 mount indices per Title
SetSaveGameFolder | For ELC, we're going to use the savegame folder that is used by DLC. So we need to allow the game to specify the folder rather than just always using XEX_TITLE_ID
SetSaveGameTitle | On the PS3, this will set the Title of all subsequent save games. The display name of the individual save game will be the subtitle
SetSelectedDevice | Sets device id
SetSelectedDeviceToAny |
SetStateToIdle | set the current state to IDLE
SetUserServiceId | On Orbis, this will set the User Service Id for the given Index.
ShowDeleteDialog |
ShowLoadDialog |
ShowSaveDialog | On Orbis, performs a save mount enumeration and displays the system UI for selecting save mounts for save, load and delete. The system dialog causes a pad interupt.
ShutdownClass | Teardown
UpdateClass | Call this once per frame to keep asynchronous operations moving. Currently a NO-OP
Enumerations
Enumeration | Description
Errors | list of possible errors while saving,loading,ect..


fiSaveGame Class Methods

fiSaveGame Class Methods
fiSaveGame Class
Methods
Method | Description
BeginContentVerify | Verify saved content (this will probably be platform specific)
BeginDelete | Begin deleting content for the associated signInId
BeginDeleteFromList | Begin the PS3's delete from list function
BeginEnumeration | Begin enumerating content for the associated signInId
BeginExtraSpaceCheck | Begins a check to determine how much extra space is required to save a save game file This gives slightly more information than BeginFreeSpaceCheck. The extra info is needed in certain circumstances such as checking if there is enough free space for several save games before allowing the game to start.
BeginFreeSpaceCheck | Begins a check for sufficient free space to save a save game file
BeginGetCreator | Begin checking if the signed-in user is the creator of a save game file
BeginGetFileModifiedTime | Get the modified time of a file. Only implemented for PS3 so far. Called after a file is saved so that the game has an accurate record of the file's timestamp.
BeginGetFileSize | Get the size of a file so that we know how big a buffer we need to allocate to load the file On the 360, we use GetFileSize On the PS3, we read the size from listParam. This size will also include the size of the icon and system files
BeginIconSave | Begins an icon save
BeginLoad | Begins a content load
BeginReadNamesAndSizesOfAllSaveGames | This is an attempt to speed up the free space checks at the start of the game on PS3. cellSaveDataAutoSave2 is just too slow. I still need to call ExtraSpaceCheck once before this to get the total free space on the hard disk and the size of the system files. So call ExtraSpaceCheck for the profile and then call this for checking the save game slots. This is based on a suggestion of James Wang of SCEA Developer Support. We store the size of each file in the listparam string when a save is made and then read that in a Fixed Callback rather than sizeKB in a Stat Callback. This relies on the listparam being saved correctly with the file and the listparam not being needed for anything else. It also relies on sysSizeKB being the same for all files.
BeginSave | Begins a content save
BeginSelectDevice | Select the active content device
CalculateDataSizeOnDisk | returns the total space on file for data with the given size. Note that xenon and ps3 will increase the size of the file by adding headers, security, encryption, ect. This file returns the size of the file on disk after all modifications and additions are applied by the system.
CalculateSizeOfSaveGameFile | Calculates the actual PS3 HDD space required to store a file of the given size
CheckContentVerify | Checks if a content verify is complete
CheckDelete | Check if a deletion is complete
CheckDeleteFromList | Check if the PS3's delete from list function has finished
CheckEnumeration | Check if an enumeration is complete
CheckExtraSpaceCheck | Checks if an extra space check is complete
CheckFreeSpaceCheck | Checks if a free space check is complete
CheckGetCreator |
CheckGetFileModifiedTime | Checks if a get file modified time process is complete. Only implemented for PS3 so far
CheckGetFileSize | Checks if a get file size process is complete
CheckIconSave | Checks if an icon save is complete
CheckLoad | Checks if a content load is complete
CheckReadNamesAndSizesOfAllSaveGames | Checks if the names and sizes of all save games have been successfully read
CheckSave | Checks if a content save is complete
CheckSelectDevice | See if device selection has completed
EndContentVerify | Ends a content verify
EndDelete | Close a deletion successfully started via BeginDelete
EndDeleteFromList | Tidies up after the PS3's delete from list function has finished
EndEnumeration | Close an enumeration successfully started via BeginEnumeration
EndExtraSpaceCheck | Ends an extra space check
EndFreeSpaceCheck | Ends a free space check
EndGetCreator | Ends a GetCreator
EndGetFileModifiedTime | Ends a get file modified time process. Only implemented for PS3 so far
EndGetFileSize | Ends a get file size process
EndIconSave | Ends an icon save
EndLoad | Ends a content load
EndReadNamesAndSizesOfAllSaveGames | Ends the reading of the names and sizes of all save games
EndSave | Ends a content save
EndSelectDevice | Close down a device selection
FillDevice | fills the current device for testing purposes
GetCurrentDeviceData | Retrieves device data for the current device
GetDeviceData | Retrieves device data for the specified device
GetError | returns the error associated with the latest action
GetMaxUsers | gets the maximum number of users that can be signed into the system at one time (hardware specific)
GetSelectedDevice | Return currently selected device id
GetState | Returns current internal state.
GetTotalAvailableSpace | returns the total available space for the currently selected device
HasFileBeenAccessed | Checks to see if a file has been accessed (verified, loaded, or saved)
InitClass | Setup
IsCurrentDeviceValid | checks to see if the currently selected device is valid
IsDeviceValid | checks to see if the given device is valid
IsStorageDeviceChanged | checks to see if a storage device has been inserted or removed
IsStorageDeviceRemoved | checks to see if a storage device has been removed
SetCheckForUserBindErrors | Enables checking for bind errors and sets the string to display if a bind error occurs
SetIcon | Sets the PNG file to be used for the savegame icon on PS3
SetMaxNumberOfSaveGameFilesToEnumerate | Sets the maximum number of save files to enumerate on PS3
SetMountIndex | On Orbis, each user is given up to 16 mount indices per Title
SetSaveGameFolder | For ELC, we're going to use the savegame folder that is used by DLC. So we need to allow the game to specify the folder rather than just always using XEX_TITLE_ID
SetSaveGameTitle | On the PS3, this will set the Title of all subsequent save games. The display name of the individual save game will be the subtitle
SetSelectedDevice | Sets device id
SetSelectedDeviceToAny |
SetStateToIdle | set the current state to IDLE
SetUserServiceId | On Orbis, this will set the User Service Id for the given Index.
ShowDeleteDialog |
ShowLoadDialog |
ShowSaveDialog | On Orbis, performs a save mount enumeration and displays the system UI for selecting save mounts for save, load and delete. The system dialog causes a pad interupt.
ShutdownClass | Teardown
UpdateClass | Call this once per frame to keep asynchronous operations moving. Currently a NO-OP


fiSaveGame Class Structs

fiSaveGame Class Structs
fiSaveGame Class
Structs
Struct | Description
Content | Shadows XCONTENT_DATA structure
Device | Mirrors XDEVICE_DATA structure


Inheritance Hierarchy

Inheritance Hierarchy
fiSaveGame Class
Inheritance Hierarchy
fiSaveGame


rage::fiSaveGameState Namespace Enumerations

rage::fiSaveGameState Namespace Enumerations
rage::fiSaveGameState Namespace
Enumerations
Enumeration | Description
State |


fiSerialize Class Constructors

fiSerialize Class Constructors
fiSerialize Class
Constructors
Constructor | Description
fiSerialize |


fiSerialize Class Data Members

fiSerialize Class Data Members
fiSerialize Class
Data Members
Data Member | Description
m_Stream | Used for binary files
m_Token | Used for ascii files
m_Version | Version of file


fiSerialize Class Destructors

fiSerialize Class Destructors
fiSerialize Class
Destructors
Destructor | Description
~fiSerialize |


Legend

Legend
fiSerialize Class
Legend
protected
Data Member
Method
virtual


fiSerialize Class Members

fiSerialize Class Members
fiSerialize Class
Members
Data Members
Data Member | Description
m_Stream | Used for binary files
m_Token | Used for ascii files
m_Version | Version of file
Constructors
Constructor | Description
fiSerialize |
Destructors
Destructor | Description
~fiSerialize |
Methods
Method | Description
Get | Unserialize a null-terminated string. Storage for the new string must be pre-allocated. UNLESS, size is 0, at which point the string is just discarded.
Put | Serialize a null-terminated string
Serialize |


Members

Legend
protected
Data Member
Method
virtual


fiSerialize Class Methods

fiSerialize Class Methods
fiSerialize Class
Methods
Method | Description
Get | Unserialize a null-terminated string. Storage for the new string must be pre-allocated. UNLESS, size is 0, at which point the string is just discarded.
Put | Serialize a null-terminated string
Serialize |


Inheritance Hierarchy

Inheritance Hierarchy
fiSerialize Class
Inheritance Hierarchy
datSerialize
    fiSerialize


Legend

Legend
fiStream Class
Legend
Method


fiStream Class Members

fiStream Class Members
fiStream Class
Members
Methods
Method | Description
AllowBlockingLoads | __ASSERT
AreBlockingLoadsAllowed |
Close | Closes the stream.
CloseOpenFiles | Close all open files
CloseShared | Closes the stream without closing the underlying handle (assuming it's shared) This flushes the buffers and frees our fiStream object without invalidating the handle.
Create | Attempts to create a file of the given name for read-write access, returning NULL on failure. All filenames are treated verbatim at this level. Uses the current "default create file method" to access the file.
DumpOpenFiles | Print information about open files
FastGetCh | Pulls next available character from the file stream. Returns -1 on EOF.
FastPutCh | Pushes supplied character into the file stream.
fdopen | Associates an already-existing device handle with a stream (which assumes ownership of the file and will close the handle when the stream is closed, unless you call CloseShared)
Flush | Flush any buffered data.
GetCh | Gets a single char from the stream, returns it.
GetCloseCallback | Returns the current stream-close callback
GetCreateCallback | Returns the current stream-create callback
GetLocalHandle |
GetName | Get the name of this stream (__DEV && __TOOL builds only)
GetOpenCallback | Returns the current stream-open callback
Open | Attempts to open a file of the given name, returning NULL on failure. All filenames are treated verbatim at this level; there is no notion of an asset path or anything like that. See data/asset.h for a higher-level way to open files. Uses the current "default open file method" to access the file.
OutputAllFileAccess | Turns on a bool that causes all file operations to print debug information
PreLoad | Fully loads a stream into memory. Will create a new stream and close the given one.
PutCh | Puts a single char to the string.
Read | Read the as many as "count" into the "dest".
ReadByte |
ReadFloat |
ReadInt |
ReadLong |
ReadShort |
ReadTChar |
Seek | Seeks directly to specified position in the file. No "whence" parameter is supported; use fiStream::Tell as necessary to implement relative file pointer movement.
Seek64 | Seeks directly to specified position in the file. No "whence" parameter is supported; use fiStream::Tell64 as necessary to implement relative file pointer movement.
SetCloseCallback | Sets a callback that gets called every time a stream is closed.
SetCreateCallback | Sets a callback that gets called every time a stream is created.
SetFaultInjectionPath | also for testing error handling by making certain folders fail loading
SetOpenCallback | Sets a callback that gets called every time a stream is opened.
Size | Returns the total size of the file.
Size64 | Returns the total size of the file.
Tell | Returns current file position (start + offset.)
Tell64 | Returns current file position (start + offset.)
TellStart |
Write | Write as many as "count" from src into buffer.
WriteByte |
WriteFloat |
WriteInt |
WriteLong |
WriteShort |
WriteTChar |


fiStream Class Methods

fiStream Class Methods
fiStream Class
Methods
Method | Description
AllowBlockingLoads | __ASSERT
AreBlockingLoadsAllowed |
Close | Closes the stream.
CloseOpenFiles | Close all open files
CloseShared | Closes the stream without closing the underlying handle (assuming it's shared) This flushes the buffers and frees our fiStream object without invalidating the handle.
Create | Attempts to create a file of the given name for read-write access, returning NULL on failure. All filenames are treated verbatim at this level. Uses the current "default create file method" to access the file.
DumpOpenFiles | Print information about open files
FastGetCh | Pulls next available character from the file stream. Returns -1 on EOF.
FastPutCh | Pushes supplied character into the file stream.
fdopen | Associates an already-existing device handle with a stream (which assumes ownership of the file and will close the handle when the stream is closed, unless you call CloseShared)
Flush | Flush any buffered data.
GetCh | Gets a single char from the stream, returns it.
GetCloseCallback | Returns the current stream-close callback
GetCreateCallback | Returns the current stream-create callback
GetLocalHandle |
GetName | Get the name of this stream (__DEV && __TOOL builds only)
GetOpenCallback | Returns the current stream-open callback
Open | Attempts to open a file of the given name, returning NULL on failure. All filenames are treated verbatim at this level; there is no notion of an asset path or anything like that. See data/asset.h for a higher-level way to open files. Uses the current "default open file method" to access the file.
OutputAllFileAccess | Turns on a bool that causes all file operations to print debug information
PreLoad | Fully loads a stream into memory. Will create a new stream and close the given one.
PutCh | Puts a single char to the string.
Read | Read the as many as "count" into the "dest".
ReadByte |
ReadFloat |
ReadInt |
ReadLong |
ReadShort |
ReadTChar |
Seek | Seeks directly to specified position in the file. No "whence" parameter is supported; use fiStream::Tell as necessary to implement relative file pointer movement.
Seek64 | Seeks directly to specified position in the file. No "whence" parameter is supported; use fiStream::Tell64 as necessary to implement relative file pointer movement.
SetCloseCallback | Sets a callback that gets called every time a stream is closed.
SetCreateCallback | Sets a callback that gets called every time a stream is created.
SetFaultInjectionPath | also for testing error handling by making certain folders fail loading
SetOpenCallback | Sets a callback that gets called every time a stream is opened.
Size | Returns the total size of the file.
Size64 | Returns the total size of the file.
Tell | Returns current file position (start + offset.)
Tell64 | Returns current file position (start + offset.)
TellStart |
Write | Write as many as "count" from src into buffer.
WriteByte |
WriteFloat |
WriteInt |
WriteLong |
WriteShort |
WriteTChar |


Inheritance Hierarchy

Inheritance Hierarchy
fiStream Class
Inheritance Hierarchy
fiStream


fiTokenizer Class Constructors

fiTokenizer Class Constructors
fiTokenizer Class
Constructors
Constructor | Description
fiAsciiTokenizer |
fiTokenizer |


fiTokenizer Class Data Members

fiTokenizer Class Data Members
fiTokenizer Class
Data Members
Data Member | Description
CommentChar |
filename |
line |
m_nNumTabs | Holds the current indentation tabs
m_WriteState |
nextch |
S |


fiTokenizer Class Destructors

fiTokenizer Class Destructors
fiTokenizer Class
Destructors
Destructor | Description
~fiBaseTokenizer |


fiTokenizer Class Enumerations

fiTokenizer Class Enumerations
fiTokenizer Class
Enumerations
Enumeration | Description
enState |


Legend

Legend
fiTokenizer Class
Legend
Method
Data Member
protected
virtual
abstract


fiTokenizer Class Members

fiTokenizer Class Members
fiTokenizer Class
Members
Constructors
Constructor | Description
fiAsciiTokenizer |
fiTokenizer |
Data Members
Data Member | Description
CommentChar |
filename |
line |
m_nNumTabs | Holds the current indentation tabs
m_WriteState |
nextch |
S |
Methods
Method | Description
CheckIToken |
CheckToken |
EndBlock | Decreases the tab by one
EndBlock | Decreases the tab by one
EndLine | Starts a new line
EndLine | Starts a new line
EndOfFile |
GetBlock | get a block of "length" characters
GetByte | read functions:
GetByte | Reads a numerical value and returns it
GetDelimiter |
GetDelimiter |
GetFloat | Reads a numerical value and returns it
GetFloat | Reads a numerical value and returns it
GetHexU32 |
GetInt | Reads a numerical value and returns it
GetInt | Reads a numerical value and returns it
GetLine |
GetName |
GetNextCh |
GetShort | Reads a numerical value and returns it
GetShort | Reads a numerical value and returns it
GetStream |
GetStreamPosition |
GetToken | read functions:
GetTokenCh |
GetTokenToChar |
GetTokenToChars |
GetVector | Reads a numerical value and returns it
GetVector | Reads a numerical value and returns it
GetWriteState |
IgnoreToken |
Indent |
Indent |
Init |
IsBinary |
IsBinary |
iswhitespace |
MatchFloat |
MatchFloat |
MatchIFloat |
MatchIFloat |
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchIToken |
MatchIVector |
MatchIVector |
MatchToken |
MatchVector |
MatchVector |
Pop | pop the current block as defined by "{" and "}" delimiters. this will also pop any sub-blocks. useful for file formats in a state of flux.
Put |
Put |
PutByte |
PutByte |
PutDelimiter |
PutDelimiter |
PutShort |
PutShort |
PutStr |
PutStrLine | convenience functions
Reset |
SetNextCh |
SetStreamPosition |
SetTerminators | Sets a list of characters that should be used for terminating tokens and skipped over.
SetWriteState |
SkipComment |
SkipToEndOfLine |
StartBlock | Increases the tab by one
StartBlock | Increases the tab by one
StartLine | Indents by tab
StartLine | Indents by tab
WriteTabs |
Destructors
Destructor | Description
~fiBaseTokenizer |
Enumerations
Enumeration | Description
enState |


Members

Legend
Method
Data Member
protected
virtual
abstract


fiTokenizer Class Methods

fiTokenizer Class Methods
fiTokenizer Class
Methods
Method | Description
CheckIToken |
CheckToken |
EndBlock | Decreases the tab by one
EndBlock | Decreases the tab by one
EndLine | Starts a new line
EndLine | Starts a new line
EndOfFile |
GetBlock | get a block of "length" characters
GetByte | read functions:
GetByte | Reads a numerical value and returns it
GetDelimiter |
GetDelimiter |
GetFloat | Reads a numerical value and returns it
GetFloat | Reads a numerical value and returns it
GetHexU32 |
GetInt | Reads a numerical value and returns it
GetInt | Reads a numerical value and returns it
GetLine |
GetName |
GetNextCh |
GetShort | Reads a numerical value and returns it
GetShort | Reads a numerical value and returns it
GetStream |
GetStreamPosition |
GetToken | read functions:
GetTokenCh |
GetTokenToChar |
GetTokenToChars |
GetVector | Reads a numerical value and returns it
GetVector | Reads a numerical value and returns it
GetWriteState |
IgnoreToken |
Indent |
Indent |
Init |
IsBinary |
IsBinary |
iswhitespace |
MatchFloat |
MatchFloat |
MatchIFloat |
MatchIFloat |
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchIInt | Case insensitive version of Match*. Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchInt | Match a token and return the subsequent value
MatchIToken |
MatchIVector |
MatchIVector |
MatchToken |
MatchVector |
MatchVector |
Pop | pop the current block as defined by "{" and "}" delimiters. this will also pop any sub-blocks. useful for file formats in a state of flux.
Put |
Put |
PutByte |
PutByte |
PutDelimiter |
PutDelimiter |
PutShort |
PutShort |
PutStr |
PutStrLine | convenience functions
Reset |
SetNextCh |
SetStreamPosition |
SetTerminators | Sets a list of characters that should be used for terminating tokens and skipped over.
SetWriteState |
SkipComment |
SkipToEndOfLine |
StartBlock | Increases the tab by one
StartBlock | Increases the tab by one
StartLine | Indents by tab
StartLine | Indents by tab
WriteTabs |


Inheritance Hierarchy

Inheritance Hierarchy
fiTokenizer Class
Inheritance Hierarchy
rage::fiBaseTokenizer
    rage::fiAsciiTokenizer
        fiTokenizer


fiZipfile Class Constructors

fiZipfile Class Constructors
fiZipfile Class
Constructors
Constructor | Description
fiDevice |
fiZipfile |


fiZipfile Class Data Members

fiZipfile Class Data Members
fiZipfile Class
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
m_ArchiveBias | for nested zipfiles (sigh)
m_ArchiveSize |
m_Device | device the zipfile itself lives on
m_Handle | (bulk) handle on the device of the zipfile itself
m_Name | debug name
m_RelativeOffset | amount of incoming pathname to strip off
m_Root |
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.


fiZipfile Class Destructors

fiZipfile Class Destructors
fiZipfile Class
Destructors
Destructor | Description
~fiDevice |
~fiZipfile |


fiZipfile Class Enumerations

fiZipfile Class Enumerations
fiZipfile Class
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


Legend

Legend
fiZipfile Class
Legend
Data Member
protected
Method
virtual
abstract


fiZipfile Class Members

fiZipfile Class Members
fiZipfile Class
Members
Data Members
Data Member | Description
HARDDRIVE_LSN | Fake offset applied to all sector addresses on the hard drive Small enough to avoid problems with sign changes on 32bit arithmetic.
LAYER1_LSN | Unknown.
m_ArchiveBias | for nested zipfiles (sigh)
m_ArchiveSize |
m_Device | device the zipfile itself lives on
m_Handle | (bulk) handle on the device of the zipfile itself
m_Name | debug name
m_RelativeOffset | amount of incoming pathname to strip off
m_Root |
sm_DeviceProfiler |
sm_FatalReadError | Callback on fatal read errors; system will retry several times before calling this function. The function is not expected to return, although if it does, we will simply continue to retry the read indefinitely with no further notifications. On Xbox 360, you should call XShowDirtyDiscErrorUI, with an appropriate user index (good luck with that), and heed this important caveat: "Titles should continue rendering while the dialog box is displayed; to do so, a title must call this function from a thread other than the thread responsible for rendering."
sm_InjectReadError | Set this to nonzero and it will inject a read error once the counter reaches zero again.
Constructors
Constructor | Description
fiDevice |
fiZipfile |
Destructors
Destructor | Description
~fiDevice |
~fiZipfile |
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk |
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create |
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FillData |
FindEntry |
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
Init |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
MountAs |
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
OpenInternal |
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
ReadInternal |
ReadInternalBulk |
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime |
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size | Determine size of file
Size64 | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write |
WriteBulk | Seek and write binary data to file
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)
Enumerations
Enumeration | Description
eFindFileOptions | Find File in a directory by name and other options


fiZipfile Class Methods

fiZipfile Class Methods
fiZipfile Class
Methods
Method | Description
Close | Close a file
Close | Close a file
CloseBulk | Close a file opened via OpenBulk
CloseBulk |
ConvertFileTimeToSystemTime | Convert a file time (u64, equivalent to a Win32 FILETIME) into human-readable form.
CopyDirectory | Copy a directory and all its contents
CopySingleFile | Copy a file
Create | Attempt to create a file on this device
Create |
CreateBulk | Attempt to open a file on this device for bulk write
DefaultGetDevice | Default implementation of GetDevice function
Delete | Delete a file from device
DeleteDirectory | Remove a directory and optionally all of its contents from a device
FillData |
FindEntry |
FindFile |
FindFileBegin | Iterate over all files in a directory
FindFileBegin | Iterate over all files in a directory
FindFileEnd | Close a search begun with FindFileBegin
FindFileEnd | Close a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FindFileNext | Continue a search begun with FindFileBegin
FixRelativeName |
Flush | Flushes all file data
GetAttributes | Retrieves file attributes
GetAttributes | Retrieves file attributes
GetBulkOffset |
GetDebugName |
GetDebugName |
GetDevice | Returns appropriate device for file
GetFileSize | Determine size of file
GetFileSize | Determine size of file
GetFileTime | Return time-of-date information for a file
GetFileTime | Return time-of-date information for a file
GetLocalSystemTime | Gets the local time from the console
GetLowLevelDevice | Get the actual low-level device that drives I/O on this device.
GetPackfileIndex | Returns a small nonzero number uniquely identifying this device as a packfile which can then be passed to pgStreamer::GetArchive later on.
GetPhysicalSortKey |
GetResourceInfo | Retrieve resource information for a file. It only works files that have a standard resource header.
GetRpfDevice |
Init |
InitClass |
IsCloud |
IsOutOfDate | Convenience function which compares to files.
IsRpf |
Lock | Lock the filesystem (for serialization).
MakeDirectory | Make a directory on device
MakeGrowBufferFileName | Create a filename that can be used to reference a growable buffer
MakeMemoryFileName | Create a filename that can be used to reference a file in memory
Mount | Establish a mount point in the global file namespace
MountAs |
Normalize | Normalize a filename in-place
Open | Attempt to open a file on this device
Open | Attempt to open a file on this device
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulk | Attempt to open a file on this device for bulk read
OpenBulkDrm | Attempt to open a drm secured file on this device for bulk read
OpenInternal |
PrefetchDir | Tell the file system to prefetch information about this directory. On some devices (currently only fiDeviceRemote), this will speed up subsequent calls to get more information about files within this particular directory.
Read | Read binary data from file
Read | Read binary data from file
ReadBulk | Seek and read binary data from file
ReadBulk | Seek and read binary data from file
ReadInternal |
ReadInternalBulk |
Remount | Re-establish a mount point in the global file namespace for an existing device.
Rename | Rename a file on device. Behavior is undefined if you attempt to change its directory during a rename. New name must not exist, delete any file with the new name first if necessary.
SafeRead | Read data from file, with retry until error Safe version of coreRawReadFile.
SafeWrite | Write data to file, with retry until error Safe version of coreRawWriteFile.
Seek | Seek to a location in file
Seek | Seek to a location in file
Seek64 | Seek to a location in file
Seek64 | Seek to a location in file
SetAttributes | Sets file attributes
SetDeviceProfiler |
SetEndOfFile | Sets the end of the file to the current file position.
SetFileTime | Set time-of-date information for a file
SetFileTime |
SetFindNewest | Enables or disables ability to look through all devices mounted to a path and select the one containing the file with newest timestamp
SetMaxMounts | Specify the number of archives that can be mounted. This needs to be called before the first archive gets mounted.
Size | Determine size of file
Size | Determine size of file
Size64 | Determine size of file
Size64 | Determine size of file
Unlock | Unlock the filesystem (for serialization).
UnmakeDirectory | Remove an empty directory on device. Lame is name to avoid #define conflict with Windows SDK
Unmount | Remove a previously established mount point
Write | Write binary data to file
Write |
WriteBulk | Seek and write binary data to file


fiZipfile Class Structs

fiZipfile Class Structs
fiZipfile Class
Structs
Struct | Description
SystemTime | __DEVPROF This is a portable version of Win32 SYSTEMTIME structure. (Field names are kept identical for clarity)


Inheritance Hierarchy

Inheritance Hierarchy
fiZipfile Class
Inheritance Hierarchy
rage::fiDevice
    fiZipfile


fiZipfileState Struct Constructors

fiZipfileState Struct Constructors
fiZipfileState Struct
Constructors
Constructor | Description
fiZipfileState |


fiZipfileState Struct Data Members

fiZipfileState Struct Data Members
fiZipfileState Struct
Data Members
Data Member | Description
BufferSize |
m_Buffer |
m_CompOffset | Current offset within the compressed file
m_DebugName |
m_Entry | Pointer to the file directory entry
m_Offset | Current offset within the (virtual, uncompressed) file
m_zStream | Stream object used by Zlib


Legend

Legend
fiZipfileState Struct
Legend
Data Member
Method


fiZipfileState Struct Members

fiZipfileState Struct Members
fiZipfileState Struct
Members
Data Members
Data Member | Description
BufferSize |
m_Buffer |
m_CompOffset | Current offset within the compressed file
m_DebugName |
m_Entry | Pointer to the file directory entry
m_Offset | Current offset within the (virtual, uncompressed) file
m_zStream | Stream object used by Zlib
Constructors
Constructor | Description
fiZipfileState |
Methods
Method | Description
IsCompressed |
Reset |


fiZipfileState Struct Methods

fiZipfileState Struct Methods
fiZipfileState Struct
Methods
Method | Description
IsCompressed |
Reset |


Inheritance Hierarchy

Inheritance Hierarchy
fiZipfileState Struct
Inheritance Hierarchy
fiZipfileState


Header Class Constructors

Header Class Constructors
Header Class
Constructors
Constructor | Description
Header |


Header Class Data Members

Header Class Data Members
Header Class
Data Members
Data Member | Description
FILE_VERSION |
m_DisplayName |
m_Hash |
m_Version |
MAX_BYTE_SIZEOF_PAYLOAD | m_Hash


Legend

Legend
Header Class
Legend
Data Member
Method


Header Class Members

Header Class Members
Header Class
Members
Data Members
Data Member | Description
FILE_VERSION |
m_DisplayName |
m_Hash |
m_Version |
MAX_BYTE_SIZEOF_PAYLOAD | m_Hash
Constructors
Constructor | Description
Header |
Methods
Method | Description
CalculateHash |
Clear |
Export |
GetDisplayName |
GetExpectedVersion |
GetVersion |
Import |


Header Class Methods

Header Class Methods
Header Class
Methods
Method | Description
CalculateHash |
Clear |
Export |
GetDisplayName |
GetExpectedVersion |
GetVersion |
Import |


Inheritance Hierarchy

Inheritance Hierarchy
Header Class
Inheritance Hierarchy
Header


Mount_t Struct Constructors

Mount_t Struct Constructors
Mount_t Struct
Constructors
Constructor | Description
Mount_t |


Mount_t Struct Data Members

Mount_t Struct Data Members
Mount_t Struct
Data Members
Data Member | Description
Device |
Path |
PathLen |
ReadOnly |


Legend

Legend
Mount_t Struct
Legend
Data Member
Method


Mount_t Struct Members

Mount_t Struct Members
Mount_t Struct
Members
Data Members
Data Member | Description
Device |
Path |
PathLen |
ReadOnly |
Constructors
Constructor | Description
Mount_t |


Inheritance Hierarchy

Inheritance Hierarchy
Mount_t Struct
Inheritance Hierarchy
Mount_t


Legend

Legend
MsDosDate Struct
Legend
Method


MsDosDate Struct Members

MsDosDate Struct Members
MsDosDate Struct
Members
Methods
Method | Description
DECLARE_BITFIELD_3 | day is 1-31, month is 1-12


MsDosDate Struct Methods

MsDosDate Struct Methods
MsDosDate Struct
Methods
Method | Description
DECLARE_BITFIELD_3 | day is 1-31, month is 1-12


Inheritance Hierarchy

Inheritance Hierarchy
MsDosDate Struct
Inheritance Hierarchy
MsDosDate


Legend

Legend
MsDosTime Struct
Legend
Method


MsDosTime Struct Members

MsDosTime Struct Members
MsDosTime Struct
Members
Methods
Method | Description
DECLARE_BITFIELD_3 |


MsDosTime Struct Methods

MsDosTime Struct Methods
MsDosTime Struct
Methods
Method | Description
DECLARE_BITFIELD_3 |


Inheritance Hierarchy

Inheritance Hierarchy
MsDosTime Struct
Inheritance Hierarchy
MsDosTime


XenonProfile Class Constructors

XenonProfile Class Constructors
XenonProfile Class
Constructors
Constructor | Description
XenonProfile |


XenonProfile Class Destructors

XenonProfile Class Destructors
XenonProfile Class
Destructors
Destructor | Description
~XenonProfile |


Legend

Legend
XenonProfile Class
Legend
Method


XenonProfile Class Members

XenonProfile Class Members
XenonProfile Class
Members
Constructors
Constructor | Description
XenonProfile |
Destructors
Destructor | Description
~XenonProfile |
Methods
Method | Description
BeginContentVerify |
BeginDelete |
BeginEnumeration |
BeginFreeSpaceCheck | HACK_GTA4 HACK_GTA4
BeginGetCreator |
BeginGetFileSize |
BeginIconSave |
BeginLoad |
BeginSave |
BeginSelectDevice |
CalculateDataSizeOnDisk |
CheckContentVerify |
CheckDelete |
CheckEnumeration |
CheckFreeSpaceCheck |
CheckGetCreator |
CheckGetFileSize |
CheckIconSave |
CheckLoad |
CheckSave |
CheckSelectDevice |
CompareTimestamps |
EndContentVerify |
EndDelete |
EndEnumeration |
EndFreeSpaceCheck |
EndGetCreator |
EndGetFileSize |
EndIconSave |
EndLoad |
EndSave |
EndSelectDevice |
FillDevice |
GetCurrentDeviceData |
GetDeviceData |
GetError |
GetLoadSize |
GetSaveSize |
GetSelectedDevice |
GetState |
GetTotalAvailableSpace |
HasFileBeenAccessed |
IsCurrentDeviceValid |
IsDeviceValid |
IsStorageDeviceChanged |
IsStorageDeviceRemoved |
SetSelectedDevice |
SetSelectedDeviceToAny |
SetStateToIdle |


XenonProfile Class Methods

XenonProfile Class Methods
XenonProfile Class
Methods
Method | Description
BeginContentVerify |
BeginDelete |
BeginEnumeration |
BeginFreeSpaceCheck | HACK_GTA4 HACK_GTA4
BeginGetCreator |
BeginGetFileSize |
BeginIconSave |
BeginLoad |
BeginSave |
BeginSelectDevice |
CalculateDataSizeOnDisk |
CheckContentVerify |
CheckDelete |
CheckEnumeration |
CheckFreeSpaceCheck |
CheckGetCreator |
CheckGetFileSize |
CheckIconSave |
CheckLoad |
CheckSave |
CheckSelectDevice |
CompareTimestamps |
EndContentVerify |
EndDelete |
EndEnumeration |
EndFreeSpaceCheck |
EndGetCreator |
EndGetFileSize |
EndIconSave |
EndLoad |
EndSave |
EndSelectDevice |
FillDevice |
GetCurrentDeviceData |
GetDeviceData |
GetError |
GetLoadSize |
GetSaveSize |
GetSelectedDevice |
GetState |
GetTotalAvailableSpace |
HasFileBeenAccessed |
IsCurrentDeviceValid |
IsDeviceValid |
IsStorageDeviceChanged |
IsStorageDeviceRemoved |
SetSelectedDevice |
SetSelectedDeviceToAny |
SetStateToIdle |


Inheritance Hierarchy

Inheritance Hierarchy
XenonProfile Class
Inheritance Hierarchy
XenonProfile


zipDirEntry Struct Constructors

zipDirEntry Struct Constructors
zipDirEntry Struct
Constructors
Constructor | Description
zipDirEntry |


zipDirEntry Struct Data Members

zipDirEntry Struct Data Members
zipDirEntry Struct
Data Members
Data Member | Description
1 |
Child |
CompSize |
FileTime | Only for files
Hash |
Name |
Next |
Offset | Only for files (zero if it's a directory)
UncompSize |


zipDirEntry Struct Destructors

zipDirEntry Struct Destructors
zipDirEntry Struct
Destructors
Destructor | Description
~zipDirEntry |


Legend

Legend
zipDirEntry Struct
Legend
Data Member
Method


zipDirEntry Struct Members

zipDirEntry Struct Members
zipDirEntry Struct
Members
Data Members
Data Member | Description
1 |
Child |
CompSize |
FileTime | Only for files
Hash |
Name |
Next |
Offset | Only for files (zero if it's a directory)
UncompSize |
Constructors
Constructor | Description
zipDirEntry |
Destructors
Destructor | Description
~zipDirEntry |
Methods
Method | Description
Dump |
Insert |
IsCompressed |
IsDir |


zipDirEntry Struct Methods

zipDirEntry Struct Methods
zipDirEntry Struct
Methods
Method | Description
Dump |
Insert |
IsCompressed |
IsDir |


Inheritance Hierarchy

Inheritance Hierarchy
zipDirEntry Struct
Inheritance Hierarchy
zipDirEntry


Contents

Contents
asset
Overview
Components
Relationships
Command Line Options
Working Examples
Symbol Reference
rage Namespace
fiSaveGameState Namespace
State Enumeration
fiArchive Class
Constructors
fiArchive Constructor
Methods
GetVersion Method
IsLoading Method
IsStoring Method
Operators
&
& Operator (Quaternion&)
& Operator (T&)
& Operator (Vector3&)
& Operator (char&)
& Operator (float&)
& Operator (int&)
& Operator (short&)
& Operator (std::pair<X, Y>&)
& Operator (std::vector<T>&)
& Operator (unsigned char&)
& Operator (unsigned int&)
& Operator (unsigned short&)
fiAsciiTokenizer Class Component
Data Members
m_nNumTabs Data Member
Constructors
fiAsciiTokenizer Constructor
Methods
EndBlock Method
EndLine Method
GetByte Method
GetDelimiter Method
GetHexU32 Method
GetVector
Indent Method
IsBinary Method
MatchFloat Method
MatchIFloat Method
MatchIInt Method
MatchInt Method
MatchIVector
MatchIVector Method (const char *, Vec_xyz&)
MatchIVector Method (const char *, Vec_xyzw&)
MatchIVector Method (const char *, Vector2&)
MatchIVector Method (const char *, Vector3&)
MatchIVector Method (const char *, Vector4&)
MatchVector
MatchVector Method (const char *, Vec_xyz&)
MatchVector Method (const char *, Vec_xyzw&)
MatchVector Method (const char *, Vector2&)
MatchVector Method (const char *, Vector3&)
MatchVector Method (const char *, Vector4&)
Put
Put Method (const Mat33V&)
Put Method (const Mat34V&)
Put Method (const ScalarV&)
Put Method (const Vec2V&)
Put Method (const Vec3V&)
Put Method (const Vec4V&)
Put Method (const Vector2&)
Put Method (const Vector3&)
Put Method (const Vector4&)
Put Method (const char*, unsigned int)
Put Method (float)
Put Method (int)
PutByte Method
PutDelimiter Method
PutShort Method
StartBlock Method
StartLine Method
WriteTabs Method
fiAssetManager Class Component
Data Members
MAX_FILENAME_LENGTH Data Member
Structs
Entry Struct
Constructors
fiAssetManager Constructor
Destructors
~fiAssetManager Destructor
Methods
AddExtension Method
BaseName Method
ClearAttributes Method
Create Method
CreateLeadingPath Method
EnumFiles Method
Exists Method
FileName Method
FindExtensionInPath Method
FindPath Method
FullPath Method
FullReadPath Method
FullWritePath Method
GetAttributes Method
GetPath Method
GetPathCount Method
GetStackedPath Method
InsertPathElement Method
IsAbsolutePath Method
MakeFolderRelative Method
MakeRelative Method
Open Method
PopFolder Method
PushFolder Method
RemoveExtensionFromPath Method
RemoveNameFromPath Method
SetAttributes Method
SetPath Method
fiAsynchStream Class
Constructors
fiAsynchStream Constructor
Destructors
~fiAsynchStream Destructor
Methods
GetMemoryFileName Method
GetSize Method
Init
Init Method (const char *, const char *)
Init Method (const char *, const char *, int, int)
Poll Method
fiBaseTokenizer Class Component
Data Members
CommentChar Data Member
filename Data Member
line Data Member
m_WriteState Data Member
nextch Data Member
S Data Member
Destructors
~fiBaseTokenizer Destructor
Methods
CheckIToken Method
CheckToken Method
EndBlock Method
EndLine Method
EndOfFile Method
GetBlock Method
GetByte Method
GetDelimiter Method
GetLine Method
GetName Method
GetNextCh Method
GetStream Method
GetStreamPosition Method
GetToken Method
GetTokenCh Method
GetTokenToChar Method
GetTokenToChars Method
GetVector
GetWriteState Method
IgnoreToken Method
Indent Method
Init Method
IsBinary Method
iswhitespace Method
MatchFloat Method
MatchIFloat Method
MatchIInt Method
MatchInt Method
MatchIToken Method
MatchIVector
MatchIVector Method (const char *, Vec_xyz&)
MatchIVector Method (const char *, Vec_xyzw&)
MatchIVector Method (const char *, Vector2&)
MatchIVector Method (const char *, Vector3&)
MatchIVector Method (const char *, Vector4&)
MatchToken Method
MatchVector
MatchVector Method (const char *, Vec_xyz&)
MatchVector Method (const char *, Vec_xyzw&)
MatchVector Method (const char *, Vector2&)
MatchVector Method (const char *, Vector3&)
MatchVector Method (const char *, Vector4&)
Pop Method
Put
Put Method (bool)
Put Method (char)
Put Method (const Vector2&)
Put Method (const Vector3&)
Put Method (const Vector4&)
Put Method (const char*, unsigned int)
Put Method (float)
Put Method (int)
PutByte Method
PutDelimiter Method
PutShort Method
PutStr Method
PutStrLine Method
Reset Method
SetNextCh Method
SetStreamPosition Method
SetTerminators Method
SetWriteState Method
SkipComment Method
SkipToEndOfLine Method
StartBlock Method
StartLine Method
Enumerations
enState Enumeration
fiBinTokenizer Class Component
Methods
GetByte Method
GetDelimiter Method
GetVector
IsBinary Method
MatchFloat Method
MatchIFloat Method
MatchIInt Method
MatchInt Method
MatchIVector
MatchIVector Method (const char *, Vec_xyz&)
MatchIVector Method (const char *, Vec_xyzw&)
MatchIVector Method (const char *, Vector2&)
MatchIVector Method (const char *, Vector3&)
MatchIVector Method (const char *, Vector4&)
MatchVector
MatchVector Method (const char *, Vec_xyz&)
MatchVector Method (const char *, Vec_xyzw&)
MatchVector Method (const char *, Vector2&)
MatchVector Method (const char *, Vector3&)
MatchVector Method (const char *, Vector4&)
Put
Put Method (const Vector2&)
Put Method (const Vector3&)
Put Method (const Vector4&)
Put Method (const char*, unsigned int)
Put Method (float)
Put Method (int)
PutByte Method
PutDelimiter Method
PutShort Method
fiCachedDevice Class
Methods
Close Method
CloseBulk Method
Create Method
GetBlockPhysicalSortKey Method
GetDebugName Method
GetFileSize Method
GetFileTime Method
Open Method
OpenBulk Method
Prefetch Method
Read Method
ReadBulk Method
Seek Method
Seek64 Method
SetFileTime Method
Write Method
Friends
class fiDiskCache Friend
fiCachePartition Class
Methods
GetCachePrefix Method
Init Method
IsAvailable Method
Reset Method
Shutdown Method
fiCollection Class
Data Members
ArchiveMask Data Member
ArchiveShift Data Member
EntryMask Data Member
m_isStreaming Data Member
sm_Collections Data Member
Constructors
fiCollection Constructor
Methods
GetBasePhysicalSortKey Method
GetCollection Method
GetCollectionIndex Method
GetEntryFullName Method
GetEntryIndex Method
GetEntryInfo Method
GetEntryName Method
GetEntryPhysicalSortKey Method
IsPackfile Method
IsStreaming Method
MakeHandle Method
OpenBulkFromHandle Method
Prefetch Method
SetStreaming Method
Shutdown Method
fiCompressionData Class
Constructors
fiCompressionData Constructor
Destructors
~fiCompressionData Destructor
Methods
BuildHeader Method
Compress Method
CreateNewInstance Method
Decompress Method
GetCompressUpperBound Method
GetHeaderPrefix Method
GetHeaderSize Method
GetStaticHeaderPrefix Method
ParseHeader Method
fiDevice Class Component
Data Members
HARDDRIVE_LSN Data Member
LAYER1_LSN Data Member
sm_DeviceProfiler Data Member
sm_FatalReadError Data Member
sm_InjectReadError Data Member
Structs
SystemTime Struct
Constructors
fiDevice Constructor
Destructors
~fiDevice Destructor
Methods
Close Method
CloseBulk Method
ConvertFileTimeToSystemTime Method
CopyDirectory Method
CopySingleFile Method
Create Method
CreateBulk Method
DefaultGetDevice Method
Delete Method
DeleteDirectory Method
FindFile Method
FindFileBegin Method
FindFileEnd Method
FindFileNext Method
FixRelativeName Method
Flush Method
GetAttributes Method
GetBulkOffset Method
GetDebugName Method
GetDevice Method
GetFileSize Method
GetFileTime Method
GetLocalSystemTime Method
GetLowLevelDevice Method
GetPackfileIndex Method
GetPhysicalSortKey Method
GetResourceInfo Method
GetRpfDevice Method
InitClass Method
IsCloud Method
IsOutOfDate Method
IsRpf Method
Lock Method
MakeDirectory Method
MakeGrowBufferFileName Method
MakeMemoryFileName Method
Mount Method
Normalize Method
Open Method
OpenBulk Method
OpenBulkDrm Method
PrefetchDir Method
Read Method
ReadBulk Method
Remount Method
Rename Method
SafeRead Method
SafeWrite Method
Seek Method
Seek64 Method
SetAttributes Method
SetDeviceProfiler Method
SetEndOfFile Method
SetFileTime Method
SetFindNewest Method
SetMaxMounts Method
Size Method
Size64 Method
Unlock Method
UnmakeDirectory Method
Unmount
Unmount Method (const char *)
Unmount Method (const fiDevice &)
Write Method
WriteBulk Method
Enumerations
eFindFileOptions Enumeration
fiDeviceCount Class
Methods
Close Method
Create Method
GetDebugName Method
GetFileTime Method
GetInstance Method
Open Method
Read Method
Seek Method
Seek64 Method
SetFileTime Method
Size Method
Size64 Method
Write Method
fiDeviceGrowBuffer Class
Methods
Close Method
CloseBulk Method
Create Method
GetAttributes Method
GetDebugName Method
GetFileSize Method
GetFileTime Method
GetInstance Method
Open Method
OpenBulk Method
Read Method
ReadBulk Method
SafeRead Method
SafeWrite Method
Seek Method
Seek64 Method
SetFileTime Method
Write Method
fiDeviceInstaller Class
Structs
HddFile Struct
InitData Struct
InitDataList Struct
InstallFile Struct
Constructors
fiDeviceInstaller Constructor
Destructors
~fiDeviceInstaller Destructor
Methods
Close Method
CloseBulk Method
CopyContentInfoFile Method
Create Method
Delete Method
DoFileSizesMatch Method
DoTimestampsMatch Method
FindFileBegin Method
FindFileEnd Method
FindFileNext Method
FinishInstall Method
FixName Method
FlagInstalledRpfs Method
GetAttributes Method
GetBulkOffset Method
GetDebugName Method
GetFileSize Method
GetFileTime Method
GetInstallName Method
GetInstallProgress Method
GetInstallStatus Method
GetIsBootedFromHdd Method
GetPackFileSize Method
GetPartitionName Method
GetPhysicalSortKey Method
GetResourceInfo Method
GetRpfDevice Method
Init Method
InitInstall Method
InitPartitionDevice Method
InstallerThread Method
InstallProgress Method
IsPartitionPath Method
IsRpf Method
IsTargetDeviceValid Method
MakeDirectory Method
MountAs Method
Open Method
OpenBulk Method
PauseDiscRead Method
Read Method
ReadBulk Method
ReadInstallFile Method
RegisterFileDoneCallback Method
Rename Method
ResumeDiscRead Method
ScheduleFile Method
Seek Method
Seek64 Method
SetAsync Method
SetAttributes Method
SetEndOfFile Method
SetFileTime Method
SetIsBootedFromHdd Method
SetKeepaliveCallback Method
StartInstall Method
StorePackageTimestamp Method
StripPath Method
UnmakeDirectory Method
Write Method
WriteInstallFile Method
fiDeviceLocal Class
Methods
Close Method
CloseBulk Method
Create Method
CreateBulk Method
Delete Method
FindFileBegin Method
FindFileEnd Method
FindFileNext Method
FixName Method
GetAttributes Method
GetDebugName Method
GetFileSize Method
GetFileTime Method
GetInstance Method
GetPhysicalSortKey Method
MakeDirectory Method
OnDiscSwap Method
Open Method
OpenBulk Method
Read Method
ReadBulk Method
Rename Method
Seek Method
Seek64 Method
SetAttributes Method
SetEndOfFile Method
SetFileTime Method
UnmakeDirectory Method
Write Method
WriteBulk Method
fiDeviceLocalDrm Class
Methods
OpenBulkDrm Method
fiDeviceMemory Class
Methods
Close Method
CloseBulk Method
Create Method
GetAttributes Method
GetDebugName Method
GetFileSize Method
GetFileTime Method
GetInstance Method
Open Method
OpenBulk Method
Read Method
ReadBulk Method
SafeRead Method
SafeWrite Method
Seek Method
Seek64 Method
SetFileTime Method
Write Method
fiDeviceProfiler Struct
Destructors
~fiDeviceProfiler Destructor
Methods
OnClose Method
OnOpen Method
OnRead Method
OnReadEnd Method
OnSeek Method
OnWrite Method
fiDeviceRelative Class
Data Members
m_pDevice Data Member
Constructors
fiDeviceRelative Constructor
Destructors
~fiDeviceRelative Destructor
Methods
Close Method
CloseBulk Method
Create Method
Delete Method
FindFileBegin Method
FindFileEnd Method
FindFileNext Method
FixName Method
FixRelativeName Method
GetAttributes Method
GetBulkOffset Method
GetDebugName Method
GetFileSize Method
GetFileTime Method
GetLowLevelDevice Method
GetPhysicalSortKey Method
GetResourceInfo Method
Init Method
MakeDirectory Method
MountAs Method
Open Method
OpenBulk Method
OpenBulkDrm Method
PrefetchDir Method
Read Method
ReadBulk Method
Rename Method
Seek Method
Seek64 Method
SetAttributes Method
SetEndOfFile Method
SetFileTime Method
UnmakeDirectory Method
Write Method
fiDeviceRemote Class
Methods
Close Method
CloseBulk Method
Create Method
Delete Method
DeleteDirectory Method
FindFileBegin Method
FindFileEnd Method
FindFileNext Method
GetAttributes Method
GetAttributesDir Method
GetAverageThroughput Method
GetDebugName Method
GetFileCount Method
GetFileSize Method
GetFileTime Method
GetInstance Method
GetResourceInfo Method
InitClass Method
InvalidateDirectoryCache Method
MakeDirectory Method
Open Method
OpenBulk Method
PrefetchDir Method
Read Method
ReadBulk Method
Seek Method
Seek64 Method
SetAttributes Method
SetFileTime Method
ShutdownClass Method
Write Method
fiDeviceTcpIp Class
Constructors
fiDeviceTcpIp Constructor
Destructors
~fiDeviceTcpIp Destructor
Methods
Close Method
Connect Method
Create Method
GetDebugName Method
GetFileTime Method
GetInstance Method
GetLastError Method
GetLocalHost Method
GetReadCount Method
InitClass Method
Listen Method
Open Method
Pickup Method
PrintInterfaceState Method
PrintNetStats Method
Read Method
Seek Method
Seek64 Method
SetBlocking Method
SetFileTime Method
SetLastError Method
SetLocalHost Method
ShutdownClass Method
StaticWrite Method
WaitForNetworkReady Method
Write Method
fiDeviceXContent Class
Constructors
fiDeviceXContent Constructor
Destructors
~fiDeviceXContent Destructor
Methods
Init Method
MountAs Method
Shutdown Method
fiDiskCache Class
Methods
GetCachedDevice Method
GetCacheInProgress Method
GetCacheOccupancy Method
GetHoldoffTime Method
GetLastCacheCopyCompletion Method
InitClass Method
IsCacheCopying Method
IsCacheEnabled Method
IsCachePrimed Method
LeaveBootMode Method
SetHoldoffTime Method
ShutdownClass Method
Friends
class fiCachedDevice Friend
fiEmbeddedFile Class
Constructors
fiEmbeddedFile Constructor
Methods
Lookup Method
fiMultiTokenizer Class
Constructors
fiMultiTokenizer Constructor
Methods
GetReadTokenizer Method
GetWriteTokenizer Method
fiPackEntry Struct
Data Members
FileOffset_IsDir Data Member
FileOffset_Shift Data Member
MaxConsumedSize Data Member
u Data Member
Methods
DECLARE_BITFIELD_4 Method
GetConsumedSize Method
GetFileOffset Method
GetUncompressedSize Method
GetVersion Method
IsCompressed Method
IsDir Method
IsFile Method
IsResource Method
SetFileOffset Method
fiPackfile Class COMPONENT
Data Members
m_ArchiveBias Data Member
m_ArchiveSize Data Member
m_CachedDataSize Data Member
m_CachedMetaDataSize Data Member
m_Device Data Member
m_Entries Data Member
m_EntryCount Data Member
m_FileTime Data Member
m_Fullname Data Member
m_Handle Data Member
m_IsByteSwapped Data Member
m_IsCached Data Member
m_IsInstalled Data Member
m_IsRpf Data Member
m_IsUserHeader Data Member
m_IsXCompressed Data Member
m_KeyId Data Member
m_MemoryBuffer Data Member
m_Name Data Member
m_NameHeap Data Member
m_NameHeapInDebugHeap Data Member
m_NameShift Data Member
m_ParentIndices Data Member
m_pDrmKey Data Member
m_RelativeOffset Data Member
m_SelfIndex Data Member
m_SortKey Data Member
Constructors
fiPackfile Constructor
Destructors
~fiPackfile Destructor
Methods
ClearRelativeOffset Method
Close Method
CloseBulk Method
Create Method
ExtractFileToMemory Method
FillData Method
FillParentIndices Method
FindEntry Method
FindFileBegin Method
FindFileEnd Method
FindFileNext Method
GetAttributes Method
GetBasePhysicalSortKey Method
GetBulkOffset Method
GetDebugName Method
GetEntries Method
GetEntryCount Method
GetEntryFullName Method
GetEntryIndex Method
GetEntryInfo Method
GetEntryName Method
GetEntryPhysicalSortKey Method
GetFileSize Method
GetFileTime Method
GetHeaderSize Method
GetNameHeap Method
GetNameShift Method
GetPackfileHandle Method
GetPackfileIndex Method
GetPackfileSize Method
GetPackfileTime Method
GetPhysicalSortKey Method
GetRelativeOffset Method
GetResourceInfo Method
Init Method
InitFromImg Method
InitFromZip Method
IsInitialized Method
IsPackfile Method
IsRpf Method
IsUserHeader Method
MountAs Method
Open Method
OpenBulk Method
OpenBulkFromHandle Method
OpenDirect Method
OpenInternal Method
Prefetch Method
Read Method
ReadBulk Method
ReadInternal Method
ReadInternalBulk Method
ReInit Method
RemountDependentPackfiles Method
Seek Method
Seek64 Method
SetDrmKey Method
SetFileTime Method
SetpackfileHandle Method
SetPackfileTime Method
SetReadAheadCacheCPU Method
SetRelativePath Method
Shutdown Method
Size Method
Size64 Method
UnInit Method
Write Method
Enumerations
CacheMode Enumeration
Nested Types
ParentIndexType Nested Type
fiPackfileState Struct
Data Members
avail_in Data Member
BufferSize Data Member
m_Buffer Data Member
m_CompOffset Data Member
m_DebugName Data Member
m_Entry Data Member
m_Offset Data Member
m_xStream Data Member
m_zStream Data Member
next_in Data Member
Constructors
fiPackfileState Constructor
Methods
IsCompressed Method
Reset Method
fiRpf7Builder Class
Constructors
fiRpf7Builder Constructor
Destructors
~fiRpf7Builder Destructor
Methods
AddData Method
AddFile Method
Save Method
fiRpf7Entry Struct
Data Members
1 Data Member
Child Data Member
DataSize Data Member
NameOffset Data Member
Next Data Member
SourceName Data Member
Constructors
fiRpf7Entry Constructor
Destructors
~fiRpf7Entry Destructor
fiSafeStream Class Component
Constructors
fiSafeStream Constructor
Destructors
~fiSafeStream Destructor
Operators
-> Operator
fiStream* Operator
fiSaveGame Class
Data Members
SIGNIN_COUNT Data Member
Structs
Content Struct
Device Struct
Methods
BeginContentVerify Method
BeginDelete Method
BeginDeleteFromList Method
BeginEnumeration Method
BeginExtraSpaceCheck Method
BeginFreeSpaceCheck Method
BeginGetCreator Method
BeginGetFileModifiedTime Method
BeginGetFileSize Method
BeginIconSave Method
BeginLoad Method
BeginReadNamesAndSizesOfAllSaveGames Method
BeginSave Method
BeginSelectDevice Method
CalculateDataSizeOnDisk Method
CalculateSizeOfSaveGameFile Method
CheckContentVerify Method
CheckDelete Method
CheckDeleteFromList Method
CheckEnumeration Method
CheckExtraSpaceCheck Method
CheckFreeSpaceCheck Method
CheckGetCreator
CheckGetCreator Method (int, bool &)
CheckGetCreator Method (int, bool &, bool&)
CheckGetFileModifiedTime Method
CheckGetFileSize Method
CheckIconSave Method
CheckLoad Method
CheckReadNamesAndSizesOfAllSaveGames Method
CheckSave Method
CheckSelectDevice Method
EndContentVerify Method
EndDelete Method
EndDeleteFromList Method
EndEnumeration Method
EndExtraSpaceCheck Method
EndFreeSpaceCheck Method
EndGetCreator Method
EndGetFileModifiedTime Method
EndGetFileSize Method
EndIconSave Method
EndLoad Method
EndReadNamesAndSizesOfAllSaveGames Method
EndSave Method
EndSelectDevice Method
FillDevice Method
GetCurrentDeviceData Method
GetDeviceData Method
GetError Method
GetMaxUsers Method
GetSelectedDevice Method
GetState Method
GetTotalAvailableSpace Method
HasFileBeenAccessed Method
InitClass Method
IsCurrentDeviceValid Method
IsDeviceValid Method
IsStorageDeviceChanged Method
IsStorageDeviceRemoved Method
SetCheckForUserBindErrors Method
SetIcon Method
SetMaxNumberOfSaveGameFilesToEnumerate Method
SetMountIndex Method
SetSaveGameFolder Method
SetSaveGameTitle Method
SetSelectedDevice Method
SetSelectedDeviceToAny Method
SetStateToIdle Method
SetUserServiceId Method
ShowDeleteDialog Method
ShowLoadDialog Method
ShowSaveDialog Method
ShutdownClass Method
UpdateClass Method
Enumerations
Errors Enumeration
fiSerialize Class
Data Members
m_Stream Data Member
m_Token Data Member
m_Version Data Member
Constructors
fiSerialize Constructor
Destructors
~fiSerialize Destructor
Methods
Get Method
Put Method
Serialize
Serialize Method (bool &)
Serialize Method (f32 &)
Serialize Method (s16 &)
Serialize Method (s32 &)
Serialize Method (s8 &)
Serialize Method (u16 &)
Serialize Method (u32 &)
Serialize Method (u64 &)
Serialize Method (u8 &)
fiStream Class Component
Methods
AllowBlockingLoads Method
AreBlockingLoadsAllowed Method
Close Method
CloseOpenFiles Method
CloseShared Method
Create
Create Method (const char *)
Create Method (const char *, const fiDevice &)
DumpOpenFiles Method
FastGetCh Method
FastPutCh Method
fdopen Method
Flush Method
GetCh Method
GetCloseCallback Method
GetCreateCallback Method
GetLocalHandle Method
GetName Method
GetOpenCallback Method
Open
Open Method (const char *, bool)
Open Method (const char *, const fiDevice &, bool)
OutputAllFileAccess Method
PreLoad Method
PutCh Method
Read Method
ReadByte
ReadByte Method (char *, int)
ReadByte Method (unsigned char*, int)
ReadFloat Method
ReadInt
ReadInt Method (int *, int)
ReadInt Method (unsigned *, int)
ReadLong
ReadLong Method (s64 *, int)
ReadLong Method (u64 *, int)
ReadShort
ReadShort Method (short *, int)
ReadShort Method (unsigned short *, int)
ReadTChar Method
Seek Method
Seek64 Method
SetCloseCallback Method
SetCreateCallback Method
SetFaultInjectionPath Method
SetOpenCallback Method
Size Method
Size64 Method
Tell Method
Tell64 Method
TellStart Method
Write Method
WriteByte
WriteByte Method (const char *, int)
WriteByte Method (const unsigned char *, int)
WriteFloat Method
WriteInt
WriteInt Method (const int *, int)
WriteInt Method (const unsigned *, int)
WriteLong
WriteLong Method (const s64 *, int)
WriteLong Method (const u64 *, int)
WriteShort
WriteShort Method (const short *, int)
WriteShort Method (const unsigned short *, int)
WriteTChar Method
fiTokenizer Class
Constructors
fiTokenizer
fiTokenizer Constructor ()
fiTokenizer Constructor (const char *, fiStream *)
fiZipfile Class COMPONENT
Data Members
m_ArchiveBias Data Member
m_ArchiveSize Data Member
m_Device Data Member
m_Handle Data Member
m_Name Data Member
m_RelativeOffset Data Member
m_Root Data Member
Constructors
fiZipfile Constructor
Destructors
~fiZipfile Destructor
Methods
Close Method
CloseBulk Method
Create Method
FillData Method
FindEntry Method
FindFileBegin Method
FindFileEnd Method
FindFileNext Method
GetAttributes Method
GetDebugName Method
GetFileSize Method
GetFileTime Method
Init Method
MountAs Method
Open Method
OpenBulk Method
OpenInternal Method
Read Method
ReadBulk Method
ReadInternal Method
ReadInternalBulk Method
Seek Method
Seek64 Method
SetFileTime Method
Size Method
Size64 Method
Write Method
fiZipfileState Struct
Data Members
BufferSize Data Member
m_Buffer Data Member
m_CompOffset Data Member
m_DebugName Data Member
m_Entry Data Member
m_Offset Data Member
m_zStream Data Member
Constructors
fiZipfileState Constructor
Methods
IsCompressed Method
Reset Method
Header Class
Data Members
FILE_VERSION Data Member
m_DisplayName Data Member
m_Hash Data Member
m_Version Data Member
MAX_BYTE_SIZEOF_PAYLOAD Data Member
Constructors
Header Constructor
Methods
CalculateHash Method
Clear Method
Export Method
GetDisplayName Method
GetExpectedVersion Method
GetVersion Method
Import Method
Mount_t Struct
Data Members
Device Data Member
Path Data Member
PathLen Data Member
ReadOnly Data Member
Constructors
Mount_t Constructor
MsDosDate Struct
Methods
DECLARE_BITFIELD_3 Method
MsDosTime Struct
Methods
DECLARE_BITFIELD_3 Method
XenonProfile Class
Constructors
XenonProfile Constructor
Destructors
~XenonProfile Destructor
Methods
BeginContentVerify Method
BeginDelete Method
BeginEnumeration Method
BeginFreeSpaceCheck
BeginFreeSpaceCheck Method (const char *, u32)
BeginFreeSpaceCheck Method (eTypeOfSpaceCheck, const char *, u32)
BeginGetCreator Method
BeginGetFileSize Method
BeginIconSave Method
BeginLoad Method
BeginSave Method
BeginSelectDevice Method
CalculateDataSizeOnDisk Method
CheckContentVerify Method
CheckDelete Method
CheckEnumeration Method
CheckFreeSpaceCheck
CheckFreeSpaceCheck Method (eTypeOfSpaceCheck, int &, int &)
CheckFreeSpaceCheck Method (int &)
CheckGetCreator Method
CheckGetFileSize Method
CheckIconSave Method
CheckLoad Method
CheckSave Method
CheckSelectDevice Method
CompareTimestamps Method
EndContentVerify Method
EndDelete Method
EndEnumeration Method
EndFreeSpaceCheck
EndFreeSpaceCheck Method ()
EndFreeSpaceCheck Method (eTypeOfSpaceCheck)
EndGetCreator Method
EndGetFileSize Method
EndIconSave Method
EndLoad Method
EndSave Method
EndSelectDevice Method
FillDevice Method
GetCurrentDeviceData Method
GetDeviceData Method
GetError Method
GetLoadSize Method
GetSaveSize Method
GetSelectedDevice Method
GetState Method
GetTotalAvailableSpace Method
HasFileBeenAccessed Method
IsCurrentDeviceValid Method
IsDeviceValid Method
IsStorageDeviceChanged Method
IsStorageDeviceRemoved Method
SetSelectedDevice Method
SetSelectedDeviceToAny Method
SetStateToIdle Method
zipDirEntry Struct
Data Members
1 Data Member
Child Data Member
CompSize Data Member
FileTime Data Member
Hash Data Member
Name Data Member
Next Data Member
Offset Data Member
UncompSize Data Member
Constructors
zipDirEntry Constructor
Destructors
~zipDirEntry Destructor
Methods
Dump Method
Insert Method
IsCompressed Method
IsDir Method
CacheHeader Struct
DeviceMemoryState Struct
eInstallDeviceStatus Enumeration
EncoderState Struct
eTypeOfSaveProcess Enumeration
eTypeOfSpaceCheck Enumeration
fiFindData Struct
File Struct
fiPackHeader Struct
fiRemoteDirEntry Struct
fiSeekWhence Enumeration
node Struct
sInstallProgress Struct
Slot Struct
atou Function
CompileTimeAssertSize Function
fgetline Function
fgets Function
fiCompress Function
fiCompressUpperBound Function
fiDecompress Function
fiFtpServer Function
fiGetFramesSinceLastMessageBox Function
fiLaunchFtpServerThread Function
fiRemoteExec Function
fiRemoteGetEnv Function
fiRemoteResetFiles Function
fiRemoteServer Function
fiRemoteShowAssertMessageBox Function
fiRemoteShowMessageBox Function
fiRemoteTty Function
FlushCacheHeader Function
fprintf Function
fseek Function
GetDisplayName Function
GetSaveFilePath Function
MakeNewest Function
MakeOldest Function
NOSTRIP_PARAM Function (clearhddcache, "Force console disk cache to be cleared")
NOSTRIP_PARAM Function (xboxSecureNetworking, "If present use xbox secure networking ***RFS WON'T WORK***")
NOSTRIP_XPARAM Function
Quitf Function
ResetCache Function
StringLength Function
StreamCloseCallback Type
StreamCreateCallback Type
StreamOpenCallback Type
ASSET Variable
CACHE_BLOCK_COUNT Variable
CACHE_BLOCK_MASK Variable
CACHE_BLOCK_MAX Variable
CACHE_BLOCK_SHIFT Variable
CACHE_BLOCK_SIZE Variable
CACHE_FILE_BLOCK_COUNT Variable
CACHE_FILE_COUNT Variable
CACHE_FILE_HEADER_SIZE Variable
CACHE_FILE_MAGIC Variable
CACHE_FILE_SIZE Variable
CACHE_FILE_VERSION Variable
CACHE_PADDING Variable
CACHE_SUBFILE_COUNT Variable
CACHE_SUBFILE_MASK Variable
CACHE_SUBFILE_SHIFT Variable
CENTINANOSECONDS_PER_SECOND Variable
fiIsShowingMessageBox Variable
FileName Variable
FILETIME_2000 Variable
fiRemoteServerIsRunning Variable
g_AES Variable
g_enumeratedContent Variable
g_fiCaseSensitive Variable
g_IsExiting Variable
g_numContent Variable
g_SaveGameState Variable
gExitThread Variable
info_table Variable
m_State Variable
MAX_RPFS Variable
maxMem Variable
MaxPackfiles Variable
messageToken Variable
nameheap Variable
nameshift Variable
pgStreamingLog Variable
pgStreamingLogToken Variable
pIconImage Variable
RAGE_MAX_PATH Variable
s_bCalculateSizeOnDisk Variable
s_bCheckForUserBindErrors Variable
s_bCheckingForFreeSpace Variable
s_bFileMissing Variable
s_bHasCreator Variable
s_bIsCreator Variable
s_CacheBlockFiles Variable
s_CachedDevices Variable
s_CacheFile Variable
s_CachePath Variable
s_CacheWorkerThread Variable
s_Container Variable
s_Content Variable
s_ContentMax Variable
s_count Variable
s_Counts Variable
s_Data Variable
s_DataSize Variable
s_DefaultDevice Variable
s_DefaultDeviceReadOnly Variable
s_Device Variable
s_DeviceCount Variable
s_DeviceGrowBuffer Variable
s_DeviceLocal Variable
s_DeviceMemory Variable
s_DeviceUpdateDebug Variable
s_DirName Variable
s_DisplayName Variable
s_Done Variable
s_DummyProfiler Variable
s_EnumCount Variable
s_eSaveProcessToPerform Variable
s_FileExists Variable
s_FilenameBuf Variable
s_FileProgress Variable
s_fileSize Variable
s_FileSize Variable
s_filetime Variable
s_Handle Variable
s_hddFreeSizeKB Variable
s_Header Variable
s_Header_CritSec Variable
s_HoldoffDelta Variable
s_HoldoffTime Variable
s_IsCachePrimed Variable
s_IsValid Variable
s_LastError Variable
s_lastErrorCode Variable
s_LastThreadOwner Variable
s_Loads Variable
s_LocalHost Variable
s_location Variable
s_MaxNumberOfDirectories Variable
s_MemoryState Variable
s_ModifiedTimeHigh Variable
s_ModifiedTimeLow Variable
s_Mounts Variable
s_netError Variable
s_netErrorCount Variable
s_NumInProgressBlocks Variable
s_numRpfs Variable
s_NumValidBlocks Variable
s_pDeviceUpdate Variable
s_PendingState Variable
s_Profiles Variable
s_Reader Variable
s_ResidentMap Variable
s_SaveGameSizes Variable
s_Saves Variable
s_Selects Variable
s_setBuf Variable
s_setList Variable
s_ShutdownCacheWorkerThread Variable
s_SizeOfIconAndSystemFiles Variable
s_SizeOfSystemOverheads Variable
s_SpaceRequired Variable
s_SpaceRequiredToSaveThisFile Variable
s_States Variable
s_TcpIpInstance Variable
s_TcpIpLastError Variable
s_ThreadId Variable
s_TitleIdForSavesFolder Variable
s_TitleString Variable
s_TotalHDDFreeSize Variable
s_UserBindErrorMsg Variable
s_ZipfileOpen Variable
s_ZipOpen Variable
s_ZipStates Variable
SAVEGAME Variable
secureFileId Variable
SizeOfIconImage Variable
sm_ExtraSpaceRequired Variable
sm_FallbackToDefaultDevice Variable
sm_IsLoadedDataValid Variable
sm_MatchLongestPath Variable
sm_MatchNewest Variable
tls_Uncached Variable
XCONTENT_DATA_SIZE Variable
XEX_TITLE_ID Variable
__ENABLE_RFS Macro
ASYNC_CACHE_COPIES Macro
CACHE_BLOCK_HANDLE Macro
CACHEDEV Macro
CORRUPT_FILE_CODE Macro
COULD_NOT_MAP_DEVICE_CODE Macro
dcDebugf1 Macro
dcDebugf2 Macro
dcDebugf3 Macro
dcDisplayf Macro
dcErrorf Macro
dcWarningf Macro
DECLARE_STREAM_BUFFERS Macro
DIALOG_MODE Macro
DVD_DEVICE_NAME Macro
ENABLE_GAMEDATA_FOR_DISKCACHE Macro
FILE_ATTRIBUTE_ARCHIVE Macro
FILE_ATTRIBUTE_COMPRESSED Macro
FILE_ATTRIBUTE_DIRECTORY Macro
FILE_ATTRIBUTE_HIDDEN Macro
FILE_ATTRIBUTE_INVALID Macro
FILE_ATTRIBUTE_NORMAL Macro
FILE_ATTRIBUTE_NOT_CONTENT_INDEXED Macro
FILE_ATTRIBUTE_OFFLINE Macro
FILE_ATTRIBUTE_READONLY Macro
FILE_ATTRIBUTE_REPARSE_POINT Macro
FILE_ATTRIBUTE_SPARSE_FILE Macro
FILE_ATTRIBUTE_SYSTEM Macro
FILE_ATTRIBUTE_TEMPORARY Macro
IDABORT Macro
IDCANCEL Macro
IDCONTINUE Macro
IDCUSTOM1 Macro
IDCUSTOM2 Macro
IDCUSTOM3 Macro
IDCUSTOM4 Macro
IDIGNORE Macro
IDNO Macro
IDOK Macro
IDRETRY Macro
IDTRYAGAIN Macro
IDYES Macro
INSTALL_SLICE_NUM Macro
INSTALL_SLICE_SIZE Macro
MAX_CHARS_IN_TITLE_ID_FOR_SAVES_FOLDER Macro
MAX_DEVICE_NAME_LENGTH Macro
MAX_PARTITION_SIZE Macro
MAX_XCONTENT_HANDLES Macro
MB_ABORTRETRYIGNORE Macro
MB_APPLMODAL Macro
MB_CANCELTRYCONTINUE Macro
MB_DEFAULT_DESKTOP_ONLY Macro
MB_DEFBUTTON1 Macro
MB_DEFBUTTON2 Macro
MB_DEFBUTTON3 Macro
MB_DEFBUTTON4 Macro
MB_HELP Macro
MB_ICONASTERISK Macro
MB_ICONERROR Macro
MB_ICONHAND Macro
MB_ICONINFORMATION Macro
MB_ICONQUESTION Macro
MB_NOFOCUS Macro
MB_OK Macro
MB_OKCANCEL Macro
MB_RETRYCANCEL Macro
MB_RIGHT Macro
MB_SETFOREGROUND Macro
MB_SYSTEMMODAL Macro
MB_TASKMODAL Macro
MB_TOPMOST Macro
MB_YESNO Macro
MB_YESNOCANCEL Macro
MULTIPLE_CACHE_FILES Macro
NO_FILES_EXIST_CODE Macro
PS3_FILE_HANDLE_HACK Macro
READ_PROGRESS_WATCHDOG Macro
READ_PROGRESS_WATCHDOG_ERROR_LIMIT_SECONDS Macro
REPLAY_SAVE_FILENAME Macro
s_Files Macro
s_Magic Macro
s_Newest Macro
s_Oldest Macro
s_Slots Macro
SAVEGAME_STACK_SIZE Macro
SAVEGAME_STACK_SIZE_FOR_ENUMERATION Macro
sgDebug1 Macro
sgDebug2 Macro
sgDebug3 Macro
sgError Macro
sgWarning Macro
STATIC_STATE_BUFFERS Macro
STREAM_STORE_NAME Macro
THE_DEVICE_IS_NOT_READY_CODE Macro
USER_CANCELLED_DEVICE_SELECTION_CODE Macro
Functions
AssertMessageBox Function
InitWinSock Function
safe_recv Function
safe_send Function
ShutdownWinSock Function
Structs, Records, Enums
FFData Struct
Types
fiHandle Type
SOCKET Type
socklen_t Type
Variables
Variable
__libnet_memory Variable
assetDebug Variable
BINARY Variable
c_InitialWidth Variable
c_Magic_1 Variable
c_Magic_2 Variable
c_WidthStep Variable
cellGameDataPath Variable
CENTINANOSECONDS_PER_SECOND Variable
fiBaseTokenizer::CommentChar Variable
fiDevice::sm_InjectReadError Variable
FILE_VERSION Variable
FILETIME_BIAS Variable
fiStream::m_bOutputAllFileAccess Variable
fiStream::sm_AllowBlockingLoads Variable
fiStream::sm_CloseCallback Variable
fiStream::sm_CreateCallback Variable
fiStream::sm_FaultInjectionPath Variable
fiStream::sm_OpenCallback Variable
fiStream::sm_UnavailableString Variable
hEvent Variable
PREFIX_SIZE Variable
s_AllocStream Variable
s_AssetCritSec Variable
s_LSNRange Variable
s_RefCount Variable
sMaxIndex Variable
streamDebug Variable
Macros
__DEVPROF Macro
__GAMESPY_MATCHMAKING Macro
__GAMESPY_NEEDS_REPLACEMENT Macro
__GAMESPYPC Macro
__GFWL Macro
__LAUNCHER_CHECK Macro
__LIVE Macro
__RGSC_DLL Macro
__STEAM_BUILD Macro
__STEAM_COMMERCE_BUILD Macro
__STEAM_KOREAN_BUILD Macro
__USE_TUS Macro
_WINSOCKAPI_ Macro
CHECK Macro
CheckForFatalError Macro
DBG Macro
ENABLE_NO_BUFFERING Macro
ERRORF Macro
FieldAssign Macro
fiHandleInvalid Macro
FILLDEVICE_MAX_FILE_SIZE Macro
GAMESPYPC_ONLY Macro
HANDLEFMT Macro
INC_DEVICE_XCONTENT_H_ Macro
INVALID_DEVICE Macro
IPV6_SOCKETS Macro
LIVE_ONLY Macro
LOCAL Macro
LOG_EVERYTHING Macro
LOG1 Macro
LOG2 Macro
MAX_DISPLAY_NAME Macro
OTHER_SEPARATOR Macro
PC_FILE_SIZE Macro
RAGE_CELL_SAVEGAME_VERSION Macro
RSG_DURANGO Macro
SCE_STM_RWU Macro
SEPARATOR Macro
SEPARATOR_STRING Macro
STEAMBUILD_ONLY Macro
STRICT Macro
SUPPORT_OTHER_PLATFORM Macro
SUPPORT_SDAT Macro
TCPIP Macro
USE_CACHED_DIRECTORY_INFO Macro
USE_XCOMPRESS Macro
XCONTENT_MAX_NAME_LENGTH Macro


Index

Index
| & | _ | ~ | - | 1 | A | B | C | D | E | F | G | H | I | L | M | N | O | P | R | S | T | U | W | X | Z
variable
&
&
_
__DEVPROF
__DEVPROF macro
__GAMESPY_MATCHMAKING
__GAMESPY_MATCHMAKING macro
__GAMESPY_NEEDS_REPLACEMENT
__GAMESPY_NEEDS_REPLACEMENT macro
__GAMESPYPC
__GAMESPYPC macro
__GFWL
__GFWL macro
__LAUNCHER_CHECK
__LAUNCHER_CHECK macro
__libnet_memory
__libnet_memory variable
__LIVE
__LIVE macro
__RGSC_DLL
__RGSC_DLL macro
__STEAM_BUILD
__STEAM_BUILD macro
__STEAM_COMMERCE_BUILD
__STEAM_COMMERCE_BUILD macro
__STEAM_KOREAN_BUILD
__STEAM_KOREAN_BUILD macro
__USE_TUS
__USE_TUS macro
_WINSOCKAPI_
_WINSOCKAPI_ macro
~
~fiAssetManager
~fiAsynchStream
~fiBaseTokenizer
~fiCompressionData
~fiDevice
~fiDeviceInstaller
~fiDeviceProfiler
~fiDeviceRelative
~fiDeviceTcpIp
~fiDeviceXContent
~fiPackfile
~fiRpf7Builder
~fiRpf7Entry
~fiSafeStream
~fiSerialize
~fiZipfile
~XenonProfile
~zipDirEntry
-
->
1
1
A
AddData
AddExtension
AddFile
AllowBlockingLoads
ArchiveMask
ArchiveShift
AreBlockingLoadsAllowed
AssertMessageBox
AssertMessageBox function
asset
assetDebug
assetDebug variable
avail_in
B
BaseName
BeginContentVerify
BeginDelete
BeginDeleteFromList
BeginEnumeration
BeginExtraSpaceCheck
BeginFreeSpaceCheck
BeginGetCreator
BeginGetFileModifiedTime
BeginGetFileSize
BeginIconSave
BeginLoad
BeginReadNamesAndSizesOfAllSaveGames
BeginSave
BeginSelectDevice
BINARY
BINARY variable
BufferSize
BuildHeader
C
c_InitialWidth
c_InitialWidth variable
c_Magic_1
c_Magic_1 variable
c_Magic_2
c_Magic_2 variable
c_WidthStep
c_WidthStep variable
CalculateDataSizeOnDisk
CalculateHash
CalculateSizeOfSaveGameFile
cellGameDataPath
cellGameDataPath variable
CENTINANOSECONDS_PER_SECOND
CENTINANOSECONDS_PER_SECOND variable
CHECK
CHECK macro
CheckContentVerify
CheckDelete
CheckDeleteFromList
CheckEnumeration
CheckExtraSpaceCheck
CheckForFatalError
CheckForFatalError macro
CheckFreeSpaceCheck
CheckGetCreator
CheckGetFileModifiedTime
CheckGetFileSize
CheckIconSave
CheckIToken
CheckLoad
CheckReadNamesAndSizesOfAllSaveGames
CheckSave
CheckSelectDevice
CheckToken
Child
class fiCachedDevice
class fiDiskCache
Clear
ClearAttributes
ClearRelativeOffset
Close
CloseBulk
CloseOpenFiles
CloseShared
Command Line Options
CommentChar
CompareTimestamps
Components
Compress
CompSize
Connect
ConvertFileTimeToSystemTime
CopyContentInfoFile
CopyDirectory
CopySingleFile
Create
CreateBulk
CreateLeadingPath
CreateNewInstance
D
DataSize
DBG
DBG macro
DECLARE_BITFIELD_3
DECLARE_BITFIELD_4
Decompress
DefaultGetDevice
Delete
DeleteDirectory
Device
DoFileSizesMatch
DoTimestampsMatch
Dump
DumpOpenFiles
E
ENABLE_NO_BUFFERING
ENABLE_NO_BUFFERING macro
EndBlock
EndContentVerify
EndDelete
EndDeleteFromList
EndEnumeration
EndExtraSpaceCheck
EndFreeSpaceCheck
EndGetCreator
EndGetFileModifiedTime
EndGetFileSize
EndIconSave
EndLine
EndLoad
EndOfFile
EndReadNamesAndSizesOfAllSaveGames
EndSave
EndSelectDevice
EntryMask
EnumFiles
ERRORF
ERRORF macro
Exists
Export
ExtractFileToMemory
F
FastGetCh
FastPutCh
fdopen
FFData
FFData struct
fiArchive
fiArchive class
&
&
&
&
&
&
&
&
&
&
&
&
fiArchive
GetVersion
IsLoading
IsStoring
fiArchive::& operator
fiArchive::fiArchive constructor
fiArchive::GetVersion method
fiArchive::IsLoading method
fiArchive::IsStoring method
fiAsciiTokenizer
fiAsciiTokenizer class
EndBlock
EndLine
fiAsciiTokenizer
GetByte
GetDelimiter
GetFloat
GetHexU32
GetInt
GetShort
GetVector
Indent
IsBinary
m_nNumTabs
MatchFloat
MatchIFloat
MatchIInt
MatchInt
MatchIVector
MatchIVector
MatchIVector
MatchIVector
MatchIVector
MatchVector
MatchVector
MatchVector
MatchVector
MatchVector
Put
Put
Put
Put
Put
Put
Put
Put
Put
Put
Put
Put
PutByte
PutDelimiter
PutShort
StartBlock
StartLine
WriteTabs
fiAsciiTokenizer::EndBlock method
fiAsciiTokenizer::EndLine method
fiAsciiTokenizer::fiAsciiTokenizer constructor
fiAsciiTokenizer::GetByte method
fiAsciiTokenizer::GetDelimiter method
fiAsciiTokenizer::GetFloat method
fiAsciiTokenizer::GetHexU32 method
fiAsciiTokenizer::GetInt method
fiAsciiTokenizer::GetShort method
fiAsciiTokenizer::GetVector method
fiAsciiTokenizer::Indent method
fiAsciiTokenizer::IsBinary method
fiAsciiTokenizer::m_nNumTabs data member
fiAsciiTokenizer::MatchFloat method
fiAsciiTokenizer::MatchIFloat method
fiAsciiTokenizer::MatchIInt method
fiAsciiTokenizer::MatchInt method
fiAsciiTokenizer::MatchIVector method
fiAsciiTokenizer::MatchVector method
fiAsciiTokenizer::Put method
fiAsciiTokenizer::PutByte method
fiAsciiTokenizer::PutDelimiter method
fiAsciiTokenizer::PutShort method
fiAsciiTokenizer::StartBlock method
fiAsciiTokenizer::StartLine method
fiAsciiTokenizer::WriteTabs method
fiAssetManager
fiAssetManager class
~fiAssetManager
AddExtension
BaseName
ClearAttributes
Create
CreateLeadingPath
EnumFiles
Exists
fiAssetManager
FileName
FindExtensionInPath
FindPath
FullPath
FullReadPath
FullWritePath
GetAttributes
GetPath
GetPathCount
GetStackedPath
InsertPathElement
IsAbsolutePath
MakeFolderRelative
MakeRelative
MAX_FILENAME_LENGTH
Open
PopFolder
PushFolder
RemoveExtensionFromPath
RemoveNameFromPath
SetAttributes
SetPath
fiAssetManager::~fiAssetManager destructor
fiAssetManager::AddExtension method
fiAssetManager::BaseName method
fiAssetManager::ClearAttributes method
fiAssetManager::Create method
fiAssetManager::CreateLeadingPath method
fiAssetManager::EnumFiles method
fiAssetManager::Exists method
fiAssetManager::fiAssetManager constructor
fiAssetManager::FileName method
fiAssetManager::FindExtensionInPath method
fiAssetManager::FindPath method
fiAssetManager::FullPath method
fiAssetManager::FullReadPath method
fiAssetManager::FullWritePath method
fiAssetManager::GetAttributes method
fiAssetManager::GetPath method
fiAssetManager::GetPathCount method
fiAssetManager::GetStackedPath method
fiAssetManager::InsertPathElement method
fiAssetManager::IsAbsolutePath method
fiAssetManager::MakeFolderRelative method
fiAssetManager::MakeRelative method
fiAssetManager::MAX_FILENAME_LENGTH data member
fiAssetManager::Open method
fiAssetManager::PopFolder method
fiAssetManager::PushFolder method
fiAssetManager::RemoveExtensionFromPath method
fiAssetManager::RemoveNameFromPath method
fiAssetManager::SetAttributes method
fiAssetManager::SetPath method
fiAsynchStream
fiAsynchStream class
~fiAsynchStream
fiAsynchStream
GetMemoryFileName
GetSize
Init
Init
Poll
fiAsynchStream::~fiAsynchStream destructor
fiAsynchStream::fiAsynchStream constructor
fiAsynchStream::GetMemoryFileName method
fiAsynchStream::GetSize method
fiAsynchStream::Init method
fiAsynchStream::Poll method
fiBaseTokenizer class
~fiBaseTokenizer
CheckIToken
CheckToken
CommentChar
EndBlock
EndLine
EndOfFile
filename
GetBlock
GetByte
GetDelimiter
GetFloat
GetInt
GetLine
GetName
GetNextCh
GetShort
GetStream
GetStreamPosition
GetToken
GetTokenCh
GetTokenToChar
GetTokenToChars
GetVector
GetWriteState
IgnoreToken
Indent
Init
IsBinary
iswhitespace
line
m_WriteState
MatchFloat
MatchIFloat
MatchIInt
MatchInt
MatchIToken
MatchIVector
MatchIVector
MatchIVector
MatchIVector
MatchIVector
MatchToken
MatchVector
MatchVector
MatchVector
MatchVector
MatchVector
nextch
Pop
Put
Put
Put
Put
Put
Put
Put
Put
PutByte
PutDelimiter
PutShort
PutStr
PutStrLine
Reset
S
SetNextCh
SetStreamPosition
SetTerminators
SetWriteState
SkipComment
SkipToEndOfLine
StartBlock
StartLine
fiBaseTokenizer::~fiBaseTokenizer destructor
fiBaseTokenizer::CheckIToken method
fiBaseTokenizer::CheckToken method
fiBaseTokenizer::CommentChar
fiBaseTokenizer::CommentChar data member
fiBaseTokenizer::CommentChar variable
fiBaseTokenizer::EndBlock method
fiBaseTokenizer::EndLine method
fiBaseTokenizer::EndOfFile method
fiBaseTokenizer::filename data member
fiBaseTokenizer::GetBlock method
fiBaseTokenizer::GetByte method
fiBaseTokenizer::GetDelimiter method
fiBaseTokenizer::GetFloat method
fiBaseTokenizer::GetInt method
fiBaseTokenizer::GetLine method
fiBaseTokenizer::GetName method
fiBaseTokenizer::GetNextCh method
fiBaseTokenizer::GetShort method
fiBaseTokenizer::GetStream method
fiBaseTokenizer::GetStreamPosition method
fiBaseTokenizer::GetToken method
fiBaseTokenizer::GetTokenCh method
fiBaseTokenizer::GetTokenToChar method
fiBaseTokenizer::GetTokenToChars method
fiBaseTokenizer::GetVector method
fiBaseTokenizer::GetWriteState method
fiBaseTokenizer::IgnoreToken method
fiBaseTokenizer::Indent method
fiBaseTokenizer::Init method
fiBaseTokenizer::IsBinary method
fiBaseTokenizer::iswhitespace method
fiBaseTokenizer::line data member
fiBaseTokenizer::m_WriteState data member
fiBaseTokenizer::MatchFloat method
fiBaseTokenizer::MatchIFloat method
fiBaseTokenizer::MatchIInt method
fiBaseTokenizer::MatchInt method
fiBaseTokenizer::MatchIToken method
fiBaseTokenizer::MatchIVector method
fiBaseTokenizer::MatchToken method
fiBaseTokenizer::MatchVector method
fiBaseTokenizer::nextch data member
fiBaseTokenizer::Pop method
fiBaseTokenizer::Put method
fiBaseTokenizer::PutByte method
fiBaseTokenizer::PutDelimiter method
fiBaseTokenizer::PutShort method
fiBaseTokenizer::PutStr method
fiBaseTokenizer::PutStrLine method
fiBaseTokenizer::Reset method
fiBaseTokenizer::S data member
fiBaseTokenizer::SetNextCh method
fiBaseTokenizer::SetStreamPosition method
fiBaseTokenizer::SetTerminators method
fiBaseTokenizer::SetWriteState method
fiBaseTokenizer::SkipComment method
fiBaseTokenizer::SkipToEndOfLine method
fiBaseTokenizer::StartBlock method
fiBaseTokenizer::StartLine method
fiBinTokenizer class
GetByte
GetDelimiter
GetFloat
GetInt
GetShort
GetVector
IsBinary
MatchFloat
MatchIFloat
MatchIInt
MatchInt
MatchIVector
MatchIVector
MatchIVector
MatchIVector
MatchIVector
MatchVector
MatchVector
MatchVector
MatchVector
MatchVector
Put
Put
Put
Put
Put
Put
PutByte
PutDelimiter
PutShort
fiBinTokenizer::GetByte method
fiBinTokenizer::GetDelimiter method
fiBinTokenizer::GetFloat method
fiBinTokenizer::GetInt method
fiBinTokenizer::GetShort method
fiBinTokenizer::GetVector method
fiBinTokenizer::IsBinary method
fiBinTokenizer::MatchFloat method
fiBinTokenizer::MatchIFloat method
fiBinTokenizer::MatchIInt method
fiBinTokenizer::MatchInt method
fiBinTokenizer::MatchIVector method
fiBinTokenizer::MatchVector method
fiBinTokenizer::Put method
fiBinTokenizer::PutByte method
fiBinTokenizer::PutDelimiter method
fiBinTokenizer::PutShort method
fiCachedDevice class
class fiDiskCache
Close
CloseBulk
Create
GetBlockPhysicalSortKey
GetDebugName
GetFileSize
GetFileTime
Open
OpenBulk
Prefetch
Read
ReadBulk
Seek
Seek64
SetFileTime
Write
fiCachedDevice::Close method
fiCachedDevice::CloseBulk method
fiCachedDevice::Create method
fiCachedDevice::GetBlockPhysicalSortKey method
fiCachedDevice::GetDebugName method
fiCachedDevice::GetFileSize method
fiCachedDevice::GetFileTime method
fiCachedDevice::Open method
fiCachedDevice::OpenBulk method
fiCachedDevice::Prefetch method
fiCachedDevice::Read method
fiCachedDevice::ReadBulk method
fiCachedDevice::Seek method
fiCachedDevice::Seek64 method
fiCachedDevice::SetFileTime method
fiCachedDevice::Write method
fiCachePartition class
GetCachePrefix
Init
IsAvailable
Reset
Shutdown
fiCachePartition::GetCachePrefix method
fiCachePartition::Init method
fiCachePartition::IsAvailable method
fiCachePartition::Reset method
fiCachePartition::Shutdown method
fiCollection
fiCollection class
ArchiveMask
ArchiveShift
EntryMask
fiCollection
GetBasePhysicalSortKey
GetCollection
GetCollectionIndex
GetEntryFullName
GetEntryIndex
GetEntryInfo
GetEntryName
GetEntryPhysicalSortKey
IsPackfile
IsStreaming
m_isStreaming
MakeHandle
OpenBulkFromHandle
Prefetch
SetStreaming
Shutdown
sm_Collections
fiCollection::ArchiveMask data member
fiCollection::ArchiveShift data member
fiCollection::EntryMask data member
fiCollection::fiCollection constructor
fiCollection::GetBasePhysicalSortKey method
fiCollection::GetCollection method
fiCollection::GetCollectionIndex method
fiCollection::GetEntryFullName method
fiCollection::GetEntryIndex method
fiCollection::GetEntryInfo method
fiCollection::GetEntryName method
fiCollection::GetEntryPhysicalSortKey method
fiCollection::IsPackfile method
fiCollection::IsStreaming method
fiCollection::m_isStreaming data member
fiCollection::MakeHandle method
fiCollection::OpenBulkFromHandle method
fiCollection::Prefetch method
fiCollection::SetStreaming method
fiCollection::Shutdown method
fiCollection::sm_Collections data member
fiCompressionData
fiCompressionData class
~fiCompressionData
BuildHeader
Compress
CreateNewInstance
Decompress
fiCompressionData
GetCompressUpperBound
GetHeaderPrefix
GetHeaderSize
GetStaticHeaderPrefix
ParseHeader
fiCompressionData::~fiCompressionData destructor
fiCompressionData::BuildHeader method
fiCompressionData::Compress method
fiCompressionData::CreateNewInstance method
fiCompressionData::Decompress method
fiCompressionData::fiCompressionData constructor
fiCompressionData::GetCompressUpperBound method
fiCompressionData::GetHeaderPrefix method
fiCompressionData::GetHeaderSize method
fiCompressionData::GetStaticHeaderPrefix method
fiCompressionData::ParseHeader method
fiDevice
fiDevice class
~fiDevice
Close
CloseBulk
ConvertFileTimeToSystemTime
CopyDirectory
CopySingleFile
Create
CreateBulk
DefaultGetDevice
Delete
DeleteDirectory
fiDevice
FindFile
FindFileBegin
FindFileEnd
FindFileNext
FixRelativeName
Flush
GetAttributes
GetBulkOffset
GetDebugName
GetDevice
GetFileSize
GetFileTime
GetLocalSystemTime
GetLowLevelDevice
GetPackfileIndex
GetPhysicalSortKey
GetResourceInfo
GetRpfDevice
HARDDRIVE_LSN
InitClass
IsCloud
IsOutOfDate
IsRpf
LAYER1_LSN
Lock
MakeDirectory
MakeGrowBufferFileName
MakeMemoryFileName
Mount
Normalize
Open
OpenBulk
OpenBulkDrm
PrefetchDir
Read
ReadBulk
Remount
Rename
SafeRead
SafeWrite
Seek
Seek64
SetAttributes
SetDeviceProfiler
SetEndOfFile
SetFileTime
SetFindNewest
SetMaxMounts
Size
Size64
sm_DeviceProfiler
sm_FatalReadError
sm_InjectReadError
Unlock
UnmakeDirectory
Unmount
Unmount
Write
WriteBulk
fiDevice::~fiDevice destructor
fiDevice::Close method
fiDevice::CloseBulk method
fiDevice::ConvertFileTimeToSystemTime method
fiDevice::CopyDirectory method
fiDevice::CopySingleFile method
fiDevice::Create method
fiDevice::CreateBulk method
fiDevice::DefaultGetDevice method
fiDevice::Delete method
fiDevice::DeleteDirectory method
fiDevice::fiDevice constructor
fiDevice::FindFile method
fiDevice::FindFileBegin method
fiDevice::FindFileEnd method
fiDevice::FindFileNext method
fiDevice::FixRelativeName method
fiDevice::Flush method
fiDevice::GetAttributes method
fiDevice::GetBulkOffset method
fiDevice::GetDebugName method
fiDevice::GetDevice method
fiDevice::GetFileSize method
fiDevice::GetFileTime method
fiDevice::GetLocalSystemTime method
fiDevice::GetLowLevelDevice method
fiDevice::GetPackfileIndex method
fiDevice::GetPhysicalSortKey method
fiDevice::GetResourceInfo method
fiDevice::GetRpfDevice method
fiDevice::HARDDRIVE_LSN data member
fiDevice::InitClass method
fiDevice::IsCloud method
fiDevice::IsOutOfDate method
fiDevice::IsRpf method
fiDevice::LAYER1_LSN data member
fiDevice::Lock method
fiDevice::MakeDirectory method
fiDevice::MakeGrowBufferFileName method
fiDevice::MakeMemoryFileName method
fiDevice::Mount method
fiDevice::Normalize method
fiDevice::Open method
fiDevice::OpenBulk method
fiDevice::OpenBulkDrm method
fiDevice::PrefetchDir method
fiDevice::Read method
fiDevice::ReadBulk method
fiDevice::Remount method
fiDevice::Rename method
fiDevice::SafeRead method
fiDevice::SafeWrite method
fiDevice::Seek method
fiDevice::Seek64 method
fiDevice::SetAttributes method
fiDevice::SetDeviceProfiler method
fiDevice::SetEndOfFile method
fiDevice::SetFileTime method
fiDevice::SetFindNewest method
fiDevice::SetMaxMounts method
fiDevice::Size method
fiDevice::Size64 method
fiDevice::sm_DeviceProfiler data member
fiDevice::sm_FatalReadError data member
fiDevice::sm_InjectReadError
fiDevice::sm_InjectReadError data member
fiDevice::sm_InjectReadError variable
fiDevice::Unlock method
fiDevice::UnmakeDirectory method
fiDevice::Unmount method
fiDevice::Write method
fiDevice::WriteBulk method
fiDeviceCount class
Close
Create
GetDebugName
GetFileTime
GetInstance
Open
Read
Seek
Seek64
SetFileTime
Size
Size64
Write
fiDeviceCount::Close method
fiDeviceCount::Create method
fiDeviceCount::GetDebugName method
fiDeviceCount::GetFileTime method
fiDeviceCount::GetInstance method
fiDeviceCount::Open method
fiDeviceCount::Read method
fiDeviceCount::Seek method
fiDeviceCount::Seek64 method
fiDeviceCount::SetFileTime method
fiDeviceCount::Size method
fiDeviceCount::Size64 method
fiDeviceCount::Write method
fiDeviceGrowBuffer class
Close
CloseBulk
Create
GetAttributes
GetDebugName
GetFileSize
GetFileTime
GetInstance
Open
OpenBulk
Read
ReadBulk
SafeRead
SafeWrite
Seek
Seek64
SetFileTime
Write
fiDeviceGrowBuffer::Close method
fiDeviceGrowBuffer::CloseBulk method
fiDeviceGrowBuffer::Create method
fiDeviceGrowBuffer::GetAttributes method
fiDeviceGrowBuffer::GetDebugName method
fiDeviceGrowBuffer::GetFileSize method
fiDeviceGrowBuffer::GetFileTime method
fiDeviceGrowBuffer::GetInstance method
fiDeviceGrowBuffer::Open method
fiDeviceGrowBuffer::OpenBulk method
fiDeviceGrowBuffer::Read method
fiDeviceGrowBuffer::ReadBulk method
fiDeviceGrowBuffer::SafeRead method
fiDeviceGrowBuffer::SafeWrite method
fiDeviceGrowBuffer::Seek method
fiDeviceGrowBuffer::Seek64 method
fiDeviceGrowBuffer::SetFileTime method
fiDeviceGrowBuffer::Write method
fiDeviceInstaller
fiDeviceInstaller class
~fiDeviceInstaller
Close
CloseBulk
CopyContentInfoFile
Create
Delete
DoFileSizesMatch
DoTimestampsMatch
fiDeviceInstaller
FindFileBegin
FindFileEnd
FindFileNext
FinishInstall
FixName
FlagInstalledRpfs
GetAttributes
GetBulkOffset
GetDebugName
GetFileSize
GetFileTime
GetInstallName
GetInstallProgress
GetInstallStatus
GetIsBootedFromHdd
GetPackFileSize
GetPartitionName
GetPhysicalSortKey
GetResourceInfo
GetRpfDevice
Init
InitInstall
InitPartitionDevice
InstallerThread
InstallProgress
IsPartitionPath
IsRpf
IsTargetDeviceValid
MakeDirectory
MountAs
Open
OpenBulk
PauseDiscRead
Read
ReadBulk
ReadInstallFile
RegisterFileDoneCallback
Rename
ResumeDiscRead
ScheduleFile
Seek
Seek64
SetAsync
SetAttributes
SetEndOfFile
SetFileTime
SetIsBootedFromHdd
SetKeepaliveCallback
StartInstall
StorePackageTimestamp
StripPath
UnmakeDirectory
Write
WriteInstallFile
fiDeviceInstaller::~fiDeviceInstaller destructor
fiDeviceInstaller::Close method
fiDeviceInstaller::CloseBulk method
fiDeviceInstaller::CopyContentInfoFile method
fiDeviceInstaller::Create method
fiDeviceInstaller::Delete method
fiDeviceInstaller::DoFileSizesMatch method
fiDeviceInstaller::DoTimestampsMatch method
fiDeviceInstaller::fiDeviceInstaller constructor
fiDeviceInstaller::FindFileBegin method
fiDeviceInstaller::FindFileEnd method
fiDeviceInstaller::FindFileNext method
fiDeviceInstaller::FinishInstall method
fiDeviceInstaller::FixName method
fiDeviceInstaller::FlagInstalledRpfs method
fiDeviceInstaller::GetAttributes method
fiDeviceInstaller::GetBulkOffset method
fiDeviceInstaller::GetDebugName method
fiDeviceInstaller::GetFileSize method
fiDeviceInstaller::GetFileTime method
fiDeviceInstaller::GetInstallName method
fiDeviceInstaller::GetInstallProgress method
fiDeviceInstaller::GetInstallStatus method
fiDeviceInstaller::GetIsBootedFromHdd method
fiDeviceInstaller::GetPackFileSize method
fiDeviceInstaller::GetPartitionName method
fiDeviceInstaller::GetPhysicalSortKey method
fiDeviceInstaller::GetResourceInfo method
fiDeviceInstaller::GetRpfDevice method
fiDeviceInstaller::Init method
fiDeviceInstaller::InitInstall method
fiDeviceInstaller::InitPartitionDevice method
fiDeviceInstaller::InstallerThread method
fiDeviceInstaller::InstallProgress method
fiDeviceInstaller::IsPartitionPath method
fiDeviceInstaller::IsRpf method
fiDeviceInstaller::IsTargetDeviceValid method
fiDeviceInstaller::MakeDirectory method
fiDeviceInstaller::MountAs method
fiDeviceInstaller::Open method
fiDeviceInstaller::OpenBulk method
fiDeviceInstaller::PauseDiscRead method
fiDeviceInstaller::Read method
fiDeviceInstaller::ReadBulk method
fiDeviceInstaller::ReadInstallFile method
fiDeviceInstaller::RegisterFileDoneCallback method
fiDeviceInstaller::Rename method
fiDeviceInstaller::ResumeDiscRead method
fiDeviceInstaller::ScheduleFile method
fiDeviceInstaller::Seek method
fiDeviceInstaller::Seek64 method
fiDeviceInstaller::SetAsync method
fiDeviceInstaller::SetAttributes method
fiDeviceInstaller::SetEndOfFile method
fiDeviceInstaller::SetFileTime method
fiDeviceInstaller::SetIsBootedFromHdd method
fiDeviceInstaller::SetKeepaliveCallback method
fiDeviceInstaller::StartInstall method
fiDeviceInstaller::StorePackageTimestamp method
fiDeviceInstaller::StripPath method
fiDeviceInstaller::UnmakeDirectory method
fiDeviceInstaller::Write method
fiDeviceInstaller::WriteInstallFile method
fiDeviceLocal class
Close
CloseBulk
Create
CreateBulk
Delete
FindFileBegin
FindFileEnd
FindFileNext
FixName
GetAttributes
GetDebugName
GetFileSize
GetFileTime
GetInstance
GetPhysicalSortKey
MakeDirectory
OnDiscSwap
Open
OpenBulk
Read
ReadBulk
Rename
Seek
Seek64
SetAttributes
SetEndOfFile
SetFileTime
UnmakeDirectory
Write
WriteBulk
fiDeviceLocal::Close method
fiDeviceLocal::CloseBulk method
fiDeviceLocal::Create method
fiDeviceLocal::CreateBulk method
fiDeviceLocal::Delete method
fiDeviceLocal::FindFileBegin method
fiDeviceLocal::FindFileEnd method
fiDeviceLocal::FindFileNext method
fiDeviceLocal::FixName method
fiDeviceLocal::GetAttributes method
fiDeviceLocal::GetDebugName method
fiDeviceLocal::GetFileSize method
fiDeviceLocal::GetFileTime method
fiDeviceLocal::GetInstance method
fiDeviceLocal::GetPhysicalSortKey method
fiDeviceLocal::MakeDirectory method
fiDeviceLocal::OnDiscSwap method
fiDeviceLocal::Open method
fiDeviceLocal::OpenBulk method
fiDeviceLocal::Read method
fiDeviceLocal::ReadBulk method
fiDeviceLocal::Rename method
fiDeviceLocal::Seek method
fiDeviceLocal::Seek64 method
fiDeviceLocal::SetAttributes method
fiDeviceLocal::SetEndOfFile method
fiDeviceLocal::SetFileTime method
fiDeviceLocal::UnmakeDirectory method
fiDeviceLocal::Write method
fiDeviceLocal::WriteBulk method
fiDeviceLocalDrm class
OpenBulkDrm
fiDeviceLocalDrm::OpenBulkDrm method
fiDeviceMemory class
Close
CloseBulk
Create
GetAttributes
GetDebugName
GetFileSize
GetFileTime
GetInstance
Open
OpenBulk
Read
ReadBulk
SafeRead
SafeWrite
Seek
Seek64
SetFileTime
Write
fiDeviceMemory::Close method
fiDeviceMemory::CloseBulk method
fiDeviceMemory::Create method
fiDeviceMemory::GetAttributes method
fiDeviceMemory::GetDebugName method
fiDeviceMemory::GetFileSize method
fiDeviceMemory::GetFileTime method
fiDeviceMemory::GetInstance method
fiDeviceMemory::Open method
fiDeviceMemory::OpenBulk method
fiDeviceMemory::Read method
fiDeviceMemory::ReadBulk method
fiDeviceMemory::SafeRead method
fiDeviceMemory::SafeWrite method
fiDeviceMemory::Seek method
fiDeviceMemory::Seek64 method
fiDeviceMemory::SetFileTime method
fiDeviceMemory::Write method
fiDeviceProfiler struct
~fiDeviceProfiler
OnClose
OnOpen
OnRead
OnReadEnd
OnSeek
OnWrite
fiDeviceProfiler::~fiDeviceProfiler destructor
fiDeviceProfiler::OnClose method
fiDeviceProfiler::OnOpen method
fiDeviceProfiler::OnRead method
fiDeviceProfiler::OnReadEnd method
fiDeviceProfiler::OnSeek method
fiDeviceProfiler::OnWrite method
fiDeviceRelative
fiDeviceRelative class
~fiDeviceRelative
Close
CloseBulk
Create
Delete
fiDeviceRelative
FindFileBegin
FindFileEnd
FindFileNext
FixName
FixRelativeName
GetAttributes
GetBulkOffset
GetDebugName
GetFileSize
GetFileTime
GetLowLevelDevice
GetPhysicalSortKey
GetResourceInfo
Init
m_pDevice
MakeDirectory
MountAs
Open
OpenBulk
OpenBulkDrm
PrefetchDir
Read
ReadBulk
Rename
Seek
Seek64
SetAttributes
SetEndOfFile
SetFileTime
UnmakeDirectory
Write
fiDeviceRelative::~fiDeviceRelative destructor
fiDeviceRelative::Close method
fiDeviceRelative::CloseBulk method
fiDeviceRelative::Create method
fiDeviceRelative::Delete method
fiDeviceRelative::fiDeviceRelative constructor
fiDeviceRelative::FindFileBegin method
fiDeviceRelative::FindFileEnd method
fiDeviceRelative::FindFileNext method
fiDeviceRelative::FixName method
fiDeviceRelative::FixRelativeName method
fiDeviceRelative::GetAttributes method
fiDeviceRelative::GetBulkOffset method
fiDeviceRelative::GetDebugName method
fiDeviceRelative::GetFileSize method
fiDeviceRelative::GetFileTime method
fiDeviceRelative::GetLowLevelDevice method
fiDeviceRelative::GetPhysicalSortKey method
fiDeviceRelative::GetResourceInfo method
fiDeviceRelative::Init method
fiDeviceRelative::m_pDevice data member
fiDeviceRelative::MakeDirectory method
fiDeviceRelative::MountAs method
fiDeviceRelative::Open method
fiDeviceRelative::OpenBulk method
fiDeviceRelative::OpenBulkDrm method
fiDeviceRelative::PrefetchDir method
fiDeviceRelative::Read method
fiDeviceRelative::ReadBulk method
fiDeviceRelative::Rename method
fiDeviceRelative::Seek method
fiDeviceRelative::Seek64 method
fiDeviceRelative::SetAttributes method
fiDeviceRelative::SetEndOfFile method
fiDeviceRelative::SetFileTime method
fiDeviceRelative::UnmakeDirectory method
fiDeviceRelative::Write method
fiDeviceRemote class
Close
CloseBulk
Create
Delete
DeleteDirectory
FindFileBegin
FindFileEnd
FindFileNext
GetAttributes
GetAttributesDir
GetAverageThroughput
GetDebugName
GetFileCount
GetFileSize
GetFileTime
GetInstance
GetResourceInfo
InitClass
InvalidateDirectoryCache
MakeDirectory
Open
OpenBulk
PrefetchDir
Read
ReadBulk
Seek
Seek64
SetAttributes
SetFileTime
ShutdownClass
Write
fiDeviceRemote::Close method
fiDeviceRemote::CloseBulk method
fiDeviceRemote::Create method
fiDeviceRemote::Delete method
fiDeviceRemote::DeleteDirectory method
fiDeviceRemote::FindFileBegin method
fiDeviceRemote::FindFileEnd method
fiDeviceRemote::FindFileNext method
fiDeviceRemote::GetAttributes method
fiDeviceRemote::GetAttributesDir method
fiDeviceRemote::GetAverageThroughput method
fiDeviceRemote::GetDebugName method
fiDeviceRemote::GetFileCount method
fiDeviceRemote::GetFileSize method
fiDeviceRemote::GetFileTime method
fiDeviceRemote::GetInstance method
fiDeviceRemote::GetResourceInfo method
fiDeviceRemote::InitClass method
fiDeviceRemote::InvalidateDirectoryCache method
fiDeviceRemote::MakeDirectory method
fiDeviceRemote::Open method
fiDeviceRemote::OpenBulk method
fiDeviceRemote::PrefetchDir method
fiDeviceRemote::Read method
fiDeviceRemote::ReadBulk method
fiDeviceRemote::Seek method
fiDeviceRemote::Seek64 method
fiDeviceRemote::SetAttributes method
fiDeviceRemote::SetFileTime method
fiDeviceRemote::ShutdownClass method
fiDeviceRemote::Write method
fiDeviceTcpIp
fiDeviceTcpIp class
~fiDeviceTcpIp
Close
Connect
Create
fiDeviceTcpIp
GetDebugName
GetFileTime
GetInstance
GetLastError
GetLocalHost
GetReadCount
InitClass
Listen
Open
Pickup
PrintInterfaceState
PrintNetStats
Read
Seek
Seek64
SetBlocking
SetFileTime
SetLastError
SetLocalHost
ShutdownClass
StaticWrite
WaitForNetworkReady
Write
fiDeviceTcpIp::~fiDeviceTcpIp destructor
fiDeviceTcpIp::Close method
fiDeviceTcpIp::Connect method
fiDeviceTcpIp::Create method
fiDeviceTcpIp::fiDeviceTcpIp constructor
fiDeviceTcpIp::GetDebugName method
fiDeviceTcpIp::GetFileTime method
fiDeviceTcpIp::GetInstance method
fiDeviceTcpIp::GetLastError method
fiDeviceTcpIp::GetLocalHost method
fiDeviceTcpIp::GetReadCount method
fiDeviceTcpIp::InitClass method
fiDeviceTcpIp::Listen method
fiDeviceTcpIp::Open method
fiDeviceTcpIp::Pickup method
fiDeviceTcpIp::PrintInterfaceState method
fiDeviceTcpIp::PrintNetStats method
fiDeviceTcpIp::Read method
fiDeviceTcpIp::Seek method
fiDeviceTcpIp::Seek64 method
fiDeviceTcpIp::SetBlocking method
fiDeviceTcpIp::SetFileTime method
fiDeviceTcpIp::SetLastError method
fiDeviceTcpIp::SetLocalHost method
fiDeviceTcpIp::ShutdownClass method
fiDeviceTcpIp::StaticWrite method
fiDeviceTcpIp::WaitForNetworkReady method
fiDeviceTcpIp::Write method
fiDeviceXContent
fiDeviceXContent class
~fiDeviceXContent
fiDeviceXContent
Init
MountAs
Shutdown
fiDeviceXContent::~fiDeviceXContent destructor
fiDeviceXContent::fiDeviceXContent constructor
fiDeviceXContent::Init method
fiDeviceXContent::MountAs method
fiDeviceXContent::Shutdown method
fiDiskCache class
class fiCachedDevice
GetCachedDevice
GetCacheInProgress
GetCacheOccupancy
GetHoldoffTime
GetLastCacheCopyCompletion
InitClass
IsCacheCopying
IsCacheEnabled
IsCachePrimed
LeaveBootMode
SetHoldoffTime
ShutdownClass
fiDiskCache::GetCachedDevice method
fiDiskCache::GetCacheInProgress method
fiDiskCache::GetCacheOccupancy method
fiDiskCache::GetHoldoffTime method
fiDiskCache::GetLastCacheCopyCompletion method
fiDiskCache::InitClass method
fiDiskCache::IsCacheCopying method
fiDiskCache::IsCacheEnabled method
fiDiskCache::IsCachePrimed method
fiDiskCache::LeaveBootMode method
fiDiskCache::SetHoldoffTime method
fiDiskCache::ShutdownClass method
FieldAssign
FieldAssign macro
fiEmbeddedFile
fiEmbeddedFile class
fiEmbeddedFile
Lookup
fiEmbeddedFile::fiEmbeddedFile constructor
fiEmbeddedFile::Lookup method
fiHandle
fiHandle type
fiHandleInvalid
fiHandleInvalid macro
FILE_VERSION
FILE_VERSION variable
filename
FileName
FileOffset_IsDir
FileOffset_Shift
FileTime
FILETIME_BIAS
FILETIME_BIAS variable
FillData
FillDevice
FILLDEVICE_MAX_FILE_SIZE
FILLDEVICE_MAX_FILE_SIZE macro
FillParentIndices
fiMultiTokenizer
fiMultiTokenizer class
fiMultiTokenizer
GetReadTokenizer
GetWriteTokenizer
fiMultiTokenizer::fiMultiTokenizer constructor
fiMultiTokenizer::GetReadTokenizer method
fiMultiTokenizer::GetWriteTokenizer method
FindEntry
FindExtensionInPath
FindFile
FindFileBegin
FindFileEnd
FindFileNext
FindPath
FinishInstall
fiPackEntry struct
DECLARE_BITFIELD_4
FileOffset_IsDir
FileOffset_Shift
GetConsumedSize
GetFileOffset
GetUncompressedSize
GetVersion
IsCompressed
IsDir
IsFile
IsResource
MaxConsumedSize
SetFileOffset
u
fiPackEntry::DECLARE_BITFIELD_4 method
fiPackEntry::FileOffset_IsDir data member
fiPackEntry::FileOffset_Shift data member
fiPackEntry::GetConsumedSize method
fiPackEntry::GetFileOffset method
fiPackEntry::GetUncompressedSize method
fiPackEntry::GetVersion method
fiPackEntry::IsCompressed method
fiPackEntry::IsDir method
fiPackEntry::IsFile method
fiPackEntry::IsResource method
fiPackEntry::MaxConsumedSize data member
fiPackEntry::SetFileOffset method
fiPackEntry::u data member
fiPackfile
fiPackfile class
~fiPackfile
ClearRelativeOffset
Close
CloseBulk
Create
ExtractFileToMemory
FillData
FillParentIndices
FindEntry
FindFileBegin
FindFileEnd
FindFileNext
fiPackfile
GetAttributes
GetBasePhysicalSortKey
GetBulkOffset
GetDebugName
GetEntries
GetEntryCount
GetEntryFullName
GetEntryIndex
GetEntryInfo
GetEntryName
GetEntryPhysicalSortKey
GetFileSize
GetFileTime
GetHeaderSize
GetNameHeap
GetNameShift
GetPackfileHandle
GetPackfileIndex
GetPackfileSize
GetPackfileTime
GetPhysicalSortKey
GetRelativeOffset
GetResourceInfo
Init
InitFromImg
InitFromZip
IsInitialized
IsPackfile
IsRpf
IsUserHeader
m_ArchiveBias
m_ArchiveSize
m_CachedDataSize
m_CachedMetaDataSize
m_Device
m_Entries
m_EntryCount
m_FileTime
m_Fullname
m_Handle
m_IsByteSwapped
m_IsCached
m_IsInstalled
m_IsRpf
m_IsUserHeader
m_IsXCompressed
m_KeyId
m_MemoryBuffer
m_Name
m_NameHeap
m_NameHeapInDebugHeap
m_NameShift
m_ParentIndices
m_pDrmKey
m_RelativeOffset
m_SelfIndex
m_SortKey
MountAs
Open
OpenBulk
OpenBulkFromHandle
OpenDirect
OpenInternal
ParentIndexType
Prefetch
Read
ReadBulk
ReadInternal
ReadInternalBulk
ReInit
RemountDependentPackfiles
Seek
Seek64
SetDrmKey
SetFileTime
SetpackfileHandle
SetPackfileTime
SetReadAheadCacheCPU
SetRelativePath
Shutdown
Size
Size64
UnInit
Write
fiPackfile::~fiPackfile destructor
fiPackfile::ClearRelativeOffset method
fiPackfile::Close method
fiPackfile::CloseBulk method
fiPackfile::Create method
fiPackfile::ExtractFileToMemory method
fiPackfile::FillData method
fiPackfile::FillParentIndices method
fiPackfile::FindEntry method
fiPackfile::FindFileBegin method
fiPackfile::FindFileEnd method
fiPackfile::FindFileNext method
fiPackfile::fiPackfile constructor
fiPackfile::GetAttributes method
fiPackfile::GetBasePhysicalSortKey method
fiPackfile::GetBulkOffset method
fiPackfile::GetDebugName method
fiPackfile::GetEntries method
fiPackfile::GetEntryCount method
fiPackfile::GetEntryFullName method
fiPackfile::GetEntryIndex method
fiPackfile::GetEntryInfo method
fiPackfile::GetEntryName method
fiPackfile::GetEntryPhysicalSortKey method
fiPackfile::GetFileSize method
fiPackfile::GetFileTime method
fiPackfile::GetHeaderSize method
fiPackfile::GetNameHeap method
fiPackfile::GetNameShift method
fiPackfile::GetPackfileHandle method
fiPackfile::GetPackfileIndex method
fiPackfile::GetPackfileSize method
fiPackfile::GetPackfileTime method
fiPackfile::GetPhysicalSortKey method
fiPackfile::GetRelativeOffset method
fiPackfile::GetResourceInfo method
fiPackfile::Init method
fiPackfile::InitFromImg method
fiPackfile::InitFromZip method
fiPackfile::IsInitialized method
fiPackfile::IsPackfile method
fiPackfile::IsRpf method
fiPackfile::IsUserHeader method
fiPackfile::m_ArchiveBias data member
fiPackfile::m_ArchiveSize data member
fiPackfile::m_CachedDataSize data member
fiPackfile::m_CachedMetaDataSize data member
fiPackfile::m_Device data member
fiPackfile::m_Entries data member
fiPackfile::m_EntryCount data member
fiPackfile::m_FileTime data member
fiPackfile::m_Fullname data member
fiPackfile::m_Handle data member
fiPackfile::m_IsByteSwapped data member
fiPackfile::m_IsCached data member
fiPackfile::m_IsInstalled data member
fiPackfile::m_IsRpf data member
fiPackfile::m_IsUserHeader data member
fiPackfile::m_IsXCompressed data member
fiPackfile::m_KeyId data member
fiPackfile::m_MemoryBuffer data member
fiPackfile::m_Name data member
fiPackfile::m_NameHeap data member
fiPackfile::m_NameHeapInDebugHeap data member
fiPackfile::m_NameShift data member
fiPackfile::m_ParentIndices data member
fiPackfile::m_pDrmKey data member
fiPackfile::m_RelativeOffset data member
fiPackfile::m_SelfIndex data member
fiPackfile::m_SortKey data member
fiPackfile::MountAs method
fiPackfile::Open method
fiPackfile::OpenBulk method
fiPackfile::OpenBulkFromHandle method
fiPackfile::OpenDirect method
fiPackfile::OpenInternal method
fiPackfile::ParentIndexType nested type
fiPackfile::Prefetch method
fiPackfile::Read method
fiPackfile::ReadBulk method
fiPackfile::ReadInternal method
fiPackfile::ReadInternalBulk method
fiPackfile::ReInit method
fiPackfile::RemountDependentPackfiles method
fiPackfile::Seek method
fiPackfile::Seek64 method
fiPackfile::SetDrmKey method
fiPackfile::SetFileTime method
fiPackfile::SetpackfileHandle method
fiPackfile::SetPackfileTime method
fiPackfile::SetReadAheadCacheCPU method
fiPackfile::SetRelativePath method
fiPackfile::Shutdown method
fiPackfile::Size method
fiPackfile::Size64 method
fiPackfile::UnInit method
fiPackfile::Write method
fiPackfileState
fiPackfileState struct
avail_in
BufferSize
fiPackfileState
IsCompressed
m_Buffer
m_CompOffset
m_DebugName
m_Entry
m_Offset
m_xStream
m_zStream
next_in
Reset
fiPackfileState::avail_in data member
fiPackfileState::BufferSize data member
fiPackfileState::fiPackfileState constructor
fiPackfileState::IsCompressed method
fiPackfileState::m_Buffer data member
fiPackfileState::m_CompOffset data member
fiPackfileState::m_DebugName data member
fiPackfileState::m_Entry data member
fiPackfileState::m_Offset data member
fiPackfileState::m_xStream data member
fiPackfileState::m_zStream data member
fiPackfileState::next_in data member
fiPackfileState::Reset method
fiRpf7Builder
fiRpf7Builder class
~fiRpf7Builder
AddData
AddFile
fiRpf7Builder
Save
fiRpf7Builder::~fiRpf7Builder destructor
fiRpf7Builder::AddData method
fiRpf7Builder::AddFile method
fiRpf7Builder::fiRpf7Builder constructor
fiRpf7Builder::Save method
fiRpf7Entry
fiRpf7Entry struct
~fiRpf7Entry
1
Child
DataSize
fiRpf7Entry
NameOffset
Next
SourceName
fiRpf7Entry::~fiRpf7Entry destructor
fiRpf7Entry::1 data member
fiRpf7Entry::Child data member
fiRpf7Entry::DataSize data member
fiRpf7Entry::fiRpf7Entry constructor
fiRpf7Entry::NameOffset data member
fiRpf7Entry::Next data member
fiRpf7Entry::SourceName data member
fiSafeStream
fiSafeStream class
~fiSafeStream
->
fiSafeStream
fiStream*
fiSafeStream::~fiSafeStream destructor
fiSafeStream::-> operator
fiSafeStream::fiSafeStream constructor
fiSafeStream::fiStream* operator
fiSaveGame class
BeginContentVerify
BeginDelete
BeginDeleteFromList
BeginEnumeration
BeginExtraSpaceCheck
BeginFreeSpaceCheck
BeginGetCreator
BeginGetFileModifiedTime
BeginGetFileSize
BeginIconSave
BeginLoad
BeginReadNamesAndSizesOfAllSaveGames
BeginSave
BeginSelectDevice
CalculateDataSizeOnDisk
CalculateSizeOfSaveGameFile
CheckContentVerify
CheckDelete
CheckDeleteFromList
CheckEnumeration
CheckExtraSpaceCheck
CheckFreeSpaceCheck
CheckGetCreator
CheckGetCreator
CheckGetFileModifiedTime
CheckGetFileSize
CheckIconSave
CheckLoad
CheckReadNamesAndSizesOfAllSaveGames
CheckSave
CheckSelectDevice
EndContentVerify
EndDelete
EndDeleteFromList
EndEnumeration
EndExtraSpaceCheck
EndFreeSpaceCheck
EndGetCreator
EndGetFileModifiedTime
EndGetFileSize
EndIconSave
EndLoad
EndReadNamesAndSizesOfAllSaveGames
EndSave
EndSelectDevice
FillDevice
GetCurrentDeviceData
GetDeviceData
GetError
GetMaxUsers
GetSelectedDevice
GetState
GetTotalAvailableSpace
HasFileBeenAccessed
InitClass
IsCurrentDeviceValid
IsDeviceValid
IsStorageDeviceChanged
IsStorageDeviceRemoved
SetCheckForUserBindErrors
SetIcon
SetMaxNumberOfSaveGameFilesToEnumerate
SetMountIndex
SetSaveGameFolder
SetSaveGameTitle
SetSelectedDevice
SetSelectedDeviceToAny
SetStateToIdle
SetUserServiceId
ShowDeleteDialog
ShowLoadDialog
ShowSaveDialog
ShutdownClass
SIGNIN_COUNT
UpdateClass
fiSaveGame::BeginContentVerify method
fiSaveGame::BeginDelete method
fiSaveGame::BeginDeleteFromList method
fiSaveGame::BeginEnumeration method
fiSaveGame::BeginExtraSpaceCheck method
fiSaveGame::BeginFreeSpaceCheck method
fiSaveGame::BeginGetCreator method
fiSaveGame::BeginGetFileModifiedTime method
fiSaveGame::BeginGetFileSize method
fiSaveGame::BeginIconSave method
fiSaveGame::BeginLoad method
fiSaveGame::BeginReadNamesAndSizesOfAllSaveGames method
fiSaveGame::BeginSave method
fiSaveGame::BeginSelectDevice method
fiSaveGame::CalculateDataSizeOnDisk method
fiSaveGame::CalculateSizeOfSaveGameFile method
fiSaveGame::CheckContentVerify method
fiSaveGame::CheckDelete method
fiSaveGame::CheckDeleteFromList method
fiSaveGame::CheckEnumeration method
fiSaveGame::CheckExtraSpaceCheck method
fiSaveGame::CheckFreeSpaceCheck method
fiSaveGame::CheckGetCreator method
fiSaveGame::CheckGetFileModifiedTime method
fiSaveGame::CheckGetFileSize method
fiSaveGame::CheckIconSave method
fiSaveGame::CheckLoad method
fiSaveGame::CheckReadNamesAndSizesOfAllSaveGames method
fiSaveGame::CheckSave method
fiSaveGame::CheckSelectDevice method
fiSaveGame::EndContentVerify method
fiSaveGame::EndDelete method
fiSaveGame::EndDeleteFromList method
fiSaveGame::EndEnumeration method
fiSaveGame::EndExtraSpaceCheck method
fiSaveGame::EndFreeSpaceCheck method
fiSaveGame::EndGetCreator method
fiSaveGame::EndGetFileModifiedTime method
fiSaveGame::EndGetFileSize method
fiSaveGame::EndIconSave method
fiSaveGame::EndLoad method
fiSaveGame::EndReadNamesAndSizesOfAllSaveGames method
fiSaveGame::EndSave method
fiSaveGame::EndSelectDevice method
fiSaveGame::FillDevice method
fiSaveGame::GetCurrentDeviceData method
fiSaveGame::GetDeviceData method
fiSaveGame::GetError method
fiSaveGame::GetMaxUsers method
fiSaveGame::GetSelectedDevice method
fiSaveGame::GetState method
fiSaveGame::GetTotalAvailableSpace method
fiSaveGame::HasFileBeenAccessed method
fiSaveGame::InitClass method
fiSaveGame::IsCurrentDeviceValid method
fiSaveGame::IsDeviceValid method
fiSaveGame::IsStorageDeviceChanged method
fiSaveGame::IsStorageDeviceRemoved method
fiSaveGame::SetCheckForUserBindErrors method
fiSaveGame::SetIcon method
fiSaveGame::SetMaxNumberOfSaveGameFilesToEnumerate method
fiSaveGame::SetMountIndex method
fiSaveGame::SetSaveGameFolder method
fiSaveGame::SetSaveGameTitle method
fiSaveGame::SetSelectedDevice method
fiSaveGame::SetSelectedDeviceToAny method
fiSaveGame::SetStateToIdle method
fiSaveGame::SetUserServiceId method
fiSaveGame::ShowDeleteDialog method
fiSaveGame::ShowLoadDialog method
fiSaveGame::ShowSaveDialog method
fiSaveGame::ShutdownClass method
fiSaveGame::SIGNIN_COUNT data member
fiSaveGame::UpdateClass method
fiSerialize
fiSerialize class
~fiSerialize
fiSerialize
Get
m_Stream
m_Token
m_Version
Put
Serialize
Serialize
Serialize
Serialize
Serialize
Serialize
Serialize
Serialize
Serialize
fiSerialize::~fiSerialize destructor
fiSerialize::fiSerialize constructor
fiSerialize::Get method
fiSerialize::m_Stream data member
fiSerialize::m_Token data member
fiSerialize::m_Version data member
fiSerialize::Put method
fiSerialize::Serialize method
fiStream class
AllowBlockingLoads
AreBlockingLoadsAllowed
Close
CloseOpenFiles
CloseShared
Create
Create
DumpOpenFiles
FastGetCh
FastPutCh
fdopen
Flush
GetCh
GetCloseCallback
GetCreateCallback
GetLocalHandle
GetName
GetOpenCallback
Open
Open
OutputAllFileAccess
PreLoad
PutCh
Read
ReadByte
ReadByte
ReadFloat
ReadInt
ReadInt
ReadLong
ReadLong
ReadShort
ReadShort
ReadTChar
Seek
Seek64
SetCloseCallback
SetCreateCallback
SetFaultInjectionPath
SetOpenCallback
Size
Size64
Tell
Tell64
TellStart
Write
WriteByte
WriteByte
WriteFloat
WriteInt
WriteInt
WriteLong
WriteLong
WriteShort
WriteShort
WriteTChar
fiStream*
fiStream::AllowBlockingLoads method
fiStream::AreBlockingLoadsAllowed method
fiStream::Close method
fiStream::CloseOpenFiles method
fiStream::CloseShared method
fiStream::Create method
fiStream::DumpOpenFiles method
fiStream::FastGetCh method
fiStream::FastPutCh method
fiStream::fdopen method
fiStream::Flush method
fiStream::GetCh method
fiStream::GetCloseCallback method
fiStream::GetCreateCallback method
fiStream::GetLocalHandle method
fiStream::GetName method
fiStream::GetOpenCallback method
fiStream::m_bOutputAllFileAccess
fiStream::m_bOutputAllFileAccess variable
fiStream::Open method
fiStream::OutputAllFileAccess method
fiStream::PreLoad method
fiStream::PutCh method
fiStream::Read method
fiStream::ReadByte method
fiStream::ReadFloat method
fiStream::ReadInt method
fiStream::ReadLong method
fiStream::ReadShort method
fiStream::ReadTChar method
fiStream::Seek method
fiStream::Seek64 method
fiStream::SetCloseCallback method
fiStream::SetCreateCallback method
fiStream::SetFaultInjectionPath method
fiStream::SetOpenCallback method
fiStream::Size method
fiStream::Size64 method
fiStream::sm_AllowBlockingLoads
fiStream::sm_AllowBlockingLoads variable
fiStream::sm_CloseCallback
fiStream::sm_CloseCallback variable
fiStream::sm_CreateCallback
fiStream::sm_CreateCallback variable
fiStream::sm_FaultInjectionPath
fiStream::sm_FaultInjectionPath variable
fiStream::sm_OpenCallback
fiStream::sm_OpenCallback variable
fiStream::sm_UnavailableString
fiStream::sm_UnavailableString variable
fiStream::Tell method
fiStream::Tell64 method
fiStream::TellStart method
fiStream::Write method
fiStream::WriteByte method
fiStream::WriteFloat method
fiStream::WriteInt method
fiStream::WriteLong method
fiStream::WriteShort method
fiStream::WriteTChar method
fiTokenizer
fiTokenizer class
fiTokenizer
fiTokenizer
fiTokenizer::fiTokenizer constructor
FixName
FixRelativeName
fiZipfile
fiZipfile class
~fiZipfile
Close
CloseBulk
Create
FillData
FindEntry
FindFileBegin
FindFileEnd
FindFileNext
fiZipfile
GetAttributes
GetDebugName
GetFileSize
GetFileTime
Init
m_ArchiveBias
m_ArchiveSize
m_Device
m_Handle
m_Name
m_RelativeOffset
m_Root
MountAs
Open
OpenBulk
OpenInternal
Read
ReadBulk
ReadInternal
ReadInternalBulk
Seek
Seek64
SetFileTime
Size
Size64
Write
fiZipfile::~fiZipfile destructor
fiZipfile::Close method
fiZipfile::CloseBulk method
fiZipfile::Create method
fiZipfile::FillData method
fiZipfile::FindEntry method
fiZipfile::FindFileBegin method
fiZipfile::FindFileEnd method
fiZipfile::FindFileNext method
fiZipfile::fiZipfile constructor
fiZipfile::GetAttributes method
fiZipfile::GetDebugName method
fiZipfile::GetFileSize method
fiZipfile::GetFileTime method
fiZipfile::Init method
fiZipfile::m_ArchiveBias data member
fiZipfile::m_ArchiveSize data member
fiZipfile::m_Device data member
fiZipfile::m_Handle data member
fiZipfile::m_Name data member
fiZipfile::m_RelativeOffset data member
fiZipfile::m_Root data member
fiZipfile::MountAs method
fiZipfile::Open method
fiZipfile::OpenBulk method
fiZipfile::OpenInternal method
fiZipfile::Read method
fiZipfile::ReadBulk method
fiZipfile::ReadInternal method
fiZipfile::ReadInternalBulk method
fiZipfile::Seek method
fiZipfile::Seek64 method
fiZipfile::SetFileTime method
fiZipfile::Size method
fiZipfile::Size64 method
fiZipfile::Write method
fiZipfileState
fiZipfileState struct
BufferSize
fiZipfileState
IsCompressed
m_Buffer
m_CompOffset
m_DebugName
m_Entry
m_Offset
m_zStream
Reset
fiZipfileState::BufferSize data member
fiZipfileState::fiZipfileState constructor
fiZipfileState::IsCompressed method
fiZipfileState::m_Buffer data member
fiZipfileState::m_CompOffset data member
fiZipfileState::m_DebugName data member
fiZipfileState::m_Entry data member
fiZipfileState::m_Offset data member
fiZipfileState::m_zStream data member
fiZipfileState::Reset method
FlagInstalledRpfs
Flush
friend class fiCachedDevice
friend class fiCachedDevice friend
friend class fiDiskCache
friend class fiDiskCache friend
FullPath
FullReadPath
FullWritePath
G
GAMESPYPC_ONLY
GAMESPYPC_ONLY macro
Get
GetAttributes
GetAttributesDir
GetAverageThroughput
GetBasePhysicalSortKey
GetBlock
GetBlockPhysicalSortKey
GetBulkOffset
GetByte
GetCachedDevice
GetCacheInProgress
GetCacheOccupancy
GetCachePrefix
GetCh
GetCloseCallback
GetCollection
GetCollectionIndex
GetCompressUpperBound
GetConsumedSize
GetCreateCallback
GetCurrentDeviceData
GetDebugName
GetDelimiter
GetDevice
GetDeviceData
GetDisplayName
GetEntries
GetEntryCount
GetEntryFullName
GetEntryIndex
GetEntryInfo
GetEntryName
GetEntryPhysicalSortKey
GetError
GetExpectedVersion
GetFileCount
GetFileOffset
GetFileSize
GetFileTime
GetFloat
GetHeaderPrefix
GetHeaderSize
GetHexU32
GetHoldoffTime
GetInstallName
GetInstallProgress
GetInstallStatus
GetInstance
GetInt
GetIsBootedFromHdd
GetLastCacheCopyCompletion
GetLastError
GetLine
GetLoadSize
GetLocalHandle
GetLocalHost
GetLocalSystemTime
GetLowLevelDevice
GetMaxUsers
GetMemoryFileName
GetName
GetNameHeap
GetNameShift
GetNextCh
GetOpenCallback
GetPackfileHandle
GetPackfileIndex
GetPackfileSize
GetPackFileSize
GetPackfileTime
GetPartitionName
GetPath
GetPathCount
GetPhysicalSortKey
GetReadCount
GetReadTokenizer
GetRelativeOffset
GetResourceInfo
GetRpfDevice
GetSaveSize
GetSelectedDevice
GetShort
GetSize
GetStackedPath
GetState
GetStaticHeaderPrefix
GetStream
GetStreamPosition
GetToken
GetTokenCh
GetTokenToChar
GetTokenToChars
GetTotalAvailableSpace
GetUncompressedSize
GetVector
GetVersion
GetWriteState
GetWriteTokenizer
H
HANDLEFMT
HANDLEFMT macro
HARDDRIVE_LSN
HasFileBeenAccessed
Hash
Header
Header class
CalculateHash
Clear
Export
FILE_VERSION
GetDisplayName
GetExpectedVersion
GetVersion
Header
Import
m_DisplayName
m_Hash
m_Version
MAX_BYTE_SIZEOF_PAYLOAD
Header::CalculateHash method
Header::Clear method
Header::Export method
Header::FILE_VERSION data member
Header::GetDisplayName method
Header::GetExpectedVersion method
Header::GetVersion method
Header::Header constructor
Header::Import method
Header::m_DisplayName data member
Header::m_Hash data member
Header::m_Version data member
Header::MAX_BYTE_SIZEOF_PAYLOAD data member
hEvent
hEvent variable
I
IgnoreToken
Import
INC_DEVICE_XCONTENT_H_
INC_DEVICE_XCONTENT_H_ macro
Indent
Init
InitClass
InitFromImg
InitFromZip
InitInstall
InitPartitionDevice
InitWinSock
InitWinSock function
Insert
InsertPathElement
InstallerThread
InstallProgress
INVALID_DEVICE
INVALID_DEVICE macro
InvalidateDirectoryCache
IPV6_SOCKETS
IPV6_SOCKETS macro
IsAbsolutePath
IsAvailable
IsBinary
IsCacheCopying
IsCacheEnabled
IsCachePrimed
IsCloud
IsCompressed
IsCurrentDeviceValid
IsDeviceValid
IsDir
IsFile
IsInitialized
IsLoading
IsOutOfDate
IsPackfile
IsPartitionPath
IsResource
IsRpf
IsStorageDeviceChanged
IsStorageDeviceRemoved
IsStoring
IsStreaming
IsTargetDeviceValid
IsUserHeader
iswhitespace
L
LAYER1_LSN
LeaveBootMode
line
Listen
LIVE_ONLY
LIVE_ONLY macro
LOCAL
LOCAL macro
Lock
LOG_EVERYTHING
LOG_EVERYTHING macro
LOG1
LOG1 macro
LOG2
LOG2 macro
Lookup
M
m_ArchiveBias
m_ArchiveSize
m_Buffer
m_CachedDataSize
m_CachedMetaDataSize
m_CompOffset
m_DebugName
m_Device
m_DisplayName
m_Entries
m_Entry
m_EntryCount
m_FileTime
m_Fullname
m_Handle
m_Hash
m_IsByteSwapped
m_IsCached
m_IsInstalled
m_IsRpf
m_isStreaming
m_IsUserHeader
m_IsXCompressed
m_KeyId
m_MemoryBuffer
m_Name
m_NameHeap
m_NameHeapInDebugHeap
m_NameShift
m_nNumTabs
m_Offset
m_ParentIndices
m_pDevice
m_pDrmKey
m_RelativeOffset
m_Root
m_SelfIndex
m_SortKey
m_Stream
m_Token
m_Version
m_WriteState
m_xStream
m_zStream
MakeDirectory
MakeFolderRelative
MakeGrowBufferFileName
MakeHandle
MakeMemoryFileName
MakeRelative
MatchFloat
MatchIFloat
MatchIInt
MatchInt
MatchIToken
MatchIVector
MatchToken
MatchVector
MAX_BYTE_SIZEOF_PAYLOAD
MAX_DISPLAY_NAME
MAX_DISPLAY_NAME macro
MAX_FILENAME_LENGTH
MaxConsumedSize
Mount
Mount_t
Mount_t struct
Device
Mount_t
Path
PathLen
ReadOnly
Mount_t::Device data member
Mount_t::Mount_t constructor
Mount_t::Path data member
Mount_t::PathLen data member
Mount_t::ReadOnly data member
MountAs
MsDosDate struct
DECLARE_BITFIELD_3
MsDosDate::DECLARE_BITFIELD_3 method
MsDosTime struct
DECLARE_BITFIELD_3
MsDosTime::DECLARE_BITFIELD_3 method
N
Name
NameOffset
Next
next_in
nextch
Normalize
O
Offset
OnClose
OnDiscSwap
OnOpen
OnRead
OnReadEnd
OnSeek
OnWrite
Open
OpenBulk
OpenBulkDrm
OpenBulkFromHandle
OpenDirect
OpenInternal
OTHER_SEPARATOR
OTHER_SEPARATOR macro
OutputAllFileAccess
Overview
P
ParentIndexType
ParseHeader
Path
PathLen
PauseDiscRead
PC_FILE_SIZE
PC_FILE_SIZE macro
Pickup
Poll
Pop
PopFolder
Prefetch
PrefetchDir
PREFIX_SIZE
PREFIX_SIZE variable
PreLoad
PrintInterfaceState
PrintNetStats
PushFolder
Put
PutByte
PutCh
PutDelimiter
PutShort
PutStr
PutStrLine
R
rage
rage namespace
rage::__ENABLE_RFS
rage::__ENABLE_RFS macro
rage::ASSET
rage::ASSET variable
rage::ASYNC_CACHE_COPIES
rage::ASYNC_CACHE_COPIES macro
rage::atou
rage::atou function
rage::CACHE_BLOCK_COUNT
rage::CACHE_BLOCK_COUNT variable
rage::CACHE_BLOCK_HANDLE
rage::CACHE_BLOCK_HANDLE macro
rage::CACHE_BLOCK_MASK
rage::CACHE_BLOCK_MASK variable
rage::CACHE_BLOCK_MAX
rage::CACHE_BLOCK_MAX variable
rage::CACHE_BLOCK_SHIFT
rage::CACHE_BLOCK_SHIFT variable
rage::CACHE_BLOCK_SIZE
rage::CACHE_BLOCK_SIZE variable
rage::CACHE_FILE_BLOCK_COUNT
rage::CACHE_FILE_BLOCK_COUNT variable
rage::CACHE_FILE_COUNT
rage::CACHE_FILE_COUNT variable
rage::CACHE_FILE_HEADER_SIZE
rage::CACHE_FILE_HEADER_SIZE variable
rage::CACHE_FILE_MAGIC
rage::CACHE_FILE_MAGIC variable
rage::CACHE_FILE_SIZE
rage::CACHE_FILE_SIZE variable
rage::CACHE_FILE_VERSION
rage::CACHE_FILE_VERSION variable
rage::CACHE_PADDING
rage::CACHE_PADDING variable
rage::CACHE_SUBFILE_COUNT
rage::CACHE_SUBFILE_COUNT variable
rage::CACHE_SUBFILE_MASK
rage::CACHE_SUBFILE_MASK variable
rage::CACHE_SUBFILE_SHIFT
rage::CACHE_SUBFILE_SHIFT variable
rage::CACHEDEV
rage::CACHEDEV macro
rage::CacheHeader
rage::CacheHeader struct
rage::CENTINANOSECONDS_PER_SECOND
rage::CENTINANOSECONDS_PER_SECOND variable
rage::CompileTimeAssertSize
rage::CompileTimeAssertSize function
rage::CORRUPT_FILE_CODE
rage::CORRUPT_FILE_CODE macro
rage::COULD_NOT_MAP_DEVICE_CODE
rage::COULD_NOT_MAP_DEVICE_CODE macro
rage::dcDebugf1
rage::dcDebugf1 macro
rage::dcDebugf2
rage::dcDebugf2 macro
rage::dcDebugf3
rage::dcDebugf3 macro
rage::dcDisplayf
rage::dcDisplayf macro
rage::dcErrorf
rage::dcErrorf macro
rage::dcWarningf
rage::dcWarningf macro
rage::DECLARE_STREAM_BUFFERS
rage::DECLARE_STREAM_BUFFERS macro
rage::DeviceMemoryState
rage::DeviceMemoryState struct
rage::DIALOG_MODE
rage::DIALOG_MODE macro
rage::DVD_DEVICE_NAME
rage::DVD_DEVICE_NAME macro
rage::eInstallDeviceStatus
rage::eInstallDeviceStatus enumeration
rage::ENABLE_GAMEDATA_FOR_DISKCACHE
rage::ENABLE_GAMEDATA_FOR_DISKCACHE macro
rage::EncoderState
rage::EncoderState struct
rage::eTypeOfSaveProcess
rage::eTypeOfSaveProcess enumeration
rage::eTypeOfSpaceCheck
rage::eTypeOfSpaceCheck enumeration
rage::fgetline
rage::fgetline function
rage::fgets
rage::fgets function
rage::fiArchive
rage::fiArchive::&
rage::fiArchive::fiArchive
rage::fiArchive::GetVersion
rage::fiArchive::IsLoading
rage::fiArchive::IsStoring
rage::fiAsciiTokenizer
rage::fiAsciiTokenizer::EndBlock
rage::fiAsciiTokenizer::EndLine
rage::fiAsciiTokenizer::fiAsciiTokenizer
rage::fiAsciiTokenizer::GetByte
rage::fiAsciiTokenizer::GetDelimiter
rage::fiAsciiTokenizer::GetFloat
rage::fiAsciiTokenizer::GetHexU32
rage::fiAsciiTokenizer::GetInt
rage::fiAsciiTokenizer::GetShort
rage::fiAsciiTokenizer::GetVector
rage::fiAsciiTokenizer::Indent
rage::fiAsciiTokenizer::IsBinary
rage::fiAsciiTokenizer::m_nNumTabs
rage::fiAsciiTokenizer::MatchFloat
rage::fiAsciiTokenizer::MatchIFloat
rage::fiAsciiTokenizer::MatchIInt
rage::fiAsciiTokenizer::MatchInt
rage::fiAsciiTokenizer::MatchIVector
rage::fiAsciiTokenizer::MatchVector
rage::fiAsciiTokenizer::Put
rage::fiAsciiTokenizer::PutByte
rage::fiAsciiTokenizer::PutDelimiter
rage::fiAsciiTokenizer::PutShort
rage::fiAsciiTokenizer::StartBlock
rage::fiAsciiTokenizer::StartLine
rage::fiAsciiTokenizer::WriteTabs
rage::fiAssetManager
rage::fiAssetManager::~fiAssetManager
rage::fiAssetManager::AddExtension
rage::fiAssetManager::BaseName
rage::fiAssetManager::ClearAttributes
rage::fiAssetManager::Create
rage::fiAssetManager::CreateLeadingPath
rage::fiAssetManager::Entry
rage::fiAssetManager::Entry struct
rage::fiAssetManager::EnumFiles
rage::fiAssetManager::Exists
rage::fiAssetManager::fiAssetManager
rage::fiAssetManager::FileName
rage::fiAssetManager::FindExtensionInPath
rage::fiAssetManager::FindPath
rage::fiAssetManager::FullPath
rage::fiAssetManager::FullReadPath
rage::fiAssetManager::FullWritePath
rage::fiAssetManager::GetAttributes
rage::fiAssetManager::GetPath
rage::fiAssetManager::GetPathCount
rage::fiAssetManager::GetStackedPath
rage::fiAssetManager::InsertPathElement
rage::fiAssetManager::IsAbsolutePath
rage::fiAssetManager::MakeFolderRelative
rage::fiAssetManager::MakeRelative
rage::fiAssetManager::MAX_FILENAME_LENGTH
rage::fiAssetManager::Open
rage::fiAssetManager::PopFolder
rage::fiAssetManager::PushFolder
rage::fiAssetManager::RemoveExtensionFromPath
rage::fiAssetManager::RemoveNameFromPath
rage::fiAssetManager::SetAttributes
rage::fiAssetManager::SetPath
rage::fiAsynchStream
rage::fiAsynchStream::~fiAsynchStream
rage::fiAsynchStream::fiAsynchStream
rage::fiAsynchStream::GetMemoryFileName
rage::fiAsynchStream::GetSize
rage::fiAsynchStream::Init
rage::fiAsynchStream::Poll
rage::fiBaseTokenizer
rage::fiBaseTokenizer::~fiBaseTokenizer
rage::fiBaseTokenizer::CheckIToken
rage::fiBaseTokenizer::CheckToken
rage::fiBaseTokenizer::CommentChar
rage::fiBaseTokenizer::EndBlock
rage::fiBaseTokenizer::EndLine
rage::fiBaseTokenizer::EndOfFile
rage::fiBaseTokenizer::enState
rage::fiBaseTokenizer::enState enumeration
rage::fiBaseTokenizer::filename
rage::fiBaseTokenizer::GetBlock
rage::fiBaseTokenizer::GetByte
rage::fiBaseTokenizer::GetDelimiter
rage::fiBaseTokenizer::GetFloat
rage::fiBaseTokenizer::GetInt
rage::fiBaseTokenizer::GetLine
rage::fiBaseTokenizer::GetName
rage::fiBaseTokenizer::GetNextCh
rage::fiBaseTokenizer::GetShort
rage::fiBaseTokenizer::GetStream
rage::fiBaseTokenizer::GetStreamPosition
rage::fiBaseTokenizer::GetToken
rage::fiBaseTokenizer::GetTokenCh
rage::fiBaseTokenizer::GetTokenToChar
rage::fiBaseTokenizer::GetTokenToChars
rage::fiBaseTokenizer::GetVector
rage::fiBaseTokenizer::GetWriteState
rage::fiBaseTokenizer::IgnoreToken
rage::fiBaseTokenizer::Indent
rage::fiBaseTokenizer::Init
rage::fiBaseTokenizer::IsBinary
rage::fiBaseTokenizer::iswhitespace
rage::fiBaseTokenizer::line
rage::fiBaseTokenizer::m_WriteState
rage::fiBaseTokenizer::MatchFloat
rage::fiBaseTokenizer::MatchIFloat
rage::fiBaseTokenizer::MatchIInt
rage::fiBaseTokenizer::MatchInt
rage::fiBaseTokenizer::MatchIToken
rage::fiBaseTokenizer::MatchIVector
rage::fiBaseTokenizer::MatchToken
rage::fiBaseTokenizer::MatchVector
rage::fiBaseTokenizer::nextch
rage::fiBaseTokenizer::Pop
rage::fiBaseTokenizer::Put
rage::fiBaseTokenizer::PutByte
rage::fiBaseTokenizer::PutDelimiter
rage::fiBaseTokenizer::PutShort
rage::fiBaseTokenizer::PutStr
rage::fiBaseTokenizer::PutStrLine
rage::fiBaseTokenizer::Reset
rage::fiBaseTokenizer::S
rage::fiBaseTokenizer::SetNextCh
rage::fiBaseTokenizer::SetStreamPosition
rage::fiBaseTokenizer::SetTerminators
rage::fiBaseTokenizer::SetWriteState
rage::fiBaseTokenizer::SkipComment
rage::fiBaseTokenizer::SkipToEndOfLine
rage::fiBaseTokenizer::StartBlock
rage::fiBaseTokenizer::StartLine
rage::fiBinTokenizer
rage::fiBinTokenizer::GetByte
rage::fiBinTokenizer::GetDelimiter
rage::fiBinTokenizer::GetFloat
rage::fiBinTokenizer::GetInt
rage::fiBinTokenizer::GetShort
rage::fiBinTokenizer::GetVector
rage::fiBinTokenizer::IsBinary
rage::fiBinTokenizer::MatchFloat
rage::fiBinTokenizer::MatchIFloat
rage::fiBinTokenizer::MatchIInt
rage::fiBinTokenizer::MatchInt
rage::fiBinTokenizer::MatchIVector
rage::fiBinTokenizer::MatchVector
rage::fiBinTokenizer::Put
rage::fiBinTokenizer::PutByte
rage::fiBinTokenizer::PutDelimiter
rage::fiBinTokenizer::PutShort
rage::fiCachedDevice
rage::fiCachedDevice::Close
rage::fiCachedDevice::CloseBulk
rage::fiCachedDevice::Create
rage::fiCachedDevice::GetBlockPhysicalSortKey
rage::fiCachedDevice::GetDebugName
rage::fiCachedDevice::GetFileSize
rage::fiCachedDevice::GetFileTime
rage::fiCachedDevice::Open
rage::fiCachedDevice::OpenBulk
rage::fiCachedDevice::Prefetch
rage::fiCachedDevice::Read
rage::fiCachedDevice::ReadBulk
rage::fiCachedDevice::Seek
rage::fiCachedDevice::Seek64
rage::fiCachedDevice::SetFileTime
rage::fiCachedDevice::Write
rage::fiCachePartition
rage::fiCachePartition::GetCachePrefix
rage::fiCachePartition::Init
rage::fiCachePartition::IsAvailable
rage::fiCachePartition::Reset
rage::fiCachePartition::Shutdown
rage::fiCollection
rage::fiCollection::ArchiveMask
rage::fiCollection::ArchiveShift
rage::fiCollection::EntryMask
rage::fiCollection::fiCollection
rage::fiCollection::GetBasePhysicalSortKey
rage::fiCollection::GetCollection
rage::fiCollection::GetCollectionIndex
rage::fiCollection::GetEntryFullName
rage::fiCollection::GetEntryIndex
rage::fiCollection::GetEntryInfo
rage::fiCollection::GetEntryName
rage::fiCollection::GetEntryPhysicalSortKey
rage::fiCollection::IsPackfile
rage::fiCollection::IsStreaming
rage::fiCollection::m_isStreaming
rage::fiCollection::MakeHandle
rage::fiCollection::OpenBulkFromHandle
rage::fiCollection::Prefetch
rage::fiCollection::SetStreaming
rage::fiCollection::Shutdown
rage::fiCollection::sm_Collections
rage::fiCompress
rage::fiCompress function
rage::fiCompressionData
rage::fiCompressionData::~fiCompressionData
rage::fiCompressionData::BuildHeader
rage::fiCompressionData::Compress
rage::fiCompressionData::CreateNewInstance
rage::fiCompressionData::Decompress
rage::fiCompressionData::fiCompressionData
rage::fiCompressionData::GetCompressUpperBound
rage::fiCompressionData::GetHeaderPrefix
rage::fiCompressionData::GetHeaderSize
rage::fiCompressionData::GetStaticHeaderPrefix
rage::fiCompressionData::ParseHeader
rage::fiCompressUpperBound
rage::fiCompressUpperBound function
rage::fiDecompress
rage::fiDecompress function
rage::fiDevice
rage::fiDevice::~fiDevice
rage::fiDevice::Close
rage::fiDevice::CloseBulk
rage::fiDevice::ConvertFileTimeToSystemTime
rage::fiDevice::CopyDirectory
rage::fiDevice::CopySingleFile
rage::fiDevice::Create
rage::fiDevice::CreateBulk
rage::fiDevice::DefaultGetDevice
rage::fiDevice::Delete
rage::fiDevice::DeleteDirectory
rage::fiDevice::eFindFileOptions
rage::fiDevice::eFindFileOptions enumeration
rage::fiDevice::fiDevice
rage::fiDevice::FindFile
rage::fiDevice::FindFileBegin
rage::fiDevice::FindFileEnd
rage::fiDevice::FindFileNext
rage::fiDevice::FixRelativeName
rage::fiDevice::Flush
rage::fiDevice::GetAttributes
rage::fiDevice::GetBulkOffset
rage::fiDevice::GetDebugName
rage::fiDevice::GetDevice
rage::fiDevice::GetFileSize
rage::fiDevice::GetFileTime
rage::fiDevice::GetLocalSystemTime
rage::fiDevice::GetLowLevelDevice
rage::fiDevice::GetPackfileIndex
rage::fiDevice::GetPhysicalSortKey
rage::fiDevice::GetResourceInfo
rage::fiDevice::GetRpfDevice
rage::fiDevice::HARDDRIVE_LSN
rage::fiDevice::InitClass
rage::fiDevice::IsCloud
rage::fiDevice::IsOutOfDate
rage::fiDevice::IsRpf
rage::fiDevice::LAYER1_LSN
rage::fiDevice::Lock
rage::fiDevice::MakeDirectory
rage::fiDevice::MakeGrowBufferFileName
rage::fiDevice::MakeMemoryFileName
rage::fiDevice::Mount
rage::fiDevice::Normalize
rage::fiDevice::Open
rage::fiDevice::OpenBulk
rage::fiDevice::OpenBulkDrm
rage::fiDevice::PrefetchDir
rage::fiDevice::Read
rage::fiDevice::ReadBulk
rage::fiDevice::Remount
rage::fiDevice::Rename
rage::fiDevice::SafeRead
rage::fiDevice::SafeWrite
rage::fiDevice::Seek
rage::fiDevice::Seek64
rage::fiDevice::SetAttributes
rage::fiDevice::SetDeviceProfiler
rage::fiDevice::SetEndOfFile
rage::fiDevice::SetFileTime
rage::fiDevice::SetFindNewest
rage::fiDevice::SetMaxMounts
rage::fiDevice::Size
rage::fiDevice::Size64
rage::fiDevice::sm_DeviceProfiler
rage::fiDevice::sm_FatalReadError
rage::fiDevice::sm_InjectReadError
rage::fiDevice::SystemTime
rage::fiDevice::SystemTime struct
rage::fiDevice::Unlock
rage::fiDevice::UnmakeDirectory
rage::fiDevice::Unmount
rage::fiDevice::Write
rage::fiDevice::WriteBulk
rage::fiDeviceCount
rage::fiDeviceCount::Close
rage::fiDeviceCount::Create
rage::fiDeviceCount::GetDebugName
rage::fiDeviceCount::GetFileTime
rage::fiDeviceCount::GetInstance
rage::fiDeviceCount::Open
rage::fiDeviceCount::Read
rage::fiDeviceCount::Seek
rage::fiDeviceCount::Seek64
rage::fiDeviceCount::SetFileTime
rage::fiDeviceCount::Size
rage::fiDeviceCount::Size64
rage::fiDeviceCount::Write
rage::fiDeviceGrowBuffer
rage::fiDeviceGrowBuffer::Close
rage::fiDeviceGrowBuffer::CloseBulk
rage::fiDeviceGrowBuffer::Create
rage::fiDeviceGrowBuffer::GetAttributes
rage::fiDeviceGrowBuffer::GetDebugName
rage::fiDeviceGrowBuffer::GetFileSize
rage::fiDeviceGrowBuffer::GetFileTime
rage::fiDeviceGrowBuffer::GetInstance
rage::fiDeviceGrowBuffer::Open
rage::fiDeviceGrowBuffer::OpenBulk
rage::fiDeviceGrowBuffer::Read
rage::fiDeviceGrowBuffer::ReadBulk
rage::fiDeviceGrowBuffer::SafeRead
rage::fiDeviceGrowBuffer::SafeWrite
rage::fiDeviceGrowBuffer::Seek
rage::fiDeviceGrowBuffer::Seek64
rage::fiDeviceGrowBuffer::SetFileTime
rage::fiDeviceGrowBuffer::Write
rage::fiDeviceInstaller
rage::fiDeviceInstaller::~fiDeviceInstaller
rage::fiDeviceInstaller::Close
rage::fiDeviceInstaller::CloseBulk
rage::fiDeviceInstaller::CopyContentInfoFile
rage::fiDeviceInstaller::Create
rage::fiDeviceInstaller::Delete
rage::fiDeviceInstaller::DoFileSizesMatch
rage::fiDeviceInstaller::DoTimestampsMatch
rage::fiDeviceInstaller::fiDeviceInstaller
rage::fiDeviceInstaller::FindFileBegin
rage::fiDeviceInstaller::FindFileEnd
rage::fiDeviceInstaller::FindFileNext
rage::fiDeviceInstaller::FinishInstall
rage::fiDeviceInstaller::FixName
rage::fiDeviceInstaller::FlagInstalledRpfs
rage::fiDeviceInstaller::GetAttributes
rage::fiDeviceInstaller::GetBulkOffset
rage::fiDeviceInstaller::GetDebugName
rage::fiDeviceInstaller::GetFileSize
rage::fiDeviceInstaller::GetFileTime
rage::fiDeviceInstaller::GetInstallName
rage::fiDeviceInstaller::GetInstallProgress
rage::fiDeviceInstaller::GetInstallStatus
rage::fiDeviceInstaller::GetIsBootedFromHdd
rage::fiDeviceInstaller::GetPackFileSize
rage::fiDeviceInstaller::GetPartitionName
rage::fiDeviceInstaller::GetPhysicalSortKey
rage::fiDeviceInstaller::GetResourceInfo
rage::fiDeviceInstaller::GetRpfDevice
rage::fiDeviceInstaller::HddFile
rage::fiDeviceInstaller::HddFile struct
rage::fiDeviceInstaller::Init
rage::fiDeviceInstaller::InitData
rage::fiDeviceInstaller::InitData struct
rage::fiDeviceInstaller::InitDataList
rage::fiDeviceInstaller::InitDataList struct
rage::fiDeviceInstaller::InitInstall
rage::fiDeviceInstaller::InitPartitionDevice
rage::fiDeviceInstaller::InstallerThread
rage::fiDeviceInstaller::InstallFile
rage::fiDeviceInstaller::InstallFile struct
rage::fiDeviceInstaller::InstallProgress
rage::fiDeviceInstaller::IsPartitionPath
rage::fiDeviceInstaller::IsRpf
rage::fiDeviceInstaller::IsTargetDeviceValid
rage::fiDeviceInstaller::MakeDirectory
rage::fiDeviceInstaller::MountAs
rage::fiDeviceInstaller::Open
rage::fiDeviceInstaller::OpenBulk
rage::fiDeviceInstaller::PauseDiscRead
rage::fiDeviceInstaller::Read
rage::fiDeviceInstaller::ReadBulk
rage::fiDeviceInstaller::ReadInstallFile
rage::fiDeviceInstaller::RegisterFileDoneCallback
rage::fiDeviceInstaller::Rename
rage::fiDeviceInstaller::ResumeDiscRead
rage::fiDeviceInstaller::ScheduleFile
rage::fiDeviceInstaller::Seek
rage::fiDeviceInstaller::Seek64
rage::fiDeviceInstaller::SetAsync
rage::fiDeviceInstaller::SetAttributes
rage::fiDeviceInstaller::SetEndOfFile
rage::fiDeviceInstaller::SetFileTime
rage::fiDeviceInstaller::SetIsBootedFromHdd
rage::fiDeviceInstaller::SetKeepaliveCallback
rage::fiDeviceInstaller::StartInstall
rage::fiDeviceInstaller::StorePackageTimestamp
rage::fiDeviceInstaller::StripPath
rage::fiDeviceInstaller::UnmakeDirectory
rage::fiDeviceInstaller::Write
rage::fiDeviceInstaller::WriteInstallFile
rage::fiDeviceLocal
rage::fiDeviceLocal::Close
rage::fiDeviceLocal::CloseBulk
rage::fiDeviceLocal::Create
rage::fiDeviceLocal::CreateBulk
rage::fiDeviceLocal::Delete
rage::fiDeviceLocal::FindFileBegin
rage::fiDeviceLocal::FindFileEnd
rage::fiDeviceLocal::FindFileNext
rage::fiDeviceLocal::FixName
rage::fiDeviceLocal::GetAttributes
rage::fiDeviceLocal::GetDebugName
rage::fiDeviceLocal::GetFileSize
rage::fiDeviceLocal::GetFileTime
rage::fiDeviceLocal::GetInstance
rage::fiDeviceLocal::GetPhysicalSortKey
rage::fiDeviceLocal::MakeDirectory
rage::fiDeviceLocal::OnDiscSwap
rage::fiDeviceLocal::Open
rage::fiDeviceLocal::OpenBulk
rage::fiDeviceLocal::Read
rage::fiDeviceLocal::ReadBulk
rage::fiDeviceLocal::Rename
rage::fiDeviceLocal::Seek
rage::fiDeviceLocal::Seek64
rage::fiDeviceLocal::SetAttributes
rage::fiDeviceLocal::SetEndOfFile
rage::fiDeviceLocal::SetFileTime
rage::fiDeviceLocal::UnmakeDirectory
rage::fiDeviceLocal::Write
rage::fiDeviceLocal::WriteBulk
rage::fiDeviceLocalDrm
rage::fiDeviceLocalDrm::OpenBulkDrm
rage::fiDeviceMemory
rage::fiDeviceMemory::Close
rage::fiDeviceMemory::CloseBulk
rage::fiDeviceMemory::Create
rage::fiDeviceMemory::GetAttributes
rage::fiDeviceMemory::GetDebugName
rage::fiDeviceMemory::GetFileSize
rage::fiDeviceMemory::GetFileTime
rage::fiDeviceMemory::GetInstance
rage::fiDeviceMemory::Open
rage::fiDeviceMemory::OpenBulk
rage::fiDeviceMemory::Read
rage::fiDeviceMemory::ReadBulk
rage::fiDeviceMemory::SafeRead
rage::fiDeviceMemory::SafeWrite
rage::fiDeviceMemory::Seek
rage::fiDeviceMemory::Seek64
rage::fiDeviceMemory::SetFileTime
rage::fiDeviceMemory::Write
rage::fiDeviceProfiler
rage::fiDeviceProfiler::~fiDeviceProfiler
rage::fiDeviceProfiler::OnClose
rage::fiDeviceProfiler::OnOpen
rage::fiDeviceProfiler::OnRead
rage::fiDeviceProfiler::OnReadEnd
rage::fiDeviceProfiler::OnSeek
rage::fiDeviceProfiler::OnWrite
rage::fiDeviceRelative
rage::fiDeviceRelative::~fiDeviceRelative
rage::fiDeviceRelative::Close
rage::fiDeviceRelative::CloseBulk
rage::fiDeviceRelative::Create
rage::fiDeviceRelative::Delete
rage::fiDeviceRelative::fiDeviceRelative
rage::fiDeviceRelative::FindFileBegin
rage::fiDeviceRelative::FindFileEnd
rage::fiDeviceRelative::FindFileNext
rage::fiDeviceRelative::FixName
rage::fiDeviceRelative::FixRelativeName
rage::fiDeviceRelative::GetAttributes
rage::fiDeviceRelative::GetBulkOffset
rage::fiDeviceRelative::GetDebugName
rage::fiDeviceRelative::GetFileSize
rage::fiDeviceRelative::GetFileTime
rage::fiDeviceRelative::GetLowLevelDevice
rage::fiDeviceRelative::GetPhysicalSortKey
rage::fiDeviceRelative::GetResourceInfo
rage::fiDeviceRelative::Init
rage::fiDeviceRelative::m_pDevice
rage::fiDeviceRelative::MakeDirectory
rage::fiDeviceRelative::MountAs
rage::fiDeviceRelative::Open
rage::fiDeviceRelative::OpenBulk
rage::fiDeviceRelative::OpenBulkDrm
rage::fiDeviceRelative::PrefetchDir
rage::fiDeviceRelative::Read
rage::fiDeviceRelative::ReadBulk
rage::fiDeviceRelative::Rename
rage::fiDeviceRelative::Seek
rage::fiDeviceRelative::Seek64
rage::fiDeviceRelative::SetAttributes
rage::fiDeviceRelative::SetEndOfFile
rage::fiDeviceRelative::SetFileTime
rage::fiDeviceRelative::UnmakeDirectory
rage::fiDeviceRelative::Write
rage::fiDeviceRemote
rage::fiDeviceRemote::Close
rage::fiDeviceRemote::CloseBulk
rage::fiDeviceRemote::Create
rage::fiDeviceRemote::Delete
rage::fiDeviceRemote::DeleteDirectory
rage::fiDeviceRemote::FindFileBegin
rage::fiDeviceRemote::FindFileEnd
rage::fiDeviceRemote::FindFileNext
rage::fiDeviceRemote::GetAttributes
rage::fiDeviceRemote::GetAttributesDir
rage::fiDeviceRemote::GetAverageThroughput
rage::fiDeviceRemote::GetDebugName
rage::fiDeviceRemote::GetFileCount
rage::fiDeviceRemote::GetFileSize
rage::fiDeviceRemote::GetFileTime
rage::fiDeviceRemote::GetInstance
rage::fiDeviceRemote::GetResourceInfo
rage::fiDeviceRemote::InitClass
rage::fiDeviceRemote::InvalidateDirectoryCache
rage::fiDeviceRemote::MakeDirectory
rage::fiDeviceRemote::Open
rage::fiDeviceRemote::OpenBulk
rage::fiDeviceRemote::PrefetchDir
rage::fiDeviceRemote::Read
rage::fiDeviceRemote::ReadBulk
rage::fiDeviceRemote::Seek
rage::fiDeviceRemote::Seek64
rage::fiDeviceRemote::SetAttributes
rage::fiDeviceRemote::SetFileTime
rage::fiDeviceRemote::ShutdownClass
rage::fiDeviceRemote::Write
rage::fiDeviceTcpIp
rage::fiDeviceTcpIp::~fiDeviceTcpIp
rage::fiDeviceTcpIp::Close
rage::fiDeviceTcpIp::Connect
rage::fiDeviceTcpIp::Create
rage::fiDeviceTcpIp::fiDeviceTcpIp
rage::fiDeviceTcpIp::GetDebugName
rage::fiDeviceTcpIp::GetFileTime
rage::fiDeviceTcpIp::GetInstance
rage::fiDeviceTcpIp::GetLastError
rage::fiDeviceTcpIp::GetLocalHost
rage::fiDeviceTcpIp::GetReadCount
rage::fiDeviceTcpIp::InitClass
rage::fiDeviceTcpIp::Listen
rage::fiDeviceTcpIp::Open
rage::fiDeviceTcpIp::Pickup
rage::fiDeviceTcpIp::PrintInterfaceState
rage::fiDeviceTcpIp::PrintNetStats
rage::fiDeviceTcpIp::Read
rage::fiDeviceTcpIp::Seek
rage::fiDeviceTcpIp::Seek64
rage::fiDeviceTcpIp::SetBlocking
rage::fiDeviceTcpIp::SetFileTime
rage::fiDeviceTcpIp::SetLastError
rage::fiDeviceTcpIp::SetLocalHost
rage::fiDeviceTcpIp::ShutdownClass
rage::fiDeviceTcpIp::StaticWrite
rage::fiDeviceTcpIp::WaitForNetworkReady
rage::fiDeviceTcpIp::Write
rage::fiDeviceXContent
rage::fiDeviceXContent::~fiDeviceXContent
rage::fiDeviceXContent::fiDeviceXContent
rage::fiDeviceXContent::Init
rage::fiDeviceXContent::MountAs
rage::fiDeviceXContent::Shutdown
rage::fiDiskCache
rage::fiDiskCache::GetCachedDevice
rage::fiDiskCache::GetCacheInProgress
rage::fiDiskCache::GetCacheOccupancy
rage::fiDiskCache::GetHoldoffTime
rage::fiDiskCache::GetLastCacheCopyCompletion
rage::fiDiskCache::InitClass
rage::fiDiskCache::IsCacheCopying
rage::fiDiskCache::IsCacheEnabled
rage::fiDiskCache::IsCachePrimed
rage::fiDiskCache::LeaveBootMode
rage::fiDiskCache::SetHoldoffTime
rage::fiDiskCache::ShutdownClass
rage::fiEmbeddedFile
rage::fiEmbeddedFile::fiEmbeddedFile
rage::fiEmbeddedFile::Lookup
rage::fiFindData
rage::fiFindData struct
rage::fiFtpServer
rage::fiFtpServer function
rage::fiGetFramesSinceLastMessageBox
rage::fiGetFramesSinceLastMessageBox function
rage::fiIsShowingMessageBox
rage::fiIsShowingMessageBox variable
rage::fiLaunchFtpServerThread
rage::fiLaunchFtpServerThread function
rage::File
rage::File struct
rage::FILE_ATTRIBUTE_ARCHIVE
rage::FILE_ATTRIBUTE_ARCHIVE macro
rage::FILE_ATTRIBUTE_COMPRESSED
rage::FILE_ATTRIBUTE_COMPRESSED macro
rage::FILE_ATTRIBUTE_DIRECTORY
rage::FILE_ATTRIBUTE_DIRECTORY macro
rage::FILE_ATTRIBUTE_HIDDEN
rage::FILE_ATTRIBUTE_HIDDEN macro
rage::FILE_ATTRIBUTE_INVALID
rage::FILE_ATTRIBUTE_INVALID macro
rage::FILE_ATTRIBUTE_NORMAL
rage::FILE_ATTRIBUTE_NORMAL macro
rage::FILE_ATTRIBUTE_NOT_CONTENT_INDEXED
rage::FILE_ATTRIBUTE_NOT_CONTENT_INDEXED macro
rage::FILE_ATTRIBUTE_OFFLINE
rage::FILE_ATTRIBUTE_OFFLINE macro
rage::FILE_ATTRIBUTE_READONLY
rage::FILE_ATTRIBUTE_READONLY macro
rage::FILE_ATTRIBUTE_REPARSE_POINT
rage::FILE_ATTRIBUTE_REPARSE_POINT macro
rage::FILE_ATTRIBUTE_SPARSE_FILE
rage::FILE_ATTRIBUTE_SPARSE_FILE macro
rage::FILE_ATTRIBUTE_SYSTEM
rage::FILE_ATTRIBUTE_SYSTEM macro
rage::FILE_ATTRIBUTE_TEMPORARY
rage::FILE_ATTRIBUTE_TEMPORARY macro
rage::FileName
rage::FileName variable
rage::FILETIME_2000
rage::FILETIME_2000 variable
rage::fiMultiTokenizer
rage::fiMultiTokenizer::fiMultiTokenizer
rage::fiMultiTokenizer::GetReadTokenizer
rage::fiMultiTokenizer::GetWriteTokenizer
rage::fiPackEntry
rage::fiPackEntry::DECLARE_BITFIELD_4
rage::fiPackEntry::FileOffset_IsDir
rage::fiPackEntry::FileOffset_Shift
rage::fiPackEntry::GetConsumedSize
rage::fiPackEntry::GetFileOffset
rage::fiPackEntry::GetUncompressedSize
rage::fiPackEntry::GetVersion
rage::fiPackEntry::IsCompressed
rage::fiPackEntry::IsDir
rage::fiPackEntry::IsFile
rage::fiPackEntry::IsResource
rage::fiPackEntry::MaxConsumedSize
rage::fiPackEntry::SetFileOffset
rage::fiPackEntry::u
rage::fiPackfile
rage::fiPackfile::~fiPackfile
rage::fiPackfile::CacheMode
rage::fiPackfile::CacheMode enumeration
rage::fiPackfile::ClearRelativeOffset
rage::fiPackfile::Close
rage::fiPackfile::CloseBulk
rage::fiPackfile::Create
rage::fiPackfile::ExtractFileToMemory
rage::fiPackfile::FillData
rage::fiPackfile::FillParentIndices
rage::fiPackfile::FindEntry
rage::fiPackfile::FindFileBegin
rage::fiPackfile::FindFileEnd
rage::fiPackfile::FindFileNext
rage::fiPackfile::fiPackfile
rage::fiPackfile::GetAttributes
rage::fiPackfile::GetBasePhysicalSortKey
rage::fiPackfile::GetBulkOffset
rage::fiPackfile::GetDebugName
rage::fiPackfile::GetEntries
rage::fiPackfile::GetEntryCount
rage::fiPackfile::GetEntryFullName
rage::fiPackfile::GetEntryIndex
rage::fiPackfile::GetEntryInfo
rage::fiPackfile::GetEntryName
rage::fiPackfile::GetEntryPhysicalSortKey
rage::fiPackfile::GetFileSize
rage::fiPackfile::GetFileTime
rage::fiPackfile::GetHeaderSize
rage::fiPackfile::GetNameHeap
rage::fiPackfile::GetNameShift
rage::fiPackfile::GetPackfileHandle
rage::fiPackfile::GetPackfileIndex
rage::fiPackfile::GetPackfileSize
rage::fiPackfile::GetPackfileTime
rage::fiPackfile::GetPhysicalSortKey
rage::fiPackfile::GetRelativeOffset
rage::fiPackfile::GetResourceInfo
rage::fiPackfile::Init
rage::fiPackfile::InitFromImg
rage::fiPackfile::InitFromZip
rage::fiPackfile::IsInitialized
rage::fiPackfile::IsPackfile
rage::fiPackfile::IsRpf
rage::fiPackfile::IsUserHeader
rage::fiPackfile::m_ArchiveBias
rage::fiPackfile::m_ArchiveSize
rage::fiPackfile::m_CachedDataSize
rage::fiPackfile::m_CachedMetaDataSize
rage::fiPackfile::m_Device
rage::fiPackfile::m_Entries
rage::fiPackfile::m_EntryCount
rage::fiPackfile::m_FileTime
rage::fiPackfile::m_Fullname
rage::fiPackfile::m_Handle
rage::fiPackfile::m_IsByteSwapped
rage::fiPackfile::m_IsCached
rage::fiPackfile::m_IsInstalled
rage::fiPackfile::m_IsRpf
rage::fiPackfile::m_IsUserHeader
rage::fiPackfile::m_IsXCompressed
rage::fiPackfile::m_KeyId
rage::fiPackfile::m_MemoryBuffer
rage::fiPackfile::m_Name
rage::fiPackfile::m_NameHeap
rage::fiPackfile::m_NameHeapInDebugHeap
rage::fiPackfile::m_NameShift
rage::fiPackfile::m_ParentIndices
rage::fiPackfile::m_pDrmKey
rage::fiPackfile::m_RelativeOffset
rage::fiPackfile::m_SelfIndex
rage::fiPackfile::m_SortKey
rage::fiPackfile::MountAs
rage::fiPackfile::Open
rage::fiPackfile::OpenBulk
rage::fiPackfile::OpenBulkFromHandle
rage::fiPackfile::OpenDirect
rage::fiPackfile::OpenInternal
rage::fiPackfile::ParentIndexType
rage::fiPackfile::Prefetch
rage::fiPackfile::Read
rage::fiPackfile::ReadBulk
rage::fiPackfile::ReadInternal
rage::fiPackfile::ReadInternalBulk
rage::fiPackfile::ReInit
rage::fiPackfile::RemountDependentPackfiles
rage::fiPackfile::Seek
rage::fiPackfile::Seek64
rage::fiPackfile::SetDrmKey
rage::fiPackfile::SetFileTime
rage::fiPackfile::SetpackfileHandle
rage::fiPackfile::SetPackfileTime
rage::fiPackfile::SetReadAheadCacheCPU
rage::fiPackfile::SetRelativePath
rage::fiPackfile::Shutdown
rage::fiPackfile::Size
rage::fiPackfile::Size64
rage::fiPackfile::UnInit
rage::fiPackfile::Write
rage::fiPackfileState
rage::fiPackfileState::avail_in
rage::fiPackfileState::BufferSize
rage::fiPackfileState::fiPackfileState
rage::fiPackfileState::IsCompressed
rage::fiPackfileState::m_Buffer
rage::fiPackfileState::m_CompOffset
rage::fiPackfileState::m_DebugName
rage::fiPackfileState::m_Entry
rage::fiPackfileState::m_Offset
rage::fiPackfileState::m_xStream
rage::fiPackfileState::m_zStream
rage::fiPackfileState::next_in
rage::fiPackfileState::Reset
rage::fiPackHeader
rage::fiPackHeader struct
rage::fiRemoteDirEntry
rage::fiRemoteDirEntry struct
rage::fiRemoteExec
rage::fiRemoteExec function
rage::fiRemoteGetEnv
rage::fiRemoteGetEnv function
rage::fiRemoteResetFiles
rage::fiRemoteResetFiles function
rage::fiRemoteServer
rage::fiRemoteServer function
rage::fiRemoteServerIsRunning
rage::fiRemoteServerIsRunning variable
rage::fiRemoteShowAssertMessageBox
rage::fiRemoteShowAssertMessageBox function
rage::fiRemoteShowMessageBox
rage::fiRemoteShowMessageBox function
rage::fiRemoteTty
rage::fiRemoteTty function
rage::fiRpf7Builder
rage::fiRpf7Builder::~fiRpf7Builder
rage::fiRpf7Builder::AddData
rage::fiRpf7Builder::AddFile
rage::fiRpf7Builder::fiRpf7Builder
rage::fiRpf7Builder::Save
rage::fiRpf7Entry
rage::fiRpf7Entry::~fiRpf7Entry
rage::fiRpf7Entry::1
rage::fiRpf7Entry::Child
rage::fiRpf7Entry::DataSize
rage::fiRpf7Entry::fiRpf7Entry
rage::fiRpf7Entry::NameOffset
rage::fiRpf7Entry::Next
rage::fiRpf7Entry::SourceName
rage::fiSafeStream
rage::fiSafeStream::~fiSafeStream
rage::fiSafeStream::->
rage::fiSafeStream::fiSafeStream
rage::fiSafeStream::fiStream*
rage::fiSaveGame
rage::fiSaveGame::BeginContentVerify
rage::fiSaveGame::BeginDelete
rage::fiSaveGame::BeginDeleteFromList
rage::fiSaveGame::BeginEnumeration
rage::fiSaveGame::BeginExtraSpaceCheck
rage::fiSaveGame::BeginFreeSpaceCheck
rage::fiSaveGame::BeginGetCreator
rage::fiSaveGame::BeginGetFileModifiedTime
rage::fiSaveGame::BeginGetFileSize
rage::fiSaveGame::BeginIconSave
rage::fiSaveGame::BeginLoad
rage::fiSaveGame::BeginReadNamesAndSizesOfAllSaveGames
rage::fiSaveGame::BeginSave
rage::fiSaveGame::BeginSelectDevice
rage::fiSaveGame::CalculateDataSizeOnDisk
rage::fiSaveGame::CalculateSizeOfSaveGameFile
rage::fiSaveGame::CheckContentVerify
rage::fiSaveGame::CheckDelete
rage::fiSaveGame::CheckDeleteFromList
rage::fiSaveGame::CheckEnumeration
rage::fiSaveGame::CheckExtraSpaceCheck
rage::fiSaveGame::CheckFreeSpaceCheck
rage::fiSaveGame::CheckGetCreator
rage::fiSaveGame::CheckGetFileModifiedTime
rage::fiSaveGame::CheckGetFileSize
rage::fiSaveGame::CheckIconSave
rage::fiSaveGame::CheckLoad
rage::fiSaveGame::CheckReadNamesAndSizesOfAllSaveGames
rage::fiSaveGame::CheckSave
rage::fiSaveGame::CheckSelectDevice
rage::fiSaveGame::Content
rage::fiSaveGame::Content struct
rage::fiSaveGame::Device
rage::fiSaveGame::Device struct
rage::fiSaveGame::EndContentVerify
rage::fiSaveGame::EndDelete
rage::fiSaveGame::EndDeleteFromList
rage::fiSaveGame::EndEnumeration
rage::fiSaveGame::EndExtraSpaceCheck
rage::fiSaveGame::EndFreeSpaceCheck
rage::fiSaveGame::EndGetCreator
rage::fiSaveGame::EndGetFileModifiedTime
rage::fiSaveGame::EndGetFileSize
rage::fiSaveGame::EndIconSave
rage::fiSaveGame::EndLoad
rage::fiSaveGame::EndReadNamesAndSizesOfAllSaveGames
rage::fiSaveGame::EndSave
rage::fiSaveGame::EndSelectDevice
rage::fiSaveGame::Errors
rage::fiSaveGame::Errors enumeration
rage::fiSaveGame::FillDevice
rage::fiSaveGame::GetCurrentDeviceData
rage::fiSaveGame::GetDeviceData
rage::fiSaveGame::GetError
rage::fiSaveGame::GetMaxUsers
rage::fiSaveGame::GetSelectedDevice
rage::fiSaveGame::GetState
rage::fiSaveGame::GetTotalAvailableSpace
rage::fiSaveGame::HasFileBeenAccessed
rage::fiSaveGame::InitClass
rage::fiSaveGame::IsCurrentDeviceValid
rage::fiSaveGame::IsDeviceValid
rage::fiSaveGame::IsStorageDeviceChanged
rage::fiSaveGame::IsStorageDeviceRemoved
rage::fiSaveGame::SetCheckForUserBindErrors
rage::fiSaveGame::SetIcon
rage::fiSaveGame::SetMaxNumberOfSaveGameFilesToEnumerate
rage::fiSaveGame::SetMountIndex
rage::fiSaveGame::SetSaveGameFolder
rage::fiSaveGame::SetSaveGameTitle
rage::fiSaveGame::SetSelectedDevice
rage::fiSaveGame::SetSelectedDeviceToAny
rage::fiSaveGame::SetStateToIdle
rage::fiSaveGame::SetUserServiceId
rage::fiSaveGame::ShowDeleteDialog
rage::fiSaveGame::ShowLoadDialog
rage::fiSaveGame::ShowSaveDialog
rage::fiSaveGame::ShutdownClass
rage::fiSaveGame::SIGNIN_COUNT
rage::fiSaveGame::UpdateClass
rage::fiSaveGameState
rage::fiSaveGameState namespace
rage::fiSaveGameState::State
rage::fiSaveGameState::State enumeration
rage::fiSeekWhence
rage::fiSeekWhence enumeration
rage::fiSerialize
rage::fiSerialize::~fiSerialize
rage::fiSerialize::fiSerialize
rage::fiSerialize::Get
rage::fiSerialize::m_Stream
rage::fiSerialize::m_Token
rage::fiSerialize::m_Version
rage::fiSerialize::Put
rage::fiSerialize::Serialize
rage::fiStream
rage::fiStream::AllowBlockingLoads
rage::fiStream::AreBlockingLoadsAllowed
rage::fiStream::Close
rage::fiStream::CloseOpenFiles
rage::fiStream::CloseShared
rage::fiStream::Create
rage::fiStream::DumpOpenFiles
rage::fiStream::FastGetCh
rage::fiStream::FastPutCh
rage::fiStream::fdopen
rage::fiStream::Flush
rage::fiStream::GetCh
rage::fiStream::GetCloseCallback
rage::fiStream::GetCreateCallback
rage::fiStream::GetLocalHandle
rage::fiStream::GetName
rage::fiStream::GetOpenCallback
rage::fiStream::Open
rage::fiStream::OutputAllFileAccess
rage::fiStream::PreLoad
rage::fiStream::PutCh
rage::fiStream::Read
rage::fiStream::ReadByte
rage::fiStream::ReadFloat
rage::fiStream::ReadInt
rage::fiStream::ReadLong
rage::fiStream::ReadShort
rage::fiStream::ReadTChar
rage::fiStream::Seek
rage::fiStream::Seek64
rage::fiStream::SetCloseCallback
rage::fiStream::SetCreateCallback
rage::fiStream::SetFaultInjectionPath
rage::fiStream::SetOpenCallback
rage::fiStream::Size
rage::fiStream::Size64
rage::fiStream::Tell
rage::fiStream::Tell64
rage::fiStream::TellStart
rage::fiStream::Write
rage::fiStream::WriteByte
rage::fiStream::WriteFloat
rage::fiStream::WriteInt
rage::fiStream::WriteLong
rage::fiStream::WriteShort
rage::fiStream::WriteTChar
rage::fiTokenizer
rage::fiTokenizer::fiTokenizer
rage::fiZipfile
rage::fiZipfile::~fiZipfile
rage::fiZipfile::Close
rage::fiZipfile::CloseBulk
rage::fiZipfile::Create
rage::fiZipfile::FillData
rage::fiZipfile::FindEntry
rage::fiZipfile::FindFileBegin
rage::fiZipfile::FindFileEnd
rage::fiZipfile::FindFileNext
rage::fiZipfile::fiZipfile
rage::fiZipfile::GetAttributes
rage::fiZipfile::GetDebugName
rage::fiZipfile::GetFileSize
rage::fiZipfile::GetFileTime
rage::fiZipfile::Init
rage::fiZipfile::m_ArchiveBias
rage::fiZipfile::m_ArchiveSize
rage::fiZipfile::m_Device
rage::fiZipfile::m_Handle
rage::fiZipfile::m_Name
rage::fiZipfile::m_RelativeOffset
rage::fiZipfile::m_Root
rage::fiZipfile::MountAs
rage::fiZipfile::Open
rage::fiZipfile::OpenBulk
rage::fiZipfile::OpenInternal
rage::fiZipfile::Read
rage::fiZipfile::ReadBulk
rage::fiZipfile::ReadInternal
rage::fiZipfile::ReadInternalBulk
rage::fiZipfile::Seek
rage::fiZipfile::Seek64
rage::fiZipfile::SetFileTime
rage::fiZipfile::Size
rage::fiZipfile::Size64
rage::fiZipfile::Write
rage::fiZipfileState
rage::fiZipfileState::BufferSize
rage::fiZipfileState::fiZipfileState
rage::fiZipfileState::IsCompressed
rage::fiZipfileState::m_Buffer
rage::fiZipfileState::m_CompOffset
rage::fiZipfileState::m_DebugName
rage::fiZipfileState::m_Entry
rage::fiZipfileState::m_Offset
rage::fiZipfileState::m_zStream
rage::fiZipfileState::Reset
rage::FlushCacheHeader
rage::FlushCacheHeader function
rage::fprintf
rage::fprintf function
rage::fseek
rage::fseek function
rage::g_AES
rage::g_AES variable
rage::g_enumeratedContent
rage::g_enumeratedContent variable
rage::g_fiCaseSensitive
rage::g_fiCaseSensitive variable
rage::g_IsExiting
rage::g_IsExiting variable
rage::g_numContent
rage::g_numContent variable
rage::g_SaveGameState
rage::g_SaveGameState variable
rage::GetDisplayName
rage::GetDisplayName function
rage::GetSaveFilePath
rage::GetSaveFilePath function
rage::gExitThread
rage::gExitThread variable
rage::Header
rage::Header::CalculateHash
rage::Header::Clear
rage::Header::Export
rage::Header::FILE_VERSION
rage::Header::GetDisplayName
rage::Header::GetExpectedVersion
rage::Header::GetVersion
rage::Header::Header
rage::Header::Import
rage::Header::m_DisplayName
rage::Header::m_Hash
rage::Header::m_Version
rage::Header::MAX_BYTE_SIZEOF_PAYLOAD
rage::IDABORT
rage::IDABORT macro
rage::IDCANCEL
rage::IDCANCEL macro
rage::IDCONTINUE
rage::IDCONTINUE macro
rage::IDCUSTOM1
rage::IDCUSTOM1 macro
rage::IDCUSTOM2
rage::IDCUSTOM2 macro
rage::IDCUSTOM3
rage::IDCUSTOM3 macro
rage::IDCUSTOM4
rage::IDCUSTOM4 macro
rage::IDIGNORE
rage::IDIGNORE macro
rage::IDNO
rage::IDNO macro
rage::IDOK
rage::IDOK macro
rage::IDRETRY
rage::IDRETRY macro
rage::IDTRYAGAIN
rage::IDTRYAGAIN macro
rage::IDYES
rage::IDYES macro
rage::info_table
rage::info_table variable
rage::INSTALL_SLICE_NUM
rage::INSTALL_SLICE_NUM macro
rage::INSTALL_SLICE_SIZE
rage::INSTALL_SLICE_SIZE macro
rage::m_State
rage::m_State variable
rage::MakeNewest
rage::MakeNewest function
rage::MakeOldest
rage::MakeOldest function
rage::MAX_CHARS_IN_TITLE_ID_FOR_SAVES_FOLDER
rage::MAX_CHARS_IN_TITLE_ID_FOR_SAVES_FOLDER macro
rage::MAX_DEVICE_NAME_LENGTH
rage::MAX_DEVICE_NAME_LENGTH macro
rage::MAX_PARTITION_SIZE
rage::MAX_PARTITION_SIZE macro
rage::MAX_RPFS
rage::MAX_RPFS variable
rage::MAX_XCONTENT_HANDLES
rage::MAX_XCONTENT_HANDLES macro
rage::maxMem
rage::maxMem variable
rage::MaxPackfiles
rage::MaxPackfiles variable
rage::MB_ABORTRETRYIGNORE
rage::MB_ABORTRETRYIGNORE macro
rage::MB_APPLMODAL
rage::MB_APPLMODAL macro
rage::MB_CANCELTRYCONTINUE
rage::MB_CANCELTRYCONTINUE macro
rage::MB_DEFAULT_DESKTOP_ONLY
rage::MB_DEFAULT_DESKTOP_ONLY macro
rage::MB_DEFBUTTON1
rage::MB_DEFBUTTON1 macro
rage::MB_DEFBUTTON2
rage::MB_DEFBUTTON2 macro
rage::MB_DEFBUTTON3
rage::MB_DEFBUTTON3 macro
rage::MB_DEFBUTTON4
rage::MB_DEFBUTTON4 macro
rage::MB_HELP
rage::MB_HELP macro
rage::MB_ICONASTERISK
rage::MB_ICONASTERISK macro
rage::MB_ICONERROR
rage::MB_ICONERROR macro
rage::MB_ICONHAND
rage::MB_ICONHAND macro
rage::MB_ICONINFORMATION
rage::MB_ICONINFORMATION macro
rage::MB_ICONQUESTION
rage::MB_ICONQUESTION macro
rage::MB_NOFOCUS
rage::MB_NOFOCUS macro
rage::MB_OK
rage::MB_OK macro
rage::MB_OKCANCEL
rage::MB_OKCANCEL macro
rage::MB_RETRYCANCEL
rage::MB_RETRYCANCEL macro
rage::MB_RIGHT
rage::MB_RIGHT macro
rage::MB_SETFOREGROUND
rage::MB_SETFOREGROUND macro
rage::MB_SYSTEMMODAL
rage::MB_SYSTEMMODAL macro
rage::MB_TASKMODAL
rage::MB_TASKMODAL macro
rage::MB_TOPMOST
rage::MB_TOPMOST macro
rage::MB_YESNO
rage::MB_YESNO macro
rage::MB_YESNOCANCEL
rage::MB_YESNOCANCEL macro
rage::messageToken
rage::messageToken variable
rage::Mount_t
rage::Mount_t::Device
rage::Mount_t::Mount_t
rage::Mount_t::Path
rage::Mount_t::PathLen
rage::Mount_t::ReadOnly
rage::MsDosDate
rage::MsDosDate::DECLARE_BITFIELD_3
rage::MsDosTime
rage::MsDosTime::DECLARE_BITFIELD_3
rage::MULTIPLE_CACHE_FILES
rage::MULTIPLE_CACHE_FILES macro
rage::nameheap
rage::nameheap variable
rage::nameshift
rage::nameshift variable
rage::NO_FILES_EXIST_CODE
rage::NO_FILES_EXIST_CODE macro
rage::node
rage::node struct
rage::NOSTRIP_PARAM
rage::NOSTRIP_PARAM function
rage::NOSTRIP_XPARAM
rage::NOSTRIP_XPARAM function
rage::pgStreamingLog
rage::pgStreamingLog variable
rage::pgStreamingLogToken
rage::pgStreamingLogToken variable
rage::pIconImage
rage::pIconImage variable
rage::PS3_FILE_HANDLE_HACK
rage::PS3_FILE_HANDLE_HACK macro
rage::Quitf
rage::Quitf function
rage::RAGE_MAX_PATH
rage::RAGE_MAX_PATH variable
rage::READ_PROGRESS_WATCHDOG
rage::READ_PROGRESS_WATCHDOG macro
rage::READ_PROGRESS_WATCHDOG_ERROR_LIMIT_SECONDS
rage::READ_PROGRESS_WATCHDOG_ERROR_LIMIT_SECONDS macro
rage::REPLAY_SAVE_FILENAME
rage::REPLAY_SAVE_FILENAME macro
rage::ResetCache
rage::ResetCache function
rage::s_bCalculateSizeOnDisk
rage::s_bCalculateSizeOnDisk variable
rage::s_bCheckForUserBindErrors
rage::s_bCheckForUserBindErrors variable
rage::s_bCheckingForFreeSpace
rage::s_bCheckingForFreeSpace variable
rage::s_bFileMissing
rage::s_bFileMissing variable
rage::s_bHasCreator
rage::s_bHasCreator variable
rage::s_bIsCreator
rage::s_bIsCreator variable
rage::s_CacheBlockFiles
rage::s_CacheBlockFiles variable
rage::s_CachedDevices
rage::s_CachedDevices variable
rage::s_CacheFile
rage::s_CacheFile variable
rage::s_CachePath
rage::s_CachePath variable
rage::s_CacheWorkerThread
rage::s_CacheWorkerThread variable
rage::s_Container
rage::s_Container variable
rage::s_Content
rage::s_Content variable
rage::s_ContentMax
rage::s_ContentMax variable
rage::s_count
rage::s_count variable
rage::s_Counts
rage::s_Counts variable
rage::s_Data
rage::s_Data variable
rage::s_DataSize
rage::s_DataSize variable
rage::s_DefaultDevice
rage::s_DefaultDevice variable
rage::s_DefaultDeviceReadOnly
rage::s_DefaultDeviceReadOnly variable
rage::s_Device
rage::s_Device variable
rage::s_DeviceCount
rage::s_DeviceCount variable
rage::s_DeviceGrowBuffer
rage::s_DeviceGrowBuffer variable
rage::s_DeviceLocal
rage::s_DeviceLocal variable
rage::s_DeviceMemory
rage::s_DeviceMemory variable
rage::s_DeviceUpdateDebug
rage::s_DeviceUpdateDebug variable
rage::s_DirName
rage::s_DirName variable
rage::s_DisplayName
rage::s_DisplayName variable
rage::s_Done
rage::s_Done variable
rage::s_DummyProfiler
rage::s_DummyProfiler variable
rage::s_EnumCount
rage::s_EnumCount variable
rage::s_eSaveProcessToPerform
rage::s_eSaveProcessToPerform variable
rage::s_FileExists
rage::s_FileExists variable
rage::s_FilenameBuf
rage::s_FilenameBuf variable
rage::s_FileProgress
rage::s_FileProgress variable
rage::s_Files
rage::s_Files macro
rage::s_fileSize
rage::s_FileSize
rage::s_fileSize variable
rage::s_FileSize variable
rage::s_filetime
rage::s_filetime variable
rage::s_Handle
rage::s_Handle variable
rage::s_hddFreeSizeKB
rage::s_hddFreeSizeKB variable
rage::s_Header
rage::s_Header variable
rage::s_Header_CritSec
rage::s_Header_CritSec variable
rage::s_HoldoffDelta
rage::s_HoldoffDelta variable
rage::s_HoldoffTime
rage::s_HoldoffTime variable
rage::s_IsCachePrimed
rage::s_IsCachePrimed variable
rage::s_IsValid
rage::s_IsValid variable
rage::s_LastError
rage::s_LastError variable
rage::s_lastErrorCode
rage::s_lastErrorCode variable
rage::s_LastThreadOwner
rage::s_LastThreadOwner variable
rage::s_Loads
rage::s_Loads variable
rage::s_LocalHost
rage::s_LocalHost variable
rage::s_location
rage::s_location variable
rage::s_Magic
rage::s_Magic macro
rage::s_MaxNumberOfDirectories
rage::s_MaxNumberOfDirectories variable
rage::s_MemoryState
rage::s_MemoryState variable
rage::s_ModifiedTimeHigh
rage::s_ModifiedTimeHigh variable
rage::s_ModifiedTimeLow
rage::s_ModifiedTimeLow variable
rage::s_Mounts
rage::s_Mounts variable
rage::s_netError
rage::s_netError variable
rage::s_netErrorCount
rage::s_netErrorCount variable
rage::s_Newest
rage::s_Newest macro
rage::s_NumInProgressBlocks
rage::s_NumInProgressBlocks variable
rage::s_numRpfs
rage::s_numRpfs variable
rage::s_NumValidBlocks
rage::s_NumValidBlocks variable
rage::s_Oldest
rage::s_Oldest macro
rage::s_pDeviceUpdate
rage::s_pDeviceUpdate variable
rage::s_PendingState
rage::s_PendingState variable
rage::s_Profiles
rage::s_Profiles variable
rage::s_Reader
rage::s_Reader variable
rage::s_ResidentMap
rage::s_ResidentMap variable
rage::s_SaveGameSizes
rage::s_SaveGameSizes variable
rage::s_Saves
rage::s_Saves variable
rage::s_Selects
rage::s_Selects variable
rage::s_setBuf
rage::s_setBuf variable
rage::s_setList
rage::s_setList variable
rage::s_ShutdownCacheWorkerThread
rage::s_ShutdownCacheWorkerThread variable
rage::s_SizeOfIconAndSystemFiles
rage::s_SizeOfIconAndSystemFiles variable
rage::s_SizeOfSystemOverheads
rage::s_SizeOfSystemOverheads variable
rage::s_Slots
rage::s_Slots macro
rage::s_SpaceRequired
rage::s_SpaceRequired variable
rage::s_SpaceRequiredToSaveThisFile
rage::s_SpaceRequiredToSaveThisFile variable
rage::s_States
rage::s_States variable
rage::s_TcpIpInstance
rage::s_TcpIpInstance variable
rage::s_TcpIpLastError
rage::s_TcpIpLastError variable
rage::s_ThreadId
rage::s_ThreadId variable
rage::s_TitleIdForSavesFolder
rage::s_TitleIdForSavesFolder variable
rage::s_TitleString
rage::s_TitleString variable
rage::s_TotalHDDFreeSize
rage::s_TotalHDDFreeSize variable
rage::s_UserBindErrorMsg
rage::s_UserBindErrorMsg variable
rage::s_ZipfileOpen
rage::s_ZipfileOpen variable
rage::s_ZipOpen
rage::s_ZipOpen variable
rage::s_ZipStates
rage::s_ZipStates variable
rage::SAVEGAME
rage::SAVEGAME variable
rage::SAVEGAME_STACK_SIZE
rage::SAVEGAME_STACK_SIZE macro
rage::SAVEGAME_STACK_SIZE_FOR_ENUMERATION
rage::SAVEGAME_STACK_SIZE_FOR_ENUMERATION macro
rage::secureFileId
rage::secureFileId variable
rage::sgDebug1
rage::sgDebug1 macro
rage::sgDebug2
rage::sgDebug2 macro
rage::sgDebug3
rage::sgDebug3 macro
rage::sgError
rage::sgError macro
rage::sgWarning
rage::sgWarning macro
rage::sInstallProgress
rage::sInstallProgress struct
rage::SizeOfIconImage
rage::SizeOfIconImage variable
rage::Slot
rage::Slot struct
rage::sm_ExtraSpaceRequired
rage::sm_ExtraSpaceRequired variable
rage::sm_FallbackToDefaultDevice
rage::sm_FallbackToDefaultDevice variable
rage::sm_IsLoadedDataValid
rage::sm_IsLoadedDataValid variable
rage::sm_MatchLongestPath
rage::sm_MatchLongestPath variable
rage::sm_MatchNewest
rage::sm_MatchNewest variable
rage::STATIC_STATE_BUFFERS
rage::STATIC_STATE_BUFFERS macro
rage::STREAM_STORE_NAME
rage::STREAM_STORE_NAME macro
rage::StreamCloseCallback
rage::StreamCloseCallback type
rage::StreamCreateCallback
rage::StreamCreateCallback type
rage::StreamOpenCallback
rage::StreamOpenCallback type
rage::StringLength
rage::StringLength function
rage::THE_DEVICE_IS_NOT_READY_CODE
rage::THE_DEVICE_IS_NOT_READY_CODE macro
rage::tls_Uncached
rage::tls_Uncached variable
rage::USER_CANCELLED_DEVICE_SELECTION_CODE
rage::USER_CANCELLED_DEVICE_SELECTION_CODE macro
rage::XCONTENT_DATA_SIZE
rage::XCONTENT_DATA_SIZE variable
rage::XenonProfile
rage::XenonProfile::~XenonProfile
rage::XenonProfile::BeginContentVerify
rage::XenonProfile::BeginDelete
rage::XenonProfile::BeginEnumeration
rage::XenonProfile::BeginFreeSpaceCheck
rage::XenonProfile::BeginGetCreator
rage::XenonProfile::BeginGetFileSize
rage::XenonProfile::BeginIconSave
rage::XenonProfile::BeginLoad
rage::XenonProfile::BeginSave
rage::XenonProfile::BeginSelectDevice
rage::XenonProfile::CalculateDataSizeOnDisk
rage::XenonProfile::CheckContentVerify
rage::XenonProfile::CheckDelete
rage::XenonProfile::CheckEnumeration
rage::XenonProfile::CheckFreeSpaceCheck
rage::XenonProfile::CheckGetCreator
rage::XenonProfile::CheckGetFileSize
rage::XenonProfile::CheckIconSave
rage::XenonProfile::CheckLoad
rage::XenonProfile::CheckSave
rage::XenonProfile::CheckSelectDevice
rage::XenonProfile::CompareTimestamps
rage::XenonProfile::EndContentVerify
rage::XenonProfile::EndDelete
rage::XenonProfile::EndEnumeration
rage::XenonProfile::EndFreeSpaceCheck
rage::XenonProfile::EndGetCreator
rage::XenonProfile::EndGetFileSize
rage::XenonProfile::EndIconSave
rage::XenonProfile::EndLoad
rage::XenonProfile::EndSave
rage::XenonProfile::EndSelectDevice
rage::XenonProfile::FillDevice
rage::XenonProfile::GetCurrentDeviceData
rage::XenonProfile::GetDeviceData
rage::XenonProfile::GetError
rage::XenonProfile::GetLoadSize
rage::XenonProfile::GetSaveSize
rage::XenonProfile::GetSelectedDevice
rage::XenonProfile::GetState
rage::XenonProfile::GetTotalAvailableSpace
rage::XenonProfile::HasFileBeenAccessed
rage::XenonProfile::IsCurrentDeviceValid
rage::XenonProfile::IsDeviceValid
rage::XenonProfile::IsStorageDeviceChanged
rage::XenonProfile::IsStorageDeviceRemoved
rage::XenonProfile::SetSelectedDevice
rage::XenonProfile::SetSelectedDeviceToAny
rage::XenonProfile::SetStateToIdle
rage::XenonProfile::XenonProfile
rage::XEX_TITLE_ID
rage::XEX_TITLE_ID variable
rage::zipDirEntry
rage::zipDirEntry::~zipDirEntry
rage::zipDirEntry::1
rage::zipDirEntry::Child
rage::zipDirEntry::CompSize
rage::zipDirEntry::Dump
rage::zipDirEntry::FileTime
rage::zipDirEntry::Hash
rage::zipDirEntry::Insert
rage::zipDirEntry::IsCompressed
rage::zipDirEntry::IsDir
rage::zipDirEntry::Name
rage::zipDirEntry::Next
rage::zipDirEntry::Offset
rage::zipDirEntry::UncompSize
rage::zipDirEntry::zipDirEntry
RAGE_CELL_SAVEGAME_VERSION
RAGE_CELL_SAVEGAME_VERSION macro
Read
ReadBulk
ReadByte
ReadFloat
ReadInstallFile
ReadInt
ReadInternal
ReadInternalBulk
ReadLong
ReadOnly
ReadShort
ReadTChar
RegisterFileDoneCallback
ReInit
Relationships
Remount
RemountDependentPackfiles
RemoveExtensionFromPath
RemoveNameFromPath
Rename
Reset
ResumeDiscRead
RSG_DURANGO
RSG_DURANGO macro
S
S
s_AllocStream
s_AllocStream variable
s_AssetCritSec
s_AssetCritSec variable
s_LSNRange
s_LSNRange variable
s_RefCount
s_RefCount variable
safe_recv
safe_recv function
safe_send
safe_send function
SafeRead
SafeWrite
Save
SCE_STM_RWU
SCE_STM_RWU macro
ScheduleFile
Seek
Seek64
SEPARATOR
SEPARATOR macro
SEPARATOR_STRING
SEPARATOR_STRING macro
Serialize
SetAsync
SetAttributes
SetBlocking
SetCheckForUserBindErrors
SetCloseCallback
SetCreateCallback
SetDeviceProfiler
SetDrmKey
SetEndOfFile
SetFaultInjectionPath
SetFileOffset
SetFileTime
SetFindNewest
SetHoldoffTime
SetIcon
SetIsBootedFromHdd
SetKeepaliveCallback
SetLastError
SetLocalHost
SetMaxMounts
SetMaxNumberOfSaveGameFilesToEnumerate
SetMountIndex
SetNextCh
SetOpenCallback
SetpackfileHandle
SetPackfileTime
SetPath
SetReadAheadCacheCPU
SetRelativePath
SetSaveGameFolder
SetSaveGameTitle
SetSelectedDevice
SetSelectedDeviceToAny
SetStateToIdle
SetStreaming
SetStreamPosition
SetTerminators
SetUserServiceId
SetWriteState
ShowDeleteDialog
ShowLoadDialog
ShowSaveDialog
Shutdown
ShutdownClass
ShutdownWinSock
ShutdownWinSock function
SIGNIN_COUNT
Size
Size64
SkipComment
SkipToEndOfLine
sm_Collections
sm_DeviceProfiler
sm_FatalReadError
sm_InjectReadError
sMaxIndex
sMaxIndex variable
SOCKET
SOCKET type
socklen_t
socklen_t type
SourceName
StartBlock
StartInstall
StartLine
StaticWrite
STEAMBUILD_ONLY
STEAMBUILD_ONLY macro
StorePackageTimestamp
streamDebug
streamDebug variable
STRICT
STRICT macro
StripPath
SUPPORT_OTHER_PLATFORM
SUPPORT_OTHER_PLATFORM macro
SUPPORT_SDAT
SUPPORT_SDAT macro
T
TCPIP
TCPIP macro
Tell
Tell64
TellStart
U
u
UncompSize
UnInit
Unlock
UnmakeDirectory
Unmount
UpdateClass
USE_CACHED_DIRECTORY_INFO
USE_CACHED_DIRECTORY_INFO macro
USE_XCOMPRESS
USE_XCOMPRESS macro
W
WaitForNetworkReady
Working Examples
Write
WriteBulk
WriteByte
WriteFloat
WriteInstallFile
WriteInt
WriteLong
WriteShort
WriteTabs
WriteTChar
X
XCONTENT_MAX_NAME_LENGTH
XCONTENT_MAX_NAME_LENGTH macro
XenonProfile
XenonProfile class
~XenonProfile
BeginContentVerify
BeginDelete
BeginEnumeration
BeginFreeSpaceCheck
BeginFreeSpaceCheck
BeginGetCreator
BeginGetFileSize
BeginIconSave
BeginLoad
BeginSave
BeginSelectDevice
CalculateDataSizeOnDisk
CheckContentVerify
CheckDelete
CheckEnumeration
CheckFreeSpaceCheck
CheckFreeSpaceCheck
CheckGetCreator
CheckGetFileSize
CheckIconSave
CheckLoad
CheckSave
CheckSelectDevice
CompareTimestamps
EndContentVerify
EndDelete
EndEnumeration
EndFreeSpaceCheck
EndFreeSpaceCheck
EndGetCreator
EndGetFileSize
EndIconSave
EndLoad
EndSave
EndSelectDevice
FillDevice
GetCurrentDeviceData
GetDeviceData
GetError
GetLoadSize
GetSaveSize
GetSelectedDevice
GetState
GetTotalAvailableSpace
HasFileBeenAccessed
IsCurrentDeviceValid
IsDeviceValid
IsStorageDeviceChanged
IsStorageDeviceRemoved
SetSelectedDevice
SetSelectedDeviceToAny
SetStateToIdle
XenonProfile
XenonProfile::~XenonProfile destructor
XenonProfile::BeginContentVerify method
XenonProfile::BeginDelete method
XenonProfile::BeginEnumeration method
XenonProfile::BeginFreeSpaceCheck method
XenonProfile::BeginGetCreator method
XenonProfile::BeginGetFileSize method
XenonProfile::BeginIconSave method
XenonProfile::BeginLoad method
XenonProfile::BeginSave method
XenonProfile::BeginSelectDevice method
XenonProfile::CalculateDataSizeOnDisk method
XenonProfile::CheckContentVerify method
XenonProfile::CheckDelete method
XenonProfile::CheckEnumeration method
XenonProfile::CheckFreeSpaceCheck method
XenonProfile::CheckGetCreator method
XenonProfile::CheckGetFileSize method
XenonProfile::CheckIconSave method
XenonProfile::CheckLoad method
XenonProfile::CheckSave method
XenonProfile::CheckSelectDevice method
XenonProfile::CompareTimestamps method
XenonProfile::EndContentVerify method
XenonProfile::EndDelete method
XenonProfile::EndEnumeration method
XenonProfile::EndFreeSpaceCheck method
XenonProfile::EndGetCreator method
XenonProfile::EndGetFileSize method
XenonProfile::EndIconSave method
XenonProfile::EndLoad method
XenonProfile::EndSave method
XenonProfile::EndSelectDevice method
XenonProfile::FillDevice method
XenonProfile::GetCurrentDeviceData method
XenonProfile::GetDeviceData method
XenonProfile::GetError method
XenonProfile::GetLoadSize method
XenonProfile::GetSaveSize method
XenonProfile::GetSelectedDevice method
XenonProfile::GetState method
XenonProfile::GetTotalAvailableSpace method
XenonProfile::HasFileBeenAccessed method
XenonProfile::IsCurrentDeviceValid method
XenonProfile::IsDeviceValid method
XenonProfile::IsStorageDeviceChanged method
XenonProfile::IsStorageDeviceRemoved method
XenonProfile::SetSelectedDevice method
XenonProfile::SetSelectedDeviceToAny method
XenonProfile::SetStateToIdle method
XenonProfile::XenonProfile constructor
Z
zipDirEntry
zipDirEntry struct
~zipDirEntry
1
Child
CompSize
Dump
FileTime
Hash
Insert
IsCompressed
IsDir
Name
Next
Offset
UncompSize
zipDirEntry
zipDirEntry::~zipDirEntry destructor
zipDirEntry::1 data member
zipDirEntry::Child data member
zipDirEntry::CompSize data member
zipDirEntry::Dump method
zipDirEntry::FileTime data member
zipDirEntry::Hash data member
zipDirEntry::Insert method
zipDirEntry::IsCompressed method
zipDirEntry::IsDir method
zipDirEntry::Name data member
zipDirEntry::Next data member
zipDirEntry::Offset data member
zipDirEntry::UncompSize data member
zipDirEntry::zipDirEntry constructor