Overview

shaderMaterial Documentation
Contents | Index
Overview
Show All
Origin Of Module Name

Insert origin of module name here.

Overview

Insert overview here.

Send comments on this topic.
Copyright (c) 2003-2008 Rockstar San Diego. All rights reserved.


Components

Components
Show All

Here's a table listing the primary components of this module.

Send comments on this topic.


Relationships

Relationships

Insert text with inheritance and dependency info for the classes in this library. Ideally, include UML diagrams (as a GIF) followed by any additional explanations.


Command Line Options

Command Line Options
Parameter Name
In File
Description
Send comments on this topic.


Working Examples

Working Examples
Send comments on this topic.


rage Namespace

rage Namespace
Classes | Types | Macros
Show All
Classes
Class | Description
shaderMaterialGeoInstance |
shaderMaterialGeoManager |
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionFloat |
shaderMaterialGeoParamDescriptionMatrix34 |
shaderMaterialGeoParamDescriptionMatrix44 |
shaderMaterialGeoParamDescriptionString |
shaderMaterialGeoParamDescriptionTexture |
shaderMaterialGeoParamDescriptionVector2 |
shaderMaterialGeoParamDescriptionVector3 |
shaderMaterialGeoParamDescriptionVector4 |
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueFloat |
shaderMaterialGeoParamValueMatrix34 |
shaderMaterialGeoParamValueMatrix44 |
shaderMaterialGeoParamValueString |
shaderMaterialGeoParamValueTexture |
shaderMaterialGeoParamValueVector2 |
shaderMaterialGeoParamValueVector3 |
shaderMaterialGeoParamValueVector4 |
shaderMaterialGeoTemplate |
shaderMaterialGeoType |
Types
Type | Description
grmVariableInfo |
Macros
Macro | Description
DEFAULT_UV_SET_NAME |
Links
Classes, Types, Macros
Send comments on this topic.


shaderMaterialGeoInstance Class

shaderMaterialGeoInstance Class
Constructors | Destructors | Members | Methods | Operators | Data Members | rage Namespace | Inheritance Hierarchy
Show All
rage::shaderMaterialGeoType
    shaderMaterialGeoInstance
C++
public: class shaderMaterialGeoInstance : public shaderMaterialGeoType;
Constructors
Constructor | Description
shaderMaterialGeoInstance |
shaderMaterialGeoType |
Destructors
Destructor | Description
~shaderMaterialGeoInstance |
~shaderMaterialGeoType |
Methods
Method | Description
AddParamValuesFromParamDescriptions | Loading and saving
AssignNewUID |
ChangeParentType |
ConstructFromParentType |
ConstructFromParentType |
Copy |
CopyParamValues |
CopyParamValuesSelectively |
CopyParamValuesSelectively |
GetInstanceFilename |
GetInstanceName |
GetInstancePathAndFilename |
GetNoOfParams | Param accessors
GetNoOfShaderParams |
GetParam |
GetParamByUIName |
GetParentType |
GetParentTypeFilename |
GetParentTypeName |
GetParentTypePathAndFilename |
GetShaderParam |
GetShaderParamByUIName |
GetTemplate |
GetTemplate |
GetTemplateName |
GetTypeFilename | Accessors
GetTypeName |
GetTypePathAndFilename |
GetUID |
GetUvSetCount |
InitialiseFromTemplate |
IsEqual |
LoadFromGeoInstance |
LoadFromGeoType |
LoadParameterFromGeoType |
SaveTo |
SaveTo |
SaveToGeoType |
SetParentTypePathAndFilename |
SetShaderVariableValue | sets the value of the grmShaderVar from the stored data
SetTypePathAndFilename |
SetUIDToString |
UpdateShaderVariable | Sets the value of the stored data from grmShaderVar
Operators
Operator | Description
= | Assignment operator
== |
Data Members
Data Member | Description
m_apShaderParamValues |
m_bInstance |
m_pobParentType |
m_pobTemplate |
m_sGeoTypeUID |
m_strParentTypeName |
m_strParentTypePathAndFilename | Useful info
m_strTypeName |
m_strTypePathAndFilename |
Namespace

rage Namespace

File

shaderMaterialGeoInstance.h

Links
Constructors, Destructors, Members, Methods, Operators, Data Members, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoInstance::shaderMaterialGeoInstance Constructor

shaderMaterialGeoInstance::shaderMaterialGeoInstance Constructor
shaderMaterialGeoInstance Class
Show All
C++
public: shaderMaterialGeoInstance();
Class

shaderMaterialGeoInstance Class

File

shaderMaterialGeoInstance.h

Links
shaderMaterialGeoInstance Class


shaderMaterialGeoInstance::~shaderMaterialGeoInstance Destructor

shaderMaterialGeoInstance::~shaderMaterialGeoInstance Destructor
shaderMaterialGeoInstance Class
Show All
C++
public: virtual ~shaderMaterialGeoInstance();
Class

shaderMaterialGeoInstance Class

File

shaderMaterialGeoInstance.h

Links
shaderMaterialGeoInstance Class


shaderMaterialGeoInstance::ConstructFromParentType Method

shaderMaterialGeoInstance::ConstructFromParentType Method
shaderMaterialGeoInstance Class
Show All
C++
public: bool ConstructFromParentType(
    const shaderMaterialGeoType* pobParentShaderMaterialGeoType
);
Class

shaderMaterialGeoInstance Class

File

shaderMaterialGeoInstance.h

Links
shaderMaterialGeoInstance Class


shaderMaterialGeoInstance::CopyParamValuesSelectively Method

shaderMaterialGeoInstance::CopyParamValuesSelectively Method
shaderMaterialGeoInstance Class
Show All
C++
public: void CopyParamValuesSelectively(
    const shaderMaterialGeoType & obThat
);
Class

shaderMaterialGeoInstance Class

File

shaderMaterialGeoInstance.h

Links
shaderMaterialGeoInstance Class


shaderMaterialGeoInstance::GetInstanceFilename Method

shaderMaterialGeoInstance::GetInstanceFilename Method
shaderMaterialGeoInstance Class
Show All
C++
public: const char* GetInstanceFilename() const;
Class

shaderMaterialGeoInstance Class

File

shaderMaterialGeoInstance.h

Links
shaderMaterialGeoInstance Class


shaderMaterialGeoInstance::GetInstanceName Method

shaderMaterialGeoInstance::GetInstanceName Method
shaderMaterialGeoInstance Class
Show All
C++
public: const char* GetInstanceName() const;
Class

shaderMaterialGeoInstance Class

File

shaderMaterialGeoInstance.h

Links
shaderMaterialGeoInstance Class


shaderMaterialGeoInstance::GetInstancePathAndFilename Method

shaderMaterialGeoInstance::GetInstancePathAndFilename Method
shaderMaterialGeoInstance Class
Show All
C++
public: const char* GetInstancePathAndFilename() const;
Class

shaderMaterialGeoInstance Class

File

shaderMaterialGeoInstance.h

Links
shaderMaterialGeoInstance Class


shaderMaterialGeoInstance::GetTemplate Method

shaderMaterialGeoInstance::GetTemplate Method
shaderMaterialGeoInstance Class
Show All
C++
public: const shaderMaterialGeoTemplate* GetTemplate() const;
Class

shaderMaterialGeoInstance Class

File

shaderMaterialGeoInstance.h

Links
shaderMaterialGeoInstance Class


shaderMaterialGeoInstance::GetTemplateName Method

shaderMaterialGeoInstance::GetTemplateName Method
shaderMaterialGeoInstance Class
Show All
C++
public: const char* GetTemplateName() const;
Class

shaderMaterialGeoInstance Class

File

shaderMaterialGeoInstance.h

Links
shaderMaterialGeoInstance Class


shaderMaterialGeoInstance::LoadFromGeoInstance Method

shaderMaterialGeoInstance::LoadFromGeoInstance Method
shaderMaterialGeoInstance Class
Show All
C++
public: bool LoadFromGeoInstance(
    const char * szFilename
);
Class

shaderMaterialGeoInstance Class

File

shaderMaterialGeoInstance.h

Links
shaderMaterialGeoInstance Class


shaderMaterialGeoInstance::SaveTo Method

shaderMaterialGeoInstance::SaveTo Method
shaderMaterialGeoInstance Class
Show All
C++
public: virtual bool SaveTo(
    const char * szFilename
) const;
Class

shaderMaterialGeoInstance Class

File

shaderMaterialGeoInstance.h

Links
shaderMaterialGeoInstance Class


shaderMaterialGeoManager Class

shaderMaterialGeoManager Class
Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
shaderMaterialGeoManager
C++
public: class shaderMaterialGeoManager;
Methods
Method | Description
AddChildShaderMaterialGeoInstance | connections used by reload
AddChildShaderMaterialGeoInstanceWithGUID | connections used by reload
AddRefToShaderMaterialGeoInstanceWithGUID |
CreateShaderMaterialGeoInstanceFromTemplate |
CreateShaderMaterialGeoInstanceFromType |
CreateShaderMaterialGeoTemplateFromShader | WARNING!!! WARNING!!! WARNING!!! WARNING!!! DO NOT HOLD ONTO THESE POINTERS use filename or guid as identifier
CreateShaderMaterialGeoTypeFromTemplate |
GetBaseGEOPath | Utility functions
GetPathToTemplates |
GetPathToTypes |
GetShaderMaterialGeoInstance |
GetShaderMaterialGeoInstanceFromUID |
GetShaderMaterialGeoManager | Singleton access
GetShaderMaterialGeoTemplate | WARNING!!! WARNING!!! WARNING!!! WARNING!!! DO NOT HOLD ONTO THESE POINTERS use filename or guid as identifier
GetShaderMaterialGeoType |
Initialize |
LoadShaderMaterialGeoInstance |
LoadShaderMaterialGeoTemplate | DO NOT HOLD ONTO THESE POINTERS use filename or guid as identifier WARNING!!! WARNING!!! WARNING!!! WARNING!!!
LoadShaderMaterialGeoType |
ReleaseShaderMaterialGeoInstance |
ReleaseShaderMaterialGeoInstanceWithGUID |
ReloadShaderMaterialGeoInstance |
ReloadShaderMaterialGeoType |
RemoveChildShaderMaterialGeoInstance | connections used by reload
RemoveChildShaderMaterialGeoInstanceWithGUID | connections used by reload
Shutdown |
Namespace

rage Namespace

File

shaderMaterialGeoManager.h

Links
Members, Methods, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoManager::AddChildShaderMaterialGeoInstance Method

shaderMaterialGeoManager::AddChildShaderMaterialGeoInstance Method
shaderMaterialGeoManager Class
Show All

connections used by reload

C++
public: void AddChildShaderMaterialGeoInstance(
    const char* pcGeoInstancePathAndFilename,
    grmShader* shader
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::AddChildShaderMaterialGeoInstanceWithGUID Method

shaderMaterialGeoManager::AddChildShaderMaterialGeoInstanceWithGUID Method
shaderMaterialGeoManager Class
Show All

connections used by reload

C++
public: void AddChildShaderMaterialGeoInstanceWithGUID(
    const char* pcGeoInstanceUID,
    grmShader* shader
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::AddRefToShaderMaterialGeoInstanceWithGUID Method

shaderMaterialGeoManager::AddRefToShaderMaterialGeoInstanceWithGUID Method
shaderMaterialGeoManager Class
Show All
C++
public: void AddRefToShaderMaterialGeoInstanceWithGUID(
    const char* pcGeoInstanceUID
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::CreateShaderMaterialGeoInstanceFromTemplate Method

shaderMaterialGeoManager::CreateShaderMaterialGeoInstanceFromTemplate Method
shaderMaterialGeoManager Class
Show All
C++
public: const shaderMaterialGeoInstance * CreateShaderMaterialGeoInstanceFromTemplate(
    const char* pcGeoTemplatePathAndFilename
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::CreateShaderMaterialGeoInstanceFromType Method

shaderMaterialGeoManager::CreateShaderMaterialGeoInstanceFromType Method
shaderMaterialGeoManager Class
Show All
C++
public: const shaderMaterialGeoInstance * CreateShaderMaterialGeoInstanceFromType(
    const char* pcGeoTypePathAndFilename
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::CreateShaderMaterialGeoTemplateFromShader Method

shaderMaterialGeoManager::CreateShaderMaterialGeoTemplateFromShader Method
shaderMaterialGeoManager Class
Show All

WARNING!!! WARNING!!! WARNING!!! WARNING!!! DO NOT HOLD ONTO THESE POINTERS use filename or guid as identifier

C++
public: const shaderMaterialGeoTemplate * CreateShaderMaterialGeoTemplateFromShader(
    const char* pcShaderPathAndFilename
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::CreateShaderMaterialGeoTypeFromTemplate Method

shaderMaterialGeoManager::CreateShaderMaterialGeoTypeFromTemplate Method
shaderMaterialGeoManager Class
Show All
C++
public: const shaderMaterialGeoType * CreateShaderMaterialGeoTypeFromTemplate(
    const char* pcGeoTemplatePathAndFilename,
    bool asNew = false
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::GetBaseGEOPath Method

shaderMaterialGeoManager::GetBaseGEOPath Method
shaderMaterialGeoManager Class
Show All

Utility functions

C++
public: static const atString& GetBaseGEOPath();
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::GetPathToTemplates Method

shaderMaterialGeoManager::GetPathToTemplates Method
shaderMaterialGeoManager Class
Show All
C++
public: static const atString& GetPathToTemplates();
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::GetPathToTypes Method

shaderMaterialGeoManager::GetPathToTypes Method
shaderMaterialGeoManager Class
Show All
C++
public: static const atString& GetPathToTypes();
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::GetShaderMaterialGeoInstance Method

shaderMaterialGeoManager::GetShaderMaterialGeoInstance Method
shaderMaterialGeoManager Class
Show All
C++
public: shaderMaterialGeoInstance * GetShaderMaterialGeoInstance(
    const char* pcGeoInstancePathAndFilename
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::GetShaderMaterialGeoInstanceFromUID Method

shaderMaterialGeoManager::GetShaderMaterialGeoInstanceFromUID Method
shaderMaterialGeoManager Class
Show All
C++
public: shaderMaterialGeoInstance * GetShaderMaterialGeoInstanceFromUID(
    const char* pcGeoInstanceUID
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::GetShaderMaterialGeoManager Method

shaderMaterialGeoManager::GetShaderMaterialGeoManager Method
shaderMaterialGeoManager Class
Show All

Singleton access

C++
public: static shaderMaterialGeoManager* GetShaderMaterialGeoManager();
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::GetShaderMaterialGeoTemplate Method

shaderMaterialGeoManager::GetShaderMaterialGeoTemplate Method
shaderMaterialGeoManager Class
Show All

WARNING!!! WARNING!!! WARNING!!! WARNING!!! DO NOT HOLD ONTO THESE POINTERS use filename or guid as identifier

C++
public: const shaderMaterialGeoTemplate * GetShaderMaterialGeoTemplate(
    const char* pcGeoTemplatePathAndFilename
) const;
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::GetShaderMaterialGeoType Method

shaderMaterialGeoManager::GetShaderMaterialGeoType Method
shaderMaterialGeoManager Class
Show All
C++
public: shaderMaterialGeoType * GetShaderMaterialGeoType(
    const char* pcGeoTypePathAndFilename
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::Initialize Method

shaderMaterialGeoManager::Initialize Method
shaderMaterialGeoManager Class
Show All
C++
public: static void Initialize();
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::LoadShaderMaterialGeoInstance Method

shaderMaterialGeoManager::LoadShaderMaterialGeoInstance Method
shaderMaterialGeoManager Class
Show All
C++
public: shaderMaterialGeoInstance * LoadShaderMaterialGeoInstance(
    const char* pcGeoInstancePathAndFilename
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::LoadShaderMaterialGeoTemplate Method

shaderMaterialGeoManager::LoadShaderMaterialGeoTemplate Method
shaderMaterialGeoManager Class
Show All

DO NOT HOLD ONTO THESE POINTERS use filename or guid as identifier WARNING!!! WARNING!!! WARNING!!! WARNING!!!

C++
public: const shaderMaterialGeoTemplate * LoadShaderMaterialGeoTemplate(
    const char* pcGeoTemplatePathAndFilename
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::LoadShaderMaterialGeoType Method

shaderMaterialGeoManager::LoadShaderMaterialGeoType Method
shaderMaterialGeoManager Class
Show All
C++
public: const shaderMaterialGeoType * LoadShaderMaterialGeoType(
    const char* pcGeoTypePathAndFilename
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::ReleaseShaderMaterialGeoInstance Method

shaderMaterialGeoManager::ReleaseShaderMaterialGeoInstance Method
shaderMaterialGeoManager Class
Show All
C++
public: void ReleaseShaderMaterialGeoInstance(
    const char* pcGeoInstancePathAndFilename
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::ReleaseShaderMaterialGeoInstanceWithGUID Method

shaderMaterialGeoManager::ReleaseShaderMaterialGeoInstanceWithGUID Method
shaderMaterialGeoManager Class
Show All
C++
public: void ReleaseShaderMaterialGeoInstanceWithGUID(
    const char* pcGeoInstanceUID
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::ReloadShaderMaterialGeoInstance Method

shaderMaterialGeoManager::ReloadShaderMaterialGeoInstance Method
shaderMaterialGeoManager Class
Show All
C++
public: bool ReloadShaderMaterialGeoInstance(
    const char* pcGeoInstancePathAndFilename
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::ReloadShaderMaterialGeoType Method

shaderMaterialGeoManager::ReloadShaderMaterialGeoType Method
shaderMaterialGeoManager Class
Show All
C++
public: bool ReloadShaderMaterialGeoType(
    const char* pcGeoTypePathAndFilename
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::RemoveChildShaderMaterialGeoInstance Method

shaderMaterialGeoManager::RemoveChildShaderMaterialGeoInstance Method
shaderMaterialGeoManager Class
Show All

connections used by reload

C++
public: void RemoveChildShaderMaterialGeoInstance(
    const char* pcGeoInstancePathAndFilename,
    grmShader* shader
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::RemoveChildShaderMaterialGeoInstanceWithGUID Method

shaderMaterialGeoManager::RemoveChildShaderMaterialGeoInstanceWithGUID Method
shaderMaterialGeoManager Class
Show All

connections used by reload

C++
public: void RemoveChildShaderMaterialGeoInstanceWithGUID(
    const char* pcGeoInstanceUID,
    grmShader* shader
);
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoManager::Shutdown Method

shaderMaterialGeoManager::Shutdown Method
shaderMaterialGeoManager Class
Show All
C++
public: static void Shutdown();
Class

shaderMaterialGeoManager Class

File

shaderMaterialGeoManager.h

Links
shaderMaterialGeoManager Class


shaderMaterialGeoParamDescription Class

shaderMaterialGeoParamDescription Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
shaderMaterialGeoParamDescription
    rage::shaderMaterialGeoParamDescriptionFloat
    rage::shaderMaterialGeoParamDescriptionMatrix34
    rage::shaderMaterialGeoParamDescriptionMatrix44
    rage::shaderMaterialGeoParamDescriptionString
    rage::shaderMaterialGeoParamDescriptionTexture
    rage::shaderMaterialGeoParamDescriptionVector2
    rage::shaderMaterialGeoParamDescriptionVector3
    rage::shaderMaterialGeoParamDescriptionVector4
C++
public: class shaderMaterialGeoParamDescription;
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |
Namespace

rage Namespace

File

shaderMaterialGeoParamDescription.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoParamDescription::LIGHTMAP_TYPE_NAMES Data Member

shaderMaterialGeoParamDescription::LIGHTMAP_TYPE_NAMES Data Member
shaderMaterialGeoParamDescription Class
Show All
C++
public: static const char * LIGHTMAP_TYPE_NAMES[LIGHTMAP_TYPE_COUNT];
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::m_eValueSource Data Member

shaderMaterialGeoParamDescription::m_eValueSource Data Member
shaderMaterialGeoParamDescription Class
Show All
C++
protected: int m_eValueSource;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::m_iNoOfMipLevels Data Member

shaderMaterialGeoParamDescription::m_iNoOfMipLevels Data Member
shaderMaterialGeoParamDescription Class
Show All

No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)

C++
protected: int m_iNoOfMipLevels;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::m_MaterialDefaultValueUvSetIndex Data Member

shaderMaterialGeoParamDescription::m_MaterialDefaultValueUvSetIndex Data Member
shaderMaterialGeoParamDescription Class
Show All

DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data

C++
protected: int m_MaterialDefaultValueUvSetIndex;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::m_Name Data Member

shaderMaterialGeoParamDescription::m_Name Data Member
shaderMaterialGeoParamDescription Class
Show All

Semantic name

C++
protected: ConstString m_Name;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::m_TextureOutputFormats Data Member

shaderMaterialGeoParamDescription::m_TextureOutputFormats Data Member
shaderMaterialGeoParamDescription Class
Show All

The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs

C++
protected: ConstString m_TextureOutputFormats;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::m_UIHelp Data Member

shaderMaterialGeoParamDescription::m_UIHelp Data Member
shaderMaterialGeoParamDescription Class
Show All

Extra info for widget tool tips

C++
protected: ConstString m_UIHelp;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::m_UIHidden Data Member

shaderMaterialGeoParamDescription::m_UIHidden Data Member
shaderMaterialGeoParamDescription Class
Show All

Flag if hidden to the UI

C++
protected: bool m_UIHidden;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::m_UIHint Data Member

shaderMaterialGeoParamDescription::m_UIHint Data Member
shaderMaterialGeoParamDescription Class
Show All
C++
protected: ConstString m_UIHint;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::m_UIMax Data Member

shaderMaterialGeoParamDescription::m_UIMax Data Member
shaderMaterialGeoParamDescription Class
Show All
C++
protected: float m_UIMax;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::m_UIMin Data Member

shaderMaterialGeoParamDescription::m_UIMin Data Member
shaderMaterialGeoParamDescription Class
Show All

Minimum allowed value for a widget

C++
protected: float m_UIMin;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::m_UIName Data Member

shaderMaterialGeoParamDescription::m_UIName Data Member
shaderMaterialGeoParamDescription Class
Show All

Name to display in widgets

C++
protected: ConstString m_UIName;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::m_UIStep Data Member

shaderMaterialGeoParamDescription::m_UIStep Data Member
shaderMaterialGeoParamDescription Class
Show All
C++
protected: float m_UIStep;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::m_UIWidget Data Member

shaderMaterialGeoParamDescription::m_UIWidget Data Member
shaderMaterialGeoParamDescription Class
Show All

Describes which type of UI widget to display

C++
protected: ConstString m_UIWidget;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::m_UvSetIndex Data Member

shaderMaterialGeoParamDescription::m_UvSetIndex Data Member
shaderMaterialGeoParamDescription Class
Show All

Uvset index for this texture

C++
protected: int m_UvSetIndex;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::m_UvSetName Data Member

shaderMaterialGeoParamDescription::m_UvSetName Data Member
shaderMaterialGeoParamDescription Class
Show All

Uvset name for this texture

C++
protected: ConstString m_UvSetName;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::shaderMaterialGeoParamDescription Constructor ()

shaderMaterialGeoParamDescription::shaderMaterialGeoParamDescription Constructor ()
shaderMaterialGeoParamDescription Class
Show All
C++
public: shaderMaterialGeoParamDescription();
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::shaderMaterialGeoParamDescription Constructor (const parTreeNode*)

shaderMaterialGeoParamDescription::shaderMaterialGeoParamDescription Constructor (const parTreeNode*)
shaderMaterialGeoParamDescription Class
Show All
C++
protected: shaderMaterialGeoParamDescription(
    const parTreeNode* pobGeoParamDescriptionGeoRootNode
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::~shaderMaterialGeoParamDescription Destructor

shaderMaterialGeoParamDescription::~shaderMaterialGeoParamDescription Destructor
shaderMaterialGeoParamDescription Class
Show All
C++
public: virtual ~shaderMaterialGeoParamDescription();
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::CleanUp Method

shaderMaterialGeoParamDescription::CleanUp Method
shaderMaterialGeoParamDescription Class
Show All

This function cleans up any of the parameter data

C++
public: virtual bool CleanUp();
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::Copy Method

shaderMaterialGeoParamDescription::Copy Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: virtual void Copy(
    const shaderMaterialGeoParamDescription * param,
    const bool copyBase = true
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::GetMaterialDataUvSetIndex Method

shaderMaterialGeoParamDescription::GetMaterialDataUvSetIndex Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: int GetMaterialDataUvSetIndex() const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::GetName Method

shaderMaterialGeoParamDescription::GetName Method
shaderMaterialGeoParamDescription Class
Show All

Accessors

C++
public: const char * GetName() const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::GetNoOfMipLevels Method

shaderMaterialGeoParamDescription::GetNoOfMipLevels Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: int GetNoOfMipLevels() const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::GetSourceOfParamValue Method

shaderMaterialGeoParamDescription::GetSourceOfParamValue Method
shaderMaterialGeoParamDescription Class
Show All

bool GetUIHidden() const {return m_UIHidden;

C++
public: int GetSourceOfParamValue() const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::GetTextureOutputFormats Method

shaderMaterialGeoParamDescription::GetTextureOutputFormats Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: const char * GetTextureOutputFormats() const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::GetType Method

shaderMaterialGeoParamDescription::GetType Method
shaderMaterialGeoParamDescription Class
Show All

Pure virtuals

C++
public: virtual int GetType() const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::GetTypeName Method

shaderMaterialGeoParamDescription::GetTypeName Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: virtual const char * GetTypeName() const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::GetUIHelp Method

shaderMaterialGeoParamDescription::GetUIHelp Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: const char * GetUIHelp() const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::GetUIHint Method

shaderMaterialGeoParamDescription::GetUIHint Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: const char * GetUIHint() const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::GetUIMax Method

shaderMaterialGeoParamDescription::GetUIMax Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: float GetUIMax() const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::GetUIMin Method

shaderMaterialGeoParamDescription::GetUIMin Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: float GetUIMin() const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::GetUIName Method

shaderMaterialGeoParamDescription::GetUIName Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: const char * GetUIName() const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::GetUIStep Method

shaderMaterialGeoParamDescription::GetUIStep Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: float GetUIStep() const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::GetUIWidget Method

shaderMaterialGeoParamDescription::GetUIWidget Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: const char * GetUIWidget() const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::GetUvSetIndex Method

shaderMaterialGeoParamDescription::GetUvSetIndex Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: int GetUvSetIndex() const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::GetUvSetName Method

shaderMaterialGeoParamDescription::GetUvSetName Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: const char * GetUvSetName() const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::Init Method

shaderMaterialGeoParamDescription::Init Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: bool Init(
    const grmVariableInfo & varInfo,
    grcEffect & effect
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::IsEqual Method

shaderMaterialGeoParamDescription::IsEqual Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: virtual bool IsEqual(
    const shaderMaterialGeoParamDescription * param
) const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::IsLightmap Method

shaderMaterialGeoParamDescription::IsLightmap Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: bool IsLightmap(
    const int lightmapType
) const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::ReadGeoParamDescriptionData Method

shaderMaterialGeoParamDescription::ReadGeoParamDescriptionData Method
shaderMaterialGeoParamDescription Class
Show All

This function reads all the paramdata

C++
public: virtual bool ReadGeoParamDescriptionData(
    fiTokenizer & T
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::Reset Method

shaderMaterialGeoParamDescription::Reset Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: virtual void Reset();
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetDefaultValue Method (const Matrix34&)

shaderMaterialGeoParamDescription::SetDefaultValue Method (const Matrix34&)
shaderMaterialGeoParamDescription Class
Show All
C++
public: virtual void SetDefaultValue(
    const Matrix34&
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetDefaultValue Method (const Matrix44&)

shaderMaterialGeoParamDescription::SetDefaultValue Method (const Matrix44&)
shaderMaterialGeoParamDescription Class
Show All
C++
public: virtual void SetDefaultValue(
    const Matrix44&
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetDefaultValue Method (const Vector2&)

shaderMaterialGeoParamDescription::SetDefaultValue Method (const Vector2&)
shaderMaterialGeoParamDescription Class
Show All
C++
public: virtual void SetDefaultValue(
    const Vector2&
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetDefaultValue Method (const Vector3&)

shaderMaterialGeoParamDescription::SetDefaultValue Method (const Vector3&)
shaderMaterialGeoParamDescription Class
Show All
C++
public: virtual void SetDefaultValue(
    const Vector3&
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetDefaultValue Method (const Vector4&)

shaderMaterialGeoParamDescription::SetDefaultValue Method (const Vector4&)
shaderMaterialGeoParamDescription Class
Show All
C++
public: virtual void SetDefaultValue(
    const Vector4&
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetDefaultValue Method (const bool &)

shaderMaterialGeoParamDescription::SetDefaultValue Method (const bool &)
shaderMaterialGeoParamDescription Class
Show All
C++
public: virtual void SetDefaultValue(
    const bool &
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetDefaultValue Method (const char*)

shaderMaterialGeoParamDescription::SetDefaultValue Method (const char*)
shaderMaterialGeoParamDescription Class
Show All
C++
public: virtual void SetDefaultValue(
    const char*
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetDefaultValue Method (const float&)

shaderMaterialGeoParamDescription::SetDefaultValue Method (const float&)
shaderMaterialGeoParamDescription Class
Show All
C++
public: virtual void SetDefaultValue(
    const float&
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetDefaultValue Method (const int&)

shaderMaterialGeoParamDescription::SetDefaultValue Method (const int&)
shaderMaterialGeoParamDescription Class
Show All
C++
public: virtual void SetDefaultValue(
    const int&
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetDefaultValueUvSetIndex Method

shaderMaterialGeoParamDescription::SetDefaultValueUvSetIndex Method
shaderMaterialGeoParamDescription Class
Show All

void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;

C++
public: void SetDefaultValueUvSetIndex(
    int iMaterialDefaultValueUvSetIndex
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetName Method

shaderMaterialGeoParamDescription::SetName Method
shaderMaterialGeoParamDescription Class
Show All

Modifiers

C++
public: void SetName(
    const char * name
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetTextureOutputFormats Method

shaderMaterialGeoParamDescription::SetTextureOutputFormats Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: void SetTextureOutputFormats(
    const char* pcTextureOutputFormats
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetUIHint Method

shaderMaterialGeoParamDescription::SetUIHint Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: void SetUIHint(
    const char * hint
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetUIMax Method

shaderMaterialGeoParamDescription::SetUIMax Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: void SetUIMax(
    const float fUiMax
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetUIMin Method

shaderMaterialGeoParamDescription::SetUIMin Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: void SetUIMin(
    const float fUiMin
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetUIName Method

shaderMaterialGeoParamDescription::SetUIName Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: void SetUIName(
    const char * name
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetUIStep Method

shaderMaterialGeoParamDescription::SetUIStep Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: void SetUIStep(
    const float fUiStep
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetUIWidget Method

shaderMaterialGeoParamDescription::SetUIWidget Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: void SetUIWidget(
    const char * widget
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetUvSetIndex Method

shaderMaterialGeoParamDescription::SetUvSetIndex Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: void SetUvSetIndex(
    int iUvSetIndex
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetUvSetName Method

shaderMaterialGeoParamDescription::SetUvSetName Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: void SetUvSetName(
    const char* pcUvSetName
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::SetValueSource Method

shaderMaterialGeoParamDescription::SetValueSource Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: void SetValueSource(
    int iValueSource
);
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::WriteAsGeoInstanceMember Method

shaderMaterialGeoParamDescription::WriteAsGeoInstanceMember Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: virtual void WriteAsGeoInstanceMember(
    parTreeNode*,
    const char*
) const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::WriteAsGeoTemplateMember Method

shaderMaterialGeoParamDescription::WriteAsGeoTemplateMember Method
shaderMaterialGeoParamDescription Class
Show All
C++
public: virtual void WriteAsGeoTemplateMember(
    parTreeNode*,
    parTreeNode*
) const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescription::WriteGeoParamDescriptionData Method

shaderMaterialGeoParamDescription::WriteGeoParamDescriptionData Method
shaderMaterialGeoParamDescription Class
Show All

This function writes out all the param data to the .shadergroup format

C++
public: virtual bool WriteGeoParamDescriptionData(
    fiTokenizer & T
) const;
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


rage::shaderMaterialGeoParamDescription::LIGHTMAP_TYPES Enumeration

rage::shaderMaterialGeoParamDescription::LIGHTMAP_TYPES Enumeration
shaderMaterialGeoParamDescription Class
Show All
C++
public: enum LIGHTMAP_TYPES {
  public: LT_LIGHTMAP = 0,
  public: LT_LIGHTMAP_HDR_COLOR,
  public: LT_LIGHTMAP_HDR_EXP,
  public: LIGHTMAP_TYPE_COUNT
};
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


rage::shaderMaterialGeoParamDescription::ValueSource Enumeration

rage::shaderMaterialGeoParamDescription::ValueSource Enumeration
shaderMaterialGeoParamDescription Class
Show All
C++
private: enum ValueSource {
  public: GeoInstance = 1,
  public: GeoType = 2,
  public: GeoTemplate = 4
};
Class

shaderMaterialGeoParamDescription Class

File

shaderMaterialGeoParamDescription.h

Links
shaderMaterialGeoParamDescription Class


shaderMaterialGeoParamDescriptionFloat Class

shaderMaterialGeoParamDescriptionFloat Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::shaderMaterialGeoParamDescription
    shaderMaterialGeoParamDescriptionFloat
C++
public: class shaderMaterialGeoParamDescriptionFloat : public shaderMaterialGeoParamDescription;
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionFloat |
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionFloat |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
LoadFromXML |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SaveToXML |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |
Namespace

rage Namespace

File

shaderMaterialGeoParamDescriptionFloat.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoParamDescriptionFloat::shaderMaterialGeoParamDescriptionFloat Constructor ()

shaderMaterialGeoParamDescriptionFloat::shaderMaterialGeoParamDescriptionFloat Constructor ()
shaderMaterialGeoParamDescriptionFloat Class
Show All
C++
public: shaderMaterialGeoParamDescriptionFloat();
Class

shaderMaterialGeoParamDescriptionFloat Class

File

shaderMaterialGeoParamDescriptionFloat.h

Links
shaderMaterialGeoParamDescriptionFloat Class


shaderMaterialGeoParamDescriptionFloat::shaderMaterialGeoParamDescriptionFloat Constructor (const parTreeNode*)

shaderMaterialGeoParamDescriptionFloat::shaderMaterialGeoParamDescriptionFloat Constructor (const parTreeNode*)
shaderMaterialGeoParamDescriptionFloat Class
Show All
C++
public: shaderMaterialGeoParamDescriptionFloat(
    const parTreeNode* pobGeoParamDescriptionGeoRootNode
);
Class

shaderMaterialGeoParamDescriptionFloat Class

File

shaderMaterialGeoParamDescriptionFloat.h

Links
shaderMaterialGeoParamDescriptionFloat Class


shaderMaterialGeoParamDescriptionFloat::~shaderMaterialGeoParamDescriptionFloat Destructor

shaderMaterialGeoParamDescriptionFloat::~shaderMaterialGeoParamDescriptionFloat Destructor
shaderMaterialGeoParamDescriptionFloat Class
Show All
C++
public: virtual ~shaderMaterialGeoParamDescriptionFloat();
Class

shaderMaterialGeoParamDescriptionFloat Class

File

shaderMaterialGeoParamDescriptionFloat.h

Links
shaderMaterialGeoParamDescriptionFloat Class


shaderMaterialGeoParamDescriptionFloat::CleanUp Method

shaderMaterialGeoParamDescriptionFloat::CleanUp Method
shaderMaterialGeoParamDescriptionFloat Class
Show All

This function cleans up any of the parameter data

C++
public: bool CleanUp();
Class

shaderMaterialGeoParamDescriptionFloat Class

File

shaderMaterialGeoParamDescriptionFloat.h

Links
shaderMaterialGeoParamDescriptionFloat Class


shaderMaterialGeoParamDescriptionFloat::Copy Method

shaderMaterialGeoParamDescriptionFloat::Copy Method
shaderMaterialGeoParamDescriptionFloat Class
Show All
C++
public: void Copy(
    const shaderMaterialGeoParamDescription * param,
    const bool copyBase = true
);
Class

shaderMaterialGeoParamDescriptionFloat Class

File

shaderMaterialGeoParamDescriptionFloat.h

Links
shaderMaterialGeoParamDescriptionFloat Class


shaderMaterialGeoParamDescriptionFloat::GetDefaultValue Method

shaderMaterialGeoParamDescriptionFloat::GetDefaultValue Method
shaderMaterialGeoParamDescriptionFloat Class
Show All
C++
public: float GetDefaultValue() const;
Class

shaderMaterialGeoParamDescriptionFloat Class

File

shaderMaterialGeoParamDescriptionFloat.h

Links
shaderMaterialGeoParamDescriptionFloat Class


shaderMaterialGeoParamDescriptionFloat::GetType Method

shaderMaterialGeoParamDescriptionFloat::GetType Method
shaderMaterialGeoParamDescriptionFloat Class
Show All

Pure virtuals

C++
public: int GetType() const;
Class

shaderMaterialGeoParamDescriptionFloat Class

File

shaderMaterialGeoParamDescriptionFloat.h

Links
shaderMaterialGeoParamDescriptionFloat Class


shaderMaterialGeoParamDescriptionFloat::GetTypeName Method

shaderMaterialGeoParamDescriptionFloat::GetTypeName Method
shaderMaterialGeoParamDescriptionFloat Class
Show All
C++
public: const char * GetTypeName() const;
Class

shaderMaterialGeoParamDescriptionFloat Class

File

shaderMaterialGeoParamDescriptionFloat.h

Links
shaderMaterialGeoParamDescriptionFloat Class


shaderMaterialGeoParamDescriptionFloat::IsEqual Method

shaderMaterialGeoParamDescriptionFloat::IsEqual Method
shaderMaterialGeoParamDescriptionFloat Class
Show All
C++
public: bool IsEqual(
    const shaderMaterialGeoParamDescription * param
) const;
Class

shaderMaterialGeoParamDescriptionFloat Class

File

shaderMaterialGeoParamDescriptionFloat.h

Links
shaderMaterialGeoParamDescriptionFloat Class


shaderMaterialGeoParamDescriptionFloat::LoadFromXML Method

shaderMaterialGeoParamDescriptionFloat::LoadFromXML Method
shaderMaterialGeoParamDescriptionFloat Class
Show All
C++
public: bool LoadFromXML(
    const char * szFilename
);
Class

shaderMaterialGeoParamDescriptionFloat Class

File

shaderMaterialGeoParamDescriptionFloat.h

Links
shaderMaterialGeoParamDescriptionFloat Class


shaderMaterialGeoParamDescriptionFloat::ReadGeoParamDescriptionData Method

shaderMaterialGeoParamDescriptionFloat::ReadGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionFloat Class
Show All

This function reads all the paramdata

C++
public: bool ReadGeoParamDescriptionData(
    fiTokenizer & T
);
Class

shaderMaterialGeoParamDescriptionFloat Class

File

shaderMaterialGeoParamDescriptionFloat.h

Links
shaderMaterialGeoParamDescriptionFloat Class


shaderMaterialGeoParamDescriptionFloat::Reset Method

shaderMaterialGeoParamDescriptionFloat::Reset Method
shaderMaterialGeoParamDescriptionFloat Class
Show All
C++
public: virtual void Reset();
Class

shaderMaterialGeoParamDescriptionFloat Class

File

shaderMaterialGeoParamDescriptionFloat.h

Links
shaderMaterialGeoParamDescriptionFloat Class


shaderMaterialGeoParamDescriptionFloat::SaveToXML Method

shaderMaterialGeoParamDescriptionFloat::SaveToXML Method
shaderMaterialGeoParamDescriptionFloat Class
Show All
C++
public: bool SaveToXML(
    const char * szFilename
) const;
Class

shaderMaterialGeoParamDescriptionFloat Class

File

shaderMaterialGeoParamDescriptionFloat.h

Links
shaderMaterialGeoParamDescriptionFloat Class


shaderMaterialGeoParamDescriptionFloat::SetDefaultValue Method

shaderMaterialGeoParamDescriptionFloat::SetDefaultValue Method
shaderMaterialGeoParamDescriptionFloat Class
Show All
C++
public: void SetDefaultValue(
    const float& fDefaultValue
);
Class

shaderMaterialGeoParamDescriptionFloat Class

File

shaderMaterialGeoParamDescriptionFloat.h

Links
shaderMaterialGeoParamDescriptionFloat Class


shaderMaterialGeoParamDescriptionFloat::WriteAsGeoInstanceMember Method

shaderMaterialGeoParamDescriptionFloat::WriteAsGeoInstanceMember Method
shaderMaterialGeoParamDescriptionFloat Class
Show All
C++
public: virtual void WriteAsGeoInstanceMember(
    parTreeNode* pobParent,
    const char* pcTemplateName
) const;
Class

shaderMaterialGeoParamDescriptionFloat Class

File

shaderMaterialGeoParamDescriptionFloat.h

Links
shaderMaterialGeoParamDescriptionFloat Class


shaderMaterialGeoParamDescriptionFloat::WriteAsGeoTemplateMember Method

shaderMaterialGeoParamDescriptionFloat::WriteAsGeoTemplateMember Method
shaderMaterialGeoParamDescriptionFloat Class
Show All
C++
public: virtual void WriteAsGeoTemplateMember(
    parTreeNode* pobParent,
    parTreeNode* pobGeoTemplatesNode
) const;
Class

shaderMaterialGeoParamDescriptionFloat Class

File

shaderMaterialGeoParamDescriptionFloat.h

Links
shaderMaterialGeoParamDescriptionFloat Class


shaderMaterialGeoParamDescriptionFloat::WriteGeoParamDescriptionData Method

shaderMaterialGeoParamDescriptionFloat::WriteGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionFloat Class
Show All

This function writes out all the param data to the .shadergroup format

C++
public: bool WriteGeoParamDescriptionData(
    fiTokenizer & T
) const;
Class

shaderMaterialGeoParamDescriptionFloat Class

File

shaderMaterialGeoParamDescriptionFloat.h

Links
shaderMaterialGeoParamDescriptionFloat Class


shaderMaterialGeoParamDescriptionMatrix34 Class

shaderMaterialGeoParamDescriptionMatrix34 Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::shaderMaterialGeoParamDescription
    shaderMaterialGeoParamDescriptionMatrix34
C++
public: class shaderMaterialGeoParamDescriptionMatrix34 : public shaderMaterialGeoParamDescription;
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionMatrix34 |
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionMatrix34 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |
Namespace

rage Namespace

File

shaderMaterialGeoParamDescriptionMatrix34.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoParamDescriptionMatrix34::shaderMaterialGeoParamDescriptionMatrix34 Constructor

shaderMaterialGeoParamDescriptionMatrix34::shaderMaterialGeoParamDescriptionMatrix34 Constructor
shaderMaterialGeoParamDescriptionMatrix34 Class
Show All
C++
public: shaderMaterialGeoParamDescriptionMatrix34();
Class

shaderMaterialGeoParamDescriptionMatrix34 Class

File

shaderMaterialGeoParamDescriptionMatrix34.h

Links
shaderMaterialGeoParamDescriptionMatrix34 Class


shaderMaterialGeoParamDescriptionMatrix34::~shaderMaterialGeoParamDescriptionMatrix34 Destructor

shaderMaterialGeoParamDescriptionMatrix34::~shaderMaterialGeoParamDescriptionMatrix34 Destructor
shaderMaterialGeoParamDescriptionMatrix34 Class
Show All
C++
public: virtual ~shaderMaterialGeoParamDescriptionMatrix34();
Class

shaderMaterialGeoParamDescriptionMatrix34 Class

File

shaderMaterialGeoParamDescriptionMatrix34.h

Links
shaderMaterialGeoParamDescriptionMatrix34 Class


shaderMaterialGeoParamDescriptionMatrix34::Copy Method

shaderMaterialGeoParamDescriptionMatrix34::Copy Method
shaderMaterialGeoParamDescriptionMatrix34 Class
Show All
C++
public: void Copy(
    const shaderMaterialGeoParamDescription * param,
    const bool copyBase = true
);
Class

shaderMaterialGeoParamDescriptionMatrix34 Class

File

shaderMaterialGeoParamDescriptionMatrix34.h

Links
shaderMaterialGeoParamDescriptionMatrix34 Class


shaderMaterialGeoParamDescriptionMatrix34::GetDefaultValue Method

shaderMaterialGeoParamDescriptionMatrix34::GetDefaultValue Method
shaderMaterialGeoParamDescriptionMatrix34 Class
Show All
C++
public: Matrix34 GetDefaultValue() const;
Class

shaderMaterialGeoParamDescriptionMatrix34 Class

File

shaderMaterialGeoParamDescriptionMatrix34.h

Links
shaderMaterialGeoParamDescriptionMatrix34 Class


shaderMaterialGeoParamDescriptionMatrix34::GetType Method

shaderMaterialGeoParamDescriptionMatrix34::GetType Method
shaderMaterialGeoParamDescriptionMatrix34 Class
Show All

Pure virtuals

C++
public: int GetType() const;
Class

shaderMaterialGeoParamDescriptionMatrix34 Class

File

shaderMaterialGeoParamDescriptionMatrix34.h

Links
shaderMaterialGeoParamDescriptionMatrix34 Class


shaderMaterialGeoParamDescriptionMatrix34::GetTypeName Method

shaderMaterialGeoParamDescriptionMatrix34::GetTypeName Method
shaderMaterialGeoParamDescriptionMatrix34 Class
Show All
C++
public: const char * GetTypeName() const;
Class

shaderMaterialGeoParamDescriptionMatrix34 Class

File

shaderMaterialGeoParamDescriptionMatrix34.h

Links
shaderMaterialGeoParamDescriptionMatrix34 Class


shaderMaterialGeoParamDescriptionMatrix34::IsEqual Method

shaderMaterialGeoParamDescriptionMatrix34::IsEqual Method
shaderMaterialGeoParamDescriptionMatrix34 Class
Show All
C++
public: bool IsEqual(
    const shaderMaterialGeoParamDescription * param
) const;
Class

shaderMaterialGeoParamDescriptionMatrix34 Class

File

shaderMaterialGeoParamDescriptionMatrix34.h

Links
shaderMaterialGeoParamDescriptionMatrix34 Class


shaderMaterialGeoParamDescriptionMatrix34::ReadGeoParamDescriptionData Method

shaderMaterialGeoParamDescriptionMatrix34::ReadGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionMatrix34 Class
Show All

This function reads all the paramdata

C++
public: bool ReadGeoParamDescriptionData(
    fiTokenizer & T
);
Class

shaderMaterialGeoParamDescriptionMatrix34 Class

File

shaderMaterialGeoParamDescriptionMatrix34.h

Links
shaderMaterialGeoParamDescriptionMatrix34 Class


shaderMaterialGeoParamDescriptionMatrix34::Reset Method

shaderMaterialGeoParamDescriptionMatrix34::Reset Method
shaderMaterialGeoParamDescriptionMatrix34 Class
Show All
C++
public: virtual void Reset();
Class

shaderMaterialGeoParamDescriptionMatrix34 Class

File

shaderMaterialGeoParamDescriptionMatrix34.h

Links
shaderMaterialGeoParamDescriptionMatrix34 Class


shaderMaterialGeoParamDescriptionMatrix34::SetDefaultValue Method

shaderMaterialGeoParamDescriptionMatrix34::SetDefaultValue Method
shaderMaterialGeoParamDescriptionMatrix34 Class
Show All
C++
public: void SetDefaultValue(
    const Matrix34& obMatrix
);
Class

shaderMaterialGeoParamDescriptionMatrix34 Class

File

shaderMaterialGeoParamDescriptionMatrix34.h

Links
shaderMaterialGeoParamDescriptionMatrix34 Class


shaderMaterialGeoParamDescriptionMatrix34::WriteAsGeoInstanceMember Method

shaderMaterialGeoParamDescriptionMatrix34::WriteAsGeoInstanceMember Method
shaderMaterialGeoParamDescriptionMatrix34 Class
Show All
C++
public: virtual void WriteAsGeoInstanceMember(
    parTreeNode* pobParent,
    const char* pcTemplateName
) const;
Class

shaderMaterialGeoParamDescriptionMatrix34 Class

File

shaderMaterialGeoParamDescriptionMatrix34.h

Links
shaderMaterialGeoParamDescriptionMatrix34 Class


shaderMaterialGeoParamDescriptionMatrix34::WriteAsGeoTemplateMember Method

shaderMaterialGeoParamDescriptionMatrix34::WriteAsGeoTemplateMember Method
shaderMaterialGeoParamDescriptionMatrix34 Class
Show All
C++
public: virtual void WriteAsGeoTemplateMember(
    parTreeNode* pobParent,
    parTreeNode* pobGeoTemplatesNode
) const;
Class

shaderMaterialGeoParamDescriptionMatrix34 Class

File

shaderMaterialGeoParamDescriptionMatrix34.h

Links
shaderMaterialGeoParamDescriptionMatrix34 Class


shaderMaterialGeoParamDescriptionMatrix34::WriteGeoParamDescriptionData Method

shaderMaterialGeoParamDescriptionMatrix34::WriteGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionMatrix34 Class
Show All

This function writes out all the param data to the .shadergroup format

C++
public: bool WriteGeoParamDescriptionData(
    fiTokenizer & T
) const;
Class

shaderMaterialGeoParamDescriptionMatrix34 Class

File

shaderMaterialGeoParamDescriptionMatrix34.h

Links
shaderMaterialGeoParamDescriptionMatrix34 Class


shaderMaterialGeoParamDescriptionMatrix44 Class

shaderMaterialGeoParamDescriptionMatrix44 Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::shaderMaterialGeoParamDescription
    shaderMaterialGeoParamDescriptionMatrix44
C++
public: class shaderMaterialGeoParamDescriptionMatrix44 : public shaderMaterialGeoParamDescription;
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionMatrix44 |
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionMatrix44 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |
Namespace

rage Namespace

File

shaderMaterialGeoParamDescriptionMatrix44.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoParamDescriptionMatrix44::shaderMaterialGeoParamDescriptionMatrix44 Constructor

shaderMaterialGeoParamDescriptionMatrix44::shaderMaterialGeoParamDescriptionMatrix44 Constructor
shaderMaterialGeoParamDescriptionMatrix44 Class
Show All
C++
public: shaderMaterialGeoParamDescriptionMatrix44();
Class

shaderMaterialGeoParamDescriptionMatrix44 Class

File

shaderMaterialGeoParamDescriptionMatrix44.h

Links
shaderMaterialGeoParamDescriptionMatrix44 Class


shaderMaterialGeoParamDescriptionMatrix44::~shaderMaterialGeoParamDescriptionMatrix44 Destructor

shaderMaterialGeoParamDescriptionMatrix44::~shaderMaterialGeoParamDescriptionMatrix44 Destructor
shaderMaterialGeoParamDescriptionMatrix44 Class
Show All
C++
public: virtual ~shaderMaterialGeoParamDescriptionMatrix44();
Class

shaderMaterialGeoParamDescriptionMatrix44 Class

File

shaderMaterialGeoParamDescriptionMatrix44.h

Links
shaderMaterialGeoParamDescriptionMatrix44 Class


shaderMaterialGeoParamDescriptionMatrix44::Copy Method

shaderMaterialGeoParamDescriptionMatrix44::Copy Method
shaderMaterialGeoParamDescriptionMatrix44 Class
Show All
C++
public: void Copy(
    const shaderMaterialGeoParamDescription * param,
    const bool copyBase = true
);
Class

shaderMaterialGeoParamDescriptionMatrix44 Class

File

shaderMaterialGeoParamDescriptionMatrix44.h

Links
shaderMaterialGeoParamDescriptionMatrix44 Class


shaderMaterialGeoParamDescriptionMatrix44::GetDefaultValue Method

shaderMaterialGeoParamDescriptionMatrix44::GetDefaultValue Method
shaderMaterialGeoParamDescriptionMatrix44 Class
Show All
C++
public: Matrix44 GetDefaultValue() const;
Class

shaderMaterialGeoParamDescriptionMatrix44 Class

File

shaderMaterialGeoParamDescriptionMatrix44.h

Links
shaderMaterialGeoParamDescriptionMatrix44 Class


shaderMaterialGeoParamDescriptionMatrix44::GetType Method

shaderMaterialGeoParamDescriptionMatrix44::GetType Method
shaderMaterialGeoParamDescriptionMatrix44 Class
Show All

Pure virtuals

C++
public: int GetType() const;
Class

shaderMaterialGeoParamDescriptionMatrix44 Class

File

shaderMaterialGeoParamDescriptionMatrix44.h

Links
shaderMaterialGeoParamDescriptionMatrix44 Class


shaderMaterialGeoParamDescriptionMatrix44::GetTypeName Method

shaderMaterialGeoParamDescriptionMatrix44::GetTypeName Method
shaderMaterialGeoParamDescriptionMatrix44 Class
Show All
C++
public: const char * GetTypeName() const;
Class

shaderMaterialGeoParamDescriptionMatrix44 Class

File

shaderMaterialGeoParamDescriptionMatrix44.h

Links
shaderMaterialGeoParamDescriptionMatrix44 Class


shaderMaterialGeoParamDescriptionMatrix44::IsEqual Method

shaderMaterialGeoParamDescriptionMatrix44::IsEqual Method
shaderMaterialGeoParamDescriptionMatrix44 Class
Show All
C++
public: bool IsEqual(
    const shaderMaterialGeoParamDescription * param
) const;
Class

shaderMaterialGeoParamDescriptionMatrix44 Class

File

shaderMaterialGeoParamDescriptionMatrix44.h

Links
shaderMaterialGeoParamDescriptionMatrix44 Class


shaderMaterialGeoParamDescriptionMatrix44::ReadGeoParamDescriptionData Method

shaderMaterialGeoParamDescriptionMatrix44::ReadGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionMatrix44 Class
Show All

This function reads all the paramdata

C++
public: bool ReadGeoParamDescriptionData(
    fiTokenizer & T
);
Class

shaderMaterialGeoParamDescriptionMatrix44 Class

File

shaderMaterialGeoParamDescriptionMatrix44.h

Links
shaderMaterialGeoParamDescriptionMatrix44 Class


shaderMaterialGeoParamDescriptionMatrix44::Reset Method

shaderMaterialGeoParamDescriptionMatrix44::Reset Method
shaderMaterialGeoParamDescriptionMatrix44 Class
Show All
C++
public: virtual void Reset();
Class

shaderMaterialGeoParamDescriptionMatrix44 Class

File

shaderMaterialGeoParamDescriptionMatrix44.h

Links
shaderMaterialGeoParamDescriptionMatrix44 Class


shaderMaterialGeoParamDescriptionMatrix44::SetDefaultValue Method

shaderMaterialGeoParamDescriptionMatrix44::SetDefaultValue Method
shaderMaterialGeoParamDescriptionMatrix44 Class
Show All
C++
public: void SetDefaultValue(
    const Matrix44& obMatrix
);
Class

shaderMaterialGeoParamDescriptionMatrix44 Class

File

shaderMaterialGeoParamDescriptionMatrix44.h

Links
shaderMaterialGeoParamDescriptionMatrix44 Class


shaderMaterialGeoParamDescriptionMatrix44::WriteAsGeoInstanceMember Method

shaderMaterialGeoParamDescriptionMatrix44::WriteAsGeoInstanceMember Method
shaderMaterialGeoParamDescriptionMatrix44 Class
Show All
C++
public: virtual void WriteAsGeoInstanceMember(
    parTreeNode* pobParent,
    const char* pcTemplateName
) const;
Class

shaderMaterialGeoParamDescriptionMatrix44 Class

File

shaderMaterialGeoParamDescriptionMatrix44.h

Links
shaderMaterialGeoParamDescriptionMatrix44 Class


shaderMaterialGeoParamDescriptionMatrix44::WriteAsGeoTemplateMember Method

shaderMaterialGeoParamDescriptionMatrix44::WriteAsGeoTemplateMember Method
shaderMaterialGeoParamDescriptionMatrix44 Class
Show All
C++
public: virtual void WriteAsGeoTemplateMember(
    parTreeNode* pobParent,
    parTreeNode* pobGeoTemplatesNode
) const;
Class

shaderMaterialGeoParamDescriptionMatrix44 Class

File

shaderMaterialGeoParamDescriptionMatrix44.h

Links
shaderMaterialGeoParamDescriptionMatrix44 Class


shaderMaterialGeoParamDescriptionMatrix44::WriteGeoParamDescriptionData Method

shaderMaterialGeoParamDescriptionMatrix44::WriteGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionMatrix44 Class
Show All

This function writes out all the param data to the .shadergroup format

C++
public: bool WriteGeoParamDescriptionData(
    fiTokenizer & T
) const;
Class

shaderMaterialGeoParamDescriptionMatrix44 Class

File

shaderMaterialGeoParamDescriptionMatrix44.h

Links
shaderMaterialGeoParamDescriptionMatrix44 Class


shaderMaterialGeoParamDescriptionString Class

shaderMaterialGeoParamDescriptionString Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::shaderMaterialGeoParamDescription
    shaderMaterialGeoParamDescriptionString
C++
public: class shaderMaterialGeoParamDescriptionString : public shaderMaterialGeoParamDescription;
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionString |
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionString |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue | Non virtual function
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Virtual functions
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |
Namespace

rage Namespace

File

shaderMaterialGeoParamDescriptionString.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoParamDescriptionString::shaderMaterialGeoParamDescriptionString Constructor ()

shaderMaterialGeoParamDescriptionString::shaderMaterialGeoParamDescriptionString Constructor ()
shaderMaterialGeoParamDescriptionString Class
Show All
C++
public: shaderMaterialGeoParamDescriptionString();
Class

shaderMaterialGeoParamDescriptionString Class

File

shaderMaterialGeoParamDescriptionString.h

Links
shaderMaterialGeoParamDescriptionString Class


shaderMaterialGeoParamDescriptionString::shaderMaterialGeoParamDescriptionString Constructor (const parTreeNode*)

shaderMaterialGeoParamDescriptionString::shaderMaterialGeoParamDescriptionString Constructor (const parTreeNode*)
shaderMaterialGeoParamDescriptionString Class
Show All
C++
public: shaderMaterialGeoParamDescriptionString(
    const parTreeNode* pobGeoParamDescriptionGeoRootNode
);
Class

shaderMaterialGeoParamDescriptionString Class

File

shaderMaterialGeoParamDescriptionString.h

Links
shaderMaterialGeoParamDescriptionString Class


shaderMaterialGeoParamDescriptionString::~shaderMaterialGeoParamDescriptionString Destructor

shaderMaterialGeoParamDescriptionString::~shaderMaterialGeoParamDescriptionString Destructor
shaderMaterialGeoParamDescriptionString Class
Show All
C++
public: virtual ~shaderMaterialGeoParamDescriptionString();
Class

shaderMaterialGeoParamDescriptionString Class

File

shaderMaterialGeoParamDescriptionString.h

Links
shaderMaterialGeoParamDescriptionString Class


shaderMaterialGeoParamDescriptionString::CleanUp Method

shaderMaterialGeoParamDescriptionString::CleanUp Method
shaderMaterialGeoParamDescriptionString Class
Show All

This function cleans up any of the parameter data

C++
public: bool CleanUp();
Class

shaderMaterialGeoParamDescriptionString Class

File

shaderMaterialGeoParamDescriptionString.h

Links
shaderMaterialGeoParamDescriptionString Class


shaderMaterialGeoParamDescriptionString::Copy Method

shaderMaterialGeoParamDescriptionString::Copy Method
shaderMaterialGeoParamDescriptionString Class
Show All
C++
public: void Copy(
    const shaderMaterialGeoParamDescription * param,
    const bool copyBase = true
);
Class

shaderMaterialGeoParamDescriptionString Class

File

shaderMaterialGeoParamDescriptionString.h

Links
shaderMaterialGeoParamDescriptionString Class


shaderMaterialGeoParamDescriptionString::GetDefaultValue Method

shaderMaterialGeoParamDescriptionString::GetDefaultValue Method
shaderMaterialGeoParamDescriptionString Class
Show All

Non virtual function

C++
public: const char * GetDefaultValue() const;
Class

shaderMaterialGeoParamDescriptionString Class

File

shaderMaterialGeoParamDescriptionString.h

Links
shaderMaterialGeoParamDescriptionString Class


shaderMaterialGeoParamDescriptionString::GetType Method

shaderMaterialGeoParamDescriptionString::GetType Method
shaderMaterialGeoParamDescriptionString Class
Show All

Virtual functions

C++
public: int GetType() const;
Class

shaderMaterialGeoParamDescriptionString Class

File

shaderMaterialGeoParamDescriptionString.h

Links
shaderMaterialGeoParamDescriptionString Class


shaderMaterialGeoParamDescriptionString::GetTypeName Method

shaderMaterialGeoParamDescriptionString::GetTypeName Method
shaderMaterialGeoParamDescriptionString Class
Show All
C++
public: const char * GetTypeName() const;
Class

shaderMaterialGeoParamDescriptionString Class

File

shaderMaterialGeoParamDescriptionString.h

Links
shaderMaterialGeoParamDescriptionString Class


shaderMaterialGeoParamDescriptionString::IsEqual Method

shaderMaterialGeoParamDescriptionString::IsEqual Method
shaderMaterialGeoParamDescriptionString Class
Show All
C++
public: bool IsEqual(
    const shaderMaterialGeoParamDescription * param
) const;
Class

shaderMaterialGeoParamDescriptionString Class

File

shaderMaterialGeoParamDescriptionString.h

Links
shaderMaterialGeoParamDescriptionString Class


shaderMaterialGeoParamDescriptionString::ReadGeoParamDescriptionData Method

shaderMaterialGeoParamDescriptionString::ReadGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionString Class
Show All

This function reads all the paramdata

C++
public: bool ReadGeoParamDescriptionData(
    fiTokenizer & T
);
Class

shaderMaterialGeoParamDescriptionString Class

File

shaderMaterialGeoParamDescriptionString.h

Links
shaderMaterialGeoParamDescriptionString Class


shaderMaterialGeoParamDescriptionString::Reset Method

shaderMaterialGeoParamDescriptionString::Reset Method
shaderMaterialGeoParamDescriptionString Class
Show All
C++
public: virtual void Reset();
Class

shaderMaterialGeoParamDescriptionString Class

File

shaderMaterialGeoParamDescriptionString.h

Links
shaderMaterialGeoParamDescriptionString Class


shaderMaterialGeoParamDescriptionString::SetDefaultValue Method

shaderMaterialGeoParamDescriptionString::SetDefaultValue Method
shaderMaterialGeoParamDescriptionString Class
Show All
C++
public: void SetDefaultValue(
    const char * szDefaultValue
);
Class

shaderMaterialGeoParamDescriptionString Class

File

shaderMaterialGeoParamDescriptionString.h

Links
shaderMaterialGeoParamDescriptionString Class


shaderMaterialGeoParamDescriptionString::WriteAsGeoInstanceMember Method

shaderMaterialGeoParamDescriptionString::WriteAsGeoInstanceMember Method
shaderMaterialGeoParamDescriptionString Class
Show All
C++
public: virtual void WriteAsGeoInstanceMember(
    parTreeNode* pobParent,
    const char* pcTemplateName
) const;
Class

shaderMaterialGeoParamDescriptionString Class

File

shaderMaterialGeoParamDescriptionString.h

Links
shaderMaterialGeoParamDescriptionString Class


shaderMaterialGeoParamDescriptionString::WriteAsGeoTemplateMember Method

shaderMaterialGeoParamDescriptionString::WriteAsGeoTemplateMember Method
shaderMaterialGeoParamDescriptionString Class
Show All
C++
public: virtual void WriteAsGeoTemplateMember(
    parTreeNode* pobParent,
    parTreeNode* pobGeoTemplatesNode
) const;
Class

shaderMaterialGeoParamDescriptionString Class

File

shaderMaterialGeoParamDescriptionString.h

Links
shaderMaterialGeoParamDescriptionString Class


shaderMaterialGeoParamDescriptionString::WriteGeoParamDescriptionData Method

shaderMaterialGeoParamDescriptionString::WriteGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionString Class
Show All

This function writes out all the param data to the .shadergroup format

C++
public: bool WriteGeoParamDescriptionData(
    fiTokenizer & T
) const;
Class

shaderMaterialGeoParamDescriptionString Class

File

shaderMaterialGeoParamDescriptionString.h

Links
shaderMaterialGeoParamDescriptionString Class


shaderMaterialGeoParamDescriptionTexture Class

shaderMaterialGeoParamDescriptionTexture Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::shaderMaterialGeoParamDescription
    shaderMaterialGeoParamDescriptionTexture
C++
public: class shaderMaterialGeoParamDescriptionTexture : public shaderMaterialGeoParamDescription;
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionTexture |
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionTexture |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureName |
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Virtual functions
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |
Namespace

rage Namespace

File

shaderMaterialGeoParamDescriptionTexture.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoParamDescriptionTexture::shaderMaterialGeoParamDescriptionTexture Constructor ()

shaderMaterialGeoParamDescriptionTexture::shaderMaterialGeoParamDescriptionTexture Constructor ()
shaderMaterialGeoParamDescriptionTexture Class
Show All
C++
public: shaderMaterialGeoParamDescriptionTexture();
Class

shaderMaterialGeoParamDescriptionTexture Class

File

shaderMaterialGeoParamDescriptionTexture.h

Links
shaderMaterialGeoParamDescriptionTexture Class


shaderMaterialGeoParamDescriptionTexture::shaderMaterialGeoParamDescriptionTexture Constructor (const parTreeNode*)

shaderMaterialGeoParamDescriptionTexture::shaderMaterialGeoParamDescriptionTexture Constructor (const parTreeNode*)
shaderMaterialGeoParamDescriptionTexture Class
Show All
C++
public: shaderMaterialGeoParamDescriptionTexture(
    const parTreeNode* pobGeoParamDescriptionGeoRootNode
);
Class

shaderMaterialGeoParamDescriptionTexture Class

File

shaderMaterialGeoParamDescriptionTexture.h

Links
shaderMaterialGeoParamDescriptionTexture Class


shaderMaterialGeoParamDescriptionTexture::~shaderMaterialGeoParamDescriptionTexture Destructor

shaderMaterialGeoParamDescriptionTexture::~shaderMaterialGeoParamDescriptionTexture Destructor
shaderMaterialGeoParamDescriptionTexture Class
Show All
C++
public: virtual ~shaderMaterialGeoParamDescriptionTexture();
Class

shaderMaterialGeoParamDescriptionTexture Class

File

shaderMaterialGeoParamDescriptionTexture.h

Links
shaderMaterialGeoParamDescriptionTexture Class


shaderMaterialGeoParamDescriptionTexture::CleanUp Method

shaderMaterialGeoParamDescriptionTexture::CleanUp Method
shaderMaterialGeoParamDescriptionTexture Class
Show All

This function cleans up any of the parameter data

C++
public: bool CleanUp();
Class

shaderMaterialGeoParamDescriptionTexture Class

File

shaderMaterialGeoParamDescriptionTexture.h

Links
shaderMaterialGeoParamDescriptionTexture Class


shaderMaterialGeoParamDescriptionTexture::Copy Method

shaderMaterialGeoParamDescriptionTexture::Copy Method
shaderMaterialGeoParamDescriptionTexture Class
Show All
C++
public: void Copy(
    const shaderMaterialGeoParamDescription * param,
    const bool copyBase = true
);
Class

shaderMaterialGeoParamDescriptionTexture Class

File

shaderMaterialGeoParamDescriptionTexture.h

Links
shaderMaterialGeoParamDescriptionTexture Class


shaderMaterialGeoParamDescriptionTexture::GetDefaultValue Method

shaderMaterialGeoParamDescriptionTexture::GetDefaultValue Method
shaderMaterialGeoParamDescriptionTexture Class
Show All
C++
public: const char * GetDefaultValue() const;
Class

shaderMaterialGeoParamDescriptionTexture Class

File

shaderMaterialGeoParamDescriptionTexture.h

Links
shaderMaterialGeoParamDescriptionTexture Class


shaderMaterialGeoParamDescriptionTexture::GetTextureName Method (ConstString &)

shaderMaterialGeoParamDescriptionTexture::GetTextureName Method (ConstString &)
shaderMaterialGeoParamDescriptionTexture Class
Show All
C++
public: void GetTextureName(
    ConstString & sTextureName
) const;
Class

shaderMaterialGeoParamDescriptionTexture Class

File

shaderMaterialGeoParamDescriptionTexture.h

Links
shaderMaterialGeoParamDescriptionTexture Class


shaderMaterialGeoParamDescriptionTexture::GetTextureName Method (ConstString &, const char *)

shaderMaterialGeoParamDescriptionTexture::GetTextureName Method (ConstString &, const char *)
shaderMaterialGeoParamDescriptionTexture Class
Show All

Non virtual function

C++
public: static void GetTextureName(
    ConstString & sTextureName,
    const char * szTextureFilename
);
Class

shaderMaterialGeoParamDescriptionTexture Class

File

shaderMaterialGeoParamDescriptionTexture.h

Links
shaderMaterialGeoParamDescriptionTexture Class


shaderMaterialGeoParamDescriptionTexture::GetType Method

shaderMaterialGeoParamDescriptionTexture::GetType Method
shaderMaterialGeoParamDescriptionTexture Class
Show All

Virtual functions

C++
public: int GetType() const;
Class

shaderMaterialGeoParamDescriptionTexture Class

File

shaderMaterialGeoParamDescriptionTexture.h

Links
shaderMaterialGeoParamDescriptionTexture Class


shaderMaterialGeoParamDescriptionTexture::GetTypeName Method

shaderMaterialGeoParamDescriptionTexture::GetTypeName Method
shaderMaterialGeoParamDescriptionTexture Class
Show All
C++
public: const char * GetTypeName() const;
Class

shaderMaterialGeoParamDescriptionTexture Class

File

shaderMaterialGeoParamDescriptionTexture.h

Links
shaderMaterialGeoParamDescriptionTexture Class


shaderMaterialGeoParamDescriptionTexture::IsEqual Method

shaderMaterialGeoParamDescriptionTexture::IsEqual Method
shaderMaterialGeoParamDescriptionTexture Class
Show All
C++
public: bool IsEqual(
    const shaderMaterialGeoParamDescription * param
) const;
Class

shaderMaterialGeoParamDescriptionTexture Class

File

shaderMaterialGeoParamDescriptionTexture.h

Links
shaderMaterialGeoParamDescriptionTexture Class


shaderMaterialGeoParamDescriptionTexture::ReadGeoParamDescriptionData Method

shaderMaterialGeoParamDescriptionTexture::ReadGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionTexture Class
Show All

This function reads all the paramdata

C++
public: bool ReadGeoParamDescriptionData(
    fiTokenizer & T
);
Class

shaderMaterialGeoParamDescriptionTexture Class

File

shaderMaterialGeoParamDescriptionTexture.h

Links
shaderMaterialGeoParamDescriptionTexture Class


shaderMaterialGeoParamDescriptionTexture::Reset Method

shaderMaterialGeoParamDescriptionTexture::Reset Method
shaderMaterialGeoParamDescriptionTexture Class
Show All
C++
public: virtual void Reset();
Class

shaderMaterialGeoParamDescriptionTexture Class

File

shaderMaterialGeoParamDescriptionTexture.h

Links
shaderMaterialGeoParamDescriptionTexture Class


shaderMaterialGeoParamDescriptionTexture::SetDefaultValue Method

shaderMaterialGeoParamDescriptionTexture::SetDefaultValue Method
shaderMaterialGeoParamDescriptionTexture Class
Show All
C++
public: void SetDefaultValue(
    const char * szDefaultValue
);
Class

shaderMaterialGeoParamDescriptionTexture Class

File

shaderMaterialGeoParamDescriptionTexture.h

Links
shaderMaterialGeoParamDescriptionTexture Class


shaderMaterialGeoParamDescriptionTexture::WriteAsGeoInstanceMember Method

shaderMaterialGeoParamDescriptionTexture::WriteAsGeoInstanceMember Method
shaderMaterialGeoParamDescriptionTexture Class
Show All
C++
public: virtual void WriteAsGeoInstanceMember(
    parTreeNode* pobParent,
    const char* pcTemplateName
) const;
Class

shaderMaterialGeoParamDescriptionTexture Class

File

shaderMaterialGeoParamDescriptionTexture.h

Links
shaderMaterialGeoParamDescriptionTexture Class


shaderMaterialGeoParamDescriptionTexture::WriteAsGeoTemplateMember Method

shaderMaterialGeoParamDescriptionTexture::WriteAsGeoTemplateMember Method
shaderMaterialGeoParamDescriptionTexture Class
Show All
C++
public: virtual void WriteAsGeoTemplateMember(
    parTreeNode* pobParent,
    parTreeNode* pobGeoTemplatesNode
) const;
Class

shaderMaterialGeoParamDescriptionTexture Class

File

shaderMaterialGeoParamDescriptionTexture.h

Links
shaderMaterialGeoParamDescriptionTexture Class


shaderMaterialGeoParamDescriptionTexture::WriteGeoParamDescriptionData Method

shaderMaterialGeoParamDescriptionTexture::WriteGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionTexture Class
Show All

This function writes out all the param data to the .shadergroup format

C++
public: bool WriteGeoParamDescriptionData(
    fiTokenizer & T
) const;
Class

shaderMaterialGeoParamDescriptionTexture Class

File

shaderMaterialGeoParamDescriptionTexture.h

Links
shaderMaterialGeoParamDescriptionTexture Class


shaderMaterialGeoParamDescriptionVector2 Class

shaderMaterialGeoParamDescriptionVector2 Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::shaderMaterialGeoParamDescription
    shaderMaterialGeoParamDescriptionVector2
C++
public: class shaderMaterialGeoParamDescriptionVector2 : public shaderMaterialGeoParamDescription;
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionVector2 |
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionVector2 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |
Namespace

rage Namespace

File

shaderMaterialGeoParamDescriptionVector2.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoParamDescriptionVector2::shaderMaterialGeoParamDescriptionVector2 Constructor ()

shaderMaterialGeoParamDescriptionVector2::shaderMaterialGeoParamDescriptionVector2 Constructor ()
shaderMaterialGeoParamDescriptionVector2 Class
Show All
C++
public: shaderMaterialGeoParamDescriptionVector2();
Class

shaderMaterialGeoParamDescriptionVector2 Class

File

shaderMaterialGeoParamDescriptionVector2.h

Links
shaderMaterialGeoParamDescriptionVector2 Class


shaderMaterialGeoParamDescriptionVector2::shaderMaterialGeoParamDescriptionVector2 Constructor (const parTreeNode*)

shaderMaterialGeoParamDescriptionVector2::shaderMaterialGeoParamDescriptionVector2 Constructor (const parTreeNode*)
shaderMaterialGeoParamDescriptionVector2 Class
Show All
C++
public: shaderMaterialGeoParamDescriptionVector2(
    const parTreeNode* pobGeoParamDescriptionGeoRootNode
);
Class

shaderMaterialGeoParamDescriptionVector2 Class

File

shaderMaterialGeoParamDescriptionVector2.h

Links
shaderMaterialGeoParamDescriptionVector2 Class


shaderMaterialGeoParamDescriptionVector2::~shaderMaterialGeoParamDescriptionVector2 Destructor

shaderMaterialGeoParamDescriptionVector2::~shaderMaterialGeoParamDescriptionVector2 Destructor
shaderMaterialGeoParamDescriptionVector2 Class
Show All
C++
public: virtual ~shaderMaterialGeoParamDescriptionVector2();
Class

shaderMaterialGeoParamDescriptionVector2 Class

File

shaderMaterialGeoParamDescriptionVector2.h

Links
shaderMaterialGeoParamDescriptionVector2 Class


shaderMaterialGeoParamDescriptionVector2::Copy Method

shaderMaterialGeoParamDescriptionVector2::Copy Method
shaderMaterialGeoParamDescriptionVector2 Class
Show All
C++
public: void Copy(
    const shaderMaterialGeoParamDescription * param,
    const bool copyBase = true
);
Class

shaderMaterialGeoParamDescriptionVector2 Class

File

shaderMaterialGeoParamDescriptionVector2.h

Links
shaderMaterialGeoParamDescriptionVector2 Class


shaderMaterialGeoParamDescriptionVector2::GetDefaultValue Method

shaderMaterialGeoParamDescriptionVector2::GetDefaultValue Method
shaderMaterialGeoParamDescriptionVector2 Class
Show All
C++
public: const Vector2 & GetDefaultValue() const;
Class

shaderMaterialGeoParamDescriptionVector2 Class

File

shaderMaterialGeoParamDescriptionVector2.h

Links
shaderMaterialGeoParamDescriptionVector2 Class


shaderMaterialGeoParamDescriptionVector2::GetType Method

shaderMaterialGeoParamDescriptionVector2::GetType Method
shaderMaterialGeoParamDescriptionVector2 Class
Show All

Pure virtuals

C++
public: int GetType() const;
Class

shaderMaterialGeoParamDescriptionVector2 Class

File

shaderMaterialGeoParamDescriptionVector2.h

Links
shaderMaterialGeoParamDescriptionVector2 Class


shaderMaterialGeoParamDescriptionVector2::GetTypeName Method

shaderMaterialGeoParamDescriptionVector2::GetTypeName Method
shaderMaterialGeoParamDescriptionVector2 Class
Show All
C++
public: const char * GetTypeName() const;
Class

shaderMaterialGeoParamDescriptionVector2 Class

File

shaderMaterialGeoParamDescriptionVector2.h

Links
shaderMaterialGeoParamDescriptionVector2 Class


shaderMaterialGeoParamDescriptionVector2::IsEqual Method

shaderMaterialGeoParamDescriptionVector2::IsEqual Method
shaderMaterialGeoParamDescriptionVector2 Class
Show All
C++
public: bool IsEqual(
    const shaderMaterialGeoParamDescription * param
) const;
Class

shaderMaterialGeoParamDescriptionVector2 Class

File

shaderMaterialGeoParamDescriptionVector2.h

Links
shaderMaterialGeoParamDescriptionVector2 Class


shaderMaterialGeoParamDescriptionVector2::ReadGeoParamDescriptionData Method

shaderMaterialGeoParamDescriptionVector2::ReadGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionVector2 Class
Show All

This function reads all the paramdata

C++
public: bool ReadGeoParamDescriptionData(
    fiTokenizer & T
);
Class

shaderMaterialGeoParamDescriptionVector2 Class

File

shaderMaterialGeoParamDescriptionVector2.h

Links
shaderMaterialGeoParamDescriptionVector2 Class


shaderMaterialGeoParamDescriptionVector2::Reset Method

shaderMaterialGeoParamDescriptionVector2::Reset Method
shaderMaterialGeoParamDescriptionVector2 Class
Show All
C++
public: virtual void Reset();
Class

shaderMaterialGeoParamDescriptionVector2 Class

File

shaderMaterialGeoParamDescriptionVector2.h

Links
shaderMaterialGeoParamDescriptionVector2 Class


shaderMaterialGeoParamDescriptionVector2::SetDefaultValue Method

shaderMaterialGeoParamDescriptionVector2::SetDefaultValue Method
shaderMaterialGeoParamDescriptionVector2 Class
Show All
C++
public: void SetDefaultValue(
    const Vector2& vDefaultValue
);
Class

shaderMaterialGeoParamDescriptionVector2 Class

File

shaderMaterialGeoParamDescriptionVector2.h

Links
shaderMaterialGeoParamDescriptionVector2 Class


shaderMaterialGeoParamDescriptionVector2::WriteAsGeoInstanceMember Method

shaderMaterialGeoParamDescriptionVector2::WriteAsGeoInstanceMember Method
shaderMaterialGeoParamDescriptionVector2 Class
Show All
C++
public: virtual void WriteAsGeoInstanceMember(
    parTreeNode* pobParent,
    const char* pcTemplateName
) const;
Class

shaderMaterialGeoParamDescriptionVector2 Class

File

shaderMaterialGeoParamDescriptionVector2.h

Links
shaderMaterialGeoParamDescriptionVector2 Class


shaderMaterialGeoParamDescriptionVector2::WriteAsGeoTemplateMember Method

shaderMaterialGeoParamDescriptionVector2::WriteAsGeoTemplateMember Method
shaderMaterialGeoParamDescriptionVector2 Class
Show All
C++
public: virtual void WriteAsGeoTemplateMember(
    parTreeNode* pobParent,
    parTreeNode* pobGeoTemplatesNode
) const;
Class

shaderMaterialGeoParamDescriptionVector2 Class

File

shaderMaterialGeoParamDescriptionVector2.h

Links
shaderMaterialGeoParamDescriptionVector2 Class


shaderMaterialGeoParamDescriptionVector2::WriteGeoParamDescriptionData Method

shaderMaterialGeoParamDescriptionVector2::WriteGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionVector2 Class
Show All

This function writes out all the param data to the .shadergroup format

C++
public: bool WriteGeoParamDescriptionData(
    fiTokenizer & T
) const;
Class

shaderMaterialGeoParamDescriptionVector2 Class

File

shaderMaterialGeoParamDescriptionVector2.h

Links
shaderMaterialGeoParamDescriptionVector2 Class


shaderMaterialGeoParamDescriptionVector3 Class

shaderMaterialGeoParamDescriptionVector3 Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::shaderMaterialGeoParamDescription
    shaderMaterialGeoParamDescriptionVector3
C++
public: class shaderMaterialGeoParamDescriptionVector3 : public shaderMaterialGeoParamDescription;
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionVector3 |
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionVector3 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |
Namespace

rage Namespace

File

shaderMaterialGeoParamDescriptionVector3.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoParamDescriptionVector3::shaderMaterialGeoParamDescriptionVector3 Constructor ()

shaderMaterialGeoParamDescriptionVector3::shaderMaterialGeoParamDescriptionVector3 Constructor ()
shaderMaterialGeoParamDescriptionVector3 Class
Show All
C++
public: shaderMaterialGeoParamDescriptionVector3();
Class

shaderMaterialGeoParamDescriptionVector3 Class

File

shaderMaterialGeoParamDescriptionVector3.h

Links
shaderMaterialGeoParamDescriptionVector3 Class


shaderMaterialGeoParamDescriptionVector3::shaderMaterialGeoParamDescriptionVector3 Constructor (const parTreeNode*)

shaderMaterialGeoParamDescriptionVector3::shaderMaterialGeoParamDescriptionVector3 Constructor (const parTreeNode*)
shaderMaterialGeoParamDescriptionVector3 Class
Show All
C++
public: shaderMaterialGeoParamDescriptionVector3(
    const parTreeNode* pobGeoParamDescriptionGeoRootNode
);
Class

shaderMaterialGeoParamDescriptionVector3 Class

File

shaderMaterialGeoParamDescriptionVector3.h

Links
shaderMaterialGeoParamDescriptionVector3 Class


shaderMaterialGeoParamDescriptionVector3::~shaderMaterialGeoParamDescriptionVector3 Destructor

shaderMaterialGeoParamDescriptionVector3::~shaderMaterialGeoParamDescriptionVector3 Destructor
shaderMaterialGeoParamDescriptionVector3 Class
Show All
C++
public: virtual ~shaderMaterialGeoParamDescriptionVector3();
Class

shaderMaterialGeoParamDescriptionVector3 Class

File

shaderMaterialGeoParamDescriptionVector3.h

Links
shaderMaterialGeoParamDescriptionVector3 Class


shaderMaterialGeoParamDescriptionVector3::Copy Method

shaderMaterialGeoParamDescriptionVector3::Copy Method
shaderMaterialGeoParamDescriptionVector3 Class
Show All
C++
public: void Copy(
    const shaderMaterialGeoParamDescription * param,
    const bool copyBase = true
);
Class

shaderMaterialGeoParamDescriptionVector3 Class

File

shaderMaterialGeoParamDescriptionVector3.h

Links
shaderMaterialGeoParamDescriptionVector3 Class


shaderMaterialGeoParamDescriptionVector3::GetDefaultValue Method

shaderMaterialGeoParamDescriptionVector3::GetDefaultValue Method
shaderMaterialGeoParamDescriptionVector3 Class
Show All
C++
public: const Vector3 & GetDefaultValue() const;
Class

shaderMaterialGeoParamDescriptionVector3 Class

File

shaderMaterialGeoParamDescriptionVector3.h

Links
shaderMaterialGeoParamDescriptionVector3 Class


shaderMaterialGeoParamDescriptionVector3::GetType Method

shaderMaterialGeoParamDescriptionVector3::GetType Method
shaderMaterialGeoParamDescriptionVector3 Class
Show All

Pure virtuals

C++
public: int GetType() const;
Class

shaderMaterialGeoParamDescriptionVector3 Class

File

shaderMaterialGeoParamDescriptionVector3.h

Links
shaderMaterialGeoParamDescriptionVector3 Class


shaderMaterialGeoParamDescriptionVector3::GetTypeName Method

shaderMaterialGeoParamDescriptionVector3::GetTypeName Method
shaderMaterialGeoParamDescriptionVector3 Class
Show All
C++
public: const char * GetTypeName() const;
Class

shaderMaterialGeoParamDescriptionVector3 Class

File

shaderMaterialGeoParamDescriptionVector3.h

Links
shaderMaterialGeoParamDescriptionVector3 Class


shaderMaterialGeoParamDescriptionVector3::IsEqual Method

shaderMaterialGeoParamDescriptionVector3::IsEqual Method
shaderMaterialGeoParamDescriptionVector3 Class
Show All
C++
public: bool IsEqual(
    const shaderMaterialGeoParamDescription * param
) const;
Class

shaderMaterialGeoParamDescriptionVector3 Class

File

shaderMaterialGeoParamDescriptionVector3.h

Links
shaderMaterialGeoParamDescriptionVector3 Class


shaderMaterialGeoParamDescriptionVector3::ReadGeoParamDescriptionData Method

shaderMaterialGeoParamDescriptionVector3::ReadGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionVector3 Class
Show All

This function reads all the paramdata

C++
public: bool ReadGeoParamDescriptionData(
    fiTokenizer & T
);
Class

shaderMaterialGeoParamDescriptionVector3 Class

File

shaderMaterialGeoParamDescriptionVector3.h

Links
shaderMaterialGeoParamDescriptionVector3 Class


shaderMaterialGeoParamDescriptionVector3::Reset Method

shaderMaterialGeoParamDescriptionVector3::Reset Method
shaderMaterialGeoParamDescriptionVector3 Class
Show All
C++
public: virtual void Reset();
Class

shaderMaterialGeoParamDescriptionVector3 Class

File

shaderMaterialGeoParamDescriptionVector3.h

Links
shaderMaterialGeoParamDescriptionVector3 Class


shaderMaterialGeoParamDescriptionVector3::SetDefaultValue Method

shaderMaterialGeoParamDescriptionVector3::SetDefaultValue Method
shaderMaterialGeoParamDescriptionVector3 Class
Show All
C++
public: void SetDefaultValue(
    const Vector3& vDefaultValue
);
Class

shaderMaterialGeoParamDescriptionVector3 Class

File

shaderMaterialGeoParamDescriptionVector3.h

Links
shaderMaterialGeoParamDescriptionVector3 Class


shaderMaterialGeoParamDescriptionVector3::WriteAsGeoInstanceMember Method

shaderMaterialGeoParamDescriptionVector3::WriteAsGeoInstanceMember Method
shaderMaterialGeoParamDescriptionVector3 Class
Show All
C++
public: virtual void WriteAsGeoInstanceMember(
    parTreeNode* pobParent,
    const char* pcTemplateName
) const;
Class

shaderMaterialGeoParamDescriptionVector3 Class

File

shaderMaterialGeoParamDescriptionVector3.h

Links
shaderMaterialGeoParamDescriptionVector3 Class


shaderMaterialGeoParamDescriptionVector3::WriteAsGeoTemplateMember Method

shaderMaterialGeoParamDescriptionVector3::WriteAsGeoTemplateMember Method
shaderMaterialGeoParamDescriptionVector3 Class
Show All
C++
public: virtual void WriteAsGeoTemplateMember(
    parTreeNode* pobParent,
    parTreeNode* pobGeoTemplatesNode
) const;
Class

shaderMaterialGeoParamDescriptionVector3 Class

File

shaderMaterialGeoParamDescriptionVector3.h

Links
shaderMaterialGeoParamDescriptionVector3 Class


shaderMaterialGeoParamDescriptionVector3::WriteGeoParamDescriptionData Method

shaderMaterialGeoParamDescriptionVector3::WriteGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionVector3 Class
Show All

This function writes out all the param data to the .shadergroup format

C++
public: bool WriteGeoParamDescriptionData(
    fiTokenizer & T
) const;
Class

shaderMaterialGeoParamDescriptionVector3 Class

File

shaderMaterialGeoParamDescriptionVector3.h

Links
shaderMaterialGeoParamDescriptionVector3 Class


shaderMaterialGeoParamDescriptionVector4 Class

shaderMaterialGeoParamDescriptionVector4 Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::shaderMaterialGeoParamDescription
    shaderMaterialGeoParamDescriptionVector4
C++
public: class shaderMaterialGeoParamDescriptionVector4 : public shaderMaterialGeoParamDescription;
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionVector4 |
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionVector4 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |
Namespace

rage Namespace

File

shaderMaterialGeoParamDescriptionVector4.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoParamDescriptionVector4::shaderMaterialGeoParamDescriptionVector4 Constructor ()

shaderMaterialGeoParamDescriptionVector4::shaderMaterialGeoParamDescriptionVector4 Constructor ()
shaderMaterialGeoParamDescriptionVector4 Class
Show All
C++
public: shaderMaterialGeoParamDescriptionVector4();
Class

shaderMaterialGeoParamDescriptionVector4 Class

File

shaderMaterialGeoParamDescriptionVector4.h

Links
shaderMaterialGeoParamDescriptionVector4 Class


shaderMaterialGeoParamDescriptionVector4::shaderMaterialGeoParamDescriptionVector4 Constructor (const parTreeNode*)

shaderMaterialGeoParamDescriptionVector4::shaderMaterialGeoParamDescriptionVector4 Constructor (const parTreeNode*)
shaderMaterialGeoParamDescriptionVector4 Class
Show All
C++
public: shaderMaterialGeoParamDescriptionVector4(
    const parTreeNode* pobGeoParamDescriptionGeoRootNode
);
Class

shaderMaterialGeoParamDescriptionVector4 Class

File

shaderMaterialGeoParamDescriptionVector4.h

Links
shaderMaterialGeoParamDescriptionVector4 Class


shaderMaterialGeoParamDescriptionVector4::~shaderMaterialGeoParamDescriptionVector4 Destructor

shaderMaterialGeoParamDescriptionVector4::~shaderMaterialGeoParamDescriptionVector4 Destructor
shaderMaterialGeoParamDescriptionVector4 Class
Show All
C++
public: virtual ~shaderMaterialGeoParamDescriptionVector4();
Class

shaderMaterialGeoParamDescriptionVector4 Class

File

shaderMaterialGeoParamDescriptionVector4.h

Links
shaderMaterialGeoParamDescriptionVector4 Class


shaderMaterialGeoParamDescriptionVector4::Copy Method

shaderMaterialGeoParamDescriptionVector4::Copy Method
shaderMaterialGeoParamDescriptionVector4 Class
Show All
C++
public: void Copy(
    const shaderMaterialGeoParamDescription * param,
    const bool copyBase = true
);
Class

shaderMaterialGeoParamDescriptionVector4 Class

File

shaderMaterialGeoParamDescriptionVector4.h

Links
shaderMaterialGeoParamDescriptionVector4 Class


shaderMaterialGeoParamDescriptionVector4::GetDefaultValue Method

shaderMaterialGeoParamDescriptionVector4::GetDefaultValue Method
shaderMaterialGeoParamDescriptionVector4 Class
Show All
C++
public: const Vector4 & GetDefaultValue() const;
Class

shaderMaterialGeoParamDescriptionVector4 Class

File

shaderMaterialGeoParamDescriptionVector4.h

Links
shaderMaterialGeoParamDescriptionVector4 Class


shaderMaterialGeoParamDescriptionVector4::GetType Method

shaderMaterialGeoParamDescriptionVector4::GetType Method
shaderMaterialGeoParamDescriptionVector4 Class
Show All

Pure virtuals

C++
public: int GetType() const;
Class

shaderMaterialGeoParamDescriptionVector4 Class

File

shaderMaterialGeoParamDescriptionVector4.h

Links
shaderMaterialGeoParamDescriptionVector4 Class


shaderMaterialGeoParamDescriptionVector4::GetTypeName Method

shaderMaterialGeoParamDescriptionVector4::GetTypeName Method
shaderMaterialGeoParamDescriptionVector4 Class
Show All
C++
public: const char * GetTypeName() const;
Class

shaderMaterialGeoParamDescriptionVector4 Class

File

shaderMaterialGeoParamDescriptionVector4.h

Links
shaderMaterialGeoParamDescriptionVector4 Class


shaderMaterialGeoParamDescriptionVector4::IsEqual Method

shaderMaterialGeoParamDescriptionVector4::IsEqual Method
shaderMaterialGeoParamDescriptionVector4 Class
Show All
C++
public: bool IsEqual(
    const shaderMaterialGeoParamDescription * param
) const;
Class

shaderMaterialGeoParamDescriptionVector4 Class

File

shaderMaterialGeoParamDescriptionVector4.h

Links
shaderMaterialGeoParamDescriptionVector4 Class


shaderMaterialGeoParamDescriptionVector4::ReadGeoParamDescriptionData Method

shaderMaterialGeoParamDescriptionVector4::ReadGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionVector4 Class
Show All

This function reads all the paramdata

C++
public: bool ReadGeoParamDescriptionData(
    fiTokenizer & T
);
Class

shaderMaterialGeoParamDescriptionVector4 Class

File

shaderMaterialGeoParamDescriptionVector4.h

Links
shaderMaterialGeoParamDescriptionVector4 Class


shaderMaterialGeoParamDescriptionVector4::Reset Method

shaderMaterialGeoParamDescriptionVector4::Reset Method
shaderMaterialGeoParamDescriptionVector4 Class
Show All
C++
public: virtual void Reset();
Class

shaderMaterialGeoParamDescriptionVector4 Class

File

shaderMaterialGeoParamDescriptionVector4.h

Links
shaderMaterialGeoParamDescriptionVector4 Class


shaderMaterialGeoParamDescriptionVector4::SetDefaultValue Method

shaderMaterialGeoParamDescriptionVector4::SetDefaultValue Method
shaderMaterialGeoParamDescriptionVector4 Class
Show All
C++
public: void SetDefaultValue(
    const Vector4& vDefaultValue
);
Class

shaderMaterialGeoParamDescriptionVector4 Class

File

shaderMaterialGeoParamDescriptionVector4.h

Links
shaderMaterialGeoParamDescriptionVector4 Class


shaderMaterialGeoParamDescriptionVector4::WriteAsGeoInstanceMember Method

shaderMaterialGeoParamDescriptionVector4::WriteAsGeoInstanceMember Method
shaderMaterialGeoParamDescriptionVector4 Class
Show All
C++
public: virtual void WriteAsGeoInstanceMember(
    parTreeNode* pobParent,
    const char* pcTemplateName
) const;
Class

shaderMaterialGeoParamDescriptionVector4 Class

File

shaderMaterialGeoParamDescriptionVector4.h

Links
shaderMaterialGeoParamDescriptionVector4 Class


shaderMaterialGeoParamDescriptionVector4::WriteAsGeoTemplateMember Method

shaderMaterialGeoParamDescriptionVector4::WriteAsGeoTemplateMember Method
shaderMaterialGeoParamDescriptionVector4 Class
Show All
C++
public: virtual void WriteAsGeoTemplateMember(
    parTreeNode* pobParent,
    parTreeNode* pobGeoTemplatesNode
) const;
Class

shaderMaterialGeoParamDescriptionVector4 Class

File

shaderMaterialGeoParamDescriptionVector4.h

Links
shaderMaterialGeoParamDescriptionVector4 Class


shaderMaterialGeoParamDescriptionVector4::WriteGeoParamDescriptionData Method

shaderMaterialGeoParamDescriptionVector4::WriteGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionVector4 Class
Show All

This function writes out all the param data to the .shadergroup format

C++
public: bool WriteGeoParamDescriptionData(
    fiTokenizer & T
) const;
Class

shaderMaterialGeoParamDescriptionVector4 Class

File

shaderMaterialGeoParamDescriptionVector4.h

Links
shaderMaterialGeoParamDescriptionVector4 Class


shaderMaterialGeoParamValue Class

shaderMaterialGeoParamValue Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
shaderMaterialGeoParamValue
    rage::shaderMaterialGeoParamValueFloat
    rage::shaderMaterialGeoParamValueMatrix34
    rage::shaderMaterialGeoParamValueMatrix44
    rage::shaderMaterialGeoParamValueString
    rage::shaderMaterialGeoParamValueTexture
    rage::shaderMaterialGeoParamValueVector2
    rage::shaderMaterialGeoParamValueVector3
    rage::shaderMaterialGeoParamValueVector4
C++
public: class shaderMaterialGeoParamValue;
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetTypeName |
Init |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
Reset |
SetDefaultValue |
SetMaterialValue |
SetName |
Update |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
Namespace

rage Namespace

File

shaderMaterialGeoParamValue.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoParamValue::LIGHTMAP_TYPE_NAMES Data Member

shaderMaterialGeoParamValue::LIGHTMAP_TYPE_NAMES Data Member
shaderMaterialGeoParamValue Class
Show All
C++
public: static const char * LIGHTMAP_TYPE_NAMES[LIGHTMAP_TYPE_COUNT];
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::m_Name Data Member

shaderMaterialGeoParamValue::m_Name Data Member
shaderMaterialGeoParamValue Class
Show All

Semantic name

C++
protected: ConstString m_Name;
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::m_pobParamDescription Data Member

shaderMaterialGeoParamValue::m_pobParamDescription Data Member
shaderMaterialGeoParamValue Class
Show All

For backwards referencing

C++
protected: const shaderMaterialGeoParamDescription* m_pobParamDescription;
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::shaderMaterialGeoParamValue Constructor (const parTreeNode*)

shaderMaterialGeoParamValue::shaderMaterialGeoParamValue Constructor (const parTreeNode*)
shaderMaterialGeoParamValue Class
Show All
C++
protected: shaderMaterialGeoParamValue(
    const parTreeNode* pobGeoParamValueGeoRootNode
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::shaderMaterialGeoParamValue Constructor (const shaderMaterialGeoParamDescription*)

shaderMaterialGeoParamValue::shaderMaterialGeoParamValue Constructor (const shaderMaterialGeoParamDescription*)
shaderMaterialGeoParamValue Class
Show All
C++
public: shaderMaterialGeoParamValue(
    const shaderMaterialGeoParamDescription* pobParamDescription
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::shaderMaterialGeoParamValue Constructor (const shaderMaterialGeoParamValue*)

shaderMaterialGeoParamValue::shaderMaterialGeoParamValue Constructor (const shaderMaterialGeoParamValue*)
shaderMaterialGeoParamValue Class
Show All
C++
public: shaderMaterialGeoParamValue(
    const shaderMaterialGeoParamValue* pobSourceParam
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::~shaderMaterialGeoParamValue Destructor

shaderMaterialGeoParamValue::~shaderMaterialGeoParamValue Destructor
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual ~shaderMaterialGeoParamValue();
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::CleanUp Method

shaderMaterialGeoParamValue::CleanUp Method
shaderMaterialGeoParamValue Class
Show All

This function cleans up any of the parameter data

C++
public: virtual bool CleanUp();
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::Copy Method

shaderMaterialGeoParamValue::Copy Method
shaderMaterialGeoParamValue Class
Show All
C++
public: void Copy(
    const shaderMaterialGeoParamValue * param
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::CopyValueIntoVector2 Method

shaderMaterialGeoParamValue::CopyValueIntoVector2 Method
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual void CopyValueIntoVector2(
    Vector2 &
) const;
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::GetName Method

shaderMaterialGeoParamValue::GetName Method
shaderMaterialGeoParamValue Class
Show All

Accessors

C++
public: const char * GetName() const;
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::GetParamDescription Method

shaderMaterialGeoParamValue::GetParamDescription Method
shaderMaterialGeoParamValue Class
Show All
C++
public: const shaderMaterialGeoParamDescription* GetParamDescription() const;
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::GetSourceOfParamValue Method

shaderMaterialGeoParamValue::GetSourceOfParamValue Method
shaderMaterialGeoParamValue Class
Show All
C++
public: int GetSourceOfParamValue() const;
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::GetType Method

shaderMaterialGeoParamValue::GetType Method
shaderMaterialGeoParamValue Class
Show All

Pure virtuals

C++
public: virtual int GetType() const;
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::GetTypeName Method

shaderMaterialGeoParamValue::GetTypeName Method
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual const char * GetTypeName() const;
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::Init Method

shaderMaterialGeoParamValue::Init Method
shaderMaterialGeoParamValue Class
Show All
C++
public: bool Init(
    const grmVariableInfo & varInfo,
    grcEffect & effect
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::IsEqual Method

shaderMaterialGeoParamValue::IsEqual Method
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual bool IsEqual(
    const shaderMaterialGeoParamValue * param
) const;
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::IsLightmap Method

shaderMaterialGeoParamValue::IsLightmap Method
shaderMaterialGeoParamValue Class
Show All
C++
public: bool IsLightmap(
    const int lightmapType
) const;
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::ReadGeoParamValueData Method

shaderMaterialGeoParamValue::ReadGeoParamValueData Method
shaderMaterialGeoParamValue Class
Show All

This function reads all the paramdata

C++
public: virtual bool ReadGeoParamValueData(
    fiTokenizer & T
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::Reset Method

shaderMaterialGeoParamValue::Reset Method
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual void Reset();
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::SetDefaultValue Method

shaderMaterialGeoParamValue::SetDefaultValue Method
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual void SetDefaultValue(
    grcEffect &,
    grcEffectVar &
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::SetMaterialValue Method

shaderMaterialGeoParamValue::SetMaterialValue Method
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual void SetMaterialValue(
    Vector2 &
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::SetName Method

shaderMaterialGeoParamValue::SetName Method
shaderMaterialGeoParamValue Class
Show All
C++
public: void SetName(
    const char * name
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::Update Method (const Matrix34&)

shaderMaterialGeoParamValue::Update Method (const Matrix34&)
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual bool Update(
    const Matrix34&
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::Update Method (const Matrix44&)

shaderMaterialGeoParamValue::Update Method (const Matrix44&)
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual bool Update(
    const Matrix44&
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::Update Method (const Vector2&)

shaderMaterialGeoParamValue::Update Method (const Vector2&)
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual bool Update(
    const Vector2&
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::Update Method (const Vector3&)

shaderMaterialGeoParamValue::Update Method (const Vector3&)
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual bool Update(
    const Vector3&
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::Update Method (const Vector4&)

shaderMaterialGeoParamValue::Update Method (const Vector4&)
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual bool Update(
    const Vector4&
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::Update Method (const bool)

shaderMaterialGeoParamValue::Update Method (const bool)
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual bool Update(
    const bool
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::Update Method (const char *)

shaderMaterialGeoParamValue::Update Method (const char *)
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual bool Update(
    const char *
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::Update Method (const char *, const float)

shaderMaterialGeoParamValue::Update Method (const char *, const float)
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual bool Update(
    const char *,
    const float
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::Update Method (const char *, const float, const float, const float)

shaderMaterialGeoParamValue::Update Method (const char *, const float, const float, const float)
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual bool Update(
    const char *,
    const float,
    const float,
    const float
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::Update Method (const float)

shaderMaterialGeoParamValue::Update Method (const float)
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual bool Update(
    const float
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::Update Method (const int)

shaderMaterialGeoParamValue::Update Method (const int)
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual bool Update(
    const int
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::Update Method (const shaderMaterialGeoParamValue *)

shaderMaterialGeoParamValue::Update Method (const shaderMaterialGeoParamValue *)
shaderMaterialGeoParamValue Class
Show All

Update functions

C++
public: virtual bool Update(
    const shaderMaterialGeoParamValue *
);
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::WriteAsGeoTypeMember Method

shaderMaterialGeoParamValue::WriteAsGeoTypeMember Method
shaderMaterialGeoParamValue Class
Show All
C++
public: virtual void WriteAsGeoTypeMember(
    parTreeNode*,
    const char*
) const;
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValue::WriteGeoParamValueData Method

shaderMaterialGeoParamValue::WriteGeoParamValueData Method
shaderMaterialGeoParamValue Class
Show All

This function writes out all the param data to the .shadergroup format

C++
public: virtual bool WriteGeoParamValueData(
    fiTokenizer & T
) const;
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


rage::shaderMaterialGeoParamValue::LIGHTMAP_TYPES Enumeration

rage::shaderMaterialGeoParamValue::LIGHTMAP_TYPES Enumeration
shaderMaterialGeoParamValue Class
Show All
C++
public: enum LIGHTMAP_TYPES {
  public: LT_LIGHTMAP = 0,
  public: LT_LIGHTMAP_HDR_COLOR,
  public: LT_LIGHTMAP_HDR_EXP,
  public: LIGHTMAP_TYPE_COUNT
};
Class

shaderMaterialGeoParamValue Class

File

shaderMaterialGeoParamValue.h

Links
shaderMaterialGeoParamValue Class


shaderMaterialGeoParamValueFloat Class

shaderMaterialGeoParamValueFloat Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::shaderMaterialGeoParamValue
    shaderMaterialGeoParamValueFloat
C++
public: class shaderMaterialGeoParamValueFloat : public shaderMaterialGeoParamValue;
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueFloat |
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueFloat |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
LoadFromXML |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SaveToXML |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
Namespace

rage Namespace

File

shaderMaterialGeoParamValueFloat.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoParamValueFloat::shaderMaterialGeoParamValueFloat Constructor (const parTreeNode*)

shaderMaterialGeoParamValueFloat::shaderMaterialGeoParamValueFloat Constructor (const parTreeNode*)
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: shaderMaterialGeoParamValueFloat(
    const parTreeNode* pobGeoParamValueGeoRootNode
);
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::shaderMaterialGeoParamValueFloat Constructor (const shaderMaterialGeoParamDescription*)

shaderMaterialGeoParamValueFloat::shaderMaterialGeoParamValueFloat Constructor (const shaderMaterialGeoParamDescription*)
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: shaderMaterialGeoParamValueFloat(
    const shaderMaterialGeoParamDescription* pobParamDescription
);
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::shaderMaterialGeoParamValueFloat Constructor (const shaderMaterialGeoParamValueFloat*)

shaderMaterialGeoParamValueFloat::shaderMaterialGeoParamValueFloat Constructor (const shaderMaterialGeoParamValueFloat*)
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: shaderMaterialGeoParamValueFloat(
    const shaderMaterialGeoParamValueFloat* pobSourceParam
);
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::~shaderMaterialGeoParamValueFloat Destructor

shaderMaterialGeoParamValueFloat::~shaderMaterialGeoParamValueFloat Destructor
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: virtual ~shaderMaterialGeoParamValueFloat();
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::CleanUp Method

shaderMaterialGeoParamValueFloat::CleanUp Method
shaderMaterialGeoParamValueFloat Class
Show All

This function cleans up any of the parameter data

C++
public: bool CleanUp();
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::Copy Method

shaderMaterialGeoParamValueFloat::Copy Method
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: void Copy(
    const shaderMaterialGeoParamValueFloat * param
);
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::CopyValueIntoVector2 Method

shaderMaterialGeoParamValueFloat::CopyValueIntoVector2 Method
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: void CopyValueIntoVector2(
    Vector2 & vData
) const;
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::GetType Method

shaderMaterialGeoParamValueFloat::GetType Method
shaderMaterialGeoParamValueFloat Class
Show All

Pure virtuals

C++
public: int GetType() const;
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::GetTypeName Method

shaderMaterialGeoParamValueFloat::GetTypeName Method
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: const char * GetTypeName() const;
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::GetValue Method

shaderMaterialGeoParamValueFloat::GetValue Method
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: float GetValue() const;
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::IsEqual Method

shaderMaterialGeoParamValueFloat::IsEqual Method
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: bool IsEqual(
    const shaderMaterialGeoParamValue * param
) const;
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::LoadFromXML Method

shaderMaterialGeoParamValueFloat::LoadFromXML Method
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: bool LoadFromXML(
    const char * szFilename
);
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::ReadGeoParamValueData Method

shaderMaterialGeoParamValueFloat::ReadGeoParamValueData Method
shaderMaterialGeoParamValueFloat Class
Show All

This function reads all the paramdata

C++
public: bool ReadGeoParamValueData(
    fiTokenizer & T
);
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::Reset Method

shaderMaterialGeoParamValueFloat::Reset Method
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: virtual void Reset();
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::SaveToXML Method

shaderMaterialGeoParamValueFloat::SaveToXML Method
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: bool SaveToXML(
    const char * szFilename
) const;
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::SetDefaultValue Method

shaderMaterialGeoParamValueFloat::SetDefaultValue Method
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: void SetDefaultValue(
    grcEffect & effect,
    grcEffectVar & var
);
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::SetMaterialValue Method

shaderMaterialGeoParamValueFloat::SetMaterialValue Method
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: void SetMaterialValue(
    Vector2 & vValue
);
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::SetValue Method

shaderMaterialGeoParamValueFloat::SetValue Method
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: void SetValue(
    float fValue
);
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::Update Method (const bool)

shaderMaterialGeoParamValueFloat::Update Method (const bool)
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: bool Update(
    const bool b
);
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::Update Method (const char *)

shaderMaterialGeoParamValueFloat::Update Method (const char *)
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: bool Update(
    const char * texture
);
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::Update Method (const char *, const float)

shaderMaterialGeoParamValueFloat::Update Method (const char *, const float)
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: bool Update(
    const char * param,
    const float f
);
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::Update Method (const char *, const float, const float, const float)

shaderMaterialGeoParamValueFloat::Update Method (const char *, const float, const float, const float)
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: bool Update(
    const char * param,
    const float f0,
    const float f1,
    const float f2
);
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::Update Method (const float)

shaderMaterialGeoParamValueFloat::Update Method (const float)
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: bool Update(
    const float f
);
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::Update Method (const int)

shaderMaterialGeoParamValueFloat::Update Method (const int)
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: bool Update(
    const int n
);
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::Update Method (const shaderMaterialGeoParamValue *)

shaderMaterialGeoParamValueFloat::Update Method (const shaderMaterialGeoParamValue *)
shaderMaterialGeoParamValueFloat Class
Show All

Update functions

C++
public: bool Update(
    const shaderMaterialGeoParamValue * param
);
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::WriteAsGeoTypeMember Method

shaderMaterialGeoParamValueFloat::WriteAsGeoTypeMember Method
shaderMaterialGeoParamValueFloat Class
Show All
C++
public: virtual void WriteAsGeoTypeMember(
    parTreeNode* pobParent,
    const char* pcTemplateName
) const;
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueFloat::WriteGeoParamValueData Method

shaderMaterialGeoParamValueFloat::WriteGeoParamValueData Method
shaderMaterialGeoParamValueFloat Class
Show All

This function writes out all the param data to the .shadergroup format

C++
public: bool WriteGeoParamValueData(
    fiTokenizer & T
) const;
Class

shaderMaterialGeoParamValueFloat Class

File

shaderMaterialGeoParamValueFloat.h

Links
shaderMaterialGeoParamValueFloat Class


shaderMaterialGeoParamValueMatrix34 Class

shaderMaterialGeoParamValueMatrix34 Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::shaderMaterialGeoParamValue
    shaderMaterialGeoParamValueMatrix34
C++
public: class shaderMaterialGeoParamValueMatrix34 : public shaderMaterialGeoParamValue;
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueMatrix34 |
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueMatrix34 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
Namespace

rage Namespace

File

shaderMaterialGeoParamValueMatrix34.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoParamValueMatrix34::shaderMaterialGeoParamValueMatrix34 Constructor (const shaderMaterialGeoParamDescription*)

shaderMaterialGeoParamValueMatrix34::shaderMaterialGeoParamValueMatrix34 Constructor (const shaderMaterialGeoParamDescription*)
shaderMaterialGeoParamValueMatrix34 Class
Show All
C++
public: shaderMaterialGeoParamValueMatrix34(
    const shaderMaterialGeoParamDescription* pobParamDescription
);
Class

shaderMaterialGeoParamValueMatrix34 Class

File

shaderMaterialGeoParamValueMatrix34.h

Links
shaderMaterialGeoParamValueMatrix34 Class


shaderMaterialGeoParamValueMatrix34::shaderMaterialGeoParamValueMatrix34 Constructor (const shaderMaterialGeoParamValueMatrix34*)

shaderMaterialGeoParamValueMatrix34::shaderMaterialGeoParamValueMatrix34 Constructor (const shaderMaterialGeoParamValueMatrix34*)
shaderMaterialGeoParamValueMatrix34 Class
Show All
C++
public: shaderMaterialGeoParamValueMatrix34(
    const shaderMaterialGeoParamValueMatrix34* pobSourceParam
);
Class

shaderMaterialGeoParamValueMatrix34 Class

File

shaderMaterialGeoParamValueMatrix34.h

Links
shaderMaterialGeoParamValueMatrix34 Class


shaderMaterialGeoParamValueMatrix34::~shaderMaterialGeoParamValueMatrix34 Destructor

shaderMaterialGeoParamValueMatrix34::~shaderMaterialGeoParamValueMatrix34 Destructor
shaderMaterialGeoParamValueMatrix34 Class
Show All
C++
public: virtual ~shaderMaterialGeoParamValueMatrix34();
Class

shaderMaterialGeoParamValueMatrix34 Class

File

shaderMaterialGeoParamValueMatrix34.h

Links
shaderMaterialGeoParamValueMatrix34 Class


shaderMaterialGeoParamValueMatrix34::Copy Method

shaderMaterialGeoParamValueMatrix34::Copy Method
shaderMaterialGeoParamValueMatrix34 Class
Show All
C++
public: void Copy(
    const shaderMaterialGeoParamValueMatrix34 * param
);
Class

shaderMaterialGeoParamValueMatrix34 Class

File

shaderMaterialGeoParamValueMatrix34.h

Links
shaderMaterialGeoParamValueMatrix34 Class


shaderMaterialGeoParamValueMatrix34::GetType Method

shaderMaterialGeoParamValueMatrix34::GetType Method
shaderMaterialGeoParamValueMatrix34 Class
Show All

Pure virtuals

C++
public: int GetType() const;
Class

shaderMaterialGeoParamValueMatrix34 Class

File

shaderMaterialGeoParamValueMatrix34.h

Links
shaderMaterialGeoParamValueMatrix34 Class


shaderMaterialGeoParamValueMatrix34::GetTypeName Method

shaderMaterialGeoParamValueMatrix34::GetTypeName Method
shaderMaterialGeoParamValueMatrix34 Class
Show All
C++
public: const char * GetTypeName() const;
Class

shaderMaterialGeoParamValueMatrix34 Class

File

shaderMaterialGeoParamValueMatrix34.h

Links
shaderMaterialGeoParamValueMatrix34 Class


shaderMaterialGeoParamValueMatrix34::GetValue Method

shaderMaterialGeoParamValueMatrix34::GetValue Method
shaderMaterialGeoParamValueMatrix34 Class
Show All
C++
public: Matrix34 GetValue() const;
Class

shaderMaterialGeoParamValueMatrix34 Class

File

shaderMaterialGeoParamValueMatrix34.h

Links
shaderMaterialGeoParamValueMatrix34 Class


shaderMaterialGeoParamValueMatrix34::IsEqual Method

shaderMaterialGeoParamValueMatrix34::IsEqual Method
shaderMaterialGeoParamValueMatrix34 Class
Show All
C++
public: bool IsEqual(
    const shaderMaterialGeoParamValue * param
) const;
Class

shaderMaterialGeoParamValueMatrix34 Class

File

shaderMaterialGeoParamValueMatrix34.h

Links
shaderMaterialGeoParamValueMatrix34 Class


shaderMaterialGeoParamValueMatrix34::ReadGeoParamValueData Method

shaderMaterialGeoParamValueMatrix34::ReadGeoParamValueData Method
shaderMaterialGeoParamValueMatrix34 Class
Show All

This function reads all the paramdata

C++
public: bool ReadGeoParamValueData(
    fiTokenizer & T
);
Class

shaderMaterialGeoParamValueMatrix34 Class

File

shaderMaterialGeoParamValueMatrix34.h

Links
shaderMaterialGeoParamValueMatrix34 Class


shaderMaterialGeoParamValueMatrix34::Reset Method

shaderMaterialGeoParamValueMatrix34::Reset Method
shaderMaterialGeoParamValueMatrix34 Class
Show All
C++
public: virtual void Reset();
Class

shaderMaterialGeoParamValueMatrix34 Class

File

shaderMaterialGeoParamValueMatrix34.h

Links
shaderMaterialGeoParamValueMatrix34 Class


shaderMaterialGeoParamValueMatrix34::SetDefaultValue Method

shaderMaterialGeoParamValueMatrix34::SetDefaultValue Method
shaderMaterialGeoParamValueMatrix34 Class
Show All
C++
public: void SetDefaultValue(
    grcEffect & effect,
    grcEffectVar & var
);
Class

shaderMaterialGeoParamValueMatrix34 Class

File

shaderMaterialGeoParamValueMatrix34.h

Links
shaderMaterialGeoParamValueMatrix34 Class


shaderMaterialGeoParamValueMatrix34::SetValue Method

shaderMaterialGeoParamValueMatrix34::SetValue Method
shaderMaterialGeoParamValueMatrix34 Class
Show All
C++
public: void SetValue(
    const Matrix34& obMatrix
);
Class

shaderMaterialGeoParamValueMatrix34 Class

File

shaderMaterialGeoParamValueMatrix34.h

Links
shaderMaterialGeoParamValueMatrix34 Class


shaderMaterialGeoParamValueMatrix34::Update Method (const Matrix34&)

shaderMaterialGeoParamValueMatrix34::Update Method (const Matrix34&)
shaderMaterialGeoParamValueMatrix34 Class
Show All
C++
public: bool Update(
    const Matrix34& m
);
Class

shaderMaterialGeoParamValueMatrix34 Class

File

shaderMaterialGeoParamValueMatrix34.h

Links
shaderMaterialGeoParamValueMatrix34 Class


shaderMaterialGeoParamValueMatrix34::Update Method (const char *, const float)

shaderMaterialGeoParamValueMatrix34::Update Method (const char *, const float)
shaderMaterialGeoParamValueMatrix34 Class
Show All
C++
public: bool Update(
    const char * param,
    const float f
);
Class

shaderMaterialGeoParamValueMatrix34 Class

File

shaderMaterialGeoParamValueMatrix34.h

Links
shaderMaterialGeoParamValueMatrix34 Class


shaderMaterialGeoParamValueMatrix34::Update Method (const shaderMaterialGeoParamValue *)

shaderMaterialGeoParamValueMatrix34::Update Method (const shaderMaterialGeoParamValue *)
shaderMaterialGeoParamValueMatrix34 Class
Show All

Update functions

C++
public: bool Update(
    const shaderMaterialGeoParamValue * param
);
Class

shaderMaterialGeoParamValueMatrix34 Class

File

shaderMaterialGeoParamValueMatrix34.h

Links
shaderMaterialGeoParamValueMatrix34 Class


shaderMaterialGeoParamValueMatrix34::WriteAsGeoTypeMember Method

shaderMaterialGeoParamValueMatrix34::WriteAsGeoTypeMember Method
shaderMaterialGeoParamValueMatrix34 Class
Show All
C++
public: virtual void WriteAsGeoTypeMember(
    parTreeNode* pobParent,
    const char* pcTemplateName
) const;
Class

shaderMaterialGeoParamValueMatrix34 Class

File

shaderMaterialGeoParamValueMatrix34.h

Links
shaderMaterialGeoParamValueMatrix34 Class


shaderMaterialGeoParamValueMatrix34::WriteGeoParamValueData Method

shaderMaterialGeoParamValueMatrix34::WriteGeoParamValueData Method
shaderMaterialGeoParamValueMatrix34 Class
Show All

This function writes out all the param data to the .shadergroup format

C++
public: bool WriteGeoParamValueData(
    fiTokenizer & T
) const;
Class

shaderMaterialGeoParamValueMatrix34 Class

File

shaderMaterialGeoParamValueMatrix34.h

Links
shaderMaterialGeoParamValueMatrix34 Class


shaderMaterialGeoParamValueMatrix44 Class

shaderMaterialGeoParamValueMatrix44 Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::shaderMaterialGeoParamValue
    shaderMaterialGeoParamValueMatrix44
C++
public: class shaderMaterialGeoParamValueMatrix44 : public shaderMaterialGeoParamValue;
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueMatrix44 |
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueMatrix44 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
Namespace

rage Namespace

File

shaderMaterialGeoParamValueMatrix44.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoParamValueMatrix44::shaderMaterialGeoParamValueMatrix44 Constructor (const shaderMaterialGeoParamDescription*)

shaderMaterialGeoParamValueMatrix44::shaderMaterialGeoParamValueMatrix44 Constructor (const shaderMaterialGeoParamDescription*)
shaderMaterialGeoParamValueMatrix44 Class
Show All
C++
public: shaderMaterialGeoParamValueMatrix44(
    const shaderMaterialGeoParamDescription* pobParamDescription
);
Class

shaderMaterialGeoParamValueMatrix44 Class

File

shaderMaterialGeoParamValueMatrix44.h

Links
shaderMaterialGeoParamValueMatrix44 Class


shaderMaterialGeoParamValueMatrix44::shaderMaterialGeoParamValueMatrix44 Constructor (const shaderMaterialGeoParamValueMatrix44*)

shaderMaterialGeoParamValueMatrix44::shaderMaterialGeoParamValueMatrix44 Constructor (const shaderMaterialGeoParamValueMatrix44*)
shaderMaterialGeoParamValueMatrix44 Class
Show All
C++
public: shaderMaterialGeoParamValueMatrix44(
    const shaderMaterialGeoParamValueMatrix44* pobSourceParam
);
Class

shaderMaterialGeoParamValueMatrix44 Class

File

shaderMaterialGeoParamValueMatrix44.h

Links
shaderMaterialGeoParamValueMatrix44 Class


shaderMaterialGeoParamValueMatrix44::~shaderMaterialGeoParamValueMatrix44 Destructor

shaderMaterialGeoParamValueMatrix44::~shaderMaterialGeoParamValueMatrix44 Destructor
shaderMaterialGeoParamValueMatrix44 Class
Show All
C++
public: virtual ~shaderMaterialGeoParamValueMatrix44();
Class

shaderMaterialGeoParamValueMatrix44 Class

File

shaderMaterialGeoParamValueMatrix44.h

Links
shaderMaterialGeoParamValueMatrix44 Class


shaderMaterialGeoParamValueMatrix44::Copy Method

shaderMaterialGeoParamValueMatrix44::Copy Method
shaderMaterialGeoParamValueMatrix44 Class
Show All
C++
public: void Copy(
    const shaderMaterialGeoParamValueMatrix44 * param
);
Class

shaderMaterialGeoParamValueMatrix44 Class

File

shaderMaterialGeoParamValueMatrix44.h

Links
shaderMaterialGeoParamValueMatrix44 Class


shaderMaterialGeoParamValueMatrix44::GetType Method

shaderMaterialGeoParamValueMatrix44::GetType Method
shaderMaterialGeoParamValueMatrix44 Class
Show All

Pure virtuals

C++
public: int GetType() const;
Class

shaderMaterialGeoParamValueMatrix44 Class

File

shaderMaterialGeoParamValueMatrix44.h

Links
shaderMaterialGeoParamValueMatrix44 Class


shaderMaterialGeoParamValueMatrix44::GetTypeName Method

shaderMaterialGeoParamValueMatrix44::GetTypeName Method
shaderMaterialGeoParamValueMatrix44 Class
Show All
C++
public: const char * GetTypeName() const;
Class

shaderMaterialGeoParamValueMatrix44 Class

File

shaderMaterialGeoParamValueMatrix44.h

Links
shaderMaterialGeoParamValueMatrix44 Class


shaderMaterialGeoParamValueMatrix44::GetValue Method

shaderMaterialGeoParamValueMatrix44::GetValue Method
shaderMaterialGeoParamValueMatrix44 Class
Show All
C++
public: Matrix44 GetValue() const;
Class

shaderMaterialGeoParamValueMatrix44 Class

File

shaderMaterialGeoParamValueMatrix44.h

Links
shaderMaterialGeoParamValueMatrix44 Class


shaderMaterialGeoParamValueMatrix44::IsEqual Method

shaderMaterialGeoParamValueMatrix44::IsEqual Method
shaderMaterialGeoParamValueMatrix44 Class
Show All
C++
public: bool IsEqual(
    const shaderMaterialGeoParamValue * param
) const;
Class

shaderMaterialGeoParamValueMatrix44 Class

File

shaderMaterialGeoParamValueMatrix44.h

Links
shaderMaterialGeoParamValueMatrix44 Class


shaderMaterialGeoParamValueMatrix44::ReadGeoParamValueData Method

shaderMaterialGeoParamValueMatrix44::ReadGeoParamValueData Method
shaderMaterialGeoParamValueMatrix44 Class
Show All

This function reads all the paramdata

C++
public: bool ReadGeoParamValueData(
    fiTokenizer & T
);
Class

shaderMaterialGeoParamValueMatrix44 Class

File

shaderMaterialGeoParamValueMatrix44.h

Links
shaderMaterialGeoParamValueMatrix44 Class


shaderMaterialGeoParamValueMatrix44::Reset Method

shaderMaterialGeoParamValueMatrix44::Reset Method
shaderMaterialGeoParamValueMatrix44 Class
Show All
C++
public: virtual void Reset();
Class

shaderMaterialGeoParamValueMatrix44 Class

File

shaderMaterialGeoParamValueMatrix44.h

Links
shaderMaterialGeoParamValueMatrix44 Class


shaderMaterialGeoParamValueMatrix44::SetDefaultValue Method

shaderMaterialGeoParamValueMatrix44::SetDefaultValue Method
shaderMaterialGeoParamValueMatrix44 Class
Show All
C++
public: void SetDefaultValue(
    grcEffect & effect,
    grcEffectVar & var
);
Class

shaderMaterialGeoParamValueMatrix44 Class

File

shaderMaterialGeoParamValueMatrix44.h

Links
shaderMaterialGeoParamValueMatrix44 Class


shaderMaterialGeoParamValueMatrix44::SetValue Method

shaderMaterialGeoParamValueMatrix44::SetValue Method
shaderMaterialGeoParamValueMatrix44 Class
Show All
C++
public: void SetValue(
    const Matrix44& obMatrix
);
Class

shaderMaterialGeoParamValueMatrix44 Class

File

shaderMaterialGeoParamValueMatrix44.h

Links
shaderMaterialGeoParamValueMatrix44 Class


shaderMaterialGeoParamValueMatrix44::Update Method (const Matrix44&)

shaderMaterialGeoParamValueMatrix44::Update Method (const Matrix44&)
shaderMaterialGeoParamValueMatrix44 Class
Show All
C++
public: bool Update(
    const Matrix44& m
);
Class

shaderMaterialGeoParamValueMatrix44 Class

File

shaderMaterialGeoParamValueMatrix44.h

Links
shaderMaterialGeoParamValueMatrix44 Class


shaderMaterialGeoParamValueMatrix44::Update Method (const char *, const float)

shaderMaterialGeoParamValueMatrix44::Update Method (const char *, const float)
shaderMaterialGeoParamValueMatrix44 Class
Show All
C++
public: bool Update(
    const char * param,
    const float f
);
Class

shaderMaterialGeoParamValueMatrix44 Class

File

shaderMaterialGeoParamValueMatrix44.h

Links
shaderMaterialGeoParamValueMatrix44 Class


shaderMaterialGeoParamValueMatrix44::Update Method (const shaderMaterialGeoParamValue *)

shaderMaterialGeoParamValueMatrix44::Update Method (const shaderMaterialGeoParamValue *)
shaderMaterialGeoParamValueMatrix44 Class
Show All

Update functions

C++
public: bool Update(
    const shaderMaterialGeoParamValue * param
);
Class

shaderMaterialGeoParamValueMatrix44 Class

File

shaderMaterialGeoParamValueMatrix44.h

Links
shaderMaterialGeoParamValueMatrix44 Class


shaderMaterialGeoParamValueMatrix44::WriteAsGeoTypeMember Method

shaderMaterialGeoParamValueMatrix44::WriteAsGeoTypeMember Method
shaderMaterialGeoParamValueMatrix44 Class
Show All
C++
public: virtual void WriteAsGeoTypeMember(
    parTreeNode* pobParent,
    const char* pcTemplateName
) const;
Class

shaderMaterialGeoParamValueMatrix44 Class

File

shaderMaterialGeoParamValueMatrix44.h

Links
shaderMaterialGeoParamValueMatrix44 Class


shaderMaterialGeoParamValueMatrix44::WriteGeoParamValueData Method

shaderMaterialGeoParamValueMatrix44::WriteGeoParamValueData Method
shaderMaterialGeoParamValueMatrix44 Class
Show All

This function writes out all the param data to the .shadergroup format

C++
public: bool WriteGeoParamValueData(
    fiTokenizer & T
) const;
Class

shaderMaterialGeoParamValueMatrix44 Class

File

shaderMaterialGeoParamValueMatrix44.h

Links
shaderMaterialGeoParamValueMatrix44 Class


shaderMaterialGeoParamValueString Class

shaderMaterialGeoParamValueString Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::shaderMaterialGeoParamValue
    shaderMaterialGeoParamValueString
C++
public: class shaderMaterialGeoParamValueString : public shaderMaterialGeoParamValue;
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueString |
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueString |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Virtual functions
GetTypeName |
GetTypeName |
GetValue | Non virtual function
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
Namespace

rage Namespace

File

shaderMaterialGeoParamValueString.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoParamValueString::shaderMaterialGeoParamValueString Constructor (const parTreeNode*)

shaderMaterialGeoParamValueString::shaderMaterialGeoParamValueString Constructor (const parTreeNode*)
shaderMaterialGeoParamValueString Class
Show All
C++
public: shaderMaterialGeoParamValueString(
    const parTreeNode* pobGeoParamValueGeoRootNode
);
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::shaderMaterialGeoParamValueString Constructor (const shaderMaterialGeoParamDescription*)

shaderMaterialGeoParamValueString::shaderMaterialGeoParamValueString Constructor (const shaderMaterialGeoParamDescription*)
shaderMaterialGeoParamValueString Class
Show All
C++
public: shaderMaterialGeoParamValueString(
    const shaderMaterialGeoParamDescription* pobParamDescription
);
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::shaderMaterialGeoParamValueString Constructor (const shaderMaterialGeoParamValueString*)

shaderMaterialGeoParamValueString::shaderMaterialGeoParamValueString Constructor (const shaderMaterialGeoParamValueString*)
shaderMaterialGeoParamValueString Class
Show All
C++
public: shaderMaterialGeoParamValueString(
    const shaderMaterialGeoParamValueString* pobSourceParam
);
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::~shaderMaterialGeoParamValueString Destructor

shaderMaterialGeoParamValueString::~shaderMaterialGeoParamValueString Destructor
shaderMaterialGeoParamValueString Class
Show All
C++
public: virtual ~shaderMaterialGeoParamValueString();
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::CleanUp Method

shaderMaterialGeoParamValueString::CleanUp Method
shaderMaterialGeoParamValueString Class
Show All

This function cleans up any of the parameter data

C++
public: bool CleanUp();
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::Copy Method

shaderMaterialGeoParamValueString::Copy Method
shaderMaterialGeoParamValueString Class
Show All
C++
public: void Copy(
    const shaderMaterialGeoParamValueString * param
);
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::GetType Method

shaderMaterialGeoParamValueString::GetType Method
shaderMaterialGeoParamValueString Class
Show All

Virtual functions

C++
public: int GetType() const;
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::GetTypeName Method

shaderMaterialGeoParamValueString::GetTypeName Method
shaderMaterialGeoParamValueString Class
Show All
C++
public: const char * GetTypeName() const;
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::GetValue Method

shaderMaterialGeoParamValueString::GetValue Method
shaderMaterialGeoParamValueString Class
Show All

Non virtual function

C++
public: const char * GetValue() const;
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::IsEqual Method

shaderMaterialGeoParamValueString::IsEqual Method
shaderMaterialGeoParamValueString Class
Show All
C++
public: bool IsEqual(
    const shaderMaterialGeoParamValue * param
) const;
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::ReadGeoParamValueData Method

shaderMaterialGeoParamValueString::ReadGeoParamValueData Method
shaderMaterialGeoParamValueString Class
Show All

This function reads all the paramdata

C++
public: bool ReadGeoParamValueData(
    fiTokenizer & T
);
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::Reset Method

shaderMaterialGeoParamValueString::Reset Method
shaderMaterialGeoParamValueString Class
Show All
C++
public: virtual void Reset();
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::SetDefaultValue Method

shaderMaterialGeoParamValueString::SetDefaultValue Method
shaderMaterialGeoParamValueString Class
Show All
C++
public: void SetDefaultValue(
    grcEffect & effect,
    grcEffectVar & var
);
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::SetValue Method

shaderMaterialGeoParamValueString::SetValue Method
shaderMaterialGeoParamValueString Class
Show All
C++
public: void SetValue(
    const char * szValue
);
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::Update Method (const bool)

shaderMaterialGeoParamValueString::Update Method (const bool)
shaderMaterialGeoParamValueString Class
Show All
C++
public: bool Update(
    const bool b
);
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::Update Method (const char *)

shaderMaterialGeoParamValueString::Update Method (const char *)
shaderMaterialGeoParamValueString Class
Show All
C++
public: bool Update(
    const char * data
);
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::Update Method (const char *, const float)

shaderMaterialGeoParamValueString::Update Method (const char *, const float)
shaderMaterialGeoParamValueString Class
Show All
C++
public: bool Update(
    const char * param,
    const float f
);
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::Update Method (const char *, const float, const float, const float)

shaderMaterialGeoParamValueString::Update Method (const char *, const float, const float, const float)
shaderMaterialGeoParamValueString Class
Show All
C++
public: bool Update(
    const char * param,
    const float f0,
    const float f1,
    const float f2
);
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::Update Method (const float)

shaderMaterialGeoParamValueString::Update Method (const float)
shaderMaterialGeoParamValueString Class
Show All
C++
public: bool Update(
    const float f
);
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::Update Method (const int)

shaderMaterialGeoParamValueString::Update Method (const int)
shaderMaterialGeoParamValueString Class
Show All
C++
public: bool Update(
    const int n
);
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::Update Method (const shaderMaterialGeoParamValue *)

shaderMaterialGeoParamValueString::Update Method (const shaderMaterialGeoParamValue *)
shaderMaterialGeoParamValueString Class
Show All

Update functions

C++
public: bool Update(
    const shaderMaterialGeoParamValue * param
);
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::WriteAsGeoTypeMember Method

shaderMaterialGeoParamValueString::WriteAsGeoTypeMember Method
shaderMaterialGeoParamValueString Class
Show All
C++
public: virtual void WriteAsGeoTypeMember(
    parTreeNode* pobParent,
    const char* pcTemplateName
) const;
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueString::WriteGeoParamValueData Method

shaderMaterialGeoParamValueString::WriteGeoParamValueData Method
shaderMaterialGeoParamValueString Class
Show All

This function writes out all the param data to the .shadergroup format

C++
public: bool WriteGeoParamValueData(
    fiTokenizer & T
) const;
Class

shaderMaterialGeoParamValueString Class

File

shaderMaterialGeoParamValueString.h

Links
shaderMaterialGeoParamValueString Class


shaderMaterialGeoParamValueTexture Class

shaderMaterialGeoParamValueTexture Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::shaderMaterialGeoParamValue
    shaderMaterialGeoParamValueTexture
C++
public: class shaderMaterialGeoParamValueTexture : public shaderMaterialGeoParamValue;
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueTexture |
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueTexture |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetTextureName |
GetType | Pure virtuals
GetType | Virtual functions
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
Namespace

rage Namespace

File

shaderMaterialGeoParamValueTexture.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoParamValueTexture::shaderMaterialGeoParamValueTexture Constructor (const parTreeNode*)

shaderMaterialGeoParamValueTexture::shaderMaterialGeoParamValueTexture Constructor (const parTreeNode*)
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: shaderMaterialGeoParamValueTexture(
    const parTreeNode* pobGeoParamValueGeoRootNode
);
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::shaderMaterialGeoParamValueTexture Constructor (const shaderMaterialGeoParamDescription*)

shaderMaterialGeoParamValueTexture::shaderMaterialGeoParamValueTexture Constructor (const shaderMaterialGeoParamDescription*)
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: shaderMaterialGeoParamValueTexture(
    const shaderMaterialGeoParamDescription* pobParamDescription
);
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::shaderMaterialGeoParamValueTexture Constructor (const shaderMaterialGeoParamValueTexture*)

shaderMaterialGeoParamValueTexture::shaderMaterialGeoParamValueTexture Constructor (const shaderMaterialGeoParamValueTexture*)
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: shaderMaterialGeoParamValueTexture(
    const shaderMaterialGeoParamValueTexture* pobSourceParam
);
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::~shaderMaterialGeoParamValueTexture Destructor

shaderMaterialGeoParamValueTexture::~shaderMaterialGeoParamValueTexture Destructor
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: virtual ~shaderMaterialGeoParamValueTexture();
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::CleanUp Method

shaderMaterialGeoParamValueTexture::CleanUp Method
shaderMaterialGeoParamValueTexture Class
Show All

This function cleans up any of the parameter data

C++
public: bool CleanUp();
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::Copy Method

shaderMaterialGeoParamValueTexture::Copy Method
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: void Copy(
    const shaderMaterialGeoParamValueTexture * param
);
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::GetTextureName Method (ConstString &)

shaderMaterialGeoParamValueTexture::GetTextureName Method (ConstString &)
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: void GetTextureName(
    ConstString & sTextureName
) const;
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::GetTextureName Method (ConstString &, const char *)

shaderMaterialGeoParamValueTexture::GetTextureName Method (ConstString &, const char *)
shaderMaterialGeoParamValueTexture Class
Show All

Non virtual function

C++
public: static void GetTextureName(
    ConstString & sTextureName,
    const char * szTextureFilename
);
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::GetType Method

shaderMaterialGeoParamValueTexture::GetType Method
shaderMaterialGeoParamValueTexture Class
Show All

Virtual functions

C++
public: int GetType() const;
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::GetTypeName Method

shaderMaterialGeoParamValueTexture::GetTypeName Method
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: const char * GetTypeName() const;
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::GetValue Method

shaderMaterialGeoParamValueTexture::GetValue Method
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: const char * GetValue() const;
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::IsEqual Method

shaderMaterialGeoParamValueTexture::IsEqual Method
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: bool IsEqual(
    const shaderMaterialGeoParamValue * param
) const;
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::ReadGeoParamValueData Method

shaderMaterialGeoParamValueTexture::ReadGeoParamValueData Method
shaderMaterialGeoParamValueTexture Class
Show All

This function reads all the paramdata

C++
public: bool ReadGeoParamValueData(
    fiTokenizer & T
);
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::Reset Method

shaderMaterialGeoParamValueTexture::Reset Method
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: virtual void Reset();
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::SetDefaultValue Method

shaderMaterialGeoParamValueTexture::SetDefaultValue Method
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: void SetDefaultValue(
    grcEffect & effect,
    grcEffectVar & var
);
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::SetValue Method

shaderMaterialGeoParamValueTexture::SetValue Method
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: void SetValue(
    const char * szValue
);
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::Update Method (const bool)

shaderMaterialGeoParamValueTexture::Update Method (const bool)
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: bool Update(
    const bool b
);
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::Update Method (const char *)

shaderMaterialGeoParamValueTexture::Update Method (const char *)
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: bool Update(
    const char * texture
);
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::Update Method (const char *, const float)

shaderMaterialGeoParamValueTexture::Update Method (const char *, const float)
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: bool Update(
    const char * param,
    const float f
);
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::Update Method (const char *, const float, const float, const float)

shaderMaterialGeoParamValueTexture::Update Method (const char *, const float, const float, const float)
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: bool Update(
    const char * param,
    const float f0,
    const float f1,
    const float f2
);
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::Update Method (const float)

shaderMaterialGeoParamValueTexture::Update Method (const float)
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: bool Update(
    const float f
);
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::Update Method (const int)

shaderMaterialGeoParamValueTexture::Update Method (const int)
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: bool Update(
    const int n
);
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::Update Method (const shaderMaterialGeoParamValue *)

shaderMaterialGeoParamValueTexture::Update Method (const shaderMaterialGeoParamValue *)
shaderMaterialGeoParamValueTexture Class
Show All

Update functions

C++
public: bool Update(
    const shaderMaterialGeoParamValue * param
);
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::WriteAsGeoTypeMember Method

shaderMaterialGeoParamValueTexture::WriteAsGeoTypeMember Method
shaderMaterialGeoParamValueTexture Class
Show All
C++
public: virtual void WriteAsGeoTypeMember(
    parTreeNode* pobParent,
    const char* pcTemplateName
) const;
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueTexture::WriteGeoParamValueData Method

shaderMaterialGeoParamValueTexture::WriteGeoParamValueData Method
shaderMaterialGeoParamValueTexture Class
Show All

This function writes out all the param data to the .shadergroup format

C++
public: bool WriteGeoParamValueData(
    fiTokenizer & T
) const;
Class

shaderMaterialGeoParamValueTexture Class

File

shaderMaterialGeoParamValueTexture.h

Links
shaderMaterialGeoParamValueTexture Class


shaderMaterialGeoParamValueVector2 Class

shaderMaterialGeoParamValueVector2 Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::shaderMaterialGeoParamValue
    shaderMaterialGeoParamValueVector2
C++
public: class shaderMaterialGeoParamValueVector2 : public shaderMaterialGeoParamValue;
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueVector2 |
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueVector2 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
Namespace

rage Namespace

File

shaderMaterialGeoParamValueVector2.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoParamValueVector2::shaderMaterialGeoParamValueVector2 Constructor (const parTreeNode*)

shaderMaterialGeoParamValueVector2::shaderMaterialGeoParamValueVector2 Constructor (const parTreeNode*)
shaderMaterialGeoParamValueVector2 Class
Show All
C++
public: shaderMaterialGeoParamValueVector2(
    const parTreeNode* pobGeoParamValueGeoRootNode
);
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::shaderMaterialGeoParamValueVector2 Constructor (const shaderMaterialGeoParamDescription*)

shaderMaterialGeoParamValueVector2::shaderMaterialGeoParamValueVector2 Constructor (const shaderMaterialGeoParamDescription*)
shaderMaterialGeoParamValueVector2 Class
Show All
C++
public: shaderMaterialGeoParamValueVector2(
    const shaderMaterialGeoParamDescription* pobParamDescription
);
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::shaderMaterialGeoParamValueVector2 Constructor (const shaderMaterialGeoParamValueVector2*)

shaderMaterialGeoParamValueVector2::shaderMaterialGeoParamValueVector2 Constructor (const shaderMaterialGeoParamValueVector2*)
shaderMaterialGeoParamValueVector2 Class
Show All
C++
public: shaderMaterialGeoParamValueVector2(
    const shaderMaterialGeoParamValueVector2* pobSourceParam
);
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::~shaderMaterialGeoParamValueVector2 Destructor

shaderMaterialGeoParamValueVector2::~shaderMaterialGeoParamValueVector2 Destructor
shaderMaterialGeoParamValueVector2 Class
Show All
C++
public: virtual ~shaderMaterialGeoParamValueVector2();
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::Copy Method

shaderMaterialGeoParamValueVector2::Copy Method
shaderMaterialGeoParamValueVector2 Class
Show All
C++
public: void Copy(
    const shaderMaterialGeoParamValueVector2 * param
);
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::CopyValueIntoVector2 Method

shaderMaterialGeoParamValueVector2::CopyValueIntoVector2 Method
shaderMaterialGeoParamValueVector2 Class
Show All
C++
public: void CopyValueIntoVector2(
    Vector2 & vData
) const;
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::GetType Method

shaderMaterialGeoParamValueVector2::GetType Method
shaderMaterialGeoParamValueVector2 Class
Show All

Pure virtuals

C++
public: int GetType() const;
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::GetTypeName Method

shaderMaterialGeoParamValueVector2::GetTypeName Method
shaderMaterialGeoParamValueVector2 Class
Show All
C++
public: const char * GetTypeName() const;
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::GetValue Method

shaderMaterialGeoParamValueVector2::GetValue Method
shaderMaterialGeoParamValueVector2 Class
Show All
C++
public: const Vector2 & GetValue() const;
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::IsEqual Method

shaderMaterialGeoParamValueVector2::IsEqual Method
shaderMaterialGeoParamValueVector2 Class
Show All
C++
public: bool IsEqual(
    const shaderMaterialGeoParamValue * param
) const;
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::ReadGeoParamValueData Method

shaderMaterialGeoParamValueVector2::ReadGeoParamValueData Method
shaderMaterialGeoParamValueVector2 Class
Show All

This function reads all the paramdata

C++
public: bool ReadGeoParamValueData(
    fiTokenizer & T
);
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::Reset Method

shaderMaterialGeoParamValueVector2::Reset Method
shaderMaterialGeoParamValueVector2 Class
Show All
C++
public: virtual void Reset();
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::SetDefaultValue Method

shaderMaterialGeoParamValueVector2::SetDefaultValue Method
shaderMaterialGeoParamValueVector2 Class
Show All
C++
public: void SetDefaultValue(
    grcEffect & effect,
    grcEffectVar & var
);
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::SetMaterialValue Method

shaderMaterialGeoParamValueVector2::SetMaterialValue Method
shaderMaterialGeoParamValueVector2 Class
Show All
C++
public: void SetMaterialValue(
    Vector2 & vValue
);
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::SetValue Method

shaderMaterialGeoParamValueVector2::SetValue Method
shaderMaterialGeoParamValueVector2 Class
Show All
C++
public: void SetValue(
    const Vector2& vValue
);
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::Update Method (const Vector2&)

shaderMaterialGeoParamValueVector2::Update Method (const Vector2&)
shaderMaterialGeoParamValueVector2 Class
Show All
C++
public: bool Update(
    const Vector2& obValue
);
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::Update Method (const char *, const float)

shaderMaterialGeoParamValueVector2::Update Method (const char *, const float)
shaderMaterialGeoParamValueVector2 Class
Show All
C++
public: bool Update(
    const char * param,
    const float f
);
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::Update Method (const shaderMaterialGeoParamValue *)

shaderMaterialGeoParamValueVector2::Update Method (const shaderMaterialGeoParamValue *)
shaderMaterialGeoParamValueVector2 Class
Show All

Update functions

C++
public: bool Update(
    const shaderMaterialGeoParamValue * param
);
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::WriteAsGeoTypeMember Method

shaderMaterialGeoParamValueVector2::WriteAsGeoTypeMember Method
shaderMaterialGeoParamValueVector2 Class
Show All
C++
public: virtual void WriteAsGeoTypeMember(
    parTreeNode* pobParent,
    const char* pcTemplateName
) const;
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector2::WriteGeoParamValueData Method

shaderMaterialGeoParamValueVector2::WriteGeoParamValueData Method
shaderMaterialGeoParamValueVector2 Class
Show All

This function writes out all the param data to the .shadergroup format

C++
public: bool WriteGeoParamValueData(
    fiTokenizer & T
) const;
Class

shaderMaterialGeoParamValueVector2 Class

File

shaderMaterialGeoParamValueVector2.h

Links
shaderMaterialGeoParamValueVector2 Class


shaderMaterialGeoParamValueVector3 Class

shaderMaterialGeoParamValueVector3 Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::shaderMaterialGeoParamValue
    shaderMaterialGeoParamValueVector3
C++
public: class shaderMaterialGeoParamValueVector3 : public shaderMaterialGeoParamValue;
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueVector3 |
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueVector3 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
Namespace

rage Namespace

File

shaderMaterialGeoParamValueVector3.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoParamValueVector3::shaderMaterialGeoParamValueVector3 Constructor (const parTreeNode*)

shaderMaterialGeoParamValueVector3::shaderMaterialGeoParamValueVector3 Constructor (const parTreeNode*)
shaderMaterialGeoParamValueVector3 Class
Show All
C++
public: shaderMaterialGeoParamValueVector3(
    const parTreeNode* pobGeoParamValueGeoRootNode
);
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector3::shaderMaterialGeoParamValueVector3 Constructor (const shaderMaterialGeoParamDescription*)

shaderMaterialGeoParamValueVector3::shaderMaterialGeoParamValueVector3 Constructor (const shaderMaterialGeoParamDescription*)
shaderMaterialGeoParamValueVector3 Class
Show All
C++
public: shaderMaterialGeoParamValueVector3(
    const shaderMaterialGeoParamDescription* pobParamDescription
);
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector3::shaderMaterialGeoParamValueVector3 Constructor (const shaderMaterialGeoParamValueVector3*)

shaderMaterialGeoParamValueVector3::shaderMaterialGeoParamValueVector3 Constructor (const shaderMaterialGeoParamValueVector3*)
shaderMaterialGeoParamValueVector3 Class
Show All
C++
public: shaderMaterialGeoParamValueVector3(
    const shaderMaterialGeoParamValueVector3* pobSourceParam
);
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector3::~shaderMaterialGeoParamValueVector3 Destructor

shaderMaterialGeoParamValueVector3::~shaderMaterialGeoParamValueVector3 Destructor
shaderMaterialGeoParamValueVector3 Class
Show All
C++
public: virtual ~shaderMaterialGeoParamValueVector3();
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector3::Copy Method

shaderMaterialGeoParamValueVector3::Copy Method
shaderMaterialGeoParamValueVector3 Class
Show All
C++
public: void Copy(
    const shaderMaterialGeoParamValueVector3 * param
);
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector3::GetType Method

shaderMaterialGeoParamValueVector3::GetType Method
shaderMaterialGeoParamValueVector3 Class
Show All

Pure virtuals

C++
public: int GetType() const;
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector3::GetTypeName Method

shaderMaterialGeoParamValueVector3::GetTypeName Method
shaderMaterialGeoParamValueVector3 Class
Show All
C++
public: const char * GetTypeName() const;
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector3::GetValue Method

shaderMaterialGeoParamValueVector3::GetValue Method
shaderMaterialGeoParamValueVector3 Class
Show All
C++
public: const Vector3 & GetValue() const;
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector3::IsEqual Method

shaderMaterialGeoParamValueVector3::IsEqual Method
shaderMaterialGeoParamValueVector3 Class
Show All
C++
public: bool IsEqual(
    const shaderMaterialGeoParamValue * param
) const;
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector3::ReadGeoParamValueData Method

shaderMaterialGeoParamValueVector3::ReadGeoParamValueData Method
shaderMaterialGeoParamValueVector3 Class
Show All

This function reads all the paramdata

C++
public: bool ReadGeoParamValueData(
    fiTokenizer & T
);
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector3::Reset Method

shaderMaterialGeoParamValueVector3::Reset Method
shaderMaterialGeoParamValueVector3 Class
Show All
C++
public: virtual void Reset();
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector3::SetDefaultValue Method

shaderMaterialGeoParamValueVector3::SetDefaultValue Method
shaderMaterialGeoParamValueVector3 Class
Show All
C++
public: void SetDefaultValue(
    grcEffect & effect,
    grcEffectVar & var
);
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector3::SetValue Method

shaderMaterialGeoParamValueVector3::SetValue Method
shaderMaterialGeoParamValueVector3 Class
Show All
C++
public: void SetValue(
    const Vector3& vValue
);
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector3::Update Method (const Vector3&)

shaderMaterialGeoParamValueVector3::Update Method (const Vector3&)
shaderMaterialGeoParamValueVector3 Class
Show All
C++
public: bool Update(
    const Vector3& obValue
);
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector3::Update Method (const char *, const float)

shaderMaterialGeoParamValueVector3::Update Method (const char *, const float)
shaderMaterialGeoParamValueVector3 Class
Show All
C++
public: bool Update(
    const char * param,
    const float f
);
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector3::Update Method (const char *, const float, const float, const float)

shaderMaterialGeoParamValueVector3::Update Method (const char *, const float, const float, const float)
shaderMaterialGeoParamValueVector3 Class
Show All
C++
public: bool Update(
    const char * param,
    const float f0,
    const float f1,
    const float f2
);
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector3::Update Method (const shaderMaterialGeoParamValue *)

shaderMaterialGeoParamValueVector3::Update Method (const shaderMaterialGeoParamValue *)
shaderMaterialGeoParamValueVector3 Class
Show All

Update functions

C++
public: bool Update(
    const shaderMaterialGeoParamValue * param
);
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector3::WriteAsGeoTypeMember Method

shaderMaterialGeoParamValueVector3::WriteAsGeoTypeMember Method
shaderMaterialGeoParamValueVector3 Class
Show All
C++
public: virtual void WriteAsGeoTypeMember(
    parTreeNode* pobParent,
    const char* pcTemplateName
) const;
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector3::WriteGeoParamValueData Method

shaderMaterialGeoParamValueVector3::WriteGeoParamValueData Method
shaderMaterialGeoParamValueVector3 Class
Show All

This function writes out all the param data to the .shadergroup format

C++
public: bool WriteGeoParamValueData(
    fiTokenizer & T
) const;
Class

shaderMaterialGeoParamValueVector3 Class

File

shaderMaterialGeoParamValueVector3.h

Links
shaderMaterialGeoParamValueVector3 Class


shaderMaterialGeoParamValueVector4 Class

shaderMaterialGeoParamValueVector4 Class
Constructors | Destructors | Members | Methods | Data Members | Enumerations | rage Namespace | Inheritance Hierarchy
Show All
rage::shaderMaterialGeoParamValue
    shaderMaterialGeoParamValueVector4
C++
public: class shaderMaterialGeoParamValueVector4 : public shaderMaterialGeoParamValue;
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueVector4 |
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueVector4 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
Namespace

rage Namespace

File

shaderMaterialGeoParamValueVector4.h

Links
Constructors, Destructors, Members, Methods, Data Members, Enumerations, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoParamValueVector4::shaderMaterialGeoParamValueVector4 Constructor (const parTreeNode*)

shaderMaterialGeoParamValueVector4::shaderMaterialGeoParamValueVector4 Constructor (const parTreeNode*)
shaderMaterialGeoParamValueVector4 Class
Show All
C++
public: shaderMaterialGeoParamValueVector4(
    const parTreeNode* pobGeoParamValueGeoRootNode
);
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoParamValueVector4::shaderMaterialGeoParamValueVector4 Constructor (const shaderMaterialGeoParamDescription*)

shaderMaterialGeoParamValueVector4::shaderMaterialGeoParamValueVector4 Constructor (const shaderMaterialGeoParamDescription*)
shaderMaterialGeoParamValueVector4 Class
Show All
C++
public: shaderMaterialGeoParamValueVector4(
    const shaderMaterialGeoParamDescription* pobParamDescription
);
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoParamValueVector4::shaderMaterialGeoParamValueVector4 Constructor (const shaderMaterialGeoParamValueVector4*)

shaderMaterialGeoParamValueVector4::shaderMaterialGeoParamValueVector4 Constructor (const shaderMaterialGeoParamValueVector4*)
shaderMaterialGeoParamValueVector4 Class
Show All
C++
public: shaderMaterialGeoParamValueVector4(
    const shaderMaterialGeoParamValueVector4* pobSourceParam
);
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoParamValueVector4::~shaderMaterialGeoParamValueVector4 Destructor

shaderMaterialGeoParamValueVector4::~shaderMaterialGeoParamValueVector4 Destructor
shaderMaterialGeoParamValueVector4 Class
Show All
C++
public: virtual ~shaderMaterialGeoParamValueVector4();
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoParamValueVector4::Copy Method

shaderMaterialGeoParamValueVector4::Copy Method
shaderMaterialGeoParamValueVector4 Class
Show All
C++
public: void Copy(
    const shaderMaterialGeoParamValueVector4 * param
);
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoParamValueVector4::GetType Method

shaderMaterialGeoParamValueVector4::GetType Method
shaderMaterialGeoParamValueVector4 Class
Show All

Pure virtuals

C++
public: int GetType() const;
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoParamValueVector4::GetTypeName Method

shaderMaterialGeoParamValueVector4::GetTypeName Method
shaderMaterialGeoParamValueVector4 Class
Show All
C++
public: const char * GetTypeName() const;
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoParamValueVector4::GetValue Method

shaderMaterialGeoParamValueVector4::GetValue Method
shaderMaterialGeoParamValueVector4 Class
Show All
C++
public: const Vector4 & GetValue() const;
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoParamValueVector4::IsEqual Method

shaderMaterialGeoParamValueVector4::IsEqual Method
shaderMaterialGeoParamValueVector4 Class
Show All
C++
public: bool IsEqual(
    const shaderMaterialGeoParamValue * param
) const;
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoParamValueVector4::ReadGeoParamValueData Method

shaderMaterialGeoParamValueVector4::ReadGeoParamValueData Method
shaderMaterialGeoParamValueVector4 Class
Show All

This function reads all the paramdata

C++
public: bool ReadGeoParamValueData(
    fiTokenizer & T
);
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoParamValueVector4::Reset Method

shaderMaterialGeoParamValueVector4::Reset Method
shaderMaterialGeoParamValueVector4 Class
Show All
C++
public: virtual void Reset();
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoParamValueVector4::SetDefaultValue Method

shaderMaterialGeoParamValueVector4::SetDefaultValue Method
shaderMaterialGeoParamValueVector4 Class
Show All
C++
public: void SetDefaultValue(
    grcEffect & effect,
    grcEffectVar & var
);
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoParamValueVector4::SetValue Method

shaderMaterialGeoParamValueVector4::SetValue Method
shaderMaterialGeoParamValueVector4 Class
Show All
C++
public: void SetValue(
    const Vector4& vValue
);
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoParamValueVector4::Update Method (const Vector4&)

shaderMaterialGeoParamValueVector4::Update Method (const Vector4&)
shaderMaterialGeoParamValueVector4 Class
Show All
C++
public: bool Update(
    const Vector4& obValue
);
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoParamValueVector4::Update Method (const char *, const float)

shaderMaterialGeoParamValueVector4::Update Method (const char *, const float)
shaderMaterialGeoParamValueVector4 Class
Show All
C++
public: bool Update(
    const char * param,
    const float f
);
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoParamValueVector4::Update Method (const char *, const float, const float, const float)

shaderMaterialGeoParamValueVector4::Update Method (const char *, const float, const float, const float)
shaderMaterialGeoParamValueVector4 Class
Show All
C++
public: bool Update(
    const char * param,
    const float f0,
    const float f1,
    const float f2
);
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoParamValueVector4::Update Method (const shaderMaterialGeoParamValue *)

shaderMaterialGeoParamValueVector4::Update Method (const shaderMaterialGeoParamValue *)
shaderMaterialGeoParamValueVector4 Class
Show All

Update functions

C++
public: bool Update(
    const shaderMaterialGeoParamValue * param
);
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoParamValueVector4::WriteAsGeoTypeMember Method

shaderMaterialGeoParamValueVector4::WriteAsGeoTypeMember Method
shaderMaterialGeoParamValueVector4 Class
Show All
C++
public: virtual void WriteAsGeoTypeMember(
    parTreeNode* pobParent,
    const char* pcTemplateName
) const;
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoParamValueVector4::WriteGeoParamValueData Method

shaderMaterialGeoParamValueVector4::WriteGeoParamValueData Method
shaderMaterialGeoParamValueVector4 Class
Show All

This function writes out all the param data to the .shadergroup format

C++
public: bool WriteGeoParamValueData(
    fiTokenizer & T
) const;
Class

shaderMaterialGeoParamValueVector4 Class

File

shaderMaterialGeoParamValueVector4.h

Links
shaderMaterialGeoParamValueVector4 Class


shaderMaterialGeoTemplate Class

shaderMaterialGeoTemplate Class
Constructors | Destructors | Members | Methods | rage Namespace | Inheritance Hierarchy
Show All
shaderMaterialGeoTemplate
C++
public: class shaderMaterialGeoTemplate;
Constructors
Constructor | Description
shaderMaterialGeoTemplate |
Destructors
Destructor | Description
~shaderMaterialGeoTemplate |
Methods
Method | Description
CreateFromShader |
GetBucketNumber |
GetParamDescription |
GetRunTimeVertexColourDescriptions |
GetShaderFilename |
GetShaderName |
GetShaderParamDescriptions |
GetShaderPathAndFilename |
GetSourceVertexColourDescriptions |
GetTemplateFilename |
GetTemplateName |
GetTemplatePathAndFilename |
LoadFromGeoTemplate |
SaveTo |
Namespace

rage Namespace

File

shaderMaterialGeoTemplate.h

Links
Constructors, Destructors, Members, Methods, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoTemplate::shaderMaterialGeoTemplate Constructor ()

shaderMaterialGeoTemplate::shaderMaterialGeoTemplate Constructor ()
shaderMaterialGeoTemplate Class
Show All
C++
public: shaderMaterialGeoTemplate();
Class

shaderMaterialGeoTemplate Class

File

shaderMaterialGeoTemplate.h

Links
shaderMaterialGeoTemplate Class


shaderMaterialGeoTemplate::shaderMaterialGeoTemplate Constructor (const char *)

shaderMaterialGeoTemplate::shaderMaterialGeoTemplate Constructor (const char *)
shaderMaterialGeoTemplate Class
Show All
C++
public: shaderMaterialGeoTemplate(
    const char * szFilename
);
Class

shaderMaterialGeoTemplate Class

File

shaderMaterialGeoTemplate.h

Links
shaderMaterialGeoTemplate Class


shaderMaterialGeoTemplate::~shaderMaterialGeoTemplate Destructor

shaderMaterialGeoTemplate::~shaderMaterialGeoTemplate Destructor
shaderMaterialGeoTemplate Class
Show All
C++
public: virtual ~shaderMaterialGeoTemplate();
Class

shaderMaterialGeoTemplate Class

File

shaderMaterialGeoTemplate.h

Links
shaderMaterialGeoTemplate Class


shaderMaterialGeoTemplate::CreateFromShader Method

shaderMaterialGeoTemplate::CreateFromShader Method
shaderMaterialGeoTemplate Class
Show All
C++
public: bool CreateFromShader(
    const char * pcShaderFilename
);
Class

shaderMaterialGeoTemplate Class

File

shaderMaterialGeoTemplate.h

Links
shaderMaterialGeoTemplate Class


shaderMaterialGeoTemplate::GetBucketNumber Method

shaderMaterialGeoTemplate::GetBucketNumber Method
shaderMaterialGeoTemplate Class
Show All
C++
public: int GetBucketNumber() const;
Class

shaderMaterialGeoTemplate Class

File

shaderMaterialGeoTemplate.h

Links
shaderMaterialGeoTemplate Class


shaderMaterialGeoTemplate::GetParamDescription Method

shaderMaterialGeoTemplate::GetParamDescription Method
shaderMaterialGeoTemplate Class
Show All
C++
public: const shaderMaterialGeoParamDescription* GetParamDescription(
    const char* pcParamName
) const;
Class

shaderMaterialGeoTemplate Class

File

shaderMaterialGeoTemplate.h

Links
shaderMaterialGeoTemplate Class


shaderMaterialGeoTemplate::GetRunTimeVertexColourDescriptions Method

shaderMaterialGeoTemplate::GetRunTimeVertexColourDescriptions Method
shaderMaterialGeoTemplate Class
Show All
C++
public: const rsmRunTimeVertexColourDescriptions& GetRunTimeVertexColourDescriptions() const;
Class

shaderMaterialGeoTemplate Class

File

shaderMaterialGeoTemplate.h

Links
shaderMaterialGeoTemplate Class


shaderMaterialGeoTemplate::GetShaderFilename Method

shaderMaterialGeoTemplate::GetShaderFilename Method
shaderMaterialGeoTemplate Class
Show All
C++
public: const char* GetShaderFilename() const;
Class

shaderMaterialGeoTemplate Class

File

shaderMaterialGeoTemplate.h

Links
shaderMaterialGeoTemplate Class


shaderMaterialGeoTemplate::GetShaderName Method

shaderMaterialGeoTemplate::GetShaderName Method
shaderMaterialGeoTemplate Class
Show All
C++
public: const char* GetShaderName() const;
Class

shaderMaterialGeoTemplate Class

File

shaderMaterialGeoTemplate.h

Links
shaderMaterialGeoTemplate Class


shaderMaterialGeoTemplate::GetShaderParamDescriptions Method

shaderMaterialGeoTemplate::GetShaderParamDescriptions Method
shaderMaterialGeoTemplate Class
Show All
C++
public: const atArray <shaderMaterialGeoParamDescription *>* GetShaderParamDescriptions() const;
Class

shaderMaterialGeoTemplate Class

File

shaderMaterialGeoTemplate.h

Links
shaderMaterialGeoTemplate Class


shaderMaterialGeoTemplate::GetShaderPathAndFilename Method

shaderMaterialGeoTemplate::GetShaderPathAndFilename Method
shaderMaterialGeoTemplate Class
Show All
C++
public: const char* GetShaderPathAndFilename() const;
Class

shaderMaterialGeoTemplate Class

File

shaderMaterialGeoTemplate.h

Links
shaderMaterialGeoTemplate Class


shaderMaterialGeoTemplate::GetSourceVertexColourDescriptions Method

shaderMaterialGeoTemplate::GetSourceVertexColourDescriptions Method
shaderMaterialGeoTemplate Class
Show All
C++
public: const rsmSourceVertexColourDescriptions& GetSourceVertexColourDescriptions() const;
Class

shaderMaterialGeoTemplate Class

File

shaderMaterialGeoTemplate.h

Links
shaderMaterialGeoTemplate Class


shaderMaterialGeoTemplate::GetTemplateFilename Method

shaderMaterialGeoTemplate::GetTemplateFilename Method
shaderMaterialGeoTemplate Class
Show All
C++
public: const char* GetTemplateFilename() const;
Class

shaderMaterialGeoTemplate Class

File

shaderMaterialGeoTemplate.h

Links
shaderMaterialGeoTemplate Class


shaderMaterialGeoTemplate::GetTemplateName Method

shaderMaterialGeoTemplate::GetTemplateName Method
shaderMaterialGeoTemplate Class
Show All
C++
public: const char* GetTemplateName() const;
Class

shaderMaterialGeoTemplate Class

File

shaderMaterialGeoTemplate.h

Links
shaderMaterialGeoTemplate Class


shaderMaterialGeoTemplate::GetTemplatePathAndFilename Method

shaderMaterialGeoTemplate::GetTemplatePathAndFilename Method
shaderMaterialGeoTemplate Class
Show All
C++
public: const char* GetTemplatePathAndFilename() const;
Class

shaderMaterialGeoTemplate Class

File

shaderMaterialGeoTemplate.h

Links
shaderMaterialGeoTemplate Class


shaderMaterialGeoTemplate::LoadFromGeoTemplate Method

shaderMaterialGeoTemplate::LoadFromGeoTemplate Method
shaderMaterialGeoTemplate Class
Show All
C++
public: bool LoadFromGeoTemplate(
    const char * szFilename
);
Class

shaderMaterialGeoTemplate Class

File

shaderMaterialGeoTemplate.h

Links
shaderMaterialGeoTemplate Class


shaderMaterialGeoTemplate::SaveTo Method

shaderMaterialGeoTemplate::SaveTo Method
shaderMaterialGeoTemplate Class
Show All
C++
public: bool SaveTo(
    const char * szFilename
) const;
Class

shaderMaterialGeoTemplate Class

File

shaderMaterialGeoTemplate.h

Links
shaderMaterialGeoTemplate Class


shaderMaterialGeoType Class

shaderMaterialGeoType Class
Constructors | Destructors | Members | Methods | Operators | Data Members | rage Namespace | Inheritance Hierarchy
Show All
shaderMaterialGeoType
    rage::shaderMaterialGeoInstance
C++
public: class shaderMaterialGeoType;
Constructors
Constructor | Description
shaderMaterialGeoType |
Destructors
Destructor | Description
~shaderMaterialGeoType |
Methods
Method | Description
AddParamValuesFromParamDescriptions | Loading and saving
AssignNewUID |
ChangeParentType |
ConstructFromParentType |
Copy |
CopyParamValues |
CopyParamValuesSelectively |
GetNoOfParams | Param accessors
GetNoOfShaderParams |
GetParam |
GetParamByUIName |
GetParentType |
GetParentTypeFilename |
GetParentTypeName |
GetParentTypePathAndFilename |
GetShaderParam |
GetShaderParamByUIName |
GetTemplate |
GetTypeFilename | Accessors
GetTypeName |
GetTypePathAndFilename |
GetUID |
GetUvSetCount |
InitialiseFromTemplate |
IsEqual |
LoadFromGeoType |
LoadParameterFromGeoType |
SaveTo |
SaveToGeoType |
SetParentTypePathAndFilename |
SetShaderVariableValue | sets the value of the grmShaderVar from the stored data
SetTypePathAndFilename |
SetUIDToString |
UpdateShaderVariable | Sets the value of the stored data from grmShaderVar
Operators
Operator | Description
= | Assignment operator
== |
Data Members
Data Member | Description
m_apShaderParamValues |
m_bInstance |
m_pobParentType |
m_pobTemplate |
m_sGeoTypeUID |
m_strParentTypeName |
m_strParentTypePathAndFilename | Useful info
m_strTypeName |
m_strTypePathAndFilename |
Namespace

rage Namespace

File

shaderMaterialGeoType.h

Links
Constructors, Destructors, Members, Methods, Operators, Data Members, rage Namespace, Inheritance Hierarchy


shaderMaterialGeoType::m_apShaderParamValues Data Member

shaderMaterialGeoType::m_apShaderParamValues Data Member
shaderMaterialGeoType Class
Show All
C++
protected: atArray <shaderMaterialGeoParamValue *> m_apShaderParamValues;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::m_bInstance Data Member

shaderMaterialGeoType::m_bInstance Data Member
shaderMaterialGeoType Class
Show All
C++
protected: bool m_bInstance;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::m_pobParentType Data Member

shaderMaterialGeoType::m_pobParentType Data Member
shaderMaterialGeoType Class
Show All
C++
protected: const shaderMaterialGeoType* m_pobParentType;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::m_pobTemplate Data Member

shaderMaterialGeoType::m_pobTemplate Data Member
shaderMaterialGeoType Class
Show All
C++
protected: const shaderMaterialGeoTemplate* m_pobTemplate;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::m_sGeoTypeUID Data Member

shaderMaterialGeoType::m_sGeoTypeUID Data Member
shaderMaterialGeoType Class
Show All
C++
protected: mutable ConstString m_sGeoTypeUID;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::m_strParentTypeName Data Member

shaderMaterialGeoType::m_strParentTypeName Data Member
shaderMaterialGeoType Class
Show All
C++
protected: ConstString m_strParentTypeName;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::m_strParentTypePathAndFilename Data Member

shaderMaterialGeoType::m_strParentTypePathAndFilename Data Member
shaderMaterialGeoType Class
Show All

Useful info

C++
protected: ConstString m_strParentTypePathAndFilename;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::m_strTypeName Data Member

shaderMaterialGeoType::m_strTypeName Data Member
shaderMaterialGeoType Class
Show All
C++
protected: ConstString m_strTypeName;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::m_strTypePathAndFilename Data Member

shaderMaterialGeoType::m_strTypePathAndFilename Data Member
shaderMaterialGeoType Class
Show All
C++
protected: ConstString m_strTypePathAndFilename;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::shaderMaterialGeoType Constructor ()

shaderMaterialGeoType::shaderMaterialGeoType Constructor ()
shaderMaterialGeoType Class
Show All
C++
public: shaderMaterialGeoType();
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::shaderMaterialGeoType Constructor (const shaderMaterialGeoType &)

shaderMaterialGeoType::shaderMaterialGeoType Constructor (const shaderMaterialGeoType &)
shaderMaterialGeoType Class
Show All

Copy constructor

C++
public: shaderMaterialGeoType(
    const shaderMaterialGeoType &
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::~shaderMaterialGeoType Destructor

shaderMaterialGeoType::~shaderMaterialGeoType Destructor
shaderMaterialGeoType Class
Show All
C++
public: virtual ~shaderMaterialGeoType();
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::AddParamValuesFromParamDescriptions Method

shaderMaterialGeoType::AddParamValuesFromParamDescriptions Method
shaderMaterialGeoType Class
Show All

Loading and saving

C++
protected: void AddParamValuesFromParamDescriptions(
    const atArray <shaderMaterialGeoParamDescription *>* papParamDescriptions,
    atArray <shaderMaterialGeoParamValue *>* papParamValues
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::AssignNewUID Method

shaderMaterialGeoType::AssignNewUID Method
shaderMaterialGeoType Class
Show All
C++
protected: void AssignNewUID() const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::ChangeParentType Method

shaderMaterialGeoType::ChangeParentType Method
shaderMaterialGeoType Class
Show All
C++
public: bool ChangeParentType(
    const shaderMaterialGeoType* pobNewParentShaderMaterialGeoType
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::ConstructFromParentType Method

shaderMaterialGeoType::ConstructFromParentType Method
shaderMaterialGeoType Class
Show All
C++
public: virtual bool ConstructFromParentType(
    const shaderMaterialGeoType* pobParentShaderMaterialGeoType
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::Copy Method

shaderMaterialGeoType::Copy Method
shaderMaterialGeoType Class
Show All
C++
protected: void Copy(
    const shaderMaterialGeoType & obThat
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::CopyParamValues Method

shaderMaterialGeoType::CopyParamValues Method
shaderMaterialGeoType Class
Show All
C++
protected: void CopyParamValues(
    const shaderMaterialGeoType & obThat
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::CopyParamValuesSelectively Method

shaderMaterialGeoType::CopyParamValuesSelectively Method
shaderMaterialGeoType Class
Show All
C++
public: virtual void CopyParamValuesSelectively(
    const shaderMaterialGeoType & obThat
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetNoOfParams Method

shaderMaterialGeoType::GetNoOfParams Method
shaderMaterialGeoType Class
Show All

Param accessors

C++
public: int GetNoOfParams() const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetNoOfShaderParams Method

shaderMaterialGeoType::GetNoOfShaderParams Method
shaderMaterialGeoType Class
Show All
C++
public: int GetNoOfShaderParams() const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetParam Method (const char*)

shaderMaterialGeoType::GetParam Method (const char*)
shaderMaterialGeoType Class
Show All
C++
public: shaderMaterialGeoParamValue * GetParam(
    const char* pcParamName
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetParam Method (const char*)

shaderMaterialGeoType::GetParam Method (const char*)
shaderMaterialGeoType Class
Show All
C++
public: const shaderMaterialGeoParamValue * GetParam(
    const char* pcParamName
) const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetParam Method (int)

shaderMaterialGeoType::GetParam Method (int)
shaderMaterialGeoType Class
Show All
C++
public: shaderMaterialGeoParamValue * GetParam(
    int iParamNo
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetParam Method (int)

shaderMaterialGeoType::GetParam Method (int)
shaderMaterialGeoType Class
Show All
C++
public: const shaderMaterialGeoParamValue * GetParam(
    int iParamNo
) const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetParamByUIName Method (const char*)

shaderMaterialGeoType::GetParamByUIName Method (const char*)
shaderMaterialGeoType Class
Show All
C++
public: shaderMaterialGeoParamValue * GetParamByUIName(
    const char* pcParamName
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetParamByUIName Method (const char*)

shaderMaterialGeoType::GetParamByUIName Method (const char*)
shaderMaterialGeoType Class
Show All
C++
public: const shaderMaterialGeoParamValue * GetParamByUIName(
    const char* pcParamName
) const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetParentType Method

shaderMaterialGeoType::GetParentType Method
shaderMaterialGeoType Class
Show All
C++
public: const shaderMaterialGeoType* GetParentType() const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetParentTypeFilename Method

shaderMaterialGeoType::GetParentTypeFilename Method
shaderMaterialGeoType Class
Show All
C++
public: const char* GetParentTypeFilename() const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetParentTypeName Method

shaderMaterialGeoType::GetParentTypeName Method
shaderMaterialGeoType Class
Show All
C++
public: const char* GetParentTypeName() const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetParentTypePathAndFilename Method

shaderMaterialGeoType::GetParentTypePathAndFilename Method
shaderMaterialGeoType Class
Show All
C++
public: const char* GetParentTypePathAndFilename() const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetShaderParam Method (const char*)

shaderMaterialGeoType::GetShaderParam Method (const char*)
shaderMaterialGeoType Class
Show All
C++
public: shaderMaterialGeoParamValue * GetShaderParam(
    const char* pcParamName
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetShaderParam Method (const char*)

shaderMaterialGeoType::GetShaderParam Method (const char*)
shaderMaterialGeoType Class
Show All
C++
public: const shaderMaterialGeoParamValue * GetShaderParam(
    const char* pcParamName
) const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetShaderParam Method (int)

shaderMaterialGeoType::GetShaderParam Method (int)
shaderMaterialGeoType Class
Show All
C++
public: shaderMaterialGeoParamValue * GetShaderParam(
    int iParamNo
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetShaderParam Method (int)

shaderMaterialGeoType::GetShaderParam Method (int)
shaderMaterialGeoType Class
Show All
C++
public: const shaderMaterialGeoParamValue * GetShaderParam(
    int iParamNo
) const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetShaderParamByUIName Method (const char*)

shaderMaterialGeoType::GetShaderParamByUIName Method (const char*)
shaderMaterialGeoType Class
Show All
C++
public: shaderMaterialGeoParamValue * GetShaderParamByUIName(
    const char* pcParamName
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetShaderParamByUIName Method (const char*)

shaderMaterialGeoType::GetShaderParamByUIName Method (const char*)
shaderMaterialGeoType Class
Show All
C++
public: const shaderMaterialGeoParamValue * GetShaderParamByUIName(
    const char* pcParamName
) const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetTemplate Method

shaderMaterialGeoType::GetTemplate Method
shaderMaterialGeoType Class
Show All
C++
public: virtual const shaderMaterialGeoTemplate* GetTemplate() const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetTypeFilename Method

shaderMaterialGeoType::GetTypeFilename Method
shaderMaterialGeoType Class
Show All

Accessors

C++
public: const char* GetTypeFilename() const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetTypeName Method

shaderMaterialGeoType::GetTypeName Method
shaderMaterialGeoType Class
Show All
C++
public: const char* GetTypeName() const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetTypePathAndFilename Method

shaderMaterialGeoType::GetTypePathAndFilename Method
shaderMaterialGeoType Class
Show All
C++
public: const char* GetTypePathAndFilename() const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetUID Method

shaderMaterialGeoType::GetUID Method
shaderMaterialGeoType Class
Show All
C++
public: const char* GetUID() const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::GetUvSetCount Method

shaderMaterialGeoType::GetUvSetCount Method
shaderMaterialGeoType Class
Show All
C++
public: int GetUvSetCount() const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::InitialiseFromTemplate Method

shaderMaterialGeoType::InitialiseFromTemplate Method
shaderMaterialGeoType Class
Show All
C++
public: bool InitialiseFromTemplate(
    const shaderMaterialGeoTemplate* pobShaderMaterialGeoTemplate
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::IsEqual Method

shaderMaterialGeoType::IsEqual Method
shaderMaterialGeoType Class
Show All
C++
public: bool IsEqual(
    const shaderMaterialGeoType & that
) const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::LoadFromGeoType Method (const char *)

shaderMaterialGeoType::LoadFromGeoType Method (const char *)
shaderMaterialGeoType Class
Show All
C++
public: bool LoadFromGeoType(
    const char * szFilename
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::LoadFromGeoType Method (fiStream *)

shaderMaterialGeoType::LoadFromGeoType Method (fiStream *)
shaderMaterialGeoType Class
Show All
C++
protected: bool LoadFromGeoType(
    fiStream * s
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::LoadParameterFromGeoType Method

shaderMaterialGeoType::LoadParameterFromGeoType Method
shaderMaterialGeoType Class
Show All
C++
protected: bool LoadParameterFromGeoType(
    parTreeNode* pobMemberNode,
    shaderMaterialGeoParamValue* pobParam
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::SaveTo Method

shaderMaterialGeoType::SaveTo Method
shaderMaterialGeoType Class
Show All
C++
public: virtual bool SaveTo(
    const char * szFilename
) const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::SaveToGeoType Method (const char *)

shaderMaterialGeoType::SaveToGeoType Method (const char *)
shaderMaterialGeoType Class
Show All
C++
protected: bool SaveToGeoType(
    const char * szFilename
) const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::SaveToGeoType Method (fiStream *)

shaderMaterialGeoType::SaveToGeoType Method (fiStream *)
shaderMaterialGeoType Class
Show All
C++
protected: bool SaveToGeoType(
    fiStream * s
) const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::SetParentTypePathAndFilename Method

shaderMaterialGeoType::SetParentTypePathAndFilename Method
shaderMaterialGeoType Class
Show All
C++
protected: void SetParentTypePathAndFilename(
    const char* pcParentTypePathAndFilename
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::SetShaderVariableValue Method

shaderMaterialGeoType::SetShaderVariableValue Method
shaderMaterialGeoType Class
Show All

sets the value of the grmShaderVar from the stored data

C++
public: bool SetShaderVariableValue(
    grmShaderVar & var
) const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::SetTypePathAndFilename Method

shaderMaterialGeoType::SetTypePathAndFilename Method
shaderMaterialGeoType Class
Show All
C++
protected: void SetTypePathAndFilename(
    const char* pcTypePathAndFilename
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::SetUIDToString Method

shaderMaterialGeoType::SetUIDToString Method
shaderMaterialGeoType Class
Show All
C++
protected: void SetUIDToString(
    const char* pcDebugText
) const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::UpdateShaderVariable Method

shaderMaterialGeoType::UpdateShaderVariable Method
shaderMaterialGeoType Class
Show All

Sets the value of the stored data from grmShaderVar

C++
public: bool UpdateShaderVariable(
    const grmShaderVar & var
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::= Operator

shaderMaterialGeoType::= Operator
shaderMaterialGeoType Class
Show All

Assignment operator

C++
public: shaderMaterialGeoType & operator =(
    const shaderMaterialGeoType & rhs
);
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


shaderMaterialGeoType::== Operator

shaderMaterialGeoType::== Operator
shaderMaterialGeoType Class
Show All
C++
public: bool operator ==(
    const shaderMaterialGeoType & that
) const;
Class

shaderMaterialGeoType Class

File

shaderMaterialGeoType.h

Links
shaderMaterialGeoType Class


rage::grmVariableInfo Type

rage::grmVariableInfo Type
rage Namespace
Show All
C++
typedef grcEffect::VariableInfo grmVariableInfo;
Namespace

rage Namespace

File

shaderMaterialGeoParamDescription.h

Links
rage Namespace


rage::DEFAULT_UV_SET_NAME Macro

rage::DEFAULT_UV_SET_NAME Macro
rage Namespace
Show All
C++
#define DEFAULT_UV_SET_NAME "map1"
Namespace

rage Namespace

File

shaderMaterialGeoParamDescriptionTexture.h

Links
rage Namespace


shaderMaterialGeoManager::m_gShaderMaterialGeoManager Variable

shaderMaterialGeoManager::m_gShaderMaterialGeoManager Variable
Show All
C++
shaderMaterialGeoManager* shaderMaterialGeoManager::m_gShaderMaterialGeoManager = NULL;
File

shaderMaterialGeoManager.cpp


shaderMaterialGeoParamDescription::LIGHTMAP_TYPE_NAMES Variable

shaderMaterialGeoParamDescription::LIGHTMAP_TYPE_NAMES Variable
Show All
C++
const char * shaderMaterialGeoParamDescription::LIGHTMAP_TYPE_NAMES[] = { "lightmap", "lightmapColorHDR", "lightmapExpHDR" };
File

shaderMaterialGeoParamDescription.cpp


shaderMaterialGeoParamValue::LIGHTMAP_TYPE_NAMES Variable

shaderMaterialGeoParamValue::LIGHTMAP_TYPE_NAMES Variable
C++
const char * shaderMaterialGeoParamValue::LIGHTMAP_TYPE_NAMES[] = { "lightmap", "lightmapColorHDR", "lightmapExpHDR" };
File

shaderMaterialGeoParamValue.cpp


BUFFER_LEN Macro

BUFFER_LEN Macro
C++
#define BUFFER_LEN 1024
File

shaderMaterialGeoManager.cpp


CleanFilename Macro

CleanFilename Macro
C++
#define CleanFilename(a,b) StringNormalize(a, b, sizeof(a));
File

shaderMaterialGeoManager.h


SHADER_MATERIAL_GEO_MANAGER Macro

SHADER_MATERIAL_GEO_MANAGER Macro
C++
#define SHADER_MATERIAL_GEO_MANAGER (*shaderMaterialGeoManager::GetShaderMaterialGeoManager())
File

shaderMaterialGeoManager.h


rage Namespace Classes

rage Namespace Classes
rage Namespace
Classes
Class | Description
shaderMaterialGeoInstance |
shaderMaterialGeoManager |
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionFloat |
shaderMaterialGeoParamDescriptionMatrix34 |
shaderMaterialGeoParamDescriptionMatrix44 |
shaderMaterialGeoParamDescriptionString |
shaderMaterialGeoParamDescriptionTexture |
shaderMaterialGeoParamDescriptionVector2 |
shaderMaterialGeoParamDescriptionVector3 |
shaderMaterialGeoParamDescriptionVector4 |
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueFloat |
shaderMaterialGeoParamValueMatrix34 |
shaderMaterialGeoParamValueMatrix44 |
shaderMaterialGeoParamValueString |
shaderMaterialGeoParamValueTexture |
shaderMaterialGeoParamValueVector2 |
shaderMaterialGeoParamValueVector3 |
shaderMaterialGeoParamValueVector4 |
shaderMaterialGeoTemplate |
shaderMaterialGeoType |


rage Namespace Macros

rage Namespace Macros
rage Namespace
Macros
Macro | Description
DEFAULT_UV_SET_NAME |


rage Namespace Types

rage Namespace Types
rage Namespace
Types
Type | Description
grmVariableInfo |


shaderMaterialGeoInstance Class Constructors

shaderMaterialGeoInstance Class Constructors
shaderMaterialGeoInstance Class
Constructors
Constructor | Description
shaderMaterialGeoInstance |
shaderMaterialGeoType |


Constructors

Legend
Method


shaderMaterialGeoInstance Class Data Members

shaderMaterialGeoInstance Class Data Members
shaderMaterialGeoInstance Class
Data Members
Data Member | Description
m_apShaderParamValues |
m_bInstance |
m_pobParentType |
m_pobTemplate |
m_sGeoTypeUID |
m_strParentTypeName |
m_strParentTypePathAndFilename | Useful info
m_strTypeName |
m_strTypePathAndFilename |


Data Members

Legend
protected
Data Member


shaderMaterialGeoInstance Class Destructors

shaderMaterialGeoInstance Class Destructors
shaderMaterialGeoInstance Class
Destructors
Destructor | Description
~shaderMaterialGeoInstance |
~shaderMaterialGeoType |


Destructors

Legend
Method
virtual


Legend

Legend
shaderMaterialGeoInstance Class
Legend
Method
virtual
protected
Data Member


shaderMaterialGeoInstance Class Members

shaderMaterialGeoInstance Class Members
shaderMaterialGeoInstance Class
Members
Constructors
Constructor | Description
shaderMaterialGeoInstance |
shaderMaterialGeoType |
Destructors
Destructor | Description
~shaderMaterialGeoInstance |
~shaderMaterialGeoType |
Methods
Method | Description
AddParamValuesFromParamDescriptions | Loading and saving
AssignNewUID |
ChangeParentType |
ConstructFromParentType |
ConstructFromParentType |
Copy |
CopyParamValues |
CopyParamValuesSelectively |
CopyParamValuesSelectively |
GetInstanceFilename |
GetInstanceName |
GetInstancePathAndFilename |
GetNoOfParams | Param accessors
GetNoOfShaderParams |
GetParam |
GetParamByUIName |
GetParentType |
GetParentTypeFilename |
GetParentTypeName |
GetParentTypePathAndFilename |
GetShaderParam |
GetShaderParamByUIName |
GetTemplate |
GetTemplate |
GetTemplateName |
GetTypeFilename | Accessors
GetTypeName |
GetTypePathAndFilename |
GetUID |
GetUvSetCount |
InitialiseFromTemplate |
IsEqual |
LoadFromGeoInstance |
LoadFromGeoType |
LoadParameterFromGeoType |
SaveTo |
SaveTo |
SaveToGeoType |
SetParentTypePathAndFilename |
SetShaderVariableValue | sets the value of the grmShaderVar from the stored data
SetTypePathAndFilename |
SetUIDToString |
UpdateShaderVariable | Sets the value of the stored data from grmShaderVar
Data Members
Data Member | Description
m_apShaderParamValues |
m_bInstance |
m_pobParentType |
m_pobTemplate |
m_sGeoTypeUID |
m_strParentTypeName |
m_strParentTypePathAndFilename | Useful info
m_strTypeName |
m_strTypePathAndFilename |
Operators
Operator | Description
= | Assignment operator
== |


Members

Legend
Method
virtual
protected
Data Member


shaderMaterialGeoInstance Class Methods

shaderMaterialGeoInstance Class Methods
shaderMaterialGeoInstance Class
Methods
Method | Description
AddParamValuesFromParamDescriptions | Loading and saving
AssignNewUID |
ChangeParentType |
ConstructFromParentType |
ConstructFromParentType |
Copy |
CopyParamValues |
CopyParamValuesSelectively |
CopyParamValuesSelectively |
GetInstanceFilename |
GetInstanceName |
GetInstancePathAndFilename |
GetNoOfParams | Param accessors
GetNoOfShaderParams |
GetParam |
GetParamByUIName |
GetParentType |
GetParentTypeFilename |
GetParentTypeName |
GetParentTypePathAndFilename |
GetShaderParam |
GetShaderParamByUIName |
GetTemplate |
GetTemplate |
GetTemplateName |
GetTypeFilename | Accessors
GetTypeName |
GetTypePathAndFilename |
GetUID |
GetUvSetCount |
InitialiseFromTemplate |
IsEqual |
LoadFromGeoInstance |
LoadFromGeoType |
LoadParameterFromGeoType |
SaveTo |
SaveTo |
SaveToGeoType |
SetParentTypePathAndFilename |
SetShaderVariableValue | sets the value of the grmShaderVar from the stored data
SetTypePathAndFilename |
SetUIDToString |
UpdateShaderVariable | Sets the value of the stored data from grmShaderVar


Methods

Legend
protected
Method
virtual


shaderMaterialGeoInstance Class Operators

shaderMaterialGeoInstance Class Operators
shaderMaterialGeoInstance Class
Operators
Operator | Description
= | Assignment operator
== |


Operators

Legend
Method


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoInstance Class
Inheritance Hierarchy
rage::shaderMaterialGeoType
    shaderMaterialGeoInstance


Legend

Legend
shaderMaterialGeoManager Class
Legend
Method


shaderMaterialGeoManager Class Members

shaderMaterialGeoManager Class Members
shaderMaterialGeoManager Class
Members
Methods
Method | Description
AddChildShaderMaterialGeoInstance | connections used by reload
AddChildShaderMaterialGeoInstanceWithGUID | connections used by reload
AddRefToShaderMaterialGeoInstanceWithGUID |
CreateShaderMaterialGeoInstanceFromTemplate |
CreateShaderMaterialGeoInstanceFromType |
CreateShaderMaterialGeoTemplateFromShader | WARNING!!! WARNING!!! WARNING!!! WARNING!!! DO NOT HOLD ONTO THESE POINTERS use filename or guid as identifier
CreateShaderMaterialGeoTypeFromTemplate |
GetBaseGEOPath | Utility functions
GetPathToTemplates |
GetPathToTypes |
GetShaderMaterialGeoInstance |
GetShaderMaterialGeoInstanceFromUID |
GetShaderMaterialGeoManager | Singleton access
GetShaderMaterialGeoTemplate | WARNING!!! WARNING!!! WARNING!!! WARNING!!! DO NOT HOLD ONTO THESE POINTERS use filename or guid as identifier
GetShaderMaterialGeoType |
Initialize |
LoadShaderMaterialGeoInstance |
LoadShaderMaterialGeoTemplate | DO NOT HOLD ONTO THESE POINTERS use filename or guid as identifier WARNING!!! WARNING!!! WARNING!!! WARNING!!!
LoadShaderMaterialGeoType |
ReleaseShaderMaterialGeoInstance |
ReleaseShaderMaterialGeoInstanceWithGUID |
ReloadShaderMaterialGeoInstance |
ReloadShaderMaterialGeoType |
RemoveChildShaderMaterialGeoInstance | connections used by reload
RemoveChildShaderMaterialGeoInstanceWithGUID | connections used by reload
Shutdown |


Members

Legend
Method


shaderMaterialGeoManager Class Methods

shaderMaterialGeoManager Class Methods
shaderMaterialGeoManager Class
Methods
Method | Description
AddChildShaderMaterialGeoInstance | connections used by reload
AddChildShaderMaterialGeoInstanceWithGUID | connections used by reload
AddRefToShaderMaterialGeoInstanceWithGUID |
CreateShaderMaterialGeoInstanceFromTemplate |
CreateShaderMaterialGeoInstanceFromType |
CreateShaderMaterialGeoTemplateFromShader | WARNING!!! WARNING!!! WARNING!!! WARNING!!! DO NOT HOLD ONTO THESE POINTERS use filename or guid as identifier
CreateShaderMaterialGeoTypeFromTemplate |
GetBaseGEOPath | Utility functions
GetPathToTemplates |
GetPathToTypes |
GetShaderMaterialGeoInstance |
GetShaderMaterialGeoInstanceFromUID |
GetShaderMaterialGeoManager | Singleton access
GetShaderMaterialGeoTemplate | WARNING!!! WARNING!!! WARNING!!! WARNING!!! DO NOT HOLD ONTO THESE POINTERS use filename or guid as identifier
GetShaderMaterialGeoType |
Initialize |
LoadShaderMaterialGeoInstance |
LoadShaderMaterialGeoTemplate | DO NOT HOLD ONTO THESE POINTERS use filename or guid as identifier WARNING!!! WARNING!!! WARNING!!! WARNING!!!
LoadShaderMaterialGeoType |
ReleaseShaderMaterialGeoInstance |
ReleaseShaderMaterialGeoInstanceWithGUID |
ReloadShaderMaterialGeoInstance |
ReloadShaderMaterialGeoType |
RemoveChildShaderMaterialGeoInstance | connections used by reload
RemoveChildShaderMaterialGeoInstanceWithGUID | connections used by reload
Shutdown |


Methods

Legend
Method


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoManager Class
Inheritance Hierarchy
shaderMaterialGeoManager


shaderMaterialGeoParamDescription Class Constructors

shaderMaterialGeoParamDescription Class Constructors
shaderMaterialGeoParamDescription Class
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |


shaderMaterialGeoParamDescription Class Data Members

shaderMaterialGeoParamDescription Class Data Members
shaderMaterialGeoParamDescription Class
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture


Data Members

Legend
Data Member
protected


shaderMaterialGeoParamDescription Class Destructors

shaderMaterialGeoParamDescription Class Destructors
shaderMaterialGeoParamDescription Class
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |


shaderMaterialGeoParamDescription Class Enumerations

shaderMaterialGeoParamDescription Class Enumerations
shaderMaterialGeoParamDescription Class
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |


Legend

Legend
shaderMaterialGeoParamDescription Class
Legend
Data Member
protected
Method
virtual


shaderMaterialGeoParamDescription Class Members

shaderMaterialGeoParamDescription Class Members
shaderMaterialGeoParamDescription Class
Members
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |


Members

Legend
Data Member
protected
Method
virtual


shaderMaterialGeoParamDescription Class Methods

shaderMaterialGeoParamDescription Class Methods
shaderMaterialGeoParamDescription Class
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format


Methods

Legend
Method
virtual


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoParamDescription Class
Inheritance Hierarchy
shaderMaterialGeoParamDescription
    rage::shaderMaterialGeoParamDescriptionFloat
    rage::shaderMaterialGeoParamDescriptionMatrix34
    rage::shaderMaterialGeoParamDescriptionMatrix44
    rage::shaderMaterialGeoParamDescriptionString
    rage::shaderMaterialGeoParamDescriptionTexture
    rage::shaderMaterialGeoParamDescriptionVector2
    rage::shaderMaterialGeoParamDescriptionVector3
    rage::shaderMaterialGeoParamDescriptionVector4


shaderMaterialGeoParamDescriptionFloat Class Constructors

shaderMaterialGeoParamDescriptionFloat Class Constructors
shaderMaterialGeoParamDescriptionFloat Class
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionFloat |


shaderMaterialGeoParamDescriptionFloat Class Data Members

shaderMaterialGeoParamDescriptionFloat Class Data Members
shaderMaterialGeoParamDescriptionFloat Class
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture


shaderMaterialGeoParamDescriptionFloat Class Destructors

shaderMaterialGeoParamDescriptionFloat Class Destructors
shaderMaterialGeoParamDescriptionFloat Class
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionFloat |


shaderMaterialGeoParamDescriptionFloat Class Enumerations

shaderMaterialGeoParamDescriptionFloat Class Enumerations
shaderMaterialGeoParamDescriptionFloat Class
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |


Legend

Legend
shaderMaterialGeoParamDescriptionFloat Class
Legend
Method
virtual
Data Member
protected


shaderMaterialGeoParamDescriptionFloat Class Members

shaderMaterialGeoParamDescriptionFloat Class Members
shaderMaterialGeoParamDescriptionFloat Class
Members
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionFloat |
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionFloat |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
LoadFromXML |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SaveToXML |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |


Members

Legend
Method
virtual
Data Member
protected


shaderMaterialGeoParamDescriptionFloat Class Methods

shaderMaterialGeoParamDescriptionFloat Class Methods
shaderMaterialGeoParamDescriptionFloat Class
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
LoadFromXML |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SaveToXML |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoParamDescriptionFloat Class
Inheritance Hierarchy
rage::shaderMaterialGeoParamDescription
    shaderMaterialGeoParamDescriptionFloat


shaderMaterialGeoParamDescriptionMatrix34 Class Constructors

shaderMaterialGeoParamDescriptionMatrix34 Class Constructors
shaderMaterialGeoParamDescriptionMatrix34 Class
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionMatrix34 |


shaderMaterialGeoParamDescriptionMatrix34 Class Data Members

shaderMaterialGeoParamDescriptionMatrix34 Class Data Members
shaderMaterialGeoParamDescriptionMatrix34 Class
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture


shaderMaterialGeoParamDescriptionMatrix34 Class Destructors

shaderMaterialGeoParamDescriptionMatrix34 Class Destructors
shaderMaterialGeoParamDescriptionMatrix34 Class
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionMatrix34 |


shaderMaterialGeoParamDescriptionMatrix34 Class Enumerations

shaderMaterialGeoParamDescriptionMatrix34 Class Enumerations
shaderMaterialGeoParamDescriptionMatrix34 Class
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |


Legend

Legend
shaderMaterialGeoParamDescriptionMatrix34 Class
Legend
Method
virtual
Data Member
protected


shaderMaterialGeoParamDescriptionMatrix34 Class Members

shaderMaterialGeoParamDescriptionMatrix34 Class Members
shaderMaterialGeoParamDescriptionMatrix34 Class
Members
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionMatrix34 |
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionMatrix34 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |


shaderMaterialGeoParamDescriptionMatrix34 Class Methods

shaderMaterialGeoParamDescriptionMatrix34 Class Methods
shaderMaterialGeoParamDescriptionMatrix34 Class
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoParamDescriptionMatrix34 Class
Inheritance Hierarchy
rage::shaderMaterialGeoParamDescription
    shaderMaterialGeoParamDescriptionMatrix34


shaderMaterialGeoParamDescriptionMatrix44 Class Constructors

shaderMaterialGeoParamDescriptionMatrix44 Class Constructors
shaderMaterialGeoParamDescriptionMatrix44 Class
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionMatrix44 |


shaderMaterialGeoParamDescriptionMatrix44 Class Data Members

shaderMaterialGeoParamDescriptionMatrix44 Class Data Members
shaderMaterialGeoParamDescriptionMatrix44 Class
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture


shaderMaterialGeoParamDescriptionMatrix44 Class Destructors

shaderMaterialGeoParamDescriptionMatrix44 Class Destructors
shaderMaterialGeoParamDescriptionMatrix44 Class
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionMatrix44 |


shaderMaterialGeoParamDescriptionMatrix44 Class Enumerations

shaderMaterialGeoParamDescriptionMatrix44 Class Enumerations
shaderMaterialGeoParamDescriptionMatrix44 Class
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |


Legend

Legend
shaderMaterialGeoParamDescriptionMatrix44 Class
Legend
Method
virtual
Data Member
protected


shaderMaterialGeoParamDescriptionMatrix44 Class Members

shaderMaterialGeoParamDescriptionMatrix44 Class Members
shaderMaterialGeoParamDescriptionMatrix44 Class
Members
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionMatrix44 |
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionMatrix44 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |


shaderMaterialGeoParamDescriptionMatrix44 Class Methods

shaderMaterialGeoParamDescriptionMatrix44 Class Methods
shaderMaterialGeoParamDescriptionMatrix44 Class
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoParamDescriptionMatrix44 Class
Inheritance Hierarchy
rage::shaderMaterialGeoParamDescription
    shaderMaterialGeoParamDescriptionMatrix44


shaderMaterialGeoParamDescriptionString Class Constructors

shaderMaterialGeoParamDescriptionString Class Constructors
shaderMaterialGeoParamDescriptionString Class
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionString |


shaderMaterialGeoParamDescriptionString Class Data Members

shaderMaterialGeoParamDescriptionString Class Data Members
shaderMaterialGeoParamDescriptionString Class
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture


shaderMaterialGeoParamDescriptionString Class Destructors

shaderMaterialGeoParamDescriptionString Class Destructors
shaderMaterialGeoParamDescriptionString Class
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionString |


shaderMaterialGeoParamDescriptionString Class Enumerations

shaderMaterialGeoParamDescriptionString Class Enumerations
shaderMaterialGeoParamDescriptionString Class
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |


Legend

Legend
shaderMaterialGeoParamDescriptionString Class
Legend
Method
virtual
Data Member
protected


shaderMaterialGeoParamDescriptionString Class Members

shaderMaterialGeoParamDescriptionString Class Members
shaderMaterialGeoParamDescriptionString Class
Members
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionString |
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionString |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue | Non virtual function
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Virtual functions
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |


shaderMaterialGeoParamDescriptionString Class Methods

shaderMaterialGeoParamDescriptionString Class Methods
shaderMaterialGeoParamDescriptionString Class
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue | Non virtual function
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Virtual functions
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoParamDescriptionString Class
Inheritance Hierarchy
rage::shaderMaterialGeoParamDescription
    shaderMaterialGeoParamDescriptionString


shaderMaterialGeoParamDescriptionTexture Class Constructors

shaderMaterialGeoParamDescriptionTexture Class Constructors
shaderMaterialGeoParamDescriptionTexture Class
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionTexture |


shaderMaterialGeoParamDescriptionTexture Class Data Members

shaderMaterialGeoParamDescriptionTexture Class Data Members
shaderMaterialGeoParamDescriptionTexture Class
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture


shaderMaterialGeoParamDescriptionTexture Class Destructors

shaderMaterialGeoParamDescriptionTexture Class Destructors
shaderMaterialGeoParamDescriptionTexture Class
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionTexture |


shaderMaterialGeoParamDescriptionTexture Class Enumerations

shaderMaterialGeoParamDescriptionTexture Class Enumerations
shaderMaterialGeoParamDescriptionTexture Class
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |


Legend

Legend
shaderMaterialGeoParamDescriptionTexture Class
Legend
Method
virtual
Data Member
protected


shaderMaterialGeoParamDescriptionTexture Class Members

shaderMaterialGeoParamDescriptionTexture Class Members
shaderMaterialGeoParamDescriptionTexture Class
Members
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionTexture |
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionTexture |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureName |
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Virtual functions
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |


shaderMaterialGeoParamDescriptionTexture Class Methods

shaderMaterialGeoParamDescriptionTexture Class Methods
shaderMaterialGeoParamDescriptionTexture Class
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureName |
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Virtual functions
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoParamDescriptionTexture Class
Inheritance Hierarchy
rage::shaderMaterialGeoParamDescription
    shaderMaterialGeoParamDescriptionTexture


shaderMaterialGeoParamDescriptionVector2 Class Constructors

shaderMaterialGeoParamDescriptionVector2 Class Constructors
shaderMaterialGeoParamDescriptionVector2 Class
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionVector2 |


shaderMaterialGeoParamDescriptionVector2 Class Data Members

shaderMaterialGeoParamDescriptionVector2 Class Data Members
shaderMaterialGeoParamDescriptionVector2 Class
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture


shaderMaterialGeoParamDescriptionVector2 Class Destructors

shaderMaterialGeoParamDescriptionVector2 Class Destructors
shaderMaterialGeoParamDescriptionVector2 Class
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionVector2 |


shaderMaterialGeoParamDescriptionVector2 Class Enumerations

shaderMaterialGeoParamDescriptionVector2 Class Enumerations
shaderMaterialGeoParamDescriptionVector2 Class
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |


Legend

Legend
shaderMaterialGeoParamDescriptionVector2 Class
Legend
Method
virtual
Data Member
protected


shaderMaterialGeoParamDescriptionVector2 Class Members

shaderMaterialGeoParamDescriptionVector2 Class Members
shaderMaterialGeoParamDescriptionVector2 Class
Members
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionVector2 |
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionVector2 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |


shaderMaterialGeoParamDescriptionVector2 Class Methods

shaderMaterialGeoParamDescriptionVector2 Class Methods
shaderMaterialGeoParamDescriptionVector2 Class
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoParamDescriptionVector2 Class
Inheritance Hierarchy
rage::shaderMaterialGeoParamDescription
    shaderMaterialGeoParamDescriptionVector2


shaderMaterialGeoParamDescriptionVector3 Class Constructors

shaderMaterialGeoParamDescriptionVector3 Class Constructors
shaderMaterialGeoParamDescriptionVector3 Class
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionVector3 |


shaderMaterialGeoParamDescriptionVector3 Class Data Members

shaderMaterialGeoParamDescriptionVector3 Class Data Members
shaderMaterialGeoParamDescriptionVector3 Class
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture


shaderMaterialGeoParamDescriptionVector3 Class Destructors

shaderMaterialGeoParamDescriptionVector3 Class Destructors
shaderMaterialGeoParamDescriptionVector3 Class
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionVector3 |


shaderMaterialGeoParamDescriptionVector3 Class Enumerations

shaderMaterialGeoParamDescriptionVector3 Class Enumerations
shaderMaterialGeoParamDescriptionVector3 Class
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |


Legend

Legend
shaderMaterialGeoParamDescriptionVector3 Class
Legend
Method
virtual
Data Member
protected


shaderMaterialGeoParamDescriptionVector3 Class Members

shaderMaterialGeoParamDescriptionVector3 Class Members
shaderMaterialGeoParamDescriptionVector3 Class
Members
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionVector3 |
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionVector3 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |


shaderMaterialGeoParamDescriptionVector3 Class Methods

shaderMaterialGeoParamDescriptionVector3 Class Methods
shaderMaterialGeoParamDescriptionVector3 Class
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoParamDescriptionVector3 Class
Inheritance Hierarchy
rage::shaderMaterialGeoParamDescription
    shaderMaterialGeoParamDescriptionVector3


shaderMaterialGeoParamDescriptionVector4 Class Constructors

shaderMaterialGeoParamDescriptionVector4 Class Constructors
shaderMaterialGeoParamDescriptionVector4 Class
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionVector4 |


shaderMaterialGeoParamDescriptionVector4 Class Data Members

shaderMaterialGeoParamDescriptionVector4 Class Data Members
shaderMaterialGeoParamDescriptionVector4 Class
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture


shaderMaterialGeoParamDescriptionVector4 Class Destructors

shaderMaterialGeoParamDescriptionVector4 Class Destructors
shaderMaterialGeoParamDescriptionVector4 Class
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionVector4 |


shaderMaterialGeoParamDescriptionVector4 Class Enumerations

shaderMaterialGeoParamDescriptionVector4 Class Enumerations
shaderMaterialGeoParamDescriptionVector4 Class
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |


Legend

Legend
shaderMaterialGeoParamDescriptionVector4 Class
Legend
Method
virtual
Data Member
protected


shaderMaterialGeoParamDescriptionVector4 Class Members

shaderMaterialGeoParamDescriptionVector4 Class Members
shaderMaterialGeoParamDescriptionVector4 Class
Members
Constructors
Constructor | Description
shaderMaterialGeoParamDescription |
shaderMaterialGeoParamDescriptionVector4 |
Destructors
Destructor | Description
~shaderMaterialGeoParamDescription |
~shaderMaterialGeoParamDescriptionVector4 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_eValueSource |
m_iNoOfMipLevels | No of mip map levels to create (If this value is zero, a complete mipmap chain is created. This also the default.)
m_MaterialDefaultValueUvSetIndex | DefaultValue for the material that gets pushed into the given texture coord. -1 means it does not have any material data
m_Name | Semantic name
m_TextureOutputFormats | The output formats of the texture, this is a ; seperated list of 'platform'='format' pairs
m_UIHelp | Extra info for widget tool tips
m_UIHidden | Flag if hidden to the UI
m_UIHint |
m_UIMax |
m_UIMin | Minimum allowed value for a widget
m_UIName | Name to display in widgets
m_UIStep |
m_UIWidget | Describes which type of UI widget to display
m_UvSetIndex | Uvset index for this texture
m_UvSetName | Uvset name for this texture
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |
ValueSource |


shaderMaterialGeoParamDescriptionVector4 Class Methods

shaderMaterialGeoParamDescriptionVector4 Class Methods
shaderMaterialGeoParamDescriptionVector4 Class
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
GetDefaultValue |
GetMaterialDataUvSetIndex |
GetName | Accessors
GetNoOfMipLevels |
GetSourceOfParamValue | bool GetUIHidden() const {return m_UIHidden;
GetTextureOutputFormats |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetUIHelp |
GetUIHint |
GetUIMax |
GetUIMin |
GetUIName |
GetUIStep |
GetUIWidget |
GetUvSetIndex |
GetUvSetName |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamDescriptionData | This function reads all the paramdata
ReadGeoParamDescriptionData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetDefaultValueUvSetIndex | void SetUIHidden(bool bHidden) {m_UIHidden = bHidden;
SetName | Modifiers
SetTextureOutputFormats |
SetUIHint |
SetUIMax |
SetUIMin |
SetUIName |
SetUIStep |
SetUIWidget |
SetUvSetIndex |
SetUvSetName |
SetValueSource |
WriteAsGeoInstanceMember |
WriteAsGeoInstanceMember |
WriteAsGeoTemplateMember |
WriteAsGeoTemplateMember |
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format
WriteGeoParamDescriptionData | This function writes out all the param data to the .shadergroup format


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoParamDescriptionVector4 Class
Inheritance Hierarchy
rage::shaderMaterialGeoParamDescription
    shaderMaterialGeoParamDescriptionVector4


shaderMaterialGeoParamValue Class Constructors

shaderMaterialGeoParamValue Class Constructors
shaderMaterialGeoParamValue Class
Constructors
Constructor | Description
shaderMaterialGeoParamValue |


Constructors

Legend
protected
Method


shaderMaterialGeoParamValue Class Data Members

shaderMaterialGeoParamValue Class Data Members
shaderMaterialGeoParamValue Class
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing


shaderMaterialGeoParamValue Class Destructors

shaderMaterialGeoParamValue Class Destructors
shaderMaterialGeoParamValue Class
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |


shaderMaterialGeoParamValue Class Enumerations

shaderMaterialGeoParamValue Class Enumerations
shaderMaterialGeoParamValue Class
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |


Legend

Legend
shaderMaterialGeoParamValue Class
Legend
Data Member
protected
Method
virtual


shaderMaterialGeoParamValue Class Members

shaderMaterialGeoParamValue Class Members
shaderMaterialGeoParamValue Class
Members
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetTypeName |
Init |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
Reset |
SetDefaultValue |
SetMaterialValue |
SetName |
Update |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |


shaderMaterialGeoParamValue Class Methods

shaderMaterialGeoParamValue Class Methods
shaderMaterialGeoParamValue Class
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetTypeName |
Init |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
Reset |
SetDefaultValue |
SetMaterialValue |
SetName |
Update |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoParamValue Class
Inheritance Hierarchy
shaderMaterialGeoParamValue
    rage::shaderMaterialGeoParamValueFloat
    rage::shaderMaterialGeoParamValueMatrix34
    rage::shaderMaterialGeoParamValueMatrix44
    rage::shaderMaterialGeoParamValueString
    rage::shaderMaterialGeoParamValueTexture
    rage::shaderMaterialGeoParamValueVector2
    rage::shaderMaterialGeoParamValueVector3
    rage::shaderMaterialGeoParamValueVector4


shaderMaterialGeoParamValueFloat Class Constructors

shaderMaterialGeoParamValueFloat Class Constructors
shaderMaterialGeoParamValueFloat Class
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueFloat |


shaderMaterialGeoParamValueFloat Class Data Members

shaderMaterialGeoParamValueFloat Class Data Members
shaderMaterialGeoParamValueFloat Class
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing


shaderMaterialGeoParamValueFloat Class Destructors

shaderMaterialGeoParamValueFloat Class Destructors
shaderMaterialGeoParamValueFloat Class
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueFloat |


shaderMaterialGeoParamValueFloat Class Enumerations

shaderMaterialGeoParamValueFloat Class Enumerations
shaderMaterialGeoParamValueFloat Class
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |


Legend

Legend
shaderMaterialGeoParamValueFloat Class
Legend
protected
Method
virtual
Data Member


shaderMaterialGeoParamValueFloat Class Members

shaderMaterialGeoParamValueFloat Class Members
shaderMaterialGeoParamValueFloat Class
Members
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueFloat |
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueFloat |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
LoadFromXML |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SaveToXML |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |


Members

Legend
protected
Method
virtual
Data Member


shaderMaterialGeoParamValueFloat Class Methods

shaderMaterialGeoParamValueFloat Class Methods
shaderMaterialGeoParamValueFloat Class
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
LoadFromXML |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SaveToXML |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoParamValueFloat Class
Inheritance Hierarchy
rage::shaderMaterialGeoParamValue
    shaderMaterialGeoParamValueFloat


shaderMaterialGeoParamValueMatrix34 Class Constructors

shaderMaterialGeoParamValueMatrix34 Class Constructors
shaderMaterialGeoParamValueMatrix34 Class
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueMatrix34 |


shaderMaterialGeoParamValueMatrix34 Class Data Members

shaderMaterialGeoParamValueMatrix34 Class Data Members
shaderMaterialGeoParamValueMatrix34 Class
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing


shaderMaterialGeoParamValueMatrix34 Class Destructors

shaderMaterialGeoParamValueMatrix34 Class Destructors
shaderMaterialGeoParamValueMatrix34 Class
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueMatrix34 |


shaderMaterialGeoParamValueMatrix34 Class Enumerations

shaderMaterialGeoParamValueMatrix34 Class Enumerations
shaderMaterialGeoParamValueMatrix34 Class
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |


Legend

Legend
shaderMaterialGeoParamValueMatrix34 Class
Legend
protected
Method
virtual
Data Member


shaderMaterialGeoParamValueMatrix34 Class Members

shaderMaterialGeoParamValueMatrix34 Class Members
shaderMaterialGeoParamValueMatrix34 Class
Members
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueMatrix34 |
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueMatrix34 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |


shaderMaterialGeoParamValueMatrix34 Class Methods

shaderMaterialGeoParamValueMatrix34 Class Methods
shaderMaterialGeoParamValueMatrix34 Class
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoParamValueMatrix34 Class
Inheritance Hierarchy
rage::shaderMaterialGeoParamValue
    shaderMaterialGeoParamValueMatrix34


shaderMaterialGeoParamValueMatrix44 Class Constructors

shaderMaterialGeoParamValueMatrix44 Class Constructors
shaderMaterialGeoParamValueMatrix44 Class
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueMatrix44 |


shaderMaterialGeoParamValueMatrix44 Class Data Members

shaderMaterialGeoParamValueMatrix44 Class Data Members
shaderMaterialGeoParamValueMatrix44 Class
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing


shaderMaterialGeoParamValueMatrix44 Class Destructors

shaderMaterialGeoParamValueMatrix44 Class Destructors
shaderMaterialGeoParamValueMatrix44 Class
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueMatrix44 |


shaderMaterialGeoParamValueMatrix44 Class Enumerations

shaderMaterialGeoParamValueMatrix44 Class Enumerations
shaderMaterialGeoParamValueMatrix44 Class
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |


Legend

Legend
shaderMaterialGeoParamValueMatrix44 Class
Legend
protected
Method
virtual
Data Member


shaderMaterialGeoParamValueMatrix44 Class Members

shaderMaterialGeoParamValueMatrix44 Class Members
shaderMaterialGeoParamValueMatrix44 Class
Members
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueMatrix44 |
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueMatrix44 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |


shaderMaterialGeoParamValueMatrix44 Class Methods

shaderMaterialGeoParamValueMatrix44 Class Methods
shaderMaterialGeoParamValueMatrix44 Class
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoParamValueMatrix44 Class
Inheritance Hierarchy
rage::shaderMaterialGeoParamValue
    shaderMaterialGeoParamValueMatrix44


shaderMaterialGeoParamValueString Class Constructors

shaderMaterialGeoParamValueString Class Constructors
shaderMaterialGeoParamValueString Class
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueString |


shaderMaterialGeoParamValueString Class Data Members

shaderMaterialGeoParamValueString Class Data Members
shaderMaterialGeoParamValueString Class
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing


shaderMaterialGeoParamValueString Class Destructors

shaderMaterialGeoParamValueString Class Destructors
shaderMaterialGeoParamValueString Class
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueString |


shaderMaterialGeoParamValueString Class Enumerations

shaderMaterialGeoParamValueString Class Enumerations
shaderMaterialGeoParamValueString Class
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |


Legend

Legend
shaderMaterialGeoParamValueString Class
Legend
protected
Method
virtual
Data Member


shaderMaterialGeoParamValueString Class Members

shaderMaterialGeoParamValueString Class Members
shaderMaterialGeoParamValueString Class
Members
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueString |
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueString |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Virtual functions
GetTypeName |
GetTypeName |
GetValue | Non virtual function
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |


shaderMaterialGeoParamValueString Class Methods

shaderMaterialGeoParamValueString Class Methods
shaderMaterialGeoParamValueString Class
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Virtual functions
GetTypeName |
GetTypeName |
GetValue | Non virtual function
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoParamValueString Class
Inheritance Hierarchy
rage::shaderMaterialGeoParamValue
    shaderMaterialGeoParamValueString


shaderMaterialGeoParamValueTexture Class Constructors

shaderMaterialGeoParamValueTexture Class Constructors
shaderMaterialGeoParamValueTexture Class
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueTexture |


shaderMaterialGeoParamValueTexture Class Data Members

shaderMaterialGeoParamValueTexture Class Data Members
shaderMaterialGeoParamValueTexture Class
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing


shaderMaterialGeoParamValueTexture Class Destructors

shaderMaterialGeoParamValueTexture Class Destructors
shaderMaterialGeoParamValueTexture Class
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueTexture |


shaderMaterialGeoParamValueTexture Class Enumerations

shaderMaterialGeoParamValueTexture Class Enumerations
shaderMaterialGeoParamValueTexture Class
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |


Legend

Legend
shaderMaterialGeoParamValueTexture Class
Legend
protected
Method
virtual
Data Member


shaderMaterialGeoParamValueTexture Class Members

shaderMaterialGeoParamValueTexture Class Members
shaderMaterialGeoParamValueTexture Class
Members
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueTexture |
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueTexture |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetTextureName |
GetType | Pure virtuals
GetType | Virtual functions
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |


shaderMaterialGeoParamValueTexture Class Methods

shaderMaterialGeoParamValueTexture Class Methods
shaderMaterialGeoParamValueTexture Class
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetTextureName |
GetType | Pure virtuals
GetType | Virtual functions
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoParamValueTexture Class
Inheritance Hierarchy
rage::shaderMaterialGeoParamValue
    shaderMaterialGeoParamValueTexture


shaderMaterialGeoParamValueVector2 Class Constructors

shaderMaterialGeoParamValueVector2 Class Constructors
shaderMaterialGeoParamValueVector2 Class
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueVector2 |


shaderMaterialGeoParamValueVector2 Class Data Members

shaderMaterialGeoParamValueVector2 Class Data Members
shaderMaterialGeoParamValueVector2 Class
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing


shaderMaterialGeoParamValueVector2 Class Destructors

shaderMaterialGeoParamValueVector2 Class Destructors
shaderMaterialGeoParamValueVector2 Class
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueVector2 |


shaderMaterialGeoParamValueVector2 Class Enumerations

shaderMaterialGeoParamValueVector2 Class Enumerations
shaderMaterialGeoParamValueVector2 Class
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |


Legend

Legend
shaderMaterialGeoParamValueVector2 Class
Legend
protected
Method
virtual
Data Member


shaderMaterialGeoParamValueVector2 Class Members

shaderMaterialGeoParamValueVector2 Class Members
shaderMaterialGeoParamValueVector2 Class
Members
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueVector2 |
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueVector2 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |


shaderMaterialGeoParamValueVector2 Class Methods

shaderMaterialGeoParamValueVector2 Class Methods
shaderMaterialGeoParamValueVector2 Class
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoParamValueVector2 Class
Inheritance Hierarchy
rage::shaderMaterialGeoParamValue
    shaderMaterialGeoParamValueVector2


shaderMaterialGeoParamValueVector3 Class Constructors

shaderMaterialGeoParamValueVector3 Class Constructors
shaderMaterialGeoParamValueVector3 Class
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueVector3 |


shaderMaterialGeoParamValueVector3 Class Data Members

shaderMaterialGeoParamValueVector3 Class Data Members
shaderMaterialGeoParamValueVector3 Class
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing


shaderMaterialGeoParamValueVector3 Class Destructors

shaderMaterialGeoParamValueVector3 Class Destructors
shaderMaterialGeoParamValueVector3 Class
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueVector3 |


shaderMaterialGeoParamValueVector3 Class Enumerations

shaderMaterialGeoParamValueVector3 Class Enumerations
shaderMaterialGeoParamValueVector3 Class
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |


Legend

Legend
shaderMaterialGeoParamValueVector3 Class
Legend
protected
Method
virtual
Data Member


shaderMaterialGeoParamValueVector3 Class Members

shaderMaterialGeoParamValueVector3 Class Members
shaderMaterialGeoParamValueVector3 Class
Members
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueVector3 |
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueVector3 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |


shaderMaterialGeoParamValueVector3 Class Methods

shaderMaterialGeoParamValueVector3 Class Methods
shaderMaterialGeoParamValueVector3 Class
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoParamValueVector3 Class
Inheritance Hierarchy
rage::shaderMaterialGeoParamValue
    shaderMaterialGeoParamValueVector3


shaderMaterialGeoParamValueVector4 Class Constructors

shaderMaterialGeoParamValueVector4 Class Constructors
shaderMaterialGeoParamValueVector4 Class
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueVector4 |


shaderMaterialGeoParamValueVector4 Class Data Members

shaderMaterialGeoParamValueVector4 Class Data Members
shaderMaterialGeoParamValueVector4 Class
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing


shaderMaterialGeoParamValueVector4 Class Destructors

shaderMaterialGeoParamValueVector4 Class Destructors
shaderMaterialGeoParamValueVector4 Class
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueVector4 |


shaderMaterialGeoParamValueVector4 Class Enumerations

shaderMaterialGeoParamValueVector4 Class Enumerations
shaderMaterialGeoParamValueVector4 Class
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |


Legend

Legend
shaderMaterialGeoParamValueVector4 Class
Legend
protected
Method
virtual
Data Member


shaderMaterialGeoParamValueVector4 Class Members

shaderMaterialGeoParamValueVector4 Class Members
shaderMaterialGeoParamValueVector4 Class
Members
Constructors
Constructor | Description
shaderMaterialGeoParamValue |
shaderMaterialGeoParamValueVector4 |
Destructors
Destructor | Description
~shaderMaterialGeoParamValue |
~shaderMaterialGeoParamValueVector4 |
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
Data Members
Data Member | Description
LIGHTMAP_TYPE_NAMES |
m_Name | Semantic name
m_pobParamDescription | For backwards referencing
Enumerations
Enumeration | Description
LIGHTMAP_TYPES |


shaderMaterialGeoParamValueVector4 Class Methods

shaderMaterialGeoParamValueVector4 Class Methods
shaderMaterialGeoParamValueVector4 Class
Methods
Method | Description
CleanUp | This function cleans up any of the parameter data
Copy |
Copy |
CopyValueIntoVector2 |
GetName | Accessors
GetParamDescription |
GetSourceOfParamValue |
GetType | Pure virtuals
GetType | Pure virtuals
GetTypeName |
GetTypeName |
GetValue |
Init |
IsEqual |
IsEqual |
IsLightmap |
ReadGeoParamValueData | This function reads all the paramdata
ReadGeoParamValueData | This function reads all the paramdata
Reset |
Reset |
SetDefaultValue |
SetDefaultValue |
SetMaterialValue |
SetName |
SetValue |
Update |
Update |
WriteAsGeoTypeMember |
WriteAsGeoTypeMember |
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format
WriteGeoParamValueData | This function writes out all the param data to the .shadergroup format


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoParamValueVector4 Class
Inheritance Hierarchy
rage::shaderMaterialGeoParamValue
    shaderMaterialGeoParamValueVector4


shaderMaterialGeoTemplate Class Constructors

shaderMaterialGeoTemplate Class Constructors
shaderMaterialGeoTemplate Class
Constructors
Constructor | Description
shaderMaterialGeoTemplate |


shaderMaterialGeoTemplate Class Destructors

shaderMaterialGeoTemplate Class Destructors
shaderMaterialGeoTemplate Class
Destructors
Destructor | Description
~shaderMaterialGeoTemplate |


Legend

Legend
shaderMaterialGeoTemplate Class
Legend
Method
virtual


shaderMaterialGeoTemplate Class Members

shaderMaterialGeoTemplate Class Members
shaderMaterialGeoTemplate Class
Members
Constructors
Constructor | Description
shaderMaterialGeoTemplate |
Destructors
Destructor | Description
~shaderMaterialGeoTemplate |
Methods
Method | Description
CreateFromShader |
GetBucketNumber |
GetParamDescription |
GetRunTimeVertexColourDescriptions |
GetShaderFilename |
GetShaderName |
GetShaderParamDescriptions |
GetShaderPathAndFilename |
GetSourceVertexColourDescriptions |
GetTemplateFilename |
GetTemplateName |
GetTemplatePathAndFilename |
LoadFromGeoTemplate |
SaveTo |


Members

Legend
Method
virtual


shaderMaterialGeoTemplate Class Methods

shaderMaterialGeoTemplate Class Methods
shaderMaterialGeoTemplate Class
Methods
Method | Description
CreateFromShader |
GetBucketNumber |
GetParamDescription |
GetRunTimeVertexColourDescriptions |
GetShaderFilename |
GetShaderName |
GetShaderParamDescriptions |
GetShaderPathAndFilename |
GetSourceVertexColourDescriptions |
GetTemplateFilename |
GetTemplateName |
GetTemplatePathAndFilename |
LoadFromGeoTemplate |
SaveTo |


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoTemplate Class
Inheritance Hierarchy
shaderMaterialGeoTemplate


shaderMaterialGeoType Class Constructors

shaderMaterialGeoType Class Constructors
shaderMaterialGeoType Class
Constructors
Constructor | Description
shaderMaterialGeoType |


shaderMaterialGeoType Class Data Members

shaderMaterialGeoType Class Data Members
shaderMaterialGeoType Class
Data Members
Data Member | Description
m_apShaderParamValues |
m_bInstance |
m_pobParentType |
m_pobTemplate |
m_sGeoTypeUID |
m_strParentTypeName |
m_strParentTypePathAndFilename | Useful info
m_strTypeName |
m_strTypePathAndFilename |


shaderMaterialGeoType Class Destructors

shaderMaterialGeoType Class Destructors
shaderMaterialGeoType Class
Destructors
Destructor | Description
~shaderMaterialGeoType |


Legend

Legend
shaderMaterialGeoType Class
Legend
protected
Data Member
Method
virtual


shaderMaterialGeoType Class Members

shaderMaterialGeoType Class Members
shaderMaterialGeoType Class
Members
Data Members
Data Member | Description
m_apShaderParamValues |
m_bInstance |
m_pobParentType |
m_pobTemplate |
m_sGeoTypeUID |
m_strParentTypeName |
m_strParentTypePathAndFilename | Useful info
m_strTypeName |
m_strTypePathAndFilename |
Constructors
Constructor | Description
shaderMaterialGeoType |
Destructors
Destructor | Description
~shaderMaterialGeoType |
Methods
Method | Description
AddParamValuesFromParamDescriptions | Loading and saving
AssignNewUID |
ChangeParentType |
ConstructFromParentType |
Copy |
CopyParamValues |
CopyParamValuesSelectively |
GetNoOfParams | Param accessors
GetNoOfShaderParams |
GetParam |
GetParamByUIName |
GetParentType |
GetParentTypeFilename |
GetParentTypeName |
GetParentTypePathAndFilename |
GetShaderParam |
GetShaderParamByUIName |
GetTemplate |
GetTypeFilename | Accessors
GetTypeName |
GetTypePathAndFilename |
GetUID |
GetUvSetCount |
InitialiseFromTemplate |
IsEqual |
LoadFromGeoType |
LoadParameterFromGeoType |
SaveTo |
SaveToGeoType |
SetParentTypePathAndFilename |
SetShaderVariableValue | sets the value of the grmShaderVar from the stored data
SetTypePathAndFilename |
SetUIDToString |
UpdateShaderVariable | Sets the value of the stored data from grmShaderVar
Operators
Operator | Description
= | Assignment operator
== |


Members

Legend
protected
Data Member
Method
virtual


shaderMaterialGeoType Class Methods

shaderMaterialGeoType Class Methods
shaderMaterialGeoType Class
Methods
Method | Description
AddParamValuesFromParamDescriptions | Loading and saving
AssignNewUID |
ChangeParentType |
ConstructFromParentType |
Copy |
CopyParamValues |
CopyParamValuesSelectively |
GetNoOfParams | Param accessors
GetNoOfShaderParams |
GetParam |
GetParamByUIName |
GetParentType |
GetParentTypeFilename |
GetParentTypeName |
GetParentTypePathAndFilename |
GetShaderParam |
GetShaderParamByUIName |
GetTemplate |
GetTypeFilename | Accessors
GetTypeName |
GetTypePathAndFilename |
GetUID |
GetUvSetCount |
InitialiseFromTemplate |
IsEqual |
LoadFromGeoType |
LoadParameterFromGeoType |
SaveTo |
SaveToGeoType |
SetParentTypePathAndFilename |
SetShaderVariableValue | sets the value of the grmShaderVar from the stored data
SetTypePathAndFilename |
SetUIDToString |
UpdateShaderVariable | Sets the value of the stored data from grmShaderVar


shaderMaterialGeoType Class Operators

shaderMaterialGeoType Class Operators
shaderMaterialGeoType Class
Operators
Operator | Description
= | Assignment operator
== |


Inheritance Hierarchy

Inheritance Hierarchy
shaderMaterialGeoType Class
Inheritance Hierarchy
shaderMaterialGeoType
    rage::shaderMaterialGeoInstance


Contents

Contents
Overview
Components
Relationships
Command Line Options
Working Examples
Symbol Reference
rage Namespace
shaderMaterialGeoInstance Class
Constructors
shaderMaterialGeoInstance Constructor
Destructors
~shaderMaterialGeoInstance Destructor
Methods
ConstructFromParentType Method
CopyParamValuesSelectively Method
GetInstanceFilename Method
GetInstanceName Method
GetInstancePathAndFilename Method
GetTemplate Method
GetTemplateName Method
LoadFromGeoInstance Method
SaveTo Method
shaderMaterialGeoManager Class
Methods
AddChildShaderMaterialGeoInstance Method
AddChildShaderMaterialGeoInstanceWithGUID Method
AddRefToShaderMaterialGeoInstanceWithGUID Method
CreateShaderMaterialGeoInstanceFromTemplate Method
CreateShaderMaterialGeoInstanceFromType Method
CreateShaderMaterialGeoTemplateFromShader Method
CreateShaderMaterialGeoTypeFromTemplate Method
GetBaseGEOPath Method
GetPathToTemplates Method
GetPathToTypes Method
GetShaderMaterialGeoInstance Method
GetShaderMaterialGeoInstanceFromUID Method
GetShaderMaterialGeoManager Method
GetShaderMaterialGeoTemplate Method
GetShaderMaterialGeoType Method
Initialize Method
LoadShaderMaterialGeoInstance Method
LoadShaderMaterialGeoTemplate Method
LoadShaderMaterialGeoType Method
ReleaseShaderMaterialGeoInstance Method
ReleaseShaderMaterialGeoInstanceWithGUID Method
ReloadShaderMaterialGeoInstance Method
ReloadShaderMaterialGeoType Method
RemoveChildShaderMaterialGeoInstance Method
RemoveChildShaderMaterialGeoInstanceWithGUID Method
Shutdown Method
shaderMaterialGeoParamDescription Class
Data Members
LIGHTMAP_TYPE_NAMES Data Member
m_eValueSource Data Member
m_iNoOfMipLevels Data Member
m_MaterialDefaultValueUvSetIndex Data Member
m_Name Data Member
m_TextureOutputFormats Data Member
m_UIHelp Data Member
m_UIHidden Data Member
m_UIHint Data Member
m_UIMax Data Member
m_UIMin Data Member
m_UIName Data Member
m_UIStep Data Member
m_UIWidget Data Member
m_UvSetIndex Data Member
m_UvSetName Data Member
Constructors
shaderMaterialGeoParamDescription
shaderMaterialGeoParamDescription Constructor ()
shaderMaterialGeoParamDescription Constructor (const parTreeNode*)
Destructors
~shaderMaterialGeoParamDescription Destructor
Methods
CleanUp Method
Copy Method
GetMaterialDataUvSetIndex Method
GetName Method
GetNoOfMipLevels Method
GetSourceOfParamValue Method
GetTextureOutputFormats Method
GetType Method
GetTypeName Method
GetUIHelp Method
GetUIHint Method
GetUIMax Method
GetUIMin Method
GetUIName Method
GetUIStep Method
GetUIWidget Method
GetUvSetIndex Method
GetUvSetName Method
Init Method
IsEqual Method
IsLightmap Method
ReadGeoParamDescriptionData Method
Reset Method
SetDefaultValue
SetDefaultValue Method (const Matrix34&)
SetDefaultValue Method (const Matrix44&)
SetDefaultValue Method (const Vector2&)
SetDefaultValue Method (const Vector3&)
SetDefaultValue Method (const Vector4&)
SetDefaultValue Method (const bool &)
SetDefaultValue Method (const char*)
SetDefaultValue Method (const float&)
SetDefaultValue Method (const int&)
SetDefaultValueUvSetIndex Method
SetName Method
SetTextureOutputFormats Method
SetUIHint Method
SetUIMax Method
SetUIMin Method
SetUIName Method
SetUIStep Method
SetUIWidget Method
SetUvSetIndex Method
SetUvSetName Method
SetValueSource Method
WriteAsGeoInstanceMember Method
WriteAsGeoTemplateMember Method
WriteGeoParamDescriptionData Method
Enumerations
LIGHTMAP_TYPES Enumeration
ValueSource Enumeration
shaderMaterialGeoParamDescriptionFloat Class
Constructors
shaderMaterialGeoParamDescriptionFloat
shaderMaterialGeoParamDescriptionFloat Constructor ()
shaderMaterialGeoParamDescriptionFloat Constructor (const parTreeNode*)
Destructors
~shaderMaterialGeoParamDescriptionFloat Destructor
Methods
CleanUp Method
Copy Method
GetDefaultValue Method
GetType Method
GetTypeName Method
IsEqual Method
LoadFromXML Method
ReadGeoParamDescriptionData Method
Reset Method
SaveToXML Method
SetDefaultValue Method
WriteAsGeoInstanceMember Method
WriteAsGeoTemplateMember Method
WriteGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionMatrix34 Class
Constructors
shaderMaterialGeoParamDescriptionMatrix34 Constructor
Destructors
~shaderMaterialGeoParamDescriptionMatrix34 Destructor
Methods
Copy Method
GetDefaultValue Method
GetType Method
GetTypeName Method
IsEqual Method
ReadGeoParamDescriptionData Method
Reset Method
SetDefaultValue Method
WriteAsGeoInstanceMember Method
WriteAsGeoTemplateMember Method
WriteGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionMatrix44 Class
Constructors
shaderMaterialGeoParamDescriptionMatrix44 Constructor
Destructors
~shaderMaterialGeoParamDescriptionMatrix44 Destructor
Methods
Copy Method
GetDefaultValue Method
GetType Method
GetTypeName Method
IsEqual Method
ReadGeoParamDescriptionData Method
Reset Method
SetDefaultValue Method
WriteAsGeoInstanceMember Method
WriteAsGeoTemplateMember Method
WriteGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionString Class
Constructors
shaderMaterialGeoParamDescriptionString
shaderMaterialGeoParamDescriptionString Constructor ()
shaderMaterialGeoParamDescriptionString Constructor (const parTreeNode*)
Destructors
~shaderMaterialGeoParamDescriptionString Destructor
Methods
CleanUp Method
Copy Method
GetDefaultValue Method
GetType Method
GetTypeName Method
IsEqual Method
ReadGeoParamDescriptionData Method
Reset Method
SetDefaultValue Method
WriteAsGeoInstanceMember Method
WriteAsGeoTemplateMember Method
WriteGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionTexture Class
Constructors
shaderMaterialGeoParamDescriptionTexture
shaderMaterialGeoParamDescriptionTexture Constructor ()
shaderMaterialGeoParamDescriptionTexture Constructor (const parTreeNode*)
Destructors
~shaderMaterialGeoParamDescriptionTexture Destructor
Methods
CleanUp Method
Copy Method
GetDefaultValue Method
GetTextureName
GetTextureName Method (ConstString &)
GetTextureName Method (ConstString &, const char *)
GetType Method
GetTypeName Method
IsEqual Method
ReadGeoParamDescriptionData Method
Reset Method
SetDefaultValue Method
WriteAsGeoInstanceMember Method
WriteAsGeoTemplateMember Method
WriteGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionVector2 Class
Constructors
shaderMaterialGeoParamDescriptionVector2
shaderMaterialGeoParamDescriptionVector2 Constructor ()
shaderMaterialGeoParamDescriptionVector2 Constructor (const parTreeNode*)
Destructors
~shaderMaterialGeoParamDescriptionVector2 Destructor
Methods
Copy Method
GetDefaultValue Method
GetType Method
GetTypeName Method
IsEqual Method
ReadGeoParamDescriptionData Method
Reset Method
SetDefaultValue Method
WriteAsGeoInstanceMember Method
WriteAsGeoTemplateMember Method
WriteGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionVector3 Class
Constructors
shaderMaterialGeoParamDescriptionVector3
shaderMaterialGeoParamDescriptionVector3 Constructor ()
shaderMaterialGeoParamDescriptionVector3 Constructor (const parTreeNode*)
Destructors
~shaderMaterialGeoParamDescriptionVector3 Destructor
Methods
Copy Method
GetDefaultValue Method
GetType Method
GetTypeName Method
IsEqual Method
ReadGeoParamDescriptionData Method
Reset Method
SetDefaultValue Method
WriteAsGeoInstanceMember Method
WriteAsGeoTemplateMember Method
WriteGeoParamDescriptionData Method
shaderMaterialGeoParamDescriptionVector4 Class
Constructors
shaderMaterialGeoParamDescriptionVector4
shaderMaterialGeoParamDescriptionVector4 Constructor ()
shaderMaterialGeoParamDescriptionVector4 Constructor (const parTreeNode*)
Destructors
~shaderMaterialGeoParamDescriptionVector4 Destructor
Methods
Copy Method
GetDefaultValue Method
GetType Method
GetTypeName Method
IsEqual Method
ReadGeoParamDescriptionData Method
Reset Method
SetDefaultValue Method
WriteAsGeoInstanceMember Method
WriteAsGeoTemplateMember Method
WriteGeoParamDescriptionData Method
shaderMaterialGeoParamValue Class
Data Members
LIGHTMAP_TYPE_NAMES Data Member
m_Name Data Member
m_pobParamDescription Data Member
Constructors
shaderMaterialGeoParamValue
shaderMaterialGeoParamValue Constructor (const parTreeNode*)
shaderMaterialGeoParamValue Constructor (const shaderMaterialGeoParamDescription*)
shaderMaterialGeoParamValue Constructor (const shaderMaterialGeoParamValue*)
Destructors
~shaderMaterialGeoParamValue Destructor
Methods
CleanUp Method
Copy Method
CopyValueIntoVector2 Method
GetName Method
GetParamDescription Method
GetSourceOfParamValue Method
GetType Method
GetTypeName Method
Init Method
IsEqual Method
IsLightmap Method
ReadGeoParamValueData Method
Reset Method
SetDefaultValue Method
SetMaterialValue Method
SetName Method
Update
Update Method (const Matrix34&)
Update Method (const Matrix44&)
Update Method (const Vector2&)
Update Method (const Vector3&)
Update Method (const Vector4&)
Update Method (const bool)
Update Method (const char *)
Update Method (const char *, const float)
Update Method (const char *, const float, const float, const float)
Update Method (const float)
Update Method (const int)
Update Method (const shaderMaterialGeoParamValue *)
WriteAsGeoTypeMember Method
WriteGeoParamValueData Method
Enumerations
LIGHTMAP_TYPES Enumeration
shaderMaterialGeoParamValueFloat Class
Constructors
shaderMaterialGeoParamValueFloat
shaderMaterialGeoParamValueFloat Constructor (const parTreeNode*)
shaderMaterialGeoParamValueFloat Constructor (const shaderMaterialGeoParamDescription*)
shaderMaterialGeoParamValueFloat Constructor (const shaderMaterialGeoParamValueFloat*)
Destructors
~shaderMaterialGeoParamValueFloat Destructor
Methods
CleanUp Method
Copy Method
CopyValueIntoVector2 Method
GetType Method
GetTypeName Method
GetValue Method
IsEqual Method
LoadFromXML Method
ReadGeoParamValueData Method
Reset Method
SaveToXML Method
SetDefaultValue Method
SetMaterialValue Method
SetValue Method
Update
Update Method (const bool)
Update Method (const char *)
Update Method (const char *, const float)
Update Method (const char *, const float, const float, const float)
Update Method (const float)
Update Method (const int)
Update Method (const shaderMaterialGeoParamValue *)
WriteAsGeoTypeMember Method
WriteGeoParamValueData Method
shaderMaterialGeoParamValueMatrix34 Class
Constructors
shaderMaterialGeoParamValueMatrix34
shaderMaterialGeoParamValueMatrix34 Constructor (const shaderMaterialGeoParamDescription*)
shaderMaterialGeoParamValueMatrix34 Constructor (const shaderMaterialGeoParamValueMatrix34*)
Destructors
~shaderMaterialGeoParamValueMatrix34 Destructor
Methods
Copy Method
GetType Method
GetTypeName Method
GetValue Method
IsEqual Method
ReadGeoParamValueData Method
Reset Method
SetDefaultValue Method
SetValue Method
Update
Update Method (const Matrix34&)
Update Method (const char *, const float)
Update Method (const shaderMaterialGeoParamValue *)
WriteAsGeoTypeMember Method
WriteGeoParamValueData Method
shaderMaterialGeoParamValueMatrix44 Class
Constructors
shaderMaterialGeoParamValueMatrix44
shaderMaterialGeoParamValueMatrix44 Constructor (const shaderMaterialGeoParamDescription*)
shaderMaterialGeoParamValueMatrix44 Constructor (const shaderMaterialGeoParamValueMatrix44*)
Destructors
~shaderMaterialGeoParamValueMatrix44 Destructor
Methods
Copy Method
GetType Method
GetTypeName Method
GetValue Method
IsEqual Method
ReadGeoParamValueData Method
Reset Method
SetDefaultValue Method
SetValue Method
Update
Update Method (const Matrix44&)
Update Method (const char *, const float)
Update Method (const shaderMaterialGeoParamValue *)
WriteAsGeoTypeMember Method
WriteGeoParamValueData Method
shaderMaterialGeoParamValueString Class
Constructors
shaderMaterialGeoParamValueString
shaderMaterialGeoParamValueString Constructor (const parTreeNode*)
shaderMaterialGeoParamValueString Constructor (const shaderMaterialGeoParamDescription*)
shaderMaterialGeoParamValueString Constructor (const shaderMaterialGeoParamValueString*)
Destructors
~shaderMaterialGeoParamValueString Destructor
Methods
CleanUp Method
Copy Method
GetType Method
GetTypeName Method
GetValue Method
IsEqual Method
ReadGeoParamValueData Method
Reset Method
SetDefaultValue Method
SetValue Method
Update
Update Method (const bool)
Update Method (const char *)
Update Method (const char *, const float)
Update Method (const char *, const float, const float, const float)
Update Method (const float)
Update Method (const int)
Update Method (const shaderMaterialGeoParamValue *)
WriteAsGeoTypeMember Method
WriteGeoParamValueData Method
shaderMaterialGeoParamValueTexture Class
Constructors
shaderMaterialGeoParamValueTexture
shaderMaterialGeoParamValueTexture Constructor (const parTreeNode*)
shaderMaterialGeoParamValueTexture Constructor (const shaderMaterialGeoParamDescription*)
shaderMaterialGeoParamValueTexture Constructor (const shaderMaterialGeoParamValueTexture*)
Destructors
~shaderMaterialGeoParamValueTexture Destructor
Methods
CleanUp Method
Copy Method
GetTextureName
GetTextureName Method (ConstString &)
GetTextureName Method (ConstString &, const char *)
GetType Method
GetTypeName Method
GetValue Method
IsEqual Method
ReadGeoParamValueData Method
Reset Method
SetDefaultValue Method
SetValue Method
Update
Update Method (const bool)
Update Method (const char *)
Update Method (const char *, const float)
Update Method (const char *, const float, const float, const float)
Update Method (const float)
Update Method (const int)
Update Method (const shaderMaterialGeoParamValue *)
WriteAsGeoTypeMember Method
WriteGeoParamValueData Method
shaderMaterialGeoParamValueVector2 Class
Constructors
shaderMaterialGeoParamValueVector2
shaderMaterialGeoParamValueVector2 Constructor (const parTreeNode*)
shaderMaterialGeoParamValueVector2 Constructor (const shaderMaterialGeoParamDescription*)
shaderMaterialGeoParamValueVector2 Constructor (const shaderMaterialGeoParamValueVector2*)
Destructors
~shaderMaterialGeoParamValueVector2 Destructor
Methods
Copy Method
CopyValueIntoVector2 Method
GetType Method
GetTypeName Method
GetValue Method
IsEqual Method
ReadGeoParamValueData Method
Reset Method
SetDefaultValue Method
SetMaterialValue Method
SetValue Method
Update
Update Method (const Vector2&)
Update Method (const char *, const float)
Update Method (const shaderMaterialGeoParamValue *)
WriteAsGeoTypeMember Method
WriteGeoParamValueData Method
shaderMaterialGeoParamValueVector3 Class
Constructors
shaderMaterialGeoParamValueVector3
shaderMaterialGeoParamValueVector3 Constructor (const parTreeNode*)
shaderMaterialGeoParamValueVector3 Constructor (const shaderMaterialGeoParamDescription*)
shaderMaterialGeoParamValueVector3 Constructor (const shaderMaterialGeoParamValueVector3*)
Destructors
~shaderMaterialGeoParamValueVector3 Destructor
Methods
Copy Method
GetType Method
GetTypeName Method
GetValue Method
IsEqual Method
ReadGeoParamValueData Method
Reset Method
SetDefaultValue Method
SetValue Method
Update
Update Method (const Vector3&)
Update Method (const char *, const float)
Update Method (const char *, const float, const float, const float)
Update Method (const shaderMaterialGeoParamValue *)
WriteAsGeoTypeMember Method
WriteGeoParamValueData Method
shaderMaterialGeoParamValueVector4 Class
Constructors
shaderMaterialGeoParamValueVector4
shaderMaterialGeoParamValueVector4 Constructor (const parTreeNode*)
shaderMaterialGeoParamValueVector4 Constructor (const shaderMaterialGeoParamDescription*)
shaderMaterialGeoParamValueVector4 Constructor (const shaderMaterialGeoParamValueVector4*)
Destructors
~shaderMaterialGeoParamValueVector4 Destructor
Methods
Copy Method
GetType Method
GetTypeName Method
GetValue Method
IsEqual Method
ReadGeoParamValueData Method
Reset Method
SetDefaultValue Method
SetValue Method
Update
Update Method (const Vector4&)
Update Method (const char *, const float)
Update Method (const char *, const float, const float, const float)
Update Method (const shaderMaterialGeoParamValue *)
WriteAsGeoTypeMember Method
WriteGeoParamValueData Method
shaderMaterialGeoTemplate Class
Constructors
shaderMaterialGeoTemplate
shaderMaterialGeoTemplate Constructor ()
shaderMaterialGeoTemplate Constructor (const char *)
Destructors
~shaderMaterialGeoTemplate Destructor
Methods
CreateFromShader Method
GetBucketNumber Method
GetParamDescription Method
GetRunTimeVertexColourDescriptions Method
GetShaderFilename Method
GetShaderName Method
GetShaderParamDescriptions Method
GetShaderPathAndFilename Method
GetSourceVertexColourDescriptions Method
GetTemplateFilename Method
GetTemplateName Method
GetTemplatePathAndFilename Method
LoadFromGeoTemplate Method
SaveTo Method
shaderMaterialGeoType Class
Data Members
m_apShaderParamValues Data Member
m_bInstance Data Member
m_pobParentType Data Member
m_pobTemplate Data Member
m_sGeoTypeUID Data Member
m_strParentTypeName Data Member
m_strParentTypePathAndFilename Data Member
m_strTypeName Data Member
m_strTypePathAndFilename Data Member
Constructors
shaderMaterialGeoType
shaderMaterialGeoType Constructor ()
shaderMaterialGeoType Constructor (const shaderMaterialGeoType &)
Destructors
~shaderMaterialGeoType Destructor
Methods
AddParamValuesFromParamDescriptions Method
AssignNewUID Method
ChangeParentType Method
ConstructFromParentType Method
Copy Method
CopyParamValues Method
CopyParamValuesSelectively Method
GetNoOfParams Method
GetNoOfShaderParams Method
GetParam
GetParam Method (const char*)
GetParam Method (const char*)
GetParam Method (int)
GetParam Method (int)
GetParamByUIName
GetParamByUIName Method (const char*)
GetParamByUIName Method (const char*)
GetParentType Method
GetParentTypeFilename Method
GetParentTypeName Method
GetParentTypePathAndFilename Method
GetShaderParam
GetShaderParam Method (const char*)
GetShaderParam Method (const char*)
GetShaderParam Method (int)
GetShaderParam Method (int)
GetShaderParamByUIName
GetShaderParamByUIName Method (const char*)
GetShaderParamByUIName Method (const char*)
GetTemplate Method
GetTypeFilename Method
GetTypeName Method
GetTypePathAndFilename Method
GetUID Method
GetUvSetCount Method
InitialiseFromTemplate Method
IsEqual Method
LoadFromGeoType
LoadFromGeoType Method (const char *)
LoadFromGeoType Method (fiStream *)
LoadParameterFromGeoType Method
SaveTo Method
SaveToGeoType
SaveToGeoType Method (const char *)
SaveToGeoType Method (fiStream *)
SetParentTypePathAndFilename Method
SetShaderVariableValue Method
SetTypePathAndFilename Method
SetUIDToString Method
UpdateShaderVariable Method
Operators
= Operator
== Operator
grmVariableInfo Type
DEFAULT_UV_SET_NAME Macro
Variables
shaderMaterialGeoManager::m_gShaderMaterialGeoManager Variable
shaderMaterialGeoParamDescription::LIGHTMAP_TYPE_NAMES Variable
shaderMaterialGeoParamValue::LIGHTMAP_TYPE_NAMES Variable
Macros
BUFFER_LEN Macro
CleanFilename Macro
SHADER_MATERIAL_GEO_MANAGER Macro


Index

Index
~ | = | A | B | C | G | I | L | M | O | R | S | U | W
~
~shaderMaterialGeoInstance
~shaderMaterialGeoParamDescription
~shaderMaterialGeoParamDescriptionFloat
~shaderMaterialGeoParamDescriptionMatrix34
~shaderMaterialGeoParamDescriptionMatrix44
~shaderMaterialGeoParamDescriptionString
~shaderMaterialGeoParamDescriptionTexture
~shaderMaterialGeoParamDescriptionVector2
~shaderMaterialGeoParamDescriptionVector3
~shaderMaterialGeoParamDescriptionVector4
~shaderMaterialGeoParamValue
~shaderMaterialGeoParamValueFloat
~shaderMaterialGeoParamValueMatrix34
~shaderMaterialGeoParamValueMatrix44
~shaderMaterialGeoParamValueString
~shaderMaterialGeoParamValueTexture
~shaderMaterialGeoParamValueVector2
~shaderMaterialGeoParamValueVector3
~shaderMaterialGeoParamValueVector4
~shaderMaterialGeoTemplate
~shaderMaterialGeoType
=
=
==
A
AddChildShaderMaterialGeoInstance
AddChildShaderMaterialGeoInstanceWithGUID
AddParamValuesFromParamDescriptions
AddRefToShaderMaterialGeoInstanceWithGUID
AssignNewUID
B
BUFFER_LEN
BUFFER_LEN macro
C
ChangeParentType
CleanFilename
CleanFilename macro
CleanUp
Command Line Options
Components
ConstructFromParentType
Copy
CopyParamValues
CopyParamValuesSelectively
CopyValueIntoVector2
CreateFromShader
CreateShaderMaterialGeoInstanceFromTemplate
CreateShaderMaterialGeoInstanceFromType
CreateShaderMaterialGeoTemplateFromShader
CreateShaderMaterialGeoTypeFromTemplate
G
GetBaseGEOPath
GetBucketNumber
GetDefaultValue
GetInstanceFilename
GetInstanceName
GetInstancePathAndFilename
GetMaterialDataUvSetIndex
GetName
GetNoOfMipLevels
GetNoOfParams
GetNoOfShaderParams
GetParam
GetParamByUIName
GetParamDescription
GetParentType
GetParentTypeFilename
GetParentTypeName
GetParentTypePathAndFilename
GetPathToTemplates
GetPathToTypes
GetRunTimeVertexColourDescriptions
GetShaderFilename
GetShaderMaterialGeoInstance
GetShaderMaterialGeoInstanceFromUID
GetShaderMaterialGeoManager
GetShaderMaterialGeoTemplate
GetShaderMaterialGeoType
GetShaderName
GetShaderParam
GetShaderParamByUIName
GetShaderParamDescriptions
GetShaderPathAndFilename
GetSourceOfParamValue
GetSourceVertexColourDescriptions
GetTemplate
GetTemplateFilename
GetTemplateName
GetTemplatePathAndFilename
GetTextureName
GetTextureOutputFormats
GetType
GetTypeFilename
GetTypeName
GetTypePathAndFilename
GetUID
GetUIHelp
GetUIHint
GetUIMax
GetUIMin
GetUIName
GetUIStep
GetUIWidget
GetUvSetCount
GetUvSetIndex
GetUvSetName
GetValue
I
Init
InitialiseFromTemplate
Initialize
IsEqual
IsLightmap
L
LIGHTMAP_TYPE_NAMES
LoadFromGeoInstance
LoadFromGeoTemplate
LoadFromGeoType
LoadFromXML
LoadParameterFromGeoType
LoadShaderMaterialGeoInstance
LoadShaderMaterialGeoTemplate
LoadShaderMaterialGeoType
M
m_apShaderParamValues
m_bInstance
m_eValueSource
m_iNoOfMipLevels
m_MaterialDefaultValueUvSetIndex
m_Name
m_pobParamDescription
m_pobParentType
m_pobTemplate
m_sGeoTypeUID
m_strParentTypeName
m_strParentTypePathAndFilename
m_strTypeName
m_strTypePathAndFilename
m_TextureOutputFormats
m_UIHelp
m_UIHidden
m_UIHint
m_UIMax
m_UIMin
m_UIName
m_UIStep
m_UIWidget
m_UvSetIndex
m_UvSetName
O
Overview
R
rage
rage namespace
rage::DEFAULT_UV_SET_NAME
rage::DEFAULT_UV_SET_NAME macro
rage::grmVariableInfo
rage::grmVariableInfo type
rage::shaderMaterialGeoInstance
rage::shaderMaterialGeoInstance::~shaderMaterialGeoInstance
rage::shaderMaterialGeoInstance::ConstructFromParentType
rage::shaderMaterialGeoInstance::CopyParamValuesSelectively
rage::shaderMaterialGeoInstance::GetInstanceFilename
rage::shaderMaterialGeoInstance::GetInstanceName
rage::shaderMaterialGeoInstance::GetInstancePathAndFilename
rage::shaderMaterialGeoInstance::GetTemplate
rage::shaderMaterialGeoInstance::GetTemplateName
rage::shaderMaterialGeoInstance::LoadFromGeoInstance
rage::shaderMaterialGeoInstance::SaveTo
rage::shaderMaterialGeoInstance::shaderMaterialGeoInstance
rage::shaderMaterialGeoManager
rage::shaderMaterialGeoManager::AddChildShaderMaterialGeoInstance
rage::shaderMaterialGeoManager::AddChildShaderMaterialGeoInstanceWithGUID
rage::shaderMaterialGeoManager::AddRefToShaderMaterialGeoInstanceWithGUID
rage::shaderMaterialGeoManager::CreateShaderMaterialGeoInstanceFromTemplate
rage::shaderMaterialGeoManager::CreateShaderMaterialGeoInstanceFromType
rage::shaderMaterialGeoManager::CreateShaderMaterialGeoTemplateFromShader
rage::shaderMaterialGeoManager::CreateShaderMaterialGeoTypeFromTemplate
rage::shaderMaterialGeoManager::GetBaseGEOPath
rage::shaderMaterialGeoManager::GetPathToTemplates
rage::shaderMaterialGeoManager::GetPathToTypes
rage::shaderMaterialGeoManager::GetShaderMaterialGeoInstance
rage::shaderMaterialGeoManager::GetShaderMaterialGeoInstanceFromUID
rage::shaderMaterialGeoManager::GetShaderMaterialGeoManager
rage::shaderMaterialGeoManager::GetShaderMaterialGeoTemplate
rage::shaderMaterialGeoManager::GetShaderMaterialGeoType
rage::shaderMaterialGeoManager::Initialize
rage::shaderMaterialGeoManager::LoadShaderMaterialGeoInstance
rage::shaderMaterialGeoManager::LoadShaderMaterialGeoTemplate
rage::shaderMaterialGeoManager::LoadShaderMaterialGeoType
rage::shaderMaterialGeoManager::ReleaseShaderMaterialGeoInstance
rage::shaderMaterialGeoManager::ReleaseShaderMaterialGeoInstanceWithGUID
rage::shaderMaterialGeoManager::ReloadShaderMaterialGeoInstance
rage::shaderMaterialGeoManager::ReloadShaderMaterialGeoType
rage::shaderMaterialGeoManager::RemoveChildShaderMaterialGeoInstance
rage::shaderMaterialGeoManager::RemoveChildShaderMaterialGeoInstanceWithGUID
rage::shaderMaterialGeoManager::Shutdown
rage::shaderMaterialGeoParamDescription
rage::shaderMaterialGeoParamDescription::~shaderMaterialGeoParamDescription
rage::shaderMaterialGeoParamDescription::CleanUp
rage::shaderMaterialGeoParamDescription::Copy
rage::shaderMaterialGeoParamDescription::GetMaterialDataUvSetIndex
rage::shaderMaterialGeoParamDescription::GetName
rage::shaderMaterialGeoParamDescription::GetNoOfMipLevels
rage::shaderMaterialGeoParamDescription::GetSourceOfParamValue
rage::shaderMaterialGeoParamDescription::GetTextureOutputFormats
rage::shaderMaterialGeoParamDescription::GetType
rage::shaderMaterialGeoParamDescription::GetTypeName
rage::shaderMaterialGeoParamDescription::GetUIHelp
rage::shaderMaterialGeoParamDescription::GetUIHint
rage::shaderMaterialGeoParamDescription::GetUIMax
rage::shaderMaterialGeoParamDescription::GetUIMin
rage::shaderMaterialGeoParamDescription::GetUIName
rage::shaderMaterialGeoParamDescription::GetUIStep
rage::shaderMaterialGeoParamDescription::GetUIWidget
rage::shaderMaterialGeoParamDescription::GetUvSetIndex
rage::shaderMaterialGeoParamDescription::GetUvSetName
rage::shaderMaterialGeoParamDescription::Init
rage::shaderMaterialGeoParamDescription::IsEqual
rage::shaderMaterialGeoParamDescription::IsLightmap
rage::shaderMaterialGeoParamDescription::LIGHTMAP_TYPE_NAMES
rage::shaderMaterialGeoParamDescription::LIGHTMAP_TYPES
rage::shaderMaterialGeoParamDescription::LIGHTMAP_TYPES enumeration
rage::shaderMaterialGeoParamDescription::m_eValueSource
rage::shaderMaterialGeoParamDescription::m_iNoOfMipLevels
rage::shaderMaterialGeoParamDescription::m_MaterialDefaultValueUvSetIndex
rage::shaderMaterialGeoParamDescription::m_Name
rage::shaderMaterialGeoParamDescription::m_TextureOutputFormats
rage::shaderMaterialGeoParamDescription::m_UIHelp
rage::shaderMaterialGeoParamDescription::m_UIHidden
rage::shaderMaterialGeoParamDescription::m_UIHint
rage::shaderMaterialGeoParamDescription::m_UIMax
rage::shaderMaterialGeoParamDescription::m_UIMin
rage::shaderMaterialGeoParamDescription::m_UIName
rage::shaderMaterialGeoParamDescription::m_UIStep
rage::shaderMaterialGeoParamDescription::m_UIWidget
rage::shaderMaterialGeoParamDescription::m_UvSetIndex
rage::shaderMaterialGeoParamDescription::m_UvSetName
rage::shaderMaterialGeoParamDescription::ReadGeoParamDescriptionData
rage::shaderMaterialGeoParamDescription::Reset
rage::shaderMaterialGeoParamDescription::SetDefaultValue
rage::shaderMaterialGeoParamDescription::SetDefaultValueUvSetIndex
rage::shaderMaterialGeoParamDescription::SetName
rage::shaderMaterialGeoParamDescription::SetTextureOutputFormats
rage::shaderMaterialGeoParamDescription::SetUIHint
rage::shaderMaterialGeoParamDescription::SetUIMax
rage::shaderMaterialGeoParamDescription::SetUIMin
rage::shaderMaterialGeoParamDescription::SetUIName
rage::shaderMaterialGeoParamDescription::SetUIStep
rage::shaderMaterialGeoParamDescription::SetUIWidget
rage::shaderMaterialGeoParamDescription::SetUvSetIndex
rage::shaderMaterialGeoParamDescription::SetUvSetName
rage::shaderMaterialGeoParamDescription::SetValueSource
rage::shaderMaterialGeoParamDescription::shaderMaterialGeoParamDescription
rage::shaderMaterialGeoParamDescription::ValueSource
rage::shaderMaterialGeoParamDescription::ValueSource enumeration
rage::shaderMaterialGeoParamDescription::WriteAsGeoInstanceMember
rage::shaderMaterialGeoParamDescription::WriteAsGeoTemplateMember
rage::shaderMaterialGeoParamDescription::WriteGeoParamDescriptionData
rage::shaderMaterialGeoParamDescriptionFloat
rage::shaderMaterialGeoParamDescriptionFloat::~shaderMaterialGeoParamDescriptionFloat
rage::shaderMaterialGeoParamDescriptionFloat::CleanUp
rage::shaderMaterialGeoParamDescriptionFloat::Copy
rage::shaderMaterialGeoParamDescriptionFloat::GetDefaultValue
rage::shaderMaterialGeoParamDescriptionFloat::GetType
rage::shaderMaterialGeoParamDescriptionFloat::GetTypeName
rage::shaderMaterialGeoParamDescriptionFloat::IsEqual
rage::shaderMaterialGeoParamDescriptionFloat::LoadFromXML
rage::shaderMaterialGeoParamDescriptionFloat::ReadGeoParamDescriptionData
rage::shaderMaterialGeoParamDescriptionFloat::Reset
rage::shaderMaterialGeoParamDescriptionFloat::SaveToXML
rage::shaderMaterialGeoParamDescriptionFloat::SetDefaultValue
rage::shaderMaterialGeoParamDescriptionFloat::shaderMaterialGeoParamDescriptionFloat
rage::shaderMaterialGeoParamDescriptionFloat::WriteAsGeoInstanceMember
rage::shaderMaterialGeoParamDescriptionFloat::WriteAsGeoTemplateMember
rage::shaderMaterialGeoParamDescriptionFloat::WriteGeoParamDescriptionData
rage::shaderMaterialGeoParamDescriptionMatrix34
rage::shaderMaterialGeoParamDescriptionMatrix34::~shaderMaterialGeoParamDescriptionMatrix34
rage::shaderMaterialGeoParamDescriptionMatrix34::Copy
rage::shaderMaterialGeoParamDescriptionMatrix34::GetDefaultValue
rage::shaderMaterialGeoParamDescriptionMatrix34::GetType
rage::shaderMaterialGeoParamDescriptionMatrix34::GetTypeName
rage::shaderMaterialGeoParamDescriptionMatrix34::IsEqual
rage::shaderMaterialGeoParamDescriptionMatrix34::ReadGeoParamDescriptionData
rage::shaderMaterialGeoParamDescriptionMatrix34::Reset
rage::shaderMaterialGeoParamDescriptionMatrix34::SetDefaultValue
rage::shaderMaterialGeoParamDescriptionMatrix34::shaderMaterialGeoParamDescriptionMatrix34
rage::shaderMaterialGeoParamDescriptionMatrix34::WriteAsGeoInstanceMember
rage::shaderMaterialGeoParamDescriptionMatrix34::WriteAsGeoTemplateMember
rage::shaderMaterialGeoParamDescriptionMatrix34::WriteGeoParamDescriptionData
rage::shaderMaterialGeoParamDescriptionMatrix44
rage::shaderMaterialGeoParamDescriptionMatrix44::~shaderMaterialGeoParamDescriptionMatrix44
rage::shaderMaterialGeoParamDescriptionMatrix44::Copy
rage::shaderMaterialGeoParamDescriptionMatrix44::GetDefaultValue
rage::shaderMaterialGeoParamDescriptionMatrix44::GetType
rage::shaderMaterialGeoParamDescriptionMatrix44::GetTypeName
rage::shaderMaterialGeoParamDescriptionMatrix44::IsEqual
rage::shaderMaterialGeoParamDescriptionMatrix44::ReadGeoParamDescriptionData
rage::shaderMaterialGeoParamDescriptionMatrix44::Reset
rage::shaderMaterialGeoParamDescriptionMatrix44::SetDefaultValue
rage::shaderMaterialGeoParamDescriptionMatrix44::shaderMaterialGeoParamDescriptionMatrix44
rage::shaderMaterialGeoParamDescriptionMatrix44::WriteAsGeoInstanceMember
rage::shaderMaterialGeoParamDescriptionMatrix44::WriteAsGeoTemplateMember
rage::shaderMaterialGeoParamDescriptionMatrix44::WriteGeoParamDescriptionData
rage::shaderMaterialGeoParamDescriptionString
rage::shaderMaterialGeoParamDescriptionString::~shaderMaterialGeoParamDescriptionString
rage::shaderMaterialGeoParamDescriptionString::CleanUp
rage::shaderMaterialGeoParamDescriptionString::Copy
rage::shaderMaterialGeoParamDescriptionString::GetDefaultValue
rage::shaderMaterialGeoParamDescriptionString::GetType
rage::shaderMaterialGeoParamDescriptionString::GetTypeName
rage::shaderMaterialGeoParamDescriptionString::IsEqual
rage::shaderMaterialGeoParamDescriptionString::ReadGeoParamDescriptionData
rage::shaderMaterialGeoParamDescriptionString::Reset
rage::shaderMaterialGeoParamDescriptionString::SetDefaultValue
rage::shaderMaterialGeoParamDescriptionString::shaderMaterialGeoParamDescriptionString
rage::shaderMaterialGeoParamDescriptionString::WriteAsGeoInstanceMember
rage::shaderMaterialGeoParamDescriptionString::WriteAsGeoTemplateMember
rage::shaderMaterialGeoParamDescriptionString::WriteGeoParamDescriptionData
rage::shaderMaterialGeoParamDescriptionTexture
rage::shaderMaterialGeoParamDescriptionTexture::~shaderMaterialGeoParamDescriptionTexture
rage::shaderMaterialGeoParamDescriptionTexture::CleanUp
rage::shaderMaterialGeoParamDescriptionTexture::Copy
rage::shaderMaterialGeoParamDescriptionTexture::GetDefaultValue
rage::shaderMaterialGeoParamDescriptionTexture::GetTextureName
rage::shaderMaterialGeoParamDescriptionTexture::GetType
rage::shaderMaterialGeoParamDescriptionTexture::GetTypeName
rage::shaderMaterialGeoParamDescriptionTexture::IsEqual
rage::shaderMaterialGeoParamDescriptionTexture::ReadGeoParamDescriptionData
rage::shaderMaterialGeoParamDescriptionTexture::Reset
rage::shaderMaterialGeoParamDescriptionTexture::SetDefaultValue
rage::shaderMaterialGeoParamDescriptionTexture::shaderMaterialGeoParamDescriptionTexture
rage::shaderMaterialGeoParamDescriptionTexture::WriteAsGeoInstanceMember
rage::shaderMaterialGeoParamDescriptionTexture::WriteAsGeoTemplateMember
rage::shaderMaterialGeoParamDescriptionTexture::WriteGeoParamDescriptionData
rage::shaderMaterialGeoParamDescriptionVector2
rage::shaderMaterialGeoParamDescriptionVector2::~shaderMaterialGeoParamDescriptionVector2
rage::shaderMaterialGeoParamDescriptionVector2::Copy
rage::shaderMaterialGeoParamDescriptionVector2::GetDefaultValue
rage::shaderMaterialGeoParamDescriptionVector2::GetType
rage::shaderMaterialGeoParamDescriptionVector2::GetTypeName
rage::shaderMaterialGeoParamDescriptionVector2::IsEqual
rage::shaderMaterialGeoParamDescriptionVector2::ReadGeoParamDescriptionData
rage::shaderMaterialGeoParamDescriptionVector2::Reset
rage::shaderMaterialGeoParamDescriptionVector2::SetDefaultValue
rage::shaderMaterialGeoParamDescriptionVector2::shaderMaterialGeoParamDescriptionVector2
rage::shaderMaterialGeoParamDescriptionVector2::WriteAsGeoInstanceMember
rage::shaderMaterialGeoParamDescriptionVector2::WriteAsGeoTemplateMember
rage::shaderMaterialGeoParamDescriptionVector2::WriteGeoParamDescriptionData
rage::shaderMaterialGeoParamDescriptionVector3
rage::shaderMaterialGeoParamDescriptionVector3::~shaderMaterialGeoParamDescriptionVector3
rage::shaderMaterialGeoParamDescriptionVector3::Copy
rage::shaderMaterialGeoParamDescriptionVector3::GetDefaultValue
rage::shaderMaterialGeoParamDescriptionVector3::GetType
rage::shaderMaterialGeoParamDescriptionVector3::GetTypeName
rage::shaderMaterialGeoParamDescriptionVector3::IsEqual
rage::shaderMaterialGeoParamDescriptionVector3::ReadGeoParamDescriptionData
rage::shaderMaterialGeoParamDescriptionVector3::Reset
rage::shaderMaterialGeoParamDescriptionVector3::SetDefaultValue
rage::shaderMaterialGeoParamDescriptionVector3::shaderMaterialGeoParamDescriptionVector3
rage::shaderMaterialGeoParamDescriptionVector3::WriteAsGeoInstanceMember
rage::shaderMaterialGeoParamDescriptionVector3::WriteAsGeoTemplateMember
rage::shaderMaterialGeoParamDescriptionVector3::WriteGeoParamDescriptionData
rage::shaderMaterialGeoParamDescriptionVector4
rage::shaderMaterialGeoParamDescriptionVector4::~shaderMaterialGeoParamDescriptionVector4
rage::shaderMaterialGeoParamDescriptionVector4::Copy
rage::shaderMaterialGeoParamDescriptionVector4::GetDefaultValue
rage::shaderMaterialGeoParamDescriptionVector4::GetType
rage::shaderMaterialGeoParamDescriptionVector4::GetTypeName
rage::shaderMaterialGeoParamDescriptionVector4::IsEqual
rage::shaderMaterialGeoParamDescriptionVector4::ReadGeoParamDescriptionData
rage::shaderMaterialGeoParamDescriptionVector4::Reset
rage::shaderMaterialGeoParamDescriptionVector4::SetDefaultValue
rage::shaderMaterialGeoParamDescriptionVector4::shaderMaterialGeoParamDescriptionVector4
rage::shaderMaterialGeoParamDescriptionVector4::WriteAsGeoInstanceMember
rage::shaderMaterialGeoParamDescriptionVector4::WriteAsGeoTemplateMember
rage::shaderMaterialGeoParamDescriptionVector4::WriteGeoParamDescriptionData
rage::shaderMaterialGeoParamValue
rage::shaderMaterialGeoParamValue::~shaderMaterialGeoParamValue
rage::shaderMaterialGeoParamValue::CleanUp
rage::shaderMaterialGeoParamValue::Copy
rage::shaderMaterialGeoParamValue::CopyValueIntoVector2
rage::shaderMaterialGeoParamValue::GetName
rage::shaderMaterialGeoParamValue::GetParamDescription
rage::shaderMaterialGeoParamValue::GetSourceOfParamValue
rage::shaderMaterialGeoParamValue::GetType
rage::shaderMaterialGeoParamValue::GetTypeName
rage::shaderMaterialGeoParamValue::Init
rage::shaderMaterialGeoParamValue::IsEqual
rage::shaderMaterialGeoParamValue::IsLightmap
rage::shaderMaterialGeoParamValue::LIGHTMAP_TYPE_NAMES
rage::shaderMaterialGeoParamValue::LIGHTMAP_TYPES
rage::shaderMaterialGeoParamValue::LIGHTMAP_TYPES enumeration
rage::shaderMaterialGeoParamValue::m_Name
rage::shaderMaterialGeoParamValue::m_pobParamDescription
rage::shaderMaterialGeoParamValue::ReadGeoParamValueData
rage::shaderMaterialGeoParamValue::Reset
rage::shaderMaterialGeoParamValue::SetDefaultValue
rage::shaderMaterialGeoParamValue::SetMaterialValue
rage::shaderMaterialGeoParamValue::SetName
rage::shaderMaterialGeoParamValue::shaderMaterialGeoParamValue
rage::shaderMaterialGeoParamValue::Update
rage::shaderMaterialGeoParamValue::WriteAsGeoTypeMember
rage::shaderMaterialGeoParamValue::WriteGeoParamValueData
rage::shaderMaterialGeoParamValueFloat
rage::shaderMaterialGeoParamValueFloat::~shaderMaterialGeoParamValueFloat
rage::shaderMaterialGeoParamValueFloat::CleanUp
rage::shaderMaterialGeoParamValueFloat::Copy
rage::shaderMaterialGeoParamValueFloat::CopyValueIntoVector2
rage::shaderMaterialGeoParamValueFloat::GetType
rage::shaderMaterialGeoParamValueFloat::GetTypeName
rage::shaderMaterialGeoParamValueFloat::GetValue
rage::shaderMaterialGeoParamValueFloat::IsEqual
rage::shaderMaterialGeoParamValueFloat::LoadFromXML
rage::shaderMaterialGeoParamValueFloat::ReadGeoParamValueData
rage::shaderMaterialGeoParamValueFloat::Reset
rage::shaderMaterialGeoParamValueFloat::SaveToXML
rage::shaderMaterialGeoParamValueFloat::SetDefaultValue
rage::shaderMaterialGeoParamValueFloat::SetMaterialValue
rage::shaderMaterialGeoParamValueFloat::SetValue
rage::shaderMaterialGeoParamValueFloat::shaderMaterialGeoParamValueFloat
rage::shaderMaterialGeoParamValueFloat::Update
rage::shaderMaterialGeoParamValueFloat::WriteAsGeoTypeMember
rage::shaderMaterialGeoParamValueFloat::WriteGeoParamValueData
rage::shaderMaterialGeoParamValueMatrix34
rage::shaderMaterialGeoParamValueMatrix34::~shaderMaterialGeoParamValueMatrix34
rage::shaderMaterialGeoParamValueMatrix34::Copy
rage::shaderMaterialGeoParamValueMatrix34::GetType
rage::shaderMaterialGeoParamValueMatrix34::GetTypeName
rage::shaderMaterialGeoParamValueMatrix34::GetValue
rage::shaderMaterialGeoParamValueMatrix34::IsEqual
rage::shaderMaterialGeoParamValueMatrix34::ReadGeoParamValueData
rage::shaderMaterialGeoParamValueMatrix34::Reset
rage::shaderMaterialGeoParamValueMatrix34::SetDefaultValue
rage::shaderMaterialGeoParamValueMatrix34::SetValue
rage::shaderMaterialGeoParamValueMatrix34::shaderMaterialGeoParamValueMatrix34
rage::shaderMaterialGeoParamValueMatrix34::Update
rage::shaderMaterialGeoParamValueMatrix34::WriteAsGeoTypeMember
rage::shaderMaterialGeoParamValueMatrix34::WriteGeoParamValueData
rage::shaderMaterialGeoParamValueMatrix44
rage::shaderMaterialGeoParamValueMatrix44::~shaderMaterialGeoParamValueMatrix44
rage::shaderMaterialGeoParamValueMatrix44::Copy
rage::shaderMaterialGeoParamValueMatrix44::GetType
rage::shaderMaterialGeoParamValueMatrix44::GetTypeName
rage::shaderMaterialGeoParamValueMatrix44::GetValue
rage::shaderMaterialGeoParamValueMatrix44::IsEqual
rage::shaderMaterialGeoParamValueMatrix44::ReadGeoParamValueData
rage::shaderMaterialGeoParamValueMatrix44::Reset
rage::shaderMaterialGeoParamValueMatrix44::SetDefaultValue
rage::shaderMaterialGeoParamValueMatrix44::SetValue
rage::shaderMaterialGeoParamValueMatrix44::shaderMaterialGeoParamValueMatrix44
rage::shaderMaterialGeoParamValueMatrix44::Update
rage::shaderMaterialGeoParamValueMatrix44::WriteAsGeoTypeMember
rage::shaderMaterialGeoParamValueMatrix44::WriteGeoParamValueData
rage::shaderMaterialGeoParamValueString
rage::shaderMaterialGeoParamValueString::~shaderMaterialGeoParamValueString
rage::shaderMaterialGeoParamValueString::CleanUp
rage::shaderMaterialGeoParamValueString::Copy
rage::shaderMaterialGeoParamValueString::GetType
rage::shaderMaterialGeoParamValueString::GetTypeName
rage::shaderMaterialGeoParamValueString::GetValue
rage::shaderMaterialGeoParamValueString::IsEqual
rage::shaderMaterialGeoParamValueString::ReadGeoParamValueData
rage::shaderMaterialGeoParamValueString::Reset
rage::shaderMaterialGeoParamValueString::SetDefaultValue
rage::shaderMaterialGeoParamValueString::SetValue
rage::shaderMaterialGeoParamValueString::shaderMaterialGeoParamValueString
rage::shaderMaterialGeoParamValueString::Update
rage::shaderMaterialGeoParamValueString::WriteAsGeoTypeMember
rage::shaderMaterialGeoParamValueString::WriteGeoParamValueData
rage::shaderMaterialGeoParamValueTexture
rage::shaderMaterialGeoParamValueTexture::~shaderMaterialGeoParamValueTexture
rage::shaderMaterialGeoParamValueTexture::CleanUp
rage::shaderMaterialGeoParamValueTexture::Copy
rage::shaderMaterialGeoParamValueTexture::GetTextureName
rage::shaderMaterialGeoParamValueTexture::GetType
rage::shaderMaterialGeoParamValueTexture::GetTypeName
rage::shaderMaterialGeoParamValueTexture::GetValue
rage::shaderMaterialGeoParamValueTexture::IsEqual
rage::shaderMaterialGeoParamValueTexture::ReadGeoParamValueData
rage::shaderMaterialGeoParamValueTexture::Reset
rage::shaderMaterialGeoParamValueTexture::SetDefaultValue
rage::shaderMaterialGeoParamValueTexture::SetValue
rage::shaderMaterialGeoParamValueTexture::shaderMaterialGeoParamValueTexture
rage::shaderMaterialGeoParamValueTexture::Update
rage::shaderMaterialGeoParamValueTexture::WriteAsGeoTypeMember
rage::shaderMaterialGeoParamValueTexture::WriteGeoParamValueData
rage::shaderMaterialGeoParamValueVector2
rage::shaderMaterialGeoParamValueVector2::~shaderMaterialGeoParamValueVector2
rage::shaderMaterialGeoParamValueVector2::Copy
rage::shaderMaterialGeoParamValueVector2::CopyValueIntoVector2
rage::shaderMaterialGeoParamValueVector2::GetType
rage::shaderMaterialGeoParamValueVector2::GetTypeName
rage::shaderMaterialGeoParamValueVector2::GetValue
rage::shaderMaterialGeoParamValueVector2::IsEqual
rage::shaderMaterialGeoParamValueVector2::ReadGeoParamValueData
rage::shaderMaterialGeoParamValueVector2::Reset
rage::shaderMaterialGeoParamValueVector2::SetDefaultValue
rage::shaderMaterialGeoParamValueVector2::SetMaterialValue
rage::shaderMaterialGeoParamValueVector2::SetValue
rage::shaderMaterialGeoParamValueVector2::shaderMaterialGeoParamValueVector2
rage::shaderMaterialGeoParamValueVector2::Update
rage::shaderMaterialGeoParamValueVector2::WriteAsGeoTypeMember
rage::shaderMaterialGeoParamValueVector2::WriteGeoParamValueData
rage::shaderMaterialGeoParamValueVector3
rage::shaderMaterialGeoParamValueVector3::~shaderMaterialGeoParamValueVector3
rage::shaderMaterialGeoParamValueVector3::Copy
rage::shaderMaterialGeoParamValueVector3::GetType
rage::shaderMaterialGeoParamValueVector3::GetTypeName
rage::shaderMaterialGeoParamValueVector3::GetValue
rage::shaderMaterialGeoParamValueVector3::IsEqual
rage::shaderMaterialGeoParamValueVector3::ReadGeoParamValueData
rage::shaderMaterialGeoParamValueVector3::Reset
rage::shaderMaterialGeoParamValueVector3::SetDefaultValue
rage::shaderMaterialGeoParamValueVector3::SetValue
rage::shaderMaterialGeoParamValueVector3::shaderMaterialGeoParamValueVector3
rage::shaderMaterialGeoParamValueVector3::Update
rage::shaderMaterialGeoParamValueVector3::WriteAsGeoTypeMember
rage::shaderMaterialGeoParamValueVector3::WriteGeoParamValueData
rage::shaderMaterialGeoParamValueVector4
rage::shaderMaterialGeoParamValueVector4::~shaderMaterialGeoParamValueVector4
rage::shaderMaterialGeoParamValueVector4::Copy
rage::shaderMaterialGeoParamValueVector4::GetType
rage::shaderMaterialGeoParamValueVector4::GetTypeName
rage::shaderMaterialGeoParamValueVector4::GetValue
rage::shaderMaterialGeoParamValueVector4::IsEqual
rage::shaderMaterialGeoParamValueVector4::ReadGeoParamValueData
rage::shaderMaterialGeoParamValueVector4::Reset
rage::shaderMaterialGeoParamValueVector4::SetDefaultValue
rage::shaderMaterialGeoParamValueVector4::SetValue
rage::shaderMaterialGeoParamValueVector4::shaderMaterialGeoParamValueVector4
rage::shaderMaterialGeoParamValueVector4::Update
rage::shaderMaterialGeoParamValueVector4::WriteAsGeoTypeMember
rage::shaderMaterialGeoParamValueVector4::WriteGeoParamValueData
rage::shaderMaterialGeoTemplate
rage::shaderMaterialGeoTemplate::~shaderMaterialGeoTemplate
rage::shaderMaterialGeoTemplate::CreateFromShader
rage::shaderMaterialGeoTemplate::GetBucketNumber
rage::shaderMaterialGeoTemplate::GetParamDescription
rage::shaderMaterialGeoTemplate::GetRunTimeVertexColourDescriptions
rage::shaderMaterialGeoTemplate::GetShaderFilename
rage::shaderMaterialGeoTemplate::GetShaderName
rage::shaderMaterialGeoTemplate::GetShaderParamDescriptions
rage::shaderMaterialGeoTemplate::GetShaderPathAndFilename
rage::shaderMaterialGeoTemplate::GetSourceVertexColourDescriptions
rage::shaderMaterialGeoTemplate::GetTemplateFilename
rage::shaderMaterialGeoTemplate::GetTemplateName
rage::shaderMaterialGeoTemplate::GetTemplatePathAndFilename
rage::shaderMaterialGeoTemplate::LoadFromGeoTemplate
rage::shaderMaterialGeoTemplate::SaveTo
rage::shaderMaterialGeoTemplate::shaderMaterialGeoTemplate
rage::shaderMaterialGeoType
rage::shaderMaterialGeoType::~shaderMaterialGeoType
rage::shaderMaterialGeoType::=
rage::shaderMaterialGeoType::==
rage::shaderMaterialGeoType::AddParamValuesFromParamDescriptions
rage::shaderMaterialGeoType::AssignNewUID
rage::shaderMaterialGeoType::ChangeParentType
rage::shaderMaterialGeoType::ConstructFromParentType
rage::shaderMaterialGeoType::Copy
rage::shaderMaterialGeoType::CopyParamValues
rage::shaderMaterialGeoType::CopyParamValuesSelectively
rage::shaderMaterialGeoType::GetNoOfParams
rage::shaderMaterialGeoType::GetNoOfShaderParams
rage::shaderMaterialGeoType::GetParam
rage::shaderMaterialGeoType::GetParamByUIName
rage::shaderMaterialGeoType::GetParentType
rage::shaderMaterialGeoType::GetParentTypeFilename
rage::shaderMaterialGeoType::GetParentTypeName
rage::shaderMaterialGeoType::GetParentTypePathAndFilename
rage::shaderMaterialGeoType::GetShaderParam
rage::shaderMaterialGeoType::GetShaderParamByUIName
rage::shaderMaterialGeoType::GetTemplate
rage::shaderMaterialGeoType::GetTypeFilename
rage::shaderMaterialGeoType::GetTypeName
rage::shaderMaterialGeoType::GetTypePathAndFilename
rage::shaderMaterialGeoType::GetUID
rage::shaderMaterialGeoType::GetUvSetCount
rage::shaderMaterialGeoType::InitialiseFromTemplate
rage::shaderMaterialGeoType::IsEqual
rage::shaderMaterialGeoType::LoadFromGeoType
rage::shaderMaterialGeoType::LoadParameterFromGeoType
rage::shaderMaterialGeoType::m_apShaderParamValues
rage::shaderMaterialGeoType::m_bInstance
rage::shaderMaterialGeoType::m_pobParentType
rage::shaderMaterialGeoType::m_pobTemplate
rage::shaderMaterialGeoType::m_sGeoTypeUID
rage::shaderMaterialGeoType::m_strParentTypeName
rage::shaderMaterialGeoType::m_strParentTypePathAndFilename
rage::shaderMaterialGeoType::m_strTypeName
rage::shaderMaterialGeoType::m_strTypePathAndFilename
rage::shaderMaterialGeoType::SaveTo
rage::shaderMaterialGeoType::SaveToGeoType
rage::shaderMaterialGeoType::SetParentTypePathAndFilename
rage::shaderMaterialGeoType::SetShaderVariableValue
rage::shaderMaterialGeoType::SetTypePathAndFilename
rage::shaderMaterialGeoType::SetUIDToString
rage::shaderMaterialGeoType::shaderMaterialGeoType
rage::shaderMaterialGeoType::UpdateShaderVariable
ReadGeoParamDescriptionData
ReadGeoParamValueData
Relationships
ReleaseShaderMaterialGeoInstance
ReleaseShaderMaterialGeoInstanceWithGUID
ReloadShaderMaterialGeoInstance
ReloadShaderMaterialGeoType
RemoveChildShaderMaterialGeoInstance
RemoveChildShaderMaterialGeoInstanceWithGUID
Reset
S
SaveTo
SaveToGeoType
SaveToXML
SetDefaultValue
SetDefaultValueUvSetIndex
SetMaterialValue
SetName
SetParentTypePathAndFilename
SetShaderVariableValue
SetTextureOutputFormats
SetTypePathAndFilename
SetUIDToString
SetUIHint
SetUIMax
SetUIMin
SetUIName
SetUIStep
SetUIWidget
SetUvSetIndex
SetUvSetName
SetValue
SetValueSource
SHADER_MATERIAL_GEO_MANAGER
SHADER_MATERIAL_GEO_MANAGER macro
shaderMaterialGeoInstance
shaderMaterialGeoInstance class
~shaderMaterialGeoInstance
ConstructFromParentType
CopyParamValuesSelectively
GetInstanceFilename
GetInstanceName
GetInstancePathAndFilename
GetTemplate
GetTemplateName
LoadFromGeoInstance
SaveTo
shaderMaterialGeoInstance
shaderMaterialGeoInstance::~shaderMaterialGeoInstance destructor
shaderMaterialGeoInstance::ConstructFromParentType method
shaderMaterialGeoInstance::CopyParamValuesSelectively method
shaderMaterialGeoInstance::GetInstanceFilename method
shaderMaterialGeoInstance::GetInstanceName method
shaderMaterialGeoInstance::GetInstancePathAndFilename method
shaderMaterialGeoInstance::GetTemplate method
shaderMaterialGeoInstance::GetTemplateName method
shaderMaterialGeoInstance::LoadFromGeoInstance method
shaderMaterialGeoInstance::SaveTo method
shaderMaterialGeoInstance::shaderMaterialGeoInstance constructor
shaderMaterialGeoManager class
AddChildShaderMaterialGeoInstance
AddChildShaderMaterialGeoInstanceWithGUID
AddRefToShaderMaterialGeoInstanceWithGUID
CreateShaderMaterialGeoInstanceFromTemplate
CreateShaderMaterialGeoInstanceFromType
CreateShaderMaterialGeoTemplateFromShader
CreateShaderMaterialGeoTypeFromTemplate
GetBaseGEOPath
GetPathToTemplates
GetPathToTypes
GetShaderMaterialGeoInstance
GetShaderMaterialGeoInstanceFromUID
GetShaderMaterialGeoManager
GetShaderMaterialGeoTemplate
GetShaderMaterialGeoType
Initialize
LoadShaderMaterialGeoInstance
LoadShaderMaterialGeoTemplate
LoadShaderMaterialGeoType
ReleaseShaderMaterialGeoInstance
ReleaseShaderMaterialGeoInstanceWithGUID
ReloadShaderMaterialGeoInstance
ReloadShaderMaterialGeoType
RemoveChildShaderMaterialGeoInstance
RemoveChildShaderMaterialGeoInstanceWithGUID
Shutdown
shaderMaterialGeoManager::AddChildShaderMaterialGeoInstance method
shaderMaterialGeoManager::AddChildShaderMaterialGeoInstanceWithGUID method
shaderMaterialGeoManager::AddRefToShaderMaterialGeoInstanceWithGUID method
shaderMaterialGeoManager::CreateShaderMaterialGeoInstanceFromTemplate method
shaderMaterialGeoManager::CreateShaderMaterialGeoInstanceFromType method
shaderMaterialGeoManager::CreateShaderMaterialGeoTemplateFromShader method
shaderMaterialGeoManager::CreateShaderMaterialGeoTypeFromTemplate method
shaderMaterialGeoManager::GetBaseGEOPath method
shaderMaterialGeoManager::GetPathToTemplates method
shaderMaterialGeoManager::GetPathToTypes method
shaderMaterialGeoManager::GetShaderMaterialGeoInstance method
shaderMaterialGeoManager::GetShaderMaterialGeoInstanceFromUID method
shaderMaterialGeoManager::GetShaderMaterialGeoManager method
shaderMaterialGeoManager::GetShaderMaterialGeoTemplate method
shaderMaterialGeoManager::GetShaderMaterialGeoType method
shaderMaterialGeoManager::Initialize method
shaderMaterialGeoManager::LoadShaderMaterialGeoInstance method
shaderMaterialGeoManager::LoadShaderMaterialGeoTemplate method
shaderMaterialGeoManager::LoadShaderMaterialGeoType method
shaderMaterialGeoManager::m_gShaderMaterialGeoManager
shaderMaterialGeoManager::m_gShaderMaterialGeoManager variable
shaderMaterialGeoManager::ReleaseShaderMaterialGeoInstance method
shaderMaterialGeoManager::ReleaseShaderMaterialGeoInstanceWithGUID method
shaderMaterialGeoManager::ReloadShaderMaterialGeoInstance method
shaderMaterialGeoManager::ReloadShaderMaterialGeoType method
shaderMaterialGeoManager::RemoveChildShaderMaterialGeoInstance method
shaderMaterialGeoManager::RemoveChildShaderMaterialGeoInstanceWithGUID method
shaderMaterialGeoManager::Shutdown method
shaderMaterialGeoParamDescription
shaderMaterialGeoParamDescription class
~shaderMaterialGeoParamDescription
CleanUp
Copy
GetMaterialDataUvSetIndex
GetName
GetNoOfMipLevels
GetSourceOfParamValue
GetTextureOutputFormats
GetType
GetTypeName
GetUIHelp
GetUIHint
GetUIMax
GetUIMin
GetUIName
GetUIStep
GetUIWidget
GetUvSetIndex
GetUvSetName
Init
IsEqual
IsLightmap
LIGHTMAP_TYPE_NAMES
m_eValueSource
m_iNoOfMipLevels
m_MaterialDefaultValueUvSetIndex
m_Name
m_TextureOutputFormats
m_UIHelp
m_UIHidden
m_UIHint
m_UIMax
m_UIMin
m_UIName
m_UIStep
m_UIWidget
m_UvSetIndex
m_UvSetName
ReadGeoParamDescriptionData
Reset
SetDefaultValue
SetDefaultValue
SetDefaultValue
SetDefaultValue
SetDefaultValue
SetDefaultValue
SetDefaultValue
SetDefaultValue
SetDefaultValue
SetDefaultValueUvSetIndex
SetName
SetTextureOutputFormats
SetUIHint
SetUIMax
SetUIMin
SetUIName
SetUIStep
SetUIWidget
SetUvSetIndex
SetUvSetName
SetValueSource
shaderMaterialGeoParamDescription
shaderMaterialGeoParamDescription
WriteAsGeoInstanceMember
WriteAsGeoTemplateMember
WriteGeoParamDescriptionData
shaderMaterialGeoParamDescription::~shaderMaterialGeoParamDescription destructor
shaderMaterialGeoParamDescription::CleanUp method
shaderMaterialGeoParamDescription::Copy method
shaderMaterialGeoParamDescription::GetMaterialDataUvSetIndex method
shaderMaterialGeoParamDescription::GetName method
shaderMaterialGeoParamDescription::GetNoOfMipLevels method
shaderMaterialGeoParamDescription::GetSourceOfParamValue method
shaderMaterialGeoParamDescription::GetTextureOutputFormats method
shaderMaterialGeoParamDescription::GetType method
shaderMaterialGeoParamDescription::GetTypeName method
shaderMaterialGeoParamDescription::GetUIHelp method
shaderMaterialGeoParamDescription::GetUIHint method
shaderMaterialGeoParamDescription::GetUIMax method
shaderMaterialGeoParamDescription::GetUIMin method
shaderMaterialGeoParamDescription::GetUIName method
shaderMaterialGeoParamDescription::GetUIStep method
shaderMaterialGeoParamDescription::GetUIWidget method
shaderMaterialGeoParamDescription::GetUvSetIndex method
shaderMaterialGeoParamDescription::GetUvSetName method
shaderMaterialGeoParamDescription::Init method
shaderMaterialGeoParamDescription::IsEqual method
shaderMaterialGeoParamDescription::IsLightmap method
shaderMaterialGeoParamDescription::LIGHTMAP_TYPE_NAMES
shaderMaterialGeoParamDescription::LIGHTMAP_TYPE_NAMES data member
shaderMaterialGeoParamDescription::LIGHTMAP_TYPE_NAMES variable
shaderMaterialGeoParamDescription::m_eValueSource data member
shaderMaterialGeoParamDescription::m_iNoOfMipLevels data member
shaderMaterialGeoParamDescription::m_MaterialDefaultValueUvSetIndex data member
shaderMaterialGeoParamDescription::m_Name data member
shaderMaterialGeoParamDescription::m_TextureOutputFormats data member
shaderMaterialGeoParamDescription::m_UIHelp data member
shaderMaterialGeoParamDescription::m_UIHidden data member
shaderMaterialGeoParamDescription::m_UIHint data member
shaderMaterialGeoParamDescription::m_UIMax data member
shaderMaterialGeoParamDescription::m_UIMin data member
shaderMaterialGeoParamDescription::m_UIName data member
shaderMaterialGeoParamDescription::m_UIStep data member
shaderMaterialGeoParamDescription::m_UIWidget data member
shaderMaterialGeoParamDescription::m_UvSetIndex data member
shaderMaterialGeoParamDescription::m_UvSetName data member
shaderMaterialGeoParamDescription::ReadGeoParamDescriptionData method
shaderMaterialGeoParamDescription::Reset method
shaderMaterialGeoParamDescription::SetDefaultValue method
shaderMaterialGeoParamDescription::SetDefaultValueUvSetIndex method
shaderMaterialGeoParamDescription::SetName method
shaderMaterialGeoParamDescription::SetTextureOutputFormats method
shaderMaterialGeoParamDescription::SetUIHint method
shaderMaterialGeoParamDescription::SetUIMax method
shaderMaterialGeoParamDescription::SetUIMin method
shaderMaterialGeoParamDescription::SetUIName method
shaderMaterialGeoParamDescription::SetUIStep method
shaderMaterialGeoParamDescription::SetUIWidget method
shaderMaterialGeoParamDescription::SetUvSetIndex method
shaderMaterialGeoParamDescription::SetUvSetName method
shaderMaterialGeoParamDescription::SetValueSource method
shaderMaterialGeoParamDescription::shaderMaterialGeoParamDescription constructor
shaderMaterialGeoParamDescription::WriteAsGeoInstanceMember method
shaderMaterialGeoParamDescription::WriteAsGeoTemplateMember method
shaderMaterialGeoParamDescription::WriteGeoParamDescriptionData method
shaderMaterialGeoParamDescriptionFloat
shaderMaterialGeoParamDescriptionFloat class
~shaderMaterialGeoParamDescriptionFloat
CleanUp
Copy
GetDefaultValue
GetType
GetTypeName
IsEqual
LoadFromXML
ReadGeoParamDescriptionData
Reset
SaveToXML
SetDefaultValue
shaderMaterialGeoParamDescriptionFloat
shaderMaterialGeoParamDescriptionFloat
WriteAsGeoInstanceMember
WriteAsGeoTemplateMember
WriteGeoParamDescriptionData
shaderMaterialGeoParamDescriptionFloat::~shaderMaterialGeoParamDescriptionFloat destructor
shaderMaterialGeoParamDescriptionFloat::CleanUp method
shaderMaterialGeoParamDescriptionFloat::Copy method
shaderMaterialGeoParamDescriptionFloat::GetDefaultValue method
shaderMaterialGeoParamDescriptionFloat::GetType method
shaderMaterialGeoParamDescriptionFloat::GetTypeName method
shaderMaterialGeoParamDescriptionFloat::IsEqual method
shaderMaterialGeoParamDescriptionFloat::LoadFromXML method
shaderMaterialGeoParamDescriptionFloat::ReadGeoParamDescriptionData method
shaderMaterialGeoParamDescriptionFloat::Reset method
shaderMaterialGeoParamDescriptionFloat::SaveToXML method
shaderMaterialGeoParamDescriptionFloat::SetDefaultValue method
shaderMaterialGeoParamDescriptionFloat::shaderMaterialGeoParamDescriptionFloat constructor
shaderMaterialGeoParamDescriptionFloat::WriteAsGeoInstanceMember method
shaderMaterialGeoParamDescriptionFloat::WriteAsGeoTemplateMember method
shaderMaterialGeoParamDescriptionFloat::WriteGeoParamDescriptionData method
shaderMaterialGeoParamDescriptionMatrix34
shaderMaterialGeoParamDescriptionMatrix34 class
~shaderMaterialGeoParamDescriptionMatrix34
Copy
GetDefaultValue
GetType
GetTypeName
IsEqual
ReadGeoParamDescriptionData
Reset
SetDefaultValue
shaderMaterialGeoParamDescriptionMatrix34
WriteAsGeoInstanceMember
WriteAsGeoTemplateMember
WriteGeoParamDescriptionData
shaderMaterialGeoParamDescriptionMatrix34::~shaderMaterialGeoParamDescriptionMatrix34 destructor
shaderMaterialGeoParamDescriptionMatrix34::Copy method
shaderMaterialGeoParamDescriptionMatrix34::GetDefaultValue method
shaderMaterialGeoParamDescriptionMatrix34::GetType method
shaderMaterialGeoParamDescriptionMatrix34::GetTypeName method
shaderMaterialGeoParamDescriptionMatrix34::IsEqual method
shaderMaterialGeoParamDescriptionMatrix34::ReadGeoParamDescriptionData method
shaderMaterialGeoParamDescriptionMatrix34::Reset method
shaderMaterialGeoParamDescriptionMatrix34::SetDefaultValue method
shaderMaterialGeoParamDescriptionMatrix34::shaderMaterialGeoParamDescriptionMatrix34 constructor
shaderMaterialGeoParamDescriptionMatrix34::WriteAsGeoInstanceMember method
shaderMaterialGeoParamDescriptionMatrix34::WriteAsGeoTemplateMember method
shaderMaterialGeoParamDescriptionMatrix34::WriteGeoParamDescriptionData method
shaderMaterialGeoParamDescriptionMatrix44
shaderMaterialGeoParamDescriptionMatrix44 class
~shaderMaterialGeoParamDescriptionMatrix44
Copy
GetDefaultValue
GetType
GetTypeName
IsEqual
ReadGeoParamDescriptionData
Reset
SetDefaultValue
shaderMaterialGeoParamDescriptionMatrix44
WriteAsGeoInstanceMember
WriteAsGeoTemplateMember
WriteGeoParamDescriptionData
shaderMaterialGeoParamDescriptionMatrix44::~shaderMaterialGeoParamDescriptionMatrix44 destructor
shaderMaterialGeoParamDescriptionMatrix44::Copy method
shaderMaterialGeoParamDescriptionMatrix44::GetDefaultValue method
shaderMaterialGeoParamDescriptionMatrix44::GetType method
shaderMaterialGeoParamDescriptionMatrix44::GetTypeName method
shaderMaterialGeoParamDescriptionMatrix44::IsEqual method
shaderMaterialGeoParamDescriptionMatrix44::ReadGeoParamDescriptionData method
shaderMaterialGeoParamDescriptionMatrix44::Reset method
shaderMaterialGeoParamDescriptionMatrix44::SetDefaultValue method
shaderMaterialGeoParamDescriptionMatrix44::shaderMaterialGeoParamDescriptionMatrix44 constructor
shaderMaterialGeoParamDescriptionMatrix44::WriteAsGeoInstanceMember method
shaderMaterialGeoParamDescriptionMatrix44::WriteAsGeoTemplateMember method
shaderMaterialGeoParamDescriptionMatrix44::WriteGeoParamDescriptionData method
shaderMaterialGeoParamDescriptionString
shaderMaterialGeoParamDescriptionString class
~shaderMaterialGeoParamDescriptionString
CleanUp
Copy
GetDefaultValue
GetType
GetTypeName
IsEqual
ReadGeoParamDescriptionData
Reset
SetDefaultValue
shaderMaterialGeoParamDescriptionString
shaderMaterialGeoParamDescriptionString
WriteAsGeoInstanceMember
WriteAsGeoTemplateMember
WriteGeoParamDescriptionData
shaderMaterialGeoParamDescriptionString::~shaderMaterialGeoParamDescriptionString destructor
shaderMaterialGeoParamDescriptionString::CleanUp method
shaderMaterialGeoParamDescriptionString::Copy method
shaderMaterialGeoParamDescriptionString::GetDefaultValue method
shaderMaterialGeoParamDescriptionString::GetType method
shaderMaterialGeoParamDescriptionString::GetTypeName method
shaderMaterialGeoParamDescriptionString::IsEqual method
shaderMaterialGeoParamDescriptionString::ReadGeoParamDescriptionData method
shaderMaterialGeoParamDescriptionString::Reset method
shaderMaterialGeoParamDescriptionString::SetDefaultValue method
shaderMaterialGeoParamDescriptionString::shaderMaterialGeoParamDescriptionString constructor
shaderMaterialGeoParamDescriptionString::WriteAsGeoInstanceMember method
shaderMaterialGeoParamDescriptionString::WriteAsGeoTemplateMember method
shaderMaterialGeoParamDescriptionString::WriteGeoParamDescriptionData method
shaderMaterialGeoParamDescriptionTexture
shaderMaterialGeoParamDescriptionTexture class
~shaderMaterialGeoParamDescriptionTexture
CleanUp
Copy
GetDefaultValue
GetTextureName
GetTextureName
GetType
GetTypeName
IsEqual
ReadGeoParamDescriptionData
Reset
SetDefaultValue
shaderMaterialGeoParamDescriptionTexture
shaderMaterialGeoParamDescriptionTexture
WriteAsGeoInstanceMember
WriteAsGeoTemplateMember
WriteGeoParamDescriptionData
shaderMaterialGeoParamDescriptionTexture::~shaderMaterialGeoParamDescriptionTexture destructor
shaderMaterialGeoParamDescriptionTexture::CleanUp method
shaderMaterialGeoParamDescriptionTexture::Copy method
shaderMaterialGeoParamDescriptionTexture::GetDefaultValue method
shaderMaterialGeoParamDescriptionTexture::GetTextureName method
shaderMaterialGeoParamDescriptionTexture::GetType method
shaderMaterialGeoParamDescriptionTexture::GetTypeName method
shaderMaterialGeoParamDescriptionTexture::IsEqual method
shaderMaterialGeoParamDescriptionTexture::ReadGeoParamDescriptionData method
shaderMaterialGeoParamDescriptionTexture::Reset method
shaderMaterialGeoParamDescriptionTexture::SetDefaultValue method
shaderMaterialGeoParamDescriptionTexture::shaderMaterialGeoParamDescriptionTexture constructor
shaderMaterialGeoParamDescriptionTexture::WriteAsGeoInstanceMember method
shaderMaterialGeoParamDescriptionTexture::WriteAsGeoTemplateMember method
shaderMaterialGeoParamDescriptionTexture::WriteGeoParamDescriptionData method
shaderMaterialGeoParamDescriptionVector2
shaderMaterialGeoParamDescriptionVector2 class
~shaderMaterialGeoParamDescriptionVector2
Copy
GetDefaultValue
GetType
GetTypeName
IsEqual
ReadGeoParamDescriptionData
Reset
SetDefaultValue
shaderMaterialGeoParamDescriptionVector2
shaderMaterialGeoParamDescriptionVector2
WriteAsGeoInstanceMember
WriteAsGeoTemplateMember
WriteGeoParamDescriptionData
shaderMaterialGeoParamDescriptionVector2::~shaderMaterialGeoParamDescriptionVector2 destructor
shaderMaterialGeoParamDescriptionVector2::Copy method
shaderMaterialGeoParamDescriptionVector2::GetDefaultValue method
shaderMaterialGeoParamDescriptionVector2::GetType method
shaderMaterialGeoParamDescriptionVector2::GetTypeName method
shaderMaterialGeoParamDescriptionVector2::IsEqual method
shaderMaterialGeoParamDescriptionVector2::ReadGeoParamDescriptionData method
shaderMaterialGeoParamDescriptionVector2::Reset method
shaderMaterialGeoParamDescriptionVector2::SetDefaultValue method
shaderMaterialGeoParamDescriptionVector2::shaderMaterialGeoParamDescriptionVector2 constructor
shaderMaterialGeoParamDescriptionVector2::WriteAsGeoInstanceMember method
shaderMaterialGeoParamDescriptionVector2::WriteAsGeoTemplateMember method
shaderMaterialGeoParamDescriptionVector2::WriteGeoParamDescriptionData method
shaderMaterialGeoParamDescriptionVector3
shaderMaterialGeoParamDescriptionVector3 class
~shaderMaterialGeoParamDescriptionVector3
Copy
GetDefaultValue
GetType
GetTypeName
IsEqual
ReadGeoParamDescriptionData
Reset
SetDefaultValue
shaderMaterialGeoParamDescriptionVector3
shaderMaterialGeoParamDescriptionVector3
WriteAsGeoInstanceMember
WriteAsGeoTemplateMember
WriteGeoParamDescriptionData
shaderMaterialGeoParamDescriptionVector3::~shaderMaterialGeoParamDescriptionVector3 destructor
shaderMaterialGeoParamDescriptionVector3::Copy method
shaderMaterialGeoParamDescriptionVector3::GetDefaultValue method
shaderMaterialGeoParamDescriptionVector3::GetType method
shaderMaterialGeoParamDescriptionVector3::GetTypeName method
shaderMaterialGeoParamDescriptionVector3::IsEqual method
shaderMaterialGeoParamDescriptionVector3::ReadGeoParamDescriptionData method
shaderMaterialGeoParamDescriptionVector3::Reset method
shaderMaterialGeoParamDescriptionVector3::SetDefaultValue method
shaderMaterialGeoParamDescriptionVector3::shaderMaterialGeoParamDescriptionVector3 constructor
shaderMaterialGeoParamDescriptionVector3::WriteAsGeoInstanceMember method
shaderMaterialGeoParamDescriptionVector3::WriteAsGeoTemplateMember method
shaderMaterialGeoParamDescriptionVector3::WriteGeoParamDescriptionData method
shaderMaterialGeoParamDescriptionVector4
shaderMaterialGeoParamDescriptionVector4 class
~shaderMaterialGeoParamDescriptionVector4
Copy
GetDefaultValue
GetType
GetTypeName
IsEqual
ReadGeoParamDescriptionData
Reset
SetDefaultValue
shaderMaterialGeoParamDescriptionVector4
shaderMaterialGeoParamDescriptionVector4
WriteAsGeoInstanceMember
WriteAsGeoTemplateMember
WriteGeoParamDescriptionData
shaderMaterialGeoParamDescriptionVector4::~shaderMaterialGeoParamDescriptionVector4 destructor
shaderMaterialGeoParamDescriptionVector4::Copy method
shaderMaterialGeoParamDescriptionVector4::GetDefaultValue method
shaderMaterialGeoParamDescriptionVector4::GetType method
shaderMaterialGeoParamDescriptionVector4::GetTypeName method
shaderMaterialGeoParamDescriptionVector4::IsEqual method
shaderMaterialGeoParamDescriptionVector4::ReadGeoParamDescriptionData method
shaderMaterialGeoParamDescriptionVector4::Reset method
shaderMaterialGeoParamDescriptionVector4::SetDefaultValue method
shaderMaterialGeoParamDescriptionVector4::shaderMaterialGeoParamDescriptionVector4 constructor
shaderMaterialGeoParamDescriptionVector4::WriteAsGeoInstanceMember method
shaderMaterialGeoParamDescriptionVector4::WriteAsGeoTemplateMember method
shaderMaterialGeoParamDescriptionVector4::WriteGeoParamDescriptionData method
shaderMaterialGeoParamValue
shaderMaterialGeoParamValue class
~shaderMaterialGeoParamValue
CleanUp
Copy
CopyValueIntoVector2
GetName
GetParamDescription
GetSourceOfParamValue
GetType
GetTypeName
Init
IsEqual
IsLightmap
LIGHTMAP_TYPE_NAMES
m_Name
m_pobParamDescription
ReadGeoParamValueData
Reset
SetDefaultValue
SetMaterialValue
SetName
shaderMaterialGeoParamValue
shaderMaterialGeoParamValue
shaderMaterialGeoParamValue
Update
Update
Update
Update
Update
Update
Update
Update
Update
Update
Update
Update
WriteAsGeoTypeMember
WriteGeoParamValueData
shaderMaterialGeoParamValue::~shaderMaterialGeoParamValue destructor
shaderMaterialGeoParamValue::CleanUp method
shaderMaterialGeoParamValue::Copy method
shaderMaterialGeoParamValue::CopyValueIntoVector2 method
shaderMaterialGeoParamValue::GetName method
shaderMaterialGeoParamValue::GetParamDescription method
shaderMaterialGeoParamValue::GetSourceOfParamValue method
shaderMaterialGeoParamValue::GetType method
shaderMaterialGeoParamValue::GetTypeName method
shaderMaterialGeoParamValue::Init method
shaderMaterialGeoParamValue::IsEqual method
shaderMaterialGeoParamValue::IsLightmap method
shaderMaterialGeoParamValue::LIGHTMAP_TYPE_NAMES
shaderMaterialGeoParamValue::LIGHTMAP_TYPE_NAMES data member
shaderMaterialGeoParamValue::LIGHTMAP_TYPE_NAMES variable
shaderMaterialGeoParamValue::m_Name data member
shaderMaterialGeoParamValue::m_pobParamDescription data member
shaderMaterialGeoParamValue::ReadGeoParamValueData method
shaderMaterialGeoParamValue::Reset method
shaderMaterialGeoParamValue::SetDefaultValue method
shaderMaterialGeoParamValue::SetMaterialValue method
shaderMaterialGeoParamValue::SetName method
shaderMaterialGeoParamValue::shaderMaterialGeoParamValue constructor
shaderMaterialGeoParamValue::Update method
shaderMaterialGeoParamValue::WriteAsGeoTypeMember method
shaderMaterialGeoParamValue::WriteGeoParamValueData method
shaderMaterialGeoParamValueFloat
shaderMaterialGeoParamValueFloat class
~shaderMaterialGeoParamValueFloat
CleanUp
Copy
CopyValueIntoVector2
GetType
GetTypeName
GetValue
IsEqual
LoadFromXML
ReadGeoParamValueData
Reset
SaveToXML
SetDefaultValue
SetMaterialValue
SetValue
shaderMaterialGeoParamValueFloat
shaderMaterialGeoParamValueFloat
shaderMaterialGeoParamValueFloat
Update
Update
Update
Update
Update
Update
Update
WriteAsGeoTypeMember
WriteGeoParamValueData
shaderMaterialGeoParamValueFloat::~shaderMaterialGeoParamValueFloat destructor
shaderMaterialGeoParamValueFloat::CleanUp method
shaderMaterialGeoParamValueFloat::Copy method
shaderMaterialGeoParamValueFloat::CopyValueIntoVector2 method
shaderMaterialGeoParamValueFloat::GetType method
shaderMaterialGeoParamValueFloat::GetTypeName method
shaderMaterialGeoParamValueFloat::GetValue method
shaderMaterialGeoParamValueFloat::IsEqual method
shaderMaterialGeoParamValueFloat::LoadFromXML method
shaderMaterialGeoParamValueFloat::ReadGeoParamValueData method
shaderMaterialGeoParamValueFloat::Reset method
shaderMaterialGeoParamValueFloat::SaveToXML method
shaderMaterialGeoParamValueFloat::SetDefaultValue method
shaderMaterialGeoParamValueFloat::SetMaterialValue method
shaderMaterialGeoParamValueFloat::SetValue method
shaderMaterialGeoParamValueFloat::shaderMaterialGeoParamValueFloat constructor
shaderMaterialGeoParamValueFloat::Update method
shaderMaterialGeoParamValueFloat::WriteAsGeoTypeMember method
shaderMaterialGeoParamValueFloat::WriteGeoParamValueData method
shaderMaterialGeoParamValueMatrix34
shaderMaterialGeoParamValueMatrix34 class
~shaderMaterialGeoParamValueMatrix34
Copy
GetType
GetTypeName
GetValue
IsEqual
ReadGeoParamValueData
Reset
SetDefaultValue
SetValue
shaderMaterialGeoParamValueMatrix34
shaderMaterialGeoParamValueMatrix34
Update
Update
Update
WriteAsGeoTypeMember
WriteGeoParamValueData
shaderMaterialGeoParamValueMatrix34::~shaderMaterialGeoParamValueMatrix34 destructor
shaderMaterialGeoParamValueMatrix34::Copy method
shaderMaterialGeoParamValueMatrix34::GetType method
shaderMaterialGeoParamValueMatrix34::GetTypeName method
shaderMaterialGeoParamValueMatrix34::GetValue method
shaderMaterialGeoParamValueMatrix34::IsEqual method
shaderMaterialGeoParamValueMatrix34::ReadGeoParamValueData method
shaderMaterialGeoParamValueMatrix34::Reset method
shaderMaterialGeoParamValueMatrix34::SetDefaultValue method
shaderMaterialGeoParamValueMatrix34::SetValue method
shaderMaterialGeoParamValueMatrix34::shaderMaterialGeoParamValueMatrix34 constructor
shaderMaterialGeoParamValueMatrix34::Update method
shaderMaterialGeoParamValueMatrix34::WriteAsGeoTypeMember method
shaderMaterialGeoParamValueMatrix34::WriteGeoParamValueData method
shaderMaterialGeoParamValueMatrix44
shaderMaterialGeoParamValueMatrix44 class
~shaderMaterialGeoParamValueMatrix44
Copy
GetType
GetTypeName
GetValue
IsEqual
ReadGeoParamValueData
Reset
SetDefaultValue
SetValue
shaderMaterialGeoParamValueMatrix44
shaderMaterialGeoParamValueMatrix44
Update
Update
Update
WriteAsGeoTypeMember
WriteGeoParamValueData
shaderMaterialGeoParamValueMatrix44::~shaderMaterialGeoParamValueMatrix44 destructor
shaderMaterialGeoParamValueMatrix44::Copy method
shaderMaterialGeoParamValueMatrix44::GetType method
shaderMaterialGeoParamValueMatrix44::GetTypeName method
shaderMaterialGeoParamValueMatrix44::GetValue method
shaderMaterialGeoParamValueMatrix44::IsEqual method
shaderMaterialGeoParamValueMatrix44::ReadGeoParamValueData method
shaderMaterialGeoParamValueMatrix44::Reset method
shaderMaterialGeoParamValueMatrix44::SetDefaultValue method
shaderMaterialGeoParamValueMatrix44::SetValue method
shaderMaterialGeoParamValueMatrix44::shaderMaterialGeoParamValueMatrix44 constructor
shaderMaterialGeoParamValueMatrix44::Update method
shaderMaterialGeoParamValueMatrix44::WriteAsGeoTypeMember method
shaderMaterialGeoParamValueMatrix44::WriteGeoParamValueData method
shaderMaterialGeoParamValueString
shaderMaterialGeoParamValueString class
~shaderMaterialGeoParamValueString
CleanUp
Copy
GetType
GetTypeName
GetValue
IsEqual
ReadGeoParamValueData
Reset
SetDefaultValue
SetValue
shaderMaterialGeoParamValueString
shaderMaterialGeoParamValueString
shaderMaterialGeoParamValueString
Update
Update
Update
Update
Update
Update
Update
WriteAsGeoTypeMember
WriteGeoParamValueData
shaderMaterialGeoParamValueString::~shaderMaterialGeoParamValueString destructor
shaderMaterialGeoParamValueString::CleanUp method
shaderMaterialGeoParamValueString::Copy method
shaderMaterialGeoParamValueString::GetType method
shaderMaterialGeoParamValueString::GetTypeName method
shaderMaterialGeoParamValueString::GetValue method
shaderMaterialGeoParamValueString::IsEqual method
shaderMaterialGeoParamValueString::ReadGeoParamValueData method
shaderMaterialGeoParamValueString::Reset method
shaderMaterialGeoParamValueString::SetDefaultValue method
shaderMaterialGeoParamValueString::SetValue method
shaderMaterialGeoParamValueString::shaderMaterialGeoParamValueString constructor
shaderMaterialGeoParamValueString::Update method
shaderMaterialGeoParamValueString::WriteAsGeoTypeMember method
shaderMaterialGeoParamValueString::WriteGeoParamValueData method
shaderMaterialGeoParamValueTexture
shaderMaterialGeoParamValueTexture class
~shaderMaterialGeoParamValueTexture
CleanUp
Copy
GetTextureName
GetTextureName
GetType
GetTypeName
GetValue
IsEqual
ReadGeoParamValueData
Reset
SetDefaultValue
SetValue
shaderMaterialGeoParamValueTexture
shaderMaterialGeoParamValueTexture
shaderMaterialGeoParamValueTexture
Update
Update
Update
Update
Update
Update
Update
WriteAsGeoTypeMember
WriteGeoParamValueData
shaderMaterialGeoParamValueTexture::~shaderMaterialGeoParamValueTexture destructor
shaderMaterialGeoParamValueTexture::CleanUp method
shaderMaterialGeoParamValueTexture::Copy method
shaderMaterialGeoParamValueTexture::GetTextureName method
shaderMaterialGeoParamValueTexture::GetType method
shaderMaterialGeoParamValueTexture::GetTypeName method
shaderMaterialGeoParamValueTexture::GetValue method
shaderMaterialGeoParamValueTexture::IsEqual method
shaderMaterialGeoParamValueTexture::ReadGeoParamValueData method
shaderMaterialGeoParamValueTexture::Reset method
shaderMaterialGeoParamValueTexture::SetDefaultValue method
shaderMaterialGeoParamValueTexture::SetValue method
shaderMaterialGeoParamValueTexture::shaderMaterialGeoParamValueTexture constructor
shaderMaterialGeoParamValueTexture::Update method
shaderMaterialGeoParamValueTexture::WriteAsGeoTypeMember method
shaderMaterialGeoParamValueTexture::WriteGeoParamValueData method
shaderMaterialGeoParamValueVector2
shaderMaterialGeoParamValueVector2 class
~shaderMaterialGeoParamValueVector2
Copy
CopyValueIntoVector2
GetType
GetTypeName
GetValue
IsEqual
ReadGeoParamValueData
Reset
SetDefaultValue
SetMaterialValue
SetValue
shaderMaterialGeoParamValueVector2
shaderMaterialGeoParamValueVector2
shaderMaterialGeoParamValueVector2
Update
Update
Update
WriteAsGeoTypeMember
WriteGeoParamValueData
shaderMaterialGeoParamValueVector2::~shaderMaterialGeoParamValueVector2 destructor
shaderMaterialGeoParamValueVector2::Copy method
shaderMaterialGeoParamValueVector2::CopyValueIntoVector2 method
shaderMaterialGeoParamValueVector2::GetType method
shaderMaterialGeoParamValueVector2::GetTypeName method
shaderMaterialGeoParamValueVector2::GetValue method
shaderMaterialGeoParamValueVector2::IsEqual method
shaderMaterialGeoParamValueVector2::ReadGeoParamValueData method
shaderMaterialGeoParamValueVector2::Reset method
shaderMaterialGeoParamValueVector2::SetDefaultValue method
shaderMaterialGeoParamValueVector2::SetMaterialValue method
shaderMaterialGeoParamValueVector2::SetValue method
shaderMaterialGeoParamValueVector2::shaderMaterialGeoParamValueVector2 constructor
shaderMaterialGeoParamValueVector2::Update method
shaderMaterialGeoParamValueVector2::WriteAsGeoTypeMember method
shaderMaterialGeoParamValueVector2::WriteGeoParamValueData method
shaderMaterialGeoParamValueVector3
shaderMaterialGeoParamValueVector3 class
~shaderMaterialGeoParamValueVector3
Copy
GetType
GetTypeName
GetValue
IsEqual
ReadGeoParamValueData
Reset
SetDefaultValue
SetValue
shaderMaterialGeoParamValueVector3
shaderMaterialGeoParamValueVector3
shaderMaterialGeoParamValueVector3
Update
Update
Update
Update
WriteAsGeoTypeMember
WriteGeoParamValueData
shaderMaterialGeoParamValueVector3::~shaderMaterialGeoParamValueVector3 destructor
shaderMaterialGeoParamValueVector3::Copy method
shaderMaterialGeoParamValueVector3::GetType method
shaderMaterialGeoParamValueVector3::GetTypeName method
shaderMaterialGeoParamValueVector3::GetValue method
shaderMaterialGeoParamValueVector3::IsEqual method
shaderMaterialGeoParamValueVector3::ReadGeoParamValueData method
shaderMaterialGeoParamValueVector3::Reset method
shaderMaterialGeoParamValueVector3::SetDefaultValue method
shaderMaterialGeoParamValueVector3::SetValue method
shaderMaterialGeoParamValueVector3::shaderMaterialGeoParamValueVector3 constructor
shaderMaterialGeoParamValueVector3::Update method
shaderMaterialGeoParamValueVector3::WriteAsGeoTypeMember method
shaderMaterialGeoParamValueVector3::WriteGeoParamValueData method
shaderMaterialGeoParamValueVector4
shaderMaterialGeoParamValueVector4 class
~shaderMaterialGeoParamValueVector4
Copy
GetType
GetTypeName
GetValue
IsEqual
ReadGeoParamValueData
Reset
SetDefaultValue
SetValue
shaderMaterialGeoParamValueVector4
shaderMaterialGeoParamValueVector4
shaderMaterialGeoParamValueVector4
Update
Update
Update
Update
WriteAsGeoTypeMember
WriteGeoParamValueData
shaderMaterialGeoParamValueVector4::~shaderMaterialGeoParamValueVector4 destructor
shaderMaterialGeoParamValueVector4::Copy method
shaderMaterialGeoParamValueVector4::GetType method
shaderMaterialGeoParamValueVector4::GetTypeName method
shaderMaterialGeoParamValueVector4::GetValue method
shaderMaterialGeoParamValueVector4::IsEqual method
shaderMaterialGeoParamValueVector4::ReadGeoParamValueData method
shaderMaterialGeoParamValueVector4::Reset method
shaderMaterialGeoParamValueVector4::SetDefaultValue method
shaderMaterialGeoParamValueVector4::SetValue method
shaderMaterialGeoParamValueVector4::shaderMaterialGeoParamValueVector4 constructor
shaderMaterialGeoParamValueVector4::Update method
shaderMaterialGeoParamValueVector4::WriteAsGeoTypeMember method
shaderMaterialGeoParamValueVector4::WriteGeoParamValueData method
shaderMaterialGeoTemplate
shaderMaterialGeoTemplate class
~shaderMaterialGeoTemplate
CreateFromShader
GetBucketNumber
GetParamDescription
GetRunTimeVertexColourDescriptions
GetShaderFilename
GetShaderName
GetShaderParamDescriptions
GetShaderPathAndFilename
GetSourceVertexColourDescriptions
GetTemplateFilename
GetTemplateName
GetTemplatePathAndFilename
LoadFromGeoTemplate
SaveTo
shaderMaterialGeoTemplate
shaderMaterialGeoTemplate
shaderMaterialGeoTemplate::~shaderMaterialGeoTemplate destructor
shaderMaterialGeoTemplate::CreateFromShader method
shaderMaterialGeoTemplate::GetBucketNumber method
shaderMaterialGeoTemplate::GetParamDescription method
shaderMaterialGeoTemplate::GetRunTimeVertexColourDescriptions method
shaderMaterialGeoTemplate::GetShaderFilename method
shaderMaterialGeoTemplate::GetShaderName method
shaderMaterialGeoTemplate::GetShaderParamDescriptions method
shaderMaterialGeoTemplate::GetShaderPathAndFilename method
shaderMaterialGeoTemplate::GetSourceVertexColourDescriptions method
shaderMaterialGeoTemplate::GetTemplateFilename method
shaderMaterialGeoTemplate::GetTemplateName method
shaderMaterialGeoTemplate::GetTemplatePathAndFilename method
shaderMaterialGeoTemplate::LoadFromGeoTemplate method
shaderMaterialGeoTemplate::SaveTo method
shaderMaterialGeoTemplate::shaderMaterialGeoTemplate constructor
shaderMaterialGeoType
shaderMaterialGeoType class
~shaderMaterialGeoType
=
==
AddParamValuesFromParamDescriptions
AssignNewUID
ChangeParentType
ConstructFromParentType
Copy
CopyParamValues
CopyParamValuesSelectively
GetNoOfParams
GetNoOfShaderParams
GetParam
GetParam
GetParam
GetParam
GetParamByUIName
GetParamByUIName
GetParentType
GetParentTypeFilename
GetParentTypeName
GetParentTypePathAndFilename
GetShaderParam
GetShaderParam
GetShaderParam
GetShaderParam
GetShaderParamByUIName
GetShaderParamByUIName
GetTemplate
GetTypeFilename
GetTypeName
GetTypePathAndFilename
GetUID
GetUvSetCount
InitialiseFromTemplate
IsEqual
LoadFromGeoType
LoadFromGeoType
LoadParameterFromGeoType
m_apShaderParamValues
m_bInstance
m_pobParentType
m_pobTemplate
m_sGeoTypeUID
m_strParentTypeName
m_strParentTypePathAndFilename
m_strTypeName
m_strTypePathAndFilename
SaveTo
SaveToGeoType
SaveToGeoType
SetParentTypePathAndFilename
SetShaderVariableValue
SetTypePathAndFilename
SetUIDToString
shaderMaterialGeoType
shaderMaterialGeoType
UpdateShaderVariable
shaderMaterialGeoType::~shaderMaterialGeoType destructor
shaderMaterialGeoType::= operator
shaderMaterialGeoType::== operator
shaderMaterialGeoType::AddParamValuesFromParamDescriptions method
shaderMaterialGeoType::AssignNewUID method
shaderMaterialGeoType::ChangeParentType method
shaderMaterialGeoType::ConstructFromParentType method
shaderMaterialGeoType::Copy method
shaderMaterialGeoType::CopyParamValues method
shaderMaterialGeoType::CopyParamValuesSelectively method
shaderMaterialGeoType::GetNoOfParams method
shaderMaterialGeoType::GetNoOfShaderParams method
shaderMaterialGeoType::GetParam method
shaderMaterialGeoType::GetParamByUIName method
shaderMaterialGeoType::GetParentType method
shaderMaterialGeoType::GetParentTypeFilename method
shaderMaterialGeoType::GetParentTypeName method
shaderMaterialGeoType::GetParentTypePathAndFilename method
shaderMaterialGeoType::GetShaderParam method
shaderMaterialGeoType::GetShaderParamByUIName method
shaderMaterialGeoType::GetTemplate method
shaderMaterialGeoType::GetTypeFilename method
shaderMaterialGeoType::GetTypeName method
shaderMaterialGeoType::GetTypePathAndFilename method
shaderMaterialGeoType::GetUID method
shaderMaterialGeoType::GetUvSetCount method
shaderMaterialGeoType::InitialiseFromTemplate method
shaderMaterialGeoType::IsEqual method
shaderMaterialGeoType::LoadFromGeoType method
shaderMaterialGeoType::LoadParameterFromGeoType method
shaderMaterialGeoType::m_apShaderParamValues data member
shaderMaterialGeoType::m_bInstance data member
shaderMaterialGeoType::m_pobParentType data member
shaderMaterialGeoType::m_pobTemplate data member
shaderMaterialGeoType::m_sGeoTypeUID data member
shaderMaterialGeoType::m_strParentTypeName data member
shaderMaterialGeoType::m_strParentTypePathAndFilename data member
shaderMaterialGeoType::m_strTypeName data member
shaderMaterialGeoType::m_strTypePathAndFilename data member
shaderMaterialGeoType::SaveTo method
shaderMaterialGeoType::SaveToGeoType method
shaderMaterialGeoType::SetParentTypePathAndFilename method
shaderMaterialGeoType::SetShaderVariableValue method
shaderMaterialGeoType::SetTypePathAndFilename method
shaderMaterialGeoType::SetUIDToString method
shaderMaterialGeoType::shaderMaterialGeoType constructor
shaderMaterialGeoType::UpdateShaderVariable method
Shutdown
U
Update
UpdateShaderVariable
W
Working Examples
WriteAsGeoInstanceMember
WriteAsGeoTemplateMember
WriteAsGeoTypeMember
WriteGeoParamDescriptionData
WriteGeoParamValueData